Check installation failed with error "network write failed"

  • KM03792610
  • 26-Mar-2021
  • 07-May-2021

Summary

This happens with linux clients only

Error

When i run the Options to Check the Installation on my Linux Clients, i receive the following error messages:
-----------------------------------------------------------------------------
[Critical] <client_hostname>  Network write failed:
/tmp/omni_tmp
[Critical]  client_hostname: Unsupported architecture/OS type
()
Skipping client!
[Normal]  Installation session finished on Dienstag, 9. März 2021, 09:23:05.
==========================================================================
Session completed with errors!

Cause

In the BM_SETUP debug:

[  4] 2021-03-23 16:19:12.079 ("/lib/ipc/ipc.c $Rev$ $Date::                      $:":14757)
[  4] [MARK 2] in IpcGetThumbprint:14757
    Code: 1002
    Info: .

.

.

[ 10] Cannot connect to INET!

[  4] 2021-03-23 16:19:12.389 ("/install/ $Rev$ $Date::                      $:":197)
[  4] [CLEAR 2]
    Marked: ("/lib/ipc/ipc.c $Rev$ $Date::                      $:":17485)
    Code is:3039

Fix

omnicc -secure_comm -reconfigure_peer Client_hostname

 

from client:

omnicc -secure_comm -reconfigure_peer CM_hostname

in some cases, we might need to secure the communication between Installation Server and client before checking the installation on client.