This document has not been formally reviewed for accuracy and is provided "as is" for your convenience.
Summary
Regenerate Cognos certificates.
Error
ERROR E:\Program Files (x86)\HP\HP BTO Software\\nonOV\Perl\a\lib\site_perl/NPS/nps.pm[1215] Utility.startALL BI Service startup log: CAM-CRP-1095 Unable to find the encryption certificate with alias 'encryption' in the keystore 'E:/Program Files (x86)/HP/HP BTO Software/nonOV/cognos/bi/configuration/certs\CAMKeystore'.
ERROR E:\Program Files (x86)\HP\HP BTO Software\\nonOV\Perl\a\lib\site_perl/NPS/nps.pm[1215] Utility.startALL BI Service startup log: at com.cognos.accman.jcam.crypto.misc.KeyStoreReader.getEncryptionCertificateFromKeystore(KeyStoreReader.java:638)
Cause
Cognos cryptographic keys have expired or are corrupted.
Fix
Try regenerating them using below procedure:
1. Stop the Cognos services.
2. Open Cognos Configuration page with runBIConfigGUI.ovpl
3. Click "File - Export As", Choose "yes" (at the prompt) and save the file (for example as "backup.xml" in the %NPSInstallDir%\nonOV\cognos\bi\configuration folder
Close Cognos Configuration
4..Create a backup of the following files and directories and move these files and folders to this different location that is secure.
During the crypto keys regeneration process these files and folders will be re-created
The files are:
%NPSInstallDir%\nonOV\cognos\bi\configuration\cogstartup.xml
%NPSInstallDir%\nonOV\cognos\bi\configuration\caSerial
%NPSInstallDir%\nonOV\cognos\bi\configuration\certs\CAMCrypto.status
%NPSInstallDir%\nonOV\cognos\bi\configuration\certs\CAMKeystore
%NPSInstallDir%\nonOV\cognos\bi\configuration\certs\CAMKeystore.lock
%NPSInstallDir%\nonOV\cognos\bi\temp\cam\freshness
The directory is:
%NPSInstallDir%\nonOV\cognos\bi\configuration\csk
5. In the %NPSInstallDir%\nonOV\cognos\bi\configuration folder, rename backup.xml to cogstartup.xml.
6. Open Cognos Configuration, save the configuration and start the services.