Authentication through the Service Manager server failed

  • KM03764002
  • 19-Nov-2020
  • 07-Jun-2021

Summary

SMA-SM setup: https://docs.microfocus.com/itom/Service_Management_Automation_-_SM:2019.11/Home Error found in the log: EVP_CipherFinal_ex failed in desDecryptWithAES256CBC() [OPENSSL] error:06065064:digital envelope

Error

Authentication through the Service Manager server failed

 
  7984(  5292) 11/18/2020 16:19:06  RTE I Language en is valid
  7984(  5292) 11/18/2020 16:19:06  RTE E EVP_CipherFinal_ex failed in desDecryptWithAES256CBC()
  7984(  5292) 11/18/2020 16:19:06  RTE E [OPENSSL] error:06065064:digital envelope routines:EVP_DecryptFinal_ex:bad decrypt
  7984(  5292) 11/18/2020 16:19:06  RTE I Set lwsso login user to dbuser1
  7984(  5292) 11/18/2020 16:19:06  RTE I Language en is valid
  7984(  5292) 11/18/2020 16:19:06  RTE E EVP_CipherFinal_ex failed in desDecryptWithAES256CBC()
  7984(  5292) 11/18/2020 16:19:06  RTE E [OPENSSL] error:06065064:digital envelope routines:EVP_DecryptFinal_ex:bad decrypt

Cause

Strong.queryhash.key in the SM company table was having incorrect value.

 
>d strong.queryhash.key in $file
 
FEFE27F1721557B56539028A6AB70CA5072429729C7EB0FD4BFCB0E3CFB7CB08257BED875EE1E9314711A3F7D788102654E904ADF17E9648D5ED0B12D0AB7EBBB81A74F79EDFB830FE765AAB18C3A01AD6CBEFEF

Fix

Clear the query hash by using below script  and restart SM service:

// Clear Query Hash Key

lib.c.$('info').select('type="company"').iterate(function(item) {

      item['strong.queryhash.key'] = null;

      item.doUpdate();

});