NPS reports for non-admin users are not opening

  • KM03749965
  • 21-Oct-2020
  • 21-Oct-2020

This document has not been formally reviewed for accuracy and is provided "as is" for your convenience.

Summary

If below error is observed this is due to a user mapping issue due to missing database table.

Error

FATAL C:/Program Files (x86)/HP/HP BTO Software/NNMPerformanceSPI/bin/ugsg_etl.ovpl[88] ETL.ugsg DBD::SQLAnywhere::db prepare failed:

Table 'NMS_UG_SG' not found (DBD: prepare failed) at C:/Program Files (x86)/HP/HP BTO Software/NNMPerformanceSPI/bin/ugsg_etl.ovpl line 88.

Cause

UGSG mechanism is used for mapping user group to security groups in NPS. The process runs on the NPS server and mappings are persisted in the table NMS_UG_SG in Sybase IQ database.

NNM creates the mapping file in theNPS DataDir which is consumed by the ugsg_etl.ovpl process to populate the NMS_UG_SG table.

Fix

1. stopALL.ovpl

2. startDB.ovpl

3. go to /NNMPerformanceSPI/rconfig/ugsg

4. execute dbisql -c "DSN=PerfSPIDSN" -nogui dfltCreateSchema.sql 5>StartALL.ovpl

5. startALL.ovpl