Summary
Error
The user is unable to book timeslot resources from a specific Performance Center (PC) project that is assigned to a newly created pool. This specific project was assigned to an old pool and it was deleted or unassigned for the same.
The issue is observed only for specific project under specific domain which is assigned to a newly created project pool in 12.63 version.
This issue is observed in the PC 12.63 version which was recently migrated from 12.5X.
Below issue snapshot shows the <Add New timeslot> window under <Timeslots> page from MYPC UI. The <Pool and Project> tab in <Add New Timeslot> window has blank pool details although the project is assigned to a specific pool from PC Admin UI.
Cause
The root cause of the issue is unknown.
Fix
To fix the issue, Please follow the next steps:
- Login to Site Administration page.
- Navigate to Lab Management tab.
- Select the LAB_PROJECT_PROPERTIES table.
- Run below query for the affected projects where XXX refers to the affected project_name.
- SELECT * FROM LAB_PROJECT_PROPERTIES WHERE PRJP_DOMAIN= 'dddd' and PRJP_PROJECT_NAME='XXX'
- If the above select query returns more than 1 record and also if in case, the returned records has project_id=0 and prjp_id=2 or 3, then proceed to run the update query (step 6) to inactivate the old project(s) enty by appending the project_name with '99'.
- Refer to below UPDATE query example :
- UPDATE LAB_PROJECT_PROPERTIES SET PRJP_PROJECT_NAME='XXX99' where PRJP_ID=xxxx
- After the above steps 1-7 are followed, Login to the affected project to verify if issue is fixed now.