Verifying NNMi direct integration data

  • KM03652988
  • 19-Jun-2020
  • 19-Jun-2020

This document has not been formally reviewed for accuracy and is provided "as is" for your convenience.

Summary

Verifying NNMi direct integration data

Error

Npo data in Component and Interface health reports.

Cause

Possible missconfig or any other data issue on OBR or NNMI

Fix

We can verify with below steps:

 

Verify whether dimension & metric csvs having pattern like *_SHR_* are dumped on the shared drive as mentioned in the summary
                Dimension csvs path: /mnt/NMMICCMAQA-SN/PerfSpi/topoDump/final/
                Metric csvs path: /mnt/NMMICCMAQA-SN/PerfSpi/metric/final/

 

 Restart NNMi services as below:
/opt/OV/bin/ovstop
/opt/OV/bin/ovstart
/opt/OV/bin/ovstatus

Verify the status ETL and just restart it once as below:
perl $PMDB_HOME/bin/stopETL.ovpl
perl $PMDB_HOME/bin/startETL.ovpl

Check for processed CSV.s from NNMI in OBR:

/opt/HP/BSM/PMDB/config/NRT_ETL/Interface_Health/archives/topology/
/opt/HP/BSM/PMDB/config/NRT_ETL/Component_Health/archives/topology/
/opt/HP/BSM/PMDB/config/NRT_ETL/Interface_Health/archives/metric/
/opt/HP/BSM/PMDB/config/NRT_ETL/Component_Health/archives/metric/