This document has not been formally reviewed for accuracy and is provided "as is" for your convenience.
Summary
Error
The bus adapter is responsible for processing State Poller results to the iSPI Performance for Metrics.
When both warnings are seen, this most commonly indicates that there is a problem with the communication or processing of metric files between NNMi and iSPI Performance for Metrics (NPS).
The following article can be used as an initial guidance of how to approach this issue from a few perspectives.
[Minor] The Performance SPI Custom Poller Bus Adapter has status Minor because the file space limit (1,000 megabytes) has been reached and no additional data can be written.
[Minor] The Performance SPI Bus Adapter has status Minor because the file space limit (1,000 megabytes) has been reached and no additional data can be written.Cause
Cause 1:
This can happen if there are metric files in the metric/final directory which are not getting consumed by NPS.
Cause 2:
The ETLs are DEAD and thus again the consumption of metrics is not happening.
Fix
Cause 1:
On the NPS server, check if NPS has access to the shared directory on the NNMi server using the script runCheckConfig.ovpl, which in case of failure will print the following output:
/opt/OV/NNMPerformanceSPI/bin/runcheckConfig.ovpl
Checking validity of configuration settings in /var/opt/OV/NNMPerformanceSPI/rconfig/HPNNMPerformanceSPI.cfg...
/opt/OV/NNMPerformanceSPI/lib/perllibs/lib/perfspi.pm(348) INFO: Configuration: Check setting of PRSPI_NNMDIR
/opt/OV/NNMPerformanceSPI/lib/perllibs/lib/perfspi.pm(350) ERROR: Configuration: Unable to access directory /net/<nnm-server-fqdn>/var/opt/OV/shared/perfSpi/datafiles
/opt/OV/NNMPerformanceSPI/lib/perllibs/lib/perfspi.pm(389) ERROR: Please fix configuration file errors and restart process!
ERROR: Configuration file contains errors.
The shared folder is created on the NNMi server by the nnmenableperfspi.ovpl script which can be run again to establish the access of the NpsUser to the final directory.
Then, to configure NPS to use this location, the Configuration GUI can be launched on the NPS server side using the script рunConfigurationGUI.ovpl.
On the NPS server verify with statusALL.ovpl that all services including the ETLs have started.
If some of them appear as DEAD, try running below sequence for each of these ETLs:
1. stopETL.ovpl
2. dbCheckIndexes.ovpl -r -p <ETL_name>
3. groomTopology.ovpl -p <ETL_name>
4. startETL.ovpl
Note:
For a standalone NPS installation (not a distributed one where the ETL, DB, and UI components are installed on separate servers) the maximum number of ETLs to be active on the server is 40 so that the ETL component to be able to work properly. If there are more than 40 ETLs currently listed in the statusALL.ovpl output, revisit those and see if some can be disabled.
To disable those:
1. stopALL.ovpl
2. Modify the configuration file $NPSDataDir$/NNMPerformanceSPI/rconfig/NNMPerformanceSPI.cfg:
i. Remove the unwanted ETLs from the enabled tag, e.g:
# PRSPI_EXTENSIONPACKS PackageName[,PackageName]...
PRSPI_EXTENSIONPACKS PerfSPI_Diagnostics,Component_Health,Interface_Health,
ii. And paste them under the disabled tag:
# PRSPI_ETL_DISABLED PackageName[,PackageName]...
PRSPI_ETL_DISABLED AllExtensionPacks,Microsoft_Lync
3. startALL.ovpl
Cause 3:
Some metric files can be considered as corrupted if they are generated with garbage characters which NPS is not able to read.
To locate those CSV's, browse the prspi.log log in /var/opt/OV/NNMPerformanceSPI/logs/ for the keywords "mlaformed" or "corrupted". The stack trace in the log will show the offending CSV file which can be safely removed from the final directory. Most likely this is the oldest CSV file generated in the metric/final directory.