Summary
Error
404 Not found error:
Errors in opr-webapp.log of the Gateway server, erros about Identification map is larger than te fuse and a lot of CIs of type HP Operations Manager System reffering to the same OBM FQDN:
Error while trying to [addOrUpdate] on level [1]! Error appending ID 44d43b7d86dec77a9a231e7c8f44dfcc to identification map. Total size of map is larger than the limit 4000000 which defined in reconciliation.identification.map.fuse : operation DataInAddOrUpdateData
...
Caused by: com.hp.ucmdb.reconciliation.data.IdentificationMapTotalSizeException: [ErrorCode [63010] Identification map total size is larger than the defined fuse.{4000000}]
Cause
This happens because there are a lot of CIs of type HP Operations Manager System reffering to the same OBM FQDN but with different IDs, there should be just one for the OBM server and others if there is an Integration with an OMU, OMW or other OBM server but not hundreds or thousands of it.
Having that big amount of CIs causes the jboss to not start properly, opr-web component doesn't start, in jboss7_boot.log this error appears:
Fix
To check if this is the issue:
- Access UCMDB/RTSM UI (should be able to connect directly to UCMDB on port 8443 even if JBoss is not up): https://OBM_FQDN:8443
- Go to CI Type Manager
- Select the CI type HP Operations Manager system and that should already show the count.
If the count is high (hundreds or thousands), delete the ones that do NOT have a connection to operations agent CI(s):
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Go to Modeling Studio
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Create a new Query
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Add CI type HP Operations Agent and HP Operations Manager System, then create a Membership relationship:
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Need to identify the HP Operations Manager System CIs that don't have the relationship so select the HP Operations Manager system of the query, then select the Cardinality tab and click Edit.
Select Min:0 Max:0
That should show hundreds ot thousands CIs that need to be deleted.
*Note: It could be that all CIs has a relationship with Operations Agents so the way to proceed is go to the CI Type Manager, right click over CI type HP Operations Manager system and select Show CI Instances, that would list all the CIs. Select and delete all CIs but one, so there is just one CI for OBM.
Then restart OBM services, after the restart UI should work properly.