List of Previous Tickets is blank in Service Portal

  • KM03603873
  • 28-Feb-2020
  • 28-Feb-2020

Summary

List of Previous Tickets is blank in Service Portal

Error

When Service Portal Users start a Chat from Service Portal, the list of previous tickets is empty

Cause

One possible reason of this issue is that the Javascript with Name EndUserChat makes a query of interactions where the callback.contact value is the current user logged in in Service Portal and the propel.request.id field is not null. Make sure that this query will return data.

Make sure that the customer followed the steps in this document:

Fix

A workaround for this issue is to update the propel.request.id field with the same value as the Interaction number. One way to make this update is directly from the database, but from Service Manager it would be necessary to create a trigger and update this field only when an interaction comes from Service Portal

Please contact support for more details.