Error: Key cannot be retrieved

  • KM03596436
  • 07-Feb-2020
  • 07-Feb-2020

This document has not been formally reviewed for accuracy and is provided "as is" for your convenience.

Summary

receiving error when downloading keys. Message cannot be sent securely because your security parameters must be retrieved from a server that is not responding

Error

The message cannot be sent securely because your security parameters must be retrieved from a server that is not responding. To send securely, click Cancel and try again later when the server returns to service

Cause

Sometimes it is necessary to donwload the client policy again and that is what resetting the VEC does

Fix

Reset the Voltage Encryption Client by using the following steps

1. Close Outlook
2. From the Windows Start menu, double click on the Voltage Encryption Manager icon
3. Click on the Support tab
4. Click on “Reset Encryption Client" button
5. Click on the corresponding “OK” prompts
6. Restart the Voltage Encryption Client by going to Start>All Programs>Voltage Encryption>Voltage Encryption Manager
7. Restart Outlook
8. If the above  steps don't work, have the customer navigate to the following directory: C:\users\<log on name>\AppData\Roaming\Voltage\Store
9. Delete all items inside the "Store" directory.  This is where the keys for VEC are kept.  Then stop/restart Outlook and try again to send a secure email.