Registration/Recovery Failure

  • KM03581884
  • 20-Jan-2020
  • 20-Jan-2020

Summary

Installing or reinstalling Agent, it fails when try to reach Support Center servers, blocking account registration. Keywords: Reinstall agent msi addresses

Error

Registration/Recovery Failure

A Window Screen saying: “The Agent failed to register/recover an account with the Data Center”.
The Agent is inactive. Before you can back up and retrieve files, you must first activate the Agent.
Log Saying:
Connected Backup/PC Agent Version: 8.8.4.0 (16.4.0.0101) (or “it could be other Agent version”.)
 
Account Number: 00000-00000
++++++
1/13/2020 10:44 AM Network library error: call to connect() failed with error: Error Text: WSAETIMEDOUT
Error Code: 10060
 Tried to connect to ip address <Log will say here current IP SC address>  (or <any other ‘old SC IP addresses>), port 16,384

Cause

Two possible causes:
1.       IPs to access Support Center (SC, CBK servers) changed recently or customer never tried in time since that change.
     2.       IPs changed about SC but end user is trying to install or reinstall an Agent with old msi file.
Agent version if not concerned here, it could be any.

Fix

 WorkAround/Fix

For Support Center IPs changed please check out the following:
1.       Have on handy the new IP addresses and ports
2.       Open (or ensure you have defined and opened) Ports on the traffic controllers like: Firewalls, Network traffic controller (BlueCoat, and others)
3.       If you have allowed, you would do a telnet to new IP addresses just to get out from your network to outside, or if the servers are hosted by Customer also, then you also can do the following:   telnet <new IP address>
4.       Or make sure with your Security and Network team that all new ports are open and the ip addresses aren’t blocked
 
Being sure from above guidelines worked fine.
 
Next steps and more important ones are:
 
Most probably your .msi file is pointing to old SC IP Addresses, so you will need to generate and download a new .msi at your machine.
 
1.      Go to SC
2.      Go to agent configuration
3.      Download the .msi (this will have new way to access SC)
4.      Please download a fresh MSI file so it will have the new IP address in the code
5.       Once you have downloaded the new MSI please try to install the account.
 
This is proven method where you will now are able to install the agent accessing new servers locations, registering the user account.
Also, you have to have on hand emails or document talking about new IP addresses where to check log error versus current used ones.