WebInspect Enterprise Manager Log not Updating

  • KM03228254
  • 16-Aug-2018
  • 16-Aug-2018

Summary

A permissions issue is the mostly likely cause of the manager log not updating on an otherwise functioning WebInspect Enterprise installation.

Error

The manager log for WebInspect Enterprise located at C:\ProgramData\HP\WIE\Manager\ManagerWS_trace.log will normally be observed to contain recent updates an the INFO level (together with any warnings or errors).  If an upgrade or other change has been made to the system, logging may be seen to be stopped - i.e. no further updates are made to this file.

Cause

A likely cause is that the WebInspect Enterprise Manager service no longer has the necessary permissions to write to the log location.

Fix

The WebInspect Enterprise Manager runs as a w3wp (IIS) process and the account that it runs as is that which is configured as the identity of the WIEAppPool application pool in IIS.

If the manager log no longer updates, as a quick test you can try changing the application pool identity to LocalSystem.  If logging resumes, the issue is indeed one of inadequate permissions. 

Depending on the installation, leaving the application pool identity as LocalSystem may be a permanent workaround, however if local policy precludes having the service running as LocalSystem, or if the installation of WIE is standalone (not integrated with an SSC instance) the LocalSystem user may not have the required Active Directory access to authenticate user logon attempts the following steps can be taken:

  • Navigate to C:\ProgramData\HP\ and right click the WIE folder and select Properties
  • Select the Security tab
  • Click Advanced
  • Click Change Permissions
  • Click Add
  • Click Select a principal

If your environment mandates a specific user account must be used as the application pool identity (for example a domain user account):

  • Find the desired user account using the available options - for example to find a domain account ensure that the locations include the desired domain
  • Click OK and "Allow" access to "Tthis folder, subfolder and files" 
  • Select at least Read, Write and Modify - but it is recommended to allow Full Control
  • Click OK to apply the change

If your environment does not mandates a specific user account:

  • Change the location to include just the local machine
  • Enter IIS_IUSRS as the object name and click Check Names (the name should be resolved to include the local machine as the domain)
  • Click OK and "Allow" access to "Tthis folder, subfolder and files" 
  • Select at least Read, Write and Modify - but it is recommended to allow Full Control
  • Click OK to apply the change