Interaction tickets unable to generate Request Fulfillment (RF) tickets

  • KM03171538
  • 04-Jun-2018
  • 04-Jun-2018

Summary

Interaction tickets which are expected to have RF tickets are found not able to generate RF tickets.

Error

There is no error message from SM web or windows client after an interaction ticket is opened from order from catalog, no error message after the interaction ticket is approved, but there is no Request Fulfilment ticket is generated as expected.

Cause

Investigation:
1. Add debug parameters -RTM:3 -debugdbquery:999 and get sm.log, there is log message as below
4076( 5424) 05/22/2018 17:35:52 RTE D RADTRACE    156 [ 1] se.lock.object                      check.lock                lock         CPU(    0 13702 )
4076( 5424) 05/22/2018 17:35:52 JRTE W LockHandler: LockHandler thread might be blocked by a previous task, tasks in the queue: 0, blocking time: 117000
2. Log in to windows client, go to search sch records where name is started with "Service Catalog Fulfillment for SD", there are many records exists and not executed as expected.
3. Go to System Status > Show Locks, there is a lock repeat again and again
Resource Name: incidents;SD259468
Locked By: linker
4. It takes a long time to display and view SD259468, get message below
Exceeded virtual join record limit of 2000 records on subform activityservicedesk.list. Unable to display all virtual join records. (display,show.rio)
Related RF ticket activity is correct.
5. Search out 542 sch records where name is "Interoperability Record - Activity Update" and strings contain "incidents;SD259468"
Note: this is the root cause of the issue which cause the issue in log: JRTE W LockHandler: LockHandler thread might be blocked by a previous task, tasks in the queue: 0, blocking time: 117000
6. Search out 22768 activityservicemgt records where number is "SD259468" and operator is "linker"

Fix

1. Search and delete the sch records where name is "Interoperability Record - Activity Update" and strings contain "incidents;SD259468"
2. Search and delete the activityservicemgt records where number is "SD259468" and operator is "linker"
3. Restart the linker process, sch records of linker is executed one by one automatically
 
Verification:
Create a new interaction of a different catalog item, RF ticket could be created. The issue is resolved.