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Documentation updates
The title page of this document contains the following identifying information:

l Software Version number, which indicates the software version.
l Document Release Date, which changes each time the document is updated.
l Software Release Date, which indicates the release date of this version of the software.

To verify you are using the most recent edition of a document, go to
https://softwaresupport.softwaregrp.com/group/softwaresupport/search-result?doctype=manuals?keyword=.

To check for recent software patches, go to https://softwaresupport.softwaregrp.com/group/softwaresupport/search-
result?doctype=patches?keyword=.

This site requires that you register for a Passport and sign in. To register for a Passport ID, go to
https://cf.passport.softwaregrp.com/hppcf/login.do.

Or click the Register link at the top of the Software Support page.

You will also receive updated or new editions if you subscribe to the appropriate product support service. Contact
your sales representative for details.

The title page of this document contains the following identifying information:

l Software Version number, which indicates the software version.
l Document Release Date, which changes each time the document is updated.
l Software Release Date, which indicates the release date of this version of the software.

To verify you are using the most recent edition of a document, go to
https://softwaresupport.softwaregrp.com/group/softwaresupport/search-result?doctype=online help.

This site requires that you register for a Passport and sign in. To register for a Passport ID, go to
https://cf.passport.softwaregrp.com/hppcf/login.do.

You will also receive updated or new editions if you subscribe to the appropriate product support service. Contact
your sales representative for details.

For information and details about the products, services, and support that offers, contact your Client Director.

Application PerformanceManagement (9.50) Page 3 of 43

https://softwaresupport.softwaregrp.com/group/softwaresupport/search-result?doctype=manuals?keyword=
https://softwaresupport.softwaregrp.com/group/softwaresupport/search-result?doctype=patches?keyword=
https://softwaresupport.softwaregrp.com/group/softwaresupport/search-result?doctype=patches?keyword=
https://cf.passport.softwaregrp.com/hppcf/login.do
https://softwaresupport.softwaregrp.com/group/softwaresupport/search-result?doctype=online help
https://cf.passport.softwaregrp.com/hppcf/login.do


Support
Visit the Software Support Online web site at https://softwaresupport.softwaregrp.com/.

This web site provides contact information and details about the products, services, and support that offers.

online support provides customer self-solve capabilities. It provides a fast and efficient way to access interactive
technical support tools needed to manage your business. As a valued support customer, you can benefit by using
the support web site to:

l Search for knowledge documents of interest
l Submit and track support cases and enhancement requests
l Manage software licenses
l Download new versions of software or software patches
l Access product documentation
l Manage support contracts
l Look up support contacts
l Review information about available services
l Enter into discussions with other software customers
l Research and register for software training

Most of the support areas require you to register as a Passport user and sign in. Many also require a support
contract.

To register for a Passport ID, go to https://cf.passport.softwaregrp.com/hppcf/login.do.

Visit the Software Support Online web site at https://softwaresupport.softwaregrp.com/.

This web site provides contact information and details about the products, services, and support that offers.

online support provides customer self-solve capabilities. It provides a fast and efficient way to access interactive
technical support tools needed to manage your business. As a valued support customer, you can benefit by using
the support web site to:

l Search for knowledge documents of interest
l Submit and track support cases and enhancement requests
l Manage software licenses
l Download software
l Access product documentation
l Manage support contracts
l Look up support contacts
l Review information about available services
l Enter into discussions with other software customers
l Research and register for software training

Most of the support areas require you to register as a Passport user and sign in. Many also require a support
contract.

To register for a Passport ID, go to https://softwaresupport.softwaregrp.com/.

To check for recent updates or to verify that you are using the most recent edition of a document, contact your Client
Director.
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Chapter 1: Introduction
This section introduces the Getting StartedWith BPM - Best Practices and includes the following
topics:

l Scope andMotivation, below

l Why Use BPM?, below

Scope and Motivation
Business Process Monitor (BPM) is one of theMicro Focus or one of its affiliates Application
PerformanceManagement (APM) data collectors. BPM proactively monitors enterprise applications in
real time, identifying performance and availability problems before users experience them. It enables
you tomonitor sites from various locations, emulating the end-user experience, and so assess site
performance from different client perspectives.

The purpose of this document is to provide BPM users with an understanding of how to deploy BPM
quickly and correctly, and how to realize value in a short time.

The target audience for this guide is customers who are new implementers of BPM, or partners who
already have APM knowledge, but are new to BPM. While no deep networking/encryption knowledge is
needed, you will need to know the protocol and encryption used by themonitored application.

Why Use BPM?
BPM should be used to gather data during inactive hours of the users, so you will be able to detect
problems before a real user encounters them. In addition, BPM is the basic monitor for building SLAs,
because it has the same transactionmonitored at the same time intervals.

Getting StartedWith BPM - Best Practices
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Chapter 2: Installing BPM
The following provides instructions for installing BPM.

Before beginning the installation, verify that you haveminimum requirements. For details, see the
Business Process Monitor Deployment Guide.

1. Download the BPM setup file from the SMTA web site:

a. Go to the SMTA web site (http://prssc.int.hpe.com/smta/smta.cgi) and sign in.

b. Next toRelease Name, select APM0930 and click Search.

c. Download the required zip file:

HPE_Business_Process_Monitor_9.30_Windows_x64_Setup.zip

HPE_Business_Process_Monitor_9.30_Linux_x64_Setup.zip

2. Save the file under: C:\Temp.

3. Click the executable installation file. The BPM Setup wizard appears.

4. In the first screen, select your language and click OK.

5. In the Introduction screen, read the introduction text and click Next.

Getting StartedWith BPM - Best Practices
Chapter 2: Installing BPM
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6. In the Product Agreement screen, accept the license agreement and click Next.

7. In the Product Customization screen, accept the default folders or browse to and select the
application and data folders and click Next.
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8. In the Product Requirements screen, verify that there is enough disk space for the installation and
click Next.

9. In the Pre-Install Summary screen, verify that the application and data folder paths are correct and
click Install.

Getting StartedWith BPM - Best Practices
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The Installing screen appears.

The BPMConfiguration wizard is automatically launched after the setup program installed the
BPM application.

10. In the Run as User screen of the BPMConfigurationWizard, configure the BPM data collection to
run as a system user, or as a specific user. Running it as a specific user limits access to
resources, settings, and applications located on the local machine. (This may not be true for
resources located on remotemachines, where a specific user may have different privileges than
the local system user.)

Getting StartedWith BPM - Best Practices
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11. If your APM gateway server is protected, in the Server Authentication screen, select Use basic
authentication and enter your APM user name and password.

12. In the Instance Definition screen, select Define Instance and type your APM details. The
Location name is used for script assignment, so give it a meaningful name (for example, New
York, Office).

Getting StartedWith BPM - Best Practices
Chapter 2: Installing BPM

Application PerformanceManagement (9.50) Page 12 of 43



13. When the Finish screen appears, click Close.

14. InWindows, select Start > Programs > Business Process Monitor > Business Process
Monitor Admin (or in an internet browser, access http://<local host>:2696/).

Getting StartedWith BPM - Best Practices
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15. Verify that your instance connected successfully by checking the Health value in the General
Information page.
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Chapter 3: Connecting BPM to APM
1. From your internet browser, access http://<local host>:2696/. The BPM application appears.

2. Click the Create New Instance button . The Create New InstanceWizard appears.

3. In the Define Identification Parameters screen, define the identification parameters for the new
instance. All fields aremandatory. Make sure you can access the Gateway Server URL from the
BPMmachine. The Location name is used for script assignment, so give it a meaningful name (for
example, Boston, Office).

4. Click Next. The Run Instance as User screen appears.
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5. If you need to run the instance as a specific user, enter the user name, password and domain.
Leave these values blank if you do not need to run the instance as a specific user.

6. Click Next. The Retry on Failure screen appears.

7. The Retry on Failure setting enables you to control how BPM responds when a script fails. If a
script fails, this may be caused by a temporary problem not related to the script, for example a
temporary network or Internet error. When this option is enabled, if a script fails the first attempt,
BPM attempts again. Only the last attempt is displayed in BPM reports.

Enter the following information:

Getting StartedWith BPM - Best Practices
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l Retry on Failure:Select this option to activate the Retry on Failure option.

l Retry on failure delay: The number of seconds to wait before retrying. Note that a long failure
delay may cause the application to skip a scheduled run.

l Retry on failure count: Themaximum number of attempts to retry the script before the script
is defined as "Failed".

l Send additional error message:Select this option to include the number of attempts in the
failure error message.

8. If required, click Next to set the proxy connection and security settings, or click Finish to close
the wizard.

9. Refresh your browser and verify that BPM successfully connected to your APM.

10. If your Gateway Server URL is not accessible from your BPMmachine, or if you need a proxy, an
error message appears. If this occurs, click theConfiguration tab, reconfigure the details, and
click Save.

If you successfully connected, the following status appears.
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Chapter 4: Creating Scripts in
TruClient

NOTE:
If you are using script services from other teammembers or companies, you can download the
Business Process Template for BPM Scripting Requests from the Software Support site
(https://softwaresupport.softwaregrp.com/) to define your script requirements.

You can create scripts using the standalone version of TruClient.

1. Open TruClient and create a new script of typeWeb.

2. Select a browser.

TruClient opens the selected browser with the TruClient Toolbox docked in the browser window.

3. Click the Start Recording button to record browser activity.

4. In the browser address bar, type the address of your web application. Each action you perform is
indicated by a recording event in the TruClient add-in.

5. After completing the required browser activity, click the Stop button to stop recording.

6. Select File > Save Script and save the script as a *.usr file.

7. Use additional TruClient functionality to modify the script. For details see the TruClient
documentation.

8. When you have completed the script, select File > Export to Zip (Runtime only) to create a zip
file that can be imported into APM.

Getting StartedWith BPM - Best Practices
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Chapter 5: Creating Business
Applications
1. In APM, select Admin > End User Administration > Monitoring.

2. Right-click End User Management (default view) and select Add > Application and its BPM
Configuration.

3. In the Default Transaction Settings screen, define your transaction settings for performance
monitoring.

NOTE:
You can wait to define these settings after you determine your application's expected
behavior.

Getting StartedWith BPM - Best Practices
Chapter 5: Creating Business Applications
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4. In the Set TransactionMonitor Scripts screen, click Script Repository to view the scripts in the
repository.

Getting StartedWith BPM - Best Practices
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5. To select a script, double-click the script in the Available Scripts tree.
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6. In the Application Data Collectors screen, click .

7. In the Add Data Collectors screen, assign the data collectors to a location.
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8. In the Application Data Collectors screen, edit the schedule for each location, or leave the default
value (every 15minutes).

9. After reviewing your settings, click Finish and your script will start to run. It can take up to 20
minutes to see the first data point, depending on BPM's scheduled jobs.
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Chapter 6: Configuring Alerts
1. In APM, Select Admin > End User Management.

2. In theMonitoring tab, select your application.

3. Open theAlerts tab in the right pane and double-click on an existing alert, or click to create a

new alert.
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4. Click the Trigger Condition tab.

5. In theAlert name field, type ameaningful name for the alert. In Outlook, you will be able to filter

Getting StartedWith BPM - Best Practices
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your alerts by this name.

NOTE:
The contents of theSeverity field is for internal use. The trigger criteria is set according to
the number of locations you have, and the frequency of themonitor runs. If you have four
locations around the word, and if two subsequent runs fail, then a real problem alert is
indicated and false alerts are ignored.

6. Click the Filters tab.

7. Select the relevant transactions by which to filter the alert.

8. Click theActions tab.

Getting StartedWith BPM - Best Practices
Chapter 6: Configuring Alerts

Application PerformanceManagement (9.50) Page 26 of 43



9. Select theSend to specified recipients option and in the Definition Details area, click specified
recipients and select the required recipients.

10. Click theAdvanced Settings tab.
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11. To send an alert when the trigger condition clears, click theSend clear (follow up) alert
notification option.

12. To limit the number of alerts that are sent, click theSend no more than one alert for every
option and enter the time period.

Getting StartedWith BPM - Best Practices
Chapter 6: Configuring Alerts

Application PerformanceManagement (9.50) Page 28 of 43



Chapter 7: Configuring Transaction
Thresholds
In APM there are threemethods for setting performance transaction thresholds:

l Manual – Provides full control of the transaction thresholds

l Semi-automatic – Utilizes the Calculate Suggested Thresholds tool which provides static
thresholds based on a specific time period.

l Automatic – Provides automatic threshold baselines

In order to get accurate results, take into account that each location has different thresholds. You can
set a different threshold for each transaction location.

Getting StartedWith BPM - Best Practices
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To create threshold baselines for Business Process Monitor, you first need to activate a general key to
enable this feature. Then you adapt the thresholds for each application. We recommend that you create
the thresholds one at a time in order to ensure that the results are accurate. You can then add the
results to your best practices.

For more information, see the Business Process Monitor Administration Guide which is available for
download from the Software Support site: https://softwaresupport.softwaregrp.com.
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Chapter 8: Viewing Data in APM
You can view your monitored application data by accessing the 360° View in System Health or by
running the BPM PerformanceOver Time report.

Viewing Data in Service Health
The BPM checks if there is a new configuration every 2minutes. If you schedule your script to run an
application every 15minutes, the first data point arrives within 17minutes.

If a script fails, a red icon appears near the relevant transaction CI, You need to fix the script, and

upload it again.

1. In APM, click Application > Service Health > 360° View.

2. UnderHierarchy, select End User Monitors.

3. In theName column, click the application to expand it. The latest monitored data is displayed.

.

Viewing Data in BPMPerformance Over Time
Report
You can view your data in the BPM PerformanceOver Time report. This is one of themost important
reports for BPMmonitoring. The BPM PerformanceOver Time report displays a flat view of the data for
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all your BPM applications and transactions.

1. In APM, click Applications > End User Management > Analysis Reports > BPM
Performance Over Time.

2. In theApplication Filter, select your application.

3. Click Run.

4. To verify that all your BPMs are reporting, in theGroup by field, select Location.The report
displays our BPM data and you can determine if all you BPMs are reporting data as expected.

5. To view an advanced report that summarizes all data collection problems, in APM, click
Applications > Utilities > BPM Self Monitoring. The BPM Self Monitoring report displays
valuable information about your BPM health based on the data that is expected to arrive.
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Viewing Application Health Reports
Application Health includes Business Process Monitor reports which enable you tomonitor the
performance, availability, and volume of your applications’ health.

To access Application Health, in APM select Applications > Application Health> Business

Process Monitor ( ).

Application Health includes the following Business Process Monitor reports:

Status Over Time Report

The Status Over Time report shows a summary of all synthetic transactions and all locations in an
application, and their status over time.

Location Isolation Report

The Location Isolation report shows the availability or performance status of an application by location.
Locations are sorted by severity and the worst five locations are included in the report’s graph by
default. You can select additional locations from the list on the left of the graph.

You can filter the list by transaction by selecting the required transactions from the dropdown list above
the list of locations.

You can select whether to view data based onAvailability orPerformance. At the bottom of the report
there is a timeline with icons to indicate when alerts were recorded. This timeline includes all alerts
recorded by the system, including alerts in locations not currently displayed.
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Transaction Isolation Report

The Transaction Isolation report shows the availability or performance status of an application’s
transactions, for selected locations. The transactions are sorted by severity and the worst five
transactions are included in the report’s graph by default.

You can select whether to view data based onAvailability orPerformance. The timeline at the bottom
of the report indicates times when alerts were generated.

You can view the Transaction Isolation report for a time frame of 2 hours, 12 hours, day, week, or
month. When viewing data for a day, aggregated data is used except for the last hour, for which raw
data is used.

Layer Isolation Report

The Layer Isolation report shows transaction layer response times for selected transactions.

Themain transaction breakdown components are as follows:

Component Breakdown Report

The Component Breakdown report displays page component elements as they are loaded into a
browser in their exact loading order. Data is displayed in a waterfall format.

This report lists all components in a transaction. For example, a transactionmay include several html
files, images, and css files. For each component, the report lists the request size and the time it took to
complete the request.

Because each page component has its own breakdown bar, the report helps you identify if there are
specific components that are problematic or if there is a problem with specific domains or in a network
layer.

You can select which transaction components to display. For example, youmay want to hide the
Connection, DNS, and Retry time so that you can troubleshoot problems during the initial stages of a
transaction.

You can filter the report by transaction, location, or sample.

The data displayed on the report corresponds to a time unit on the Component Breakdown report. This
is typically an hour or a day. If you are viewing data for more than a day, the report displays the
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minimum andmaximum values for the time frame. To see further details you need to select a specific
hour in the Layer Isolation report.

Location Map

The LocationMap shows an interactivemap that displays the location of synthetic transactions, and
their status over time. At the top of the page you can select whether to view data based onAvailability
orPerformance.

Failure Log

The Failure Log report displays details of error messages for selected locations or transactions. You
can filter the report by location or transaction.

For each error, the report displays time, error name, location, transaction, and details of the error
message. If the error includes a snapshot, you can open a new tab with an image of the application at
the time of the error.

Alert Log

The Alert Log lists all synthetic alerts (alerts generated by BPM), for a single transaction, over the
selected time frame. This report includes both Availability and Performance alerts.

Viewing Data in Scheduled Reports
You can configure schedules to enable specified recipients to automatically receive reports, through
email, at regularly defined intervals.

You can schedule Custom Reports, Trend Reports, and Service Reports defined in the Report
Manager, or reports saved from the specific report page. You can also schedule Favorite Filter reports.

1. To create a scheduled report, click Applications > User Reports > Report Manager.

This page enables you tomanage the contents of Report Manager and view, edit, and clone
existing components, configure new user reports, email reports, and create a schedule for
selected reports to run.

2. Click and select New Custom Report to create your first report using the built-in APM
reports.
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3. If you want to run this report in the background, select theRefresh the report every option and
select the number of minutes.
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4. Click Next.

5. In theReport Components page, click . TheAdd Component page appears.

6. All BPM report are located in theEnd User Management folder.
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7. Expand the contents of theEnd User Management folder and click Status Reports.

8. From theReport drop down list, select BPM Performance Overtime By Transaction.

9. Click OK.
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10. In theReport Components page, click . TheAdd Component page appears.

11. Under theEnd User Management folder, click Analysis Reports.

12. From theReport drop down list, selectMetrics Over Time for a report that displays over time
measurements.

13. Click OK.

14. For each report, select the report and click theEdit Filter button.
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15. Select the relevant application.
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Chapter 9: BPM Report
Recommendation
Use the following reports for isolating problems:

l Performance Over Time Report

You can view your application availability and performance in one report. You can select to view the
data by transaction or by location over time. By clicking on a specific transaction or location, you can
view the Error Log, Snapshot on Error, Transaction Breakdown, and Error vs Availability Over Timer
in the same screen.

In APM, select Applications > End User Management > Analysis Reports > BPM
Performance Over Time.

l Triage Report

Data in the Triage report is organized by transactions and locations, and includes a transaction
breakdown component, as well as graphs showing error data. This report also includes information
about the health of the transaction scripts running at the various locations (Script Health), as well as
indicators for the health of the BPM data collectors.

In APM, select Applications > End User Management > Analysis Reports > Triage Report.

Getting StartedWith BPM - Best Practices
Chapter 9: BPM Report Recommendation

Application PerformanceManagement (9.50) Page 41 of 43



l Metrics Report

This report enables you to select one or moremetrics for selected applications and to view their
behavior over a period of time. By selectingmultiple metrics, you can compare their behavior to
discover possible correlations between them. You can also view data for up to four different time
comparisons.

In APM, select Applications > End User Management > Analysis Reports > Metrics Over
Time.
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Send documentation feedback
If you have comments about this document, you can contact the documentation team by email. If an
email client is configured on this system, click the link above and an email window opens with the
following information in the subject line:

Feedback on Getting Started With BPM - Best Practices (Micro Focus Application
Performance Management 9.50)

Add your feedback to the email and click Send.

If no email client is available, copy the information above to a new message in a webmail client, and
send your feedback to docs.feedback@microfocus.com.

We appreciate your feedback!
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