Summary
Error
It works well for other knowledge document id in Search Knowledgebase, only unable to find ceratin knowledge document id, but can find them in Published Documents.
Go to System Navigator > Knowledge Management > Search Knowledgebase
1) In query field, input the knowledge document id which have the issue, and click Search button directly
Result: could not search the record, 0 documents found
2) Go to Advanced search, select the tab "Knowledge_Library", input "Document ID", and click Search button
Result: could search the record.
Cause
The Locale value of the knowledge document in Published Documents is not set to the login language
Fix
1. Go to System Navigator > Knowledge Management > Published Documents
2. Search the document with Document ID
3. Click Edit, update the Locale value to the login language
4. Click Publish External / Internal
5. Go to Knowledge Management > Configuration > Knowledgebases
6. Find the Knowledge_Library, and click Full Reindex.
Confirm the reindex runs successfully
7. Go to Knowledge Management > Search Knowledgebase wich document id