Summary
"12:1012 Cannot access the file. [2] The system cannot find the file specified" error is received for all Windows VMs, when trying to perform granular recovery
Error
Error while trying to get the partitions for the disk(s)
12:1012 Cannot access the file. [2] The system cannot find the file specified.
Details:C:/ProgramData/OmniBack/tmp/VMWareGRE/vcentername/restore/0002/datastore_name/vm_name/vm_name-000002.vmdk
Cause
Problem is related to "quiscene" snapshot option at backup time, this is nor properly handled and we store snapshot disk name in IDB
Hence during recovery we expect to get vm_name-000002.vmdk file, while presented name stored on StoreOnce media is vm_name.vmdk
[111] +===== START [6666] DPMessageReceive
[111] |ProxyEnumDiskPartitions
[111] |{
disks=({
name='scsi0:0';
vmdkname='vm_name-000002.vmdk';
vmdkdirname='C:/ProgramData/OmniBack/tmp/VMWareGRE/vcenter_name/restore/0002/datastore_name/vm_name';
mounteddatastorename='datastore_name';
vmdknamewithdatastore='[datastore_name] vm_name/vm_name-000002.vmdk';
size='107374182400';
sizestr='100.00';
usescbt=1;
status='Approved';
arraytype=-1;
});
Fix
Workaround:
On mount proxy host rename:
C:/ProgramData/OmniBack/tmp/VMWareGRE/vcentername/restore/0002/datastore_name/vm_name/vm_name.vmdk to:
C:/ProgramData/OmniBack/tmp/VMWareGRE/vcentername/restore/0002/datastore_name/vm_name/vm_name-000002.vmdk
HF available via Support case - QCCR2A77210