Cannot access to PPM URL after DB migration

  • KM03060873
  • 22-Dec-2017
  • 22-Dec-2017

This document has not been formally reviewed for accuracy and is provided "as is" for your convenience.

Summary

unable to login to PPM with invalid user/password

Question

Afte DB refresh, PPM service is running properly however users are not able to login to PPM with invalid user/password. Logon denied error.

Answer

Cause:

The password is stored in KNTA_USERS.PASSWORD as an encrypted string meanwhile SOURCE and DESTINATION have individual encryption scheme so the encrypted password from SOURCE does not match with the encryption scheme on DESTINATION.

Solution:

1.Run kEncrypt.sh to generate a password to an encrypted string

2. Copy the text string between #!# and update to the KNTA_USERS.PASSWORD

- Open sql*plus with ppm user and run: set define off
- Execute the following sql to update the password

update knta_users
set password='xxxxxxxxx'
where username='your_username'
commit;

3. Enforce users to change their password on first login

update knta_users
set PASSWORD_EXPIRATION_DATE = sysdate
commit;