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Chapter 1: Introduction
This guide explains processes and procedures that help you tomigrate data from the previous versions
of Service Health Reporter (SHR) (9.3x/9.4x) to current version of Operations Bridge Reporter (OBR).
It provides information about preparing, migrating and validating your system post migration.

Note: Service Health Reporter is now Operations Bridge Reporter.

Need for Migration

SHR 9.x bundles the following components:

l SHR 9.x server

l SAP BusinessObjects server

l Sybase IQ server

l Remote Collector

OBR 10.x bundles the following components:

l OBR 10.x server

l SAP BusinessObjects server

l Vertica server

l Remote Collector

You have tomigrate data from previous versions of SHR (9.x) to current version of OBR system for the
following reasons:

SHR 9.x OBR 10.x

Used SAP BusinessObjects 3.x as the
reporting platform

Uses SAP BusinessObjects 4.x as the
reporting platform

Used Sybase IQ as the database Uses Vertica as database

Sybase IQ database supported onWindows
2008 operating system

Vertica database is supported only on
Linux operating system
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Formore information on the supported operating system, seeOperations Bridge Reporter Support
Matrix.

Audience

The information in this guide is intended for users who have administrator access.
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Chapter 2: Migration Process Overview
This section gives you an overview of themigration process from SHR 9.3x/9.4x to OBR 10.21 in
different deployment options using the Side-by-Sidemigration.

In Side-by-Sidemigration, OBR 10.21 is installed on a different system and the data is migrated from
SHR 9.3x/9.4x to OBR 10.21 system. Additional systems are required for this type of migration. This
migrationmethod ensures SHR 9.3x/9.4x system is functional until OBR 10.21 is operational on a
parallel system.

Note: For information to install OBR 10.20 using different install scenarios, seeOperations Bridge
Reporter Interactive Installation Guide.

Migration of Typical Install (Single System)

Following is the approach for migration of SHR 9.3x/9.4x typical install:

On Linux

l Install OBR 10.20 on a Linux system. Apply the OBR 10.21 patch.

l Migrate data and configuration from SHR 9.x to OBR 10.21 system.

l Validate the OBR 10.21 system and decommission SHR 9.3x/9.4x system.
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On Windows

o Install OBR 10.20 server onWindows 2012 and database (Vertica) on Linux. Apply the OBR
10.21 patch on both the servers.

o Migrate data and configuration from SHR 9.x to OBR 10.21 system.

o Validate the OBR 10.21 system and decommission SHR 9.3x/9.4x system.

Migration of Custom Install (Distributed System)

Following is the approach for migration of SHR 9.3x/9.4x custom install:

On Linux

l Install OBR 10.20 server and database on different systems. Apply the OBR 10.21 patch on both
the servers.

Note: In a custom install scenario, make sure that the OBR 10.21 patch is applied to all the
OBR component servers.
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l Migrate data and configuration to OBR 10.21.

l Validate the OBR 10.21 and decommission SHR 9.3x/9.4x.

On Windows

l Install OBR 10.20 server onWindows 2012 and database (Vertica) on Linux systems. Apply the
OBR 10.21 patch on both the servers.

Note: In a custom install scenario, make sure that the OBR 10.21 patch is applied to all the
OBR component servers.

l Migrate data and configuration from SHR 9.x and import it to OBR 10.21.

l Validate the OBR 10.21 and decommission SHR 9.3x/9.4x.
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Chapter 3: Getting Started
This chapter helps you to prepare for migration before you start themigration process.

Planning for Migration

Perform the following steps to prepare for migration:

1. Youmust ensure that the system(s) that you plan to install OBR 10.20 is ready with all the sizing
requirements completed.

Note: The requirements for the OBR 10.20 setup is significantly different from SHR 9.x. For
OBR 10.20 sizing information, seeOperations Bridge Reporter Performance, Sizing and
Tuning Guide.

For information on supported Operating System, seeOperations Bridge Reporter Support
Matrix.

In a typical scenario, apply the OBR 10.21 patch on theOBR 10.20 setup. In a custom install
scenario, make sure that the OBR 10.21 patch is applied to all the OBR component servers.

2. Identify the data that has to bemigrated. Also, identify the Content pack and the amount of data
that you want to migrate.

3. Following are the storage requirements for SHR 9.3x/9.4x system for data export:

a. Migration process is input/output intensive and the performance of migration is highly
dependent on the disk performance. It is recommended to use a disk with 15,000 rpm or high
performance for Migration.

b. Youmust make sure that the disk is accessible from theOBR 10.20 system during import.

c. The calculator feature in Migration can be used to calculate the downtime and the disk space
required for exporting the specified data. For steps, see Task 2: Migration Precheck > Step
calc.

4. Sybase IQ database in SHR 9.x uses main, temporary, and large buffer caches for database
operations. You can increase the value of the buffer cache using the parameters iqmc, iqtc and
iqlm located in the {PMDB_HOME}/config/pmdbconfig.cfg file for better database performance.
Depending on the physical memory available in the system you can allocate thememory to the
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Sybase IQ database.

After changing the values of the buffer cache, youmust restart the Sybase IQ database.

5. Take a backup of the existing SHR data. For more information on backup, see the relevant version
Service Health Reporter Disaster Recovery Guide.

6. Migrating from SHR 9.3x/9.4x to OBR 10.20 does not require a new license key.

If there is a change in IP address, the rehost option in Licensing portal can be used to obtain the 
license key. You can either use the new Software Entitlement system website or log on to 
Administration Console and go to Administration > Licensing > Launch HPE Password 
Center and use the rehost option.

7. Identify the content that requires manual migration. The configurations that should bemanually
created in OBR 10.20 post migration are:

a. OBR 10.20 uses the new universe format (unx) so schedules cannot bemigrated. You should
plan to recreate the schedules post migration.

b. LDAP Settings and Server configuration settings on SAP BusinessObjects.

c. User rights configured in SAP BusinessObjects.

d. Users, User Groups andmost of the Access Control List (ACL) can bemigrated. However,
the access level settings at folder, report or any other objects are not migrated. You should
manually apply the security settings for each objects after migration to realign with the
previous ones.

Note: The SAP BusinessObjects default users are not migrated.

e. Security configuration: https, SSO and Client Authentication Certificate.

Note: The SAP BusinessObjects audit database andOrchestration (ABC) history data
cannot bemigrated.

8. Determine if you have custom content deployed on your SHR 9.3x/9.4x instance and plan the
migration for custom content. Refer Migration Steps for Custom Content section for more details.

Migration Best Practices

Following are the best practices to reduce downtime duringmigration:
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l Migrate in chunks - this helps to bring the OBR 10.20 system up early and start the collections.

l Threads: This is a tunable parameter in Migration.conf file which gets created after precheck.
The default value is 20. If the I/O is under utilized then the value for the threads can be increased.
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Chapter 4: Migration Steps
This chapter guides you with the steps to perform migration.

Task 1: Pre-migration

1. Install OBR 10.20. You can choose to install different components of OBR on a single system or
different systems. For information onOBR 10.20 installation, seeOperations Bridge Reporter
Interactive Installation Guide.

If you have configured Remote Collectors, ensure that the number of collectors configured in OBR
10.20 should be same as the number of collectors configured in SHR 9.3x/9.4x.

2. Perform the Post-installation steps. For more information on post-installation steps, see
Operations Bridge Reporter Configuration Guide.

Note: Youmust not configure the Data Source and Topology Source at this stage.

Deploy the same set of content packs that were deployed on SHR 9.3x/9.4x system onOBR
10.20 using the Deployment Manager in the Administration Console.

3. Install the OBR 10.21 patch. For steps, seeOperations Bridge Reporter Release Notes for 10.21.

For OBR 10.20 custom install scenario, install the OBR 10.21 patch on all the systems.

4. From OBR 10.21 system, go to the location {PMDB_HOME}, copy the OBR9x_10x_Migration_
Binaries.zip file to the {PMDB_HOME} location in SHR 9.3x/9.4x system.

Note: If SHR 9.3x/9.4x components are on Linux operating system, copy the OBR9x_10x_
Migration_Binaries.zip file from OBR 10.21 on Linux operating system.

In case of SHR 9.3x/9.4x custom install scenario, copy the OBR9x_10x_Migration_
Binaries.zip file to all the SHR 9.3x/9.4x server components.

5. Unzip OBR9x_10x_Migration_Binaries.zip file in all SHR 9.3x/9.4x system(s). The {PMDB_
HOME}/Migration folder will be created.

Similarly, unzip OBR9x_10x_Migration_Binaries.zip file in all OBR 10.21 system(s). The
{PMDB_HOME}/Migration folder will be created.

6. If any of the SHR 9.3x/9.4x component(s) is installed on Linux Operating System, perform the
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following steps:

a. Go to {PMDB_HOME}/Migration folder.

b. Run the following command to give permission for setup.sh file:

chmod 777 setup.sh

c. Run the command: ./setup.sh

Similarly, perform the following for OBR 10.21 component(s) installed on Linux Operating System:

a. Go to {PMDB_HOME}/Migration folder.

b. Run the following command to give permission for setup.sh file:

chmod 777 setup.sh

c. Run the command: ./setup.sh

Task 2: Migration Precheck

1. Stop the collection and timer service on SHR 9.3x/9.4x server and wait for all the data to be
processed, follow these steps:

Note: If you have installed SHR 9.3x/9.4x Remote Collector, stop the collection service on
the remote collector system.

On Windows:

a. Click Start > Run. The Run dialog box appears.

b. Type services.msc in the open field, and then press ENTER. The Services window appears.

c. Right-click on the following services and click Stop:

HP_PMDB_Platform_Collection

HP_PMDB_Platform_Timer

On Linux:

a. Go to the /etc/init.d directory, run the following commands on the command prompt:

On RHEL 6.x:

l service HP_PMDB_Platform_Collection stop

l service TrendTimer stop
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2. On SHR 9.3x/9.4x server, make sure that the PostgreSQL service is running, follow these steps:

On Windows:

a. Click Start > Run. The Run dialog box appears.

b. Type services.msc in the open field, and then press ENTER. The Services window appears.

c. Check the status for the following service is Running:

HP_PMDB_Platform_PostgreSQL

If the service is not running, right-click on the service and click Start.

On Linux:

Go to the /etc/init.d directory, run the following commands on the command prompt:

On RHEL 6.x: service HP_PMDB_Platform_PostgreSQL status

If the service is not running, run the following command:

On RHEL 6.x: service HP_PMDB_Platform_PostgreSQL start

The status of the servicemust be Running.

3. On the SHR 9.3x/9.4x server execute theMigration Utility Precheck command to validate the
readiness for data export.

On successful precheck the following are created in the specified <path> of the SHR 9.3x/9.4x
server:

o Migration.conf file

o Summary folder with PrecheckSummary html

Note: You should take necessary actions on "Pre-check failed" message from the Pre-check
tool.

4. In case of remote SAP BusinessObjects server in SHR 9.3x/9.4x, copy the config.prp file from
{PMDB_HOME}/data of SHR 9.3x/9.4x server to {PMDB_HOME}/data in SHR 9.3x/9.4x SAP
BusinessObjects server.

In case of remote Sybase IQ server, copy the config.prp file from {PMDB_HOME}/data of SHR
9.3x/9.4x server to {PMDB_HOME}/data in Sybase IQ server.

5. The -calc option in migrationUtilitymust be run on the SHR 9.3x/9.4x Sybase IQ server to
calculate the downtime and the disk space required for exporting the specified data.
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Note: Make sure to execute the precheck option on the SHR 9.3x/9.4x server before
executing –calc option.

Run the following command:

migrationUtility –calc <number of days>/-startDate <YYYY-MM-DD> -endDate <YYYY-
MM-DD>

You can type the number of days or the start date and end date to calculate the downtime and the
disk space required for exporting the data for the specified days.

Note: The value displayed after running the -calc option is based on the benchmarks
performed in the lab.

6. After successful precheck, in case of SHR 9.3x/9.4x custom install scenario, copy the folder that
is created after precheck to all the SHR 9.3x/9.4x server components.

Task 3: Export

1. Execute theMigration Utility Export command to export Content Packs data, SAP
BusinessObjects artifacts and Data Source Configuration in a zipped file format from SHR
9.3x/9.4x system(s).

Note: In SHR 9.3x/9.4x system during the export, the content data is exported from Sybase
server, data source configuration from SHR server and BusinessObjects artifacts from SAP
BusinessObjects server. In case of SHR custom (distributed) installation scenarios, run the
export tool from each of SHR 9.3x/9.4x servers.

On successful export the following folders are created in the specified <path> of the SHR 9.3x/9.4x
system(s):

o Summary folder with ExportSummary html

o BusinessObjects folder with exported artifacts details. This folder consists of the following
folders:

i. OBR.biar: The BIAR file.

ii. bo.ini: This file lists all the SAP BusinessObjects configurations that will be to be
imported to the OBR 10.21 system

iii. export.log: This is a text log file with the SAP BusinessObjects export log summary.
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o ContentData folder with exported individual Content Pack data details. Each Content pack
folder consists of the following folders:

i. csv: This folder lists all the csv’s to be imported on the 10.21 system.

ii. ret_csv: This folder lists the dsi_retention table csv.

iii. sql folder: This folder is created during the data export. It contains the SQLs required for
exporting data.

o metadata folder with exported configuration details. This folder consists of the following folders:

i. configFiles: This folder lists all the configurations to be imported on the 10.21system.

ii. csv: This folder lists all the csv’s to be imported on the 10.21 system.

iii. RemoteCollector.prp: This file consists the collection data to be imported on the 10.21
system.

Task 4: Import

1. Copy/Share/Mount the folder where the SHR 9.3x/9.4x data is exported to OBR 10.21 system(s).

Note: Youmust not Copy/Share/Mount theMigration export folder to the /root directory or to
any user specific home directory.

2. If you have configured Remote Collectors in OBR 10.21, perform the following steps:

a. On theOBR 10.21 server, go to the location where the export folder is copied/mounted/shared
from SHR 9.3x/9.4x system.

b. Open the metadata folder and edit the RemoteCollector.prp file as follows:

collectormapping

local=local

RC9x=<edit this value with OBR 10.21 Remote Collector Name>

3. In case of remote SAP BusinessObjects server in OBR 10.21, copy the config.prp file from
{PMDB_HOME}/data of OBR 10.21 server to {PMDB_HOME}/data of SAP BusinessObjects server.

In case of remote Vertica server, copy the config.prp file from {PMDB_HOME}/data of OBR 10.21
server to {PMDB_HOME}/Migration of Vertica server.

4. Stop collection, jobmanager, task manager and orchestration service on theOBR 10.21 server,
follow these steps:
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Note: If you have installed OBR 10.21 Remote Collector, stop the collection service on the
remote collector system.

On Windows:

a. Click Start > Run. The Run dialog box appears.

b. Type services.msc in the open field, and then press ENTER. The Services window appears.

c. Right-click on the following services and click Stop:

HPE_PMDB_Platform_Collection

HPE_PMDB_Platform_Orchestration

HPE_PMDB_Platform_JobManager

HPE_PMDB_Platform_TaskManager

On Linux:

a. Go to the /etc/init.d directory, run the following commands on the command prompt:

On RHEL 6.x/SUSE Linux Enterprise Server 11:

l service HPE_PMDB_Platform_Collection stop

l service HPE_PMDB_Platform_Orchestration stop

l service HPE_PMDB_Platform_JobManager stop

l service HPE_PMDB_Platform_TaskManager stop

On RHEL 7.x:

l systemctl stop HPE_PMDB_Platform_Collection.service

l systemctl stop HPE_PMDB_Platform_Orchestration.service

l systemctl stop HPE_PMDB_Platform_JobManager.service

l systemctl stop HPE_PMDB_Platform_TaskManager.service

5. OnOBR 10.21 server, make sure that the PostgreSQL service is running, follow these steps:

On Windows:

a. Click Start > Run. The Run dialog box appears.

b. Type services.msc in the open field, and then press ENTER. The Services window appears.

c. Check the status for the following service is Running:
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HPE_PMDB_Platform_PostgreSQL

If the service is not running, right-click on the service and click Start.

On Linux:

Go to the /etc/init.d directory, run the following commands on the command prompt:

On RHEL 6.x/SUSE Linux Enterprise Server 11: service HP_PMDB_Platform_PostgreSQL
status

On RHEL 7.x: systemctl status HP_PMDB_Platform_PostgreSQL.service

If the service is not running, run the following command:

On RHEL 6.x/SUSE Linux Enterprise Server 11: service HP_PMDB_Platform_PostgreSQL
start

On RHEL 7.x: systemctl start HP_PMDB_Platform_PostgreSQL.service

6. Execute theMigration Utility Import command to import Content Packs data, SAP
BusinessObjects artifacts and Data Source Configuration from SHR 9.3x/9.4x system(s) to OBR
10.21 system(s).

Note: In OBR 10.21 system during the import, the content data gets imported to Vertica
server, data source configuration to OBR server and BusinessObjects artifacts to SAP
BusinessObjects server. In case of OBR custom (distributed) installation scenarios, make
sure to copy the exported folder from SHR 9.3x/9.4x system(s) to the respective OBR 10.21
system(s).

For example, if you have a typical SHR 9.3x/9.4x scenario inWindows operating system, and
you want to migrate to the custom install scenario where OBR 10.21 server and SAP
BusinessObjects server are on single system and Vertica server on remote system,
copy/share/mount the exported folder from the SHR 9.3x/9.4x system to both the OBR 10.21
systems.

In case of OBR custom (distributed) installation scenarios, run the import tool from each of
OBR servers.

Note: After successful data import on OBR 10.21 system, if Generic database (for example:
Sybase database) is configured as data source, copy the jconn4.jar from {SYBASE}
/jConnect-7_0/classes on Sybase IQ server to {PMDB_HOME}/lib directory onOBR 10.21
system for connection and collection to work fine.
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Task 5: Post-migration

1. Verify the summary of old data and new datamigrated from CompareSummary.htm. For more
details, see Validation using Summary HTMLs.

2. Start collection, jobmanager, task manager and orchestration service on theOBR 10.21 server,
follow these steps:

Note: If you have installed OBR 10.21 Remote Collector, start the collection service on the
remote collector system.

On Windows:

a. Click Start > Run. The Run dialog box appears.

b. Type services.msc in the open field, and then press ENTER. The Services window appears.

c. Right-click on the following services and click Start:

HPE_PMDB_Platform_Collection

HPE_PMDB_Platform_Orchestration

HPE_PMDB_Platform_JobManager

HPE_PMDB_Platform_TaskManager

On Linux:

a. Go to the /etc/init.d directory, run the following commands on the command prompt:

On RHEL 6.x/SUSE Linux Enterprise Server 11:

l service HPE_PMDB_Platform_Collection start

l service HPE_PMDB_Platform_Orchestration start

l service HPE_PMDB_Platform_JobManager start

l service HPE_PMDB_Platform_TaskManager start

On RHEL 7.x:

l systemctl start HPE_PMDB_Platform_Collection.service

l systemctl start HPE_PMDB_Platform_Orchestration.service

l systemctl start HPE_PMDB_Platform_JobManager.service

l systemctl start HPE_PMDB_Platform_TaskManager.service
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Chapter 5: Migration Utility
OBR migration provides migrationUtility that helps you tomigrate data from SHR 9.3x/9.4x
system to OBR 10.21.

The command to run the utility is as follows:

migrationUtility -precheck/-export/-import/-dataSourceClean/-calc

To get more information on the usage of the utility, run the command: migrationUtility -help

l Precheck option

l Export option

l Import option

l Validation using Summary HTMLs

Precheck option

The Precheck option performs all the checks needed for migration as follows:

l Checks if the Collection service is stopped on both the remote collector and the SHR system.

l Checks if Data from the remote collector is moved to the SHR system.

l Checks if there are files pending in the collect and stage folder. If the files are not processed or in
pending state the precheck fails and displays themessagePre-check failed.

l Checks if all the data from the stage table gets processed.

l Checks if the Timer service is stopped on the SHR system.

The following table lists the parameters in Migration.conf file:

Parameter Options Description

Pre-check PASSED|
FAILED

The information on the precheck status will be displayed.

The value for precheck will be PASSED if the precheck is
successful and FAILED if the precheck fails.

Content Packs yes | no Lists all installed Content Packs on SHR 9.x system.

The default value is yes, all the installed Content Packs will be
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exported. You can change the value to no to exclude the export of
specific Content pack.

Example: Core=yes

SYSTEM=yes

MSAppCore=yes

AppCore=no

WebLogic=no

l fact

l hourly

l daily

all |
number of
days

Specify the number of days for the table to export data.

The value all is specified if all of the data in the table has to be
exported. If you want to export data for a specific number of days
from these tables specify the value for number of days.

Example: fact=5

In the above example, the data of the last 5 days from the current
system date will be exported.

l factStartDate

l factEndDate

l hourlyStartDat
e

l hourlyEndDate

l dailyStartDate

l dailyEndDate

yyyy-mm-
dd

Specify the start date and end date for the table to export data.

The format to specify the date to export the data is yyyy-mm-dd.

Example: factStartDate =2015-01-01 factEndDate=2015-01-31

The data of the specified start date and end date will bemigrated.
If the end date is not specified then the data untill the current
system date will bemigrated.

Note: If the EndDate is specified for fact, hourly and daily
values, then the EndDate value will take the priority over the
number of days value.

concurrent_
processes

10 The number of concurrent processes for which the data has to be
exported.

chunk_rate 30 The number of days for data export batch.

SHR_OS windows |
linux

TheOperating System of SHR 9.x from where the data is
exported.

Precheck option command

To run the precheck option, go to the location {PMDB_HOME}/bin and run the following command:

migrationUtility –precheck –path <path>

where, <path> is the location of the folder where you want the precheck artifacts to be created.
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Note: Youmust make sure that the <path> is a folder and not drive.

Example:

Linux: migrationUtility –precheck –path /opt/upgrade_pack

Windows: migrationUtility –precheck –path C:\upgrade_pack

Export option

The Export option helps you to export the Content Packs data, SAP BusinessObjects artifacts and
Data Source Configuration in a zipped file format.

In SHR 9.3x/9.4x system during the export, the content data is exported from Sybase server, data
source configuration from SHR server and BusinessObjects artifacts from SAP BusinessObjects
server. In case of SHR custom (distributed) installation scenarios, run the export tool from each of
SHR 9.3x/9.4x servers.

Note: For the OMi Content pack migration, the data of minimum 35 days must bemigrated at
once.

Content Pack data

The Export option reads the data from Migration.conf file that is created in the SHR 9.3x/9.4x
system after the precheck is completed. The data of the Content packs that are specified as yes in
Migration.conf file will be exported.

Note: If you do not want to export specific Content pack then change the yes option to no in the
Migration.conf file.

SAP BusinessObjects artifacts

The following SAP BusinessObjects artifacts created by the SAP BusinessObjects non-default user in
SHR 9.3x/9.4x can be exported using the Export option:

l Users

l UserGroups
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l Access levels

Note: If the SAP BusinessObjects non-default user has mapped the users, usergroups and
Access levels in SHR 9.3x/9.4x, then after migrating to OBR 10.21 themapping has to be done
manually. This is because of the change in universe objects in OBR 10.21.

Data Source Configuration

The Export option helps you to export the Data Source Configurations from a SHR 9.3x/9.4x system.

Export option command

On the SHR 9.3x/9.4x system(s), go to the location {PMDB_HOME}/bin and run the following command:

migrationUtility –export –path <path>

Note: Youmust specify the folder path that has been created after migration precheck. Do not
create the folder before as the export tool creates the folder after execution. In case of SHR
9.3x/9.4x distributed scenario, on the SAP BusinessObjects server and/or Sybase IQ server,
specify the folder path that you have copied from the SHR 9.3x/9.4x server.

If you are executing the export tool again, then the precheck should be run with a different folder
and the export should also be done to a new folder.

where, <path> is the location where you export data.

To export the Content Data and/or Data Source and/or BOArtifacts, run the following command:

migrationUtility –export –path <path> [-run contentData,dataSource,boArtifacts]

For Example: migrationUtility –export –path /opt/migrateall -run
contentData,dataSource

The above example exports the Content Data and the Data Source Configuration data.

To export all the Content Data and/or Data Source and/or BOArtifacts, run the following command:

migrationUtility –export –path <path>

On a remote Sybase IQ server, to export Content Data, run the following command:

migrationUtility –export –path <path> [-run contentData]

The above command exports the Content Data from remote Sybase IQ server.

The following log files for the export tool is available at the location {PMDB_HOME}/log/:
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l metaDataMigrate.log

l boMigrate.log

l contentDataMigrate.log

l migrationUtility.log

After running the Export option, the ExportSummary html is created with details of the exported data.

Import option

The Import option helps you to import the Content Packs data, SAP BusinessObjects artifacts and
Data Source Configuration.

In OBR 10.21 system during the import, the content data gets imported to Vertica server, data source
configuration to OBR server and BusinessObjects artifacts to SAP BusinessObjects server. In case of
OBR custom (distributed) installation scenarios, make sure to copy the exported folder from SHR
9.3x/9.4x system(s) to the respective OBR 10.21 system(s).

For example, if you have a typical SHR 9.3x/9.4x scenario inWindows operating system, and you
want to migrate to the custom install scenario where OBR 10.21 server and SAP BusinessObjects
server are on single system and Vertica server on remote system, copy/share/mount the exported
folder from the SHR 9.3x/9.4x system to both the OBR 10.21 systems.

In case of OBR custom (distributed) installation scenarios, run the import tool from each of OBR
servers.

Note: For the OMi Content pack migration, the data of minimum 35 days must bemigrated at
once.

Content Pack data

The Import option reads the data from Migration.conf file. The data of the Content Packs that are
specified as yes in Migration.conf file will be imported.

Note: If you do not want to import specific Content Pack then change the yes option to no in the
Migration.conf file.
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SAP BusinessObjects artifacts

The following SAP BusinessObjects artifacts of SHR 9.3x/9.4x to OBR 10.21 is imported using the
Import option:

l Users

l Usergroups

l Access levels

Data Source Configuration

This option helps you to import Data Source Configurations from a SHR 9.3x/9.4x system to OBR
10.21 system.

Youmust make sure that the following actions are completed on theOBR 10.21 system before the
Import option is run:

l OBR 10.20 is installed. Configure Remote Collector if required.

l Post installation steps are performed.

l TheOBR 10.21 patch is installed.

l Install the Content Packs msi(s) and deployed.

l Copy the folder where the SHR 9.3x/9.4x data is exported to OBR 10.21 system.

l The Collection andOrchestration services are stopped.

Note: The dataSourceClean option can be used to re-import the data toOBR 10.21 system. This
option cleans the tables with the previous imported data.

You can use this option only when:

1. The Data Source Configuration data is already imported once toOBR 10.21 system.

2. The data collection is NOT started on theOBR 10.21 system.

dataSourceClean option command:

migrationUtility -dataSourceClean
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Import option command

To import the all of the data, go to the location {PMDB_HOME}/bin and run the following command:

Note: If OBR 10.21 is installed on non-default drive inWindows operating system, execute Import
option on command prompt from C:/ drive.

migrationUtility –import –path <path>

where, <path> is the location where the export folder is copied/shared/mounted on theOBR 10.21
system.

To import the Content Data and/or Data Source and/or BOArtifacts, run the following command:

migrationUtility –import –path <path> [-run contentData,dataSource,boArtifacts]

For Example: migrationUtility –import –path /opt/migrateall [-run
boArtifacts,dataSource]

The above example imports the BOArtifacts and the Data Source Configuration data.

The following log files for the Import option is available at the location {PMDB_HOME}/log:

l metaDataMigrate.log

l boMigrate.log

l contentDataMigrate.log

l migrationUtility.log

After running the Import option, the ImportSummary html is created with details of the imported data.

Calculator Option

The calculator feature in Migration can be used to calculate the downtime and the disk space required
for exporting the specified data.

The -calc option in migrationUtilitymust be run on the SHR 9.3x/9.4x Sybase IQ server to
calculate the downtime and the disk space required for exporting the specified data.

Note: Make sure to execute the precheck option on the SHR 9.3x/9.4x server before executing –
calc option.

Run the following command:
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migrationUtility –calc <number of days>/-startDate <YYYY-MM-DD> -endDate <YYYY-MM-
DD>

You can type the number of days or the start date and end date to calculate the downtime and the disk
space required for exporting the data for the specified days.

Note: The value displayed after running the -calc option is based on the benchmarks performed
in the lab.
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Chapter 6: Validation using Summary HTML
The Validation Summary HTML helps the user to verify if migration is successful. These Summary
HTML are available in the path that you have specified while running the import and export option.

Following are the HTML available:

l PrecheckSummary.htm - This HTML is created after the precheck tool is run successfully. It
provides information of the installed Content Packs for export. You can click on the links provided
for the individual Content Packs for more details.

l ExportSummary.htm - This HTML is created after the export tool is run successfully. It provides
information of the installed Content Packs that are exported. You can click on the links provided for
the individual Content Packs for more details.

l ImportSummary.htm - This HTML is created after the import tool is run successfully. It provides
information of the Content Packs that are imported. You can click on the links provided for the
individual Content Packs for more details.

l CompareSummary.htm - This HTML provides comparative information of the Content packs that
aremigrated. The value of the columns No. of Records Imported andNo. of Records Exported
can be referred to compare the data. The Import Status column displays true if the No. of Records
Imported and No. of Records Exported is same else it displays false. For a successful import the
No. of Records Imported and No. of Records Exported columns should have same values and the
Import Status column should display true.

Note: If you have completedmigration and started the collections in the OBR 10.21 system,
and there is another migration done after few days, there can bemiss-match in the Compare
Summary for dimensions.

Along with the abovementioned HTMLs, there are following folders that consists of individual HTML of
eachmigrated Content Pack:

l Precheck

l Import

l Export
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Chapter 7: Migration Steps for Custom Content
This chapter describes the approach tomigrate custom content.

Custom Reports and/or Universe on Custom Schema

If you have developed new reports on the universe or created new universe shipped in SHR 9.3x/9.4x
then these reports and universe can bemigrated to OBR 10.21. Follow these steps tomigrate new
reports and universe:

1. From SHR 9.3x/9.4x's SAP BusinessObjects 3.x installed system, "Export universe and related
reports as BIAR" on page 32.

2. Follow these steps for universemigration

a. Change the connection to vertica connection from BO 4.x.

b. If there are any Sybase specific SQLs move it to Vertica.

3. Use BO 4.x "UpgradeManagement Tool (UMT) " on page 45 onOBR 10.21 and import these
reports.

4. "Convert unv to unx" on page 51 using Information Design Tool (IDT).

Note: XCelsius dashboards using Qaaws does not work with unx.

5. "Use Remapping Tool " on page 55 onOBR 10.21 tomap the reports to OBR 10.x universe.

Custom Domain, Application and ETL Content

Domain content

Tomigrate the Domain content from SHR 9.3x/9.4x to OBR 10.21 system, follow these steps:

1. Compile the domain content with OBR 10.21 CDE.

2. Port Sybase IQ procedures, if any, to Vertica scripts and update ABC step definition.

3. Deploy the content on OBR 10.21
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4. Migrate the data from SHR 9.3x/9.4x to OBR 10.21. Use themigration script generation tool to
generatemigration scripts. You canmodify the script if required and use the scripts to export data
from SHR 9.3x/9.4x and import the data to OBR 10.21.

5. CreateManifest and compile content pack. For steps, seeOperations Bridge Reporter Content
Development Guide.

Application content

Tomigrate the Application content from SHR 9.3x/9.4x to OBR 10.21 system, follow these steps:

1. Tomigrate the application content the "LCM BIAR " on page 58should be taken.

2. CreateManifest and compile content pack. For steps, seeOperations Bridge Reporter Content
Development Guide.

Tomigrate app content, perform the steps described in Custom Reports and/or Universe on Custom
Schema section.

Tomigrate the ETLcontent from SHR 9.3x/9.4x to OBR 10.21 system, follow these steps:

1. If your ETL uses Sybase IQ specific SQLs/functions in DB collection policies, port it to Vertica.

2. If your ETL uses Sybase IQ specific SQLs/functions in stage rules, port it to Vertica.

3. Compile the ETL content with OBR 10.21 CDE.

4. Deploy the ETL onOBR 10.21. For steps, seeOperations Bridge Reporter Content Development
Guide.
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Reference

Export universe and related reports as BIAR

1. From SHR 9.3x/9.4x system, click Start > All Programs > BusinessObjects XI 3.1 > Import
Wizard .

2. The welcome screen of the Import Wizard appears. Click Next.
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3. In theSource drop-down, select BusinessObjects Enterprise XI 3.x and click Next.
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4. In theDestination drop-down, select Business Intelligence Archive Resource (BIAR) File
and click Next.
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5. Select the check-boxes as shown in the following image and click Next.
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6. A note on importing object rights appears, click Next.
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7. Click Next on the Custom Access Levels screen.

8. Select Custom Content Pack reports and click Next.
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9. Select Next.
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10. Select the option forSelect an importing option for universe objects: as shown in the
following image and click Next.

Migration Guide

HPE Operations Bridge Reporter (10.21) Page 39 of 70



11. The Universe will be selected by default, click Next.
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12. Select the option forSelect an importing option for repository objects: as shown in the
following image. Click Next.
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13. Select Do not import recipients and click Next.
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14. The Ready to import screen appears with import details, click Finish.
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15. Click View Detail Log to check if all the objects were successfully imported to BIAR.
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16. Copy the BIAR file from the location to the specified location.

Upgrade Management Tool (UMT)

Perform the following steps onOBR 10.21 system and import the custom reports.

For Windows:

1. InSearch, type UpgradeManagement Tool. The welcome page appears.

Click Complete Upgrade, and click Next

2. In Upgrade Scenario select Biar to Live, select the Source BIAR file. InDestination, type the
CMS Name and credentials click Next.
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Click Start.

After completion upgrade the BIAR into 4.1 system.

Note: Youmust install the SAP BusinessObjects client tools that is shipped as part of OBR
media.

For Linux:
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1. Go to the locaton <BOinstallpath>/sap_bobj/enterprise_
xi40/java/apps/upgradeManagementTool/jars

2. Run the following command:

java -jar upgrademanagementtool.jar -mode biartolive -biarfile "<location of
biarfile>/test.biar" -destination <destination system>:6400 -
destinationusername "Administrator" -destinationpassword "<password>" -logfile
"/opt/log.txt"

After completing the UpgradeManagement Tool steps, perform these steps to import universe:

1. InSearch, type Universe Design Tool.

2. Log on to Universe Design Tool (UDT). Type the SAP BusinessObjects 4.1 system details, where
the BIAR is migrated from the previous steps and click Ok.

3. Click Connections icon to create a Vertica connection. In Define a new connection page, click
Next.
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4. Click Hewlett Packard > HP Vertica 6.1 > JDBC Drivers. Click Next.

5. Click Test Connection to verify the connection and then click Next.
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6. Click Finish. A connection is created with Vertica as database.

7. Go to File > New > Parameters > Definition tab.

8. Select the connection created in the previous step and click Test. Click OK.
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9. Go to the File > Import.

10. Click Browse. Select the Universe from Repository and click OK

11. The followingmessage appears. Click OK.

12. Click Tools > Check Integrity to verify any issues.

Migration Guide

HPE Operations Bridge Reporter (10.21) Page 50 of 70



13. Click File > Export to Repository this Universe.

Convert unv to unx
1. InSearch, type Information Design Tool. Log on to Information Design Tool (IDT) and Click OK.

2. In IDT > Repository Resources, click + and insert Session. Type the system details that was
provided in the previous step.
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3. Click File > New > Project.

4. Type the project name to save the unx in the local system with the same name. Click Finish.
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5. Click File > Convert .unv Universe.... The Convert .unv Universe page appears.

6. Select the universe that has to converted to unx. Select Automatically Convert @Prompt into
universe named parameters andSave for all users check-box.
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Now wewill see 3 files created under the project which we created

a. <Universename.blx>

b. <Universename.dfx>

c. <Connection.cns>

7. In the IDT left pane, right-click <Universename.blx>. Select all options and click Check
Integrity.
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Publish to Repository. This step ensures that unv is successfully converted to unx.

Use Remapping Tool

1. Log on to SAP BusinessObjects BI Launch pad from the link:
http://<servername>:8080/BOE/BI

2. Click Documents. Click Folder that has the reports to bemapped. Right-click on the report and
click Modify.
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3. Click Data. The list of data providers appears.

4. Right-click on the first data providers list and click Change Sources.

5. Select the Universe (UNX) and click Next.

6. Select the Universe that is converted to unx in the previous task and click Select.
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7. Select the Apply changes in all queries sharing the same data source check-box. Click Next.

8. In Strategy Selection, verify if the objects aremapped and click Next and Finish.

Migration Guide

HPE Operations Bridge Reporter (10.21) Page 57 of 70



This will ensure that the reports aremapped to the converted UNX. After converting the reports
and universe, take an "LCM BIAR " below.

LCM BIAR

Follow these steps on theOBR 10.21 system to take an LCM BIAR:

1. Log on to Central Management Console (CMC) as administrator from the following URL:

http://<servername>:8080/CMC

You can log on to CMC from the Administration Console, click Administration > SAP BOBJ and
then click Launch CMC.

The CMC Home page appears.

2. Click Promotion Management.
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3. Click New Job to create a job.

4. Type the job name inName as per your content. You can type the description if required.
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For Example:

5. From Source, select Login to a New CMS.
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6. Type the source system details where SAP BusinessObjects reports and universes exist and
click Login.

The source details appears in theSource field.
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7. From Destination, select theOutput to LCMBIAR File option. Click Create.

8. From the left pane, select the Reports from the folders.

For example: The following image displays selections from Operations Bridge Reporter folder:
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9. Click the folder where the reports available to bemigrated.

10. Select the Reports and click Add.
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11. In the left pane, scroll down and click on the universe. Select the universe and then click Add.

12. In the left pane, scroll down and click on the Connection used for the universe. Select the
connection and then click Add & Close.
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13. Click Manage Dependencies to check the reports, universe and connection.

Click Select Dependents to check the dependencies, this dependency check will automatically
add the dependents here. Click onApply & Close.
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14. Select all the objects (reports, universe and connection) and click Promote.

15. Verify Source andDestination andObjects to be promoted. Click Export.
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16. Save the exported objects LCM BIAR to Local folder.

17. Rename the File and Save
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Troubleshooting Migration Issues

This section covers the common problems that youmay encounter duringmigrating data from SHR
9.3x/9.4x to OBR10.21 and provide steps to troubleshoot them. Each problem is documented with a
symptom, the description about the symptom and resolution for the symptom.

Symptom: Export Failing with Out of Memory Error

Description
:

This error occurs when the export option is run on the SHR 9.3x/9.4x system if there
is no sufficient memory for export.

Resolution: Perform the following steps to resolve this issue:

1. On the SHR 9.3x/9.4x system, go to the location {PMDB_HOME}
/config/startup.

2. Open the migrationUtility.ini file.

3. Edit the parameter as follows:

jargs=-DBSMR_HOME={bsmr.home} -Dbsmr.home={bsmr.home} -DDPIPE_
HOME={bsmr.home} -Dpmdb.home={bsmr.home} -Xms120M -Xmx2048M

jargs=-DBSMR_HOME={bsmr.home} -Dbsmr.home={bsmr.home} -DDPIPE_
HOME={bsmr.home} -Dpmdb.home={bsmr.home} -Xms120M –Xmx3000M

Symptom: After import on OBR 10.21 system, collection is not complete for all days

Description
:

The collection is based on collector.maxHistory property in config.prp file. By
default it is 360 hours. If themigration (import) has takenmore time than 360 hours
then the collection for the additional days will not happen.

Resolution: Perform the following steps onOBR 10.21 system to resolve this issue:

1. Go to the location {PMDB_HOME}/data.

2. Open the config.prp file.

3. Edit the value for collector.maxHistorywith the number of hours for the
migration (import) to complete.

For Example: If themigration (import) takes 16 days to complete, edit the
parameter as follows:

collector.maxHistory=384
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Send documentation feedback
If you have comments about this document, you can contact the documentation team by email. If an
email client is configured on this system, click the link above and an email window opens with the
following information in the subject line:

Feedback on Migration Guide (Operations Bridge Reporter 10.21)

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a webmail client, and
send your feedback to docfeedback@hpe.com.

We appreciate your feedback!
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