Summary
Error
STR:
1.At windows client,
Login to SM > From the Navigator go to Knowledge Management=>Draft Documents=>Select Document Type: Reference
2.at Reference tab, input some characters, by add a space before change the line:
A1111 A2222(space)
B1111 B2222(space)
C1111 C2222
3.click Save
4.click "Source" to check, we can see the space is at the end of the line, just coincident as what we have saved.
5.But this behavior is different at webtier for different versions.
6.At webtier 9.32, or versions before 9.32(9.31, 9.30), the behavior is the same as windows client, the space will be saved at the end of the line.
7. From webtier 9.33 and after 9.33(9.34, 9.35), the behavior has been changed, the space at the end of the line will be deleted after saving.
The above STR is for IE11, this issue is not happened in Chrome browser.
Cause
We have checked this issue with lab.
We use a third-party component CKEditor in SM knowledge management.
After investigation, it seems removing the space is the behavior of CKEditor.
So there is no way for SM to change the behavior.
We have QCCR1E138768 to this issue.