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l Manage support contracts
l Look up HP support contacts
l Review information about available services
l Enter into discussions with other software customers
l Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a
support contract. To register for an HP Passport ID, go to:

https://hpp12.passport.hp.com/hppcf/createuser.do

To find more information about access levels, go to:

https://softwaresupport.hp.com/web/softwaresupport/access-levels

HP Software Solutions Now accesses the HPSW Solution and Integration Portal Web site. This site enables
you to explore HP Product Solutions to meet your business needs, includes a full list of Integrations between
HP Products, as well as a listing of ITIL Processes. The URL for this Web site is
http://h20230.www2.hp.com/sc/solutions/index.jsp
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Server patching overview
Server Automation (SA) lets you patch the operating systems onmanaged servers in your
environment, such as Windows, HP-UX, Solaris, and Unix. Using the SA Client, you can create patch
policies and software policies that ensure standardization and compliance across your enterprise.

This section describes how to create andmodify patch policies and software policies, attach them to
your managed servers, remediate the servers to install and uninstall patches, and perform routine
audits that identify compliance status.

See the following topics:

l "Quick start to patchmanagement" below
l "Patchmanagement forWindows " on the next page
l "Patchmanagement for HP-UX" on page 96
l "Patchmanagement for Solaris " on page 114
l "Patchmanagement for Solaris 11 " on page 160
l "Patchmanagement for Ubuntu " on page 172
l "Patchmanagement for Unix " on page 214
l "Patchmanagement for Oracle Enterprise Linux " on page 271
l "Patchmanagement for SUSE Linux Enterprise" on page 294

Quick start to patch management
This quick start is an overview of how to download, install, andmaintain patches on SA managed
servers in your IT environment. This section identifies the steps required to set up andmanage patches
for all supported operating systems.

The following figure shows the general workflow for downloading patches, testing them, adding them to
SA policies, attaching policies to servers, attaching servers to policies, remediating servers to install
patches, running compliance scans to determine which servers are out of compliance, and remediating
servers to bring them back into compliance. SA policies are either patch policies or software policies,
and are used according to the operating system you are patching.

Patch management workflow
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For detailed information about SA patchmanagement for a certain operating system, see the following
sections:

l "Patchmanagement forWindows " below
l "Patchmanagement for HP-UX" on page 96
l "Patchmanagement for Solaris " on page 114
l "Patchmanagement for Solaris 11 " on page 160
l "Patchmanagement for Ubuntu " on page 172
l "Patchmanagement for Unix " on page 214
l "Patchmanagement for Red Hat Enterprise Linux" on page 241
l "Patchmanagement for Oracle Enterprise Linux " on page 271
l "Patchmanagement for SUSE Linux Enterprise" on page 294

Patch management for Windows
In Server Automation (SA), patchmanagement forWindows enables you to identify, install, and
removeMicrosoft® Windows patches, andmaintain a high level of security across managed servers in
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your organization. You can identify and install patches that protect against security vulnerabilities for
the SA-supportedManaged Server platforms.

Note:
See the SA Support and Compatibility Matrix for the list of SA-supportedManaged Server
platforms for your version of SA.

SA automates the key aspects of patchmanagement, while offering a fine degree of control over how
and under what conditions patches are installed. By automating the patching process, patch
management can reduce the amount of downtime required for patching. SA also allows you to schedule
patch activity, so that patching occurs during off-peak hours.

BecauseWindows patches are often released to address serious security threats, an organization
must be able to roll out patches quickly, before systems are compromised. However, at the same time,
patches themselves can cause serious problems, from performance degradation to server failures.

While patchmanagement allows you to react quickly to newly discovered threats, it also provides
support for strict testing and standardization of patch installation. And, if patches cause problems, even
after being tested and approved, Windows patching also allows you to uninstall the patches in a safe
and standardized way.

This documentation contains information about how to install Windows patches using patch policies
and how to uninstall patches using a sequence of tasks. It also contains information about running
patch compliance scans and generating patch policy compliance reports.

SA integration
When a server is managed by Server Automation, the SA Agent installed on the server registers the
server’s configuration, including its installed patches, with SA. The SA Agent repeats this registration
every 24 hours. This information is immediately recorded in theModel Repository, such as data about
the operating system version, hardware type, and installed software and patches. When you first
provision a server with SA, the same data is immediately recorded.

When a new patch is issued, you can use the SA Client to immediately identify which servers require
patching. SA provides a Software Repository where you upload patches and other software to. Using
the SA Client, you access this software to install patches on the appropriate servers.

Best Practice: After a server is brought under SA management, you should install all Windows
patches by using SAWindows patchmanagement. If you install a patchmanually, SA does not have
data about that patch until the next software registration. If you install a patchmanually, it can take as
long as 24 hours until data about that server in theModel Repository is up-to-date. However, when you
install patches using SAWindows patchmanagement, the Agent immediately updates the information
about the server in theModel Repository.

Note:
You cannot use Server Automation to uninstall a patch that was not installed by using SA
Windows PatchManagement.

Features
SA automates Windows patching by providing the following features and capabilities:
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l A central repository where patches are stored and organized in their native formats
l A database that stores information about every patch that has been applied
l Customized scripts that can be run before and after a patch is installed
l Advanced search abilities that identify servers that require patching
l Auditing abilities for tracking the deployment of important patches
l Multibinary patch support that enables you to install Windows multibinary patches
l All Windows product support for patching any Windows products or operating system
These features and capabilities enable you to browse patches by a certain operating system, schedule
patch downloads and installations, set up email notifications, preview a patch installation, use policies
and remediation to install patches, and export patch information to a reusable file format.

Types of patch browsing

The SA Client interface organizes Windows patches by operating systems and displays detailed
vendor security information about each patch, such as Microsoft Security Bulletins. You can browse
patches by the dateMicrosoft released the patch, by the severity level, Security Bulletin ID, QNumber,
and so on. You can also browse all patches that are installed on a server, and view and edit patch
metadata.

Scheduling and notifications

In the SA Client, you can separately schedule when you want patches to be imported fromMicrosoft
into Server Automation, either by a schedule or on demand, and when you want these patches to be
downloaded tomanaged servers.

Best Practice: Schedule patch installations for a day and time that minimize disruption to your
business operation.

You can also set up email notifications that alert you when the download and installation operations
completed, succeeded, or failed. When you schedule a patch installation, you can also specify reboot
preferences to adopt, override, postpone, or suppress the vendor’s reboot options.

Patch policies and exceptions

To provide flexibility in how you identify and distribute patches onmanaged servers or groups of
servers, Windows patching allows you to create patch policies that define groups of patches you need
to install.

By creating a patch policy and attaching it to a server or a group of servers, you can effectively manage
which patches get installed where in your organization. If you want to include or exclude a patch from a
patch installation, patchmanagement allows you to deviate from a patch policy by specifying that a
certain patch is a patch policy exception.

An additional patch is one that is not already specified in the patch policy and is one that you want to
include in (add to) the patch installation. A patch that you want to exclude from a patch installation is
one that is already specified in a patch policy and is identified in the patch policy exception as one you
do not want installed.
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Best Practice: In cases where it is already known that a certainWindows patchmay cause a server or
application tomalfunction, you should create a patch policy exception to exclude it from being installed
on that server or on all servers that have that application.

Patch installation preview

While PatchManagement allows you to react quickly to newly discovered security vulnerabilities, it
also provides support for strict testing and standardization of patch installation.

After you have identified patches to install, PatchManagement allows you to simulate (preview) the
installation before you actually install a patch. Use the preview process to identify whether the servers
that you selected for the patch installation already have that patch installed. In some cases, a server
could already have a patch installed if a system administrator hadmanually installed it.

The preview process provides an up-to-date report of the patch state of servers. The preview process
reports on patch dependency and supersedence information, such as patches that require certain
Windows products, and patches that supersede other patches or are superseded by other patches.

Patch uninstallation preview

Patchmanagement also provides a solution for remediating servers that are not operating properly due
to installed patches. If installed patches cause problems, even after being tested and approved,
Windows patching allows you to uninstall patches in a safe and standardized way. You can specify
uninstall options that control server reboots and the execution of uninstall commands, and pre-uninstall
and post-uninstall scripts. Similar to previewing a patch installation, you can also preview a patch
uninstallation.

Exporting patch data

To help you track the patch state of servers or groups of servers, PatchManagement allows you to
export this information. This information can be exported in a comma-separated value (.csv) file and
includes details about when a patch was last detected as being installed, when a patch was installed
by Server Automation, the patch compliance level, what patch policy exceptions exist, and so on. You
can then import this information into a spreadsheet or database to perform a variety of patch analysis
tasks.

Support for Windows patch testing and installation
standardization
Server Automationminimizes the risks of rolling out patches. When a patch is initially imported into SA,
its status is marked as Limited and only administrators with the required permissions can install it.

The patch administrator then defines patch installation and uninstallation options and tests the patch.
Only after the patch is tested and the patch administrator marks it as available for use (Available) can
other administrators install the patch.

In Server Automation, Windows PatchManagement allows you to standardize the way patches are
installed and uninstalled, thereby preventing ad-hoc installation procedures. Patch administrators
standardize patch installation by providing pre-install and post-install scripts, install and uninstall flags,
reboot instructions, and error handling options.
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Windows patch database conflict report
After importing yourWindows patch database, check whether there are any duplicate patches in your
patch library. Depending on your selected patchingmode, SA reports import results under:

l Administration > Patch Settings > Patch Database > Last Import Summarywhenworking in
Offline Catalog patchingmode.

l Administration > Patch Settings > Patch Database > Last Metadata Import and Import
SummarywhenworkingWSUS patchingmode.

After performing a patch import, SA updates these fields to reflect the state of the imported database. If
these fields are still blank after running an import, the import might be taking a long time to finish
updating the patch library or there is a rendering delay. Clear the SA Client cache from Tools >
Options > Reload Cache.

Field value Description

Successful The import operation completed.

Warning: <number> duplicates
found.

There is a conflict in the patch database due to duplicate
patches.

Remove the duplicates then run a new compliance
scan/remediation job.

Supported technologies for patch management
In Server Automation, Windows patchmanagement consolidates many tools that allow you to perform
server patching using a single interface.

The following patchmanagement and installation tools are used for supportedWindows operating
systems:

l msiexec.exe - Installs and uninstalls MSI packages.
l pkgmgr.exe - Installs and uninstalls CAB patches.
l unzip.exe - Extracts info-zip compatible zip archives.
l Windows Update Agent (WUA) - Enables access to theMicrosoft framework for patch installations
and updates.

l WSUS Web service - Enables communication with theWindows Server Update Services in
WSUS patchingmode.

Roles for Windows patch management
Server Automation provides support for rigorous changemanagement by assigning the functions of
patchmanagement to several types of users in an organization. These users include a policy setter, a
patch administrator, and a system administrator.
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Note:
These responsibilities are controlled by assigning permissions for managing patches in SA. To
obtain these permissions, contact your SA Administrator. See the SA Administration Guide.

l Policy setter: The policy setter is amember of a security standards group that reviews patch
releases and identifies the vendor patches that will be included in the organization’s patch policies. A
policy setter is responsible for reviewing the latest security threats and the patches that vendors
have released to address these problems. A policy setter is generally known as an expert in the
operating systems and applications that they manage, and is able to assess the necessity of
applying patches issued by vendors. A policy setter is also able to diagnose common problems that
arise after patches are installed, allowing for a thorough test of the patch application process.

l Patch administrator: The patch administrator has the authority to import, test, and edit patch
options. The patch administrator is often referred to as the security administrator in an organization.
A patch administrator is granted specific permissions to import patches into Server Automation to
test the patches and thenmark them as available for use. Basic users can import patches, but they
cannot install them ormark them as available. Patch administrators are also able to edit patch
options (such as installation scripts) through patchmanagement. Other types of users are not
allowed to import or edit patches. Typically, a patch administrator imports theMicrosoft patch
database and tests patches on non-production reference hardware. After testing the patches and
determining that the patches are safe to apply to production systems, a patch administrator marks
the patches available in the Library and then advises the system administrators that they must apply
the approved patches.

l System administrator: The system administrator installs patches (that have been approved for
use) uniformly and automatically, according to the options that the patch administrator specifies.
The system administrator is an SA user who is responsible for the day-to-day maintenance of the
servers in a deployment. These users are not required to have the same level of expertise in low-
level system details as the policy setter and patch administrator. Because the patch administrator
has set up the patch installation, the system administrator can attach policies to servers, set an
exception for a patch, and install patches on a large number of managed servers. They are
responsible for searching for servers that require the approved patch, installing the patches, and
verifying that the patches were successfully installed. The system administrator can import patches
but cannot install a patch until the patch administrator has marked it as available. The system
administrator can also uninstall patches.

Note:
Server Automation also provides predefined patch user groups for patch deployers and patch
policy setters. See "Predefined patch user groups" below.

Predefined patch user groups

During an SA installation or upgrade, certain predefined user groups are created, such as patch
deployers and patch policy setters.

l Patch deployers—Access to install patches.
l Patch policy setters—Access to set patching policy.
l Software policy setters—Access to set software policy. (For Ubuntu patch policy management,
you need both Patch Policy Setters and Software Policy Setters user groups.)
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Next to the predefined action permissions, youmust grant the necessary resource permissions to
these user groups. Use of these predefined user groups is optional. You canmodify the permissions of
the predefined user groups and you can also delete or copy these groups to create new groups.
Changes to or deletions of these predefined user groups are not affected by SA upgrades. See the SA
User Guide for more information.

Requirements for managed servers
Themanaged servers that will be patched have the following requirements:

l Microsoft Core XMLServices (MSXML) or Internet Explorer (IE) must be installed on themanaged
servers. The versions of MSXML and IE that you install must support theMicrosoft XML parser and
related DLL files.

l Windows Installer must be installed onmanaged servers that are runningWindows servers. This
installer is available on theMicrosoft support site, such as:
http://support.microsoft.com/kb/893803/

l On themanaged servers, theWindows Update servicemust be set to either Automatic or Manual.
To set aWindows service, from theWindows Control Panel select Administration Tools >
Services.

l ForWindows Servers, theAdd and Remove Programs dialoguemust be closed when you run
Windows patchmanagement tasks.

l To install and uninstall patches, and to perform remediation, a supported version of the SA Agent
must installed.

l Managed servers must be set to a supported language for the SA Agent that is installed on the
server.
To set the language, on themanaged server, open the Control Panel, open theRegional and
Language Optionswindow, select theRegional Options tab, and then select a language from the
drop-down list in theStandards and formats section. Click OK to save your changes.

Note: See the SA Support and Compatibility Matrix for more information about platform version
support and compatibility.

Supported Windows versions
See the SA Support and Compatibility Matrix for the list of SA-supportedManaged Server platforms for
your version of SA.

Note:
In order to apply patches toManaged Servers runningWindows Server 2003 RTM, youmust first
ensure that theMicrosoft updateMS04-011 (or a subsequent update) has been applied to those
servers.

Supported products in theMicrosoft patch database
SAWindows Patching supports all Microsoft products, which includes operating systems (OS) and
other non-OS products.
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Previously, SA Windows Patching only supported OS patches. Most product-specific patches, such
as those for MS Office 2010 or MSWord, were not supported. Windows product patches were present
in theMicrosoft Offline Catalog file (wsusscn2.cab), but they were not uploaded to the SA database
when you imported the. cab file.

Now, when you import theMicrosoft Offline Catalog file or you connect to aWSUS server,
SA retrieves all product-specific patches according to your specified patch products and locales.

Requirements

Product-specific patches can only be installed on servers that have the product installed.

The product installation and upgrade scripts make any necessary configuration adjustments. No
additional configuration steps on the core are required.

About unsupported products

Windows Patch Import will only import patches for operating systems (OS) that SA supports. Patches
for any unsupported OS will be excluded at import time. This exclusion applies to any unsupported
Windows OS as well as any OS-specific product for any unsupportedWindows OS. For information on
the SA-supported operating systems, see the SA Support and Compatibility Matrix for your version of
SA.

Note:
TheMicrosoft patch databasemay include patches forWindows OS or OS-specific products that
SA does not support. These unsupported patches may still appear underAdministration > Patch
Settings > Patch Products. However, SA excludes unsupportedWindows patches from the
patch import, even if they are selected in the product selection list.

Identifying product names for missing recommended patches

If the Vendor Recommended Patch Policy (VRPP) recommends any patches for a server that are not
included in the imported patches, the compliance scan will show thesemissing patches in gray. To
determine theMS product necessary to import thesemissing patches, a KB#-to-Product Mapping
script is available. Contact SA Customer Support for details.

About the SA Client patch library
The SA Client Library provides flexibility in searching for and displayingMicrosoft patches by bulletin
ID, release date, severity level, operating system, and so on.

In the content pane, a dimmed patch icon indicates that the patch has not been uploaded to the Library.
Use the column selector to control the columns of patchmetadata data that you want to display.

TheWindows folder of the SA Client Library shows patch information pulled from your Microsoft patch
database. You can access theMicrosoft patch database from theMicrosoft Offline Catalog or from a
WSUS server. This view shows the parsed patch data fromMicrosoft at the time of your most recent
update.

Windows patches in the SA Client Library
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Windows server patch management support
SAWindows Server patchmanagement support is compatible with amixed-versionmultimaster mesh
(where both patched and unpatched cores co-exist). Windows platform patchmanagement includes
the following supported functions:

l Windows Server patches appear under Library after the patch database is imported.
l Select the specific Windows Server version underAdministration > Windows Patch Downloads
> Patch Products to specify whether to import Windows Server patchmetadata.
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l TomanageWindows Server patches you can:
l Invoke a patch browser to edit patch properties, descriptions, and reboot/install/uninstall flags.

l See the following patch views when aWindows Server server is selected.
o Patches Needed
o Patches Recommended By Vendor
o Patches with Policies or Exceptions
o Patches Installed
o Patches with Exceptions
o All Patches

l You can import patch binaries from the vendor using the SA Client or from a file.
l You can attachWindows Server patch policies to servers and server groups.
l You can define patch policy exceptions forWindows Server patches on servers and server groups.

SA patching modes

To patch yourWindows managed servers with applicable Microsoft updates, SA requires access to the
Microsoft patching database. You can access this database either by importingMicrosoft's offline
catalog of patches or by connecting SA to aWSUS server in your network.

Depending on your available network infrastructure, enable one of the available SA patchingmodes:

l Offline Catalog - imports the wsusscn2.cab file from the SA Client or from the populate-opsware-
update-library script. The wsusscn2.file contains only security updates. HP can providemissing
non-security updates via HPLN.

l WSUS - connects to aWSUS server to retrieveMicrosoft patches from a customWindows
patching repository. Unlike theOffline Catalogmode,WSUS patching requires access only to the
WSUS server on your network from where it can retrieve both security and non-security updates.

The populate-opsware-update-library script

The populate-opsware-update-library script automates the download of theMicrosoft's offline
catalog of patches and the import of these patches into SA. The populate-opsware-update-library
downloads the wsusscn2.cab file and imports its contents (hotfixes, service packs, and update rollups)
into SA.

The populate-opsware-update-library script is specific toMicrosoft Offline Catalog
patching and does not run inWSUS patchingmode.

For more information about running the script and the available options, see "Downloading the
Microsoft Offline patch catalog from the command line " on page 33

Policies and exceptions for Windows server patches

SA provides a recommended patch policy forWindows Servers. You can also define additional custom
patch policies in the sameway as described in Application Deployment in the SA Developer Guide.
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Remediate and ad-hoc install/uninstall

You can remediateWindows Server patch policies and perform ad-hoc Windows Server patch
installations and uninstallations. Windows Server patches can be remediated in software policies and
ad-hoc installations using install/uninstall software. However, software compliance does not account
for applicability.

Patch compliance

You can perform patch compliance scans onWindows Server servers to determine compliance relative
to attached policies and exceptions. Patch compliance is based on patch applicability on the selected
server(s).

The Compliance view in the SA Client displays compliance details forWindows Server servers.

Known limitations

l The Install/Uninstall Patch window typically allows you to specify install/uninstall flags when a
patch is selected for installation/uninstallation. The patchmust be in an .EXE file format. Microsoft
delivers Windows Server patches in both .EXE and .CAB format. In SA, if a patch is in .CAB file
format, you cannot specify install/uninstall flags in the Patch, Install Patch, and/or Uninstall Patch
windows because command-line arguments are not supported for .CAB format patches.

l If you add install or uninstall flags using theWindows patch browser, any flags that SA would
otherwise have used are overwritten.
Therefore, if youmust use additional flags in aWindows patch browser, youmust specify the -q flag
with your additional flags. For example, if you want to log the install/uninstall process and do not
want to override the default flags, specify the following:

/log:c:\mylog.txt /q /z

Note:
Overriding the -q flag (if the patch supports -q) will cause the patch installation to fail. This type of
installation can take as long as one hour to time out.

Patch Settings window
This window enables you to configure the following settings for patchingWindows and Ubuntu servers:

l Patchmetadata and binaries import
l SupportedMicrosoft products and locales
l Ubuntu patchingmethods for your environment

Windows Patch Settings

Setting Description

Patch Availability WhenWindows patches are imported into
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Server Automation (SA), they are
assigned a default value for Availability.
To specify the default value, select either
Available or Limited.

The populate-opsware-update-library
script that automatically imports patches
inOffline Catalogmode can override the
selection in this window.

Patching Mode Depending on your available network
infrastructure, enable one of the available
SA patchingmodes:

l Offline Catalog - imports the
wsusscn2.cab file from the SA Client
or from the populate-opsware-update-
library script. The wsusscn2.file
contains only security updates. HP can
providemissing non-security updates
via HPLN.

l WSUS - connects to aWSUS server to
retrieveMicrosoft patches from a
customWindows patching repository.
Unlike theOffline Catalogmode,
WSUS patching requires access only
to theWSUS server on your network
from where it can retrieve both security
and non-security updates.

Windows Patch Downloads This section contains information about
theWindows patch database used in SA:

l Patch Database:Depending on your
network infrastructure, you can get the
Microsoft patching database into SA
either by importing theWindows
patching catalog (wsusscn2.cab file) or
by connecting to aWSUS server on
your network.

l Patch Products: This section lists the
Microsoft Windows products affected
by the patches tracked by SA.

l Patch Locales: This section lists the
patch languages managed by SA.

InWSUS mode, filtering by patch product
and locale is done on theWSUS server
side. SA only displays the read-only list of
products and locales selected by the
WSUS administrator.
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Windows Patch Utilities InOffline Catalog patchingmode, SA
requires theWindows Patch utilities to
deploy the latest version of theMicrosoft
Update agent onto themanaged servers.
Windows Update Agent (WUA) scans
computers for security updates without
connecting toWindows Server Update
Services (WSUS) server.

Ubuntu Patch Settings

Setting Description

Proxy Define the Ubuntu proxy configuration.

Repositories Define the Ubuntu repositories to access.

Policy Settings Configure the Ubuntu Patch Policy
Settings.

Scanner Options Specify the Ubuntu scanner behavior.

General Specify the Ubuntu log settings.

Patch management process
To deploy Windows patches, import the required patches, test them, update or create new policies and
specify install options. The following steps detail the patchmanagement workflow andmain task
involved:

l Step 1 - Configure patch settings
l Step 2 - Configure patch policies
l Step 3 - Scan servers for compliance
l Step 4 - Import applicable binaries
l Step 5 - Install patches/Remediate servers
l Step 6 - Check for patch updates

Configure patch settings
To patch yourWindows managed servers, SA requires the following resources:

l Access to theMicrosoft database. This tells SA where to look for patches and associatedmetadata.
l The list of products and locales for which you want to track patches. This ensures SA imports only
relevant patches for your applicable Microsoft products.

l Themetadata for the selected patch products and locales. This contains information that SA
requires to install Microsoft patches on your managed servers.
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l The binary files for the patches required to remediate non-compliant servers. These contain the
Microsoft update files themselves.

Access the Microsoft patch database

TheMicrosoft patch database contains information about released patches and how they should be
applied. SA requires access to this database in order to get the appropriate resources for patching your
managedWindows servers.

Before PatchManagement can install a patch on amanaged server, the patchmust be downloaded
from theMicrosoft web site and imported into the Software Repository.

Depending on your network infrastructure, you can get theMicrosoft patching database into SA:

l by importing theWindows patching catalog (wsusscn2.cab file) from theMicrosoft website.
TheMicrosoft offline catalog only contains security updates. SA provides missing and non-security
updates as patch supplements via HPLN.

l by connecting to aWSUS server on your network.
WSUS synchronizes with Microsoft Update to regularly download both security and non-security
updates to a central WSUS repository on your network. Access theMicrosoft patch database via
WSUS if you are working in a tightly secured environment, where you cannot connect to Microsoft
and HPLN.

Once every 24 hours, the SA Agent on aWindows server compares the server’s current state against
theMicrosoft patch database that has been imported into SA by the patch administrator. The Agent
reports the results of that comparison and then stores the data in theModel Repository. When you
request a compliance scan, it can take several minutes. When you look up compliance for a server, the
status information is derived from theModel Repository as well.

The Vendor patch key is currently available for Ubuntu andWindows database views. The vendor
patch key is a vendor-specific value that allows users to tie a unit (patch) in SA back to the specific
patch supplied by the vendor.

ImportingWindows patch database from theMS offline catalog

SA can retrieveWindows updates from wsusscn2.cab, the offline version of theWindows patch
database. This cabinet file is available on theMicrosoft website and contains security-related patch
metadata published by Microsoft.

Microsoft updates this file every second Tuesday of themonth to include new or revisedWindows
security patches. To keep your managed servers up-to-date, make sure to reimport this file into
SA monthly, and to connect to HPLN for downloading non-security Microsoft updates.

Alternatively, if you cannot connect to HPLN or to theMicrosoft website, you can get all Windows
updates from aWSUS server on your network. For more information, see "Importing theWindows
patch database fromWSUS" on page 37.

To import the offline catalog of Windows patches into SA:

1. Go to theAdministration > Patch Settings.
2. In thePatch Downloads section, enable theMicrosoft Offline Catalog patchingmode.
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3. Select thePatch Products tab and click Edit to add the products for which you want SA to import
patches and patchmetadata.

4. Select thePatch Locales tab and click Edit to add the languages for which you want SA to
import patches and patchmetadata. During patch installation, SA matches the locale of the patch
with the locale of eachmanaged server.

5. Select thePatch Database tab to import patchmetadata for your selected patch products and
locales. You can choose to either:
l Import from File - to import the patchmetadata from the wsusscn2.cab file available on your
local machine.
Before you can import theMicrosoft patch database from a local file, youmust configure your
browser to not use the web proxy when communicating with your SA core. See "Configuring
your browser for importing theMS offline catalog " below

l Import from Vendor - to import the patchmetadata directly from theMicrosoft website. By
default, this points to the URLwhere the wsusscn2.cab is available on theMicrosoft website.

6. Click Import. SA displays the Importing Microsoft Patch Database showing the import
progress and an option to run the import in the background.

7. Click Closewhen the patchmetadata import is complete.

Prerequisites for importing theMS offline catalog

If you are working in theOffline Catalog patchingmode, check the following prerequisites before
importing the wsusscn2.cab file fromMicrosoft:

l "Configuring your browser for importing theMS offline catalog " below
l "ImportingWindows patch utilities for the offline patch catalog" on the next page
l Make sure that Windows Installer 3.1, Windows Update Agent andMSXML 3+ are installed on your
Windows managed servers. MSXML is a general requirement for all Windows managed servers.

l TheWindows Update service on your managed servers is not be disabled but is set to never check
for updates.

Configuring your browser for importing theMS offline catalog

If you are working inOffline Catalog patchingmode and you want to import the wsusscn2.cab file from
your local network, configure your browser to not use the web proxy when communicating with your SA
core.

If you are importing the offline catalog using the Import from Vendor option, make sure to use a proxy
to be able to connect to Microsoft for accessing theWindows patch database.

To configure your browser for importing theWindows offline catalog file stored locally:

1. In the Log in to Server Automation Clientwindow, click More to expand the window.
2. Click Advanced Settings to open theAdvanced Settingswindow.
3. In theProxies section, if theUse Browser is selected, configure your browser to not use the web

proxy when communicating with your SA core.
Or

4. In theProxies section, ifManual is selected (whichmeans that the proxy is set manually), enter
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the core's IP or hostname in theNo Proxy Hosts text box. This will ensure that the SA Client
communicates directly with the SA core.

ImportingWindows patch utilities for theoffline patch catalog

Windows Patch utilities deploys the latest version of theMicrosoft Update agent onto themanaged
servers. SA uses Windows Update Agent (WUA) to scan computers for security updates without
connecting toWindows Server Update Services (WSUS) server.

Import theWindows Patch utilities only if you are working inOffline Catalog patchingmode. Windows
Update Agent (WUA) automatically updates itself when it is connected to theWSUS server.

l If you do not plan to use SA tomanage yourWindows servers, you can optionally choose not to
install these files and still successfully complete the installation process. However, if these
files are not installed, no operations against Windows servers should be performed. These files
are required for many Windows-based operations other thanWindows patching.

l During an SA core installation, if you set the windows_util_loc parameter to none, the
Windows utilities will not be imported during a core installation and operations onWindows
servers will not be supported. See the SA Install Guide for more information.

l Before you can import theWindows utilities, youmust configure your browser to not use the
web proxy when communicating with your SA core. See "Prerequisites for importing the
MS offline catalog " on the previous page for instructions.

After you install an SA core, you can import (download) the followingWindows utilities from the vendor:

l WindowsUpdateAgent-ia64.exe
l WindowsUpdateAgent-x64.exe
l WindowsUpdateAgent-x86.exe
To update and import Windows patch utilities:

1. In the navigation pane, select Administration > Patch Settings.
2. ThePatch Settingswindow appears and SA checks forWindows patch utility updates. The

Latest column in theWindows Patch Utilities section of the window indicates that SA is
checking for updates.
l The Latest column displays the latest version that is available from the vendor.

l TheVersion column displays the version of the utility that is already in the SA database.

3. If you are connected to the internet, the Latest column is updated to the latest version that is
available from the vendor.
a. Compare the values in the Latest column to theVersion column.
b. If the Version in the SA database is lower than the Latest version that is available from the

vendor your utilities need to be updated.
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c. Click Import from Vendor to get the latest utilities.
d. In the Import from Vendorwindow, select one or more utilities and then click Import.

The Importing Utility Updatewindow displays the status of the process.
o If the job complete, the Status columnwill display the success icon .
o If the job fails, the Status columnwill display the error icon . Double-click the error icon

to display the error message.
e. After the process completes, click Close.

4. If you are not connected to the internet, the Unable to Access wuredist.cabwindow appears
providing an option to import theWindows Update Agent (wuredist.cab) from a local file.

a. Click Import.
b. In the Import Patch Utility dialog, find and select the wuredist.cab file locally.
c. Click Import to import the utility update.
d. After the import is complete, the Latest column shows which utilities have updates available.

1. Manually importing theWindows patching utilities

If you are working inMicrosoft Offline Catalog patchingmode and you did not install the
Windows patchmanagement files during core installation, get the followingMicrosoft files from a
machine with internet access and add them to the core.
If you need to work in a tightly secured environment, consider switching toWSUS patchingmode
as this enables you to get Windows patches from aWSUS server on your network.

Note: The links to the followingMicrosoft files are provided as a convenience. However,
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Microsoft Corporationmay change the links after the release of this document. Therefore, we
cannot guarantee that these links will be valid when you use them and youmay need to
search theMicrosoft Support website to find the correct files.

a. wsusscn2.cab
The wsusscn2.cab file contains theMicrosoft patch database.

Download wsusscn2.cab from:
http://go.microsoft.com/fwlink/?LinkId=76054

b. WindowsUpdateAgent30-x86.exe
The WindowsUpdateAgent30-x86.exe file is required when SA scans x86-basedmanaged
servers to determine whichWindows patches/hotfixes are installed.
i. Download the package containingWindowsUpdateAgent30-x86.exe from:

http://go.microsoft.com/fwlink/?LinkID=100334
ii. After downloading, rename the file "WindowsUpdateAgent-x86.exe".

c. WindowsUpdateAgent30-x64.exe
The WindowsUpdateAgent30-x64.exe file is required when SA scans x64-basedmanaged
servers to determine whichWindows patches/hotfixes are installed.
i. Download the package containingWindowsUpdateAgent30-x64.exe from:

http://go.microsoft.com/fwlink/?LinkID=100335
ii. After downloading, rename the file "WindowsUpdateAgent-x64.exe".

d. WindowsUpdateAgent30-ia64.exe
The WindowsUpdateAgent30-ia64.exe file is required when SA scans Itanium x64-based
managed servers to determine whichWindows patches/hotfixes are installed.
i. Download the package containingWindowsUpdateAgent30-ia64.exe from:

http://go.microsoft.com/fwlink/?LinkID=100336
ii. After downloading, rename the file "WindowsUpdateAgent-ia64.exe".

Retrieving Microsoft patch supplements fromHPLN

InWSUS patchingmode, SA retrieves all required patches directly from aWSUS Server in your
network. However, if you are working inMicrosoft Offline Catalog patchingmode, SA retrieves
information about Microsoft patches from the wsusscn2.cab file. This file contains patches and
associatedmetadata only for security Microsoft updates. SA provides non-security patches via
the HP Live Network.
When HP updates this supplemental data, you can configure the HP Live Network to
automatically upload it to the SA Microsoft patch database.

You cannot download patches from HPLN inWSUS patchingmode.

To obtain the supplementary data file when it is updated and upload it into the SA Library:
a. Obtain an HP Passport ID from:

http://h20229.www2.hp.com/passport-registration.html
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b. Log in to the HP Live Network portal using your HP Passport credentials:
https://hpln.hpe.com/group/hp-live-network-connector

c. The HP Live Network connector (LNc) is installed on the core server where the SA Software
Repository component is installed.
You can download the HP Live Network Connector User Guide from the Live Network
Connector community on the HP Live Network at:
https://hpln.hpe.com/group/hp-live-network-connector
Click theResources tab and open theDocumentation folder.

d. On the system where the LNc is installed, run the following commands to enable theMicrosoft
patching service:

live-network-connector write-config --add --setting=content.ms_patch_supp=1

and

live-network-connector write-config --setting=sas.force_win_patch_import=1 -
-add

e. (Optional) To disable theMicrosoft patching service, run the same commandwith the value
set to 0:

live-network-connector write-config --setting=content.ms_patch_supp=0

and

live-network-connector write-config --setting=sas.force_win_patch_import=0

Alternatively, you canmanually download the supplemental patch data file from the HP Live
Network and upload it to the SA database. See "Manually downloading theMicrosoft patch
supplements from HPLN" below.

Manually downloading theMicrosoft patch supplements fromHPLN

This section describes how tomanually download the supplementary Microsoft patch data file from the
HP Live Network and upload it into the SA patch database.

This is only required if you are working inOffline Catalog patchingmode as the wsusscn2.cab file
contains updates for security issues. InWSUS patchingmode, WSUS synchronizes with Microsoft
Update to regularly download both security and non-security updates to a central WSUS repository on
your network.

We recommend that you set up the LNc to automatically upload this file whenever it changes as
described in "RetrievingMicrosoft patch supplements from HPLN" on the previous page. However, if
you download the file manually, you should regularly check for updates and install them into the SA
patch database as described here.

To obtain the supplementary data file:

1. Obtain an HP Passport ID from:
http://h20229.www2.hp.com/passport-registration.html

2. Log in to the HP Live Network portal using your HP Passport credentials:
https://hpln.hpe.com/group/hp-live-network-connector

3. The HP Live Network connector (LNc) is installed on the core server where the SA Software
Repository component is installed.
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You can download the HP Live Network Connector User Guide from the Live Network Connector
community on the HP Live Network at:
https://hpln.hpe.com/group/hp-live-network-connector
Click the Resources tab and open the Documentation folder.

4. Click Content Catalog from the HP Live Network menu and search for “MS Patch Supplement for
Server Automation” under the Server Automation product.

5. Download the latest Microsoft Patch Supplement, named latest_OPSWWinPatchDB.zip, and
place it in the Core slice server directory:

/opt/opsware/mm_wordbot/util

6. Import theMicrosoft Patch Supplement metadata via the following command:

./import_win_patch_bundle --bundle latest_OPSWWinPatchDB.zip

7. Since HP updates theMicrosoft patch supplementary data file, it is recommended that you
periodically check this file for updates and when this file changes, follow these steps again to
download the latest supplementary patch information into your SA patch database.

Downloading theMicrosoft Offline patch catalog from the command line

The populate-opsware-update-library shell script downloads the OfflineMicrosoft Catalog from
theMicrosoft site and imports theWindows database and patches into Server Automation.

l This script is specific toMicrosoft Offline Catalog patching and does not run inWSUS patching
mode.

l Do not run concurrent instances of the script.
Prerequisites

Before running the command line script, ensure that:

l your patchingmode in SA Client > Administration > Patch Settings > Patch Downloads is set to
Microsoft Offline Catalog.

l your SA Core has access to the internet or to a web proxy.
l the patchmetadata is available in the currently loadedMicrosoft patch database. SA maps patch
binaries to available patchmetadata during patch import. For more information, see "Import
metadata forWindows patches" on page 51.

Note: themetadata import method has the same capabilities as this shell script.

Script vs. SA Client imports
You can import patches from theMicrosoft Offline Catalog either from the SA Client using this script.
The command line script is better when you want to download all the available patches to the system. If
you updated your patches monthly, for example, you wouldmost likely use the command line tool, and
save the arguments.

For information about importing the offlineMicrosoft catalog via the SA Client, see "ImportingWindows
patch utilities for the offline patch catalog" on page 29

Running the script

The populate-opsware-update-library script is located in the following directory:

/opt/opsware/mm_wordbot/util/
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To run the script:

1. Log on to the Software Repository server as root.
2. Schedule the script to run periodically as a cron job on the Software Repository server. From the

SA Client, the patches imported with the script show up as automatically imported.
3. Run the populate-opsware-update-library script with --help parameter for a complete list of

available options.
Script Options
l This shell script sets the initial status of newly imported patches toAvailable or Limited.
l The script can also filter the patches imported according to operating system, such as specific
versions of Windows Servers. When you run this script, patches from all products that are selected
in thePatch Settings product list will be imported, unless they are specifically omitted by one of the
command-line options. See "Parameters for the populate-opsware-update-library script" below.

l This script provides options for omitting patches from certainWindows operating systems; but it
does not provide options for omitting non-OS products, such as Microsoft Office or Exchange.

Option Description

--spin
<hostname-or-
IP>

Hostname or IP address of the Data Access Engine (spin) host.
Default: spin

--theword
<hostname-or-
IP>

Hostname or IP address of the Software Repository (theword) host.
Default: theword

--cert_path
<file-path>

File specification of the cert file to be used for the spin connection.
Default:
/var/opt/opsware/crypto/wordbot/wordbot.srv

--ca_path
<file-path>

File specification of CA file to be used for Spin connection.
Default value:
/var/opt/opsware/crypto/wordbot/opsware-ca.crt

--verbose Display copious output.

--no_nt4 Do not process NT4 patches.

--no_w2k Do not process W2K patches.

--no_xp Do not process XP patches.

--no_w2k3 Do not process W2K3 patches.

--no_w2k3x64 Do not process W2K8 x64 patches.

--no_w2k8 Do not process W2K8 patches.

--no_w2k8x64 Do not process W2K8 x64 patches.

--no_ Do not process W2K8R2 x64 patches.

Parameters for the populate-opsware-update-library script
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Option Description

w2k8r2x64

--no_
w2k8r2ia64

Do not process W2K8R2 IA64 patches.

--no_
w2k12x64

Do not process W2K12 x64 patches.

--no_
w2k12r2x64

Do not process W2K12R2 x64 patches.

--no_w7x64 Do not process W7 x64 patches.

--no_w7 Do not process W7 patches.

--no_w81x64 Do not process W8.1 x64 patches.

--no_w10x64 Do not process W10 x64 patches.

--no_
w2k16x64

Do not process W16 x64 patches.

--wget_path
<file-path>

Usewget for the downloads vs built-in download support. File specification of the
wget utility.

--wget_http_
proxy
<server:port>

wget HTTP proxy server in format proxyserver:httpport. This option is ignored if
wget http proxy is configured in wget user startup file .wgetrc.

--wget_ftp_
proxy
<server:port>

wget FTP proxy server in format proxyserver:ftpport. This option is ignored if wget
ftp proxy is configured in wget user startup file .wgetrc.

--use_proxy_
url <url>

When downloading binaries, connect via this proxy URL. This option overrides the
proxy settings specified via the http_proxy environment variable.

--proxy_
userid
<userid>

Basic-auth userid to provide to proxy server. Another way of providing the proxy
userid is by setting the POP_OPSW_LIB_PROXY_USER environment variable.
This option overrides the proxy userid specified via the POP_OPSW_LIB_
PROXY_USER environment variable.

--proxy_
passwd
<passwd>

Basic-auth passwd to provide to proxy server. Another way of providing the proxy
password is by setting the POP_OPSW_LIB_PROXY_PASSWD environment
variable. This option overrides the proxy password specified via the POP_OPSW_
LIB_PROXY_PASSWD environment variable. Please note that specifying the
proxy password via this optionmakes the password visible to any user on the
process command line. To avoid this do not use this option and specify the
password via the POP_OPSW_LIB_PROXY_PASSWD environment variable.

--set_ Set availability status to Available when uploading patches.

Parameters for the populate-opsware-update-library script, continued
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Option Description

available

--set_limited Set availability status to Limited when uploading patches.

--no_hotfixes Do not upload hotfixes.

--no_
servicepacks

Do not upload service packs.

--no_
updaterollups

Do not upload updaterollups.

--no_
wsusscan_
upload

Do not upload theMBSA 2.1x patch database.

--wsusscan_
url_override
<url>

Download theMBSA 2.1x patch database from this URL.

--force_
msutil_upload

Force new Microsoft utilities to be fetched and uploaded This option is ignored if --
download_only is also specified.

--no_msutil_
upload

SkipMicrosoft utilites check and upload

--wua_x86_
url_override
<url

Download x86Windows Update Agent from this URL.

--wua_x64_
url_override
<url>

Download x64Windows Update Agent from this URL.

--wua_ia64_
url_override
<url>

Download ia64Windows Update Agent from this URL.

--update_all Refresh the patches already uploaded into Opsware SAS.

--download_
only <path>

Download files from the vendor's web site to the specified path, but do not upload
them into Opsware SAS.

--download_
only_if_not_
exists

If --download_only specified, only download patches that don't yet exist.

--upload_
from_update_
root <path>

Upload files from specified directory instead of from vendor's website. This option
is ignored if --download_only is also specified.

Parameters for the populate-opsware-update-library script, continued
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Option Description

--use_temp_
download_path
<path>

Download files to temporary download directory instead of a subdirectory under
/var/tmp.

--log_file
<path>

Log the output to the specific file.

--parallel_
uploads
<number>

Number of patch uploads to run in parallel. System specific default value will be
used.

--download_
retry
<number>

Number of times to retry the download of patches

--help Display this message.

Note that --set_limited and --set_available cannot both be set at the same
time.

./populate-opsware-update-library.pyc: version 3.2.0

This script has been developed and test-run on a word server, but should run on
any core server with word or spin crypto. No parsing of the cab is done in this
script.

Parameters for the populate-opsware-update-library script, continued

ExportingWindows patch utilities

If you are working inOffline Catalog patchingmode, you can export the followingWindows utilities
from Server Automation to your local file system:

l WindowsUpdateAgent-ia64.exe
l WindowsUpdateAgent-x64.exe
l WindowsUpdateAgent-x86.exe
To export aWindows patch utility:

1. In the navigation pane, select Administration>PatchSettings.
2. In theWindows Patch Utilities section, select one or more utilities.
3. Click Export Utility.
4. In theExport Patch Utilitywindow, specify a location in your file system.
5. Click Export.

Importing theWindows patch database fromWSUS

If you are working in an environment whereMicrosoft patches are downloaded centrally to aWindows
Server Update Services (WSUS) internal server, you can use yourWSUS repository as your SA patch
database. TheWSUS patch repository synchronizes regularly with Microsoft Update which ensures
that theWSUS patches you import into SA are always up-to-date.
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Unlike theOffline Catalog patchingmode, WSUS patching does not require access to theMicrosoft
website and to HPLN for importing patch updates. SA integrates withWSUS on your network to:

l pull security and non-security patches into your SA patch library.
l assess whichWindows updates are required for your SA managed servers.
l deploy applicable updates to SA servers.
When you import theWindows patch database, SA only imports the patchmetadata for the available
patches. After importing the patch database, run a compliance scan and import binaries only for the
patches required to remediate non-compliant servers.

To import theWindows patch database from aWSUS server:

Prerequisite: "Connecting SA to aWSUS server " on the next page before importing theWindows
patch database.

1. Go to theAdministration > Patch Settings.
2. In thePatch Downloads section, select theMicrosoftWSUS patchingmode.
3. On theGeneral page, specify the URL of theWSUSWeb service: http(s)://hostname/<your_

folder_name>/WsusREST. SA downloads patches to the SA core via theWSUS Web service
and distributes them to connectedmanaged servers, as required.

4. Select your preferredBinaries Import Mode to indicate which patch executables to import from
WSUS:
l Recommended - imports the list of Microsoft recommended patches.

l All - imports required patch executables for all patchmetadata retrieved fromWSUS.

5. Select thePatch Database tab and click:
l Import Metadata - to import patchmetadata for all patches filtered fromWSUS. By default,
SA imports metadata only for patches that theWSUS Administrator marks as Approved. To
import Declined andNot Approved patches as well, change the settings of theWSUS Web
service. This option runs the Import WSUS Metadata script on the core slice.

Note: SA uses patchmetadata during compliance scans to identify which servers require the
patches approved by theWSUS administrator.

l Import Binaries - to import binaries for the patches required to remediate servers reported as non-
compliant following a compliance scan. This runs the Import WSUS Package Binaries script on
the core slice.

6. On theRun Server Script wizard, click Next and specify any custom import options for the
script import steps.

7. Click Start Job then click Closewhen the import is complete.

Workflow diagram - ImportingWSUS patches into SA

The diagram below illustrates the detailed workflow for importing and deployingWindows patches to
SA managed servers.
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Connecting SA to aWSUS server

Before importing patch and patchmetadata fromWSUS, configure SA to communicate with your
WSUS server.

To connect SA to an upstreamWSUS server:

1. ConfigureWSUS to synchronize with Microsoft Update.
2. Approve/decline patches inWSUS to filter which patches are visible in SA.
3. Deploy theWSUS Web Service to set up the communication with the SA core. SA downloads all

patches and associatedmetadata to the SA core and then distributes them, as required, to the
managed servers that you connect toWSUS.
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4. "Connecting SA managed servers toWSUS" on page 44 tomake them visible for compliance
scans against WSUS patches.

Deploying theWSUSWeb service

SA communicates withWindows Server Update Services through aWeb service installed on the
WSUS server. TheWeb service sends the requested patches and patchmetadata to the SA core
which then distributes them to the appropriate SA managed severs.

WSUS Web service is deployed only in front of theWSUS upstream server visible to SA. All patches
and associatedmetadata are retrieved from this upstream server. TheWSUS administrator is
responsible for keeping any downstream servers synchronized with the upstream server.
Prerequisite: Before deploying theWSUSWeb service, install OpenSSL (on any other machine) if you
want to allow HTTPS requests.

To install theWSUS Web service on theWSUS upstream server and enable SA client connections:

1. Deploy theWeb Service into IIS

a. In the SA  Client, go to Library > By Folder > Opsware > Tools > Patching.
b. Right-click on archivedWeb service file, hpsa_wsus_ws_versionnumber.zip file and select

Export Software.
c. Unpack theWeb service ZIP file on themachine that holds theWSUS server, in a new folder

under C:\inetpub\wwwroot.
d. Click theWindows Start button, type IIS and open Internet Information Services.
e. Under theDefault Web Site, right-click on the folder you have created in step c and select

Convert to Application.

2. Add aWeb ServiceManager user to theWSUS Administrators group

Skip the first three steps if you are usingWindows Small Business Server 2008.
a. Click theWindows Start button and typeComputer Management.
b. Go to Local Users and Groups > Users and create a new user that will manage theWeb

service.
c. Add the new user to theWSUS Administrators group under theGroups folder.
d. In IIS, right-click Application Pools above theSites section and select Add Application

Pool.
e. If .NET 4.0 is not already installed on your system, install it and run the following command as

Administrator: c:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe
-iru

f. Enter a name for your application pool, select .NET 4 or above and click OK.

3. Configure IIS to use the new Web ServiceManager user for running theWeb service

Skip the first two steps if you are usingWindows Small Business Server 2008.
a. Right-click the newly created application pool and select Advanced Settings.
b. UnderProcess Model, change the identity configuration to use a custom account and provide

the credentials for your newly createdWeb Server Manager account.
c. In IIS, select theWeb service under theDefault Web Site and click Basic Settings.
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d. Select your newly created application pool as the default one and click OK. TheWeb service
will now use your new application pool.

4. Configure IIS to accept HTTP and HTTPS requests forWCF

By default, IIS does not accept HTTP and HTTPS requests for a .NETWCFWeb Service. To
enable this optionmanually:
a. Click theWindows Start button and type TurnWindows features on or off.
b. Expand Features >  .NET Framework 4.5 Features > WCF Services and enableHTTP

Activation.
c. Click Install then click Next until you reach the end of the wizard.

5. Setting up SSL certificates for IIS and theWeb service clients (SA core and SA client)

a. Cmd to the OpenSSL installation directory. By default OpenSSL installs under Program
Files (x86)\GnuWin32\bin

b. Type the following command to create a new system variable pointing to the openssl.cnf . Edit
the command if you installed OpenSSL at a different location than the default one: 
Set OPENSSL_CONF=C:\Program Files (x86)\GnuWin32\share\openssl.cnf

c. Create a private and a public key using the following command:
openssl req -x509 -newkey rsa:2048 -keyout your_private_key.pem -out your_
public_key.pem -days XXX. ChangeXXX to the number of days you want the certificate to
be valid for and give a custom name to the two .pem files.

d. Type the following command in the OpenSSL installation directory to convert the two .pem
files into a single .pfx file: openssl pkcs12 -inkey your_private_key.pem -in your_
public_key.pem -export -out your_pkcs12_cert.pfx.

e. Copy the .pfx file onWSUS Web servicemachine to import the server certificate into IIS:
i. Go to IIS and select your server from theConnections pane.
ii. Double-click Server Certificates select your certificate and click Import.
iii. Browse to your .pfx file and type in the password you created for your public and

private keys.
f. Create a new binding for theWeb service, to use HTTPS with this certificate.

i. In the IIS, select Default Web Site from theConnections pane.
ii. Click Bindings from theActions pane. This displays theSite Bindings dialog box.
iii. Click Add and select https from the Type drop-downmenu.
iv. Pick your IP address and/or hostname from theSSL certificate drop-downmenu.
v. Click Apply to save your changes.

g. Configure the Web service to require SSL.
i. Select yourWeb service from the IIS Connectionsmenu, underDefault Web Site.
ii. Click SSL Settings.
iii. Check Require SSL checkbox and click Apply.

h. Paste the content of your_public_key.pem at the bottom of the following file:
/opt/opsware/openssl/certs/ca-bundle.crt. This copies the public certificate into the
KnownCertification Authorities file on your SA core.
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Do not delete any existing certificates from the bundle.crt file.

6. Setting up SSL certificates for securing theWeb service-WSUS communication

a. Edit the WsusConfig.config file to set secureConnection to True and change the port to
WSUS's HTTPS port. ForWindows Server 2012, the default port is 8531.

b. Use a self-signed certificate generated and import it into IIS as described in step 5. When
OpenSSL prompts you for theCommon Name, type the FQDN or IP of your machine that
holds WSUS and theWeb service.

c. In the IIS Connections pane, expand your host server > Sites and select the
WSUS Administration node. Depending on your operating system, this is displayed either
underDefault Web Site or on the same level.

d. Click Bindings from theActions pane. This displays theSite Bindings dialog box.
e. Select the https binding and click Edit.
f. Pick your IP address and/or hostname from theSSL certificate drop-downmenu.
g. Choose your imported certificate and click OK to close theEdit Site Bindings dialog box.
h. In theWSUS Administration node, enable theRequire SSL option for the following

subnodes: APIRemoting30, ClientWebService, DssAuthWebServicee,
ServerSyncWebService andSimpleAuthWebService.

i. Open theContent node andmake sure theRequire SSL option is disabled. TheWeb service
does not require SSL to secure content coming from theWSUS server. WSUS updates are
signed by Microsoft by default, thus they are already secure.

j. Click Apply to save your changes.
k. Install your generated public key on the computer that holds WSUS and theWeb service.

7. Configuring connection and import settings for theWSUS Web service

TheWeb service archive that you unpacked under C:\inetpub\wwwroot\[your folder]
contains two configuration files: WsusConfig.config and Web.config. Edit these XML files to
configure the connection andmetadata import settings for patches for theWSUS Web service.
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a. WsusConfig.config

Attribute Description

serverName IP or hostname of theWSUS server. This is included in
the URL of theWSUS Web service. TheWSUS Web
service supports both IPv6 and IPv4 hosts.

port The port whereWSUS is located on the server. Default
HTTP port is 8530.

secureConnection Set to True if you want the connection betweenWeb
Service and theWSUS server to be secure.

ignoredProperties Specify whichmetadata properties to ignore when the
Web service retrieves WSUS patches and associated
metadata.

includeApprovedUpdatesOnly Specify which type of patchmetadata SA retrieves from
theWSUS server:
True - Web service imports only metadata for the
patches marked as Approved inWSUS.
False - Web service imports metadata for all patches
available inWSUS:
o Approved
o Declined
o Not Approved

b. Web.config
The following lines in this XML file define the two endpoints available for connecting theWeb
service toWSUS:
l <endpoint address="" binding="webHttpBinding"

bindingConfiguration="secureHttpBinding" contract="WsusREST.IWsusREST"
behaviorConfiguration="web"></endpoint>

l <endpoint address="" binding="webHttpBinding" contract="WsusREST.IWsusREST"
behaviorConfiguration="web"></endpoint>

Make sure these endpoints mirror the IIS binding settings that you have configured in step 5.
HTTP connection:
If your IIS configuration specifies an HTTP binding, remove the
bindingConfiguration="secureHttpBinding line from this file, otherwise theWeb service call
fails.
HTTPS connections:
If your IIS configuration specifies an HTTPS binding, keep the
bindingConfiguration="secureHttpBinding line

HTTTP and HTTPS connections:
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If your IIS configuration specifies both HTTP and HTTPS bindings, keep both lines.

8. Hide IIS version information

For security reasons, We recommend limiting the information that theWSUS Web service
provides to remote clients. To hide the IIS version that theWSUS Web service is using:
a. Install UrlScan from theMicrosoft website. This security extension enables you to filter IIS

connection requests.
b. Navigate to %WINDIR%/System32/inetsrv/urlscan and open the UrlScan.ini file.
c. Search for the RemoveServerHeader attribute and change it from 0 to 1. This stops sending

the HTTP server header to remote clients.
d. Save the UrlScan.ini file and close it.

9. Access the deployedWeb service

a. Enter the following URL in your browser to test theWSUS-Web service connection. This
downloads a JSON file containing all the languages enabled on yourWSUS Server.

l secure binding: https://<hostNameOrIP>/<your_folder_name>/WsusREST/Locales
l non-secure binding: http://<hostNameOrIP>/<your_folder_

name>/WsusREST/Locales

b. Check that eachWindows managed server is able to access this WSUS Web service URL.
SA cannot patch servers that do not have direct access toWSUS as these connections are
not routed through the SA gateway mesh.

Connecting SAmanaged servers toWSUS

To be able to scan for and deploy requiredWSUS patches, connect yourWindows managed
servers toWSUS. This enables WSUS to communicate with theWindows Update Agent
available on themanaged servers.
Prerequisites
l Make sure each SA managed server can access theWSUS URL set for it as a custom
attribute at the Facility/Customer/Device group/Server level. SA cannot patch servers that do
not have direct access toWSUS as these connections are not routed through the SA gateway
mesh.

l Check that themanaged servers you want to connect toWSUS are using the SA Agent
version, which is packaged along with the SA 10.23.007 Patch.

You can connect managed servers toWSUS either:

When installing the SA Agent

1. Go to theAdministration > Patch Settings andmake sure that theMicrosoftWSUS patching
mode is enabled.

2. Add the following custom attribute at Facility orCustomer level: 
Name Value

WSUS_URL <protocol>://<WSUShostnameOrIP>:<portNumber>
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3. Go toDevices > SA Agent installation and select the servers on which you want to install the
SA agent.

Optionally, you can specify extra installer options:

Flag

Arguments

Enclosemultiple arguments in double quotes.

--wsus_
cfg_args

--setupConnection. Mandatory argument.

--wsusURL - specifies aWSUS URL that overrides any custom attributes already set
for the selectedmanaged servers. Optional argument.

--ignoreWSUSModeCheck - ignores thatWSUS patchingmode is not enabled on the
core. Optional argument.

--wsus_
cfg_skip

Does not run theWSUS configuration script.

When upgrading the SA Agent

1. Go toAdministration > Patch Settings andmake sure that theMicrosoftWSUS patchingmode
is enabled.

2. Add the following custom attribute at Facility, Customer, Device Groups orServers level: 
Name Value

WSUS_URL <protocol>://<WSUShostnameOrIP>:<portNumber>

3. Go toDevices > All Managed servers, right-click on the servers on which you want to upgrade
the SA Agent and select Run > Agent Upgrade.

Optionally, you can specify extra installer options:

Flag

Arguments

Enclosemultiple arguments in double quotes.

--wsus_
cfg_args

--setupConnection. Mandatory argument.

--wsusURL - specifies aWSUS URL that overrides any custom attributes already set
for the selectedmanaged servers. Optional argument.

--ignoreWSUSModeCheck - ignores thatWSUS patchingmode is not enabled on the
core. Optional argument.

--wsus_
cfg_skip

Does not run theWSUS configuration script.

When provisioning a server

1. Go to theAdministration > Patch Settings andmake sure that theMicrosoftWSUS patching
mode is enabled.
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2. Add the following custom attribute at Facility orCustomer level: 
Name Value

WSUS_URL <protocol>://<WSUShostnameOrIP>:<portNumber>

3. Start the provisioning process. SeePerforming provisioning in the SA Administration Guide.
Before running compliance scans

If you have not connected yourWindows servers to theWSUS server during Agent installation or
upgrade, you can run an SA script to manually make your servers available forWSUS patching.

1. Go to theAdministration > Patch Settings andmake sure that theMicrosoftWSUS patching
mode is enabled.

2. Add the following custom attribute at Facility, Customer, Device Groups orServers level: 
Name Value

WSUS_URL <protocol>://<WSUShostnameOrIP>:<portNumber>

3. Go toDevices > Servers > All Managed Servers and right-click on a server that you want to
connect toWSUS.

4. Select Run Script > Configure Server With WSUS from the context menu. This launches the
Configure Server With WSUS.bat script file from Library > By Folder > Opsware
> Tools > Patching.

5. On theRun Server Script wizard, click Next and specify any custom options for the script.
6. Click Start Job then click Closewhen the import is complete.

Parameters for the Configure Server WithWSUS script

The following parameters enable you to change the default behavior for running theConfigure Server
With WSUS .bat file on the selected servers.

l --wsusURL - specifies aWSUS URL that overrides any custom attributes already set for the
selectedmanaged servers.

l --ignoreWSUSModeCheck - ignores thatWSUS patchingmode is not enabled on the core.

Changing configuration settings for theWSUSWeb service

As part of deploying theWSUS Web service on aWSUS server, you define how SA connects and
imports patches fromWSUS via theWSUS Web service.

You can change your settings at any time, from the twoWSUSWeb service configuration files:
WsusConfig.config and Web.config. These XML files are available on themachine that holds the
WSUS server, under C:\inetpub\wwwroot\[your folder].

You cannot change the list of patch products and patch locales that SA reads fromWSUS. This
list is defined by theWSUS administrator on theWSUS side.

To changemetadata import settings:

1. On theWSUS machine, go to C:\inetpub\wwwroot\<folder_where_you_deployed_the WSUS_
Web_service> and open WsusConfig.config.
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2. Find the includeApprovedUpdatesOnly attribute and set it to False.
3. Save your changes and close the XML file.
4. Restart the IIS site that holds theWSUSWeb service.
By default, SA imports metadata only for patches that theWSUS Administrator marked as Approved.
You can edit this filter to import Declined andNot Approved patches as well.

To change connection settings:
TheWsusConfig.config XML file defines the IP, port number and specifies whether the connection
between theWSUS server and yourWSUS Web service is secure or not. To change the connection or
the URL of theWSUS Web service:

1. On theWSUS machine, go to C:\inetpub\wwwroot\<folder_where_you_deployed_the WSUS_
Web_service> and open WsusConfig.config.

2. Find the serverName attribute and change it to use the new hostname or IP of yourWSUS Web
service.

3. Change the port number if required.
4. Set the secureConnection to True if you want to create an SSL HTTPS connection between the

Web service and theWSUS server.
5. Save your changes and close theWsusConfig.config XML file.
6. Open the XML fileWeb.configand remove the bindingConfiguration="secureHttpBinding

line if you want to create an HTTP connection. To create an HTTPS or both an HTTP and
HTTPS connection, make sure the following line is available in the XML file: <endpoint
address="" binding="webHttpBinding" bindingConfiguration="secureHttpBinding"
contract="WsusREST.IWsusREST" behaviorConfiguration="web"></endpoint>.

7. Go to IIS and ensure that the connection endpoints defined in theWeb.config XML file mirror your
current IIS binding settings. For secure HTTPS connections, make sure theRequire SSL option
is enabled for the following pages of theWSUS Administration node in theConnections
pane: APIRemoting30, ClientWebService, DssAuthWebServicee, ServerSyncWebService
andSimpleAuthWebService.

8. Restart the IIS site that holds theWSUSWeb service.

Select Windows patch products and locales for import

You can limit the patches tracked by Server Automation to specific Windows products and locales of
these products. When you import theMicrosoft Patch Database, SA retrieves only the products and
locales that you selected. This minimizes data storage issues in the SA Core and Software Repository
(Word).

A product is a specific edition of an operating system or application, for exampleWindows Server 2008
R2. The locale of a patch identifies the language of theWindows servers that should receive the patch.

To specify patch products and patch locales for your Microsoft patch database:

In WSUS patching mode
InWSUS mode, filtering by patch product and locale is done on theWSUS server side. SA only
displays the read-only list of products and locales selected by theWSUS administrator.

In Offline Catalog patching mode

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 47 of 307



By default, when you import theMicrosoft Offline Catalog, SA imports patchmetadata for all patches
listed in the database. The default product list is based on theMicrosoft product list at the time this
version of SA was released. Modify the list of products according to the products in your environment.
If there are products in the default selected list that you do not want, deselect them before you import
patch binaries.

From the SA client

1. In the navigation pane, select Administration>PatchSettings.
2. In theMicrosoft tab, select Patch Products and then click Edit.
3. In theEdit Patch Productswindow, use (+) the include and (-) exclude arrows to select the

products whose patches you want to import.
4. To populate the list of available products fromMicrosoft, click either:

l Update Products from Vendor: to update the list of products directly from the vendor site.
The vendor site URL is the default URL for theMicrosoft Offline Catalog on theMicrosoft
website. If youmodified the default URL, select Revert to Vendor Default go back to the
URL defined in your system implementation settings.

l Update Products from File: Use this option to update the list of products from the
wsusscn2.cab file on your local machine. This method is useful for air-gapped environments,
where themanaged servers do not have internet access.

5. Click OK to save your settings.The next time you run import Windows patches, patches for the
selected products will be included in the download.

From the populate-opsware-update-library shell script

To limit the patches tracked to specific Windows operating systems, run the command-line script that
automatically imports patches.

The script can filter the patches imported according to operating system, such as specific versions of
Windows Servers. When you run this script, patches from all products that are selected in thePatch
Settings product list will be imported, unless they are specifically omitted by one of the command-line
options. See Script Options.

Patch locales

The locale of a patch identifies the language of theWindows servers that should receive the patch. A
patch with the same namemight be available for different locales. For example, a patch named
Q123456might be available for servers running the English and Japanese versions of Windows.
Although they have the same name, the patches installed on the English and Japanese servers are
different binaries.

Windows patchmanagement supports multiple locales in the same SA multimaster mesh. To install a
patch onWindows servers with different locales, you specify the patch by name. During the installation
(or policy remediation), SA matches the locale of the patch with the locale of eachmanaged server.
You do not need to repeat the installation for each locale.

Supported locales

Depending on your selected patchingmode, SA supports the following locales forWindows patching:
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For patches coming from the Offline Catalog of Microsoft patches

l English (en)
l French (fr)
l German (de)
l Italian (it)
l Japanese (ja)
l Korean (ko)

For patches coming from a WSUS server

SA supports all patch locales specified on theWSUS side.

Locale configuration tasks

By default, Windows patchmanagement supports only the English locale.

Configuring theSA Core for non-English locales

Note:
This task requires root access to core servers and a restart of the SA Client.

To configure the core for non-English locales, complete the following steps on each core server that is
running the SA Client:

1. Log on to the server as root.
2. In /etc/opt/opsware/occ/psrvr.properties, change the line for

pref.user.locales

to

pref.user.localesAllowed=en;ja;ko

3. Restart the SA Client on the core:

/etc/init.d/opsware-sas restart occ.server

4. In a text editor, open the following file:

/opt/opsware/occclient/jnlp.tmpl

5. For the Japanese language, in the <resources> section of the jnlp.tmpl file, add the following
XML element:

<property name="com.opsware.ngui.font.japanese" value="Arial Unicode MS"/>

6. For the Korean language, in the <resources> section of the jnlp.tmpl file, add the following XML
element:

<property name="com.opsware.ngui.font.korean" value="Arial Unicode MS"/>

7. In the /opt/opsware/occclient directory, if the following files exist, delete them:
l $HOST_ja.jnlp

l $IP_ja.jnlp
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l $HOST_ko.jnlp

l $IP_ko.jnlp

8. Complete the steps in "Selecting the locales of patches to import" below.

Selecting the locales of patches to import

Note:
Complete the instructions in "Configuring the SA Core for non-English locales" on the
previous page before performing the steps in this section.

You can only edit the list of patch locales when SA is set toOffline Catalog patchingmode. In
WSUS patchingmode, this list is configured on theWSUS side and is displayed in SA as read-
only information only.
When you select the locales of theWindows patches to import inOffline Catalog patchingmode,
the changes take effect the next time patches are imported into SA. After the patches have been
imported, they can be installed onmanaged servers. If you remove locales from the list with this
operation, patches with those locales that have already been imported are not removed from SA.
To select the locales of theWindows patches to import into SA:
a. In the navigation pane, select Administration.
b. Select Patch Settings.
c. In theMicrosoft tab, select Patch Locales.
d. Click Edit.
e. In the Edit Patch Locales window, use the include (+) and exclude (-) arrows to select the

locales whose patches you want to import.
f. If you want to select a locale that is not listed in "Supported locales" on page 48, contact

Support.
g. Click OK to save your settings.
h. Complete the steps in "End user requirements for non-English locales" below.

End user requirements for non-English locales

To view non-English fonts in the SA Client:
Verify that theWindows desktop running the SA Client uses the Arial UnicodeMS font.
After the system administrator performs the steps in "Configuring the SA Core for non-English
locales" on the previous page, the end user logs on to the SA Client and selects their “Logged in
as” link in the upper right corner of the SA Client window. This displays the User window. Select
the Properties view.
On theUser Properties view, the end user updates the Locale field in the User Preferences
section. For example, if the system administrator configured the core for Japanese, then the end
user sets the Locale field to Japanese.
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Import metadata for Windows patches

When you import theWindows patch database fromMicrosoft's Offline Catalog or from aWSUS
server, SA only imports the patchmetadata for your filtered patches. The imported patchmetadata is
stored in the Software Repository (Word) and displayed under Library > Patches > Windows.

Patchmetadata contains the information that SA requires to install Microsoft patches on your managed
servers. Metadata supplies information for the properties of an update, thus enabling you to find out
whether the patch is relevant for yourWindows managed servers. Themetadata package downloaded
for an update is typically much smaller than the update file itself.

To import patchmetadata:

l inOffline Catalogmode, see ImportingWindows patches from the offlineMS catalog.
l inWSUSmode, see "Importing theWindows patch database fromWSUS" on page 37.

Filteringmetadata for import

Depending on your patchingmode, SA applies different levels of filtering to ensure that you only import
patches for the relevant Microsoft products on yourWindows managed servers.

l InOffline Catalog patchingmode, you can filter importedmetadata by patch product and patch
locale.

l inWSUS patchingmode, you can also filter metadata by approval status. SA imports metadata only
for patches that theWSUS Administrator marked as Approved. You can cancel this filter to import
Declined andNot Approved patches as well by "Changing configuration settings for theWSUS
Web service" on page 46.
InWSUS mode, filtering by patch product and locale is done on theWSUS server side. SA only
displays the read-only list of products and locales selected by theWSUS administrator.

SA retrieves patchmetadata from the upstream server where you deployed theWSUS Web service.
TheWSUS administrator is responsible for keeping any downstream servers synchronized with the
upstream server. This ensure you always get the complete and up-to-date list of patchmetadata into
SA.
After configuring and importing themetadata, you can import theMicrosoft patch binaries by using the
SA Client. If you are working inOffline Catalogmode, you can also import patch binaries from the
populate-opsware-update library command-line script.

Check the list of imported MS patchmetadata

After importingWindows patch database from theMicrosoft Offline Catalog or from aWSUS server, go
to Library > Patches > Windows to verify that SA has imported themetadata for your filtered patches.
Patches for which you imported only metadata show up in dimmed, indicating that their binaries are not
available in SA yet.

Import patch binaries only for the patches required to remediate non-compliant servers. Before
importing binaries, run a compliance scan to find out which patches require your managed servers.

To search for a product patch, select Description as the search value and enter the name of the
product, such as Office 2003, in the text box.

For more information see, "Import applicableWindows patch binaries" on page 70.
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Set patch availability

From theSA Client

To set the default value for the availability of a newly imported patch by using the SA Client:

1. In the navigation pane, select Administration > Patch Settings.
2. From theDefault Availability for Imported Patches drop-down list, select either:

l Limited Availability (Default) - for patches imported into Server Automation that can be
installed only by patch administrators with required permissions. To obtain these permissions,
contact your system administrator. See the SA Administration Guide for an explanation of
these permissions.

l Available - patches can be installed onmanaged servers.

From the command-line script

If you are working inOffline Catalog patchingmode, you can also change patch availability from the
populate-opsware-update-library command-line script.

The default used by the script overrides the default set by the SA Client. For information about the
script, see "Downloading theMicrosoft Offline patch catalog from the command line " on page 33.

Configure patch policies
Patch policies and patch policy exceptions enable you to customize which patches are distributed for
installation in your environment.

You can choose to have patching in your server environment comply to themodel that these policies
and exceptions define or you can choose to deviate from this model. If you choose to deviate from the
patch policies and exceptions and perform ad-hoc patch installs, then you need to remediate. The
remediation process ensures that the applicable patches get installed on servers.

Patch policy

A patch policy is a group of patches that you want to install on SA managed servers. All patches in a
patch policy must apply to the sameWindows operating system.

A patch policy provides broad flexibility for distributing patches. For example, you can create a patch
policy that contains security patches that you want to distribute only to servers used by your sales
force. You can also create a patch policy that contains security patches that are applicable to specific
software that is already installed on a server, such as Exchange Server, Internet Information Services
(IIS), SQL Server, and so on. Or, you can create a patch policy that includes all patches ranked as
critical by Microsoft and then installs them on all servers that are used by everyone in your
organization.

Note:
If you do not want to create a patch policy, you can use the vendor-recommended set of patches
(by operating system) as a default patch policy. If you are working inWSUS patchingmode,
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enable theRecommended binaries import option. InOffline Catalogmode, SA retrieves the
recommended set of patches from the wsusscn2.cab file.

You can attach as many patch policies as you want to servers or groups of servers. If several policies
are attached to one server, the installation logic is cumulative—all patches listed in all attached policies
will be installed on the server. TheRemediatewindow allows you to select an individual patch policy to
remediate. You do not have to remediate all policies attached to a server. You cannot nest patch
policies.

If a description of the patch policy is defined, it is recorded in the server’s patched state in theModel
Repository. This information enables PatchManagement to report on patch policies for patch
compliance purposes. The patch compliance process compares patch policies with corresponding
patch policy exceptions.

Windows PatchManagement supports the following types of patch policies:

l User-defined patch policy: This type of patch policy allows you to specify the patches you want in
the policy. A user-defined patch policy can be edited or deleted by a user who has the required
permissions.
This type of patch policy allows a policy setter to opt out of patches. The policy setter can create a
user-defined patch policy that is a subset of all available patches that are in a vendor-recommended
patch policy. This enables the policy setter to apply only those patches that their environment
needs.

l Vendor-recommended patch policy: Depending on your selected patchingmode, the list of
recommended patches is retrieved on a server-by-server basis either by WSUS or from the
wsusscn2.cab file. Vendor-recommended patch policies are system defined and cannot be edited or
deleted by a user.

Note:
You can only export user-defined patch policies. You cannot export vendor-recommended patch
policies.

Patch policies have the following characteristics:

l All patches in a patch policy must apply to the same operating system.
l A patch policy is associated with an operating system version.
l A patch policy has a name and can (optionally) include a description that explains its purpose.
l A patch policy can be either user-defined or vendor-defined.
l A patch policy does not have sub-policies. There is no inheritance.
l A patch policy is Customer Independent, whichmeans that patches in the policy can be installed on
any managed server, nomatter what customer is associated with it. See the SA User Guide.

l A patch policy is always public.
l A patch policy can be attached to zero or more servers or public device groups.
l More than one patch policy can be attached to a server or public device group.
l Only user-defined patch policies can be created, edited, and deleted by a user who has permissions.
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Patch policy exception

A patch policy exception identifies a single patch that you want to explicitly include or exclude from a
specific managed server, along with an optional reason for why the exception exists. The patch in a
patch policy exceptionmust apply to the sameWindows operating system that the established patch
policy is attached to.

A patch policy exception allows you to deviate from an established patch policy—one that is already
attached to a server or a group of servers. You can do this by deselecting or adding individual patches
to a server. Since patch policy exceptions override all patch policies attached to a server, you can use
them to intentionally deviate from a patch policy on a server-by-server basis.

If a reason for a patch policy exception is defined, the description is recorded in the server’s patched
state in theModel Repository. This information enables SA to report on patch policy exceptions for
patch compliance purposes. The patch compliance results explain how patch policy exceptions
compare with corresponding established patch policies. All users who have access to themanaged
server can view its attached patch policy exceptions.

Windows PatchManagement supports the following types of patch policy exceptions:

l Always Installed: The patch should be installed on the server, even if the patch is not in the policy.
l Never Installed: The patch should not be installed on the server, even if the patch is in the policy.

Note:
If you ever need to override a patch policy exception, you canmanually install a patch.

The following information summarizes characteristics of a patch policy exception:

l A patch policy exception can (optionally) include a description that explains its purpose.
l A patch policy exception can have a rule value of Never Installed or Always Installed.
l A patch policy exception can be set for one patch and one server of the same operating system
version. If a patch policy exception is set for a public device group and a server in that group does
not match the operating system version specified in the patch policy exception, the patch policy
exception is not applied.

l A patch policy exception can be set, copied, and removed by users who have permissions.

Precedence rules for applying policies

By creatingmultiple patch policies and patch policy exceptions that are either directly attached to a
server or attached to a group of servers, you control the patches that should be installed or not installed
on a server. A precedence hierarchy in PatchManagement delineates how a patch policy or a patch
policy exception is applied to a patch installation. This hierarchy is based on whether the patch policy or
patch policy exception is attached at the server or device group level.

The following precedence rules apply to policies and exceptions:

l Patch policy exceptions that are directly attached to a server always take precedence over patch
policies that are directly attached to a device group.

l Patch policies that are directly attached to a server take precedence over patch policies and patch
policy exceptions that are attached to a public device group.
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l Patch policy exceptions that are attached to a public device group take precedence over patch
policies that are attached to a public device group.

l If a server is in multiple public device groups, a Never Installed patch policy exception type always
take precedence over an Always Installed patch policy exception type for the same patch.

Add items to a Windows patch policy using the Object ID

Themethod for adding items toWindows Patch Policies has changed in order to prevent duplicate KB
errors. SA identifies Windows hotfixes by the Object ID, now, instead of the KB number. This enables
you to bemore selective about the patches you add to the policy. However, it alsomeans that when
you select a patch of a certain KB number, SA will not automatically select all the other patches with
that KB number—youmust select them individually or use shift-click to multi-select items.

Set remediate options

You can specify the following remediate policy option:

Do not interrupt the remediate process even when an error occurs with one of the policies.

To set this option:

1. In the Remediate window, click Next to advance to the Options step.
2. Select a rebooting option. See "Set reboot options for remediation" on page 57.
3. Select theError Handling check box if you want the remediation process to continue even when

an error occurs with any of the patches or scripts. As a default, this check box is not selected.
4. Click Next to go to the next step or click Close to close the Remediate window.

Windows patch policy remediation job option—Windows Patch Installation Order

Whenworking inOffline Catalog patchingmode, theWindows Patch Installation Order option
enables you to control patch installation sequence during remediation. Because theMicrosoft Offline
Catalog of patches (wsusscn2.cab) only contains security updates, HP provides patch supplements
via HPLN. Selecting this option prevents the collision of Windows patch data derived from different
sources.

Some newer patches from the offline catalog have incorporated or enhanced the fixes that were
previously defined in the patch supplement, which rendered the supplement patches obsolete.
Consequently, patch data can be corrupted if you install the patch supplement patches before the
wsusscn2.cab patches.

l HP  strongly recommends using this option when remediatingWindows patch policies in
Offline Catalog patchingmode.

l This setting is not available inWSUS patchingmode. This is because SA can retrieve all
requiredMicrosoft updates from yourWSUS server. For more information see Accessing the
Microsoft patch database

How it works:

1. When running aWindows Patch Policy remediation job, select theWindows Patch Installation
Order setting in theOptions view.

Windows Patch Installation Order setting in the Remediate window
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2. When you run the remediation job, all theMicrosoft Offline Catalog patches (wsusscn2.cab) will
be deployed first, and the HPLN Patch Supplement patches will be excluded until the job no longer
contains any Microsoft Offline Catalog patches.

Note:When this option is not selected, the default order is by KB #, which can cause problems if
you are installing patches from both sources: Windows Offline Catalog (wsusscn2.cab) and HPLN
Microsoft Patch Supplement.

3. You will need to run the remediation jobmultiple times in order to deploy all the patches and
achieve full compliance.

Note: If you use this option, youmust runmultiple remediation jobs tomake a server fully
compliant.

4. The status of each patch installation is provided in thePreview or Job Status view of the
Remediatewindow.
To view additional details about a specific item, select the row in the table to display details in the
bottom pane, as shown in the "Preview Patch Install Status" below figure.

Preview Patch Install Status
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Note: If the policy has patches from both sources, wsusscn2.cab and the HPLN supplement, then
the job will not install the HPLN patches. The followingmessage should be displayed:

This patch is not aWindows Offline Catalog patch. TheWindows Patch Ordering option was
enabled for this job, so only Windows Offline Catalog patches will be considered.

Set reboot options for remediation

Tominimize the downtime that server reboots can cause, you can control when servers reboot during a
patch installation.

You can specify the reboot options in the following SA Client windows:

l Patch Properties window—Install Parameters tab
l Remediate window—Pre and Post Actions step
Best Practice: When you are selecting reboot options in the Remediate window, Hewlett Packard
recommends that you useMicrosoft’s reboot recommendations, which is the Reboot servers as
specified by individual software items option. If it is not possible to use theMicrosoft reboot setting,
select the single reboot option, which is the Hold all server reboots until after all packages are installed
and/or uninstalled option. Failure to do this can result in theWindows Update Agent (WUA) incorrectly
reporting which patches are installed on the server until the next reboot occurs (outside of SA control).

The following options in the Remediate window determine whether the servers are rebooted after the
patch is installed. These options apply only to the job launched by the Remediate window. They do not
change the Reboot Required option, which is in the Install Parameters tab of the Patch Properties
window. Except for the first option, the following options override the Reboot Required option.

l Reboot servers as specified by individual software items (Default): By default, the decision to
reboot depends on the Reboot Required option of the patch or package properties.
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l Reboot servers after each installation or uninstallation: As a best practice, reboot the server
after every patch or package installation or uninstallation, regardless of the vendor reboot setting on
the individual patch or package.

l Hold all server reboots until after all packages are installed and/or uninstalled: If the Reboot
Required option is set for some selected patches but not for others, the server is rebooted one time
after all patches are installed. If the Reboot Required option is not set for any of the selected
patches, the server is not rebooted.

l Suppress all server reboots: Even if the Reboot Required option of the patch properties is set, do
not reboot the server. (Because of vendor settings, some patches ignore the suppress option and
force a reboot.

To set reboot options:

1. From the Remediate window, click Next to advance to the Options step.
2. Select one of the Rebooting options.
3. Click Next to go to the next step or click Close to close the Remediate window.

Specify pre-installation and post-installation scripts for remediation

For each patch remediation, you can specify a command or script to run before or after remediation. A
pre-install script, for example, could check a certain condition on themanaged server. If the condition is
not met or if the pre-install script fails, the patches would not be installed. A pre-install script could also
be used to shut down a service or application before it is patched. A post-install script could be used to
perform a certain cleanup process on themanaged server.

You can specify the following types of scripts to run on themanaged server before or after a
remediation process:

l Pre-download: A script that runs before patches are downloaded from SA to themanaged server.
This is available only if you select Staged in the Remediate Options step.

l Post-download: A script that runs after patches are downloaded from SA to themanaged server
and before the patch is installed. This is available only if you select Staged in the Remediate Options
step.

l Pre-install: A script that runs before patches are installed on themanaged server.
l Post-install: A script that runs after patches are installed on themanaged server.
To specify a pre-install script:

1. From the Remediate window, click Next to advance to the Pre & Post Actions step.
2. Select thePre-Install tab.

Youmay specify different scripts and options on each of the tabs.
3. Select theEnable Script check box. This option enables the remainder of the fields on the tab. If

Enable Script is not selected, the script will not run.
4. Select either Saved Script or Ad-Hoc Script from the drop-down list.

A Saved Script has been previously stored in Server Automation with SA Client. To specify the
script, click Select.
An Ad-Hoc script runs only for this operation and is not saved in SA. Select the Type, such as
.bat. In the Script box, enter the contents of the script, including the drive letter of where the script
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is located, such as echo dir>> C:\temp\preinstall1.log. If you do not enter a drive letter, the default
is %SYSTEMDRIVE%, which is where the system folder of Ubuntu is installed.

5. If the script requires command-line flags, enter the flags in theCommand text box.
6. In the User section, if the system is not Local System, select Name.
7. Enter the system name, your password, and the Domain name.
8. To stop the installation if the script returns an error, select theError check box.
9. Click Next to go to the next step or click Cancel to close the Remediate window.

Schedule a patch installation for remediation

You can schedule when you want patches installed and when you want patches downloaded.

To schedule a patch installation:

1. In the Remediate window, select the Scheduling step.
By default, the Scheduling step displays only the scheduling options for the installation phase. If
you selected Staged in the Remediate Options step, the scheduling options for the download
phase will also be displayed.

2. Select one of the following Scheduling options:
l Schedule Analysis: This enables you to specify a date and time that you want the analysis to
run.

l Schedule Download: This enables you to specify a date and time that you want the download
or installation performed.

l Schedule Remediate: This enables you to specify a data and time that you want the
remediate process to run.

3. Click Next to go to the next step or click Cancel to close the Remediate window.

Set up email notifications for remediation

You can set up email notifications to alert users when the download and installation operations
complete successfully or with errors.

To set up email notifications:

1. From the Remediate window, click Next to advance to the Notifications step.
2. To add email addresses, click Add Notifier and enter the email addresses in the Notification

Email Address field.

3. To set the notification status on the success of a Job, select the icon. To set the

notification status on the failure of a Job, select the icon. By default, the Notification step
displays only the notification status for the installation phase. If you selected Staged in the
Remediate Options step, the notification status for the download phase is also displayed.

4. Enter a Ticket ID to be associated with a Job in the Ticket ID field.
5. Click Next to go to the next step or click Cancel to close the Remediate window.
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Note:
If you previously selected Staged in the Remediate Options step, the Notifications pane displays
notification options for both the download and installation phases.

Preview and start a remediation

The remediate preview process provides an up-to-date report about the patch state of servers. The
Preview is an optional step that lets you see the patches that will be installed onmanaged servers. This
preview process verifies whether the servers you selected for the patch installation already have that
patch installed. This verification is based on the imported Microsoft path database. In some cases, a
server could already have the patch installed if a system administrator hadmanually installed it, which
means that PatchManagement does not know about it.

In the Preview, the servers, device groups, and patches that are listed in the Summary Step window
will be submitted to remediation when you click Start Job. Patches that are not recommended by the
vendor will be excluded from this list. If there are other patches in the policy with the sameQNumber,
only the vendor-recommended patch is displayed.

This list shows patches and their associated servers, regardless of any patch policy and server group
membership changes that may have occurred. If you preview a remediation, this same list of servers,
device groups, and patches will be used, even if changes have occurred to the patch policy or server
groupmemberships.

If youmodify parameters in the Remediate window after you have already clicked Preview, the preview
process will produce an invalid summary of simulated patching actions. For example, if you have
already clicked Preview and you add patches, patch policies, servers, or device groups, youmust click
Preview again for results that include your changes.

Note:
The remediation preview does not report on the behavior of the server as though the patches have
been applied.

To preview a remediation:

1. In the Remediate window, in the Servers and Policies step, select a server or policy.
2. Click Next or select the Options step to specify your rebooting, error handling, and script

preferences.
3. Click Next or select the Preview step to see the separate actions that will be performed when the

patch is installed.
4. In the Preview step, click Preview to view the details of a previewed action.
5. To launch the installation job, click Start Job.

If you selected Run Immediately After Analysis in the Scheduling step, the job will run now. If you
selected a specific time, the job will run then.

6. The Job Status displays in the Remediate window.
The Status bar and text indicate how many of the actions listed in the table have been completed.
For each server, the following actions can be performed:
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l Overall Server Status: The overall status of all servers included in this remediation job.

l Analyze: SA examines the patches needed for the installation, checks themanaged servers
for themost recent patches installed, and determines other actions that must be performed,
such as download, install, or reboot.

l Download: The patch is downloaded from Server Automation to themanaged server.

l Install: After it is downloaded, the patch is installed.

l Reboot: If this action is specified in the Options step, the server is rebooted.

l Registration: Software registration is performed to retrieve currently installed packages and
patches on themanaged server.

l Test Compliance: A compliance scan is performed to report the current compliance status of
themanaged server.

l Run Script: If scripts are specified in the Options step, the scripts are run before or/and after
the download or/and installation.

l Install & Reboot: If you specify to reboot the server according to each patch or package
setting in the Options step, the server will be rebooted immediately after each individual patch
or package is installed.

7. To view additional details about a specific action, select the row in the table to display this
information in the bottom pane.
Or
In the navigation pane, select Jobs and Sessions to review detailed information about the job. See
"Browsing Job Logs" in the SA User Guide.

8. In the navigation pane, select Jobs and Sessions to review detailed information about the job. See
"Browsing Job Logs" in the SA User Guide.

9. Click End Job to prevent the job from running or click Close to close the Remediate window. You
can end a job only if it is scheduled.
(Optional) See the "Cancelling or Terminating Installation, Uninstallation or Remediation Jobs"
section in the SA Administration Guide.

Verify patch policy compliance

To determine whether amanaged server complies with patch policies and exceptions:

1. In the navigation pane, select Devices > All Managed Servers.
2. From the View drop-down list, select Compliance to display patch compliance status.
3. Select a specific server or check Check All Rows to view detailed Patch compliance information

in the details pane. At any time, select Uncheck All Rows to modify your server selection.
4. In the details pane, expand the Patch row to see status and compliance summary details. Use the

status filter to narrow your compliance display preferences. By default, this is set to No Status
Filter.
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Create a patch policy

A patch policy is a set of patches that should be installed on amanaged server. When it is first created,
a patch policy contains no patches and is not attached to servers.

To create a patch policy:

1. In the navigation pane, select Library > By Type > Patch Policies.
2. Select a specific Windows operating system.
3. From the Actions menu, select Create Patch Policy.

The name of the policy you just created is New Patch Policy n, where n is a number based on the
number of New Patch Policies already in existence.

4. In the content pane, open the New Patch Policy.
(Optional) In the Name field of the Properties, enter a name that describes the purpose or contents of
the policy.

Delete a patch policy

This action removes a patch policy from SA but does not remove or uninstall patches frommanaged
servers. You cannot delete a patch policy if it is attached to servers or groups of servers. Youmust first
detach the policy from the servers or groups of servers before removing it from SA.

To delete a patch policy from SA:

1. In the navigation pane, select Library>By Type>Patch Policies.
2. Select a specific Windows operating system.
3. In the content pane of themain window, select a policy.
4. From the Actions menu, select Delete Patch Policy.

Add apatch to a patch policy

This action adds a patch to a patch policy, but does not install the patch on amanaged server. The
patch will be installed when the policy is remediated.

To add a patch to a patch policy to SA:

1. In the navigation pane, select Library > By Type > Patch Policies.
2. Select a specific Windows operating system and view the list of Windows patches.
3. In the content pane, select the patch.
4. From the View drop-down list, select Patch Policies.
5. From the Show drop-down list, select Policies without Patch Added.
6. Select a policy.
7. From the Actions menu, select Add to Patch Policy.
8. In the Add to Patch Policy window, click Add.
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Removeapatch from apatch policy

This action only removes a patch from a patch policy. This action does not uninstall the patch from a
managed server and does not remove the patch from SA.

To remove a patch from a patch policy:

1. In the navigation pane, select Library > By Type > Patches.
2. Select a specific Windows operating system and view the list of Windows patches.
3. From the content pane, select a patch.
4. From the View drop-down list, select Patch Policies.
5. From the Show drop-down list, select Policies with Patch Added.
6. Select a patch. From the Actions menu, select Remove from Patch Policy.
7. In the Remove Patch from Policy window, select the policy and click Remove.

Attach a patch policy to a server

This action associates a patch policy with a server or a group of servers). Youmust perform this action
before you remediate a policy with a server or a group of servers.

To attach the policy:

1. In the navigation pane, select Library > By Type > Patch Policies.
2. Select a specific Windows operating system and view the list of Windows patch policies.
3. In the content pane, select a patch policy.
4. From the View drop-down list, select Server Usage or Device Group Usage.
5. From the Show drop-down list, select Servers with Policy Not Attached orServer Groups with

Policy Not Attached.
6. In the preview pane, select one or more servers.
7. From the Actions menu, select Attach Server.
8. Click Attach.

Detach a patch policy from a server

This action does not delete the patch policy and does not uninstall patches from amanaged server.

To detach the policy:

1. In the navigation pane, select Library > By Type > Patch Policies.
2. Select a specific Windows operating system and view the list of Windows patch policies.
3. In the content pane, select a patch policy.
4. From the View drop-down list, select Server Usage (orDevice Group Usage).
5. From the Show drop-down list, select Servers with Policy Attached orServer Groups with

Policy Attached.
6. In the preview pane, select one or more servers.
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7. From the Actions menu, select Detach Server.
8. Click Detach.

Set a patch policy exception

A patch policy exception indicates whether the patch is installed during the remediation process. The
Install Patch and Uninstall Patch actions ignore patch policy exceptions. A patch policy exception
overrides the policy. You can specify an exception for a particular patch and server or a group of
servers, but not for a patch policy.

To set a patch policy exception:

1. In the navigation pane, select Devices > All Managed Servers.
2. Select a server.
3. In the content pane, select a server.
4. From the View drop-down list, select Patches.
5. In the preview pane, select a patch.
6. From the Actions menu, select Set Exception.
7. In the Set Policy Exception window, select the Exception Type:

l Never Install: The patch should not be installed on the server, even if the patch is in the policy.

l Always Install: The patch should be installed on the server even if the patch is not in the policy.

8. (Optional) In the Reason field, enter an explanation. This explanation is displayed when youmove
the cursor over the Exception column in the preview pane. The Patches with Exceptions option
must be selected. When you are finished, click OK.

Find an existing patch policy exception

You can search for managed servers that already have patch policy exceptions attached to them and
you can search for patches that have exceptions.

To find an existing patch policy exception:

1. In the navigation pane, select Devices > All Managed Servers.
2. From the View drop-down list, select Patches.
3. In the content pane, select a server.
4. From the Show drop-down list, select Patches with Policies or Exceptions orPatches with

Exceptions.
5. In the Exception column, move the cursor over the icon to display the reason for this exception.

The following icons indicate the type of patch policy exception:

An always install exception on a patch/server association.

An always install exception inherited to a server from a group of servers/patch association.

A never install exception on a patch/server association.

A never install exception inherited to a server from a group of servers/patch association.
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Copy a patch policy exception

To copy an exception between servers or groups of servers:

1. In the navigation pane, select Library > By Type > Patches.
2. Expand the Patches and select a specific Windows operating system.
3. In the content pane, select a patch.
4. From the View drop-down list, select Server Usage orDevice Group Usage.
5. From the Show drop-down list, select Servers with Exception orServer Groups with

Exception.
6. In the preview pane, select a server. This server is the source of the copied exception.
7. From the Actions menu, select Copy Exception.
8. In the Copy Policy Exception window, select the target servers or device groups.

These servers are the destinations of the copied exception. If this operation would result in
replacing an existing exception, amessage displays asking you to confirm whether this is the
preferred action.

9. Click Copy.

Removeapatch policy exception

To remove a patch policy exception:

1. In the navigation pane, select Library >> By Type >> Patches.
2. Expand the Patches and select a specific Windows operating system.
3. In the content pane, select a patch.
4. From the View drop-down list, select Servers.
5. From the Show drop-down list, select Serverswith Exception.
6. In the preview pane, select a server.
7. From the Actions menu, select Remove Exception.

Run compliance scans

After importing all the patches for all the desiredWindows products, run a compliance scan and
remediate any necessary servers according to the scan results.

Note:
The remaining steps assume that Vendor Recommended Patch Policies (VRPPs) are already
attached to yourWindows servers. If the VRPP is not attached to a server, attach it as you
normally would before running the compliance scan. See "Attach a patch policy to a server" on
page 63.

1. Scan aWindows server with the VPRR attached for patch compliance.
2. From Devices, select theWindows server you wish to scan.
3. Select Actions > Scan > Patch Compliance.
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The scan results will indicate if you need to remediate the server to apply any product-specific
patches.

4. Remediate the recommended patches as you normally would. See "Deploy patches/Remediate
servers" on page 71.

Note:
When you run this script, patches from all products that are selected in the Patch Settings product
list will be imported. This script does not provide an option to omit patches for specific products
other thanOperating System from the import. This script does provide options for omitting patches
from certainWindows operating systems; but it does not provide options for omitting non-OS
products, such as Microsoft Office or Exchange.

Patch compliance

You can perform patch compliance scans onWindows Server servers to determine compliance relative
to attached policies and exceptions. Patch compliance is based on patch applicability on the selected
server(s).

The Compliance view in the SA Client displays compliance details forWindows Server servers.

Patch compliance scans

A patch compliance scan compares patches that are installed on a server with patch policies and patch
policy exceptions that are attached to that server. The results of this scan show you the servers that
are in compliance (have all required patches installed) and the servers that are out of compliance (do
not have all required patches installed).

You should run or schedule patch compliance scans based on the dynamics of your patching
environment. For example, if you updated a patch policy or installed a patch outside of (by not using)
Server Automation, a compliance scan is required because the SA model has been changed and the
compliance informationmust now be recalculated. SA indicates these types of conditions by displaying
Scan Needed. In this case, instead of waiting for the scan schedule to iterate, you can start compliance
scan on one or more servers.

Ways to start a patch compliance scan

You can start a patch compliance scan in the following ways:

l Immediately, by selecting servers or groups and then selecting amenu item.
See "Start a patch compliance scan immediately" on the next page.

l Periodically, by setting up a schedule.
See "Schedule a patch compliance scan" on page 69. By default, the scans are not scheduled.

l As a result of another task.
SA performs a patch compliance scan on amanaged server at the end of the tasks described in the
following sections:

l "Patch installation forWindows" on page 72
l "Uninstall aWindows patch" on page 87
l "Deploy patches/Remediate servers" on page 71
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Start a patch compliance scan immediately

To start a scan on selected servers:

1. In the navigation pane, select Devices.
2. Select an entry from the Servers or Device Groups list.
3. Right-click and then select Scan > Patch Compliance to display the Patch Compliance Scan

Status window.

Refresh the compliance status of selected servers

When you refresh the compliance status of aWindows server, the SA Client retrieves the latest data
from theWeb Services Data Access Engine. A refresh action does not re-scanWindows servers for
compliance information.

To refresh the compliance status for one or more servers:

1. In the navigation pane, select Devices.
2. From the View drop-down list, select Compliance.
3. In the content pane, select one or more servers.
4. Right-click and select Refresh Server.
5. Review the Status column for any changed compliance information.

View scan failure details

If the scan operation fails, you cannot determine whether a server is in compliance. A scan failure is

indicated by the Scan Failed icon. To find out why a patch compliance scan failed:

1. In the navigation pane, select Devices.
2. Drill down to the server you want to check.
3. In the contents pane, select a server.
4. Right-click and then select Scan > Show Patch Compliance Scan Failure Details.
5. In the Patch Compliance Scan Failure Details window, select a server and examine the detailed

error message that appears in the lower part of the window.

Patch compliance icons

Server Automation displays the following icons in the "Patch Compliance Status Icons" below table

Status/Icon Description

Compliant

The server is compliant for all patches. Patches in policies attached to the server are
all installed on the target server.

Partial The server is partially compliant for patches. An exception has been set for these
patches.

Patch Compliance Status Icons
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Status/Icon Description

Non-
Compliant

The installed patches on the server do not match the conditions defined in the patch
policy.

Scan
Failed

The scan operation failed. PatchManagement is unable to check the compliance of
the server.

Patch Compliance Status Icons, continued

Patch non-compliance

A Patch non-compliant status for a server or group of servers can be cause by different factors, such as
the existence of applicable patches that need to be installed as defined in a patch policy attached to the
servers. Or, there could be exceptions that affect a server patch compliance level.

For example, a server will be considered non-compliant if the patch policy has a patchmarked as a
“Never Install” exception but the target server does have that patch installed.

Also, if superseded patches are recommended and included in policies or exception, they are counted
in the compliance calculations, and if they aremissing on the target server, then the server's patch
compliance status will be non-compliant.

Patch compliance levels

Patch compliance levels define your patch compliance rules. Results of a patch compliance scan can
include only policies, both policies and exceptions, or your own customized level.

Windows PatchManagement supports the following compliance levels:

l Policy Only: Verifies whether the patches installed on a server comply with the patch policies.
l Policy and Exception: Verifies whether the patches installed on a server comply with the patch
policies and any exceptions. The Partial icon is displayed if the policy and exception do not agree
and the exception does not have data in the Reason field.

l Customized: Verifies the rules that you edited for this compliance level.

Patch compliance rules

Patch compliance rules are the conditions that determine the compliance icons that are displayed in the
Managed Server window.

Windows PatchManagement supports the following compliance rules:

l Patch Added to Policy: The patch has been added to the patch policy.
l Patch Installed on Server: The patch has been installed on themanaged server.
l Exception Type: The Exception Type can have the following values:

l Always Installed: The patch should be installed on the server, even if the patch is not in the
policy.
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l Never Installed: The patch should not be installed on the server, even if the patch is in the policy.

l None: An exception has not been specified for the patch and server.

l Exception Reason: A description entered in the Exception Reason of the Set Policy Exception
window. In the Patch Compliance Rules window, the Exception Reason can have the following
values.
l Yes: The Exception Reason has data.

l No: The Exception Reason is empty.

l N/A: An exception has not been specified for the patch and server.

l Compliance Result: The icon that indicates the result of the patch compliance scan. These icons are
displayed in theManaged Server window.

Schedule a patch compliance scan

To schedule a patch compliance scan on all Windows managed servers:

1. In the navigation pane, select Administration >Compliance Settings.
2. In the Compliance Settings content pane, in the Patch Compliance Schedule section, click Edit

Settings.
3. In the Schedule Compliance Scan window, select Enable Compliance Scan.
4. From the Schedule drop-down list, select the frequency of the scans.

If you select Custom, specify the crontab string with the following values:
l Minute (0-59)

l Hour (0-23)

l Day of themonth (1-31)

l Month of the year (1-12)

l Day of the week (0-6 with 0=Sunday)

l Any of these fields can contain an asterisk to indicate all possible values. For example, the
following crontab string runs the job at midnight every weekday:

0 0 * * 1-5

The crontab string can also handle serial (1,2,3,4) as well as range (1-5) values. For more
information, consult the crontabman pages on a Unix computer.

5. In theStart Time field, specify the time you want the job to begin.
6. From the Time Zone drop-down list, select a default time zone for the job execution time or accept

the default time zone. The default time shown converts the scheduled time to the time zone set in
your user preferences. If you do not set a preferred time zone, the time zone is derived from the
Server Automation core server, which is typically UTC.

7. Click OK to save your settings.
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Set a patch compliance level

The patch policy compliance level defines your patch compliance level.

To set the patch compliance level:

1. In the navigation pane, select Administration > Compliance Settings.
2. From theCompliance Rules drop-down list, select one of the following compliance levels:

l Policy Only

l Policy and Exception

l Customized

If you select Customized, click Edit Custom to open theEdit Customized Policy Compliance
Level window. To edit the compliance level, click the icon in theCompliance Result column.
Click Apply to save your changes.

Import applicableWindows patch binaries
When you import theWindows patch database from the offlineMicrosoft Catalog or from aWSUS
server in your network, SA only imports the patchmetadata for the available patches.

This enables SA to save disk space, as your managed servers might not require all the patches
imported fromMicrosoft. After importing the patch database fromWSUS or from the wsusscn2.cab
file, run a compliance scan on yourWindows managed servers. Import patch binaries only for the
patches reported as required to remediate non-compliant servers.

Patch binaries contain theMicrosoft update files themselves and are stored together with associated
metadata in the Software Repository (Word). When you import binaries for patches, SA maps the
executables for the selected patchmatadata available under Library > Patches.

Depending on your network infrastructure, you can import Microsoft patches into the SA Patch Library
fromMicrosoft's Offline Patching Catalog or from aWSUS server.

Importing binaries in Offline Catalog patching mode

InOffline Catalogmode, you can download binaries from the SA Client or with the populate-
opsware-update-library script. For information about using the script, see "Downloading the
Microsoft Offline patch catalog from the command line " on page 33.

1. In the navigation pane, select Library>By Type>Patches.
2. Expand theWindows tree and select an OS version.
3. In the content pane, right-click on a patch, select Import Contents and choose:

l From Vendor - to import the patch directly from theMicrosoft website. By default, this points
to the URLwhere the patch executable is available on theMicrosoft website.

l Import from File - to import the patch executable stored locally your local machine.

4. Click Import.
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Importing binaries in WSUS patching mode

SA uses a script to import WSUS patch binaries from the SA Client. This script is available on the
SA Core under /opt/opsware/patch_importer/wsus_importer. To import WSUS patch binaries:

1. In the SA Client, select Administration > Patch Settings.
2. In thePatch Downloads section, make sure theWSUS patchingmode is enabled.
3. On theGeneral page, make sure you areWSUS Web server URL points to the correct WSUS

server in your network.
4. Check your selectedBinaries Import Mode:

l Recommended - imports required patch executables only for those patches that the
WSUS Administrator has specified for your SA servers.

l All - imports required patch executables for all patchmetadata imported fromWSUS. By
default, SA imports metadata only for patches that yourWSUS Administrator marked as
Approved. You can cancel this filter to import Declined andNot Approved patches as well
by "Changing configuration settings for theWSUSWeb service" on page 46.

5. On thePatch Database page, click Import Binaries. This launches theRun Server Script
wizard with the Import WSUS Package Binaries script selected by default.

6. Edit the script options as required and click Start Job.
7. Click Closewhen SA finishes importing the available binaries on your selectedmanaged servers.
SA retrieves patchmetadata from the upstream server where you deployed theWSUS Web service.
TheWSUS administrator is responsible for keeping any downstream servers synchronized with the
upstream server. This ensure you always get the complete and up-to-date list of patch into SA.

Deploy patches/Remediate servers
After running a compliance scan, remediate any necessary servers according to the scan results. If the
Vendor Recommended Patch Policy (VRPP) recommends any patches for a server that are not
included in the imported patches, the compliance scan will show thesemissing patches in a subdued
gray font.

To remediate a patch policy:

1. In the navigation pane, select Library > By Type > Patch Policies.
2. ExpandPatch Policies and select a specific Windows operating system.

The content pane displays all patch policies associated with that operating system.
3. In the content pane, open a patch policy.
4. In theView drop-down list, select Servers.
5. In theShow drop-down list in the content pane, select Servers with Policy Attached.
6. In thePreview pane, select one or more servers.
7. From theActionsmenu, select Remediate.

The first step of theRemediatewindow appears: Servers and Device Groups.
For instructions on each step, see the following sections:
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l "Set reboot options for remediation" on page 57

l "Set reboot options for remediation" on page 57

l "Specify pre-installation and post-installation scripts for remediation" on page 193

l "Schedule a patch installation for remediation" on page 193

l "Set up email notifications for remediation" on page 194

l "Preview and start a remediation" on page 194

After you have completed a step, click Next to advance to the next step. Before you click Start
Job, you can return to a completed step tomake changes by clicking on it in the list of steps.

8. Click Start Job to launch the remediation job.
After you launch the job, you cannot change its parameters, even if the job is scheduled to run at a
later time.

Patch installation for Windows

The patch installation process consists of two phases:

l Download phase - This is when the patch is downloaded from Server Automation to themanaged
server. This phase is commonly referred to as staging.

l Installation phase -This is when the patch is installed on themanaged server. This phase is
commonly referred to as deployment.

You can specify whether you want the installation to occur immediately after the patch is downloaded
(staged) or you can schedule it to occur at a later date and time. Patchmanagement also supports the
need for best-effort installations of multiple patches by allowing you to specify that the patch
installation process will continue even when an error occurs with one of the patches.

SA displays the name of the command that installs the patch. The SA Agent runs this command on the
managed server. You can override the default command-line arguments that you want to perform the
installation.

To optimally manage patch installations, patchmanagement enables you tomanage server reboot
options and pre- and post-installation scripts, simulate (preview) a patch installation, and set up email
notifications to alert you about the status of the installation process. The Install Patch wizard guides
you through the setup.

Install Patch wizard
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Installation flags Windows

You can specify installation flags that are applied whenever aWindows patch is installed. However,
Server Automation also uses default installation flags and requires that patches are installed with these
flags. Therefore, youmust be sure that you do not specify any installation flags that override or
contradict the default flags passed by Server Automation. See"Set install options" on page 75for
information about how to specify commands and flags.

Note:
SomeWindows hotfixes do not support the -z flag, some do not support the -q flag, and some do
not support either. In such cases, youmust use a special expression: /-z or /-q or /-z -q
respectively. This prevents Windows patchmanagement from passing in the -z or -q or -z -q flag.
By default, SA adds /z /q to the command line arguments when installing patches. To override this,
specify /-z /-q. For example, if you prefer to not suppress the reboot, specify /-z.

The following table lists the default installation flags that Server Automation uses.

Windows patch type Flags

Windows Hotfix -q -z

Windows Security Rollup Package
(treated identically like a Hotfix by WIndows patchmanagement)

-q -z

Windows OS Service Pack -u -n -o -q -z

Default installation flags
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Application patches

SA does not allow you to apply a patch to an operating system for which the patch is not intended.
When you are installing an application patch, SA does not automatically filter out servers that do not
have the corresponding application installed. Although SA does not prevent you from doing so, you
should not attempt to apply application patches to servers that do not have the necessary applications
installed. If a patch is for an application that is not installed on the server, the patch will not be applied
and an error message will display, such as “There was an error with package <name of the package>”.

If an application patch is intended for an application that is running onmore than one version of the
same operating system, you cannot apply the patch to all of the servers at the same time. An
application patch is associated with only one operating system version. Youmust first select the patch
for one operating system, select the servers where the application is installed, and apply the patch. You
must repeat this process for each version of the operating system where the application is installed.

Similarly, when uninstalling application patches that are installed onmultiple versions of the same
operating system, you cannot uninstall all of the patches at the same time. Youmust repeat the
uninstallation process for each version of the operating system where the patch is installed.

Install a patch

Before a patch can be installed on amanaged server, it must be imported into Server Automation and
its status must be Available. Administrators who have the required permissions can install patches that
aremarked Limited.

Note: Youmust have a set of permissions tomanage patches. To obtain these permissions,
contact your SA Administrator. See the SA Administration Guide.

You can perform the installation by explicitly selecting patches and servers.

To install a patch on amanaged server:

1. In the navigation pane, select Library and then select Patches.
2. Expand the Patches and select a specific Unix operating system.
3. In the content pane, select a patch.
4. From the View drop-down list, select Servers (orServer Groups).
5. From the Show drop-down list, select Servers without Patch Installed (orServer Groups

without Patch Installed).
6. In the preview pane, select one or more servers.
7. From the Actions menu, select Install Patch.

The first step of the Install Patch window appears: Servers and Server Groups. For instructions on
each step, see the following sections:
l "Set reboot options" on page 232

l "Specify install scripts" on page 232

l "Scheduling a patch uninstallation" on page 239

l "Set up email notifications" on page 234
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l "Preview a patch installation" on page 234

l "View job progress for a patch uninstallation" on page 240

After you have completed a step, click Next to advance to the next step. Before you click Start
Job, you can return to a completed step tomake changes by clicking on it in the list of steps.

8. When you are ready to launch the installation job, click Start Job.
After you launch the job, you cannot change its parameters, even if the job is scheduled to run at a
later time.
If the Install Patch window remains open until the job completes, SA updates the Patch
Compliance column in the All Managed Servers window with the revised compliance count (in
parenthesis) for affected servers. Press F5 or select Refresh from the View menu to update
information in the patch preview pane.

Set install options

You can specify the following types of patch installation options:

l Perform the patch installation immediately after the patch is downloaded or at a later date and time.
l Do not interrupt the patch installation process even when an error occurs with one of the patches.
l Use different command-line options to perform the installation.
To set these options:

1. In the Install Patch window, click Next to advance to the Install Options step.
2. Select one of the following Staged Install Options:

l Continuous: This allows you to run all phases as an uninterrupted operation.

l Staged: This allows you to schedule the download and installation to run separately

3. Select the Error Options check box if you want the patch installation process to continue even
when an error occurs with one of the patches. As a default, this check box is not selected.

4. In the Install Command text box, enter command-line arguments for the command that is
displayed.

5. Click Next to go to the next step or click Cancel to close the Install Patch window.

Set reboot options for aWindows patch installation

Tominimize the downtime that server reboots can cause, you can control when servers will and will not
be rebooted. You can adopt the vendor’s reboot assignments, reboot a server each time a patch is
installed on it, completely suppress all server reboots, or postpone reboots until all patches have been
installed.

Note:When you are selecting reboot options in the Install Patch window, HP recommends that
you useMicrosoft’s reboot recommendations, which is the Reboot servers as specified by
individual software items option. If it is not possible to use theMicrosoft reboot setting, select the
single reboot option, which is the Hold all server reboots until after all packages are installed and/or
uninstalled option. Failure to do this can result inWUA incorrectly reporting the patches that are
installed on the server until the next reboot occurs (outside of SA control).
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The following options determine whether the servers are rebooted after the patch is installed. These
options apply only to the job launched by the Install Patch window; they do not change the Reboot
Required that is in the Install Parameters tab of the Patch Properties window.

Note: If a server has a state of Reboot Pending, a subsequent install patch actionmay fail. Before
performing any subsequent patch installation actions on the server, youmust first reboot the
server. See "Find servers that require a reboot" on page 92.

Except for the first option, the following options override the Reboot Required option.

l Reboot servers as specified by individual software items(Default): By default, the decision to
reboot depends on the Reboot Required option of the patch properties.

l Reboot servers after each patch install: Even if the Reboot Required option of the patch properties is
not set, reboot the server. If multiple patches are installed, the server reboots multiple times.

l Suppress all server reboots: Even if the Reboot Required option of the patch properties is set, do not
reboot the server. Because of vendor settings, some patches ignore the suppress option and force a
reboot. For a service pack, if a reboot is suppressed, then the action is incomplete—the service
pack is not installed until after the reboot. The system does not have the software installed. The
status is “Not Installed/Uninstalled”. If youmanually check the system (look at the registry or server
properties), this is not the same information that displays in the SA Client. After the reboot, the SA
Client will not reflect the correct software or patch installed information until after the next software
registration.

Note: : When you suppress reboot during aWindows patch installation (such as for a service
pack), the system's software statemight not accurately display. Accurate state information will
display after themanaged server is rebooted and software registration has completed.

l Hold all server reboots until after all packages are installed and/or uninstalled: If the Reboot
Required option is set for some selected patches but not for others, the server is rebooted one time
after all patches are installed. This option is commonly known as the single reboot option. If the
Reboot Required option is not set for any of the selected patches, the server is not rebooted.

To set reboot options:

1. From the Install Patch window, click Next to advance to the Pre and Post Actions step.
2. Select one of the Rebooting Options.
3. Click Next to go to the next step or click Cancel to close the Install Patch window.

Specify install scripts

For each patch, you can specify a command or script to run before installation or after installation. A
pre-install script, for example, could check a certain condition on themanaged server. If the condition is
not met or if the pre-install script fails, the patch would not be installed. A pre-install script could also be
used to shut down a service or application before it is patched. A post-install script could be used to
perform a certain cleanup process on themanaged server.

You can also specify the following types of scripts to run on themanaged server before or after an
installation or download phase:

l Pre-download: A script that runs before patches are downloaded from SA to themanaged server.
This is available only if you select Staged in the Install Options step.
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l Post-download: A script that runs after patches are downloaded from SA to themanaged server and
before the patch is installed. This is available only if you select Staged in the Install Options step.

l Pre-install: A script that runs before patches are installed on themanaged server.
l Post-install: A script that runs after patches are installed on themanaged server.
To specify a pre-install script:

1. In the Install Patch window, click Next to advance to the Pre & Post Actions step.
2. Select thePre-Install tab. Youmay specify different scripts and options on each of the tabs.
3. Select Enable Script. This option enables the remainder of the fields on the tab. If Enable Script

is not selected, the script will not run.
4. Select eitherSaved Script orAd-Hoc Script.

A Saved Script has been previously stored in Server Automation with the SA Client. To specify
the script, click Select.

5. If the script requires command-line flags, enter the flags in the Command text box.
6. Specify the information in the RuntimeOptions. If you choose a user account other than root, enter

the User Name and Password. The script will be run by this user on themanaged server.
7. To stop the installation if the script returns an error, select theError check box.
8. Click Next to go to the next step or click Cancel to close the Install Patch window.

Schedule aWindows patch installation

Since the two phases of Windows patching can be decoupled, you can schedule when you want
patches installed independently of when you want patches downloaded.

To schedule a patch installation:

1. From the Install Patch window, click Next to advance to the Scheduling step.
By default, the Scheduling step displays only the scheduling options for the installation phase. If
you selected Staged in the Install Options step, the scheduling options for the download phase will
also be displayed.

2. Select one of the following Install Phase options:
l Run Task Immediately: This enables the system to perform a preview analysis in the Summary
Review step. The scheduling option for the download phase is Run Immediately Following
Download.

l Run Task At: This enables you to specify a later date and time that you want the installation or
download performed.

3. Click Next to go to the next step or click Cancel to close the Install Patch window.

Note:
A scheduled patch installation can be cancelled prior to its execution, even if the patch download
has already completed.

l "Set install options" on page 75
l "Set reboot options for aWindows patch installation" on page 88
l "Schedule aWindows patch installation" above
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l "Set up email notifications for aWindows patch installation" below
l "Preview aWindows patch installation" below
l "View job progress of aWindows patch installation" on the next page

Set up email notifications for aWindows patch installation

You can set up email notifications to alert users when the download and installation operations
complete successfully or with errors.

To set up email notifications:

1. From the Install Patch window, click Next to advance to the Notifications step.
2. To add email addresses, click Add Notifier and enter the email addresses in the Notification Email

Address field.

3. To set the notification status on the success of a Job, select the icon. To set the

notification status on the failure of a Job, select the icon. By default, the Notification step
displays only the notification status for the installation phase.

4. Enter a Ticket ID to be associated with a Job in the Ticket ID field.
5. Click Next to go to the next step or click Cancel to close the Install Patch window.

Note:
If you previously selected Staged in the Install Options step, the Notifications pane displays
notification options for both the download and installation phases.

l "Set install options" on page 75
l "Set reboot options for aWindows patch installation" on page 88
l "Schedule aWindows patch installation" on the previous page
l "Set up email notifications for aWindows patch installation" above
l "Preview aWindows patch installation" below
l "View job progress of aWindows patch installation" on the next page

Preview aWindows patch installation

The installation preview process provides an up-to-date report about the patch state of servers. The
installation preview is an optional step that lets you see the patches that will be installed onmanaged
servers and the type of server reboots that are required. This preview process verifies whether the
servers that you selected for the patch installation already have that patch installed, based onWUA. In
some cases, a server could already have the patch installed if a system administrator hadmanually
installed it, whichmeans that Windows PatchManagement does not know about it.

The preview process also reports on dependency and supersedence information, such as patches that
require certainWindows products, and patches that supersede other patches or are superseded by
other patches. If a dependency is not met, PatchManagement will display an error message indicating
this condition.

The following list explains user cases in which a patch will not be installed, as displayed in the Preview
step of the Install Patch or Remediate PatchWindow:
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l This patch has a Never Install patch policy exception, so it will not be installed.
l This patch is superseded by another patch in the same job, so it will not be installed. This means
that another patch in the current job is more up to date than themarked patch.

l This patch is superseded by another patch, so it will not be installed. This means that the patch
installed on the server is more recent than the patch in the policy, so it will not be installed.

l This patch is not applicable because it is not recommended by WUA, so it will not be installed.
l This patch is for a different locale, so it will not be installed.
This information is also displayed in the Job results window and in an email, if email notification has
been configured for the patch install job.

Note: The installation preview does not report on the behavior of the server as though the patches
have been applied.

To preview a patch installation:

1. From the Install Patch window, click Next to advance to the Summary Review step.
2. (Optional) Click Preview to see the separate actions that will be performed when the patch is

installed. To view the details of a previewed action, select a row in the table.
3. Click Start Jobto launch the installation job or click Cancel to close the Install Patch window

without launching the installation.
If you selected Run Task Immediately in the Scheduling step, the job begins now. If you selected Run
Task At, the job will be launched at the specified time and date.

View job progress of aWindows patch installation

You can review progress information about a patch installation job, such as whether actions have
completed or failed.

To display job progress information:

1. From the Install Patch window, click Next to advance to the Job Progress step. This will start the
installation job.
The Progress bar and text indicate how many of the actions listed in the table have been
completed. For each server, the following actions can be performed:
l Analyze: Server Automation examines the patches needed for the installation, checks the
managed servers for themost recent patches installed, and determines other actions that it
must perform.

l Download: The patch is downloaded from Server Automation to themanaged server.

l Install: After it is downloaded, the patch is installed.

l Final Reboot: If this action is specified in the Pre & Post Actions step, the server is rebooted.

l Pre/Post Install/Download Script: If this action is specified in the Pre & Post Actions step, a
script is run before or after the installation.

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 79 of 307



l Install & Reboot: When a patch is installed, the server is also rebooted.

l Verify: Installed patches will be included in the software registration.

2. To view additional details about a specific action, select the row in the table to display the start
and completion times of the job. In the navigation pane, select Jobs and Sessions to review
detailed information about the job. See the SA User Guide for more information about browsing job
logs.
When a Vendor Recommended Patch Policy is remediated on aWindows managed server,
depending on what patches were applied, the server may require an additional remediation. This
can occur when the remediation installs a patch that requires subsequent vendor updates.

3. Click Close to close the Install Patch window or click End Job to prevent the job from running.

Check for patch updates
Microsoft releases updates forWindows products regularly. New patches are immediately available in
WSUS and also included in theWindows Update offline scan file every Patch Tuesday. Tomake new
Windows patches available in SA:

l inOffline Catalog patchingmode - reimport the wsusscn2.cab file
l inWSUS patchingmode - reimport patchmetadata and patch binaries
The following figure illustrate the patch update phases and their required steps:

Patch management administration

View patch information
To view detailed information (properties) about a patch:
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1. In the navigation pane, select Library > By Type > Patches.
2. Expand Patches and select a specific operating system.

The content pane displays all patches associated with that operating system.
3. In the content pane, open a patch to view its properties in the Patch window.

Note:
Press F1 to display descriptions of the fields displayed in the Patch Properties window.

Patch dependencies and supersedence
Patchmetadata identifies all known dependency and supersedence relationships between patches and
Windows products, and between patches and other patches.

In Server Automation:

l Dependency relationships identify Windows products that must already exist on a server before you
can install a certain patch.

l Supersedence relationships identify patches that supersede or are superseded by other patches. In
Windows PatchManagement, supersedes means that one patch replaces another and superseded
by means that the patch you are installing is replaced by another patch.

In Server Automation, Windows patchmanagement does not detect whether two patches aremutually
exclusive—which is when either one can be installed but not both. Subsequently, PatchManagement
does not prevent you from installing both patches on a server. This means that youmay be able to
install both a superseded patch and a superseding patch on a server.

Supersedence relationships in WSUS patching mode

SA may not always mirror exactly theWSUS hierarchy of patch supersedence. This is because, by
default, SA only imports approved patches. If yourWSUS administrator declines a patch involved in a
supersedence relationship, this patch does not show up in SA. Consequently, supersedence details
related to non-imported patches are ignored.

Skipping superseded patches

The following patchman parameters allow SA to be configured to skip the import of superseded
patches.

l patchman.ms_mbsa20_skip_import_superseded: Skip import of superseded patches
l patchman.ms_mbsa20_skip_import_superseded_overrides: To be used if you need specific
patches imported even if they are superseded by other patches

ViewWindows patches
The SA Client displays information about Microsoft Windows patches that have been imported into
Server Automation.

To view information about a patch:
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1. In the navigation pane, select Library > By Type > Patches.
2. Expand Patches and select a specific Windows operating system.

The content pane displays all patches listed in theMicrosoft Patch Database for theWindows
operating system that you selected.

3. (Optional) Use the column selector to sort the patches according to Name, Type, Severity,
Availability, Release Date, and Bulletin Number.

4. In the content pane, open a patch to view its properties in the Patch window.

EditWindows patch properties
You can edit the Description, Availability, Install Parameters, and Uninstall parameters of a patch.

The Availability property indicates the status of the patch in Server Automation. If the Availability is Not
Imported, you cannot change this property.

You can set the install and uninstall parameters on either the patch properties page or in the Patch
Actions only when you are installing or uninstalling one patch at a time. The parameters on the
properties page are saved in theModel Repository, but the parameters in Patch Actions are used only
for that action. The parameters in Patch Actions override those on the patch properties page.

To edit the patch properties:

1. In the navigation pane, select Library > By Type > Patches.
2. Expand Patches and select a specific Windows operating system.

The content pane displays all patches associated with that operating system.
3. In the content pane, open a patch to view its properties in the Patch window.
4. Edit any of the following fields: Description, Availability, and the Install and Uninstall parameters.
5. From the File menu, select Save to save your changes.

Import customdocumentation for a patch
The Custom Documentation view of a patch displays text files that have been imported from the local
file system. Non-plain text file types, such as .html or .doc, are not supported.

To import your own documentation for a patch:

1. In the navigation pane, select Library > By Type > Patches.
2. Expand Patches and select a specific Windows operating system.

The content pane displays all patches associated with that operating system.
3. In the content pane, open a patch to view its properties in the Patch window.
4. In the Views pane, select Custom Documentation.
5. From the Actions menu, select Import.
6. In the Import Custom Documentation window, locate a text file and specify encoding.
7. Click Import.
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Delete customdocumentation for a patch
The Custom Documentation view of a patch displays text files that have been imported from the local
file system. Non-plain text file types, such as .html or .doc, are not supported.

To delete custom documentation for a patch:

1. In the navigation pane, select Library > By Type > Patches.
2. Expand Patches and select a specific Windows operating system.

The content pane displays all patches associated with that operating system.
3. In the content pane, open a patch to view its properties in the Patch window.
4. In the Views pane, select Custom Documentation.
5. From the Actions menu, select Delete.
6. In the Delete Custom Documentation window, click Delete.

Find vendor-recommended Windows patches
To find patches that Microsoft recommends for a particular server, based onWindows Update Agent
(WUA):

1. In the navigation pane, select Devices > Servers > All Managed Servers.
2. In the content pane, select Patchesfrom theView drop-down list.
3. Select a server that is running a supportedWindows server.
4. In the details pane, select Patches Recommended By Vendor from the drop-down list to display

the types of patches for the selected server.

Find servers that haveWindows patch installed
To find servers that have a particular patch installed:

1. In the navigation pane, select Library > By Type > Patches.
2. Expand Patches and select a specific Windows operating system.

The content pane displays all patches associated with that operating system.
3. In the content pane, select a patch.
4. From the View drop-down list in the content pane, select Servers.
5. From the Show drop-down list for the selected patch, select Servers with Patch Installed.

You can browse a server in this list to view a list of all installed patches. Notice that this list might
display amore complete list of installed patches than the list you will find in theWindows Add or
Remove Programs utility.

Find servers that do not haveWindows patch installed
To find servers that do not have a particular patch installed:
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1. In the navigation pane, select Library > Patches.
2. Expand Patches and select a specific Windows operating system.

The content pane displays all patches associated with that operating system.
3. In the content pane, select a patch.
4. In the View drop-down list, select Servers.
5. In the Show drop-down list, select Serverswithout Patch Installed.

Export aWindows patch
To export a patch from Server Automation to a local file system:

1. In the navigation pane, select Library > By Type > Patches.
2. Expand Patches and select a specific Windows operating system.

The content pane displays all patches associated with that operating system.
3. In the content pane, select a patch.
4. From the Actions menu, select Export.
5. In the Export Patch window, enter the folder name that will contain the patch file in the File Name

field.
6. Click Export.

Enable/disableWindows Server 2008 Itanium (IA64) patches
Starting in 9.14, SA Windows Patching does not import Itanium (IA64) patches by default. However, a
script is available to enable importingWindows Server IA64 patches.

Previously, Itanium patches were imported by default when theWindows Server 2008 R2 patch
product was selected. In SA 9.14 and later, Itanium patches are not imported by default. The default
setting was changed to reduce the patch import footprint, saving storage space and download time, for
the customers who do not need Itanium patches.

About the enable-itanium-patches script:

l Location: /opt/opsware/mm_wordbot/util/enable-itanium-patches
l Usage: enable-itanium-patches enable|disable
To enable importing of Windows Server IA64 patches:

1. Log in it the SA Core as root.
2. Run the enable-itanium-patches script:

/opt/opsware/mm_wordbot/util/enable_itanium_patches enable

To disable importing of Windows Server IA64 patches:

1. Log in it the SA Core as root.
2. Run the enable-itanium-patches script:

/opt/opsware/mm_wordbot/util/enable_itanium_patches disable

To view the current setting:
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1. Log in to the SA Client as an administrator with Opsware System Administrators privileges.

Note: SA configuration parameters are accessible only through the SA Client. Only system
administrators with the Opsware System Administrators user group permission can change these
settings.

2. Navigate to the SA Software Repository system settings: Administration > System
configuration > Software Repository.

The patchman.ms_mbsa20_import_architecturessetting will indicate enabled or disabled.

l ['x86', 'x64'] is the default
l ['x86', 'x64', 'ia64' ] indicates that Itanium patches are enabled

Note: Do not change this setting from this view; use the script instead. Only use this view to verify
the current setting. Changes to certain SA Core configuration parameter values, as listed in this
document, are verified by HP and you can safely apply them as directed. However, exercise
caution whenmodifying any default SA Core configuration parameter values as modifications can
have a negative effect on core functionality and performance.

ExportWindows patch information
You can export information about patches installed on an SA managed server and patches
recommended by the vendor. You can also export information from patches recommended by the
vendor along with model information on the selected server, such as patch policies or patch policy
exceptions. The following information is exported into a .csv file:

l ServerName: The name of themanaged server.
l OS: The operating system of the server.
l Service Pack: The service pack level of the server being reported, such as Service Pack 3, Service
Pack 4, and so on.

l KB#: TheMicrosoft Knowledge Base Article number for the patch.
l Bulletin: TheMSYY-XXX ID associated with a hotfix, such as MS05-012, MS06-012, and so on. If
theMSYY-XXX ID is unknown, this columnwill be blank.

l Description: A brief description of the purpose of the patch.
l TimeQueried: The last software registration by the Agent.
l Time Installed: The time that the patch was installed.
l Type: The patch type.
l Compliance Level: An integer that represents the compliance level.
l Compliance: Text that displays when you place your cursor over the Compliance column in the
Patch preview pane.

l Exception Type: The type of exception, such as Always Install or Never Install.
l Exception Reason: A description that explains the purpose of the exception.
Windows patchmanagement will display all of the text, including commas, from the Description field
displayed in the Patch Properties window in the Description column in the .csv file. To ensure that all of
the text about a patch displays in the Description field in the .csv file, PatchManagement surrounds the
entire description (that you see in the Patch Properties window) with double quotes.
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To export the patch information to a .csv file:

1. In the navigation pane, select Devices > All Managed Servers.
2. In the content pane, select one or moremanaged servers.
3. From the Show drop-down list, select an option.
4. From the Actions menu, select Export Patch Info to CSV.
5. In the Export to CSV window, navigate to a folder and enter the file name.
6. Verify that the file type is CommaSeparated Value Files (.csv).

If you did not include the .csv extension in the file name field, SA will append it only if you have the
.csv file type selected.

7. Click Export to save the patch information in a .csv file or click Cancel if you do not want to
export the patch information.

Patch uninstallation
PatchManagement provides granular control over how and under what conditions patches are
uninstalled (removed) frommanaged servers. Tominimize problems, you can only uninstall one patch
at a time. You cannot use Server Automation to uninstall a patch that was not originally installed using
Server Automation.

To help you optimally manage these conditions, PatchManagement allows you to do the following:

l Manage server reboot options, and pre and post installation scripts.
l Simulate (preview) a patch uninstallation.
l Set up email notifications to alert you about the status of the uninstallation process.
The Uninstall Patch wizard steps you through setting up these conditions.

Uninstallation flags

You can specify uninstallation flags that are applied whenever aWindows patch is uninstalled.
However, SA also uses default uninstallation flags and requires that patches are uninstalled with these
flags. Youmust therefore be certain that you do not specify any uninstallation flags that override or
contradict the default flags passed by Server Automation.

SomeWindows hotfixes do not support the -z flag, some do not support the -q flag, and some do not
support either. In such cases, youmust use a special expression: /-z or /-q or /-z -q respectively, to
prevent Server Automation from passing in the -z or -q or -z -q flag. By default, Server Automation adds
/z /q to the command line arguments when uninstalling patches. To override this, specify /-z /-q. For
example, if you prefer to not suppress the reboot, specify /-z.

The following table lists the default uninstallation flags used in SA.

Windows patch types Flags

Windows Hotfix -q -z

Security Rollup Package -q -z

Default uninstallation flags
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Windows patch types Flags

Windows OS Service Pack Not uninstallable

Default uninstallation flags, continued

Uninstall a Windows patch

You can uninstall a Service Pack if it was originally installed by SA and can be uninstalled from the
control panel, directly from the server. If the Service Pack cannot be uninstalled by the control panel,
then SA cannot uninstall it either.

To remove a patch from amanaged server:

1. In the navigation pane, select Library >By Type >Patches.
2. Expand the Patches and select a specific Windows operating system.
3. In the content pane, select a patch.
4. From the View drop-down list, select Servers.
5. From the Show drop-down list, select Servers with Patch Installed.
6. In the preview pane, select one or more servers.
7. From the Actions menu, select Uninstall Patch. The first step (Servers) in the Uninstall Patch

window appears.
For instructions on each step, see the following sections:
l "Set uninstall options" on page 237

l "Set reboot options for aWindows patch installation" on the next page

l "Specify install scripts for aWindows patch uninstallation" on page 89

l "Schedule aWindows patch uninstallation" on page 90

l "Set up email notifications for aWindows patch uninstallation" on page 90

l "View job progress of a patch uninstallation" on page 91

After you have completed a step, click Next to advance to the next step. Before you click Start
Job, you can return to a completed step tomake changes by clicking on it in the list of steps.

8. When you are ready to launch the uninstallation job, click Start Job.
After you launch the job, you cannot change its parameters, even if the job is scheduled to run at a
later time.
If the Uninstall Patch window remains open until the job completes, PatchManagement updates
the Patch Compliance column in the All Managed Servers window with the revised compliance
count (in parenthesis) for affected servers. Press F5 or select Refresh from the View menu to
update information in the Patch preview pane.

Set uninstall options

You can specify the following types of patch uninstallation options:
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l Do not interrupt the patch uninstallation process even when an error occurs with one of the patches.
l Use different command-line options to perform the uninstallation.
To set these options:

1. From the Uninstall Patch window, click Next to advance to the Uninstall Options step.
2. Select theError Options check box if you want the patch installation process to continue even

when an error occurs with one of the patches. As a default, this check box is not selected.
3. In the Uninstall Command text box, enter command-line arguments for the command (.exe file)

that is displayed. By default, Server Automation adds /z /q. If you want to override these uninstall
flags, enter /-z /-q in the text box.

4. Click Next to go to the next step or click Cancel to close the Uninstall Patch window.

Set reboot options for a Windows patch installation

Tominimize the downtime that server reboots can cause, you can control when servers will and will not
be rebooted. You can adopt the vendor’s reboot assignments, reboot a server each time a patch is
installed on it, completely suppress all server reboots, or postpone reboots until all patches have been
installed.

Note:When you are selecting reboot options in the Install Patch window, HP recommends that
you useMicrosoft’s reboot recommendations, which is the Reboot servers as specified by
individual software items option. If it is not possible to use theMicrosoft reboot setting, select the
single reboot option, which is the Hold all server reboots until after all packages are installed and/or
uninstalled option. Failure to do this can result inWUA incorrectly reporting the patches that are
installed on the server until the next reboot occurs (outside of SA control).

The following options determine whether the servers are rebooted after the patch is installed. These
options apply only to the job launched by the Install Patch window; they do not change the Reboot
Required that is in the Install Parameters tab of the Patch Properties window.

Note: If a server has a state of Reboot Pending, a subsequent install patch actionmay fail. Before
performing any subsequent patch installation actions on the server, youmust first reboot the
server. See "Find servers that require a reboot" on page 92.

Except for the first option, the following options override the Reboot Required option.

l Reboot servers as specified by individual software items (Default): By default, the decision to
reboot depends on the Reboot Required option of the patch properties.

l Reboot servers after each patch install: Even if the Reboot Required option of the patch
properties is not set, reboot the server. If multiple patches are installed, the server reboots multiple
times.

l Suppress all server reboots: Even if the Reboot Required option of the patch properties is set, do
not reboot the server. Because of vendor settings, some patches ignore the suppress option and
force a reboot. For a service pack, if a reboot is suppressed, then the action is incomplete—the
service pack is not installed until after the reboot. The system does not have the software installed.
The status is “Not Installed/Uninstalled”. If youmanually check the system (look at the registry or
server properties), this is not the same information that displays in the SA Client. After the reboot,
the SA Client will not reflect the correct software or patch installed information until after the next

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 88 of 307



software registration.

Note: : When you suppress reboot during aWindows patch installation (such as for a service
pack), the system's software statemight not accurately display. Accurate state information will
display after themanaged server is rebooted and software registration has completed.

l Hold all server reboots until after all packages are installed and/or uninstalled: If the Reboot
Required option is set for some selected patches but not for others, the server is rebooted one time
after all patches are installed. This option is commonly known as the single reboot option. If the
Reboot Required option is not set for any of the selected patches, the server is not rebooted.

To set reboot options:

1. From the Install Patch window, click Next to advance to the Pre and Post Actions step.
2. Select one of the Rebooting Options.
3. Click Next to go to the next step or click Cancel to close the Install Patch window.

Specify install scripts for a Windows patch uninstallation

For each patch, you can specify a command or script to run before uninstallation or after uninstallation.
A pre-uninstall script, for example, could check a certain condition on themanaged server. If the
condition is not met or if the pre-uninstall script fails, the patch would not be removed from a server. A
pre-uninstall script could also be used to shut down a service or application before it is removed from a
server. A post-uninstall script could be used to perform a certain cleanup process on themanaged
server.

You can specify the following types of scripts to run on themanaged server before or after a patch
uninstallation:

l Pre-Uninstall: A script that runs before the patch is removed from amanaged server.
l Post-Uninstall: A script that runs after the patch is removed from amanaged server.
To specify a script:

1. From the Uninstall Patch window, click Next to advance to the Pre & Post Actions step.
2. Select thePre-Uninstall orPost-Uninstall tab.

Youmay specify different scripts and options on each of the tabs.
3. Select Enable Script.

This option enables the remainder of the fields on the tab. If Enable Script is not selected, the
script will not run.

4. Select eitherSaved Script orAd-Hoc Script.
A Saved Script has been previously stored in Server Automation with the SA Client. To specify
the script, click Select.
An Ad-Hoc script runs only for this operation and is not saved in Server Automation. Select the
Type, such as .bat. In the Script box, enter the contents of the script, including the drive letter of
where the script is located, such as echo dir>> C:\temp\preinstall1.log. If you do not enter
a drive letter, the default is %SYSTEMDRIVE%, which is where the system folder of Windows is
installed.

5. If the script requires command-line flags, enter the flags in Commands.
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6. Specify the information in the User section. The script will be run by this user on themanaged
server.

7. To stop the uninstallation if the script returns an error, select Error.

Schedule a Windows patch uninstallation

You can remove a patch from a server immediately, or at a later date and time.

To schedule a patch uninstallation:

1. From the Uninstall Patch window, click Next to advance to the Scheduling step.
Select one of the following Install Phase options:
l Run Task Immediately: This enables you to perform the uninstallation in the Summary
Review step.

l Run Task At: This enables you to specify a later date and time that you want the uninstallation
performed.

Click Next to go to the next step or click Cancel to close the Uninstall Patch window.

Set up email notifications for a Windows patch uninstallation

You can set up email notifications to alert users when the patch uninstallation operation completes
successfully or with errors.

To set up email notifications:

1. From the Uninstall Patch window, click Next to advance to the Notifications step.
2. To add email addresses, click Add Notifier and enter the email addresses in the Notification Email

Address field.

3. To set the notification status on the success of a Job, select the icon. To set the

notification status on the failure of a Job, select the icon. By default, the Notification step
displays only the notification status for the uninstallation phase.

4. Enter a Ticket ID to be associated with a Job in the Ticket ID field.
5. Click Next to go to the next step or click Cancel to close the Uninstall Patch window.

Preview and starting a Windows patch uninstallation

The uninstallation preview process provides an up-to-date report about the patch state of servers. The
uninstallation preview is an optional step that lets you see the patches that will be removed from
managed servers. This preview process verifies whether the servers you selected for the patch
uninstallation have that patch installed, based on the imported patch database.

Note: The uninstallation preview process does not report or simulate the behavior of a system with
patches removed from the server.

To preview a patch uninstallation:
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1. From the Uninstall Patch window, click Next to advance to the Summary Review step.
2. Verify the information displayed for the Servers, Device Groups, and Patches at the top of the

window.
3. (Optional) Click Preview to see the separate actions that will be performed when the patch is

uninstalled. To view the details of a previewed action, select a row in the table.
4. Click Start Job to launch the job or click Cancel to close the Uninstall Patch window without

launching the uninstallation.
If you selectedRun Task Immediately in the Scheduling step, the job begins now. If you
selectedRun Task At, the job will be launched at the specified time and date.

View job progress of a patch uninstallation

You can review progress information about a patch uninstallation job, such as whether actions have
completed or failed.

To display job progress information:

1. From the Uninstall Patch window, click Next to advance to the Job Progress step. The Progress
bar and text indicate how many of the actions listed in the table have been completed. For each
server, the following actions can be performed:
l Analyze: Server Automation examines the patches needed for the uninstallation, checks the
managed servers for themost recent patches installed, and determines other actions it must
perform.

l Uninstall: The patch is uninstalled.

l Final Reboot: If this action is specified in the Pre & Post Actions step, the server is rebooted.

l Pre/Post Uninstall Script: If this action is specified in the Pre & Post Actions step, a script is
run before or after the uninstallation.

l Uninstall & Reboot: When a patch is installed, the server is also rebooted.

l Verify: Installed patches will be included in the software registration.

2. To view additional details about a specific action, select the row in the table to display the start
and completion times of the job. In the navigation pane, select Jobs and Sessions to review
detailed information about the job. See the SA User Guide for more information on browsing job
logs.

3. Click End Job to prevent the job from running or click Close to close the Uninstall Patch window.
(Optional) See "Cancelling or Terminating Installation, Uninstallation or Remediation Jobs" in the
SA Administration Guide.

Note: Some secondary binaries may fail to uninstall because prior binaries already uninstalled the
same components; somemay fail because they were non-installing components originally, such
as a script that edits the registry. In these cases, a File Not Found error may appear. To verify the
uninstall, run a compliance scan.
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Searching for patches and patch policies
In the SA Client, you can search for information about your operational environment by using the SA
Client Search feature. TheSearch feature enables you to search for patches, patch policies, servers,
and so on. See “SA Client Search” in the SA User Guide.

Find servers that require a reboot
The following are typical use cases where a Reboot Pending server state occurs:

l When aWindows patch or package is installed or uninstalled and a reboot is not performed, the
server is marked as needing a reboot.

l When aWindows package is installed or uninstalled and the SA metadata for the package indicates
that a reboot is required, but no reboot is performed, the server is marked as needing a reboot.

Note:
When a server has a state of Reboot Pending, a subsequent install or uninstall patch actionmight
fail. Before performing any subsequent patch install or uninstall actions on the server or group of
servers (device group), youmust first reboot the server.

In SA, you can easily determine whether an individual managed server requires a reboot by reviewing
its properties or by filtering the list of managed servers. You can also use the SA Client Search feature
to find all managed servers and device groups in your data center that require a reboot.

Reboot required for a single managed server

Review themanaged server’s properties to determine whether it requires a reboot.

To find this information:

1. In theAll Managed Servers pane, select a server and then select Properties in the View drop-
down list.

2. In the bottom Properties pane, review theReboot Required field. A Yes valuemeans that this
server requires a reboot.

3. With the server selected, right-click and then select Reboot Server to manually reboot or
schedule a reboot for the server, using theReboot Server wizard. See "Rebooting a Server" in
the SA User Guide.

Reboot required for all managed servers

You can easily filter the All Managed Servers pane to determine which servers require a reboot.

To find this information:

1. In theAll Managed Servers pane, use the search tool to select Reboot Required.
2. A Yes value in theReboot Required columnmeans that this server requires a reboot.

Use the column selector to make sure you have this column set to show.
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3. With one or more servers selected, right-click and then select Reboot Server to manually reboot
or schedule a reboot for the server(s), using the Reboot Server wizard. See "Rebooting a Server"
in the SA User Guide.

Reboot required for multiple servers and device groups

Use the SA Client Search feature to find all servers that have had a patch or package installed, that
require a reboot. This information allows you to schedule reboots for these servers and device groups.

To find servers and device groups that require a reboot:

1. In theAdvanced Searchwindow, in theWhere field, select Reboot Required.
2. KeepEquals as the default operator.
3. In theSelect Values dialog, inAvailable, select Yes and click the plus (+) arrow tomove this

setting to Selected.
4. Click OK to save your Select Values settings.
5. In theAdvanced Searchwindow, click Search to display a list of servers that require a reboot.

For each server in this list, theReboot Required column displays Yes.
6. Select one or more servers in this list.
7. Right-click and then select Reboot Server to manually reboot or schedule a reboot for one or more

servers or device groups, using theReboot Serverwizard. See "Rebooting a Server" in the SA
User Guide.

Change the SA patching mode
Depending on your network infrastructure, you can choose to import theWindows patching database
into SA either from aWSUS server or from the offline catalog of Microsoft patches.

Unlike theOffline Catalogmode,WSUS patching requires access only to theWSUS server on your
network from where it can retrieve both security and non-security updates.

To change your current patchingmode:

1. Go toAdministration > Patch settings and enable either theOffline Catalog or theWSUS
option.

2. Run a new metadata import to tag all patches in the database with the new patch source. This
enables SA to update the patch library and use the right source when importing the binaries for
existing patches.

Disconnect SAmanaged servers fromWSUS
If you are no longer using aWSUS infrastructure for patching your SA Windows servers, disconnect
these servers fromWSUS before switching SA toOffline Catalog patchingmode.

This ensures that your SA managed servers are no longer visible on theWSUS side and removes any
WSUS information from theirWindows registries.

To disconnect SA managed servers fromWSUS:
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1. Go toDevices > Servers > All Managed Servers and right-click on the server that you want to
disconnect fromWSUS.

2. Select Run Script > Select Script and browse forConfigure Server With Offline Catalog from
the list of saved scripts. This launches theConfigure Server With Offline Catalog.bat script file
from Library > By Folder > Opsware > Tools > Patching.

3. Click Next on theRun Scriptwizard and specify any custom script options before starting the
job.

TroubleshootWSUS errors
These troubleshooting topics detail the possible errors youmight encounter when working in
WSUS patchingmode.

To fix these issues, review theSolution section of each troubleshooting topic and check the list of
known issues in the SA Release Notes.

"Cannot install or unistall software inWSUS mode" below

"Mesh conflicts after importing patches" on the next page

"Vendor patch key error when importingmetadata" on the next page

Cannot install or unistall software in WSUSmode

Symptoms

Running any patch or softwaremanagement job on SA managed servers fails with the following error
message:

The operation to install or uninstall software failed.Execution error:

[...]

OpswareError:

been_cascaded: 0

error_id: None

error_name: cogbot.WUAerror

faultCode: 101

faultString: cogbot.WUAerror

hostname: dimsum33

line: 1696

method: searchCatalog

module: nt_patch_lib.py

params: {'message': 'WUA searchCatalog error, db path :None'}

request: UNKNOWN

[...]
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Causes

Yourmanaged servers are not connected to theWSUS server although the SA core is set to
WSUS patchingmode.

Solution

See "Connecting SA managed servers toWSUS" on page 44.

Mesh conflicts after importing patches

Symptoms

After importing patchmetadata inWSUS patchingmode, SA shows a list of mesh conflicts in the
Conflict view.

Cause

You have enabledWSUS patchingmode on a core while another core in the SA mesh is trying to import
patches from theOffline Catalog.

SA cannot synchronize incompatible patching actions across the cores of amesh.

Solution

1. Make sure that all your mesh cores are set to the same patchingmode.
2. Check any scheduled cron jobs tomake sure you are not running the populate-opsware-update-

library script while theWSUS patchingmode is enabled on a core.
3. Resolve all the reportedmesh conflicts.

Vendor patch key error when importing metadata

Symptom

SA shows the following error message when importing patchmetadata fromWSUS:

"Vendor patch key x is not unique. Remove patches [x, x] associated with this VPK and reimport the
patchmetadata"

Cause

TheWSUS patchmetadata importer is trying to import a patch which has more than one duplicate in
the SA Patch Library. These duplicates have been previously imported from theMicrosoft Offline
Catalog and/or from HPLN.

Solution

Remove duplicate patches from the SA library and reimport patchmetadata fromWSUS:
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1. Go to Library > Patches > Windows > [yourWindows version].
2. In theObject ID search field, enter the patch IDs listed in the error message.
3. Right-click on each duplicate patch and select Delete.
4. Go toAdministration > Patch Settings > WSUS PatchingMode and click Import Metadata on

thePatch Database page.
5. Click Start Job on theRun Server Scriptwizard.

Patch management for HP-UX
In Server Automation (SA), patches for the HP-UX operating system are delivered exclusively by HP
as depots. Depots contain multiple patch products and each patch product contains multiple patch file
sets. These depots can be uploaded into Server Automation.

In patchmanagement for HP-UX, you can:

l Create HP-UX software policies from HP-UX patches or patch bundles.
l Identify, install, and remove HP-UX patches from the server.
l Install software and patches by remediating software policies.
l Downloadmetadata information associated with each patch.
l Support multi-platform patches, patch dependencies, and automatic reboots.
l Run compliance scans.

Features
SA automates HP-UX patchmanagement by enabling you to:

l Define HP-UX software policies that provide amodel-based approach tomanaging your HP-UX
servers. Server Automation enables you to create amodel of your IT environment using HP-UX
software policies. These software policies specify patches and scripts that can be installed on the
managed servers.

l Install HP-UX patches on your managed servers.
l Establish a patch installation process.
l Schedule the stages of patchmanagement: analysis, download, and installation. You can also set
up email notification for each stage and associate a ticket ID for each job.

l Verify the compliance status of servers, based on software policies.
l Display the Compliance view to see whether servers are configured according to the software policy
and to remediate non-compliant servers.

l Search for software resources and servers.
l Use the Library to search for HP-UX packages, patches, and software policies using powerful and
flexible search criteria, such as availability, architecture, operating system, reboot options, version,
and so on. You can also search for HP-UX software policies by name, folder name, availability, and
operating system.

l View patch dependencies and patch applicability analysis while previewing patch installation.
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Prerequisites
Youmust complete the following tasks to use the PatchManagement for HP-UX:

l Download the HP-UX Software Catalog file.
Youmust have a service level contract to download the HP-UX Software Catalog file. Use the
import_hpux_metadata script to download this file. For more information, review the -h option that
is provided with this script. See "/opt/opsware/mm_wordbot/util/import_hpux_depots" on page 103.

l Upload the new patches and re-upload the existing HP-UX patches, depots, and bundles to the SA.
l Update the HP-UX agent on all existingmanaged servers. The agent versionmust be equal to or
higher than opsware-agent-37.0.0.2.130.

Patch installation
PatchManagement provides the following two phases in the patch installation process:

l Phase 1—Download/Staging: This is when the patch is downloaded from Server Automation to the
managed server. This phase is commonly referred to as staging.

l Phase 2—Installation/Deployment: This is when the patch is installed on amanaged server. This
phase is commonly referred to as deployment.

You can specify whether you want the installation to occur immediately after the patch is downloaded
(staged) or you can schedule the installation to occur at a later date and time.

l "Installing an HP-UX patch" below
l "Setting HP-UX install options" on the next page
l "Setting reboot options" on the next page
l "Specifying Install Scripts for a HP-UX patch installation" on page 99
l "Scheduling a Patch Installation for Remediation" on page 100
l "Setting up email notifications" on page 100
l "Previewing a patch installation" on page 100
l "Viewing job progress" on page 102

Installing an HP-UX patch
Before a patch can be installed on amanaged server, it must be imported into SA and its status must
be Available. Only system administrators who have the required permissions can install patches that
aremarked Limited.

You can perform the installation by explicitly selecting patches and servers.

To install a patch on amanaged server:

1. In the navigation pane, select Devices > Servers > All Managed Servers
2. In the content pane, select an HP-UX server.
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3. From the Actions menu, select Install Patch. The first step of the Install Patch window, Servers
and Server Groups, opens.

4. Click Next to advance to the next step in the Install Patch wizard.
5. From the list of patches, select the patch you want to install.
6. After you complete a step, click Next to advance to the next step. Before you click Start Job, you

can return to a completed step tomake changes by clicking on it in the list of steps.
7. When you are ready to launch the installation job, click Start Job.

After you launch the job, you cannot change its parameters, even if the job is scheduled to run at a
later time.

Setting HP-UX install options
You can specify the following types of patch installation options:

l Perform the patch installation immediately after the patch is downloaded or at a later date and time.
l Do not interrupt the patch installation process, even when an error occurs with one of the patches.
l Use different command-line options to perform the installation.
To set these install options:

1. In the Install Patch window, click Next to advance to the Options step.
2. Select one of the following Staged Install Options:

l Continuous: Enables you to run all phases as an uninterrupted operation.

l Staged: Enables you to schedule the download and installation to run separately.

3. Select the Error Options check box if you want the patch installation process to continue even
when an error occurs with one of the patches. By default, this check box is not selected.

4. In the Install Command text box, enter command-line arguments for the command that is
displayed.

5. Click Next to go to the next step or click Cancel to close the Install Patch window.

Setting reboot options
Tominimize the downtime that server reboots can cause, you can control when servers will and will not
be rebooted. You can adopt the vendor's reboot assignments, reboot a server each time a patch is
installed on it, completely suppress all server reboots, or postpone reboots until all patches are
installed.

When you are selecting reboot options in the Install Patch window, We recommend that you use the
HP-UX reboot recommendations, which is the “Reboot servers as specified by patch properties”
option. If you cannot use the HP-UX reboot setting, select the single reboot option, which is the “Do not
reboot servers until all patches are installed” option.

The following options determine whether the servers are rebooted after the patch is installed. These
options apply only to the job launched by the Install Patch window. They do not change the Reboot
Required option, which is on the Install Parameters tab of the patch properties window. Except for the
first option, the following options override the Reboot Required option.
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l Reboot servers as specified by patch properties
By default, the decision to reboot depends on the Reboot Required option of the patch properties.
The server is rebooted only once at the end. This is done to satisfy the patch dependency. In effect,
the option works as the third option which is to not reboot servers until all patches are installed

l Reboot servers after each patch install
Even if the Reboot Required option of the patch properties is not set, reboot the server. If multiple
patches are installed, the server will be rebooted only once after all patches are installed.

l Do not reboot servers until all patches are installed
If the Reboot Required option is set for some selected patches but not for others, the server is
rebooted one time after all patches are installed. If the Reboot Required option is not set for any of
the selected patches, the server is not rebooted.

l Suppress all server reboots
Even if the Reboot Required option of the patch properties is set, do not reboot the server. (Because
of vendor settings, some patches ignore the suppress option and force a reboot.)

To set reboot options:

1. In the Install Patch window, click Next to advance to the Pre & Post Actions step.
2. Select one of the Rebooting Options.
3. Click Next to go to the next step or click Cancel to close the Install Patch window.

Specifying Install Scripts for a HP-UX patch installation
For each patch, you can specify a command or script to run before installation or after installation. A
pre-install script, for example, could check a certain condition on themanaged server. If the condition is
not met or if the pre-install script fails, the patch would not be installed. A pre-install script could also be
used to shut down a service or application before it is patched. A post-install script could be used to
perform a certain cleanup process on themanaged server.

You can also specify the following types of scripts to run on themanaged server before or after an
installation phase:

l Pre-Install: A script that runs before patches are installed on themanaged server.
l Post-Install: A script that runs after patches are installed on themanaged server.
To specify a pre-install or post-install script:

1. From the Install Patch window, click Next to advance to the Pre & Post Actions step.
2. Select thePre-Install tab. Youmay specify different scripts and options on each of the tabs.
3. Select Enable Script. This option enables the remainder of the fields on the tab. If Enable Script

is not selected, the script will not run.
4. Select eitherSaved Script orAd-Hoc Script. To specify the script, click Select. An Ad-Hoc

script runs only for this operation and is not saved in Server Automation.
5. If the script requires command-line flags, enter the flags in the Command text box.
6. Specify the information in the User section. If you choose a system other than Local System,

enter the user Name and Password. The script will be run by this user on themanaged server.

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 99 of 307



7. To stop the installation if the script returns an error, select theError check box.
8. Click Next to go to the next step or click Cancel to close the Install Patch window.

Scheduling a Patch Installation for Remediation
You can schedule when you want patches installed and when you want patches downloaded.

To schedule a patch installation:

1. In the Remediate window, select theScheduling step.

By default, the Scheduling step displays only the scheduling options for the installation phase. If
you selectedStaged in theRemediate Options step, the scheduling options for the download
phase will also be displayed.

2. Select one of the following Scheduling options:
l Schedule Analysis: This enables you to specify a date and time that you want the analysis to
run.

l Schedule Download: This enables you to specify a date and time that you want the download
or installation performed.

l Schedule Remediate: This enables you to specify a data and time that you want the
remediate process to run.

3. Click Next to go to the next step or click Cancel to close the Remediate window.

Setting up email notifications
You can set up email notifications to alert users when the download and installation operations
complete successfully or with errors.

To set up email notifications:

1. In the Install Patch window, click Next to advance to the Notifications step.

2. To set the notification status on the success of a Job, select the icon. To set the

notification status on the failure of a Job, select the icon. By default, the Notification step
displays only the notification status for the installation phase.

3. Enter a Ticket ID to be associated with a Job in the Ticket ID field.
4. Click Next to go to the next step or click Cancel to close the Install Patch window.
If you previously selected Staged in the Install Options step, the Notifications pane displays
notification options for both the download and installation phase.

Previewing a patch installation
The installation preview process provides an up-to-date report about the patch state of servers. The
installation preview is an optional step that lets you see what patches will be installed onmanaged
servers and what type of server reboots are required. This preview process verifies whether the servers
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you selected for the patch installation already have that patch installed. In some cases, a server could
already have the patch installed if a system administrator hadmanually installed it, whichmeans that
SA does not know about it.

The preview process also reports on dependency information, such as patches that require certain Unix
products, and patches that obsolete other patches or are obsoleted by other patches. If a dependency
is not met, SA will display an error message indicating this condition.

The installation preview does not report on the behavior of the server as though the patches have been
applied.

To preview a patch installation:

1. From the Install Patch window, click Next to advance to the Summary Review step.
2. Verify the information displayed for the Servers, Server Groups, and Patches at the top of the

window.
3. (Optional) Click Preview to see the separate actions that will be performed when the patch is

installed. To view the details of a previewed action, select a row in the table.
4. Click Start Jobto launch the installation job or click Cancel to close the Install Patch window

without launching the installation.
If you selectedRun Task Immediately in the Scheduling step, the job begins now. If you selected
Run Task At, the job will be launched at the specified time and date.
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Viewing job progress
You can review progress information about a patch installation (job), such as whether actions
completed or failed.

To display job progress information:

1. From the Install Patch window, click Next to advance to the Job Progress step. This starts the
installation job.
The Progress bar and text indicate how many of the actions listed in the table were completed. For
each server, the following actions can be performed:
l Analyze: SA examines the patches needed for the installation, checks themanaged servers for
themost recent patches installed, and determines other actions it must perform.

l Download: The patch is downloaded from SA to themanaged server.

l Install: After being downloaded, the patch is installed.

l FinalReboot: If this action is specified in the Pre & Post Actions step, the server is rebooted.

l Pre/Post Install/Download Script: If this action is specified in the Pre & Post Actions step, a
script is run before or after the uninstallation.

l Install & Reboot: When a patch will be installed is also when the server will be rebooted.

l Verify: Installed patches will be included in the software registration.

2. To view additional details about a specific action, select the row in the table to display the start
and completion times of the job. In the navigation pane, select Jobs and Sessions to review
detailed information about the job.

3. Click End Job to prevent the job from running or click Close to close the Install Patch window.

Supported operating systems
See the SA Support and Compatibility Matrix for detailed information about supported HP-UX operating
systems for patchmanagement.

HP-UX depots
The import_hpux_depot script imports HP-UX patches, bundles, and depots into the SA Library. For
each source depot, this tool creates a <depot name>Depot policy in the SA Library that contains the
depot's products.

The import_hpux_depot script requires the .depot extension to script input:

l By default, standard HP-UX bundles that are downloaded from http://itrc.hp.com already have a
.depot extension.
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l By default, HP-UX patches that are downloaded from http://itrc.hp.com do not include the .depot
extension. These patches must bemanually downloaded to an HP-UX server, unshared to create a
.depot file, and then uploaded to the SA Library using the import_hpux_depot script.

The import_hpux_depot script is located in the following directory:

/opt/opsware/mm_wordbot/util/import_hpux_depots

Importing patches and depots using the SA Client instead of scripts will not create software policies
and patch dependency will not work.

After HP-UX patches have been uploaded to the SA Library, you cannot delete them. The delete option
is disabled when you select an "HP-UX Patch Product" or an "HP-UX Patch Fileset".

"Options of import_hpux_depot" below describes the script’s options.

Option Description

import_hpux_depots
[options]

All *.depot files in the current working directory are imported into the
Library.

import_hpux_depots
[options] <source-
directory>

All *.depot files in the specified directory are imported into the Library.

import_hpux_depots
[options] <*.depot

The specified depots are imported into the Library.

import_hpux_depots -h Show additional options.

-b, --bundle-policies
create a policy for each
depot bundle

For each bundle that appears in a source depot, this tool creates a
<bundle name> Bundle policy in the SA Library that contains the bundle's
products using the --bundle-policies option.

-f, --force Force depot products to be imported even if already in the SA Library.

-h, --help Displays the helpmessage.

-n, --silent Display errors only.

-o OS, --os=OS HP-UX release of depot products 10.20, 11.00, 11.11, 11.23, and 11.31.
Some patches are common to both 11.23 and 11.31 operating system
versions. Use -o=11.23 or -o=11.31 to upload these patches into the SA
Library.

-p POLICY_FOLDER, --
policy_folder=POLICY_
FOLDER

Path to Library folder in which to create policies.

-s SPLIT, --split=SPLIT
How to split each depot
(default: product):
'product', 'instance',
'none'

Products that are already in the SA Library are not re-imported unless --
force is specified.

By default, depots containingmultiple products are split by product so
that each product is kept in the SA Library as its own self-contained

Options of import_hpux_depot
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Option Description

depot. The split behavior is controlled by the --split option:

none—Source depots are not split but are imported as is.

product—Source depots are split by product. If a depot contains multiple
instances of the same product (by name), the instances are kept
together. This is the default.

instance—Source depots are split by product instance. If a depot
contains multiple instances of the same product (by name), each
instance is split into its own depot. Source depots are split by product. No
HPUXPatchBundleUnits will be created and individual depot files will be
generated for each product. If a depot contains multiple instances of the
same product (by name), the instances are kept together. This is the
default.

--timeout=USER_
TIMEOUT

Override default timeout values (2 hours if split is 'none', else 5minutes)

-u USERNAME, --
username=USERNAME

Upload packages as specified user (default: opsware).

-v, --verbose Display verbose output

--manual Show manual page and exit.

--version Show version and exit.

Options of import_hpux_depot, continued

HP-UX software catalog file
The HP-UX Software Catalog file is the HP-UX Patch Database in XML format. The catalog file is swa_
catalog.xml and can be downloaded from ftp://ftp.itrc.hp.com/export/patches.

The HP-UX Metadata script is used to import the HP-UX Software Catalog file into the SA Library. This
script can list dependent patches for any patch that exists in the software catalog file and indicate the
dependent patches that aremissing in the package repository.

The HP-UX Metadata script is located in the following directory:

/opt/opsware/mm_wordbot/util/import_hpux_metadata

"Options of the HP-UX Metadata Script" below describes the script’s options.

Option Description

-a HPUX_ANALYZE_
PATCHES, --analyze_
patches=HPUX_
ANALYZE_PATCHES

Specifies the HP-UX patches that will be analyzed for any dependent
patches missing in the package repository. Multiple HP-UX patches
can be specified by separating them with a comma (,). To analyze all
HP-UX patches in the package repository, include the keyword all.

Options of the HP-UX Metadata Script
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Option Description

-c HPUX_SW_
CATALOG_FILE, --
catalog_file=HPUX_SW_
CATALOG_FILE

Specifies the source location of the HP-UX software catalog file. The
swa_catalog.xml catalog file can be downloaded from
ftp://ftp.itrc.hp.com/export/patches. This option does not apply when
the user ID and password are specified.

-d DISPLAY_
DEPENDENCIES,--
display_
dependencies=DISPLAY_
DEPENDENCIES

Specifies HP-UX patches for which the dependencies should be
displayed. To display the dependencies for all patches in the software
catalog file, include the keyword all.

-f, --force Forces catatlog upload. If catalog upload is specified, either through the
-u and -p options or the -c option, this option ensures that a new catalog
will be uploaded even if checksummatches current catalog.

-h, --help Displays the helpmessage.

-n, --no_supersedence Flag is used with the -a option indicating whether to use the superseded
dependence tree or the basic dependence tree for reportingmissing
patches. The superseded dependence tree is the default behavior for
HP-UX patching. It performs themost recent dependency check. The
basic dependency tree performs the least recent dependence check.

-p PASSWORD, --
password=PASSWORD

The password that is required to access the itrc.hp.com website to
automatically download the swa_catalog.xml file. Both user ID and
passwordmust be specified.

-t TEST_OPTION, --
test=TEST_OPTION

Test mode option. Options are 'bundle', 'product' and ‘all’.

-u USERID, --
user=USERID

The user ID that is required to access the itrc.hp.com website to
automatically download the swa_catalog.xml file. Both user ID and
passwordmust be specified.

-w UPLOAD_WAIT, --
wait=UPLOAD_WAIT

Specifies the number of seconds to wait between file uploads and
subsequent updates when the catalog upload is specified. If 'optimistic
concurrency' failures occur, this valuemay need to be increased.

Options of the HP-UX Metadata Script, continued

Software policy management
In Server Automation, HP-UX software policies enable you to install HP-UX software and patches on
servers and groups of servers. When you create a software policy, you attach it to servers or groups of
servers. When you remediate a server or a group of servers, the patches specified in the attached
software policy are automatically installed. The remediation process compares what is actually
installed on a server with the software policy that specifies the patches that should be installed on the
server. SA then determines what operations are required tomodify the server to bring it in compliance
with the policy. The following sections describe how tomanage HP-UX software policies.
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Create an HP-UX software policy
In the SA Client, you create a software policy by using either one of the following Library features:

l "Library—By Type" below
l "Library—By Folder" on the next page
Youmust have permissions to create andmanage an HP-UX software policy. To obtain these
permissions, contact your system administrator. See the SA Administration Guide for more
information about softwaremanagement permissions.

In the content pane, a dimmed patch icon indicates that the patch has not been uploaded to the Library.
Use the column selector to control the columns of patchmetadata data that you want to display.

HP-UX patches in the SA Client library

Library—By Type

To use the By Type feature to create a software policy:

1. In the navigation pane, select Library > ByType > SoftwarePolicies > HP-UX. The content
pane displays a list of software policies. By default, the software policies are organized by
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operating system families.
2. Double-click to select an operating system.
3. From the Actions menu, select New to open the New Software Policy window.
4. In the Name field, enter the name of the HP-UX software policy.
5. (Optional) In theDescription field, enter text that describes the purpose or contents of the policy.
6. Next to the Location field, click Select to specify the location for the software policy in the folder

hierarchy.
7. In the Select Folder window, select a folder in the Library to specify the location of the software

policy and then click Select to save your setting.
8. From the Availability drop-down list, select an SA server life cycle value (Available or Deprecated)

for the software policy.
9. From theOS drop-down list, select the operating system family or specific operating systems in

that family.
10. Keep the Template value set to No, which is the default.
11. From the File menu, select Save.

Library—By Folder

To use the By Folder feature to create a software policy:

1. In the navigation pane, select Library > ByFolder. The content pane displays the folder hierarchy
in the library.

2. In the content pane, select the folder that you want to contain the software policy.
3. From the Actions menu, select New > SoftwarePolicy to open the New Software Policy window.
4. In the Name field, enter the name of the HP-UX software policy.
5. (Optional) In the Description field, enter text that describes the purpose or contents of the policy.
6. Next to the Location field, click Select to change the location for the software policy in the folder

hierarchy.
7. In the Select Folder window, select a folder in the Library to specify the location of the software

policy and then Select to save your setting.
8. In the Availability drop-down list, select an SA server life cycle value (Available or Deprecated) for

the software policy.
9. In the OS drop-down list, select the operating system family or specific operating systems in that

family.
10. Keep the Template value set to No, which is the default.
11. From the File menu, select Save.

View an HP-UX software policy
In the SA Client, you view a software policy by using any of the following navigation features:

l "Search" on the next page
l "Devices" on the next page
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l "Library—By Type" below
l "Library—By Folder" on the next page

Search

To use the Search feature to view a software policy:

1. In the navigation pane, select Search.
2. In the drop-down list, select Software Policy and then enter the name of the policy in the text field.

3. Click to display the search results in the content pane.
4. In the content pane, select the software policy and then right-click to open the Software Policy

window.

Devices

To use the Devices feature to view a software policy:

1. In the navigation pane, select Devices > Servers > All Managed Servers to display a list of
servers in the content pane.
Or
In the navigation pane, select Devices > Device Groups to display a list of servers in the content
pane.

2. In the content pane, select a server.
3. Right-click the selected server to open the Server window.
4. In the Information pane, selectManagement Policies.
5. In theManagement Policies pane, select Software Policies to display the software policies

attached to the server in the content pane.
6. In the content pane, select the software policy and then right-click to open the Software Policy

window.

Library—By Type

To use the By Type feature to create a software policy:

1. In the navigation pane, select Library > By Type > Software Policies > HP-UX. The content
pane displays a list of software policies. By default, the software policies are organized by
operating system families.

2. Double-click to select an operating system.
3. From the Actions menu, select New to open the New Software Policy window.
4. In theName field, enter the name of the HP-UX software policy.
5. (Optional) In theDescription field, enter text that describes the purpose or contents of the policy.
6. Next to the Location field, click Select to specify the location for the software policy in the folder

hierarchy.
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7. In the Select Folder window, select a folder in the Library to specify the location of the software
policy and then click Select to save your setting.

8. From theAvailability drop-down list, select an SA server life cycle value (Available or
Deprecated) for the software policy.

9. From theOS drop-down list, select the operating system family or specific operating systems in
that family.

10. Keep the Template value set to No, which is the default.
11. From the File menu, select Save.

Library—By Folder

To use the By Folder feature to create a software policy:

1. In the navigation pane, select Library > By Folder. The content pane displays the folder
hierarchy in the library.

2. In the content pane, select the folder that you want to contain the software policy.
3. From the Actions menu, select New > Software Policy to open the New Software Policy

window.
4. In theName field, enter the name of the HP-UX software policy.
5. (Optional) In theDescription field, enter text that describes the purpose or contents of the policy.
6. Next to the Location field, click Select to change the location for the software policy in the folder

hierarchy.
7. In the Select Folder window, select a folder in the Library to specify the location of the software

policy and then Select to save your setting.
8. In theAvailability drop-down list, select an SA server life cycle value (Available or Deprecated)

for the software policy.
9. In theOS drop-down list, select the operating system family or specific operating systems in that

family.
10. Keep the Template value set to No, which is the default.
11. From the File menu, select Save.

Edit an HP-UX software policy
After you create an HP-UX software policy, you can view andmodify its properties. You can view
properties, such as the SA user who created the software policy, the date when it was created, and the
SA ID of the software policy. You can alsomodify (edit) the name, description, availability, location of
the software policy in the Library, and the operating systems of the software policy.

Youmust have permissions tomanage an HP-UX software policy. To obtain these permissions,
contact your system administrator. See the Administration Guide for more information about software
management permissions.

To edit the properties of a software policy:

1. In the navigation pane, select Library > By Type > Software Policies > HP-UX and an
operating system version.
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2. In the content pane, select the software policy and then right-click to open the Software Policy
window.

3. In the Software Policy window, in the Views pane, select Properties.
4. In the Properties content pane, you can edit the Name, Description, Location, Availability, andOS

for the software policy. See "Create an HP-UX software policy" on page 106 for guidelines about
information in these fields.

5. After you havemade your changes, from the File menu, select Save.

Add an HP-UX patch to a software policy
After you create an HP-UX software policy, you can add HP-UX patches, HP-UX software, and server
scripts to it. Adding these does not install them on amanaged server. Youmust attach the software
policy to amanaged server and then remediate the server.

Youmust have permissions to add an HP-UX patch, HP-UX software, and server scripts to an HP-UX
software policy. To obtain these permissions, contact your system administrator. See the SA
Administration Guide for more information about softwaremanagement permissions.

To add software resources to a software policy:

1. In the navigation pane, select Library > By Type > Software Policies > HP-UX and an
operating system version.

2. In the content pane, select a software policy.
3. Right-click the selected software policy to open the Software Policy window.
4. In the Views pane, select Policy Items.

5. Click or, from the Actions menu, select Add to display the Select Library Item window.
6. Select the Browse Types tab to display items that can be added to the software policy.
7. Select one or more items you want to add to the policy and then click Select. The items are added

to the policy.
Or
Select theBrowse Folders tab to display the folder hierarchy in the Library and the list of items
contained in the folders. Select one or more items you want to add to the policy and then click
Select. The items are added to the policy.

8. To change the order in which the software is installed, use the arrows.

9. To remove an item from the policy, select it and then click . See "Remove software from a
software policy" below for more information about this action.

10. From the File menu, select Save to save the changes youmade to the policy.

Remove software froma software policy
When you remove software from anHP-UX software policy, the software is not uninstalled from the
managed server. This action only removes the software from the policy. To uninstall the HP-UX
software from amanaged server, youmust directly uninstall the software from themanaged server.
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Youmust have permissions to remove HP-UX software from anHP-UX software policy. To obtain
these permissions, contact your system administrator. For more information, see the SA
Administration Guide.

To remove HP-UX software from a software policy:

1. In the navigation pane, select Library > By Type > Software Policies > HP-UX and an
operating system version.

2. In the content pane, select the software policy and then right-click to open the Software Policy
window.

3. In the Views pane, select Policy Items.
4. Select the items that you want to remove from the list of policy items displayed in the Content

pane.

5. Click or, from the Actions menu, select Remove.
6. From the File menu, select Save to save the changes youmade to the policy.

View software policy history
To view the events associated with an HP-UX software policy:

1. In the navigation pane, select Library > By Type > Software Policies > HP-UX and an
operating system version.

2. In the content pane, select the software policy and then right-click to open the Software Policy
window.

3. In the Views pane, select History. The events associated with the software policy display in the
content pane. You can view the action performed on the policy, the user who performed the action,
and the time when the action was performed.

4. From the Show drop-down list, select ameaningful time period narrows or widens the volume of
events.

View servers attached to a software policy
In the SA Client, you can view a list of all servers and device groups that have a selected HP-UX
software policy attached to them.

To view a list of all servers that have a selected HP-UX software policy attached to them:

1. In the navigation pane, select Library > By Type > Software Policies > HP-UX and an operating
system version.

2. In the content pane, select the software policy and then right-click to open the Software Policy
window.

3. In the Views pane, select Server Usage. A list of servers that have the selected software policy
attached to them displays in the content pane.

Find a software policy in folders
To find an HP-UX software policy in the folder hierarchy:
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1. In the navigation pane, select Library > ByType > Software Policies > HP-UX and an operating
system version.

2. In the content pane, select a software policy.
3. Right-click and then select Locate in Folders to display the folder hierarchy for the software

policy in the content pane.

Custom attributes
Patchmanagement for HP-UX enables you to set a hpuxpatch_dont_supersede custom attribute to
any managed server.

Custom attribute: hpuxpatch_dont_supersede

Server Automation requires that the latest patches are included in the software policy, with the custom
attribute not set. This default behavior is designed to resolve dependency by looking for the latest
patches in the software policy. If the latest patches are not available, SA will display an error message
that reminds you to download the latest patches from HP.

Patch compliance
AnHP-UX patch compliance scan compares the patches that are installed on amanaged server with
the patch policies that are attached to the server. If the actual server configuration does not match the
patch policies attached to the server, the server is out of compliance with the patch policies. In
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addition, if a patch in the patch policy has been superseded by a newer patch and the newer patch is
installed on a server, that server will bemarked as compliant.

In the SA Client, when you perform a patch compliance scan, the scan indicates the server's overall
compliance with all HP-UX patch policies that are attached to the server. Even if only one HP-UX
patch policy attached to the server is not compliant, the server is considered non-compliant. You can
then view the non-compliant server and remediate the server against the applicable patch policy.

The SA Client displays the following compliance information for a patch policy:

Status Description

Compliant All patch policies attached to a server are compliant—all patches specified in all
patch policies are installed on the server.

Non-
compliant

At least one of the patch policies attached to the server is not compliant—at least
one patch in the policy is not installed on the server.

Scan
Started

The patch compliance information is currently being collected.

Scan
Failed

The patch compliance scan was unable to run.

Scan
Needed

The patch compliance information needs to be collected or the compliance
informationmay be inaccurate.

— Not
Applicable

The patch compliance information does not apply.

Compliance status for a managed server

See the following figure for an example of patch compliance status for the Standard HP-UX bundle.

Patch compliance status
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In this example, Server Automation reports that the compliance status for the Standard HP-UX QPK
bundle is “2 of 258 rules out of compliance.” The total number of patches within QPK bundle is 259. SA
determined that one patch in this bundle is not applicable to this managed server. Therefore, it reports
compliance status only for 258 patches instead of 259 patches.

SA also determined that two patches have superseded patches and that these superseded patches are
installed on the server but not uploaded in the repository. Therefore, they are reported as out of
compliance.

Patch uninstallation
Uninstalling HP-UX patches and bundles are not supported in this release. To uninstall an HP-UX
patch and bundle from amanaged server, youmust directly uninstall the HP-UX patch and bundles
from themanaged server.

Patch management for Solaris
In Server Automation (SA), patchmanagement for Solaris enables you to identify, install, and remove
Solaris patches and IPS packages, andmaintain a high level of security across managed servers in
your organization. You can identify and install patches that protect against security vulnerabilities for
the following Solaris operating systems:.
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OS version Architecture

Solaris 10 (Update 1 through Update 9) Sun SPARC, 64bit x86, 32 bit x86, and Niagara

Solaris 11 Sun SPARC, 64bit x86, 32 bit x86, and Niagara

Supported operating system version

In Oracle Solaris 11, a patch unit is referred to as an Image Packaging System (IPS). IPS is a network-
based packagemanagement system that provides a framework for software lifecycle management
such as installation, upgrade and removal of software packages. For information and instructions
specific to Solaris 11, see "Patchmanagement for Solaris 11 " on page 160.

See the SA Support and Compatibility Matrix for completeManaged Server platform support
information.

Features
SA automates Solaris patching by enabling you to:

l Determine which patches and IPS packages your managed servers need.
SA can determine the patches and IPS packages your managed Solaris servers need by examining
the OS version, the applications installed on your servers, and the patches already installed on your
servers. SA examines all available Solaris patches and then determines which patches your servers
need, the required installation order, and the reboot requirements.

l Create Solaris patch policies.
This is amodel-based approach tomanaging your Solaris servers. SA enables a policy setter to
create amodel of their IT environment by creating a Solaris patch policy. A Solaris patch policy
specifies patches, patch clusters, and scripts that must be installed on your managed servers. A
system administrator can then apply the patch policies to the Solaris servers in their environment.
Create Solaris patch policies from downloaded Solaris patches and patch clusters.

l Download Solaris patches, patch clusters, and patch bundles, and then store them, and
related vendor information, in the SA Library.
SA can import Solaris patches, patch clusters, Fujitsu clusters,IPS packages and related vendor
information fromMy Oracle website and add them to Solaris patch policies. Vendor information can
include reboot specifications, platform settings (such as support for multi-platform patches), patch
dependencies, and a Readme file. Your patch policies are stored in the SA Library and accessible
from the SA Client.

l Resolve all dependent patches for Solaris patches.
SA can examine all Solaris patchmetadata and identify obsolete patches, superseded patches,
incompatible patches, required dependent patches and withdrawn patches, and then update your
patch policy. SA also places the patches and IPS packages in the correct install order.

l Install Solaris patches, patch clusters and IPS packages on managed servers.
SA allows you to directly install Solaris patches, patch clusters and IPS packages onmanaged
servers or to install by using Solaris patch policies. In the SA Client, you can set the installation
order for the patches and patch clusters in the patch policy. SA includes the reboot settings from the
Solaris patches in the policy.
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SA installs patches, patch clusters, Fujitsu clusters, patch bundles and IPS packages by
remediating patch policies onmanaged Solaris servers. The remediate process offers various patch
reboot settings, such as single-user mode, reconfiguration reboot, and reboot immediate.
SA ensures that each patch is applicable to each server. For example, if the package or application
the patch applies to is not installed on the server or if a newer patch is already installed on the server,
SA will not install that patch on the server.

l Install Solaris patches in single-user mode.
SA will install Solaris patches in single-user mode if it is required by the patchmetadata published by
Oracle. After the patch installation is completed, SA will return tomulti-user mode. (See
"Troubleshoot Solaris patch installation " on page 125 for additional tips about install modes.)

l Install patches by Solaris zones
The SA Client lets you can install patches on Solaris global and non-global zones by using Solaris
patch policies.

l Establish a patch installation process.
In SA, you can separate and independently schedule the various stages of Solaris patch
management, such as by analysis, download, and installation. You can set up email notification for
the job status of each completed stage and associate a ticket ID with each job.

l Verify the compliance status of servers with patch policies
The Compliance view allows you to determine if servers are configured according to the patch policy
and to remediate non-compliant servers. You can perform compliance scans, including server
platform, patch supersedence, and package applicability checks.

l Search for software resources and servers.
In the SA Client, the Library provides a way to search for Solaris patches, clusters and patch
policies using powerful and flexible search criteria such as by availability, architecture, operating
system, reboot options, version, andmany other parameters. You can also search for Solaris patch
policies by name, folder name, availability, operating system, and so on.

Policy-based patch management
With Solaris patch policies, you can ensure your Solaris servers have the right patches installed by
creating a patch policy. A patch policy is amodel of your desired IT environment. A Solaris patch
policy defines a server baseline to ensure that all servers are provisioned with standard contents.
Using SA, you can automatically download Solaris patches, organize them into polices, define
installation order among patches in the policy, automatically resolve all dependencies for the
patches and set reboot settings for all patches in the policy.
System administrators can thenmanage the servers in their environment by applying the Solaris
patch policy to the servers. SA applies the changes to themanaged servers when you remediate the
managed servers with the patch policy. When a change needs to bemade to a patch policy, a policy
setter simply changes the baseline defined in the policy and the incremental differences are applied
across the target servers.

Solaris patch bundles
You can import and install Solaris patch bundles.
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l You can download Solaris patch bundles and import them into the SA library using the solpatch_
import command.

l You can install Solaris patch bundles directly onmanaged servers or on all servers in a device
group or you can add Solaris patch bundles to a Solaris patch policy (or to a software policy),
attach the policy to managed servers or device groups and then remediate the servers against
those policies. When you remediate the servers or device groups, the Solaris patches specified
in the attached policy are automatically installed on themanaged servers.

l All solpatch_import actions, except the policy action, now can be performed with patch
bundles.

l When you import a bundle, SA updates themetadata in the SA Library with all the patches
contained in the bundle. Depending on the number of patches in your SA Library, the bundle
import may take some time.

l Deleting a patch bundle from the SA Library or by using the solpatch_import command deletes all
the parts of the bundle.

l The default reboot settings for patch bundles are listed below. You can change these settings by
opening the patch bundle in the SA Client, selecting the Properties view and editing the Install
Parameters.
o Reboot Required: Yes – This setting indicates themanaged server will be rebooted when

the patch bundle is successfully installed.
o Install Mode: Single-user Mode – This setting indicates that the patch bundle will be

installed in single user mode. Note that the Solaris system is rebooted to single user mode,
then the patch bundle is installed, then the system is rebooted tomultiuser mode.
See"Troubleshoot Solaris patch installation " on page 125 for additional tips about install
modes.

o Reboot Type: Reconfiguration – This setting indicates that a reconfiguration reboot will be
performed after installing the patch bundle.

o Reboot Time: Immediate – This setting indicates that the server will be rebooted
immediately after installing the patch bundle.

l A Solaris patch compliance scan will indicate that the server is out of compliance even though
the patch bundle installed successfully if one or more patches in the bundle were not installed
because a required prerequisite patch was not installed. For details on what patches in the patch
bundle were not installed, see the log file for the patch bundle installation job.
A software compliance scan will similarly indicate the server is out of compliance if the patch
bundle is included in the software policy and the same scenario occurs.
To bring the server into compliance, place the relevant patches into a patch policy, resolve the
dependencies on the policy to place all required patches in the policy and remediate the policy on
the server.

l Youmust set the “Manage Packages” permission to “Read andWrite” to use the solpatch_
import command. For details on permissions, see the SA Administration Guide.

l If you encounter errors when importing Solaris patch bundles, perform the following

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 117 of 307



troubleshooting steps.
i. Log in as root to the SA core where the SA patch has been installed.
ii. Locate the log file from the patch install, which is typically located at:

/var/log/opsware/install_opsware/patch_opsware.<time stamp>.log
iii. Search this log file for amessage with “update_supplements.” For example, you could use

the following grep command:

grep update_supp patch_opsware*

iv. The result should be a logmessage with “update_supplements successfully completed”.
However, if themessage indicates the update_supplements failed, update the Solaris
patch supplement file manually as follows.

v. Log in as root to an SA core system where the solpatch_import command is installed.
vi. Change to the directory where the solpatch_import command is:

/opt/opsware/solpatch_import/bin.
vii. Run the following command:

./solpatch_import -a update_supplements

viii. Try importing Solaris patch bundles again.

Fujitsu clusters
A Fujitsu cluster is a cluster designed for a Solaris operating system that runs on Fujitsu
hardware. SA supports Fujitsu clusters.

Cluster downloads
If you use a single solpatch_import command to download both a Fujitsu cluster and a Solaris
recommended cluster file, both files will be downloaded to the same location but will not be
imported into the SA core. The first downloaded cluster will be overwritten by the second
downloaded cluster, because both clusters have the same file names (such as: 10_
Recommended.zip). To avoid overwriting one file with the other, do not use a single solpatch_
import command to download the two clusters. Instead, download the first cluster, move it to a
different location, and then download the second one.

You can still use a single solpatch_import command to import Fujitsu clusters and standard
Solaris recommended clusters for the same operating system because when SA imports a file, it
downloads and then immediately imports it to the core. No file overwriting can occur.

Patch policies
You can create patch policies for any cluster from the command line or by using the SA Client.

When you create a patch policy for a Fujitsu cluster by using the –a policy or --action=policy
option from a command line, all applicable patches included in the cluster are applied—regardless
of whether Fujitsu intended them to be installed on your hardwaremodel, using the cluster install.
These extra patches do not cause harm.
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If you want to apply only the patches that Fujitsu has designated for your hardwaremodel, use
the SA Client to create a new policy and include the Fujitsu cluster. When you remediate the
policy, SA will correctly apply only the relevant patches.

SA commands
You can use the same cluster commands for Fujitsu clusters as you do for standard Solaris
clusters.
Use the following command to display additional information about cluster commands:

/opt/opsware/solpatch_import/bin/solpatch_import --manual

Fujitsu clusters can only be imported using the solpatch_import command.

Quick start
To set up and initialize Solaris patching in SA:

1. Create an SA user that has the following permissions:
l Read and write permissions for the /Opsware/Tools/Solaris Patching folder

l Read and write permission for the “Manage Patch” feature permission

l Feature permissions set to “Yes” for:
o “Allow Install Patch”
o “Allow Uninstall Patch”
o “Manage Patch Compliance Rules”

See the SA Administration Guide for more information on creating users and setting permissions.
2. Log in as root to an SA slice core server or amaster core server.
3. Update the configuration file located at /etc/opt/opsware/solpatch_import/solpatch_

import.conf as follows:
l Add your SA user name and password to the lines that begin with hpsa_user and hpsa_pass.
Example:

hpsa_user=my_sa_username
hpsa_pass=<password>

l Add your My Oracle account user name and password to the lines that begin with download_
user and download_pass.
Example:

download_user=my_oracle_username
download_pass=<password>

This configuration file is used by the solpatch_import command.
You can create a separate, private copy of the configuration file and use the -c option or the --
conf option for solpatch_import to specify your configuration file.
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4. (Optional) Run the following command to encrypt your passwords in the configuration file:

solpatch_import --hide_passwords

The solpatch_import command is located at /opt/opsware/solpatch_import/bin.
If this is the first time you are using Solaris patchmanagement in SA, youmust create a new
Solaris patch database. The solpatch_import -a create_db command creates the Solaris patch
database, downloads patch information from Oracle (in the patchdiag.xref file), and then uploads
the patch information into the database:

solpatch_import -a create_db

If you already have a patchdiag.xref file, use the following command to create the Solaris patch
database and upload the patch information from your patchdiag.xref file into the database:

solpatch_import -a create_db -x <local patchdiag.xref file>

This command can take a few hours to run, depending on how many Solaris patches are already in
your SA Library.
SA is now ready for you to download Solaris patches and install them on your servers as
described in the following sections.

5. Make sure your Solaris patch database contains the latest patch information. See "Maintain the
Solaris patch database" on page 147.

Install a patch
You can install a Solaris patch directly onmanaged a server or on all servers in a device group, or you
can add a Solaris patch to a Solaris patch policy (or to a software policy), attach the policy to a
managed server or device group and then remediate the server against the policy. When you remediate
a server or device group, the Solaris patch specified in the attached policy is installed on themanaged
server.

SA provides the following ways to install a Solaris patch on amanaged server:

l Install a Solaris patch directly on amanaged server by using the Install Patch wizard.
l Install a Solaris patch directly on amanaged server by using the Install Software wizard.
l Install a Solaris patch or a patch cluster on amanaged server by using a Solaris patch policy.
l Install a Solaris patch or a patch cluster on amanaged server by using a software policy.
If you install or remove a Solaris patch without using SA, youmust perform a software registration and
a compliance scan tomake sure that SA has complete and up-to-date information about themanaged
server. See "Patch compliance" on page 130.

Install a patch cluster
Before you install the Solaris patch cluster, review the Readme file for each cluster. For clusters that
require a passcode, SA does not require that you tomanually enter the passcode that is in the Readme
file.

SA can install all Solaris patch clusters, including clusters that require passcodes. Some clusters may
need to reboot the server multiple times during the install process. SA will automatically perform the
reboots when the cluster Install Parameters has Reboot Required set to Yes and the remediate job

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 120 of 307



options for rebooting are set to either Reboot servers as specified by individual software items (Default)
or Reboot servers after each installation or uninstallation.

If any of these reboot options are not set, the cluster will install up to the point where a reboot is
required, if one is required. At the completion of the remediation job, the cluster status will display Not
installed, the job status will show Failed, and the output of the job will contain amessage indicating that
the server must be rebooted before any more patches can be installed. After rebooting the server, the
rest of the cluster can be installed by running the job again. If the cluster requires a reboot, no other
patches can be installed until the server is rebooted.

Installmanual patches—patchadd
SA uses the patchadd utility to install Solaris patches. However, some patches, such as firmware
updates, cannot be installed with patchadd. Thesemanual patches have special installation
instructions in their Readme files andmust be installedmanually on your Solaris servers.

While you can import these patches into the SA software repository and install themmanually on
servers, if you attempt to remediate amanual patch, the job will result in aWarning status. The patch
status displayWill Not Install and the output will indicate that the patch requires a special installation
procedure andmust be installedmanually.

SA cannot determine if thesemanual patches have been installed. A compliance scan on a patch
policy that contains amanual patch will report that the policy is non-compliant. In this case, you should
install the patchmanually and remove the patch from the policy.

Detect benign error codes
Installing Solaris patches sometimes results in benign error codes. A benign error code is an error code
that does not reflect a true error situation. For example, a patch installationmay fail because the patch
is already installed or because a superseding patch is already installed, resulting in a benign error code.
The exit code from the Solaris patchadd commandwould indicate an error, when in reality the patch
was not installed for a valid reason.

When a patch does not install because of a true error situation such as the server being out of disk
space, SA reports the error and the valid error code.

SA detects benign error codes and reports success in most cases. In the following two cases,
however, Solaris cannot detect benign error codes:

l Solaris Deferred-Activation Patches
l Any patches installed on Solaris Global Zones, where Local Zones are defined
To configure SA so that it will detect benign error codes:

1. Install the following patches on all your servers that are running Solaris 10:
l 119254-36 (sparc)

l 119255-36 (i386)

2. Select theAdministration tab in the SA Client.
3. In the navigation pane select System Configuration > Configuration Parameters. This

displays the SA components, facilities and realms that have system configuration parameters.
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4. In the list of SA components, select Command Engine. This displays the system configuration
parameters for this component.

5. Locate the parameter way.remediate.sol_parse_patchadd_output and set it to 1.
6. Click Revert to discard your changes or Save to save your changes.

Install patches using a patch policy
Using a patch policy to install a Solaris patch consists of the following phases:

l "Attaching a patch policy to a server" below
l "Attaching a server to a patch policy" below

Attaching a patch policy to a server

When you attach a Solaris patch policy to a server or a group of servers, the Solaris patch policy is
associated with that server or group of servers. This action does not install the patches and patch
clusters contained in the Solaris patch policy. To install the patches and patch clusters, youmust
remediate the server with the Solaris patch policies.

Note: Youmust have permissions to attach a Solaris patch policy to a server. To obtain these
permissions, contact your SA Administrator. See the SA Administration Guide for more
information.

To attach a Solaris patch policy to a server:

1. In the navigation pane, select Library > By Type> Patch Policies > Solaris.
2. Select a Solaris version to display the patch policies in the content pane.
3. (Optional) In the content pane, select the Solaris patch policy.

a. Right-click to open the patch policy in the Solaris Patch Policy window.
b. From the View drop-down list, select Servers.
c. In the content pane, select a server.

4. From the Actions menu, select Attach Server.
5. In the Attach Server window, select servers or device groups and then click Attach.

You can only select servers that are not in italics. Servers in italics indicate that you do not have
the permission to attach a Solaris patch policy to the server.

6. (Optional) Select Remediate Servers Immediately to remediate the servers against the Solaris
patch policy. Selecting this option displays the Remediate window. This option is only available if
you have the Remediate Servers permission.

Attaching a server to a patch policy

When you attach a server or a group of servers to a Solaris patch policy, the policy is associated with
that server or group of servers. This action does not install the patches or patch clusters contained in
the Solaris patch policy. To install the patch and patch clusters, youmust remediate the server with the
Solaris patch policy.
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Youmust have permissions to attach a server to a Solaris patch policy. To obtain these permissions,
contact your SA Administrator. See the SA Administration Guide for more information.

To attach a server to a Solaris patch policy:

1. In the navigation pane, select Devices > Servers> All Managed Servers to display a list of
managed servers in the content pane.
Or
In the navigation pane, select Devices > Device Groups. Navigate to a device group to display a
list of device groups list in the content pane.

2. In the content pane, select a server or a device group.
3. From the Actions menu, select Attach > Patch Policy to open the Attach Solaris Patch Policy

window.
4. Click Browse Solaris Patch Policies and then select one or more policies in the list.

Or
Click Browse Folders and then select one or more policies in the folder hierarchy.

5. Click Attach.
6. (Optional) Select Remediate Servers Immediately to remediate the servers against the Solaris

patch policy. Selecting this option displays the Remediate window. This option is only available if
you have the Remediate Servers permission.

Remediate a server against a patch policy
To install a Solaris patch in a patch policy on a Solaris server, you remediate the server against the
policy. To remediate Solaris servers against a Solaris patch policy, perform the steps described in the
SoftwareManagement.

l "Analyzing patch applicability" below
l "Install parameters " on the next page
l "Rebooting options" on the next page

Analyzing patch applicability

Before patches are downloaded and installed on eachmanaged Solaris server, SA verifies that the
patch is required on the server. This applicability analysis verifies that the:

1. Server platform matches the supported platform listed for the patch.
2. Patch or a superseding patch is not already installed on the server.
3. Package the patch applies to is already installed on the server.
If any of these conditions do not exist, the patch is non-applicable and will not be downloaded to or
installed on amanaged server. Non-applicable patches do not impact the overall job status—the job
can still complete successfully.
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Install parameters

The following figure shows a list of the actual settings for the patch and the settings that Oracle
specifies for the patch. The selected radio buttons are the actual settings that will be used when the
patch is installed. Settings that Oracle recommends are labeled “Oracle default”. TheOracle default
settings are the values that were downloaded with the patch.

The settings specified by the selected radio buttons will be used when the patch is installed. However,
when you remediate a server against a patch policy or install a patch, you can override these settings.
For more information, see "Rebooting options" below.

Install Parameters in the Patch Properties window

l Install Flags: (Optional) Arguments that are used when the patch or patch cluster is installed on a
managed server.

l Reboot Required: Specifies whether themanaged server will be rebooted when the patch or patch
cluster is successfully installed. Oracle’s recommendation is labeled “Oracle default”.

l Install Mode: Specifies whether the patch or patch cluster will be installed in single user mode or
multi-user mode. Oracle’s recommendation is labeled “Oracle default”. The Solaris system is
rebooted to get into single user mode, then the patch is installed, and then the system is rebooted to
get to multi-user mode.

l Reboot Type: Specifies whether a standard reboot or a reconfiguration reboot will be performed after
installing the patch or patch cluster. Oracle’s recommendation is labeled “Oracle default”.

l Reboot Time: Specifies whether the server will be rebooted immediately after installing the patch or
at some later time after the patch or patch cluster is installed. Oracle’s recommendation is labeled
“Oracle default”.
When installing a patch with the setting Reboot Time: Normal, the reboot will occur at the end of the
job, unless another patch in the job requires an immediate reboot before the end of the job. However,
the Job Preview and the Job Status windows will display the Install and Reboot message for the
patch. This indicates that the reboot will occur sometime after the patch is installed, not immediately
after the patch is installed.

Rebooting options

When you remediate a Solaris server against a Solaris patch policy, SA installs the patches and uses
the reboot settings specified for each patch. However, you can override these settings when starting
the remediate job. The following figure shows theOptions settings for the Remediate patch policy job.
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Rebooting Options window

The following options in the Remediate wizard determine whether the servers are rebooted after the
patch is installed. These options apply only to the job launched by the Remediate window. They do not
change the Reboot Required option, which is in the Install Parameters tab of the Patch Properties
window. Except for the first option, the following options override the Reboot Required option.

l Reboot servers as specified by individual software items (Default): By default, the decision to reboot
depends on the Reboot Required option of the patch or package properties.

l Reboot servers after each installation or uninstallation: As a best practice, reboot the server after
every patch or package installation or uninstallation, regardless of the vendor reboot setting on the
individual patch or package.

l Hold all server reboots until all actions are complete: If the Reboot Required option is set for some
selected patches but not for others, the server is rebooted one time after all patches are installed. If
the Reboot Required option is not set for any of the selected patches, the server is not rebooted.

l Suppress all server reboots: Even if the Reboot Required option of the patch properties is set, do not
reboot the server. (Because of vendor settings, some patches ignore the suppress option and force a
reboot.

Troubleshoot Solaris patch installation

Changing the Solaris patch install mode

When you remediate a Solaris patch that has the Install Mode (under Install Parameters in the
Properties view) set to Single User Mode, the server will be rebooted into single user-mode before
installing the patch. If the remediation fails for some reason (such as when there is a network outage or
a hardware failure), the system will remain in single-user mode.
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To return the system tomulti-user mode:

1. Log in to the Solaris server console.
2. Depending on the Solaris version, change to the directory by entering one of the following

commands:
cd /etc/rcS.d/ # On Solaris 5.10
cd /etc/rc1.d # On Solaris 5.6 - 5.9

3. Enter the following command.
./S99zOpswPatching exit_single_user_mode

4. Reboot the server by entering the following command or another method. This will reboot the
server into multi-user mode.
shutdown -y -g 0 -i 6

If you do not have access to a server console on your Solaris server, use the SA Global Shell (OGSH)
rosh utility:

1. Using an SA user who has the OGFS permission “Log in to Server”, open anOGSH session. For
example, you could enter an ssh command such as:
ssh -p 2222 <user-name>@<ogfs-host>

2. Navigate to your Solaris server using a command such as:
cd /opsw/Server/@/<server name>/files/root

3. Launch the rosh utility.
4. Depending on the Solaris version, change to the directory by entering one of the following

commands:
cd /etc/rcS.d/ # On Solaris 5.10
cd /etc/rc1.d # On Solaris 5.6 - 5.9

5. Enter the following command:
./S99zOpswPatching exit_single_user_mode

6. Reboot the server entering the following command or another method. This will reboot the server
into multi-user mode.
shutdown -y -g 0 -i 6

When you reboot the server, your rosh process will be terminated. Make sure the server is configured to
auto-reboot.

If a patch requires single-user mode and fails to install for some other reason, such as a dependent
patch is not installed, the Solaris host will be rebooted to single-user mode, the patch installation will be
attempted, and the host will be rebooted tomulti-user mode. These two reboots occur even if the path
installation fails.

Mounting the staging directory in single-user mode

When one item in a remediation process requires a server to restart in single-user mode it can prohibit
the rest of the items from being processed if the item is stored in an atypical directory that is not
available in single-user mode.
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Single-user mode will need tomount the staging directory upon startup. The default staging directory is
/var/opt/opsware/agent. If the next item is not in the default directory, then the remediation process
will not be able to find it and the job will fail.

To resolve this, themanaged server just needs tomount the staging directory where the items are
stored prior to running the remediation. The simplest way to do this is to write a server script with mount
instructions and add it to an existing Solaris start-up script.

For example:

echo "mount<stage_dir>">>/etc/rcS.d/S99mount_stage

where '<stage_dir>' is the directory where the item is stored and '/etc/rcS.d/S99mount_stage' is
the start-up script on a Solaris managed server.

Install patches using offline volumes
You can install Solaris patches using offline volumes. This section assumes you are familiar with
Solaris VolumeManager.

A sample script is available so that you canmodify it and use it to install Solaris patches using offline
volumes.

To install Solaris patches using offline volumes:

1. Create a Solaris patch policy that contains the patches you want to install on the server. See
"Create a Solaris patch policy" on page 133.

2. Create a disk mirror on the server being patched.
3. Split themirror.
4. Mount the offline disk.
5. Create a text file on the server named /etc/opt/opsware/agent/offline_disk.
6. Edit this file and enter themount point of the offline disk, such as /alt.
7. Remediate the server against the patch policy to install the patches on the server.

SA installs the patches to the offline disk at the offline disk mount point listed in the file
/etc/opt/opsware/agent/offline_disk.

8. Reboot the server to the newly patched offline disk.
9. Verify that the patches are installed on the patched disk and that the server is running properly.
10. If the patched disk is behaving as expected, sync themirror.

If the patched disk is not behaving as expected, reboot the system to the original disk and sync
themirrors.

Patch management process
There are twomain use cases in Solaris patching:

l "Patching selected servers" on the next page
l "Installing selected patches" on page 129
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Patching selected servers
The following figure shows the steps required when you know which Solaris servers you want to patch
and how you identify which patches those servers need. These steps include downloading and
installing patches on your Solaris managed servers.

Patching Selected Servers

1. A policy setter determines which Solaris servers need to be patched. For example, youmay want
to patch one specific Solaris server, all your servers running 5.10, all servers used by a particular
department, or some other subset of your Solaris servers.

2. A policy setter uses the solpatch_import command to download the patches from Oracle that
are required by the selected Solaris servers. The solpatch_import command determines which
patches are required by the selected servers, resolves all patch dependencies, and includes all
applicable patches.

3. A policy setter adds the patches to a Solaris patch policy.

This step can be completed by running the solpatch_import command as part of step 2
(excluding patch bundles) or you canmanually place the Solaris patches into a patch policy by
using the SA Client.
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4. A system administrator attaches the patch policies tomanaged servers.
Your system administrator can test the patches by attaching the patch policy to one or more test
servers, to make sure they behave as expected. If problems occur, you can add or remove
patches from the patch policy and then test the patches again. After testing is complete, your
system administrator can attach the patch policy to all other Solaris servers.

5. A system administrator remediates patch policies. The remediate process installs the patches on
your managed servers.

6. A compliancemanager performs a compliance scan to determine which servers do not have the
required patches installed.

Installing selected patches
The following figure shows the steps required when you know which Solaris patches you want to install
and how you identify all dependent patches. These steps include downloading and installing one or
more Solaris patches.

Installing selected patches

1. A policy setter determines which Solaris patches need to be installed. Youmight be required to
install one specific Solaris security patch or one specific patch that fixes a known problem on your
managed servers.
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2. A policy setter uses the solpatch_import command to download specific patches, patch
clusters, or patch bundles from Oracle.

3. A policy setter adds the patches to a Solaris patch policy.

This step can be completed by running the solpatch_import command as part of step 2
(excluding patch bundles) or you canmanually add the Solaris patches to a patch policy by using
the SA Client.

4. A policy setter uses the button in the SA Client to resolve all dependencies
for patches in the patch policy, including determining dependent patches, superseding patches,
obsolete patches, incompatible patches, and withdrawn patches.

5. A system administrator attaches the patch policies tomanaged servers.
Your system administrator can test the patches by attaching the patch policy to one or more test
servers, to make sure they behave as expected. If problems occur, you can add or remove
patches from the patch policy and then test the patches again. After testing is complete, your
system administrator can attach the patch policy to all other Solaris servers.

6. A system administrator remediates patch policies. The remediate process installs the patches on
your managed servers.

7. A compliancemanager performs a compliance scan to determine which servers do not have the
required patches installed.

Patch compliance
A Solaris Patch compliance scan compares the Solaris patches that are installed on amanaged server
with the patches listed in the Solaris patch policies that are attached to the server and reports the
results. If the actual server configuration does not match the Solaris patch policies attached to the
server, then the server is out of compliance with the Solaris patch policies.

Patches that are not applicable to a particular Solaris server will not impact the compliance status of
the server. For example:

l If a policy contains a patch for the package “SUNWpkga”, but “SUNWpkga” is not installed on a
particular server, the patch is not applicable to that server and that patch will not impact the results
of the compliance scan for that server. The Compliance Summary does not include non-applicable
patches. For example, if a policy contained 5 patches but only 3 were applicable to a given server
and those 3 were installed on that server, the Compliance Summary would report “3 of 3 Rules In
Compliance”, ignoring the 2 non-applicable patches.

l If a particular patch in the patch policy has been superseded by a newer patch and the newer patch
is installed on a server, that server will bemarked as compliant. (In essence, the patch policy is out
of date. You can update the policy as described in "Resolve patch dependencies" on page 138.)

l Manual patches are always shown as out of compliance because SA cannot determine if manual
patches are installed on Solaris servers. For more information, see "Install manual patches—
patchadd" on page 121.

In the SA Client, when you perform a patch compliance scan, the results indicate the server’s overall
compliance with all the Solaris patch policies attached to the server. Even if only one Solaris patch
policy attached to the server is not compliant, the server is considered non-compliant. You can then
view the non-compliant server and remediate the server against the applicable patch policy.
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The following figure shows the compliance view for a Solaris server. Notice that the server is out of
compliance because some patches are not installed on the server:

l Patch policy “Test for 121430-37” contains 4 applicable patches, but only 2 are installed on the
server.

l Patch policy “mwps_policy1” contains 384 applicable patches and all are installed on the server.
Compliance results for a Solaris server

The values for the Status column are described in the table below.

Compliance
Icon

Compliance
Status Description

Compliant All the patch policies attached to a server are compliant. That is, all
the patches specified in all the patch policies are installed on the
server.

Non-
compliant

At least one of the patch policies attached to the server is not
compliant, whichmeans at least one patch in the policy is not
installed on the server.

Scan Started The patch compliance information is currently being gathered.

Scan Failed The patch compliance scan was unable to run.

Compliance status for a managed server
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Compliance
Icon

Compliance
Status Description

Scan
Needed

The patch compliance information needs to be gathered or the
compliance informationmay be inaccurate.

— Not
Applicable

The patch compliance information does not apply.

Compliance status for a managed server, continued

In the SA Client, you can check for patch compliance on an individual server or view overall compliance
levels for all servers and groups of servers in your facility.

Run a patch compliance scan
Youmust have a set of permissions to perform a patch compliance scan. To obtain these permissions,
contact your SA Administrator. See the SA Administration Guide for more information.

To scan a server for Solaris patch compliance:

1. In the navigation pane, select Devices > Servers >All Managed Servers. The server list
appears in the content pane.

2. In the content pane, select a Solaris server.
3. Right-click or from the Actions menu, select Scan > Patch Compliance. The Patch Compliance

Scan Status window appears and begins the patch compliance scan.
4. Click on the status icon in the Status column for more information on the current status.
5. When the scan finishes, view the results in the Status column of the Patch Compliance Scan

Status window.
6. (Optional) In the content pane, select Compliance from the View drop down list to view the patch

policies that are not compliant. This displays all the patch policies attached to the server and the
compliance status of each policy.

Patch Policy Management
In Server Automation, Solaris patch policies allow you to install patches and patch clusters on
managed servers and groups of managed servers in your environment. After creating a patch policy,
you can attach it to servers or groups of servers. When you remediate a server or group of servers, the
patches specified in the attached policy are installed. The remediate process compares what is
actually installed on a server to the patches that should be installed on the server, based on the policy.
SA then determines what operations are required to configure the server so that it complies with the
policy.

After you add Solaris patches and patch clusters to a patch policy, you can specify the order in which
you want them to be installed. When you attach the patch policy to a server and remediate the server,
SA installs the patches and patch clusters in the patch policy in the specified order.
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You can also use software policies tomanage and install patches. A Solaris patch policy cannot
include other patch policies; however, a software policy can include Solaris patch policies. See the SA
User Guide for more information.

Using the SA Client, you can also attach a Solaris patch policy to anOS sequence. When you run the
OS sequence, if the remediate option is enabled (in the Remediate Policy window), all the patches in
the patch policy will be installed on the server where the OS sequence is being installed. If the
remediate option is disabled, none of the patches will be installed on the server. See the SA OS
Provisioning Guide for more information.

Solaris patch policy management includes the following tasks:

l "Create a Solaris patch policy" below
l "View a Solaris patch policy" on page 135
l "Edit a Solaris patch policy" on page 136
l "Add a Solaris patch to a patch policy" on page 136
l "Remove a patch from a Solaris patch policy" on page 137
l "Resolve patch dependencies" on page 138
l "Custom attributes" on page 141
l "View patch policy history" on page 142
l "View software policies associated with a patch policy" on page 142
l "View OS sequences associated with a patch policy" on page 142
l "View servers attached to a patch policy" on page 142
l "Find a Solaris patch policy in folders" on page 143

Create a Solaris patch policy
In the SA Client, you create a Solaris patch policy by using one of the Library features.

Youmust have permissions to create andmanage a Solaris patch policy. To obtain these permissions,
contact your system administrator. See the the SA Administration Guide for more information about
patchmanagement permissions.

Library—By type

To use the By Type feature to create a patch policy:

1. In the navigation pane, select Library > By Type> Patch Policies > Solaris. The content pane
displays a list of patch policies. By default, the patch policies are organized by operating system
families.

2. Double-click to select an operating system.
3. From the Actions menu, select New to open the Solaris Patch Policy window.
4. In theName field, enter the name of the Solaris patch policy.
5. (Optional) In theDescription field, enter text that describes the purpose or contents of the policy.
6. Click Browse to specify the location for the Solaris patch policy in the folder hierarchy. The Select

Folder window appears.
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7. In theSelect Folderwindow, select a folder in the Library to specify the location of the Solaris
patch policy and then click Select to save your setting.

8. From the Availability drop-down list, select an SA server life cycle value for the Solaris patch
policy.

9. From theOS drop-down list, select the operating system family or specific operating systems in
that family.

10. To save your changes, select Save from the File menu.

Library—By folder

To use the By Folder feature to create a patch policy:

1. In the navigation pane, select Library > By Folder. The content pane displays the folder
hierarchy in the library.

2. Select the folder that should contain the Solaris patch policy.
3. From the Actions menu, select New > Solaris Patch Policy to open the Solaris Patch Policy

window.
4. In theName field, enter the name of the Solaris patch policy.
5. (Optional) In theDescription field, enter text that describes the purpose or contents of the policy.
6. Click Browse to change the location for the Solaris patch policy in the folder hierarchy. The Select

Folder window appears.
7. Select a folder in the Library to specify the location of the Solaris patch policy and then click

Select.
8. From theAvailability drop-down list, select an SA server life cycle value for the Solaris patch

policy.
9. From theOS drop-down list, select the operating system family or specific operating systems in

that family.
10. From the File menu, select Save.

solpatch_import

You can create a Solaris patch policy using the solpatch_import command and then add patches to
the policy.

l Example A: Show vendor-recommended patches
The following command displays all vendor-recommended Solaris patches for all managed servers
running Solaris 5.8:

solpatch_import --action=show --filter=”rec,OS=5.8”

l Example B: Vendor recommended patches and security patches in a policy
The following command downloads all vendor-recommended patches and security patches for all
managed servers running Solaris 5.8, uploads these patches to the SA library, and then adds them
to the Sol/SolPatches patch policy in the SA library:

solpatch_import --action=policy --policy_path=/Sol/Solpatches \
  --filter=”rec,sec,OS=5.8”
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l Example C: Patch cluster in a policy
The following command downloads the Solaris 10 SPARC Sun Alert Patch Cluster and adds all
patches in that cluster to the SolClusterPatches policy. The cluster is not added to the policy;
however, all patches in the cluster are added to the policy.

echo “Solaris 10 SPARC Sun Alert Patch Cluster” | solpatch_import\
  -a policy --policy_path=”/Sol/SolClusterPatches”

View a Solaris patch policy
In the SA Client, you view a patch policy by using any of the following navigation features:

l "Search" below
l "Devices" below
l "Library—By Type" on the next page
l "Library—By Folder" on the next page

Search

To use the Search feature to view a software policy:

1. In the navigation pane, select Search.
2. In the drop-down list, select Software Policy and then enter the name of the policy in the text field.

3. Click to display the search results in the content pane.
4. In the content pane, select the software policy and then right-click to open the Software Policy

window.

Devices

To use the Devices feature to view a software policy:

1. In the navigation pane, select Devices > Servers > All Managed Servers to display a list of
servers in the content pane.
Or
In the navigation pane, select Devices > Device Groups to display a list of servers in the content
pane.

2. In the content pane, select a server.
3. Right-click the selected server to open the Server window.
4. In the Information pane, selectManagement Policies.
5. In theManagement Policies pane, select Software Policies to display the software policies

attached to the server in the content pane.
6. In the content pane, select the software policy and then right-click to open the Software Policy

window.
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Library—By Type

To use the By Type feature to view a patch policy:

1. In the navigation pane, select Library > By Type> Patch Policies > Solaris to display the
Solaris patch policies in the content pane.

2. In the content pane, select the Solaris patch policy and then right-click to open the Solaris Patch
Policy window.

Library—By Folder

To use the By Folder feature to view a patch policy:

1. In the navigation pane, select Library > By Folder. The content pane displays the folder
hierarchy in the library.

2. In the content pane, select the folder that contains the patch policy.
3. Right-click to open the folder.
4. Select the patch policy and then right-click to open the Solaris Patch Policy window.

Edit a Solaris patch policy
After you create a Solaris patch policy, you can view andmodify its properties. You can view properties
such as the SA user who created the Solaris patch policy, the date when it was created, and the SA ID
of the Solaris patch policy. You can alsomodify (edit) the name, description, availability, location of the
Solaris patch policy in the Library, and the operating systems of the Solaris patch policy.

Youmust have permissions to edit Solaris patch policy properties. To obtain these permissions,
contact your system administrator. See the the SA Administration Guide for more information about
these permissions.

To edit the properties of a patch policy:

1. In the navigation pane, select Library > By Type > Patch Policies > Solaris.
2. In the content pane, select the Solaris patch policy and then right-click to open the Solaris Patch

Policy window.
3. In the Views pane, select Properties.
4. In the Properties content pane, you can edit the Name, Description, Location, Availability, andOS

for the software policy.
5. You can edit the name, description, location, life cycle, and operating systems for the Solaris

patch policy in the content pane. See "Create a Solaris patch policy" on page 133 for guidelines
about information in these fields.

6. After you havemade your changes, from the File menu, select Save.

Add a Solaris patch to a patch policy
After you create a Solaris patch policy, you can add a Solaris patches, patch clusters and bundles, and
server scripts to it. Adding these does not install them on amanaged server. After you add these to a
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Solaris patch policy, youmust attach the patch policy to amanaged server and then remediate the
server.

You can also use the solpatch_importcommand to place patches in a patch policy.

Youmust have permissions to add Solaris patches, Solaris patch clusters, and server scripts to a
Solaris patch policy. To obtain these permissions, contact your system administrator. See the SA
Administration Guide for more information about these permissions.

To add patch resources to a patch policy:

1. In the navigation pane, select Library > By Type > Patch Policies > Solaris.
2. In the content pane, select the Solaris patch policy and then right-click to open the Solaris Patch

Policy window.
3. In the Views pane, select Policy Items.

4. Click , or, from the Actions menu, select Add to display the Select Library Item window.
5. Select theBrowse Types tab to display items that can be added to the Solaris patch policy.
6. Select one or more items you want to add to the policy and then click Select. The items are added

to the policy.
Or
Select theBrowse Folders tab to display the folder hierarchy in the Library and the list of items
contained in the folders. Select one or more items you want to add to the policy and then click
Select. The items are added to the policy.

7. To change the order in which the patches are installed, use the arrows.

8. To remove a patch from the policy, select the patch and then click .
9. To determine all dependent, obsolete, superseding, incompatible and withdrawn patches, select

Actions > Resolve Dependencies or select .
10. From the File menu, select Save to save the changes youmade to the policy.
11. To save the changes to the policy, select Save from the File menu.

Remove a patch froma Solaris patch policy
When you remove a patch or patch clusters from a Solaris patch policy, they are not uninstalled from
themanaged server. This action only removes the patch or patch cluster from the policy. To uninstall
the Solaris patch or patch cluster from amanaged server, youmust directly uninstall the Solaris patch
or patch cluster from themanaged server.

Youmust have permissions to remove Solaris patches or patch clusters from a Solaris patch policy. To
obtain these permissions, contact your system administrator. See the SA Administration Guide for
more information.

To remove a Solaris patch or patch cluster from a Solaris patch policy:

1. In the navigation pane, select Library > By Type > Patch Policies > Solaris and then select a
version of Solaris.

2. In the content pane, select the Solaris patch policy and then right-click to open the Solaris Patch
Policy window.
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3. In the Views pane, select Policy Items.
4. Select the items that you want to remove from the list of policy items displayed in the content

pane.

5. Click , or, from the Actions menu, select Remove.
6. From the File menu, select Save to save the changes youmade to the policy.

Resolve patch dependencies
When you use the solpatch_import commandwith the filter option, the command resolves all patch
dependencies, resulting in a complete set of installable patches.

When you add patches manually to a patch policy, SA can determine the dependencies for all patches
in the patch policy.

For each patch in the Solaris patch policy, SA determines the following conditions:

l Patches that supersede or obsolete a given patch and should be installed instead of the patch.
l Patches that are a prerequisite to a given patch andmust be installed before the patch.
l Patches that are incompatible with each other and cannot be installed together. Youmust specify
which incompatible patches you want to install.

l Patches that have been withdrawn by the vendor.
l The valid installation order of all patches, preserving the installation order of the original patches that
were in the policy, unless a change is required.

To determine patch dependencies, youmust place the patches in a Solaris patch policy.

To resolve dependent patches in a patch policy:

1. Select Library > By Type > Patch Policies > Solaris.
2. Select a version of SunOS and then select a patch policy.)
3. Double-click a Solaris patch to open the Patch Policy window.
4. In the Patch Policy window, select Policy Items in the View pane. This displays the list of Solaris

patches in the patch policy.
5. In the Patch Policy window, select Actions > ResolveDependencies or click

. This action examines the Solaris patch database in SA and identifies all
dependencies and displays the result, showing the resulting list of patches that need to be
installed.

Example: Resolving Solaris patch dependencies

The following figure shows a Solaris patch policy that contains 2 scripts and 3 patches. The order
shown is the order in which the scripts will be executed and the order in which the patches will be
installed

Solaris patch policy: Resolve dependencies
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The following figure shows the results of selecting Resolve Dependencies for this patch policy. The
following changes have beenmade to this patch policy:

l Patch 105181-25 has been replaced with a newer version, 105181-39.
l Patch 117435-02 remains in the policy.
l Patch 137124-01 replaces patch 138170-01.
l 23 additional patches have been added because they are required by 137124-01.
l The two scripts remain in the policy, in their respective positions in the policy.

Note:
Because of the iterative nature of resolving dependencies for a set of patches, it is not always
obvious how the changes to a patch policy weremade.

Dependencies for all patches in a patch policy
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Click Show Differences to display more details about the differences between the original patch policy
and the proposed new set of patches. In the Show Differences window, click Export to save the
differences between the policies to a file. You can use this information with the solpatch_import
command to import the new patches into SA.
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Customattributes
Custom attributes are named data values that you can create and set for patch policies. They provide a
way for you can save additional information about patch policies. You can use custom attributes in a
variety of ways including in scripts, network and server configuration, notifications, and CRON script
configurations. When you set a custom attribute for a patch policy, it is available to all servers attached
to the policy. For more information on custom attributes, see the SA User Guide.

Adding a custom attribute to a patch policy

When you add a custom attribute to a Solaris patch policy, the attribute values affect the servers
attached to the policy. After you add a custom attribute to a Solaris patch policy, youmust attach the
policy to amanaged server and then remediate the server against the policy.

Youmust have a set of permissions to add custom attributes to a Solaris patch policy. To obtain these
permissions, contact your SA administrator. See the SA Administration Guide for more information.

To add a custom attribute to a patch policy:

1. In the navigation pane, select Library > By Type> Patch Policies > Solaris and select a version
of Solaris.

2. In the content pane, select the Solaris patch policy and open it. The Solaris Patch Policy window
appears.

3. In the Views pane, select Custom Attributes.

4. Either select , or from the Actions menu, select Add.... A new custom attribute is added named
“New Attribute”.

5. Enter the name of the custom attribute and select Enter.
6. To give a value to the custom attribute, either double click on the row under the Value column and

enter the value, or click and enter the value in the Input Dialog.
7. Select Save from the File menu.

Deleting a custom attribute from a patch policy

To delete a custom attribute from a patch policy:

1. In the navigation pane, select Library > By Type> Patch Policies > Solaris and select a version
of Solaris.

2. In the content pane, select the Solaris patch policy and open it. The Solaris Patch Policy window
appears.

3. In the Views pane, select Custom Attributes. This displays the custom attributes defined for the
policy.

4. In the content pane, select the custom attribute that you want to delete and then click , or from
the Actions menu, select Remove.

5. Select Save from the File menu.

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 141 of 307



View patch policy history
To view the events associated with a Solaris patch policy:

1. In the navigation pane, select Library > By Type > Patch Policies > Solaris and select a version
of Solaris.

2. In the content pane, select the Solaris patch policy.
3. Right-click to open the Solaris Patch Policy window.
4. In the Views pane, select History. The content pane displays the events associated with the

Solaris patch policy. You can view the action performed on the policy, the user who performed the
action, and the time when the action was performed.

5. From the Show drop-down list, select the time period you want to see the events from.

View software policies associated with a patch policy
A software policy can contain Solaris patch policies. In the Solaris patch policy window, you can view
all software policies that include the selected Solaris patch policy as one of the items to be installed.

To view software policies that contain the selected Solaris patch policy:

1. In the navigation pane, select Library > By Type > Patch Policies > Solaris and select a version
of Solaris.

2. In the content pane, select the Solaris patch policy.
3. Right-click to open the Solaris Patch Policy window.
4. In the Views pane, select Software Policies. The content pane displays a list of software policies

that contain the selected Solaris patch policy as one of the items to be installed.

View OS sequences associated with a patch policy
In the Solaris Patch Policy window, you can view all the OS Sequences that contain the selected patch
policy as one of the items to be installed.

To view OS sequences associated with a Solaris patch policy:

1. In the navigation pane, select Library > By Type > Patch Policies > Solaris and select a
version of Solaris.

2. In the content pane, select the Solaris patch policy.
3. Right-click to open the Solaris Patch Policy window.
4. In the Views pane, select OS Sequences. The content pane displays a list of OS Sequences that

contain the selected patch policy as one of the items to be installed.

View servers attached to a patch policy
In the SA Client, you can view a list of all servers and device groups that have a selected Solaris patch
policy attached to them.

To view a list of all servers that have a selected Solaris patch policy attached to them:
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1. In the navigation pane, select Library > By Type > Software Policies > Solaris and an
operating system version.

2. In the content pane, select the Solaris patch policy and then right-click to open the Solaris Patch
Policy window.

3. In the Views pane, select Servers. A list of servers that have the selected Solaris patch policy
attached to them displays in the content pane.

Find a Solaris patch policy in folders
To find a Solaris patch policy in the folder hierarchy:

1. In the navigation pane, select Library > By Type > Patch Policies > Solaris and select a
version of Solaris.

2. In the content pane, select a Solaris patch policy.
3. Right-click and then select Locate in Folders to display the folder hierarchy for the Solaris patch

policy in the content pane.

Patch Management Tasks
Patchmanagement for Solaris consists of the following tasks:

l "Patches and patch clusters" below
l "Run solpatch_import" on page 145
l "Initialize the Solaris patch database" on page 146
l "Maintain the Solaris patch database" on page 147
l "Retrieve the latest patch data from Oracle" on page 147
l "Retrieve the Solaris patch supplementary data file" on page 147
l "Manually download the Solaris patch supplementary data file" on page 148
l "Find Solaris patches" on page 149
l "Import a patch or patch cluster" on page 151
l "solpatch_import" on page 152
l "Import a Solaris patch to SA Client" on page 152
l "Export a patch or patch cluster" on page 153
l "Open a Solaris patch" on page 153
l "Manage properties" on page 154
l "Import custom documentation" on page 159
l "Solaris zones" on page 159

Patches and patch clusters
The SA Client provides the following capabilities that help youmanage Solaris patches and patch
clusters:

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 143 of 307



l "Viewing patch cluster contents" below
l "Viewing patch clusters associated with a patch" below
l "Viewing software policies associated with a patch or patch cluster" below
l "Viewing patch policies associated with a patch or patch cluster" on the next page
l "Viewing patch policies associated with a patch or patch cluster" on the next page
l "Deleting a patch or patch cluster" on the next page

Viewing patch cluster contents

To view the contents of a Solaris patch cluster:

1. In the navigation pane, select Library > By Type > Patches. The patches organized by operating
systems appear in the content pane. Navigate to the desired OS version.

2. In the content pane, select the Solaris patch cluster.
3. From the Actions menu, select Open. The Patch Cluster window appears.
4. In the Views pane, select Contents. The list of patches included in the patch cluster appears in

the content pane.
5. Select a patch in the content pane.
6. From the Actions menu, select Open to view the patch properties.

Viewing patch clusters associated with a patch

To view the patch clusters that contain the Solaris patch:

1. In the navigation pane, select Library>By Type>Patches. The patches organized by operating
systems appear in the content pane. Navigate to the desired OS version.

2. In the content pane, select the Solaris patch.
3. From the Actions menu, select Open. The Patch window appears.
4. In the Views pane, select Patch Clusters. The list of patch clusters that contain the patch

appears in the content pane.
5. Select a patch cluster in the content pane, and from the Actions menu, select Open to view the

properties of the patch cluster.

Viewing software policies associated with a patch or patch cluster

To view the software policies that contain the Solaris patch or patch cluster:

1. In the navigation pane, select Library > By Type > Patches. The patches organized by operating
systems appear in the content pane. Navigate to the desired OS version.

2. In the content pane, select the Solaris patch or patch cluster.
3. From the Actions menu, select Open. The Patch or Patch Cluster window appears.
4. In the Views pane, select Software Policies. The list of software policies that contain the patch or

patch cluster as one of the policy items appear in the content pane.
5. Select a software policy in the content pane, and from the Actions menu, select Open to view the

properties of the software policy.
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Viewing patch policies associated with a patch or patch cluster

To view patch policies that contain the Solaris patch or patch cluster:

1. In the navigation pane, select Library > By Type > Patches. The patches organized by operating
systems appear in the content pane. Navigate to the desired OS version.

2. In the content pane, select the Solaris patch.
3. From the Actions menu, select Open. The Patch or Patch Cluster window appears.
4. In the Views pane, select Patch Policies. The list of patch policies that contain the patch or patch

cluster as one of the policy items appear in the content pane.
5. Select a software policy in the content pane, and from the Actions menu, select Open to view the

properties of the patch policy.

Viewing patch policies associated with a patch or patch cluster

To view patch policies that contain the Solaris patch or patch cluster:

1. In the navigation pane, select Library>By Type>Patches. The patches organized by operating
systems appear in the content pane. Navigate to the desired OS version.

2. In the content pane, select the Solaris patch.
3. From the Actions menu, select Open. The Patch or Patch Cluster window appears.
4. In the Views pane, select Patch Policies. The list of patch policies that contain the patch or patch

cluster as one of the policy items appear in the content pane.
5. Select a software policy in the content pane, and from the Actions menu, select Open to view the

properties of the patch policy.

Deleting a patch or patch cluster

When you delete a Solaris patch or patch cluster, it is removed from SA; however, it is not uninstalled
from your managed servers. A patch or patch cluster cannot be deleted if it is attached to a patch policy
or a software policy.

Youmust have a set of permissions to delete a patch or patch cluster. To obtain these permissions,
contact your SA administrator. See the SA Administration Guide for more information.

To delete a Solaris patch or patch cluster:

1. In the navigation pane, select Library > By Type > Patches. The patches organized by operating
system appear in the content pane. Navigate to the desired OS version.

2. In the content pane, select a patch or patch cluster to delete.
3. From the Actions menu, select Delete.

Run solpatch_import

Note: In amultimaster mesh environment, do not simultaneously run the solpatch_import
command onmore than one core system. This action could result in lost data. It is recommended
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that you run solpatch_import on your core servers, one at a time.

Some Solaris patchmanagement tasks use the solpatch_import command. Youmust have the
following permissions to run the solpatch_import command:

Type of permission Permission setting

Permissions on the folders /Opsware,
/Opsware/Tools and /Opsware/Tools/Solaris
Patching in the SA library

Youmust have full permissions on these
folders. This is where SA stores Solaris patch
information.

“Manage Patch” feature permission Youmust have “Read & Write” permission.

“Allow Install Patch” feature permission This must be set to “Yes”.

“Allow Uninstall Patch” feature permission This must be set to “Yes”.

“Manage Patch Compliance Rules” feature
permission

This must be set to “Yes”.

Permissions required for using solpatch_import

See the SA Administration Guide for more information on folder permissions and Solaris patching
permissions.

To use the solpatch_import command, youmust log in to the SA core server as root.

To run the command, log into the core server running the Software Repository component (part of the
Slice Component bundle) and, as root, run the solpatch_import command that is located in the following
directory:

/opt/opsware/solpatch_import/bin/

The complete documentation for the solpatch_import command is available by running the command
with the following option:

solpatch_import --manual

Initialize the Solaris patch database
Before you download patches and patch data from Oracle, youmust set up and initialize the Solaris
patch database in SA.

To set up and initialize the Solaris patch database:

1. Create a configuration file that specifies information needed by the solpatch_import command.
The default location for this file is /etc/opt/opsware/solpatch_import/solpatch_
import.conf.
If you do not use the default location, youmust use the -c or --conf option. If you use the default
location, you do not need the -c or --conf option.
For details on the contents of this configuration file, see the solpatch_import man page by running
solpatch_import --manual. The following example shows partial contents of a configuration file.
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[main]
hpsa_user=<SA user name>
hpsa_pass=<SA user password>
download_user=<My Oracle account user name>
download_pass=<My Oracle account password>

2. Run the following command to initialize SA for Solaris patch information:

solpatch_import -a create_db

3. This command downloads the patchdiag.xref file from Oracle (or you can specify a local copy of
this file if you previously downloaded it), examines the patch information and places the data in
SA.

Note:
You only need to use the -a create_db option once to initialize the Solaris patch information in SA.

4. Make sure your Solaris patch database contains the latest patch information. See "Maintain the
Solaris patch database" below.

Maintain the Solaris patch database
Complete the following tasks tomake sure your Solaris patch database contains the latest patch
information:

l "Retrieve the latest patch data from Oracle" below
l "Retrieve the Solaris patch supplementary data file" below
l "Retrieve the Solaris patch supplementary data file" below
Best Practice: Whichever method you use, it is recommended that you regularly check for updates and
install them to the SA patch database.

Retrieve the latest patch data from Oracle

Oracle typically updates their patch information daily Monday through Friday. To obtain the latest
Solaris patch information from Oracle (in the patchdiag.xref file) and upload it to the SA patch database,
you should routinely run the command below, based on your company policy. For example you could
place the following command in a cron job:

solpatch_import -a update_db

Retrieve the Solaris patch supplementary data file

SA retrieves information about Solaris patches from Oracle (from the patchdiag.xref file). However, SA
provides valuable supplementary data about Solaris patches that you can obtain automatically from the
HP Live Network. When HP updates this supplementary data, you can configure the HP Live Network
to automatically upload it to the SA Solaris patch database.

To obtain the supplementary data file when it is updated and upload it into the SA Library:

1. Obtain an HP Passport ID from:
http://h20229.www2.hp.com/passport-registration.html
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2. Log in to the HP Live Network portal using your HP Passport credentials:
https://hpln.hpe.com/group/hp-live-network-connector

3. The HP Live Network connector (LNc) is installed on the core server where the SA Software
Repository component is installed.
You can download the HP Live Network Connector User Guide from the Live Network Connector
community on the HP Live Network at:
https://hpln.hpe.com/group/hp-live-network-connector
Click the Resources tab and open the Documentation folder.

4. On the system where the LNc is installed, run the following command to enable the Solaris
patching service:

live-network-connector write-config --setting=content.solaris_patching=1

5. (Optional) To disable the Solaris patching service, run the same commandwith the value set to 0:

live-network-connector write-config --setting=content.solaris_patching=0

Alternatively, you canmanually download the supplementary Solaris patch data file from the HP Live
Network and upload it to the SA database. See "Manually download the Solaris patch supplementary
data file" below.

Manually download the Solaris patch supplementary data file

This section describes how tomanually download the supplementary Solaris patch data file from the
HP Live Network and upload it into the SA patch database. It is recommended that you set up the LNc
to automatically upload this file whenever it changes as described in "Retrieve the Solaris patch
supplementary data file" on the previous page. However, if you download the file manually, you should
regularly check for updates and install them into the SA patch database as described here.

To obtain the supplementary data file:

1. Obtain an HP Passport ID from:
http://h20229.www2.hp.com/passport-registration.html

2. Log in to the HP Live Network portal using your HP Passport credentials:
https://hpln.hpe.com/group/hp-live-network-connector

3. The HP Live Network connector (LNc) is installed on the core server where the SA Software
Repository component is installed.
You can download the HP Live Network Connector User Guide from the Live Network Connector
community on the HP Live Network at:
https://hpln.hpe.com/group/hp-live-network-connector
Click the Resources tab and open the Documentation folder.

4. Click Content Catalog from the HP Live Network menu and search for ““Solaris Patching for
Server Automation” under the Server Automation product.

5. Download the latest Solaris patching package, named solpatchdb_supplement.zip, and place it in
the Core slice server in any temporary directory such as /tmp.

6. Unzip the solpatchdb_supplement.zip file.
7. Run the file install.shwhich was in the solpatchdb_supplement.zip file. This uploads the

Solaris patch supplementary data into the SA patch database.
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8. Since HP updates the Solaris patch supplementary data file, it is recommended that you
periodically check this file for updates and when this file changes, follow these steps again to
download the latest supplementary patch information into your SA patch database.

Find Solaris patches
With SA you can quickly and easily determine which patches your Solaris servers need.

Using the solpatch_import command, you can:

l Display Solaris patches required by your Solaris servers, including all dependent patches and
patches listed in the correct install order.

l Download those patches and import them to the SA Library.
l Add those patches to a Solaris patch policy.
The following table lists options for the solpatch_import command to display patch information,
download patches, import them to the SA Library, and add them to a Solaris patch policy.

Option to
solpatch_
import
command Description

-a show
or
--action show

Displays information about the specified patches.

-a import
or
--action import

Downloads the specified patches and imports them into the SA Library.

-a policy
or
--action policy

Downloads the specified patches, imports them into the SA Library, and places
them in the specified Solaris patch policy. This action requires you to specify a
Solaris patch policy using the --policy_path option.

Specifying actions for the solpatch_import Ccmmand

The solpatch_import command finds all patches that are applicable to your managed servers,
excluding patches that are not applicable. For example, if you do not have certain software applications
or dependent patches installed, SA considers certain patches as not applicable. The resulting set of
patches are complete and in the required install order.

"Specifying desired patches with the Filter option to solpatch_import" below lists the solpatch_import
command filters that specify which Solaris patches you want:

Desired set of patches

Filter
options
to use Example filter option

Description of example Filter
option

All patches
recommended by Oracle

rec
server

-f
“rec,server=sys01.hpe.com”

Specifies all patches
recommended by Oracle for the

Specifying desired patches with the Filter option to solpatch_import
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Desired set of patches

Filter
options
to use Example filter option

Description of example Filter
option

for a particular server sys01.hp.commanaged
server.

All patches
recommended by Oracle
for a set of servers

rec
platform

-f “rec,OS=5.10” Specifies all patches
recommended by Oracle for all
managed servers running
Solaris 5.10.

All Oracle security
patches for a particular
server

sec
server

-f “sec,
server=sys01.hpe.com”

Specifies all Oracle security
patches for the sys01.hp.com
managed server.

All Oracle security
patches for a set of
servers

sec
OS

-f “sec, OS=5.9” Specifies all Oracle security
patches for all managed
servers running Solaris 5.9.

All Oracle security
patches and all Oracle
recommended patches
for a server.

rec
sec
server

-f “rec, sec, OS=5.8” Specifies all Oracle security
patches and all the Oracle
recommended patches for all
managed servers running
Solaris 5.8.

Specifying desired patches with the Filter option to solpatch_import, continued

The following examples show ways you can use the solpatch_import command to determine which
patches are needed by your Solaris servers:

l "Finding all patches required by a selected server" below
l "Finding Oracle recommended patches for your servers" on the next page
l "Finding Oracle security patches for your servers" on the next page
l "Finding a specific set of patches" on the next page

For complete information, run solpatch_import --manual as described in "Run solpatch_import" on
page 145.

Finding all patches required by a selected server

The following example command finds all the patches needed by the server named “sys01.hp.com”.
The first command just displays the list of patches. The second command downloads the patches and
places them into the SA Library. The third command places them into the Solaris patch policy names
“SolPatches/MyPolicy”.

solpatch_import --action=show --filter=”server=sys01.hpe.com”
solpatch_import --action=import --filter=”server=sys01.hpe.com”
solpatch_import --action=policy --policy_path=”SolPatches/MyPolicy”\
   --filter=”server=sys01.hpe.com”
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Finding Oracle recommended patches for your servers

The following example command finds the Oracle recommended patches for all managed servers
running Solaris 10. The first command just displays the list of patches. The second command
downloads the patches and places them into the SA Library. The third command places them into the
Solaris patch policy namedMySolPolicy.

solpatch_import --action=show --filter=”rec,OS=5.10”

solpatch_import --action=import --filter=”rec,OS=5.10”

solpatch_import --action=policy --policy_path=”MySolPolicy\”    --
filter=”rec,OS=5.10”

Finding Oracle security patches for your servers

The following example command displays the Oracle security patches for all your managed servers
running Solaris 9:

solpatch_import --action=show --filter=”sec,OS=5.9”

Finding a specific set of patches

You can display information about one or more patches by providing the patch names to the solpatch_
import command or in a text file. This example assumes the file my_sol_patches.txt contains the
following lines:

120900-04 121133-02 119254-67
119317-01 121296-01 127884-01

The following example command displays the set of patches listed in the file my_sol_patches.txt:

solpatch_import --action=show my_sol_patches.txt

The following command downloads the set of patches listed in the file my_sol_patches.txt and places
the patches into the SA Library:

solpatch_import --action=import my_sol_patches.txt

The following example command downloads the set of patches listed in the file my_sol_patches.txt,
places the patches into the SA Library, and places the patches into a Solaris patch policy named
“/SolPatches/SolPatchPolicy”:

solpatch_import --action=policy --policy_path=/SolPatches/SolPatchPolicy \
  my_sol_patches.txt

Formore information on the solpatch_import command, see "Run solpatch_import" on page 145.

Import a patch or patch cluster
You can import a patch or patch cluster by using solpatch_import command or you can import a patch
or patch cluster by using the SA Client.
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solpatch_import

Best Practice: HP recommends that you use the solpatch_import command to import Solaris
patches and patch clusters from Oracle.

With the solpatch_import command you can automatically download Solaris patches and patch
clusters from Oracle, import them into SA, place them into Solaris patch policies, and store the patch
policies in a folder in the SA Library. The solpatch_import command also downloads reboot settings
and patch dependencies and saves them with the patch.

Import a Solaris patch to SA Client

You can also import Solaris patches by using the SA Client.

Solaris patches are downloaded from Oracle and stored in SA.

To see if a patch has been imported, view the patch’s Availability property in the SA Client. The
Availability property of an imported patch can be set to one of the values listed in the following table.

Patch
availability
setting Description

Available The patch has been imported into SA, has been tested, and can be installed on
managed servers.

Limited The patch has been imported into SA but requires additional permissions (Manage
Patch: Read & Write) to be installed. This is the default patch availability. For more
information on permissions, see the SA Administration Guide.

Deprecated The patch cannot be added to patch policies but can still be installed.

Not
Imported

The patch is not stored in the SA library.

Patch availability property settings

Youmust have permissions to import Solaris patches or patch clusters. To obtain these permissions,
contact your SA administrator. See the SA Administration Guide for more information.

To import a Solaris patch or patch cluster from a file into SA:

1. In the navigation pane, select Library > By Type > Patches. The patches are organized by
operating system.

2. From the Actions menu, select Import Software to open the Import Software window.
3. Click Browse to locate and select the patch or patch cluster to import.

Before you click Open in the Open window, select the character encoding to be used by the patch
or patch cluster from the Encoding drop-down list.
Youmust specify the character encoding so that SA can extract themetadata contained in the
patch or patch cluster and then correctly display the information in non-ASCII characters in the SA
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Client, such as in the Patch Properties window. Patchmetadata includes comments, READMEs,
scripts, descriptions, and content lists.

4. Click Open.
5. In the Import Software window, from the Type drop-down list, select eitherSolaris Patch or

Solaris Patch Cluster.
This action grays out the Folder edit field because Solaris patches and patch clusters are not
stored in folders.

6. From the Platform drop-down list, select the applicable Solaris operating system.
7. Click Importt to import the Solaris patch or patch cluster into SA.
8. Run the following command to update the Solaris patch information in SA:

solpatch_import -a update_db

Export a patch or patch cluster
You can export a Solaris patch or patch cluster to your local computer so that you can check the
installation of the patch or patch cluster on a test or stagingmachine.

To export a patch or patch cluster to your local drive:

1. In the navigation pane, select Library > By Type > Patches. The patches are organized by
operating system in the content pane. Navigate to the desired operating system version.

2. In the content pane, select a patch or patch cluster to export.
3. Right click or from the Actions menu, select Export to openthe Export Patch window.
4. Specify the location for the package to be exported to.
5. Click Export.

Open a Solaris patch
In the SA Client, you open a Solaris patch by using any of the following navigation features:

l "Search" below
l "Library—By Type" on the next page
l "Library—By Folder" on the next page

Search

1. In the navigation pane, select Search.
2. Select Patch from the drop-down list and then enter the name of the Solaris patch or patch cluster

in the text field.

3. Select . The search results appear in the content pane.
4. In the content pane, select the patch or patch cluster.
5. From the Actions menu, select Open to open the Patch or Patch Cluster window.
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Library—By Type

To use the By Type feature to view a patch policy:

1. In the navigation pane, select Library> By Type >Patch Policies> Solaris to display the Solaris
patch policies in the content pane.

2. In the content pane, select the Solaris patch policy and then right-click to open the Solaris Patch
Policy window.

Library—By Folder

To use the By Folder feature to view a patch policy:

1. In the navigation pane, select Library> By Folder. The content pane displays the folder hierarchy
in the library.

2. In the content pane, select the folder that contains the patch policy.
3. Right-click to open the folder.
4. Select the patch policy and then right-click to open the Solaris Patch Policy window.

Manage properties
To view the properties of a Solaris patch, patch cluster, or patch bundle:

1. In the navigation pane, select Library > By Type > Patches. The patches are organized by
operating system appear in the content pane. Navigate to the desired OS version.

2. In the content pane, select the Solaris patch, patch cluster or patch bundle to view.
3. Right-click and select Open to display the Patch window.
4. In the Views pane, select Properties to display the patch properties.
Patch Properties window
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General properties

l Name: The name of the patch, patch cluster or bundle, as defined by Oracle.
l Description: The description of the patch, cluster, or bundle’s contents.
l Version: The version number, as defined by Oracle.
l Status: The status as defined, by Oracle.
l ReadmeURL: A link to documentation about the patch. Youmust provide your My Oracle
credentials to view this information.

l Type: Specifies whether the item is a patch, a patch cluster, or a patch bundle.
l OS: The operating systems associated with the patch, cluster, or bundle.
l Availability: The availability of the patch to SA users. You can set this to Limited, Available or
Deprecated.

l Last Modified: The date and time when the patch was last modified and the SA user who last
modified the patch.

l Created: The date and time when the patch or patch cluster was created by an SA user.
l File Name: The file name of the package.
l File Size: The file size of the package.
l Object ID: The unique SA identifier for the package.

Dependencies

The following figure shows the dependencies for a patch in the Patch Properties window.

Patch Dependencies

l Prerequisites: The patches that must be installed before this patch can be installed.
l Obsoletes: The older patches that aremade obsolete by this patch.
l Obsoleted by: The newer patches that make this patch obsolete.
l Incompatible: The patches that cannot be installed with this patch.

Install parameters

The following figure shows a list of the actual settings for the patch and the settings that Oracle
specifies for the patch. The selected radio buttons are the actual settings that will be used when the
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patch is installed. Settings that Oracle recommends are labeled “Oracle default”. TheOracle default
settings are the values that were downloaded with the patch.

The settings specified by the selected radio buttons will be used when the patch is installed. However,
when you remediate a server against a patch policy or install a patch, you can override these settings.
For more information, see "Rebooting options" on page 124.

Install Parameters in the Patch Properties window

l Install Flags: (Optional) Arguments that are used when the patch or patch cluster is installed on a
managed server.

l Reboot Required: Specifies whether themanaged server will be rebooted when the patch or patch
cluster is successfully installed. Oracle’s recommendation is labeled “Oracle default”.

l Install Mode: Specifies whether the patch or patch cluster will be installed in single user mode or
multi-user mode. Oracle’s recommendation is labeled “Oracle default”. The Solaris system is
rebooted to get into single user mode, then the patch is installed, and then the system is rebooted to
get to multi-user mode.

l Reboot Type: Specifies whether a standard reboot or a reconfiguration reboot will be performed after
installing the patch or patch cluster. Oracle’s recommendation is labeled “Oracle default”.

l Reboot Time: Specifies whether the server will be rebooted immediately after installing the patch or
at some later time after the patch or patch cluster is installed. Oracle’s recommendation is labeled
“Oracle default”.
When installing a patch with the setting Reboot Time: Normal, the reboot will occur at the end of the
job, unless another patch in the job requires an immediate reboot before the end of the job. However,
the Job Preview and the Job Status windows will display the Install and Reboot message for the
patch. This indicates that the reboot will occur sometime after the patch is installed, not immediately
after the patch is installed.

Install scripts

l Pre-Install Script: A script that is required to run on amanaged server before the patch or patch
cluster is installed.

l Post-Install Script: A script that is required to run on amanaged server after the patch or patch
cluster is installed.

l If script returns an error: Specifies whether or not to stop the installation of the patch or patch
cluster if the script fails.
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Uninstall parameters

l Uninstall Flags: (Optional) Arguments that are used when the patch or patch cluster is uninstalled
from amanaged server.

l Reboot Required: Specifies whether themanaged server will be rebooted when the patch or
patch cluster is successfully uninstalled. Oracle’s recommendation is labeled “Oracle default”.

l Uninstall Mode: Specifies whether the patch or patch cluster will be uninstalled in single user
mode or multi-user mode. Oracle’s recommendation is labeled “Oracle default”. The Solaris
system is rebooted to get into single user mode, then the patch is uninstalled, and then the
system is rebooted to get to multi-user mode. (See "Troubleshoot Solaris patch installation " on
page 125 for additional tips about install modes.)

l Reboot Type: Specifies whether a standard reboot or a reconfiguration reboot will be performed
after uninstalling the patch or patch cluster. Oracle’s recommendation is labeled “Oracle default”.

l Reboot Time: Specifies whether the server will be rebooted immediately or at some later time
after the patch or patch cluster is uninstalled. Oracle’s recommendation is labeled “Oracle
default”.

Uninstall scripts

l Pre-Uninstall Script: A script that is required to run on amanaged server before the patch or patch
cluster is uninstalled.

l Post-Uninstall Script: A script that is required to run on amanaged server after the patch or patch
cluster is uninstalled.

l If script returns an error: Specifies whether or not to stop the uninstallation of the patch or patch
cluster if the script fails.

Editing properties

After you upload a new Solaris patch, patch cluster, or patch bundle, or select an existing one, you
can add or edit many of its properties in the SA Client.

Note:
Youmust have a set of permissions to edit the properties of a patch or patch cluster. To obtain
these permissions, contact your SA administrator. See the SA Administration Guide for more
information.

To edit the properties of a Solaris patch, patch cluster, or patch bundle:
a. In the Patch window, select a patch.
b. Right-click to open the Patch Properties.
c. Edit any of the properties that are editable in the SA Client.
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Viewing the vendor readme

The SA Client gives you access to patch information from Oracle, using the URL provided with the
downloaded patch, cluster, or bundle.
To view the readme:
a. In the navigation pane, select Library>By Type>Patches. The patches are organized by

operating system. Navigate to anOS version.
b. In the content pane, select a Solaris patch, patch cluster, or patch bundle to view.
c. From the Actions menu, select Open. This displays the patch information window.
d. In the Views pane, select Properties. This displays information about the patch, including a

URL link to the patch information.
e. Select the ReadmeURL and enter your My Oracle credentials to view the vendor information.

Import customdocumentation
To import custom documentation for a Solaris patch or patch cluster using the SA Client:

1. In the navigation pane, select Library > By Type > Patches. The patches are organized by
operating system. Navigate to the desired OS version.

2. In the content pane, select the Solaris patch or patch cluster to view.
3. Right-click and then select Open. The Patch or Patch Cluster window appears.
4. In the Views pane, select Custom Documentation. The contents of the Custom Documentation

for the patch or patch cluster appear in the content pane.
5. From the Actions menu, select Import. The Import Custom Documentation window appears.
6. In the Import Custom Documentation window, locate the text file and specify the encoding.
7. Click Import.

Solaris zones
The SA Client provides the following capabilities that help youmanage Solaris zones:

l "Patching Solaris zones" below
l "Viewing Solaris zones " on the next page

Patching Solaris zones

SA virtual server management enables you to perform the same operations on virtual servers that you
can perform on physical servers, including audit, remediation, application configuration, software
management, patchmanagement, and so on.

You can install patches on Solaris global and non-global zones by using Solaris patch policies or by
installing patches directly on a virtual server. In the SA Client, you can view the Solaris zones from
either theManaged Servers lists or the Virtual Servers list.
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Viewing Solaris zones

To view Solaris zones:

1. In the navigation pane, select Devices.
2. ExpandServers.
3. Select Virtual Servers to display a list of virtual servers in the content pane.

Or
SelectManaged Servers. To identify whether a server is a hypervisor or a virtual server in the All
Managed Servers list, select Virtualization from the column selector.

4. From the View drop-down list, select Virtualization to display the configuration properties of the
virtual server.

Uninstall a Solaris patch
When you remove a Solaris patch or patch cluster from a Solaris patch policy, this action does not
uninstall it from amanaged server. This action only removes the Solaris patch or patch cluster from the
Solaris patch policy. To uninstall a Solaris patch from amanaged server, youmust directly uninstall the
Solaris patch from themanaged server. To remove a patch cluster, youmust remove each of the
patches in the patch cluster from themanaged server.

SA provides the following ways to uninstall Solaris patches frommanaged servers or device groups:

l Uninstall a Solaris patch directly from amanaged server by using the Uninstall Patch wizard.
l Uninstall a Solaris patch directly from amanaged servers by using the Uninstall Software wizard.
In the SA Client, you can check for patch compliance on an individual server or view overall compliance
levels for all servers and groups of servers in your facility.

Patch management for Solaris 11
Oracle Solaris 11 uses IPS packages to deliver software and software updates. IPS (Image Packaging
System) is a network-based packagemanagement system that is used for the entire software
lifecycle, including package installation, upgrade and removal.

Server Automation's Solaris 11 platform support for server patching allows you to update your managed
servers to the latest versions of existing software without installing new software. This is a powerful
way to keep your system up to date in an environment that no longer supports explicit patch units.

Solaris 11 patching support leverages the existing Solaris patching functionality, with a few differences
to adapt to the new Solaris IPS package delivery structure. Additionally, there are setup requirements
for setting up the initial IPS Package database. This section describes the Solaris 11 Patching setup
steps and the differences in SA patching with Solaris 11.
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Get started with Solaris 11 patching
The advantage of the IPS package structure is that it contains themetadata and the binaries,
combined. IPS packages are used for everything from the initial software installation to the updates.
Because IPS packages are so complete, they have internal integrity, whichmeans they require the
complete package and are not divided into patch units.

Because of these structural differences, there are some typical patching functions that are not relevant
for Solaris 11.

The process for creating a vendor recommended patch policy is different. For example, Solaris 10 looks
at installed packages and computes what needs to be updated based on the existing installations. With
Solaris 11, Server Automation uses the IPS tools to find the recommended patches and their
dependencies.

SA comes with a predefined software policy, Solaris 11 IPS Package Acquisition Tool, which enables
you to set up the initial IPS Package database.

Summary
Complete the following steps to set up your initial IPS Package database and enable Solaris 11
patching with SA. The initial IPS Package acquisition only needs to be done using one Solaris 11
managed server. After the initial acquisition, additional updates will need to be done periodically to
maintain compliance. These instructions are just for the initial acquisition.

RECOMMENDATION: The entire IPS Package repository could be as large as 40GB. Tomake sure
there is ample room on your server, choose a Solaris 11managed server with 100GB ormore.

This summary has two parts:

l Set up your Solaris 11 IPS Package Database
l Create a recommended patch policy and remediate your Solaris 11managed servers
Detailed instructions for each of these steps are provided under "Set up Solaris 11managed server for
SA patching" on the next page.

To set up your Solaris 11 IPS package database:

1. Remediate the chosen Solaris 11managed server with the SA-provided software policy, Solaris
11 IPS Package Acquisition Tools.
This installs SA UAPI access and IPS import tools on the server, which will be used to acquire
IPS packages from the vendor.

2. Complete the import prerequisite steps before importing IPS packages:
a. SetupManaged Server Customers to have visibility to all relevant IPS packages in the SA

Library.
b. If your environment requires HTTP proxies to access the desired repository, set up the

proxies on your managed server before attempting to import the IPS packages.
c. Configure sol_ips_import.conf

3. Import all IPS packages onto the core by running the IPS import script (sol_ips_import) from the
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chosen Solaris 11managed server.
4. If software registration has not yet occurred, run the Software Registration script (bs_software).
This completes the IPS Package Database set-up steps. Next, create the patch policy and remediate
your Solaris 11 servers.

To create a recommended patch policy and remediate your Solaris 11managed servers:

1. Create the recommended patch policy for themanaged server by running the patch policy script
(solpatch_import) on the core.

2. From the SA Client, attach the recommended patch policy to the server and remediate.

Set up Solaris 11managed server for SA patching
Use the following steps to set up Solaris 11Managed Servers for SA Patching:

"STEP 1: Remediate themanaged server with the Solaris 11 IPS Package Acquisition software policy"
below

"STEP 2: Complete the Import prerequisites" below

"STEP 3: Import all IPS packages onto the core by running the IPS import script (sol_ips_import)" on
page 165

"STEP 4: Register the software" on page 168

"STEP 5: Create the recommended patch policy (run solpatch_import)" on page 168

"STEP 6: Attach the recommended patch policy to a server and remediate " on page 169

STEP 1: Remediate themanaged server with the Solaris 11 IPS
Package Acquisition software policy
1. From the SA Client, navigate to SA Library > By Type and select Solaris 11 IPS Package

Acquisition Tools.
2. From the Actions menu, select Attach Server….
3. Select Remediate Servers Immediately. (This option enables the remediation process to run

immediately after attaching the servers.)
4. Select the desired servers to remediate and click Attach.
5. In the Remediate window, accept all remaining defaults and click Start Job to remediate the

selected servers.

STEP 2: Complete the Import prerequisites
l Grant amanaged server's customer visibility to all relevant IPS Packages in the SA Library
l Granting customer visibility is a prerequisite to running the sol_ips_import script to import the IPS
packages.

The IPS packages are delivered to a directory in the SA Library on the core, but the import script is run
from themanaged server. There is one customer per managed server and the customer governs the
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managed server's visibility into the SA Library. When the sol_ips_import script runs, it bases the
analysis of what to import on the set of IPS packages themanaged server's customer can see. For this
reason, the customer associated with themanaged server where the import is being runmust have
visibility to all IPS packages.

To achieve that, grant the customer folder permission for the parent folder of the destination directory
for the IPS packages.

1. Identify themanaged server's customer from themanaged server properties view.
a. From the SA Client, navigate to Devices and select themanaged server you wish to update.
b. Select View > Properties to display the server properties in the details pane.
c. The customer is displayed under theManagement Information section.

2. Grant IPS package folder permission to the customer:
a. From the SA Client, navigate toSA Library > By Folder and select the parent folder for the

customer's Solaris 11 IPS packages.
For example, this is sample file structure for an "Accounting" customer:

In this example, the library has folders organized by customers; Accounting and Engineering. All
the IPS packages associated with each customer are under the customer folders. In this case,
you would select the "c_Accounting" parent directory because you want to give the customer
permission to the upper-most directory for that customer tomake sure it has visibility to ALL the
IPS packages.
b. Select Actions > Folder Properties > Customer tab.
c. Click Add and select the customer for themanaged server with the IPS import tools.
d. Click Add and thenOK.

Running the sol_ips_import script without giving themanaged server's customer visibility to this folder
could have adverse effects. The customer's folder permissions affect what patches are recommended
for the server. Without correct customer folder permissions, the script might unnecessarily re-upload
thousands of patches to the core.

Setting the HTTP proxies
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If your environment requires HTTP proxies (e.g., http_proxy, https_proxy) to access your desired
repository, make sure they are set correctly on your managed server before importing the IPS
packages.

Configure the IPS package import configuration file (sol_ips_import.conf)

1. Setting up the sol_ips_import.conf configuration file before running the sol_ips_import import
script is recommended to save time and improve reliability.

2. From a remote server window, log in to the Solaris 11managed server.
3. Navigate to /opt/opsware/solimport
4. Open the configuration file: sol_ips_import.conf
5. Edit the configuration file to define your preferences for the IPS package download process:

Configuration
File option Explanation and example

User name
and password

Specify your SA login credentials

Local
download
directory

Specify the staging directory on your managed server where the packages are
initially downloaded from the vendor.

For example: download_dir=/var/<UserFolderName>/IPSPkg_Stage

RECOMMENDATION: The entire IPS Package repository could be as large as 40
GB. Tomake sure there is ample room on your server, choose a Solaris 11
managed server with 100GB ormore.

SA Folder
Upload
directory

Specify the final destination directory on the SA Core where the IPS packages will
be stored.

For example: core_destination_
folder=/Home/<AllSolaris11CustomersFolderName>/

URL of the
IPS repository

Specify the URL of the vendor's IPS repository from which the packages will be
acquired.

For example:

repo_url=https://pkg.oracle.com/solaris/support

or:

repo_url=https://pkg.oracle.com/solaris/release

Note: This is an example of Oracle's repositories for demonstration purposes
only. In this example, the…/release URL contains updates for each new
release of Oracle Solaris, and…/support contains bug fixes and updates, but
is restricted to those with support contract. Many vendors supply IPS
packages andmay deliver packages to different directories for various
purposes. Specify the one for your purpose.

Get only the Set to True to acquire all packages; False to only get the latest versions.

IPS configuration file options defined
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Configuration
File option Explanation and example

latest
packages

For example:all_versions=False

Certificate and
Key files

If the vendor's repository requires a certificate and key authentication, you can set
them up here.

For example:

cert=/var/pkg/ssl/Oracle_Solaris_11_Support.certificate.pen
key=/var/pkg/ssl/Oracle_Solaris_11_Support.key.pen

Note: all examples are for demonstration purposes only.

IPS configuration file options defined, continued

STEP 3: Import all IPS packages onto the core by running the IPS
import script (sol_ips_import)
Unless otherwise specified in the command line, the sol_ips_import commandwill run according to the
details specified in the sol_ips_import.conf configuration file in the previous step.

1. Log in to the Solaris 11 server where you installed the IPS Acquisition tools.
2. Test the connection to the remote repository before running the import, run the sol_ips_import

commandwith a string filter first. For example, to display all packages containing 'telnet', run:

./sol_ips_import -f 'telnet' –n

where -n indicates preview instead of download, and -f specifies a filter.
3. Run the IPS Package import, run the command:

./sol_ips_import

The IPS packages will download from the vendor's repository to the local staging directory on the
managed server and then upload to the final destination directory on the core as specified in the
.conf file.
In order to construct an upgrade path, SA's repository needs to have all versions of a package, not
just the latest. In order to import all versions of a package, you can use the following option to
import all versions of a package: --all_versions

For details about this and other command options, see the "Command options for sol_ips_import"
on the next page table.

Options for handling upload failures:

When the IPS Package import process is complete, the fmrifail_<DATE> file tracks any files that failed
to upload to the core. This file can bemanually run with the --fmri_file option:

./sol_ips_import --fmri_file fmrifail_<DATE>

where <DATE> is the date and time that the upload started, as included in the filename.

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 165 of 307



If any files have failed to upload, the import script will automatically attempt to re-download and upload
them. If the automatic upload does not work, you can also use the --force_process flag tomanually
force a re-download and upload.

./sol_ips_import –f ‘<package name>’ --force_process

Options for setting the number of download retry attempts:

A failed package will attempt to download three times, by default. You can change the number of retries
at the command line or by modifying the configuration file, sol_ips_import.conf.

The command-line option:

-a <MAX_RETRY_ATTEMPTS>

or

--max_download_attempts=<MAX_RETRY_ATTEMPTS>

where <MAX_RETRY_ATTEMPTS> is replaced by a whole number representing themaximum number of
attempts

The configuration-file setting:

max_retry_attempts=3

where “3” is the default value, but can be any whole number representing themaximum number of
attempts

As a rule, the command line option will supersede the configuration file setting. If the command line
option is not used and there is no configuration file value defined for this setting, then the default is three
retry attempts.

Note: Run ./sol_ips_import –h for information about additional command options.

In the following CommandOptions table, variables are represented in ALL CAPS

Command option Description

-a MAX_RETRY_
ATTEMPTS

--max_download_
attempts=MAX_
RETRY_ATTEMPTS

Specify themaximum number of times a failed package download will be
retried. If no value is specified, the default behavior is three attempts.

--all_versions Get ALL available package versions from the remote repository. Defaults
to latest. Results in ~300% more packages.

By enabling this option, you will import the entire Oracle repository into
SA.

This option is available to import all packages if you are unable to generate
recommended packages using the default package import option.

-c REPO_CERT, or
--cert=REPO_CERT

Certificate file for IPS repository such as Oracle_Solaris_11_
Support.certificate.pem

Command options for sol_ips_import
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Command option Description

--config=CONFIG_
PATH

Read command line options from this file. Defaults to sol_ips_import.conf

-d DOWNLOAD_DIR,
or
--download_
dir=DOWNLOAD_DIR

Directory on local system to store packages

--download_only Download packages only

-f PKG_FILTER, or
--filter=PKG_FILTER

Uses a Python regular expression string to filter available packages. In
upload-only mode, this filters the file name

--fmri_file=FMRI_FILE File containing one FMRI per line that will be used to filter the repository's
available packages. In upload-only mode, this will filter against the FMRI
associated with a file

--force_process Force acquisition and upload of packages that have been previously
uploaded to the core.

-h, or
--help

Show this helpmessage and exit

-k REPO_KEY, or
--key=REPO_KEY

Key file for IPS repository such as Oracle_Solaris_11_Support.key.pem

-m, or
--manual

Show manual page and exit

-n, or
--preview

Show what would be downloaded from the remote repository (dry-run)

-p HPSA_PASS, or
--hpsa_pass=HPSA_
PASS

SA password that will be used to upload packages

-s REPO_URL, or
--
sourcerepourl=REPO_
URL

URL of a IPS repository

-u HPSA_USER, or
--hpsa_user=HPSA_
USER

SA user that will be used to upload packages

--upload_only Uploaded packages from local directory specified by
--download_dir

--version Show program's version number and exit

Command options for sol_ips_import, continued
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Command option Description

-w OPSWARE_
FOLDER, or
--core_destination_
folder=OPSWARE_
FOLDER

Destination folder in the SA folder system

Command options for sol_ips_import, continued

STEP 4: Register the software
Software Registration occurs automatically during SA Agent deployment or within 24 hours of
deployment, depending on the options set during deployment.

If software registration has not yet occurred, you can run the Software Registration script manually:

1. Log in to themanaged server.
2. Run the Software Registration script:

/opt/opsware/agent/pylibs/cog/bs_software –full

STEP 5: Create the recommended patch policy (run solpatch_
import)
1. Log in to the SA core server as root.
2. Create recommended patch policy for themanaged server by running the solpatch_import script.

For example:

/opt/opsware/solpatch_import/bin/solpatch_import -a policy --policy_path='svrname-
policy-all-new' --filter="rec,server=svrname"

where policy_path = the name of the policy, filter = the name of the server, and rec =
recommended patches.

Note: Both of the path and filter options are required to create a recommended patch policy for a
particular server.

Note: To perform a preview before creating the policy use the –a show option.

For example, to preview the policy with recommended patches for the 'kalai' server, run:

/opt/opsware/solpatch_import/bin/solpatch_import -a show --
filter="rec,server=kelai"

Then, to create a patch policy named 'kalai-policy-all-new' on the 'kelai' server, run:

/opt/opsware/solpatch_import/bin/solpatch_import -a policy --policy_path='kelai-
policy-all-new' --filter="server=kelai"
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Note: Run /opt/opsware/solpatch_import/bin/solpatch_import–h for information about additional
command options. Additional details about the solpatch_import command options are provided in
the "Patchmanagement for Solaris 11 " on page 160.

STEP 6: Attach the recommended patch policy to a server and
remediate
To attach a Solaris patch policy to a server:

1. In the navigation pane, select Devices > Servers > All Managed ServersorDevices > Device
Groups.

2. In the content pane, select the desired Solaris 11 servers or device group.
3. From the Actions menu, select Attach > Patch Policyto open the Attach Solaris Patch Policy

window.
4. From either the Browse Solaris Patch Policies or Browse Folders tab, find and select the

recommended patch policy that you just created.
5. Select Remediate Servers Immediately. (This option enables the remediation process to run

immediately after attaching the servers.)
6. Click Attach.
7. In the Remediate window, accept all remaining defaults and click Start Job to remediate the

selected server.

Best practice: Youmay remediate multiple servers at once, but since the IPS Packages in the policy
are based on a specific server, the servers that you remediate must be at the same level of
maintenance in order for the policy to be a perfect fit. The recommended best practice is to use one
policy per server, or to manage servers via a device group to keep their maintenance levels in sync.

SA patching in Solaris 11
Solaris 11 patching support leverages the existing Solaris patching functionality, with a few differences
to adapt to the new Solaris IPS package delivery structure.

l "IPS packages and server types in Solaris 11 recommended patch policies " below
l "Differences in Solaris 11 patch policies" on the next page
l "Differences in Solaris 11 remediation" on the next page
l "Solaris 11 patch policy rules" on page 171
l "Reasons an IPS packagemight not install" on page 171
l "Other differences" on page 171

IPS packages and server types in Solaris 11 recommended patch
policies
The recommended Solaris 11 patch policy that is created via the solpatch_import command applies to
both types of Solaris 11 servers: SunOS 5.11 (SPARC) or SunOS 5.11 x86 (x86). Individual IPS
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Packages can apply to Solaris 11 servers with SPARC architecture, x86 architecture, or both. The SA
remediation process prevents irrelevant or wrong packages from installing.

Differences in Solaris 11 patch policies
l All patch units are IPS Packages, so when adding items to Solaris 11 patch policies, there are only
two item types: IPS packages and scripts.

l The Resolve Dependency action is not needed because the dependency check is done during
remediation for Solaris 11. For previous versions of Solaris, the Resolve Dependency action was a
separate step that needed to be done within the policy before remediation.

l A Solaris 11 patch policy only performs applicable updates on IPS packages that are already
installed on amanaged server.
For instance:
If a managed server has the following files:
l X version 1 and

l Y version 2

and you try to install these files:
l X version 2,

l Y version 2, and

l Z version 2

only X version 2 will be installed because it is an update to X version 1, which is already installed on
the server.

Package Y will be omitted from the install because it is already up to date; Z will be omitted because it
was not updating a package that already existed on the server.

Differences in Solaris 11 remediation
l Applicability analysis: SA verifies that the IPS package is relevant to the server by determining if a
previous version of the package has already been installed on the server. If a previous version does
not exist or if a superseding package does, then the IPS package is considered not applicable.

l Remediation process: Remediating IPS packages essentially installs the new IPS package version
on top of the previous version.

After running the remediation job, a new boot environment (BE)may be created. In this case, the server
will not be compliant until after the server reboots and the new packages are available. If a new BE is
required, then the system will need to reboot. The reboot options defined for the remediation job will be
obeyed.

We recommend not to change the Default Reboot Setting, “Hold all server reboots until all actions
have completed” when remediating a Solaris 11 Patch Policy. Changing this default reboot setting
may result in patches not being installed during a patch policy remediation.

See Solaris documentation for information on Solaris 11 boot environments and zones.
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Solaris 11 patch policy rules
Solaris 11 patch policy supersedence rules

If IPS package Z version 1 and version 2 are included in a policy, Z version 1 will bemarked as
superseded by Z version 2 and will not be installed.

Solaris 11 patch policy applicability rules

1. If IPS package Z version 2 is in the policy, and no previous version of Z is installed on the
managed server, Z version 2 will not be installed.

2. If IPS package Z version 1 is in the policy, and Z version 2 is installed on themanaged server, Z
version 1 will bemarked as superseded by an installed package and will not install.

3. If IPS package Z version 1 is in the policy, and Z version 1 is installed on themanaged server, Z
version 1 will bemarked as already installed and will not install.

Reasons an IPS packagemight not install
Patch policy rules are applied first:

1. Base package does not exist: IPS Package A version 1 cannot install because there is no
previous version of package A installed on themanaged server

2. Newer version is already installed:
l Package A version 1 cannot install because a newer version, package A version 2, was also
included in the policy and was installed instead.

l Package A version 1 cannot install because package A version 2 (newer package) is already
installed on themanaged server

Generic rules for all policies (software or patch) are applied second:

l Dependency: Package B version 1 cannot install because it requires package A version 3, which is
not in the SA repository.

l Blocker: Package A version 1 cannot be installed because package X, which is installed on the
managed server, prevents it.

l Duplicate: Package A version 1 cannot install because it is already installed
l Other: Additional reasons may apply per Solaris IPS analysis. SA passes the Solaris error
messages through to the SA remediation job.

Other differences
The patchadd utility is not applicable to Solaris 11 because there is no concept of a patch unit like there
is in previous versions (version) of Solaris. All units are IPS packages, which use the 'pkg' command
instead.
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Patch management for Ubuntu
Server Automation (SA) patchmanagement for Ubuntu enables you to identify, install, and remove
Ubuntu Debian package updates, andmaintain a high level of security across managed servers in your
organization. You can identify and install Ubuntu packages that protect against security vulnerabilities
for the SA-supportedManaged Server platforms.

In Ubuntu, “patches” are Debian “packages.” SA uses Ubuntu patchmanagement to apply Ubuntu
packages.

SA automates the key aspects of patchmanagement while offering a fine degree of control over how
and under what conditions Ubuntu packages are installed. By automating the patching process, patch
management can reduce the amount of downtime required for patching. SA also allows you to schedule
patch activity, so that patching occurs during off-peak hours.

Because Ubuntu package updates are often released to address serious security threats, an
organizationmust be able to roll out packages quickly, before systems are compromised. However, the
packages themselves can cause serious problems, from performance degradation to server failures.
While patchmanagement allows you to react quickly to newly discovered threats, it also provides
support for strict testing and standardization of patch installation.

SA Ubuntu Unified Patching Process

Best Practice: With Ubuntu patching in SA, you can import themetadata before importing the binary
packages. You can run the Ubuntu scanner with only themetadata downloaded to determine the server
vulnerabilities. Then you can run the Ubuntu package importer to import only those packages that are
required by managed servers. This practice saves you storage space as well as scan and remediation
processing time.
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This documentation contains information about how to import Ubuntumetadata and packages, scan for
vulnerabilities, and install Ubuntu package updates using patch policies.

Features
SA automates Ubuntu patching by providing the following features and capabilities:

l A central repository where packages are stored and organized in their native formats.
l A database that stores information about every package that has been applied.
l Dynamic Patch Policies that analyze platform vulnerabilities based on the latest metadata from the
vendor.

l Advanced search abilities that identify servers that require package updates.
l Auditing abilities for tracking the deployment of important package updates.
Types of Patch Browsing

The SA Client interface organizes Ubuntu packages andmetadata by operating systems and displays
detailed information about each package. You can also browse for usage information, such as software
policy usage or server and device group usage. You can sort packages by the Date Created or
Modified, by Object ID, OS, and so on. You can also browse all packages that are installed on a server,
and view and edit packagemetadata.

Scheduling and notifications
In the SA Client, you can separately schedule when you want patches to be imported fromMicrosoft
into Server Automation, either by a schedule or on demand, and when you want these patches to be
downloaded tomanaged servers.

Best Practice: Schedule patch installations for a day and time that minimize disruption to your business
operation.

Ubuntu patching also allows you to set up email notifications that alert you when the download and
installation operations completed, succeeded, or failed. When you schedule a patch installation, you
can also specify reboot preferences to adopt, override, postpone, or suppress the vendor’s reboot
options.

Patch policies
To provide flexibility in how you identify and distribute packages onmanaged servers or groups of
servers, Ubuntu patching allows you to create patch policies that define groups of packages you need
to install. By creating a patch policy and attaching it to a server or a group of servers, you canmanage
which packages get installed, and where, in your organization.

The Patch Policy model that Ubuntu uses is based on software and packages that are imported as
patches.

l Dynamic Policies can automatically import the latest Ubuntu packages from the vendor. When new
Debian binary packages are imported, the icon shows that the policy now contains the latest
package content and is active.
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l Dynamic Policies are designed to remediate servers.
l Static Patch Policies contain metadata that defines the Debian binary package updates.
Best Practice: For reliable automated updates, use the Dynamic Policies.

For more information, see "Create a patch policy " on page 196.

Patch installation preview
While PatchManagement allows you to react quickly to newly discovered security vulnerabilities, it
also provides support for strict testing and standardization of patch installation.

After you have scanned servers and have identified packages to install, PatchManagement allows you
to simulate (preview) the installation before you actually install a package. Use the preview process to
identify whether the servers that you selected for the patch installation already have that package
installed. In some cases, a server could already have a package installed if a system administrator had
manually installed it.

After this type of package installation, if a compliance scan has not been run or the installed package
has not been registered, SA does not know about it. Use the preview process for an up-to-date report of
the package state of servers.

The preview process also reports on package dependency and supersedence information, such as
packages that require certain Ubuntu products, and packages that supersede other packages or are
superseded by other packages.

Exporting patch data
To help you track the patch state of servers or groups of servers, PatchManagement allows you to
export this information. This information can be exported in a comma-separated value (.csv) file and
includes details about when a patch was last detected as being installed, when a patch was installed
by Server Automation, the patch compliance level, what patch policy exceptions exist, and so on. You
can then import this information into a spreadsheet or database to perform a variety of patch analysis
tasks.

SA Client Library
The SA Client Library provides flexibility in searching for and displaying Ubuntu packages and
metadata by Object ID, Created or Modified Date, operating system, and so on.

In the content pane, a dimmed package icon indicates that the package’s binary file has not been
uploaded to the Library. After you upload the binary, the icon shows as Active. Use the column selector
to control the columns of packagemetadata data that you want to display.

Because the Library is integrated with Ubuntu packagemetadata, you can review vendor information in
real-time in the preview pane.

Ubuntu packages and metadata in the SA Client Library
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Prerequisites - Patching amanaged server
To patch anmanaged server, the following prerequisites must bemet:

l Ubuntumetadatamust be imported into SA.
l A compliance scanmust be performed on themanaged server after metadata import.
See the SA Support and Compatibility Matrix for platform version support information.

Patch and patch policy search
In the SA Client, you can search for information about your operational environment by using the SA
Client Search feature. The Search feature enables you to search for packages, patch policies, servers,
and so on. See “SA Client Search” in the SA User Guide.
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SAmanagement of Debian metadata database
The Debianmetadata database contains information about released packages and how they should be
applied. PatchManagement compares all Ubuntu servers to the Debianmetadata to identify which
packages must be applied.

When a server is managed by Server Automation, the SA Agent installed on the server registers the
server’s configuration, including its installed packages, with SA. The SA Agent repeats this registration
every 24 hours. This information is immediately recorded in theModel Repository, such as data about
the operating system version, hardware type, and installed software and packages. When you first
provision a server with SA, the same data is immediately recorded.

When a new package is issued, you can use the SA Client to identify which servers require patching.
SA provides a Software Repository to which you upload packages and other software. Using the SA
Client, you can access this software to install packages on the appropriate servers.

In Ubuntu, Debian packagemetadata is imported automatically, but the package units are not. You
have the option of importing all packages found in the Ubuntu database or importing only those
packages you need for your managed servers. This feature allows you to limit the number of packages
you import, which saves storage space and user time.

The Vendor patch key is currently available for Ubuntu andWindows database views. The vendor
patch key is a vendor-specific value that allows users to tie a unit (patch) in SA back to the specific
patch supplied by the vendor.

Best Practice: After an Ubuntu server is brought under SA management, you should install all Ubuntu
packages by using SA Ubuntu patchmanagement. If you install a packagemanually, SA does not
have data about that package until the next software registration. However, when you install packages
using SA Ubuntu patchmanagement, the Agent immediately updates the information about the server
in theModel Repository.

Roles for Ubuntu patch management
Server Automation provides support for rigorous changemanagement by assigning the functions of
patchmanagement to several types of users in an organization. These users include a policy setter, a
patch administrator, and a system administrator.

Note: These responsibilities are controlled by assigning permissions for managing patches in SA.
To obtain these permissions, contact your SA Administrator. See the SA Administration Guide.

l Policy setter: The Policy Setter is amember of a security standards group that reviews package
releases and identifies the vendor packages that will be included in the organization’s patch policies.
A Policy Setter is responsible for reviewing the latest security threats and the packages that vendors
have released to address these problems. Policy Setters generally are experts in the operating
systems and applications that they manage, and is able to assess the necessity of applying
packages issued by vendors. A Policy Setter is also able to diagnose common problems that arise
after packages are installed, allowing for a thorough test of the patch application process.

Best Practice: For reliable automated updates, use the dynamic patch policies instead of static
manual patch policies.
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l Patch administrator: The Patch Administrator has the authority to import, test, and edit package
options. The Patch Administrator is often referred to as the security administrator in an organization.
A Patch Administrator is granted specific permissions to import packages into Server Automation to
test them and thenmark them as available for use. Patch Administrators are also able to edit
package options (such as installation scripts) through patchmanagement. Other types of users are
not allowed to import or edit packages. Typically, a Patch Administrator imports the Ubuntu Debian
metadata database and tests package on non-production reference hardware. After testing the
packages and determining that the packages are safe to apply to production systems, a Patch
Administrator marks the packages available in the Library and then advises System Administrators
to apply the approved packages.

l System administrator: The System Administrator installs packages that have been approved for use
uniformly and automatically, according to the options that the Patch Administrator specifies. The
System Administrator is an SA user who is responsible for the day-to-day maintenance of the
servers in a deployment. These users are not required to have the same level of expertise in low-
level system details as the Policy Setter and Patch Administrator. Because the Patch Administrator
has set up the patch installation, the System Administrator can attach policies to servers, set an
exception for a package, and install packages on a large number of managed servers. They are
responsible for searching for servers that require the approved package, installing the packages, and
verifying that the packages were successfully installed. The System Administrator can import
packages but cannot install a package until the Patch Administrator has marked it as available. The
System Administrator can also uninstall packages.

l Server Automation also provides predefined patch user groups for patch deployers and patch policy
setters. See "Roles for Ubuntu patchmanagement" on the previous page.

During an SA installation or upgrade, certain predefined user groups are created, such as patch
deployers and patch policy setters.

l Patch deployers—Access to install patches.
l Patch policy setters—Access to set patching policy.
l Software policy setters—Access to set software policy. (For Ubuntu patch policy management,
you need both Patch Policy Setters and Software Policy Setters user groups.)

Next to the predefined action permissions, youmust grant the necessary resource permissions to
these user groups. Use of these predefined user groups is optional. You canmodify the permissions of
the predefined user groups and you can also delete or copy these groups to create new groups.
Changes to or deletions of these predefined user groups are not affected by SA upgrades. See the SA
User Guide for more information.

Patch management process
The Ubuntu patching process consists of the following phases:

l Define Setup: This phase includes configuring Ubuntu patching settings for the Ubuntu proxy,
repositories, policy settings, and scanner behavior.

l Import Metadata: This phase includes getting the initial Ubuntumetadata into Server Automation.
l Run Patch Compliance Scan: This phase includes running compliance scans to determine
whether a server is out of compliance. This is usually an automatic process that occurs every 24
hours based on the SA Agent settings of the server. You can also run a Patch Compliance Scan
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manually using an empty policy. See "Start a patch compliance scan" on page 199 and "Start a
patch compliance scan immediately" on page 199.

l Import Package Binaries: User must import package binaries before the Remediation phase.
l Remediate: This phase includes using a patch policy to download packages and install updates on
recommended servers.

Ubuntu Patching Process

Specify Ubuntu patch settings
Ubuntu patch settings provide extensive options for configuring the patching options and functionality
to fit your environment.

l "Ubuntu patch settings: Set the proxy " on the next page
l "Ubuntu patch settings: Set the repositories " on the next page
l "Ubuntu patch settings: Configure the policy settings" on page 180
l "Ubuntu patch settings: Specify the scanner behavior" on page 181
l "Ubuntu patch settings: Specify the general logging options" on page 182
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Setting Description

Proxy Define the Ubuntu proxy configuration.

Repositories Define the Ubuntu repositories to access.

Policy Settings Configure the Ubuntu Patch Policy Settings.

Scanner Options Specify the Ubuntu scanner behavior.

General Specify the Ubuntu log settings.

Ubuntu patch settings

Ubuntu patch settings: Set the proxy
Specify the proxy information for your environment. Proxies provide network security and are used in
most environments.

Setting Description

User ID Enter the User ID to access theWeb proxy.

Password Enter the Password to access theWeb proxy.

Proxy
URL

Enter the full URL to access theWeb proxy. For example: http://web-
proxy.company.com:8080

User
Agent

Specify the User Agent to pass to the proxy server, if required.

Ubuntu proxy settings

Ubuntu patch settings: Set the repositories
Define the repository settings for your environment. The repository settings include the desired Ubuntu
repository as well as how it will be stored in SA.

Setting Description

Ubuntu URL Enter the full URL to access the Ubuntu repositories. For example:
http://archive.ubuntu.com/ubuntu/dists/

Repositories Select one or more repositories to use:

Security: Import security packages.

Updates: Import updates to official packages.

Suite Code
Name

Specify the Ubuntu Suite Code Names:

Precise Pangolin

Ubuntu repository settings
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Setting Description

Component
Name

Specify the Ubuntu Component name(s):

Main: Officially supported software. This is themajor part of the distribution, and is
supported by Ubuntu.

Restricted: Supported software that is not available under a free license. This
software is supported by Ubuntu.

Universe: Community-maintained software; i.e., not officially supported software.
(Note: Software from this repository is entirely unsupported by the Ubuntu team.
Software in a Universe repository will not receive any review or updates from the
Ubuntu Security Team.)

Multiverse: Software that is not free. (Note: Software from this repository is entirely
unsupported by the Ubuntu team. Software in aMultiverse repository will not receive
any review or updates from the Ubuntu Security Team.)

Architecture Select the SA-supported Ubuntu architectures in your environment:

32 bit or 64 bit

Repository
Policy
Name
Format

Choose whether to include date and time along with the Ubuntu Repository path
namewhen creating the repository policy. Your format options are:

Use Ubuntu Path: Uses only the Ubuntu path when creating the repository policy.

Add Date to Ubuntu Path: Appends Year-Month-Day to the Ubuntu path when
creating the repository policy.

Add Date and Time to Ubuntu Path: Appends Year-Month-Day-HOUR:MINUTE to
the Ubuntu path when creating the repository policy name.

Ubuntu repository settings, continued

Ubuntu patch settings: Configure the policy settings
Use the Policy Settings section to configure the default settings for handling Ubuntu patch policies:

Setting Description

Automatically
include
dependent
packages

Specify whether to make Ubuntu patch remediation jobs automatically include
dependent packages:

Yes: Dependent packages will be included in Ubuntu patch remediation jobs by
default.

No: Dependent packages must bemanually added to Ubuntu patch remediation
jobs.

Import based
on Scan
results

Specify whether to filter import contents and only import what your environment
needs. Note: Best policy practice is to leave the default value of Yes:

Yes: (Default) A scan will be run, and import contents will be filtered based on the

Ubuntu policy settings
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Setting Description

results.

No: All content will be imported without first running a scan.

Download
Package
Binaries

Controls the import of all Ubuntu packages from the repository:

Yes: Import Ubuntu packages at policy creation.

No: Delay download of Ubuntu packages until a scan is run to determine the
packages needed in your environment.

Production
Requirements

Enter the full path to the file on the SA Slice server or single core server that
specifies the packages needed for your production environment. Youmust be
logged in to this server when you perform Ubuntu patch or package updates.

When the package importer is run, it imports packages from this list if they match
information in the Ubuntumetadata catalog.

Create Static
Policies

Determine if static policies can be created based on the Debian packages defined
in the repository:

Yes: Enables creation of static policies.

No: Prevents creation of static policies.

Package
Policy Name
Format

Choose whether to include date and time along with the Ubuntu Repository path
namewhen creating the package policy:

Use Ubuntu Path: Uses only the Ubuntu path when creating the package policy
name.

Add Date to Ubuntu Path: Appends Year-Month-Day to the Ubuntu path when
creating the package policy name.

Add Date and Time to Ubuntu Path: Appends Year-Month-Day-HOUR:MINUTE to
the Ubuntu path when creating the package policy name.

Ubuntu policy settings, continued

Ubuntu patch settings: Specify the scanner behavior
Use the Scanner Settings section to configure the behavior of the Ubuntu scanner.

Setting Description

Enable Ubuntu
Scanner

Determine whether to enable the Ubuntu Scanner:

Yes: Enables the Ubuntu scanner

No: Disables the Ubuntu scanner

Note: The Ubuntu Scanner is critical to the Ubuntu Patching functionality. If this
option is disabled, the Ubuntu Patching feature is essentially disabled.

Ubuntu scanner settings

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 181 of 307



Setting Description

Use Implicit
Scan Policy

Enables the implicit scan policy which picks up the latest imported Ubuntu
repository policy by default; bypasses the need tomanually attachmodified
policies to servers.

Yes: Enable implicit policies.

No: Disable implicit policies: Ubuntu repository policies must bemanually attached
to each server

Logging
Options

Defines theManaged Server logging options during scan and remediation.

Errors only:Logs only errors.

Errors and warningmessages:Logs errors and warningmessages.

Errors and debugmessages:Logs errors and debugmessages.

Errors and informational only:Logs only errors and informational messages.

Repository
Scope

Define the repository scope on theManaged Server.

Public: Keeps the repository public on theManaged Server.

Private: Keeps the repository private on theManaged Server: the repo control file
will be deleted after SA has used it and re-created the next time.

Repository
Filename

Enter the name of the repository file to create on theManaged Server.

Repository
Directory

Enter the name of the repository directory to create on theManaged Server.

Scanner
Handler
Directory

Enter the name of the handler directory to create on theManaged Server.

List
information for
all packages

Determine ability to get installed information for all packages even if they do not
exist in the current repository.

Yes:Gets information about all packages that are installed on theManaged Server.

No:Collects information only about installed packages from the current repository.

Debug
Servers

List of debug servers.

Ubuntu scanner settings, continued

Ubuntu patch settings: Specify the general logging options
TheGeneral section allows you to specify how you want to handle error logging.
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Setting Description

Logging Options Choose the Ubuntu Importer logging options:

Errors only: Logs only errors.

Errors and warningmessages: Logs errors and warningmessages.

Errors and debugmessages: Logs errors and debugmessages.

Errors and informational only: Log errors and informational messages.

Ubuntu general logging settings

Ubuntu patch management tasks
This section describes how to find andmanage information about an Ubuntu package.

l "View package information" below
l "Package dependencies and supersedence" below
l "View Ubuntu packages " on the next page
l "Edit Ubuntu package properties" on the next page
l "Find Ubuntu packages" on the next page
l "Find servers that have an Ubuntu package installed " on page 186
l "Find servers that do not have an Ubuntu package installed" on page 186
l "Import Ubuntu patch contents from themanaged servers view" on page 187
l "Export an Ubuntu package" on page 188

View package information
To view detailed information (properties) about a package:

1. In the navigation pane, select Library. In theBy Type tab, select Packages > Ubuntu.
2. ExpandUbuntu, and select a specific Ubuntu operating system.

The content pane displays all packages associated with that operating system.
3. In the content pane, open a package to view its properties in the Packages: Properties window.

Press F1 to display descriptions of the fields displayed in the Packages: Properties window.

Package dependencies and supersedence
Packagemetadata identifies all known dependency and supersedence relationships between
packages and Ubuntu products, and between packages and other packages.

In Server Automation:

l Dependency relationships identify Ubuntu products that must already exist on a server before you
can install a certain package.
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l Supersedence relationships identify packages that supersede or are superseded by other packages.
In Ubuntu PatchManagement, supersedes means that one package replaces another and
superseded by means that the package you are installing is replaced by another package.

Note:
In Server Automation, Ubuntu patchmanagement does not detect whether two packages are
mutually exclusive—which is when either one can be installed but not both. Subsequently, Patch
Management does not prevent you from installing both packages on a server. This means that you
may be able to install both a superseded package and a superseding package on a server if both
packages are recommended by an Ubuntu server.

View Ubuntu packages
The SA Client displays information about Ubuntu packages that have been imported into Server
Automation.

To view information about a package:

1. In the navigation pane, select Library. In theBy Type tab, select Packages > Ubuntu.
2. ExpandUbuntu, and select a specific Ubuntu operating system.

The content pane displays all packages listed in the Ubuntu Package Database for the Ubuntu
operating system that you selected.

3. (Optional) Use the column selector to sort the packages according to Name, Type, Location, Last
Modified, Last Modified By, and Size.

4. In the content pane, open a package to view its properties in the Package window.

Edit Ubuntu package properties
You can edit a package’s Name and Description.

To edit the package properties:

1. In the navigation pane, select Library. In theBy Type tab, select Packages > Ubuntu.
2. ExpandUbuntu, and select a specific Ubuntu operating system.

The content pane displays all packages listed in the Ubuntu Package Database for the Ubuntu
operating system that you selected.

3. In the content pane, open a package to view its properties in the Package window.
4. Edit the following fields: Name andDescription.
5. From the File menu, select Save to save your changes.

Find Ubuntu packages
To find packages for a particular Ubuntu server:

1. In the navigation pane, select Devices > Servers > All Managed Servers.
2. From the View drop-down list, select Patches.
3. In the content pane, select a server that is running SA Agent 5.5 and Ubuntu.
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4. In the preview pane, use the Show drop-down list to select any of the following for patch details:
l Patches Needed

l Patches Recommended by Vendor

l Patches With Policies or Exceptions

l Patches Installed

l Patches With Exceptions

l All Patches

Patches recommended by vendor

The Patches window shows these values:

l Name - The name of the patch.
l Compliance - Shows whether or not the patch is compliant with the version of Ubuntu server used.
l Version - Version of the patch.
l Type of Patch - Debian package
l Description - Patch description
l Installed -Whether or not the patch is installed on the particular server.
l Recommended -Whether or not the patch is vendor-recommended.
l Exception -Whether or not the patch includes an exception.
l Bulletin - The Ubuntu Security Notice Bulletin number.
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l Vendor Patch key - The Vendor Patch key.
l Release Date - The date on which the patch was provided.
l Exposure Time - Amount of time between when the patch was installedminus when the patch was
released.

l Action - Information taken from the scanner
l Category - The patch category.
l Rating -Whether installation of this patch is Required or Optional.
l Object ID - The object ID of the patch.

Find servers that have an Ubuntu package installed
To find servers that have a particular package installed:

1. In the navigation pane, select Library. In theBy Type tab, select Packages > Ubuntu.
2. ExpandUbuntu, and select a specific Ubuntu operating system.

The content pane displays all packages associated with that operating system.
3. In the content pane, select a package.
4. From theSearch drop-down list in the content pane, select Server Usage.

You can browse a server in this list to view a list of all installed packages. Notice that this list
might display amore complete list of installed patches than the list you will find in the Ubuntu Add
or Remove Programs utility.

Note:
For each listed binary, the Exposure Time column shows the gap between the Release Date and
the Install Date, so you can analyze vulnerability.

An alternative way to find servers that have a particular patch installed:

1. In the navigation pane, click on theAdvanced Search link.
2. In the Advanced Search pane, set Search: For Servers.
3. Set Where: to Installed Software.

a. Set appropriate values (e.g., equals, contains, etc.).
b. Specify the name of the patch.

4. Press theSearch button.

Find servers that do not have an Ubuntu package installed
To find servers that do not have a particular package installed:

1. In the navigation pane, select Library. In theBy Type tab, select Packages > Ubuntu.
2. ExpandUbuntu and select a specific Ubuntu operating system.

The content pane displays all packages associated with that operating system.
3. In the content pane, select a package.
4. In the View drop-down list, select Server Usage.
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Import an Ubuntu patch from the SA Client Library
Ubuntu packages are downloaded from the Ubuntu web site and then imported (uploaded) into Server
Automation. To verify whether a package has been imported, view the package’s Availability property.
The Availability of an imported package is either Limited, Available, or Deprecated.

To import a patch with the SA Client:

1. In the navigation pane, select Library. In theBy Type tab, select Packages > Ubuntu.
2. ExpandUbuntu and select a specific Ubuntu operating system.

The content pane displays all packages associated with that operating system.
3. In the content pane, select a package.
4. To import a package directly from the Ubuntu web site, from the Actions menu, select Import

Contents > Import from Vendor.
The Import from Vendor window displays the URL of the package’s location on the Ubuntu web
site. (Optional) You can override this URL.
Or
To import a package that has already been downloaded to your local file system, from the Actions
menu, select Import> Import from File.
In the file browser window, locate the package.

5. Click Import.

Import Ubuntu patch contents from themanaged servers view
An Import Contents menu option is available from theManaged Servers view that enables you to import
package contents from a file. Ubuntu package contents (binaries) can be imported directly from the
vendor as well.

To import patch contents from the All Managed Servers view:

1. Log in to the SA Client with Manage Patch (Read andWrite) permissions.
2. Navigate toDevices > All Managed Servers.
3. Under View, select Patches.
4. In the Patches content pane, select one or multiple packages.
5. Right-click and select Import Contents and select From Vendor… or From File….

Singular package content can be downloaded from a local file or directly from a vendor. However,
if multiple packages are selected, only the "From Vendor…" option is available.
l From Vendor…: This option enables you to import package contents directly from the vendor.
(Note: This option is only available for Ubuntu packages.)

l From File…: This option enables you to import package contents from a local file that is
accessible from the system where the SA Client is running.
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Export an Ubuntu package
To export a package from Server Automation to a local file system:

1. In the navigation pane, select Library. In theBy Type tab, select Packages > Ubuntu.
2. ExpandUbuntu and select a specific Ubuntu operating system.

The content pane displays all packages associated with that operating system.
3. In the content pane, select a package.
4. From the Actions menu, select Export.
5. In the Export Patch window, enter the folder name that will contain the package file in the File

Name field.
6. Click Export.

Policymanagement
In Ubuntu patchmanagement, patch policies and patch policy exceptions enable you to customize
patch distribution in your environment. Policies and exceptions define the Ubuntu packages that should
be installed or not installed on your managed servers.

You can choose to have patching in your server environment comply to themodel that these policies
and exceptions define, or you can choose to deviate from this model. If you choose to deviate from the
patch policies and exceptions and perform ad hoc patch installs, then you need to remediate. The
remediation process ensures that the applicable packages get installed on servers.

Patch policy
A patch policy is a group of packages that you want to install on SA managed servers. All packages in
a patch policy must apply to the sameUbuntu operating system.

A patch policy provides broad flexibility for distributing packages. For example, you can create a patch
policy that contains security packages that you want to distribute only to servers used by your sales
force. You can also create a patch policy that contains security packages that are applicable to specific
software that is already installed on a server, such as Exchange Server, Internet Information Services
(IIS), SQL Server, and so on. Or, you can create a patch policy that includes all packages ranked as
critical by Ubuntu and then installs them on all servers that are used by everyone in your organization.

If you do not want to create a patch policy, you can use the vendor-recommended set of packages (by
operating system) as a default patch policy.

You can attach as many patch policies as you want to servers or groups of servers. If several policies
are attached to one server, the installation logic is cumulative—all packages listed in all attached
policies will be installed on the server. The Remediate window allows you to select an individual patch
policy to remediate. You do not have to remediate all policies attached to a server. You cannot nest
patch policies.

If a description of the patch policy is defined, it is recorded in the server’s patched state in theModel
Repository. This information enables PatchManagement to report on patch policies for patch
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compliance purposes. The patch compliance process compares patch policies with corresponding
patch policy exceptions.

Ubuntu PatchManagement supports the following types of patch policies:

l User-defined patch policy: This type of patch policy allows you to specify the packages you want in
the policy. A user-defined patch policy can be edited or deleted by a user who has the required
permissions.
This type of patch policy allows a policy setter to opt out of packages. The policy setter can create a
user-defined patch policy that is a subset of all available packages that are in a vendor-
recommended patch policy. This enables the policy setter to apply only those patches that their
environment needs.

l Dynamic patch policy: Membership of packages is defined by Individual UbuntuManaged Server
Scan Results, based on Ubuntu packagemetadata. Dynamic Patch Policies are system defined
and cannot be edited or deleted by a user.

You can only export user-defined patch policies. You cannot export vendor-recommended patch
policies.

Patch policies have the following characteristics:

l A patch policy has a name and can (optionally) include a description that explains its purpose.
l A patch policy can be either user-defined or vendor-defined.
l A patch policy does not have sub-policies. There is no inheritance.
l A patch policy is Customer Independent, whichmeans that patches in the policy can be installed on
any managed server, nomatter what customer is associated with it. See the SA User Guide.

l A patch policy is always public.
l A patch policy can be attached to zero or more servers or public device groups.
l More than one patch policy can be attached to a server or public device group.
l Only user-defined patch policies can be created, edited, and deleted by a user who has permissions.

Precedence rules for applying policies
By creatingmultiple patch policies and patch policy exceptions that are either directly attached to a
server or attached to a group of servers, you control the patches that should be installed or not installed
on a server. A precedence hierarchy in PatchManagement delineates how a patch policy or a patch
policy exception is applied to a patch installation. This hierarchy is based on whether the patch policy or
patch policy exception is attached at the server or device group level.

The following precedence rules apply to policies and exceptions:

l Patch policy exceptions that are directly attached to a server always take precedence over patch
policies that are directly attached to a server.

l Patch policies that are directly attached to a server take precedence over patch policies and patch
policy exceptions that are attached to a public device group.

l Patch policy exceptions that are attached to a public device group take precedence over patch
policies that are attached to a public device group.

l If a server is in multiple public device groups, a Never Installed patch policy exception type always
take precedence over an Always Installed patch policy exception type for the same patch.
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Remediation process
See "Remediating and Installing Software" in the SA User Guide: SoftwareManagement for
information about the fundamentals of SA remediation.

To ensure patch compliance, Ubuntu PatchManagement identifies vulnerable managed servers and
simultaneously deploys packages tomany servers when a remediation process is performed. The
remediation process examines and applies an entire patch policy, includingmultiple policies, to the
managed servers to which it is attached. A policy must be attached to a server or a group of servers
before you can remediate the policy with that server or group.

Best Practice: Each time you review the latest Ubuntu package releases and subsequently update a
patch policy by adding new packages to a policy, you should perform remediation. In these situations, a
remediation process provides demand forecasting information. This allows you to determine how patch
policy changes will impact servers to which this policy is attached.

If the remediation process discovers any applicable missing packages, these packages will be
installed on the servers.

To help youmanage remediation conditions, SA allows you to specify remediate options and pre and
post actions, and set up ticket IDs and email notifications that alert you about the status of the
remediate process. The Remediate wizard guides you through setting up these conditions.

Remediate Wizard
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Remediate patch policies
This action installs the packages in a policy that has been attached tomanaged servers. This action
does not uninstall packages. A patch policy can be overridden by an exception, which indicates that a
package is either always or never installed on a particular server.

To remediate a patch policy:

1. In the navigation pane, select Library. In theBy Type tab, select Packages > Ubuntu.
2. Expand Ubuntuand select a specific Ubuntu operating system.

The content pane displays all patch policies associated with that operating system.
3. In the content pane, open a patch policy.
4. In the View drop-down list, select Servers.
5. In the Show drop-down list in the content pane, select Servers with Policy Attached.
6. In the preview pane, select one or more servers.
7. From the Actions menu, select Remediate.

The first step of the Remediate window appears: Servers and Device Groups. For instructions
on each step, see the following sections:
l "Set remediate options" below

l "Set reboot options for remediation" on the next page

l "Specify pre-installation and post-installation scripts for remediation" on page 193

l "Schedule a patch installation for remediation" on page 193

l "Set up email notifications for remediation" on page 194

l "Preview and start a remediation" on page 194

After you have completed a step, click Next to advance to the next step. Before you click Start
Job, you can return to a completed step tomake changes by clicking on it in the list of steps.

8. Click Start Job to launch the remediation job.
After you launch the job, you cannot change its parameters, even if the job is scheduled to run at a later
time.

Set remediate options
You can specify the following remediate policy option:

Do not interrupt the remediate process even when an error occurs with one of the policies.

To set this option:

1. In the Remediate window, click Next to advance to the Options step.
2. Select a rebooting option. See "Set reboot options for remediation" on page 57.
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3. Select theError Handling check box if you want the remediation process to continue even when
an error occurs with any of the patches or scripts. As a default, this check box is not selected.

4. Click Next to go to the next step or click Close to close the Remediate window.

Set reboot options for remediation
Tominimize the downtime that server reboots can cause, you can control when servers reboot during a
patch installation.

You can specify the reboot options in the following SA Client Ubuntu locations:

l Patch Properties window—Install Parameters tab
l Remediate window—Pre & Post Actions step
Best Practice: When you are selecting reboot options in the Remediate window, Hewlett Packard
recommends that you use Ubuntu’s reboot recommendations, which is the Reboot servers as specified
by individual software items option. If it is not possible to use the Ubuntu reboot setting, select the
single reboot option, which is the Hold all server reboots until after all packages are installed and/or
uninstalled option. Failure to do this can result in incorrectly reporting which patches are installed on the
server until the next reboot occurs (outside of SA control).

The following options in the Remediate window determine whether the servers are rebooted after the
patch is installed. These options apply only to the job launched by the Remediate window. They do not
change the Reboot Required option, which is in the Install Parameters tab of the Patch Properties
window. Except for the first option, the following options override the Reboot Required option.

l Reboot servers as specified by individual software items (Default): By default, the decision to
reboot depends on the Reboot Required option of the patch or package properties.

l Reboot servers after each installation or uninstallation: As a best practice, reboot the server
after every patch or package installation or uninstallation, regardless of the vendor reboot setting on
the individual patch or package.

l Hold all server reboots until after all packages are installed and/or uninstalled: If the Reboot
Required option is set for some selected patches but not for others, the server is rebooted one time
after all patches are installed. If the Reboot Required option is not set for any of the selected
patches, the server is not rebooted.

l Suppress all server reboots: Even if the Reboot Required option of the patch properties is set, do
not reboot the server. (Because of vendor settings, some patches ignore the suppress option and
force a reboot.

To set reboot options:

1. From the Remediate window, click Next to advance to the Options step.
2. Select one of the Rebooting options.
3. Click Next to go to the next step or click Close to close the Remediate window.
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Specify pre-installation and post-installation scripts for
remediation
For each patch remediation, you can specify a command or script to run before or after remediation. A
pre-install script, for example, could check a certain condition on themanaged server. If the condition is
not met or if the pre-install script fails, the patches would not be installed. A pre-install script could also
be used to shut down a service or application before it is patched. A post-install script could be used to
perform a certain cleanup process on themanaged server.

You can specify the following types of scripts to run on themanaged server before or after a
remediation process:

l Pre-download: A script that runs before patches are downloaded from SA to themanaged server.
This is available only if you select Staged in the Remediate Options step.

l Post-download: A script that runs after patches are downloaded from SA to themanaged server
and before the patch is installed. This is available only if you select Staged in the Remediate Options
step.

l Pre-install: A script that runs before patches are installed on themanaged server.
l Post-install: A script that runs after patches are installed on themanaged server.
To specify a pre-install script:

1. From the Remediate window, click Next to advance to the Pre & Post Actions step.
2. Select thePre-Install tab.

Youmay specify different scripts and options on each of the tabs.
3. Select theEnable Script check box. This option enables the remainder of the fields on the tab. If

Enable Script is not selected, the script will not run.
4. Select either Saved Script or Ad-Hoc Script from the drop-down list.

A Saved Script has been previously stored in Server Automation with SA Client. To specify the
script, click Select.
An Ad-Hoc script runs only for this operation and is not saved in SA. Select the Type, such as
.bat. In the Script box, enter the contents of the script, including the drive letter of where the script
is located, such as echo dir>> C:\temp\preinstall1.log. If you do not enter a drive letter, the default
is %SYSTEMDRIVE%, which is where the system folder of Ubuntu is installed.

5. If the script requires command-line flags, enter the flags in theCommand text box.
6. In the User section, if the system is not Local System, select Name.
7. Enter the system name, your password, and the Domain name.
8. To stop the installation if the script returns an error, select theError check box.
9. Click Next to go to the next step or click Cancel to close the Remediate window.

Schedule a patch installation for remediation
You can schedule when you want patches installed and when you want patches downloaded.

To schedule a patch installation:
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1. In the Remediate window, select the Scheduling step.
By default, the Scheduling step displays only the scheduling options for the installation phase. If
you selected Staged in the Remediate Options step, the scheduling options for the download
phase will also be displayed.

2. Select one of the following Scheduling options:
l Schedule Analysis: This enables you to specify a date and time that you want the analysis to
run.

l Schedule Download: This enables you to specify a date and time that you want the download
or installation performed.

l Schedule Remediate: This enables you to specify a data and time that you want the
remediate process to run.

3. Click Next to go to the next step or click Cancel to close the Remediate window.

Set up email notifications for remediation
You can set up email notifications to alert users when the download and installation operations
complete successfully or with errors.

To set up email notifications:

1. From the Remediate window, click Next to advance to the Notifications step.
2. To add email addresses, click Add Notifier and enter the email addresses in the Notification

Email Address field.

3. To set the notification status on the success of a Job, select the icon. To set the

notification status on the failure of a Job, select the icon. By default, the Notification step
displays only the notification status for the installation phase. If you selected Staged in the
Remediate Options step, the notification status for the download phase is also displayed.

4. Enter a Ticket ID to be associated with a Job in the Ticket ID field.
5. Click Next to go to the next step or click Cancel to close the Remediate window.

Note:
If you previously selected Staged in the Remediate Options step, the Notifications pane displays
notification options for both the download and installation phases.

Preview and start a remediation
The remediate preview process provides an up-to-date report about the patch state of servers. The
Preview is an optional step that lets you see the patches that will be installed onmanaged servers. This
preview process verifies whether the servers you selected for the patch installation already have that
patch installed. This verification is based on the imported Microsoft path database. In some cases, a
server could already have the patch installed if a system administrator hadmanually installed it, which
means that PatchManagement does not know about it.
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In the Preview, the servers, device groups, and patches that are listed in the Summary Step window
will be submitted to remediation when you click Start Job. Patches that are not recommended by the
vendor will be excluded from this list. If there are other patches in the policy with the sameQNumber,
only the vendor-recommended patch is displayed.

This list shows patches and their associated servers, regardless of any patch policy and server group
membership changes that may have occurred. If you preview a remediation, this same list of servers,
device groups, and patches will be used, even if changes have occurred to the patch policy or server
groupmemberships.

If youmodify parameters in the Remediate window after you have already clicked Preview, the preview
process will produce an invalid summary of simulated patching actions. For example, if you have
already clicked Preview and you add patches, patch policies, servers, or device groups, youmust click
Preview again for results that include your changes.

Note:
The remediation preview does not report on the behavior of the server as though the patches have
been applied.

To preview a remediation:

1. In the Remediate window, in the Servers and Policies step, select a server or policy.
2. Click Next or select the Options step to specify your rebooting, error handling, and script

preferences.
3. Click Next or select the Preview step to see the separate actions that will be performed when the

patch is installed.
4. In the Preview step, click Preview to view the details of a previewed action.
5. To launch the installation job, click Start Job.

If you selected Run Immediately After Analysis in the Scheduling step, the job will run now. If you
selected a specific time, the job will run then.

6. The Job Status displays in the Remediate window.
The Status bar and text indicate how many of the actions listed in the table have been completed.
For each server, the following actions can be performed:
l Overall Server Status: The overall status of all servers included in this remediation job.

l Analyze: SA examines the patches needed for the installation, checks themanaged servers
for themost recent patches installed, and determines other actions that must be performed,
such as download, install, or reboot.

l Download: The patch is downloaded from Server Automation to themanaged server.

l Install: After it is downloaded, the patch is installed.

l Reboot: If this action is specified in the Options step, the server is rebooted.

l Registration: Software registration is performed to retrieve currently installed packages and
patches on themanaged server.

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 195 of 307



l Test Compliance: A compliance scan is performed to report the current compliance status of
themanaged server.

l Run Script: If scripts are specified in the Options step, the scripts are run before or/and after
the download or/and installation.

l Install & Reboot: If you specify to reboot the server according to each patch or package
setting in the Options step, the server will be rebooted immediately after each individual patch
or package is installed.

7. To view additional details about a specific action, select the row in the table to display this
information in the bottom pane.
Or
In the navigation pane, select Jobs and Sessions to review detailed information about the job. See
"Browsing Job Logs" in the SA User Guide.

8. In the navigation pane, select Jobs and Sessions to review detailed information about the job. See
"Browsing Job Logs" in the SA User Guide.

9. Click End Job to prevent the job from running or click Close to close the Remediate window. You
can end a job only if it is scheduled.
(Optional) See the "Cancelling or Terminating Installation, Uninstallation or Remediation Jobs"
section in the SA Administration Guide.

Verify patch policy compliance
To determine whether amanaged server complies with patch policies and exceptions:

1. In the navigation pane, select Devices > All Managed Servers.
2. From the View drop-down list, select Compliance to display patch compliance status.
3. Select a specific server or check Check All Rows to view detailed Patch compliance information

in the details pane. At any time, select Uncheck All Rows to modify your server selection.
4. In the details pane, expand the Patch row to see status and compliance summary details. Use the

status filter to narrow your compliance display preferences. By default, this is set to No Status
Filter.

Create a patch policy
A patch policy is a set of patches that should be installed on amanaged server. When it is first created,
a patch policy contains no patches and is not attached to servers.

As mentioned before the Ubuntu patches are just software/packages under the hood, and that is why,
when imported from the “Patch Settings” they get populated in the Library/Packages/Ubuntu. However
the icon in the tab distinguishes a patch from a package. Once a patchmetadata is imported, it shows
up qualified by a greyed out patch icon, if its binary has not been imported. User can right click on the
greyed out patches in the Library/Packages/Ubuntu view and select “import from vendor” or “import
from file” (just likeWindows patches) and import the binaries to turn the icon green.

User can create a Generic Patch Policy by right clicking on the Library/Patch Policy/Ubuntu tab and
select “Static Patch Policy” or “Dynamic Patch Policy” to create either a static or dynamic policy. Once
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the new policy creation screen opens up, user can select the Policy Options there in. Though note that
the “Policy Items” is enabled only for the Static Policies and not for Dynamic Policies as Dynamic
policies cannot hold any item.

To create a patch policy:

1. In the navigation pane, select Library > By Type > Patch Policies.
2. Select a specific Ubuntu operating system.
3. From the Actions menu, select New Dynamic Policy orNew Static Policy.
4. In the Properties window, give the policy a unique name. Save andClose.
5. In the content pane, open the New Patch Policy.
6. (Optional) In theName field of the Properties, enter a name that describes the purpose or contents

of the policy.

Delete a patch policy
This action removes a patch policy from SA but does not remove or uninstall patches frommanaged
servers. You cannot delete a patch policy if it is attached to servers or groups of servers. Youmust first
detach the policy from the servers or groups of servers before removing it from SA.

To delete a patch policy from SA:

1. In the navigation pane, select Library > By Type > Patch Policies.
2. Select a specific Ubuntu operating system.
3. In the content pane of themain window, select a policy.
4. From the Actions menu, select Delete Patch Policy.

Add a patch to a patch policy
This action adds a patch to a patch policy, but does not install the patch on amanaged server. The
patch will be installed when the policy is remediated.

To add a patch to a patch policy to SA:

1. In the navigation pane, select Library > By Type > Patch Policies.
2. Select a specific Ubuntu operating system and view the list of Ubuntu patches.
3. In the content pane, select the patch.
4. From the View drop-down list, select Patch Policies.
5. From the Show drop-down list, select Policies without Patch Added.
6. Select a policy.
7. From the Actions menu, select Add to Patch Policy.
8. In the Add to Patch Policy window, click Add.

Remove a patch froma patch policy
This action only removes a patch from a patch policy. This action does not uninstall the patch from a
managed server and does not remove the patch from SA.
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To remove a patch from a patch policy:

1. In the navigation pane, select Library > By Type > Patches.
2. Select a specific Ubuntu operating system and view the list of Ubuntu patches.
3. From the content pane, select a patch.
4. From the View drop-down list, select Patch Policies.
5. From the Show drop-down list, select Policies with Patch Added.
6. Select a patch. From the Actions menu, select Remove from Patch Policy.
7. In the Remove Patch from Policy window, select the policy and click Remove.

Attach a patch policy to a server
This action associates a patch policy with a server or a group of servers). Youmust perform this action
before you remediate a policy with a server or a group of servers.

To attach the policy:

1. In the navigation pane, select Library > By Type > Patch Policies.
2. Select a specific Ubuntu operating system and view the list of Ubuntu patch policies.
3. In the content pane, select a patch policy.
4. From the View drop-down list, select Server Usage orDevice Group Usage.
5. From the Show drop-down list, select Servers with Policy Not Attached orServer Groups with

Policy Not Attached.
6. In the preview pane, select one or more servers.
7. From the Actions menu, select Attach Server.
8. Click Attach.

Detach a patch policy froma server
This action does not delete the patch policy and does not uninstall patches from amanaged server.

To detach the policy:

1. In the navigation pane, select Library > By Type > Patch Policies.
2. Select a specific Ubuntu operating system and view the list of Ubuntu patch policies.
3. In the content pane, select a patch policy.
4. From the View drop-down list, select Server Usage (orDevice Group Usage).
5. From the Show drop-down list, select Servers with Policy Attached orServer Groups with

Policy Attached.
6. In the preview pane, select one or more servers.
7. From the Actions menu, select Detach Server.
8. Click Detach.
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Patch compliance
Server Automation performs conformance tests (compliance checks) against managed servers and
public device groups to determine whether all patches in a policy and a policy exception were installed
successfully. To optimize patch compliance information for your organization, you can set the patch
compliance levels and edit the rules of the customized patch compliance level.

Patch compliance scans
A patch compliance scan compares patches that are installed on a server with patch policies and patch
policy exceptions that are attached to that server. The results of this scan show you the servers that
are in compliance (have all required patches installed) and the servers that are out of compliance (do
not have all required patches installed).

You should run or schedule patch compliance scans based on the dynamics of your patching
environment. For example, if you updated a patch policy or installed a patch outside of (by not using)
Server Automation, a compliance scan is required because the SA model has been changed and the
compliance informationmust now be recalculated. SA indicates these types of conditions by displaying
Scan Needed. In this case, instead of waiting for the scan schedule to iterate, you can start compliance
scan on one or more servers.

Start a patch compliance scan
You can start a patch compliance scan in the following ways:

l Immediately, by selecting servers or groups and then selecting amenu item.
See "Start a patch compliance scan immediately" below.

l Periodically, by setting up a schedule.
See "Schedule a patch compliance scan" on page 69. By default, the scans are not scheduled.

l As a result of another task.
SA performs a patch compliance scan on amanaged server at the end of the tasks described in the
following sections:
l "Install an Ubuntu patch" on page 208

l "Remediate patch policies" on page 191

Start a patch compliance scan immediately
To run a Patch Compliance Scanmanually, you need to create an empty policy and attach it to the
server(s) or device group(s).

To start a scan on selected servers:

1. In the navigation pane, select Devices.
2. Select an entry from the Servers or Device Groups list.
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3. Right-click and then select Scan > Patch Compliance to display the Patch Compliance Scan
Status window.

Refresh the compliance status of selected servers
When you refresh the compliance status of an Ubuntu server, the SA Client retrieves the latest data
from theWeb Services Data Access Engine. A refresh action does not re-scan Ubuntu servers for
compliance information.

To refresh the compliance status for one or more servers:

1. In the navigation pane, select Devices.
2. From the View drop-down list, select Compliance.
3. In the content pane, select one or more servers.
4. Right-click and select Refresh Server.
5. Review the Status column for any changed compliance information.

View scan failure details
If the scan operation fails, you cannot determine whether a server is in compliance. A scan failure is

indicated by the Scan Failed icon. To find out why a patch compliance scan failed:

1. In the navigation pane, select Devices.
2. Drill down to the server you want to check.
3. In the contents pane, select a server.
4. Right-click and then select Scan > Show Patch Compliance Scan Failure Details.
5. In the Patch Compliance Scan Failure Details window, select a server and examine the detailed

error message that appears in the lower part of the window.

Patch compliance icons
Server Automation displays the following icons in the "Patch Compliance Status Icons" below table

Status/Icon Description

Compliant

The server is compliant for all patches. Patches in policies attached to the server are
all installed on the target server.

Partial The server is partially compliant for patches. An exception has been set for these
patches.

Non-
Compliant

The installed patches on the server do not match the conditions defined in the patch
policy.

Patch Compliance Status Icons
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Status/Icon Description

Scan
Failed

The scan operation failed. PatchManagement is unable to check the compliance of
the server.

Patch Compliance Status Icons, continued

Patch compliance levels
Patch compliance levels define your patch compliance rules. Results of a patch compliance scan can
include only policies, both policies and exceptions, or your own customized level.

Ubuntu PatchManagement supports the following compliance levels:

l Policy Only: Verifies whether the patches installed on a server comply with the patch policies.
l Policy and Exception: Verifies whether the patches installed on a server comply with the patch
policies and any exceptions. The Partial icon is displayed if the policy and exception do not agree
and the exception does not have data in the Reason field.

l Customized: Verifies the rules that you edited for this compliance level.

Patch compliance rules
Patch compliance rules are the conditions that determine the compliance icons that are displayed in the
Managed Server window.

Ubuntu PatchManagement supports the following compliance rules:

l Patch Added to Policy: The patch has been added to the patch policy.
l Patch Installed on Server: The patch has been installed on themanaged server.
l Exception Type: The Exception Type can have the following values:

l Always Installed: The patch should be installed on the server, even if the patch is not in the
policy.

l Never Installed: The patch should not be installed on the server, even if the patch is in the policy.

l None: An exception has not been specified for the patch and server.

l Exception Reason: A description entered in the Exception Reason of the Set Policy Exception
window. In the Patch Compliance Rules window, the Exception Reason can have the following
values.
l Yes: The Exception Reason has data.

l No: The Exception Reason is empty.

l N/A: An exception has not been specified for the patch and server.

l Compliance Result: The icon that indicates the result of the patch compliance scan. These icons are
displayed in theManaged Server window.
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Patch administration
The section provides information on following topics:

l "Prerequisites for importing the patch database (metadata)" below
l "Setting patch availability" below
l "Importing the Ubuntu patch databasemetadata and packages" on the next page
l "Scheduling a patch compliance scan" on page 204
l "Setting a patch compliance level" on page 206
l "Supported Ubuntu versions" on page 206

Prerequisites for importing the patch database (metadata)
Before you can import the Ubuntu patch database, youmust configure your SA Client to use aWeb
proxy when communicating with your SA core.

To configure your SA Client:

1. In the Log in to Server Automation Client window, click More to expand the window.
2. Click Advanced Settings to open the Advanced Settings window.
3. In the Proxies section:

l If you want to use the same proxy as the browser, select Use Browser
Or

l If you want to set a different proxy, selectManual and enter the SA Core's IP or hostname in
theNo Proxy Hosts text box. This will ensure that the SA Client communicates directly with
the SA core.

Setting patch availability
You can set the default patch availability by using the SA Client.

To set the default value for the availability of a newly imported patch by using the SA Client:

1. In the navigation pane, select Administration >Patch Settings.
2. From the Default Availability for Imported Patches drop-down list, select either Limited

Availability orAvailable.
l Limited Availability (Default)—A patchmarked Limited Availability has been imported into
Server Automation and can be installed only by a patch administrator who has the required
permissions. To obtain these permissions, contact your system administrator. See the SA
Administration Guide for an explanation of these permissions.

l Available—A patchmarked Available can be installed onmanaged servers.
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Importing the Ubuntu patch databasemetadata and packages
To import the Ubuntumetadata using the SA Client:

Before performing these steps, see "Prerequisites for importing the patch database (metadata)" on the
previous page.

1. In the navigation pane, select Administration>PatchSettings.
2. Click theUbuntu tab.
3. If a proxy is needed, set the Proxy value. If the proxy requires a user name, password or user

agent, set those values as needed.
4. To import themetadata of the Ubuntu repository from the Ubuntu web site, click Import

Metadata.
The Import Repository Metadata for Ubuntu window displays the overall progress of the unites as
well as the units being processed.

To import the Ubuntu packages using the SA Client:

Before performing these steps, import themetadata and scan your servers for patch compliance. After
scanning servers for compliance, you can import the Ubuntu patches using the SA Client.

1. In the navigation pane, select Administration>Patch Settings.
2. Click theUbuntu tab.
3. To import the database from the Ubuntu web site, click Import Packages.

The Run Server Script window appears displaying the script to run (Import Ubuntu Packages is
selected by default. You can switch to Import UbuntuMetatadata to just import the package
metadata.
The script page also provides script metadata, such as the version, type, location (import
destination) and description.

4. Click Next or select the next step to proceed through the Run Server Script steps:
l Servers andGroups

l Options

l Scheduling

l Notifications

l Job Status

Note: For information on Run Server Script steps and options, see the SA User Guide for
information on running server scripts.

5. When you are done defining the options, click Start Job.
6. The Job Status will display the results as the import is processing. The import may take a long

time depending on the size of the import.
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When the import job is complete, the Job Status will display the details of the job activity. Select
any server to see a log of the job details on that server in the detail pane, including an Ubuntu
Package Import Summary at the bottom of the job results log.

Scheduling a patch compliance scan
To schedule a patch compliance scan on all Ubuntumanaged servers:

1. In the navigation pane, select Administration > Compliance Settings.
Compliance Scan window
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2. In the Compliance Settings content pane, in the Patch Compliance Schedule section, click Edit
Settings.

3. In the Schedule Compliance Scan window, select Enable Compliance Scan.
4. From the Schedule drop-down list, select the frequency of the scans.

If you select Custom, specify the crontab string with the following values:
l Minute (0-59)

l Hour (0-23)

l Day of themonth (1-31)

l Month of the year (1-12)

l Day of the week (0-6 with 0=Sunday)

l Any of these fields can contain an asterisk to indicate all possible values. For example, the
following crontab string runs the job at midnight every weekday:
0 0 * * 1-5

The crontab string can also handle serial (1,2,3,4) as well as range (1-5) values. For more
information, consult the crontabman pages on a Unix computer.
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5. In theStart Time field, specify the time you want the job to begin.
6. From the Time Zone drop-down list, select a default time zone for the job execution time or accept

the default time zone. The default time shown converts the scheduled time to the time zone set in
your user preferences. If you do not set a preferred time zone, the time zone is derived from the
Server Automation core server, which is typically UTC.

7. Click OK to save your settings.

Setting a patch compliance level
The patch policy compliance level defines your patch compliance level.

To set the patch compliance level:

1. In the navigation pane, select Administration>Compliance Settings.
2. From the Compliance Rules drop-down list, select one of the following compliance levels: Policy

Only, Policy and Exception, or Customized.
If you select Customized, click Edit Custom to open the Edit Customized Policy Compliance
Level window. To edit the compliance level, click the icon in the Compliance Result column. Click
Apply to save your changes.

Supported Ubuntu versions
See the SA Support and Compatibility Matrix for the list of SA-supportedManaged Server platforms for
your version of SA.

Patch locale configuration tasks
By default, Ubuntu patchmanagement supports only the English locale. To set up Ubuntu patching for
non-English locales, complete the instructions in the following sections:

l "Configuring the SA Core for non-English locales" below
l "End user requirements for non-English locales" on the next page

Configuring the SA Core for non-English locales
To configure the core for non-English locales, complete the following steps on each core server that is
running the SA Client:

1. Log on to the server as root.
2. In /etc/opt/opsware/occ/psrvr.properties, change the line for

pref.user.locales

to

pref.user.localesAllowed=en;ja;ko

3. Restart the SA Client on the core:

/etc/init.d/opsware-sas restart occ.server
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4. In a text editor, open the following file:

/opt/opsware/occclient/jnlp.tmpl

5. For the Japanese language, in the <resources> section of the jnlp.tmpl file, add the following
XML element:

<property name="com.opsware.ngui.font.japanese" value="Arial Unicode MS"/>

6. For the Korean language, in the <resources> section of the jnlp.tmpl file, add the following XML
element:

<property name="com.opsware.ngui.font.korean" value="Arial Unicode MS"/>

7. In the /opt/opsware/occclientdirectory, if the following files exist, delete them:

$HOST_ja.jnlp

$IP_ja.jnlp

$HOST_ko.jnlp

$IP_ko.jnlp

End user requirements for non-English locales
To view non-English fonts in the SA Client:
a. Verify that the Ubuntu desktop running the SA Client uses the Arial UnicodeMS font.
b. After the system administrator performs the steps in "Configuring the SA Core for non-English

locales" on the previous page, the end user logs on to the SA Client and selects their “Logged
in as” link in the upper right corner of the SA Client window. This displays the User window.
Select the Properties view.

c. On the User Properties view, the end user updates the Locale field in the User Preferences
section. For example, if the system administrator configured the core for Japanese, then the
end user sets the Locale field to Japanese.

Patch installation
Patchmanagement provides the following two phases in the patch installation process:

l Phase 1—Download/Staging: This is when the patch is downloaded from Server Automation to
themanaged server. This phase is commonly referred to as staging.

l Phase 2—Installation/Deployment: This is when the patch is installed on amanaged server. This
phase is commonly referred to as deployment.

You can specify whether you want the installation to occur immediately after the patch is downloaded
(staged) or you can schedule the installation to occur at a later date and time. Ubuntu Patch
Management also supports the need for best-effort installations of multiple patches by allowing you to
specify that the patch installation process will continue even when an error occurs with one of the
patches.

Ubuntu PatchManagement displays the name of the command, such as a .deb file and any predefined
command-line arguments, that the SA Agent runs on themanaged server to install the patch. You can
override these default command-line arguments.
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To help you optimally manage Ubuntu patch installation, PatchManagement allows you tomanage
server reboot options, specify pre and post installation scripts, simulate (preview) a patch installation,
and set up email notifications to alert you about the status of the installation process. The Install Patch
wizard guides you through setting up these conditions.

Install an Ubuntu patch
Before a patch can be installed on amanaged server, it must be imported into Server Automation and
its status must be Available. Administrators who have the required permissions can install patches that
aremarked Limited.

Youmust have permissions tomanage patches. To obtain these permissions, contact your system
administrator. See the SA Administration Guide.

You can perform the installation by explicitly selecting patches and servers, and you can install a patch
even if the patch policy exception is Never Install.

To install a patch on amanaged server or device group:

1. In the navigation pane, select Devices > All Manages Servers (orDevice Groups).
2. In the content pane, select a server or device group.
3. From the Show drop-down list, select Patches Recommended by Vendors.
4. Right-click on a patch which has the content imported and select Install.

The first step of the Install Patch window appears: Servers and Device Groups.
For instructions on each step, see the following sections:
l "Set Ubuntu install options" on the next page

l "Set reboot options for an Ubuntu patch installation" on the next page

l "Specify install scripts for an Ubuntu patch installation" on page 210

l "Schedule an Ubuntu patch installation" on page 211

l "Set up email notifications for an Ubuntu patch installation" on page 211

l "Preview an Ubuntu patch installation" on page 212

l "View job progress of an Ubuntu patch installation" on page 213

After you have completed a step, click Next to advance to the next step. Before you click Start
Job, you can return to a completed step tomake changes by clicking on it in the list of steps.

5. When you are ready to launch the installation job, click Start Job.
After you launch the job, you cannot change its parameters, even if the job is scheduled to run at a
later time.
If the Install Patch window remains open until the job completes, Ubuntu PatchManagement
updates the Patch Compliance column in the All Managed Servers window with the revised
compliance count (in parenthesis) for affected servers. Press F5 or select Refresh from the View
menu to update information in the Patch Preview pane.
See "Remediate patch policies" on page 191 for another method of installing a patch.
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Set Ubuntu install options
You can specify the following types of patch installation options:

l Perform the patch installation immediately after the patch is downloaded or at a later date and time.
l Do not interrupt the patch installation process, even when an error occurs with only one of the
patches.

l Use different command-line options to perform the installation.
To set these options:

1. In the Install Patch window, click Next to advance to the Install Options step.
2. Select one of the following Staged Install Options:

l Continuous: This allows you to run all phases as an uninterrupted operation.

l Staged: This allows you to schedule the download and installation to run separately.

3. Select theError Options check box if you want the patch installation process to continue even
when an error occurs with one of the patches. As a default, this check box is not selected.

4. In the Install Command text box, enter command-line arguments for the command (.deb file) that
is displayed.

5. Click Next to go to the next step or click Cancel to close the Install Patch window.

Set reboot options for an Ubuntu patch installation
Tominimize the downtime that server reboots can cause, you can control when servers will and will not
be rebooted. You can adopt the vendor’s reboot assignments, reboot a server each time a patch is
installed on it, completely suppress all server reboots, or postpone reboots until all patches have been
installed.

When you are selecting reboot options in the Install Patch window, HP recommends that you use
Ubuntu’s reboot recommendations, which is the Reboot servers as specified by individual software
items option. If it is not possible to use the Ubuntu reboot setting, select the single reboot option, which
is the Hold all server reboots until after all packages are installed and/or uninstalled option. Failure to do
this can result in incorrectly reporting the patches that are installed on the server until the next reboot
occurs (outside of SA control).

The following options determine whether the servers are rebooted after the patch is installed. These
options apply only to the job launched by the Install Patch window; they do not change the Reboot
Required that is in the Install Parameters tab of the Patch Properties window.

If a server has a state of Reboot Pending, a subsequent install patch actionmay fail. Before performing
any subsequent patch installation actions on the server, youmust first reboot the server.

Except for the first option, the following options override the Reboot Required option.

l Reboot servers as specified by individual software items (Default): By default, the decision to
reboot depends on the Reboot Required option of the patch properties.

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 209 of 307



l Reboot servers after each patch install: Even if the Reboot Required option of the patch
properties is not set, reboot the server. If multiple patches are installed, the server reboots multiple
times.

l Suppress all server reboots: Even if the Reboot Required option of the patch properties is set, do not
reboot the server. Because of vendor settings, some patches ignore the suppress option and force a
reboot. For a service pack, if a reboot is suppressed, then the action is incomplete—the service
pack is not installed until after the reboot. The system does not have the software installed. The
status is “Not Installed/Uninstalled”. If youmanually check the system (look at the registry or server
properties), this is not the same information that displays in the SA Client. After the reboot, the SA
Client will not reflect the correct software or patch installed information until after the next software
registration.
When you suppress reboot during an Ubuntu patch installation (such as for a service pack), the
system's software statemight not accurately display. Accurate state information will display after
themanaged server is rebooted and software registration has completed.

l Hold all server reboots until after all packages are installed and/or uninstalled: If the Reboot
Required option is set for some selected patches but not for others, the server is rebooted one time
after all patches are installed. This option is commonly known as the single reboot option. If the
Reboot Required option is not set for any of the selected patches, the server is not rebooted.

To set reboot options:

1. From the Install Patch window, click Next to advance to the Pre & Post Actions step.
2. Select one of the Rebooting Options.
3. Click Next to go to the next step or click Cancel to close the Install Patch window.

Specify install scripts for an Ubuntu patch installation
For each patch, you can specify a command or script to run before installation or after installation. A
pre-install script, for example, could check a certain condition on themanaged server. If the condition is
not met or if the pre-install script fails, the patch would not be installed. A pre-install script could also be
used to shut down a service or application before it is patched. A post-install script could be used to
perform a certain cleanup process on themanaged server.

You can also specify the following types of scripts to run on themanaged server before or after an
installation or download phase:

l Pre-Download: A script that runs before patches are downloaded from SA to themanaged server.
This is available only if you select Staged in the Install Options step.

l Post-Download: A script that runs after patches are downloaded from SA to themanaged server
and before the patch is installed. This is available only if you select Staged in the Install Options
step.

l Pre-Install: A script that runs before patches are installed on themanaged server.
l Post-Install: A script that runs after patches are installed on themanaged server.
To specify a pre-install script:

1. From the Install Patch window, click Next to advance to the Pre & Post Actions step.
2. Select thePre-Install tab. Youmay specify different scripts and options on each of the tabs.
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3. Select Enable Script. This option enables the remainder of the fields on the tab. If Enable Script
is not selected, the script will not run.

4. Select eitherSaved Script orAd-Hoc Script.
A Saved Script has been previously stored in Server Automation with the SA Client. To specify
the script, click Select.
An Ad-Hoc script runs only for this operation and is not saved in Server Automation. Select the
Type, such as .bat. In the Script box, enter the contents of the script, including the drive letter of
where the script is located, such as echo dir>> C:\temp\preinstall1.log. If you do not enter a
drive letter, the default is%SYSTEMDRIVE%, which is where the system folder of Ubuntu is
installed.

5. If the script requires command-line flags, enter the flags in theCommand text box.
6. Specify the information in the User section. If you choose a system other than Local System,

enter the User Name, Password, and Domain. The script will be run by this user on themanaged
server.

7. To stop the installation if the script returns an error, select theError check box.
8. Click Next to go to the next step or click Cancel to close the Install Patch window.

Schedule an Ubuntu patch installation
Since the two phases of Ubuntu patching can be decoupled, you can schedule when you want patches
installed independently of when you want patches downloaded.

To schedule a patch installation:

1. From the Install Patch window, click Next to advance to the Scheduling step.
By default, the Scheduling step displays only the scheduling options for the installation phase. If
you selected Staged in the Install Options step, the scheduling options for the download phase will
also be displayed.

2. Select one of the following Install Phase options:
l Run Task Immediately: This enables the system to perform a preview analysis in the
Summary Review step. The scheduling option for the download phase is Run Immediately
Following Download

l Run Task At: This enables you to specify a later date and time that you want the installation or
download performed.

3. Click Next to go to the next step or click Cancel to close the Install Patch window.

Note:
A scheduled patch installation can be cancelled prior to its execution, even if the patch download
has already completed.

Set up email notifications for an Ubuntu patch installation
You can set up email notifications to alert users when the download and installation operations
complete successfully or with errors.

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 211 of 307



To set up email notifications:

1. From the Install Patch window, click Next to advance to the Notifications step.
2. To add email addresses, click Add Notifier and enter the email addresses in the Notification

Email Address field.

3. To set the notification status on the success of a Job, select the icon. To set the

notification status on the failure of a Job, select the icon. By default, the Notification step
displays only the notification status for the installation phase.

4. Enter a Ticket ID to be associated with a Job in the Ticket ID field.
5. Click Next to go to the next step or click Cancel to close the Install Patch window.

Note:
If you previously selected Staged in the Install Options step, the Notifications pane displays
notification options for both the download and installation phases.

Preview an Ubuntu patch installation
The installation preview process provides an up-to-date report about the patch state of servers. The
installation preview is an optional step that lets you see the patches that will be installed onmanaged
servers and the type of server reboots that are required. This preview process verifies whether the
servers that you selected for the patch installation already have that patch installed. In some cases, a
server could already have the patch installed if a system administrator hadmanually installed it, which
means that Ubuntu PatchManagement does not know about it.

The preview process also reports on dependency and supersedence information, such as patches that
require certain Ubuntu products, and patches that supersede other patches or are superseded by other
patches. If a dependency is not met, PatchManagement will display an error message indicating this
condition. If a patch is not needed, it will appear as ‘will not install’.

The following list explains user cases in which a patch will not be installed, as displayed in the Preview
step of the Install Patch or Remediate PatchWindow:

l This patch has a Never Install patch policy exception, so it will not be installed.
l This patch is superseded by another patch in the same job, so it will not be installed. This means
that another patch in the current job is more up to date than themarked patch.

l This patch is superseded by another patch, so it will not be installed. This means that the patch
installed on the server is more recent than the patch in the policy, so it will not be installed.

l This patch is not applicable because it is not recommended, so it will not be installed.
This information is also displayed in the Job results window and in an email, if email notification has
been configured for the patch install job.

Note: The installation preview does not report on the behavior of the server as though the patches
have been applied.

To preview a patch installation:
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1. From the Install Patch window, click Next to advance to the Summary Review step.
2. (Optional) Click Preview to see the separate actions that will be performed when the patch is

installed. To view the details of a previewed action, select a row in the table.
3. Click Start Job to launch the installation job or click Cancel to close the Install Patch window

without launching the installation.
If you selectedRun Task Immediately in the Scheduling step, the job begins now. If you
selectedRun Task At, the job will be launched at the specified time and date.

View job progress of an Ubuntu patch installation
You can review progress information about a patch installation job, such as whether actions have
completed or failed.

To display job progress information:

1. From the Install Patch window, click Next to advance to the Job Progress step. This will start the
installation job.
The Progress bar and text indicate how many of the actions listed in the table have been
completed. For each server, the following actions can be performed:
l Analyze: Server Automation examines the patches needed for the installation, checks the
managed servers for themost recent patches installed, and determines other actions that it
must perform.

l Download: The patch is downloaded from Server Automation to themanaged server.

l Install: After it is downloaded, the patch is installed.

l Final Reboot: If this action is specified in the Pre & Post Actions step, the server is rebooted.

l Pre/Post Install/Download Script: If this action is specified in the Pre & Post Actions step, a
script is run before or after the installation.

l Install & Reboot: When a patch is installed, the server is also rebooted.

l Verify: Installed patches will be included in the software registration.

2. To view additional details about a specific action, select the row in the table to display the start
and completion times of the job. In the navigation pane, select Jobs and Sessions to review
detailed information about the job. See the SA User Guide for more information about browsing job
logs.

Note:When a Vendor Recommended Patch Policy is remediated on an Ubuntumanaged
server, depending on what patches were applied, the server may require an additional
remediation. This can occur when the remediation installs a patch that requires subsequent
vendor updates.

3. Click Close to close the Install Patch window or click End Job to prevent the job from running.
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Patch management for Unix
In Server Automation (SA), patchmanagement for Unix enables you to identify, install, and remove
patches, to maintain a high level of security across managed servers in your organization. Using the
SA Client, you can identify and install patches that protect against security vulnerabilities for AIX
operating systems.

This section contains information about how to install and uninstall Unix patches using software
policies.

SA automates the key aspects of patchmanagement, while offering a fine degree of control over how
and under what conditions patches are installed.

Because patches are often released to address grave security threats, an organization needs to be able
to roll out patches quickly, before systems are compromised. At the same time, however, patches can
cause serious problems, from performance degradation to server failures.

SA allows you to react quickly to newly discovered threats and also provides support for strict testing
and standardization of patch installation. If patches cause problems after being tested and approved,
SA allows you to uninstall the patches in a safe and standardized way.

SA stores patch information in the SA Library that includes detailed information about every server
under management, the patches and software installed on the servers, and the patches and software
available for installation. You can use this data to determine the severity of your exposure to a newly
discovered threats, and to help assess the benefits of rolling out a patch versus the costs in downtime
and testing requirements.

By automating the patching procedure, SA can reduce the amount of downtime required for patching.
SA also allows you to schedule patch activity, so that patching occurs during off-peak hours.

Server Automation automates patchmanagement by providing the following features:

l The SA Library where patches are stored and organized in their formats
l A database that includes information on every patch that has been applied
l Customized scripts that can be run before and after a patch is installed
l Advanced search abilities that identify servers that require patching
l Auditing abilities that enable security personnel to track the deployment of important patches
These features enable you to browse patches by a certain operating system, schedule patch
downloads and installations, set up email notifications, preview a patch installation, use software
policies and remediation to install and uninstall patches, and export patch information to a reusable file
format.

Track patches on managed servers
When a server is brought under management by SA, the SA Agent installed on the server registers the
server’s hardware and software configuration with SA. This information includes installed software and
patches, is recorded in the SA Library. The SA Agent repeats this registration every 24 hours.
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When a new patch is issued, you can use Server Automation to immediately identify the servers that
require patching. The SA Library stores patches and other software. You can access the SA Library
from the SA Client to install patches on the appropriate servers.

After a server is brought under management, you should install all required patches. If you install a
patchmanually, Server Automation does not have data about that patch until the next SA Agent
registration. If you install a patchmanually, it can take up to 24 hours until the data about that server in
the SA Library is up-to-date.

Whenever you install or uninstall software or patches with Server Automation, however, SA
immediately updates the information about the server in the SA Library.

Support for Unix patch testing and installation
standardization
With SA you canminimize the risk of rolling out patches. First, when a patch is uploaded into the SA
Library, its status is marked as untested and only administrators with special privileges can install it.

The patch administrator then defines patch installation and uninstallation options and tests the patch.
Only after the patch is tested and the patch administrator marks it as available for use can other
administrators install the patch.

SA allows you to standardize the way that patches are installed and uninstalled, thereby preventing ad-
hoc installation procedures. Patch administrators standardize patch installation by providing pre-install
and post-install scripts, install and uninstall flags, reboot instructions, and how to handle error codes
from the pre-install and post-install scripts.

View patches in the SA Client
The SA Client lets you search for and display Unix patches by name, type of patch, operating system,
relationship to other packages, and so on. The following "HP-UX patches in the SA Library "
belowfigure below shows a list of patches for HP-UX 11.23. Use the column selector to right of the
column headers to control which columns of patch data to display. For more information, see "Unix
patch information" on page 223 and "View and edit Unix patch properties" on page 226.

HP-UX patches in the SA Library
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Search for patches
In the SA Client, you can search for any information about your operational environment that is
available in Server Automation using the SA Client. The SA Client enables you to search for patches,
software policies, servers, and so on. See “SA Client Search” in the SA User Guide.

Patch management roles for Unix
Server Automation provides support for rigorous changemanagement by assigning the functions of
patchmanagement to the patch administrator and the system administrator:

l The patch administrator (often referred to as the security administrator) has the authority to upload,
test, and edit patch options.
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l The system administrator applies the patches (that have been approved for use) uniformly,
according to the options that the patch administrator specifies.

Note: Only the patch administrator should have the Patches permission, which gives access to
advanced features. To obtain these permissions, contact your SA Administrator. See the
Permissions Reference section in the SA Administration Guide.

Patch Administrator
In most organizations, patch administrators are responsible for reviewing the latest security threats and
the patches that vendors have released to address these problems. The patch administrators are
generally experts in the operating systems and applications that they manage, and are able to assess
the necessity of applying patches issued by vendors. They are able to diagnose common problems that
arise after patches are installed, allowing them to thoroughly test the patch application process.

In Server Automation, patch administrators are granted specific permissions that allow them to upload
patches into Server Automation to test the patches and thenmark them as available for use. Basic
users can upload patches, but they cannot install them ormark them as available. Patch administrators
are also able to edit patch options (such as installation scripts) through patchmanagement. Other types
of users are not allowed to upload or edit patches.

Typically, the patch administrator uploads patches and then tests them on non-production reference
hardware. After testing the patches and determining that the patches are safe to apply to production
systems, they mark the patches as available in the Server Automation Client, and then advise the
system administrators that they must apply the approved patches.

SystemAdministrator
System administrators are responsible for the day-to-day maintenance of the servers in a deployment.
These users are not required to have the same level of expertise in low-level system details as the
patch administrator.

Because the patch administrator has set up the patch installation, the system administrators can apply
the patches to a large number of servers with a few mouse clicks. They are responsible for searching
for the servers that require the approved patch, installing the patch, and verifying that the patches are
installed successfully.

Patch management for specific Unix operating
systems
The types of patches and their underlying technologies can vary according to the vendor of the
operating system. This section discusses the vendor-specific details for Unix patchmanagement in
Server Automation.

Supported Unix versions and patch types
SA supports all of the operating system versions that Server Automation supports, except for Linux.
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Linux does not support patches in the ordinary sense. The packages are not patchable. Instead, new
versions of the RPM are delivered. Linux systems that Server Automationmanages are therefore not
viewable through the patch interfaces. New Linux packages and updates should bemanaged and
applied though the software policy. See the SA User Guide for information about importing and
installing RPMs using a software policy.

To see the Unix versions and patch types that SA supports.

1. In the SA Client, select the Library tab.
2. Select theBy Type tab.
3. Locate and open thePatches node. This displays all the operating systems on which SA supports

patches.
4. Select an operating system and open the node for that operating system. This displays all the

versions of that operating system that SA supports.

Underlying technologies for patch management on Unix
Although the utilities vary, Server Automation enables you to perform patching tasks by using a single
interface. Server Automationmodels the way it treats patches by the way the underlying utility treats
patches. For example, if the Solaris patchadd utility is not able to install one patch contained in a patch
cluster, the Solaris utility continues to install the remaining patches in the patch cluster. Server
Automation respects this behavior and allows that patch installation operation to continue. Any patches
that are not installed are reported at the end of the installation operation.

The following table shows the patchmanagement and installation tools that are used for each of the
supported Unix systems.

Solaris AIX HP-UX

Patchadd

installs Solaris patches

Installp

installs and uninstalls
filesets

Swlist

lists patch products, files, products, and
filesets

Patchrm

uninstalls Solaris patches

Lslpp

lists installed LPPs

Swinstall

installs a depot

Showrev

lists installed Solaris
patches

Instfix

lists installed APARs

Swremove

removes a depot

Pkgadd

installs Solaris packages

Pkginfo

lists installed Solaris
packages

Supporting Technologies for Patch Management on Unix
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AIX patches
AIX periodically releases Authorized Program Analysis Reports (APARs), which specify what update
filesets (contained in LPPs) are necessary to fix an identified problem. An APAR only specifies the
minimum version of an update fileset required to fix a problem; an APAR can therefore be satisfied with
later versions of the same filesets. Tomaintain compatibility, however, Server Automation always
adopts the fileset with the lowest version number that meets theminimum version that APAR
specifies. If a later version of the update fileset is uploaded, Server Automation still associates the
earlier version of the fileset with the APAR.

When uploading an LPP, Server Automation recognizes which APARs the filesets contained in the
LPP belong to. An entry is created for the APAR in the SA Library when the first fileset associated with
an APAR is uploaded. (In some cases, a fileset is associated with more than one APAR. An entry is
created for each APAR the fileset is associated with, if the entry does not already exist.)

If you want to install all LPPs that APAR specifies, youmust make certain to upload all of the specified
LPPs into the SA Library.

If you do not upload all of the LPPs that APAR specifies, it is still possible for the system administrator
to browse for an APAR and install the partial set of LPPs that are uploaded. In such cases, the
administrator receives a warning that the filesets for the APAR are not all installed.

The Patch Administrator must first upload and test an LPP before it is generally available in Server
Automation. The new fileset is integrated into the APAR only after the LPP is tested and approved.
Even though the APAR is updated automatically, you still maintain control over the exact filesets that
are allowed to be installed on your managed servers.

Update filesets cannot be installed on a server if the server does not already have the base filesets for
which the update filesets are intended.

If, however, a server has a partial set of the base filesets, the APAR can be applied and only the
applicable filesets for the base filesets are installed. For example, if an APAR specifies four update
filesets to update four base filesets, and you attempt to apply the APAR to a server that has only three
of the base filesets, three of the four update filesets from the APAR are installed.

When installing an AIX update fileset, the SA normally applies the fileset, which allows it to be rejected
(uninstalled.) If you want to commit the fileset instead (so that it cannot be removed), use the -c option
here.

Note:
Patch files, such as AIX update filesets and APARS, cannot be added to a particular folder and
cannot be owned by a particular user. See the the SA User Guide for information about how to use
folders.

Importing and remediating AIX patches

SA supports importing and remediating a set of AIX packages from aMaintenance Level (ML) or
Technology Level (TL) to perform AIX package installations.

Packages and patches are imported into SA independently. In order to update a server to a particular
ML or TL, you can import all the packages and patches that belong to theML or TL into SA with a single
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import. During this import, specify a new policy be created for the packages and patches. This will
create a policy representing theML/TL that you can then install onmanaged servers.

To import AIX patches:

1. Login to an SA Core as root.
2. Download all of the packages from an AIX Maintenance Level or Technology Level from IBM’s

website and place them in a temporary directory on the SA Core.
3. Import the patches into the SA Library using the import_aix_packages tool. This tool can also

generate a software policy containing all of the packages that have been imported.

/opt/opsware/mm_wordbot/util/import_aix_packages <directory containing AIX
packages>

where the import command always ends with the path for the directory containing the AIX
packages. See "AIX import options" below for additional AIX import options.

Sample import and remediate process for AIX

The following example imports AIX packages from a temporary directory on the SA Core,
/var/tmp/aix_package_files_directory.

1. Run the AIX import tool:
a. Sample A: Simple Import of AIX Packages and Patches

/opt/opsware/mm_wordbot/util/import_aix_packages /var/tmp/aix_package_files_
directory
o By default, the import_aix_packages tool will attempt to identify the OS version of the

package being imported. You can also use the '-o' or '--os' option to explicitly define the OS
for the imported packages. See "AIX import options" below for options.

o The imported AIX files can be viewed in the SA Client under Library > By Type >
Packages > AIX or Library > By Type > Patches > AIX.

b. Sample B: Import AIX Packages /Patches and Create a Policy
Use the ‘-p’ option to import patches and specify a policy:

/opt/opsware/mm_wordbot/util/import_aix_packages –p /AIX/AIX6.1/AIXPOLICY
/var/tmp/aix_package_file_directory
o The newly created policy can be viewed in the SA Client under Library > By Type >

Software Policies or Library > By Folder under the directory:

/AIX/AIX6.1/AIXPOLICY

2. Attach the newly created policy, AIXPOLICY, to an AIX managed server.
3. Remediate the server with the policy attached as you normally would to install the AIX package or

patch.

AIX import options

Option Description

-h,
--help

Show this helpmessage and exit

Options for import_aix_packages
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Option Description

-f,
--force

Force packages to be imported even if already in library.

-o OS,
--os=OS

OS version of packages: '4.3', '5.1', '5.2', '5.3', '6.1', '7.1'

The -o parameter value works with or without quotes, but only one value
can be specified at a time.

For example, to specify Technology Level 6 Service Pack 1, youmight
say:

/opt/opsware/mm_wordbot/util/import_aix_packages –o ‘6.1’
/var/tmp/aix_package_file_directory

OR

/opt/opsware/mm_wordbot/util/import_aix_packages –o 6.1
/var/tmp/aix_package_file_directory

-p POLICY_PATH, --
policy_path=POLICY_
PATH

Use this option to import AIX patches and generate a specified software
policy containing the uploaded units in one step.

Syntax:

/opt/opsware/mm_wordbot/util/import_aix_packages –p <full name and
path where SA Software Policy will be created> <directory containing
AIX packages>

Example:

/opt/opsware/mm_wordbot/util/import_aix_packages –p
/AIX/AIX6.1/AIXPOLICY /var/tmp/aix_package_file_directory

--policy_
mode=POLICY_MODE

policy installation semantics: 'update_all', 'install_latest'

-s,
--silent

Display errors only

-u USERNAME,
--
username=USERNAME

Upload packages as specified user (default: opsware)

-v,
--verbose

Display verbose output

--manual Show manual page and exit

Options for import_aix_packages, continued

Using multiple options

If you are usingmultiple options, there is no rule about the sequence of the options as long as the
command ends with the <directory containing AIX packages> parameter.
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For example, these commands would work equally well to import AIX 6.1 patches and create a policy
with the uploaded fileset:

/opt/opsware/mm_wordbot/util/import_aix_packages –p /AIX/AIX6.1/aix_policy –o ‘6.1’
/var/tmp/aix_package_file_directory

OR

/opt/opsware/mm_wordbot/util/import_aix_packages –o ‘6.1’ –p /AIX/AIX6.1/aix_
policy/var/ tmp/aix_package_file_directory

Solaris patches
A Solaris patch cluster contains a set of selected patches for a specific Solaris release level.
Ordinarily, after a patch cluster is installed, it is not possible to search for a particular patch cluster. The
patches do not contain any metadata that relate them to the patch cluster in which they were originally
bundled. You can only search for the individual patches.

If you install a Solaris patch cluster, however, Server Automation keeps track of the patch cluster in the
SA Library. You can therefore search for a patch cluster to determine if a full patch cluster is installed. If
you installed the patch cluster, you can uninstall individual patches in the cluster. You cannot uninstall
a patch cluster.

HP-UX patches
HP-UX patches are delivered exclusively as depots, which are patch products that contain patch
filesets. The depot is uploaded directly into Server Automation.

If a depot is already uploaded and attached to a node, it cannot be uploaded by SA. If you want to
upload the depot with SA, youmust detach a depot from any nodes that it is attached to, and then
delete it from the SA Library.

Upload Unix patches into the SA Library
Before a Unix patch can be installed on amanaged server, the patchmust be downloaded from the
server vendor and uploaded into the SA Library. For more information, see the SA Administration
Guide.

To upload Unix patches to the SA Library:

1. In the navigation pane, select Library > By Type > Patches. The patches are organized by
operating system.

2. Navigate to the desired operating system version.
3. From the Actions menu, select Import Software to open the Import Software window.
4. In the Import Software window, click Browse to locate and select the patch to import.

Before clickingOpen in the Open window, select the character encoding to be used by the patch
from the Encoding drop-down list.
You need to specify the character encoding so that SA can extract themetadata contained in the
patch and correctly display the information in non-ASCII characters in the SA Client (for example,
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in the Patch Properties pages). Patchmetadata includes comments, READMEs, scripts,
descriptions, and content lists.

5. Click Open.
The selected item should appear in the File(s) field in the Import Software window.

6. Select the appropriate type from the Type drop-down list.
The type is often populated based on the extension of the selected file. Review the listed types to
make sure the best one is selected for your import.

7. In the Folder field, select the desired directory of the SA Library.
8. From the Platform drop-down list, select all the operating system versions that the patch applies

to. You can only install the patch on servers that are running those versions of the operating
system.

9. Click Import to import the patch into the SA Library.
When the import is complete, the Status columnwill indicate the results:
l A check mark in the Status column indicates success.

l An X in the Status column indicates an error. Click theX to view the error details.

10. To find the imported patch, use the Search tool from theBy Type tab in the SA Library.

Unix patch information
The SA Client displays detailed information about a patch in several different views. For example, the
following figure shows the Properties view of an HP-UX patch. Note that the details about each patch
vary depending on the type andOS of patch. To view or edit patch properties, see "View and edit Unix
patch properties" on page 226.

Unix patch properties in the SA Client
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Patch properties view
Patch properties include the following information. Note that some information is only displayed for
certain operating systems and not others.

l Version: The version number of the patch.
l Status: The vendor’s status for the patch.
l Type: The type of Unix patch. Some examples are HP-UX Patch Product, HP-UX Patch Fileset,
Solaris Patch, Solaris Cluster, AIX APAR and AIX Update Fileset.

l OS: The Unix operating systems that are known to be affected by this patch.
l Availability: The status of a patch within Server Automation, which can be one of the following:
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l Limited: The patch has been imported into SA but requires additional permissions (Manage
Patch: Read & Write) to be installed. This is the default patch availability. For more information
on permissions, see the SA Administration Guide.

l Available: The patch has been imported into Server Automation, tested, and has beenmarked
available to be installed onmanaged servers.

l Deprecated: The patch cannot be added to patch policies or set as a patch policy exception but
can still be installed.

l Object ID: The Server Automation unique ID for the patch.
l Dependencies: When present, lists the dependencies on the selected patch. This is only provided
for some patch types and some platforms. For more information, see "Manage properties" on page
154.

l Install Parameters: When present, lists the actual install settings for the patch and the settings that
the patch vendor specifies for the patch. This is only provided for some patch types and some
platforms.

l Install Scripts: When present, lists scripts that will run on amanaged server before or after the patch
is installed. This is only provided for some patch types and some platforms.

l Uninstall Parameters: When present, lists the actual uninstall settings for the patch and the settings
that the patch vendor specifies for the patch. This is only provided for some patch types and some
platforms.

l Uninstall Scripts: When present, lists scripts that will run on amanaged server before or after the
patch is uninstalled. This is only provided for some patch types and some platforms.

Contents view
Patch Contents are displayed only for certain types of patch containers such as HP-UX Patch
Products, AIX APARs and Solaris Clusters. The Contents view lists all the patches included in the
selected patch container.

Depots view—HP-UX only
Patch Depots are only displayed for HP-UX Patch Products. The Depots view displays the HP-UX
depots that contain the selected patch product. SA displays HP-UX depots as SA packages.

Patch products view—HP-UX only
Patch Products are only displayed for HP-UX Patch Filesets. The Patch Products view displays the
HP-UX patch products that contain the selected HP-UX patch fileset.

Patch clusters view—Solaris only
Patch Clusters are only displayed for Solaris patches. The Patch Clusters view displays the Solaris
patch clusters that contain the selected Solaris patch. For more information on Solaris patches, see
"Patchmanagement for Solaris " on page 114.
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LPPs/APARs view—AIX only
The LPPs/APARs view is only displayed for AIX patches. This view displays the LPPs and APARs
that contain the selected patch.

Software policies view
The Software Policies view displays all the software policies that include the selected patch.

Patch policies view
The Patch Policies view displays all the patch policies that include the selected patch. The Patch
Policies view is only displayed for some platforms.

Servers view
The Servers view displays all the servers where the selected patch is installed.

View and edit Unix patch properties
The SA Client displays information about Unix patches that have been imported into Server Automation
as described in "Unix patch information" on page 223. You can edit some of a patch’s properties in the
properties view. Some properties are not editable.

You can set the install and uninstall parameters on either the patch properties page or when you are
install or uninstall the patch. The parameters on the Properties view are saved in the SA Library, but the
parameters specified during a patch install or uninstall are used only for that action. The parameters
specified during an install or uninstall override those on the patch Properties view.

To view or edit information about a patch:

1. In the navigation pane, select Library > By Type > Patches.
2. Expand Patches and select a specific Unix operating system.
3. (Optional) Use the column selector to sort the patches according to Name, Type, Availability, and

Description.
4. In the content pane, select a patch.
5. Right-click the patch or, from the Actions menu, select theOpenmenu. This displays the patch in

a separate screen.
6. If you havemodified any properties, select File > Save to save your changes.

Find servers that have a Unix patch installed
To find out which servers have a particular patch installed:
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1. In the navigation pane, select Library > By Type > Patches.
2. Expand Patches and select a specific Unix operating system. The content pane will display all

patches associated with that operating system.
3. In the content pane, select a patch.
4. From the View drop-down list in the content pane, select Servers. This shows all the servers

where the selected patch is installed.

Export a patch
You can export patches to the local file system. However, not all patch types can be exported. If you
attempt to export a patch and find that the Export menu is grayed out, that patch cannot be exported.

To export a patch from the SA Library to the local file system:

1. In the navigation pane, select Library > By Type > Patches.
2. Expand Patches and select a specific Unix operating system. The content pane will display all

patches associated with that operating system.
3. In the content pane, select a patch.
4. From the Actions menu, select Export. If the Export menu is grayed out, that patch cannot be

exported.
5. In the Export Patch window, enter the folder name that will contain the patch file in the File Name

field.
6. Click Export.

Delete a patch
This action removes a patch from the SA Library; however, it does not uninstall the patch from
managed servers. A patch cannot be deleted if it is attached to a policy.

Do not delete all of the patches from the SA Library. If you accidentally do so, contact your support
representative for assistance in uploading all of the patches back into SA.

To delete a patch:

1. In the navigation pane, select Library > By Type > Patches.
2. ExpandPatches.
3. Select a Unix operating system. The content pane displays all patches associated with that

operating system.
4. In the content pane, select a patch.
5. From the Actions menu, select Delete Patch.
6. In the Delete Patches window, click Delete.

Use software policies to manage patches
Patch Policies forWindows and Solaris are the best way tomanage patches for theWindows and
Solaris platforms. For more information see "Patchmanagement forWindows " on page 14 and "Patch
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management for Solaris " on page 114.

For other platforms, software policies enable you to customize patch distribution in your environment.
Software policies define which Unix patches should be installed or not installed on certain managed
servers.

If you use software policies and you also perform ad hoc patch installs, youmust run the remediate
process to install all applicable patches on servers. See the SA Administration Guide for more
information about creating and remediating software policies to install Unix patches.

Patch compliance reports
To troubleshoot and resolve patch compliance problems, you can run and examine several patch
compliance reports in the SA Client. The following patch compliance reports identify whether all
patches in a software policy were installed successfully onmanaged servers in your environment.

Patch policy compliance (All servers)

This report groups all managed servers by their patch policy compliance level to show compliant and
non-compliant servers.

Patch policy compliance by customer

This report lists all servers by the customer they belong to and then by the patch policy compliance
level.

Patch policy compliance by facility

This report groups all managed servers by the facility they belong to and then by the patch software
policy compliance level.

See the SA Administration Guide for information about how to run, export, and print these reports.

Patch administration for Unix
You can customize patch administration for Unix to best support your environment by setting the
availability flag.

Setting the default patch availability
You can set the default patch availability with the SA Client. The default used by the script overrides
the default set by the SA Client. See the SA Administration Guide for information about the script.

To set the default value for the Availability of a newly imported patch:

1. In the navigation pane, select Administration.
2. Select Patch Configuration.
3. For the Default Availability for Imported Patches, select eitherAvailable or Limited. The default

is Limited.
If the patch is Available, it can be installed onmanaged servers. If the patch is Limited, it has been
imported into Server Automation and can be installed only by a patch administrator who has the
required permissions (Manage Patch: Read & Write). To obtain these permissions, contact your
SA Administrator. See also the SA Administration Guide.
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Patch installation
The patch installation process consists of two phases:

l Download phase - This is when the patch is downloaded from Server Automation to themanaged
server. This phase is commonly referred to as staging.

l Installation phase -This is when the patch is installed on themanaged server. This phase is
commonly referred to as deployment.

You can specify whether you want the installation to occur immediately after the patch is downloaded
(staged) or you can schedule it to occur at a later date and time. Patchmanagement also supports the
need for best-effort installations of multiple patches by allowing you to specify that the patch
installation process will continue even when an error occurs with one of the patches.

SA displays the name of the command that installs the patch. The SA Agent runs this command on the
managed server. You can override the default command-line arguments that you want to perform the
installation.

To optimally manage patch installations, patchmanagement enables you tomanage server reboot
options and pre- and post-installation scripts, simulate (preview) a patch installation, and set up email
notifications to alert you about the status of the installation process. The Install Patch wizard guides
you through the setup.

Install Patch wizard

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 229 of 307



Installation flags
You can specify installation flags that are applied whenever a Unix patch is installed. However, Server
Automation also uses default installation flags and requires that patches are installed with these flags.
Youmust therefore be certain that you do not specify any installation flags that override or contradict
the default flags passed in by Server Automation. See "Set install options" on the next page for
information about how to specify commands.

The following table lists the default installation flags that Server Automation uses.

Unix patch type Flags

AIX -a -Q -g -X -w

HP-UX None

Default installation flags

Application patches
SA does not allow you to apply a patch to an operating system for which the patch is not intended.
When you are installing an application patch, SA does not automatically filter out servers that do not
have the corresponding application installed. Although SA does not prevent you from doing so, you
should not attempt to apply application patches to servers that do not have the necessary applications
installed. If a patch is for an application that is not installed on the server, the patch will not be applied
and an error message will display, such as “There was an error with package <name of the package>”.

If an application patch is intended for an application that is running onmore than one version of the
same operating system, you cannot apply the patch to all of the servers at the same time. An
application patch is associated with only one operating system version. Youmust first select the patch
for one operating system, select the servers where the application is installed, and apply the patch. You
must repeat this process for each version of the operating system where the application is installed.

Similarly, when uninstalling application patches that are installed onmultiple versions of the same
operating system, you cannot uninstall all of the patches at the same time. Youmust repeat the
uninstallation process for each version of the operating system where the patch is installed.

Install a patch
Before a patch can be installed on amanaged server, it must be imported into Server Automation and
its status must be Available. Administrators who have the required permissions can install patches that
aremarked Limited.

Note: Youmust have a set of permissions tomanage patches. To obtain these permissions,
contact your SA Administrator. See the SA Administration Guide.

You can perform the installation by explicitly selecting patches and servers.

To install a patch on amanaged server:
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1. In the navigation pane, select Library and then select Patches.
2. Expand the Patches and select a specific Unix operating system.
3. In the content pane, select a patch.
4. From the View drop-down list, select Servers (orServer Groups).
5. From the Show drop-down list, select Servers without Patch Installed (orServer Groups

without Patch Installed).
6. In the preview pane, select one or more servers.
7. From the Actions menu, select Install Patch.

The first step of the Install Patch window appears: Servers and Server Groups. For instructions on
each step, see the following sections:
l "Set reboot options" on the next page

l "Specify install scripts" on the next page

l "Scheduling a patch uninstallation" on page 239

l "Set up email notifications" on page 234

l "Preview a patch installation" on page 234

l "View job progress for a patch uninstallation" on page 240

After you have completed a step, click Next to advance to the next step. Before you click Start
Job, you can return to a completed step tomake changes by clicking on it in the list of steps.

8. When you are ready to launch the installation job, click Start Job.
After you launch the job, you cannot change its parameters, even if the job is scheduled to run at a
later time.
If the Install Patch window remains open until the job completes, SA updates the Patch
Compliance column in the All Managed Servers window with the revised compliance count (in
parenthesis) for affected servers. Press F5 or select Refresh from the View menu to update
information in the patch preview pane.

Set install options

You can specify the following types of patch installation options:

l Perform the patch installation immediately after the patch is downloaded or at a later date and time.
l Do not interrupt the patch installation process even when an error occurs with one of the patches.
l Use different command-line options to perform the installation.
To set these options:

1. In the Install Patch window, click Next to advance to the Install Options step.
2. Select one of the following Staged Install Options:

l Continuous: This allows you to run all phases as an uninterrupted operation.

l Staged: This allows you to schedule the download and installation to run separately
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3. Select the Error Options check box if you want the patch installation process to continue even
when an error occurs with one of the patches. As a default, this check box is not selected.

4. In the Install Command text box, enter command-line arguments for the command that is
displayed.

5. Click Next to go to the next step or click Cancel to close the Install Patch window.

Set reboot options

Tominimize the downtime that server reboots can cause, you can control when servers will and will not
be rebooted. You can adopt the vendor's reboot assignments, reboot a server each time a patch is
installed on it, completely suppress all server reboots, or postpone reboots until all patches are
installed.

When you are selecting reboot options in the Install Patch window, HP recommends that you use the
HP-UX reboot recommendations, which is the “Reboot servers as specified by patch properties”
option. If you cannot use the HP-UX reboot setting, select the single reboot option, which is the “Do not
reboot servers until all patches are installed” option.

The following options determine whether the servers are rebooted after the patch is installed. These
options apply only to the job launched by the Install Patch window. They do not change the Reboot
Required option, which is on the Install Parameters tab of the patch properties window. Except for the
first option, the following options override the Reboot Required option.

l Reboot servers as specified by patch properties
By default, the decision to reboot depends on the Reboot Required option of the patch properties.
The server is rebooted only once at the end. This is done to satisfy the patch dependency. In effect,
the option works as the third option which is to not reboot servers until all patches are installed

l Reboot servers after each patch install
Even if the Reboot Required option of the patch properties is not set, reboot the server. If multiple
patches are installed, the server will be rebooted only once after all patches are installed.

l Do not reboot servers until all patches are installed
If the Reboot Required option is set for some selected patches but not for others, the server is
rebooted one time after all patches are installed. If the Reboot Required option is not set for any of
the selected patches, the server is not rebooted.

l Suppress all server reboots
Even if the Reboot Required option of the patch properties is set, do not reboot the server. (Because
of vendor settings, some patches ignore the suppress option and force a reboot.)

To set reboot options:

1. In the Install Patch window, click Next to advance to the Pre & Post Actions step.
2. Select one of the Rebooting Options.
3. Click Next to go to the next step or click Cancel to close the Install Patch window.

Specify install scripts

For each patch, you can specify a command or script to run before installation or after installation. A
pre-install script, for example, could check a certain condition on themanaged server. If the condition is
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not met or if the pre-install script fails, the patch would not be installed. A pre-install script could also be
used to shut down a service or application before it is patched. A post-install script could be used to
perform a certain cleanup process on themanaged server.

You can also specify the following types of scripts to run on themanaged server before or after an
installation or download phase:

l Pre-download: A script that runs before patches are downloaded from SA to themanaged server.
This is available only if you select Staged in the Install Options step.

l Post-download: A script that runs after patches are downloaded from SA to themanaged server and
before the patch is installed. This is available only if you select Staged in the Install Options step.

l Pre-install: A script that runs before patches are installed on themanaged server.
l Post-install: A script that runs after patches are installed on themanaged server.
To specify a pre-install script:

1. In the Install Patch window, click Next to advance to the Pre & Post Actions step.
2. Select thePre-Install tab. Youmay specify different scripts and options on each of the tabs.
3. Select Enable Script. This option enables the remainder of the fields on the tab. If Enable Script

is not selected, the script will not run.
4. Select eitherSaved Script orAd-Hoc Script.

A Saved Script has been previously stored in Server Automation with the SA Client. To specify
the script, click Select.

5. If the script requires command-line flags, enter the flags in the Command text box.
6. Specify the information in the RuntimeOptions. If you choose a user account other than root, enter

the User Name and Password. The script will be run by this user on themanaged server.
7. To stop the installation if the script returns an error, select theError check box.
8. Click Next to go to the next step or click Cancel to close the Install Patch window.

Schedule a patch installation

Since the two phases of patching can be decoupled, you can schedule when you want patches
installed (deployed) to occur independently of when patches are downloaded (staged).

To schedule a patch installation:

1. In the Install Patch window, click Next to advance to the Scheduling step.
By default, the Scheduling step displays only the scheduling options for the install phase. If you
selected Staged in the Install Options step, the scheduling options for the download phase will
also be displayed.

2. Select one of the following Install Phase options:
l Run Task Immediately: This enables the system to perform a preview analysis in the
Summary Review step. The scheduling option for the download phase is Run Immediately
Following Download.

l Run Task At: This enables you to specify a later date and time that you want the installation or
download performed.

3. Click Next to go to the next step or click Cancel to close the Install Patch window.
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Note:
A scheduled patch installation can be cancelled (prior to its execution), even if the patch download
has already completed.

Set up email notifications

You can set up email notifications to alert users when the download and installation operations
complete successfully or with errors.

To set up email notifications:

1. In the Install Patch window, click Next to advance to the Notifications step.

2. To set the notification status on the success of a Job, select the icon. To set the

notification status on the failure of a Job, select the icon. By default, the Notification step
displays only the notification status for the installation phase.

3. Enter a Ticket ID to be associated with a Job in the Ticket ID field.
4. Click Next to go to the next step or click Cancel to close the Install Patch window.

Note:
If you previously selected Staged in the Install Options step, the Notifications pane displays
notification options for both the download and installation phases.

Preview a patch installation

The installation preview process provides an up-to-date report about the patch state of servers. The
installation preview is an optional step that lets you see what patches will be installed onmanaged
servers and what type of server reboots are required. This preview process verifies whether the servers
you selected for the patch installation already have that patch installed. In some cases, a server could
already have the patch installed if a system administrator hadmanually installed it, whichmeans that
SA does not know about it.

The preview process also reports on dependency information, such as patches that require certain Unix
products, and patches that obsolete other patches or are obsoleted by other patches. If a dependency
is not met, SA will display an error message indicating this condition.

The installation preview does not report on the behavior of the server as though the patches have been
applied.

To preview a patch installation:

1. From the Install Patch window, click Next to advance to the Summary Review step.
2. Verify the information displayed for the Servers, Server Groups, and Patches at the top of the

window.
3. (Optional) Click Preview to see the separate actions that will be performed when the patch is

installed. To view the details of a previewed action, select a row in the table.
4. Click Start Job to launch the installation job or click Cancel to close the Install Patch window

without launching the installation.
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If you selectedRun Task Immediately in the Scheduling step, the job begins now. If you selected
Run Task At, the job will be launched at the specified time and date.

View job progress for a patch installation

You can review progress information about a patch installation (job), such as whether actions have
completed or failed.

To display job progress information:

1. In the Install Patch window, click Next to advance to the Job Progress step. This will start the
installation job.
The Progress bar and text indicate how many of the actions listed in the table have been
completed. For each server, the following actions can be performed:
l Analyze: Server Automation examines the patches needed for the installation, checks the
managed servers for themost recent patches installed, and determines other actions that it
must perform.

l Download: The patch is downloaded from Server Automation to themanaged server.

l Install: After it is downloaded, the patch is installed.

l Final Reboot: If this action is specified in the Pre & Post Actions step, the server is rebooted.

l Pre/Post Install/Download Script: If this action is specified in the Pre & Post Actions step, a
script is run before or after the uninstallation.

l Install & Reboot: When a patch will be installed is also when the server will be rebooted.

l Verify: Installed patches will be included in the software registration.

2. To view additional details about a specific action, select the row in the table to display the start
and completion times of the job. In the navigation pane, select Jobs and Sessions to review
detailed information about the job.

3. Click End Job to prevent the job from running or click Close to close the Install Patch window.

Patch uninstallation
SA provides granular control over how and under what conditions Unix patches are uninstalled
(removed) frommanaged servers. Tominimize problems, you can only uninstall one patch at a time.
You cannot use SA to uninstall a patch that was not installed using SA.

To help you optimally manage these conditions, SA allows you to do the following:

l Manage server reboot options, and pre and post installation scripts.
l Simulate (preview) a patch uninstallation.
l Set up email notifications to alert you about the status of the uninstallation process.
The Uninstall Patch window guides you through setting up these conditions.

Uninstall Patch window
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Uninstallation flags
You can specify uninstallation flags that are applied whenever a Unix patch is uninstalled. However,
Server Automation also uses default uninstallation flags and requires that patches are uninstalled with
these flags. Youmust therefore be certain that you do not specify any uninstallation flags that override
or contradict the default flags passed by Server Automation.

The following table lists the default uninstallation flags that Server Automation uses.

Operating System/Patch Types Flags

AIX -u -g -X

AIX Reject Options -r -g -X

HP-UX None

Default uninstallation flags

Uninstalling a patch
To remove a patch from amanaged server:

1. In the navigation pane, select Library and then select Patches.
2. Expand the Patches and select a specific Unix operating system.
3. In the content pane, select a patch.
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4. From the View drop-down list, select Servers.
5. From the Show drop-down list, select Servers with Patch Installed.
6. In the preview pane, select one or more servers.
7. From the Actions menu, select UninstallPatch.

The first step of the Uninstall Patch window appears: Servers. For instructions on each step, see
the following sections:
l "Set reboot options" on the next page

l "Specifying pre-installation and post-installation scripts" on the next page

l "Scheduling a patch uninstallation" on page 239

l "Set up email notifications" on page 239

l "View job progress for a patch uninstallation" on page 240

After you have completed a step, select Next to advance to the next step. Before you click Start
Job, you can return to a completed step tomake changes by clicking on it in the list of steps.

8. When you are ready to launch the uninstallation job, select Start Job.
After you launch the job, you cannot change its parameters, even if the job is scheduled to run at a
later time.
If the Uninstall Patch window remains open until the job completes, SA updates the Patch
Compliance column in the All Managed Servers window with the revised compliance count (in
parenthesis) for affected servers. Press F5 or select Refresh from the View menu to update
information in the patch preview pane.

Set uninstall options
You can specify the following types of patch uninstallation options:

l Do not interrupt the patch uninstallation process even when an error occurs with one of the patches.
l Use different command-line options to perform the uninstallation.
To set these options:

1. From the Uninstall Patch window, click Next to advance to the Uninstall Options step.
2. Select theError Options check box if you want the patch installation process to continue even

when an error occurs with one of the patches. As a default, this check box is not selected.
3. In the Uninstall Command text box, enter command-line arguments for the command (.exe file)

that is displayed. By default, Server Automation adds /z /q. If you want to override these uninstall
flags, enter /-z /-q in the text box.

4. Click Next to go to the next step or click Cancel to close the Uninstall Patch window.
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Set reboot options
Tominimize the downtime that server reboots can cause, you can control when servers will and will not
be rebooted. You can adopt the vendor’s reboot assignments, reboot a server each time a patch is
removed from it, completely suppress all server reboots, or postpone reboots until all patches have
been uninstalled.

When you are selecting reboot options in the Uninstall Patch window, Hewlett Packard recommends
that you use the Unix reboot recommendations, which is the “Reboot servers as specified by patch
properties” option in the window. If it is not possible to use the Unix reboot setting, select the single
reboot option, which is the “Do not reboot servers until all patches are installed” option in the window.

The following options determine whether the servers are rebooted after the patch is uninstalled. These
options apply only to the job launched by the Uninstall Patch window; they do not change the Reboot
Required option, which is on the Uninstall Parameters tab of the patch properties window. Except for
the first option, the following options override the Reboot Required option.

l Reboot servers as specified by patch properties: By default, the decision to reboot depends on the
Reboot Required option of the patch properties.

l Reboot servers after each patch install: Even if the Reboot Required option of the patch properties is
not set, reboot the server. If multiple patches are installed, the server reboots multiple times.

l Suppress all server reboots: Even if the Reboot Required option of the patch properties is set, do not
reboot the server. (Because of vendor settings, some patches ignore the suppress option and force a
reboot.)

l Do not reboot servers until all patches are installed: If the Reboot Required option is set for some
selected patches but not for others, the server is rebooted one time after all patches are installed. If
the Reboot Required option is not set for any of the selected patches, the server is not rebooted.

To set reboot options:

1. In the Uninstall Patch window, click Next to advance to the Pre & Post Actions step.
2. Select one of the Rebooting Options.
3. Click Next to go to the next step or click Cancel to close the Uninstall Patch window.

Specifying pre-installation and post-installation scripts
For each patch, you can specify a command or script to run before uninstallation or after uninstallation.
A pre-uninstall script, for example, could check a certain condition on themanaged server. If the
condition is not met or if the pre-uninstall script fails, the patch would not be removed from a server. A
pre-uninstall script could also be used to shut down a service or application before it is removed from a
server. A post-uninstall script could be used to perform a certain cleanup process on themanaged
server.

You can specify the following types of scripts to run on themanaged server before or after a patch
uninstallation:

l Pre-uninstall: A script that runs before the patch is removed from amanaged server.
l Post-uninstall: A script that runs after the patch is removed from amanaged server.
To specify a script:
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1. In the Uninstall Patch window, click Next to advance to the Pre & Post Actions step.
2. Select thePre-Uninstall orPost-Uninstall tab.

Youmay specify different scripts and options on each of the tabs.
3. Select Enable Script.

This option enables the remainder of the fields on the tab. If Enable Script is not selected, the
script will not run.

4. Select eitherSaved Script orAd-Hoc Script.
A Saved Script has been previously stored in Server Automation with the SA Client. To specify
the script, click Select.

5. If the script requires command-line flags, enter the flags in Commands.
6. Specify the information in theRuntimeOptions. If you choose a user account other than root,

enter the User Name and Password. The script will be run by this user on themanaged server.
7. To stop the uninstallation if the script returns an error, select Error.

Scheduling a patch uninstallation
You can schedule that a patch will be removed from a server immediately, or at a later date and time.

To schedule a patch uninstallation:

1. In the Uninstall Patch window, click Next to advance to the Scheduling step.
2. Select one of the following Install Phase options:

Run Task Immediately: This enables you to perform the uninstallation in the Summary Review
step.
Run Task At: This enables you to specify a later date and time that you want the uninstallation
performed.

3. Click Next to go to the next step or click Cancel to close the Uninstall Patch window.

Set up email notifications
You can set up email notifications to alert users when the patch uninstallation operation completes
successfully or with errors.

To set up email notifications:

1. In the Uninstall Patch window, click Next to advance to the Notifications step.

2. To set the notification status on the success of a Job, select the icon. To set the

notification status on the failure of a Job, select the icon. By default, the Notification step
displays only the notification status for the uninstallation phase.

3. Enter a Ticket ID to be associated with a Job in the Ticket ID field.
4. Click Next to go to the next step or click Cancel to close the Uninstall Patch window.
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Preview a patch uninstallation
The uninstallation preview process provides an up-to-date report about the patch state of servers. The
uninstallation preview is an optional step that lets you see what patches will be removed frommanaged
servers. This preview process verifies whether the servers you selected for the patch uninstallation
have that patch installed.

The uninstallation preview process does not report or simulate the behavior of a system with patches
removed from the server.

To preview a patch uninstallation:

1. In the Uninstall Patch window, click Next to advance to the Summary Review step.
2. Verify the information displayed for the Servers, Server Groups, and Patches at the top of the

window.
3. (Optional) Click Preview to see the separate actions that will be performed when the patch is

uninstalled. To view the details of a previewed action, select a row in the table.
4. Click Start Jobto launch the job or click Cancel to close the Uninstall Patch window without

launching the uninstallation.
If you selectedRun Task Immediately in the Scheduling step, the job begins now. If you
selectedRun Task At, the job will be launched at the specified time and date.

View job progress for a patch uninstallation
You can review progress information about a patch uninstallation (job), such as whether actions have
completed or failed.

To display job progress information:

1. In the Uninstall Patch window, click Next to advance to the Job Progress step. The Progress bar
and text indicate how many of the actions listed in the table have been completed. For each
server, the following actions can be performed:
l Analyze: Server Automation examines the patches needed for the uninstallation, checks the
managed servers for themost recent patches installed, and determines other actions that it
must perform.

l Uninstall: The patch is uninstalled.

l Final Reboot: If this action is specified in the Pre & Post Actions step, the server is rebooted.

l Pre/Post Uninstall Script: If this action is specified in the Pre & Post Actions step, a script is
run before or after the uninstallation.

l Uninstall & Reboot: When a patch will be installed is also when the server will be rebooted.

l Verify: Installed patches will be included in the software registration.

2. To view additional details about a specific action, select the row in the table to display the start
and completion times of the job. In the navigation pane, select Jobs and Sessions to review
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detailed information about the job. .
3. Click End Job to prevent the job from running or click Close to close the Uninstall Patch window.

Patch management for Red Hat Enterprise
Linux
Server Automation patchmanagement for Red Hat Enterprise Linux enables you tomanage security
and non-security patches for your Red Hat supportedManaged Servers. It allows you to identify,
install, and audit Red Hat package updates, keeping a high level of security across managed servers in
your organization.

In Server Automation, patches are the equivalent of Red Hat errata. The latter are package updates,
bug fixes, and security patches for Red Hat Linux. They have been tested and approved by Red Hat,
Inc. and can be found at https://rhn.redhat.com/errata/.

High-level architecture
Server Automation Red Hat patchingmechanism allows you to import patches from RedHat or from
other sources, scanmanaged servers to determine their current patching level and perform the
deployment of patches. Finally, the server can be checked for compliance against the recommended
set of patches.

The following figure displays the high level architecture for the Server Automation Red Hat patching
mechanism.

A typical Red Hat patching use case follows a well-defined process. Patches are first imported into
Server Automation. This is followed by an optional step where you canmanage the patches. In the third
step we need to determine what patches are recommended for the Red Hat managed servers. The
result of this step is dependent on the patching levels of each of your managed servers. In other words,

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 241 of 307

https://rhn.redhat.com/errata/


twomachines with the sameRedHat platform can have different patches recommended. Once the
recommended patches are found, themanaged servers can be remediated. After the remediation
occurs, the patched servers can be checked for compliance.

Import patches for Red Hat platforms
A RedHat patch in the Server Automation terminology is equivalent to an RPM package. This means
that you can have your own custom packages imported in Server Automation that can be found
applicable to a set of managed servers. The import process uploads the RPM patches into the SA
Library and, since they are treated as normal RPM packages, you can use them in operations like
Software Installation, Software Policy creation and remediation, Software Compliance, and so on.

Currently, there are three ways to import Red Hat patches into Server Automation. The first one will be
to upload the RPM packages into SA Library using the Server Automation Command Line Interface.
For details on OCLI, see the SA User Guide.

The second way of importing Red Hat packages into Server Automation is through SA Client built in
importer. This tool allows importing of multiple RPM packages simultaneously. If a RPM package that
is being uploaded already exists in the SA Library, you can replace (overwrite) the contents of the
existing package, skip the package import (useful when importingmultiple packages), or cancel the
import in progress. When overwriting an existing software package, SA preserves any reboot options or
flags previously set for the package. For a detailed guide on how to import Red Hat patches using the
SA Client see the SA User Guide, specifically the Import Software Packages section.

The first two approaches work best for scenarios where custom patches must be imported into SA. To
import the official patches issued by Red Hat you have to use the Server Automation Red Hat Importer
tool which comes preinstalled with the slice component. You can find the binaries for this tool in
/opt/opsware/rhn_import/bin.

Importing Red Hat Errata and channels in SA using SA Red Hat
Importer tool
RedHat publishes Errata which contains information describing security patches, bug fixes, and
package updates for Red Hat Enterprise Linux. To install the packages in the Errata, the Erratamust be
downloaded from the Red Hat web site and imported into Server Automation. Using Server Automation
you can automatically download the Errata released by Red Hat, convert them to policies, and store the
policy in a folder in the SA Library. Also, Red Hat publishes channels which contain packages from a
particular repository. Using Server Automation you can automatically download the packages in a
channel, convert them to policies, and store the policy in a folder in the SA Library.

The rhn_import and redhat_importCLI programs provided by Server Automation enable you to
create policies which correspond to Red Hat errata and channels. Using the CLI programs, you can
create the following types of policies:

l Channel-based software policy: A Red Hat Network channel contains a list of packages. A
channel allows you group packages as per your organizational requirements. For example, a channel
may contain packages for a particular Red Hat operating system version or architecture. A channel
may contain other child channels. When you run the importer, Server Automation downloads the
latest packages from the Red Hat Network channel, imports the packages to the Server Automation
Library and creates a channel based software policy.
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Thus, a channel based policy reflects a particular channel. In the SA Client, you can view the name,
description, location, availability, and the operating system version of the channel based policy in
the Library.

l Errata based software policy: Red Hat Network Errata contains information on a particular
problem and the associated packages to resolve the problem. An Errata based policy contains all the
individual Erratum-based policies for a given channel. Server Automation downloads the latest
packages from the Red Hat Network errata and then imports the packages to the Server Automation
Library and creates an errata based software policy. There are three types of Red Hat Network
Errata: Bug Fix Advisories, Product Enhancement Advisories, and Security Advisories. The
importer allows you to create errata policies for Bug Fix Advisories, Product Enhancement
Advisories, and Security Advisories in the SA Client. In the SA Client, you can view the name,
description, location, availability, and the operating system version of the errata based policy in the
Library.

l Erratum-based software policy: Erratum-based policies contain packages associated with a
particular erratum. When you run the rhn_import or redhat_import program, Server Automation
downloads the latest packages from the Red Hat Network erratum and then imports the packages to
the Server Automation Library and creates an Erratum-based software policy.

To create andmaintain policies from the Red Hat Linux errata, erratum, and channels, log into the core
server running the Software Repository component (part of the Slice Component bundle) and run the
redhat_import program located in the /opt/opsware/rhn_import/bin/redhat_import directory.

The software policies created by redhat_importwill, by default, have an empty uninstall sequence.
This setting prevents the inadvertent uninstall of the RPMs in the policy when it is detached.

Importing RPM packages from the Red Hat Network to Server Automation requires a large amount of
disk space. Over a period of time, the amount of disk space required increases as new versions of
packages are released by Red Hat. HP recommend having at least 5 GB of disk space available in
Software Repository for every Red Hat channel you enable using the importer.

To view the complete documentation run the program with the following option:

/opt/opsware/rhn_import/bin/redhat_import --manual

When you run the importer you can specify the options listed in the documentation provided by the tool
or use the Configuration File provided by Server Automation. This is located in the
/etc/opt/opsware/rhn_import/redhat_import.conf file.

Users of redhat_import should notice improved performance when importing from RedHat
SubscriptionManagement (RHSM) compared to importing the same content from RedHat Network
Classic (RHN).

Red Hat Subscription Management overview
RHSM is the primary subscriptionmanagement service provided by Red Hat and is the replacement for
Red Hat Network Classic (RHN). RHSM is an end-to-end solution with status, inventory, organization,
and reporting for Red Hat subscriptions via a hosted web-interface accessed from the Red Hat
Customer Portal.

Although subscriptionmanagement was primarily established on RedHat Enterprise Linux, all Red Hat
products are expected to be integrated with Red Hat SubscriptionManagement. Red Hat Subscription
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Services are available for systems running Red Hat Enterprise Linux 5 (5.7 or later), 6 (6.1 or later) and
7.

Systems running RHEL 5 (5.7+) and 6 (6.1+) can subscribe to both RHN and RHSM. However, RHEL
7 systems can only subscribe to RHSM, unless using Red Hat Satellite 5.6 or above. A direct
consequence of this is that the RHEL 7 channels are not available in RHN whichmeans that the old
rhn_import cannot be used to import RHEL 7 content into the SA Library. The RHEL 7 channels are
only available when using Satellite 5.6 or above. The old rhn_import tool can only be used to import
RHEL 7 content when used behind a Satellite 5.6 or Satellite 5.7.

Note: More details about the specific supported versions can be found in the SA Support and
Compatibility Matrix associated with your SA version.

The following table provides amapping between the subscription tools provided by Red Hat and the
content they provide.

Subscription Type Content Provided
SA Import
Tool

RedHat Network Classic (RHN) Everything except channels for Red Hat
Enterprise Linux 7

rhn_import
redhat_import

Red Hat SubscriptionManagement
(RHSM)

Everything including channels for Red Hat
Enterprise Linux 7 and above

redhat_import

Red Hat Satellite 4.x and 5.x (up to
and including version 5.5)

Everything except channels for Red Hat
Enterprise Linux 7

rhn_import
redhat_import

Red Hat Satellite 5.6 and 5.7 Everything including channels for Red Hat
Enterprise Linux 7

rhn_import
redhat_import

Red Hat Satellite 6.x Everything including channels for Red Hat
Enterprise Linux 7 and above

redhat_import

The new redhat_import tool is the preferred way to import Red Hat content and will be detailed in the
sections that will follow.

RHN Classic, RHSM, and Satellite
There are some conceptual differences between RedHat SubscriptionManagement and RHN Classic,
and this translates into differences in the way that subscriptions are defined. In older subscription
models — themodel used by RHN Classic and Satellite 5— a system required channel entitlements
which granted access to sets of content and software – commonly known as channels.

Red Hat SubscriptionManagement and Satellite 6 uses public-key infrastructure (PKI) certificates to
uniquely identify the system, the products on the system, and their attached subscriptions.

The old and new subscriptionmodels are fundamentally different. The old rhn_import tool is
associated with the old subscriptionmodel and thus is only capable of importing content from RHN
Classic, and Satellite 5. To support Red Hat Customer Portal and Satellite 6 with the new subscription
model — that is RHSM—a new tool has been added.
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Content import using Red Hat Subscription Management
The Server Automation RHN import has been enhanced to support content import from both RHN and
RHSM. This allows for content import for RHEL 7 and other Red Hat products using RHSM.

redhat_import binary

To support content import from RHSM, a new binary has been added: redhat_import. This binary is
capable of importing from both RHN and RHSM and uses an updated configuration file format (see
"redhat_import configuration file" below). The behavior of the old rhn_import binary has not been
changed and it uses the old configuration file format. Users that do not need to import content from
RHSM can still use the rhn_import binary without any changes to the configuration file. However
users are encouraged tomigrate to the new redhat_import binary.

redhat_import configuration file

Users using the new binary file will have tomigrate the existing configuration files to the new format.
The new redhat_import binary does not work with old configuration files.

The redhat_import configuration file adds two new sections [RHN] and [RHSM] to control the import
from RHN andRHSM respectively. For more details on the format of the redhat_import configuration
file, see themanual page of redhat_import:

/opt/opsware/rhn_import/bin/redhat_import --manual

A sample configuration file is available at:

/etc/opt/opsware/rhn_import/redhat_import.conf-sample

Entitlement certificates
RedHat subscriptions provide software entitlements. The actual content is delivered through the Red
Hat Content Delivery Network (CDN) or through RedHat Satellite 6.

Note: In the following sections, CDN is used to denote content imported from either Red Hat CDN
or Satellite 6. When there are specifics to the online portal, Red Hat CDN will be used to denote
the difference.

RHSM uses the following X.509 certificates for managing subscriptions:

l Identity certificate - Issued to a system upon registration with the subscriptionmanagement
service. This certificate is used to authenticate and identify the system to the subscription
management service.

l Product certificate - Generated and installed on a system once a product is installed. This
certificate contains information about the specific system that the product is installed on (such as its
hardware and architecture) and the product name, version, and namespace.

l Entitlement certificate - Contains a list of subscriptions for a system, including information about
the products and quantities, content repositories, roles, and different namespaces.
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To be able to connect to Red Hat CDN or Satellite 6 and download content, redhat_import requires an
entitlement certificate from RHSM. This must be available on the SA Core where redhat_import is run.
redhat_import does not use the identity and product certificates.

The entitlement certificate must be generated on the Red Hat Customer Portal or on the Satellite 6 if
you want to import content from the Satellite. The next step is to download the certificate and place it
on the SA Core.

To generate an entitlement certificate, perform the following steps:

1. Register a system (unit):
l For Red Hat Customer Portal, the easiest way to achieve this is to register an offline system
by providing the system details on the Red Hat Customer Portal. However, if you already have
a suitable system that is registered on the Red Hat Customer Portal, you can reuse it.

l For Red Hat Satellite 6, there is no official way of registering offline systems. To proceed to the
next step, you need to have a suitable system that can be registered to the Satellite server
using the subscription_management tool provided by Red Hat.

2. Attach a subscription to the registered system.
l The attached subscription is required to cover the Red Hat product(s) that you need to
download using redhat_import. For example, if you need to download content for RHEL 7,
x86_64, the subscription needs to cover Red Hat Enterprise Linux product.

l For the Red Hat Customer Portal, the entitlement certificate is available on the portal.

l For Satellite 6, the default path for entitlement certificate is /etc/pki/entitlement. This is
available on the system registered with the Satellite server. Usually you will find two .pem files
(a public and a private key). You should concatenate these two files into a single .pem file. This
will be the entitlement certificate that must be downloaded to the SA Core.

Multiple entitlement certificates

redhat_import supports multiple entitlement certificates. If you need to import content that is not
covered by any of the existing entitlement certificates, you can generate a new entitlement
certificate, covering the required CDN content and add it to the redhat_import configuration file.
No entitlement certificate is required for rhn_import binary or when redhat_import binary is only
used to download content from RHN.

Note: As a best practice, do not mix entitlements for Red Hat Customer Portal with
entitlements for Red Hat Satellite 6.

Install Red Hat CA certificates
SA RedHat importer validates the server certificates for Red Hat Network Classic (RHN), Red Hat
SubscriptionManagement (RHSM) and RedHat Satellite. By default SA comes bundled with CA
certificates only for RHN. Out of the three content providers only Red Hat Network Classic is signed
by a certificate authority trusted by both SA and RedHat.

RHSM andRedHat Satellite servers have self signed certificates so by default there is no CA
certificate bundled for these two content providers with SA rhn_import component. To enable access
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to Red Hat SubscriptionManagement and/or Red Hat Satellite you need to install the self signed server
certificate in the openssl trust store.

Depending on your use cases you only need to install the RHSM server certificate if you are using the
new RedHat SubscriptionManagement content provider, or the satellite server certificate in case you
have a RedHat Satellite and want to import from it. Otherwise, if you only use RHN as a provider you
can safely skip this section.

The process of installing a certificate in the trust store is split in three steps:

1. Download the self signed certificate from RHSM/Red Hat Satellite
2. Install the self signed certificate in SA trust store
3. Verify that openssl is validating the server certificate
The first step is different on RHSM andRedHat Satellite server while the last two steps are the same
for both content providers.

Downloading the self-signed certificate

Download RHSM self-signed certificate

The RSHM server certificate is not signed by a public certificate authority. You have to use the openssl
tool to download the certificate chain for cdn.redhat.com. After download, extract the last certificate
issued by Entitlement Master CA and copy it into a .pem file:

A command example to download the certificate chain for RHSM:

/opt/opsware/bin/openssl s_client -connect cdn.redhat.com:443 -prexit -showcerts

Note: The latest released version of openssl (i.e openssl-1.0.2h) does not work with HTTP
proxies. The easiest option is to use a web browser to download the certificate.

Download Red Hat Satellite self-signed certificate

The self signed certificate is made public by Red Hat Satellite server at /pub/RHN-ORG-TRUSTED-SSL-
CERT. Run the following command to download the certificate file:

wget -O /tmp/RHN-ORG-TRUSTED-SSL-CERT http://redhat.satellite.hostname/pub/RHN-ORG-
TRUSTED-SSL-CERT

If you need proxy access to the Red Hat Satellite server, you can export the http_proxy environment
variable and wget will use the value exported.

Installing the self-signed certificate in SA trust store

At the end of the downloaded certificate, a block similar to the following appears:

-----BEGIN CERTIFICATE-----
MIIE4TCCA8mgAwIBAgIJANwa5OFPkBHHMA0GCSqGSIb3DQEBCwUAMIGGMQswCQYD
haXhmbq+5pEkpxGAactW+tORsJmpgTdAXeq2rreYtgZ2/vCwdM0iwSVakGNFAvni
T9lnSVrADcO/S8V/DzcH30RzSpIS44beE23zag82019fCrsZg9VkYJER4Fn0tRq4
6U9I4OgBSPSU34MXclGld0BAN+mANWHQYacZ7hHQJtMRP+mc8ZgHIvsKNnKRoHOd
Rhla7cP7GYrXn/piQAxRW66fOYJOeVIsAWJvgUb+A8ecwb+s6k56cQdLKkm0wKD0 2zUFMAg= -----END
CERTIFICATE-----
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Append the block to the end of /opt/opsware/openssl/cert.pem. At this point, the certificate is
installed in the SA trust store. Ensure that openssl tool can verify the RHSM and/or Red Hat Satellite
server certificate.

Verifying that openssl is validating the server certificate

After the CA certificate is installed in SA trust store, youmust verify if the SA-bundled openssl
validates the installed certificates before running the importer. To do so, run the following command:

/opt/opsware/bin/openssl s_client -connect rhsm.or.satellite.hostname:443 -verify 3

If the verification succeeds at the end of the output, the followingmessage appears:

Verify return code: 0 (ok)

In case of an error, a return code different than 0 appears, for example:

Verify return code: 21 (unable to verify the first certificate)

Note: Since openssl cannot work behind a proxy, the above commandmight not work if there is an
HTTP proxy in your local network.

Content labels
When importing from RHSM, redhat_import uses content labels to identify the CDN content to import.
The format of the content label is the following:

<entitlement_content_label>{<releasever>-<basearch>}

where:

l <entitlement_content_label> is the content label as specified in the entitlement certificate
l <releasever> is the release version of Red Hat Enterprise Linux. This has the same value as the
$releasever yum variable

l <basearch> is the base architecture of the system. This has the same value as the $basearch yum
variable

<releasever> is not required for all contents; when it is not used, the format of the content label
becomes <entitlement_content_label>{<basearch>}

To determine the label of the CDN content to import, the following steps can be performed:

l If the content to import belongs to one of the SA-supported platforms then the content label to use
can be found by running:
redhat_import --show_labels

l If the content to import belongs to any other Red Hat product that is not listed by --show_labels,
the content label to use can be determined as follows:
l Locate the content section for the product in the entitlement certificate. The content of the
entitlement certificate can be visualized using the rct tool. For more details on the rct tool, see
https://access.redhat.com/documentation/en-US/Red_Hat_Subscription_
Management/1/html/RHSM/rct-tool.html

l Extract the content label from the entitlement certificate and construct the redhat_import content
label by appending the <releasever> and <basearch> between curly braces.
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For example, to import content for RHEL Server 6.4 from RedHat Extended Update Support, the
content in the example below needs to be located in the entitlement certificate.

Content for RHEL Server 6.4 from Red Hat extended update support

Content:

Type: yum
Name: Red Hat Enterprise Linux 6 Server - Extended Update Support (RPMs)
Label: rhel-6-server-eus-rpms
Vendor: Red Hat
URL: /content/eus/rhel/server/6/$releasever/$basearch/os
GPG: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
Enabled: True
Expires: 86400
Required Tags: rhel-6-server
Arches: x86_64, x86

The entitlement content label is “rhel-6-server-eus-rpms”. To import version 6.4 for x86_64, the content
label needs to be specified as:

rhel-6-server-eus-rpms{6.4-x86_64}

As another example, to import content from RHEL 7 Server Extras repository, the content in the
example below needs to be located in the entitlement certificate.

Content for RHEL 7 Server Extras Repository

Content:
Type: yum
Name: Red Hat Enterprise Linux 7 Server - Extras (RPMs)
Label: rhel-7-server-extras-rpms
Vendor: Red Hat
URL: /content/dist/rhel/server/7/7Server/$basearch/extras/os
GPG: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
Enabled: False
Expires: 86400
Required Tags: rhel-7-server
Arches: x86_64

The entitlement content label is “rhel-7-server-extras-rpms”. In this case, the content URL does not
contain the <releasever> variable so this should not be included in the redhat_import content label.
To import the packages for x86_64 architecture, the content label needs to be specified as:

rhel-7-server-extras-rpms{x86_64}

Sample use cases

Import only from RHN

To import content only from RHN, the [RHSM] section should not be present in the configuration file.

Sample RHN configuration file

# main section
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[main]

package_search_path=
/Package Repository/OS Media/$opsware_platform
/Package Repository/All Red Hat Linux/$opsware_platform
/Migrated/Package Repository/Customer Independent/$opsware_platform

# RHN section. Contains options specific to import from RHN that apply to all
channel labels
[RHN]

# Required options to login to Red Hat Network
rhn_user=USERNAME
rhn_pass=PASSWORD

channels: rhel-x86_64-server-5 rhel-x86_64-server-6

# SA recommendations:
package_path=/RHN/Packages/$channel_name
channel_path=/RHN/Channels/$parent_channel_name/$channel_name Policy
erratum_path=/RHN/Errata/$erratum_type Policies/$erratum_name
errata_path =/RHN/Errata/$parent_channel_name/$channel_name Advisory Roll-Up Policy

Provided that this configuration file is available at the default location (/etc/opt/opsware/rhn_
import/redhat_import.conf), redhat_import can be run without any command line options to
import content for the channels with the following labels as specified by the “channels” option in the
above sample configuration file.

l rhel-x86_64-server-5

l rhel-x86_64-server-6

Import only from RHSM

To import content only from RHSM, the [RHN] section should not be present in the configuration file.

Sample RHSM configuration file

# main section
[main]

package_search_path=
/Package Repository/OS Media/$opsware_platform
/Package Repository/All Red Hat Linux/$opsware_platform
/Migrated/Package Repository/Customer Independent/$opsware_platform

# RHSM section. Contains options specific to import from CDN that apply to all
content labels
[RHSM]
# To sync from Red Hat Network Satellite 6.1 or later:
; satellite_host=HOSTNAME
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# Specify one or more paths to entitlement certificates. To specify multiple paths,
# place each path on its own line, indenting any additional lines.
certificate_paths=/etc/opt/opsware/rhn_import/8a85f981478d1fa601478e12507f36e8.pem

content_labels=rhel-7-server-rpms{7Server-x86_64} rhel-6-server-rpms{6Server-x86_
64}

# SA recommendations:
package_path=/RHSM/Packages/$content_name
content_policy_path=/RHSM/Content/$content_name Policy
erratum_policy_path=/RHSM/Errata/$erratum_type Policies/$erratum_name
errata_policy_path =/RHSM/Errata/$content_name Advisory Roll-Up Policy

Provided that this configuration file is available at the default location, (/etc/opt/opsware/rhn_
import/redhat_import.conf), redhat_import can be run without any command line options to
import the CDN contents with the following labels:

l rhel-7-server-rpms{7Server-x86_64}

l rhel-6-server-rpms{6Server-x86_64}

RHSM options

The following table describes the options presented in the sample RHSM configuration file:

Option Description

satellite_
host

This option defines whether or not to import from Satellite 6. When this option is
enabled and a valid hostname is provided, the importer will connect to the Satellite 6
and import from there. If this option is not enabled, then the importer will connect to
Red Hat CDN for content import.

certificate_
paths

This option defines the path to the entitlement certificate. The certificate must
provide entitlement to content you wish to download. You can download the
certificate from the Red Hat Customer Portal after a subscription is attached to a
system that is registered with Red Hat Customer Portal. For more information
about the subscription and entitlement certification process, see Entitlement
Certificates.

content_
labels

This option defines the labels of the CDN contents that need to be imported into the
SA Library. See "Content labels" on page 248 for more details on the format of the
content labels.

Importing from both RHN and RHSM

[main]

package_search_path=
/Package Repository/OS Media/$opsware_platform
/Package Repository/All Red Hat Linux/$opsware_platform
/Migrated/Package Repository/Customer Independent/$opsware_platform
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# RHN section. Contains options specific to import from RHN that apply to all
channel labels
[RHN]
rhn_user=USERNAME
rhn_pass=PASSWORD

channels: rhel-x86_64-server-6

# SA recommendations:
package_path=/RHN/Packages/$channel_name
channel_path=/RHN/Channels/$parent_channel_name/$channel_name Policy
erratum_path=/RHN/Errata/$erratum_type Policies/$erratum_name
errata_path =/RHN/Errata/$parent_channel_name/$channel_name Advisory Roll-Up Policy

[rhel-x86_64-server-extras-6]
enabled=1
; platform = Red Hat Enterprise Linux Server 6 X86_64
# RHSM section. Contains options specific to import from CDN that apply to all
content labels
[RHSM]
# To sync from Red Hat Network Satellite 6.1 or later:
; satellite_host=HOSTNAME

# Specify one or more paths to entitlement certificates. To specify multiple paths,
# place each path on its own line, indenting any additional lines.
certificate_paths=/etc/opt/opsware/rhn_import/8a85f981478d1fa601478e12507f36e8.pem

content_labels=rhel-7-server-rpms{7Server-x86_64}

# SA recommendations:
package_path=/RHSM/Packages/$content_name
content_policy_path=/RHSM/Content/$content_name Policy
erratum_policy_path=/RHSM/Errata/$erratum_type Policies/$erratum_name
errata_policy_path =/RHSM/Errata/$content_name Advisory Roll-Up Policy

[rhel-7-server-extras-rpms{x86_64}]
enabled=1
platform=Red Hat Enterprise Linux Server 7 X86_64

Provided that this configuration file is available at the default location (/etc/opt/opsware/rhn_
import/redhat_import.conf), redhat_import can be run without any command line options to
import content for the following RHN channels and RHSM contents:

RHN:

l rhel-x86_64-server-6

l rhel-x86_64-server-extras-6

RHSM:
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l rhel-7-server-rpms{7Server-x86_64}

l rhel-7-server-extras-rpms{x86_64}

l RHN channels have a parent-child relationship. In this example “rhel-x86_64-server-
extras-6” is a child of “rhel-x86_64-server-6”. By default, child channels are imported under
the platform of the parent channel in the SA Library. This is why the “platform” option is
commented out under “rhel-x86_64-server-extras-6” section and the import still works fine.

l CDN contents do not have any parent-child relationship. As a result of this any content that is
not mapped by default to one of the SA-supported platforms needs to have its own content
section and define the “platform” option. This is the case for “rhel-7-server-extras-rpms
{x86_64}” above. Failure to define the “platform” option for such contents will result in the
content label being ignored during import with a warningmessage being displayed, similar to the
following:

Unable to process content label rhel-7-server-extras-rpms{x86_64}. No
platform could be associated with this label. This content label will be
dropped. If you need to import this content, add the 'platform' option to the
configuration file.
Ignoring unknown content label rhel-7-server-extras-rpms{x86_64}

Migration
Users of the old rhn_import binary are encouraged tomigrate to the new redhat_import binary. Multiple
migration paths are available as described in the following sections.

Continue usage of RHN

Users canmigrate from rhn_import to redhat_import and continue to use RHN to import content. In
this case the only requirement is to migrate the configuration file from the old format to the new format.
For more details on the redhat_import configuration file format see redhat_import configuration
file.

Once the configuration is migrated to the new format, while preserving the existing SA Library paths,
redhat_importwill update the existing packages and software policies, making themigration
transparent. Moreover, new products that have not been imported in the SA Library can be imported
from RHSMwhile the old products continue to be imported from RHN. For example, a user who is
already importing RHEL 5 and 6 content from RHN can start importing RHEL 7 content from RHSM
while still using RHN for the older RHEL 5 and 6. For a sample configuration that allows import from
both RHN and RHSM see Import from both RHN and RHSM.

Partial migration to RHSM

This section only applies to users who are using the SA-recommended library paths. Users using
custom SA Library paths should derive their ownmigration procedure based on the instructions in this
section. The SA-recommended library paths are as follows:
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l RHN
l package_path=/RHN/Packages/$channel_name

l channel_path=/RHN/Channels/$parent_channel_name/$channel_name Policy

l erratum_path=/RHN/Errata/$erratum_type Policies/$erratum_name

l errata_path =/RHN/Errata/$parent_channel_name/$channel_name Advisory Roll-Up
Policy

l RHSM
l package_path=/RHSM/Packages/$content_name

l content_policy_path=/RHSM/Content/$content_name Policy

l erratum_policy_path=/RHSM/Errata/$erratum_type Policies/$erratum_name

l errata_policy_path =/RHSM/Errata/$content_name Advisory Roll-Up Policy

This section describes the scenario where a user is currently using RHN to import some channels and
would like to start using RHSM to import a subset of these channels while still using RHN for the other
channels.

To achieve partial migration to RHSM, perform the following steps:

1. Migrate from rhn_import to redhat_import and convert the configuration file to the new format
2. In the SA Library, move the channel policies of the channels that need to bemigrated to the RHSM

content_policy_path folder (/RHSM/Content). Rename these channel policies to content policies
“$content_name Policy”. The value of the “$content_name” variable can be found in the
entitlement certificate or by using --show_labels for CDN contents mapped to SA-supported
platforms. This ensures that redhat_import will update these content policies instead of creating
new ones.

3. Move the errata policies of the channels that need to bemigrated to the RHSM errata_policy_
path folder (/RHSM/Errata). Rename these errata policies to be compliant with RHSM format
“$content_name Advisory Roll-Up Policy.” The value of the “$content_name” variable can be
found in the entitlement certificate or by using --show_labels for CDN contents mapped to SA-
supported platforms. This ensures that redhat_importwill update these errata policies instead of
creating new ones.

4. Move the package folders of the channels that need to bemigrated to the RHSM package_path
folder (/RHSM/Packages). Rename these package folders to be compliant with RHSM format
“$content_name”. The value of the “$content_name” variable can be found in the entitlement
certificate or by using --show_labels for CDN contents mapped to SA-supported platforms. This
ensures that redhat_importwill import packages into these folders instead of creating new
folders.

5. Ensure that redhat_importwill use the same erratum library path for both RHN and RHSM. An
erratum can be available in multiple RHN channels. When using the SA-recommended library
paths a single erratum policy is created even for an erratum available in multiple channels and this
policy is updated with content from all channels. As not all channels aremigrated to RHSM the
erratum policies cannot bemoved to the RHSM folders. Instead, the RHSM “erratum_policy_
path” is updated to point to the path used by RHN (/RHN/Errata/$erratum_type
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Policies/$erratum_name). The “erratum_policy_path” should be updated as described above
only for the contents migrated from RHN, so for each such content a new content section needs to
be defined in the configuration file and define the “erratum_policy_path” option as
“/RHN/Errata/$erratum_type Policies/$erratum_name”.

6. Finally, the configuration file should be updated to ensure that themigrated channels are no longer
imported from RHN and that the new CDN contents are imported from RHSM (e.g. by updating
the “content_labels” option).

Tip: Review your repo.restrict. custom attributes. If any of them refer to package folders that
weremoved and renamed, you need to edit the attributes tomake them refer to the new package
folder locations.

Sample scenario: partial migration to RHSM

As an example, consider the case where the following channels are imported from RHN:

Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)

Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64)

The SA Library structure concerning RHN and RHSM import would initially look as shown below

Example: SA Library structure for RHN and RHSM import—before partial migration

- RHN
| - Channels
| | Red Hat Enterprise Linux (v. 5 for 64-bit x86_64) Policy
| | Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64) Policy
| - Errata
| | + Bug Fix Advisory Policies
| | + Product Enhancement Advisory Policies
| | + Security Advisory Policies
| | Red Hat Enterprise Linux (v. 5 for 64-bit x86_64) Advisory Roll-Up Policy
| | Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64) Advisory Roll-Up
Policy
| - Packages
| | + Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)
| | + Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64)
- RHSM
| - Content
| - Errata
| - Packages

If Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64) needs to bemigrated to RHSMwhile Red
Hat Enterprise Linux (v. 5 for 64-bit x86_64) continues to be imported from RHN, the partial migration
steps would be as follows.

Steps for sample scenario—Partial migration to RHSM:

1. Migrate the existing configuration file to the new format required by redhat_import. For details on
the redhat_import configuration file format see redhat_import configuration file. The precise
details on how tomigrate the configuration file depend on the actual content of the existing
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configuration file. However the resultedmigrated configuration is expected to allow redhat_
import to import the sameRHN channels into the SA Library. In other words, running rredhat_
importwith themigrated configuration file should yield the same result as running rhn_import with
the old configuration file.

2. Move RedHat Enterprise Linux Server (v. 6 for 64-bit x86_64) Policy policy to /RHSM/Content
folder. Rename the policy to Red Hat Enterprise Linux 6 Server (RPMs) (6Server-x86_64) Policy.

3. Move RedHat Enterprise Linux Server (v. 6 for 64-bit x86_64) Advisory Roll-Up Policy policy to
/RHSM/Errata folder. Rename the policy to Red Hat Enterprise Linux 6 Server (RPMs) (6Server-
x86_64) Advisory Roll-Up Policy.

4. Move the package folder “Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64)” to
“/RHSM/Packages folder. Rename the package folder to “Red Hat Enterprise Linux 6 Server
(RPMs) (6Server-x86_64)”.

5. Create a new content section in the configuration file: [rhel-6-server-rpms{6Server-x86_64}].
Define the erratum_policy_path as follows under the above section: erratum_policy_
path=/RHN/Errata/$erratum_type Policies/$erratum_name

6. Update the configuration file to ensure that RHN channel “rhel-x86_64-server-6” is no longer
imported from RHN and the equivalent CDN content “rhel-6-server-rpms{6Server-x86_64} is
imported from RHSM.

Following this, the SA Library folders concerning RHN and RHSM import should look as shown below.

Example: SA Library folders for RHN and RHSM import—after partial migration

- RHN
| - Channels
| | Red Hat Enterprise Linux (v. 5 for 64-bit x86_64) Policy
| - Errata
| | + Bug Fix Advisory Policies
| | + Product Enhancement Advisory Policies
| | + Security Advisory Policies
| | Red Hat Enterprise Linux (v. 5 for 64-bit x86_64) Advisory Roll-Up Policy
| - Packages
| | + Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)
- RHSM
| - Content
| | Red Hat Enterprise Linux 6 Server (RPMs) (6Server-x86_64) Policy
| - Errata
| | Red Hat Enterprise Linux 6 Server (RPMs) (6Server-x86_64) Advisory Roll-Up
Policy
| - Packages
| | + Red Hat Enterprise Linux 6 Server (RPMs) (6Server-x86_64)

Full migration to RHSM

This section only applies to users who are using the SA-recommended library paths. Users using
custom SA Library paths should derive their ownmigration procedure based on the instructions in this
section. Also this section only applies if there are no errata imported from RHSM for any CDN content.
If errata are already imported from RHSM under the SA-recommended library path (/RHSM/Errata) and
you would like tomigrate some or all RHN channels to RHSM please use the instructions in Partial
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migration to RHSM. This is becausemoving erratum policies from RHN folder structure to RHSM
might conflict with existing erratum policies under the RHSM folder structure.

For a list of SA-recommended library paths, see "Partial migration to RHSM" on page 253.

This section describes the scenario where a user is currently using RHN to import some channels and
would like to start using RHSM to import all of these channels. Basically, after migration, no channels
will be imported from RHN. Tomigrate only someRHN channels to RHSM, see "Partial migration to
RHSM" on page 253.

To achieve full migration to RHSM, perform the following steps:

1. In the SA Library, move the channel policies of the channels that need to bemigrated to the RHSM
content_policy_path folder (/RHSM/Content). Rename these channel policies to content policies
“$content_name Policy”. The value of the “$content_name” variable can be found in the
entitlement certificate or by using --show_labels for CDN contents mapped to SA-supported
platforms. This ensures that redhat_import will update these content policies instead of creating
new ones.

2. Move the errata policies of the channels that need to bemigrated to the RHSM errata_policy_
path”folder (/RHSM/Errata). Rename these errata policies to be compliant with RHSM format
“$content_name Advisory Roll-Up Policy”. The value of the “$content_name” variable can be
found in the entitlement certificate or by using --show_labels for CDN contents mapped to SA-
supported platforms. This ensures that redhat_importwill update these errata policies instead of
creating new ones.

3. Move the package folders of the channels that need to bemigrated to the RHSM package_path
folder (/RHSM/Packages). Rename these package folders to be compliant with RHSM format
“$content_name”. The value of the “$content_name” variable can be found in the entitlement
certificate or by using --show_labels for CDN contents mapped to SA-supported platforms. This
ensures that redhat_importwill import packages into these folders instead of creating new
folders.

4. Move the erratum policies folders (“Bug Fix Advisory Policies”, “Product Enhancement
Advisory Policies”, “Security Advisory Policies”) to the RHSM “erratum_policy_path”
(/RHSM/Errata).

5. Migrate from rhn_import to redhat_import and convert the configuration file to the new format.
During themigration process ensure that no channels are imported from RHN and that the new
CDN contents are imported from RHSM (e.g. by updating the “content_labels” option). The
[RHN] section should not be present in the redhat_import configuration file.

Tip: Review your repo.restrict. custom attributes. If any of them refer to package folders that
weremoved and renamed, you need to edit the attributes tomake them refer to the new package
folder locations.

Sample scenario: full migration to RHSM

As an example, consider the case where the following channels are imported from RHN:

l Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)

l Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64)

The SA Library structure concerning RHN and RHSM import would initially look as shown below

Example: SA Library folders for RHN and RHSM import—before full migration

- RHN
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| - Channels
| | Red Hat Enterprise Linux (v. 5 for 64-bit x86_64) Policy
| | Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64) Policy
| - Errata
| | + Bug Fix Advisory Policies
| | + Product Enhancement Advisory Policies
| | + Security Advisory Policies
| | Red Hat Enterprise Linux (v. 5 for 64-bit x86_64) Advisory Roll-Up Policy
| | Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64) Advisory Roll-Up
Policy
| - Packages
| | + Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)
| | + Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64)
- RHSM
| - Content
| - Errata
| - Packages

If both “Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64)” and “Red Hat
Enterprise Linux (v. 5 for 64-bit x86_64)” channels need to bemigrated to RHSM, the full
migration steps would be as follows:

Steps for Sample Scenario—pull migration to RHSM:

1. Move the following software policies to /RHSM/Content folder:
l Red Hat Enterprise Linux (v. 5 for 64-bit x86_64) Policy

l Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64) Policy
Rename the policies to:
o Red Hat Enterprise Linux 5 Server (RPMs) (5Server-x86_64) Policy
o Red Hat Enterprise Linux 6 Server (RPMs) (6Server-x86_64) Policy

2. Move the following software policies to “/RHSM/Errata” folder:
l Red Hat Enterprise Linux (v. 5 for 64-bit x86_64) Advisory Roll-Up Policy

l Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64) Advisory Roll-Up
Policy

Rename the policies to:
o Red Hat Enterprise Linux 5 Server (RPMs) (5Server-x86_64) Advisory Roll-Up

Policy
o Red Hat Enterprise Linux 6 Server (RPMs) (6Server-x86_64) Advisory Roll-Up

Policy

3. Move the following package folders to /RHSM/Packages folder:
l Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)

l Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64)
Rename the folders to:
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o Red Hat Enterprise Linux 5 Server (RPMs) (5Server-x86_64)
o Red Hat Enterprise Linux 6 Server (RPMs) (6Server-x86_64)

4. Move the erratum policies folders (Bug Fix Advisory Policies, Product Enhancement
Advisory Policies, Security Advisory Policies) to /RHSM/Errata.

5. Migrate the configuration file and ensure that the CDN contents “rhel-5-server-rpms{5Server-
x86_64}” and “rhel-6-server-rpms{6Server-x86_64}” are imported from RHSM. There should
be no [RHN] section in the redhat_import configuration file as no channels are imported from
RHN.

After the above steps are completed, the SA Library folders concerning RHN and RHSM import should
look as shown in below.

Example: SA Library folders for RHN and RHSM import—after full migration

- RHN
| - Channels
| - Errata
| - Packages
- RHSM
| - Content
| | Red Hat Enterprise Linux 5 Server (RPMs) (5Server-x86_64) Policy
| | Red Hat Enterprise Linux 6 Server (RPMs) (6Server-x86_64) Policy
| - Errata
| | + Bug Fix Advisory Policies
| | + Product Enhancement Advisory Policies
| | + Security Advisory Policies
| | Red Hat Enterprise Linux 5 Server (RPMs) (5Server-x86_64) Advisory Roll-Up
Policy
| | Red Hat Enterprise Linux 6 Server (RPMs) (6Server-x86_64) Advisory Roll-Up
Policy
| - Packages
| | + Red Hat Enterprise Linux 5 Server (RPMs) (5Server-x86_64)
| | + Red Hat Enterprise Linux 6 Server (RPMs) (6Server-x86_64)

Supported RHEL versions
When importing from RHSM, redhat_import supports the RHEL versions that can bemanaged by
Red Hat SubscriptionManagement: 5.7+, 6.1+, and 7+.

When importing from RHN, redhat_import supports the same channels as the old rhn_import
binary.

Reuse a Red Hat import configuration file
You can reuse an rhn_import.conf file that contains encrypted passwords on another core, however
youmust clear all the encrypted passwords before copying the file and reuse the --hide_passwords
option on the new core.
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The sequence of the steps matters. It is important that you change the encrypted passwords into clear
text and use the --hide_passwords option. If you attempt to reuse an rhn_import.conf file with
encrypted passwords on another core without performing these steps, an error (500 Internal Server) will
occur.

To reuse an rhn_import.conf file containing encrypted passwords on another core:

1. Change all encrypted passwords in the file into clear text.
2. Copy the rhn_import.conf file to the other core.
3. Reuse the –hide_passwords option when running the RHN import on the new core.

View errata based and channel based policies in the SA Client
The rhn_import program allows you to create errata-based, erratum-based, and channel-based
policies in the SA Client. After successfully running the program, you can view the properties of errata-
based, erratum-based, and channel-based policies in the SA Client. You can view properties such as
the SA user who created the software policy, the date when it was created, the name, the description,
the availability, the location of the policy in the Library, the operating systems applicable to the policy
and the SA Client ID of the software policy. HP recommends that you do not edit the policies created
by the rhn_import program.

To view the properties of a software policy:

1. From the navigation pane, select Library > By Folder.
2. Select the Red Hat Network Folder (RHN).
3. From the content pane, select the errata-based or channel-based policy and open it. The policy

window appears.
4. From the Views pane, select Properties. You can view the properties for the policy in the content

pane.
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l Name: Contains the errata reference for the errata based software policy.

l Description: Includes all the errata documentation for the errata.

l Location: Specifies the location of the policy in the folder hierarchy. To change the location
click select to specify the location for the policy in the folder hierarchy. The Select Location
window appears. Select a folder in the Library to specify the location of the policy and then click
Select.

l Created: Corresponds to the time when the errata was downloaded by SA to create the
software policy.

l Last Modified: Corresponds to the time when the errata based policy was modified.

l Availability: Contains the SA server life cycle values for the errata based software policy. The
default value for an errata based policy is set to Available.

l Platform: Specifies the operating systems applicable to the errata. You can expand the list to
see the selected platforms.

5. To save the changes, select Save from the File menu.
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Errata caching

When importing errata, SA RedHat Import tool keeps track of the imported errata. Details of each
imported erratum are stored in a cache file and subsequent runs will skip the cached errata completely.
This improves performance as it avoids some calls to Red Hat and to SA Library. In the absence of the
cached data these calls are beingmade even for errata that has not beenmodified and is up to date in
the SA Library. Errata that has beenmodified by Red Hat is updated anyway so there is no danger of
having outdated errata after import.

A cache file is created for each imported Red Hat Network channel / Red Hat Subscription
Management content.

The cache files are kept in the following folder on the SA core server:

/var/opt/opsware/rhn_import

The file name uses the following pattern:

prev_import_ch_<label>.dat

where <label> is the Red Hat Network channel label or the Red Hat SubscriptionManagement
content label. Some example file names are presented below:

l prev_import_ch_rhel-x86_64-server-6.dat
l prev_import_ch_rhel-7-server-rpms{7Server-x86_64}.dat
As a result of the cachingmechanism described above the following scenarios are possible:

l An erratum is imported into SA Library and then it is removed / renamed / moved to another folder.
When rhn_import or redhat_import are run next time, the erratum will not be reimported into the
SA Library. This is because the erratum details are present in the cache file so it is skipped during
the import.

l The errata roll-up policy is created and then it is removed, renamed, or moved to another folder (for
example, by using the SA Client). When rhn_import or redhat_import are run next time the errata
roll-up policy will be recreated but it will contain only the errata that has been previously published by
Red Hat.

Manage Red Hat patches
The second phase of the Red Hat Patchingmechanism – although optional, sometimes can be very
important in the patching process. Since Red Hat patches are just normal RPM packages you can do
all the operations that SA Client allows you to do on RedHat packages:

l Open the package
l Viewing and editing package properties
l Viewing package contents
l Viewing all software policies associated with a package
l Deleting a package
l Renaming a package
l Locating packages in Folders
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Restricting access to RPM folders
SA builds a custom RPM repository for use by both Red Hat Patchingmechanism and the software
management jobs. This is built on a server-by-server basis, taking into account several packages and
server properties and user-defined settings.

The repository that SA downloads to amanaged server before actually scanning the server for
recommended patches is built as follows:

l Packages whose platform set does not include the server platform are excluded from the RPM
repository.

l Packages in folders whose customer constraints do not include the customer of the server are
excluded from the RPM repository.

l If one or more repo.restrict custom attributes are defined for a particular server, only packages in the
folders specified by these custom attributes are included in the RPM repository.

In SA, you can specify in a custom attribute the folders in the SA Library that the server has access to.
All other folders will be inaccessible to the server. This gives you folder-level control over which
versions of RPMs can be applied to a given server, allowing you to precisely manage platform update
versions, for example Red Hat Linux Server 6 Update 4 versus Update 5.

Note: This is not intended as a user-level access control mechanism, but rather to restrict the
library and folder view of amanaged server from access to the full set of RPMs in the SA Library.

Scan managed servers for recommended patches
Before actually remediating the patches to a Red Hat managed server, SA needs to know what
patches are applicable to a Red Hat server. Not all errata issued by Red Hat is applicable to amanaged
server. This depends on what packages are installed and at what level of patching is the server. The job
of Red Hat patch scanning is to report RPM units that are recommended for amanaged server. After
the scanning runs and recommended RPM units are found, the remediation can occur. The scanner
responsible for determining the recommended patches uses the RPM repositories generated after
importing the patches. If there is a repo.restrict custom attribute (please read the previous section –
Managing Red Hat patches) then the RPM repository metadata downloaded to themanaged server will
reflect the value of the custom attribute.

The RedHat patch scanner is implemented using dynamic handlers, meaning that the actual software
implementing the scan resides on the core and is passed to themanaged server during scan. The
scanner downloads the RPM repository from core locally on themanaged server and then it uses the
native tools to run a scan on themachine. The scan results are sent up to the core and then can be
used for remediation. The native tool used for Red Hat is yum.

Note: For the scanner to work, you will require Yum version 2.4.3 or later.
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Running patch scanning onmanaged servers periodically
RedHat patch scanning runs on a periodic basis on themanaged server, that is each time software
registration is performed. But in order to get some recommended patches youmust first perform patch
import.

Besides depending on the patch scanning that runs periodically with the software registration you can
force the scanner to run either from HSA Client or directly from themanaged server.

Running patch scanning manually fromSA Client
From the SA Client you can perform a patch scan on amanaged server in two ways:

l Run a Software Compliance Check
l Run a Patch Compliance check
The first method is simpler, in the sense that you don’t have any prerequisite to run the scanning (apart
from the patches that need to be imported in SA Library in order to get some recommended patches).
The secondmethods implies that the Red Hat managed servers on which the patch compliance is run
must have a Dynamic Patch Policy attached, otherwise the scanner will not be executed on the
managed servers. More about Dynamic Patch Policies can be found in the next section: Remediate
Red Hat Patches.

To run a Software Compliance check that starts the scanning process on a list of managed servers:

1. From the navigation pane, select Devices > Servers >All Managed Servers.
2. Select one or more Red Hat Servers.
3. From the context menu, right click and select Scan.
4. From the new menu list, select Software Compliance.
To run a Patch Compliance check, first make sure that eachmanaged server that you want to scan has
a Dynamic Patch Policy attached, followed by these steps:

1. From the navigation pane, select Devices > Servers >All Managed Servers.
2. Select one or more Red Hat Servers.
3. Right click. From the context menu select Scan.
4. From the new menu list, select Patch Compliance.

Run patch scanning manually on themanaged server
The user can explicitly invoke a scan on themanaged server by running the following command:

/opt/opsware/agent/pylibs/cog/bs_software [--full]

Viewing the recommended patches
The result of scanning produces a list of patches that are applicable to amanaged server. In Red Hat
Patching terminology we call these recommended patches.
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You can view the recommended patches applicable to amanaged server from the SA Client. There are
two ways to do this. You can either:

1. From the navigation pane, select Devices > Servers >All Managed Servers.
2. Select a Red Hat managed server
3. From theView combo box, select Patches.

The second option involves opening the Server Browser:

1. From the navigation pane, select Devices > Servers >All Managed Servers.
2. Open a RedHat managed server.
3. In the new window, select Inventory tab.
4. In the navigation pane, select Patches. A window much like the one depicted above should be

rendered.

Policymanagement
Patches recommended in the scanning phase can be remediated on themanaged server. A typical
software remediation job involves a software policy with some policy items to be remediated. In the
case of Red Hat Patch remediation, a Dynamic Patch Policy is involved.

A Red Hat Dynamic Patch Policy is very similar with a normal (static) policy. It contains the same
properties like name, description, platforms associated, can be attached tomultiple managed servers
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and it allows the samemanagement operations that software policies and static patch policies allow.
The difference comes from the fact that Red Hat Dynamic Patch Policies do not allow editing policy
items. Upon remediation of a dynamic patch policy, the process will populate the policy items at
runtime with patches.

Creating a Red Hat dynamic patch policy
To create a dynamic patch policy for a Red Hat managed servers:

1. In the navigation pane, select Library > By Type > Patch Policies.
2. Select a specific Red Hat operating system
3. Select Actions or right click in the patch policies pane.
4. Select New Dynamic Policy.
5. Provide a name and description to the policy. Save and close.

Attaching a dynamic patch policy to a Red Hatmanaged server
After a dynamic patch policy is created, the policy must be attached and then the remediation can
occur. To attach a dynamic patch policy:

1. In the navigation pane, select Library > By Type > Patch Policies.
2. Select a specific Red Hat operating system, and view the list of Red Hat patch policies.
3. Select a patch policy from the content pane and open it.
4. In the server browser from theViews drop-down list, select Servers.
5. From the Actions menu, select Attach.
6. From the new dialog select a Red Hat server click Attach. If you want the server to be remediated

immediately, select theRemediate Servers Immediately.

Remediating Red Hat dynamic patch policies
After this step, the recommended patches from the scan phase are installed to the system. To
remediate a patch policy:

1. In the navigation pane, select Library > By Type > Patch Policies.
2. Select a specific Red Hat operating system, and view the list of Red Hat patch policies.
3. Select a patch policy from the content pane and open it.
4. In the server browser from theViews drop-down list, select Servers and then select a server to

remediate on.
5. From the Actions menu, select Remediate.

Patch compliance
SA performs conformance checks against managed servers and device groups to determine whether
all patches in a policy were installed successfully. In case of Red Hat Patching, although the dynamic
patch policy is empty, this will be populated with items at runtime. The items that fill the patch policy
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are none other than the recommended patches from the Scan phase. In other words, the patch
compliance scan for Red Hat will check if all patches recommended by the scan phase are installed on
themanaged server.

There aremultiple ways of starting a compliance scan. Themost important are:

l Manually start of patch compliance scan
l Scheduled
l As a result of a Patch Policy Remediation

Manually starting a patch compliance scan
Tomanually start a patch compliance scan on one or moremanaged servers:

1. In the navigation pane, select Devices.
2. Select the device(s) and right click. From the context menu select Scan.
3. From the new menu list, select Patch Compliance.

Scheduling patch compliance scans
To schedule a patch compliance scan on all Red Hat Managed servers:

1. In the navigation pane, select Administration > Compliance Settings.
2. In the Compliance Settings content pane, in the Patch Compliance Schedule section, click Edit

Settings.
3. In the Schedule Compliance Scan window, select Enable Compliance Scan.
4. From theSchedule drop-down list, select the frequency of the scans and then click OK to save

the settings.

Patch compliance scans as part of other tasks
SA performs a patch compliance scan on amanaged server at the end of remediating a patch policy or
at the end of installing a recommended patch.

Best practices for managing minor RHEL releases
The current SA model differentiates between RedHat platforms based on themajor version number. A
major version is denoted by a whole number version change. For example, Red Hat Enterprise Linux
5.0 and RedHat Enterprise Linux 6.0 are bothmajor versions of Red Hat Enterprise Linux while RHEL
6.6 and 7.1 are consideredminor releases.

SA follows Red Hat practices and allows managing of packages and upgrades betweenminor
versions. A customer with a Red Hat Enterprise Linux 7.0 can use SA to patch the system and upgrade
to Red Hat Enterprise Linux 7.2minor release.

Themost common use cases that involves the SA RedHat patchingmechanism are upgrade scenario
and keeping a point-release up to date. This chapter is only addressed to customers that want to keep a
minor release up to date or want to upgrade to another minor release.
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Guidelines for upgrading a RHEL minor release
This involves importing the content into SA, setting a proper value for repo.restrict custom attribute,
scanning themanaged servers and then remediating a policy. The guidelines in this section apply to
both software policies and dynamic patch policies, unless otherwise specified.

Let’s take the following scenario: a Red Hat Enterprise Linux Server 7 needs to be upgraded to the
Update 2minor version.

Importing minor release packages
RedHat Enterprise Linux minor releases are an aggregation of enhancement, security, and bug fix
errata since the last major release.

To be able to upgrade themanaged servers at Update 2 you will have to import the 7.2 content
repository. The upgrade operation does not need to go through all subsequent releases. In our case we
don’t need to upgrade the system at 7.1 release and then at 7.2 release. You can upgrade directly to
7.2.

For the import process, besides configuring redhat_import.conf you need to add at the end of the file
the following three lines:

[rhel-7-server-rpms{7.2-x86_64}]

platform=Red Hat Enterprise Linux Server 7 X86_64

enabled=1

This assigns a platform for the Update 2 content repository and enables it for import.

Setting up repo.restrict customattributes
By default, the Red Hat Importer tool imports packages in specific folders. Eachminor release version
will be imported in its own path. For example, the packages for Red Hat Enterprise Linux 7 Update 2
will be stored in /RHSM/Packages/Red Hat Enterprise Linux 7 Server (RPMS) (7.2-x86_64)
folder. Similarly, content for 7.1 and 7.0 will be imported in their own custom folder.

Note: This step is mandatory for dynamic policies. For software policies, although not mandatory,
having a repo.restrict in place is recommended when remediating the content software policy.

Typically, a content repository can have thousands of packages but not all of them are eligible for
upgrade. The scan procedure queries themanaged server for the RPMs already installed. Then it will
mark only RPMs with newer version than the ones installed for upgrade.

The scanmechanism by default – builds an RPM repository with all available RPM packages in SA
Software Repository. If you have content imported for 7.1 and 7.2, the repo will contain packages for
both releases. The repo.restrict custom attribute comes in handy when you want to upgrade some
machines at Update 1 and some others at Update 2. It will help you restrict the folders in the SA Library
that the server has access to. All other folders will be inaccessible to the server. This gives you folder-
level control over which versions of RPMs can be applied to a given server, allowing you to precisely
upgrade to a specific version per eachmanaged server.
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In other words, please set the repo.restrict custom attribute value to the path where Update 2 packages
are located. This can be set per device, or per device group. You can even set it on the dynamic patch
policy/software policy if you are sure that the policy will be attached only on devices that need to be
upgraded to the 7.2 release.

For more information about repo.restrict, see "Manage RedHat patches" on page 262.

Scaning managed servers
This step only applies to dynamic patch policies. Once the custom attribute is set you need to create a
dynamic patch policy , attach it on the devices that need to be upgraded and then run a patch
compliance scan. This will trigger the actual scanning for building the recommended RPMs to install.

Remediating the patch policy
In case the patching happens with dynamic patch policies you can remediate the recommended
patches – discovered in the previous step - by starting a remediation job against the dynamic patch
policy previously attached to themanaged servers. For more information, see "Policy management" on
page 265.

For patching with static software policy things are a little bit different. You can’t benefit from the
scanning procedure that occurred in the previous step. You will have to remediate all packages
imported from theminor content repository. Fortunately – redhat_importer tool already groups all
imported packages into a software policy. Using the default configurations for the importer the policy
you can find the policy in SA Client under /RHSM/Content/ Red Hat Enterprise Linux 7 Server
(RPMs) (7.2-x86_64) Policy.

The remediation job for this policy will determine the eligible packages for upgrade in the analyze phase
and install them.

Note: HP recommends upgradingminor releases through dynamic patch policies because it offers
better performance.

Keeping aminor release up to date
Patching a Red Hat minor release with fixes, updates and security errata involves exactly the same
steps used for upgrading. Just make sure that repo.restrict custom attribute restricts the SA repo to the
packages corresponding to your particular minor version.

Frequently asked questions

The importer fails with SSL: CERTIFICATE_VERIFY_FAILED
One of themost common issues when importing Red Hat packages through RedHat Importer tool is
the:

Unexpected error: URLError: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED]
certificate verify failed (_ssl.c:590)
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This error means that the importer could not validate the server certificate during SSL handshake. Most
probably because the CA certificate of the Red Hat server from where packages are imported is not
imported in the SA trusted store. If you are importing from RHSM or from aRedHat Satellite make sure
you import the certificate from https://cdn.redhat.com or from your satellite using the steps provided in
"Install Red Hat CA certificates" on page 246.

Configuration file error: Invalid option [main] 'package_path'
Themost likely cause for this error is an invalid structure in the configuration file. In this particular case
the [RHN] section was removed from the config, and all of its properties are now children of [main]
section. But [main] section can only have a predefined set of attributes. In this case the fix is to add
back the [RHN] section in the config. A second solution is to make sure that when you removed the
[RHN] label, all of its children are either commented or removed from the configuration file.

As a general rule, don’t remove and don’t comment the [main], [RHN] and [RHSM] sections tag. If you
don’t want to import content from [RHN] you can set the channels property to an empty value. If you
still insist to remove/comment a particular section pleasemake sure themember properties are also
commented out. Also please note that the [main] section can’t be removed otherwise the importer will
fail if the section is not found in the configuration file

Import fails with: HTTP Error 403: Forbidden
If the import fails with a trace like the one below most probably your entitlement certificate is expired.

Requesting https://cdn.redhat.com/content/dist/rhel/server/7/7.2/x86_
64/os/repodata/repomd.xml

Unexpected error: HTTPError: HTTP Error 403: Forbidden

Please read the Entitlement certificates chapter to find out more details on how you can get an up to
date entitlement certificate.

Unable to process content label. No platform could be associated
with this label.
As the error suggests it means that redhat_import tool could not associate the CDN content for the
label to a specific SA supported platform.

Internally we have some default labels like rhel-7-server-rpms{7Server-x86_64} that have an SA
platform associated. But most of them don’t have.

In this case all you need to do is edit the redhat_import.conf file, go to the bottom and configure the
platform. For example if the original error is:

Unable to process content label rhel-7-server-rpms{7.2-x86_64}. No platform could
be associated with this label. This content label will be dropped. If you need to
import this content, add the 'platform' option to the configuration file.

The fix in the config file should be:

[rhel-7-server-rpms{7.2-x86_64}]
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platform=Red Hat Enterprise Linux Server 7 X86_64

The --show_labels option does not list all content labels from
entitlement
The --show_labels lists an intersection of labels configured in redhat_import.conf and the labels
found in entitlement. The option will render only labels that have an SA RedHat platform associated in
the redhat_import.conf (or /etc/opt/opsware/rhn_import/content_labels.json) and only if
they exist in the entitlement file.

For example, if you have the following three labels in the entitlement:

1. rhel-5-server-rpms

2. rhel-7-server-debug-rpms

3. rhel-7-server-optional-rpms

And in the redhat_import.conf file you only have the rhel-7-server-optional-rpms{7Server-
x86_64} content label associated with Red Hat Enterprise Linux Server 7 X86_64 platform, then --
show_labelswill only list two labels: rhel-5-server-rpms and rhel-7-server-optional-rpms.
Why? Because the first is configured by default in /etc/opt/opsware/rhn_import/content_
labels.jsonwhile the second one is configured in the redhat_import.conf file.

Please note that /etc/opt/opsware/rhn_import/content_labels.json contains the default
configured labels by SA and it should not bemodified.

Patch management for Oracle Enterprise Linux

The SA Patch Importer for Oracle Enterprise Linux (OEL) allows users to import packages for the
subscribed channels from theOracle Unbreakable Linux Network (ULN) and automatically create the
corresponding software policies for each imported channel in SA. It can be run from the command line
manually, or can be part of a cron job which performs the import on a recurring basis.

Before you begin

Prerequisites
The following prerequisites must bemet before using SA Patch Importer for Oracle Enterprise Linux.

l Purchase a support license from theOracle Unbreakable Linux Store to obtain a valid CSI
(Customer Support Identifier).See https://linux.oracle.com for more details.

l Register with the Oracle Unbreakable Linux Network (ULN) to obtain the username/password for
single sign-on.

l At least 100GB of free disk space is required on the system in which this tool will be used.
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Depending on the type of support license purchased from Oracle, youmay be able to subscribe to any
channels that Oracle is currently supporting. However, the SA Patch Importer will only import
packages for the platforms that SA supports.

Limitations
The SA Patch Importer for Oracle Enterprise Linux is intended to run on SA Core platforms only.

Patch importer file locations

Binaries /opt/opsware/patch_
importer/bin/

Configuration File /etc/opt/opsware/patch_
importer/uln_import.conf

Log File /var/log/opsware/patch_
importer/patch_
importer.log

Package Download Directory (where the downloaded packages will be
temporarily stored). Make sure you have at least 100GB of free disk
space on the file system.

/var/opt/opsware/patch_
importer/

Libraries /opt/opsware/patch_
importer/patch_
importer/

Importer file locations

Get started
Using SA Patch Importer for Oracle Enterprise Linux encompasses the following tasks:

1. Edit the configuration file, /etc/opt/opsware/patch_importer/uln_import.conf, to provide
the requirement information.

2. Register the system with the ULN.
3. Log on to the ULN to subscribe the channels.
4. Import the packages.
The first three tasks should be done once, or infrequently. The forth task, importing the packages, can
be scheduled on a recurring basis.

Note:
This tool must be run as root user on a core host.
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Editing the configuration file
The configuration file for SA Patch Importer for Oracle Enterprise Linux is located in
/etc/opt/opsware/patch_importer/uln_import.conf. It is divided into various sections. It has two
mandatory sections, [main] and [system_id], and zero or more optional sections. The optional sections
are used to control channel-specific behaviors.

The following tables describe the various configuration sections.

[main] Section

The [main] section has the general configuration options.

Property
name Expected values Description

username String (in the form of email) ULN username

password String ULN password

CSI String (a sequence of
numbers)

Oracle Customer Support Identifier

hide_
passwords

1, 0 (Default: 1) Indicates whether to obfuscate the passwords.

If set to 1, all the passwords in this file will be
obfuscated the very first time the tool is used. Once a
password is obfuscated, it will remain obfuscated,
there’s no way to de-obfuscate it.

If the password has changed, you can simply re-enter
the clear text password and it will be obfuscated on the
next run, assuming hide_passwords is still set to 1.

Youmay also use the --hide_passwords command line
option to obfuscate the passwords. If --hide_
passwords option is specified at the command line, it
will be used instead of the one from the configuration
file.

server_uri A valid URI (Default:
https://linux-
update.oracle.com/XMLRPC)

URI to the ULN RPC server. It points to the default
ULN instance. We do not support a server list for live
failover at this point. If the primary server is down, you
have tomanually change it to point to one of the
mirrors.

system_id A valid file path. ( Default:
/var/opt/opsware/uln_
import/system_id)

The location to store the system_id. Once the system
is registered with the ULN.

Warning: Please do not remove or change the location
of this file. Otherwise, you will have to re-register with

[main] Section options
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Property
name Expected values Description

the ULN.

proxy_
host

<FQHN>:[<port>] If HTTP proxy is used, specify it here.

proxy_
user

String If HTTP proxy authentication is required, specify the
proxy username. It will be ignored if proxy_host is not
specified.

proxy_
pass

String If HTTP proxy authentication is required, specify the
proxy user password. It will be ignored if proxy_host is
not specified.

proxy_
agent

String If HTTP proxy authentication is required, youmay
optionally specify the proxy_agent HTTP header for
identification purposes.

opsware_
user

String Youmay elect to import the packages in the context of
an SA user. If so, specify the username here. If
opsware_user is omitted, package import will be run in
the context of a system (internal) user.

opsware_
pass

String Password for the SA user. It will be ignored if
opsware_user is not specified.

continue_
on_error

1, 0 (Default: 1) This option is for not supported.

import_
threads

Number (Default: 10) Maximum number of import threads. Setting this to an
unreasonable valuemay cause service outage since
some source networks may not be capable of
supporting heavy load.

limit_
policy_
description

1, 0 (Default: 1) This option is not supported

channels An explicit list of channels
may be given separated by
spaces and/or newlines:

channels:

LABEL1

LABEL2

LABELn

If the channels option is not specified, then all SA
supported top-level (parent) channels are enabled, plus
any channels that have their own [channel] sections in
this configuration file.

[main] Section options, continued
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Property
name Expected values Description

package_
path

A valid directory path.
(Default:
/ULN/Packages/$channel_
name)

The folder in which the package will be uploaded for a
given channel.

“$channel_name” is a special placeholder. It will be
replaced by the channel at runtime.

Packages can be quarantined to prevent their use until
they are approved. Note that youmust ensure that the
permissions on the Unapproved folder limit the servers
that can access it. You can configure package_path to
a special folder for this purpose. For example:
package_
path=/ULN/Packages/Unapproved/$channel_name

channel_
path

A valid directory path.
(Default:
/ULN/Channels/$channel_
name Policy)

The folder in which the channel software policies will
be created for a given channel.

“$channel_name” is a special placeholder. It will be
replaced by the channel at runtime.

erratum_
path

A valid directory path.
(Default:
/ULN/Errata/$erratum_type
Policies/$erratum_name)

The folder in which the erratum software policies will
be created for the given channel.

“$erratum_type” and “$erratum_name” are special
placeholders. They will be replaced by erratum type
and erratum name respectively at runtime.

Instead of creating a roll-up policy by channel, you
might choose to create it by month For example,

errata_path=/ULN/Errata/$Y-$m Advisory Roll-Up
Policy

Notice that “$Y” and “$m” are special placeholders for
year andmonth respectively.

This configuration is currently not being used.

errata_
path

A valid directory path.
(Default:
/ULN/Errata/$channel_name
Advisory Roll-Up Policy)

The folder in which the errata software policies will be
created for the given channel.

“$channel_name” is a special placeholder. It will be
replaced by the channel at runtime.

This configuration is currently not being used.

package_
search_
path

An explicit list of directory
paths may be given separated
by spaces and/or newlines:

channels:

The paths to search for previously uploaded packages.

“$opsware_platform” is a special placeholder. It will be
replaced by the platform name at runtime.

[main] Section options, continued
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Property
name Expected values Description

PATH1

PATH2

PATHn

Default:

/Package Repository/OS
Media/$opsware_platform

/Package Repository/All Red
Hat Linux/$opsware_platform

/Migrated/Package
Repository/Customer
Independent/$opsware_
platform

[main] Section options, continued

[system_profile] section

This section is used to specify the properties for the system profile. The information is used to register
with the ULN. Typically, before downloading packages, the systemmust first register with the ULN. A
system profile is created, which contains OS and hardware information, upon registration. Once the
system is registered, the ULN will automatically assign the default channels associated with the
platform in which the system is running. However, since SA can be run on a non-OEL system, this
essentially generates a pseudo system profile.

The system profile is created using the information from the [system_profile] section:

Property
name Expected values Description

profile_
name

String (Default:
FQDN of the
system where the
tool is run)

Name of the profile. Typically it is the Fully Qualified Domain
Name of the host where the tool is run.

os_release Number (Default: 5) Oracle Enterprise Linux OS release number.

release-
name

String (Default:
enterprise-release)

Oracle Enterprise Linux OS release name.

architecture X86 or x86_64
(Default: x86_64)

OS architecture. We only support x86 and x86_64 right now.

uuid String UUID. Will be generated in runtime.

[system_profile] Section Options
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Warning: Do not modify this property unless you are not certain
of how it will affect your system. Misuse of this property can
break the import tool and require you need to re-register.

rhnuuid String RHN UUID. Will be generated in runtime.

Warning: Do not modify this property unless you are not certain
of how it will affect your system. Misuse of this property can
break the import tool and require you to re-register.

[system_profile] Section Options, continued

Channel-specific sections

Here is an example of a channel specific section. In this case, it enables the Oracle Enterprise Linux 5
Update 6 Patch channel, creating a policy composed of all the packages in that channel. Note that this
section is enabled by default as long as the ‘channels’ option is not specified in the [main] section. If the
‘channels’ option is specified in the [main] section, then it must be explicitly enabled via the "enabled"
option. Also, channel_path is defined here only as we don't wish to create channel policies for top-level
channels

[ol5_u6_x86_64_patch]

; enabled=1

# You may wish to import all versions of each packages in the channel. By

# default, only the latest version of each package is imported. Note that

# when importing all versions, it is recommended that packages_only=1 also be

# used since it is not useful to have a policy with more than one version of

# each package.

; which_packages=all

# You may wish to download the packages for this channel only and then

# create the policies manually. Also useful in combination with

# which_packages=all:

; packages_only=1

# To locate a child channel's packages next to the corresponding policy in

# the library, use a path such as the following:

; package_path=/ULN/Channels/$channel_name Packages

Registere the systemwith the ULN
After editing the configuration file, you are now ready to register the system with the ULN.

To register the system with the ULN:
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1. Run the /opt/opsware/patch_importer/bin/uln_importwith the –show_conf option.
This option has twomain purposes. It shows your current configuration as well as registering the
system if the system has not been previously registered with the ULN.

[root@vc002 patch_importer]# /opt/opsware/patch_importer/bin/uln_import --show_
conf

********** Configuration For ULN **********

Retrieving platform information from SA

Retrieving channel information from Oracle ULN

|

[system_profile]

rand_key_path : /var/opt/opsware/crypto/wordbot/.randkey-rhn_import

package_path : /var/opt/opsware/patch_importer/packages

which_packages : latest

server_uri : https://linux-update.oracle.com/XMLRPC

cache_path : /var/opt/opsware/uln_import/cache

dbg_random_fail : 0

erratum_path : /$network_name/Errata/$erratum_type Policies/$erratum_
name

download_server_uri : http://linux-update.oracle.com/XMLRPC

package_search_path :

/Package Repository/OS Media/$opsware_platform

/Package Repository/All Red Hat Linux/$opsware_platform

/Migrated/Package Repository/Customer Independent/$opsware_platform

packages_only : False

errata_path : /$network_name/Errata/$parent_channel_name/$channel_name
Advisory Roll-Up Policy

hide_passwords : 1

import_threads : 5

show_config_only : 0

tmp_path : /var/opt/opsware/patch_importer

system_id : /etc/opt/opsware/patch_importer/system_id

mode : all

continue_on_error : 1
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channel_path : /$network_name/Channels/$parent_channel_name/$channel_
name Policy

[main]

rand_key_path : /var/opt/opsware/crypto/wordbot/.randkey-rhn_import

erratum_path : /ULN/Errata/$erratum_type Policies/$erratum_name

which_packages : latest

package_path : /ULN/Packages/$channel_name

download_server_uri : http://linux-update.oracle.com/XMLRPC

package_search_path :

/Package Repository/OS Media/$opsware_platform

/Package Repository/All Red Hat Linux/$opsware_platform

/Migrated/Package Repository/Customer Independent/$opsware_platform

packages_only : False

csi : 1234567

proxy_host : abc.acme.com:8080

errata_path : /ULN/Errata/$channel_name Advisory Roll-Up Policy

import_threads : 10

tmp_path : /var/opt/opsware/patch_importer

system_id : /etc/opt/opsware/patch_importer/system_id

channel_path : /ULN/Channels/$channel_name Policy

continue_on_error : 1

username : test@hpe.com

server_uri : https://linux-update.oracle.com/XMLRPC

cache_path : /var/opt/opsware/uln_import/cache

dbg_random_fail : 0

password : (Hidden)

hide_passwords : 1

show_config_only : 1

mode : all

<Configuration For Channel: ol5_x86_64_latest>
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Enabled : True

Packages Only : False

Which Packages : latest

Package Path : /ULN/Packages/$channel_name

********************************************

2. Once the system is registered, you should be able to view it under the Systems tab at the ULN:
https://linux.oracle.com. By default, the ULN automatically assigns the latest platform channel to
the newly registered system.

A system_id file is created in /etc/opt/opsware/patch_importer/uln/. If you are unable to
register with the ULN, you can check the log file at /var/log/opsware/patch_importer/patch_
importer.log for possible errors. You can also run uln_import in debugmode if necessary.
/opt/opsware/patch_importer/bin/uln_import --show_conf –v

If you need to register with the ULN, make sure to remove the old system_id anddelete the
registered system from the ULN before doing so.

rm –rf /etc/opt/opsware/patch_importer/uln/system_id

/opt/opsware/patch_importer/bin/uln_import –show_conf

Subscribing and unsubscribing channels from the ULN

Subscribing and unsubscribing channels must be done with the ULN. Before you can perform the
subscription/unsubscription step, you need designate the system as a YUM server.

To designate the registered system as a YUM server:

1. If you have different flavors of Enterprise Linux deployed in your environment, check the Yum
Server box in the Edit System Properties tab of your registered system in order to subscribe to all
the available channels.
IMPORTANT: It is important to select the Yum Server box. If it is not selected, the ULN will
restrict the channels to only those that are relevant to the registered system’s platform. By
designating the registered system as a Yum Server, the ULN will allow it to subscribe to any
currently available channels.

2. Click Apply Changes to submit the changes.

Once the registered system is designated as a Yum Server, it is capable of subscribing any
channels currently available.
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To subscribe/unsubscribe channels:

1. Navigate to theManage Subscriptions tab of the registered system.
Keep inmind that some channels do not contain any updates. They are just base RPMs from the
ISO or the releasemedia. Some channels are superset of others. Also, unlike the RedHat
network, the ULN has no concept of “parent channels.”

2. Select the desired channels.
3. To subscribe to a channel, move it from the Available channels column to the Subscribed

channels column.
4. To unsubscribe, move it from the Subscribed channels column to the Available channels column.
5. Click Save Subscriptions.

6. Once you subscribe to the desired channels from the ULN, youmay want to verify it by running
/opt/opsware/patch_importer/bin/uln_importwith the –show_conf option tomake sure the
channels are enabled.

[root@vc002 bin]# /opt/opsware/patch_importer/bin/uln_import --show_conf

********** Configuration For ULN **********

Retrieving platform information from SA

Retrieving channel information from Oracle ULN

|

[system_profile]

rand_key_path : /var/opt/opsware/crypto/wordbot/.randkey-rhn_import

package_path : /var/opt/opsware/patch_importer/packages

which_packages : latest

server_uri : https://linux-update.oracle.com/XMLRPC
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cache_path : /var/opt/opsware/uln_import/cache

dbg_random_fail : 0

erratum_path : /$network_name/Errata/$erratum_type Policies/$erratum_
name

download_server_uri : http://linux-update.oracle.com/XMLRPC

package_search_path :

/Package Repository/OS Media/$opsware_platform

/Package Repository/All Red Hat Linux/$opsware_platform

/Migrated/Package Repository/Customer Independent/$opsware_platform

packages_only : False

errata_path : /$network_name/Errata/$parent_channel_name/$channel_name
Advisory Roll-Up Policy

hide_passwords : 1

import_threads : 5

show_config_only : 0

tmp_path : /var/opt/opsware/patch_importer

system_id : /etc/opt/opsware/patch_importer/system_id

mode : all

continue_on_error : 1

channel_path : /$network_name/Channels/$parent_channel_name/$channel_
name Policy

[main]

rand_key_path : /var/opt/opsware/crypto/wordbot/.randkey-rhn_import

erratum_path : /ULN/Errata/$erratum_type Policies/$erratum_name

which_packages : latest

package_path : /ULN/Packages/$channel_name

download_server_uri : http://linux-update.oracle.com/XMLRPC

package_search_path :

/Package Repository/OS Media/$opsware_platform

/Package Repository/All Red Hat Linux/$opsware_platform

/Migrated/Package Repository/Customer Independent/$opsware_platform
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packages_only : False

csi : 12345678

proxy_host : test.acme.com:8080

errata_path : /ULN/Errata/$channel_name Advisory Roll-Up Policy

import_threads : 10

tmp_path : /var/opt/opsware/patch_importer

system_id : /etc/opt/opsware/patch_importer/system_id

channel_path : /ULN/Channels/$channel_name Policy

continue_on_error : 1

username : abc@hpe.com

server_uri : https://linux-update.oracle.com/XMLRPC

cache_path : /var/opt/opsware/uln_import/cache

dbg_random_fail : 0

password : (Hidden)

hide_passwords : 1

show_config_only : 1

mode : all

<Configuration For Channel: el5_u5_i386_patch>

Enabled : True

Packages Only : False

Which Packages : latest

Package Path : /ULN/Packages/$channel_name

<Configuration For Channel: el5_u5_x86_64_patch>

Enabled : True

Packages Only : False

Which Packages : latest

Package Path : /ULN/Packages/$channel_name
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********************************************

Keep inmind that SA will filter out the channels for the platforms that it does not currently support. For
example, youmay subscribe to Enterprise Linux 3 channels, but they will be ignored by SA.

Importing packages

By default, the SA Patch Importer will create a software policy for each channel, unless users elect not
to do so by specifying the –package_only option.

To import the packages:

1. Run /opt/opsware/patch_importer/bin/uln_import

[root@vc002 bin]# /opt/opsware/patch_importer/bin/uln_import

********** Importing Packages From ULN **********

Retrieving platform information from SA

Retrieving channel information from Oracle ULN

Processing package information

|

***** Import Phase *****

Importing 649 packages for channel Enterprise Linux 5 Update 5 Patch (x86_64)

|============================================================| 100% 00:00:00

Elapsed Time: 912 seconds

Importing 530 packages for channel Enterprise Linux 5 Update 5 Patch (i386)

|============================================================| 100% 00:00:00

Elapsed Time: 978 seconds

ULN Import Completed

*************************************************

2. When the import process is complete, you can logon to the SA Java Client to view the newly
created policies.

3. By default, the policies are created in the /ULN/Channels/ folder and will be named, <Channel
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Name> Policy, where <Channel Name> is the name of the channel. For example:
/ULN/Channels/Enterprise Linux 5 Update 5 Patch (i386) Policy.

‘Read’ (or greater) permission to the /ULN/Channels/ folder is required to view the newly created
policies.

4. By default the packages are imported into the /ULN/Packages/<Channel Name>/ folder, where
<Channel Name> is the name of the channel. For example: /ULN/Packages/Enterprise Linux
5 Update 5 Patch (i386)/

‘Read’ (or greater) permission to the channel folder is required to view the newly imported

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 285 of 307



packages.

5. After you verify the newly created software policies, youmay start remediating the OEL servers.
Youmust have the proper permissions to perform remediation tasks. See the the SA User Guide for
more information on software remediation.

Use the SA patch importer for Oracle Enterprise Linux
The SA Patch Importer for Oracle Enterprise Linux can be run from the command line, or can be part of
a cron job, which runs the import on the recurring basis. By default, the importer will import the
packages for the subscribed channels from the ULN and create the corresponding software policies for
each of the imported channels.

A full set of command line options gives you full control over the import action. For example, you can:

l Selectively enable or disable one or more channels at runtime
l Decide whether to import the packages without creating the corresponding software policies
l Add new channels to a supported platform
l Remove channels from a supported platform
l View supported channels for the supported platforms
l Do a dry run on the import to see what actions will be performing

The following table describes the command line options for uln_import:
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Option Description

--version Show the version number of this program and exit.

-h, --help Show this helpmessage and exit.

-E LABEL [LABEL...], --
enable=LABEL
[LABEL...]

Enable a previously disabled channel; multiple labels may be provided;
use 'all' to enable all configured channels.

A channel can be disabled by setting the ‘enabled=0’ in the channel
section in the configuration file, /etc/opt/opsware/patch_importer/uln_
import.conf.

Use this option to dynamically enable it at run time.

-D LABEL [LABEL...], --
disable=LABEL
[LABEL...]

Disable a previously enabled channel at run time; multiple labels may be
provided; use 'all' to disable all configured channels.

Using 'all' will effectively disabled all channels, whichmeans no channels
will be imported. It’s as good as running a no-op.

This option does not permanently disabled channels; it only disables the
given channels for this particular run.

-m MODE, --
mode=MODE

Import mode: 'channel', 'erratum', 'errata', 'all' [default: all]

--
source=SUPPORTED_
SOURCES

Source: 'uln', 'all' [default: all]

-c FILE, --conf=FILE Configuration file [default: none]

Use this option to specify an alternative configuration file.

--packages_only Don't create policies, download packages only.

-n, --preview Show what would be done (dry-run).

-s, --silent Display errors only.

-v, --verbose Debugmode.

Debugmessages are available in the log file.

--show_conf Show configuration settings and exit.

--show_labels Show default RHN channel labels and exit.

--hide_passwords Rewrite the configuration file hiding any plain-text passwords and exit.

--show_platform_labels List the platforms and their supported channel labels; may use the --
platform_name option to filter the platforms to be displayed.

--add_platform_label Add channel labels to a given platform; must use the --platform_name

Command Line Options for uln_import
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Option Description

option to specify a platform, along with the labels to be added.

--remove_platform_
label

Remove channel labels from a given platform; must use the --platform_
name option to specify a platform, along with the labels to be removed.

--platform_
name=PLATFORM_
NAME

Specify the platform name; when used with --show_platform_labels
option, it will be used as a name filter; when used with --add_platform_
label option, it must be an exact match; when used with --remove_
platform_label option, it must be an exact match.

Command Line Options for uln_import, continued

Disable channels at runtime

By default, a subscribed channel is enabled if it meets the following conditions:

1. It is one of the supported channels of a supported SA agent platform.
2. It has no [<Channel Label>] section the configuration file /etc/opt/opsware/patch_

importer/uln_import.conf.
3. It has a [<Channel Label>] section the configuration file /etc/opt/opsware/patch_

importer/uln_import.conf and it has “enabled=1” specified.
Youmay disable one or more channels at runtime by using the –D or –disable option. For
example,

/opt/opsware/patch_importer/bin/uln_import -D el5_u5_x86_64_patch el5_u5_i386_patch

This option does not permanently disable channels. It merely disables the given channels for this
particular run.

Enable channels at runtime

By default, a subscribed channel is disabled if it meets the following condition:

It has a [<Channel Label>] section the configuration file /etc/opt/opsware/patch_importer/uln_
import.conf and it has “enabled=0” specified.

Youmay enable one or more disabled channels at runtime by using the –E or –enable option. For
example,

/opt/opsware/patch_importer/bin/uln_import -E el5_u5_x86_64_patch el5_u5_i386_patch

Limitations: You can only use this option to enable channels for platforms that SA supports. You
cannot use it to enable channels for platforms that SA does not support.

Import packages without creating the corresponding software policies

By default, SA will create the corresponding software policy for a given channel unless one of the
following conditions is true:

1. “packages_only=1” exist in the [main] section of the configuration file /etc/opt/opsware/patch_
importer/uln_import.conf.
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2. It has a [<Channel Label>] section the configuration file /etc/opt/opsware/patch_
importer/uln_import.conf and it has “packages_only=1” specified.

However, youmay choose to override the default behavior by specifying the –packages_only option at
runtime. For example:

/opt/opsware/patch_importer/bin/uln_import –packages_only

Like other runtime options, this option does not cause permanent changes in the configuration file.

View the enabled channel information

You can view the enabled channels information by specifying the –show_labels
option. For example:

[root@vc002 bin]# /opt/opsware/patch_importer/bin/uln_import --show_labels

********** Supported Channels For ULN **********

Retrieving platform information from SA

Retrieving channel information from Oracle ULN

Processing package information

Supported Labels: ['el5_u5_x86_64_patch', 'el5_u5_i386_patch']

---------- Channels Details ----------

Channel Label : el5_u5_x86_64_patch

Channel Name : Enterprise Linux 5 Update 5 Patch (x86_64)

Channel Description : Updated packages published after release of Enterprise Linux
5 Update 5 (x86_64)

Channel Version : 20110111133047

Number of Packages : 649

Channel Label : el5_u5_i386_patch

Channel Name : Enterprise Linux 5 Update 5 Patch (i386)

Channel Description : Updated packages published after release of Enterprise Linux
5 Update 5 (i386)

Channel Version : 20110111125211

Number of Packages : 530

*************************************************
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View the supported channels for the Agent platforms

You can view the list of channels SA currently support, along with its corresponding platform, by
specifying the –show_platform_labels option. For example:

[root@vc002 bin]# /opt/opsware/patch_importer/bin/uln_import --show_platform_labels

Retrieving platform information from SA

|

---------- Channel Label ---------- ---------- Platform Name ----------

el5_exadata_i386_latest Oracle Enterprise Linux 5

el5_exadata_x86_64_latest Oracle Enterprise Linux 5 X86_64

el5_ga_i386_base Oracle Enterprise Linux 5

el5_ga_i386_patch Oracle Enterprise Linux 5

el5_ga_x86_64_base Oracle Enterprise Linux 5 X86_64

el5_ga_x86_64_patch Oracle Enterprise Linux 5 X86_64

el5_i386_addons Oracle Enterprise Linux 5

el5_i386_lsb4 Oracle Enterprise Linux 5

el5_i386_ocfs2 Oracle Enterprise Linux 5

el5_i386_oracle Oracle Enterprise Linux 5

el5_i386_oracle_addons Oracle Enterprise Linux 5

el5_rds_i386_latest Oracle Enterprise Linux 5

el5_rds_x86_64_latest Oracle Enterprise Linux 5 X86_64

el5_u1_i386_base Oracle Enterprise Linux 5

el5_u1_i386_patch Oracle Enterprise Linux 5

el5_u1_x86_64_base Oracle Enterprise Linux 5 X86_64

el5_u1_x86_64_patch Oracle Enterprise Linux 5 X86_64

el5_u2_i386_base Oracle Enterprise Linux 5

el5_u2_i386_patch Oracle Enterprise Linux 5

el5_u2_x86_64_base Oracle Enterprise Linux 5 X86_64

el5_u2_x86_64_patch Oracle Enterprise Linux 5 X86_64

el5_u3_i386_base Oracle Enterprise Linux 5

el5_u3_i386_patch Oracle Enterprise Linux 5

el5_u3_x86_64_base Oracle Enterprise Linux 5 X86_64

el5_u3_x86_64_patch Oracle Enterprise Linux 5 X86_64
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el5_u4_i386_base Oracle Enterprise Linux 5

el5_u4_i386_patch Oracle Enterprise Linux 5

el5_u4_x86_64_base Oracle Enterprise Linux 5 X86_64

el5_u4_x86_64_patch Oracle Enterprise Linux 5 X86_64

el5_u5_i386_base Oracle Enterprise Linux 5

el5_u5_i386_patch Oracle Enterprise Linux 5

el5_u5_x86_64_base Oracle Enterprise Linux 5 X86_64

el5_u5_x86_64_patch Oracle Enterprise Linux 5 X86_64

el5_unsupported_i386_latest Oracle Enterprise Linux 5

el5_unsupported_x86_64_latest Oracle Enterprise Linux 5 X86_64

el5_x86_64_addons Oracle Enterprise Linux 5 X86_64

el5_x86_64_lsb4 Oracle Enterprise Linux 5 X86_64

el5_x86_64_ocfs2 Oracle Enterprise Linux 5 X86_64

el5_x86_64_oracle Oracle Enterprise Linux 5 X86_64

el5_x86_64_oracle_addons Oracle Enterprise Linux 5 X86_64

ol5_i386_latest Oracle Enterprise Linux 5

ol5_u5_x86_64_patch Oracle Enterprise Linux 5 X86_64

ol5_u6_i386_base Oracle Enterprise Linux 5

ol5_u6_i386_patch Oracle Enterprise Linux 5

ol5_u6_x86_64_base Oracle Enterprise Linux 5 X86_64

ol5_u6_x86_64_patch Oracle Enterprise Linux 5 X86_64

ol5_x86_64_latest Oracle Enterprise Linux 5 X86_64

redhat-advanced-server-i386 Red Hat Enterprise Linux AS 2.1

redhat-ent-linux-i386-es-2.1 Red Hat Enterprise Linux ES 2.1

redhat-ent-linux-i386-ws-2.1 Red Hat Enterprise Linux WS 2.1

rhel-i386-as-3 Red Hat Enterprise Linux AS 3

rhel-i386-as-4 Red Hat Enterprise Linux AS 4

rhel-i386-client-5 Red Hat Enterprise Linux Desktop 5

rhel-i386-es-3 Red Hat Enterprise Linux ES 3

rhel-i386-es-4 Red Hat Enterprise Linux ES 4

rhel-i386-server-5 Red Hat Enterprise Linux Server 5

rhel-i386-ws-3 Red Hat Enterprise Linux WS 3

rhel-i386-ws-4 Red Hat Enterprise Linux WS 4
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rhel-ia64-as-3 Red Hat Enterprise Linux AS 3 IA64

rhel-ia64-as-4 Red Hat Enterprise Linux AS 4 IA64

rhel-ia64-es-3 Red Hat Enterprise Linux ES 3 IA64

rhel-ia64-es-4 Red Hat Enterprise Linux ES 4 IA64

rhel-ia64-server-5 Red Hat Enterprise Linux Server 5 IA64

rhel-ia64-ws-3 Red Hat Enterprise Linux WS 3 IA64

rhel-ia64-ws-4 Red Hat Enterprise Linux WS 4 IA64

rhel-x86_64-as-3 Red Hat Enterprise Linux AS 3 X86_64

rhel-x86_64-as-4 Red Hat Enterprise Linux AS 4 X86_64

rhel-x86_64-client-5 Red Hat Enterprise Linux Desktop 5 X86_64

rhel-x86_64-es-3 Red Hat Enterprise Linux ES 3 X86_64

rhel-x86_64-es-4 Red Hat Enterprise Linux ES 4 X86_64

rhel-x86_64-server-5 Red Hat Enterprise Linux Server 5 X86_64

rhel-x86_64-ws-3 Red Hat Enterprise Linux WS 3 X86_64

rhel-x86_64-ws-4 Red Hat Enterprise Linux WS 4 X86_64

You can also filter the platforms by using the –platform_name option. This is a case-sensitive partial
match. For example, to display only platforms with the string “Oracle” in their name:

[root@vc002 bin]# /opt/opsware/patch_importer/bin/uln_import --show_platform_labels
--platform_name Oracle

Retrieving platform information from SA

|

---------- Channel Label ---------- ---------- Platform Name ----------

el5_exadata_i386_latest Oracle Enterprise Linux 5

el5_exadata_x86_64_latest Oracle Enterprise Linux 5 X86_64

el5_ga_i386_base Oracle Enterprise Linux 5

el5_ga_i386_patch Oracle Enterprise Linux 5

el5_ga_x86_64_base Oracle Enterprise Linux 5 X86_64

el5_ga_x86_64_patch Oracle Enterprise Linux 5 X86_64

el5_i386_addons Oracle Enterprise Linux 5

el5_i386_lsb4 Oracle Enterprise Linux 5

el5_i386_ocfs2 Oracle Enterprise Linux 5

el5_i386_oracle Oracle Enterprise Linux 5
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el5_i386_oracle_addons Oracle Enterprise Linux 5

el5_rds_i386_latest Oracle Enterprise Linux 5

el5_rds_x86_64_latest Oracle Enterprise Linux 5 X86_64

el5_u1_i386_base Oracle Enterprise Linux 5

el5_u1_i386_patch Oracle Enterprise Linux 5

el5_u1_x86_64_base Oracle Enterprise Linux 5 X86_64

el5_u1_x86_64_patch Oracle Enterprise Linux 5 X86_64

el5_u2_i386_base Oracle Enterprise Linux 5

el5_u2_i386_patch Oracle Enterprise Linux 5

el5_u2_x86_64_base Oracle Enterprise Linux 5 X86_64

el5_u2_x86_64_patch Oracle Enterprise Linux 5 X86_64

el5_u3_i386_base Oracle Enterprise Linux 5

el5_u3_i386_patch Oracle Enterprise Linux 5

el5_u3_x86_64_base Oracle Enterprise Linux 5 X86_64

el5_u3_x86_64_patch Oracle Enterprise Linux 5 X86_64

el5_u4_i386_base Oracle Enterprise Linux 5

el5_u4_i386_patch Oracle Enterprise Linux 5

el5_u4_x86_64_base Oracle Enterprise Linux 5 X86_64

el5_u4_x86_64_patch Oracle Enterprise Linux 5 X86_64

el5_u5_i386_base Oracle Enterprise Linux 5

el5_u5_i386_patch Oracle Enterprise Linux 5

el5_u5_x86_64_base Oracle Enterprise Linux 5 X86_64

el5_u5_x86_64_patch Oracle Enterprise Linux 5 X86_64

el5_unsupported_i386_latest Oracle Enterprise Linux 5

el5_unsupported_x86_64_latest Oracle Enterprise Linux 5 X86_64

el5_x86_64_addons Oracle Enterprise Linux 5 X86_64

el5_x86_64_lsb4 Oracle Enterprise Linux 5 X86_64

el5_x86_64_ocfs2 Oracle Enterprise Linux 5 X86_64

el5_x86_64_oracle Oracle Enterprise Linux 5 X86_64

el5_x86_64_oracle_addons Oracle Enterprise Linux 5 X86_64

ol5_i386_latest Oracle Enterprise Linux 5

ol5_u5_x86_64_patch Oracle Enterprise Linux 5 X86_64

ol5_u6_i386_base Oracle Enterprise Linux 5
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ol5_u6_i386_patch Oracle Enterprise Linux 5

ol5_u6_x86_64_base Oracle Enterprise Linux 5 X86_64

ol5_u6_x86_64_patch Oracle Enterprise Linux 5 X86_64

ol5_x86_64_latest Oracle Enterprise Linux 5 X86_64

Add a channel label to a platform

Sometime vendors may add channel labels to a given platform. SA must be aware of the new labels
before the new channels can be supported.

To add the new labels to the SA’s supported list:

[root@vc002 bin]# /opt/opsware/patch_importer/bin/uln_import --add_platform_label -
-platform_name "Oracle Enterprise Linux 5" el5_new_label

Adding channel label el5_new_label for platform Oracle Enterprise Linux 5

Done

Remove a channel label from a platform

Sometime a channel is obsolete and can be removed from SA’s supported list.

To remove an obsolete channel from the supported list:

[root@vc002 bin]# /opt/opsware/patch_importer/bin/uln_import --remove_platform_
label --platform_name "Oracle Enterprise Linux 5" el5_new_label

Removing channel label el5_new_label for platform Oracle Enterprise Linux 5

Done

Patch management for SUSE Linux Enterprise
Server Automation patchmanagement for SUSE Linux Enterprise enables you tomanage security and
non-security patches for your SUSE-supportedmanaged servers. It allows you to identify, install, and
audit SUSE package updates, keeping a high level of security across managed servers in your
organization.

In SA, patches are the equivalent of SUSE errata. The latter are package updates, bug fixes, and
security patches for Linux Enterprise.

High-level architecture
The SA SUSE patchingmechanism allows you to import patches from SUSE or from other sources,
scanmanaged servers to determine their current patching level, and perform the deployment of
patches. Finally, the server can be checked for compliance against the recommended set of patches.

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 294 of 307



A typical SUSE patching use case follows a well-defined process. Patches are first imported into SA.
This is followed by an optional step where you canmanage the patches. Once the recommended
patches are included in one or multiple software policies, the servers can be remediated. After the
remediation occurs, the patched servers can be checked for compliance.

Import patches for SUSE platforms
In SA, SUSE platforms can be customized and kept up-to-date by using RPM packages. These
packages can be imported and applied to a set of SUSE-supportedmanaged servers in SA. The import
process uploads RPM patches into the SA Library and can be used in operations like software
installation, software policy creation and remediation, software compliance, and so on.

Currently, there are three ways to import SUSE patches into SA:

l Upload the RPM packages into the SA Library using the SA Command Line Interface.
l Import the SUSE packages into SA through the SA Client built-in importer. This tool allows you to
import multiple RPM packages simultaneously. If an RPM package that is being uploaded exists in
the SA Library already , then you can:
l Replace (overwrite) the content of the existing package

l Skip the package import (useful when importingmultiple packages)

l Cancel the import in progress

When you overwrite an existing software package, SA preserves any reboot options or flags
previously set for the package.

Note: The approaches listed above work best for scenarios where custom patches must be
imported into SA.

l Import the official patches issued by SUSE using one of the following SA SUSE tools, which comes
preinstalled with the slice component:
l SUSE Manager Importer tool

l SubscriptionManagement Tool (SMT) Importer

You can find the binaries for these tools in /opt/opsware/sles_import/bin.

Importing SUSE Errata and channels in SA using SA SUSE
Importer tools
SUSE publishes Errata that contains information describing security patches, bug fixes, and package
updates for SUSE Linux Enterprise. To install the packages in the Errata, youmust download the
Errata from the SUSE web-site and then import into SA. Using SA, you can automatically download the
Errata released by SUSE, convert them to policies, and store the policy in a folder in the SA Library.

In addition, SUSE publishes repositories that contain packages from a particular repository. Using SA,
you can automatically download the packages in a channel (SuSE Manager Importer) or content label
(SMT), convert them to policies, and store the policies in a folder in the SA Library. The suse_manager_
import and smt_import tools provided by SA enable you to create policies that correspond to the
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SUSE errata and channels/content labels. Using these tools, you can create the following types of
policies:

l Channel-based software policy: A SUSE Network channel contains a list of packages. A channel
allows you to group packages as per your organizational requirements. For example, a channel may
contain packages for a particular SUSE operating system version or architecture. A channel may
contain other child channels. When you run the importer, SA downloads the latest packages from
the SUSE Network channel (SUSE Manager Importer), imports the packages to the SA Library and
creates a channel-based or content-based software policy. Channels are equivalent to SMT content,
the only difference being the source of the packages.
Thus, a channel-based policy reflects a particular channel. In the SA Client, you can view the name,
description, location, availability, and the version of the operating system of the channel-based
policy in the SA Library.

l Errata-based software policy: SUSE Network Errata contains information on a particular problem
and the associated packages to resolve the problem. An errata-based policy contains all the
individual erratum-based policies for a given channel. SA downloads the latest packages from the
SUSE Network Errata and then imports the packages to the SA Library and creates an errata-based
software policy.
There are three types of SUSE Network Errata, specific to SUSE Manager:
l Bug Fix Advisories

l Product Enhancement Advisories

l Security Advisories

The SMT Importer uses the following types of errata:
l Security Advisories

l Recommended Advisories

l Optional Advisories

In the SA Client, you can view the name, description, location, availability, and the operating system
version of the errata-based policy in the SA Library.

l Erratum-based software policy: Erratum-based policies contain packages associated with a
particular erratum. When you run the suse_manager_import or smt_import tool, SA downloads the
latest packages from the SUSE Network erratum and then imports the packages to the SA Library
and creates an Erratum-based software policy.

To create andmaintain policies from the SUSE Linux errata, erratum, and channels, log into the core
server running the Software Repository component (part of the Slice Component bundle) and run the
suse_manager_import or smt_import tool located in the /opt/opsware/sles_import/bin directory.

The software policies created by suse_manager_import and smt_importwill, by default, have an
empty uninstall sequence. This setting prevents the inadvertent uninstall of the RPMs in the policy
when it is detached.

Importing RPM packages from the SUSE Network to SA requires a large amount of disk space. Over a
period of time, the amount of disk space required increases as new versions of packages are released
by SUSE. HP recommends having at least 5 GB of disk space available in Software Repository for
every SUSE channel you enable using the importer.
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To view the complete documentation, run one of the following commands:

l /opt/opsware/sles_import/bin/suse_manager_import --manual

l /opt/opsware/sles_import/bin/smt_import --manual

When you run the importer, you can specify the options listed in the documentation provided by the
tools or use the sample configuration files provided by SA, located at /etc/opt/opsware/sles_
import/suse_manager.conf-sample or /etc/opt/opsware/sles_import/smt_import.conf-sample.

SA SUSE Manager Importer tool
The SA SUSE Manager Importer is a tool based on the SA RedHat Importer. The tool imports
packages and errata from a SUSE Manager server, creates SA software policies for errata and
packages hosted by SUSE Manager.

The following topics are discussed in this section:

l "Installing the SUSE Manager CA certificate" below
l "Configuring the SA SUSE Manager Importer" on the next page
l "Working of SUSE Manager Importer tool" on page 299
l "Usage of SUSE Manager Importer tool" on page 299

Installing the SUSE Manager CA certificate
By default, the importer binary suse_manager_import validates the SUSE Manager server certificate.
The remote server certificate is self-signed, therefore there is no CA bundled with the SA
OSPWopenssl component. To enable access for suse_manager_import to SUSE Manager server,
youmust install the self-signed server certificate in the OSPWopenssl trust store.

To install SUSE Manager CA certificate:

1. Download the self-signed certificate from SUSE Manager.
a. Install the self-signed certificate in the SA trust store.

2. Verify if OPSWopenssl is validating the server certificate.
Downloading the self-signed certificate from SUSE Manger

The self-signed certificate is made public by SUSE Manager at /pub/RHN-ORG-TRUSTED-SSL-
CERT. Run the following command to download the certificate file:

wget -O /tmp/RHN-ORG-TRUSTED-SSL-CERT http://suse.manager.hostname/pub/RHN-ORG-
TRUSTED-SSL-CERT

If you need proxy access to SUSE Manager server, you can export the http_proxy environment
variable and thewget commandwill use the exported value.

Installing the self-signed certificate in SA trust store

1. Open the downloaded file, copy the following text appearing at the end of the file:

-----BEGIN CERTIFICATE-----
MIIE4TCCA8mgAwIBAgIJANwa5OFPkBHHMA0GCSqGSIb3DQEBCwUAMIGGMQswCQYD
haXhmbq+5pEkpxGAactW+tORsJmpgTdAXeq2rreYtgZ2/vCwdM0iwSVakGNFAvni
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T9lnSVrADcO/S8V/DzcH30RzSpIS44beE23zag82019fCrsZg9VkYJER4Fn0tRq4
6U9I4OgBSPSU34MXclGld0BAN+mANWHQYacZ7hHQJtMRP+mc8ZgHIvsKNnKRoHOd
Rhla7cP7GYrXn/piQAxRW66fOYJOeVIsAWJvgUb+A8ecwb+s6k56cQdLKkm0wKD0
2zUFMAg=
-----END CERTIFICATE-----

2. Open the /opt/opsware/openssl/cert.pem file in an editor and paste the copied text at the end of
the file.
The certificate will be installed in the SA trust store. Ensure that the openssl tool verifies the
SUSE Manager server certificate.

Verifying that OPSWopenssl is validating the server certificate

After the CA certificate is installed in SA trust store, verify if openssl validates the SUSE Manager
certificate before running the importer:

/opt/opsware/bin/openssl s_client -connect suse.manager.hostname:443 -verify 3

If the verification process is successful, the followingmessage will be displayed at the end of the
output:

Verify return code: 0 (ok)

If the verification fails, a non-zero value will be returned:

Verify return code: 21 (unable to verify the first certificate)

Configuring the SA SUSE Manager Importer
To run SA SUSE Manager Importer with a default configuration file, you have to create a configuration
file at

/etc/opt/opsware/sles_import/suse_manager.conf.

A configuration file template is available at /etc/opt/opsware/sles_import/suse_manager.conf-sample.

To create a configuration file:

1. Copy the sample configuration file to suse_manager.conf
cp /etc/opt/opsware/sles_import/suse_manager.conf-sample /etc/opt/opsware/sles_
import/suse_manager.conf

2. Provide write permission to theSuse_manager.conf file:
chmod u+w /etc/opt/opsware/sles_import/suse_manager.conf

3. Edit the /etc/opt/opsware/sles_import/suse_manager.conf file:
a. In the host option, provide the hostname/IP address of your SUSE Manager Server.

Note: If you have a custom port you can append ':<port number>’ to the IP address or
hostname. If port number is not provided, the importer uses the default HTTPS port which
is 443.

b. In the user and pass options, provide the user name and password of your SUSE Manager
Server.

c. Provide values to the opsware_user and opsware_password fields for configuring the SA
credentials.
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d. In the channel option, you can list the channels you want to import. If you are unsure what
values are valid, you can save the configuration file and run the following command:

/opt/opsware/sles_import/bin/suse_manager_import --show_labels

At this stage, the importer can access SA and your SUSE Manager to determine the default
supported labels. Later, you can come back and fill the channels option with valid values.
Channel labels can also be specified in the command line, provided that all required options
(that is SUSE Manager hostname, user and password) are defined in the configuration file. If
no label is provided in the command line or in the configuration file, then all default supported
parent channels will be imported.

Working of SUSE Manager Importer tool
The basis for SUSE Manager is the channel. A channel is a grouping of one or more packages
associated with a product repository. A patch released by SUSE is called as an erratum in SA and a
collection of these patches is called errata in SA.

Channels are of two types:

l Parent channels
l Child channels
Parent channels are usually, but not necessarily, associated with Pool repositories, whereas the
Updates repositories are considered as child channels of a Pool repository. In addition, there are other
types of child channels that are not Updates repositories.

Note: If you import a label into SA that is associated with the Pool channel, no erratum or errata
will be imported because Pool channels do not have patches associated with it. If you import a
label associated with the Updates channel, a channel software policy is created that contains all
packages from errata.

The SA SUSE Manager Importer supports both parent and child channels. The command line options
allow you to group all imported errata for a particular channel into a single software policy.

Usage of SUSE Manager Importer tool
The new importer binary (suse_manager_import) for SUSE Manager is located at /opt/opsware/sles_
import/bin.

Run the importer binary to group all imported erratum policies into a single errata policy:

/opt/opsware/sles_import/bin/suse_manager_import --mode=all [CHANNEL_LABEL...]

The --mode option specifies what to import. The all value specifies that you want to import packages
of a channel, create a Channel Software Policy in SA, import errata, and create Software Policies for
each erratum.

You can also choose:

l Channel imports packages from a repository and then creates a Software Policy
l Erratum imports patches and create software policies
l Errata imports all erratums and group them into a single software policy
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By default, suse_manager_import uses a configuration file located at /etc/opt/opsware/sles_
import/suse_manager.conf.

You can also specify another location for the configuration file using the --conf=FILE option.

To get the list of platforms supported by SA, run ./suse_manager_import --show_platforms.

To get the list of labels that are supported by default in SA and on your SUSE Manager Server, run
./suse_manager_import --show_labels.

SMT Importer tool
SubscriptionManagement Tool (SMT) is a package proxy system that is integrated with Novell
Customer Center/SUSE Customer Center (NCC/SCC). It provides a repository and registration target
that is synchronized with the NCC/SCC, allowing amore secure centralized deployment.

A repoindex file listing all the available repositories provided by SMT will be published in a public
location such as https://smt.hostname/repo/repoindex.xml. This file can be protected by a user name
and a password specified in /etc/smt.conf by mirrorUser and mirrorPassword attributes.

Following is an example of an repoindex.xml file, listing all the available repositories:

<repoindex>
<repo name="SLES12-Pool" alias="SLES12-Pool" description="SLES12-Pool for sle-12-
x86_64" distro_target="sle-12-x86_64" path="SUSE/Products/SLE-SERVER/12/x86_
64/product/" priority="0"pub="0" autorefresh="0" enabled="0"/>
<repo name="SLE10-SDK-SP4-Updates" alias="SLE10-SDK-SP4-Updates"
description="SLE10-SDK-SP4-Updates for sles-10-x86_64" distro_target="sles-10-x86_
64" path="$RCE/SLE10-SDK-SP4-Updates/sles-10-x86_64/" priority="0" pub="0"
autorefresh="1" enabled="0"/>
<repo name="SLES11-SP1-Pool" alias="SLES11-SP1-Pool" description="SLES11-SP1-Pool
for sle-11-i586" distro_target="sle-11-i586" path="$RCE/SLES11-SP1-Pool/sle-11-
i586/" priority="0"pub="0" autorefresh="0" enabled="0"/>
<repo name="SLE10-SDK-SP4-Pool" alias="SLE10-SDK-SP4-Pool" description="SLE10-SDK-
SP4-Pool for sles-10-x86_64" distro_target="sles-10-x86_64" path="$RCE/SLE10-SDK-
SP4-Pool/sles-10-x86_64/" priority="0" pub="0" autorefresh="0" enabled="0"/>
<repo name="SLES11-SP2-Updates" alias="SLES11-SP2-Updates" description="SLES11-SP2-
Updates for sle-11-ppc64" distro_target="sle-11-ppc64" path="$RCE/SLES11-SP2-
Updates/sle-11-ppc64/"priority="0" pub="0" autorefresh="1" enabled="0"/>

</repoindex>

where, path represents the relative location of a repository to https://smt.hostname/repo/. The path tag
can be configured per repository.

The repoindex file publishes both SCC and NCC synced repositories. Each repository path can be
protected by a user name and password. The requiredAuthType attribute from /etc/smt.conf enables
or disables the authentication.

User Guide: Server Patching
Server patching overview

HPE Server Automation (10.23.007) Page 300 of 307



Installing the SMT server certificate
By default, the importer binary smt_import validates the SMT server certificate. The remote server
certificate is self-signed, therefore there is no CA bundled with SA OSPWopenssl component. To
enable access for smt_import to SMT server, youmust install the self-signed server certificate in the
OSPWopenssl trust store.

To install the SMT server certificate:

1. Download the self-signed certificate from SMT server.
2. Install the self-signed certificate in SA trust store.
3. Verify OPSWopenssl is validating the server certificate.
Downloading the self-signed certificate from SMT server

You can download the certificate from the browser using the URL, http://<smt_host>/smt.crt. You can
also download the certificate from /srv/www/htdocs/smt.crt of the SMT server.

Installing the self-signed certificate in SA trust store

1. Open the downloaded file, copy the text appearing at the end of the file.
The following is an example of the text that appears at the end of the downloaded file:

-----BEGIN CERTIFICATE-----
MIIE4TCCA8mgAwIBAgIJANwa5OFPkBHHMA0GCSqGSIb3DQEBCwUAMIGGMQswCQYD
haXhmbq+5pEkpxGAactW+tORsJmpgTdAXeq2rreYtgZ2/vCwdM0iwSVakGNFAvni
T9lnSVrADcO/S8V/DzcH30RzSpIS44beE23zag82019fCrsZg9VkYJER4Fn0tRq4
6U9I4OgBSPSU34MXclGld0BAN+mANWHQYacZ7hHQJtMRP+mc8ZgHIvsKNnKRoHOd
Rhla7cP7GYrXn/piQAxRW66fOYJOeVIsAWJvgUb+A8ecwb+s6k56cQdLKkm0wKD0
2zUFMAg=
-----END CERTIFICATE-----

2. Open the /opt/opsware/openssl/cert.pem file in an editor and paste the copied text at the end of
the file.
The certificate will be installed in the SA trust store. Ensure that openssl tool verifies the SMT
server certificate.
Verifying that OPSWopenssl is validating the server certificate
After the CA certificate is installed in the SA trust store, verify if openssl validates the SMT server
certificate before running the importer:

/opt/opsware/bin/openssl s_client -connect smt.hostname:443 -verify 3

If the verification process is successful, the followingmessage will be displayed at the end of the
output:

Verify return code: 0 (ok)

If the verification fails, a non-zero value will be returned:

Verify return code: 21 (unable to verify the first certificate)

Configuring the SMT Importer
To run SMT Importer with a default configuration file, you have to create a configuration file at
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/etc/opt/opsware/sles_import/smt_import.conf.

A configuration file template is available at /etc/opt/opsware/sles_import/smt_import.conf-sample.

To create a configuration file:

1. cp /etc/opt/opsware/sles_import/smt_import.conf-sample /etc/opt/opsware/sles_
import/smt_import.conf

2. chmod u+w /etc/opt/opsware/sles_import/smt_import.conf

3. Edit the /etc/opt/opsware/sles_import/smt_import.conf file:
a. Provide values to the opsware_user and opsware_password fields for configuring the SA

credentials.
b. In the host option, provide the hostname/IP address of your SMT Server .

Note: If you have a custom port, you can append ':<port number>’ to the IP address or
hostname. If the port number is not provided, the importer can use the default HTTPS port
which is 443.

c. In theUser andPassword options, provide the user name and password of your SMT Server.
d. In the content_labels option, you can list the channels you want to import. If you are unsure

what values are valid, you can save the configuration file and run the following command:

/opt/opsware/sles_import/bin/smt_import --show_labels

At this stage, the importer can access SA and your SMT Server to determine the default
supported labels. Later, you can come back and fill in the content labels option with valid
values.
Content labels can also be specified in the command line, provided that all required options
(that is, the SMT hostname, user, and password) are defined in the configuration file. If no
label is provided in the command line or in the configuration file, then all default supported
content labels will be imported.

Working of SMT Importer
The basis for SMT is the content label. A content label is a grouping of one or more packages
associated with a product repository. A content label is just another name for a channel – content label,
which describes a repository sitting on a content deliverer (SMT in this case), while a channel is the
official descriptor (based on a remote official portal). Whatever the case, channel-based policies will be
created, one for each content label chosen. A patch released by SMT is called as an erratum in SA and
a collection of these patches is called errata in SA.

Note: If you import a label into SA that is associated with Pool channel, no erratum or errata will be
imported. This is because Pool channels do not have patches associated with them. If you import
a label associated with Updates channel, SA creates a channel software policy containing all the
packages from errata.

Content labels

When importing from SMT, smt_import uses content labels to identify the CDN content to import. The
format of the content label is the following:
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<entitlement_content_name>:<distro_target>

where:

l <entitlement_content_name> is the repository's name as specified in the repoindex.xml
l <distro_target> is the attribute for <entitlement_content_name> present under the same tag of
the repoindex.xml file.

To determine the label of the CDN content to import, run the following command: smt_import --show_
labels

Usage of SMT Importer
The new importer binary (smt_import) is located at /opt/opsware/sles_import/bin.

Run the following importer binary to group all imported erratum policies into a single errata policy:

/opt/opsware/sles_import/bin/smt_import --mode=all [CHANNEL_LABEL...]

The --mode option specifies what to import. The all value specifies that you want to import packages
of a channel, create a Channel Software Policy in SA, import errata, and create Software Policies for
each erratum.

You can also choose:

l Channel imports packages from a repository and then create a Software Policy.
l Erratum to import patches and create software policies.
l Errata to import all erratums and group them into a single software policy.

By default, smt_import uses a configuration file located at /etc/opt/opsware/sles_import/smt_
import.conf.

You can also specify another location for the configuration file using the --conf=FILE option.

To get the list of platforms supported by SA, run ./smt_import --show_platforms.

To get the list of labels that are supported by default in SA and on your SMT Server, run ./smt_import
--show_labels.

View errata-based and channel-based policies in the
SA Client
The suse_manager_import and smt_import tools allow you to create errata-based, erratum-based,
and channel-based policies in the SA Client. After successfully running them, you can view the
properties of errata-based, erratum-based, and channel-based policies in the SA Client. You can view
properties such as the SA user who created the software policy, the date when it was created, the
name, the description, the availability, the location of the policy in the Library, the operating systems
applicable to the policy and the SA Client ID of the software policy. We recommend that you do not edit
the policies created by the suse_manager_import and smt_import tools.

To view the properties of a software policy:

1. From the navigation pane, select Library > By Folder.
2. Select theSLES folder.
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3. From the content pane, select the errata, channel, or content-based policy and open it. The policy
window appears.

4. From theViews pane, select Properties. You can view the properties for the policy in the content
pane.

l Name: Contains the errata reference for the errata based software policy.

l Description: Includes all the errata documentation for the errata.

l Location: Specifies the location of the policy in the folder hierarchy. To change the location,
click Select to specify the location for the policy in the folder hierarchy. TheSelect Location
window appears. Select a folder in the Library to specify the location of the policy and then click
Select.

l Created: Corresponds to the time when the errata was downloaded by SA to create the
software policy.

l Last Modified: Corresponds to the time when the errata based policy was modified.

l Availability: Contains the SA server life cycle values for the errata based software policy. The
default value for an errata-based policy is set to Available.
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l Platform: Specifies the operating systems applicable to the errata. You can expand the list to
see the selected platforms.

5. To save the changes, select Save from the File menu.

Errata caching
When importing errata, theSA SUSE Import tools keep track of the imported errata. Details of each
imported erratum are stored in a cache file and subsequent runs will skip the cached errata completely.
This improves performance as it avoids calls to SUSE and to SA Library. In the absence of cached
data, these calls are beingmade even for errata that has not beenmodified and is up-to-date in the SA
Library. Errata that has beenmodified by SUSE is updated anyway so there is no danger of having
outdated errata after import.

A cache file is created for each channel (SUSE Manager Importer) and content label (SMT Importer).

The cache files are kept in the /var/opt/opsware/sles_import folder on the SA core server.The file name
uses the prev_import_ch_<label>.dat pattern, where <label> is the SUSE Manager Importer
channel label or the SMT content label.

Here are some sample file names:

l prev_import_ch_SLES12-SP1-Updates:sle-12-x86_64.dat
l prev_import_ch_sles12-pool-x86_64 .dat
As a result of the cachingmechanism described above, the following scenarios are possible:

l An erratum is imported into the SA Library and then it is removed, renamed, or moved to another
folder. When suse_manager_import and smt_import are run the next time, the erratum will not be
re-imported into the SA Library. This is because the erratum details are present in the cache file, so it
is skipped during the import.

l The errata roll-up policy is created and then it is removed, renamed, or moved to another folder (for
example, by using the SA Client). When suse_manager_import or smt_import are run the next
time, the errata roll-up policy will be recreated but it will contain only the errata that has been
previously published by SUSE.

Manage SUSE patches
The second phase of the SUSE Patchingmechanism – although optional, sometimes can be very
important in the patching process. Since SUSE patches are just normal RPM packages, you can do all
the operations that SA Client allows you to do on SUSE packages:

l Open the package
l Viewing and editing package properties
l Viewing package contents
l Viewing all software policies associated with a package
l Deleting a package
l Renaming a package
l Locating packages in folders
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Restricting access to RPM folders
SA builds a custom RPM repository for use by both SUSE Patchingmechanism and the software
management jobs. This is built on a server-by-server basis, taking into account several packages and
server properties and user-defined settings.

The repository that SA downloads to amanaged server before actually scanning the server for
recommended patches is built as follows:

l Packages whose platform set does not include the server platform are excluded from the RPM
repository.

l Packages in folders whose customer constraints do not include the customer of the server are
excluded from the RPM repository.

l If one or more repo.restrict custom attributes are defined for a particular server, only packages in the
folders specified by these custom attributes are included in the RPM repository.

In SA, you can specify in a custom attribute, the folders in the SA Library that the server has access to.
All other folders will be inaccessible to the server. This gives you folder-level control over which
versions of RPMs can be applied to a given server, allowing you to precisely manage platform update
versions, for example SLES 11 SP4 versus SP5.

Note: This is not intended as a user-level access control mechanism, but rather to restrict the
library and folder view of amanaged server from access to the full set of RPMs in the SA Library.
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Send Documentation Feedback
If you have comments about this document, you can contact the documentation team by email. If an
email client is configured on this system, click the link above and an email window opens with the
following information in the subject line:

Feedback on User Guide: Server Patching (Server Automation 10.23.007)

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a webmail client, and
send your feedback to hpe_sa_docs@hpe.com.

We appreciate your feedback!
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