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Before You Install

Welcome to WinRunner 2000, Mercury Interactive’s automated Year 2000 
testing tool for GUI applications, and mainframe and AS/400 applications 
running on 3270, 5250 and VT100 protocol terminal emulators. This guide 
describes everything you need to know to install WinRunner 2000 on 
Windows 95 or Windows NT 4.0, on a standalone computer or on a 
network.

Before you begin to install WinRunner 2000, review the following pre-
installation procedures.

Checking Your WinRunner 2000 Package

Make sure that your WinRunner 2000 package contains the items described 
below. If any items are missing or damaged, contact Mercury Interactive or 
your local distributor.

Program Disks

Your WinRunner 2000 package contains:

➤ 1 WinRunner 2000 CD-ROM

Documentation

In addition to this installation guide, your WinRunner 2000 package 
contains the following printed materials:

➤ WinRunner User’s Guide

➤ WinRunner Tutorial

➤ Testing Terminal Emulator Applications

➤ Testing for Year 2000 (If you did not purchase WinRunner 2000 Enterprise)

➤ QuickTest 2000 User’s Guide (if you purchased WinRunner 2000 Enterprise)
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➤ QuickTest 2000 Installation Guide (if you purchased WinRunner 2000 
Enterprise)

➤ Registration Card

System Configuration

In order to successfully run WinRunner 2000, you need the following 
minimum system configuration:

Platform An IBM-PC or compatible with a Pentium 
microprocessor.

Memory At least 16MB of RAM memory. For best performance, 
32MB is recommended.

Disk Space At least 34MB of free disk space for a minimum 
installation or 70MB for a typical or complete 
installation. (An additional 5MB of free disk space are 
required during the installation process.) Additional 
disk space is required if you install support for 
Terminal Emulator (3MB), PowerBuilder (1MB), or 
Visual Basic (8MB) applications.

Operating System Windows 95 or Windows NT 4.0

Installing on Windows NT

If you are installing WinRunner 2000 on a Windows NT machine, make sure 
you have administrator permissions before you run the setup program.
2
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Upgrading from a Previous Version

To upgrade from a previous version of WinRunner, we recommend that you 
first delete the existing WinRunner directories before running the setup 
program. Note that if you created a custom GUI configuration, you should 
ensure that your GUI configuration startup script is not deleted by saving it 
with your other WinRunner tests.

We recommend deleting any previous installations of WinRunner before 
installing WinRunner 2000 on your computer.

Note: If you are upgrading from a version number lower than 4.0, you must 
run the GUI Upgrade test on GUI map files. This test ports WinRunner 3.x 
GUI map files to WinRunner 2000, so that you can continue to use existing 
object descriptions while recording new tests. For more information, open 
the GUI Upgrade test (run_it) located in your WinRunner 2000 
installation\lib\upgrade directory.
3



WinRunner Installation Guide
Installing WinRunner 2000

You can install WinRunner 2000 on a local machine or on a network drive. 
Following are the main steps for each type of installation:

Standalone Installation

➤ Install WinRunner using the Standalone option.

➤ If you are testing a terminal emulator application, connect your terminal 
emulator to WinRunner 2000.

➤ If you are testing a Visual Basic application, configure Visual Basic support.

Network Installation

➤ Install WinRunner using a Network option.

➤ Run the workstation installation on each user workstation.

➤ If you are testing a terminal emulator application, connect each terminal 
emulator to WinRunner 2000.

➤ If you are testing a Visual Basic application, configure Visual Basic support.
4
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To install WinRunner:

 1 Insert the CD-ROM into the drive from which you want to install. If the CD 
drive is on your local machine, the WinRunner Setup window opens. If you 
are installing from a network drive, connect to it and run autorun.exe under 
the \setup subdirectory.

If you want to view the Readme file, click Readme. If you want to browse the 
WinRunner Installation CD, click Browse.

 2 Click Install. The WinRunner setup program starts. The WinRunner Setup 
splash screen and the Setup progress bar open.

 3 The software license agreement appears. To accept the terms of the license 
agreement, click Yes. If you click No, the setup program will close. To install 
WinRunner 2000, you must accept the license agreement.
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 4 In the Registration Information dialog box, type your name, the name of 
your company, and a WinRunner 2000 serial number. You can find this 
number on the outside of your WinRunner 2000 box.

Once you enter the information, the Next button is enabled. Click Next to 
proceed.

 5 Click Yes to confirm the registration information.
6
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 6 Do one of the following:

➤ To install on a hard disk of a single computer, select Standalone Installation.

➤ To install on a network drive, select Network installation.

➤ To install on a network drive and configure your workstation to run 
WinRunner from the network, select the third option.

Note: You cannot install a network installation over a previous version of 
WinRunner or WinRunner 2000.

Click Next to proceed.
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 7 If relevant, install additional support for Visual Basic applications, 
PowerBuilder applications, terminal emulators, or ActiveX controls. 

Note: Do not install Terminal Emulator support along with other support 
components. 

Note: Do not install unnecessary support components.

Click Next to proceed.
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 8 Choose the type of installation: Typical, Compact, or Custom.

Typical Installation installs commonly-used program files, including online 
documentation and samples.

Compact Installation installs only the required WinRunner 2000 program 
files, without online documentation or samples.

Custom Installation enables you to select the components you want to 
install.

Click Next to proceed.
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 9 If you chose Custom Installation, select the components you want to install.

Click Next to proceed.
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 10 If you chose Typical or Compact Installation, specify the location where you 
want to install WinRunner. To check the space available on another disk 
drive, click Disk Space. 

Click Next to proceed.
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 11 If you selected Network Installation and add shortcuts to your Start menu 
earlier in the setup, select a location for the local WinRunner folder. This 
folder will allow you to configure WinRunner to meet your specific testing 
requirements, while running a shared version over the network.

Click Next to proceed.
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 12 Choose the location of your WinRunner temporary folder.

Click Next to proceed.

 13 Review the settings you selected. To select different settings, click Back. To 
confirm the settings, click Next.

The installation process begins. To pause or quit the installation process, 
click Cancel.
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 14 Select the program folder for the WinRunner 2000 icons. 

Click Next to proceed.

 15 If you did not choose to install support for terminal emulator applications, 
the Year 2000 Configuration dialog box opens:
14
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Define the date format style (US or European) and the date conversion mode 
used by the application you want to test:

➤ Windowing (the converted date field remains two digits in length). For 
example, “98” remains “98”.

➤ Field Expansion (the converted date field is expanded to four digits). For 
example, “98” is expanded to “1998”.

Click OK to proceed.
15
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 16 If you installed a standalone installation or a network installation that 
added shortcuts to your Start menu and you installed support for terminal 
emulator applications, select whether your terminal emulator is 16-bit or 32-
bit. 

Click Next to proceed.
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 17 Define the date format (US or European) and the date conversion mode used 
by the application you want to test:

➤ Windowing (the converted date year field remains two digits in length)

➤ Field Expansion (the converted date year field is expanded to four digits)

Click Next to proceed.
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 18 Select your terminal emulator type. (Depending on whether you selected a 
32-bit or a 16-bit terminal emulator, refer to the appropriate window below.) 
If the current version of your terminal emulator is not displayed, select 
Other VT100.

Click Next to proceed.
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Click Next to proceed.
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 19 Set the emulator EHLLAPI DLL, using the Find or the Browse buttons.

The table below lists the file names used by terminal emulators for the 
EHLLAPI DLL.

Click Next to proceed.

Emulator 16-Bit EHLLAPI DLL 32-Bit EHLLAPI DLL

Rumba eehllapi.dll ehlapi32.dll

Extra, Irma acs3ehap.dll ehlapi32.dll

IBM Personal Communications pcshll.dll pcshll32.dll

Eicon ehllapi.dll

NetSoft Dynacomm/Elite hllapi.dll whllapi.dll

Reflection hllapi32.dll
20



Installing WinRunner 2000
 20 If you selected Other VT100 as your terminal emulator type, enter the 
classes, as described in the table below. To enter a class, either type it in a 
text box or click an Anchor button, drag the anchor to a window or a 
toolbar, and release the mouse.

Click Next to proceed.

Class Description

Main window class The class of the terminal emulator’s main window 
(you must set a value for this option)

Terminal window class The class of the terminal emulator’s text window 
class (client area). (This is the area where text is 
displayed and can be the same as the main 
window.)

Toolbar class The class of the terminal emulator’s toolbar

Statusbar class The class of the terminal emulator’s statusbar
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 21 Define the screen size and screen alignment of the terminal emulator.

Click Finish to proceed.

 22 Read the information about accessing online documentation. If you 
installed additional support for Visual Basic, more information appears on 
your screen. Click Next to proceed.

 23 Read the information about Mercury Interactive’s Customer Support. Click 
Next to proceed.
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 24 The installation process is complete. If you installed WinRunner 2000 on 
your hard disk (Standalone option), you need to restart your computer. If 
you installed WinRunner on the network, run a workstation installation on 
all workstations. See the next section for details.

➤ To read what’s new in WinRunner 2000 and any last-minute information, 
click Programs > WinRunner 2000 > Read Me on the Start menu.

➤ To view the WinRunner online books, you must have Acrobat Reader 3.01 
installed. You can install it by clicking Programs > WinRunner 2000 > 
Documentation > Acrobat Reader 3.01 Setup on the Start menu. To view 
online books, click Programs > WinRunner 2000 > Documentation > 
WinRunner 2000 Books Online on the Start menu.

➤ To start WinRunner 2000, click Programs > WinRunner 2000 > 
WinRunner 2000 on the Start menu.
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Running a Workstation Installation

A workstation installation should be performed for each user running 
WinRunner 2000 from the network. This installation can be performed only 
after the network installation is successfully completed. 

 1 Choose Run on the Start menu.

 2 Type installation_directory\setup\setup.exe and click OK.

The WinRunner 2000 setup program starts. The WinRunner Setup splash 
screen and the Setup progress bar open.

 3 The software license agreement appears. To accept the terms of the license 
agreement, click Yes. If you click No, the setup program will close. To install 
WinRunner 2000, you must accept the license agreement.

 4 In the Registration Information dialog box, type your name and click Next 
to proceed.

 5 Click Yes to confirm the registration information.

 6 Confirm the Workstation Installation message and click Next.

 7 Define the location for the local WinRunner 2000 folder.

The WinRunner 2000 folder on your hard drive is used to store 
configuration files you create during the testing process. Configuration files 
in this folder override configuration files of the same name on the network. 
This enables you to configure WinRunner 2000 to meet your specific testing 
requirements while running a shared version over the network.

Click Next to proceed.

 8 Select the location for the local WinRunner 2000 temporary folder.

Setup updates and installs system files.

Click Next to proceed.
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 9 Select the program folder for the WinRunner 2000 icons.

Click Next to proceed.

 10 If you did not install support for terminal emulator applications, the Year 
2000 Configuration dialog box opens:
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Define the date format style (US or European) and the date conversion mode 
used by the application you want to test:

➤ Windowing (the converted date field remains two digits in length). For 
example, “98” remains “98”.

➤ Field Expansion (the converted date field is expanded to four digits). For 
example, “98” is expanded to “1998”.

 11 If you installed support for terminal emulator applications, select whether 
your terminal emulator is 16-bit or 32-bit.

Click Next to proceed.
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 12 Define the date format (US or European) and the date conversion mode used 
by the application you want to test:

➤ Windowing (the converted date year field remains two digits in length)

➤ Field Expansion (the converted date year field is expanded to four digits)

Click Next to proceed.
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 13 Select your terminal emulator type. (Depending on whether you selected a 
32-bit or a 16-bit terminal emulator, refer to the appropriate window below.) 
If the current version of your terminal emulator is not displayed, select 
Other VT100.

Click Next to proceed.
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Click Next to proceed.
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 14 Set the emulator EHLLAPI DLL, using the Find or the Browse buttons.

The table below lists the file names used by terminal emulators for the 
EHLLAPI DLL.

Click Next to proceed.

Emulator 16-Bit EHLLAPI DLL 32-Bit EHLLAPI DLL

Rumba eehllapi.dll ehlapi32.dll

Extra, Irma acs3ehap.dll ehlapi32.dll

IBM Personal Communications pcshll.dll pcshll32.dll

Eicon ehllapi.dll

NetSoft Dynacomm/Elite hllapi.dll whllapi.dll

Reflection hllapi32.dll
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 15 If you selected Other VT100 as your terminal emulator type, you are 
prompted to enter the classes, as described in the table below. To enter a 
class, either type it in a text box or click an Anchor button, drag the anchor 
to a window or a toolbar, and release the mouse

Click Next to proceed.

Class Description

Main window class The class of the terminal emulator’s main window 
(you must set a value for this option)

Terminal window class The class of the terminal emulator’s text window 
class (client area). (This is the area where text is 
displayed and can be the same as the main 
window.)

Toolbar class The class of the terminal emulator’s toolbar

Statusbar class The class of the terminal emulator’s statusbar
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 16 Define the screen size and screen alignment of the terminal emulator.

Click Finish to proceed.

 17 Read the information about accessing online documentation. If you 
installed additional support for Visual Basic, more information appears on 
your screen. Click Next to proceed.

 18 Read the information about Mercury Interactive’s Customer Support. Click 
Next to proceed.
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 19 Restart your computer. The WinRunner 2000 program folder is added to 
your Start menu.

➤ To read what’s new in WinRunner 2000 and any last-minute information, 
click Programs > WinRunner 2000 > Read Me on the Start menu.

➤ To view the WinRunner online books, you must have Acrobat Reader 3.01 
installed. You can install it by clicking Programs > WinRunner 2000 > 
Documentation > Acrobat Reader 3.01 Setup on the Start menu. To view 
online books, click Programs > WinRunner 2000 > Documentation > 
WinRunner 2000 Books Online on the Start menu.

➤ To start WinRunner 2000, click Programs > WinRunner 2000 > 
WinRunner 2000 on the Start menu.
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Connecting a 32-Bit Terminal Emulator to 
WinRunner 2000

After you run the WinRunner 2000 setup program, you must connect your 
32-bit Rumba 5.1/5.2, Extra 6.3/6.4, IBM Personal Communications 4.1/4.2 
or NetSoft Elite 2.21-3.11 terminal emulator to WinRunner 2000.

Rumba 5.1 or Higher

If you are working with Rumba 5.1 or higher, before you can connect to 
WinRunner 2000 you must edit your wrun.ini file under the
[TermRun-CurrentEmulator] section, and change the standard=1 line to 
standard=0. For more information, consult Mercury Interactive Customer 
Support.

To connect your Rumba 5.1 (or higher) terminal emulator to WinRunner 
2000:

 1 Load Rumba 5.1 (or higher).

 2 On the Options menu, choose API. The API Options dialog box opens.

 3 Click the Identification tab.

 4 In the Short Name field, type the uppercase letter A for the first session. For 
subsequent sessions, use consecutive uppercase letters in the alphabet.

 5 Click OK.

 6 Save the profile when you exit Rumba.
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Extra 6.3 or Higher

To connect your Extra 6.3 (or higher) terminal emulator to WinRunner 
2000:

 1 Load Extra 6.3 (or higher).

 2 On the Options menu, choose Global Preferences. The Global Preferences 
dialog box opens.

 3 Click the Advanced tab.

 4 Choose a Short Name and use Browse to select a session profile.

 5 Save the profile when you exit Extra.

NetSoft Elite 2.2x or Higher

To connect your NetSoft Elite 2.2x (or higher) terminal emulator to 
WinRunner 2000:

 1 Load NS/Administrator.

 2 Select Mainframe Workspace for 3270 or Midrange Workspace for 
AS400/5250.

 3 Right-click the appropriate display icon and choose Properties on the menu.

 4 In the Short Name field, type any uppercase letter from A to Z.

 5 Click OK.

 6 Exit NS/Administrator.

 7 Load the NetSoft Display session.

 8 On the View menu, activate Auto Font Size and Auto Window Size.

 9 In the Tools menu, choose Keyboard to remap the default keys for New Line 
(Ctrl Right) and Reset (Ctrl Left). These keys conflict with WinRunner 2000 
softkeys.
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Reflection 6.2

To connect your Reflection 6.2 terminal emulator to WinRunner 2000:

 1 Load Host-Mainframe or AS400.

 2 In the Setup menu, select Terminal.

 3 In the Short Name field, type any uppercase letter from A to Z.

 4 Click OK.
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Connecting a 16-Bit Terminal Emulator to 
WinRunner 2000

After you run the WinRunner 2000 setup program, you must connect your 
16-bit Rumba terminal emulator to WinRunner 2000. Note that if you are 
using another 16-bit terminal emulator, you do not need to connect it to 
WinRunner 2000.

Rumba

If you are working with Rumba, before you can connect to WinRunner 2000 
you must choose a special configuration option in the WinRunner 2000 
setup program. In the setup program, select the Standard option in the 
Miscellaneous dialog box. For more information, consult Mercury 
Interactive Customer Support.

To connect your Rumba terminal emulator to WinRunner 2000:

 1 On the Rumba Session menu, choose EHLLAPI Configuration. The EHLAPPI 
Configuration dialog box opens.

 2 Make sure that the EHLLAPI SDK check box is selected.

 3 Choose a Short name by typing in any uppercase letter from A to Z.

 4 Click OK.

 5 Choose Preferences > Mouse Options on the Rumba Options menu. The 
Mouse Options dialog box opens.

 6 Make sure that the Cursor Position operation is set to the Left Button Click 
Mouse Action. Select OK to close the dialog box.
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Configuring Visual Basic 4.0 Support

Before you can start using WinRunner's extended support for Visual Basic 
4.0 in Windows 95, Windows 98, or Windows NT Visual Basic applications 
(32-bit), you need to compile the WinRunner OCX (wrvb40.ocx) in the 
application under test.

To configure 32-bit Visual Basic 4.0 support:

 1 Start Visual Basic 4.0 and open the project.

 2 Select the Custom Controls command from the Tools menu.

 3 In the Custom Controls dialog box, select the Wrvb40 OLE Custom Control 
Module item. Click OK. The item is added to the toolbar.

 4 Drag the new item onto the main application form.

 5 Right-click this object and select View Code.

 6 Select Form from the Object pulldown.

 7 Insert the following line into the beginning of the Form_Load function: 

Wrvb1.Init Forms

For example:

Private Sub Form Load ()
...
Wrvb1.Init Forms
...
End Sub

 8 Run or recompile your application and run the .exe file.
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Enabling Table Contents Checks for an OCX Control

To enable support for contents verification on any OCX that can be viewed 
as a table object, you must implement a capture function for the OCX in 
Visual Basic and then execute a TSL function.

WinRunner includes Visual Basic project files (wrvbsrv4.vbp for Visual Basic 
4.0 and wrvbsrv5.vbp for Visual Basic 5.0) that compile into an OLE 
Automation Server. WinRunner uses this server to capture table contents. 

Follow these steps to enable contents verification on an OCX that can be 
viewed as a table object:

 1 Start Visual Basic 4.0 or Visual Basic 5.0.

 2 In Visual Basic, open the appropriate wrvbsrv project file (wrvbsrv4.vbp or 
wrvbsrv5.vbp) located in the WinRunner installation folder under 
custom\wrvbsrv.

 3 Open capture.cls and add a Sub with the following prototype:

Public Sub<CaptureFunctionName>(ByVal <tab_ctrl> As Object, ByVal 
<file_name> As String)

The function should dump the table contents of the OCX control into 
<file_name> in the following format:

cells separated by Tab(Chr(9)), rows separated by Newline.

Note: Cell data should not contain escape characters such as Tabs or 
Newlines. Cells in the first row (Column Titles) should not contain either 
escape characters or space characters. See the MSGridCapture Sub for an 
example.

 4 Compile the project into a dll.

For Visual Basic 4.0, from the File menu select Make OLE DLL file.

For Visual Basic 5.0, from the File menu select Make WRVBSRV DLL file.
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 5 In WinRunner, execute the ole_add_class_to_gui_ver TSL function. Set the 
“Table Capture” argument to the name of the Sub you implemented in the 
Visual Basic function. For example:

ole_add_class_to_gui_ver ("MSGrid.Grid", "Enabled", "MSGridCaptureFunc");

For more information on ole_add_class_to_gui_ver, refer to the TSL Online 
Reference.
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Configuring Visual Basic 5.0 Support

WinRunner’s add-in support for Visual Basic 5.0 applications includes all the 
support provided for Visual Basic 4.0 applications, plus:

➤ all standard Visual Basic 5.0 controls

➤ Visual Basic projects that create ActiveX controls

Preparing Your Visual Basic Application

Before you can start testing a Visual Basic application using WinRunner’s 
add-in support for Visual Basic 5.0, the application developer must add the 
WinRunner agent to the application. To do so, the developer runs the 
setup.exe program from the \vbdev directory on the WinRunner 
installation CD-ROM.

Note that if the application currently references the WinRunner OCX, you 
must first remove all references from forms, as well as the associated code 
(Wrb1.Init Forms).

The WinRunner agent installation installs an AddIn to your Visual Basic 
IDE. The name of this AddIn is WinRunnerAddIn.Connect. It adds lines of 
code to your Visual Basic source code.

WinRunnerAddIn.Connect

➤ adds a reference to the wrvbasr.dll component

➤ adds a new code Module to the Visual Basic project called 
“WinRunnerSupport”

➤ adds a line to the WinRunnerSupport Module:

Global asr As New WRVBASRLib.VbMod
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➤ adds code to the StartUp object:

If the Startup Object is a Form, the AddIn adds the following line of code to 
the Form_Load event:  asr.Init Forms

If the Startup Object is Sub Main, the AddIn adds the following line of code 
to the Main() method:  asr.Init Forms

➤ For all Class modules in the project, the AddIn adds the following line of 
code to the Class_Intialize event:  asr.Init Forms

➤ For all UserControl modules in the project, the AddIn adds the following 
line of code to the UserControl_Intialize event: asr.Init Forms, UserControl

➤ For all UserDocument modules in the project, the AddIn adds the following 
line of code to the UserControl_Intialize event: asr.Init Forms, UserDocument

Notes: If the error message “DllRegisterServer in <windows 
directory>\system\wrvbasr.dll failed” appears during the WinRunner agent 
installation, copy the file oleaut32.dll (version 2.20.4054.1 or higher) to 
your system directory and re-install the WinRunner agent. 

Do not run WinRunner and the Visual Basic IDE together.

Test your application only as a running executable.
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Adding WinRunner 2000 Components

Once you install WinRunner 2000, you can run the setup program at any 
time to add program components, such as development environment 
support, samples and online documentation.

To add components:

 1 If you originally installed WinRunner 2000 from the CD-ROM, insert the 
CD-ROM into the drive from which you want to install. If you installed 
WinRunner 2000 from a network, connect to the network location.

 2 Run the setup program and follow the instructions on screen.

 3 In the Installation Type screen, choose Custom Installation. Then select the 
components you want to add.

 4 If relevant, in the Additional Support screen, select the additional support 
you want to add.

Note: Do not install Terminal Emulator support along with other support 
components. 

Note: Do not install unnecessary support components
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