SLA status is wrongly marked as "not completed" in the test and as "no data" in the HTML report although SLA is defined for the test

  • KM02768874
  • 05-Apr-2017
  • 05-Apr-2017

Summary

A test with defined SLA has an wrong SLA status marked as "not completed" in the test and as "no data" in the HTML report. The issue is caused by unsupported special characters in the transaction names.

Error

After a test with defined SLA (service level agreement) is analised the SLA status is wrongly marked as "not completed".

In the HTML report the SLA status of the transactions with defined SLA are incorrectly marked as "no data" although the transaction response times shows that the SLA status should be passed.

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Cause

One or more of the transactions contain a special character in the name. Transaction names must be unique and may contain letters or numbers.

 

Fix

To overcome the problem do not use scripts which contain transactions with special characters: . , : # / \ " < & etc.

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