Upgrading all agents (e.g. to 8.8.5) can cause a rapid loss of free space, as Agents apprear to resend PST files.

  • KM02730605
  • 13-Feb-2017
  • 13-Feb-2017

This document has not been formally reviewed for accuracy and is provided "as is" for your convenience.

Summary

When agents are upgraded several revisions at once to a new agent version, it is likely that EMO-enabled agents will re-optimize PST files and resend all constituent files (*.CMF and *.ATCH files). This resending is necessary due to bugs fixed in the new agent version and is the only way to ensure that all PST data is protected.

Error

While Compactor service may also log events in the DCMaint Event Log, the following warnings & errors can be expected if free space on Customers volumes decreases sufficiently.
  • BackupServer Warning Event ID 5170: 'Backup sessions are temporarily disabled because the free archive disk space is less than the "Minimum Disk Free Space on Backups" setting of nnnnnn.'
BackupServer will stop accepting backups when total space in Customers volumes drops below the minimum MB limit specified in DCMC > Properties > BackupServer.
  • Agent fails backup, logging (a) Error: "Not enough disk space for backup" and (b) Diagnostic: "NAK code 21" from BackupServer.
Until the low space condition is remediated, agents either fail to backup and log the error "Not enough disk space for backup", or in a mirrored configuration will attempt connection with the assigned Secondary server.

Cause

Several defects which affected optimization of PST file backup have been fixed in recent versions (e.g. including 8.8.5.) However, due to the nature of some defects it is not possible for any agent version to selectively send only missing data.  Rather, PST files are completely re-optimized and resulting constituent files are sent to ensure that each PST is protected. This can cause an unexpected influx of data, which may threaten storage capacity.

Fix

To mitigate such rapid storage consumption due to this issue, customers can take either or both of the following actions.
a. Mange agent deployment:  Slow the agent upgrade project using a phased approach -- upgrade 10-20% of the users at one time and allowing time before continuing to upgrade the next 'batch' of users. Determine when to continue by monitoring the disk space consumed by the first phase of upgraded agents.

b. Manage archive storage:  Increase archive disk space by increasing storage capacity of existing volumes, or by adding new Volume(s) to the datacenter to keep pace with consumption.

Ultimately, Compactor service will reduce the "extra" space consumed when it successfully processes each account, by enforcing expiration rules as specified in Data Center Management Console.

Contact Connected Backup Support to discuss your circumstances and determine if there are alternative approaches to mitigate this situation.