PC server is unable to connect to ALM DB

  • KM02709218
  • 25-Jan-2017
  • 25-Jan-2017

Summary

view test scripts feature in the ALM website fail and throw the following error: failed OpenConnection: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - No connection could be made because the target machine actively refused it.)

Error

 view test scripts feature in the ALM website fail and throw the following error:
image text

failed OpenConnection: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - No connection could be made because the target machine actively refused it.)

Login Lab Management->Performance Center->System Health->Check System,  the connectivity between PC server and database is also failed.

The same error also can be found from the PC Server log in <PC Server Installation>\orchidtmp\LTLogger\w3wp\log.txt



 

Cause

ALM server and DB are installed on the same machine, and localhost or 127.0.0.1 is used in the DB connection string.

Fix

Login Site Administration, goto DB servers tab, check the Connection String. If ALM server and database are installed on the same machine and localhost or 127.0.0.1 is used in the Connection String, PC server is unable to connect DB. Use the IP address or host name of the DB instead of localhost or 127.0.0.1. Do the same in Lab Management tab and Site Projects tab to modify the Connection String for Lab Project and Projects.