LncmError seen when attempting to install/update lnc on a SA core

  • KM02699957
  • 10-Jan-2017
  • 14-May-2021

Archived Content: This information is no longer maintained and is provided "as is" for your convenience.

Summary

When attempting to install or update the HPLN lnc software on a SA core, a LncmError regarding the password is seen.

Error

When attempting to install (or upgrade an existing installation of) the HP Live Network (HPLN) / Live Network Connector (lnc)
software on a SA core the following error message is seen after supplying information to all of the installation prompts...

[LncmError] password required
Installation failed!

The system prompt is returned, and HPLN / lnc will not work. 

Cause

The error is caused because the HPLN password supplied during the installation is not recognized.
The most common issue is that the password contains a space (spaces are allowed in the
password when setting up the HPLN account on the HPLN website (hpln.hpe.com).  You can
see if there's a space (or some other special charactor) causing a problem with the installation
script recognizing the password supplied by looking in the /var/log/opsware/hpln/hpln.log file.

At the time of the installation attempt, there will be entry in the logfile that shows the password
being used for the installation.. if the value for the password shown is only partially obscured by
"*" charactor this indicates that a special charactor encountered was encountered.

For example, during the installation/upgrade of the lnc code, the HPLN username of john.doe@somecompany.com
is used along with the HPLN password of 123baby blues

After the error is encountered, looking in /var/log/opsware/hpln/hpln.log there will be an entry like the following
seen..

<date> <time>  live-network-connector:NOTICE  : Running LNc command: /opt/opsware/hpln/lnc/lib/live-network-connect
or.pyc write-config --username=john.doe@somecompany.com --password=******* blues

This indicates that the special charactor that wasnt recognized (in this case a whitespace) occurred right before the pattern
of "blues" seen in the log message.  In a successful installation attempt, the entire password would be obscured by
the "*" charactors.

Fix

To address the issue, simply enclose the HPLN password in double-quotes.  For instance, in the
previous example entering in "123baby blues" (with the double-quotes), the installation script will
not fail.  Alternately, going to the HPLN website and changing the user's password to something
not containing the special charactor (causing the script to fail) is also an option.