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Welcome to This Guide

Welcome to the HPE Release Control Deployment Guide, which explains how to install and deploy
HPE Release Control software and how to upgrade to the latest version. HPE Release Control
provides a common platform of decision support for Change Advisory Board members and
implementation teams during the release life cycle. HPE Release Control analyzes each change
request in the system and provides real-time information and alerts during implementation. In addition,
HPE Release Control enables collaboration, feedback, and review throughout the release life cycle.

This chapter includes:

How This Guide Is Organized ........ ... ... .. L 6
Who Should Read This Guide ... ... .. L 6
Release Control Documentation ... ... . .. i 7
Additional Online RESOUICES ... ... ... .o e 7

How This Guide Is Organized

This guide contains the following parts:

« "Installing and Deploying HPE Release Control" on page 9
Provides instructions on how to install and deploy HPE Release Control.
» "Upgrading HPE Release Control" on page 50

Provides instructions on how to upgrade to the latest version of HPE Release Control.

Who Should Read This Guide

This guide is intended for the HP service engineers who are responsible for installing and deploying or
upgrading HPE Release Control.

HPE Release Control (9.50) Page 6 of 67



Deployment Guide
Welcome to This Guide

Release Control Documentation

HPE Release Control comes with the following documentation:

HPE Release Control Deployment Guide explains how to install and deploy HPE Release Control.
This guide is accessible in the following formats, from the following locations:

« in PDF format in the HPE Release Control installation package
« in PDF format by selecting Help > Documentation Library from the HPE Release Control

application

HPE Release Control User Guide explains how to use and configure the HPE Release Control
application. This guide is accessible in the following formats, from the following locations:

« in PDF format in the HPE Release Control installation package

« inboth PDF format and online HTML help format by selecting Help > Documentation Library
from the HPE Release Control application

« in HTML help format, from specific HPE Release Control application windows, by clicking in the
window and pressing F1, or by selecting Help from the main menu

HPE Release Control APl Reference explains how to work with HPE Release Control's API. The
API Reference is available in CHM format in the HPE Release Control installation package, or from the
HPE Release Control application by selecting Help > Documentation Library.

HPE Release Control Release Notes provides information on what's new in the current version of the
product as well as comprehensive information on known problems and limitations. The Release Notes
is available in HTML format in the HPE Release Control installation package.

Note: Anything published in PDF format can be read and printed using Adobe Reader, which can
be downloaded from the Adobe Web site (http:/ /www.adobe.com).

Additional Online Resources

HPE Software Support accesses the HPE Software Support web site. This site enables you to
browse the Self-solve knowledge base. You can also post to and search user discussion forums,
submit support requests, download patches and updated documentation, and more. Choose Help >
HPE Software Support.
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Most of the support areas require that you register as an HPE Passport user and sign in. Many also
require a support contract. To find more information about access levels and register foran HPE
Passport user ID, go to the HPE Software Support web site as well.

HPE Software Web site accesses the HPE Enterprise Software web site. This site provides you with
the most up-to-date information on HPE Software products. This includes new software releases,
seminars and trade shows, customer support, and more. Choose Help > HPE Software Web site.
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Installing and Deploying HPE Release
Control

This chapter provides instructions on how to install and deploy HPE Release Control.

This chapter includes:

The Deployment Process: Basic Steps ... ... ... i 9
Before You Install . .. 10
Installing HPE Release Control ... .. 13
Configuring the Database or UserSchema ... ... . ... ... ... ... 14
ConfiguNG JRE L 17
Launching HPE Release Control ... .. 19
Configuring the HPE Release Control Server ... ... . 20
Configuring HPE Universal CMD B .. 21

Configuring HPE Release Control to Work with a Different Version of HPE Universal CMDB .22

Configuring the Service Desk Integration ... .. 24
Configuring Web Server .. 44
Accessing HPE Release Control through Server Reverse Proxy .................................. 46
Working with HPE Release Control Configuration Settings ... ... ... .......... 47
Uninstalling HPE Release Control ... ... 49

The Deployment Process: Basic Steps

This following diagram describes the basic steps involved in getting your HPE Release Control

environment up and running:

1.

Review pre-installation information (see "Before You Install" on the next page)

2. Runtheinstallation (see "Installing HPE Release Control" on page 13)

3. Set up the database (see "Configuring the Database or User Schema" on page 14)
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Launch (see "To configure your database on Linux")
Configure the server (see "Configuring the HPE Release Control Server" on page 20)

Configure related settings (see "Configuring HPE Universal CMDB" on page 21)

N o o &

Configure the service desk (see "Configuring the Service Desk Integration" on page 24)

Before You Install

HPE strongly recommends you to review the Release Control 9.50 Support Matrix carefully before you
install HPE Release Control.

This section includes:

Server System Requirements .. 10
Client Requirements .. il 10
HPE Release Control Advanced Deployment Options ... ... ... 11
HPE Release Control Data Flow . ... ... .. .. . 11
System ArchitectUre .. 12

Server System Requirements

The following table describes the system requirements for the HPE Release Control server:

CPU Intel Pentium 4
Memory (RAM) | Minimum of 2 GB

Free Disk Space = Minimum of 5 GB

For more server system support information, including operating system, database, web server and so
on, refer to the HPE Release Control Support Matrix.

Client Requirements

The following table describes the client requirements for viewing HPE Release Control:
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Internet IPv4, IPv6
Protocol

Screen Minimum 1024x768

Resoluti

esoltion Recommended 1280x1024
Color Minimum of 16 bit
Quality

Note: If you are logging on to the HPE Release Control server through a remote
connection, ensure that the Remote Desktop color display setting is settoa
minimum of 16 bit.

For more client support information, including web browser, Flash Player browser plugin and so on,
refer to the HPE Release Control Support Matrix.

HPE Release Control Advanced Deployment
Options

In addition to the regular deployment, HPE Release Control can also be deployed with the following

options:
o Cluster deployment. HPE Release Control can be deployed on multiple nodes. For details, refer to
the section about setting up a cluster deployment in the HPE Release Control User Guide.

« Web servers. You can configure HPE Release Control to work with a Web server. For details, refer
to the section about configuring a Web server in the HPE Release Control User Guide.

« Identity management. You can configure HPE Release Control to work with a third party identity
management solution such as CA SiteMinder. For details, refer to the section about identity
management in the HPE Release Control User Guide.

HPE Release Control Data Flow

The following diagram illustrates the data flow when running HPE Release Control:
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Setvice Desk Aoplication Reguests

Change Appraovalf HPE Release Control Email
Fejedion Application Notifications

G eneric Reguest
for Change

R C Database
Server

Lo ISR

Impact Analysis

« Change requests originate in the Service Desk application and are converted into generic requests.

« HPE Release Control sends the requests to HPE Universal CMDB for analysis and to determine
the relationships between configuration items (Cls).

« HPE Release Control takes the data from HPE Universal CMDB and performs impact analysis.

« HPE Release Control further analyzes change requests, performing calculations such as risk and

collision analysis.
o Theinformation is stored on the HPE Release Control Database Server.

« Email notifications are sent according to configuration settings to decision makers, and changes are
approved or rejected.

System Architecture

HPE Release Control is a 3-tier application which consists of following:
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« Flash-based (fat) client, accessed using a Web browser
« Application servers

« Database servers

The database servers and the HPE Release Control application servers must locate in high bandwidth
and low latency network paths, which connect to the database server.

Installing HPE Release Control

You can install HPE Release Control using the InstallShield Wizard for HPE Release Control on
Windows. Or you can run a series of shell commands to install HPE Release Control on Linux.

To install HPE Release Control on Windows:

1. Click the setup-9.50.0001.exe file located in the Setup folder of your HPE Release Control
installation package. The InstallShield Wizard for HPE Release Control opens. Click Next.

2. Accept the terms of the software license agreement that is displayed. Click Next.

3. Accept the default installation directory or click Browse to select a different directory.
Note: The directory you select cannot contain spaces.

Click Next.
4. Ensure that the information in the summary screen is correct.

To review or change any settings, click Back. To accept the settings and begin installing
HPE Release Control, click Next.

5. When the installation process has successfully been completed, click Finish in the final
InstallShield Wizard screen.

Note: If you are in the middle of performing the upgrade procedure, continue with step 2 of "Stage
2: Install and Upgrade HPE Release Control" on page 52.

Toinstall HPE Release Control on Linux:

1. Copy release-control-9.50.0001.x86_64.rpm.bin to the target computer. The file resides in the
Setup folder of HPE Release Control installation package.

2. Loginthe Linux system as root.
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3. Open a shell terminal and change the current working directory to where the rpm.bin file is located.

4. Execute the following command to ensure that the execute permission is set:
chmod u+x release-control-9.50.0001.x86_64.rpm.bin

5. Execute the following command to begin installing HPE Release Control:
.Irelease-control-9.50.0001.x86_64.rpm.bin
The End User License Agreement is displayed and you are prompted to agree to its terms.

The default installation directory is /opt/HP/rc and the new user of release-control is created,
which belongs to the hp group.

The new system service of release-control is registered, which can be verified by running the
following command:

chkconfig --list|grep release-control

This service will start automatically upon system reboot.

Configuring the Database or User Schema

Caution: Upgrade is not supported if the Oracle Server user schema is created manually.

To work with HPE Release Control, you must create either a Microsoft SQL Server database or an
Oracle Server user schema. You can then configure connection properties for the HPE Release Control
database or user schema by updating the database.properties file.

Note: For MS SQL Server and Oracle Server system requirements, see "Server System
Requirements" on page 10.

For information and guidelines about configuring and maintaining MS SQL and Oracle Server
databases, see the section about database configuration and maintenance in the HPE Release
Control User Guide.

To configure your database on Windows:

1. Allocate a Microsoft SQL Server database or an Oracle Server user schema.

o For Oracle: Grant the Oracle user only Connect and Resource roles. (Populate fails if the
Oracle user has the Select any table privilege.)
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Note: From Oracle 12c, the Resource role no longer provides the UNLIMITED TABLESPACE
system privilege. You must add the privilege manually.
2. Verify the following information, which you need during this configuration process:
o DB host name and port
o DB user name and password
o For MS SQL: Database name
o ForOracle: SID
3. Before you update the database.properties file, consider the following:

o You may need to specify advanced database properties, such as minimum and maximum pool
size. For more information about these options, see
http://www.mchange.com/projects/c3p0/index.html#configuration_properties.

o You may need to specify the connection URL of the JTDS MSSQL in the database.properties
file. There are two types of authentication:

« SQL authentication. Include a valid MS SQL server name and database name.
For example:

jdbc:jtds:sqlserver://myServer:1433/myDataBase;sendStringParametersAsUnicode=
false

« Windows (NTLM) authentication. To apply Windows authentication, add the domain
property to your JTDS connection URL in the database.properties file. Specify the
Windows domain to authenticate,

For example:

jdbc:jtds:sqlserver://myServer:1433/myDatabase;sendStringParametersAsUnicode=
false;domain=myDomain

You can use Windows (NTLM) authentication with or without Lightweight Single Sign-On
Authentication Support (LW-SSO).

Using Windows (NTLM) authentication without LW-SSO. If the domain property is present
and the user name and password are provided, JTDS uses Windows (NTLM)
authentication instead of the usual SQL Server authentication. This means that the user
and password provided are the domain user and password. This allows non-Windows
clients to log in to servers which are only configured to accept Windows authentication.

Using Windows (NTLM) authentication with LW-SSO. If the domain parameter is present
but no user name and password are provided, that is the user name and password
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parameters use empty values, JTDS uses its own Single-Sign-On library and logs in with
the logged Windows user's credentials. For this to work, you need to be using Windows,
logged into a domain, and also have the LW-SSO library installed.

For details on how to install the LW-SSO library, refer to the readme.sso file, which can be
download from the latest distribution package at http://jtds.sourceforge.net.

Note: For details about configuring the JTDS URL format for MS SQL Server, see
http://jtds.sourceforge.net/faq.html#urlFormat.

o You may need to specify the connection URL of the Oracle native driver. Include a valid Oracle

server name and SID. Alternatively, if you are using Oracle RAC, specify the Oracle RAC

configuration details.

To configure HPE Release Control to support Oracle RAC:

Navigate to the <HPE Release Control 9.50 installation directory>\conf directory, and
then open the database.properties file with a text editor.

Enter URL in the following format:

jdbc:oracle:thin:@(DESCRIPTION=(LOAD_BALANCE=on) (ADDRESS_LIST=(ADDRESS=
(PROTOCOL=TCP) (HOST=host1) (PORT=1621) ) (ADDRESS=(PROTOCOL=TCP)
(HOST=host2) (PORT=1621)) ) (CONNECT_DATA=(SERVICE_NAME=MYDB)))

Each address points to a different cluster node. For example, if the previous URL is
jdbc.url=jdbc\:oracle\:thin\:@16.186.78.69\:1521\:orcl. To support RAC,
this URL should be jdbc:oracle:thin:@(DESCRIPTION=(LOAD BALANCE=on)
(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP) (HOST=16.186.78.69) (PORT=1521)))
(CONNECT_DATA=(SERVICE_NAME=orcl))).

Click Next to verify the connection.

For details about configuring the native Oracle JDBC URL format, see
http://www.orafag.com/wiki/JDBC#Thin_driver. For details about configuring the URL for
Oracle RAC, see http://download.oracle.com/docs/cd/B28359
01/java.111/e10788/rac.htm.

o HPE recommends you to encrypt your password in the database properties file.

4. Navigate to the <HPE Release Control 9.50 installation directory>\conf directory, and then update

the database.properties file.

Note: If you are in the middle of performing the upgrade procedure, continue with step 4 of
"Stage 2: Install and Upgrade HPE Release Control" on page 52.

5. When you complete the database configuration, populate the database as follows:
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Change the command line directory to <HPE Release Control installation directory>\bin and run
the following command:

Populate.bat i
To configure your database on Linux:

1. Browse to <HPE Release Control installation directory>/examples/database-config-examples.
Based on you database type, copy database.properties.mssql, database.properties.oracle9i or
database.properties.oracle10g to <HPE Release Control installation directory>/conf. Rename this
file to database.properties.

2. Open database.properties with a text editor. Change the strings in [] to correct value and save your
changes.

3. When you complete the database configuration, populate the database as follows:

a. Run the following command to log in to HPE Release Control with the user name release-
control:

su - release-control
b. Change the command line directory to /opt/HP/rc/bin and run the following command:

./Populate.sh i

Configuring JRE

As of version 9.50, HPE Release Control adds support for Open Java Development Kit (Opend DK).

Important: An OpenJDK is bundled with the Windows installation package so that you do not
have to manually install a JRE for them. For the Linux installation package, you need to manually
install either an OpenJDK or an Oracle JRE.

You have the option to use either Oracle JRE or OpenJDK with HPE Release Control. For the
supported versions, see the HPE Release Control Support Matrix.

JRE bithess

For the Windows server: use 32-bit or 64-bit JRE.

For the Linux Server: use 64-bit JRE.
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How to use OpenJDK with HPE Release Control

Use OpenJDK with HPE Release Control as described in the following table.

Installation
Package How to use OpenJDK

Windows An OpendDK (32-bit by default) folder is already bundled with the package. No
installation is required.

If you want to use 64-bit and you need:

1. Rename the <HPE Release Control 9.50 installation directory>\java folder to
create a backup copy.

2. Rename the <HPE Release Control 9.50 installation directory>\java_x64 folder
tojava.

3. Runthe CreateNode.bat command to create a new service and use this
service to start HPE Release Control windows server.

Linux 1. Before you proceed, make sure that OpendDK is already installed on the
corresponding system.

2. Update the JAVA_HOME environment variable to make it point to the OpenJDK
folder.

How to use Oracle JRE with HPE Release Control

Use Oracle JRE with HPE Release Control as described in the following table.

Installation
Package How to use Oracle JRE
Windows 1. Rename the <HPE Release Control 9.50 installation path>\java folder to create
a backup copy.
2. Download an appropriate version of 32-bit/64-bit Oracle JRE from the Oracle
website.
3. Copy the Oracle JRE folder to the <HPE Release Control 9.50 installation path>
and change its folder name to java.
4. Runthe CreateNode.bat command to create a new service and use this service
to start HPE Release Control windows server.
Linux 1. Before you proceed, make sure that Oracle JRE is already installed on the

corresponding system.
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Installation
Package How to use Oracle JRE

2. Update the JAVA_HOME environment variable to make it point to the Oracle JRE.

Launching HPE Release Control

This section describes how to launch HPE Release Control.

To launch HPE Release Control on Windows:

1. If you are using an Apache Web server, restart your Web server.
2. Start the HPE Release Control service.
a. From the Windows menu, select Start > Run and type services.msc.

b. In Services window, select HPE Release Control 9.50 <server name> and click Start
Service.

It may take a few minutes for the server to complete the startup process.

3. Enterthe appropriate URL to access HPE Release Control (depends on the user authentication
mode you are using). For example, http://server:8080/ccm.

4. Loginto HPE Release Control with the user name admin and the password admin. Ensure that
you change this password once you log in. For details on changing your password and creating
HPE Release Control users, see the section about configuring users in the HPE Release Control
User Guide.

Note: If you are working with HPE Release Control's identity management solution or LDAP
authentication, see the section about security configuration in the HPE Release Control User
Guide for details on adding an administrator and users to HPE Release Control.

To launch HPE Release Control on Linux:
1. Loginthe Linux system as release-control.
2. Execute either of the following commands to start the Release Control daemon:
letclinit.d/release-control
lopt/HP/rc/start.sh

3. Make sure port 8080 is open for INPUT in the firewall setting.
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Configuring the HPE Release Control Server

This section describes how to configure the HPE Release Control server.

1. Logonto HPE Release Control (See "Launching HPE Release Control" on the previous page).

Caution: By default, HPE Release Control supports integration with HPE Universal CMDB

9.x and above.

2. Select Module > Administrator > Configuration > Server and define the following settings in

the Server pane:

ul
Elements Description
Server Enter the server's Fully Qualified Domain Name (FQDN).
name

Note:

o Do not use the default value localhost or the IP address.

o If you cluster two or more HPE Release Control servers behind a load

balancer, specify the domain name of the load balancer.
Server Specify the HPE Release Control server address as follows:
address o If you install one HPE Release Control server, specify the URL of this machine.
Note: If you are using a web server, use the port of the web server.
o If you cluster two or more HPE Release Control servers behind a load balancer,
specify the URL of the load balancer.

SMTP Enter the host name of the SMTP mail server machine.
host
SMTP Specify the port to be used to connect to the SMTP mail server.
port
SMTP Specify the user name required to connect to the SMTP mail server, if one is
username  required.
SMTP Enter the password required to connect to the SMTP mail server. If the password
password = must be encrypted, see the section about password encryption in the HPE Release

Control User Guide.

3. Save adraft of your configuration set. (See "Saving a Draft Configuration Set" on page 48.)
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4. When you are satisfied with your configuration changes, activate the draft. (See "Activating
Configuration Changes" on page 49.)

5. Stop the HPE Release Control service:
a. From the Windows menu, select Start > Run and type services.msc.

b. In Services window, select HPE ReleaseControl 9.50 <server name> and click Stop
Service.

6. Startthe HPE Release Control service again.

Configuring HPE Universal CMDB

This section contains mandatory configuration settings for configuring HPE Release Control interaction

with HPE Universal CMDB.

For information on optional HPE Universal CMDB configuration settings, see the section about
HPE Universal CMDB configuration in the HPE Release Control User Guide.

Note: If you are working without HPE Universal CMDB (Standalone mode), see the section about
configuring HPE Release Control to work in Standalone mode in the HPE Release Control User
Guide.

To configure the HPE Universal CMDB:

1. Deploy the rc_package.zip file in the HPE Universal CMDB.

The rc_package.zip file is located in the <HPE Release Control installation
directory>\uCmdb\ucmdb-<version>\extensions folder. For more information about deploying
packages, see the HPE Universal CMDB documentation.

2. LogintoHPE Release Control.
3. Select the HPE Universal CMDB version number.

a. InHPE Release Control, select Module > Administrator > Configuration tab >
Integrations > HPE Universal CMDB.

b. Intheright pane, Inthe HPE Universal CMDB version box, select the appropriate version.
4. Enterthe HPE Universal CMDB server details.

a. Select Integrations > HPE Universal CMDB > Available Connections > Enter a valid
CMDB server name.
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b. Intheright pane, in the HPE Universal CMDB server name box, enter the DNS name of the
server on which HPE Universal CMDB is installed.

c. Inthe Portbox, specify the port used by the HPE Universal CMDB server.

5. Save adraft of your configuration set. (See "Saving a Draft Configuration Set" on page 48.)

6. When you are satisfied with your configuration changes, activate the draft. (See "Activating

Configuration Changes" on page 49.)

Configuring HPE Release Control to Work
with a Different Version of HPE Universal
CMDB

By default, HPE Release Control 9.50 supports integration with HPE Universal CMDB 9.x and above.

1.

2.

HPE Release Control (9.50)

In HPE Release Control, go to the Module > Administrator > Configuration tab.
Click the Import Configuration set 2 button and import the vanilla.zip file located in the
<HPE Release Control installation directory>\examples\configuration folder.

Go to Integrations > HPE Universal CMDB, and then choose the required HPE Universal
CMDB version in the HPE Universal CMDB version box.

In Integrations > HPE Universal CMDB > Available Connections pane, update the relevant
URL in the Modeling Studio link as follows:
For HPE Universal CMDB 9.x and above

${protocol}://${cmdb-server}:${port}/ucmdb-
ui/cms/directAppletLogin.do?ApplicationMode=UCMDB_
EDITOR&cmd=0OpenModelingStudio&model_id=${model-id}&objectld=${ci-id}
&navigation=true&interfaceVersion=8.0.0&customerld=${customer-id}

Save a draft of the configuration set, as described in "Saving a Draft Configuration Set" on page
48.

Activate the configuration set, as described in "Activating Configuration Changes" on page 49.
Log out and then log in to HPE Release Control.

In Module > Administrator > Configuration tab > Integrations > HPE Universal CMDB > Cls
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9.

10.

11.

12.

13.

14.

analysis Lookup Directive pane, and update the tables with the relevant Cl types:

Cl types for HPE Universal CMDB 9.x and above
business_elements
node

IP address

Inthe Cls analysis Lookup Directive pane, update the table with the relevant attributes for each
CIT as follows.

Cl types for HPE Universal CMDB 9.x Relevant attributes

business_elements name
node sSmMnp_sys_name; name; primery_dns_name
IP address name; authoritative_dns_name

In the CI Display pane, update the table with the following Cl types:

Cl types for HPE Universal CMDB 9.x and above
node
ip_address

In Integrations > HPE Universal CMDB > Latent Changes > Change Type Matching Cl Type
> Added Hardware pane, update the table with the relevant Cl types:

Cl types for HPE Universal CMDB 9.x and above

memory

node

logicaldisk

ip_address

file_system
In Integrations > Fields pane, make sure that the new analysis rules you configured in the
previous steps apply to the relevant fields.

Save a draft of the configuration set, as described in "Saving a Draft Configuration Set" on page
48.

Activate the configuration set, as described in "Activating Configuration Changes" on page 49.
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Configuring the Service Desk Integration

The configuration of your service desk differs depending on which service desk you are using:

Service Desk Instructions

HPE Service Manager "Configuring HPE Service Manager Integration" on page 26
HPE Project and Portfolio "Configuring HPE Project and Portfolio Management / IT
Management / IT Governance Center = Governance Center Integration" on page 29

BMC Remedy Action Request "Configuring BMC Remedy Action Request System
System Integration" on page 32

Database "Configuring a Database as a Service Desk" on page 34
XML file "Configuring an XML File as a Service Desk" on page 37
HPE Server Automation "Configuring HPE Server Automation as Your Service

Desk" on page 39

Aperture Vista DCIM "Configuring Aperture Vista DCIM as a Service Desk" on
page 41

Supported Service Desks

The Service Desk Integration module supports the following service desk applications:

Application Version
HPE Service Manager 9.3x, 9.4x, 9.50

HPE Project and Portfolio 9.x
Management

HPE Server Automation (SA) = Refer to the Support Matrix section on ID: 447 Jobs information
collection from SA (RC - SA) on the HPE Software Support website.

BMC Remedy Action 7.X
Request System

Aperture Vista Data Center 6.0
Infrastructure Manager
(DCIM)
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Feature Availability per Service Desk

Certain HPE Release Control features are only available when you integrate with certain service desk
applications. The following table describes these features and specifies their availability per service
desk. Service desks that are not listed in this table do not include these features.

HPE Project

and

HPE Service Portfolio
Feature Manager Management
Update Approval status. Approval of a change request in the Yes Yes
Analysis module Collaborate > Resolution tab, results in an updated
status of the request within the service desk.
Retract approval. Retracting approval of a change request in the Yes No
Analysis module Collaborate > Resolution tab, results in an updated
status of the request within the service desk.
Update planned times. After you run a simulation in the Analysis Yes No
module Change Planner, you can save the updated start and end
times to the originating service desk.
Update actual times. In the Director and Implementor modules, you @ Yes No
can update the actual start and end time of an activity. These times
are automatically updated in the originating service desk ticket.
Update Post Implementation Review. The data that you update in Yes No
the Post Implementation Review dialog box in the Review >
Conclusions tab is updated in the origination service desk.
Closing Tickets from HPE Release Control. You can close service | Yes No
desk tickets from the Analysis module Review > Conclusions tab.
Update analysis information. The originating service desk ticket is Yes No
updated with analysis information from HPE Release Control (for (requires
example risk level and impact analysis) configuration)
Deny change request. Denying a change request in the Analysis Yes No

module Collaborate > Resolution tab results in an updated status of
the request within the service desk.
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Configuring HPE Service Manager Integration

This task describes how to configure HPE Service Manager as your service desk and includes the
following stages:

» "Stage 1: Prerequisites" below
« "Stage 2: Run the Configuration Utility" on the next page

» "Stage 3: Apply Configuration Changes" on page 28

The server on which the HPE Release Control and HPE Service Manager servers reside must be
running in the same time zone.

Stage 1: Prerequisites

1. Verify the following information, which you need during this configuration process:

o HPE Service Manager version

o

Is HP's Lightweight Single Sign On (LW-SSO) used?

o

HPE Service Manager user name, password, time zone, host name, and port
Note: Use the Java naming conventions for time zones.
o |Is HTTPS required in order to access HPE Service Manager WSDL file?

Note: If HPE Service Manager is configured using SSL, you need to import the SSL
certificate from HPE Service Manager to the HPE Release Control server.

o

URL suffix for the HPE Service Manager WSDL file (by default, sc62server/PWS)

Note: HPE Service Manager's internal load balancer encounters technical problems when
deploying Web services due to the fact that Web services do not support the HTTP Redirect
in HPE Service Manager. To enable HPE Release Control to work with HPE Service
Manager configured with a load balancer, you need to configure a load balancer for

HPE Service Manager that is other than HPE Service Manager's internal one. For example,
Cisco CSS.
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2. Users who access HPE Service Manager from HPE Release Control need to have SOAP API
Execute Capabilities enabled. In HPE Service Manager, ensure that this option is enabled for the
relevant operators.

3. (Optional) As part of the SdiConfigurer.bat utility you run in the next stage, certain HPE Service
Manager fields are automatically mapped to HPE Release Control fields. If you want to map any
additional fields, expose these fields now in the HPE Service Manager
ChangeRC/ChangeTaskRC External Access object. You map these fields in conversion scripts
in step 3 of "Stage 3: Apply Configuration Changes" on the next page.

Note: To expose and map fields, ensure that you are using ChangeRC and ChangeTaskRC external
access objects that are dedicated to HPE Release Control instead of using the default Change and
ChangeTask external access objects.

Stage 2: Run the Configuration Utility

On the Windows System:
From the Windows command line, run the following command:
<HPE Release Control installation directory>\bin\SdiConfigurer.bat

For each question, type your selection and press Enter. (Refer to the information you verified at the
beginning of the Prerequisites section.) Where relevant, the default selection appears in square
brackets at the end of the question.

Note: If you press Enter without typing anything, the default answer is automatically selected.

Based on your selections, the configuration utility creates new configuration files, including a .zip file.
To apply the configuration settings to HPE Release Control, you use the Import configuration set
button to upload the .zip file as described below.

On the Linux System:

1. Loginthe Linux system as root.

2. Run the following command to log in to HPE Release Control with the user name release-control:
su - release-control

3. Runthe ed bin command to enter the HPE Release Control installation directory.
4. Run the following command:

.ISdiConfigurer.sh
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For each question, type your selection and press Enter. (Refer to the information you verified at
the beginning of the Prerequisites section.) Where relevant, the default selection appears in

square brackets at the end of the question.

For each question, type your selection and press Enter. (Refer to the information you verified at the
beginning of the Prerequisites section.) Where relevant, the default selection appears in square

brackets at the end of the question.

Stage 3: Apply Configuration Changes

1. In HPE Release Control, go to Module > Administrator > Configuration tab > Integrations >
Service Desk Adapters, click the Import configuration set button.

Configuration || Time Periods || Business Cls

Users |

=xp_test_01
E B8
hﬁ Change Process

] Imn-House |

Import configuration set

TE Integrations
hﬁ Enumerations
| ] Fields
» 3] HPE Universal CMDB

v E Service Desk Adapters

Service Desk Adapters

2. Inthe Select file to upload dialog box, go to <HPE Release Control installation

directory>\bin\result and open <adapter_name>.zip.

A new node (with the name of the adapter) is added under the Integrations > Service Desk
Adapters node. The node includes the new service desk configuration files, which are displayed
independently in the left pane. Select a configuration file and its content is displayed in the right

pane.

3. If you exposed additional fields in step 4 of "Stage 1: Prerequisites" on page 26, map these fields
in the relevant conversion scripts (convertChange.js/convertTask.js).

o Toview the conversion scripts, select the Integrations > Service Desk Adapters > <adapter
name> node and select the relevant tab in the right pane that displays the file.

HPE Release Control (9.50)
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o Tomake changes to the scripts, see "Modifying Configuration Files in the Configuration Tab"
on page 48.

4. You can configure HPE Release Control to update HPE Service Manager with Analysis
information. For details, see the relevant section in the HPE Release Control User Guide.

5. Save adraft of your configuration set. (See "Saving a Draft Configuration Set" on page 48.)
6. When you are satisfied with your configuration changes, activate the draft. (See "Activating

Configuration Changes" on page 49.)

Note: To modify your service desk settings after the initial configuration, see the section
about advanced service desk configuration in the HPE Release Control User Guide.

Configuring HPE Project and Portfolio
Management/IT Governance Center Integration

This task describes how to configure HPE Project and Portfolio Management / IT Governance Center
as your service desk and includes the following stages:

« "Stage 1: Prerequisites" below

» "Stage 2: Run the Configuration Utility" on the next page

« "Stage 3: Apply Configuration Changes" on the next page

Stage 1: Prerequisites

1. Verify the following information, which you need during this configuration process:
o HPE Project and Portfolio Management / IT Governance Center version
o service desk user name, password, host name, and port

o If you want to enable approval integration with HPE Release Control whereby the approval of a
change request in HPE Release Control, results in an updated status of a workflow step within
the service desk, you need to provide the following information:

« Source Workflow Step. Decide which step in HPE Project and Portfolio Management
requires approval. This step is updated with the HPE Release Control approval status.

« Oracle DB SID (System ID)
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« Oracle DB host name
« Oracle DB port

« Oracle DB user name
« Oracle DB password

o Write down the workflow steps from HPE Project and Portfolio Management. This information
is found within the HPE Project and Portfolio Management workbench. For more information,
refer to the HPE Project and Portfolio Management documentation.

2. Forversions earlier than HPE Project and Portfolio Management version 7.5: If your HPE Project
and Portfolio Management / IT Governance Center Web Services service desk application is
synchronized with the CMDB server, add a new change request field in HPE Release Control
named mam-ticket-id of the text type. Apply the mam-ticket analysis rule to this field, with the
analysis rule level set to both Change and Task.

For information about creating new change request fields and applying analysis rules, see the
section about creating or modifying change request fields in the HPE Release Control User Guide.

Stage 2: Run the Configuration Utility
From the command line, run the following command:

<HPE Release Control installation directory>\bin\SdiConfigurer.bat

For each question, type your selection and press Enter. (Refer to the information you verified at the
beginning of the Prerequisites section.) Where relevant, the default selection appears in square
brackets at the end of the question.

Note: If you press Enter without typing anything, the default answer is automatically selected.

Based on your selections, the configuration utility creates new configuration files, including a .zip file.
To apply the configuration settings to HPE Release Control, you use the Import configuration set
button to upload the .zip file as described below.

Stage 3: Apply Configuration Changes

1. In HPE Release Control, go to Module > Administrator > Configuration tab > Integrations >
Service Desk Adapters, click the Import configuration set button.
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2.

4.
5.

Configuration | Time Periods |

Business Cls

Users |

xp_test_01

E 8

¥

Service Desk Adapters

[ E Change Process

|_.] In-House | Import configuration set

L J E Integrations
[ 2 E Enumerations

| ] Fields

» 3] HPE Universal CMDB

L J E Service Desk Adapters

In the Select file to upload dialog box, go to <HPE Release Control installation
directory>\bin\result and open <adapter_name>.zip.

A new node (with the name of the adapter) is added under the Integrations > Service Desk
Adapters node. The node includes the new service desk configuration files, which are displayed
independently in the left pane. Select a configuration file and its content is displayed in the right
pane.

Map the workflow steps (that you wrote down earlier as part of the configuration prerequisites)
from HPE Project and Portfolio Management to status names in HPE Release Control in the
relevant conversion scripts (convertRelease.js/convertChange.js).

o To view the conversion scripts, select the Integrations > Service Desk Adapters > <adapter
name> node and select the relevant tab in the right pane that displays the file.

o To make changes to the scripts, see "Modifying Configuration Files in the Configuration Tab"
on page 48.

Save a draft of your configuration set. (See "Saving a Draft Configuration Set" on page 48.)

When you are satisfied with your configuration changes, activate the draft. (See "Activating
Configuration Changes" on page 49.)

Note: To modify your service desk settings after the initial configuration, see the section about
advanced service desk configuration in the HPE Release Control User Guide.

HPE Release Control (9.50)
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Configuring BMC Remedy Action Request System
Integration

This task describes how to configure BMC Remedy Action Request System as your service desk and
includes the following stages:

» "Stage 1: Prerequisites" below
« "Stage 2: Run the Configuration Utility" below
» "Stage 3: Copy BMC Remedy Files to HPE Release Control" on the next page

« "Stage 4: Apply Configuration Changes" on page 34

Stage 1: Prerequisites

Verify the following information, which you need during this configuration process:

« BMC Remedy version

« BMC Remedy user name, password, and server name

Stage 2: Run the Configuration Utility

From the command line, run the following command:
<HP Release Control installation directory>\bin\SdiConfigurer.bat

For each question, type your selection and press Enter. (Refer to the information you verified at the
beginning of the Prerequisites section.) Where relevant, the default selection appears in square
brackets at the end of the question.

Note: If you press Enter without typing anything, the default answer is automatically selected.

Based on your selections, the configuration utility creates new configuration files, including a .zip file.
To apply the configuration settings to HPE Release Control, you use the Import configuration set
button to upload the .zip file as described below.
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Stage 3: Copy BMC Remedy Files to HPE Release
Control

To connect to the BMC Remedy Action Request System service desk application, you must first
ensure that certain BMC Remedy Action Request System files are accessible to the HPE Release
Control server.

1. Stopthe HPE Release Control service:

o From the Windows menu, select Start > Run and type services.msc.

o In Services window, select HPE ReleaseControl 9.50 <server name> and click Stop
Service.

2. Copy BMC Remedy files to HPE Release Control.
o If you are working with BMC Remedy ARS 5.0:

i. Copy arapi50.jar and arutil50.jar from the BMC Remedy Action Request System
installation directory to the <HPE Release Control installation directory>\tomcat\lib
directory.

ii. Copy arapi50.dll, arjni50.dIl, arrpc50.dll, and arutl50.dll from the BMC Remedy Action
Request System installation directory to the <HPE Release
Control installation directory>\apps\ccm\WEB-INF\os_lib\win32 directory on the
HPE Release Control server machine.

o If you are working with BMC Remedy ARS 7.0:

i. Copy arapi70.jar and arutil70.jar from the BMC Remedy Action Request System
installation directory to the <HPE Release Control installation directory>\tomcat\lib
directory.

ii. Copy all the Windows library files (*.dll) from the BMC Remedy Action Request System
installation directory to the <HPE Release
Control installation directory>\apps\ccm\WEB-INF\os_lib\win32 directory on the
HPE Release Control server machine.

3. Start the HPE Release Control service.
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Stage 4: Apply Configuration Changes

1. In HPE Release Control, go to Module > Administrator > Configuration tab > Integrations >
Service Desk Adapters, click the Import configuration set button.

Configuration | Time Periods | Business CIs || Users |

xp_test 01 Saervice Desk Adapters

B A8 ?
hﬁ Change Process

._.] In-Houze | Import configuration set

TE Integraticns

FE Enumerations

__'| Fields

b3 HPE Universal CMDB

L J E Service Desk Adapters

2. Inthe Select file to upload dialog box, go to <HPE Release Control installation
directory>\bin\result and open <adapter_name>.zip.

A new node (with the name of the adapter) is added under the Integrations > Service Desk
Adaptersnode. The node includes the new service desk configuration files, which are displayed
independently in the left pane. Select a configuration file and its content is displayed in the right
pane.

3. Save adraft of your configuration set. (See "Saving a Draft Configuration Set" on page 48.)

4. When you are satisfied with your configuration changes, activate the draft. (See "Activating
Configuration Changes" on page 49.)

Note: To modify your service desk settings after the initial configuration, see the section
about advanced service desk configuration in the HPE Release Control User Guide.

Configuring a Database as a Service Desk

This task describes how to configure a database as your service desk and includes the following
stages:
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« "Stage 1: Prerequisites" below

» "Stage 2: Run the Configuration Utility" on the next page

« "Stage 3: Apply Configuration Changes" on the next page

Stage 1: Prerequisites

Depending on which database you are using, verify the following connection information and database

properties that you need during this configuration process:

Required Information

For Oracle databases: Oracle
SID, DB host name, port, user
name, and password.

For MS-SQL databases: DB
name, DB host name, port,
user name, and password.

change id column name
Note: Inthe Settings file,
this field is called
IdFieldName.

Id selection query

HPE Release Control (9.50)

Description

Database connection properties

The name of the column in the result set that contains the ID field
value.

The SQL query that returns the set of change request IDs according
to the requests' 1ast-updated field value.

Caution: The query must not include the date of the last
change request that was retrieved to avoid getting an infinite
loop in which the same change requests are retrieved each
time.

Example of a correct query:

The correct query does not include the date of the last change
request that was retrieved. The date must be greater than the date
of the last change request that was retrieved.

For example, if the last change request was retrieved on February 1,
2010, set the date the last change request was retrieved as follows:

select change_id from changes where last_updated > ?
Example of an incorrect query:

An incorrect query includes the date of the last change request that
was updated and might create an infinite loop in which the same
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Required Information Description
change requests are retrieved each time:
select change_id from changes where last_updated >= ?

change select by id query The SQL query that returns all the required details of a specific
change.

Example of a correct query:
select * from changes where change_id=?

change request ID The SQL query that returns a set of change request according to the
requestsO ID.

last updated field result The name of the column in the result set that contains the 1ast-
column name update field value.

Note: Inthe Settings file,
this field is called
lastUpdatedFieldName.

Stage 2: Run the Configuration Utility
From the command line, run the following command:
<HPE Release Control installation directory>\bin\SdiConfigurer.bat

For each question, type your selection and press Enter. (Refer to the information you verified at the
beginning of the Prerequisites section.) Where relevant, the default selection appears in square
brackets at the end of the question.

Note: If you press Enter without typing anything, the default answer is automatically selected.

Based on your selections, the configuration utility creates new configuration files, including a .zip file.
To apply the configuration settings to HPE Release Control, you use the Import configuration set
button to upload the .zip file as described below.

Stage 3: Apply Configuration Changes

1. In HPE Release Control, go to Module > Administrator > Configuration tab > Integrations >
Service Desk Adapters, click the Import configuration set button.
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Configuration | Time Periods | Business CIs | Users |

xp_test 01 Service Desk Adapters

E EBa * ¥ ?
hﬁ Change Process

|_.] In-House | Import configuration set

L J E Integrations

[ 2 E Enumerations

| ] Fields

» 3 HPE Universal CMDB

L J E Service Desk Adapters

2. Inthe Select file to upload dialog box, go to <HPE Release Control installation
directory>\bin\result and open <adapter_name>.zip.

A new node (with the name of the adapter) is added under the Integrations > Service Desk
Adapters node. The node includes the new service desk configuration files, which are displayed
independently in the left pane. Select a configuration file and its content is displayed in the right
pane.

3. Save adraft of your configuration set. (See "Saving a Draft Configuration Set" on page 48.)

4. When you are satisfied with your configuration changes, activate the draft. (See "Activating
Configuration Changes" on page 49.)

Note: To modify your service desk settings after the initial configuration, see the section about
advanced service desk configuration in the HPE Release Control User Guide.

Configuring an XML File as a Service Desk

This task describes how to configure and XML file as your service desk and includes the following
stages:

» "Stage 1: Prerequisites" on the next page
« "Stage 2: Run the Configuration Utility" on the next page

» "Stage 3: Apply Configuration Changes" on the next page
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Stage 1: Prerequisites

1. Verify the folder in which XML files are placed and retrieved by HPE Release Control. You need
this information for the configuration utility that you will run in the next stage.

2. Ensure that the HPE Release Control user has read permissions to the directory in which the
service desk application requests are placed in XML file format.

Stage 2: Run the Configuration Utility
From the command line, run the following command:
<HP Release Control installation directory>\bin\SdiConfigurer.bat

For each question, type your selection and press Enter. (Refer to the information you verified at the
beginning of the Prerequisites section.) Where relevant, the default selection appears in square
brackets at the end of the question.

Note: If you press Enter without typing anything, the default answer is automatically selected.

Based on your selections, the configuration utility creates new configuration files, including a .zip file.
To apply the configuration settings to HPE Release Control, you use the Import configuration set
button to upload the .zip file as described below.

Stage 3: Apply Configuration Changes

1. In HPE Release Control, go to Module > Administrator > Configuration tab > Integrations >
Service Desk Adapters, click the Import configuration set button.
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Configuration | Time Periods | Business CIs | Users |

xp_test 01 Service Desk Adapters

E EBa * ¥ ?
hﬁ Change Process

|_.] In-House | Import configuration set

L J E Integrations
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| ] Fields
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L J E Service Desk Adapters

2. Inthe Select file to upload dialog box, go to <HPE Release Control installation
directory>\bin\result and open <adapter_name>.zip.

A new node (with the name of the adapter) is added under the Integrations > Service Desk
Adapters node. The node includes the new service desk configuration files, which are displayed
independently in the left pane. Select a configuration file and its content is displayed in the right
pane.

3. Save adraft of your configuration set. (See "Saving a Draft Configuration Set" on page 48.)

4. When you are satisfied with your configuration changes, activate the draft. (See "Activating
Configuration Changes" on page 49.)

Note: To modify your service desk settings after the initial configuration, see the section
about advanced service desk configuration in the HPE Release Control User Guide.

Configuring HPE Server Automation as Your
Service Desk

This task describes how to configure <service desk> as your service desk and includes the following
stages:

« "Stage 1: Prerequisites" on the next page
» "Stage 2: Run the Configuration Utility" on the next page

« "Stage 3: Apply Configuration Changes" on the next page

HPE Release Control (9.50) Page 39 of 67



Deployment Guide
Installing and Deploying HPE Release Control

Stage 1: Prerequisites

Verify the following information, which you need during this configuration process:

For HP Server Automation: server name, user name, and password

Stage 2: Run the Configuration Utility
From the command line, run the following command:

<HPE Release Control installation directory>\bin\SdiConfigurer.bat

For each question, type your selection and press Enter. (Refer to the information you verified at the
beginning of the Prerequisites section.) Where relevant, the default selection appears in square
brackets at the end of the question.

Note: If you press Enter without typing anything, the default answer is automatically selected.

Based on your selections, the configuration utility creates new configuration files, including a .zip file.
To apply the configuration settings to HPE Release Control, you use the Import configuration set
button to upload the .zip file as described below.

Stage 3: Apply Configuration Changes

1. In HPE Release Control, go to Module > Administrator > Configuration tab > Integrations >
Service Desk Adapters, click the Import configuration set button.

HPE Release Control (9.50) Page 40 of 67



Deployment Guide
Installing and Deploying HPE Release Control

Configuration | Time Periods |

Business Cls

Users |

xp_test_01

E EBa - 3%
hﬁ Change Process

|_.] In-House | Import configuration set

L J E Integrations

[ 2 E Enumerations

| ] Fields

» 3 HPE Universal CMDB

L J E Service Desk Adapters

¥

Service Desk Adapters

2. Inthe Select file to upload dialog box, go to <HPE Release Control installation

directory>\bin\result and open <adapter_name>.zip.

A new node (with the name of the adapter) is added under the Integrations > Service Desk
Adapters node. The node includes the new service desk configuration files, which are displayed

independently in the left pane. Select a configuration file and its content is displayed in the right

pane.

3. Save adraft of your configuration set. (See "Saving a Draft Configuration Set" on page 48.)

4. When you are satisfied with your configuration changes, activate the draft. (See "Activating

Configuration Changes" on page 49.)

Note: To modify your service desk settings after the initial configuration, see the section
about advanced service desk configuration in the HPE Release Control User Guide.

Configuring Aperture Vista DCIM as a Service

Desk

This task describes how to configure Aperture Vista DCIM as your service desk and includes the

following stages:

« "Stage 1: Prerequisites" on the next page

« "Stage 2: Run an SQL to create an HPE Release Control view in the Aperture Vista DCIM

database" on the next page
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« "Stage 3: Run the Configuration Utility" below

« "Stage 4: Apply Configuration Changes" on the next page

Stage 1: Prerequisites

Verify the following information, which you need during this configuration process:

o Aperture Vista DCIM version 6 is supported.

« Aperture Vista DCIM database name, user name, password, host name, and port (default port is
1433)

Stage 2: Run an SQL to create an HPE Release Control
view in the Aperture Vista DCIM database

1. Connect to the Aperture Vista DCIM database. (Refer to the information you verified at the
beginning of the Prerequisites section for the Aperture Vista DCIM database name.)

2. Runthe <HPE Release Control installation directory>\\examples\service-desk-
examples\ApertureVista\CreateRcView.sql file.

Stage 3: Run the Configuration Utility

From the command line, run the following command:
<HPE Release Control installation directory>\bin\SdiConfigurer.bat

Choose option 10 and for each question, type your selection and press Enter. (Refer to the information
you verified at the beginning of the Prerequisites section.) Where relevant, the default selection
appears in square brackets at the end of the question.

Note: If you press Enter without typing anything, the default answer is automatically selected.

Based on your selections, the configuration utility creates new configuration files, including a .zip file.
To apply the configuration settings to HPE Release Control, you use the Import configuration set
button to upload the .zip file as described below.
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Stage 4: Apply Configuration Changes

1. In HPE Release Control, go to Module > Administrator > Configuration tab > Integrations >
Service Desk Adapters, click the Import configuration set button.

Configuration | Time Periods | Business CIs || Users |

xp_test 01 Saervice Desk Adapters

B A8 - X ?
hﬁ Change Process

|_.] In-Houze | Import configuration set

TE Integraticns

FE Enumerations

I_'l Fields

b3 HPE Universal CMDB

L J E Service Desk Adapters

2. Inthe Select file to upload dialog box, go to <HPE Release Control installation
directory>\bin\result and open <adapter_name>.zip.

A new node (with the name of the adapter) is added under the Integrations > Service Desk
Adapters node. The node includes the new service desk configuration files, which are displayed
independently in the left pane. Select a configuration file and its content is displayed in the right
pane.

3. Inthe EMAC_URL_part1 section of the convert.js file, enter the URL of the Aperture Vista server
instead of the aperture_vista_host field (see "Modifying Configuration Files in the Configuration
Tab" on page 48).

4. Save a draft of your configuration set. (See "Saving a Draft Configuration Set" on page 48.)
5. When you are satisfied with your configuration changes, activate the draft. (See "Activating

Configuration Changes" on page 49.)

Note: To modify your service desk settings after the initial configuration, see the section
about advanced service desk configuration in the HPE Release Control User Guide.
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Configuring Web Server

You can deploy HPE Release Control to work with a Web server. You can install one of the following
Web servers on the same computer as HPE Release Control:

« Microsoft Internet Information Services (I1S) 8.x

o Apache HTTP Server2.2, 2.4

Note: HPE Release Control cannot be configured with an Apache server if a Microsoft I1IS Web
server is already installed and activated on the server because the default port of both web servers
is 80. The Microsoft [IS Web server must be stopped first. After the installation you can configure
the Apache web server to work with a different port (e.g. 90) and restart your I1S.

You may need to configure a Web server in the following cases:

« You are working with a third party identity management solution such as CA SiteMinder.

« You are deploying a software load balancer that cannot use the AJP protocol to communicate with
Tomcat in a cluster deployment.

To configure the Web server, use the WebServerConfigurer utility.

Note: After you install the Web server, ensure that the port of the Web server is specified inside
the Server address box in the Module > Administrator > Configuration tab > Server pane. If
the server address is not configured correctly, emails and reports may not work properly.

To use the Web server configure utility:
Run the following command:
<HPE Release Control installation directory>\bin\WebServerConfigurer.bat <options>

Following are the command line <options>:

Option Description

configapache  Configure an Apache Web server. Specify the Apache configuration options:
<port>

<apache home = ° <port>. The port used by the Apache Web server.

directory> « <apache home directory>. The Apache Web server installation directory.
config IIS, Specify the configuration options for an IIS server:

<port>
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Option Description
<version> « <port>. The port used by the server. The default port is 80.
<RC Website>

« <version>. Web server version.

« <RC Website>. The Web site defined for HPE Release Control. In a new IIS
installation, the HPE Release Control default site is called Default Web Site.

—-encrypted- Use the encrypted password specified in <file>.
password-file
<file>

remove-config = Configures HPE Release Control to work without a Web server. This command
does not uninstall the Web server.

Note: Inthe <HPE Release Control installation
directory>\conf\server.settings file, the HPE Release Control port number in
the server-address property is reset to the Tomcat default port (8080).
Ensure that the HPE Release Control and Tomcat port number are the same.

For example:

« To configure an Apache server, run:

<HPE Release Control installation directory>\bin\WebServerConfigurer.bat config apache
"C:\Apache Software Foundation\Apache 2.4"

« Toconfigure an IIS server version 8 for the default Web site, run:

<HPE Release Control installation directory>\bin\WebServerConfigurer.bat config IIS 8
"Default Web Site"

Caution: After configuring an IS Web server with the webServerConfigurer utility, the ISAPI
filter that is responsible for the redirection from IS to the HPE Release Control Tomcat server,
may have a status of Unknown. After the first user logs on to HPE Release Control, the ISAPI
filter status should be updated to Ready.

It is not possible to configure an [IS Web server that has an existing ISAPI filter running in it
already. To do this you must first remove the previous installation of the mod_jk ISAPI filter,
then use the webServerConfigurer utility to configure IIS for HPE Release Control.

« Toremove the Web server configuration, run:

<HPE Release Control installation directory>\bin\WebServerConfigurer.bat remove-config

Configure HPE Release Control to work with IIS 8:
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1. Run the webServerConfigurer utility as configure IIS 8. For example:
webServerConfigurer.bat config iis 8 "Default Web Site"
Ignore the errors.

2. Download new tomcat connector from http://www.apache.org/dist/tomcat/tomcat-
connectors/jk/binaries/windows/tomcat-connectors-1.2.40-windows-x86_64-iis.zip.

Extract isapi_redirect.dll from the zip and copy it to the \webserver\bin\jakarta folder.

3. Modify \webserver\confiredirector.reg by changing
"extension_uri"="/jakarta/isapi_redirector.dll”
to
"extension_uri"="/jakarta/isapi_redirect.d1l"
Save your changes and double-click redirector.regto execute.

4. Start the [IS manager. On the server node open "ISAPI and CGI Restrictions”, add isapi_
redirect.dll and allow this extension path to execute.

5. Onthe default web site add the new virtual directory and enter its alias (jakarta) and physical path
the directory where isapi_redirect.dll resides (\webserver\bin\jakarta).

6. On the default web site open the "ISAPI Filters" and add isapi_redirect.dll naming the filter
"ikfilter".
7. Onthe node of the "jakarta" virtual directory, open "Handler Mappings" and enable the "ISAP-dII"

handler (disabled by default). Edit the "ISAPI-dII" handler permissions and enable "Read", "Script",
and "Execute".

8. RestartlIS.

Accessing HPE Release Control through
Server Reverse Proxy

You can enable access to HPE Release Control through Server Reverse Proxy (SRP).

To enable access to HPE Release Control through SRP:

1. Map the paths for /ccm and /rcdocs to the URLs of the remote server where HPE Release Control
is installed.
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For example, if the reverse proxy is Apache server, add the following lines to the https.conf file:
ProxyPass /ccm http://<RC_HOST_NAME>:<RC_HTTP_PORT>/ccm

ProxyPassReverse /ccm http://<RC_HOST_NAME>:<RC_HTTP_PORT>/ccm

ProxyPass /rcdocs http://<RC_HOST_NAME>:<RC_HTTP_PORT>/rcdocs
ProxyPassReverse /rcdocs http://<RC_HOST_NAME>:<RC_HTTP_PORT>/rcdocs

/rcdocs should be configured on the reverse proxy server as an additional application besides
ccm.

2. Save the file and restart the Apache server for the configuration to take effect.

The HPE Release Control access URL should refer to the reverse proxy host. For example:

http://<proxy_host>/ccmand http://<proxy_host>/rcdocs respectively.

Note: Different types of reverse proxy may require different configuration steps. Refer to your
proxy server documentation for more information.

Touse HTTPS with SRP:

1. Configure HPE Release Control to work with HTTPS protocol with a self-signed or CA certificate.

2. Export the security certificate from HPE Release Control and import it to the truststore of your
proxy server.

Note: On the Apache server, the truststore (cacerts file) file is not a part of the installation.
You may need to create a new PEM encoded cacerts file. Refer to your Apache
documentation for details.

3. Follow the instructions in Step 1 and add the lines to the https.conf file if the Apache server is
used.

Working with HPE Release Control
Configuration Settings

The Configuration tab in the Administrator module enables you to define the configuration settings
needed to set up your environment. This section describes the following common tasks in the
Configuration tab. These tasks are referred to during the configuration process.
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« "Modifying Configuration Files in the Configuration Tab" below
» "Saving a Draft Configuration Set" below

« "Activating Configuration Changes" on the next page

Modifying Configuration Files in the Configuration
Tab

Certain configuration settings are defined in configuration files (for example, scripts and XML files) that
are available in the Configuration tab. This task describes how to modify these files.

To modify configuration files:
1. In HPE Release Control, go to Module > Administrator > Configuration tab and select the
configuration file you want to modify. Content of this file is displayed in the right pane.

2. After making the required modifications to the file, click the Save current editable configuration
set button to open the Save as Draft dialog box and save the modified configuration set as a draft.

Saving a Draft Configuration Set

A new configuration set is initially saved as a draft. A draft is a configuration set that has not yet been
activated. Only after a draft is activated, are the new configuration properties applied to HPE Release

Control. (See "Activating Configuration Changes" on the next page.)
To save a draft configuration set:

1. Select Module > Administrator > Configuration tab and make the required configuration
changes.
2. Inthe left pane, click the Save current editable configuration set button IZll to open the Save as

Draft dialog box and save the modified configuration set as a draft.

3. Inthe Draft name box, enter the name of the draft and click Save.
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Activating Configuration Changes

This section explains how to activate a draft configuration set and apply the configuration properties to
HPE Release Control.

To apply configuration changes

1. Select Module > Administrator > Configuration tab. In the left pane, click the Open

4
Configuration Set button = to open the Open Configuration Set dialog box.

2. Select the Drafts button to display only the existing drafts.

3. Select the required draft and click Open. The name of the currently selected configuration set
appears at the top of the left pane.

4. Inthe left pane, click the Activate current configuration set button L to activate the selected

draft and apply the new configuration properties to HPE Release Control.

Uninstalling HPE Release Control

You can remove HPE Release Control from Windows using the Control Panel. Or you can run a series
of shell commands to remove HPE Release Control from Linux.

To remove HPE Release Control from Windows:

1. Click Start > Control Panel > Add or Remove Programs.

2. Select HPE Release Control in the program list and click Remove.
To remove HPE Release Control from Linux:

1. Login the Linux system as root.
2. Runthe /opt/HP/rc/stop.sh command to stop the Release Control daemon.

3. Execute the following command to remove HPE Release Control:

rpm -e release-control
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This chapter provides information on how to upgrade from HPE Release Control 9.2x to version 9.50 on

Windows and Linux.

To upgrade to version 9.50 from versions earlier than 9.2x:

« Upgrade to version 9.2x according to the instructions in the HPE Release Control 9.2x Deployment
Guide.

« Upgrade from version 9.2x to version 9.50 by following the instructions in this chapter.

This chapter includes:

Upgrading HPE Release Control on the Windows System ... ... ......................... 50
Stage 1: Prerequisites ... ... . 51
Stage 2: Install and Upgrade HPE Release Control ... . ... . 52
Stage 3: Upgrade Service Desk Adapterto 9.50 ... ... 53
Stage 4: Post Upgrade Recommendations ......... ... ... ... 54
Stage 5: Regenerate the encrypted password ... 55

Upgrading HPE Release Control on the Linux System ... . ... 55

Upgrading HPE Release Control on the
Windows System

The upgrade process includes the following stages:

» "Stage 1: Prerequisites" on the next page

« "Stage 2: Install and Upgrade HPE Release Control" on page 52
» "Stage 3: Upgrade Service Desk Adapter to 9.50" on page 53

« "Stage 4: Post Upgrade Recommendations" on page 54

» "Stage 5: Regenerate the encrypted password" on page 55
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Stage 1: Prerequisites

1. If you are using HPE Release Control with HPE Universal CMDB earlier than 9.x, do one of the
following:

o Set HPE Universal CMDB to standalone mode.

Go to Module > Administrator > Configuration tab > Integrations > HPE Universal
CMDB, and in the HPE Universal CMDB version box select No HPE Universal CMDB
(standalone).

or
o Upgrade HPE Universal CMDB to a later version.
2. Make sure that the change request queue is empty as follows:

a. Goto Module > Administrator > Configuration tab > Integrations > Service Desk
Adapters and select the relevant service desk adapter node. The configuration file is
displayed in the right pane. For information about how to edit the configuration file, see
"Working with HPE Release Control Configuration Settings" on page 47.

b. Inthe adapter configuration file, switch the adapter into init-mode as follows:
« Locate the following line:
<l-initial-load-state><last polling time></initial-load-state-->
« Uncomment the line and modify the date/time as follows:
<initial-load-state>[last polling time]</initial-load-state>

Where [last polling time] is any time before the last time HPE Release Control polled
the service desk. Polling occurs every thirty seconds by default.

It is recommended to set the last polling time to a few hours earlier than the current time.
For example, if today's date is 20 January 2016, set the last polling time as follows:

<initial-load-state>1/20/2016 00:00:00 PST</initial-load-state>
c. Restart HPE Release Control and allow it to process all the change requests still in the queue.

d. Make sure the queue is empty using the Queue Manager utility located in <old HPE Release
Control installation directory>\bin.

For more information about using the Queue Manager utility, see the HPE Release Control
User Guide.
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3. Download and save the adapter's settings and script (*.js) files.
4. Stopthe HPE Release Control service.

5. If you were using a Web server (Apache or 11S) with HPE Release Control, remove the Web
server configuration using the Web server configurer utility. To remove it, run the following
command:

<old HPE Release Control installation directory>\bin\WebServerConfigurer.bat remove-
config

Note: After you install the new version of HPE Release Control, if you still want to work with
a Web server, configure it using the Web server configurer utility in the new installation. For
more information, refer to the utilities section in the HPE Release Control User Guide.

6. Back up the database to protect your data in case of an error during the upgrade procedure.

7. Back up the configuration sets. You can back up any existing configuration sets by using the
ExportCs.bat utility to export those configuration sets, or by clicking Administrator >
Configuration > Export configuration set to a zip file in Release Control.

Stage 2: Install and Upgrade HPE Release
Control

1. Install HPE Release Control version 9.50 (see "Installing HPE Release Control" on page 13).

Before you run the installation, review the pre-installation information (see "Before You Install" on
page 10).

2. If you were using encrypted passwords in your HPE Release Control configuration (for example,
the database password), copy (and overwrite) the contents of <old HPE Release Control
installation directory>\security to <HPE Release Control 9.50 installation directory>\security.

3. Configure the database that you want to use with the upgraded version of HPE Release Control.
Update the database.properties file as described in "Configuring the Database or User Schema"
on page 14.

4. From the <HPE Release Control 9.50 installation directory>\bin directory, run Upgrade.bat to
perform the upgrade. When prompted, enter the full path of the old HPE Release Control
installation (for example, C:\HP\RC921).
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5. If you made any changes to the log levels in the ccmlog4j.properties file of your old installation,
manually make the same changes again in the new ccmlogdj.properties file and the
cmdblogdj.properties file.

6. Start the HPE Release Control server.

Stage 3: Upgrade Service Desk Adapter to
9.50

Note: You need to perform the steps in this stage for each service desk adapter that you were
using with your old version of HPE Release Control.

1. From the <HPE Release Control 9.50 installation directory>\bin directory, run SdiConfigurer.bat.
When answering the questions, you must use the same values that existed in the adapter's
settings file of the old HPE Release Control version.

2. Add the adapter to the configuration set. For details, see "Stage 3: Apply Configuration Changes"
on page 28.

3. Save your configuration set, but do not activate it. For details, see "Saving a Draft Configuration
Set" on page 48.

4. If you had previously made changes to the .js files, upload the setting and script (*.js) files of the
adapter that was used in the old HPE Release Control version.

5. Inthe adapter configuration file, configure the adapter to fetch old tickets, thus covering the time in
which the upgrade procedure took place:

o For HPE Service Manager and database adapters: locate the following property:
startFrom=

o Forall other adapters: uncomment the following line and modify the date/time as follows:
<initial-load-state>[last polling time]</initial-load-state>

Where [last polling time] is earlier than the time the upgrade procedure started. Polling
occurs every thirty seconds by default.

For example, if today's date is 20 January 2016, and you started the upgrade process at 2:00
AM, then set the last polling time to midnight:

<initial-load-state>1/20/2016 00:00:00 PST</initial-load-state>
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6. If you are using Remedy as your service desk and you manually added .jar files to the <old HPE
Release Control Installation directory>\tomcat\webapps\ccm\WEB-INF\lib directory, copy the
added files to <HPE Release Control 9.50 Installation directory>\apps\ccrm\WEB-INF\os_ib.

7. Inthe left pane, click the Activate current configuration set % button to activate the selected

draft and apply the new configuration properties to HPE Release Control.

Stage 4: Post Upgrade Recommendations

1. If you did not make any changes to the change-flow.js script of your old installation, it is
recommended to update the new change-flow.js script as follows:

a. InHPE Release Control, select the Module > Administrator > Configuration tab > Change
Process > change flow script node. Content of this file is displayed in the right pane.
Remove all content manually.

b. Browse to the <HPE Release Control 9.50 installation directory>\examples\scripts directory
and open the change-flow.js file with text editing tools.

c. Copy the content of change-flow.js and paste it to the right pane of the change flow script
node.

d. Save and activate the configuration changes (see "Working with HPE Release Control
Configuration Settings" on page 47).

2. Afteryouinstall the new version of HPE Release Control, and you still want to work with a Web
server, you need to configure it using the Web server configurer utility in the new installation. For
information on how to configure the Web server, refer to the utilities section in the HPE Release
Control User Guide.

3. If you were working in identity management mode before the upgrade, and want to continue to do
so after the upgrade, you must reconfigure HPE Release Control to work in identity management
mode. For details, see "Use Identity Management Mode" in the HPE Release Control User Guide.

4. If, previous to the upgrade, you defined time periods, go to Module > Administrator > Time

Periods tab and click the Save Settings ['=| button.
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Stage 5: Regenerate the encrypted password

If you have encrypted passwords, the old encrypted passwords are still valid after upgrade to version
9.50. HPE highly recommends you to re-encrypt the passwords by launching the GenerateKey and the
EncryptPassword utilities again for higher security.

To replace the old Database password:

Go to <HPE Release Control installation directory>\conf directory, open the database.properties file
and then replace the old password with the re-encrypted one.

To replace the old Sdi password:

Go to Module > Administrator > Configuration tab > Integrations > Service Desk Adapters > <sm
adapter> > settings file, and then replace the old password with the re-encrypted one.

To replace the old UCMDB password:

Go to Module > Administrator > Configuration tab > Integrations > HPE Universal CMDB >
Available Connections > <ucmdb server>, and then replace the old password with the re-encrypted
one.

To replace the old LDAP password:

Go to Module > Administrator > Security > Authentication > LDAP mode > LDAP server
properties, and then replace the old password with the re-encrypted one.

For more information about the GenerateKey and the EncryptPassword utilities, see Pasword
Encryption in the HPE Release Control User Guide.

Upgrading HPE Release Control on the
Linux System

1. Copy the new HPE Release Control rpm.bin package to the target computer.
2. Loginthe Linux system as root.

3. Run the following command to enter the directory where the new rpm.bin package is stored:

cd <directory where the new rpm.bin package is stored>
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4. Run the following command to extract rpm package from the rpm.bin package:
.Irelease-control-9.50-0001.x86_64.rpm.bin -x
The End User License Agreement is displayed and you are prompted to agree to its terms.
The release-control-9.50-0001.x86_64.rpm package is extracted to the same directory.

5. Execute the following command to ensure that the execute permission is set:
chmod u+x release-control-9.50.0001.x86_64.rpm

6. Run the following command:
rpm -Uvh release-control-9.50-0001.x86_64.rpm

7. Restart the HPE Release Control daemon by running the following commands successively:
lopt/HP/rc/stop.sh

lopt/HP/rc/start.sh
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This chapter provides FAQ information about HPE Release Control installation and configuration

issues and provide solutions.

This chapter includes:

How to Use Two Change Adapters to Pull Change Tickets and How to Use Different Ways to

Calculatethe Risk Value ... ... . 57
How to Set up Release Control and Service Manager Integration When SSLIsUsed .............. 58
How to Set up Users in Release Control Without LDAP Group Mapping ............................. 60
How to Translate the Label fora Custom Field ... . ... . ... ... ... .. ... ... ... 64

How to Use Two Change Adapters to Pull
Change Tickets and How to Use Different
Ways to Calculate the Risk Value

Issue

How to use two change adapters for pulling change tickets, one for the changes in Service Manager
and another for the mainframe changes (for example, DB adapter)?

For these two kinds of changes, how to use different ways (UCMDB risk/specified Risk calculation) to

calculate the risk value?

Solution

Though HPE Release Control has no Ul component for the aforementioned configuration currently, you
can update the change script to accomplish these tasks.

Refer to the following steps as an example:

1.
2.

Import two Service Desk adapters: sd1 and sd2.

In HPE Release Control, browse to Administrator > Configuration > Integrations > Field and

add a customized field named service-desk.
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3.

6.

Browse to Administrator > Configuration > Integrations > sd1 > convertChange.js, and add a
code line to function convert:

function convert(sm_rfc, generic_rfc) {

Apply the same configuration to sd2 > convertChange.js as described in the previous step.

Browse to Administrator > Configuration > Change Process > change flow script and add
the following code lines to function overrideRisk:

function overrideRisk(prevChange, newChange, analysis, result) {
//----- Example: maximize risk when change tickets from isdli adapter
if (newChange.getField("service-desk")== "sd1"){

result.risk= 100;

}

}

Restart the HPE Release Control service. Now changes from sd1 will get risk calculation.

For more functions which can be invoked by a change flow script, refer to the RiskAnalysis,

Raw

RiskFactorCalculationResult, and OverrideRulesResult classes in HPE Release Control AP/

Reference.

How to Set up Release Control and
Service Manager Integration When SSL

Is

Used

Issue

How

to set up HPE Release Control and Service Manager integration when SSL is used?

Solution

Refer to the following steps as an example of the SSL configuration with Tomcat:

1.

HPE

Generate the KeyStore file. (If you have the certificate file, you can skip this step.)

a. Open the Windows command prompt. Change directories to the Java platform's bin folder by
typing the following command:
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cd %JAVA_HOME%/bin
b. Type the following command to create a private key and KeyStore for HPE Release Control:

keytool -genkey -alias <rctracer> -keypass <rcadmin> -keystore <rctracer.bin> -
storepass <rcadmin> -keyalg RSA

Replace the parameters in angle brackets according to your requirements. Note that both the
keypass and storepass passwords should be the same. The .bin file is actually your
KeyStore file.

c. When keytool prompts you for your first and last name, type your personal information as
required.

d. When keytool prompts you for the organization unit, organization, city or locality, state or
province, and two-letter country code, type the identification information for your company.

e. Verify the information you provided and type ves if it is correct.
f. Change directories to the Java platform's bin folder and verify the rctracer.bin file is created.

2. Configure Tomcat to use the KeyStore file.

a. Copy rctracer.bin to the webapps folder of Tomcat.
b. Browse tothe servers/server-0/conf directory and open server.xml.

c. Findthe Connector port="8443" element and uncomment it. And add two code lines under
clientAuth:

<Connector port="8443" protocol="org.apache.coyote.httpll.HttpliNioProtocol"
maxThreads="150" SSLEnabled="true" scheme="https" secure="true"
clientAuth="false" sslProtocol="TLS"

keystoreFile="replace your keystore file path"

keystorePass="replace your keystore password" />

Note: Alternatively, you can add the following codes for security configuration:

<Connector port="8443"
protocol="org.apache.coyote.httpll.HttpliNioProtocol"

maxThreads="150" SSLEnabled="true" scheme="https" secure="true"
clientAuth="false" sslProtocol="TLS"

keystoreFile="replace your keystore file path"

keystorePass="replace your keystore password"
ciphers="TLS_ECDHE_RSA WITH_AES_ 128 CBC_SHA,TLS_ECDHE_RSA WITH_AES 256
CBC_SHA,

TLS_ECDHE_ECDSA _WITH AES_256_ CBC_SHA,TLS_ECDH_ECDSA WITH AES_ 256 CBC_
SHA,

TLS_ECDH_RSA _WITH_AES 256 CBC_SHA,TLS_ECDHE_ECDSA WITH_AES_128 CBC_SHA,
TLS_ECDH_ECDSA_WITH AES_ 128 CBC_SHA,TLS_ECDH_RSA WITH_AES 128 CBC_SHA,
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TLS_ECDH_ECDSA_WITH_RC4 128 SHA,TLS_ECDH_RSA WITH_RC4 128 SHA,
TLS_RSA_WITH_AES_256_CBC_SHA,TLS_RSA WITH_AES_128 CBC_SHA" />

d. Save and close the file.

Note: If there are multiple nodes, you need to modify the server.xml file for every node.

3. Configure the web server application to work with SSL.

a. Browse tothe apps/ccm/WEB-INF directory of your web server application and open
web.xml. Add the following XML fragments before </web-app>:

<security-constraint>

<web-resource-collection>
<web-resource-name>securedapp</web-resource-name>
<url-pattern>/*</url-pattern>
</web-resource-collection>

<user-data-constraint>
<transport-guarantee>CONFIDENTIAL</transport-guarantee>
</user-data-constraint>

</security-constraint>

b. Save and close the file.

How to Set up Users in Release Control
Without LDAP Group Mapping

Issue
How can users be set up in HPE Release Control without LDAP group mapping?
Solution

If an organization does not use LDAP groups for applications, or not being able to authenticate via
LDAP is unacceptable, an HPE Release Control administrator can still set up users.

Refer to the following steps as an example:

1. Import Administrator users into HPE Release Control database.

a. Prepare atext file with the following format and save it as Idap_users.csv in the <HPE
Release Control installation directory>\bin\ directory.
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2.

HPE

USERNAME , PASSWORD, FIRST_NAME, LAST_NAME, EMATL ,BUSINESS_ID,ROLE
jdoe, ,John,Doe, jon.doe@hpe.com, jdoe,System Administrator
jimmy,,,,,,Change Manager

« List the users to whom you want to grant a non-default role in this file. You must grant the
System Administrator role to a user. Note that the administrator user you granted here
refers to the HPE Release Control administrator.

« Make sure that the users listed in the file also have access to the LDAP server. Otherwise,
authorization issues will occur when LDAP is enabled.

« You can keep some fields empty except for the "USERNAME", which refers to the LDAP
attribute to be specified for the usersuniqueIDAttribute property in Idap.properties in
Step 2-c.

b. Open the Windows command prompt. Change directories to <HPE Release Control
installation directory>\bin\ and run the ImportUsers.bat command by using the default user
admin:

[ Administrator: Command Prompt

Microzsoft Windows [Uerszion 6.0.6H082]
Copyright ¢c> 2886 Microsoft Corporation. All rights reserved.

C:~Usersvadmin>cd C:~HP~RC?16-hin

C:~HP~RC?i8~hin>*ImportlUsers.bat —f ldap_users.csv —r 3 —u admin —p admin
jdoe (jdoe): success
Cjimmyl: warning
updated
raw data: jimmy Change Manager

import result: warning

C:~HP~RC?18bin>_

In the screenshot, a Warning is shown because the user jimmy already exists in the
HPE Release Control database. This user profile will be updated.

In HPE Release Control, configure LDAP to be used without group mapping.
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a. LogintoHPE Release Control as the administrator and set the Authentication mode to LDAP:

Module Freferences Help

tonfiguration | Time Periods | Business CIs | Users

Time zone: (GMT) Greenwich Mean Time : Cublin, Edinburgh, Lisbon, Lando

docz
B
PE Change Process
L E In-House Docurnentation
FE Integrations
FE Labels and Terms
w5 Modules
v [ security

PE Authentication *

[ ] HPE Lightwsight 550 [Lwss0)

b5 server

Authentication

Authentication mode:

LDAP

b. Configure LDAP mode details and pay attention to the following items:

« Select arole (for example, User) as the Default role. Refer to the following steps for how to
update a user's role and grant access to the Administration module under LDAP mode.

« Theroles are pre-defined in HPE Release Control out-of-box system. To meet the actual

requirement, run the ManageRoles.bat command to create your own roles. For example:

<HPE Release Control installation directory>\bin\ManageRoles.bat -c -r
NewRole -a <permission namel> <permission name 2> .....

Refer to the HPE Release Control User Guide > Appendices > Utilities > Role Manager
section for more details.

[Email header], [First name header] and [Last name header] refertothe
corresponding LDAP attributes' names.

« Do NOT select the Role synchronized checkbox. After a user logs in for the first time,
HPE Release Control will get the user's role from the database instead of taking the
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Default role.

Module Freferences Help

Time zanei (GMT) Grzenwich Maan Time 1 Dublin, Edinburgh, Lishan,

w3 change Frocess
b In-House Docurmentation
»[3 Integrations
» [ Labels and Terms
b Modules
v [ security
v [ Authentication *

L] Database Mode

» 5 LoAP Made *

w3 server

3. Configure LDAP Server Properties.

[} 1dentity Manager Made

[} HPE Lightweight 550 [LW5S0)

Configuration | Tirme Periods | Business Cls Users |
docz LDAP Mada
B A 2

Drefault rales:

Email header:

First name header:

Last name header:

Usar

rail

givenMame

sn

Role synchronized:

] | Don't mark the checkbox

LDAP Groups to Release Control Roles Mapping
[l

LDAP group name:

T
i Release Control roles:

a. Browse tothe <HPE Release Control installation directory>/examples/Idap-examples
directory and select one properties template file according to your LDAP server type. For
example, select Idap.properties.SO for the openDS LDAP server.

b. Open the selected template file and update the properties besides the group-related ones.

c. Afterthe update is complete, save and rename this file to Idap.properties. Upload it to RC:

Module Preferences Help

Configuration | Time Petiods | Business Cls

Time zone: (GMT) Greenwich Mean Time ; Dublin, Edinburgh, Lisban, Lot

Idap
B A8
>[5 change Process
» 5 In-House Docurnentation
[ Integrations
» [ Labels and Terrms
» 5 Medules
v [ security
v Authentication
[ Database Made
[7] 1dentity Manager Made
v LpaP Mode
[} LDAP Server Properties

(] HPE Lightweight 550 (LwS50)

IE Server

LDAP Seruer Properties

Idap. proparties

® ®
& SunOns cenfiguration example &

[ [

# Hostname of the machine running the LD &P server

|dapHost = localhost

# Part number of the machine running the LDAP servers in case if enableSSL aption is used, this is S5L port number

|dapPort = 369

Dowmload:  |dap,properties Type: properties

d. Save the configuration set with a new name. The following warning message might appear:
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Problems

Code |.& | Description

RC-00202 Ab Mo group mapped to a role containing the editConfiguration permission, This will make the LDAP configuration irraversible

This warning appears because no LDAP group is mapped to a role with administrator
permission. Ignore this warning.

e. Activate the configuration set.
f. Logout of HPE Release Control.
4. Loginto HPE Release Control as a LDAP user.

a. LogintoHPE Release Control as a LDAP user. HPE Release Control will connect to the
LDAP server for password authorization, and then it will check that if this user already exists
in the database. If yes, HPE Release Control will grant the role from database to this user.
Otherwise, HPE Release Control will grant the default role (User) and a new user will be
created in RC database.

b. Afterthe new LDAP user login with the default role, you can still update his role by running the
ImportUsers.bat command (use jdoe, the new HPE Release Control administratorin LDAP

mode now).

How to Translate the Label for a Custom
Field

Issue

When delivering HPE Release Control in more than one language, how to translate the label (or other
properties, such as toolTip, colHeader) for a custom field?

Solution

Refer to the following steps as an example:

1. GotoModule > Administrator > Configuration > Integration > Fields and select the custom
field you added in the Available Fields list.

2. Inthe Field Definition tab, set the value of Label field to properties-file. This value will
automatically change to fields.<custom field name>.label if this key does not exist in the
fields-labels.properties file, or change to the value mapped to the key if it exists in the fields-
labels.properties file.
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3. Inthe List Layout tab, set the value of Header field and Header tooltip field to properties-
file.

4. Inthethe Details Layout tab, set the value of Label field and Tooltip field to properties-file.
5. Inthe Filter Layout tab, set the value of Label field and Tooltip field to properties-file.

6. Add the required keys and value to the fields-labels.properties file.

For example, if you add a new field "my-field" with the default lable "My field" and hope to translate
this lable to French, add Fields.my-field.lable=Mon libelle to the language file fields-
labels.properties (or fields-labels_fr_FR.properties).

7. Save and active the configuration set.

8. Restart the HPE Release Control service.
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Send documentation feedback

If you have comments about this document, you can contact the documentation team by email. If an
email client is configured on this system, click the link above and an email window opens with the
following information in the subject line:

Feedback on Deployment Guide (Release Control 9.50)
Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a web mail client, and
send your feedback to ovdoc-ITSM@hpe.com.

We appreciate your feedback!
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