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Before You Install

Welcome to WinRunner, Mercury Interactive’s automated software testing 
tool for Windows 95, Windows 98, and Windows NT 4.0. This guide 
describes everything you need to know to install WinRunner on a 
standalone computer and on a network. It describes the WinRunner package 
contents, system configuration, registration and backup procedures, and 
how to run the setup program.

Before you begin to install WinRunner, please review the following pre-
installation procedures.

Checking Your WinRunner Package

Please make sure that your WinRunner package contains the items described 
below. If any items are missing or damaged, contact Mercury Interactive or 
your local distributor.

Program Disks

Your WinRunner package contains 1 CD-ROM.

Documentation

In addition to this installation guide, your WinRunner package contains the 
following printed materials:

➤ WinRunner Tutorial

➤ WinRunner User’s Guide

➤ Registration Card
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Registering Your Copy of WinRunner

Register your copy of WinRunner to become a licensed user with all rights 
and privileges. Registered users have access to technical support and 
information on all Mercury Interactive products. You will also be eligible for 
updates and upgrades.

To register your copy of WinRunner, fill out the Mercury Interactive 
Software Registration card.

➤ If you are in the USA, fill out the USA Owners portion of the card. Send the 
card to the Sunnyvale, California address printed on the card. No postage is 
necessary.

➤ If you are outside the United States, fill out the Non-USA portion of the 
registration card and send it to the appropriate international address. Affix 
postage to the card before mailing.

Remember to notify Mercury Interactive or your local representative if you 
move to a new address, so that you can continue to receive product 
information and updates.

Note: You can also register your copy of WinRunner on Mercury 
Interactive’s Customer Support site (http://web.merc-int.com).
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System Configuration

In order to successfully run WinRunner, you need the following minimum 
system configuration:

Platform An IBM-PC or compatible with a 486 
microprocessor or higher. For best performance, a 586 
microprocessor is recommended.

Memory At least 16 MB of RAM memory. For best performance, 
32 MB is recommended.

Disk Space At least 29 MB of free disk space for a compact 
installation or 74 MB for a typical or complete 
installation. (An additional 5 MB of free disk space are 
required during the installation process.) Additional 
disk space is required if you install support for Visual 
Basic or PowerBuilder applications.

Operating System Windows 95, Windows 98, or Windows NT 4.0.

Upgrading from a Previous Version

You can install a standalone version of WinRunner over a previous version. 
Note that any changes made to the tests in the \lib directory or in any other 
files will be overwritten. However, the existing \lib directory will be backed 
up as \lib.bak. Note that if lib.bak already exists, the existing \lib directory 
will not be backed up. It is recommended that you save separately any files 
that you added or changed manually before installing WinRunner 5.0 over a 
previous WinRunner installation. Note that configuration changes made in 
the wrun.ini file will not be overwritten when installing WinRunner 5.0.

Installing on Windows NT

If you are installing WinRunner on a Windows NT machine, make sure you 
have administrator permissions before you run the setup program. If you try 
to install WinRunner on a Windows NT machine without administrator 
privileges, you will receive a warning message and the setup program closes.
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Installing WinRunner

You can install WinRunner on a local computer or on a network drive. 
Following are the main steps for each type of installation:

Standalone Installation

➤ Install WinRunner using the Standalone option.

➤ Connect the Mercury Interactive HASP Plug to a parallel port on your 
computer.

➤ If you are testing a Visual Basic application, configure Visual Basic support.

Network Installation

➤ Install WinRunner using the Network option.

➤ Run the workstation installation on each user workstation.

➤ Connect a Mercury Interactive HASP plug to the parallel port of each 
workstation.

➤ If you are testing a Visual Basic application, configure Visual Basic support.
4
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To install WinRunner:

 1 Insert the CD-ROM into the drive from which you want to install. If the CD 
drive is on your local machine, the WinRunner Setup window opens. If you 
are installing from a network drive, connect to it and run autorun.exe under 
the \setup subdirectory.

If you want to view the Readme file, click Readme. If you want to browse the 
WinRunner Installation CD, click Browse.

 2 Click Install. The WinRunner setup program starts. The WinRunner Setup 
splash screen and the Setup progress bar open.

 3 The software license agreement appears. To accept the terms of the license 
agreement, click Yes. If you click No, the setup program will close. To install 
WinRunner, you must accept the license agreement.
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 4 In the Registration Information dialog box, type your name, the name of 
your company, and a WinRunner serial number. You can find this number 
on the outside of your WinRunner box.

Click Next to proceed.

 5 Click Yes to confirm the registration information.
6
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 6 Do one of the following:

➤ To install on a hard disk of a local computer, select Standalone Installation.

➤ To install on a network drive, select Network Installation.

➤ To install on a network drive and configure your workstation to run 
WinRunner from the network, select the third option. 

Note: You cannot install a network installation over a previous version of 
WinRunner.

Click Next to proceed.
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 7 If relevant, install additional support for Visual Basic applications, 
PowerBuilder applications, and ActiveX controls. 

Click Next to proceed.
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 8 Choose the type of installation: Typical, Compact, or Custom.

Typical Installation installs commonly-used program files, including online 
documentation and samples.

Compact Installation installs only the required WinRunner program files, 
without online documentation or samples.

Custom Installation enables you to select the components you want to 
install.

Click Next to proceed.
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 9 If you chose Custom Installation, select the components you want to install 
and specify the destination folder. To check the space available on a disk 
drive, click Disk Space.

Click Next to proceed.
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 10 If you chose Typical or Compact Installation, specify the destination folder. 
To check the space available on a disk drive, click Disk Space.

Click Next to proceed.
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 11 If you selected Network Installation and add shortcuts to your Start menu 
earlier in the setup, select a location for the local WinRunner folder. This 
folder will allow you to configure WinRunner to meet your specific testing 
requirements, while running a shared version over the network.

Click Next to proceed.
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 12 Choose the location of your WinRunner temporary folder. 

Click Next to proceed.

 13 Review the settings you selected. To select different settings, click Back. To 
confirm the settings, click Next.

The installation process begins. To pause or quit the installation process, 
click Cancel.
13
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 14 Select the program folder for the WinRunner icons.

Click Next to proceed.

 15 A message prompts you to connect the Mercury Interactive HASP Plug to a 
parallel port on your computer. Click OK to continue.

 16 Read the information about accessing online documentation. If you 
installed additional support for Visual Basic, PowerBuilder, or ActiveX 
controls, more information appears on your screen. Click Next to proceed.

 17 Read the information about Mercury Interactive’s Customer Support. Click 
Next to proceed.

 18 The installation process is complete. If you installed WinRunner on your 
hard disk (Standalone option), you need to restart your computer. If you 
installed WinRunner on the network, run a workstation installation on all 
workstations. See the next section for details.

➤ To read what’s new in WinRunner and any last-minute information, click 
Programs > WinRunner > Read Me on the Start menu.

➤ To view the WinRunner online books, you must have Acrobat Reader 3.01 
installed. You can install it by clicking Programs > WinRunner > 
14
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Documentation > Acrobat Reader 3.01 Setup on the Start menu. To view 
online books, click the WinRunner Books Online command.

➤ To start WinRunner, click Programs > WinRunner > WinRunner on the Start 
menu.

Running a Workstation Installation

A workstation installation should be performed for each user running 
WinRunner from the network. This installation can be performed only after 
the network installation is successfully completed. 

 1 Choose Run on the Start menu.

 2 Type installation_directory\setup\setup.exe and click OK.

 3 The software license agreement appears. To accept the terms of the license 
agreement, click Yes. If you click No, the setup program will close. To install 
WinRunner, you must accept the license agreement.

 4 In the User Information dialog box, type your name and click Next to 
proceed.

 5 Click Yes to confirm the registration information.

 6 Confirm the workstation installation message and click Next to proceed.

 7 Define the location for the local WinRunner folder.

The WinRunner folder on your hard drive is used to store configuration files 
you create during the testing process. Configuration files in this folder 
override configuration files of the same name on the network. This enables 
you to configure WinRunner to your specific testing requirements.

Click Next to proceed.

 8 Select the location of your WinRunner temporary folder. The installation 
process begins. To pause or quit the installation, click Cancel.

Click Next to proceed.

 9 Define the program group for the WinRunner icons.

Click Next to proceed.
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 10 A message prompts you to connect the Mercury Interactive HASP plug to a 
parallel port on your computer. Click OK to continue.

 11 Restart your computer. The WinRunner program folder is added to your 
Start menu.

➤ To read what’s new in WinRunner and any last-minute information, click 
Programs > WinRunner > Read Me on the Start menu.

➤ To view the WinRunner online books, you must have Acrobat Reader 3.01 
installed. You can install it by clicking Programs > WinRunner > 
Documentation > Acrobat Reader 3.01 Setup on the Start menu. To view 
online books, click the WinRunner Books Online command.

➤ To start WinRunner, click Programs > WinRunner > WinRunner on the Start 
menu.
16
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Configuring Visual Basic 4.0 Support

Before you can start using WinRunner's extended support for Visual Basic 
4.0 in Windows 95, Windows 98, or Windows NT Visual Basic applications 
(32-bit), you need to compile the WinRunner OCX (wrvb40.ocx) in the 
application under test.

To configure 32-bit Visual Basic 4.0 support:

 1 Start Visual Basic 4.0 and open the project.

 2 Select the Custom Controls command from the Tools menu.

 3 In the Custom Controls dialog box, select the Wrvb40 OLE Custom Control 
Module item. Click OK. The item is added to the toolbar.

 4 Drag the new item onto the main application form.

 5 Right-click this object and select View Code.

 6 Select Form from the Object pulldown.

 7 Insert the following line into the beginning of the Form_Load function: 

Wrvb1.Init Forms

For example:

Private Sub Form Load ()
...
Wrvb1.Init Forms
...
End Sub

 8 Run or recompile your application and run the .exe file.
17
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Enabling Table Contents Checks for an OCX Control

To enable support for contents verification on any OCX that can be viewed 
as a table object, you must implement a capture function for the OCX in 
Visual Basic and then execute a TSL function.

WinRunner includes Visual Basic project files (wrvbsrv4.vbp for Visual Basic 
4.0 and wrvbsrv5.vbp for Visual Basic 5.0) that compile into an OLE 
Automation Server. WinRunner uses this server to capture table contents. 

Follow these steps to enable contents verification on an OCX that can be 
viewed as a table object:

 1 Start Visual Basic 4.0 or Visual Basic 5.0.

 2 In Visual Basic, open the appropriate wrvbsrv project file (wrvbsrv4.vbp or 
wrvbsrv5.vbp) located in the WinRunner installation folder under 
custom\wrvbsrv.

 3 Open capture.cls and add a Sub with the following prototype:

Public Sub<CaptureFunctionName>(ByVal <tab_ctrl> As Object, ByVal 
<file_name> As String)

The function should dump the table contents of the OCX control into 
<file_name> in the following format:

cells separated by Tab(Chr(9)), rows separated by Newline.

Note: Cell data should not contain escape characters such as Tabs or 
Newlines. Cells in the first row (Column Titles) should not contain either 
escape characters or space characters. See the MSGridCapture Sub for an 
example.

 4 Compile the project into a dll.

For Visual Basic 4.0, from the File menu select Make OLE DLL file.

For Visual Basic 5.0, from the File menu select Make WRVBSRV DLL file.
18
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 5 In WinRunner, execute the ole_add_class_to_gui_ver TSL function. Set the 
“Table Capture” argument to the name of the Sub you implemented in the 
Visual Basic function. For example:

ole_add_class_to_gui_ver ("MSGrid.Grid", "Enabled", "MSGridCaptureFunc");

For more information on ole_add_class_to_gui_ver, refer to the TSL Online 
Reference.
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Configuring Visual Basic 5.0 Support

WinRunner’s add-in support for Visual Basic 5.0 applications includes all the 
support provided for Visual Basic 4.0 applications, plus:

➤ all standard Visual Basic 5.0 controls

➤ Visual Basic projects that create ActiveX controls

Preparing Your Visual Basic Application

Before you can start testing a Visual Basic application using WinRunner’s 
add-in support for Visual Basic 5.0, the application developer must add the 
WinRunner agent to the application. To do so, the developer runs the 
setup.exe program from the \vbdev directory on the WinRunner 
installation CD-ROM.

Note that if the application currently references the WinRunner OCX, you 
must first remove all references from forms, as well as the associated code 
(Wrb1.Init Forms).

The WinRunner agent installation installs an AddIn to your Visual Basic 
IDE. The name of this AddIn is WinRunnerAddIn.Connect. It adds lines of 
code to your Visual Basic source code.

WinRunnerAddIn.Connect

➤ adds a reference to the wrvbasr.dll component

➤ adds a new code Module to the Visual Basic project called 
“WinRunnerSupport”

➤ adds a line to the WinRunnerSupport Module:

Global asr As New WRVBASRLib.VbMod

➤ adds code to the StartUp object:
20
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If the Startup Object is a Form, the AddIn adds the following line of code to 
the Form_Load event:  asr.Init Forms

If the Startup Object is Sub Main, the AddIn adds the following line of code 
to the Main() method:  asr.Init Forms

➤ For all Class modules in the project, the AddIn adds the following line of 
code to the Class_Intialize event:  asr.Init Forms

➤ For all UserControl modules in the project, the AddIn adds the following 
line of code to the UserControl_Intialize event: asr.Init Forms, UserControl

➤ For all UserDocument modules in the project, the AddIn adds the following 
line of code to the UserControl_Intialize event: asr.Init Forms, UserDocument

Notes: If the error message “DllRegisterServer in <windows 
directory>\system\wrvbasr.dll failed” appears during the WinRunner agent 
installation, copy the file oleaut32.dll (version 2.20.4054.1 or higher) to 
your system directory and re-install the WinRunner agent. 

Do not run WinRunner and the Visual Basic IDE together.

Test your application only as a running executable.
21
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Adding WinRunner Components

Once you install WinRunner, you can run the setup program at any time to 
add program components, such as additional development environment or 
control support, samples, or online documentation.

To add components:

 1 Insert the CD-ROM into the drive from which you want to add WinRunner 
components. If the CD drive is on your local machine, the WinRunner 
Setup window opens. If you are installing from a network drive, connect to 
it and run autorun.exe under the \setup subdirectory.

 2 Click Install. The WinRunner setup program starts. The WinRunner Setup 
splash screen and the Setup progress bar open.

 3 The software license agreement appears. To accept the terms of the license 
agreement, click Yes. If you click No, the setup program will close. To install 
additional WinRunner components, you must accept the license agreement.

 4 In the User Information dialog box, type your name, the name of your 
company, and a WinRunner serial number. You can find this number on the 
outside of your WinRunner box. Click Next to proceed.

 5 Click Yes to confirm the registration information.

 6 Select your installation type: Standalone Installation, Network Installation, 
or Network Installation and add shortcuts to your Start menu. Click Next to 
proceed.

 7 If relevant, select the additional support you want to add (Visual Basic, 
PowerBuilder, and/or ActiveX Controls). Click Next to proceed.

 8 Choose Custom Installation. Click Next to proceed.

 9 Select the components you want to install and specify the destination 
folder. In the Choose Destination Location window, click Next to confirm 
the location of your WinRunner files.

If you select a component that is already installed, you are prompted to 
overwrite it. To overwrite existing components of WinRunner, click the 
22
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Overwrite button. If you do not want to overwrite existing components of 
WinRunner, click Cancel. The previous window reopens and you can 
modify your selection.

 10 The installation settings you selected are displayed in a read-only window. 
Review the settings. If you want to select different settings, click Back. If you 
are satisfied with the settings, click Next. 

The installation process begins.

To pause or quit the installation process, click Cancel.
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Uninstalling WinRunner

Your WinRunner installation includes an uninstall program which 
uninstalls WinRunner software and files from your computer and removes 
WinRunner shortcuts from your Start menu. 

To uninstall WinRunner:

 1 Choose Programs > WinRunner > Uninstall WinRunner on your Start menu.

The Uninstall Shield window opens.

 2 You may be prompted to removed shared files that are not in use by any 
program. If you are not sure what to do, click No to All.

The Uninstall Shield removes WinRunner from your computer.

 3 When the Uninstall program is completed, the OK button is enabled. Click 
OK.
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