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Chapter 1: Introduction
This guide explains processes and procedures that help you to migrate data from the
previous versions of HP SHR (9.x) to current version of HPE OBR. It provides
information about preparing, migrating and validating your system post migration.

Note: HP Service Health Reporter is now HPE Operations Bridge Reporter.

Need for Migration

HP SHR 9.x bundles the following components:

l HP SHR 9.x server
l SAP BusinessObjects server
l Sybase IQ server
l Remote Collector
HPE OBR 10.x bundles the following components:

l HPE OBR 10.x server
l SAP BusinessObjects server
l Vertica server
l Remote Collector
You have to migrate data from previous versions of HP SHR (9.x) to current version of
HPE OBR system for the following reasons:

HP SHR 9.x HPE OBR 10.x

Used SAP BusinessObjects 3.x as the reporting
platform

Uses SAP BusinessObjects 4.x as the
reporting platform

Used Sybase IQ as the database Uses Vertica as database

Sybase IQ database supported onWindows 2008
operating system

Vertica database is supported only on Linux
operating system

For more information on the supported operating system, see HPE Operations Bridge
Reporter Support Matrix.

Audience

The information in this guide is intended for users who have administrator access.
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Chapter 2: Migration Process Overview
This section gives you an overview of the migration process from HP SHR 9.x to HPE
OBR 10.x in different deployment options using the Side-by-Side migration.

In Side-by-Side migration, HPE OBR 10.x is installed on a different system and the data
is migrated from HP SHR 9.x to HPE OBR 10.x system. Additional systems are required
for this type of migration. This migration method ensures HP SHR 9.x system is
functional until HPE OBR 10.x is operational on a parallel system.

Note: For information to install HPE OBR 10.x using different install scenarios, see
HPE Operations Bridge Reporter Interactive Installation Guide.

Migration of Typical Install (Single System)

Following is the approach for migration of HP SHR 9.x typical install:

On Linux

l Install HPE OBR 10.x on a Linux system. Apply the HPE OBR 10.01 patch.
l Migrate data and configuration from HP SHR 9.x to HPE OBR 10.x system.
l Validate the HPE OBR 10.x and decommission HP SHR 9.x system.
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On Windows

l Install HPE OBR 10.x server on Windows 2012 and database (Vertica) on Linux.
Apply the HPE OBR10.01 patch on both the servers.

l Migrate data and configuration from HP SHR 9.x to HPE OBR 10.x system.

l Validate the HPE OBR 10.x and decommission HP SHR 9.x system.

Migration of Custom Install (Distributed System)

Following is the approach for migration of HP SHR 9.x custom install:

On Linux

l Install HPE OBR 10.x server and database on different systems. Apply the HPE OBR
10.01 patch on both the servers.

Note: In a custom install scenario, make sure that the HPE OBR 10.01 patch is
applied to all the HPE OBR component servers.

l Migrate data and configuration to HPE OBR 10.x
l Validate the HPE OBR 10.x and decommission HP SHR 9.x.
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On Windows

l Install HPE OBR 10.x server on Windows 2012 and database (Vertica) on Linux
systems. Apply the HPE OBR 10.01 patch on both the servers.

Note: In a custom install scenario, make sure that the HPE OBR 10.01 patch is
applied to all the HPE OBR component servers.

l Migrate data and configuration from HP SHR 9.x and import it to HPE OBR 10.x.
l Validate the HPE OBR 10.x and decommission HP SHR 9.x.

Vertica Appliance Hosted on Windows

For typical or custom installation on Windows Operating System, if there is a concern in
migrating the Operating System to Linux, Vertica Virtual Appliance (VA) can be hosted
on Windows Operating System.

For information on Vertica VA, see HPE Operations Bridge Reporter Database Virtual
Appliance Deployment Guide.

Side-by-Side migration of Typical Install (single system)

Following is the approach for migration of HP SHR 9.x typical install on Windows
operating system:

Migration Guide
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l Install HPE OBR 10.x on a Windows system along with Vertica VA. Apply the HPE
OBR 10.01 patch.

l Migrate data and configuration from HP SHR 9.x to HPE OBR 10.x.
l Validate the HPE OBR 10.x and decommission HP SHR 9.x.

Side-by-Side migration of Custom Install (distributed system)

Following is the approach for migration of HP SHR 9.x custom install on Windows
operating system:

l Install HPE OBR 10.x server and Database VA on different systems. Apply the HPE
OBR 10.01 patch on both the servers.

Note: In a custom install scenario, make sure that the HPE OBR 10.01 patch is
applied to all the HPE OBR component servers.

l Migrate data and configuration to HPE OBR 10.x
l Validate the HPE OBR 10.x and decommission HP SHR 9.x.

Migration Guide
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Chapter 3: Getting Started
This chapter helps you to prepare for migration before you start the migration process.

Planning for Migration

Perform the following steps to prepare for migration:

1. You must ensure that the system(s) that you plan to install HPE OBR 10.x is ready
with all the sizing requirements completed.

Note: The requirements for the HPE OBR 10.x setup is significantly different
from HP SHR 9.x. For HPE OBR 10.x sizing information, see HPE Operations
Bridge ReporterPerformance, Sizing and Tuning Guide. For sizing calculations,
see HPE Live Network - OBR Licensing and Sizing Calculator. For information
on supported Operating System, see HPE Operations Bridge Reporter Support
Matrix.

2. Identify the data that has to be migrated. Also, identify the Content pack and the
amount of data that you want to migrate.

3. Following are the storage requirements for HP SHR 9.x system for data export:
a. Migration process is input/output intensive and the performance of migration is

highly dependent on the disk performance. It is recommended to use a disk with
15,000 rpm or high performance for Migration.

b. You must make sure that the disk is accessible from the HPE OBR 10.x system
during import.

c. The calculator feature in Migration can be used to calculate the downtime and
the disk space required for exporting the specified data. For steps, see Task 2:
Migration Precheck > Step calc.

4. Sybase IQ database in HP SHR 9.x uses main, temporary, and large buffer caches
for database operations. You can increase the value of the buffer cache using the
parameters iqmc, iqtc and iqlm located in the {PMDB_HOME}
/config/pmdbconfig.cfg file for better database performance. Depending on the
physical memory available in the system you can allocate the memory to the Sybase
IQ database.
After changing the values of the buffer cache, you must restart the Sybase IQ
database.

5. Take a backup of the existing HP SHR data. For more information on backup, see
the relevant version HP Service Health Reporter Disaster Recovery Guide.
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6. Migrating from HP SHR 9.x to HPE OBR 10.x does not require a new license key.
If there is a change in IP address, the rehost option in Licensing portal can be used
to obtain the license key. You can either use the new Software Entitlement system
website or log on to Administration Console and go to Administration > Licensing
> Launch HP Password Center and use the rehost option.

7. Identify the content that requires manual migration. The configurations that should
be manually created in HPE OBR 10.x post migration are:
a. HPE OBR 10.x uses the new universe format (unx) so schedules cannot be

migrated. You should plan to recreate the schedules post migration.
b. LDAP Settings and Server configuration settings on SAP BusinessObjects.
c. User rights configured in SAP BusinessObjects.
d. Users, User Groups and most of the Access Control List (ACL) can be migrated.

However, the access level settings at folder, report or any other objects are not
migrated. You should manually apply the security settings for each objects after
migration to realign with the previous ones.

Note: The SAP BusinessObjects default users are not migrated.

e. Security configuration: https, SSO and Client Authentication Certificate.

Note: The SAP BusinessObjects audit database and Orchestration (ABC)
history data cannot be migrated.

8. Determine if you have custom content deployed on your HP SHR 9.x instance and
plan the migration for custom content. Refer Migration Steps for Custom Content
section for more details.

Migration Best Practices

Following are the best practices to reduce downtime during migration:

l Migrate in chunks - this helps to bring the HPE OBR 10.x system up early and start the
collections.

l Threads: This is a tunable parameter in Migration.conf file which gets created after
precheck. The default value is 20. If the I/O is under utilized then the value for the
threads can be increased.
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Chapter 4: Migration Steps
This chapter guides you with the steps to perform migration.

Task 1: Pre-migration

1. Install HPE OBR 10.x. You can choose to install different components of HPE OBR
on a single system or different systems. For information on HPE OBR 10.x
installation, see HPE Operations Bridge Reporter Interactive Installation Guide.
If you have configured Remote Collectors, ensure that the number of collectors
configured in HPE OBR 10.x should be same as the number of collectors configured
in HP SHR 9.x.

2. Perform the Post-installation steps. For more information on post-installation steps,
see HPE Operations Bridge Reporter Configuration Guide.

Note: You must not configure the Data Source and Topology Source at this
stage.

Deploy the same set of content packs that were deployed on HP SHR 9.x system on
HPE OBR 10.x using the Deployment Manager in the Administration Console.

3. Install the HPE OBR 10.01 patch. For steps, see HPE Operations Bridge Reporter
Release Notes for 10.01.
For HPE OBR 10.x custom install scenario, install the HPE OBR 10.01 patch on all
the systems.

4. From HPE OBR 10.x system, go to the location {PMDB_HOME}, copy the OBR9x_
10x_Migration_Binaries.zip file to the {PMDB_HOME} location in HP SHR 9.x
system.

Note: If HP SHR 9.x components are on Linux operating system, copy the
OBR9x_10x_Migration_Binaries.zip file from HPE OBR 10.x on Linux
operating system.

In case of HP SHR 9.x custom install scenario, copy the OBR9x_10x_
Migration_Binaries.zip file to all the HP SHR 9.x server components.

5. Unzip OBR9x_10x_Migration_Binaries.zip file in all HP SHR 9.x system(s).
The {PMDB_HOME}/Migration folder will be created.
Similarly, unzip OBR9x_10x_Migration_Binaries.zip file in all HPE OBR 10.x
system(s). The {PMDB_HOME}/Migration folder will be created.

6. If any of the HP SHR 9.x component(s) is installed on Linux Operating System,
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perform the following steps:
a. Go to {PMDB_HOME}/Migration folder.
b. Run the following command to give permission for setup.sh file:

chmod 777 setup.sh
c. Run the command: ./setup.sh
Similarly, perform the following for HPE OBR 10.x component(s) installed on Linux
Operating System:
a. Go to {PMDB_HOME}/Migration folder.
b. Run the following command to give permission for setup.sh file:

chmod 777 setup.sh
c. Run the command: ./setup.sh

Task 2: Migration Precheck

1. Stop the collection and timer service on HP SHR 9.x server and wait for all the data
to be processed, follow these steps:

Note: If you have installed HP SHR 9.x Remote Collector, stop the collection
service on the remote collector system.

On Windows:
a. Click Start > Run. The Run dialog box appears.
b. Type services.msc in the open field, and then press ENTER. The Services

window appears.
c. Right-click on the following services and click Stop:

HP_PMDB_Platform_Collection
HP_PMDB_Platform_Timer

On Linux:
a. Run the following command on the command prompt:

service HP_PMDB_Platform_Collection stop
service TrendTimer stop

2. On HP SHR 9.x server, make sure that the PostgreSQL service is running, follow
these steps:
On Windows:
a. Click Start > Run. The Run dialog box appears.
b. Type services.msc in the open field, and then press ENTER. The Services

window appears.

Migration Guide
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c. Check the status for the following service is Running:
HP_PMDB_Platform_PostgreSQL
If the service is not running, right-click on the service and click Start.

On Linux:
Run the following command on the command prompt:
service HP_PMDB_Platform_PostgreSQL status
If the service is not running, run the following command:
service HP_PMDB_Platform_PostgreSQL start
The status of the service must be Running.

3. On the HP SHR 9.x server execute the Migration Utility Precheck command to
validate the readiness for data export.
On successful precheck the following are created in the specified <path> of the HP
SHR 9.x server:
l Migration.conf file

l Summary folder with PrecheckSummary html

Note: You should take necessary actions on "Pre-check failed" message from
the Pre-check tool.

4. In case of remote SAP BusinessObjects server in HP SHR 9.x , copy the
config.prp file from {PMDB_HOME}/data of HP SHR 9.x server to {PMDB_HOME}
/data in HP SHR 9.x SAP BusinessObjects server.
In case of remote Sybase IQ server, copy the config.prp file from {PMDB_HOME}
/data of HP SHR 9.x server to {PMDB_HOME}/data in Sybase IQ server.

5. The -calc option in migrationUtility must be run on the HP SHR 9.x Sybase IQ
server to calculate the downtime and the disk space required for exporting the
specified data.

Note:Make sure to execute the precheck option on the HP SHR 9.x server
before executing –calc option.

Run the following command:
migrationUtility –calc <number of days>/-startDate <YYYY-MM-DD> -
endDate <YYYY-MM-DD>
You can type the number of days or the start date and end date to calculate the
downtime and the disk space required for exporting the data for the specified days.

Note: The value displayed after running the -calc option is based on the
benchmarks performed in the lab.
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6. After successful precheck, in case of HP SHR 9.x custom install scenario, copy the
folder that is created after precheck to all the HP SHR 9.x server components.

Task 3: Export

1. Execute the Migration Utility Export command to export Content Packs data, SAP
BusinessObjects artifacts and Data Source Configuration in a zipped file format from
HP SHR 9.x system(s).

Note: In HP SHR 9.x system during the export, the content data is exported from
Sybase server, data source configuration from HP SHR server and
BusinessObjects artifacts from SAP BusinessObjects server. In case of HP SHR
custom (distributed) installation scenarios, run the export tool from each of HP
SHR 9.x servers.

On successful export the following folders are created in the specified <path> of the
HP SHR 9.x system(s):

l Summary folder with ExportSummary html

l BusinessObjects folder with exported artifacts details. This folder consists of the
following folders:
i. OBR.biar: The BAIR file.
ii. bo.ini: This file lists all the SAP BusinessObjects configurations that will be

to be imported to the HPE OBR 10.x system
iii. export.log: This is a text log file with the SAP BusinessObjects export log

summary.

l ContentData folder with exported individual Content Pack data details. Each
Content pack folder consists of the following folders:
i. csv: This folder lists all the csv’s to be imported on the 10.x system.
ii. ret_csv: This folder lists the dsi_retention table csv.
iii. sql folder: This folder is created during the data export. It contains the SQLs

required for exporting data.

l metadata folder with exported configuration details. This folder consists of the
following folders:
i. configFiles: This folder lists all the configurations to be imported on the
10.x system.

ii. csv: This folder lists all the csv’s to be imported on the 10.x system.
iii. RemoteCollector.prp: This file consists the collection data to be imported

on the 10.x system.

Migration Guide
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Task 4: Import

1. Copy/Share/Mount the folder where the HP SHR 9.x data is exported to HPE OBR
10.x system(s).

Note: You must not Copy/Share/Mount the Migration export folder to the /root
directory or to any user specific home directory.

2. If you have configured Remote Collectors in HPE OBR 10.x, perform the following
steps:
a. On the HPE OBR 10.x server, go to the location where the export folder is

copied/mounted/shared from HP SHR 9.x system.
b. Open the metadata folder and edit the RemoteCollector.prp file as follows:

collectormapping

local=local

RC9x=<edit this value with HPE OBR 10.x Remote Collector Name>

3. In case of remote SAP BusinessObjects server in HPE OBR 10.x, copy the
config.prp file from {PMDB_HOME}/data of HPE OBR 10.x server to {PMDB_HOME}
/data of SAP BusinessObjects server.
In case of remote Vertica server, copy the config.prp file from {PMDB_HOME}/data
of HPE OBR 10.x server to {PMDB_HOME}/Migration of Vertica server.

4. Stop collection and orchestration service on the HPE OBR 10.x server, follow these
steps:

Note: If you have installed HPE OBR 10.x Remote Collector, stop the collection
service on the remote collector system.

On Windows:
a. Click Start > Run. The Run dialog box appears.
b. Type services.msc in the open field, and then press ENTER. The Services

window appears.
c. Right-click on the following services and click Stop:

HPE_PMDB_Platform_Collection
HPE_PMDB_Platform_Orchestration

On Linux:
a. Run the following command on the command prompt:

service HPE_PMDB_Platform_Collection stop

Migration Guide
Chapter 4: Migration Steps

HPE Operations Bridge Reporter (10.01) Page 16 of 63



service HPE_PMDB_Platform_Orchestration stop
5. On HPE OBR 10.x server, make sure that the PostgreSQL service is running, follow

these steps:
On Windows:
a. Click Start > Run. The Run dialog box appears.
b. Type services.msc in the open field, and then press ENTER. The Services

window appears.
c. Check the status for the following service is Running:

HPE_PMDB_Platform_PostgreSQL
If the service is not running, right-click on the service and click Start.

On Linux:
Run the following command on the command prompt:
service HPE_PMDB_Platform_PostgreSQL status
The status of the service must be Running.
If the service is not running, run the following command:
service HPE_PMDB_Platform_PostgreSQL start

6. Execute the Migration Utility Import command to import Content Packs data, SAP
BusinessObjects artifacts and Data Source Configuration from HP SHR 9.x system
(s) to HPE OBR 10.x system(s).

Note: In HPE OBR 10.x system during the import, the content data gets imported
to Vertica server, data source configuration to HPE OBR server and
BusinessObjects artifacts to SAP BusinessObjects server. In case of HPE OBR
custom (distributed) installation scenarios, make sure to copy the exported folder
from HP SHR 9.x system(s) to the respective HPE OBR 10.x system(s).

For example, if you have a typical HP SHR 9.x scenario in Windows operating
system, and you want to migrate to the custom install scenario where HPE OBR
10.x server and SAP BusinessObjects server are on single system and Vertica
server on remote system, copy/share/mount the exported folder from the HP
SHR 9.x system to both the HPE OBR 10.x systems.
In case of HPE OBR custom (distributed) installation scenarios, run the import
tool from each of HPE OBR servers.

Note: After successful data import on HPE OBR 10.x system, if Generic
database (for example: Sybase database) is configured as data source, copy the
jconn4.jar from {SYBASE}/jConnect-7_0/classes on Sybase IQ server to
{PMDB_HOME}/lib directory on HPE OBR 10.x system for connection and
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collection to work fine.

Task 5: Post-migration

1. Verify the summary of old data and new data migrated from CompareSummary.htm.
For more details, see Validation using Summary HTMLs.

2. Start collection and orchestration service on the HPE OBR 10.x server, follow these
steps:

Note: If you have installed HPE OBR 10.x Remote Collector, start the collection
service on the remote collector system.

On Windows:
a. Click Start > Run. The Run dialog box appears.
b. Type services.msc in the open field, and then press ENTER. The Services

window appears.
c. Right-click on the following services and click Start:

HPE_PMDB_Platform_Collection
HPE_PMDB_Platform_Orchestration

On Linux:
a. Run the following command on the command prompt:

service HPE_PMDB_Platform_Collection start
service HPE_PMDB_Platform_Orchestration start
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Chapter 5: Migration Utility
HPE OBR migration provides migrationUtility that helps you to migrate data from
HP SHR 9.x system to HPE OBR 10.x.

The command to run the utility is as follows:

migrationUtility -precheck/-export/-import/-dataSourceClean/-calc

To get more information on the usage of the utility, run the command:
migrationUtility -help

l Precheck option
l Export option
l Import option
l Validation using Summary HTMLs

Precheck option

The Precheck option performs all the checks needed for migration as follows:

l Checks if the Collection service is stopped on both the remote collector and the HP
SHR system.

l Checks if Data from the remote collector is moved to the HP SHR system.
l Checks if there are files pending in the collect and stage folder. If the files are not
processed or in pending state the precheck fails and displays the message Pre-check
failed.

l Checks if all the data from the stage table gets processed.
l Checks if the Timer service is stopped on the HP SHR system.
The following table lists the parameters in Migration.conf file:

Parameter Options Description

Pre-check PASSED|
FAILED

The information on the precheck status will be
displayed.

The value for precheck will be PASSED if the precheck
is successful and FAILED if the precheck fails.

Content Packs yes | no Lists all installed Content Packs on HP SHR 9.x
system.
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The default value is yes, all the installed Content
Packs will be exported. You can change the value to
no to exclude the export of specific Content pack.

Example: Core=yes

SYSTEM=yes

MSAppCore=yes

AppCore=no

WebLogic=no

l fact
l hourly
l daily

all |
number of
days

Specify the number of days for the table to export
data.

The value all is specified if all of the data in the table
has to be exported. If you want to export data for a
specific number of days from these tables specify the
value for number of days.

Example: fact=5

In the above example, the data of the last 5 days from
the current system date will be exported.

l factStartDate
l factEndDate
l hourlyStartDat
e

l hourlyEndDate
l dailyStartDate
l dailyEndDate

yyyy-mm-
dd

Specify the start date and end date for the table to
export data.

The format to specify the date to export the data is
yyyy-mm-dd.

Example: factStartDate =2015-01-01
factEndDate=2015-01-31

The data of the specified start date and end date will
be migrated. If the end date is not specified then the
data untill the current system date will be migrated.

Note: If the EndDate is specified for fact, hourly
and daily values, then the EndDate value will take
the priority over the number of days value.

concurrent_
processes

10 The number of concurrent processes for which the
data has to be exported.

chunk_rate 30 The number of days for data export batch.
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SHR_OS windows |
linux

The Operating System of HP SHR 9.x from where the
data is exported.

Precheck option command

To run the precheck option, go to the location {PMDB_HOME}/bin and run the following
command:

migrationUtility –precheck –path <path>

where, <path> is the location of the folder where you want the precheck artifacts to be
created.

Note: You must make sure that the <path> is a folder and not drive.

Example:

Linux: migrationUtility –precheck –path /opt/upgrade_pack

Windows: migrationUtility –precheck –path C:\upgrade_pack

Export option

The Export option helps you to export the Content Packs data, SAP BusinessObjects
artifacts and Data Source Configuration in a zipped file format.

In HP SHR 9.x system during the export, the content data is exported from Sybase
server, data source configuration from HP SHR server and BusinessObjects artifacts
from SAP BusinessObjects server. In case of HP SHR custom (distributed) installation
scenarios, run the export tool from each of HP SHR 9.x servers.

Note: For the OMi Content pack migration, the data of minimum 35 days must be
migrated at once.

Content Pack data

The Export option reads the data from Migration.conf file that is created in the HP
SHR 9.x system after the precheck is completed. The data of the Content packs that are
specified as yes in Migration.conf file will be exported.

Note: If you do not want to export specific Content pack then change the yes option
to no in the Migration.conf file.
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SAP BusinessObjects artifacts

The following SAP BusinessObjects artifacts created by the SAP BusinessObjects non-
default user in HP SHR 9.x can be exported using the Export option:

l Users
l UserGroups
l Access levels

Note: If the SAP BusinessObjects non-default user has mapped the users,
usergroups and Access levels in HP SHR 9.x, then after migrating to HPE OBR 10.x
the mapping has to be done manually. This is because of the change in universe
objects in HPE OBR 10.x.

Data Source Configuration

The Export option helps you to export the Data Source Configurations from a HP SHR
9.x system.

Export option command

On the HP SHR 9.x system(s), go to the location {PMDB_HOME}/bin and run the
following command:

migrationUtility –export –path <path>

Note: You must specify the folder path that has been created after migration
precheck. Do not create the folder before as the export tool creates the folder after
execution. In case of HP SHR 9.x distributed scenario, on the SAP BusinessObjects
server and/or Sybase IQ server, specify the folder path that you have copied from the
HP SHR 9.x server.

If you are executing the export tool again, then the precheck should be run with a
different folder and the export should also be done to a new folder.

where, <path> is the location where you export data.

To export the Content Data and/or Data Source and/or BO Artifacts, run the following
command:

migrationUtility –export –path <path> [-run
contentData,dataSource,boArtifacts]

For Example: migrationUtility –export –path /opt/migrateall -run
contentData,dataSource

The above example exports the Content Data and the Data Source Configuration data.
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To export all the Content Data and/or Data Source and/or BO Artifacts, run the following
command:

migrationUtility –export –path <path>

On a remote Sybase IQ server, to export Content Data, run the following command:

migrationUtility –export –path <path> [-run contentData]

The above command exports the Content Data from remote Sybase IQ server.

The following log files for the export tool is available at the location {PMDB_HOME}/log/:

l metaDataMigrate.log
l boMigrate.log
l contentDataMigrate.log
l migrationUtility.log
After running the Export option, the ExportSummary html is created with details of the
exported data.

Import option

The Import option helps you to import the Content Packs data, SAP BusinessObjects
artifacts and Data Source Configuration.

In HPE OBR 10.x system during the import, the content data gets imported to Vertica
server, data source configuration to HPE OBR server and BusinessObjects artifacts to
SAP BusinessObjects server. In case of HPE OBR custom (distributed) installation
scenarios, make sure to copy the exported folder from HP SHR 9.x system(s) to the
respective HPE OBR 10.x system(s).

For example, if you have a typical HP SHR 9.x scenario in Windows operating system,
and you want to migrate to the custom install scenario where HPE OBR 10.x server and
SAP BusinessObjects server are on single system and Vertica server on remote system,
copy/share/mount the exported folder from the HP SHR 9.x system to both the HPE OBR
10.x systems.

In case of HPE OBR custom (distributed) installation scenarios, run the import tool from
each of HPE OBR servers.

Note: For the OMi Content pack migration, the data of minimum 35 days must be
migrated at once.
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Content Pack data

The Import option reads the data from Migration.conf file. The data of the Content
Packs that are specified as yes in Migration.conf file will be imported.

Note: If you do not want to import specific Content Pack then change the yes option
to no in the Migration.conf file.

SAP BusinessObjects artifacts

The following SAP BusinessObjects artifacts of HP SHR 9.x to HPE OBR 10.x is
imported using the Import option:

l Users
l Usergroups
l Access levels

Data Source Configuration

This option helps you to import Data Source Configurations from a HP SHR 9.x system
to HPE OBR 10.x system.

You must make sure that the following actions are completed on the HPE OBR 10.x
system before the Import option is run:

l HPE OBR 10.x is installed. Configure Remote Collector if required.
l Post installation steps are performed.
l The HPE OBR 10.01 patch is installed.
l Install the Content Packs msi(s) and deployed.
l Copy the folder where the HP SHR 9.x data is exported to HPE OBR 10.x system.
l The Collection and Orchestration services are stopped.

Note: The dataSourceClean option can be used to re-import the data to HPE OBR
10.x system. This option cleans the tables with the previous imported data.

You can use this option only when:

1. The Data Source Configuration data is already imported once to HPE OBR 10.x
system.

2. The data collection is NOT started on the HPE OBR 10.x system.

dataSourceClean option command:

migrationUtility -dataSourceClean
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Import option command

To import the all of the data, go to the location {PMDB_HOME}/bin and run the following
command:

Note: If HPE OBR 10.x is installed on non-default drive in Windows operating
system, execute Import option on command prompt from C:/ drive.

migrationUtility –import –path <path>

where, <path> is the location where the export folder is copied/shared/mounted on the
HPE OBR 10.x system.

To import the Content Data and/or Data Source and/or BO Artifacts, run the following
command:

migrationUtility –import –path <path> [-run
contentData,dataSource,boArtifacts]

For Example: migrationUtility –import –path /opt/migrateall [-run
boArtifacts,dataSource]

The above example imports the BO Artifacts and the Data Source Configuration data.

The following log files for the Import option is available at the location {PMDB_HOME}
/log:

l metaDataMigrate.log
l boMigrate.log
l contentDataMigrate.log
l migrationUtility.log

After running the Import option, the ImportSummary html is created with details of the
imported data.

Calculator Option

The calculator feature in Migration can be used to calculate the downtime and the disk
space required for exporting the specified data.

The -calc option in migrationUtility must be run on the HP SHR 9.x Sybase IQ
server to calculate the downtime and the disk space required for exporting the specified
data.

Note:Make sure to execute the precheck option on the HP SHR 9.x server before
executing –calc option.
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Run the following command:

migrationUtility –calc <number of days>/-startDate <YYYY-MM-DD> -
endDate <YYYY-MM-DD>

You can type the number of days or the start date and end date to calculate the
downtime and the disk space required for exporting the data for the specified days.

Note: The value displayed after running the -calc option is based on the
benchmarks performed in the lab.
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Chapter 6: Validation using Summary HTML
The Validation Summary HTML helps the user to verify if migration is successful. These
Summary HTML are available in the path that you have specified while running the
import and export option.

Following are the HTML available:

l PrecheckSummary.htm - This HTML is created after the precheck tool is run
successfully. It provides information of the installed Content Packs for export. You can
click on the links provided for the individual Content Packs for more details.

l ExportSummary.htm - This HTML is created after the export tool is run successfully.
It provides information of the installed Content Packs that are exported. You can click
on the links provided for the individual Content Packs for more details.

l ImportSummary.htm - This HTML is created after the import tool is run successfully.
It provides information of the Content Packs that are imported. You can click on the
links provided for the individual Content Packs for more details.

l CompareSummary.htm - This HTML provides comparative information of the
Content packs that are migrated. The value of the columns No. of Records Imported
and No. of Records Exported can be referred to compare the data. The Import
Status column displays true if the No. of Records Imported and No. of Records
Exported is same else it displays false. For a successful import the No. of Records
Imported and No. of Records Exported columns should have same values and the
Import Status column should display true.

Note: If you have completed migration and started the collections in the HPE OBR
10.x system, and there is another migration done after few days, there can be
miss-match in the Compare Summary for dimensions.

Along with the above mentioned HTMLs, there are following folders that consists of
individual HTML of each migrated Content Pack:

l Precheck
l Import
l Export
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Chapter 7: Migration Steps for Custom Content
This chapter describes the approach to migrate custom content.

Custom Reports and/or Universe on Custom Schema

If you have developed new reports on the universe or created new universe shipped in
HP SHR 9.x then these reports and universe can be migrated to HPE OBR 10.x. Follow
these steps to migrate new reports and universe:

1. From HP SHR 9.x's SAP BusinessObjects 3.x installed system, "Export universe
and related reports as BIAR" on page 30.

2. Follow these steps for universe migration
a. Change the connection to vertica connection from BO 4.x.
b. If there are any Sybase specific SQLs move it to Vertica.

3. Use BO 4.x "Upgrade Management Tool (UMT) " on page 39 on HPE OBR 10.x and
import these reports.

4. "Convert unv to unx" on page 44 using Information Design Tool (IDT).

Note: XCelsius dashboards using Qaaws does not work with unx.

5. "Use Remapping Tool " on page 48 on HPE OBR 10.x to map the reports to HPE
OBR 10.x universe.

Custom Domain, Application and ETL Content

Domain content

To migrate the Domain content from HP SHR 9.x to HPE OBR 10.x system, follow these
steps:

1. Compile the domain content with HPE OBR 10.x CDE.
2. Port Sybase IQ procedures, if any, to Vertica scripts and update ABC step definition.
3. Deploy the content on HPE OBR 10.x
4. Migrate the data from HP SHR 9.x to HPE OBR 10.x. Use the migration script

generation tool to generate migration scripts. You can modify the script if required
and use the scripts to export data from HP SHR 9.x and import the data to HPE OBR
10.x.
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5. Create Manifest and compile content pack. For steps, see HPE Operations Bridge
Reporter Content Development Guide.

Application content

To migrate the Application content from HP SHR 9.x to HPE OBR 10.x system, follow
these steps:

1. To migrate the application content the "LCM BAIR" on page 51 should be taken.
2. Create Manifest and compile content pack. For steps, see HPE Operations Bridge

Reporter Content Development Guide.
To migrate app content, perform the steps described in Custom Reports and/or Universe
on Custom Schema section.

To migrate the ETLcontent from HP SHR 9.x to HPE OBR 10.x system, follow these
steps:

1. If your ETL uses Sybase IQ specific SQLs/functions in DB collection policies, port it
to Vertica.

2. If your ETL uses Sybase IQ specific SQLs/functions in stage rules, port it to Vertica.
3. Compile the ETL content with HPE OBR 10.x CDE.
4. Deploy the ETL on HPE OBR 10.x. For steps, see HPE Operations Bridge Reporter

Content Development Guide.
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Reference

Export universe and related reports as BIAR

1. From HP SHR9.x system, click Start > All Programs > BusinessObjects XI 3.1 >
Import Wizard .

2. The welcome screen of the Import Wizard appears. Click Next.
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3. In the Source drop-down, select BusinessObjects Enterprise XI 3.x and click
Next.
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4. In the Destination drop-down, select Business Intelligence Archive Resource
(BIAR) File and click Next.

5. Select the check-boxes as shown in the following image and click Next.
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6. A note on importing object rights appears, click Next.

7. Click Next on the Custom Access Levels screen.
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8. Select Custom Content Pack reports and click Next.

9. Select Next.
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10. Select the option for Select an importing option for universe objects: as shown in
the following image and click Next.
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11. The Universe will be selected by default, click Next.
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12. Select the option for Select an importing option for repository objects: as shown
in the following image. Click Next.

13. Select Do not import recipients and click Next.
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14. The Ready to import screen appears with import details, click Finish.

15. Click View Detail Log to check if all the objects were successfully imported to BIAR.
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16. Copy the BIAR file from the location to the specified location.

Upgrade Management Tool (UMT)

Perform the following steps on HPE OBR 10.x system and import the custom reports.

For Windows:

1. In Search, type Upgrade Management Tool. The welcome page appears.

Click Complete Upgrade, and click Next
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2. In Upgrade Scenario select Biar to Live, select the Source BIAR file. In
Destination, type the CMS Name and credentials click Next.

Click Start.

After completion upgrade the biar into 4.1 system.

Note: You must install the SAP BusinessObjects client tools that is shipped as
part of HPE OBR media.

For Linux:

1. Go to the locaton <BOinstallpath>/sap_bobj/enterprise_
xi40/java/apps/upgradeManagementTool/jars
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2. Run the following command:
java -jar upgrademanagementtool.jar -mode biartolive -biarfile
"<location of biarfile>/test.biar" -destination <destination
system>:6400 -destinationusername "Administrator" -
destinationpassword "<password>" -logfile "/opt/log.txt"

After completing the Upgrade Management Tool steps, perform these steps to import
universe:

1. In Search, type Universe Design Tool.
2. Log on to Universe Design Tool (UDT). Type the SAP BusinessObjects 4.1 system

details, where the BIAR is migrated from the previous steps and click Ok.

3. Click Connections icon to create a Vertica connection. In Define a new connection
page, click Next.

4. Click Hewlett Packard > HP Vertica 6.1 > JDBC Drivers. Click Next.
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5. Click Test Connection to verify the connection and then click Next.

6. Click Finish. A connection is created with Vertica as database.
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7. Go to File > New > Parameters > Definition tab.
8. Select the connection created in the previous step and click Test. Click OK.

9. Go to the File > Import.
10. Click Browse. Select the Universe from Repository and click OK
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11. The following message appears. Click OK.

12. Click Tools > Check Integrity to verify any issues.

13. Click File > Export to Repository this Universe.

Convert unv to unx
1. In Search, type Information Design Tool. Log on to Information Design Tool (IDT)

and Click OK.
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2. In IDT > Repository Resources, click + and insert Session. Type the system details
that was provided in the previous step.

3. Click File > New > Project.
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4. Type the project name to save the unx in the local system with the same name. Click
Finish.

5. Click File > Convert .unv Universe.... The Convert .unv Universe page appears.
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6. Select the universe that has to converted to unx. Select Automatically Convert
@Prompt into universe named parameters and Save for all users check-boxs.

Now we will see 3 files created under the project which we created
a. <Universename.blx>
b. <Universename.dfx>
c. <Connection.cns>
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7. In the IDT left pane, right-click <Universename.blx>. Select all options and click
Check Integrity.

Publish to Repository. This step ensures that unv is successfully converted to unx.

Use Remapping Tool

1. Log on to SAP BusinessObjects BI Launch pad from the link:
http://<servername>:8080/BOE/BI

2. Click Documents. Click Folder that has the reports to be mapped. Right-click on
the report and click Modify.

3. Click Data. The list of data providers appears.
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4. Right-click on the first data providers list and click Change Sources.

5. Select the Universe (UNX) and click Next.

6. Select the Universe that is converted to unx in the previous task and click Select.
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7. Select the Apply changes in all queries sharing the same data source check-box.
Click Next.

8. In Strategy Selection, verify if the objects are mapped and click Next and Finish.
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This will ensure that the reports are mapped to the converted UNX. After converting
the reports and universe, take an "LCM BAIR" below.

LCM BAIR

Follow these steps on the HPE OBR 10.x system to take an LCM BAIR:

1. Log on to Central Management Console (CMC) as administrator from the following
URL:
http://<servername>:8080/CMC
You can log on to CMC from the Administration Console, click Administration >
SAP BOBJ and then click Launch CMC.
The CMC Home page appears.

2. Click Promotion Management.

3. Click New Job to create a job.
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4. Type the job name in Name as per your content. You can type the description if
required.

For Example:
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5. From Source, select Login to a New CMS.

6. Type the source system details where SAP BusinessObjects reports and universes
exist and click Login.
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The source details appears in the Source field.

7. From Destination, select the Output to LCMBIAR File option. Click Create.
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8. From the left pane, select the Reports from the folders.
For example: The following image displays selections from Operations Bridge
Reporter folder:

9. Click the folder where the reports available to be migrated.
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10. Select the Reports and click Add.

11. In the left pane, scroll down and click on the universe. Select the universe and then
click Add.
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12. In the left pane, scroll down and click on the Connection used for the universe.
Select the connection and then click Add & Close.

13. Click Manage Dependencies to check the reports, universe and connection.
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Click Select Dependents to check the dependencies, this dependency check will
automatically add the dependents here. Click on Apply & Close.

14. Select all the objects (reports, universe and connection) and click Promote.

15. Verify Source and Destination and Objects to be promoted. Click Export.
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16. Save the exported objects LCM Bair to Local folder.

17. Rename the File and Save
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Troubleshooting Migration Issues

This section covers the common problems that you may encounter during migrating data
from HP SHR 9.x to HPE OBR10.x and provide steps to troubleshoot them. Each
problem is documented with a symptom, the description about the symptom and
resolution for the symptom.

Symptom: Export Failing with Out of Memory Error

Description
:

This error occurs when the export option is run on the HP SHR 9.x
system if there is no sufficient memory for export.

Resolution: Perform the following steps to resolve this issue:

1. On the HP SHR 9.x system, go to the location {PMDB_HOME}
/config/startup.

2. Open the migrationUtility.ini file.
3. Edit the parameter as follows:

jargs=-DBSMR_HOME={bsmr.home} -Dbsmr.home=
{bsmr.home} -DDPIPE_HOME={bsmr.home} -Dpmdb.home=
{bsmr.home} -Xms120M -Xmx2048M
jargs=-DBSMR_HOME={bsmr.home} -Dbsmr.home=

{bsmr.home} -DDPIPE_HOME={bsmr.home} -Dpmdb.home=
{bsmr.home} -Xms120M –Xmx3000M

Symptom: After import on HPE OBR 10.x system, collection is not complete
for all days

Description
:

The collection is based on collector.maxHistory property in
config.prp file. By default it is 360 hours. If the migration (import) has
taken more time than 360 hours then the collection for the additional
days will not happen.

Resolution: Perform the following steps on HPE OBR 10.x system to resolve this
issue:

1. Go to the location {PMDB_HOME}/data.
2. Open the config.prp file.
3. Edit the value for collector.maxHistory with the number of
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hours for the migration (import) to complete.
For Example: If the migration (import) takes 16 days to complete,
edit the parameter as follows:
collector.maxHistory=384
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Send Documentation Feedback
If you have comments about this document, you can contact the documentation team by
email. If an email client is configured on this system, click the link above and an email
window opens with the following information in the subject line:

Feedback on Migration Guide (Operations Bridge Reporter 10.01)

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a web
mail client, and send your feedback to docfeedback@hpe.com.

We appreciate your feedback!
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