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Chapter 1: Taxonomy Editor Guide
Welcome to the Taxonomy Editor User Guide. This guide describes how to use Taxonomy Editor as
part of HPE Enterprise Maps (HPE EM).
This guide contains the following chapters:
l

" Taxonomy Editor" on page 8
Provides an overview of the main features of Taxonomy Editor.

l

"Getting Started" on page 15
Describes the installation of the main features and shows you how to create a taxonomy project.

l

"Managing Taxonomies" on page 20
Explains how to create, download, edit, and compare taxonomies.

l

"Deploying Taxonomies" on page 28
Shows how to publish taxonomies and build and deploy a Taxonomy Extension.

l

"Conflicts and Validation Issues" on page 31
Shows how to resolve conflicts with taxonomies.

l

"Example: Creating and Publishing a Department Taxonomy" on page 33
A walkthrough example of creating and deploying a new taxonomy.

l

"Keyboard Shortcuts" on page 35
Keyboard shortcuts reference.

l

"Dialog Boxes Reference" on page 37
Dialog box reference.

l

"Troubleshooting" on page 39
Troubleshooting tips.
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Chapter 2: Taxonomy Editor
HPE Enterprise Maps is a set of HPE EM Workbench features that enable you to manage taxonomies
in HPE EM.
You can use Taxonomy Editor to create, modify, and delete taxonomies. You can also download
taxonomies from, or upload them to, any number of HPE EM servers.
This chapter introduces Taxonomy Editor in the following sections:
l

"Overview" below

l

"User Interface" on the next page

Overview
Taxonomies are, in their simplest form, a visual representation of what your organization actually
knows. A well-constructed, meaningful taxonomy enables users in your organization to quickly find the
information they need to achieve their goals.
Taxonomy Editor enables you to organize and reorganize content easily, giving more flexibility for
knowledge sharing in your organization
Use Taxonomy Editor to do the following:
1. Create a Taxonomy Project.
For details, see the following sections:
o

"Creating a Taxonomy Project" on page 15

o

"Downloading Taxonomies from a Server" on page 17

o

"Searching for Taxonomies" on page 17

2. Create and Manage Taxonomies.
For details, see the following sections:
o

"Creating Taxonomies" on page 20

o

"Editing Taxonomies" on page 21

HPE Enterprise Maps (3.20)

Page 8 of 40

Taxonomy Editor User Guide
Chapter 2: Taxonomy Editor

o

"Editing Categories" on page 22

o

"Deleting and Restoring Taxonomies" on page 24

o

"Comparing Taxonomy Files" on page 25

o

"Updating Taxonomies from the Server" on page 26

o

"Importing and Exporting Taxonomy Files" on page 26

3. Publish taxonomies to an HPE EM server.
For details, see the following sections:
o

"Publishing Taxonomies" on page 28

o

"Deploying Taxonomies" on page 28

4. Check local validity and manage conflicts.
For details, see "Conflicts and Validation Issues" on page 31.

User Interface
The default perspective is split into a number of sections, with menu options across the top.
The platform perspective consists of the following views:
l

Project Explorer
The tree view of your taxonomy projects. For details, see "Project Explorer" below.

l

Server Explorer
The view listing HPE EM server connections to the HPE EM Workbench. For details, see "Server
Explorer" on page 11.

l

Editor
The view showing the components of the taxonomy. For details, see "Editor View" on page 11.

Project Explorer
Project Explorer contains a hierarchical list of projects, the taxonomies in each project, and the
categories and subcategories of each taxonomy, as shown in the following screenshot.
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The Project Explorer contains additional context menu options enabling you to interact with a running
HPE EM server. Right-click the project name or a particular assertion, and select HPE EM to view the
options listed in the following tables.
Project Context Menu Options
Option

Function

Download
Taxonomies

Import taxonomies from HPE EM. For details, see "Downloading Taxonomies from a
Server" on page 17.

Upload to
Server

Export taxonomies to the default HPE EM server. For details, see "Publishing
Taxonomies" on page 28.

Update from
Server

Update taxonomies from HPE EM. For details, see "Updating Taxonomies from the
Server" on page 26.

Remove
from Server

Delete taxonomies from HPE EM. For details, see "Deleting and Restoring
Taxonomies" on page 24.

Upload To
Export taxonomies to a specified HPE EM server.
Other Server
Build
Extension

Create a taxonomy extension for HPE EM containing all the taxonomies in your
project. For details, see "Building a Taxonomy Extension" on page 29.

Taxonomy Context Menu Options
Option

Function

Upload to Server

Export a taxonomy to the default HPE EM server. For details, see "Publishing
Taxonomies" on page 28.

Update from
Server

Update a taxonomy from HPE EM. For details, see "Updating Taxonomies from
the Server" on page 26.

Remove from
Server

Delete the taxonomy from HPE EM. For details, see "Deleting and Restoring
Taxonomies" on page 24.

Upload To Other
Server

Export a taxonomy to a specified HPE EM server.

Validate Data
Consistency

Check the validity of the taxonomies. For details, see "Conflicts and Validation
Issues" on page 31.

Show Taxonomy
Usage

Find the artifacts that use the taxonomy for categorization. For details, see
"Conflicts and Validation Issues" on page 31.

Compare With
Latest From
Server

Compares the selected taxonomy with the latest version on the server.

Build Extension

Create a taxonomy extension for HPE EM containing all the taxonomies in your
project. For details, see "Building a Taxonomy Extension" on page 29.
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Server Explorer
The Server Explorer displays the HPE EM servers connected to HPE EM Workbench. The
functionality is shared by all the HPE EM Workbench editors.
Right-click a server in the Server Explorer to open the context menu described in the following table.
Server Explorer Context Menu Options
Option

Function

New Server

Add a server for downloading assertions and taxonomies (Assertion Editor,
Taxonomy Editor, and Customization Editor).

Remove
Server

Delete a server from the Server Explorer.

Download
Taxonomy

Download a taxonomy from a server (Taxonomy Editor and Customization Editor).

Download
Assertion

Download assertions from a platform server (Assertion Editor).

Download
Report

Download reports from a reporting server (Report Editor).

Properties

View and edit the server name, URL, username, and password.

Editor View
The Editor pane is the main feature of the Taxonomy Editor UI.
It has four tabs, described in the following sections:
l

Overview Tab
The Overview tab shows the components of the taxonomy.
The first section is General Information, where you can view and edit the following properties:
o

Name
Name for the taxonomy. The content of the name element in the taxonomy's XML representation.

o

Taxonomy ID
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Identifier for the taxonomy, with the preceding uddi:. The value of tModelKey attribute in the
taxonomy's XML representation.
o

Description
Description of the taxonomy (optional).

The second section is Origin, which shows:
o

Resource URL
REST interface URL enabling the published taxonomy to be viewed on the server.

o

Value Display Format
These options allow changing how the value is presented.

l

Categories Tab
The Categories tab enables you to change the structure and properties of taxonomy categories.
You can use the Categories tab to do the following:

l

o

"Adding a Category" on page 23

o

"Removing a Category" on page 23

o

"Copying a Category" on page 24

o

"Moving a Category" on page 24

Advanced Tab
The Advanced tab enables you to set properties used with UDDI.
It is divided into the following sections:
o

Compatibility
Enables you to select one or more of the main UDDI structures for the taxonomy. For example,
businessEntity, businessService, bindingTemplate, and tModel.
All structure types are selected by default which is the required setting if you want your
taxonomy to integrate with UDDI Registry.

o

Categorization
Enables you to select from the following taxonomy types:
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l

categorization
Tags the UDDI structure with additional information, such as identity, location, and
description.

l

categorizationGroup
Groups several categorizations into one logical category. For example, a
categorizationGroup could be a geographical location comprised of two categorizations:
longitude and latitude.
The categorizationGroup option is disabled if the taxonomy has any categories.

l

Identifiers
Reference published information in businessEntities and tModels.

l

Relationships
Defines the relationship between two businessEntities in Publisher Assertions.

o

Validation
Sets whether or not the values in keyedReferences within the taxonomy are checked. The
validation service can check the expected syntax of values. For example, a credit card number
or an ISBN number.
Validation can be against Taxonomy Editor's internal validation service or against an external
service.
To select an external validation service, do one of the following:

o

l

Enter the endpoint URL.

l

Leave keyedReferences unvalidated.

Reference
Enables you to add a reference to a key type.

o

Value Type
Enables you to Select a Value type for keyValues, using one of the following comparators:
l

em-com.comparator.string
keyValues are treated as string values. The maximum length is 255 characters.

l

em-com.comparator.numeric
keyValues are treated as decimal numbers. The value can have a maximum of 19 digits
before the decimal point and a maximum of 6 digits after the decimal point.
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l

em-com.comparator.date
keyValues are treated as dates.

l

custom
Endpoint URL of a custom comparator.

l

Source Tab
The Source tab enables you to view and directly edit the XML representation of the taxonomy.
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Chapter 3: Getting Started
This chapter describes the prerequisites for working with taxonomies in Taxonomy Editor. It contains
the following sections:
l

"Creating a Taxonomy Project" below

l

"Customizing Taxonomy Editor" on the next page

l

"Downloading Taxonomies from a Server" on page 17

l

"Searching for Taxonomies" on page 17

Creating a Taxonomy Project
To work with taxonomies, you need a Taxonomy Project. You can create any number of Taxonomy
Projects to help organize your work.
To Create a Taxonomy Project:
1. Do one of the following:
o

In the HPE EM Workbench Welcome page, click Create Taxonomy Project.

o

Click New

to open the Select a Wizard window, and select HPE EM > Taxonomy

Project.
o

From the menu, select File > New > Taxonomy Project.

o

Press Alt+Shift+N, and then press R, to open the Select a Wizard window. Then select HPE
EM>Taxonomy Project.

The New Taxonomy Project dialog box opens.
2. In the New Taxonomy Project dialog box, enter the following parameters:
Parameter

Definition

Project
Name

The name of your assertion project.

Taxonomy

The URN prefix to apply to all taxonomies in the project.
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Parameter

Definition

ID Prefix
Create from
Existing
Extension

Select this option if you want to create a new project from a previous taxonomy
extension. If selected, input the path or browse for the location of the
taxonomyn extension.

Use Default
Location

If selected, Taxonomy Editor stores the project in your default workspace. If
unselected, input the path or browse for an alternative workspace.

3. Click Next to select or create a server.
Note: If no servers are currently defined, the dialog box continues to step 5.
4. Do one of the following:
o

Select Create a New Server, and click Next.
Continue to step 5.

o

Select Use an Existing Server, select the server from the list and input its credentials, and
then click Next.
Continue to step 6.

5. In the New Server dialog box, add the required parameters, and then click Next.
6. Select the taxonomies to download from the server. Optionally, select Show System
Taxonomies to view system taxonomies for selection.
7. Click Finish.

Customizing Taxonomy Editor
Some settings are customizable in Taxonomy Editor.
To Change Taxonomy Editor Preferences:
1. Select Window > Preferences.
The Preferences dialog box opens.
2. In the tree menu, select HPE EM > Taxonomy Editor.
3. You can change the following:
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o

Default taxonomy namespace
The default namespace setting is 5.5.This defines taxonomy compatibility level with other
UDDI products.

o

Data consistency
Select Validate before publishing taxonomies to validate changes before publishing them to
the server

Downloading Taxonomies from a Server
Initially, Taxonomy Editor does not contain any taxonomies. To edit HPE EM taxonomies, you must
download them from a server.
To Download Taxonomies from a Server:
1. In Server Explorer, right-click the server containing the taxonomies you need to open its context
menu, and select Download Taxonomies.
The Download Taxonomies wizard opens.
2. Select the taxonomies to download and click Next.
The Choose Location dialog box opens.
3. Select the project to add the taxonomies to, and then click Finish.
Taxonomy Editor displays the download progress. When the download is complete, the taxonomies are
visible in Project Explorer.

Searching for Taxonomies
This section describes the search facilities provided by Taxonomy Editor.
Quick Find is the easiest way to find a taxonomy.
To use Quick Find:
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1. Do one of the following:
o

Click Search, and then select Quick Jump.

o

Press Ctrl+J.

The Find Taxonomy dialog box opens. For details, see "Find Taxonomy Dialog" on page 38.
2. In the input field, enter a search string.
3. Click View Menu
o

, and then select one of the following options:

Show in the tree without opening detail
Shows the taxonomy in the tree but does not open its details page.

o

Case-sensitive
Enables a case-sensitive or case-insensitive search.

4. In the in project field, select in which project to search for the taxonomy.
Taxonomies that match your search criteria are displayed in the Matching taxonomies pane.
5. Select the required taxonomy and click Open taxonomy.
The taxonomy opens in the Editor pane.
For a more detailed search, you can use Advanced Search to do the following:
l

Search for a specific property type.

l

Search according to a specific value of a property.

l

Search different text strings: full text, regular expression, or whole word.

To Use Advanced Search:
1. Do one of the following:
o

Select Search>Search.

o

Press Ctrl+H.

The Search dialog box opens.
2. Select the Taxonomy Search tab to open the dialog box. For details, see "Search Taxonomy
Dialog" on page 38.
3. In the Containing text field, do one of the following:
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o

Enter the text to search.

o

Select text used in a previous search by using the drop-down list.

4. In Search only in, choose the taxonomy properties or categories to search.
5. In Search controls, select one or more of the following:
o

Case-sensitive
To perform a case-sensitive search.

o

Whole words only
To search for whole word matches.

o

Regular expression
To search using regular expressions.

6. In Scope, select one of the following:
o

Workspace
To search the Eclipse workspace.

o

Selected resources
To search all entities selected in Project Explorer.

o

Working set
To customized resources from Project Explorer.

7. Click Choose.
The Select Working Sets wizard opens.
Do one of the following:
o

Select from existing working sets.

o

Create new working sets.

8. Click Search.
The results are displayed in the Search view of the UI.
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This chapter describes how to work with taxonomies, as detailed in the following sections:
l

"Creating Taxonomies" below

l

"Editing Taxonomies" on the next page

l

"Editing Categories" on page 22

l

"Deleting and Restoring Taxonomies" on page 24

l

"Comparing Taxonomy Files" on page 25

l

"Updating Taxonomies from the Server" on page 26

l

"Importing and Exporting Taxonomy Files" on page 26

Creating Taxonomies
In "Creating a Taxonomy Project" on page 15, you created a Taxonomy Project and looked at how to
download taxonomies. The following section describes how to create new taxonomies.
To Create a New Taxonomy:
1. Do one of the following:
o

Click New

to open the Select a Wizard dialog box, and select HPE EM > Taxonomy, and

then click Next.
o

Select File > New > Taxonomy.

o

Press Alt+Shift+N to open the context menu, and then select Taxonomy.
The New Taxonomy wizard opens.

2. In the New Taxonomy wizard, enter the required parameters.
Note: Note: A default Taxonomy ID and Filename are assigned according to the Taxonomy
Name entered. The Source Folder is assigned by default, according to whether there is an
active extension project. You can change these parameters to meet your requirements.
3. Click Finish to create the taxonomy.
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The taxonomy is now visible in Project Explorer and the Taxonomy Editor opens.
4. Open the Categories tab and add the categories you need. For details, see "Editing Categories" on
the next page.
5. Open the Advanced tab and enter the required parameters, as described in "Editor View" on page
11.

Editing Taxonomies
A taxonomy can be modified in the following ways:
l

"Editing Taxonomy Properties" below

l

"Refreshing Taxonomies to Reflect External Changes" below

l

"Copying Taxonomies" on the next page

Editing Taxonomy Properties
To Edit Taxonomy Properties:
1. Double-click the taxonomy in Project Explorer to open the Editor view.
2. Edit properties as required in the tabs of the Editor view. For details, see "Editor View" on page 11.
3. Click Save.
The changed status of the taxonomy is displayed in Project Explorer.

Refreshing Taxonomies to Reflect External
Changes
If you want the Editor to reflect changes made outside Taxonomy Editor, you can refresh the
taxonomy.
To refresh a taxonomy, do one of the following:
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l

Right-click the individual taxonomies or the project in Project Explorer to open the context menu,
and then select Refresh.

l

Select the individual taxonomies or the project in Project Explorer, and then press F5.

The selected taxonomies are then updated to reflect external changes.

Copying Taxonomies
You can copy or move taxonomies from one project to another using cut, copy, or paste.
To Copy or Move a Taxonomy to a Different Project:
1. Right-click the taxonomy in Project Explorer and select Copy or Cut.
2. Right-click the project to which you want to copy or move the taxonomies and select Paste.
The taxonomies are then either copied or moved to the other project.
A pasted taxonomy has the status:
l

New
If a taxonomy of that name is new to that location.

l

Modified
If an existing taxonomy is overwritten.

Editing Categories
A taxonomy can be modified in the following ways:
l

"Adding a Category" on the next page

l

"Removing a Category" on the next page

l

"Copying a Category" on page 24

l

"Moving a Category" on page 24
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Adding a Category
To Add a New Category to a Taxonomy:
1. Open the required taxonomy in the Editor pane and click the Categories tab.
2. Do one of the following:
o

Click Add Next to add a new category at the same level.

o

Click Add Child to add a new sub-category.

The New Category wizard opens.
3. Enter the category properties, as follows:
o

Name
Name for the category. This represents the value of the keyName attribute in the taxonomy's
XML representation.

o

Value
Identifier for the category. This represents the value of the keyValue attribute in the
taxonomy's XML representation.

o

Disabled
Select this check box to make sure the category cannot be used in an artifact.

4. Click Finish.
The new category is displayed in Category Structure.

Removing a Category
To Remove a Category:
1. Open the required taxonomy in the Editor pane and click the Categories tab.
2. Right-click the category in the Category Structure pane to open its context menu, and select
Delete.
The deleted category is no longer visible in the Category Structure pane.
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Copying a Category
To Copy a Category:
1. Open the required taxonomy in the Editor pane and click the Categories tab.
2. Right-click the required source category in the Category Structure pane to open its context menu,
and then select Copy or Cut.
3. Right-click the required destination category in the Category Structure pane to open its context
menu.
4. Do one of the following:
o

Select Paste to add the category as a sub-category.

o

Select Paste as Sibling to add the category at the same level.

Moving a Category
To Move a Category:
1. Open the required taxonomy in the Editor pane and click the Categories tab.
2. Select the required category in the Category Structure pane.
3. Do one of the following:
o

Click Up, to move a category up.

o

Click Down, to move a category down.

o

Click Unindent, to move a category to the left.

o

Click Indent, to move a category to the right.

Note: Note: To move multiple categories at the same time, you must select categories that are
consecutive.

Deleting and Restoring Taxonomies
You can also delete taxonomies and restore them from your local history.
To Delete a Local Taxonomy:
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1. Right-click the taxonomy in Project Explorer to open its context menu, and then select Delete.
2. Confirm deletion of the taxonomy when prompted.
To Restore a Deleted Taxonomy:
1. Right-click the project in Project Explorer to open its context menu and select Restore from
Local History.
The Restore from Local History dialog box opens.
2. Select the check box of the required taxonomy and click Restore.
3. Download the published taxonomy from the server, as described in “Downloading Taxonomies
from a Server”.
To Delete a Taxonomy from the Server:
1. Right-click the taxonomy in Project Explorer to open its context menu and select HPE EM >
Remove from Server.
2. Choose if you also want to delete the local copy.
3. Confirm deletion of the taxonomy when prompted.
Note: Note: Taxonomy Editor automatically performs a data consistency check before removing
the taxonomy from the server. For details, see “Conflict With Server”.

Comparing Taxonomy Files
If you are importing or exporting taxonomies between servers, it is essential to compare taxonomies to
keep track of changes.
Taxonomy Editor enables you to compare the following taxonomies:
l

Local taxonomy against the server taxonomy.

l

Server taxonomy against a local history taxonomy.

To Compare Taxonomies:
Right-click the taxonomies you want to compare in Project Explorer to open a context menu, and then
select one of the following:
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l

Compare With > Each Other

l

HPE EM > Compare with the latest on server

l

Compare With > Local History

The results are displayed in the Compare view.

Updating Taxonomies from the Server
If the most current version of a taxonomy exists on a server, you can update your local copy to reflect
any changes.
To Update a Local Taxonomy:
l

Right-click the taxonomy in Project Explorer to open the context menu, and then select HPE EM >
Update from Server.
Note: Confirmation is required to overwrite existing taxonomies.

Importing and Exporting Taxonomy Files
You can import and export taxonomies between your projects and your local file system.
To Import a Taxonomy from your File System:
1. In Project Explorer, right-click the taxonomy project to which you want to import taxonomies to
open its context menu, and then select Import > Taxonomy.
The Import Taxonomies wizard opens. For details, see "Import Taxonomies" on page 37.
2. Browse for the folder from which you want to export taxonomies in the Folder field.
The selected folder is displayed in the left pane.
3. Click the check box of the chosen folder.
Compatible file types are displayed in the right pane.
4. Click the check box of the files you want to import and, and then browse for the required import
folder in the Into folder field.
5. Click Finish.
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6. Publish the taxonomies to an HPE EM repository, as described in "Publishing Taxonomies" on
page 28.
Tip: Tip: When importing a taxonomy from a file whose file name already exists in the local folder,
Taxonomy Editor asks if you want to overwrite the taxonomy. If you click Yes or Yes To All, the
current taxonomy is updated by attributes and categories from the XML file and its status is
changed to modified.
To Export a Taxonomy:
1. Right-click the taxonomy in Project Explorer to open its context menu, and then select Export to
open the Export wizard. For details, see "Export Taxonomies Wizard" on page 37.
2. Select the required file type and click Next to open the corresponding wizard.
3. Browse for the required destination and enter the required parameters.
4. Select whether to overwrite existing files.
5. Click Finish.
Note: Note: You can export a taxonomy to any file type supported by Eclipse. For example:
l

XML file

l

JAR archive

l

EAR-deployable or JAR-deployable archiv
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This chapter explains how to deploy a set of taxonomies as an Extension Project.
You can publish individual taxonomies as described in "Publishing Taxonomies" below.
Alternatively, create a taxonomy extension and deploy it as described in the following sections:
l

"Publishing Taxonomies" below

l

"Building a Taxonomy Extension" on the next page

l

Applying Extensions

l

"Redeploying the EAR File" on the next page

Publishing Taxonomies
Publishing is the process of updating changes to an HPE EM server.
To Publish a Taxonomy:
l

Right-click the taxonomy in the Project Explorer to open its context menu, and then select HPE
EM> Upload to Server. Multiple taxonomies may be selected by holding CTRL and selecting
them.
The taxonomy is published to the defined HPE EM server.
Caution: Caution: You cannot publish a System taxonomy to a remote repository.

The status of a taxonomy after publishing updates as described in the following table.
Taxonomy Status After Publication
Status

Description

Impact

UP-TODATE

Local and server versions are identical.

Publication was successful, including any
modifications.

NEW ?

Local version of the taxonomy has not
been published to the server.

Publication was unsuccessful and the
status is unchanged. Possibly due to one of
the following:
l
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Taxonomy Status After Publication, continued
Status

Description

Impact
l

MODIFIED
>

Changes have been made to a local
version of a taxonomy after it has been
published.

SYSTEM

Taxonomies automatically generated
by HPE EM. For system use only.

Breach of server data integrity.

Changes to these taxonomies cannot be
published.

Building a Taxonomy Extension
After publishing taxonomies, you can create a Taxonomy Extension.
To Build a Taxonomy Extension:
1. Right-click the taxonomy project in Project Explorer to open its context menu, and expand HPE
EM > Build Extension to open the location browser.
2. Enter a name for the extension project and browse for the location you want to save the project to,
and click Save.
All taxonomies from the selected taxonomy project are copied to the Taxonomy Extension.

Redeploying the EAR File
After using the Setup Tool to apply extensions or updates, you must redeploy the EAR file to the
application server. For JBoss, you can do this using the Setup Tool.
To Redeploy the EAR file to JBoss:
1. Stop the application server.
2. Start the Setup Tool by executing the following command:
EM_HOME/bin/setup.bat(sh)
3. Select the Advanced scenario, and click Next.
4. Scroll down, select Deployment, and then click Next.
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When the Setup Tool validates the existence of the JBoss Deployment folder, click Next.
5. Click Finish to close the Setup Tool.
6. Restart the application server.
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Issues
Editing taxonomies can result in validation and conflict issues, as described in the following sections:
l

"Local Validity" below

l

"Server Conflicts" below

l

"Repair Action" on the next page

Local Validity
By default, the validity of local taxonomies is constantly checked as you modify them.. Invalid
taxonomies are marked in Project Explorer and the associated errors are listed in the Problems view.
To disable validation, from the menu, deselect Build automatically.

Server Conflicts
A local taxonomy and the version on a server can come into conflict either when the version on the
server is changed or when changes to the local version affect artifacts on the server.
Conflicts are displayed when you try to publish the taxonomy. An error message is displayed, stating
that the taxonomy could not be published.
To help prevent conflicts, you can do the following:
l

Right-click the taxonomy in Project Explorer to open its context menu, and then select one of the
following:
o

HPE EM > Show Taxonomy Usage
All artifacts categorized by the taxonomy are displayed in the Taxonomy Usage view.

o

Right-click the taxonomy in Project Explorer to open its context menu, and then select HPE EM
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> Validate Data Consistency
Conflicts are displayed in the Validation Results view.

Repair Action
The Data Consistency Check reports artifacts that use categories which no longer exist in the
taxonomy project.
Taxonomy Editor features a Repair Action which enables you to resolve these inconsistencies.
To Repair an Inconsistency:
1. In the Validation Results view, expand the problem category, and right-click an artifact to open its
context menu, then select one of the following:
o

Remove Referenced Category From Artifact

o

Change Category

2. Re-run validation.
Note: Note: Some conflicts relate to the validity of policy and lifecycle data (non-standard
artifacts). The repair actions cannot resolve these conflicts.
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Publishing a Department Taxonomy
In this example, you create and deploy a new taxonomy containing the identities of departments in your
organization.
Before proceeding, you must do the following:
l

Define your HPE EM server.

l

Update the local taxonomies, as described in "Updating Taxonomies from the Server" on page 26.

To Create a Department Taxonomy:
1. Create a new taxonomy, entering Departments as the Taxonomy Name.
For details of the procedure, see "Creating Taxonomies" on page 20.
2. Open the Editor for the Departments taxonomy and select the Categories tab.
3. Add the following categories:
o

HR

o

IT

o

Payroll

o

Finance

o

Sales

o

Development

o

QA

For details of the procedure, see "Adding a Category" on page 23.
4. Press Ctrl+S to save the taxonomy.
The Departments taxonomy is now visible in Project Explorer.
5. Right-click the Departments taxonomy to open its context menu, and then select one of the
following:
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o

HPE EM > Publish Taxonomy
To publish the taxonomy to the defined HPE EM server.

o

HPE EM > Publish To Other Server
To publish the taxonomy to a different server.
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Appendix A: Keyboard Shortcuts
Shortcut

Action

Context

Ctrl+Alt+S

Add HPE EM server.

Global

Ctrl+N

New taxonomy.

Global

Alt+A, Insert

Add next category.

Categories
tab

Alt+C

Add child category.

Categories
tab

Alt+U, Ctrl+ArrowUp

Move category up.

Categories
tab

Alt+D,
Ctrl+ArrowDown

Move category down.

Categories
tab

Alt+E, Ctrl+ArrowLeft

Move category left (unindent).

Categories
tab

Alt+I, Ctrl+ArrowRight

Move category right (indent).

Categories
tab

F2

Navigate to Category Name field.

Categories
tab

Esc

Ignore changes in current test field and switch to
Category Structure

Categories
tab

Ctrl+PgDn

Switch to next editor tab.

Taxonomy
Editor

Ctrl+PgUp

Switch to previous editor tab.

Taxonomy
Editor

F12

Activate Editor.

Global

Ctrl+W, Ctrl+F4

Close current editor.

Global

Ctrl+Shift+W,
Ctrl+Shift+F4

Close all editors.

Global

Ctrl+F6

Go to next editor.

Global

Ctrl+Shift+F6

Go to previous editor.

Global
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Shortcut

Action

Context

Ctrl+Shift+E

Switch to editor.

Global

Ctrl+J

Quick find taxonomy.

Global

Ctrl+H

Search taxonomy or category.

Global

Alt+Shift+W

Show editing resource in Taxonomy Editor.

Global

F5

Refresh items.

Global

Ctrl+S

Save changes for active editor.

Global

Ctrl+Shift+S

Save changes for all editors.

Global

Ctrl+C, Ctrl+Insert

Copy

Global

Ctrl+X, Shift+Delete

Cut

Global

Delete

Delete

Global

Ctrl+V, shift+Insert

Paste

Global

Ctrl+Shift+L

Show key assist

Global
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Appendix B: Dialog Boxes Reference
Each Taxonomy Editor input dialog is described in the following sections:
l

"Import Taxonomies" below

l

"Export Taxonomies Wizard" below

l

"Find Taxonomy Dialog" on the next page

l

"Search Taxonomy Dialog" on the next page

Import Taxonomies
Select taxonomy files to import into your taxonomy project:
Parameter Definition
Folder

Browse for the source folder containing the taxonomy files you want to import.

Left Pane

Select the source folder containing the taxonomy files you want to import.

Right
Pane

Select the individual taxonomy files you want to import.

Into Folder

Browse for the destination folder into which you want to import the selected
taxonomies.

Export Taxonomies Wizard
Select a destination for the taxonomies you wish to export:
Parameter

Definition

Select an export destination Enter text to filter your search.
Tree View

Select File System as your destination folder.

Select the taxonomies you want to export, then browse for the destination directory:
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Parameter

Definition

Left Pane

Select the project from which you want to export taxonomies.

Right Pane

Select the individual taxonomies you want to export.

To
Directory

Browse for and select the directory into which you want to export the selected
taxonomies.

Find Taxonomy Dialog
A quick search for matching taxonomies:
Parameter

Definition

Top Field

Enter text to filter your search results.

Matching Taxonomies

A list of taxonomies matching your search request.

In Project

Select the project in which you want to search for taxonomies.

Search Taxonomy Dialog
An advanced search for matching taxonomies:
Parameter

Definition

Containing
Text

Enter text to search or use the drop-down menu to select a previous search
parameter.

Working Set

Browse for and select a working set as a scope for your search.
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Appendix C: Troubleshooting
Case

Indications

Resolution

Type

Severity

A taxonomy
was changed on
the remote
server while you
were modifying
your local
version.

Your local taxonomy is
CONFLICTING. The
local version cannot be
published and its
modifications are kept.

To replace the local
taxonomy with the server
version, use the taxonomy
context action HPE EM >
Update Taxonomy. You
might want to first copy
your local version to a
temporary location.

Conflict

Error

A taxonomy
was published
that has the
same file name
as a new
taxonomy you
are trying to
publish to the
remote server.

Taxonomy is
CONFLICTING. The
local version cannot be
published. Changes to
the local taxonomy and
server remain in Project
Explorer.

To replace the local
taxonomy with the remote
server version, use the
taxonomy context action
HPE EM > Update
Taxonomy. You might
want to first make a
backup copy your local
version.

Conflict

Error

The taxonomy
you have
created has the
same ID as an
existing
taxonomy on the
remote server

The local taxonomy
cannot be published.
Changes to the local
taxonomy and server
remain in Project
Explorer. The Validation
Results include a node
giving the taxonomy ID.

Change the ID of the new
taxonomy.

Validation
Results

Error

You have
changed the ID
of a taxonomy
used by
artifacts.

The local taxonomy
cannot be published and
remains MODIFIED.
The Validation Results
list artifacts that use the
taxonomy.

To restore the original
taxonomy, use the
taxonomy context action
HPE EM > Update
Taxonomy.

Validation
Results

Error

A category that
you modified is
used by other
artifacts.

The local taxonomy
cannot be published and
remains MODIFIED.
Validation Results lists
artifacts that use the
category.

To restore the original
taxonomy, use the
taxonomy context action
HPE EM > Update
Taxonomy.

Validation
Results

Error
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Case

Indications

Resolution

Type

Severity

A new
taxonomy ID is
identical to that
of another local
taxonomy.

An error message for
this taxonomy is shown.

Change taxonomy ID to
another value.

Local
Inconsistency

Error

Taxonomy ID
A warning message for
format is invalid. this taxonomy is shown.

Change taxonomy ID to
valid format.

Local
Inconsistency

Warning

Category value
is duplicated by
another
category in the
same
taxonomy.

Change the category
value.

Local
Inconsistency

Error

Change file name so that it
does not contain invalid
character.

Local
Inconsistency

Error

An error message for
this taxonomy is shown.

Taxonomy file
An error message for
name contains
this taxonomy is shown.
invalid character
for REST URL.
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