SM 9.4x : How to fix error "Failed to save branding configuration" in SM webtier ?

  • KM02488203
  • 21-Jul-2016
  • 25-Jul-2016

Summary

This document will help to fix in SM 9.4x, while saving the changes made during branding configuration, an error pops "Failed to save branding configuration" and unable to save the configuration.

Error

 

while saving the branding configuration customer would get the below error message, as shown in the screen shot.

image text

Cause

To perfrom any branding operations, it is required to enable the branding feature by specifying a location to store your branding files.


1. On the web tier, create a folder (e.g. C:/customize). This folder will be the root folder to store your branding image files.


2. Stop the web application server.


3. Specify the folder location in the customize-folder web parameter. In the following example, we add C:/customize to the parameter value field:

<context-param>
<param-name>customize-folder</param-name>
<param-value>C:/customize</param-value>
</context-param>

4. Restart the web application server.

Fix

In the customer's web.xml, the customize-folder is not set properly

  <context-param>
    <param-name>customize-folder</param-name>
    <param-value>C:\Program Files (x86)\HP\Service Manager 9.40\customize</param-value>
  </context-param>

It should be:


  <context-param>
    <param-name>customize-folder</param-name>
    <param-value>C:/Program Files (x86)/HP/Service Manager 9.40/customize</param-value>
  </context-param>

Also you must ensure the write access to customize folder.

Backslash is used in the folder directory in Windows by default, but to be compatible with other platforms, we suggest using slash instead.