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Welcome to HPE Operations
Orchestration Studio Authoring Guide
HPE OOStudio is a standalone authoring program used for creating, modifying, and testing flows.

Visual Overview of OO Studio

Themain elements of Studio are:

l Projects pane (on the left), which shows the project you’re working in, and displays the editable flows,
operations, and other HPE OO objects that you can use in the project.

l Dependencies pane (on the left), which includes the imported content packs. In this pane, you can import,
delete and close the content packs. TheDependencies pane contains two tabs:
l Content Packs - Displays multiple trees, for multiple content packs. From this view, it is possible to
close, delete, or import a content pack.

l Library - Displays a single tree, with all of the content merged together under a general Library folder.
From this view, it is possible to import a content pack.

l Authoring pane (in the center). When a flow is opened in the authoring pane, the following three tabs are
available at the bottom of the authoring pane:
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l Design tab, where you can work on the flow diagram

l Properties tab, where you can set the properties for flows, operations, and configuration objects

l Inspector tab, where you can set the properties for individual steps and transitions (only available when
theDesign tab is open)

l Welcome tab (in the center). When you first open Studio, theWelcome tab is displayed in the authoring
pane.

l Icons pane (on the right), which contains collections of icons that you use for operations or steps. Open
this pane by clicking the Icons tab.

l Bookmarks pane (on the right), where you can store shortcuts to favorite operations and flows. Open this
pane by clicking theBookmarks tab.

l Flow Variables pane (on the right), which shows the flow variables that are used in the flow and lists and
describes how each flow variable is used. Open this pane by clicking the Flow Variables tab.

l References pane (on the bottom), which shows how flows and operations are used in existing flows. Open
this pane by clicking theReferences tab.

l Problems pane (on the bottom), which displays problems with a selected flow or operation. Open this
pane by clicking theProblems tab. See "Problems pane" on page 18 for more information.

l SCM Messages pane (on the bottom), displays source control relatedmessages. Open this pane by
clicking theSCM Messages tab. See "Working with Source Control in HPHPE OO Studio" on page 1 for
more information.

l SCM Changes pane (on the bottom), displays the latest source control changes. Open this pane by
clicking theSCM Changes tab. See "Working with Source Control in OO Studio" on page 36 for more
information.

l SCM Repository Log pane (on the bottom), displays a log of the changes made to the SCM repository
(for Git only). Open this pane by clicking theSCM Repository Log tab. See "Working with Git Source
Management System " on page 60 for more information.

l >Log Viewer pane (on the bottom), displays all the errors that have occurred in the current user session.
Open this pane by clicking the Log Viewer tab. See> "Viewing Studio Errors in the Log Viewer " on page
349 for more information.

Note: The Log Viewer tab appears only after you enable it by selectingStudio Log Viewer from the
Windowsmenu.

l Search pane (on the bottom), which enables you to search for a flow, operation or configuration item. Open
this pane by clicking theSearch tab.

l HPE Live Network Search pane (on the bottom), allows you to search for relevant information and
content on the HPE Live network based on their HPLN profile access permissions directly from Studio.
See "Searching Content on HPE Live Network from Studio" on page 1 for more information.

l Status bar (on the bottom), shows the sourcemanagement system the current project is connected to (Git
or SVN) and its current state. In addition the total heap size available and current heap size usage is
shown.

Note: If you cannot see the entire Studio screen, as it appears above, this may be a screen resolution
issue. When working in Studio, you should set your screen resolution to aminimum of 1280x1024 pixels.

Studio Authoring Guide
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Reference Material
Projects pane
TheProjects pane contains the project tree—a hierarchical folder structure containing the editable content of
your project:

l The Library folder, which holds flows and operations.
l TheConfiguration folder, which holds other OO objects (filters, scriptlets, system properties, and so on)
that you can use to process operation results, create reports, and facilitate the running of flows.

Note: You can create folders in all the configuration items under the existing Configuration Item folder
structure.

l The project properties

GUI item Description

New Project Creates a new project.

Import Project Browse to and import an existing project from a different
workspace.

Create Content Pack Creates a content pack from the selected project.

Delete
Permanently deletes the selected project from the workspace.

Studio Authoring Guide
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Open
Opens the currently selected closed project.

Close
Closes the currently selected project, so that it is grayed out.

Refresh Refreshes the files in the currently select project.

For information about working with projects, see "Working with Projects" on page 24.

Dependencies pane
TheDependencies pane displays the available content packs, with folders that contain the operations and
flows.

The Dependencies pane includes two view options: Content Packs tree view and Librarywhich is an
aggregated view of all the imported content packs.

When you switch the view to the Library pane, all the items aremerged under the same tree. In addition all
the configuration items aremerged under a general Configurations folder. All the items in the tree will be
merged into the same folder if they have a common path.

The next time you open Studio, it automatically opens the last view selected.

l Content Packs: Displays multiple trees, for multiple content packs. From this view, it is possible to close,
delete, or import a content pack. When you right-click on an item, a drop-downmenu with the available
options for this view appears.

l Library: Displays all the library and configuration items, (including all the folders and sub-folders). From
this view, it is possible to import a content pack. Content packs that were removed or deleted from the
Content Packs view will automatically update the Library view. When you right-click on an item, a drop-
downmenu with the available options for this view appears.

Authoring pane
The authoring pane is the central area in Studio, where you work on flow diagrams, adding steps and the
connections between them, and setting properties that determine how flows work.

Studio Authoring Guide
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When a flow is opened in the authoring pane, the following three tabs are available:

l Design tab, for working on the flow diagram, adding steps and the connections between them
l Properties tab, to display theProperties sheets, where you can set the properties for flows and
operations, as well as configuration objects such as selection lists, filters, and scriptlets.

l Inspector tab, to display the Inspector, where you can set the properties for individual steps and
transitions

Authoring pane toolbar
When a flow is opened in the authoring pane, and theDesign tab is open, the authoring pane toolbar is
available.

The authoring pane toolbar buttons provide shortcuts for a number of tasks.

Button What it does

Step Palette Opens theStep palette to drag step objects onto the canvas

View Options Opens theView Options palette

Find this object in

Library

Expands the Library tree to select the flow or operation that you’re working on

Debug Flow Adds or edits Central debugger connections.

Go to Step
Lets you jump to a specific step in the flow. Type the name of the step to jump to it,
or the first letters of the step to select it from a list.

For information about working with the authoring pane, see "Authoring a Flow – Basics" on page 149.

Welcome tab
When you first open Studio, theWelcome tab is displayed in the authoring pane. If it has been closed, select
Help > Show Welcome Panel to reopen it.

Studio Authoring Guide
Welcome to HPE Operations Orchestration Studio Authoring Guide

HPE Operations Orchestration (10.60) Page 11 of 350



Button Description

New Flow Click to create a new flow from a predefined template.

Search Click to open theSearch pane, so you can search for flows from
the content repository.

Community Home Page Click to go to the HPLN Community Home Page.

Tutorial Click to view the HPE OO tutorials.

Help Click to open the HPE OOHelp.

Online Content Click to go to the HPE OO Content Catalog download page on
HPLN.

Do not show the Welcome pane
again when Studio starts up

Select this check box to specify that theWelcome page will not be
shown the next time Studio is opened.

Note: Links to the HPE OO Help, HPLN Community home page and the online content are also
available from theHelpmenu.

For more information about creating a new flow from a predefined template, see "Creating a New Flow" on
page 152.

For more information about searching for a flow, see "Finding a Flow or Operation" on page 307.

Step palette
TheStep palette contains buttons for dragging return steps, parallel split steps, multi-instance steps, and
callouts onto the flow. Display theStep palette by clicking theStep Palette button
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from the authoring pane toolbar.

Button Description

Success
Lets you drag aSuccess return step to the flow.

Diagnosed
Lets you drag aDiagnosed return step to the flow.

No Action Taken
Lets you drag aNo Action Taken return step to the flow.

Failure
Lets you drag a Failure return step to the flow.

Parallel Split Step
Lets you drag a parallel split step to the flow.

Multi-instance Step
Lets you drag amulti-instance step to the flow.

Callout
Lets you drag a callout to the flow, providing information to users.

Docking bar Click to dock and undock the palette.

For information about working with return steps, see "Creating Return Steps" on page 235.

For information about parallel split steps andmulti-instance steps, see "Advanced Authoring" on page 238.

View Options palette
TheView Options palette contains buttons for changing the appearance of the flow on the authoring pane.

Display theView Options palette by clicking theView Options button from the authoring pane
toolbar. Using the Zoom bar, you can zoom into the flow up to 300%.

Studio Authoring Guide
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Button Description

Show/Hide Labels
Shows or hides response labels on objects

Show/Hide Connected

Response Icons

Shows or hides response icons on objects

Align Selection

Horizontally

Aligns selected steps horizontally

Align Selection

Vertically

Aligns selected steps vertically

Bring to Front Moves the selected object to the front of the stack

Send to Back Moves the selected object to the back of the stack

Show/Hide Grid Reveals the authoring pane grid, which you can use for arranging steps.
When you stop dragging a step, it snaps to the nearest position on the grid.

Docking bar Click to dock and undock the palette.

For information about working with the view options, see "Adjusting the Appearance of a Flow" on page 159.

Object Properties sheets
TheProperties sheets for flows, operations, and configuration objects are the editors in which you add,
remove, or change values for the objects. For most objects in the Library, theProperties sheet is the
interface you use to work with the object. In addition to the fields that you can edit, Properties sheets provide
the UUID and information about the version of the object.

After youmodify the properties of an operation in theProperties sheet, the changes affect all steps that you
create from this operation, including steps that were created earlier from this operation.

l To display theProperties sheet for a flow, open the flow in the authoring pane and click theProperties
tab.
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l To display theProperties sheet for an operation or configuration object, right-click the operation or object
in the Library and select Properties.

For information about working with theProperties sheet, see "Creating Input" on page 166 and "Setting
Operation Outputs" on page 205.

Step Inspector
The Step Inspector is similar to theProperties sheet for an operation, but it relates to a single step in a flow.
If youmodify the properties of a step in the Step Inspector, the changes only affect this step, which is an
instance of the operation.

For information about working with the Step Inspector, see "Creating Input" on page 166.

Transition Inspector
The Transition Inspector is used to configure the transitions between steps. To display the Transition
Inspector, right-click the line that leads between two steps and select Properties.

For information about working with the Transition Inspector, see "Creating Transitions" on page 188.
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Bookmarks pane
TheBookmarks pane, which you open with theBookmarks tab in the upper-right of the Studio window,
makes it easier to find and use the operations and flows that you use frequently.

You can add flows and operations to theBookmarks pane by dragging them from the Library. You can also
drag flows and operations from theBookmarks pane to the Projects pane, to copy them to a project.

For more information about bookmarks, see "Bookmarking Flows andOperations" on page 327.

Icons pane
The Icons pane, which you open with the Icons tab in the upper-right of the Studio window, contains libraries
of icons that you can use to clarify what a step does. You can use one of these icons to replace the default
icon on a flow or step.
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For information about working with the Icons pane, see "Modifying a Flow" on page 162.

Flow Variables pane
The Flow Variables pane, which you open with the Flow Variables tab in the upper-right of the Studio
window, lists the flow variables used in the flow and describes how they are used.

For information about working with the Flow Variables pane, see "Working with Variables" on page 230.
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References pane
TheReferences pane, which you open with theReferences tab on the lower edge of the Studio window,
shows how an operation or flow is used in existing flows. The pane can display two kinds of references:

l What uses this? - Identifies flows that have a step created from the operation or flow.
l What does this use? - Identifies objects (selection lists, permissions, system filters) that the operation or
flow makes use of. In the case of flows, this includes operations and subflows from which the flow’s steps
were created.

For information about working with theReferences pane, see "Finding Out How Flows andOperations are
Used" on page 318.

Problems pane
TheProblems pane, which you open with theProblems tab on the lower edge of the Studio window, lets you
check whether a selected flow or operation is valid. This pane displays problems with a selected flow or
operation, with their locations and descriptions.

For information about working with theProblems pane, see "Validating Flows in the Problems Pane" on page
265.

Search pane
TheSearch pane, which you open with theSearch tab on the lower edge of the Studio window, enables you
to search for a flow or operation. The Studio Search engine uses the Apache Lucene syntax.

For information about working with theSearch pane, see "Finding a Flow or Operation" on page 307.
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Getting Started with OO Studio – Major Steps
in the Workflow
This topic briefly describes themajor steps involved in working with OOStudio. Click the links to seemore
detailed information about each step.

Click a button to navigate to the relevant topic.

1. Create a new project - Create a project to contain the flows, operations, folders, and configuration
items for a business purpose.
See "Managing Projects" on page 28.

2. Set up source control management - Set up either the SVN or Git source control management
system.
See "Working with Source Control in OO Studio" on page 36.

3. Import a content pack - Import any content packs that you need, so you will be able to copy the
relevant content into your project.

Note: The first two steps do not have to performed in this order. It is possible to import a content
pack before creating the project.

See "Importing Content Packs to a Project" on page 97.
4. Create a flow - Put together the operations, inputs, transitions, responses, and return steps that make

up your flow.
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See "Creating a Flow – Step-by-Step" on page 149 and "Advanced Authoring" on page 238.
5. Run and debug the flow - Validate your flow in the Debugger.

See "Testing and Debugging a Flow" on page 267.
6. Release the content, packaged into a content pack - Package your project into a content pack,

containing the flows, operations, actions, and configuration items, in order to promote it to OOCentral.
See "Exporting a Content Pack" on page 287.

Adjusting the Appearance of the OO Studio
Window
You can set the panes in OOStudio to the following states:

l Docked - set in a permanent position in the Studio window
l Floating - free to be repositioned in the Studio window
l Pinned - hidden at the side of the Studio window so that only the tab is visible, and you havemore room for
your workspace

What do you want to do?
Float a pane
By floating a pane, youmake it possible to move it to a different position in the Studio window.

1. Click the Float button in the upper-right-hand corner of a docked pane.
2. Move the pane to a new position in the Studio window.

Dock a pane
If a pane has been floated to a new position in the Studio window, docking returns it to its permanent position
in the Studio window.

Click theDock button in the upper-right-hand corner of the floating pane. The pane returns to its docked
position.

Maximize a pane
Tomaximize a pane, so that it expands to the size of the entire OOwindow, click theMaximize button .

Restore a pane to its original size
To restore the pane to its size before youmaximized it, click theRestore button .

Pin a pane to the side of the Studio window
Click thePin button to pin the pane to the side of the Studio window so that only the tab is visible. You can
display the pane by clicking the tab.

Unpin a pane
After a pane has been pinned, click thePin button again to unpin it. Unpinning a pane returns it to its open,
docked position in the Studio window.
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Adjust the size of a pane
Drag the edge of a pane tomake it larger or smaller.

Reset the Studio window to the default layout
To return the Studio window to the default layout, selectWindow > Reset Window Layout.

Note:When you reset the Studio window, this will only be after creating or importing a new project.

Working with Different Languages in
OO Studio - Localization
Localization refers to the adaptation of software for specific environments (countries or regions). OOStudio
can be localized into the following languages:

l French (fr)
l German (de)
l Japanese (ja)
l Spanish (es)
l Chinese (zh)
The following Studio text strings are localized:

l Flow descriptions and callouts
l Transition descriptions
l Configuration item descriptions
l Step descriptions and prompt texts (from theDisplay tab)
l Input prompts
l Folder descriptions
Language Codes

The following codes are valid:

Language locale code
(user.language)

Region locale code
(user.region) Language

fr FR French

de DE German

ja JP Japanese

es ES Spanish

zh CN Regional Chinese

Studio Authoring Guide
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Localizing Content Packs
All the text strings contained in content pack flows and operations are shown in the current Studio locale.

The localization files are saved with the name cp_<locale>{_<region>}.properties. The region parameter
is optional.

For example:

l The default content pack properties file is named cp.properties
l The French file is named cp_fr.properties
l The Chinese file is named cp_zh_CN.properties

Localizing Projects
Projects are not localized the sameway as content packs. You can only edit the default language of a project,
which is saved as the default file (cp.properties) during the packaging of the project into a content pack.

This has two implications:

l Project texts are not really localized. For flows, operations and configuration items, the text is stored inside
the XML file, and for folders, the descriptions are stored inmultiple .properties files, one for each folder.
When creating a content pack, the texts are always written to the same cp.properties file.

l If a content pack is unpacked and loaded as a project in Studio, the localized properties file will not be
used, only the default file. If one does not exist, all text strings will be empty.

When you create a content pack from a project in OOStudio, the resource bundle folder contains only the
cp.properties file.

Note: After changing the configuration of a content pack, youmust restart Studio.

When the project is created or saved, the cp.properties file is saved in the project file system location under
\resource-bundles\cp.properties.

You can also add your own resource files to the resource-bundles directory. These files will be bundled
along with the other resource files into the content pack's jar file.

What do you want to do?
Change the current Studio locale
By default, Studio is installed in the default language of the computer.

You can override the current locale by changing its configuration:

1. Open theC:\Users\<logged in user name>\.oo\studio.properties file.
2. Search for the following line:

user.language=

3. Add the language locale, using the user.language codes listed in the Language Codes table.
For example, user.language=ja
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Note: In order to implement a different language interface, youmust assign the same valid language
locale from the table to both the user.language field and user.region fields (where relevant). If an invalid
value is assigned, or if the field is left blank, Studio uses the default system locale.

Set the Studio display language
Studio takes the display language from the user.language property. This property must be valid (and
user.regionmust be valid as well). If it is not valid, Studio uses the system locale.

Currently, Studio supports the following display languages:

Language Language code

French fr

German de

Japanese jp

Spanish es

Regional Chinese cn

In addition, you can localize content packs. See "Localizing Content Packs" on the previous page.

In versions 10.5x and later, you can havemultiple workspaces. Therefore, each workspace will have its own
studio.properties file under the .oo folder.

l If you want to use the same properties in all new workspaces, you can edit the
studio.properties.template file located underStudio\conf\.

l To configure different settings for each workspace, you can still edit each of the studio.properties files
individually. These are located under the .oo folder inside each workspace.
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Working with Projects
A project is a logical unit that can include flows, operations, folders, domain terms, selection lists, and other
items for a business purpose. A project may be developed by a single author or as a collaboration project.

Projects in Studio use a file directory structure, like that of an operating system, which enables easy
integration with a source control application.

Managing Workspaces
A "workspace" in Studio is the folder that contains the OO projects. The default workspace location is under
C:\Users\<logged in user name>\.oo\, but you can specify a different location.

Using Multiple Workspaces
Theremay be cases in which you need to work with more than one workspace—for example, when working
with source control.

You can work in SVN in one workspace, and then switch to another workspace to work in Git, without
detaching from the SVN workspace and without losing any work you did in SVN, even if you have not yet
committed the changes.

Usingmultiple workspaces in Studio allows you to easily save custom workspace-specific settings such as
the proxy settings, debugger connections, the projects you are working on, and the content packs you use.

Additionally, you can work simultaneously on several completely distinct projects and switch between
projects as necessary. In this way, you can organize your work more efficiently especially when projects are
shared with other authors.

Note: Every workspace contains its own logs folder with its own log file.

Note:When creatingmultiple workspaces in Studio, it is recommend that each user creates workspaces
only under folders to which they have read and write permissions.

Workspaces created under public folders may be accessible to all users, making them prone to
tampering and disclosure of sensitive information.

What do you want to do?
Define the workspace on startup
When you start Studio, you are prompted to select your workspace in the Select Workspace dialog box.
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1. Do one of the following:
l Select a workspace from the list.

l Enter the workspace path.

Note: The pathmust not include .oo.

l Click Browse to select a workspace from a different location.

2. (Optional) Select Use this as default and do not ask again if you do not want to be prompted again at
Studio startup, and to always open themost recently used workspace.
The next time Studio starts up, it will use the workspace that was last used, and theSelect Workspace
dialog box will not appear.
If you switch to another workspace using File > Switch Workspace and then close Studio, the next
time Studio starts up, it will use that workspace.

3. Click OK.
If the path represents an existing valid workspace, Studio loads the settings, projects and content packs
and connects to SVN or Git as configured previously in this workspace. It also uses the proxy, HPLN,
debugger settings as configured previously in this workspace.
If the path you provided does not represent an existing workspace, Studio creates a new workspace.

Note: If this workspace is already in use (by another instance of Studio), a warningmessage is
displayed.

Switch to another workspace
You can also switch to another workspace while working in Studio.

1. From the Filemenu, select Switch Workspace.
2. Do one of the following:

l From the list, select a workspace location.

l Click Other to browse to a workspace from a different location.

Note: If you select a folder that does not contain a workspace, Studio asks if you want to create
a new workspace in this folder:
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Click Yes to create a new workspace.

Studio opens the selected workspace.

Reference Material
File menu

Menu item Description

Switch workspace Select the workspace you want to switch to from the list or
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select Other... to browse to a different workspace.

Note: If you select a folder that does not contain a
workspace, Studio asks if you want to create a new
workspace in this folder.
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Managing Projects
Before you can start creating flows in HPE OOStudio, youmust be working in a project.

Note: Creating the project does not have to be the first step in the workflow. It is possible to import
content packs before creating the project.

In Studio 10.x, projects are stored locally on the author’s file system. In order to have source control
capabilities, you should use an external source control management tool. For more information about source
control management, see "Working with Source Control in OO Studio" on page 36.

Handling Duplicate UUIDs
In Studio, each flow, operation, and configuration itemmust have a unique UUID. However, it is possible to
accidentally end up with items of the same type and subtype with duplicate UUIDs. For example, this may
occur if you are doing several revert operations in SCM or when resolving conflicts while working with
branches in Git.

If there are items of the same type and subtype with duplicate UUIDs in a single project, in multiple projects
(two or more), in multiple custom content packs or between content packs and projects, they appear as
problems in the project tree (in red and underlined), and are displayed in theProblems pane.

Note: The same type and sub-typemeans flows with flows, operations with operations, configuration
items with configuration items of the same sub-type.

Items with duplicate UUIDs have the following characteristics:

l They are read-only, and you cannot move or rename them.
l They cannot be dragged to the canvas.
l You cannot move or rename the folders containing them.
l They are excluded from an exported content pack.
l You cannot debug flows containing duplicate UUIDs. You will get a validation error.
l You cannot use references. The "What uses this?" and "What does this use?" features are disabled.
l They cannot be committed. The folders and projects containing them can be committed, but you are
prompted with an error messages informing you that you are about to commit items with duplicate UUIDs.

To resolve duplicate UUIDs, delete the item with the duplicate UUID and leave the original item.

If you want to keep both items, use theCopy/Paste orDuplicate commands to save a copy of one of the
items with a different UUID, and then delete the item that you copied from.

To resolve duplicate UUIDs in content packs, delete or close the content pack.

What do you want to do?
Create a project
1. Select File > New Project.
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Note: Alternatively, you can click theNew Project button in theProjects pane.

2. In theName box, enter a name for the project.
3. In the Create Project dialog box, verify that the path in the Location box is the correct path to the

Workspace folder that you set up in the previous task. If the path does not lead to theWorkspace
folder, browse to and select theWorkspace folder.

4. Click OK.
5. If you are working with a source control management tool, add the project folder to your shared

repository. For more information, "Working with Source Control in OO Studio" on page 36.

Import a project
To open a project that was created in a different location, you need to import it to Studio. Once a project has
been imported, it appears in theProject pane.

If you are working with a source control tool, youmay need to check out the project folder, so that you have a
local working copy, and then import the project to Studio. For more information, see "Working with Source
Control in OO Studio" on page 36.

You can validate the project from the Tools > Validatemenu, and as a result theProblems pane displays
any issues in that project. For example, If the project contains items with duplicate UUIDs, they are
displayed in the Problems pane.

1. Select File > Import Project.

Note: Alternatively, you can click the Import Project button in theProjects pane.

2. In the Select Project Directory dialog box, browse to locate the project that you want to import. You can
import multiple projects into Studio at once.

3. Click OK. The project appears in theProjects pane in Studio.

Close an open project
If you close a project, it is visible in theProjects pane, but is grayed out and not available.

1. Select the project that you want to close.
2. Select File > Close Project.

Note: Alternatively, you can click theClose button in theProjects pane.

Open a closed project
After a project has been closed, you can open it, to work with it again.

1. Select the closed (grayed out) project that you want to open.
2. Select File > Open Project.

Note: Alternatively, you can click theOpen button in theProjects pane.

Delete a project
Deleting a project is different from closing it, in that a deleted project is permanently removed from the
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workspace.

1. Select the project that you want to delete.
2. Select File > Delete Project.

The Confirmation dialog opens:

Note: Alternatively, you can click theDelete button in theProjects pane.

3. Select the check box to delete the project from the Studio workspace and the file system. If you do not
select the check box, the project is removed from Studio workspace but not from the file system. If
required, you can reimport the project at a later stage.

4. Click Yes in the confirmation dialog box.

Move flows, operations, and configuration items
You canmove flows, operations, and configuration items to a different folder within a project or to a new
project.

Note: It is not possible to drag and drop flows and operations at the same time as configuration items. It
is not possible to drag and drop a flow or operation into theConfiguration folder, and vice versa.

1. In theProject pane, select the flows or operations that you want to move. You can select multiple items
using the SHIFT or CONTROL key.

2. Drag and drop the items or cut and paste them into another folder or another project.

Copy flows and operations from a content pack into a project
The flows and operations in theDependencies pane are read-only. You can create editable copies of these
flows and operations by copying them into the project.

1. In theDependencies pane, select the flow or operation that you want to copy.
2. Select Edit > Copy.
3. Select the location in the project tree where you want to paste the copy, and select Edit > Paste. The

flow or operation is treated as a new object and is detached from the content pack it arrived with.

Tip: A quick way to copy multiple items from the Dependencies pane is to select them, holding
down the SHIFT or CONTROL key, and drag and drop them into the project.

Note: If you also want copy the operations that make up a flow into the project, select Edit > Copy
Deep. For more information, see "Copying Flows andOperations" on page 315.
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Display the project properties
Do one of the following:

l Double click theProperties option in theProjects pane.
l Right-click the project and select Properties.
l Right-click the project on theProperties node in theProjects pane and select Open.
The Properties window displays information about the project. The project's Properties window allows you to
set thePublisher, Version and theDescription of the project as well as the dependencies of the project.

You can also perform standard SCM operations from theProperties node in the Projects pane (as well as
from theSCM Changes pane. You can add, commit, revert to old versions, update and see the history of the
properties.

This means that you can commit only the project metadata changes (publisher, version or description
changes) without committing the entire project's changes. Similarly, you can commit dependency changes
without committing the entire project's changes.

For full details on these options, see "Working with Subversion Source Control Management " on page 38 or
"Working with Git SourceManagement System " on page 60.

Show the project location in Windows explorer
1. Select theProperties option in theProjects pane.
2. Right-click and from themenu, select Show in Explorer.
Windows Explorer opens, showing the folder containing the project files.

Display the properties of an object in a project
l Double-click a flow, operation or other object in theProjects pane. The Properties window for the object
opens.

l If a flow is open on the authoring canvas, click theProperties tab in the lower left corner of the authoring
canvas, to display the Properties window for the flow.
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Reference Material
File menu

Menu item Description

New Project Creates a new project.

New Creates a new file, folder, or operation.

Import Project Browse to and import an existing project from a different
workspace.

Import Plugin Browse to and import an action plugin, to use as the basis of a
new operation. See "Creating Operations" on page 299.

Save Saves the selected element.

Save All Saves all updated elements.

Close Closes the currently selected flow or Properties window.

Close All Closes all open flows or Properties windows.

Recently Opened Lists recently opened items. This includes flows and
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operations that were open in the authoring canvas and
Properties windows that were recently viewed.

Create Content Pack Creates a content pack from the selected project.

Import Content Pack Browse to and import a content pack in .jar format. See
"Importing Content Packs to a Project" on page 97.

Close Project Closes the currently selected project, so that it is grayed out.

Open Project Opens the currently selected closed project.

Remove Project Removes the selected project from the workspace.

Refresh All Projects Refreshes all the projects in the Projects pane.

Quit Quits HPE OO.

Create Project dialog box

GUI item Description

Name Type a name for the new project.

Location Enter the location of the workspace, in which to store the new
project.

l Type the path to the location.

l Click the browse button to browse for the location.

Projects pane
TheProjects pane contains the project tree—a hierarchical folder structure containing the editable content of
your project:

l The Library folder, which holds flows and operations.
l TheConfiguration folder, which holds other OO objects (filters, scriptlets, system properties, and so on)
that you can use to process operation results, create reports, and facilitate the running of flows.

Note: You can create folders in all the configuration items under the existing Configuration Item folder
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structure.

l The project properties

GUI item Description

New Project Creates a new project.

Import Project Browse to and import an existing project from a different
workspace.

Create Content Pack Creates a content pack from the selected project.

Delete
Permanently deletes the selected project from the workspace.

Open
Opens the currently selected closed project.

Close
Closes the currently selected project, so that it is grayed out.

Refresh Refreshes the files in the currently select project.

Managing Folders in the Project Pane
In theProjects pane, youmanage the folders in the project—adding, deleting, copying, and renaming folders.
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What do you want to do?
Create a folder
1. Select File > New > Folder.
2. Type a name for the new folder and click OK.

Important! If you need to create an element (folder, flow, operation, or configuration item) inside your
project, make sure to do this from within Studio, and not by creating the item in the file system.

Note: Names can be amaximum of 128 characters long, and are not case-sensitive.

Rename a folder
Right-click a folder in the project tree, and select Rename.

Important! If you need to rename an element (folder, flow, operation, or configuration item) inside your
project, make sure to do this from within Studio, and not by renaming the item in the file system.

Delete a folder
Right-click a folder in the project tree, and select Delete.

Important! If you need to delete an element (folder, flow, operation, or configuration item) inside your
project, make sure to do this from within Studio, and not by deleting the item in the file system.

Note: You can delete a folder/hierarchy of folders that contains duplicate items, but cannot cut it for
pasting at a later stage.

Copy and paste a folder
1. Right-click a folder in the project tree, and select Edit > Copy.
2. Right-click the position in the project tree where you want to paste the folder, and select Edit > Paste.

Drill down to subfolders
Click the expand button to expand a folder and display the subfolders inside it.

Display the folder descriptions
Right-click a folder in the project tree, and select Properties. The properties of that folder are displayed.
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Working with Source Control in
OO Studio
This section describes the common tasks that are used with the Source Control Management (SCM) tools
andmore advanced tasks that you, as author, may encounter when projects and items are shared with
multiple authors.

What is Source Control in OO Studio?
OOStudio includes two built-in Source Control Management tools that allow authors to work in their local
environment and then synchronize changes with the public version:

l Subversion: For details, see "Working with Subversion Source Control Management " on page 38.
l Git: For details, see "Working with Git SourceManagement System " on page 60.

Note: Youmust select only one of these tools as they cannot be used concurrently. If you are not sure
which to use, consult with your system administrator.

What do you want to do?
Select a source control tool
To select a source control tool:

1. Select SCM > Connection
2. In theSCM Connection dialog box, select the SCM type: Subversion orGit.
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Reference Material
SCM Connection

Menu item Description

Type Select the source control management tool you want to use:
Subversion orGit.

SCM Repository:

URL

Enter the URL of the Subversion or Git repository.

Note: The HTTP and HTTPS protocols can be used
for the URL.

Clone / Detach For Git only:

Clones themain Git repository to the working copy on the
local machine in the directory of the current workspace .

After cloning, the Git path is disabled, and this button changes
toDetach.

Detach Detaches themain Git repository from the local directory. Use
theDetach option if you are usingmore than oneGit
repository and want to switch to a different repository.
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After selectingDetach, the followingmessage opens:

Before detaching from Git, make sure that all your
changes are committed and then pushed to the main
Git repository. You can clone the Git repository
again at a later stage to retrieve your changes.

Note: After detaching, you can no longer run any Git
commands.

Checkout / Detach For Subversion only:

Copies sources from the SVN repository to the working copy
on the local machine in the directory of the current workspace.

After checking out, the SVN path is disabled and this button
changes toDetach.

Trust server certificate If you are working with a secure server (SSL/SSH), select this
check box, otherwise you will be unable to access the server.

Credentials:

Use Windows
Authentication

When checked, performs authentication using the currently
logged in user.

To perform authentication with a different user, uncheck this
field, and enter the user name and password in the fields
below.

User name Enter the user name and password to use as credentials for
authentication.

Password

Working with Subversion Source Control
Management

Terminology
Working Copy

The SCM repository holds all versioned data on a source control server. The Source Control Management
tool in Studio manages local copies of the versioned data, known as the working copy. SCM accesses its
repository across networks. Multiple users can access the repository at the same time.

Checkout

Checkout is used to download sources from the repository to the working copy. If you want to access files
from the source control server, checkout is the first operation you should perform. When you check out, a
working copy is created, allowing you to edit, delete, or add contents. You can check out a file, directory,
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trunk or whole project. To check out, you need the source control server URL of the components you want to
check out.

Commit: Save changes to the repository

When youmake changes to your local working copy, they are not automatically saved in the source control
server. Tomake the changes permanent, commit the changes.

Add: Add a new file to SVN repository

TheAdd command allows you to add new files or directories to the repository. The repository shows the
newly added file after you commit the changes.

Delete: Removing a file from repository

TheDelete command deletes an item from the working copy (or repository). Files are deleted from the
repository after you commit the changes.

Move: Rename file or directory

TheMove commandmoves a file from one directory to another or renames a file. The file is moved on your
local sandbox immediately, as well as on the repository after committing.

Update: Update the working copy

TheUpdate command transfers changes from the repository into your working copy. It is recommended that
you update your working copy before you start working, so that all the latest changes available in repository
are available in your working copy.

Note: The Source Control Management tool does not include historical data for flows, such as date,
time, and comment.

Creating an Initial Source Control Repository
In a production environment it is recommended to use a dedicated SVN server, accessed by the protocols
http, https or svn.

Note: Go to the subversion web site, http://subversion.apache.org/packages.html, for a list of SVN
distributions for different operation systems.

Example 1: Using VisualSVN in a Multi-Author Scenario

The following example illustrates how to configure and use a VisualSVN server in amulti-author scenario.

Before beginning to work with SVN, it is recommended that you get accustomedwith its concepts from the
following link: https://subversion.apache.org/docs/.

1. Download a 1.8.x SVN compatible version of VisualSVN.
2. To configure the new SVN server users, right-click and select Users > Create User….
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Note: Every Studio persona is identified by a Visual SVN user.

3. To create a SVN repository, right-click on the Repository folder, select Create New Repository and
create an empty repository.
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4. In Studio, from theSCMmenu, select Settings.
5. Select theSubversion radio button.
6. Enter the SVN user name credentials -User Name andPassword.
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7. For an HTTPS protocol, select the Trust server certificate check box.
8. Check out the repository.

If you have direct access to the VisualSVN console application you can obtain the repository URL as
follows:
a. Right-click on the repository location in VisualSVN.
b. Select Copy URL to Clipboard.
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If you do not have access to a VisualSVN console application, ask your SVN administrator to provide
you with the repository URL.

9. In Studio, from theSCMmenu, select Connection.

10. In theSCM Repository area, URL field, paste the URL using Ctrl-V and click Checkout.
A Checkout message appears in theSCM Messages pane.

Example 2: Single-User Scenarios

The following example is only for single-user scenarios, testing, and for debugging purposes.
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Before you begin working with source control in Studio, you need to setup an initial repository.

Note: It is recommended not to use a file system-based (or network share-based) repository in
production.

This repository is intended for local, single-user access only, particularly testing and debugging, as when
shared over the network, there are security concerns and possible performance problems.

Note: If your company already has a source control repository, this section is not relevant.

To create an SVN repository:

1. Create a shared folder inWindows, and assign it with read and write permissions, for the authors that
will work on the repository.

2. Open command line (cmd) in <studio_installation_folder>\studio\tools. 
3. In the commandwindow, type:manageScmRepository.bat and the full path to the local folder.

For example:

c:\<studio_installation_folder>\Studio\tools> manageScmRepository.bat
-c LOCAL_FOLDER_FULL_PATH

The following appears:
Repository was successfully created at <LOCAL_FOLDER_FULL_PATH>

The shared repository folder is now ready for use with Studio.

Working with Multiple Authors in SVN
Whenmultiple authors work on a common project, there is a possibility that two authors will modify the same
item simultaneously. Studio attempts tomerge all these changes without causing conflicts. Locking an item
prevents other authors from working on the item at the same time. Items that are locked by another user can
still be edited, but not committed. It is highly recommended to lock any item before editing it in order to
prevent conflicts during updates. If you are unable to lock an item, then it is recommended that you do not edit
the item in order to avoid conflicts.

A flow is automatically locked if the author tries to delete, move, rename or revert a flow. Once the flow is
locked, other authors are prompted that the flow is locked when they try to perform one of these actions. This
occurs when theEnforce locking policy is enabled. See "Enforce Locking Policy" on the next page for more
information.

Note: Make sure you perform anUpdate, before locking, modifying, and committing the item.
Committing changes to a locked item automatically releases the lock.

You cannot lock items that do not exist in the SCM repository.

If an item is unable to lock, a warning (yellow)message appears, and the icon will not change.

Committing changes to a locked item will automatically release its lock.

The lock button is disabled for items that are added, but not committed yet, or for items that are in projects
that are not under Studio’s workspace.
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Note: A lock is associated to a workspace and not to a particular SCM user. Therefore, if you have
locked items and your workspace is destroyed, after recreating the workspace, you will not be able to
continue working on your previously locked items nor will you be able to unlock them. In this case, you
will need to either contact your SVN administrator, or to use an external SVN tool to break the locks on
your items.

Enforce Locking Policy
This options prevents the flow author frommaking any changes to an item (flow or configuration item) unless
the item is locked. This ensures that only one author can edit an item.

This option is automatically selected once the author checks out an SCM repository.

When the items is locked, the author can choose to unlock the itemmanually.

The author will then be prompted to select one of the following options after making changes to the item and
unlocking it:

l Commit your changes.
l Unlock the item and keep editing.
l Revert the item.
In the following cases the author cannot obtain a lock:

l Another author has already locked the item.
l Network issues.
l The item version is out-of-date.
In the above cases, the Failed to Acquire Lockmessage appears prompting you if there are any local
changes. Click Yes to continue editing, orNo to discard the changes.

WhenEnforce Locking Policy is enabled, Studio automatically obtains locks on the affected items of all
operations that change the project’s structure. For example, renaming, moving or deleting flows, operations or
folders.

What do you want to do?
After you have installed Studio with a local repository, you are ready to start authoring in Studio and use the
source control in your local environment. In the following sections, you can learn about common tasks that
you perform with SCM.

Set the authentication settings with the source control server
The first step in working with SCM is to set the user authentication with the source control server.
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1. From theSCMmenu, select Connection.

2. Under Type, select theSubversion radio button.
3. Select one of the following options, depending on your source control server:

l Use Windows Authentication: This option is the default option selected, and performs
authentication using the currently logged in user. This is applicable for file-based source control
repositories.

l Clear, theUse Windows Authentication option. Enter the user name and password defined on the
source control server. If you are working with a secure server (SSL/SSH), select Trust server
certificate. Otherwise, you will be unable to access the server.

Note: The credentials are only used to access the SCM itself. If the system is based on a simple
network fileshare, HPE OO expects the operating system to be able to create the network
connection to share. This means that HPE OO does not pass on the credentials to the operating
system for a network connection.

Check out a repository
The repository contains all your projects and can be shared by multiple authors. A repository can be hosted
either on a file system or on a web server.

You can check out the repository directly from Studio and then add projects to it for sharing with other
authors.

To check out all projects:
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1. From theSCMmenu, select Connection.

2. In theSCM Repository area, URL field, paste the URL using Ctrl-V and click Checkout. This checks
out the files from the URL and into Studio’s Workspace directory.
The first time you select Checkout, you are prompted to enter the URL of the shared folder you created
when you setup the local repository. If you are working on a local repository enter the URL using the file
URL scheme.
For example:
l Web-based URL:

http://svn.samplehost.com/repo/trunk

l If the repository folder is not shared, connect with the following:

file:///c:/temp/repo/trunk

l If the repository is shared and you have all the permissions:

file://myshared/repo/trunk

A Checkout message appears in the SCM Messages pane.TheSCM Messages pane displays the
shared folder with the location where the files are checked out to. If projects already exist in the
checked-out repository they can now be imported into Studio and worked on.

Note: In theSCM Messages pane, themessages coming from the Source Control Management
client tool may contain an encoded URL. This is the repository URL in a standard encoded form.
Themessage is coming from an external SVN client tool used by Studio (SlikSVN). Note that a non-
encoded version of the URL is also logged in theSCM Messages pane.

3. The next step is to either create a new project or import an existing project. From theProject pane, either

click the button to add a new project or click to import an existing project.
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Detach the Workspace from SVN
After detaching a repository, the Studio workspace is detached from the source control server. This is useful
if youmade amistake and checked out the wrong repository. Detaching does not delete anything from the
repository.

1. From theSCMmenu, select Connection.
2. In the SCM Repository area, click Detach.
3. Click OK to close the window.

Note: Detaching from an SVN repository will unlock all the flows, operations and configuration
items which were already locked by the user.

Commit changes to SVN
After making local changes, use theCommitmenu option to check them into the repository. There are a
number of ways to commit changes:

l From theSCMmenu, select Commit All to commit all the changes.
l In theSCM Changes pane, click theCommit button to commit all the changes.
l In theProjects pane, right-click an updated item and select SCM > Commit.
l In theSCM Changes pane, right-click an updated item and select SCM > Commit.

View a history of SVN operations in the repository
TheHistory option shows you:

l A list of commits in which the selected project/item was affected
l All affected files for a particular commit
TheHistory option also allows you to revert to a specific revision of the project/item. See "Revert to a
previous revision of a project/item " on the next page for details.

1. Right-click on a file/folder and select SCM >  History.
The Revision History dialog box opens:
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Revert to a previous revision of a project/item
To revert to a previous revision:

1. Right-click on a file/folder and select SCM > Revert.
The Revision History dialog box opens.

2. Right-click on the commit revision you want to revert to.
3. Select Revert to this version.

Note: You cannot revert to a revision number earlier than the initial revision given when the project was
first committed to SVN.

Update to a tagged version or revision of a project/item
Theremay be cases for which you need to recreate a faulty Central content pack/project in order to
troubleshoot a specific flow inside the content pack. If the content pack is not available (it has been lost or
been overwritten by a new version), you can restore a specific version of the project/item using theUpdate
to... operation.

Note: In SVN, you can perform aUpdate to... operation on individual folders and repositories.

You can use theUpdate to... option if you have already checked out the repository and you want to update
your workspace to a specific revision from the SCM tag.

1. Select the content pack/project you want to update.
2. Right-click and select SCM > Update To....

The Update Options window opens:
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3. Select Tag and type in the SCM tag you received from the Central administrator. By default, the
SCM tag is in the format [Project Name]-[Project version].
or:
Select Revision and type in the revision number you received from the Central administrator.

4. Click OK.

Move/cross-move a versioned item
You canmove an item from one location to another within the same project or cross-move an item between
two different projects.

Tomove an item:

1. In theProject pane, select the items that you want to move. You can select multiple items using the
Shift orCtrl key.

2. Drag and drop the items into another folder or another project.
or:
Cut the items usingCtrl+X and paste them at the new location usingCtrl+V.
The item is marked in theSCM Changes pane in the old location with the status deleted and in the new
location with a statusmoved.You can see the original location in parentheses.

Note:

l Whenmoving a versioned item, the itemmust also be scheduled for moving in the SVN repository.
l When cross-moving an item (between a source project and a destination project), the itemmust be
scheduled for moving, deletion or addition in the appropriate projects.

l Where relevant you can commit the result of themove/cross-move action to SVN.

Clean up the working copy
In some cases, you will need to clean up the working copy in Studio's workspace. For example, if a Studio
process crashes or if there is an IO error, and the working copy remains locked.

If you need to clean up the working copy, you will see an error message.

To clean up the workspace:

l From theSCMmenu, select Subversion > Cleanup.

Lock an Item
l In the top left corner of the items editor window, click theOpened Lock icon.
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If the lock was successful, the icon changes to a closed lock and displays an SCMmessage displaying
the full path to the locked file and with the user details.

Note: After you lock an item, its status is shown in the SCM Changes pane as "locked". If an item is
locked and has beenmodified (not recommended), its status is show as "modified". For example:

Unlock an Item
l In the top left corner of the items editor window, click theClosed Lock icon.

If the unlock was successful, the icon changes to anOpen Lock and displays an SCMmessage displaying
the full path to the unlocked file and with the user details.
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Set the Enforce Locking Policy
l From theSCM menu, select Subversion > Enforce Locking Policy.

Reference Material: SCM Changes Pane
TheSCM Changes pane displays all that was changed in the working copy, compared to the working copy’s
revision. For example, editing a flow will cause that flow to appear in theSCM Changes pane. This pane also
shows a list of deleted projects (projects marked for deletion), if such projects exist.

Note: Projects that are outside of Studio workspace are not added/committed to SCM. They are shown
as unversioned (in brown) in theProjects pane, and are not shown in theSCM Changes pane.

Types of changes
You can see how different types of changes are shown:

l Deleted flow, named flow, and colored gray.
l Added folder, named deprecated, colored green
l Unversioned project, namedProject2, colored brown.
l One deleted project.
l The changed itemMathOp, in blue, also shows a lock indicator, whichmeans it was locked for editing by
the user.

Renamed and Moved Items

Renamed andmoved items have a special label with the location where the item was moved or renamed
from. In the following example, windowswas renamed linux, and the folder flowwas moved.
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SCM Changes toolbar

Update all: Updates the entire Studio workspace.

Commit all changes: Commits all the changes that show in theSCM Changes pane. Only
available when there are changes.

Revert all changes: Reverts all changes that show in theSCM Changes pane. Only available
when there are changes.

Unlock all: Unlocks any locked item.

Color codes
Studio shows the following color indications for items:

l Black: Normal item with no changes (not available in the changes pane)
l Green: Added
l Grey: Deleted (not available in the projects tree)
l Blue: Modified
l Brown: Unversioned
l Zig-zag underscore: Includes errors.

Note: By default, SVN has a list of file patterns (shown below) that are ignored when non-versioned files
are added to SCM:

*.o *.lo *.la *.al .libs *.so *.so.[0-9]* *.a *.pyc *.pyo

This means that a non-versioned project or folder that matches one of these patterns is shown as black
(as if it is versioned) in theSCM Changes pane.

However, you can still add the project or folder to SCM andwork with them as usual.
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SCM Message Pane
TheSCM Message pane displays themessage results from the SCM actions. Every action results in a
message and is color-coded. In addition, a pop-upmessage appears informing the user of the result of the
SCM action.Clear theSCM Message pane by right clicking anywhere inside the pane and then clicking the
Clear All button.

Examples of SCM Messages

In the following example, a new operation calledMathOpwas added:

After each addition, the new items are automatically marked to be added. The following SCMmessage
shows that a folder, oo-base-plugin, and the operation’s XML file, MathOp.xmlweremarked to be added.

After you commit an item, the followingmessage appears. This message shows that your previously added
items were now successfully committed to the server.

After making a change toMathOp, for example, adding a new input, revert the changes. This message
shows that a change to MathOp.xmlwas reverted.

Error messages

In certain cases, errors appear. These are displayed in red. In this example, an author attempted to commit
these changes, but the file was out-of-date.
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Reference Material
Revision History
HPE OOStudio also offers version history control. TheRevision History pane displays the SCM history. It
is divided into four columns and contains one line for each commit.

l Revision: The revision for the commit. The revision of the local copy is marked with an asterisk. After
checkout, the asterisk always marks the latest revision, but after changes have been committed by
another user, and before updating the asterisk marks a revision that is not the latest. The screen shot
above shows that the local copy is at revision 1953, but there was a commit to the file in revision 402.

l Date/Time: The date and time in which the revision was committed.
l Author: The author who committed the revision. This displays the user's name.
l Comment: The comment added during the commit by the user.
When you right-click on a history item, the context menu displays the following options:

l Update to revision: Updates the file to the selected revision. Using this option causes some items in the
project to be in a different revision than others. In the following example, right-click on the revision above
the asterisk (*).
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l Revert to this revision: Locally changes the object to the way it was in the selected revision. If for
example a flow contains two steps in revision 333, and three steps in revision 337 then reverting it to
revision 333 causes it to have two steps again. In order to make the changes visible to other authors, you
must commit the flow. In the following example, right-click on the revision below the asterisk (*).

l Show all affected files: Shows all the files that were changed in the selected revision.

Note:When running aRevert to this revision operation on a folder with changed items or on a changed
flow/operation/configuration item, the changes can be lost and there could be tree conflicts that are
resolved using the local version. In these cases, the followingmessage appears:

It is recommended to revert the changes first, and then to try to runRevert to this revision again.

Source Control Menu
Contains operations that affect the entire workspace:
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Option Description

Update All Updates the workspace directory, but does not import projects into Studio. Projects
that are already imported will reflect any updates that were received from the server.
Since this command updates the entire workspace, new projects committed by other
authors, may be retrieved during update. These projects can be imported into Studio
and worked on now.

Commit All Commits all changes from the active projects. When you click Commit, you can add
a comment for the commit.

Revert All Reverts all changes from the active projects.

Subversion
> Enforce
Locking Policy

This options prevents the flow author frommaking any changes to an item (flow or
configuration item) unless the item is locked. This ensures that only one author can
edit an item. See Enforce Locking Policy above for more information.

Subversion
> Unlock all

Unlocks any locked items in the workspace. A warningmessage appears. For
example:

Select Yes to unlock all the items or use the other options presented in themessage.

Subversion
> Cleanup

Clean up the working copy in Studio's workspace.

Connection Allows you to change the way authentication is performed with the source control
server, to select the SCM type and to check out/detach a repository.

Windows Authentication: Performs authentication using the currently logged in
user. This is applicable for file-based source control repositories.
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Option Description

Username andPasswordAuthentication: Performs authentication using the
supplied user name and password.

Trust server certificate: If you are working with a secure server (SSL/SSH), select
this option, otherwise you will be unable to access the server.

Projects pane
Shows the project you’re working in, and displays the editable flows, operations, and other HPE OO objects
that you can use in the project.

Context Menu from the Projects pane

The context menu shows all actions that are available for the selected object, according to its state.

Following are the options available when you right-click on a flow:

If the object was to be changed by an author, for example by adding a step, then it would have local changes.
In this case, Commit andRevert are available.

Option Description

Add Marks an item (flow, operation, configuration item or folder) to be added
to source control. In StudioAdd includes all ancestor and descendant
objects. So if a folder is added, any child flows and parent folders are also
added. Sibling items are not added. Items that are created from within
Studio, are added automatically and committed on the next commit.

Commit Commits local changes to the server. This option is available for changed
items and for folders that have changed children items. A commit works
recursively, so when you commit a folder, all of its child items are also
committed. After you commit, you can add a comment for the commit.
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Option Description

Update Updates the selected item. This option is unavailable only for items that
are locally added but not committed yet. Works recursively and updates
all child items.

Update to... Updates the selected item to a specific version. When this option is
selected, the Update Options window opens:

Enter the tag name (from the deployment page in Central) or the revision
number (from the Revision History window) and click OK.

Revert Reverts all local changes in the selected items. Changes in flows,
operations and configuration Items are reverted. Items that were deleted
are restored.

Important: When you add an item it is automatically marked as added,
but when you revert changes on it only the additionmark is removed, but
the item still exists in Studio and in the file system. You can re-add the
item usingAdd in themenu, or delete it.

History TheRevision Historywindow, displays the SCM history. See Revision
History for more information.

Deleting a Project
l Select the project that you want to delete, and click theDelete button. When you click Delete, the project
is deleted from Studio (un-imported). If theDelete project from file system (cannot be undone) option
is selected, the project is marked for deletion from the repository, and the deletion occurs on the next
commit.
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Working with Git Source Management System

Git is a Source Control Management (SCM) system that provides you with an alternative solution to source
control, in parallel with the Subversion – SVN solution. Git is a distributed version-control system, with
certain concepts that differ from Subversion.

Themethodology of working with Git in Studio is very similar to themethodology of SVN.

The initial version of Git support for 10.5x and later targets the basic use cases and provides ease-of-use,
similar to the Git support integrated to other IDE tools (such as IntelliJ IDEA or Eclipse).

Git Terminology
Add: Add a new file to a Git repository

TheAdd command allows you to add new files or directories to the local repository. The repository shows the
newly added file after you commit the changes.

Clone

Clone is used to download sources from theGit repository to the working copy. If you want to access files
from the source control server, clone is the first operation you should perform. When you clone a repository, a
working copy is created, allowing you to edit, delete, or add contents. To clone, you need the source control
server URL of the Git repository you want to clone.

Commit: Save changes to the repository

When youmake changes to your local working copy, they are not automatically saved in the source control
server. Tomake the changes permanent, youmust commit the changes. The changes are saved in the local
Git repository. You can then push them to the remote Git repository.

Delete: Removing a file from repository

TheDelete command deletes an item from the working copy (or repository). Files are deleted from the
repository after you commit the changes to the remote repository.

Downstream/Upstream

In terms of source control, you're downstream when you copy (clone, checkout, etc) from a repository.
Information flowed "downstream" to you.

When youmake changes, you usually want to send them back "upstream" so they make it into that
repository so that everyone pulling from the same source is working with all the same changes. This is mostly
a social issue of how everyone can coordinate their work rather than a technical requirement of source
control. You want to get your changes into themain project so you're not tracking divergent lines of
development.

Ignore

There are files that do not need to be version-controlled in Git. These files are handled by the Git Ignore
mechanism that operates behind the scenes, and is automatically executed when adding a project. By
default, the files to ignore are (relative to the project home): *.idx, *.tmp, *.lock, and Content/.metadata.

Merge
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TheMerge command incorporates changes from the commits (since the time their histories diverged from the
current branch) into the current branch.

Move

TheMove commandmoves a file from one directory to another or renames a file. The file is moved on your
local folder structure immediately, as well as on the repository after committing.

Pull

Pull refers to when you are fetching in changes andmerging them. For example, if someone has edited the
remote file you're both working on, you'll want to pull in those changes to your local copy so that it is up to
date.

Push

Pushing refers to sending your committed changes from the local repository to a remote repository. For
instance, if you change something locally, you'd want to then push those changes so that others may access
them.

Rebase

Rebase take all the changes that were committed on one branch and replays them on another branch.

Stash

Stash saves your working directory and index to a safe place and restores your working directory and index to
themost recent commit. After stashing, you can then work on other branches, make commits, etc. and when
you’re ready to get back to where you were, run a git stash apply (unstash) operation to restore your working
directory.

Working Copy

The SCM repository holds all versioned data on a source control server. The Source Control Management
tool in Studio manages local copies of the versioned data, known as the working copy. SCM accesses its
repository across networks. Multiple users can access the repository at the same time.

Update: Update the working copy

TheUpdate command transfers changes from the remote repository into your local working copy. It is
recommended that you update your local copy before you start working, so that all the latest changes
available in the remote repository are available in your local copy.

Note: Some of the terminology in this glossary is taken from the github site
https://help.github.com/articles/github-glossary/.

For more information onGit, go to one of these sites: https://help.github.com/ or http://git-scm.com/.

Installing and Configuring the Studio Git Client
In order to use the Studio Git integration feature, youmust install the Git client version git-1.9.5-
preview20150319.

1. Download the Git client from the following URL:
https://github.com/msysgit/msysgit/releases/download/Git-1.9.5-preview20150319/Git-1.9.5-
preview20150319.exe.

2. Save the Git client to <oo_installation_folder>/studio/Git, so that the bin folder is directly under <oo_
installation_folder>/studio/Git. In the Git installation wizard, use the default options.
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Alternatively, if you already have aGit client installation with version git-1.9.5-preview20150319 on your
local disk, point Studio to use that Git installation by performing the following steps:

1. Close Studio.
2. Go to the user home folderC:\Users\<user>\.oo (the Studio workspace location) and locate the

Studio.properties file.
3. Modify theStudio.properties file by adding the following property at the end of the file:

studio.git.installation.location=<git-1.9.5-preview20150319_installation_folder>

For example:

studio.git.installation.location=C:/Program Files (x86)/Git

The bin folder should be directly underC:/Program Files (x86)/Git. Note that / should be used as a path
separator.

4. Save theStudio.properties file and start Studio.

Note: If you opted for this second alternative, you need to consider the following:

If you are usingmultiple workspaces and you want the Git location property to be added in each new
workspace, you should edit the template properties file located in
Studio\conf\studio.properties.template. Otherwise, each time you switch to a new workspace, you
will have to set the Git location in the new workspace in the .oo\Studio.properties file.

If you have another version of the Git client installed, note that youmust use the git-1.9.5-preview20150319
version with Studio. This is the version that was validated with Studio. While other versions might still work
correctly, they are not officially supported.

Getting Started with Git in Studio
To begin working with Git, youmust connect to the remote Git repository and clone it. This way, you have a
copy of the repository that you can work on, and then commit changes to the local repository and push your
changes to the remote Git repository.

Have a look at the followingmovies to get a better understanding on how to work with Git in Studio.

Movie What you will learn

Connecting to Git
and cloning aGit
repository

In this movie, you will be introduced to some basic Git operations. You will learn how
to clone aGit repository, commit changes to the local repository and push them to the
remote repository.

Working with Git –
Basic Operations

In this movie, you can see how to use a different type of authentication (SSH) to
clone the Git repository, learn how to stash local changes, revert to an earlier
committed version and unstash.

Conflict Handling In this movie, you will see how to handle conflicts that may occur in Git when two
authors make changes to the same Studio workspace and try to commit and push to
Git.

Git branching
functionality

In this movie, you will learn how to work with different branches in Git.
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Movie What you will learn

Multi-authoring In this movie, you will learn about advancedmulti-authoring capabilities in Git.

Git Branch support
Branching is one of the strong points of Git, one that is a differentiator when compared to Subversion. One
most popular branchingmodel is explained on this blog: http://nvie.com/posts/a-successful-git-branching-
model/.

Branchmanagement is an important part of the Git workflow. Branches make it easier to track changes and
collaborate with other people. You canmanage branches in the Git repository directly from Studio. You can
seemore information onGit branching here:

https://www.atlassian.com/git/tutorials/comparing-workflows/feature-branch-workflow/

For details on creating a new branch, see "Create a new branch in the Git repository" below.

Understanding the Git Repository Log
TheGit Repository Log shows a graphic representation of the latest commits and updates that have been
made to the remote Git repository. This functionality is similar to the logs provided in other Git tools.

The repository log shows the following information:

l Important pointers (such as master, HEAD, origin/master, branches, tags etc.), that allow you to identify
the branch from which the commit was done type of commit and whether or not it was pushed to a remote
branch

l A commit graph showing the relationship between the different commits/updates (based on their ancestry)
and showing how merges between the commits/updates were done

l The commit message, as entered in the Commit window
l The author of the commit (name and email address)
l The date and time of the commit (in chronological order)
Each node in the graph represents a commit/update operation. Depending on the update strategy selected
(see "Git Update Strategies " below), the path will branch off into a new branch.

Note: Every workspace contains its own logs folder with its own log file.

Git Update Strategies
When updating files from the remote Git repository, you can choose the update strategy you want to use.
Depending on the update strategy selected, the path will branch off into a new branch.

l Update strategy: Branch Default The default update strategy (which is always either merge or rebase) is
configurable by the Git repository configuration using one of the following Git keys: pull.rebase and
branch.<name>.rebase. For more information, see http://git-scm.com/docs/git-config.

l Update strategy: MergeWhen using the update strategy merge, Git preserves the original hierarchy of
the local commits, and creates a special “merge” commit that merges the two diverged “branches” (the
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local branch and the remote branch) back together.
Example:Consider a simple example of a repository that has the following graph before updating.

In this case, the local repository and the remote repository have diverged. The local repository contains
commits that the remote repository does not include (the commit with themessageAdding flow2), and
the remote repository contains commits that the local repository does not include (the commit with the
messageAdding project2).
After merging the two commits, a special merge commitMerge branch ‘master’ of …. is created:

If conflicts occur during themerge operation, themerge commit is not created automatically. Themerging
stops, and youmust resolve the conflicts in order to complete themerge process.
In this state, all the remote changes are shown as local changes, visible in theSCM Changes pane. It is
your responsibility to resolve the conflicts, review all the changes, and conclude themerging by running a
Commit All Changes operation from the toolbar in the SCM Changes pane. See "Resolve conflicts
during an Update operation" on page 72 for details.
If there aremultiple conflicts frommultiple local commits, all the conflicts are resolved at once, at the
same time.

l Update strategy: RebaseRebasing is an alternativemethod of integrating changes that is sometimes
preferable over merge. Usingmergemakes the repository history grow horizontally (as information of all
the separate “branches” are kept) and it inserts new merge commits, making it grow vertically as well. This
makes it difficult to get an overall picture of the changes made to a repository.
Rebasing changes all the local commits to appear as if they were based on themost recent changes from
the remote repository, making the repository log graph appear as a straight line. Rebasing is an iterative
operation: first it rebases the oldest (least recent) local commit on top of the latest from the remote
repository, then it rebases the second commit on top of the previously rebased commit, and so on, until it
rebases all the local commits.
If there are conflicts during the rebase of a certain commit, rebasing stops and you can select to resolve
the conflicts and continue rebasing, or to skip the commit (discarding all its changes). In any event, you
can choose to abort the rebase operation and return to the initial state, with all previously rebased commits
disappearing.
An important implication of rebasing is that youmay need to resolve conflicts multiple times (when
rebasing different commits), possibly on the same items.
Example:
Both repositories (local and remote) are identical until the author commits Introducing Utility
Operations. Then, the author of the local repository adds the operations Base64 coders, UUID
Generator, Remote Command Execution andGroovy Scripts.
In themeantime, another author pushes his commits to the remote repository, addingSearch and
Replace, his own version of theRemote Command Execution andRemote File Transfer operations.
TheRemote Command Execution operation results in a conflict as it was added by both authors with
different content.
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After running anUpdate All operation with rebase selected as the Update strategy, the following events
occur:
l Studio displays the Conflicts dialog box with the followingmessage: “Merge of the current commit:
4d10a29 detected conflicts. Resolve them before continuing the rebase.” The item in conflict is a
flow namedRemote Command Execution.
Resolve manually is chosen for the item.

l The SCMMessages pane shows that two commits were successfully rebased (Adding UUID
Generator andAdding Base64 coders), rebasing stopped due to conflicts, and the current commit is
Adding Remote Command Execution.

At this stage, the repository log looks as follows:

The commits Adding Base64 coders andAdding UUID Generator appear twice: first, at their original
location based on Introducing Utility Operations, and second, at the top of the list based on the latest
commit from origin/master: Adding Remote File Transfer. Note that the current branch (“master”) is still
intact. if the author chooses to abort rebasing, the workspace will go back to themaster branch.
Let as assume that the user resolves the conflict and chooses to continue rebasing. At this point, then, the
SCMMessages explains that it further rebased two commits (Adding Remote Command Execution
andAdding Groovy Scripts), and rebasing completed successfully. The Repository log looks like this:

Notice that after rebasing, the graph the log is a straight line. After rebasing, the author can push the newly
rebased commits to the remote repository.

Note:When there are conflicting changes onmoved or renamed items (during Update), Studio
automatically detects these and tries to resolve them automatically.

For example, user1moves a flow andmakes some changes to it, and user2makes some non-
conflicting changes on the same flow. Studio automatically detects this situation, and tries tomerge
the changes to the flow.

See "Update files from the remote Git repository" on page 70 for details on how to perform aGit Update
operation.
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When is the Git Repository Log refreshed? 
Studio automatically updates the Git Repository Log when:

l Studio starts up (and is connected to Git)
l After checking out a Git repository
l After committing files to the remote Git repository
l After updating files from the remote Git repository
l After detaching from the remote Git repository

l After you click (amanual refresh in the Git Repository Log)

Conflict Handling in Git
In Git, a change that youmade is referred to as “ours”, while a changemade by a different user is referred to
as “theirs”.

When you try to update your local repository, a conflict may occur between a local copy of a file
(added/edited/deleted by "us") and the file in the remote Git repository (added/edited/deleted by "them") in the
following cases:

l A file was deleted by you (“us”) and was modified by another user (“them”).
l A file was deleted by another user (“them”) and was modified by you (“us”).
l An item was added by both you (“us”) and another user (“them”) with different contents.
l The same item was modified by both you (“us”) and another user (“them”), and it is not possible to
automatically merge the changes.

Different Types of Conflict

There are three situations in which an author may come across conflicts – all these can be encountered on an
Update operation, but one of them can also be seen on anUnstash operation. In each situation, he type of
conflict that occurred is shown in the Conflicts dialog.

l Merge: Conflicts during amerge operation. In anUpdate operation, amerge is alsomade if the update
strategy selected in the Update window was Merge). For details on how to resolve this type of conflict,
see "Resolving Conflicts: When to use Accept Our/Theirs and when to use Prefer Ours/Theirs" on the next
page

l Rebase: Conflicts during rebase. In anUpdate operation, a rebase is alsomade if the update strategy
selected in the Update window was Rebase.

Note: In this situation, themeaning of “ours” and “theirs” are opposite to theMerge case. So, for
example, if the author selects “Accept/prefer ours”, he is accepting/preferring the change that comes
from the remote branch, and if he selects “Accept/prefer theirs”, he is accepting/preferring the change
from the local branch.

l Unstash: Conflicts during unstash. These occur if before the Update operation, the author has
uncommitted changes that are in conflict with items that are located on the remote repository.
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These conflicts behave exactly like conflicts that occur during rebase (as described Rebase: Conflicts
during rebase. In an Update operation, a rebase is alsomade if the update strategy selected in the Update
window was Rebase. ). For details, see "Manually Unstash Changes" on page 75.

See "Resolve conflicts during an Update operation" on page 72 for details on how to resolve conflicts.

Resolving Conflicts: When to use Accept Our/Theirs and when to use Prefer Ours/Theirs

Studio provides twomethods of resolving conflicts: Accept andPrefer.

TheAccept Ours/Theirs resolution uses the entire file from us/them. There is nomerging of files, even if
there are changes in some of the files.

ThePrefer Ours/Theirs resolution automatically merges as many changes as possible into the selected file.
If merging is not possible, the system selects changes from the preferred side. All other changes that cannot
be automatically resolved, can bemanually merged later in Studio. See "Resolve conflicts during an Update
operation" on page 72 for an example of automatic andmanual resolution of conflicts.

For example, two users, user1 and user2, made changes on the same flow.

l user1 changed a certain step and added a flow-level input named input1.
l user2 changed the same step and added a flow-level output named output2.
In this case, if user1 has to resolve the conflict, s/he has the following options:

l Accept Ours - user1’s entire flow will be used: user1’s version of the step, with input1, but without
output2.

l Accept Theirs - user2’s entire flow will be used: user2’s version of the step, output2, but without input1.
l Resolve Manually Preferring Ours - the flow will contain user1’s version of the step, and both input1
and output2.

l Resolve Manually Preferring Theirs - the flow will contain user2’s version of the step, and both input1
and output2.

Note: If there are conflicting changes onmoved and renamed items during anUpdate operation, Studio
detects these and tries to resolve them automatically as shown in the following example:

1. User1moves a flow andmakes some changes to it.
2. User2makes some non-conflicting changes on the same flow.
Studio automatically detects these changes andmerges them automatically. There is no conflict and
both users can see their changes to the flow.

Authentication Options
When connecting to a Git repository, you can choose to connect to the Git server using one of two
authentication schemes: Credentials or SSH Private Key.

l Git Repository Credentials: Password authentication
l Private key file: To use this scheme, you need to fill in the Private Key File and Private Key Passphrase.
You can generate a public key-private key pair by running the following command from the git command
line:

$ ssh-keygen -t <algorithm_type> -C "your_email@example.com"

where algorithm_typemay be rsa1 for protocol version 1 and rsa or dsa for protocol version 2.
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Note: The private key must be in OpenSSH format. For public keys, the RSA and DSA algorithms are
supported. A public key must have an extension of .pub only.

In addition, you can configure known host parameters in the studio.properties file:

git.ssh.known.hosts.policy=allow|strict|add

The policy for known hosts. If set to add, a connection to a host that is not in the known_hosts file will be
allowed and the host and connection will be added to the file. If set to allow, Studio allows SSH
connections to any host. If set to strict, only allow connections to hosts specified inside the known_
hosts file are allowed.

git.ssh.known.hosts.file

The location of the known_hosts file. By default, the value is ${user.home}/.ssh/known_hosts.

You can select the authentication type in the SCM Connection dialog. For details, see "Connect to and Clone
aGit repository" below.

Connecting to a Git repository using a proxy

All Git operations that are available in Studio and interact with the Git server can be done using
http/https connection URLs through a proxy. The proxy can be without authentication or using basic
authentication scheme.

See "Set the Proxy for Debugging on a Remote Central " on page 283 for details.

What do you want to do?
Note: SCM operations cannot be performed on items that have duplicate UUIDs.

To resolve this:

1. View the problematic items in theProblems pane.
2. Delete the duplicated item.
3. Leave the original item as is.
If you want to keep both items, use theCopy/Paste orDuplicate commands to save a copy of one of
the items with a different UUID, and then delete the item that you copied from.

Connect to and Clone a Git repository
In order to work with the Git source control system, youmust first connect to the Git repository and clone it to
your local file system. When you clone a repository, Studio performs the following steps:

l Copies the repository into your Studio workspace
l Creates remote-tracking branches for each branch in the cloned repository
l Creates and checks out an initial branch that is forked from the cloned repository’s currently active branch.
You can then work locally, commit your changes and then push the changes to the Git remote branch.

Note:
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l Upon cloning, the default branch is always checked out.
l If the Git server verification fails, an error message opens. You can choose to continue or abort the
operation.

1. Select SCM > Connection....
TheSCM Connection dialog box opens.

2. In the Type area, select the SCM type: Git.
3. In theSCM Repository area, in theURL field, type or paste the URL of the Git repository.

Note: The URL may include an http, https, file or ssh protocol.

When using https, If the server certificate is not trusted, amessage appears asking whether you
want to trust this certificate. You can also import the certificate automatically as described in
""Import Certificates Automatically with a Remote Debugger Connection " on page 283.

4. Authentication: There are two types of authentication available:Credentials or SSH Private Key.
l Credentials: In the Type dropdown, select Credentials to useWindows credentials, and enter the
user name and password in the User Name and Password fields.

l SSH Private Key: In the Type dropdown, select SSH Private Key to use SSH private key
authentication, and enter/select the private key file and passphrase in thePrivate Key File and
Private Key Passphrase fields.

Note: Click on the icon to select a private key file from a location on the disk.

5. User Information: Enter the user name and email address in the Full Name andEmail Address fields.
Both these fields must be filled in as this information is attached to every Git commit operation.If you do
not fill in these fields, Git will use the computer name as the full name, and the <computer
name>@<full computer name> as the email address.

6. Click Clone.
A message in the following format appears in the SCM messages pane:
<date> <time> - Clone https://<full_path>/gitTestRepo.git

Cloning from https://<full_path>/gitTestRepo.git
to C:\Users\<username>\.oo\Workspace was done successfully.

Note:

l In order for theClone command to run correctly with a destination directory that is not empty, Studio
creates a blank directory (underC:\...\.oo\Workspace\.git) and copies the entire Git repository into the
new directory.

l The first time you try to connect to Git, if you have filled in theWindows credentials, Git will use these
to configure and populate the Git library.

Note: There is no Lock functionality in Git. This is because there is no need to lock files in Git, as there is
the Git Conflict management. Therefore, the Lock button in the editor for items (flows, operations,
configuration items) is always disabled – the same behavior as when you are not connected to any SCM
repository.
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Add files to the local Git repository
1. From the projects tree, select the project whose files you want to add to the repository.
2. Right-click and select SCM > Add.
3. A message appears in theSCM messages pane. For example:

Add C:\Users\<username>\.oo\Workspace\Project\Content\Configuration\Scriptlets

Note: You cannot add projects that are located outside the current workspace. 

Move/cross-move a versioned item
You canmove an item from one location to another within the same project or cross-move an item between
two different projects.

Tomove an item:

1. In theProject pane, select the items that you want to move. You can select multiple items using the
Shift orCtrl key.

2. Drag and drop the items into another folder or another project.
or:
Cut the items usingCtrl+X and paste them at the new location usingCtrl+V.
The item is marked in theSCM Changes pane in the old location with the status deleted and in the new
location with a statusmoved.You can see the original location in parentheses. For example:

Note:

l Where relevant you can commit the result of themove/cross-move action to Git.

Update files from the remote Git repository
TheSCM Update operation performs three Git operations, Stash, Pull and Unstash.
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Stashing takes the current state of your local working workspace— that is, your modified tracked files and
staged changes — and saves it on a stack of unfinished changes that you can reapply at any time.

If changes exists in your local workspace, and you have committed them, Studio tries tomerge them
automatically with the files in the remote Git repository. If there are conflicts, the Conflicts dialog opens and
you can resolve the conflicts as described in "Resolve conflicts during an Update operation" on the next
page.

Note: You can also perform manual Stash/Unstash operations only using theStash andUnstash
options from the SCM > Git menu. For details, see "Manually Stash Local Changes" on page 74 and
"Manually Unstash Changes" on page 75.

1. Right-click and select SCM > Update.
2. The following window opens:

3. Select the Git Update strategy you want to use:
l Merge:When using the update strategy Merge, Git preserves the original hierarchy of the local
commits, and creates a special “merge” commit that merges the two diverged “branches” (the local
branch and the remote branch) back together.

l Rebase: The Rebase strategy changes all the local commits to look like they weremade based on
themost recent changes from the remote repository. This shows in the repository log as a straight
line, preventing the horizontal growth that is present when usingMerge.

Note:

o You can change the default Update strategy using the pull.rebase and
branch.<name>.rebase keys. For more information, see http://git-scm.com/docs/git-config.

o When performing a Rebase operation, theremay be several conflicts for the same file.

4. Select theStash changes check box to automatically stash local changes before updating.
5. Select the Include untracked check box to include the untracked items (the unversioned items marked

in brown) in the stash.

Note: If you try to update from the remote Git repository and it is currently empty, Studio displays the
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following error message:

Cannot update the current branch as it does not exist in the remote
repository.

Resolve conflicts during an Update operation
Conflicts during an Update operationmay appear in one of the following situations:

l On merge: If the author selects theMerge strategy on update and there are conflicting differences
between the commits on the local branch and the commits coming from the remote branch.

l On rebase: If the author selects the Rebase strategy on update and there are conflicting differences
between the commits on the local branch and the committed items coming from the remote branch.

l On stash: If the author has local changes that were not committed but have been stashed, and there are
conflicting differences between the these items and the committed items that come from remote branch.
See "Manually Stash Local Changes" on page 74 for details.

You can see any conflicts that arise in the Conflicts dialog box. For example:

Note: Theremay be several conflicts in the same item. Youmust resolve all the conflicts in order to
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mark the item as resolved.

For each conflict, you can choose to resolve the conflict now or later.

Resolve Now

l From the right pane, select Accept Ours to apply the changes made by "us" (the ones that are committed
on our local repository).
or:
Select Accept Theirs to apply the changes made by "them" (the ones received by pulling from the remote
repository).

Resolve Later (Manually)

If you choose to resolve a conflict at a later stage, Studio prepares the item for manual conflict resolution. All
non-conflicting changes are automatically merged into the item, and conflicting changes are replaced based
on your selected preference (ours or theirs).

The original file is marked as Conflicting until marked as resolved or deleted (from within theProjects pane).

If the conflict type is not "deleted by us" or "deleted by them", Studio automatically creates two new items
named <filename> - ours and <filename> - theirs shown in red:

l <filename> - ours: The original version of the item (from the local repository)
l <filename> - theirs: The original version of the item (from the remote Git repository)
For example:

These files are read-only and cannot bemodified or deleted/cut. After the conflict is resolved, Studio
automatically deletes the "ours" and "theirs" files.

Note:

l When there are unresolvedmerge conflicts, theremay be some operations that you will not be able to
perform on the conflicting items, for example, committing them to the Git repository. In addition, you
cannot move or rename conflicting items or the folders containing them.

l Conflicting files are shown in the Problems pane.
l The new file, created by merging conflicts, automatically or manually, may be in an invalid state.

Tomanually resolve the conflict:

1. From the right pane, select Prefer Ours to apply the changes made by "us" (the ones that are committed
on our local repository).
or:
Select Prefer Theirs to apply the changes made by "them" (the ones received by pulling from the remote
repository).
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2. Select Resolve Manually.
3. Right-click on a conflicting item from the project tree, and select SCM > Mark Conflict as Resolved,

SCM > Resolve Conflict Accepting Ours orSCM > Resolve Conflict Accepting Theirs.
4. Commit and push all the changes to the remote repository.

Manually Stash Local Changes
Stash enables you to create a "patch" of your local changes saved inside your local workspace, that can be
accessed later, at any time.

When you creates a stash, all the changes in the workspace are "stashed", and the local changes are
reverted, i.e., removed from the workspace.

Note: If you try to stash changes while connected to an uninitialized, empty repository, Studio displays
the following error message: "Before stashing, youmust initialize your repository by a first commit".

Note: TheStash operations always include all changes made in the workspace.

You can also choose whether or not to include the untracked files.

Note: If you have unimported projects in your workspace, when you perform aStash operation, these
projects are included. After stashing, these files are stored inmemory and not in the workspace.

However, the empty folders still remain. At any point, you can unstash your changes and the stashed
files will return to their original location.

To stash local changes:

1. From the SCMmenu, select Git > Stash.
or:

Click in the SCM Change Pane toolbar.
The Stash dialog box opens:

2. In theMessage field, type amessage to identify the Stash operation. For example, Changes to the
Integration Operations.

3. Select the Include untracked check box to include the untracked files in the stash.
4. Click Create Stash.

When the Stash operation has completed, you can see the operations that have been performed in the
SCM Messages pane. For example:
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04/14/15 15:13:30 - Stash
Stashing changes in the workspace including the untracked files.
Removed project(s): oo-virtualization-project
Stashed paths:
added: oo-virtualization-project/.gitignore
added: oo-virtualization-project/Content/Library.properties
added: oo-virtualization-project/Content/Library/Accelerator Packs.properties
added: oo-virtualization-project/Content/Library/Accelerator
Packs/Virtualization.properties
added: oo-virtualization-project/Content/Library/Accelerator
Packs/Virtualization/Get All Snapshots.xml
added: oo-virtualization-project/contentpack.properties
added: oo-virtualization-project/pom.xml

Manually Unstash Changes
The Unstash operation enables you to apply previously stashed changes. This operation is equivalent to a git
stash apply operation. The Unstash dialog box shows a list of stashes along with the details of the currently
selected stash.

Note: Take care when running an Unstash operation as it may result in conflicts.

Conflicts can occur during an Unstash operation if the author has uncommitted changes that are in
conflict with items that are located on the remote repository.

To unstash changes:

1. Select the stash commit you want to unstash.
2. From the SCMmenu, select Git > Unstash.

The Unstash dialog box opens:
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3. Select Drop to delete the currently selected stash.
4. Select Clear to delete all the stashes.
5. Select Apply Stash to implement the currently selected stash(es). If Drop after apply is selected, the

Apply Stash operation will also delete the currently selected stash.

Note: If the author has uncommitted changes that are in conflict with items that are located on the
remote repository, a conflict may occur here.

Commit and push files to the Git repository
After making changes in Studio, youmust commit the files to the local Git repository in order to record the
changes, and then push them to the remote Git repository on the Git server.

You can choose to commit changes, and then push them later, or to commit and push them in the same step.

Best practice: In order to ensure that you have the latest files, before committing it is highly
recommended to update the files (pull) from the remote Git repository using the command
SCM > Update.

1. From the projects tree, select the folder whose files you want to commit to the local repository.
2. Right-click and select SCM > Commit.

The Commit dialog box opens:
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3. Click Commit to commit the changes to the local repository.
or:
Click Commit and Push... to commit the changes to the local Git repository then push (copy) them to
the remote Git repository.

Note: Before pushing, your entire SCM workspacemust be up-to-date. The push operation pushes
all committed files in the workspace to the remote Git repository. If there are uncommitted changes,
they are not pushed to the remote repository.

You can also push changes to the remote repository using theSCM > Git > Push.. option from the
mainmenu. See "Push files to the Git repository" below for details.

Note: If there are items with duplicate UUIDs in your commit list, they are shown in underlined text
and Studio warns you with the followingmessage:

There is at least one other item with the same UUID as one of the items
included in the commit. Do you want to continue?

Click Yes to ignore the duplicate UUIDs and proceed with the commit, orNo to cancel the commit
operation.

The followingmessage appears in the SCM messages pane:

Pushed 1 commit(s) to origin/master

Note: Git does not store empty folders in the repository. However, in Studio, you can have empty folders
inside projects, as Studio automatically creates them as required..

Push files to the Git repository
After making changes in Studio, youmust commit the files to the local Git repository in order to record the
changes, and then push them to the remote Git repository on the Git server.

You can choose to commit changes, and then push them later, or to commit and push them in the same step.
This procedure describes how to push changes to the remote Git repository.

Note:When you push your changes to the remote server, all your commits are pushed.
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Best practice: In order to ensure that you have the latest files, before committing it is highly
recommended to update the files (pull) from the remote Git repository using the command
SCM > Update.

1. From themainmenu, select SCM > Git > Push....
or:

From theSCM Changes pane, click .
The Push Commits dialog box opens showing the list of commits to be pushed (along with the Commit
ID) and an aggregated list of affected files for each commit:

If the branch is not pushed on the remote repository, the Push window looks as follows:

2. From the List of commits to push, select a commit to see the list of affected files in theAffected Files
section.

Note:

l Before pushing, your entire SCM workspacemust be up-to-date. This means that theremust not
be any files in the workspace that have not yet been committed or updated.
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l If the remote Git repository is empty and you try to push to it without a local commit, Studio
displays the following error message:
Before pushing, you must initialize your repository by a first
commit.

The list of affected files is shown in theAffected Files section.
3. Click Push All to push all the commit operations to the remote repository.

A confirmationmessage appears in the SCM Messages pane. For example:

04/14/15 13:19:19 - Push
Push successful
Pushed 3 commit(s) to origin/master

Abort Merging or Rebasing
Theremay be cases in which you do not want to accept changes from the branch you aremerging/rebasing
with. Aborting is common in the case of rebase.

When rebasing, you go through each commit from the branch you are rebasing and add it sequentially to the
branch you are rebasing in. If you find a problem after several such commits, you can abort the rebase and
then restart it.

In the case of merging, youmay have a conflict in your workspace that you did not manage to resolve as you
intended. In this case you can choose to abort the operation.

1. From the SCM menu, select Git > Abort Rebasing or Merging.
or:

From the SCM Changes toolbar, select
A confirmationmessage appears in SCM Messages pane.

View a history of Git operations in the repository
TheHistory option shows you:

l A list of commits in which the selected project/item was affected
l All affected files for a particular commit
TheHistory option also allows you to revert to a specific revision of the project/item. See "Revert to a
previous revision of a repository" on the next page for details.

1. Right-click on a file/folder and select SCM >  History.
The Revision History dialog box opens:
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Revert to a previous revision of a repository
Theremay be cases for which you need to recreate a faulty Central content pack in order to troubleshoot a
specific flow inside the content pack. If the content pack is not available (it has been lost or been overwritten
by a new version), you can restore a specific version of the content pack using theHistory option.

Note: In Git, you can perform aRevert operation only on repositories.

To revert to a previous revision:

1. Right-click on a file/folder and select SCM > History.
The Revision History dialog box opens:
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2. Select the commit revision you want to revert to.
3. Click Revert to Selected.

Revert to a older version of a file/folder from the Git repository
Reverting removes the changes that the author made to the items (and in the case of folders, to all items they
contain recursively), and returns the original state of the reverted items to the state they were in, the last time
they were updated.

1. From the projects tree, select the requested folder/file(s).
2. Right-click and select SCM > Revert

or:

From the SCM Changes toolbar, select Revert All Changes .
The followingmessage appears:

3. Select the check box if you want to delete all unversioned items and local copies of added items.
4. Select Yes to revert to the previous version.

Reset to a tagged commit of a project/item
Theremay be cases for which you need to recreate a faulty Central content pack/project in order to
troubleshoot a specific flow inside the content pack. If the content pack is not available (it has been lost or
been overwritten by a new version), you can restore a specific version of the project/item using theReset to
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tag... operation.

You can use theReset to tag... option if you have already checked out the repository and you want to update
your workspace to a specific revision from the SCM tag.

Important! The entire workspace reverts to the state it was in at the time it was tagged.

1. From the SCM menu, select Git > Reset to tag....
2. Type in the SCM tag that you received from the Central administrator. By default, the SCM tag is

[Project Name]-[Project version].

Note:

l For Git, the SCM tagmust not include blank spaces.

l If you try to reset to a tag that is not on the current branch, an error message appears.

View the SCM repository log
To view the SCM repository log:

1. Select theSCM Repository Log tab at the bottom of the screen.
The repository log opens. For example:

2. If the local and the remote repositories have different versions that have beenmerged, the split and
merge are shown as two different paths in the repository log (as shown in the example above).

Add unversioned files to a Git repository
You can add unversioned files to the local Git repository at any stage. The files can be an entire project, a
specific folder (either under “Library” or a configuration item folder), a flow, an operation or a configuration
item.

Note:

l You cannot add files from projects located outside the current workspace.
l When adding a file from an unversioned project, the entire project is added to the repository.

Added files appear in green in theProjects pane and theSCM Changes pane.
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1. Right-click and select SCM > Add.
2. A confirmationmessage appears in SCM Messages pane.

Rename versioned files
When renaming versioned files, the files are also scheduled for renaming in the Git repository.

Renamed items appear in blue in theSCM Changes pane.

Note: If the file is versioned but it has the status Added, the color of the file will be green even after a
Rename action, both in the Projects Pane and in theSCM Changes pane.

If a Git error occurs during the operation, you can see it in theSCM Messages pane.

1. Right-click and select Rename.
2. Type a new name for the file and press Enter.

A confirmationmessage appears in SCM Messages pane.

Delete versioned files
When deleting versioned files, the files are also scheduled for deletion in the Git repository.

Deleted items appear in gray in theSCM Changes pane. After you delete a file, you can still commit it to the
repository from theSCM Changes pane. This is useful when working in multi-author environments.

If a Git error occurs during the operation, you can see it in the SCM Messages pane.

1. Right-click on the file(s) and select Delete.
The file is deleted from the local repository and a confirmationmessage appears inSCM Messages
pane.

2. You can now commit the deleted file(s) from theSCM Changes pane to remove it from the remote Git
repository.

Detach from the Git repository
After you have finished working in the Git repository, it is a best practice to detach from the remote Git
repository.

Note: Before detaching, make sure that you have committed and pushed all your local changes to the
remote Git repository.

If a Git error occurs during the operation, you can see it in theSCM Messages pane.

1. Select SCM > Settings
2. In theSCM Repository area, click Detach.

An informationmessage appears recommending that you to commit and push all your changes before
detaching.

3. Click OK.
Your local repository is detached from the remote Git repository.

Create a new branch in the Git repository
Creating a new (local) branch enables you to have a branch that initially points to the same commit as the
current HEAD pointer. This means that the new branch will have the projects that Studio included when
creating the branch. The newly created branch is immediately checked out and Studio connects
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automatically to the new branch). Any further commits aremade to the current branch and you can choose
later to push the branch to the remote repository.

Note:When connected to an uninitialized repository, the local branch will be created only after an initial
commit.

If a Git error occurs during the operation, you can see it in the SCM Messages pane.

1. From theSCM menu, select Git > Create a new branch...
The Create New Branch dialog opens.

2. Type the name of the new branch in the field and click OK.

Note: A Git repository namemust not include spaces andmust follow standard Git naming
conventions.

The new branch is created in the local Git repository and amessage is shown in the SCM Messages
pane.

3. Tomake the branch available to other authors working with the same remote repository, you can push
the current branch to the remote repository using thePush command.

Check out a branch in the Git repository
Checking out a branch allows you to connect to an existing branch. Connecting to an existing branchmeans
that your workspace (along with the projects in it) will be changed to reflect the state of the newly checked out
branch.

Note:

l Any project that exists in the newly checked out branch but does not exist in the current branch will be
removed. The project data is not lost, however, as you can still check out that branch at a later stage).

l Any project that exists in both branches will be changed and refreshed to reflect its state in the newly
checked out branch.

l Any project that exists only in the newly checked out branch will be copied to the disk, but Studio will
not automatically import it.

l Checking out from a branch that has local changes is not recommended.
If the same files that aremodified locally are different in the branch to be checked out, the checkout
will fail, keeping the current branch and the local changes.
In addition, local changes are lost when the branch is checked out.

1. From theSCM menu, select Git > Check out the existing branch.....
The Checkout Branch dialog opens:
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2. From theBranch to check out list, select the local branch you want to work on.
3. Click Checkout.

The branch is checked out and ready for you to work on. You can see it the list of branches with a prefix
of the remote repository's name. For example, <master>-newbranch.

Note:

l If a branch has not yet been pushed to the remote repository, it is listed with its name only under
the Local Branches heading.

l If you check out a remote branch that was never checked out locally (such as in the example
below), Studio creates a local branch with the same name and configures its upstream to the
remote branch.

The slash signmeans the branch is on the remote repository. For example origin/ refers to a
branch named origin on the remote repository.
The right arrow means that your local repository has previously been pushed to the remote
repository and has a remote version. For examplemaster →origin/master refers to a local
branchmaster that has previously been pushed to the branch named origin on the remote
repository.
Theremay bemore remote branches that are not visible as the information has not yet been
updated from the remote repository. In order to update this information, you need to perform a
Fetch operation.

After check out, the followingmessage is displayed in theSCM Messages pane:
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07/07/15 14:29:28 - Branching
Successfully checked out branch feature1 with upstream
origin/feature1.

View unimported items in the current workspace
In theSCM Changes pane, you can see items (files, folders or projects) in the current workspace that have
been changed and have not been imported into Studio. TheSCM Changes pane displays changes between
the local copy of the repository (the workspace) and the SCM repository. If a file is not changed, it is not
displayed.

This information is important when you have conflicts, or whenmerging/rebasing and you need to understand
all the changes that weremade.

Unimported items may have one of the following states:

l unversioned: The item is new in the workspace, and has not yet been pushed to the Git repository.
l modified: The item is already in the Git repository and has been changed.
1. Select theSCM Changes tab.
2. In the Item tree, select theUnimported changes node.

A list of modified and unversioned files opens. For example:

From any item in the Unimported items changes node, you can perform the following operations:

l Show in Explorer:Right-click on an item and select Show in Explorer. Windows Explorer is
opened at the item's directory, with the item highlighted.

l Import Project (from a project node only): Right-click on a project node and select Import Project.
Studio imports the selected project, and you can see it in the workspace tree.

All other modified items that are not under the Studio Project structure can not be handled by Studio. You
will need an external tool to handle them.

Reference Material: SCM Changes Pane
TheSCM Changes pane displays all that was changed in the working copy, compared to the working copy’s
revision. For example, editing a flow will cause that flow to appear in theSCM Changes pane. This pane also
shows a list of deleted projects (projects marked for deletion), if such projects exist.

Note: Projects that are outside of Studio workspace are not be added/committed to SCM. They are
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shown as unversioned (in brown) in theProjectsPane, and are not shown in theSCM Changes pane.

Types of changes
You can see the different types of changes in theStatus column.

The types of changes are also reflected in the color coding. This may be:

Status Color

added green

renamed blue

modified blue

conflicted red

moved (from/to) blue

deleted grey

unversioned brown

In addition, you can see a text message in parentheses after the item name that describes the status of the
item. For example,moved from <old location>, moved to <new location>, renamed from <old name>.
You can also perform all standard SCM actions from these entries.

If there are items with duplicate UUIDs, they are shown in the SCM Changes pane in underlined text.

In the above example, you can see:
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l A deleted project, named test1, and colored gray.
l An added flow, namedAdded, colored green.
l An unversioned folder, namedUnversioned, colored brown.
l A list of unimported items that have been changed.
l Several changed items, shown in blue:

l A modified flow, adding flow 2.

l A renamed folder, new folder a.

l A moved flow, flow 1234567.

l A folder whose description has been changed, Utils.

Note: Renamed andmoved items have a special label, shown in parentheses, with the location where
the item was moved or renamed from.

State

TheState area shows the state and the name of the current Git branch.

By default, the current Git branch is "master".

The state can be one of the following:

l Ready: the default state
l Merging:when you are in themiddle of amerge operation and there are still unresolved conflicts
l Merging - all conflicts resolved:when you are in themiddle of amerge operation and all conflicts have
been resolved

l Interactive rebase:when you are in themiddle of a rebase operation and there were conflicts

SCM Changes toolbar

GUI item Description

Update all:Updates the entire Studio workspace.

Commit all changes:Commits all the changes in theSCM Changes pane. Only
available when there are changes.

Push changes:Pushes all the changes in theSCM Changes pane to themain Git
repository.

Stash: Takes the current state of your local working directory — that is, your
modified tracked files and staged changes — and saves it on a stack of unfinished
changes that you can reapply at any time.

Unstash: Takes the stack of unfinished changes from the stash and reapplies them
on the local working directory.
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Revert all changes:Reverts all changes that show in theSCM Changes pane.

Branching: Presents the Git branching operations. Click the icon to see the
additional options, Create, Checkout,Merge andRebase.

Create:Creates a new Git branch.

Checkout:Connects to an existing branch. After checking out, your workspace
(along with the projects in it) will be changed to reflect the state of the newly
checked out branch.

Merge:Git preserves the original hierarchy of the local commits, and creates a
special “merge” commit that merges the two diverged “branches” (the local branch
and the remote branch) back together.

Continue rebasing:Rewrites the project history by creating new commits for each
commit in the original branch.

Skip commit in rebasing:Rewrites the project history without creating new
commits.

Abort:Aborts themerging (for amerge operation) or stops the project history
rewriting (for a rebase operation).

RefreshRefreshes all the projects/items in theSCM changes pane.

State: Shows the name of the current repository (e.g., master) and the rebasing stage.

When connected to an empty repository, the text (<empty>) appears. For example:

During rebasing, the text Interactive rebase appears. For example:

Whenmerging, the textMerging appears. For example:

Whenmerging after all conflicts have been resolved, the textMerging - all
conflicts resolved appears. For example:

Note: To complete themerge process, youmust perform a final commit to get
the files into a state ready for committing and pushing to themain Git

Studio Authoring Guide
Working with Source Control in OO Studio

HPE Operations Orchestration (10.60) Page 89 of 350



repository.

SCM Message Pane
TheSCM Message pane displays themessage results from theGit actions. Every action results in a
message and is color-coded. In addition, a pop-upmessage appears informing the user of the result of the Git
action. Clear theSCM Message pane by right clicking anywhere inside the pane and then clicking theClear
All button.

The type of messages that are shown depends onmany factors, such as the update strategy, stashing,
possible conflicts, or whether errors occurred when executing certain commands.

Examples of Git Messages

In the following example, the current workspace is updated. This process includes stashing, updating and
adding files.

Error messages

In certain cases, errors appear. These are displayed in red. In this example,

05/07/15 10:55:16 - Push
http://admin@address.labs.company.com:8180/r/test01.git: cannot open git-receive-pack
There were 1 error(s).

Projects pane
Shows the project you’re working in, and displays the editable flows, operations, and other HPE OO objects
that you can use in the project.

Context Menu from the Projects pane

The context menu shows all actions that are available for the selected object, according to its state.

Following are the options available when you right-click on a committed flow. In this case only Add and
History are available:
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If the object was to be changed by an author, for example by adding a step, then it would have local changes.
In this case, Commit andRevert are available.

Option Description

Add Marks an item (flow, operation, configuration item or
folder) to be added to source control. In Studio, Add
includes all ancestor and descendant objects. So if a
folder is added, any child flows and parent folders are also
added. Sibling items are not added. Items that are created
from within Studio, are added automatically and
committed on the next commit.

Commit Commits local changes to the server. This option is
available for changed items and for folders that have
changed children items. A commit works recursively, so
when you commit a folder, all of its child items are also
committed. After you commit, you can add a comment for
the commit.

Revert Reverts all local changes in the selected items. Changes
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Option Description

in flows, operations and configuration Items are reverted.
Items that were deleted are restored.

Important: When you add an item it is automatically
marked as added, but when you revert changes on it only
the additionmark is removed, but the item still exists in
Studio and in the file system. You can re-add the item
usingAdd in themenu, or delete it.

History TheRevision Historywindow, displays the SCM history.
See "View a history of Git operations in the repository" on
page 79.

History dialog box
The History dialog box is used to revert to a previous revision of a project/item.

Option Description

Commit history for
item

Name of the project/item.

Commit ID of the Commit operation.

Author User name/id of the user who committed the changes.

Date Date on which the Commit operation was done.
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Option Description

Message Commit message written when the Commit operation was done.

Changes under the
selected item:

Changes made and list of items changed for this commit.

Page If the revision history is longer than one page, you can change the number of
pages, and number of lines that are displayed on each page.

Lines to display Enter the number of lines to be displayed on each page.

Revert to selected Click Revert to selected to load the select commit of the project/item.

Conflicts dialog box
Merge Example

Stash Example
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Rebase Example
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Option Description

Conflicting
Items

A list of the items in the project that caused the conflict and their paths. For each item, a
reason for the conflict is shown.

Select All Selects all the conflicting items from the list.

Resolve
Now:

The conflicts are resolved immediately.

Accept
Ours

Applies the changes made by "us" immediately.

Accept
Theirs

Applies the changes made by "them" immediately.

Resolve
Later:

The conflicts are resolved at a later stage.

Resolve
Manually:

The original file is marked as Conflicting until marked as resolved or deleted (from within
the Projects pane).

Prefer
Ours

Changes made by us will be applied for the conflicts in the original file.

Prefer Changes made by them will be applied for the conflicts in the original file.
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Option Description

Theirs

Help Shows theHelp pane that provides additional details on the selected item.

Action
History

Shows a log of all the executed operations. For example, the items that were resolved, how
they were resolved, the items that will be resolvedmanually.

You can scroll through the log using the scroll bar.

Resolve Later

If you choose to resolve a conflict at a later stage, Studio prepares the file for manual conflict resolution. All
non-conflicting changes are automatically merged into the file, and conflicting changes are replaced based on
your selected preference (ours or theirs).

The original file is marked as Conflicting until marked as resolved or deleted (from within the Projects pane).

In addition, Studio automatically creates two new files named <filename> - ours and <filename> -
theirs representing the original versions from us and from them, respectively.

After the conflict is resolved, Studio automatically deletes the "ours" and "theirs" files.

Resolve Manually

Tomanually resolve the conflict:

1. From the right pane, select Prefer Ours to apply the changes made by "us".
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Working with Content Packs
A content pack is a jar file containing operations, flows, actions, configuration items, and resource bundles. A
content pack is themost granular entity that can be delivered for deployment.

You can download a content pack for your specific domain from HPLN, and then import it into your project.

Importing Content Packs to a Project
This section describes how to import content packs to Studio.

A content pack is a collection of operations, flows, actions (Java-based or .Net based), configuration items
(such as selection lists, domain terms, and so on) and resource bundles.

Note:When you install Studio, you can select to import existing content packs in the InstallationWizard
. These will load the first time you open Studio.

You need to import the Base content pack first, and then import the specific content packs that you need to
create your custom flows, for your specific domain. You can download these content packs from HPLN.

Once you have imported a content pack, the files are available in theDependencies pane as read only.

Note: You can import a content pack from any network drive.

You cannot import a content pack directly from a remote hosting site. To access remote content packs,
first download a copy of the files to your local system, or map to a network drive so that the File Chooser
dialog box can navigate to the location.

You can reuse a flow from a different project, by importing a content pack that was created from that flow. For
information about packaging a flow into a content pack for reuse, see "Exporting a Content Pack" on page
287.

You can download content packs frommultiple sources:

l My content – Projects and content packs that are already in Studio.
l My organization – Content packs that were developed by various authors in the organization, and which
reside in the artifact repository.

l HPEcontent - Content that HPE releases regularly, which resides on HPLN.
l Community content - Content that was contributed to the community by other organizations, which also
resides on HPLN.

What do you want to do?
Download the content packs
1. Open the HPLN site and navigate to the Operations Orchestration Community page

Studio Authoring Guide
Working with Content Packs

HPE Operations Orchestration (10.60) Page 97 of 350



https://hpln.hp.com/group/operations-orchestration, and then navigate to the list of content packs.
2. Download the Base content pack to a location on your network drive.
3. Download any other content packs that you need for your specific domain to a location on your network

drive.

Import the Base content pack when opening Studio for the first time
1. In theDependencies pane, click the Import button .

Note: You can import a content pack from either the Tree VieworMerged View tab in the
Dependencies pane.

2. Browse to locate the content pack and click Open.
3. Click OK.

Note: It may take a few minutes to import the Base content pack.

Import a content pack
1. In theDependencies pane, click the Import button or from the File menu, select Import Content

Pack.
2. Browse to locate the content pack and click Open.

Note: If required, you can select multiple content packs to import at once.

3. Click OK. The imported content pack is displayed in theDependencies pane.

Security Note: Studio does not verify digital signatures. Therefore, it is recommended tomanually verify
the digital signaturemanually using well known tools, before importing it into Studio.

Extract a content pack and open it as a project
If you have upgraded content from previous versions of HPE OO, the upgrade tool converts your content into
content packs. Follow these steps to open a content packs as an editable project.

1. In your file system (for example, Windows Explorer), unzip the content pack. The content pack is
extracted into a project folder.

2. In Studio, select File > Import Project.
3. In the Select Project Directory dialog box, browse to locate the project that was created from the

unzipped content pack.
4. Click OK. You can now edit this project in Studio.

Note: If you opened the content pack in Studio before creating the project from it, you need to close the
content pack in Studio. The project and content pack will have the sameUUID, so they cannot be open
in Studio at the same time.
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Managing Content Packs and Dependencies
in a Project
Once a content pack is imported, you can use its operations in your flows, but note that these operations are
read-only. However, you can use the flows as steps as they are read-only also in the content pack.

If you want to modify operations from a content pack, you need to copy them into the project.

Note: This is only recommended if you want to add responses or results. If only the inputs are used, you
canmodify them inside the steps.

After an operation is copied to a project, it is detached from the content pack, and becomes editable. You can
drag and drop this new operation to a flow andmodify its properties.

Dependencies
A dependency is a project or content pack that includes a reference to an item contained in the current
project. The itemmay be one or more of the following:

l Operation soft copies that reference operations inside other content packs/projects
l An operation group alias that comes from another content pack/project
l An operation/flow/step scriptlet that comes from another content pack/project
l Operation/flow outputs filters that come from other content packs/projects
l Operation response rule evaluators that come from other content packs/projects
l Operation response rule filters that come from other content packs/projects
l Operations, flows or step inputs that have anOtherwise assignment from system accounts, selection lists
or domain terms inside other content packs/projects.

l Operations, flows or step inputs evaluators and domain terms coming from input validation format and
input record under respectively that are inside other content pack/projects.

l Flow steps referencing operations/flows from other content packs/projects
l Step results filters from other content packs/projects
l Transition role aliases from other content packs/projects
Dependencies are stored in the project's pom.xml file.

Dependency Conflicts

In general, the version of a declared dependency shouldmatch the version of dependencies that are
automatically detected by Studio.

However, there are three types of conflicts that may occur between dependencies:

l New conflict – appears when the dependency is not declared in the project and Studio finds that this
dependency is used. When resolving such a conflict, the dependency will be added with the version that
exists in the current workspace.

l Updated conflict – appears when the detected version is different from the declared version. The conflict
will only occur if the detected version is outside the range of the declared version. For example, if the
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declared version is a range 1.2 - 1.6 and the detected version is 1.3 there will not be a conflict as 1.3 is
within the 1.2 - 1.6 range. If the declared version is a fixed version 1.5, and the detected version is a
different fixed version 1.6, there will be a conflict. WhenApply Change is checked for such a row in the
Resolve Dependency Conflicts dialog box, the dependency will be updated in the list of dependencies of
that project with the version taken from the Detected Version column.

l Might not be used – appears when the dependency is declared in the project but Studio does not detect
that it is used. For example, youmay have a project ProjectB that has been added as a dependency in your
project ProjectA, but is not used in any of the flows, operations and configuration items from ProjectA. Or,
youmay have a dynamic reference to a system property inside ProjectB referenced from a flow inside
ProjectA. In both these cases, ProjectB dependency will be tagged as aMight not be used conflict.
In this case, the dependency will be removed from the dependency list in the current project if Apply
Change is checked.

Updating Dependencies in a Project

If your project includes dependencies, the first step youmust perform is to manually update all the
dependencies as described in "Update dependencies for a project" below. You can then validate
dependencies, add, edit or delete dependencies in the Dependency Editor.

What do you want to do?
Copy content pack objects to the project
1. Right-click the object to be copied in theDependencies pane and select Edit > Copy. To select

multiple objects, use the SHIFT and CTRL keys.
2. Right-click the location in theProjects pane where you want to paste the object and select Edit > Paste.

Tip: You can also drag and drop an object from theDependencies pane to theProjects pane.

Delete a content pack
Deleting a content pack is different from closing it, in that a deleted content pack is permanently removed
from the workspace.

Note:When you delete a content pack, it is deleted from the workspace, but is not deleted from the file
system. If required, you can import it again.

1. Select theContent Packs tab in theDependencies pane.

2. Select the content pack and click theDelete button .
3. Click Yes in the confirmation dialog box.

Close a content pack
If you close a content pack, it is visible in theDependencies pane, but is grayed out and not available.

When to close a content pack:

l If you have two versions of a content pack in the workspace, you will need to close one before you can
work with the other. The two contents packs will have the sameUUID, so they should not be open in
Studio at the same time.
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l If you created a project from a content pack, you should close the original content pack, before working
with the project. The project and content pack will have the sameUUID, so they should not be open in
Studio at the same time.

1. Select theContent Packs tab in theDependencies pane.
2. Select the content pack that you want to close.
3. Right-click the content pack and select Close.

Note: Alternatively, you can click theClose button in theDependencies pane.

Open a closed content pack
After a content pack has been closed, you can open it, to work with it again.

1. Select the closed (gray) content pack that you want to open.
2. Right-click the content pack and select Open.

Note: Alternatively, you can click theOpen button in theDependencies pane.

Display the properties of an imported content pack
Right-click a content pack in theDependencies pane and select Properties. The Properties window for the
content pack opens, in read-only mode.

Display the properties of an object in a content pack
Double-click a flow, operation or other object in theDependencies pane. The Properties window for the
object opens, in read-only mode.

Update dependencies for a project
There are threemethods that you can use to update dependencies:

1. Right-click on the project name, and from themenu, select Update Dependencies.
or:

2. In the Projects pane, right-click onProperties.
3. From themenu, select Update Dependencies.

or:

From the Dependencies Editor toolbar, click .
If Studio finds a new dependency, it adds a new line corresponding to that dependency. If the
dependency already exists, Studio updates it.

Note: In the case of an update, the current version is kept as long as it does not conflict with the
dependency detected by Studio.

4. If there is a conflict between the current version and the version detected by Studio, the Resolve
Dependencies Conflict dialog box opens:
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5. Check Apply Change for each row, in order to resolve the conflicts.

Note: If a dependency is marked as {Might not be used}, this means that the dependency is
declared in the project but Studio cannot identify whether or not it is used. For example, youmay
have an input in a flow that has a dynamic reference to a system property in another project. In this
case, Studio cannot identify whether or not the system property is used in the flow.

For these dependencies, Apply Change is unchecked by default. After checkingApply Change
and clicking OK, the dependency will be removed from the dependency list in the current project.

6. Click OK.
After clicking OK, Studio applies (updates, adds, removes) the selected dependencies (as marked in the
Apply Change column).
If there are no conflicts, or after all the conflicts have been resolved, the followingmessage appears:

Validate dependencies for a project
This procedure shows how to validate dependencies manually. However, there are cases in which the
dependency validation is triggered automatically:

l When the dependencies of a project are changed and saved
l When a project is updated from SCM either as individual project or as part of anUpdate All operation
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l After a project is imported
l When a project is opened

Note: The validation process checks the range of dependent items of a project and also checks that the
version of dependent projects match the project version.

Tomanually validate dependencies:

1. In theProjects pane, right-click onProperties.
2. From themenu, select Validate.
If there are any dependency warnings or errors in the project, you can see them in theProblems pane. For
example:

After the validation, the problems pane is updated with the new status of the dependencies.

Add a new dependency for a project
In addition to the dependencies that are automatically added to the project, you can add new dependencies,
even if they do not exist in the workspace.

1. Click in the Dependencies Editor toolbar.
The Add Dependencies dialog box opens.

2. In theName field, type the name of the dependency you want to add or click and select the
dependency from the list of current projects and content packs that have been imported into Studio:
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For example, if your project uses information from theMiddleware content pack, click and select
typeMiddleware 1.2.0-SNAPSHOT.

3. In theVersion field, type the version of the dependency you want to add. You can use a numeric value
(up to 99999999) or a snapshot version, e.g., 1.4.0-SNAPSHOT .

Note: If you selected from the list of dependencies , theVersion field is automatically filled with the
version number. For example:

In addition, if there is no official current version, the snapshot version is used.

4. To define a range of versions to be supported in the dependency, select Range value, and type the
range in the From and To fields. For example, if you are currently using Base version 1.4.0, but you want
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your project to be backward compatible with version 1.2.0, type 1.2.0 in the From field, and 1.4.0 in the
To field.

Note: The From field includes the value entered, as well as values higher than it, while the To field
does not include the value entered. For example, "from 1.2.0 to 1.4.0" means higher than and
including 1.2.0, but lower than 1.4.0.

You can also specify all values lower than... by entering a value only in the To field, or all values greater
than.... by entering a value only in the From field.
A range is marked by (range) in the Dependencies Editor.

Note: In the inline editor, you can automatically define a range by typing the range in the From field.
For example 1.2.0 - 1.4.0.

Edit a dependency
1. In the Dependencies Editor toolbar, select the dependency you want to edit.

2. Click .
3. Edit the dependency definitions as required.

Delete a dependency
You can delete dependencies from the project.

Note: The dependency is only removed from the project, not from the file system.

1. In the Dependencies Editor toolbar, select the dependency you want to delete.

2. Click .

Show dependency details
From the Problems Pane, you can take a closer look at the dependencies that caused warningmessages,
and then update the dependencies as required.

1. In the Problems Pane, select the error/warning that you are interested in.

2. From the toolbar, click .
The Dependency Details dialog box opens showing a list of items in the project that reference the
selected dependency. For example:
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4. Double-click on an item to load it in Studio.

Reference Material
Dependencies pane
TheDependencies pane can display multiple content packs, each with its own hierarchical tree structure.

TheDependencies pane contains two tabs:

l Content Packs - Displays multiple trees, for multiple content packs. From this view, it is possible to
close, delete, or import a content pack.

l Library - Displays a single tree, with all of the content merged together under a general Library folder and
a general Configurations folder. From this view, it is possible to import a content pack.
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GUI item Description

Import Content Pack Opens the Import Content Pack dialog box, letting you select a
content pack to be imported.

Delete Deletes the selected content pack.

Open Opens the currently selected closed content pack.

Close Closes the currently selected content pack, so that it is grayed out.

Content Pack Properties
When you right-click a project and select Properties , the Properties sheet opens.

In the Properties sheet for a project, you can update all the properties. However, for a content pack, the
properties are read-only.

You can show the same information from the Dependencies pane. The information is taken from the content
pack jar file that was imported. If the content pack was created from anHPE OO project, some of the
information is taken from what was entered into the Create Content Pack dialog box.

GUI item Description
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Name The name of the content pack is taken from the project name. This
field is read-only.

Uuid A unique identifier for the content pack.

Version The content pack version.

Publisher Enter the publisher of the content pack. This information will appear
in the content pack's Properties sheet.

Description Enter a description of the content pack. This information will appear
in the content pack's Properties sheet.

Dependencies Editor
At the bottom of the Content Pack/Project Properties page, the Dependencies Editor is shown.

In the Dependencies Editor, you can see all the installed content packs, their versions and their
dependencies for the current project. You can edit these values as required.

GUI item Description

Name The content pack or project name

Version The content pack version. You can edit this version with one of the
following:

l A fixed version number: For example, 1.2.0. This means that
you can only use the exact version of the content pack.

l Interval: For example, 1.2-. This means that you can use any
version greater than or equal to 1.2.
For example,
-1.2. This means any version strictly less than 1.2.

l Interval with range: For example, 1.2-3.0.1. This means that
you can use any version from 1.2 up to 3.0.1 (up to but excluding
3.0.1).

Add Open the Add Dependency dialog to add a new dependency for the
current project.

Delete Delete the selected dependency from the current project.

Edit Open the Edit Dependency dialog to change the definition of the
selected dependency.
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Update Dependencies Show and resolve any dependency conflicts in the current project.

Problems Pane toolbar

GUI item Description

Where relevant, open the flow related to the problem.

Update dependencies in the current project.

Add a dependency for the current project.

Delete a dependency from the current project.

Show details of dependencies in the current project.

Dependencies in the Problems Pane
If any issues occur when you validate dependencies, you can see them in theProblems pane.

There are three types of dependency issues that may occur. For each issue, a specific warningmessage is
shown in the Problems pane:

l Missing Dependency: The project contains links to items from another content pack/project but the
content pack/project containing the items are not declared in the project's dependencies list. To see

l Probably unused dependency: The declared dependencies of a project contains a dependency that
cannot be found by the Studio dependency detection rules. However, these rules do not detect dynamic
references for system properties, so the declared dependency could exist for a system property dynamic
reference, or may not exist at all.

l Not in workspace: The project links to a project or content pack that is not currently imported in Studio
workspace.

The following screen shows examples of these three types :

GUI item Description

Type Type of issue: Warning or Error. You cannot debug a flow with
errors, but you can edit it.
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Note:

l It is recommended to fix all issues, warnings and errors.
l In multi-author environments, it is important that no
warnings are produced when running Validate
Dependencies as modifications in the workspace by one
author can be also used by another author. Therefore, it is
important to have the necessary projects/content packs
imported with the correct versions.

Source Type The section in which the problem occurs. This may be a flow error,
an operation error, a step error, a configuration item error or a
dependencies warning.

Name The name of the section.

Description A description of the dependency issue.

Location The location of the item.

Dependency Details dialog box

GUI item Description
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Item Path The path of the item in the project that references the dependency.

Referred Item The name of the item in the project that references the
dependency.

Referred Item
Type

The type of the item in the project that references the dependency.

Referred Item
Usage

The name of the section in the flow in which the item is used.
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Managing Configuration Items
TheConfiguration folder in a project contains a number of items that you can set up: domain terms, group
aliases, system accounts, system properties, and so on.

If an authoring team are working in different projects and need the same configuration items, it is
recommended to create a separate, shared project containing the configuration items.

Important! If you need to delete, create, or rename a configuration item inside your project, make sure to
do this from within Studio, and not by deleting, creating, or renaming the item in the file system.

Working with Configuration Items

Searching for Configuration Items
You can search for configuration items by UUID, name, and description fields. The <all fields> type
search and <with Lucene query> type search using name, description and/or UUID as fields inside the
search query, will also search through the configuration items that belong to the currently opened projects and
content packs.

Using theSearch pane, you can perform a full-text search throughout the list of open projects and open
content packs.

See "Search for an operation or configuration item" in "Finding a Flow or Operation" on page 307 for details on
how to search for a configuration item.

Working with Configuration Item Folders
You can create folders in all the configuration items under the existing configuration item's folder structure.
You can perform the following operations on the configuration item folders:

l Create folders in each configuration item section
l Copy and paste configuration Items folders from one project to another
l Move configuration items folders from one project to another
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l Move items between folders and the top level section
l Delete configuration items folders.
l Rename configuration items folders
l Set descriptions for each configuration items

What do you want to do?
Search for a configuration item using the Navigate to item... option
You can use theNavigate to item.. option to easily find and open a configuration item in your workspace.

1. Select Tools > Navigate to item... .
TheSearch items by name:window opens.

2. Type in part of the configuration item name.
The window is immediately populated with search results. For example, if you search for a item whose
name contains the string "use", youmay see the following results:

3. Use the Up and Down arrow keys tomove in the list, then press Enter to open the selected item.
Alternatively, you can open an item with a double-click.

4. You can create steps in the current Flow Editor by dragging and dropping operations or flows from the
list.

Create a configuration item folder
1. In theProjects pane, expand theConfiguration folder.
2. Right-click on a configuration item folder, and then click New > Folder.
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3. Enter a name for the new folder and click OK.
You can now add, copy or move configuration items into this folder.

Rename a configuration item/folder
1. In theProjects pane, expand theConfiguration folder.
2. Right-click on a configuration item folder, and then select Rename.
3. Type in a new name and press Enter.

Copy and paste configuration items from one project to another
1. In theProjects pane, expand theConfiguration folder.
2. Right-click on a configuration item folder, and select Edit > Copy.
3. Select the location for the configuration items in the desired folder and select Edit > Paste.

Move configuration item folders and items
1. In theProjects pane, expand theConfiguration folder.
2. Right-click on a configuration item folder and select Edit > Cut.
3. Select the location for the folder in the second project and select Edit > Paste.
The entire folder and its configuration items aremoved to the new location.

Delete a configuration item folder
1. In theProjects pane, expand theConfiguration folder.
2. Right-click on a configuration item folder, and then select Delete.

Note: Deleting the folder and its configuration items will break any dependencies that they had with other
items.

Set a configuration item folder description
1. Right-click on a configuration item folder and select Properties.
2. In theDescription box, type a description for the configuration item folder.
3. Click Save.

View all the configuration items and their folder structure
1. In theProjects pane, right-click on the configuration item folder.
2. Select Properties.

A list of all the configuration items along with their folder structure opens. For example, for System
Properties the following list opens:

Note: From this page, you can see the folder structure in read-only mode and cannot edit the names
inline. However, you can edit the individual configuration items by double-clicking on a row, or by
selecting the icon on the right of each row.
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Configuring Categories
Categories are different classifications that can be assigned to a flow. A number of categories are installed
with Studio, but you can also create your own categories.

Users might use categories to create reports that indicate the health of key infrastructure components. For
example, if you assign the category Server to all the flows that check server health, then a report that finds
only flows that were assigned theServer category could highlight the health of the servers on your network.

You can also use categories for filtering a search. For example, you can run a search that only looks for flows
that have theSecurity category.

Categories are stored in theConfiguration\Categories folder.

What do you want to do?
Create a category
1. In theProjects pane, expand theConfiguration folder.
2. From theCategories folder, right-click and select New > Category.
3. In the dialog box that appears, type a name for the new category , and then click OK.
4. In theDescription box, type a description of the new category .
5. Click Save.

Change a category
1. In theProjects pane, expand theConfiguration andCategories folders, and double-click the category

to open its editor.
2. Double-click the category you want to change and type the new value.

Rename a category
1. In theProjects pane, expand theConfiguration andCategories folders, and double-click the category

to open its editor.
2. In theName box, type the new name for the category .
3. Click Save.
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Copy a category
1. In theProjects pane, expand theConfiguration andCategory folders.
2. Right-click on the category that you want to copy.
3. Select Edit > Copy.
4. Move to theCategory folder of the project you want to copy to.
5. Right-click and select Edit > Paste.

Delete a category
Before you delete a category , it is recommended to use theWhat Uses This function to check that other
items do not depend on it. For more information, see "Finding Out How Flows andOperations are Used" on
page 318.

1. In theProjects pane, expand theConfiguration andCategories folders.
2. Right-click the category and select Delete.
3. Click Yes in the confirmation windows.

Reference Material
Categories editor

GUI item Description

Name The name of the category.

Description (Optional) Description of the category.

Configuring Domain Terms
Domain terms are attributes that you can assign to flows and inputs. For example, youmight create domain
terms for the various kinds of servers in your system, and then you could get a step to run against a certain
type of server only.

Domain terms can be used for specialized selection lists. For example, you can create a domain term for
different kinds of actions. The values in this domain term could beRestart, Reboot, Open, and so on.

In another example, to specify that a flow run against certain classes of servers and not others, you can add
domain terms for the various kinds of servers in your system, and provide a user prompt at the start of the
flow, in which the user needs to select the classes of servers that you want to run a given flow against.
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Domain terms can have values by default, obtain their values from the flow’s inputs, or have the values that
you specify for them.

Domain terms are stored in theConfiguration\Domain Terms folder.

What do you want to do?
Create a domain term
1. In theProjects pane, expand theConfiguration folder.
2. From theDomain Terms folder, select New > Domain Term.
3. In the dialog box that appears, type a name for the new domain term, and then click OK.
4. In theDescription box, type a description of the new domain term.
5. Click Add to add a new domain term value.
6. In theName column, enter the name for the domain term value.
7. (Optional) In theDescription column, enter a description for the domain term value.
8. Click Save.

Remove a domain term value
1. In theProjects pane, expand theConfiguration andDomain Terms folders, and double-click the

domain term to open its editor.
2. Highlight the value and click Remove.

Change a domain term value
1. In theProjects pane, expand theConfiguration andDomain Terms folders, and double-click the

domain term to open its editor.
2. Double-click the value you want to change and type the new value.

Copy a domain term
1. In theProjects pane, expand theConfiguration andDomain Terms folders.
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2. Right-click on the domain term that you want to copy.
3. Select Edit > Copy.
4. Move to theDomain Terms folder of the project you want to copy to.
5. Right-click and select Edit > Paste.

Rename a domain term
1. In theProjects pane, expand theConfiguration andDomain Terms folders, and double-click the

domain term to open its editor.
2. In theName box, type the new name for the domain term.
3. Click Save.

Delete a domain term
Before you delete a domain term, it is recommended to use theWhat Uses This function to check that other
items do not depend on it. For more information, see "Finding Out How Flows andOperations are Used" on
page 318.

1. In theProjects pane, expand theConfiguration andDomain Terms folders.
2. Right-click the domain term and select Delete.
3. Click Yes in the confirmation windows.

Reference Material
Domain Term editor

GUI item Description

Name The name of the domain term.

Description (Optional) Description of the domain term.

Add Click Add to add a new item to the domain term list.
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Remove Click Remove to remove the selected item from the domain
term list.

Name column Enter the name of the item in the domain term list.

Description column (Optional) Enter a description of the item in the domain term
list.

Configuring Group Aliases
RAS Groups
A RAS group is a logical collection of RASes. Deployments can benefit from havingmore than a single RAS
in a specific environment. For example, you aremanaging a remote data center in which you need two
RASes to be able to withstand the action execution load, or simply for high availability of the RASes in that
data center.

You can define a RAS group in the server using the RESTful API. For more information, see theHPE OO
Application Program Interface (API) Guide.

Group Aliases
Group aliases let you separate between assigning an operation to a RAS during authoring time and in the
runtime environment.

1. At authoring time, the author defines the operation to execute on a group alias rather than a group.
2. At runtime, the administrator maps the alias to a RAS group in the runtime environment, using the

Central RESTful API. There is no need for the administrator to dive into the flows andmodify the RAS
assignment manually.

As a fallback, if the group alias is identical to the group name, it is mapped automatically to that group.

Optionally, at triggering time, it is possible to override the group alias andmap the operation to a different RAS
group.

Studio Authoring Guide
Managing Configuration Items

HPE Operations Orchestration (10.60) Page 119 of 350



For example, you have a group of three RASes that run on theOracle client. You create an operation that runs
a query onOracle. By using an alias for this group, you are telling HPE OO that this operation needs to run on
one of the RASes in this group. The choice of which RAS to use is determined at runtime, and does not need
to be configured in the operation.

Group aliases are stored in theConfiguration\Group Aliases folder.

RAS Group Overrides
There are twomethods of overriding RAS group details in HPE OO:

l Static – as described in "Group Aliases" on the previous page
l Dynamic - HPE OO assigns a value for the input at runtime. This can be done in one of the following ways:

l The flow author can set the RAS using theOverride Group field in the Operation fields in Studio's
Input inspector. In theOverride Group field, enter a different group, if you need to override the current
group with a different one. This can be a static or a dynamic value. For example, ${overrideJRAS}
where overrideJRAS is the name of a variable. During runtime, the variable can automatically be
assigned a value using one of themethods described in "RAS GroupOverrides" above.
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l From the Scheduler in Central, add an input field that will automatically be assigned during runtime. See
"Scheduling Flow Runs" in theCentral User Guide.

l Add an input field to the flow in Studio. See "Creating Input" on page 166

Examples of RAS Group Override Use

l Example 1: Defining a dynamic run environment as a variable. This environment may be a test
environment or a runtime production environment. This variable can be used as a flow input, step input or
set context in Studio or as an input from the Scheduler.

l Example 2:Defining a SAP client with RAS. The client can be called from aCentral flow as a SAP group.

What do you want to do?
Create a group alias
For example, you have created a RAS group of three RASes that run on theOracle client. You need to create
a group alias that will direct operations to work with this group, and thus to run on one of these RASes.

1. In theProjects pane, expand theConfiguration folder.
2. From theGroup Aliases folder, right-click and select New > Group Alias.
3. In the dialog box that appears, type a name for the new group alias, and then click OK.
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4. In theDescription box, type a description of the new group alias.
5. Click Save.

Rename a group alias
1. In theProjects pane, expand theConfiguration andGroup Aliases folders, and double-click the

domain term to open its editor.
2. Right-click on the group alias and select Rename.
3. Type a new name for the group alias, and press Enter.

Copy a group alias
1. In theProjects pane, expand theConfiguration andGroup Aliases folders.
2. Right-click on the group alias that you want to copy.
3. Select Edit > Copy.
4. Move to theGroup Aliases folder of the project you want to copy to.
5. Right-click and select Edit > Paste.

Delete a group alias
1. In theProjects pane, expand theConfiguration andGroup Aliases folders.
2. Right-click on the group alias to be deleted and select Delete.

Map the group alias to a group
Map the group alias to the group in the runtime environment using the Central RESTful API.

For more information, see theHPE OOApplication Program Interface (API) Guide.

Use the group alias in an operation
1. Create a new operation from an action plugin, as described in "Creating Operations" on page 299.

2. In the Inputs tab, in theOperation Fields section, notice theGroup Alias button.

3. Go toConfiguration > Group Alias, select the required group alias, drag it to the appropriate operation
and drop it on theGroup Alias icon (the globe based icon).

4. (Optional) In theOverride Group box, enter a different group, if you need to override the current group
with a different one. This can be a static or a dynamic value. For example, ${overrideJRAS} where
overrideJRAS is the name of a variable. During runtime, the variable can automatically be assigned a
value using one of themethods described in "RAS GroupOverrides" on page 120.

5. Save the operation.
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Remove the assignment of a group alias from an operation
After a group alias has been assigned to an operation, it is possible to remove this assignment.

1. Open an operation to which a group alias was assigned.

2. In the Inputs tab, in theOperation Fields section, right-click the link next to theGroup Alias
button.

3. From the right-click menu, select Clear.

Reference Material
Group Alias editor

GUI item Description

Name The name of the group alias.

Description (Optional) Description of the group alias.

Configuring Role Aliases
Roles and permissions are assigned to users in Central. However, you can plan for the roles that will be used,
by creating role aliases in Studio. For example, youmay want to attach a role alias to a gated transition.

When the content pack is deployed to Central, role aliases such as ADMINISTRATOR, EVERYBODY,
PROMOTER, SYSTEM_ADMIN, and END_USER aremapped to the corresponding roles in Central.

Note: Note that some of the role aliases in the Base content pack (AUDITOR, LEVEL_ONE, LEVEL_
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TWO, and LEVEL_THREE) do not have a corresponding role in Central. These role aliases are
considered deprecated.

Role aliases are stored in theConfiguration\Role Aliases folder.

What do you want to do?
Create a role alias
1. In theProjects pane, expand theConfiguration folder.
2. From theRole Aliases folder, right-click and select New > Role Alias.
3. In the dialog box that appears, type a name for the new role alias, and then click OK.
4. In theDescription box, type a description of the new role alias.
5. Click Save.

Rename a role alias
1. In theProjects pane, expand theConfiguration andRole Aliases folders.
2. Right-click on the role alias to be renamed and select Rename.
3. Type a new name for the role alias, and press Enter.

Copy a role alias
1. In theProjects pane, expand theConfiguration andRole Aliases folders.
2. Right-click on the role alias that you want to copy.
3. Select Edit > Copy.
4. Move to theRole Aliases folder of the project you want to copy to.
5. Right-click and select Edit > Paste.

Delete a role alias
1. In theProjects pane, expand theConfiguration andRole Aliases folders.
2. Right-click on the role alias to be deleted and select Delete.

Reference Material
Role Alias editor
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GUI item Description

Name The name of the role alias.

Description (Optional) Description of the role alias.

Configuring Scriptlets
Scriptlets (written in JavaScript) are optional parts of an operation that you can use tomanipulate data.

You can use scriptlets to:

l Filter the results of an operation, flow, or step
l Determine the response of an operation
l Manipulate data in a subflow before passing the data to the parent flow
For example, the divide by 1k scriptlet performs amathematical division of the input number (dividend) by
1024 (divisor) and returns the quotient rounded to the closest integer value.

You can create a system scriptlet from scratch or take an existing scriptlet in an operation and save it as a
shared system scriptlet. The resulting scriptlet is independent of the context for it was created and can be
reused in any operation, flow, or step.

System scriptlets are stored in theConfiguration\Scriptlets folder.

For more information about using scriptlets, see "Using Scriptlets in a Flow" on page 252.
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What do you want to do?
Create a system scriptlet
1. In theProjects pane, expand theConfiguration folder.
2. From theScriptlets folder, right-click and select New > Scriplets.
3. Enter a name for the scriptlet and click OK.

The Scriptlet Editor opens.

4. In theDescription box, describe the purpose of the scriptlet.
5. Type the scriptlet in JavaScript.

Note: You can reference a variable that is stored in a folder using the format ${variablename} and
a system property using the format ${path/system_property}.

6. (Optional) Click Insert Template and follow the guidelines in the template to write the scriptlet.
7. Click Check Script to check for errors."Filtering Output and Results" on page 215
8. Click Save.

The scriptlet is saved in theScriptlets folder and is now available for use in any operation, flow, or step.

Save an existing scriptlet as a system scriptlet
1. Under theScriptlet tab in theProperties sheet or Step Inspector, open the scriptlet that you want to

save as a system scriptlet.
2. In theProjects pane, expand theConfiguration andScriptlets folders.

3. Drag theScriptlet icon from theScriptlet tab of theProperties sheet or Step Inspector to the
Configuration\Scriptlets folder.

4. To rename the new system scriptlet, right-click it, click Rename, and change its name.

Use a system scriptlet in an operation, flow, or step
1. Open theScriptlet tab of theProperties sheet or Step Inspector for the operation, flow, or step on which

you want to use the system scriptlet .
2. In theProjects pane, expand theConfiguration andScriptlets folders.

Studio Authoring Guide
Managing Configuration Items

HPE Operations Orchestration (10.60) Page 126 of 350



3. Drag the scriptlet from theScriptlets folder to theScriptlet icon in theScriptlet tab of the
Properties sheet or Step Inspector.
The Scriptlet tab shows that there is now a reference to a shared scriptlet.

Edit a system scriptlet
1. In theProjects pane, expand theConfiguration andScriptlets folders.
2. Double-click the system scriptlet that you want to edit.
3. Modify the scriptlet and click Save.

Copy a scriplet
1. In theProjects pane, expand theConfiguration andScriptlets folders.
2. Right-click on the scriplet that you want to copy.
3. Select Edit > Copy.
4. Move to theScriplets folder of the project you want to copy to.
5. Right-click and select Edit > Paste.

Rename a scriptlet
1. In theProjects pane, expand theConfiguration andScriplets folders.
2. Right-click on the scriplet to be renamed and select Rename.
3. Type a new name for the scriplet, and press Enter.

Delete a system scriptlet
Before you delete a system scriptlet, it is recommended to use theWhat Uses This function to check that
other items do not depend on it. For more information, see "Finding Out How Flows andOperations are Used"
on page 318.

1. In theProjects pane, expand theConfiguration andScriptlets folders.
2. Right-click the system scriptlet and select Delete.
3. Click Yes in the confirmation window.
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Reference Material
Scriptlet Editor

GUI item Description

Name The name of the scriptlet.

Description (Optional) Description of the purpose of the scriptlet.

Insert Template Click Insert Template to see guidelines to help you write your scriptlet.

Check Script Click Check Script to check the scriptlet for errors.

Status Bar
l Displays the line column according to the location of the cursor.
l Displays the status of the Insert key, when the Insert mode characters are added. InOverwritemode they
are overwritten. Toggle between the twomodes using the Insert key.

Keyword Completion
l While typing a keyword, press Ctrl and theSpace bar, to display a drop-down list of options. Use the up
and down arrow keys to navigate through the list and then select the appropriate word. After selecting an
item the list disappears and the cursor is placed after the word.
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Jump to Line
l Double-click on the line column item in the status bar or press Ctrl + G key. You can only jump to lines
inside that have a numbermarker to the left of the scriptet window.

Configuring Selection Lists
Selection lists are lists of items that can be provided in user prompts in a flow.

For example, if the flow user needs to provide a step in the flow with the service status, you can create an
input whose data source is a selection list and specify the Service Status selection list (whosemembers are
Running, Stopped, and Paused).

Selection lists are stored in theConfiguration\Selection Lists folder.
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Note: If you use theSet Selection List operation from the HP Solutions content pack to add a custom
value of a selection list, the custom value remains in Central even if the selection list itself is deleted (in
the oo_content_config_item and oo_config_item_values tables).

When redeploying, the new entity is reattached to the custom value.

You can use one of the following workarounds to ensure that the custom value is deleted correctly:

l After undeploying the old entity, but before deploying the new one, delete the configuration item using
a REST call (with DELETE).
or:
Remove the custom value using a REST call (using PUT with null in the request body).

What do you want to do?
Create a selection list
1. In theProjects pane, expand theConfiguration folder.
2. From theSelection Lists folder, right-click and select New > Selection List.
3. In the dialog box that appears, type a name for the new selection list, and then click OK.
4. In theDescription box, type a description of the new selection list.
5. Click Add to add a new selection list value.
6. In theValue column, enter the name for the selection list value.
7. Click Save.

Remove a selection list value
1. In theProjects pane, expand theConfiguration andSelection Lists folders, and double-click the

selection list to open its editor.
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2. Highlight the value and click Remove.

Change a selection list value
1. In theProjects pane, expand theConfiguration andSelection Lists folders, and double-click the

selection list to open its editor.
2. Double-click the value you want to change and type the new value.

Rename a selection list
1. In theProjects pane, expand theConfiguration andSelection Lists folders, and double-click the

selection list to open its editor.
2. In theName box, type the new name for the selection list.
3. Click Save.

Copy a selection list
1. In theProjects pane, expand theConfiguration andSelection Lists folders.
2. Right-click on the selection list that you want to copy.
3. Select Edit > Copy.
4. Move to theSelection Lists folder of the project you want to copy to.
5. Right-click and select Edit > Paste.

Delete a selection list
Before you delete a selection list, it is recommended to use theWhat Uses This function to check that other
items do not depend on this selection list. For more information, see "Finding Out How Flows andOperations
are Used" on page 318.

1. In theProjects pane, expand theConfiguration andSelection Lists folders.
2. Right-click the selection list and select Delete.
3. Click Yes in the confirmation windows.
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Reference Material
Selection List editor

GUI item Description

Name The name of the selection list.

Description (Optional) Description of the purpose of the selection list.

Add Click Add to add a new value to the selection list.

Remove Click Remove to remove the selected value from the
selection list.

Value Enter the value in the selection list.

Configuring System Accounts
A system account is an object that contains an account’s credentials (user name and password), while
protecting the credentials from being viewed other than in the installation of Studio on which the system
account was created.

Flow authors can use system accounts when creating a flow. For example, you can set an input source to be
credentials from a system account. See "Specifying the Input Source " on page 175.

Note: The system accounts defined here are for Studio only. System accounts also need to be set up for
execution. This is done via API. For more information, see theHPE OOApplication Program Interface
(API) Guide.
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Users never see the system account name that provides a flow with user account credentials for access to a
remotemachine. Thus the credentials are protected from decryption, and the system account name is hidden
from the user.

System accounts are stored in theConfiguration\System Accounts folder.

Note: The following characters cannot be used in a system account name: <>\\"/;%.

What do you want to do?
Create a system account
1. In theProjects pane, expand theConfiguration folder.
2. From theSystem Accounts folder, right-click and select New > System Account.
3. In the dialog box that appears, type a name for the new system account, and then click OK.
4. (Optional) In theDescription box, type a description of the system account.
5. In theUser Name box, type the user name of the account that the system account represents, using the

following syntax:

<domain>\<username>

6. Click theAssign Password button.
7. In thePassword box, type the password, and then in theConfirm Password box type it again.
8. Click Save.

Copy a system account
1. In theProjects pane, expand theConfiguration andSystem Accounts folders.
2. Right-click on the system account that you want to copy.
3. Select Edit > Copy.
4. Move to theSystem Accounts folder of the project you want to copy to.
5. Right-click and select Edit > Paste.

Note: You can alsomove/copy system accounts, or a folder that contains system accounts, from one
project to another by dragging and dropping.
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Edit a system account
1. In theProjects pane, expand theConfiguration andSystem Accounts folders.
2. Double-click the system account that you want to edit.
3. Make your changes in the editor and click Save.

Delete a system account
1. In theProjects pane, expand theConfiguration andSystem Accounts folders.
2. Right-click the system account and select Delete.
3. Click Yes in the confirmation windows.

Note: If you delete a system account from a content pack and then redeploy the content pack, the
system account is not removed from the database. If this occurs, you will need to remove the
system account via REST API:

Do DELETE on: /oo/rest/system-accounts/<sa_name>.
For more information about working with REST APIs, see theHPE OOApplication Program
Interface (API) Guide.

Reference Material
System Accounts editor

GUI item Description

Name The name of the system account.

Note: The following characters cannot be used in a
system account name: <>\\"/;%.

Description (Optional) Description of the purpose of the system account.

User Name The user name of the account that the system account
represents, using the syntax <domain>\<username>.
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Assign Password Click to open the Enter Password dialog box, where you will
need to type the password twice.

Configuring System Evaluators
System evaluators are string formats that flow authors can use to validate inputs for any data sources except
system accounts.

For example:

l If the input is an email address, you can use an evaluator to check that the input is in the correct email
format.

l If the input must be a numeric value greater than or equal to 1, you can use an evaluator to check that this
is the case.

See "Evaluating Input Data" on page 186.

System evaluators can use any of the following:

l Simple operators such as =, !=, Begins with, Contains, Match All Words, and Match At Least One
Word and so on

l Regular expressions – for more information, see "Using Regular Expressions in a Flow" on page 256
l Scriptlets – for more information, see "Using Scriptlets in a Flow" on page 252
System evaluators are stored in theConfiguration\System Evaluators folder.

What do you want to do?
Create a system evaluator
1. In theProjects pane, expand theConfiguration folder.
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2. From theSystem Evaluators folder, right-click and select New > System Evaluator.
3. In the Select Evaluator dialog box, select an evaluator type, and then click OK.

4. Enter a name for the evaluator and click OK.
The Evaluator Editor opens. The appearance of the Evaluator Editor varies, depending on the type of
evaluator you selected.

5. In theDescription box, describe the purpose of the evaluator.
6. Enter the text, string, expression value, or scriptlet with which the evaluator should test the input.
7. Test the filter:

a. Click Clear to clear the Test Filter Input box.
b. Click Quick Command.
c. Type a command that generates the desired data.
d. Click OK. The output of the command appears in the Test Filter Input box.
For more information about testing filters, see "Filtering Output and Results" on page 215.

8. Click Save.

Studio Authoring Guide
Managing Configuration Items

HPE Operations Orchestration (10.60) Page 136 of 350



The evaluator is saved in theSystem Evaluators folder and is now available in theValidation Format
list in the Input Editor.

Edit a system evaluator
1. In theProjects pane, expand theConfiguration andSystem Evaluators folders.
2. Double-click the system evaluator that you want to edit.
3. Modify the text, string, expression value, or scriptlet with which the evaluator should test the input.
4. Click Save.

Copy a system evaluator
1. In theProjects pane, expand theConfiguration andSystem Evaluators folders.
2. Right-click on the system evaluator that you want to copy.
3. Select Edit > Copy.
4. Move to theSystem Evaluators folder of the project you want to copy to.
5. Right-click and select Edit > Paste.

Delete a system evaluator
Before you delete a system evaluator, it is recommended to use theWhat Uses This function to check that
other items do not depend on it. For more information, see "Finding Out How Flows andOperations are Used"
on page 318.

1. In theProjects pane, expand theConfiguration andSystem Evaluators folders.
2. Right-click the system evaluator and select Delete.
3. Click Yes in the confirmation window.
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Reference Material
Evaluator Editor – Standard
The appearance of the Evaluator Editor varies, depending on the type of evaluator you selected. If you
selected a simple operator in the Select Evaluator dialog box, such as such as =, !=, Begins with,
Contains, Match All Words, and Match At Least One Word, the Evaluator Editor appears as follows:

GUI item Description

Name Displays the name of the system evaluator

Description Enter a description of the evaluator

Compare To Type the text, string, expression value, or scriptlet with which the evaluator
should test the input.

Test Filter Input This is where you place data in order to test that the filter works as expected.
detailed information about the GUI items in this section, see "Filtering Output and
Results" on page 215.

Evaluator Editor – Regular Expression
The appearance of the Evaluator Editor varies, depending on the type of evaluator you selected. If you
selectedRegular Expression in the Select Evaluator dialog box, the Evaluator Editor appears as follows:
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For information about creating regular expressions, see "Using Regular Expressions in a Flow" on page 256.

GUI item Description

Name Displays the name of the system evaluator

Description Enter a description of the evaluator

Expression Type Select Java Style as the type of regular expression. Do not use the other styles;
they have been deprecated.

Expression Value Type the regular expression.

Match the whole
input

Select to apply the evaluator to the entire input.

Multi-line Select to enablemultiple lines in an expression.

Ignore Case Select to make the regular expression not case-sensitive.

Evaluator Editor – Scriptlet
The appearance of the Evaluator Editor varies, depending on the type of evaluator you selected. If you
selectedScriptlet in the Select Evaluator dialog box, the Evaluator Editor appears as follows:
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For information about creating scriptlets, see "Using Scriptlets in a Flow" on page 252.

GUI item Description

Name Displays the name of the system evaluator.

Description Enter a description of the evaluator.

Scriptlet icon Drag this icon to theConfiguration\Scriptlets folder, to save a scriptlet there for
reuse.

Insert Template Click Insert Template to see guidelines to help you write your scriptlet.

Check Script Click Check Script to check the scriptlet for errors.
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Configuring System Filters
Filters are used to extract andmodify parts of an operation’s output or a step's result. A system filter is
available system-wide, to be used inmultiple steps and operations.

For example, the filters used in a Ping operationmight be useful for other ping operations.

You can create a system filter from scratch or take an existing filter in an operation and save it as a system
filter. The resulting system filter is independent of the operation for it was created and can be reused in any
output or result.

System filters are stored in theConfiguration\System Filter folder.

What do you want to do?
Create a system filter
1. In theProjects pane, expand theConfiguration folder.
2. From theSystem Filters folder, right-click and select New > System Filter.
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3. From theSelect Filter list, select the type of filter.

4. Enter a name for the filter and click OK.
The Filter Editor opens. The appearance of the Filter Editor varies, depending on the type of filter you
selected.

5. In theDescription box, describe the purpose of the filter.
6. Enter the text, string, expression value, or scriptlet with which to filter the output or result. For

information about the different filter options, see "Filtering Output and Results" on page 215.
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7. Test the filter:
a. Click Clear to clear the Test Filter Input box.
b. Click Quick Command.
c. Type a command that generates the desired data.
d. Click OK. The output of the command appears in the Test Filter Input box.
For more information about testing filters, see "Filtering Output and Results" on page 215.

8. Click Save.
The filter is saved in theSystem Filters folder and is now available in theValidation Format list in the
Input Editor.

Troubleshooting: If you are using a localizedWindows command line, after using Quick Command, you
might get some strange characters in the results, because of the encoding of the command line.

To avoid this:

1. Close Studio.
2. Open <Install_folder>/studio/Studio.l4j.ini.
3. Add the following:

-Ddharma.windows.cmd.unicode=true

This will ensure that the characters read from the command line are interpreted in unicode.

Note that using this parameter might cause performance problems if you havemultiple runs of flows
containing operations that use the command line. Remove it from theStudio.l4j.ini file after you finish
testing the filters.

Save an existing filter as a system filter
1. Open the operation and, in the Filter Editor, select the filter you want to save as a system filter.
2. In theProjects pane, expand theConfiguration andSystem Filters folders.
3. In the operation’s Filter Editor, drag the filter from the Filter list to theSystem Filters folder.

4. To rename the new system filter, right-click it, click Rename, and change its name.

Use a system filter in an output or result
1. Open the Filter Editor of the output or result on which you want to use the system filter.
2. In theProjects pane, expand theConfiguration andSystem Filters folders.
3. Drag the filter that you want to use from theSystem Filters folder to the Filter list in the Filter Editor.
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Edit a system filter
1. In theProjects pane, expand theConfiguration andSystem Filters folders.
2. Double-click the system filter that you want to edit.
3. Modify the filter and click Save.

Copy a system filter
1. In theProjects pane, expand theConfiguration andSystem Filters folders.
2. Right-click on the system filter that you want to copy.
3. Select Edit > Copy.
4. Move to theSystem Filters folder of the project you want to copy to.
5. Right-click and select Edit > Paste.

Delete a system filter
Before you delete a system filter, it is recommended to use theWhat Uses This function to check that other
items do not depend on it. For more information, see "Finding Out How Flows andOperations are Used" on
page 318.

1. In theProjects pane, expand theConfiguration andSystem Filters folders.
2. Right-click the system filter and select Delete.
3. Click Yes in the confirmation window.

Reference Material
Filter Editor
The appearance of the Filter Editor varies, depending on the type of filter you selected. For information about
the different options, see Filter Options in "Filtering Output and Results" on page 215.
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GUI item Description

Name Displays the name of the system filter

Description Enter a description of the system filter

Configuring System Properties
System properties are global flow variables with values that never change and so can be used in any flow,
saving you the time of recreating a flow variable each time you need to use it. Any reference to a system
property obtains the system property’s value.

For example, theSQL Database Type system property lists the different types of SQL databases.
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System properties are stored in theConfiguration\System Properties folder.

What do you want to do?
Create a system property
1. In theProjects pane, expand theConfiguration folder.
2. From theSystem Properties folder, right-click and select New > System Property.
3. Enter a name for the system property and click OK.

The System Properties Editor opens.

4. (Optional) In theDescription box, type a description of the system property.
5. In theProperty Value box, type the values for the system property, using | as a separator.
6. Click Save.

The system property is saved in theSystem Properties folder and is now available for use in any flow.

Use the value of a system property in a flow
1. Specify the system property as the data source for a flow or step input.
2. In a scriptlet, use the appropriate command to obtain the system property’s value.

Note: For information on the required command and its syntax, on theScriptlet tab of an operation,
click Insert Template. The template provides the necessary commands for working with the global
context. For more information, see "Using Scriptlets in a Flow" on page 252.
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Change the value of a system property
There are several ways to change the value of a system property:

l Change the system property in a scriptlet. This changes the value from the point at which the script is run.
For information on the required command and its syntax, on theScriptlet tab of an operation, click Insert
Template.

l Create an operation that sets the system property’s value.
l Open the system property in theConfigurations\System Properties folder, and change the value.

Rename a system property
1. In theProjects pane, expand theConfiguration andSystem Properties folders.
2. Right-click on the system property to be renamed and select Rename.
3. Type a new name for the system property, and press Enter.

Copy a system property
1. In theProjects pane, expand theConfiguration andSystem Properties folders.
2. Right-click on the system property that you want to copy.
3. Select Edit > Copy.
4. Move to theSystem Properties folder of the project you want to copy to.
5. Right-click and select Edit > Paste.

Delete a system property
Before you delete a system property, it is recommended to use theWhat Uses This function to check that
other items do not depend on it. For more information, see "Finding Out How Flows andOperations are Used"
on page 318.

1. In theProjects pane, expand theConfiguration andSystem Properties folders.
2. Right-click the system property and select Delete.
3. Click Yes in the confirmation window.

Reference Material
System Properties Editor
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GUI item Description

Name The name of the system property.

Description (Optional) Description of the system property.

Property Value Type the values for the system property, using | as a
separator.
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Authoring a Flow – Basics
A flow is a set of actions that are linked by decision-making logic, to automate tasks.

For example, you want to verify that a page on yourWeb site contains the correct, current data, such as a
certain piece of text. If the desired data is not on theWeb page, you want to push new content to the site. You
can create a flow to do these tasks automatically.

This chapter covers all the basic steps that need to be done to create a simple flow. For information about
creatingmore complex flows, see "Advanced Authoring" on page 238.

Creating a Flow – Step-by-Step
This topic takes you step-by-step through themajor steps involved in creating a flow. It demonstrates how to
create a simple flow that checks whether a page on aWeb site contains a certain piece of text and, if that text
is not found, posts a page to theWeb site.

Note that this is just a high level look at the Studio workflow, and there aremany options that are not
described here. For more detailed information about any of the steps, use the links to learn about the flow
authoring options in-depth.

This topic presents the steps in a suggested order, but the steps do not have to be completed in the order
shown.

Step 1: Create a flow
1. Open the project in which you want to create the flow.
2. Open the folder in which you want to create the flow.
3. Select File > New > Flow.
4. Type ameaningful name for the flow and click OK.

Note: Names can be amaximum of 128 characters long, and are not case-sensitive.

5. Open the flow in the authoring pane and click Properties (at the bottom of the pane), then click the
Description tab.

6. Enter a description of the flow.
For more information and options, see "Creating a New Flow" on page 152.

Step 2: Add operations as steps
Drag an operation to the authoring pane, to use it as a step in your flow.

l If you want to modify the operation, copy and paste it into theProjects pane before dragging it onto the
authoring pane.

Note: This is only recommended if you want to add responses or results, if only the inputs are used,
thenmodify them inside the steps.
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In our example, there are two steps. Step 1 uses theCheck Web Site operation, which checks aWeb page
to see whether it contains specific text. Step 2 uses thePost Page operation to post a page to theWeb site.

For more information and options, see "Creating Steps in a Flow" on page 154.

Step 3: Create return steps to end the flow
Create one or more return steps to end the flow. Return steps indicate four primary possible end states to the
flow: Success, Diagnosed, No action, and Failure.

1. On the authoring pane toolbar, click theStep Palette button .
2. From theStep palette, drag the appropriate return step icons to the authoring canvas.
3. If required, change the flow responses that are assigned to the steps.
In our example flow, there are two end states: Success and Failure. There is no need to change the default
flow responses.

For more information and options, see "Creating Return Steps" on page 235.

Step 4: Create transitions
Create connections between steps so that each response for a step takes the flow to another step or to an
end step.

Note: Every response icon on the stepmust be connected to another step; otherwise, the flow will show
errors.

1. On the step that you want to connect to the next step, click the icon that represents one of the responses

, and drag a line to the destination step for that response.
2. If you need tomodify the transition, double-click the line to open the Transition Inspector.
3. Repeat the process for the other response icons on the step.
In our example:

l If theWeb page cannot be found, the flow ends in failure. Drag from the red Fail response icon to the Fail
end step.

l If the page is there but the text isn’t present, go to the second step, of posting another page toWeb site.
Drag from the yellow response icon to the second step.

l If the page is there and the desired text is present, the flow ends in success. In both steps, drag from the
greenSuccess response icon to theSuccess end step.

For more information about transitions, see "Creating Transitions" on page 188.

For more information about setting the responses for an operation, see "Setting Responses" on page 192.

Step 5: Add inputs to the flow
1. Right-click on the flow and select Properties.
2. In the Operation Editor, click the Inputs tab.

3. Click Add input from the Inputs toolbar and enter a name for the input.
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4. Click in the row’s Type column and select one of the value assignment types from the list:

l Single Value

l List of Values - to run an operation against multiple targets

5. In theAssign From field, define the data source for the input.
In our example, theCheck Web Site step needs to know which page to check (mysite.com/mypage.htm)
and what text to look for (“needed text”). In this case, you would create two single constant value inputs.

For more information and options, see "Creating Input" on page 166.

Step 6: Add results to the flow
By adding a result, you can capture a step's output and save it as a flow variable (to be used in other steps in
the flow) or a flow output field ( to be passed to a parent flow).

1. In the Step Inspector, click theResults tab.

2. Click Add result from the Step Inspector toolbar.
3. In theName column, enter a name for the result, and press the Return key on your keyboard. This name

will be used as the name of the flow variable or flow output field.
4. From the From list, select the source for the result. For example, select the primary output.
5. From theAssign To list, decide where the value will be stored: as a flow variable or output field.
6. From theAssignment Action list, select the appropriate action: overwrite, append, prepend, or one of

the arithmetic assignment actions.
In our example, theCheck Web Site step can be set to store the text that it found as a flow variable. In our
simple two-step flow, the successful completion of the first step goes straight to theResolved: Success end
step. But it is possible to add another step, for example, aSend Email step, which includes the flow variable
data in the body of the email.

For more information and options, see "Setting Step Results" on page 209.

Step 7: Save the flow
Click theSave button.

Studio validates the flow. If a flow is not valid, it is saved and an error message appears.

The different flow elements are shown below:
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Creating a New Flow
There are two options for creating a flow:

l Create the flow from scratch
l Use a predefined template as the basis of the flow

Important! If you need to delete, create, or rename a flow inside your project, make sure to do this from
within Studio, and not by deleting, creating, or renaming the item in the file system.

Create a flow from scratch
1. Open the project in which you want to create the flow.
2. Open the folder in which you want to create the flow.
3. Select File > New > Flow.
4. Type ameaningful name for the flow and click OK.

Note: Names can be amaximum of 128 characters long, and are not case-sensitive.

Create a flow from a template
The templates provided with Studio provide flows that perform certain frequently used tasks. For example,
there is aRestart Service template for creating a flow to restart a service.

1. Open the project in which you want to create the flow.

2. On theWelcome screen, click theNew Flow button.
3. In the list of templates that appears, highlight a flow template to display its description. If required, drag

the scroll bar to display the text.
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4. Select the flow template that meets your needs, and then click theCreate button.
5. The new flow is created in theMy Ops Flows in the Library folder of the selected project. If you want to

store the flow in a different folder, drag it to the desired folder, or use theEdit > Cut andEdit > Paste
commands.

Tip: You can also get templates from the Templates folder inOO-Base Content content pack, in the
Dependencies pane. Double-click the template to open it in the authoring pane. If you want to modify the
flow, copy it into your project andmodify the copy.

Note: You can create templates from other flows, by creating a Templates folder under Library, in your
project, and storing flows in that folder. These flows will be displayed in the list of flow templates.

Add a description of the flow
1. On the authoring pane, right-click the flow, and click Properties.
2. Click theDescription tab.
3. Enter a description of the flow and click OK.
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Reference Material
Available Flow Templates
When you click theNew Flow button on the HPE OOWelcome screen, theAvailable Flow Templates list
is displayed.

GUI item Description

Name Displays the names of the available templates. Highlight a name to
display its description in the Template Description box.

Path Displays the path to the folder where each template is stored.

Template Description Displays a description of the selected template.

Creating Steps in a Flow
When you create a step from an operation, the step is an instance of the operation and so inherits the
operation’s inputs, outputs, references, and other characteristics.

To create a step from an operation, drag the operation to the authoring pane.

l If you drag an operation from theDependencies pane, you will be able tomodify the step, but note that the
operation in theDependencies pane is read-only.

l If you want to modify an operation before creating the step, copy it from theDependencies pane and paste
it into theProjects pane, before dragging it onto the authoring pane.
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What do you want to do?
Create a step from an operation
1. In theProjects pane orDependencies pane, select the operation that you want to add to the flow.

Note: The operations in theDependencies pane are read-only.

2. Drag the operation from the project tree to the authoring pane.
3. If required, rename the step to reflect its function within the flow (operation names may be too generic):

a. Right-click the step that you want to rename and select Rename.
b. Type the new name in the highlighted field.

4. If required, edit the step. For more information, see "Modifying a Flow" on page 162.

Copy a read-only operation into the project to make it editable
1. In theDependencies pane, select the operation that you want to copy.
2. Select Edit > Copy.
3. Select the location in the project tree where you want to paste the copy, and select Edit > Paste. This

operation is treated as a new object and is detached from the content pack it arrived with.
4. If required, edit the operation.

Note: If you edit the operation, any steps that were created from this operation inherit the changes
to the properties. If you edit the step, this does not affect the original operation.

5. Drag the operation from the project tree to the authoring pane.

Note: A operation that is copied from a content pack to a project is a "soft copy". This means that if the
operation was originally created by importing an action plugin, the copied operation continues to
reference the original operation. If the action plugin is upgraded and the original operation is updated to
call the new version, the copied operation is updated automatically. For more information, see "Creating
Operations" on page 299.

Copy a step from within the flow
To copy and paste a step, use any of the following tools:

l TheCopy andPaste buttons on the authoring pane toolbar
TheEdit> Copy andEdit > Pastemenu commands

l The right-click menu
l Keyboard combinations (CTRL+C, CTRL+V)

Give a step a description
1. On the authoring pane, right-click a step, and click Properties.
2. Click theDescription tab.
3. Enter a description of the step and click OK.

For best practices for writing a description, see "Best Practices for Flow Authoring" on page 1.
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Give a step a callout
Callouts contain information about a step. They can greatly enhance the usability of a flow, by providing
information such as:

l Datamovement: how information is passed from one step to another
l Names of flow variables that store data
l Formats required for the input data

1. Display theStep palette by clicking theStep Palette button from the authoring pane toolbar.

2. Click theCallout button and drag the callout onto the authoring pane.
3. Type the text for the callout.

4. To connect the callout to a step, drag from the gray circle to the step.
5. Drag the corners of the callout text area to resize it.

Create a step from a flow (subflow)
A subflow is a flow within a flow. For more information, see "Creating a Subflow Within a Flow" on page 238.

1. Open the parent flow in the authoring pane.
2. In the Library, select the flow that you want to use as a step (or subflow).
3. Drag the flow from the Library to the parent flow in the authoring pane. The flow that you dragged

becomes a step in the parent flow.

Note: TheAccelerator Packs folder contains flows that can run as parent flows.

Create a non-blocking step
A non-blocking step does not block the rest of the flow. While it is running, the flow run continues to carry out
the steps that come after it.

You would do this when a flow’s subsequent actions do not depend on the outcome of the step. For example,
you want a flow to send a notification after the failure response of a step. But you don't need the flow to wait
while the notification is being sent.

Note: In a flat flow or subflow that contains a non-blocking step, the flow run will not end until the non-
blocking step is finished. However, if it is part of a flow with multi-instance or parallel steps, the flow run
will not wait for the non-blocking step.

Note also that it is not possible for multi-instance or parallel split steps to be non-blocking.
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1. With the flow open on the authoring canvas, right-click the step, and then click Toggle Nonblocking.
An orange lightning bolt appears on the step’s icon, and the step automatically acquires a single

response, done .

2. Connect the done response to the next step.

Note: To change a non-blocking step back into a regular step, right-click the step and click Toggle
Nonblocking again.

Create a manual step
A manual step is one that offers a choice of actions. The user will need to select an action at runtime.

To create amanual step, you copy themanual operation template from the base content and define the
actions that will bemade available to the user.

1. In theDependencies pane, select themanual operation template .
2. Select Edit > Copy.
3. Select the location in the project tree where you want to paste the copy, and select Edit > Paste. This

operation is treated as a new object and is detached from the content pack it arrived with.
4. Drag the operation from the project tree to the authoring pane.
5. In the step, add the actions that will be available to the user.

Note: It is also possible to add the actions in the operation properties, rather than in the step. If you do
this, you will be able to use the operation in other flows.
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Create a display step
A display step is one that displays information in a pop-up prompt message, but does not perform any other
action. The user will just need to click Continue at runtime.

To create a display step, you copy the display operation template from the base content and define the
information that will be displayed to the user.

The prompt message can include variables. For example, to tell the user what time the preceding step
concluded, you could include a date/time variable (${dateTime}) in themessage.

1. In theDependencies pane, select the display operation template .
2. Select Edit > Copy.
3. Select the location in the project tree where you want to paste the copy, and select Edit > Paste. This

operation is treated as a new object and is detached from the content pack it arrived with.
4. Drag the operation from the project tree to the authoring pane.
5. Open the Step Inspector for the step and click theDisplay tab.
6. Select theAlways prompt user before executing this step check box.
7. In thePrompt Title box, type the prompt's label (up to 128 characters).
8. In thePrompt Width box, type the width of the prompt in pixels.
9. In theHeight box, the height of the prompt in pixels.
10. In thePrompt Text box, type amessage to the user.
11. Click OK, and save your changes.

Note: It is also possible to add the display information in the operation properties, rather than in the step.
If you do this, you will be able to use the operation in other flows.

Reference Material
Step Inspector > Display tab
In theDisplay tab of the Step Inspector, you can create a user prompt that is displayed to the user.
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GUI item Description

Always prompt user before
executing this step

Select the checkbox if you want the prompt window to appear every
time this step is run.

Prompt Title Type the label that will appear in the title bar of the prompt window.

Prompt Width Type the width of the prompt window in pixels.

Height Type the height of the prompt window in pixels.

Prompt Text Type themessage that will appear in the body of the prompt window.
You can include variables in themessage. For example, ${dateTime}.

Adjusting the Appearance of a Flow
When creating a flow, you can use theView Options palette to neaten up the flow and adjust its appearance
on the authoring pane.

Display theView Options palette by clicking theView Options button from the authoring pane
toolbar.
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What do you want to do?
Snap steps to the grid
Snapping objects to the grid is a quick way to keep them aligned and neat.

1. If the grid is not visible in the background of the authoring pane, click theShow/Hide Grid button in
theView Options palette. When you drag an operation to the authoring pane, it snaps to the nearest line
in the grid.

2. Tomove a step from one line in the grid to another, move the step slightly and release themouse.

Note: By default, the grid is not displayed in the authoring pane. If you set the grid to display, using the

Show/Hide Grid button , this state is not persistent after Studio is closed. To change the default
behavior, so that the grid is displayed by default, you can open theStudio.properties file and set the
property dharma.studio.ui.activegrid=true.

Align steps
1. To align selected steps horizontally, select one or more steps and then select Align Selection

Horizontally in theView Options palette.
2. To align selected steps vertically, select one or more steps and then select Align Selection Vertically

in theView Options palette.

Show or hide response labels and icons
If your flow is looking overcrowded because of response labels and icons on operations, you can choose to
hide these.

1. To show or hide response labels, click theShow/Hide Labels button to toggle between hiding and
showing the response labels.

2. To show or hide the response icons, click theShow/Hide Connected Response Icons button to
toggle between hiding and showing the response icons.
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Move objects to the front or back
Flows may include objects that are stacked together in the authoring pane. This may occur in long flows
where there aremany items in the flow. In such cases, you need to bring themost important objects to the
front of the stack.

1. Tomove an object to the front of the stack, select it and click Bring to Front .

2. Tomove an object to the back of the stack, select it and click Send to Back .

Reference Material
View Options palette
TheView Options palette contains buttons for changing the appearance of the flow on the authoring pane.

Button Description

Show/Hide Labels
Shows or hides response labels on objects

Show/Hide Connected

Response Icons

Shows or hides response icons on objects

Align Selection

Horizontally

Aligns selected steps horizontally

Align Selection

Vertically

Aligns selected steps vertically

Bring to Front Moves the selected object to the front of the stack

Send to Back Moves the selected object to the back of the stack
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Button Description

Show/Hide Grid Reveals the authoring pane grid, which you can use for arranging steps.
When you stop dragging a step, it snaps to the nearest position on the grid.

Modifying a Flow
After a flow has been created, you canmodify the flow. For example, youmight copy a flow that you created
earlier and adapt it for a slightly different use. Or youmight take one of the out-of-the-box flows provided in
HPE OO, such as those in theAccelerator Packs folder, and adjust it for your needs.

Best Practices
Always make a copy of a flow beforemodifying it.

Beforemaking changes to a flow, useReferences >What uses this? to check whether other flows use it.

If you are copying a flow and you think that youmay need tomodify the properties of the operations, it is best
to use theCopy Deep command. This makes a copy of the operations along with the flow, so that you can
modify them without affecting the originals. See "Copying Flows andOperations" on page 315.

If you copy a flow using theCopy Deep command, create a new folder for the flow and its operations.

Caution: Make sure that you understand the difference betweenmodifying a step andmodifying an
operation.

l When youmodify the properties of a step (in the Step Inspector), this only affects the individual step.
l When youmodify the properties of an operation (in theProperties sheet), this affects all the flows that
use this operation as a step. You need to be extremely careful about modifying an operation’s
properties—doing so can break other flows that use it.

What do you want to do?
Open a flow for editing
l Double-click a flow in theProject pane to open it for editing in the authoring pane.
l To openmultiple flows in the authoring pane, select them using the SHIFT or CONTROL keys, right-click,
and select Open.

Jump to a step to edit it

If you have a complex flow with many steps, use theGo to Step button to quickly jump to the step that
you need to edit.
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1. Open the flow in the authoring pane.

2. In theAuthoring pane toolbar, click Go to Step .
3. Type the name of the step to jump to it, or the first letters of the step to select it from a list.
4. If desired, use theUp andDown arrows on your keyboard to navigate through the list of steps.

Change the start step
If you add a new step at the start of a flow, it will appear with a warning icon, because the start step has not
been defined.

Right-click the step that you want to use to start the flow and select Set Start Step.

Rename a step
1. Right-click the step that you want to rename and select Rename.
2. Type the new name in the highlighted field, press the ENTER key, and save your work.

Best practice: Make sure that the name clearly describes the purpose of the step.

Rename a flow or operation
If you are renaming an operation, check whether this operation is used in other flows. If so, it is better to make
a copy of the operation and rename the copy.

1. In theProject pane, right-click the flow or operation that you want to rename and select Rename.
2. Type the new name in the highlighted field, press the ENTER key, and save your work.

Best practice: Make sure that the name clearly describes the purpose of the flow or operation.

Move a group of steps in the flow diagram
1. Hold down the SHIFT or CTRL key to select a group of steps.
2. Click and drag the steps as a group.

Change an icon
You can change the icon on a step, operation, or flow to one that gives a clearer visual cue to what the
element does.
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1. To open the Icons pane, click the Icons tab.

2. Select the icon group name that describes the icon you need.
3. Select the icon, and drag it onto the step, operation, or flow.

Note: By holding down the CTRL key, and then dragging an icon, you can place the icon on top of
an existing icon, in layers.

Best practice: If you have classified flows according to type, use specific icons for each flow type.

Modify a step in the Step Inspector
1. Right-click a step and select Properties. The Step Inspector opens.
2. In the Step Inspector, you canmodify the step:

l Add or edit inputs in the step. For details, see "Creating Input" on page 166.

l Add or edit results in the step. For details, see "Setting Operation Outputs" on page 205.

l Add or edit a description of the step. For details, see "Creating Steps in a Flow" on page 154.

l Add or edit a user prompt for the step. For details, seeDisplay a user prompt for the step below

l Add or edit a scriptlet in the step. For details, see "Using Scriptlets in a Flow" on page 252.

Tip: To keep the Inspector open so that you can shift its focus from step to step without having to close
and reopen the Inspector, click thePin button at the right end of the Inspector’s title bar.
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Display a user prompt for the step
You can create a user prompt that is displayed before a step is run. The prompt message can include
variables. For example, to tell the user what time the preceding step concluded, you could include a date/time
variable (${dateTime}) in themessage.

1. Right-click a step and select Properties.
2. Click theDisplay tab in the Step Inspector.
3. Select theAlways prompt user before executing this step check box.
4. In thePrompt Title box, type the prompt's label (up to 128 characters)..
5. In thePrompt Width box, type the width of the prompt in pixels.
6. In theHeight box, the height of the prompt in pixels.
7. In thePrompt Text box, type amessage to the user.
8. Click OK, and save your changes. The step acquires a blue arrowhead, indicating the display prompt.

Change which operation a step is based on
For example, you need an existing flow step to be associated with a different operation, but you want to keep
the existing transitions to and from that step.

1. Right-click a step and select Properties.
2. In the Step Inspector, click theAdvanced tab.
3. UnderSource Operation, click theSelect button.
4. In the Select Source Operation dialog box, navigate to and select the operation that you want to base the

step on, and then click OK.
5. Rename the step to reflect the change in the operation.
6. Review andmake any changes necessary to the value assignments for inputs, to reflect any differences

between the old operation’s inputs and those of the new one.

Reference Material
Step Inspector > Display tab
In theDisplay tab of the Step Inspector, you can create a user prompt that appears before a step is run.
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GUI item Description

Always prompt user before
executing this step

Select the check box if you want the prompt window to appear every
time this step is run.

Prompt Title Type the label that will appear in the title bar of the prompt window.

Prompt Width Type the width of the prompt window in pixels.

Height Type the height of the prompt window in pixels.

Prompt Text Type themessage that will appear in the body of the prompt window.
You can include variables in themessage. For example, ${dateTime}.

Creating Input
Inputs specify how and when the steps in a flow obtain the data that they need. For example, in aNetwork
Check flow, the first step pings a server, so it needs the IP address of the server to ping. The IP address is
provided via an input.

Each input is mapped to a variable, whose value can be set in the following ways:

l Create a user prompt, so that the value will be entered by the person running the flow, at the start of the
flow.

l Set the input’s value to a specific, unchanging value.
l Set the value to be obtained from another step.
l Assign a flow variable to the input. A flow variable is of a collection of variables and data values that are
available to the entire flow.

You can create an input for a flow, operation, or step.
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Caution: Make sure that you understand the difference betweenmodifying a step andmodifying an
operation.

l When youmodify the properties of a step (in the Step Inspector), this only affects the individual step.
l When youmodify the properties of an operation (in theProperties sheet), this affects all the flows that
use this operation as a step. You need to be extremely careful about modifying an operation’s
properties—doing so can break other flows that use it.

Note:

l An input that appears in red is a step input coming from a required operation input that was deleted for
that step.For example:

l An input that appears in gray is a step input coming from an optional operation input that was deleted
for that step.

l You can resize each pane by dragging the divider bar between the two panes. Use the scroll bars at
the bottom of each pane to show the unseen fields. The next time you open Studio, the divider bar is in
the same position.

l There is always one input highlighted in the Inputs pane. After deleting an input, the first input in the
Inputs pane is automatically highlighted.

l You canmove columns in the Input pane by dragging and dropping.
l Inputs are processed according to their position in the inputs list, from top to bottom.

What do you want to do?
Create an input
1. Open theProperties sheet or Input Inspector:

l To add an input to an operation, right-click the operation in theProject pane and select Properties.

l To add an input to a flow, right-click the flow in theProject pane and select Properties.

l To add an input to a step, double-click the step in the authoring pane.

2. Select the Inputs tab.

3. If there are existing inputs, select the row that you want the new input to follow. For example, if you
select the first row, the new input will appear on the second row, and will be the second item in the list.
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4. Click the button.
5. Enter the name of the new input and click OK. The input appears in a new row.

Note: Do not name the input “service” or “sp”. Doing so can create errors in flow runs in certain
situations.

6. (Optional) Tomake the input mandatory for the step to function, select theRequired check box on the
new row.

7. From the Type list, specify how the input gets its value:

l Single Value

l List of Values This enables you to run an operation with an input that contains multiple
values. The values must be provided in a list separated by the delimiter specified in the Input
Delimiter field.

8. Specify the input source in the Input Inspector:
l To assign the value from a variable with the same name as the input, select the default name (marked
by the prefix <default>) that appears at the top of theAssign From list.

l To assign the value from a different flow variable, select the variable name in theAssign From list.

l If you do not want to define a source for this input, select <not assigned> in theAssign From list.

For a detailed description of how to define different input source types, see "Specifying the Input Source
" on page 175.

Note:When you create a new input for an operation, flow, or step, the default value forAssign
From/Assign To is automatically set to <not-assigned> when installing Studio. This functionality
can be changed using the properties dharma.studio.ui.inputinspector.assignfrom.selected or
dharma.studio.ui.inputinspector.assignto.selected in theStudio.properties file.

This default also applies to the inputs of a new step, and to a step that was dragged from
Projects/Dependencies pane.
For details on the parameters in the Studio.properties file, see "Configuring Studio Properties " on
page 331.

9. In theOtherwise list, you select the action to occur if the flow variable that you specified in theAssign
from box does not exist or has no value stored in it. When you click on an input name, the right pane is

automatically updated with its details. Click to open theOtherwise dialog box or fill in the fields in the
right pane. The options are:
l Use Constant: Enter the constant value that will be used for the input. For example, an IP address
that is always used.

l Prompt User: Set up a prompt for the user to supply the information, either by entering information or
making a selection from a list, at the start of the flow.
o Prompt For: Text - Prompt the user to enter information. Type the prompt that the user will see in

theUser Message: box. For example, Enter a value for eventid.
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o Prompt For: Selection Prompt the user to select a value. Select the type of list the user will
select from:
Selection List:Select the selection list from theNamed list. All the selection lists are shown.
Domain Term: Select the domain term from theNamed list. All the domain terms are shown.
Flow Variable: Select the name of a flow variable . Flow variables are defined in the results for
flows.Type a delimiter for the flow variables in theSource Delimiter field.

Note: It is not recommended to use thePrompt User option for a step in themiddle of a flow.

l Use Previous Step Result: Select a previous step result to be used if theAssign From variable for
the input does not exist or has no value.

For example, youmight have a first step that looks for a piece of information, and which saves
this information as a flow variable. Then, youmight have a second step that displays that
information. The second step uses the flow variable that was created in the first step.

l System Account: Select the system account name and credential type.

l Logged-in user credentials: Select the credential type of the logged-in user.

Note: TheSystem Account and Logged-in user credentials fields do not appear if you define
the input as List of Values in the Type field.

For more details about different types of input source, select the relevant task in "Specifying the Input
Source " on page 175.
The default value that appears in this field depends on the settings in the studio.properties file. For
details on these settings, see the parameter
dharma.studio.ui.inputinspector.assignfrom.selected in "Configuring Studio Properties " on page
331.

Note:When you create a new input for an operation, flow or step, the default value forOtherwise is
automatically set toUse Constant.

10. Specify the input target in the Input Editor:
l To assign the value to a variable with the same name as the input, select the default name (marked
by the prefix <default>) that appears at the top of theAssign To list.

l To assign the value to a different flow variable, select the variable name in theAssign To list.

l If you do not want to define a target for this input, select <not assigned> in theAssign To list.

11. By default, Studio creates a flow variable with the same name as the input. This variable can be used in
later steps in the flow. It is possible to change this name in theAssign to Variable field on the right of
the window.

For example, if you have a step in which the user needs to enter a password, youmight want to
name the variable password to make it easy to identify.

12. (Optional) To validate that the input is in the correct format, select a system evaluator from the
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Validation Format list.
For example, if the input is an email address, you can use an evaluator to check that the input is in the
correct email format. For information about creating evaluators, see "Evaluating Input Data" on page
186.
For example, if your flow requires users to enter an email address, you can use an evaluator to check
that the input is entered with the correct email format. For information about creating evaluators, see
"Evaluating Input Data" on page 186.

13. (Optional) To record the value, to make it available for diagnostics or auditing, select <run history> from
theRecord Under list.
l <run history>

l one of the domain items in the list

Rename an input
1. Open theProperties sheet (for a flow or operation) or the Input Inspector (for a step).
2. On the Inputs tab, double-click on an input name, or press F2 and type in a new name.

or:
In the right pane, type in a new input name in theName field.

Remove an input
1. Open theProperties sheet (for a flow or operation) or the Input Inspector (for a step).

2. On the Inputs tab, select the input that you want to remove, and then click Remove Input from the
Input Inspector toolbar. A removed step input appears in italics. You can select multiple inputs using the
Ctrl andShift keys.

Restore a default input that was removed
If you removed a default input from the Inputs tab, you can restore it. Default inputs are those that were
created as part of the operation on which the step is based. Default inputs that have been removed appear in
the list of inputs grayed out and italicized.

1. On the Inputs tab, click Add Input.
2. Type the exact name of the input that you want to restore.
3. You can edit any of the input's fields as required.
4. Click OK.

The red/gray color is removed and the input is shown in black.

Change an input name globally
You can easily change the name of an input in steps in a flow. For example, if you have an input HostName in
several steps in a flow, you can change the name toHost for all the steps in the flow a single action.

1. In the flow,
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Reference Material
Input Inspector > Toolbar

GUI item Description

Add input Adds a new input row. Type the name of the new input and click OK.
The new input's attributes are assigned with default values.

Delete input Deletes the selected input row.

Move up Moves the selected input row higher in the list.

Move down Moves the selected input row lower in the list.

Cut Removes the selected input row from its current location. Use the
Paste option to place the row in a new location.

Note: If you try to remove an operation input at the step level,
Studio automatically makes it appear in italics andmoves it to the
bottom of the inputs table. Required inputs appear in red, and
optional inputs in gray.

You can restore the input by changing the Type, Assign
To/Assign From orOtherwise fields.

Copy Copies the selected input row. Use thePaste option to place the copy
in a new location.

Paste Pastes the copied/cut input row at the current location. If the input
name already exists, a message appears and the input is not pasted.
(This is the default behavior.)

If the input name already exists, Studio automatically names the new
input <input> (Copy 1).

Note: You can also cut, copy and pastemultiple inputs between steps, flows or operations. Select
additional inputs by holding down theCtrl key and clicking on the row.

Input Inspector > Inputs tab
The Inputs tab in the Step Inspector is where you specify how and when a step in a flow obtains the data that
it needs.
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GUI item Description

Input Displays the name of the input.

Sensitive Makes this input hidden in the Central user interface and in the Studio
internal and remote debugger. If this check box is selected, the input
value will be encrypted in Central and Studio, will be displayed as
asterisks and will not be persisted

This flag is transient, i.e.,assignment from a sensitive variable will also
make the assigned variable sensitive. This transitivity is only seen
during runtime execution, and is not reflected in the Studio user
interface.

When used in scriptlets, sensitive data is retrieved as encrypted.

Sensitivity is also retained when using expressions for assignment. For
example, ${input1}.

Required Makes this input mandatory.

Type From the Type list, specify how the input gets its value. The choices
are:

l Single Value

l List of Values to run an operation against multiple targets

Assign From Specifies where the input gets its value from. From theAssign From
list, select an input from which to take the value.

Otherwise Shows what action should occur if the flow variable that you specified
in theAssign From column does not exist or has no value stored in it.

When you click on an input name, the right pane is automatically
updated with its details.

Click to open theOtherwise dialog box or fill in the fields in the right
pane.

Assign To Select the flow variable that you want to assign the input’s value to.

Note: To edit theAssign From andAssign To directly, double-click in the field and type in the new
value.

Input Inspector > Inputs tab > Otherwise pane/Otherwise dialog box
TheOtherwise pane appears on the right side of the Input Inspector. In this pane, you define what action
should occur if the flow variable that you specified in the Assign From column does not exist or has no value
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stored in it. Some of these fields also appear in the Otherwise dialog box.

Otherwise Pane

Otherwise Dialog Box

Note: TheSystem Account and Logged-in user credentials fields do not appear if you define the
input as List of Values in the Type field.

GUI item Description

Use Constant Enter the constant value that will be used for the input. For example,
an IP address that is always used.

Prompt User Set up a prompt for the user to supply the information, either by
entering information or making a selection from a list, at the start of the
flow.

l Prompt For: Text - Prompt the user to enter information. Type the
prompt that the user will see in theUser Message: box. For
example, Enter a value for eventid.

l Prompt For: Selection Prompt the user to select a value. Select
the type of list the user will select from:
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Selection List:Select the selection list from theNamed dropdown
list. All the selection lists are shown.
Domain Term: Select the domain term from theNamed dropdown
list. All the domain terms are shown.
Flow Variable: Select the name of a flow variable . Flow variables
are defined in the results for flows.Type a delimiter to the domain
terms in theSource Delimiter field.

Note: It is not recommended to use thePrompt User option for a
step in themiddle of a flow.

Use Previous Step Result Select a previous step result to be used in the case that this input has
no value.

For example, youmight have a first step that looks for a piece of
information, and which saves this information as a flow variable.
Then, youmight have a second step that displays that
information. The second step uses the flow variable that was
created in the first step.

System Account Enter the system account name and credential type.

Logged-in user credentials Enter the user name or password for the logged-in user.

List Source Select one of the following from the list:

l Selection List - select from a set of predefined lists.
From theNamed list, select the list you want to present to the user.

Tip: You can add to the set of predefined lists by creating a
list. For information on creating a list, seeCreating selection
lists for user prompts.

l Domain Term - Domain terms are specialized selection lists. For
example, to specify that a flow runs against certain classes of
servers, you can add domain terms for the various kinds of servers
in your system and create a user prompt in which the user selects
the classes of servers that you want to run the flow against.
From theNamed list, select the domain term list you want to
present to the user.

l Flow Variable - create a list that is populated by the contents of a
flow variable.
From theNamed list, type or select the flow variable that contains
the list. You can reference a flow variable from a different flow. For
example, to reference a flow under the folder structure
folderA\folderB\flow1, use the string ${folderA/folder/flow1}.
In theSource Delimiter box, type the character that separates the
elements in the list.
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User Message Type a prompt message to let the user know what kind of data is
needed.

Specifying the Input Source
While you are setting up an input in a flow, operation, or step, there are a number of options available for how
to specify the input source.

l Specify the input source as a single constant value
l Specify the input source as a single user-entered text
l Specify the input source as a single user selection
l Specify the input source as a constant list of values
l Specify the input source as list of input values obtained from user-typed text
l Specify the input source as a single user selection
l Specify the input source as the previous step’s result
l Specify the input source as the system account details
l Specify the input source as the user login name or password
The tasks in this section are optional sub-tasks within themain task of setting up an input. See "Creating
Input" on page 166.

What do you want to do?
Specify the input source as a single constant value
Specify the input value source as a static value. For example, a single constant value could be an IP address
that is always used in a step.

1. Create an input and set the type toSingle Value.

2. Click the Otherwise button to open theOtherwise dialog box for that row or fill in the values directly in
the right pane:
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3. By default, <not assigned> appears in theAssign from field.
l To assign that the input value from the value of a variable of the same name, select <default> -
<name> from theAssign from dropdownmenu.

l To assign the input value from the value of a different input, select the input name from theAssign
from dropdownmenu.

l You can also type in a value directly in this field.

4. From theOtherwise list, select Use Constant. This defines what will occur if the flow variable that you
specified in theAssign from Variable box does not exist or has no value stored in it. The default value
is Use Constantwhen installing Studio, andPrompt Userwhen upgrading from a previous version of
Studio.

Note: You can change these defaults in the Editor window underConfiguration > Options:
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5. In the 'Otherwise: Use Constant' Configuration section, type the value for the input (for example,
false). You can also use a combination of text and variable reference, using the following format:
${variablename}. For example, Ping of ${targethost" succeeded. To reference a variable that is
stored in a folder use the following format: ${foldername/variablename}

Specify the input source as a single user-entered text
Specify the input value source as user-entered text when the user must supply the information necessary for
the flow to do its work. For example, youmight want the user to specify the IP address of their own server, at
the start of the flow.

Note: Do not specify the input source as user-entered text for a step in themiddle of a flow.

1. Create an input and select Single Value from the Type dropdownmenu.

2. Click the Otherwise button for that row to open theOtherwise dialog box and select Prompt User or
select Prompt User in the right pane. The default value is Use Constantwhen installing Studio, and
Prompt Userwhen upgrading from a previous version of Studio.

Note: You can change this default by setting the use.constant.default.value.input parameter in
theStudio.properties file.

3. In thePrompt For: area, select Text.
4. In theUser Message box, type a prompt message to let the user know what kind of data is needed.

Studio Authoring Guide
Authoring a Flow – Basics

HPE Operations Orchestration (10.60) Page 177 of 350



Specify the input source as a single user selection
Another way to get the user to supply the input is to present a list from which the user must make a selection.
For example, youmight want the user to select from a choice of locations, at the start of the flow.

1. Create an input and select Single Value from the Type dropdownmenu.

2. Click theOtherwise button for that row to open theOtherwise dialog box and select Prompt User or
select Prompt User in the right pane. The default value is Use Constantwhen installing Studio, and
Prompt Userwhen upgrading from a previous version of Studio.

Note: You can change this default by setting the use.constant.default.value.input parameter in
theStudio.properties file.

3. In thePrompt For: area, select Selection.
4. From the List Source dropdownmenu, select one of the following:

l Selection List - select from a set of predefined lists.
From theNamed list, select the list you want to present to the user.

Tip: You can add to the set of predefined lists by creating a list. For information on creating a list,
seeCreating selection lists for user prompts.

l Domain Term - Domain terms are specialized selection lists. For example, to specify that a flow
runs against certain classes of servers, you can add domain terms for the various kinds of servers in
your system and create a user prompt in which the user selects the classes of servers that you want
to run the flow against.
From theNamed list, select the domain term list you want to present to the user.

l Flow Variable - create a list that is populated by the contents of a flow variable.
From theNamed list, type or select the flow variable that contains the list. You can reference a flow
variable from a different flow. For example, to reference a flow under the folder structure
folderA\folderB\flow1, use the string ${folderA/folder/flow1}.
In theSource Delimiter box, type the character that separates the elements in the list.

5. In theUser Message box, type a prompt message to let the user know what kind of data is needed.

Specify the input source as a constant list of values
This type of input enables you to run a step onmultiple targets. For example, to run an operating system
health check or install a software update onmultiple machines.

1. Create an input and select List of Values from the Type dropdownmenu.

2. Click theOtherwise button for that row to open theOtherwise dialog box and select Use Constant
or select Use Constant in the right pane. The default value is Use Constantwhen installing Studio, and
Prompt Userwhen upgrading from a previous version of Studio.

Note: You can change this default by setting the use.constant.default.value.input parameter in
the Studio.properties file.

3. Un the Input Delimiter box, type the character that separates the elements in the list of values.
4. In theConstant Value box, do one of the following:
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l Type the values for the input, separating between the values with the character that you entered in
the Input Delimiter box.

l Type one or more flow variable references, using the following format:

${foldername/flowvariablename1}<delimiter>${foldername/flowvariablename2}

Note: You can include both typed values and variables in the same list. For example,
${folder1/flowvariableA}|${folder1/flowvariableB}|10.2.0.200|18.35.100.7

In this example, flowvariableA contains 220.220.3.9 and flowvariableB contains 10.51.110.12 and the
delimiter is set to the character "|". If you type the two variable names and type the IP addresses of two
others manually into theConstant Value box, the operation will run on all four machines: 220.220.3.9,
10.51.110, 1210.2.0.200, and 18.35.100.7.

Specify the input source as list of input values obtained from user-typed text
In this type of input, the user needs to type a list of values, separated by a delimiter. For example, you want
the user to enter multiple host addresses for a flow to target, at the start of the flow.

1. Create an input and set the type to List of Values.

2. Click theOtherwise button for that row to open theOtherwise dialog box and select Use Constant
or select Use Constant in the right pane. The default value is Use Constantwhen installing Studio, and
Prompt Userwhen upgrading from a previous version of Studio.

3. In the Input Delimiter box, type the character or character sequence that separates the elements in the
list.

4. From theOtherwise list, select Prompt User.
5. In thePrompt For: area, select Text.
6. In theUser Message box, type a prompt text that lets the flow user know what kind of data the operation

needs.

Note: Make sure that the prompt text explains to the user how to type a successful list, particularly
with attention to the delimiter character (or character sequence) that is required. Note that including
a space between list elements when the delimiter character sequence doesn’t specify one would
cause the operation to fail.

Specify the input source as list of input values obtained from user selections
The user prompt presents the user with a list from which they can select multiple items. For example, the
user needs to select a list of machines for the flow to target, at the start of the flow.

1. Create an input and set the type to List of Values.

2. Click theOtherwise button for that row to open theOtherwise dialog box and select Prompt User or
select Prompt User in the right pane. The default value is Use Constantwhen installing Studio, and
Prompt Userwhen upgrading from a previous version of Studio.

3. In the Input Delimiter box, type the character that separates the elements in the list.
4. In thePrompt For: area, select Selection.
5. From the List Source list, select one of the following:

l Selection List - select from a set of predefined lists.
From theNamed list, select the list you want to present to the user.
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Tip: You can add to the set of predefined lists by creating a list. For information on creating a list,
seeCreating selection lists for user prompts.

l Domain Term - Domain terms are specialized selection lists. For example, to specify that a flow
runs against certain classes of servers, you can add domain terms for the various kinds of servers in
your system and create a user prompt in which the user selects the classes of servers that you want
to run the flow against.
From theNamed list, select the domain term list you want to present to the user.

l Flow Variable - create a list that is populated by the contents of a flow variable.
From theNamed list, type or select the flow variable that contains the list.
In theSource Delimiter box, type the character that separates the elements in the list.

6. In theUser Message box, type a prompt message to let the user know what kind of data is needed.

Specify the input source as the previous step’s result
For example, the previous stepmight have been to test whether a process works, and the input in the current
step is to display the results of that test.

1. Create an input and set the type to eitherSingle Value or List of Values, depending on whether you
want multiple values for the input.

2. Click theOtherwise button for that row to open theOtherwise dialog box and select Use Previous
Step Result or select Use Previous Step Result directly in the right pane.

3. If the input value comprises more than one value, in the Input Delimiter box, type the character that
separates the elements in the list.

Note: If the previous step's result containedmultiple items, the input delimiter that you specify must
match the delimiter in that result.

Specify the input source as the system account details
If you define the input type as single value, you can use user login credentials as an input source. This lets
you enable a flow to perform tasks that require system account credentials.

Specify the input value source as the one of the credentials defined in the user account under which the flow
is started (user name or password).

1. Click theOtherwise button for that row to open theOtherwise dialog box and select System
Account or select System Account directly in the right pane.

2. From theAccount Named dropdownmenu, select the system account to use for the operation’s
credentials, and choose the property you want to extract from the system account (for example,
password/username). This allows the flow to perform tasks that require these account credentials, while
protecting the credentials from exposure by keeping them hidden behind the system account name. For
more information about system accounts, see "Configuring System Accounts" on page 132.

3. In the Credential Type field, select Username orPassword.

Specify the input source as the user login name or password
You can also use credentials as an input source. This lets you enable a flow to perform tasks that require
system account credentials.
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Specify the input value source as the one of the credentials defined in the user account under which the flow
is started (user name or password).

Note: This input method is for Studio 9.x compatibility only. If you want to define a new input for Studio
10.x , use theSystem Account option described in "Specify the input source as the system account
details " on the previous page.

1. Click theOtherwise button for that row to open theOtherwise dialog box.
2. Select Logged-in User Credentials or select Logged-in User Credentials directly in the right pane.
3. In the Credential Type dropdown, select User Name orPassword.

Specify the input source as the system account details
If you define the input type as single value, you can use user login credentials as an input source. This lets
you enable a flow to perform tasks that require system account credentials.

Specify the input value source as the one of the credentials defined in the user account under which the flow
is started (user name or password).

1. Click theOtherwise button for that row to open theOtherwise dialog box and select Use Previous
Step Result or select System Account directly in the right pane.

2. From theAccount Named dropdownmenu, select the system account to use for the operation’s
credentials, and choose the property you want to extract from the system account (for example,
password/username). This allows the flow to perform tasks that require these account credentials, while
protecting the credentials from exposure by keeping them hidden behind the system account name. For
more information about system accounts, see "Configuring System Accounts" on page 132.

3. In the Credential Type field, select Username orPassword.

Reference Material
Input Inspector > Toolbar

GUI item Description

Add input Adds a new input row. Type the name of the new input and click OK.
The new input's attributes are assigned with default values.

Delete row Deletes the selected input row.

Move up Moves the selected input row higher in the list.

Move down Moves the selected input row lower in the list.

Cut

(or Ctrl + X on the keyboard)

Removes the selected input row from its current location. Use the
Paste option to place the row in a new location.
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Note: If you try to remove a required input, Studio automatically
marks it as optional and it appears in italics. You can restore the
input by marking it as Required again.

Copy

(or Ctrl + C on the keyboard)

Copies the selected input row. Use thePaste option to place the copy
in a new location.

Paste

(or Ctrl + V on the keyboard)

Pastes the copied/cut input row at the current location. If the input
name already exists, a new input is added with the same namewith an
addition of (Copy 1). For example, if you copy and past e an input
named host, you will have two inputs: host and host (Copy 1).

Note: You can also cut, copy and pastemultiple inputs between steps, flows or operations. Select
additional inputs by holding down theCtrl key and clicking on the row.

Input Inspector > Inputs tab
The Inputs tab in the Step Inspector is where you specify how and when a step in a flow obtains the data that
it needs.

GUI item Description

Input Displays the name of the input.

Sensitive Data Makes this input hidden in the Central user interface and in the Studio
internal and remote debugger. If this check box is selected, the input
value will be encrypted in Central and Studio, will be displayed as
asterisks and will not be persisted

This flag is transient, i.e.,assignment from a sensitive variable will also
make the assigned variable sensitive. This transitivity is only seen
during runtime execution, and is not reflected in the Studio user
interface.

When used in scriptlets, sensitive data is retrieved as encrypted.

Sensitivity is also retained when using expressions for assignment. For
example, ${input1}.

Required Makes this input mandatory.

Type From the Type list, specify how the input gets its value. The choices
are:

l Single Value
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l List of Values - to run an operation against multiple targets

Assign From Specifies where the input gets its value from. From theAssign From
list, select an input from which to take the value or type in a value
directly in this field.

By default, <not assigned> appears in this field.

Note: In some situations, the flow level input will not appear in
Central:

l If you have not assigned a value toAssign From and you have
set Otherwise toUse Constant

l If the value of Assign From is different from the flow input
name

Otherwise Shows what action should occur if the flow variable that you specified
in the Assign From column does not exist or has no value stored in it.

Click to open theOtherwise dialog box or fill in the fields in the right
pane.

Assign To Select the flow variable that you want to assign the input’s value to or
type in a value directly in this field.

By default, <not assigned> appears in this field.

Step Inspector > Inputs tab > Otherwise pane/Otherwise dialog box
TheOtherwise pane appears on the right side of the Input Inspector. In this pane, you define what action
should occur if the flow variable that you specified in the Assign From column does not exist or has no value
stored in it. Some of these fields also appear in the Otherwise dialog box. If youmake changes in the
Otherwise pane, theOtherwise dialog box is automatically updated accordingly and vice versa.

Otherwise Pane
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Otherwise Dialog Box
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GUI item Description

Input column Displays the name of the input.

Required column Makes this input mandatory.

Type column From the Type list, specify how the input gets its value. The choices
are:

l Single Value

l List of Values - to run an operation against multiple targets

Assign From column Specifies where the input gets its value from. From theAssign From
list, select an input from which to take the value.

Note: If you have not assigned a value toAssign From and
Otherwise is set as Use Constant, the flow level input will not
appear in Central.

If you have assigned a value toAssign From andOtherwise is
set as Use Constant, the flow level input will appear in Central.

Otherwise column Shows what action should occur if the flow variable that you specified
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in the Assign From column does not exist or has no value stored in it.

Click to open theOtherwise dialog box or fill in the fields in the right
pane.

Assign To column Select the flow variable that you want to assign the input’s value to.

Name Displays the name of the step (read only).

Input Type Displays the input type. May bemodified here.

Assign from Variable Enter or select the name of the flow variable that will be the source of
the input.

Otherwise Select what will occur if the flow variable specified in theAssign from
Variable box does not exist or has no value stored in it.

'Otherwise: <action>'
Configuration

Configure the details of what happens if the flow variable specified in
theAssign from Variable box does not exist or has no value stored
in it. This section varies, depending on which action is selected in the
Otherwise list.

Assign to Variable Select the flow variable that you want to assign the input’s value to.

Input Delimiter Enter the delimiter to be used to separate values in

Required Makes this input mandatory.

Validation Format Validates the input’s value with a system evaluator. Select a system
evaluator from the dropdown list.

For example, if you want to prompt the user to provide an IP address,
use the IP validation format. Studio will then check that the input
provided is in valid IP address format.

Record Under Makes the value available for diagnostics or auditing. This field is a
legacy field from OO 9.x.

You can select the item under which you want to record the input in the
database from theDomain Terms list.

Evaluating Input Data
Evaluators are used to validate inputs. For example:

l If the input is an email address, you can use an evaluator to check that the input is in the correct email
format.

l If the input must be a numeric value greater than or equal to 1, you can use an evaluator to check that this
is the case.

Studio has standard system evaluators for validating the following:

l Alphanumeric values
l Email
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l File name
l IP address
l Nowhite space
l Numeric values
l UUID
l Phone number
If there is no standard system evaluators for what you need to validate, you can create additional system
evaluators. For information about creating system evaluators, see "Configuring System Evaluators" on page
135.

Note: The default data evaluator for phone numbers supports only the North American telephone number
format (1-nnn-nnn-nnnn) for calling from within North America. To validate other regional phone-number
formats, you will need to create a system evaluator for this.

Evaluators use the following:

l Simple operators such as =, !=, Begins with, Contains, Match All Words, and Match At Least One
Word and so on

l Regular expressions – for more information, see "Using Regular Expressions in a Flow" on page 256
l Scriptlets – for more information, see "Using Scriptlets in a Flow" on page 252

What do you want to do?
Use an evaluator to validate an input
While creating an input in the Input Editor, you can validate the input’s value, by selecting an evaluator from
theValidation Format list.
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Record Under: Makes the value available for diagnostics or auditing. This functionality is not currently
supported.

For more information about creating an input, see "Creating Input" on page 166.

Creating Transitions
You connect any two steps in a flow with a transition. A transition starts from one of a step’s responses
(represented by a response icon, such as Success or Fail) and goes to another step. Every response in a
flow must have a transition either to a subsequent step or to a return step that returns an outcome for the
entire flow and ends the flow.

More than one response can be connected to a given step. For example, several failure responses often are
connected to a single failure return step.

For information about setting the responses for an operation, see "Setting Responses" on page 192.

Note: In HPE OO 10.00 and later, transition descriptions are limited to 1000 bytes.
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Best Practices
l As much as possible, transition lines should not cross.
l Use straight transitions, if possible. You should only use curved transitions when this is necessary for the
flow layout.

l When possible, position steps so that transitions are horizontal, vertical, or at a 45-degree diagonal.
l Collapsemultiple transitions from one step to another so that a single line represents all of the transitions.
l Position transition labels so that they do not overlap the step labels or each other.
l Rename transition labels if this will make the flow clearer to another user.
l Place transition labels toward the outside of the flow when possible. For example, if two steps are at the
top of the flow canvas, the transition labels should be above the transition lines. If the steps are at the
bottom of the canvas the labels should be below the transition lines.

What do you want to do?
Add a transition between steps
1. Open the flow on the authoring pane in Studio.
2. On the step that you want to connect to the next step, click either the response name or the icon that

represents one of the responses, and drag to the destination step for that response.
3. Double-click the transition. The Transition Inspector opens.
4. (Optional) To change the transition’s name, in theName box, type the new name.
5. In theDescription box, type a description that explains what happened in the preceding step that

caused this transition to be followed. This description will appear in theResults Summary area in HPE
OOCentral, when the flow is run.

Note: A transition's description relates to the step from which the transition originated. For example,
themessage "localhost successfully pinged" describes what happened in the step "Ping Target
System", even though it was written for the transition that follows the step.

Create a description that includes a flow variable
You can use flow variables in the description to store changeable information. For example, to identify a
server whose name is stored in the servername flow variable, you could type: “Server ${servername} is
available for connection".

1. Create a transition between two steps.
2. Double-click the transition to open the Transition Inspector.
3. In theDescription box, type a description that includes a flow variable that contains data that came

from the step’s operation or elsewhere in the flow run. The referencemust use the format ${flow
variable name}.

For example, a step that carries out a ping command can save the host machine’s name into a flow
variable called host. To use this value in the transition description you can reference it with the syntax
${host}. The description in the transition from the success responsemight read “Successfully pinged
${host}.” When this is run in Central against a host named “server1”, the summary description will read
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“Successfully pinged server1.”

Limit who can run the step beyond the transition (gated transition)
Gated transitions let you control who can continue with the flow beyond the transition, by restricting access to
the next step to users who belong to a particular role. If someone who is not amember of this role group tries
to run the flow, the flow will stop, and the user will have the choice of handing off the flow to another user or
canceling the flow.

Gated transitions are colored red.

1. Create a transition between two steps.
2. Double-click the transition to open the Transition Inspector.
3. Select theCheck user’s groups before proceeding check box.
4. From theRequired Role Alias list, select the role that the user must be assigned in order to continue

running the flow.

Require that the run is handed off following the transition
You can set a transition to hand off the flow to another person. This might be necessary if the next step
requires information from a different user.

During the flow run, a hand-off transition opens a new email message with the URL of the flow included in the
body of themessage. The person running the flow can address the email message to the person taking over
the flow and then send themessage. After the recipient receives themessage, they can continue running the
flow.

1. Create a transition between two steps.
2. Double-click the transition to open the Transition Inspector.
3. Select theHand-off flow after this transition check box.

Count the completion of the transition in the flow’s ROI value
You can associate a value with a transition in the flow. These values represent the return on investment (ROI)
value of each transition. When the flow is executed, these values are recorded, based on the transitions
actually made. Administrators will be able to view reports, in Central, which display the ROI values of the
flow, giving it valuable business statistics.

1. Create a transition between two steps.
2. Double-click the transition to open the Transition Inspector.
3. In the Transition ROI Value box, enter a numerical value for the transition.

Add a curve-defining point to create a curved transition
You can add a curve-defining point to reshape a transition from a straight line to a curve. This helps to tidy up
your flow or to separate transitions that are stacked.
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1. Position your mouse over the transition where you want to place the curve-defining point.
2. To create the point, hold down SHIFT and click themouse.
3. Drag the point until the transition curves the way you want it to.

Remove a curve-defining point
Position the cursor over the curve-defining point, hold down SHIFT, and click themouse.

Move a transition name
Click the transition name and drag it to another location.

Break a transition between two steps
To break an existing transition between two steps, select the transition and press the Delete key on the
keyboard.

Reference Material
Transition Inspector
The Transition Inspector is where you specify the details of a transition.
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GUI item Description

Transition Name By default, the transition name is the same as the name of the
response where it originated (success, failure, and so on), but you can
change the transition name.

Check user's group before
proceeding

Select this check box to create a gated transition, which will only let a
user proceed with the next step if they are assigned to the required
role alias.

Required Role Alias Select the role alias that the user must be assigned to in order to
continue running the flow.

Hand-off flow after this
transition

Hand-off transitions are not supported in the current version.

Select this check box to hand off the flow to another person after the
transition.

Transition ROI Value Enter a value for the transition, so that if the transition is followed
during a flow run, its value is added to the value of the flow for that run.

Description Type a description that explains what happened in the preceding step
that caused this transition to be followed. The description appears in
theResults Summary area in HPE OOCentral.

Setting Responses
A response is one of a number of possible outcomes of an operation or flow.
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The four types of response are:

l Resolved – This is the standard response for an operation or flow that runs correctly.

l Diagnosed – This response indicates that an operation or flow has determined what a problem is and
has opted not to take action on it other than notification.

l No Action Taken – This response is used when an operation or flow gathers data but cannot
determine any diagnosis or remediation.

Note: An operation that is intended solely to gather data should returnResolved when it is

complete, rather thanNo Action Taken .

l Error – This response is used if the step or flow fails to run. For example, because of bad input or
failure to reach a system.

In some cases, an operation or flow may havemultiple responses of the same type. For example, an SQL
query operationmay have the following outcomes:

l More items

l No more items

l Failure
You can add, delete, andmodify the responses in an operation or flow. You cannot modify the responses on a
step, with the exception of return steps. For more information about return steps, see "Creating Return Steps"
on page 235.

Response Rules
A rule enables you to limit the response so that it only occurs when a particular condition of the operation’s
result is true. The rule compares a value that you specify with a value in a field of an operation’s raw results.

For example, you can create a rule that will only give aSuccess response if the results include a value
that is greater than 1.

If you createmore than one rule for a response, then all the rules for that responsemust evaluate to true for
the response to be chosen.

Responses are evaluated in the order in which they are listed on the operation’s Responses tab. The first
response whose rule or rules evaluate to true is the response chosen. So if the port open response’s rule
evaluates to true, then that is the response chosen, even if the rule for port listening would also evaluate to
true. The order of responses can be very important for obtaining themost helpful outcome for your flow.
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What do you want to do?
Add a response to an operation or flow
1. Click theResponses tab of the operation/flow.

2. Select the row that you want the new response to follow. For example, if you select the first row, the new
response will appear on the second row.

3. Click Add Response and then type a name for the new response.
4. Tomake a response the one chosen if an operation fails to execute, select the check box in theOn-Fail

column for that response.
5. To identify a response as the default response, select the check box in theDefault column. The default

response is the one chosen if none of the responses’ rules evaluate to true.
6. In the Type column, select the type of response:

l Resolved:

l Diagnosed:

l No action:

l Failure:
This determines which response icon will be shown on the operation, when it is used to create a step.

7. To create a rule for the response, at the right end of the response’s row, click the right-pointing arrow .
For more information, seeCreate a rule for the response, below.

Create a rule for the response
A rule enables you to limit the response so that it only occurs when a particular condition of the result is true.

1. Create a new response in an operation.
2. In the response rule editor, click Add.

The new rule appears.
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3. In theApply Rule to Field column, select the results field whose value you want to test a rule against.
The result fields you can test include the result’s exit code, output string, error string, failuremessage,
and timed-out true or false.

Note: To display more information on these result fields, click theDescription tab.

To see what the values for these fields are, test the operation in a flow, using the Studio Debugger.
In the Debugger, when you execute a flow, you will find the results for any step in the Step Result
Inspector. For more on the Debugger, see "Testing and Debugging a Flow" on page 267.

4. In theRule Type column, select the comparison or match that you want to test the field value with.

l Select a simple operator such as =, !=, Begins with, Contains, Match All Words, and Match At
Least One Word and so on

l Select Regular Expression to create a regular expression.

l Select Scriptlet to create a scriptlet.

l Select Reference to create a reference to a shared rule.

5. In theRule Text column, type the text to use in the test.

Filter and test a response rule
In the Rule Details Editor, you can:
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l Specify the rule in greater detail, including the use of rules, filters, regular expressions, or scriptlets.
l Test the rule as you develop it

1. To open the Rule Details Editor, click the right-pointing arrow at the right end of the rule’s row.

Note: If you chooseScriptlet as the rule type, the Rule Details Editor includes a scriptlet editor. For
more information on creating scriptlets, see "Using Scriptlets in a Flow" on page 252.

If you chooseRegular expression as the rule type, the Rule Details Editor includes a regular
expression editor. For more information on creating regular expressions, see "Using Regular
Expressions in a Flow" on page 256.

2. To use a different rule type, select it from theRule Type list.
3. To filter the result before applying the rule, click Filter Result Before Applying Rule and, in the Filter

Editor, create the filter.
Creating a filter for a response rule is the same as creating a filter for an output or result. See "Filtering
Output and Results" on page 215.

4. For most of the rule types, in the Text box, type the text that you want to test comparison with and, if you
want to ignore case, select the Ignore Case check box.
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ForRegular Expression rules, specify the regular expression and its application as you do when
creating aRegular Expression filter for operation results. For information, "Using Regular Expressions
in a Flow" on page 256.
The results box displays the results of the test: it displays eitherPattern Matches orPattern Does Not
Match and highlights thematching text.

5. To work on another rule for the operation’s response, click the up or down arrow next toResponses
Summary.

Note: In a rule, when you use amathematical comparator (such as =, !=, <, or >) in an evaluation of a
string that starts with a number, the comparator compares only the numerical portion of the string. For
example, if you compare “123” with “123Test” using != (does not equal), the evaluation would be “false”,
although “123” is clearly not the same as “123Test”. You can work around this issue, however, by
comparing the strings with theNot Exact Match evaluator.

Add a response to a flow
When you create responses for a flow, youmake these responses available for return steps in the flow.

For example, if the outcome leading to anError return step is not a failure in an operation but a result that did
not meet a required threshold, then youmight want to create a new response for theError return step, which
reflects this outcome, so that it will appear as Error: threshold not met.

1. Open theProperties sheet for the flow.
2. Click theResponses tab.
3. Click Add Response and then, in the text box that appears, type the name of the response. For

example, threshold not met.
4. Click OK.
When you create anError return step for the flow, you will be able to select threshold not met as a
response. For more information about return steps, see "Creating Return Steps" on page 235.

Delete a response from an operation or flow
1. Open theProperties sheet for the operation or flow.
2. Click theResponses tab.
3. Select the response, and then click Remove Response.

Reference Material
Flow Properties sheet > Responses tab
TheResponses tab in a flow's Properties sheet is where you can see the possible responses to be available
for return steps in a flow.
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GUI item Description

(Add Response) Adds a new response row.

(Remove
Response)

Removes the selected response row.

Click to move the selected response up or down in the list.

Type The type of response (read-only):

l Success / resolved:

l Diagnosed:

l No action:

l Failure:

Operation Properties sheet > Responses tab
TheResponses tab in an operation's Properties sheet is where you specify the possible responses for an
operation.
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GUI item Description

Add Response Adds a new response row.

Remove Response Removes the selected response row.

Click to move the selected response up or down in the list.

Default Select to identify a response as the default response. The default response is the
one chosen if none of the responses’ rules evaluate to true.

On-Fail Select to make a response the one chosen if an operation fails to execute.

Type Select the type of response:

l Success / resolved:

l Diagnosed:

l No action:

l Failure:

Rules Displays any rules that have been created for the response.

Click to display the Rule Editor, to create a rule for the response.

Operation Properties sheet > Responses tab > Rule Editor
The Rule Editor is where you limit the response so that it only occurs when a particular condition of the result
is true.

For example, you can create a rule that will only give aSuccess response if the results include a value that is
greater than 1.

GUI item Description
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Add Response Adds a new response row.

Remove Response Removes the selected response row.

Click to move the selected response up or down in the list.

Apply Rule to Field Select the results field whose value you want to test a rule against. The result
fields you can test include the result’s exit code, output string, error string, failure
message, and timed-out true or false.

Rule Type Select the comparison or match that you want to test the field value with.

Rule Text Type the text to use in the test.

Click to open the Rule Details Editor, to test and filter the rule.

Operation Properties sheet > Responses tab > Rule Editor > Rule Details Editor
The Rule Details Editor is where you can test and apply filters to a rule.

Rules enable you to you limit a response so that it only occurs when a particular condition of the result is true.
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GUI item Description

Rule Type Displays the rule type that was selected in the Rule Editor and enables you to
select a different rule type.

Filter Result Before
Applying Rule

Click to display the Filter Editor, in order to filter the result before applying the
rule.

Text Type the text that you want to test comparison with.

Ignore Case Select to ignore whether the text is in upper or lower case.

Results box Displays the results of the test: Displays eitherPattern Matches orPattern
Does Not Match and highlights the text that matches.

Copy Copy data within the results box.

Paste Paste data into the results box.
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Cut Cut data within the results box.

Clear Clear data within the results box.

Quick Command Type a command that generates the data on which you want to test the filter. The
output of the command appears in the results box.A

Flow Properties sheet > Responses tab
TheResponses tab in an flow's Properties sheet is where you specify the possible responses to be
available for return steps in a flow. For example, Error: threshold not met.

GUI item Description

Add Response Adds a new response row.

Remove Response Removes the selected response row.

Click to move the selected response up or down in the list.

Operation Properties sheet > Responses tab
TheResponses tab in an operation's Properties sheet is where you specify the possible responses for an
operation.

GUI item Description

Add Response Adds a new response row.

Remove Response Removes the selected response row.
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Click tomove the selected response up or down in the list.

Default Select to identify a response as the default response. The default response is the
one chosen if none of the responses’ rules evaluate to true.

On-Fail Select to make a response the one chosen if an operation fails to execute.

Type Select the type of response:

l Success / resolved:

l Diagnosed:

l No action:

l Failure:

Rules Displays any rules that have been created for the response.

Click to display the Rule Editor, to create a rule for the response.

Operation Properties sheet > Responses tab > Rule Editor
The Rule Editor is where you limit the response so that it only occurs when a particular condition of the result
is true.

For example, you can create a rule that will only give aSuccess response if the results include a value that is
greater than 1.

GUI item Description

Add Response Adds a new response row.

Remove Response Removes the selected response row.
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Click tomove the selected response up or down in the list.

Apply Rule to Field Select the results field whose value you want to test a rule against. The result
fields you can test include the result’s exit code, output string, error string, failure
message, and timed-out true or false.

Rule Type Select the comparison or match that you want to test the field value with.

Rule Text Type the text to use in the test.

Click to open the Rule Details Editor, to test and filter the rule.

Operation Properties sheet > Responses tab > Rule Editor > Rule Details Editor
The Rule Details Editor is where you can test and apply filters to a rule.

Rules enable you to you limit a response so that it only occurs when a particular condition of the result is true.
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GUI item Description

Rule Type Displays the rule type that was selected in the Rule Editor and enables you to
select a different rule type.

Filter Result Before
Applying Rule

Click to display the Filter Editor, in order to filter the result before applying the
rule.

Text Type the text that you want to test comparison with.

Ignore Case Select to ignore whether the text is in upper or lower case.

Results box Displays the results of the test: Displays eitherPattern Matches orPattern
Does Not Match and highlights the text that matches.

Copy Copy data within the results box.

Paste Paste data into the results box.

Cut Cut data within the results box.

Clear Clear data within the results box.

Quick Command Type a command that generates the data on which you want to test the filter. The
output of the command appears in the results box.

Creating Outputs and Results
One of the ways to capture data for use in a flow is via a step result. There are two ways to assign this data:

l When the output in a result is assigned to a flow variable, you can pass it as data to other steps in the
flow.

l When the output in a result is assigned to a flow output field, you can pass it as data to a parent flow.
There are a number of steps in this process:

1. Set up the outputs for an operation, including the primary output.
See "Setting Operation Outputs" below.

2. When you use the operation for a step in a flow, you decide which of the operation outputs you want to
use as step results—which ones you want to assign to flow variables or flow output fields.
See "Setting Step Results" on page 209.

3. (Optional) It is possible to narrow an output or result to amore highly focused selection by creating
filters.
See "Filtering Output and Results" on page 215.

Setting Operation Outputs
The first stage in setting up flow outputs is to set up the outputs in the operation. After this is done, when you
(and other flow authors) use this operation in a flow, you will be able to assign outputs to flow variables.
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If an operation contains sensitive data that you would like to hide from the end-user, you can define this at the
step level. See "Setting Step Results" on page 209.

Types of Operation Output
The different kinds of operation output include:

l Raw result is all of the operation’s return code, data output, and error string.
The raw output is not directly visible in Studio, except as the raw result of a step that was created from the
operation.

l The primary and other outputs are portions of the raw output—for example, success code, output string,
error string, or failuremessage—that you specify as an output.
l The primary output is the output used to populate the step's primary result. The primary output
supplies a value to an input whose assignment is Previous Step’s Result. You can see the primary
output in the Outputs Summary above the list of outputs in the Outputs tab.

l A secondary output in an operation is another output, in addition to the primary output.

Tip: You can narrow an output to amore focused selection by creating one or more filters for the output.
See "Filtering Output and Results" on page 215.

Examples of Operation Output
Most operations have outputs that are specific to the operation. However, you will frequently encounter the
following outputs when working with operations in the Library’s Accelerator Packs, Integrations, and
Operations folders:

l returnResult
When you see “returns:” with no field named, this is usually the primary output. The primary output is also
accessible viaResultwith a capital R (which is universal).

l response (or returnCode)
A code or string used to determine the response the operation will take.

l failureMessage
An internal output provided by the infrastructure. If an operation returns a failure, this output provides the
exception. Note that many operations do not use this output.

What do you want to do?
Specify the primary output for an operation
When you set up an operation, you can specify its primary output. Once you have created a primary output,
you can change its source, but you cannot return to having no primary output.

Note that this can only be done at step level.

1. Right-click the operation in theProject pane and select Properties.

Note: To openmultiple operations, select them using the SHIFT or CONTROL keys, right-click,
and select Open.
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2. Select theOutput tab.
3. From theExtract Primary Output from Field list, select a source field. For example, FailureMessage.

Tip: For information on the data provided in each output field, click the operation’s Description tab.

Add a secondary output for an operation
A secondary output in an operation is another output, in addition to the primary output.

1. Right-click the operation in theProject pane and select Properties.
2. Select theOutput tab.
3. Click Add Output.
4. Type the name of the output.
5. From theOutput Field list, select the field from which the output gets its data.

6. To create filters for the output data in the secondary output, click the right-pointing arrow at the end of
the row.
For information on creating filters, see "Filtering Output and Results" on page 215.

Change the field from which an output gets its data
1. Open theProperties sheet for the operation and select theOutput tab.
2. To change the field for the primary output, click the downward-pointing arrow to the right of theExtract

Primary Output From Field box, and then select the desired field from the list.
3. To change the field for a secondary output, click in theOutput Field column of the output’s row, and

then select the desired field from the list.

Delete an output from an operation
1. Right-click the operation in theProject pane and select Properties.
2. Select theOutputs tab.

3. Select the output you want to delete and click ..

Cut, copy and paste an output
1. Open theProperties sheet for the operation and select theOutputs tab.
2. Select an output to cut/copy.

3. From theOutputs toolbar, click or .
4. Move to the row above which you want to paste the result.

5. Click .
6. Save the operation.

Note:

l You can copy outputs to other operations.
l You can paste outputs with same name. Studio automatically names the new output <output> (Copy
1).
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Reference Material
Properties sheet > Outputs tab
TheOutputs tab in theProperties sheet is where you specify the primary and secondary outputs in an
operation.

GUI item Description

Extract Primary Output From
Field

Select the field from which the primary output will get its data

Edit Filters Displays the Filter Editor for the primary output

Add Output Adds a new output row

Remove Output Removes the selected output row

Output Field Select the field from which this secondary output will get its data

Displays the Filter Editor for the output in the row

Properties sheet > Outputs Toolbar

GUI item Description

Add output Adds a new output row. Type the name of the new output and click OK.
The new output's attributes are assigned with default values.

Delete output Deletes the selected output row.

Cut

(or Ctrl + X on the keyboard)

Removes the selected output row from its current location. Use the

option to place the row in a new location.

Copy

(or Ctrl + C on the keyboard)
Copies the selected output row. Use the option to place the copy
in a new location.
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Paste

(or Ctrl + V on the keyboard)

Pastes the copied/cut output row at the current location. If the output
name already exists, Studio automatically names the new output
<output> (Copy 1).

Setting Step Results
Operations produce a variety of outputs, but outputs are not automatically retained in the flow. If they were,
this could affect performance, by slowing down the flow with unnecessary data.

In theResults tab of the Step Inspector, you specify the results that you need and you canmark the
operation's raw results as sensitive. Results contain output from the operation and additional information that
you want to propagate.

You can alsomark a result as sensitive data.

You can store results in two ways:

l Create flow variables, which are accessible to operations, transitions, and prompts in the same flow.
For more information, see "Working with Variables" on page 230.

Example: A step called LocalPing determines whether a target host is available and stores the
output of the ping operation in a result calledPingOutput. This creates a flow variable called
PingOutput, which can be used in later steps.

The next step, calledDisplay, displays thePingOutput variable to the user. The prompt text in this
step is set up as Ping Results: {PingOutput}.

l Create output fields, which are accessible to operations, transitions, and prompts in the parent flow, if
the flow is used as subflow (a step in another flow). For more information, see "Creating a Subflow Within
a Flow" on page 238.

Example: A parent flow includes a step that contains theWindows Health Check flow as a subflow.
The results of theWindows Health Check flow are stored as value in an output field called
HealthCheckOutput and are available for themain flow.

Themain flow includes aSend Mail operation, which displays the value of theHealthCheckOutput
output field in the body of the email.

There are two kinds of step result:

l Raw result is all the raw data that was returned from an operation executed in the context of a flow. The
step’s raw and primary results come from the underlying operation’s raw output and primary output.

l Other results, which you create on theResults tab of the Step Editor. In the Step Inspector, you can
create and specify secondary results.

Before setting up the flow results in a step, make sure that the primary output has been set up for the relevant
operation. See "Setting Operation Outputs" on page 205.

For security purposes, theremay be cases in which you need to hide the results of an operation. For example,
an operationmay generate a random password, and you want to hide this password from the end user. You
can specify this in the Sensitive Data area. You can apply this functionality on an individual step, not only on
an entire operation.
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Tip: You can narrow a result to amore highly focused selection by creating one or more filters for the
output. See "Filtering Output and Results" on page 215.

What do you want to do?
Create a primary result in a step
The primary output is set in the operation. The primary output supplies a value to an input whose assignment
is Previous Step’s Result.

In a step, you can decide to capture this primary output in a flow variable (to be used in other steps in the flow)
or a flow output field (to be passed to a parent flow).

1. Double-click a step in the authoring pane.
2. Select theResults tab and click Add Result.
3. In theName column, enter a name for the result. Press the Return key on your keyboard. This namewill

be used as the name of the flow variable or flow output field.

Note: Do not use "Result" for the result name.

4. From the list in the From column, select the primary output as the source for the result.

For example, youmight select Result Field: returnResult, which is the primary output for that
operation.

For information about setting the primary output, see "Setting Operation Outputs" on page 205.

Create a secondary result in a step
1. Double-click a step in the authoring pane.
2. Select theResults tab and click Add Result.
3. In theName column, enter a name for the result. Press the Return key on your keyboard. This namewill

be used as the name of the flow variable or flow output field.
4. From the From list, select the source for the result.
5. From theAssign To list, decide where the value will be stored:

l To store the value in a flow variable, select Flow Variable

l Tomake the value available to a parent flow, select Flow Output Field

6. From theAssignment Action list, select the appropriate action:
l OVERWRITE – Replace the current value of the flow variable or flow output field with this value.

l APPEND – Place this value at the end of the current value of the flow variable or flow output field.

l PREPEND – Place this value in front of the current value of the flow variable or flow output field.

l Use one of the four arithmetic assignment actions, ADD, SUB,MULTIPLY, andDIVIDE, to
arithmetically modify the current value of the flow variable or flow output field.
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For example, if the step result is 3.14, and you selectMULTIPLY, the effect is to multiply the
current value of the flow variable or flow output field by 3.14.

7. To create filters for the output data in the secondary result, click the right-pointing arrow at the end of
the row.
For information on creating filters, see "Filtering Output and Results" on page 215.

Hide the operation's raw result
1. In the Sensitive Data area, select theHide the operation's results check box. This will hide the entire

raw results of the operation, andmake this information displayed as asterisks in the Studio and Central
user interface.
After this check box is selected, the operation's primary output will also be hidden and displayed as
asterisks in the Studio and Central user interface.
When used in scriptlets, sensitive data is retrieved as encrypted.
For example, if you select theHide the operation's results check box for the step Evaluate
Expression, it is displayed in Studio as shown below, and similarly in Central:

Hide the step result
1. Double-click a step in the authoring pane.
2. Select theResults tab.
3. Find the step result that you want to hide from the list of step results.
4. In the Results tab, select theSensitive Data check box.
This makes the result hidden in the Central user interface and in the Studio internal and remote debugger. The
result value will be displayed as asterisks and will not be persisted to the OO database.

This flag is transient, i.e.,assignment from a sensitive variable will alsomake the assigned variable sensitive.
This transitivity is only seen during runtime execution, and is not reflected in the Studio user interface.

If a result is assigned from a sensitive input or sensitive result, it will also be sensitive. If a result is assigned
from an operation raw result that is hidden, youmust mark it as sensitive if you want to hide it in the Studio
and Central user interface.

When used in scriptlets, sensitive data is retrieved as encrypted.
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Sensitivity is also retained when using expressions for assignment. For example, ${input1}.

Hide the step raw result from the end-user
1. Double-click a step in the authoring pane.
2. Select theResults tab.
3. In the Sensitive Data area, select Hide Operation Raw Results.
4. Save the step.

Note: If the step contains a sub-flow, there is noHide Operation Raw Results section.

Cut, copy and paste a result
1. Double-click a step in the authoring pane.
2. Select theResults tab and select a result to cut/copy.

3. From theResults toolbar, click or .
4. Move to the row above which you want to paste the result.

5. Click .
6. Save the step.

Note:

l You can copy step results to another step results pane only. Flow outputs can be copied to other flows
or operations.

l You can paste step results with same name. The new result will be identical to the existing result.

Delete a result from a step
1. Double-click a step in the authoring pane.

2. Select theResults tab and from the Results toolbar, click .
3. Save the step.

Change the field from which a result gets its data
1. Double-click a step in the authoring pane.
2. Select theResults tab.
3. Click in the From column of the output’s row, and then select the desired field from the list.
4. Save the step.

Change the operation linked to a step
You can select a different operation to be linked to a step. After selecting the new operation, you can
determine whether to overwrite existing inputs with the inputs of the new operation or to merge them with the
existing inputs.

1. Double-click a step in the authoring pane.
2. In the Step Inspector, select theAdvanced tab.

You can see the location and name of the current operation. For example:
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3. Click theSelect button. The Select Operation window opens:

4. Browse to the new operation.
5. To add the new operation's inputs to the current inputs, selectMerge with the target items' inputs.

Note: If an input name already exists,the original input remains and is not overwritten.

6. To delete the current inputs and add only the new inputs, select Overwrite the target items inputs.
7. Click OK.
8. Save the step.

Reference Material
Step Inspector > Results tab
TheResults tab in the Step Inspector is where you specify which outputs will be saved into flow variables or
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made available for parent flows.

GUI item Description

Name Enter a name for the result. This namewill be used as the name of the flow
variable or flow output field.

Sensitive data Makes this result hidden in the Central user interface and in the Studio internal
and remote debugger. The result will be displayed as asterisks and will not be
persisted to the OO database.

Add Result Adds a new result row.

Remove Result Removes the selected result row.

From Select the source for the result.

Assign To Select where the result value will be stored:

l To store the value in a flow variable, select Flow Variable
l Tomake the value available to a parent flow, select Flow Output Field

Assignment Action From theAssignment Action list, select the appropriate action:

l OVERWRITE – Replace the current value of the flow variable or flow output
field with this value.

l APPEND – Place this value at the end of the current value of the flow variable
or flow output field.

l PREPEND – Place this value in front of the current value of the flow variable
or flow output field.

l Use the arithmetic assignment actions ADD, SUB,MULTIPLY, andDIVIDE
to arithmetically modify the current value of the flow variable or flow output
field.

For example, if the step result is 3.14, and you selectMULTIPLY, the
effect is to multiply the current value of the flow variable or flow output
field by 3.14.

Displays the Filter Editor for the result in the row.

Note: After youmark a step result as Sensitive Data, it remains sensitive during the whole run (and
therefore encrypted).The step result passes this behavior to every input/step result that is assigned from
it.

Studio Authoring Guide
Authoring a Flow – Basics

HPE Operations Orchestration (10.60) Page 214 of 350



Step Inspector > Advanced tab
TheAdvanced tab in the Step Inspector is where you specify where you can change the source operation
that the step is based on.

GUI item Description

This step saves the
raw output

Select this check box if you need to save all of the step's raw results.

Link to Displays the source operation that the step is based on.

Location Displays the location of the source operation that the step is based on.

Select Opens the Select Source Operation dialog box, where you can navigate to and
select the operation that you want to base the step on.

Filtering Output and Results
You can create filters to extract andmodify parts of an operation’s output or a step's result.

For example, if you only want themaximum, minimum, and average round-trip times for a ping operation to a
server, you can isolate and extract all three pieces of information from the operation’s raw output by filtering
the raw output into three outputs.

What do you want to do?
Create a filter
1. Open the Filter Editor. This step varies, depending on what you are filtering:

l To filter an operation’s primary output, open the operation’s Properties sheet, click theOutputs tab,
and then click theEdit Filters button.

l To create a filter for an operation’s secondary output, open the operation’s Properties sheet, click the
Outputs tab, and then click the right-pointing arrow at the end of the output row.

l To create a filter for a step’s secondary result, double-click the step in the authoring pane, click the
Results tab, and then click the right-pointing arrow at the end of the result row.

2. In the Filter Editor, click theAdd button.
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Note: You can addmultiple filters to an output or result.

3. From theSelect Filter list, select the type of filter.

4. In theDetails area in the upper-right of the Filter Editor, configure the filter. See Filter Options to see the
options for different filters.

Test a filter with data from a command line
To test, a filter, paste some data into the Test Filter Input box. If this data can be generated by a local
command-line command, do the following:

1. Open the Filter Editor for an output or result.
2. Click Clear to clear the Test Filter Input box.
3. Click Quick Command.
4. Type a command that generates the desired data.
5. Click OK. The output of the command appears in the Test Filter Input box.
6. Do one of the following:

l Click Test All Filters

l Select the filters you want to test and click Test Selected Filters

The filters are applied to the data in the Test Filter Input box (in top-to-bottom order), and the filtered results
appear in the Test Output box.

Test a filter with data from the debugger
If the data you need is produced by means that you cannot reproduce with a simple command-line command,
copy the data from the debugger and paste it into the Test Filter Input box:

1. Open the Filter Editor for an output or result.
2. Click Clear to clear the Test Filter Input box.
3. Run the flow in the debugger.
4. Highlight the relevant step.
5. In theStep Result Inspector pane, copy the contents of theRaw Result tab.
6. In the Filter Editor, paste the contents into the Test Filter Input box.
7. Do one of the following:
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l Click Test All Filters

l Select the filters you want to test and click Test Selected Filters

The filters are applied to the data in the Test Filter Input box (in top-to-bottom order), and the filtered results
appear in the Test Output box.

Filter a different output or result
While you have the Filter Editor open, you can click the upward- or downward-pointing arrows besideOutputs
Summary to create a filter for a different output or result.

Use a system filter in an output or result
1. Open the Filter Editor of the output or result on which you want to use the system filter.
2. In theProjects pane, expand theConfiguration andSystem Filters folders.
3. Drag the filter that you want to use from theSystem Filters folder to the Filter list in the Filter Editor.

Save a filter for reuse as a system filter
You can take an existing filter in an operation and save it as a system filter. The resulting system filter is
independent of the operation for it was created and can be reused in any output or result.

For more information, see "Configuring System Filters" on page 141.

Filter Options
Diff Case
A Diff Case filter changes all the characters in the string either to upper case or to lower case. If you leave the
To Upper Case check box cleared, the filter changes all the characters to lower case.

Extract Number
AnExtract Number filter extracts the first number found in the result. The filter treats an unbroken series of
integers as a single number. For example, theExtract Number filter would extract the number “123” from the
strings “123Test” or “Test123”.

Format
A Format filter attaches text to a result or output or replaces the original content of the result or output with
the text that you specify.
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1. In the Text box, type the text you want to attach to the result or use to replace the result.
2. From thePlace Input At list:

l To attach the text to the front of the existing text, select prepend

l To add the text to the back of the existing text, select append

l To replace the output with the text, select replace

Line Count
A Line Count filter outputs the total number of lines of the result.

Regular Expression
A Regular Expression filter filters the raw results using a regular expression (regex).

1. From theExpression Type list, select Java Style. Do not use the other styles; they have been
deprecated.

2. In theExpression Value box, type the regular expression.
3. For Filter Style, select Filter Entire Input or Filter Line-by-line, according to how you want the filter

applied to the raw results.
4. Tomake the regular expression not case-sensitive, select Ignore Case.
For more information about working with regular expressions, see "Using Regular Expressions in a Flow" on
page 256.

Remove Duplicate Lines
This filter finds lines that are identical and removes all but one of them.

To apply the filter only to duplicate lines that follow each other directly, select Consecutive.
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Replace
This filter replaces the first or last instance or all instances of one string with another string.

1. In the Find box, type the string to search for and replace.
2. From theReplace, select First, All, or Last, depending on which instances of the target string you want

to replace.
3. In theWith box, type the string to replace the target string with.
4. Tomake the search not case-sensitive, select the Ignore case check box.

Round Number
This filter rounds numbers up or down.

1. To specify the accuracy of the rounding, in theNumber of Decimal Places box, type the number of
decimal places the number should be rounded to.

2. ForRounding Type, specify in which direction the number should be rounded:
l Floor always rounds the number down

l Ceiling always rounds the number up

l Round rounds the number up if the last meaningful place is 5 or more, and down otherwise

Scriptlet
This filters data with a scriptlet that you create.

Studio Authoring Guide
Authoring a Flow – Basics

HPE Operations Orchestration (10.60) Page 219 of 350



1. To obtain scriptlet lines that you will need for the scriptlet to work as a filter, click Insert Template.
The template that is inserted is specific to the language that you chose and includes themost commonly
used commands for accessing flow variables, values of global variables, operation results, and inputs,
and for setting andmanipulating flow variable values and results.

2. To debug the scriptlet, click Check Script.
For more information about scriptlets, see "Using Scriptlets in a Flow" on page 252.

Select Line
This filter defines a line that you want to extract from the raw results.

1. From the Line Select Method list, select a criterion for the line that you’re interested in.
2. In theParameter box, type a string that the line contains.
3. From the Line Ending Type group, select one of the following:

l If the text that you’re filtering was generated on a Unix operating system (which ends lines with LF),
select Unix.

l If the text that you’re filtering was generated on aWindows operating system (which ends lines with
CR/LF), selectWindows.

l To enable the filter to accept either type of line ending, select Auto.
Auto is the default selection.

Select Range
This filter defines a string that you want to extract from the input data. The two criteria for defining the string
are its length in characters and the position of its first character from the start of the input data.
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1. In theStart box, type the zero-based start position of the string.
2. In the Length box, type the number of characters in the string.

Keep inmind that a new linemay count as one or two characters, depending on the operating system
from which you obtain the data you’re filtering.

Sort
This filter orders the lines of input data by the first character in each line.

1. To specify the direction of the sort:
l For ascending order, leave theAscending check box selected.

l For descending order, clear theAscending check box.

2. To order the data by ASCII order, select the Treat as Numbers check box.
Note that ascending ASCII order is roughly as follows, for English characters:

l White space

l Symbols

l Numbers

l Alphabetic characters

Strip
This filter strips characters from the beginning or end of the raw results.

Note: If this filter follows other filters, the characters are stripped from the beginning or end of the subset
of the raw results that was obtained by the processing of preceding filters.

1. From theStrip Method list, select how you want the filter to strip the raw results. You can specify the
following options for stripping the string that you specify in theCharacters to Strip text box:
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l All Characters Up To the string

l All Characters Up To And Including the string

l All Characters After the string

l All Characters After And Including the string

2. In theCharacters to Strip text box, type the string to find.

Strip Whitespace
This filter removes all the whitespace characters from the front and the end of the raw results.

Table
A table filter does not convert the raw results into a table, but enables you tomanipulate the raw results as if
they were a table, including sorting columns and selecting columns, rows, and blocks.

Note: Row numbering is 0-based (starts with 0 [0]), and column numbering is 1-based.

1. In theColumn Delimiter list, choose the character that will serve to divide the data into columns in a
meaningful way.

2. In theRow Delimiter list, choose the character that will serve to divide the data into rows in a
meaningful way.

Note: Two ormore consecutive whitespaces count as a single whitespace, so a columnmay be
occupied by data that you expected to find in a column to the right. For example, this behavior will
appear if you apply this filter to the output of a “dir” command-line commandwith whitespace
specified as the column delimiter.

3. To treat themembers of the first row as column headers, select First Row is Header.
4. To remove the first row, select Strip First Row of Result.
5. To sort on a column, type the (1-based) column number in theSort On Column box.

Tip: The value -1means do not sort on any column.

6. To specify ascending order, select theAscending box.
By default, the sort order is descending.

7. To select a row you want the filter to extract:
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l In theSelect Row box, type the (0-based) row number.

Tip: -1 selects all the rows in the data.

l In theSelect Width box, type the number of columns in that row that you want extracted.

Tip: -1 selects all the remaining columns in the data to the right of the column specified inSelect
Col.

8. To select a column you want the filter to extract:
l InSelect Col, type the column number.

Tip: -1 selects all the columns in the data.

l In theSelect Height box, type the number of rows in that column that you want extracted.

Tip: -1 selects all the remaining rows in the data below the row specified inSelect Row.

For example, to extract the first 5 rows of the 2nd through 4th columns, you would specify the following. In
these settings, the first two settings define the rows selected, and the second two settings define the rows
selected.

l InSelect Row: 0
l InSelect Height: 5
l InSelect Col: 2
l InSelect Width: 3

XML filters
XML filters enable you to parse XMLwithin a step, the XML being obtained from the step’s input or result,
rather than having to create a flow and pass the XML to one of the XML-processing operations in HPE OO
default content.

Using XML filters in an operation and using the XML-processing operations in default content differs in
several respects.

l There is the difference between accomplishing the task within an operation and using the infrastructure of
a flow to accomplish the task

l Filters within an operation have some limits that the XML-processing operations do not have. These
limitations are described in the following sections on the particular filters. Whether you choose to filter
input XMLwith a filter or an operationmay depend on how you obtain the XML.

Following are the XML filters:

l XMLGet Attribute
l XMLGet Element
l XMLGet Element Value
l XPath Query
For illustration of the XML filters, the examples reference the following XML example:

<?xml version="1.0" encoding="utf-8"?>
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<tickets>
<ticket id="1448" severity="3">

<customer firstName="John" lastName="Doe">
<volume>30000</volume>
<company>myOrg</company>
<position>CIO</position>
<contactInfo>

<email>jdoe@myorg.com</email>
<email>johnsSecondEmail@myorg.com</email>
<mobile>12065551212</mobile>
<description internal="1">Private contact info</description>
<description>Partial contact info</description>

</contactInfo>
<description>Our best customer</description>

</customer>
<details>

<description>A simple Test xml</description>
<comment user="john"> Initially raising ticket</comment>
<comment user="frank"> Problem diagnosed, not a real issue</comment>
<comment user="albert">ok, I'm going to close it.</comment>
<state>Closed</state>

</details>
</ticket>
<ticket id="1886" severity="5">

<customer firstName="Elaine" lastName="Benson">
<volume>50000</volume>
<company>herCompany</company>
<position>CEO</position>
<contactInfo>

<email>ebenson@herco.com</email>
<mobile>011445551212</mobile>
<description internal="1">Private contact info</description>
<description>Partial contact info</description>

</contactInfo>
<description>Our other best customer</description>

</customer>
<details>

<description>datastream bug</description>
<comment user="jack">Customer found bug.</comment>
<comment user="elsbeth">It is a third-party supplier bug.</comment>
<state>Closed</state>

</details>
</ticket>

</tickets>

XML Get Attribute
TheXML Get Attribute filter extracts the value for each of one or more instances of the attribute that you
specify. In the Filter Editor, you can control which instance of the attribute the filter is applied to by specifying
an element path to the attribute.
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You can obtain the value for a single instance of the attribute or for multiple instances, returned in a table. In
such a table, the columns are comma-delimited and the rows are new line-delimited.

1. In theElement Path box, specify the path of the element that contains the attribute whose value you
want to extract. Use forward slashes to separate the parts of the path to the element.
To control which instance of the element the filter gets the attribute’s value from, add a specification such
as [2] or [3]. The numbering of elements is 1-based (starts with [1]). Thus to specify the second instance
of an element, you would use [2].

2. To search child elements of the element you’ve specified, select the Include sub-elements check box.
3. In theAttribute Name box, type the name of the attribute whose value you want.
4. ForResult, select one of the following:

l To restrict the result extracted to the value of a single instance of an attribute, select Single Match.

l To extract the value of all the instances of the attribute you have named, select As Table.

Example: To find the name of a user for one of the comments (using the example XML from the topic
XML Filters):

In theElement Path box, type /ticket/details/comment.

Example: To get the name of the user for a particular comment (in this example, the second one):

1. In theElement Path box, type /ticket/details/comment[2].
2. In theAttribute Name box, type user.
3. BesideResult, select Single Match.
The output will be john.

Example: To find the name of the user for each comment:

1. In theElement Path box, type /ticket/details/comment.
2. In theAttribute Name box, type user.
3. BesideResult, select As Table.
The output will be:

Path,user

/ticket/details/comment[1],john
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/ticket/details/comment[2],frank

/ticket/details/comment[3],albert

XML Get Element
TheXML Get Element filter enables you to extract an element in its entirety (including child elements,
values, and attributes) by describing it in any of the following ways:

l By a relative or absolute path.
l By a child element of the element you want to extract. You can also search by a specific value of the child
element.

l By an attribute of the element you want to extract. You can also search by a specific value of the attribute.

In the following procedure, you can enter specifications in any one or combination of the text boxes.

1. In theElement Path box, type an absolute path to the element.
Within the path, a relative path indicator indicates location relative to the element that precedes the
relative path indicator.
l ../ specifies the parent of the last-named element.

l ./ specifies the last-named element.

Example: in the XML example, <volume> and <company> are sibling elements, both children of the
<customer> element. You could specify the <company> element with the following relative path:

/tickets/ticket/customer/volume/../company

If there is more than one instance of the identified element, simply specifying the path, as in the
preceding example returns all the instances of the element.
You can specify a particular instance of any element in the path with an integer inside square brackets.

Example:

/tickets/ticket/details/comment specifies all the comments in the details for all the tickets.
/tickets/ticket/details/comment[2] specifies the second comment for each ticket.
/tickets/ticket[2]/details/comment specifies all the comments for the second ticket.

2. In theChild Named box, type the name of an element that is a child of the element (or elements) that
you want to extract. If the child element has a value, you can narrow the results by typing that value in
theValue box.
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l TheChild Named box works for only one level of child elements. The filter only returns the direct
parent of the child element that you specify.

l TheValue box is intended for brief values. The value that you type theremust be an exact match of
the value of the child element of the element that you want to extract.

3. In theAttribute Named box, type the name of an attribute that is unique to the element you want to
extract. To further narrow the results, you can type a value of the attribute in theValue box.

Example: In the example XML, there are several ways to extract the customer element and all of its
contents:

l In theElement Path box, type /ticket/customer
l In theChild Named box, type any of the child elements of customer:
company
position
contactInfo
If you type company in theChild box, then in the accompanyingValue box, you could also type
myOrg

l In theAttribute named box, type one of the following:
firstname
lastname
In the accompanyingValue box, you could type the respective value for those attributes:
John
Doe

For each of these filters, the output is the customer element, as follows:

<customer firstName="John" lastName="Doe">
<company>myOrg</company>
<position>CIO</position>
<contactInfo>

<email>jdoe@myorg.com</email>
<email>johnsSecondEmail@myorg.com</email>
<mobile>12065551212</mobile>
<description internal="1">Private contact info</description>
<description>Partial contact info</description>

</contactInfo>
<description>Our best customer</description>

</customer>

XML Get Element Value
TheXML Get Element Value filter enables you to get the value of a specific element.
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In theElement Path box, type the path to the element whose value you're interested in.

As with the other filters, if there aremultiple instances of an element, the filter returns the first one, unless you
specify a different instance.

Example: Using the sample XML

To get the value for the email element, type /tickets/ticket/customer/contactInfo/email

The output will be one of the two emails given:

jdoe@myorg.com

johnsSecondEmail@myorg.com

To specify a particular instance of the email element, type /ticket/customer/contactInfo/email[2]

The output will be: johnsSecondEmail@myorg.com

XPath Query
TheXPath Query filter enables you to extract data from the result with queries that use the standard XPath
syntax, which you type in theXPath Query box.

In theXPath Query box, type the query, using XPath syntax.

l The path that precedes the square brackets identifies the scope of the query with which you are narrowing
the results.

l Square brackets contain the filtering portion of the query. There can bemore than one set of filters in a
query.

Example: Using the sample XML

You can extract a customer who has a volume of more than 40,000 of some units, with either of the
following queries:

l This XPath query finds all the companies whose customer's volume is more than 40,000.

/tickets/ticket/customer/company[../volume>40000]

The <volume> element is a sibling of the <company> tag, so to locate the element <volume>, you use
the following sequence inside the square brackets to articulate the path relative to <company>:

../

l This XPath query finds all the customers whose volume is greater 40,000 units.

/tickets/ticket/customer[volume>40000]

Because <volume> is a child of <company>, you do not need to specify its relative path.

Studio Authoring Guide
Authoring a Flow – Basics

HPE Operations Orchestration (10.60) Page 228 of 350



Reference Material
Filter Editor
The Filter list in the upper-left displays a list of the filters as you create them.

When you create a filter and have selected a filter type, theDetails for: section in the upper-right changes to
show controls for modifying filters, depending on the kind of filter you select.

GUI item Description

Add Click to add a new filters.

Remove Click to delete the selected filter or filters.

Studio Authoring Guide
Authoring a Flow – Basics

HPE Operations Orchestration (10.60) Page 229 of 350



Click tomove the selected filter up or down in the list. Filters are
processed in the order that they appear in the list.

Test Filter Input This is where you place data in order to test that the filter works as
expected.

Test All Filters Applies the test to all the filters on the output or result.

Test Selected Filters Applies the test to the selected filters.

Copy Copy data within the Test Filter Input box.

Paste Paste data into the Test Filter Input box.

Cut Cut data within the Test Filter Input box.

Clear Clear data within the Test Filter Input box.

Quick Command Type a command that generates the data on which you want to test
the filter. The output of the command appears in the Test Filter Input
box.

Test Output After filters are applied to the test data in the Test Filter Input box,
the filtered results appear in the Test Output box.

Working with Variables
You can use variables tomove data within and between flows.

For example, if you have several steps that act on a server, you can have the first step get the IP address of a
server and assign that value to a flow variable. Then, any subsequent step that has an input of that namewill
automatically use that server name.

Flow Variables
Flow variables are available only for the flow within which they are defined.

Assigning Value to Flow Variables
You can assign a value to a flow variable from:

l A step's result - for example, a step with an operation to count hits will store the result in a flow variable
l An input value - for example, a step that gets an IP address as an input value will store the address as a
flow variable

l A scriptlet - for example, a scriptlet that evaluates data that is returned from a step’s operation will store
the data in a flow variable

Using Flow Variables
You can reference a flow variable and the data that it stores in any of the following places:
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l In a different step in the same flow
l Within a lane in a parallel split step – a lane step can use the value of a flow variable, if that value was
written to the flow variable by an earlier step in the same lane or prior to the parallel split step. However, a
step in one lane cannot use a flow variable value, if this value was written to the variable by a step in a
different lane.

l In an operation input
l In flow, step, and transition descriptions – for example, thePing Latency operation filters out the
average duration of the ping. A step associated with this operation could save the average duration as the
flow variable latency, then the transition that follows this step could report that value to the user

l As part of data you are testing with a response rule – for example, to see whether an output string or
error string contains a value that you have stored in a flow variable.

l In scriptlets – tomake a scriptlet result available outside of the step, the scriptlet must create a flow
variable (if the desired one doesn’t already exist), and assign the result to it.

l In operation parameters – If an operation parameter takes a value, you can access that value by
referencing a flow variable that contains it.

The Flow Variables pane helps you to keep track of the flow variables that you have created.

Global Variables
Global variables are keyname-and-value pairs that are part of the global context, and so are always available
for use or reference in any flow run.

If a flow variable and a global variable have the same name, a reference to that variable name accesses the
(local) flow variable of that name, not the global variable. This is the case either for assigning a value to the
variable or for getting its value.

When you specify that an input gets its value from a global variable, a flow variable is created with the value
of that global variable, and the value is supplied from the flow variable to the input.

What do you want to do?
Assign a value to a flow variable from an input
By default, the value of the input is assigned to a flow variable with the same name as the input.

1. Open theProperties sheet (for an operation) or the Step Inspector (for a step).
2. On the Inputs tab, select an input or create a new one.
3. From theAssign to dropdown, select the variable to which you want the value to be assigned.
4. Save.
For more information about creating an input, see "Creating Input" on page 166.

Assign a value to a flow variable from a result
1. Open theProperties sheet (for an operation) or the Step Inspector (for a step).
2. On theResults tab, select the row of the relevant result.
3. From theAssign To list, select Flow Variable.
4. UnderName, specify the name of the flow variable.
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5. Under From, specify the source of the value.
For more information about creating a result, see "Creating Outputs and Results" on page 205.

If necessary, to obtain the precise results you want, create one or more filters for the result. See "Filtering
Output and Results" on page 215.

Assign a value to a flow variable from a scriptlet
You can also create and assign a value to a flow variable from a scriptlet.

In the scriptlet, include a commandwith the following syntax:

scriptletContext.putLocal("<localflowvariablename>", <value>);

where <value> can be a variable or an object created within the scriptlet.

View information in the Flow Variables pane
The Flow Variables pane helps you track the storage of data in flow variables:

l How the flow uses flow variables tomake data available where it’s needed
l Where the flow variables obtain their data
The Flow Variables pane presents this information in a tree structure. The Flow Variables pane shows all
the flow variables used in the current flow, listing each flow variable’s creation and/or usages. Any changes
youmake to a flow variable in the flow are automatically reflected in the Flow Variables pane.

Click the Flow Variables tab in the upper-right of the Studio window to open the Flow Variables pane.

Filter information in the Flow Variables pane
To zero in on the flow variable uses that you’re most interested in, you can select which flow variable uses
you want to display in the pane.

1. Display the filter buttons by clicking the Filter button in the Flow Variables toolbar.
2. In the row of buttons that appears, click the buttons to toggle each filter type on or off. As you toggle
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each type of data source, that type is displayed or removed from the display:
l Flow input

l User-prompt step input

l Step input that does not have a user prompt

l Result

l Scriptlet

Locate the input that the flow variable listing references
To view a particular use and open the editor that defines that use, select the use instance in the Flow
Variables pane.

l If the use is for a flow input, the flow’s Properties sheet opens on the Inputs tab, with the Input Editor for
the relevant input open.

l If the use is for a step input or result, the flow diagram opens with the step selected. Beneath the flow
diagram the editor for the input or result is opened.

Tip: Use thePrevious andNext buttons tomove up or down in the list of uses.

View a global variable
To view all the global variables in a flow, debug the flow. The global variables (as well as the flow variables)
and their current values are listed in the Context Inspector.

For more information on the Context Inspector, see "Validating Content" on page 265.

Change a global variable

Important!Before you change the value of a global variable, remember that global variables are available
in any run of any flow. Changing the value of a global variable will affect other flows and operations that
use that global variable.

To change a global variable, complete the task Assign a value to a flow variable from an input. In theAssign
to Variable box, enter the name of the global variable to which you want the value to be assigned.

Reference Material
Flow Variables pane
When you have a flow open in the authoring pane, the Flow Variables pane lists each flow variable in
alphabetical order, and describes each use of the flow—each place in the flow where the flow variable may be
used.
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GUI item Description

Click tomove up in the list of uses.

Click to move down in the list of uses.

Click to display the filter buttons, in order to filter the information visible in the in the Flow
Variables pane.

Displays the number of times the flow variable is used in the flow.

Is checked when a particular use of the flow variable occurs in a flow input.

Is checked when a particular use of the flow variable gets its value from user input.

Filter buttons in the Flow Variables pane

Display the filter buttons by clicking the Filter button in the Flow Variables toolbar.

Click the filter buttons to toggle each filter type on or off. As you toggle each type of data source, that type is
displayed or removed from the display.

Filter button Description

Flow input—the flow variable is referenced in an input
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Step inputs with user prompts

Step inputs without user prompts

Results—the flow variable is associated with a step result

Scriptlets—the flow variable is referenced in a scriptlet

Creating Return Steps
A flow needs one or more return steps to end the flow.

The four types of return step are:

l Resolved – This is the standard return step for a flow that runs correctly.

l Diagnosed – This return step indicates that a flow has determined what a problem is and has opted
not to take action on it other than notification.

l No Action Taken – This return step is used when a remediation flow gathers data but cannot
determine any diagnosis or remediation.

Note: A flow that is intended solely to gather data should returnResolved when it is complete,

rather thanNo Action Taken .

l Error – This return step is used if the flow fails to run all the way to the end. For example, because of
bad input, failure to reach a system, or a problem with the flow.

In each return step name, the response of the return step is shown after the colon; for example, Error:
failure. You canmodify this response. For example, if the outcome that led to anError: failure return step
was not a failure in an operation but a result that did not meet a required threshold, then youmight want to
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create a new response for theError: failure step that reflects this outcome, such as Error: threshold not
met.

Best Practices
l If you havemultiple end steps of the same type in a flow (for example, multiple error end steps), rename
the end steps to include the cause of the failure.

l Avoid confusing a failed operation with a negative result. For example, if an operation asks a question for
which the answermay be TRUE or FALSE, a FALSE answer is not the same as a failure. In such a case,
you need twoError return results, one for a FALSE result and one for a failure of the operation.

What do you want to do?
Add a return step to a flow

1. On the authoring pane toolbar, click theStep Palette button to display theStep palette.
2. From theStep palette, drag the appropriate return step icon to the authoring canvas.
3. Create transitions from the flow steps to the return step.

Change a return step's response
You can change the response of a return step tomore accurately reflect the outcome that led to the return
step. For example, if your flow has multiple error responses ( Error: failure andError: threshold not met),

when you drag theError icon to the authoring canvas, the error return stepmay not contain the response
that you want.
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1. Right-click the return step on the authoring pane and select Select Response.
2. Select the response that you want for the return step. For example, Error: threshold not met.

Create and assign a new response to the return step
If the list of available responses does not include the response that you need, you can create a custom
response.

1. Right-click the return step on the authoring pane and select Select Response.
2. Select Add New Response.
3. In the dialog box, enter a name for the new response and click OK.

Reference Material
Step palette
TheStep palette contains buttons for dragging return steps, parallel split steps, multi-instance steps, and

callouts onto the flow. Display theStep palette by clicking theStep Palette button from the
authoring pane toolbar.

Button Description

Success
Lets you drag aSuccess return step to the flow.

Diagnosed
Lets you drag aDiagnosed return step to the flow.

No Action Taken
Lets you drag aNo Action Taken return step to the flow.

Failure
Lets you drag a Failure return step to the flow.

Parallel Split Step
Lets you drag a parallel split step to the flow.

Multi-instance Step
Lets you drag amulti-instance step to the flow.

Callout
Lets you drag a callout to the flow, providing information to users.

Docking bar Click to dock and undock the palette.

Studio Authoring Guide
Authoring a Flow – Basics

HPE Operations Orchestration (10.60) Page 237 of 350



Advanced Authoring
This chapter covers creatingmore complex flows. For information about creating simple flows, see
"Authoring a Flow – Basics" on page 149.

When creating flows, make sure not to create flows that create unlimited growth in memory. For example, do
not create a flow that runs an infinite loop, in which the flow sleeps, performs some tasks, then goes back to
sleep. In this case, the Run History grows until the system runs out of memory.

Creating a SubflowWithin a Flow
You can simplify a flow by creating steps from subflows. This way, you can:

l Separate the programming tasks into smaller, moremanageable pieces
l Test parts of the flow individually
l Reuse the pieces that you create
For example, in the flow below, theWindows Health Check step is a subflow.

A subflow is treated as a single step even though it may contain many operations.

Subflows often generate data that steps in the parent flow need to access. Flow variables that you create
within a flow cannot be referenced outside that flow. However, you can pass values from a subflow to a
parent flow, by saving the subflow results as a flow output field.

Best Practices
l A flow should fit on the canvas on a 1024 x 768 screen with Studio maximized and a 1:1 view
magnification. Larger flows are not strictly prohibited, but if a flow is larger, examine it carefully to see
whether you can break down some of its sequences of steps into subflows.
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l Supply a description and name for all transitions on a top-level parent flow. These transition descriptions
should describe what happened in the step that preceded the transition. You need not add descriptions of
transitions in a subflow unless the data is critical to see during a run.

What do you want to do?
Create a flow with a subflow
1. Create a flow first and save it.
2. Create a new flow, to act as parent flow.
3. Drag the subflow from theProjects pane onto the parent flow, to create a step from the subflow.

Pass data from a subflow to a parent flow
1. Open the subflow on the authoring canvas, and open the Step Inspector for the step whose data you

want to make available to the parent flow.
2. Click theResults tab and add a result (for more information, see "Setting Step Results" on page 209).
3. Configure the result so that result data is stored in a flow output field. This makes the data available

outside of the subflow.

a. UnderName, type a name for the flow output field.
b. Under From, select Result Field: Result.
c. UnderAssign To, select Flow Output Field.
d. If required, create a filter to filter the result (for more information, see "Filtering Output and Results"

on page 215).
4. In the parent flow’s authoring canvas, open the Step Inspector for the step that was created from the

subflow.
5. Click theResults tab and create a step result. By default, this new result:

l Obtains its value from the result field that has the name of the subflow’s flow output field

l Has the same name as that of the subflow’s flow output field

l Is assigned to a flow variable, which by default has the same name as the result, and which is now
available for use in transitions and steps that follow this step

Example
1. Copy a command operation, and have it execute “dir C:\”. Name it dir.
2. Create a flow called flowdir.
3. In the flowdir flow, create a step using the operation dir.
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4. On the dir step, add a result that comes from the operation’s output string.
5. Assign the result to a flow output field, and name the result foo. Now the flow has a flow output field also

named foo.
6. Create another flow called parentflow.
7. In parentflow, create a step from flowdir.
8. Add a result to the flowdir step.

By default, the new result is named foo. It obtains its value from theResult Field: foo, and the value is
assigned to a flow variable also named foo. The result foo of the subflow’s step dir is now available to
transitions and steps that come after the flowdir step in the parent flow.

9. To test this, after the flowdir step, add a step created from theBasic Notify operation.
10. In this new step:

a. Define the notifyData input as being a single value, that uses a constant value, and specify that
the constant value is ${foo}.

b. Define the notifyMethod input as being a single value, which uses a constant value, and specify
that the constant value is Display.

c. Define the subject input as being a single value, which uses a constant value, and specify that the
constant value is something like: If this worked, the flow output field says: "contents of outputString,
aka foo".

d. Debug the flow.

Creating a Flow with Parallel Split Steps
A parallel split step is a set of step sequences that are carried out simultaneously. Each series of steps is
represented visually in the flow diagram as a lane. The steps contained in each lane are called "lane steps".
When you run the flow, the lanes start simultaneously.

Parallel split steps are best used for doing dissimilar things simultaneously and independently of each other.
Note the contrast with multi-instance steps, whose instances do the same thing with multiple variations of a
single input.

For example, youmight use a parallel split step for writing and validating an XML file, and, at the same time,
sending email about this to the appropriate person:

l One lane contains the steps for writing and validating the file.
l The second lane sends the email.
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Note: Is not possible for parallel split steps to be non-blocking.

A parallel lane cannot include a response step.

What do you want to do?
Create a parallel split step

1. On the authoring pane toolbar, click theStep Palette button to display theStep palette.

2. From theStep palette, drag theParallel Split Step icon to the authoring canvas. By default, the
step has two lanes.

3. Create the step sequence you want within each lane.
a. Add steps (flows or operations) in the lane.

Note: You cannot add a response step in a parallel lane.

b. Connect the steps within each lane.

c. Connect the last step in the lane to the Lane-end icon .
4. Connect the parallel split step to the rest of the flow:

a. If the parallel split step is not the start step, connect the step that precedes it to theParallel Split

Step icon.

b. Connect the parallel split step’s done response to the next step in the flow.
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Change the visual order of lanes
You can change the visual order of the lanes in the flow diagram, but note that when the flow is run, all the
lanes begin at the same time. Their graphical order in the flow diagram does not affect the order in which their
processing occurs.

1. Right-click the lane that you want to move.
2. From the drop-downmenu, selectMove Lane Up orMove Lane Down.

Move a parallel split step or its components

l Tomove a parallel split step, click theParallel Split Step icon in the flow diagram, and drag.
l Tomove an individual lane step, select the step and drag, either within the lane or to another lane.

Copy a parallel split step

1. Right-click theParallel Split Step icon in the flow diagram, and select Copy.
2. Right-click on the authoring canvas and select Paste.

Copy components of a parallel split step
To copy components of the parallel split step, use any of the following tools:

l TheEdit> Copy andEdit > Pastemenu commands
l The right-click menu
l Keyboard combinations CTRL+C, CTRL+V

l TheCopy andPaste buttons on the authoring pane toolbar

Note: If you are copying a lane, keep the cursor inside the lane when you carry out thePaste command.

Add a new lane
1. Right-click an existing lane.
2. From the drop-downmenu, select Add Lane.
A new, empty lane is added below the currently selected lane.

Duplicate a lane
1. Right-click an existing lane.
2. From the drop-downmenu, select Duplicate Lane.
A new lane with the same title as the one you copied appears directly below it.

Delete a lane
To delete a lane, use any of the following tools:

l TheEdit> Remove Lanemenu command
l The right-click menu
l Keyboard combination CTRL+X

l TheRemove button on the authoring pane toolbar
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Resize a lane
1. Select a lane by clicking in a blank part of it. Handles appear at the sides and corners.
2. Drag the side or corner handles.

Rename a lane
By default, lanes are called Lane 1, Lane 2, and so on.

1. Right-click the lane and select Rename.
2. In the text box that appears, type the new name of the lane.

Change the start step of a lane
Note that the start step of a lane does not have the green outline that the start step of a flow does.

Drag the Lane-start icon connector from the lane step that is its current target to the step that you want to
be the lane’s start step.

Move data into and out of a parallel split step
When a parallel split step starts, each of its lanes obtains copies of the global context flow variables, local
context variables, and the inputs of the parallel split step itself. Each lane can use these variables and can
create, modify, or delete these variables according to normal flow rules, independently of any other lane.

A step within one lane cannot pass values to a step in another lane. The steps in each lane only have the
values that were available when the parallel split step (all its lanes) started.

As the lanes finish execution, the flow variables in each of the contexts aremerged back into the context of
the calling flow (the flow that the parallel split step is part of). The order of merging is the order in which the
lanes terminate. As a result, if two lanes write to the same flow variable, the last one to finish provides the
final value of the variable.

Steps within a parallel split step’s lanes can obtain data from the local and global contexts and save data to
local context. Lane steps can only write to the global context by means of a scriptlet that uses the
scriptletcontext.putGlobal()method. For the syntax for using scriptletcontext.putGlobal(), on
theScriptlet tab of an operation or step, insert the JavaScript template.

Debug a parallel split step
In an actual run, the lanes will start and run simultaneously when the flow is run, but when you test them in
the debugger, they are executed as a series. You cannot control the order in which lanes are run in the
debugger, but by giving them unique names, you can see the order in which they ran.
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This is one way in which the debugger does not precisely reproduce the behavior of a flow in a production
environment. On the other hand, serial execution in the debugger of parallel split steps enables you to perform
controlled tests for various conditions. For more information, see "Debugging Complex Flows" on page 278.

Creating a Flow with Multi-Instance Steps
A multi-instance step is a step that executes simultaneously onmultiple targets. For example, if you want to
run theWindows Diagnostic flow on 100 servers, you can create amulti-instance step that runs the flow on
all 100 servers at the same time.

The targets of the operation (in our example, the 100 servers) are defined in an input list in themulti-instance
step.

Inside amulti-instance step, you can include one or more operations or subflows. The operations and/or
subflows in themulti-instance step run once for each target—these runs are known as instances.

Each instance gets, at its beginning, a duplication of the global and local contexts. As it runs, each step in the
instance can change the global variables, flow variables, and flow output fields within themulti-instance step.

Note:When an exception is thrown in one of the instances, that instance is stopped. The others
continue to run, because they are running in parallel.

If running themulti-instance step against toomany targets simultaneously would slow down your
infrastructure, you can throttle amulti-instance step, by limiting how many values it can process at once. The
throttling size can be a constant (integer) or take its value from a ${variable}.

Note: Is not possible for multi-instance steps to be non-blocking.

A multi-instance lane cannot include a response step.

Differences Between a Multi-Instance Step and a Parallel Split Step
In amulti-instance step, each instance performs the same task on a different target, while in a parallel split
step, each parallel step can be set to do something different.

In amulti-instance step, the number of instances can change during runtime, while in a parallel split step, the
number of parallel steps is constant.
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Saving Flow Data
Flow variables, global variables, and flow output fields that are created in an instance of amulti-instance step
are local to the instance in which they are created and populated. These variables and flow output field
variables will disappear at the end of the lane, unless you use one of the following ways tomake this data
available to the rest of the flow:

l Bind the data to results on themulti-instance step
l Create a scriptlet in themulti-instance step to save the data

Saving Data via Results
In order to make the data from flow variables available after themulti-instance step has ended, you can define
step results in themulti-instance step, which take their value from flow variables created in the instances. In
theResults tab of the Step Inspector for amulti-instance step, select a flow variable created in the instances,
by selectingResult <result> in the From column.

You can also save the data from flow output fields created in a subflow in the instances, in a similar way. In
theResults tab of the Step Inspector for amulti-instance step, select a flow output field created in the
instances, by selectingResult Field <result> in the From column.

You can set theAssignment Action field to do different things with the values that are collected. For
example, you could append the results of the different instances, or add them together, or get later instances
to overwrite previous ones.

In the example below, there are five variables set up for the results of amulti-instance step. The first three
take their value from flow variables and the last two from flow output fields.

Assuming that there are two instances, Instance1 and Instance2, that themain flow has empty contexts,
and that Instance2 ends after Instance1, the instances provide the following variables:

l Instance1:
l Flow variables:

var1 = x

var2 = y

var3 = w
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l Flow output fields:

var1 = z

l Instance2:
l Flow variables:

var2 = t

var3 = v

l Flow output fields:

var5 = u

When themulti-instance step finishes, the values of the variables will be:

var1 = NULL (because in Instance2, there is no value for this variable, and the action is to overwrite)

var2 = t (the value in Instance2 overwrites the value from Instance1)

var3 = wv (the value in Instance2was appended to the value from Instance1)

var4 = NULL (because in Instance2, there is no value for this variable, and the action is to overwrite)

var5 = u

Saving Data via a Scriptlet
Another way tomake data generated within the step available to the rest of the flow is by creating a scriptlet
that collects the data and saves it as a variable that will continue to exist after the instance’s run completes.

In the example shown, the scriptlet tracks whether each instance run passes or fails, accumulates this data,
and saves it as a variable that is available in the global context.

This scriptlet will be executedmultiple times, once for each instance. Each time, it will be able to access the
ScriptletContext of the current instance (called scriptletBranchContext), and canmodify the parent
flow context (by accessing the scriptletContext).

scriptletBranchContext has samemethod access as the scriptletContext.

For more information about scriptlets, see "Using Scriptlets in a Flow" on page 252.

Merging after Upgrade
After upgrading from a previous version of HPE OO, if a flow contains multi-instance steps that were created
using the Toggle Multi-instance option, the global variables created in the step are updated, with later
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instances overwriting earlier ones.

What do you want to do?
Create a multi-instance step

1. On the authoring pane toolbar, click theStep Palette button to display theStep palette.

2. From theStep palette, drag theMulti-instance icon to the authoring canvas.
3. From theProjects pane, drag the flow or operation into themulti-instance lane.

Note: You can addmultiple flows and operations to themulti-instance lane.

You cannot add a response step in amulti-instance lane.

4. Set up the list of targets for themulti-instance step, by creating an input that is a list of multiple values.
For example, the list of servers that the flow will run against:

a. Open the Step Inspector for themulti-instance step by double-clicking theMulti-step icon at
the start of the step.

b. Create an input. In our example, this could be named servers.
c. Select theRequired checkbox and set the type to List of Values.

d. Click the right-pointing arrow at the end of the row to open the Input Editor for that row.
e. In the Input Delimiter box, type a delimiter (a character(s) that separates the elements in the list).

Note:

o To define a delimiter that contains several characters, use quotationmarks. For example,
"$%^".

o To use a quotationmark as part of the delimiter, type it in twice. For example, to define the
delimiter "$%, type ""$%.

f. Specify the way that the list of values will be input. For example, if you want themulti-instance step
to run against a number of servers, you can select Use Constant, and specify the server names in
theConstant Value box. Other ways to populate the list of values are to use the results of a
previous step or via integration with another program.
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Formore information about the options for creating a list of values for input, see "Specifying the
Input Source " on page 175.

5. Connect the different parts of themulti-instance step:

a. Connect the Lane-start icon to the first step in themulti-instance lane.
b.  If there aremultiple steps in themulti-instance step, connect the steps.

c. Drag all the response lines from the last step in the lane to the Lane-end icon .

6. Apply the list of targets to each internal step:
a. For each of the internal steps inside themulti-instance lane, open the Step Inspector and add an

input.
b. Open the Input Editor, and in theAssign From list, select the variable that you created to hold the

list of targets. In our example, this is servers.
7. If you want to save the data collected by the different instances of themulti-instance step, create a flow

variable to store the result:
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a. Open the Step Inspector for themulti-instance step by double-clicking theMulti-step icon.
b. Click theResults tab and add a result.
c. In theAssign To column, assign the result to a flow variable.
d. Give a name to the flow variable that will hold the data, for example, outcome.
e. Decide on how you want the data to be stored. In our example, we want to store the results for each

server, so the assignment action is APPEND. For more details, seeSave output from amulti-
instance step, below.

8. If you want to save the data collected by the different instances of themulti-instance step, to be used in
the global context, write a scriptlet to store the result:
a. In the Step Inspector for themulti-instance step, click theScriptlet tab.
b. Write a scriptlet that will collect the data from the scriptletBranchContext), and will make it

available to the scriptletContext.
In the example below, the scriptlet tells the flow to accumulate the all values of the outcome
variable. This is similar to theAPPEND action that was selected in the previous step.

9. Connect themulti-instance step to the rest of the flow:
a. If themulti-instance step is not the start step, connect the step that precedes it to theMulti-

instance icon.

b. Connect themulti-instance step’s done response to the next step in the flow.

Save output from a multi-instance step
The data in flow variables and flow output fields in instances are gone after themulti-instance step is
completed. To save this data, you can bind it to results in themulti-instance step.

1. Create amulti-instance step, as described above.
2. In the Step Inspector, click theResults tab.
3. Add a result line for each flow variable that you want to save.
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4. In theName column, enter a name for the flow variable that you will be saving the data to.
5. In the From column, select the flow variable or output field that is the source of the data that you want to

save.
l To select a flow variable created in the instances, select Result <result> in the From column.

l To select a flow output field created in the instances, select Result Field <result> in the From
column.

6. In theAssignment Action column, select the action that describes how you want to collect the data.
For example, if you wanted to calculate how long it took to run all the instances, you would select Add. If
you wanted to collect a list of all the servers that were checked in themulti-instance step, you would
select Append.

7. Save the step. The flow variables that you created will be available for the rest of the flow, after themulti-
instance step has finished running.

Save output from a multi-instance step as a global variable
To save the output from amulti-instance step, so that it can be used outside the flow, you can create a
scriptlet to save this output as a global variable.

1. Open the Step Inspector for themulti-instance step by double-clicking theMulti-step icon at the
start of the step.

2. Click theScriptlet tab.
3. Write a scriptlet that will collect the data from the scriptletBranchContext), and will make it available

to the scriptletContext. For example:
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Limit (throttle) the number of instances a multi-instance step can run on
simultaneously
If running amulti-instance step onmany instances simultaneously may slow down your system’s
performance, you can set a throttle level for the step, by limiting the number of targets themulti-instance step
can simultaneously start the flow for.

The performance is related to the target system(s), and whether or not one flow can use all of OOs worker
threads.

If throttle is not set, the number of instances is the same as the number of inputs.

If throttle is set, the number of instances is theminimum between throttle size and remaining inputs.

1. Open the Step Inspector for the step, and then click theAdvanced tab.
2. UnderExecution, select the Throttle parallel execution check box.
3. In the box, type themaximum number of instances of the step that should run at once.

Note for upgraders from OO 9.x:

There is a difference in the way that throttling works in OO 10.x.

l 9.x would keep a consistent number of concurrent threads running. For example, if you had 100 items
and you throttled at 10, themulti-instance step would keep 10 going at all times. If one finished, it
would start onemore.

l 10.x starts 10 of the 100, waits until all 10 are finished, and then starts another 10.
Please take this into account when you schedule your patching.

Move a multi-instance step

1. Select theMulti-instance icon at the start of the lane, which represents the entire step.
2. Drag the step across the authoring canvas.

Resize a multi-instance step
1. Select the lane by clicking in a blank part of it. Handles appear at the sides and corners.
2. Drag the side or corner handles to resize the lane.

Rename a multi-instance step

1. Select theMulti-instance icon at the start of the lane.
2. Right-click and select Rename.
3. Type a new name in the text box.

Debug a multi-instance step
In an actual run, themultiple instances run concurrently, but when you test them in the debugger, they are
executed serially. While this means that you are not testing under actual conditions, it does allow you to
examine how long it takes each instance to finish.

For more information, see "Debugging Complex Flows" on page 278.
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Using Scriptlets in a Flow
Scriptlets (written in Nashorn or Rhino JavaScript) are optional parts of an operation that you can use to
manipulate data from either the operation’s inputs or results, for use in other parts of the operation or flow.

You can use scriptlets to test, format, manipulate, or isolate a particular piece of the results.

You can use scriptlets to:

l Filter the results of a operation, flow, or step
l Determine the response of an operation
l Manipulate data in a subflow before passing the data to the parent flow

Note:When referencing a system property in a scriptlet, youmust use the complete path. For example,
if there is a system property under the following folder structure folderA\folderB\my_ci, use the string
${folderA/folder/my_ci} to reference it.

Resources to help you write scriptlets
l Scriptlet templates (in Nashorn or Rhino JavaScript) are available in the Scriptlet Editor.
l Default scriptlets are available in theConfiguration\Scriptlets folder.
l Copy existing scriptlets in default content.

What do you want to do?
Create a scriptlet from a template
1. Open theProperties sheet or Step Inspector:

l To add a scriptlet to an operation, right-click the operation in theProject pane and select Properties.

l To add a scriptlet to a flow, right-click the flow in theProject pane and select Properties.

l To add a scriptlet to a step, double-click the step in the authoring pane.

2. Select theScriptlet tab.
3. From the Type list, select the JavaScript language in which you will write your script: Nashorn

(recommended) or Rhino.
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4. Click Insert Template.
5. Follow the guidelines in the template to write your script.
6. Click Check Script to check for errors.
7. Save.

Use an existing scriptlet
1. Open theProperties sheet or Step Inspector:

l To add a scriptlet to an operation, right-click the operation in theProject pane and select Properties.

l To add a scriptlet to a flow, right-click the flow in theProject pane and select Properties.

l To add a scriptlet to a step, double-click the step in the authoring pane.

2. Select theScriptlet tab.
3. Open an existing scriptlet in a separate window:

l Double-click a scriptlet from theConfiguration\Scriptlets folder.

l Open an operation that contains scriptlets (for example, the operations in theOperations\Operating
Systems\Linux\Red Hat folder).

4. Copy the scriptlet text and paste it into theScriptlet text box for your operation, flow, or step.
5. Modify the scriptlet if required.
6. Click Check Script to check for errors.
7. Save.

Filter step or flow results with a scriptlet
You can filter step or flow results using a scriptlet.

1. Double-click a step in the authoring pane.
2. Select theResults tab and select the result that you want to filter.

3. Click the right-pointing arrow at the end of the result row to open the Filter Editor.
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4. In the Filter Editor, click theAdd button.
5. From theSelect Filter list, select Scriptlet.
6. Create a scriptlet to filter the data, in one of the following ways:

l Click Insert Template to use the scriptlet template as a basis.

l Copy and paste the text from an existing scriptlet in another operation or from the
Configuration\Scriptlets folder.
For more information about creating filters, see "Filtering Output and Results" on page 215.

7. Click Check Script to check for errors.
If an error is found in a scriptlet, the error is marked with a red underline, as is the flow that contains the
scriptlet.

Note: Flows containing invalid scriptlets are not included when you create content packs from a
project. See "Exporting a Content Pack" on page 287.

8. Test the filter and save your work.

Tip:When creating a scriptlet operation, in the scriptlet, specify the scriptlet response as success.
Then, on theResponses tab of the operation, select failure as the default response.

Create a scriptlet rule for an operation response
You can use a scriptlet to control the response in an operation.

1. Open theResponses tab of the operation and select a response.

2. Click the right-pointing arrow at the right end of the response’s row, to open the Rule Editor.
3. From theRule Type list, select Scriptlet.

4. Click the right-pointing arrow at the right end of the rule’s row, to open the Rule Details Editor.

5. Create the scriptlet in one of the following ways:
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l Click Insert Template to use the scriptlet template as a basis.

l Copy and paste the text from an existing scriptlet in another operation or from the
Configuration\Scriptlets folder.

6. Create the scriptlet and click Check Script to check for errors.
7. Save your work.

Use a system scriptlet in an operation, flow, or step
1. Open theScriptlet tab of theProperties sheet or Step Inspector for the operation, flow, or step on which

you want to use the system scriptlet .
2. In theProjects pane, expand theConfiguration andScriptlets folders.

3. Drag the scriptlet from theScriptlets folder to theScriptlet icon in theScriptlet tab of the
Properties sheet or Step Inspector.
The Scriptlet tab shows that there is now a reference to a shared scriptlet.

Save a scriptlet to the Configuration\Scriptlets folder
1. Under theScriptlet tab in theProperties sheet or Step Inspector, open the scriptlet that you want to

save.

2. Drag theScriptlet icon to theConfiguration\Scriptlets folder in theProjects pane.
3. Enter a name for the scriptlet.

Reference Material
Scriptlet Editor
The scriptlet editor has the same appearance, whether you get to it via theScriptlet tab in theProperties
sheet or Step Inspector or by double-clicking a scriptlet from theConfiguration\Scriptlets folder.
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GUI item Description

Scriptlet icon Drag this icon to theConfiguration\Scriptlets folder, to save a scriptlet there
for reuse.

Insert Template Click Insert Template to see guidelines to help you write your scriptlet.

Check Script Click Check Script to check the scriptlet for errors.

Using Regular Expressions in a Flow
A regular expression (also known as a regex) allows you to search not only for exact text but also for classes
of characters. For example, to match any digit, you can use the wildcard \d.

You can use regular expressions to:

l Create result/output filters that extract key pieces of data for:
l Saving in variables for use in later operations

l Testing to determine a step’s response
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Wildcards and Modifiers for Regular Expressions
The key wildcards for regular expressions are:

Wildcard Uses

^ Matches the beginning of a string

$ Matches the end of a string

. Any character except new line

\b Word boundary

\B Any except a word boundary

\d Any digit 0-9

\D Any non-digit

\n New line

\r Carriage return

\s Any white space character

\S Any non-white space character

\t Tab

\w Any letter, number, or underscore

\W Anything except a letter, number, or underscore

Themodifiers for regular expressions are:

Modifier Effect

* Match zero or more

+ Match one or more

? Match zero or one

{n} Match exactly n occurrences

{n,} Match n or more occurrences

{n,m} Match between n andm occurrences

[abc] Match either a, b, or c

[^abc] Match anything except a, b or c

[a-c] Match anything between a and c

a|b Match a or b
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\ Escape a special character (for example \. Means ‘.’ not match anything

What do you want to do?
Use a regular expression to filter test output
1. Open the Filter Editor for an output or result, and create a new filter. For more information, see "Filtering

Output and Results" on page 215.
2. From theSelect Filter list, select Regular Expression as the filter type. TheDetails for: section in the

upper-right shows controls for creating a regular expression.

3. From theExpression Type list, select Java Style. Do not use the other styles; they have been
deprecated.

4. In theExpression Value box, type a regular expression.

Example: To extract the number of packets lost, you can use the regular expression Lost = \d.

This expression tells HPE OO to search for the string “Lost = ” followed by any number.
The wildcard \d tells HPE OO tomatch any digit.

5. For Filter Style, select Filter Entire Input or Filter Line-by-line, according to how you want the filter
applied to the raw results.

6. Tomake the regular expression not case-sensitive, select Ignore Case.
7. Click Test Selected Filters to test the filter.
8. Save the filter.

Combine multiple regexes to isolate a value
You can combinemultiple regular expressions to isolate the value in a filter.

For example, in the output of the Unix ps command, extracting the time for ps requires two regular
expressions: one to filter the output down to the line for ps and the second to extract the time.

F S UID PID PPID C PRI NI ADDR SZ WCHAN TTY TIME CMD

0 S 512 21604 21603 0 75 0 - 1096 wait pts/1 00:00:00 Bash

0 R 512 2659 21604 0 76 0 - 1110 - pts/1 00:00:00 Ps
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1. Open the Filter Editor for an output or result.
2. Add a new regular expression filter.
3. In theExpression Value box, type the first regular expression.

In our example, type .*ps. This extracts any characters ending with “ps”.

Note: Make sure not to omit the leading period [.]

4. Select the Filter line by Line check box.
5. Click Test Selected Filters.

In the Test Output box, the only output is the line containing “ps”.
6. Add a second regular expression filter.
7. In theExpression Value box, type \d*:\d*:\d*

This represents three sets of digits separated by colons. In our example, this will extract the time from
the line.

8. Click Test Selected Filters.
9. Save.
The test output now shows only the time from the ps line. Now you can assign this value to a variable.

Reference Material
Filter Editor > Details for: Regular Expression
When you select Regular Expression as the filter type, theDetails for: section in the upper-right shows
controls for creating andmodifying a regular expression.

GUI item Description

Expression Type Select Java Style as the type of regular expression to filter the data
with. Do not use the other styles; they have been deprecated.

Expression Value Type the regular expression.

Filter Style > Filter Entire
Input

Select to apply the filter to the entire raw result.

Filter Style > Filter Line-by-
line

Select to apply the filter to each line separately.
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Ignore Case Select to make the regular expression not case-sensitive.
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Searching Content on HPE Live Network
from Studio
A Studio author can search for relevant information and content on the HPE Live network based on their
HPLN profile access permissions directly from Studio.

Search Types
The following search types are available:

l Search by type: You can search for a flow, operation, system account, system property, selection list,
domain term, system evaluator, system filter, scriptlet, group alias, category, and role alias.

l Search by name: Searches by name. You can use wild card characters * for incomplete words. The wild
card * matches anything. If no name is specified, then any name is amatch. This search is case
insensitive.

l Search by description: Searches the descriptions. You can use wild card characters * for incomplete
words. The wild card * matches anything. If no name is specified, then any description is amatch. This
search is case insensitive.

l Search by input name: Searches the input name. You can use wild card characters * for incomplete
words. The wild card * matches anything. It will return all items except for configuration items inside all
content packs with specific meta-data of each that have inputs matching the search string. This search
cannot be used for configuration items.

l Search by UUID: Enter the UUID as an exact string. The search is matched based on = operator. This
search will return the flow, operation or configuration item with that UUID.

l Combined search: Allows you to search with multiple criteria. This includes two or more criteria of type,
name, description, input using the AND operation.

Note: A search type with any and all other fields empty is not allowed. In this case, the search button is
disabled.

hpln-index-generator Tool
The hpln-index-generator tool, located in <oo_install_folder>/studio/tools/lib/hpln-index-generator.jar,
generates an index file (.json) describing the flows, operations and configuration items and with the
correspondingmetadata inside a content pack.

Note: In order to use the HPLN Search functionality in Studio, the .json file must be published to
HPLN along with the content pack .jar file. See "Run the HPLN Index Generator Tool " on page 263 for
details.
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What do you want to do?
Set up the HPLN Connection from Studio
1. From theConfigurationmenu, select Options > HPE Live Network.
2. In theHPE Live Network Settings dialog box, enter your HPE Live Network user id and password.

Note: The user id and password that you enter in this dialog box will determine the access
permissions and will affect the search results.

3. Click Applyand thenOK.

Search HPE Live Network from Studio
1. From theConfigurationmenu, select Options > HPE Live Network.
2. In theHPE Live Network Settings dialog box, enter your HPE Live Network user id and password.

Note: The user id and password that you enter in this dialog box will determine the access
permissions and will affect the search results.
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3. Click Applyand thenOK.
The HPLN Search pane is located at the bottom of the StudioWorkspace and is open by default.

4. Enter a search criterion and then press Enter or click the Search button.

HPE Live Network searches return amaximum of 100 results.

Note: \, (, ), & characters are not supported inside the name, description, input, UUID for HPE
Live Network searches.

Run the HPLN Index Generator Tool
1. From theWindows Startmenu, type cmd in the prompt field to open a command line window.
2. Navigate to studio\tools\lib under the OO installation folder.
3. At the DOS prompt, type in the following command:

hpln-index-generator-<version>.jar --content-pack <arg>

where <version> is the version number of HPLN Index Generator tool, and <arg> is the content pack
jar file.
At the end of the process, the tool informs that it has created a JSON file with the content pack name
and a .json extension. For example, oo10-virtualization-cp-1.7.0.json.
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Reference Material
HP Live Network Search > Search Results
The results are displayed in a table which you can sort according to the column name. In addition you can
filter the results usingmultiple values.

When you right-click on a row, you can view the full description of the search result.

You can also jump directly to the location of the content on HPE Live Network by clicking the link button
at the end of a row.

Note: If you want to find a specific item from the latest released content pack, you can filter by the
content pack name and then sort descending by the content pack version. The first items in the list are
from the latest released version.
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Validating Content
Before releasing your content, it is important to test and validate the flows in your project. Studio provides the
following tools to help you do this:

l TheProblems pane displays a list of any problems, with their locations and descriptions, to guide you in
repairing these problems

l The debugger helps you track down the causes of errors and unexpected behaviors in flows

Validating Flows in the Problems Pane
For a flow to run, the flow itself, its operations, configuration items, and any system accounts used in the flow
must be valid.

Using theProblems pane, you can check an individual flow or operation for problems, or you can validate an
entire project. This validates all the flows, operations, configuration items and system accounts in the project.

Different types of problems may be listed. The following is a partial list:

l The flow has no start/return step
l Operation cannot be found
l Multiple objects have the sameUUID
l <variable> references missing selection list
l Transition source step has no operation linked to it

What a flow needs to be valid
To be valid, a flow must have the following:

l At least one step
l One of the steps designated as the start step
l For each step, from each response, a transition connecting the step to a subsequent step
l A way for each step in the flow to be reached in one run or another
l A return step to return a value and end the flow
l Assignment of how each input gets its value
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What do you want to do?
Validate a flow or operation
1. Select a flow or operation in theProjects pane.
2. Click theProblems tab to display theProblems pane.
3. Double-click a row in theProblems pane to open the item for editing.

Note: To openmultiple items, select them using the SHIFT or CONTROL keys, right-click, and
select Open.

Validate all items in a project and project dependencies
1. Open the project that you want to validate.
2. From the Toolsmenu, select Validate.
A list of any problems appears, with their locations and descriptions, to guide you in repairing the problems.

Resolve duplicate UUIDs
1. Click theProblems tab to display theProblems pane.
2. Double-click a row containing a duplicate UUID error.

The item with the duplicated UUID opens. You can then delete the item and proceed to use the original
item.
If you want to keep both items, use theCopy/Paste orDuplicate commands to save a copy of one of
the items with a different UUID, and then delete the item that you copied from.

Reference Material
Problems pane
TheProblems pane, which you open with theProblems tab on the lower edge of the Studio window, lets you
check whether a selected flow or operation is valid.

GUI item Description

Source Type Displays the type of the element in which there is a problem.

Name Displays the name of the element in which there is a problem.

Description Describes the problem, to guide you in how to repair it.
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Location Displays the location of the element with the problem.

Testing and Debugging a Flow
The debugger helps you track down the causes of errors and unexpected behaviors in flows, by displaying the
following information:

l A tree showing the steps executed
l Step results and operation outputs generated for each step
l Flow variable values in the various contexts current to each step
l The transition description for each transition followed

You can also set breakpoints for the debugger and force response choices in order to zero in on the behavior
you want to test.

From each step in the debugger, you can jump directly to the relevant step in the flow that opens in the Flow
Editor.

Note:

l Values resulting from encrypted or hidden inputs are retrieved with ******characters. Youmust edit
these values in the Context Inspector before triggering the flow, otherwise the value of the applied
input will be ****** during the new run.

l In the Context Inspector, you can see the names of hidden outputs, but their values are shown as
obsfuscated ******.
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Debugging Flows that Require User Authentication
If authentication is enabled for a flow in Central (in theEnable Authentication check box), when you select
to debug the flow, you are prompted to enter user credentials in the Central Authentication dialog box. After
they have been entered once, theUsername andPassword credentials are remembered for the current
session, and you do not need to reenter them when debugging additional flows.

For details on the authentication settings, see "Setting up Security Settings" in the Central Guide.

Note: If authentication has been enabled in Central, you cannot log in with a user that has a colon as part
of the user name.

Best Practices
It is recommended to debug subflows before debugging their parent flows.

What do you want to do?
Debug a flow
1. Right-click the flow in theProjects pane, and then click Debug.

Note: Alternatively, you can open the flow in the authoring pane and click theDebug button.

2. To run the flow to its end, click thePlay button in the debugger toolbar.
3. To see the information for a completed step, click the step in theRun Tree pane.
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4. In theStep Result Inspector pane, you can view the step's raw results, primary result, or other filtered
results.

5. To see global variables, flow variables, and their values for the step’s inputs and the step and global
context, navigate to the appropriate section of theContext Inspector pane.

Debug a flow - step by step
1. Open the flow in the debugger.

2. To run the flow step by step, click theStep Over button.

Step into and out of a subflow
These actions allow a flow developer to step in and out of the running of a subflow, while debugging a flow.
Both actions are available when the debugged flow is paused, waiting for the user’s action.

Note: It is recommended to debug subflows before debugging their parent flows.

l To step into a step’s subflow, click theStep Into button. The debugger will start running the subflow
and will pause on the first step of the subflow.
ClickingStep Into at the beginning of the parent flow tells the debugger to pause on the first step of the
parent flow.
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l To step out of the subflow, click theStep Out button. The debugger will run the rest of the steps in
the current subflow invocation and will pause on the first step following the subflow (in the parent flow). If
the current step is in the parent flow, the action will behave like a resume action.

Collapse/restore panes in the debugger
Youmay want to collapse some of the panes in the debugger, in order to makemore room for another of the
panes.

l To collapse a pane, click the upward-facing double chevron at the top right of the pane.
l To restore a collapsed pane, click the downward-facing double chevron .

Reset and restart a flow in the debugger
When you reset and restart a flow, the values of its flow variables are reset to the values that they had when
you opened the debugger.

1. In the debugger toolbar, click theReset button.

2. Click thePlay button.

Change values of flow variables within the debugger
To see how a flow behaves with different values for its flow variables, you can change the value of a flow
variable before running a step.

1. Open the flow in the debugger.

2. Click Step-Over until the step in which you’re interested is pending.

Note: If you have set a breakpoint before the step, you can click Play to run the flow until it
pauses at the step.

TheContext Inspector pane shows the current values of Step Inputs andStep Context as of the point
at which the step is pending.
You can search, sort, and filter by columns.

l The values in theStep Input section are the values that were assigned to the input before the step
started.

l The values in theStep Context section are the values that were updated after the step began.

3. To change the value of a flow variable used in this step, underStep Inputs, find the listing for the flow
variable, highlight its value, and type a new value to replace it. In the above example, the step is amulti-
instance step. You could add another IP address to the list in the host flow variable.
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4. To change the value of a flow variable that is accessible in this step but is used in a later step, change
the value for the flow variable’s listing underStep Context.

5. Continue to play or step through the flow.
6. To reset any flow variable values that you have changed to the values that were set the last time you

saved the flow, click theReset button.

Set a breakpoint in a flow
Breakpoints provide automatic pauses in the running of a flow in the debugger. This can come in handy when
you want to, for example:

l Examine the value of a flow variable
l Change the value a flow variable to see its effect on the flow in the rest of the run
You set breakpoints in the flow’s diagram, but you can enable or disable any breakpoints that you have set
from inside the debugger.

1. Open the flow open in the authoring pane, and right-click the step where you want to set the breakpoint.
2. Select Debugging > Set Breakpoint.

In the flow diagram, the breakpoint is indicated by a yellow-and-black border surrounding the step.

3. Open the flow in the debugger.
In the debugger’s Debug Options pane, theBreakpoints tab shows the existing breakpoints.

4. Do one of the following:
l To enable a single breakpoint, select the breakpoint’s check box.

l To disable a single breakpoint, clear the breakpoint’s check box.

l To enable or disable all the breakpoints, click Enable/Disable All.

l To clear all the breakpoints, from the Toolsmenu, select Remove All Breakpoints.

Override a response in a debug run for a single step
Response overrides force the response that you selected, even if the operation fails.
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By overriding a response, you can test a particular path of the flow without having to exit the debugger and
change input values.

For example, if you have a step in a flow for which you don’t have the necessary information, youmight want
to test the rest of the flow, regardless of the certain failure of that step. You can force the run to follow the
response and transition that you want, rather than the failure response that would come about without your
intervention.

1. Open the flow open in the authoring pane, and right-click the step whose response you want to override.
2. Select Debugging > Override Response, and then click the response you want to force the step to

have:
l None

l Success

l Failure

l Prompt

After you have created a response override, you can enable or disable the override in the debugger, or
choose a different response for it.

3. Open the flow in the debugger.
In the debuggerDebug Options pane, theResponse Overrides tab shows the existing response
overrides.

4. Scroll up or down to the response override of interest.
5. Do one of the following:

l To choose a different response for an override, click the down arrow and select the response.

l To enable a single response override, select its check box.

l To disable a single response override, clear its check box.

l To enable or disable all the response overrides, click Enable/Disable All.

l To clear all the response overrides, from the Toolsmenu, select Remove All Response Overrides.

l To override the response on every step, select theOverride All Responses checkbox.
When you run the flow in the debugger after overriding all responses, you are prompted at each step
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to manually select a response for the step.

Jump to a flow step from the Run Tree
l Right-click on a step in the Run Tree and select Go to step
or:

Click theGo to step button in the toolbar .
The Flow Editor opens showing the current flow with the step selected.

Setting Overrides in Studio
In Studio you can define overrides per Central connection, for system properties and system accounts.
Creating overrides allows you to change configuration items, system properties, and system accounts (from
content packs), before triggering and without changing values in the context inspector. For example you can
use these overrides to adjust a read-only value that was imported from a content pack.

Note: You can enable or disable individual overrides. Overrides are unique by name and type, and take
precedence over Central overrides.

To access theStudio Overrides:
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1. From theConfigurationmenu, select Studio Overrides.

2. Select the Central connection from theSelect Central drop-down list. When a Central is selected, the
overrides of that Central are displayed.

3. You can perform the following:

l Add a system property or system account override.

l Edit the selected system property.

l Delete the selected system property.

4. Click Apply, to apply the changes andOK when you are done.

Note: If you override a system property with a blank value, the default value from theSystem
Properties definition is used and not the blank value.

Note:When referencing a system property, youmust use the complete path. For example, if there is a
system property under the following folder structure folderA\folderB\my_ci, use the string
${folderA/folder/my_ci} to reference it.

Studio Authoring Guide
Validating Content

HPE Operations Orchestration (10.60) Page 274 of 350



Reference Material
Run Tree pane

TheRun Tree pane shows each step that runs, including steps in subflows of the flow.

Steps that will run simultaneously in an actual execution are run in a serial sequence in the debugger.

Debug Options pane

l Breakpoints are flags that enable you to automatically pause a run at a certain step in order to examine
the results, the path of the run, or the values in the flow variables at a that point.

l Response Overrides force the response that you select, regardless of the result of the operation.
l Studio Overrides displays the enabled Studio overrides. In this view, you can enable and disable them as
required.

l Watches enables the user to create a watch list of variables during the debug. These variables are entries
of the various contexts: Step Inputs, Step Context, Global Context, and the Configuration Items: Selection
Lists, System Properties, and System Accounts. In theWatch list You can add a variable by name, and all
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entries with that name from the various context and from the lists of Configuration Items will be shown in
the watches.

TheDebug Options pane displays breakpoints and response overrides, and enables you to remove them or
enable or disable them for this run.

Transition History pane

The Transition History pane lists the transitions that have been followed in the run and displays their
descriptions.

Step Result Inspector pane

TheStep Result Inspector pane displays the results of the selected step.

l Click theRaw Result tab to see the raw results (the results of the step’s operation).
l Click thePrimary Result tab to see the primary result of the step.
l Click theOther Results tab to see other results that youmay have created.

Context Inspector pane

TheContext Inspector pane displays the current values of flow variables (global as well as local) for each
step.

Navigate to the appropriate section of theContext Inspector pane, to see global variables, flow variables,
and their values for the step’s inputs and the step and global context.

l The values in theStep Input section are the values that were assigned to the input before the step started.
The text boxes that contain the values for flow variables are color coded.
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l The values in theStep Context section are the values that were updated after the step began.
A step’s context is the collection of flow variables and their value assignments in the local contexts of the
step’s flow and any parent flows. (If a flow is a step in another flow, the relationship between the two flows
is subflow to parent flow.)

l The values in theGlobal Context section are system properties and any global variables that have been
created.

Debugger toolbar

GUI item Description Keyboard shortcut

Settings Set parameters for the run. This opens
the Run Settings dialog box.

Play Run the flow to its end. F11

Pause Pause a flow that is running in the

debugger. You can click thePlay
button to start it running again from the
point at which it was paused.

ALT + P

Stop Step a flow that is running in the
debugger.

ALT + C

Step Over Run the flow step by step. F5
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Step Into Step into a step’s subflow. F6

Step Out Step out of a step’s subflow. F7

Go to step Jump to a flow step from the run tree

Reset Reset the flow variable values to the
values that they had when you opened
the debugger.

F12

Debugging Complex Flows
Debugging Flows with Parallel Processing Steps
Studio debugs steps, multi-instance, or parallel split step, with parallel processing. To learn how a flow with
steps that use parallel processing will behave in execution, there is no substitute for running the flow in a
staging environment after testing the flow in the Studio debugger.

You debug a flow containing a parallel split or multi-instance step the sameway you debug a flow without
such steps, but you should take into account that they run differently in the debugger.

What do you want to do?
Debug a parallel split step in a flow
In a flow run, the debugger starts the flows at the start time, and the order in which they finish depends on
variable factors that cannot be predicted in Studio. Thus the debugger cannot predict considerations such as
in the case of conflicting writes to the same flow variable, which lane writes to the flow variable last.

On the other hand, in Studio, you canmanipulate the order in which the lanes will finish in the debugger in
order to test various scenarios in a controlled fashion.

For more information about parallel split steps, see "Creating a Flow with Parallel Split Steps" on page 240.

Debug a multi-instance step in a flow
In a flow run, themultiple instances run concurrently, and the flow continues with the steps that follow one
instance’s response while the other instances are processed.

While this means that you are not testing under actual conditions, it does allow you to examine how long it
takes each instance to finish.

For more information about multi-instance steps, see "Creating a Flow with Multi-Instance Steps" on page
244.
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Debugging a Remote Central with Studio
Studio Remote Debugging allows an HPE OO user to troubleshoot and debug flow runs in a remote Central.
This allows customers to use Studio when investigating issues in their Central environments without having
tomanually deploy fixes andmodify the Central Flow Library.

Before debugging a flow, the user defines the URL to connect to Central. For more information, see theHPE
OOSecurity and Hardening Guide.

You can debug the existing flows, locally changed flows or new flows. Studio takes the flow being debugged,
along with all the subflows and operations (existing, changed or new) and sends them to Central for
execution.

All the debugging or execution of the flow occurs on the selected Central using amerge of the Studio
configuration items, Central configuration items and Context Inspector values.

Configuration items can be overwritten either from Studio or from Central. Upon triggering a flow (just before
the flow starts), HPE OO determines the initial value of the configuration items as following:

l If the user has changed the configuration item in the Context Inspector, this new value is used regardless
of any overrides.

l If a configuration item is not overwritten (neither Central nor Studio) and was not changed in the Context
Inspector, the value is used as is.

l If a configuration item is overridden in Central, but not in Studio overrides, the value is the one from
Central.

l If a configuration item is overridden in Studio overrides, the value is the one from Studio overrides.
During the debug, when you pause, resume, step over, and so on, the user can change values with the
Context Inspector as needed.

Note: The only configuration Items that can be overridden in Central are system properties and system
accounts. Override settings for configuration items in new system accounts are used.

Changes of the flows and configuration items do not affect or modify the Central library. These items are
volatile, meaning that they are only visible for the debug session.

The traces left by a Remote Debugging session are visible in the Central Run Explorer (drill-down), and
Dashboard, as any other execution. The source for such traces can be eventually identified as originating
from a debugger execution and can be filtered out. The drill-down reflects the flow sent from the Studio (with
the eventual changes).

During the debug session, the user can change the context of the execution through the Context Inspector.

Note: All runs started from the Remote Debugger have the Extended persistence level.

For details on run persistence, see "Persistence Level for the Run Log " in the Central User Guide.

Note: In some cases, Studio may start up faster than the time it takes to initialize the local connection.
In these cases, if you start debugging using the local connection right after Studio starts up (the Local
Connection button shows a progress icon), you will see the followingmessage:

Studio Authoring Guide
Validating Content

HPE Operations Orchestration (10.60) Page 279 of 350



Prerequisites
l Align Content Packs
To start the Remote Debugging session, you need to import into the Studio workspace the Central relevant
content packs, with the appropriate version.Therefore, any content packs used by a debugged flow must
have been deployed to Central before starting the debug session.

l Group aliases
If you created a new group alias in Studio (and used them with certain operations), you will need to
manually configure the groups in Central. The debugger cannot decide to which worker group the group
alias shouldmap. If the assigned group of an operation is not found (during the Remote Debugging
execution), it will behave as if it was triggered from Central, pause and prompt the user about the problem.

l Authorized Users
Only users that have been assigned theRemote Debugging permission are allowed to trigger the
Debugger on a remote Central. See theCentral User Guide for more information.

Note: A user who has remote debugging permission is exposed to all flows, but not to system
accounts. The system accounts are only available to users with appropriate permissions.

Note: This restriction does not apply when debugging using the local connection (the default
connection that Studio uses if you do not configure a remote Central).

Typical Workflow
1. Assign to a user a role containing theRemote Debugging permission.
2. Set up the Studio workspace tomatch the Central Library (content packs, flows to be debugged).
3. Configure, if necessary, the Central connection.
4. (Optional) Change the flow before debug.
5. Select a connection from the debug option. When you click the debug option, you are prompted for

credentials. These credentials are saved and remembered in Studio.

Note: If theEnable Capture of Logged-in User Credentials check box is selected in theSystem
Configuration Workspace > Security > Settings option in Central, the following warning
message opens in the Studio remote debugger:
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Note: If authentication has been enabled in Central, you cannot log in with a user that has a colon
as part of the user name, when logging into Central for remote debugging.

6. Execution runs with amerge of theStudio Configuration Items, Central Configuration Items and
Context Inspector. For more information on the Context Inspector, see "Validating Content" on page
265.

7. (Optional) Set breakpoints, and change variables and configuration items by the context inspector during
debug.

8. Execution completes.

What do you want to do?
Add or Edit Central Connections
1. In Studio, select Configuration > Remote Debugger Connections.

2. Click the debug icon , and from the list select a connection to a remote Central. Local Connection
is the default connection.
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3. To add, edit or delete a connection, select Remote Debugger Connections. TheRemote Debugger
Connections dialog box contains a list of available connections. You can edit these connections, delete
existing connections and add new connections.

l Delete: Select the connection that you want to delete and either press the delete key or click the
minus (x) red button.

l Add: To add a new connection, click the green (+) button. Enter a name for the new connection and
the URL of the remote Central.

Note: There is no validation with the connection name and URL. The user is required to check
these settings. Youmust assign a unique connection name.

Always prompt for credentials when authentication is enabled: When you select this option and
the selected Central has authentication enabled, it causes Studio to always prompt the user for
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credentials; if it has already been authenticated, the authentication form will have the credentials
already filled in.

Note: If the user needs to reset the user name or password without restarting Studio, in the
Remote Debugger Connections, check Always prompt for credentials when
authentication is enabled.

Configuring LDAP user and domain: When you create a new connection to Central and connect
using a LDAP user, you are prompted to select the domain, username and password.

Note: You cannot configure the Remote Connections in the studio.properties file.

Set the Proxy for Debugging on a Remote Central
When configuring the connection to a Central, you can set the HTTP proxy information: host, port, user name
and password. The proxy supports the basic authentication scheme.

To setup the proxy:

1. In Studio from theConfigurationmenu, select Options > Connection Settings. TheProxy
Configuration dialog box appears.

2. Enter the proxy information. Youmust enter a host and port number. When you are done, click Save.
The proxy settings are validated on the host and port number.

Import Certificates Automatically with a Remote
Debugger Connection
1. When you select a remote Central connection using HTTPS, you are prompted with the SSLCertificate

message.
The SSLCertificate message displays the certificate’s issuer distinguished name, which identifies the
entity that signed the certificate and the certificate’s subject distinguished name on separate lines.
If the certificate is not trusted, the dialog asks whether you want to trust this certificate.
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Note: Studio supports both self-signed and CA signed certificates.

l If you want to trust the certificate, click Connect. The Studio trustStore is updated with the certificate
(s), and you will be able to connect to Central having a successful SSL handshake.

l If you don't want to trust the certificate, click Cancel. The Studio trustStore will not be affected and
the connection to Central will fail.

2. If the URL of the server and the certificate do not match, the Hostname Validation dialog box is shown:
l If you click Don't Trust, the connection is not permitted.

l If you click Always Trust, the hostname validation failure is ignored and the connection is allowed.
However, when you restart Studio, the hostname validationmessage will be displayed again,
because you are expected to correct this issue. You should correct the URL tomatch the hostname
in the certificate, or change the certificate to be according the connection URL.

Note: The SSLCertificate dialog box also appears when you connect to a Git server via HTTPS.

For SVN, the certificate chain details are presented in the studio.log.

Note: In the studio.l4j.ini file under the Studio installation folder, the default values for self.signed is
false, and the default value for verify.hostname is true.

If the hostname verification fails, an error message opens. You can choose to continue or abort the
operation.

Debugging a Flow on a Remote Central
1. Build a flow using operations and flows from an imported content pack or use an existing one.
2. Open the flow.
3. Run the Debug and select a remote connection that you setup earlier.

Note: Performing a debug on a Central that is part of a production system could be problematic as it
can affect the production data and operation. The Debugger view displays a banner with the name of
the remote connection.
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What do you want to do?
Debug a Flow on a Remote Central
To debug a flow:

1. Build a flow using operations and flows from an imported content pack or use an existing one.
2. Open the flow.
3. RunDebug and select a remote connection that you setup earlier.

Note: Performing a debug on a Central that is part of a production system could be problematic as it
can affect the production data and operation. The Debugger view displays a banner with the name of
the remote connection.

Reuse Existing Flow Inputs
You can use the inputs of a run as input for a new run. This allows you to troubleshoot failed flows, without
having to re-enter or prepare the inputs.

To load or specify a run ID from the current Central for re-running a flow:

1. In Studio, open a flow for debugging.
2. Select a remote Central.
3. Enter the inputs of an execution.
4. Run the flow.
5. Click Load Execution Inputs.

A dialog box appears with a text field that displays the execution id. Studio loads the inputs of the
specified execution id (they are loaded from the currently selected Central). If there are no inputs, then
the execution did not include any inputs or the execution was not found. In this case amessage appears
stating that the current execution has not changed.
After the inputs have loaded, they arematched (based on name) against the inputs of the current flow.
The existing inputs of the flow are updated (no new inputs are added) only if the corresponding loaded
value is not empty. If no input of the current execution is changed, amessage is displayed.
The context inspector highlights themodified inputs and displays the new values.

6. You can now trigger the run with the inputs of the specified execution id.
Inputs are loaded as string values regardless of their type (single value, list of values).

Rerun a Flow
You can rerun a triggered flow using the same inputs as the previous run. In the debug view, theRerun option
is disabled initially and enabled after the first run of this flow. When you click Rerun, the toolbar changes to
the view ready for debug . When you click Play, you are no longer prompted for eventual prompt inputs of the
flow. The new run will use the flow inputs of the previous run.
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Reference Material
Remote Debugger Connections
TheRemote Debugger Connections dialog box contains a list of available connections.

GUI item Description

Add connection Adds a new connection. Type the name and URL of the new connection and click
OK.

Delete connection Deletes the selected connection.

Move up Moves the selected connection higher in the list.

Move down Moves the selected connection lower in the list.
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Exporting a Content Pack
After you have finished validating your flow, you're ready to release it into a content pack, so that it can be
deployed and run.

A content pack is the outcome of a project. It contains entities in the project and reference IDs. A content
pack includes not only flows and operations but also actions and configuration items.

The content pack is the element that you release for deployment in Central.

Note: Invalid flows or operations, for example, those containing duplicate UUIDs, will not be included in
the content pack.

When you create a content pack from a project, by default, Studio names it with a unique version number.
Then, every time you create another content pack from the same project, Studio assigns it with the next
minor version number. The namingmechanism is dependent on various conditions and is described in detail
in "Content Pack Versioning Lifecycle " below.

Note: Your content pack can include folders inside the configuration items.

Note: Content packs created with a Studio version later than 10.20 from projects that contain folders
inside a configuration section (for example, System Properties, System Accounts) cannot be imported
into versions of Studio earlier than 10.20.

However, content packs created with a Studio version later than 10.20 from projects that have no folders
in any configuration section, can be imported into versions of Studio earlier than 10.20.

Content Pack Versioning Lifecycle
By default, Studio handles the versioning of content packs automatically. After a content pack is created, the
last digit of the version number (generally theminor-minor section) is incremented by 1 and a –SNAPSHOT
suffix is added to the current project version. This means that when you work on the project, you are adapting
an in-development version.

For example:

Studio Authoring Guide
Exporting a Content Pack

HPE Operations Orchestration (10.60) Page 287 of 350



You can also change the content pack versionmanually by typing a new version number in the Version field.

Note:

l Studio increments only the last minor version automatically. If you want to increment amajor version
(e.g., 1.0.1 to 2.0.1), you have to do this manually.

l If you enter a version number that is not in the standardmajor.minor.minor.minor.minor... (1.x.x.x.x)
format, the version number will not be automatically incremented when you create another content
pack.

l The number of minors in a version number is variable. So, version numbers such as 1, 1.2,
1.2.3.4.5.06 and 1.1.1.1.1.1.1.2 are also automatically incremented.

Content Pack Versioning Without Revision
Control
Whenworking in Studio without version control, Studio provides an automatic method of incrementing the
project version when creating a new content pack. In this way, you can easily createmultiple content packs
with consecutive version numbers, e.g., 1.0.1.1, 1.0.1.2, 1.0.1.3.

When opening the Create Content Pack wizard, Studio reads the version in the content pack properties,
removes the –SNAPSHOT suffix, and presents the version number in the Content Pack Properties step.

After clickingCreate CP in the Dependencies Management step, the content pack is created, and the last
digit of the version number is automatically incremented by 1.

The –SNAPSHOT suffix is added to the Project version whichmeans that when you work on the project, you
are adapting an in-development version.

Note:

l Studio increments only the last minor version automatically. If you want to increment amajor version
(e.g., 1.0.1 to 2.0.1), you have to do this manually.

l If you enter a version number that is not in the standardmajor.minor.minor.minor.minor... (1.x.x.x.x)
format, the version number will not be automatically incremented when you create another content
pack.

l The number of minors in a version number is variable. So, version numbers such as 1, 1.2,
1.2.3.4.5.06 and 1.1.1.1.1.1.1.2 are also automatically incremented.

Content Pack Versioning With Revision
Control
Whenworking with revision control, every time you create a new content pack, Studio adds an SCM (SVN or
Git) tag that represents a snapshot of the current state of the repository (for Git) or project (for SVN). This tag
incorporates the content pack name and version number.

Using this tag, you can easily reset to/update to a previous project version and reset your current environment
to the same sources that were used at the time a content pack was created.

Studio Authoring Guide
Exporting a Content Pack

HPE Operations Orchestration (10.60) Page 288 of 350



In this way, you can easily create a patch for a specific content pack.

Note: Before creating a content pack release, youmust ensure that you have no local uncommitted
changes on the project and that the project revision is up-to-date. The content pack creation will fail if
these two conditions are not met.

However, if the conditions are not met, you can create a temporary "SNAPSHOT" content pack. For this
content pack, the version number is not incremented, and you will not be able to run aRevert to an
older project version operation.

What do you want to do?
Create a content pack
1. In theProjects pane, select the project from which you want to create a content pack.
2. Select File > Create New Content Pack.

Note: Alternatively, you can select theCreate Content Pack button in theProjects pane or
right-click on the project and select Create Content Pack.

If there are unsaved editors open, theSaving dialog box gives you the option to save the changes. Click
Yes to All to save all changes in the open editors, or click Yes orNo for each one individually.

3. In the Content Pack Properties step of theCreate Content Packwizard, enter the content pack details:
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Note:

l TheName field is taken directly from the project name and you cannot change it.

l The new project version is the Development version set in the Advanced tab of the Content Pack
Properties step of the Content Pack Creation wizard.

4. In the Location field, enter or browse to the location where you want to save the content pack. By
default, the path to the project workspace is selected.

Note: By default, the path shown here is the last location in which you created a content pack.

5. In thePublisher field, enter the publisher of the content pack. This information will appear in the content
pack's Properties page.

6. To edit theDescription field, right-click on the project in the Projects tree and select Properties. Then,
type a description in Description area.

7. Select theRelease check box to create a final version of the content pack for publishing. After checking
this box, the -SNAPSHOT suffix is removed from the version number in Version field.

Note:

l If the Release check box is disabled, this means you are not connected to any source control
management system.
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l If you select theRelease check box, the SCM Synchronization window is added as Step 3 in the
Content Pack wizard. See "Content Pack CreationWizard - Step 3" on page 298 for details.

8. In theVersion field, the next minor version number is shown. The last digit of the version number is
automatically incremented when you create a new content pack. However, you can change this number
manually by typing a different version number. For details, see "Content Pack VersioningWithout
Revision Control " on page 288.

Note:When creating a release version of the content pack, Studio commits the project properties
and adds an SCM tag to the content pack.

9. For source control only: Select theRelease check box if you want to increment the revision number
when you commit the changes to SVN/Git.

10.  Select Advanced to show the following fields:
a. Development version: The next version with the extension -SNAPSHOT automatically appears in

this field. You can change it as required.
b. For source control only:SCM Tag:By default, the SCM tag name that will be used when

releasing the content pack is [<projectname>-<version>]. However, you can change this as
required, and type a different name that helps you to identify the version in the source control.

11. Select the Include the system accounts passwords? check box if you want the content pack to
include passwords for the system accounts. When the content is deployed on Central, the user names
and passwords will be deployed.

Note: The passwords will be obfuscated inside the content pack. However, this is NOT a safe
option and is not recommended.Alternatively, it is recommended to use the option of configuring the
system accounts in Central. For details, see "Setting UpConfiguration Items for a Content Pack" in
theCentral User Guide.

12. Click Next.
If the dependencies are not up-to-date, the Dependency Management window opens:

Studio Authoring Guide
Exporting a Content Pack

HPE Operations Orchestration (10.60) Page 291 of 350



13. From this window, you canmanage dependencies - add, delete, edit and update dependencies as in the
Dependencies Editor. See "Managing Content Packs and Dependencies in a Project" on page 99 for full
details.

14. Click Next.
If you selected theRelease check box in the first step, the SCM Synchronization window opens.

Note: The SCM Synchronization page displays only in the following cases:

l If the project is not synchronized

l Changes weremade to the project dependencies in theDependency Managementwindow

l If there are uncommitted changes in the workspace.

Otherwise, you will see the Validation and Progress window after clickingNext.

If there are any SCM synchronization issues between the local version and themain repository, Studio
displays them in the SCM Synchronization window. Youmust solve these issues before continuing. You
can use the SCM toolbar to commit, push or revert changes as described in "Working with Git Source
Management System " on page 60.
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Note: If youmodified the dependencies in the Dependencies management step, they will also
appear as changes in the SCM Synchronization step.

After solving the SCM issues, click Retry. If there are nomore issues, you will see the following
message:

You can now continue creating the content pack.

15. Click Create CP.
All the commit operations that were performed for the current branch are automatically pushed to the
main Git repository and the content pack is created.
If there are any invalid flows or dependency warnings in the project, Studio presents them. Click Details
to see the warnings.
Invalid flows are not packaged into the content pack.
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The content pack is created in the specified location.
16. After the new content pack is created, amessage appears,with a link to the location in which the content

pack was created.Click on the link to access the content pack.
17. Click Finish to close the wizard window.
The new content pack can now be deployed and run, or imported into another project.

Note: After the content pack is created, the contentpack.properties file contains the version number as
follows:

l Content Pack: contentpack.properties contains the published version. For example, 1.8.3.
l Project: contentpack.properties contains the next snapshot version. For example, 1.8.4-
SNAPSHOT.

l The version number is saved in the pom.xml file. The pom.xml file also includes project dependencies
information.

View/edit the project version
1. In theProjects pane, select the project whose version you want to view/edit.
2. Select theProperties option in theProjects pane.

or:
Right-click the project and select Properties.
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Reference Material
Content Pack Creation Wizard - Step 1

GUI item Description

Name The name of the content pack is taken from the project name. This
field is read-only.

Location Enter or browse to the location where you want to store the content
pack. By default, the path to the project workspace is selected.

Publisher Enter the publisher of the content pack. This information will appear
in the content pack's Properties page.

Description To edit theDescription field, right-click on the project in the
Projects tree and select Properties. Then, type a description in
Description area.

Release  Select this check box if you want to increment the revision number
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when you commit the changes to SVN/Git.

This also creates a tag with the current state of the project (SVN) or
repository (GIT).

If you select this check box, Studio adds the SCM Synchronization
step to the Create Content Pack wizard.

Version Enter the version of the content pack. This information will appear
in the content pack's Properties page.

Advanced Select the arrows to show the SCM fields.

Development version The next version with the extension -SNAPSHOT automatically
appears in this field. You can change it as required.

SCM Tag Type the text you want to use as the SCM tag name. You can use
this field to identify the version in the source control.

Include the system accounts
passwords?

Select the check box if you want the content pack to include
passwords for the system accounts. These passwords will be
obfuscated. If this check box is not selected, the passwords will
not be included in the content pack.

Note: For security reasons, it is recommended to configure
the system account passwords in Central.
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Content Pack Creation Wizard - Step 2

GUI item Description

Add a new dependency.

Delete a dependency from the list.

Edit a dependency's properties.

Update dependencies.
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Content Pack Creation Wizard - Step 3

GUI
item Description

Commit all changes:Commits all the changes in theSCM Changes pane. Only
available when there are changes.

Revert all changes:Reverts all changes that show in theSCM Changes pane.
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Managing Flows and Operations
Your project library may contain a large number of flows and operations. This chapter discusses how to
manage this library—how to locate, copy, and bookmark items, how to see how they are used, and how to
create new operations.

Creating Operations
There are three ways to create operations in Studio:

l Copying andmodifying existing operations.
l Importing an operation from an already existing plugin.
l Creating an action plugin in Java and importing that action plugin to Studio.

Creating Operations from Action plugins
An action plugin is a jar file containing IActions or@Actions. You can import an action plugin to Studio, in
order to create an operation from one of the actions in it.

An action plugin may includemultiple actions, and you can create an operation from each one of these
actions.

For information about developing action plugins, see theAction Developers Guide.

Copying Operations that were Created from Action plugins
When you copy an operation that was created by importing an action plugin, the copied operation continues to
reference the original operation. If the action plugin is upgraded, when you update the original operation to call
the new version, the copied operations are all updated automatically. This is known as a "soft copy".

The source operation, which this operation was copied from, is displayed in theAdvanced tab.

Note that the link to the action plugin is the only item that is automatically updated in the copied operations.
Changes that youmake to the original operation's input, output, variables, scriptlets, and so on, are not
updated in the copies.

Valid Operations
A valid operation requires:

l There are operations that require no inputs such as UUID Generator.
l At least one response that is mapped to valid expressions describing outcomes of the operation.
If the new operation is invalid or incomplete, its name is displayed in theProjects pane in red zig-zag
underscore. Moving the cursor over the name displays a tool tip that specifies how the operation is
incomplete.
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Best Practice
To help authors who will create flows using the operations you create, add the following information to the
operation’s Description tab:

l A description of what the operation does.
l Inputs that the operation requires, including where authors can find the data that the inputs require and the
required format for the data.

l Responses, including themeaning of each response.
l Result fields, including a description of the data supplied in each result field.
l Any additional implementation notes, such as:

l Supported platforms or applications, including version information

l Application orWeb service APIs that the flow interacts with

l Other environmental or usage requirements

What do you want to do?
Copy and modify an operation in Studio

Important! If you need to delete, create, or rename an operation inside your project, make sure to do this
from within Studio, and not by deleting, creating, or renaming the item in the file system.

1. In theDependencies pane orProjects pane, select the operation that you want to copy.
2. Select Edit > Copy.
3. Select the location in the project tree where you want to paste the copy, and select Edit > Paste. The

operation is treated as a new object.
4. To assign the operation to a category for search purposes, click Assign Categories and then select a

category from the list.
5. To create an input, click the Inputs tab and then click Add Input.
6. In the dialog that appears, type the input name and then click OK.

l For information on what inputs are and how to use them, see "Creating Input" on page 166.

l For information on defining an input data source, see "Specifying the Input Source " on page 175.

7. Add and define any output data.
For information on adding and working with output data, see "Setting Operation Outputs" on page 205.

8. Create any responses needed andmap results to the responses.
For information on defining rules that govern which responses are chosen for the operation, see "Setting
Responses" on page 192.

9. Click theDescription tab and write the description in the text box.
10. Click OK.
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Change the source operation that the operation is based on
If you created an operation by copying an existing operation, you can change the source operation. Your
copied operation will become a copy of the operation that you select as the source.

1. Open a copied operation, and select Properties.
2. In the Properties sheet, click theAdvanced tab.
3. UnderSource Operation, click theSelect button.
4. In the Select Source Operation dialog box, navigate to and select the source operation that you want to

base the copy on, and then click OK.
5. If required, rename the operation to reflect the change.
6. Review andmake any changes necessary to the value assignments for inputs, to reflect any differences

between the old operation’s inputs and those of the new one.

Create an operation by importing an action plugin
Themost direct way to create an operation from an action plugin is to import it and create the operation at the
same time.

1. Create and pack an action plugin, so that it includes the actions that were developed. For information
about how to develop an action plugin, see theAction Developers Guide.

2. In Studio, right-click the folder where you want to create the new operation, and select Import plugin.
3. In the Import Plugin dialog box, click the browse button to browse to and select the HPE OO plugin that

you want to import.

Note: It is possible to import a single plugin (maven artifact), either by the JAR file or by the POM
file. The plugin must have both its JAR and POM file at the same location.

If you import a plugin that was already deployed, the new plugin replaces the existing one.

4. Select the Import and create new operation check box and click OK.
5. In the Create Operations dialog box, expand the plugin containing the actions that you need, and select

the actions that you want use to create the operation from.
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Note: If a plugin contains multiple actions, you can select more than one action, to createmultiple
operations.

For each action that you selected, a new operation is created in the folder where you right-clicked.
In each operation, the information about the action plugin is displayed in theOperation Fields section at
the top of the Inputs tab, in the operation's Properties window.

6. Save the operation.

Create an operation from an imported action plugin
After action plugins have been imported to Studio’s repository, you can create operations from the actions in
them.

1. In Studio, right-click the folder where you want to create the new operation, and select New >
Operation.

2. Browse to locate the plugin, from Studio’s repository, and click OK.
3. In the Create Operations dialog box, select the action that you want use to create the operation from.
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Note: If the plugin contains multiple actions, you can select more than one action, to createmultiple
operations.

For each action that you selected, a new operation is created in the folder that you right-clicked on.
In each operation, the information about the action plugin is displayed at the top of the Inputs tab, in the
operation's Properties window.

Import action plugins
It is possible to simply import action plugins to Studio’s repository, so that they are available for you or other
authors to create operations from, at a later date.

1. In Studio, select File > Import plugin.
2. In the Import plugin dialog box, browse to and select the HPE OO plugin that you want to import to

Studio’s local Maven repository.
3. Click OK. The plugin is available for authors to create operations from. For more information, seeCreate

an operation from an imported action plugin.

Create a manual operation
A manual operation is one that offers a choice of actions. The user will need to select an action at runtime.

To create amanual operation, you copy themanual operation template from the base content and define the
actions that will bemade available to the user.

1. In theDependencies pane, select themanual operation template, located in the contact pack, for
example, base-cp/Library/Utility Operations/Manual.

2. Select Edit > Copy.
3. Select the location in the project tree where you want to paste the copy, and select Edit > Paste. This
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operation is treated as a new object and is detached from the content pack it arrived with.
4. In the operation properties, add the actions that will be available to the user.

Create a display operation
A display operation is one that displays information in a pop-up prompt message, but does not perform any
other action. The user will just need to click Continue at runtime.

To create a display operation, you copy the display operation template from the base content in
Library/Utility Operations/Display Message and define the information that will be displayed to the
user.

The prompt message can include variables. For example, to tell the user what time the preceding step
concluded, you could include a date/time variable (${dateTime}) in themessage.

1. In theDependencies pane, select the display operation template.
2. Select Edit > Copy.
3. Select the location in the project tree where you want to paste the copy, and select Edit > Paste. This

operation is treated as a new object and is detached from the content pack it arrived with.
4. In the operation properties sheet, select theDisplay tab.
5. Click theDisplay tab in the Step Inspector.
6. Select theAlways prompt user before executing this step check box.
7. In thePrompt Title box, type the prompt's label (up to 128 characters).
8. In thePrompt Width box, type the width of the prompt in pixels.
9. In theHeight box, the height of the prompt in pixels.
10. In thePrompt Text box, type amessage to the user.
11. Click OK, and save your changes.
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Reference Material
Create Operations dialog box

GUI item Description

Select operations to import Expand the plugin containing the actions that you need, and select the
actions that you want use to create the operation from.

Step Inspector > Display tab
In theDisplay tab of the Operation Properties sheet, you can create a user prompt that is displayed to the
user.
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GUI item Description

Always prompt user before
executing this step

Select the checkbox if you want the prompt window to appear every
time this step is run.

Prompt Title Type the label that will appear in the title bar of the prompt window (up to
128 characters).

Prompt Width Type the width of the prompt window in pixels.

Height Type the height of the prompt window in pixels.

Prompt Text Type themessage that will appear in the body of the prompt window.
You can include variables in themessage. For example, ${dateTime}.

Import Plugin

GUI item Description

Plugin location Browse to and select the HPE OO plugin that you want to
import.
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Import and create new
operation

Select this check box to create a new operation from the
imported plugin.

Operation Properties: Advanced tab

GUI item Description

Link To Displays the source operation, from which the selected
operation was copied.

Location Displays the location of the source operation.

Select Lets you select a different source operation

Open Opens the Properties sheet of the source operation.

Detach Detaches the operation from the parent plugin.

Finding a Flow or Operation
There are a number of ways to find the flow or operation that you need:

l Browse the folders in theProjects pane andDependencies pane
l View the descriptions of the folders, flows, and operations
l Run a search using theSearch tab
l Run a search using theNavigate to flow... option

What do you want to do?
Browse the folders to find a flow or operation
The simplest way to locate a flow or operation is to browse through the folders.

If the folders have been named and structured correctly, this should help you to find what you need.

Use the descriptions to locate a flow or operation
You can view the description in an operation or flow, to see if it is the one you need.

l To view the description of an operation, open the operation in the authoring pane and click theDescription
tab.

l To view the description of a flow, open the flow in the authoring pane, and click Properties (at the bottom
of the pane), and then click theDescription tab.
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Note: Alternatively, it is possible to right-click the flow or operation in theProjects pane or
Dependencies pane and select Properties.

Generate documentation to find a flow or operation
You can also use the Generate Documentation feature to gather this information for many flows and
operations into one place. For more information onGenerate Documentation, see "Generating Documentation
about Flows andOperations" on page 320.

Search for an operation or configuration item using the Search tab
Using theSearch pane, you can perform a full-text search throughout the Library. You can search for flows,
operations, or configuration items by searching on the name or other field properties.

1. Click theSearch tab at the bottom of the Studio window, to open theSearch pane.
2. From theSearch list, select a field to search on.

Note: To include all the fields in your search, leave theSearch list set to <all fields>.

3. In the for text box, type the text you want to search for.
If the search string contains a space, you can specify either an exact search or a search that includes
spaces. An exact search treats the entire string, including any spaces that it contains, as a single search
value. If you insert space, the search looks for all of the strings that are separated by spaces.

Note: The search for the search string you type is not case-sensitive.

4. Define how the search treats spaces:
l To specify a search that treats spaces as part of a single search string, select theExact check box.

l To specify a search that treats spaces as separators for alternate search strings, clear the selection
from theExact check box.

5. Click the search button .

6. Check the text in theDescription tab to identify the operation that you need.
In search results, the description is taken from theDescription tab of the operation and includes
information that is vital to getting themost from your use of the operation, including:
l The kind of information the operation’s inputs need.

l The information that the results include.

l The operation’s requirements and assumptions.

To read the entire description, see theDescription tab in the operation’s Properties sheet.
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Search using a previous search command
1. In theSearch pane, click theSearch History button.

The Previously Entered Search Strings window opens.

This window contains a list of up to 25 previous search commands.
The format of the search commands in the list is “<field name> for search text”.

2. Double-click a search command from the list to run it. It is then added to the top of the list.

Sort search results
Click the column header in any of the columns, to sort the search results by that parameter.

Search with Lucene syntax
To target more-specific results, you can construct a search with the Apache Lucene syntax. For more
information on the Lucene search syntax, see the Apache Software FoundationWeb site.

1. Click theSearch tab at the bottom of the Studio window, to open theSearch pane.
2. From theSearch drop-down list, select <with Lucene query>.

3. In the for text box, type your query, using Lucene search syntax, and then click the search button .
The simplest Lucene search syntax is:

<searchable_field_name>:<string to search for>

Tips for searching:
l The search uses a Boolean AND. If you type two words with AND, the search returns only operations
or flows that contain both words. If you type two words without AND, the search finds any results
that include either word.

l To obtain results that include only a string that has a space in it, such as in the search
category:database server, enclose the string in quotationmarks: category:”database server”

You can search for the following field names. Note that this list includes sample search strings.
l Flow or operation name
Examples:

name:Get Temp Dir
name:Clear Temp Dir
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l Operation type
Example:

type:cmd

l Category
Example:

category:network

l Input name
Example:

inputs:server

l Flow or operation UUID
Example:

id:1234-3453-3242-32423

l String contained in flow or operation descriptions
Example:

description:clear

Access an operation from the Search pane
You can work with operations and flows directly from the search results, opening them for editing or adding
them to a flow that is open in the authoring pane.

l To open an operation’s Properties sheet or a flow’s diagram, double-click in the row of the operation, in the
search results.

l To create a step from an operation in the search results, drag the operation from theSearch pane onto a
flow diagram.

Search for a flow using the Navigate to flow... option
You can also use theNavigate to flow.. option to easily find and open a flow in your workspace.

1. Select Tools > Navigate to flow... .
TheSearch flows by name:window opens.

2. Type in part of the flow name.
The window is immediately populated with search results. For example, if you search for a flow whose
name contains the string "use", youmay see the following results:
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3. Use the Up and Down arrow keys tomove in the list, then press Enter to open the selected item.
Alternatively, you can open an item with a double-click.

4. You can create steps in the current Flow Editor by dragging and dropping flows from the list.

Reference Material
Search pane

GUI item Description

Search l To run the search on one field, select the field on which to run
the search.

l To include all the fields in your search, select <all fields>.
l To search using Lucene query, select <with Lucene query>.

for Type the string you want to search for.

Exact l To specify a search that treats spaces as part of a single search
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string, select theExact checkbox
l To specify a search that treats spaces are separators for
alternate search strings, clear the selection from theExact
checkbox.

Rank Displays the ranking of each search result. More stars means a
higher rank.

Type Displays the type of item that was found, for example, a flow.

Path Displays the location where the item is stored.

Description Displays the description of the item, taken from the item's
Description tab.

Search History Click to display the Previously Entered Search Strings window,
and reuse a search command.

Search and Replace References to an
Operation or Subflow
Theremay be cases in which you want to change the reference to an operation or subflow globally throughout
all open projects or in a specific flow.

For example, youmay have a reference in your flows to a subflow namedChange Status, and now you want
to change this reference to a new subflow you created namedUpdate Status. This can be done easily with
theReplace Reference to Operation or Subflow functionality.

What do you want to do?
Find and Replace a Reference to an Operation or Subflow
1. Select Edit > Replace or press Ctrl+R.

The Replace Flow or Operation Reference dialog opens.
2. In the Find what field, type or paste in the full path of the operation or subflow you are looking for. For

example, /My Project/Library/My Ops Flows/Restart Service.
or:

Click and select the subflow or operation from the project tree.
3. Similarly, in theReplace with field, type or paste in the full path of the operation or subflow to use to

replace the original one or click and select the subflow or operation from the project tree.

Note: In both the Find what andReplace with fields, when you type in a character(s), the field is
immediately populated with search results. For example, if you type in the string "rest" youmay see
the following results:
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4. In theWhere area, select the scope in which you want to search:
l All open projects

l Selected folder

l Current flow

5. Select Include subflows to include subflows in the search for the source item according to the criteria
selected above (i.e., subflows of all open projects, the selected folder or current flow).

6. In the Inputs area, select one of the following options:
l Merge step inputsMerge the inputs of the source item with inputs of the target item

l Overwrite step inputsOverwrite the inputs of the target item with the inputs of the source item

7. When you replace a step that points to an operation, note that the results of a stepmay bemapped to
one of the operation's outputs (as defined in the Results tab of the Step Inspector).
If this output is deleted, there will be unmapped results.
In theResults area, select Remove Unmapped Results to remove these results.

8. In theAdditional options area, select the relevant check boxes:
l Remove step scriplet:Select this check box to the remove the step scriptlet in the target item if it is
no longer needed.

l Replace step description:Select this check box to replace the target item's step description with
the source item's step description in theDescription tab:

l Replace step nameSelect this check box to replace the target item's step namewith the source
item's step name.

9. To begin the search, click Find Next.
A message appears showing the next occurrence of the item. For example, a search for the stepDoes
Service Exist? produces the following results:

Found match in flow abc/Library/My Ops Flows/Restart Service

10. To replace this occurrence of the item, click Replace. To replace all occurrences of the item (in the
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locations specified in theWhere area), click Replace All.

Note: If you open theReplace flow or operation reference dialog when a flow is open, the Find What
field is automatically filled with the current step reference.

Reference Material
Replace Reference

GUI item Description

Find what Type or paste in the full path of the operation or subflow you are

looking for or click and select the subflow or operation
from the project tree.

Replace with Type or paste in the full path of the operation or subflow to use to
replace the original one or click and select the subflow or

operation from the project tree.

Where Select where to search for the source item.

All open projects Search for the source item in all the projects currently open in
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Studio.

Selected folder Search for the source item in the selected folder only. Select a
folder using the button.

Current flow Search for the source item in the current flow only.

Include subflows Include subflows in the search for the source item according to the
criteria selected above (i.e., subflows of all open projects, the
selected folder or current flow).

Inputs

Merge step inputs Merge the inputs of the source item with inputs of the target item.

Override step inputs Overwrite the inputs of the target item with the inputs of the source
item.

Results

Remove unmapped results Remove unmapped results of a step in the target item. See Step 8
in the "Find and Replace a Reference to anOperation or Subflow"
on page 312 procedure for details.

Additional options

Remove step scriplet Select this check box to remove the step scriptlet in the target item
if it is no longer needed.

Remove step description Select this check box to replace the documentation property of the
step with the documentation of the new flow/operation.

Replace step name Select this check box to replace the target item's step namewith
the source item's step name.

Copying Flows and Operations
There are different ways to copy flows and operations:

l If you copy a flow or operation, you can paste it in any folder that is not sealed. If you copy a flow, this
copies only the flow and not the operations that comprise the flow.

l If you click Copy Deep, this copies not only the flow but also all the operations that comprise the flow.
You would do this when you will need tomodify the operations in the new flow, and do not want to affect
the original operations.

l If you duplicate a flow or operation, the duplicate is automatically placed in the same folder as its original,
and is namedCopy of <name>.

l If you cut a flow or operation, you remove it from its current location, to be pasted somewhere else.
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Copying Operations that were Created from Action Plugins
Soft copies

When you copy an operation that is linked to an action plugin jar file, the copied operation continues to
reference the original operation. If the action plugin jar file is upgraded, when you update the original operation
to call the new version, the copied operations are all updated automatically. This is known as a soft copy.

Note that the link to the action plugin jar file is the only item that is automatically updated in the copied
operations. Changes that youmake to the original operation's input, output, variables, scriptlets, and so on,
are not updated in the copies.

You can copy operations from a content pack, but keep a reference to the parent contact pack. If a future fix
is implemented to the parent plugin, then the soft copy will also receive the fix. In certain cases, youmay not
want to receive fixes to the operation. In this case, you can detach the operation from the parent plugin.
However you will need tomanually fix the detached operations.

Soft copies have advantages and disadvantages:

l The disadvantage is that if the original operation gets deleted, the copy is parentless and loses its link to
the plugin. In this case, a new parent will have to be selectedmanually.

Note: In order to fix an orphan soft copy operation that points to a nonexistent parent, use theSelect
button from theAdvanced tab of the operation to attach a parent operation.

l The advantage is that if the original operation is updated with a different plugin version, the soft copy gets
updated.

For more information about creating operations from action plugin jar files, see "Creating Operations" on page
299.

Hard copies

In versions of OO prior to 10.00, when you copied an operation linked to an action plugin, this created a hard
copy, meaning that the copy was directly linked to the action plugin in the sameway that the original was.
When the action was updated—for example if the name of the JAR or the class was changed—this had to be
updated in all the hard copied operations.

In OO 10.x, you can create a hard copy by creating a new operation and selecting the relevant plugin. This
method creates a new operation according to the IAction getTemplate or the@Actionmetadata. Is not
possible to create a hard-copy of an operation that also duplicates its inputs and outputs.

Hard copies have advantages and disadvantages:

l The advantage is that if the original operation gets deleted, the copy is not affected and doesn’t remain
parent-less.

l The disadvantage is that if the original operation is updated with a different plugin version, the hard copy
does not get updated.

Note: TheSelect button in theAdvanced tab in the operation editor is not available for hard copies.
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Changing From a Soft Copy to a Hard Copy
It is possible to detach a soft copy from its parent andmake it a hard copy. In the operation's Advanced tab,
you can detach the operation from its parent by clicking theDetach button. A confirmationmessage appears
and the plugin's GAV parameters are taken from the original parent.

Replacing a Plugin in a Hard Copy
You can search for all the hard copied operations that use a specific plugin, and choose the operation, and
replace the plugin GAV parameters.

What do you want to do?
Copy a flow or operation
1. In theDependencies pane orProjects pane, right-click the flow or operation that you want to copy.
2. Select Edit > Copy.
3. Navigate to the folder in which you want to place the copy, right-click and select Edit > Copy.

Duplicate a flow or operation
When you duplicate a flow or operation, the duplicate is automatically placed in the same folder as its original,
and is namedCopy of <name>.

1. In theDependencies pane orProjects pane, right-click the flow or operation that you want to copy.
2. Select Edit > Duplicate.

Deep copy a flow or operation
Deep copying a flow copies not only the flow but also all the operations that comprise the flow.

1. In theDependencies pane orProjects pane, right-click the flow that you want to copy.
2. Select Edit > Copy Deep.
3. Navigate to the folder in which you want to place the flow and its operations, right-click and select Edit >

Paste.

Cut a flow or operation
1. In theDependencies pane orProjects pane, right-click the flow or operation that you want to move.
2. Select Edit > Cut.
3. Navigate to the folder in which you want to place the flow or operation, right-click and select Edit > Cut.
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Finding Out How Flows and Operations are
Used
You can learnmore about ways to use and implement an operation or flow by looking at how it is used in
existing flows. This can be done in theReferences pane.

Studio has two kinds of references:

l References to the operation or flow – lists the flows that have a step created from the selected operation or
flow

l References from the operation or flow – lists the objects (selection lists, permissions assigned to groups,
system filters, and so on) that the selected operation or flow makes use of. In the case of flows, these are
the operations (including subflows) from which the flow’s steps were created.

Best Practices
Changing an operation or flow can break other flows that use it. Beforemaking changes to a flow or operation,
useReferences >What uses this? to check whether other flows use it.

What do you want to do?
Identify what uses a flow or operation
1. In theProject pane, right-click the operation or flow, and select References >What uses this?.
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TheReferences pane opens, displaying the references to the operation or flow.
2. Double-click a row in theReferences pane to open the item for editing.

Note: To openmultiple items, select them using the SHIFT or CONTROL keys, right-click, and
select Open.

Identify what a flow or operation uses
1. In theProject pane, right-click the operation or flow.
2. Select References >What does this use?.

TheReferences pane opens, displaying the references from the operation or flow.

Tip: The referenced flows and operations are valuable as samples that you can copy, paste, andmodify.

Reference Material
Reference pane
In theReferences pane, you can see how an operation or flow is used in existing flows.
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GUI item Description

Object Displays the object that is used or uses the selected flow or operation

Path Displays the location of the object that is used or uses the selected flow or
operation

Generating Documentation about Flows and
Operations
Important: In the current version, the Create Documentation functionality is not supported at runtime.
You can generate documentation from within Studio, but if you create a flow with a Create
Documentation step, this step will not work at runtime.

You can document flows and operations, to providemore information about them for other users:

l Export the flow as a PNG image.
l Use theGenerate Documentation feature to create an HTML page with information about flows and
operations.

Structure of Generated Documentation
When you generate documentation, an HTML page named index.html is created. This page contains the
following frames:

l Overview frame – In the upper-left, theOverview frame lists the sub-folders contained in the folder for
which you generated documentation. Select a folder to display its contents in the Folder frame.

l Folder frame – In the lower-left, the Folder frame lists the flows and operations in the folder that is
selected in theOverview frame.

l Header frame – In the upper-right, theHeader frame contains anOO banner.
l Operation frame – In the lower-right, theOperation frame displays the description of the flow or operation.
This is the information that was entered in theDescription tab of theProperties sheet.
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What do you want to do?
Export a flow as a PNG image
1. Open the flow in the authoring pane.
2. Right-click anywhere in the authoring pane and select Export to PNG.
3. Browse to the location in which to store the image and click Save.

Generate documentation in standard format
You can generate documentation for a folder containing specific flows and/or operations, or for the entire
Library folder.
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1. Right-click the folder for which you want to create documentation.

Note: You can only generate documentation in theContent Packs tab. This option is not available
in the Library view.

2. Select Generate Documentation > Standard Format.
3. Browse to the location in which to store the documentation files and click Save. The HTML file,

index.html, opens in aWeb browser.
4. If you need to overwrite a previous version of index.html, click Yes To All.

Note: If you prefer not to overwrite the previous documentation, click Cancel and repeat the
process, while saving the files in a different location.

Generate documentation in a custom format
1. Right-click the folder for which you want to create documentation.
2. Select Generate Documentation > Custom Format.
3. In the Select Documentation Generation Template dialog box, select the template to be used when

generating the documentation.
4. Browse to the location in which to store the documentation files and click Save. The HTML file,

index.html, opens in aWeb browser.

Create a customized Generate Documentation template
Documentation templates are stored in theStudio\template folder. They have the suffix .vm and can be
edited in a text editor. For information about the templates, see theReferenceMaterial section below.

Any new .vm files that you create in theStudio\template folder will appear in the template list in the Select
Documentation Generation Template dialog box.

1. Make a copy of the relevant .vm template, and rename the copy.

Caution: Do not modify or rename the original .vm templates.

2. In a text editor, make your changes to the new template, and save.
3. In Studio, right-click the folder that you want to document and select Generate Documentation >

Custom Format.
4. In the Select Documentation Generation Template dialog box, select the custom template that you

created.
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Reference Material
.vm Template Files

Folder_template.vm
The root template, which generates a frameset and calls the following to populate it:

l All_folders_template.vm - generates a list of the sub-folders of the folder and places it in overview-frame
(upper-left).

l All_ops_template.vm - generates a list of all operations and places it in folderFrame (lower left).
l Header.html - places the header in headerFrame (upper right).
l Folder_overview_template.vm - generates information about one or more operations and places it in
opFrame (lower right).

All_folders_template.vm
Generates a table of contents for the folders.

l Header.css – style sheet used for general fonts, colors, and so on.
l All_ops_template.vm – generates a list of all operations and creates a link to display it in folderFrame
(lower left).

l Folder_contents.vm – generates a list of the selected folder’s contents and creates a link to display it in
folderFrame (lower left).

All_ops_template.vm
Generates a table of contents for all operations and the documentation for every child operation.

l Header.css – style sheet used for general fonts, colors, and so on.
l Op_template.vm – generates and creates a link to display it in opFrame (lower right).

Folder_overview_template.vm
Generates a tabular summary describing the contents of a folder.

l Header.css – style sheet used for general fonts, colors, and so on.
l Folder_contents.vm – generates and creates a link to display it in folderFrame (lower left).

Op_template.vm
Generates documentation for a single operation.

l Header.css – style sheet used for general fonts, colors, and so on.
l Folder_template.vm – generates and creates a link to display it in same frame (up to parent folder).
l Folder_contents.vm – displays the folder contents in folderFrame.
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Flow_template.vm
Generates the documentation for a single flow.

l Header.css – style sheet used for general fonts, colors, and so on.
l Flow_template.vm – generates and creates a link to display it in same frame (up to parent folder).
l Folder_contents.vm – generates a list of the folder contents and creates link to display it in folderFrame
(lower left).

l Op_template.vm – generates and creates a link to display it in opFrame (lower right).

Folder_contents.vm
Generates a table of contents for a single folder.

l Header.css – style sheet used for general fonts, colors, and so on.
l Op_template.vm – generates and creates a link to display it in opFrame (lower right).

Header.html
The Hewlett-Packard banner.

Hp_rockwell.css
Style sheet for the Hewlett-Packard banner.

Hp_steps_307x39.jpg
Graphic for the Hewlett-Packard banner.

Logo_hp_smallmasthead.gif
Logo for the Hewlett-Packard banner.

Managing Version History of Flows and
Operations
Each time that a configuration item, flow, or operation is saved, a new version of the item is created. The
Version History dialog box list these versions, and lets you:

l View an earlier version of an item
l Save the earlier version under a different name
l Restore an item to its earlier version
l View the differences between two versions

Note: Version history functionality only applies to your local authoring work in Studio, and not to versions
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saved to a source control management repository. Working with version history is something you would
do before committing your work into the source control repository. If you have committed a flow to a
shared repository, it is not recommended to use the OO local version history control function to revert to
a previous version.

For full details of how to handle version history with a source control repository, see "View a history of Git
operations in the repository" on page 79.
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What do you want to do?
Open an earlier version of a configuration item, flow, or operation
When you open an earlier version of an item for viewing, you can save the earlier version under a different
name.

1. Right-click the configuration item, flow, or operation and select Show History.
2. Right-click the version you need, and then click Open. The selected version is opened in the authoring

pane.

3. To preserve the version that you have opened, click theSave As button and give it a unique name.
The two versions of the project are saved separately.

4. Click OK to close the Version History dialog box.

Restore a configuration item, flow, or operation to a previous version
This procedure restores a configuration item, flow, or operation to an earlier version. To keep both the current
and earlier versions, seeOpen an earlier version of a configuration item, flow, or operation.

1. Right-click the configuration item, flow, or operation and select Show History.
2. Right-click the version you want to revert to, and then click Restore. The version that you are restoring

to is opened in the authoring pane.
3. Click OK to close the Version History dialog box.
4. Save the project. The opened version is saved over the current version.

Compare versions
The Version History dialog box also enables you to compare versions of a configuration item, flow, or
operation. The current version is displayed on one side, and a previous version is displayed on the other.

1. Right-click the configuration item, flow, or operation and select Show History.
2. Hold down the CTRL key and select both the current version (on the top line) and an earlier version.
3. Right-click and select Compare. The differences between the current state of the item and the earlier

version are displayed.
4. Click OK to close the Version History dialog box.
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Reference Material
Version History dialog box

Menu item Description

Version The number of the project version, generated automatically.

Date/Time The date and time that the version was changed.

Comment The type of change that was made.

Bookmarking Flows and Operations
TheBookmarks panemakes it easier to find and use the operations and flows that you use frequently.
Bookmarked flows and operations are still available in their normal location in the Library.

Adding a flow or operation to theBookmarks panemakes it available from the right-click menu in the
authoring canvas.

You can export and import bookmarks from one installation of Studio to another.
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What do you want to do?
Add a bookmark
1. Click theBookmarks tab in the upper-right of the Studio window, to open theBookmarks pane.
2. To keep the pane open, click thePin icon in the upper-right-hand corner of the pane.
3. Drag a flow or operation from the Library or theSearch pane results to the appropriate shelf of the

Bookmarks pane.

Add a shelf to the Bookmarks pane
TheBookmarks pane has two default shelves, for flow and operations, but you can add customized shelves
to organize your bookmarks.

1. Right-click in the title bar of one of the shelves of theBookmarks pane, and then select Add.
2. Enter a name for the shelf and click OK.

Rename a shelf
1. Right-click in the title bar of the shelf that you want to rename, and then select Rename.
2. Enter a new name for the shelf and click OK.

Remove a shelf
1. Right-click in the title bar of the shelf that you want to remove, and then select Remove.
2. Click Yes in the confirmation window.

Hide/show a shelf
1. Right-click in the title bar of the shelf that you want to hide, and then select Hide. The shelf is no longer

visible in theBookmarks pane.
2. To show the hidden shelf, right-click in theBookmarks pane and select Show, and then select the

name of the hidden shelf.
3. To show all the hidden shelves, right-click in theBookmarks pane and select Show All.

Move a shelf up or down
Right-click in the title bar of the shelf that you want to move up or down, and then selectMove Up orMove
Down.

Collapse/expand a shelf
1. To collapse a shelf, click the double chevrons in the shelf’s title bar. The shelf title is visible but the

bookmarks in the shelf are hidden.
2. To expand the shelf, click the double chevrons again.

Export bookmarks
You can export your bookmarks from one installation of Studio and import them to another.

1. Right-click anywhere inside theBookmarks pane, and then select Export.
2. In the Export bookmarks dialog box, select the bookshelves that you want to export.
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3. Click OK. The Select export file dialog box appears.
4. Browse to the location where you want to save the bookmarks, and enter a name for the file.
5. Click Save.

Import bookmarks
1. Right-click anywhere inside theBookmarks pane, and then select Import.
2. In the Select import file dialog box, locate and select the bookmarks file, then click Open.
3. In the Import bookmarks dialog box, select the bookshelves that you want to import, and then click OK.

During import, bookmarks in the same bookshelf aremerged, based on the UUID. Existing bookmarks
remain, no duplicates are created, and new entries are added to the bookshelf.

Copy a flow or operation from the Bookmarks pane to a project
You can also drag flows and operations from the Bookmarks pane to theProjects pane, to copy them to a
project.
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1. Select a flow or operation in theBookmarks pane.
2. Drag the item to a project in theProjects pane.

Reference Material
Bookmarks menu
When you right-click in theBookmarks pane, the Bookmarks menu is displayed. The items shown in the
menu vary, depending on the item that was selected when you right-clicked.

Menu item Description

Add Adds a new shelf to theBookmarks pane.

Remove Removes the selected shelf from theBookmarks pane.

Rename Renames the selected shelf in theBookmarks pane.

Move Up Moves the selected shelf higher in theBookmarks pane.

Move Down Moves the selected shelf lower in theBookmarks pane.

Hide Hides the selected shelf in theBookmarks pane.

Show Lets you select a hidden shelf, in order to show it in the
Bookmarks pane.

Show All Shows all hidden shelves in theBookmarks pane.

Collapse Collapses the shelf in theBookmarks pane, so that the title is
visible but the bookmarks are hidden.

Import

Export
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Configuring Studio Properties
You can configure some of the properties in Studio by changing the default settings in theOptions dialog. In
addition, you can configure all the different properties in Studio by changing the default settings manually in
theStudio.properties file. For details of all the settings, see the ReferenceMaterial.

In versions 10.51 and later, you can usemultiple workspaces. Therefore, each workspace will have its own
studio.properties file under the .oo folder.

l If you want the same properties to be used in all new workspaces, edit the studio.properties.template file
located underStudio\conf\.

l To configure different settings for each workspace, you can still edit each of the studio.properties files
individually. These are located under the .oo folder inside each workspace.

In the following sections, you can see descriptions of themore frequently used parameters.

Defining the default value of Assign from and
Assign to
By default, when you create a new input in an operation or a flow step, no value is assigned to the input
source. Your flow may require that the input value to be assigned from a flow variable.

Similarly, by default, Studio does not assign the input value to a flow variable. Again, your flow may require
that the input's value be assigned to a flow variable.

You can configure Studio so that its default behavior is to assign a flow variable of the same name as the
input either or both of the source of the input's value. You do so in theStudio.properties file.

Changing the setting's value from not-assigned to assigned causes theAssign from Variable and/or
Assign to Variable to be assigned with the flow variable of the input with the same name, when you:

l Add a new input to an operation or flow step
l Create a new step in a flow
l Create a new operation

Changing the default value of Otherwise to
Use Constant
In Studio 10.20 and later, when you create a new input in an operation or a flow step, by default the
Otherwiseparameter is set toUse Constantwith an empty value for theConstant value. With this
assignment, some inputs may not pass validation.
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Similarly, the same rule applies when you create a new step in a flow using drag and drop from the Project or
Dependencies pane. For the step inputs that have theOtherwiseparameter set toPrompt User using text
before a drag and drop operation, after the drag and drop, these inputs are changed toUse Constantwith an
empty value. The step inputs that were set toPrompt User, but aremarked as Required or are part of a list
(selection list, domain term, flow variable) remain unchanged.

You can configure the default behavior in Studio to usePrompt Userwhen a new input is created in an
operation or a flow step. In this case, when a new step is created in a flow using a drag and drop operation,
thePrompt User setting will remain unchanged.

Changing the default behavior from Use Constant toPrompt User causes the selectedOtherwise option to
bePrompt User - Prompt for Textwhen performing one of the following actions:

l Add a new input to an operation or flow step
l Create a new step in a flow
l Create a new operation

Showing special characters in the Context
inspector
The ¶ button enables you to toggle on and off hidden formattingmarks on variables. For example, white
space, carriage returns, special characters, ^Ms, andmore. By default, this is disabled.

When you enable this switch, the value elements inside the categories, Step Context, Global Context, Select
Lists and System Properties, show these special characters and white space inside the tool tips associated
with the value.

l If invalid or empty parameters are used in the studio.properties file, the default parameters are used.
l If the preferred value for a property is not properly displayed inside the tool tip, then you can switch to a
different value, or leave that property empty.

l New line characters, <CR><LF>, <CR>, <LF> are followed by a new line in the tool tip along with a visual
representation.
l The vertical tab character \u000B is displayed as ^K.

l The form feed character \u000C is displayed as ^L.
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What do you want to do?
Edit the studio properties
1. InWindows Explorer, go to the <OO home> \ Studio \ conf directory.
2. Open the file studio.properties file in a text editor.
3. If you know the name of the parameter you want to change, search for it in the text editor.
4. If you do not know the name of the parameter, review the table in "Configuring Studio Properties " on

page 331 to find it.

Specify the default values for Assign from, Assign to and Otherwise using the
Options dialog
1. In Studio, select Configuration > Options.

TheOptions dialog opens:

2. ForAssign From andAssign To, select one of the following:

Not
Assigned

No value is assigned to or from the input.

Assigned The value of a flow variable with the same name as the input is assigned to or from the
input.

3. ForOtherwise, select one of the following:
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Use Constant TheOtherwise field is set toUse Constantwith an empty value.

Prompt User TheOtherwise field is set toPrompt User.

Define the default value of Assign from and Assign to manually
1. InWindows Explorer, go to the <OO home> \ Studio \ conf directory.
2. Open the file studio.properties for editing.
3. Find the following lines:

dharma.studio.ui.inputinspector.assignfrom.selected=not-assigned
dharma.studio.ui.inputinspector.assignto.selected=not-assigned
For each parameter, set one of the following values:

not-
assigned

No value is assigned to or from the input.

assigned The value of a flow variable with the same name as the input is assigned to or from the
input.

Note: This behavior is true in the case of a clean installation of Studio 10.5x. If you upgrade to
version 10.5x, the default values of Assigned from Variable andAssigned to Variable are
automatically set to the values assigned in the previous version.

Change the default value of Otherwise to Use Constant
1. InWindows Explorer, go to the <OO home> \ Studio \ conf directory.
2. Open the file studio.properties for editing.
3. Find the following line:

default.behavior.define.input=use_constant
4. For each parameter, set one of the following values:

use_constant TheOtherwise field is set toUse Constantwith an empty value.

prompt_user TheOtherwise field is set toPrompt User.

Note: This behavior is true in the case of a clean installation of Studio 10.5x. If you upgrade to
version 10.5x, the default value of is default.behavior.define.input is automatically set to the value
assigned in the previous version.

Make the grid appear by default when opening the flow editor
This is a global setting to control the activation of the grid for all flow editors, it makes the flow editor start with

the grid activated each time. You can still change the grid using the Show/Hide Grid button for an
individual flow editor instance.

By default, the grid is not shownwhen opening the flow editor.

You canmake the grid appear from theOptions dialog or by editing the studio.properties file.

From theOptions dialog:
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1. In Studio, select Configuration > Options.
2. In theDisplay Grid field, select True to show the grid or False to hide the grid.
From the studio.properties file:

1. InWindows Explorer, go to the <OO home> \ Studio \ conf directory.
2. Open the file studio.properties for editing.
3. Find the following line:

dharma.studio.ui.activegrid=false
4. Change the value of the setting to true:

dharma.studio.ui.activegrid=true

Specify the number of characters for each tooltip
1. InWindows Explorer, go to the <OO home> \ Studio \ conf directory.
2. Open the file studio.properties for editing.
3. Find the following line:

dharma.studio.ui.tooltip.showwhitespacecharacters.max.chars.per.line=5000
4. Change the value as required.

Show special characters in the context inspector
1. InWindows Explorer, go to the <OO home> \ Studio \ conf directory.
2. Open the file studio.properties for editing.
3. Find the following lines:

dharma.studio.ui.tooltip.showwhitespacecharacters.max.chars.per.line=5000
dharma.studio.ui.tooltip.showwhitespacecharacters.space=&middot;
dharma.studio.ui.tooltip.showwhitespacecharacters.tab=&#8633;
dharma.studio.ui.tooltip.showwhitespacecharacters.enter=&#8629;
dharma.studio.ui.tooltip.showwhitespacecharacters.otherwhitespace=&#8226;

4. Change the values as required.
For example, if you define character overrides, you can see them in the Context Inspector as follows:
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Disable HPLN search
By default, the HPE Live Network panel appears in the lower area of Studio.You can disable this panel by
changing the value of the hpln.enabled parameter.

1. InWindows Explorer, go to the <OO home> \ Studio \ conf directory.
2. Open the file studio.properties for editing.
3. Find the following line:

hpln.enabled=true
4. To disable the search, change the value to false:

hpln.enabled=false

Specify the HPLN connection/read timeout
1. InWindows Explorer, go to the <OO home> \ Studio \ conf directory.
2. Open the file studio.properties for editing.
3. Find the following lines:

hpln.connection.timeout=180
hpln.read.timeout=300

4. Set the timeout value as required. For no timeout, set these parameters to 0.

Specify the maximum number of HPLN search results
This configuration setting allows you to specify themaximum number of search results to be displayed inside
the HPE Live Network search results panel.

1. InWindows Explorer, go to the <OO home> \ Studio \ conf directory.
2. Open the file studio.properties for editing.
3. Find the following lines:

hpln.search.results.maximum.count=100
4. Set themaximum number of search results as required.

Reference Material
Studio Properties List

Parameter Default Value Description

dharma.default.repository location=default/repo The default Studio local
repository.

user.language en The locale of Studio. These value
do not affect the SCM repository.
If they are not set or are invalid,
Studio uses the system locales.

user.region US

dharma.repo.max_history_length 50 The number of item to be saved in
the history for the offline
repository.
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Parameter Default Value Description

dharma.studio.ui.lookandfeel windows The look and feel of the Studio
application.

dharma.studio.ui.input.constant.
max.chars

8192 A positive integer representing
the maximum number of
characters of the constant value.
Must be less than 8193.

dharma.studio.ui.tooltip.
showwhitespacecharacters.
max.chars.per.line

5000 Showing special characters in
Context Inspector

How many characters per tooltip
line

dharma.studio.ui.tooltip.
showwhitespacecharacters.space

&middot; One of the following values:
&middot;&#8226;

dharma.studio.ui.tooltip.
showwhitespacecharacters.tab

&#8633; One of the following values:
&#8633;,&#8677;,&#8594;,&#17
2;

dharma.studio.ui.tooltip.
showwhitespacecharacters.enter

&#8629; One of the following values:
&#8629,&#8626;,&para;

dharma.studio.ui.tooltip.
showwhitespacecharacters.
otherwhitespace

&#8226; One of the following
values:&#8226;,&middot;,&#977
5;

dharma.scripting.template.Rhino
dharma.scripting.template.Nashorn This template shows how to access operation return data, inputs and

context data.

Examples:

To access an input, simply refer to the input name from the Inputs pane.
For example:myData = inputName;

To access the context instance of the current branch:
myBranchData = scriptletBranchContext.get
("myBranchVarName");

To get value associated with the context key myContextKey:
myContextData = scriptletContext.get("myContextKey");

To get a value associated with the context key myContextKey from the
local context:
myContextData = scriptletContext.getLocal("myContextKey");

To access the return code from a command line or script (note that this
is a string and must be converted into an integer for numeric
processing):
code = parseInt(scriptletRawResult['Code']);

To access the output from the operation (for example, stdout):
data = scriptletRawResult['Output String'];

To access the error string from the operation (for example, stderr):
error = scriptletRawResult['Error String'];

Other operations may have different result variables available. To see
the list for a particular operation open the Output Field dropdown on
the Outputs tab.
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Parameter Default Value Description

To set the response of the operation (must match one of the responses
from the Responses tab):
scriptletResponse = "success";

To set the result of the operation:
scriptletResult = "Your Result Here";

Use the context to store data used in other steps. It is also helpful to
place information into the context to examine variables when
developing and debugging scriptlets.For example to place the
OutputString information into a context key called 'Output':
scriptletContext.putGlobal("Output", data);

Note that the key and value are both strings. For example, to place
'code' into the context:
scriptletContext.putGlobal("Code", code.toString());

You can also place data into the local context, which means it will only
be available to the current flow, but not to its parent flow or other
subflows. To do this, use:
scriptletContext.put("LocalVariable","LocalValue");

Note: If a flow is larger than 64K, when you try to save the flow,
you will see an exception.Also, the exception will occur every time
you try to access that flow, even if you restart Studio.

You should avoid making scriptlets too long. When the scriptlets
are compiled, if they are larger than 64K, you get an exception
when trying to save the flow.The exception will occur anytime you
try to access that flow, even if you restart Studio.

dharma.studio.ui.inputinspector.
assignfrom.selected

see description This property allows setting the
initial option in the "Assign from
Variable" combobox, in the Input
Inspector.

Possible values:

assigned - default when
upgrading from an earlier Studio
version
not-assigned - default when
installing Studio 10.20

dharma.studio.ui.inputinspector.
assignto.selected

see description This property allows you to set the
initial option to be shown in the
"Assign to Variable" combobox, in
the Input Inspector.

Possible values:

assigned - default when
upgrading from an earlier Studio
version
not-assigned - default when
installing Studio 10.20

default.behavior.define.input see description This property allows you to set the
default behavior that will be used
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Parameter Default Value Description

when defining inputs in a flow.

Possible values:

prompt_user- default when
upgrading from an earlier Studio
version
use_constant - default when
installing Studio 10.20

dharma.studio.ui.activegrid false When set to true, the grid is active
by default in the Flow Editor.

engine.assigner.trigger.repeatInterval 10

community.home.page.link https://hpln.hp.com/group/operatio
ns-orchestration

Community Home Page

git.history.page.size 100 Specifies the number of items to
be shown in a single Git history
page

git.history.changes.length 500 Specifies the default number of
changes to show in the Changes
under the selected item and
Other changes sections in the Git
history.

hpln.enabled true Specifies whether or not HPLN
search is enabled

hpln.connection.timeout 180 Specifies the HPLN connection
timeout in seconds. Use 0 for
infinite timeout.

hpln.read.timeout 300 Specifies the HPLN read timeout
in seconds. Use 0 for infinite
timeout.

hpln.connection.url https://api.hpln.hp.com/hpln Specifies the HPLN connection
URL

hpln.authentication.service.uri rest/authenticate Specifies the HPLN
authentication service uri

hpln.content.packages.service.uri rest/contentpackages Specifies the HPLN content
packages service uri

hpln.content.offerings.service.uri rest/contentofferings Specifies the HPLN content
offerings service uri

hpln.search.service.uri rest/contentpackages/search Specifies the HPLN search
service uri

hpln.search.service.search.param search Specifies the HPLN search
service search parameter

hpln.search.service.size.param pageSize Specifies the HPLN search
service size parameter
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Parameter Default Value Description

hpln.search.service.provider.param provider Specifies the HPLN search
service provider parameter

hpln.search.service.product.name.para
m

primaryproduct Specifies the HPLN search
service product name parameter

hpln.search.service.product.version.val
ue

10.20 Specifies the HPLN search
service product version value.
This version number is identical
to the Studio version. For
example, if the Studio version is
10.20,
hpln.search.service.product.versi
on.
param is 10.20.

hpln.search.results.maximum.count 100 Specifies the maximum number of
HPLN search results. This value
must not be greater than 100.

local.debugger.prompt.for.run.user true When set to true, the author is
prompted for a run user on the
local debugger

online.content.packs.link https://hpln.hp.com/group/operatio
ns-orchestration-content-packs

Online Content

Note: If a property is missing from the studio.properties file, the default value is to prompt the user to
enter a value.
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Troubleshooting

Troubleshooting Studio for Those Upgrading
from OO 9.x

Where's the Studio User Interface Item?
If you are used to working with OO 9.x and cannot locate a user interface item in Studio, use these
troubleshooting hints to help you find what you're looking for.

Where’s the repository?
OOno longer uses repositories. Files are stored locally on your file system and it is recommended to use a
source control application for collaboration.

Where are the Check In Check Out buttons and the My Changes/Checkouts
pane?
You can commit and check out from the SCM Changes pane if you are connected to source control. See
Working with Source Control.

Why do the Projects and Dependencies panes seem to contain the same items?
TheProjects pane and theDependencies pane are different:

l TheProjects pane contains the editable flows, operations, and other OO objects that you can use in the
project.

l TheDependencies pane contains read-only flows, operations, and other OO objects. You can use these
objects in your project but you cannot edit them. If you want to edit any of these objects, copy them into
theProjects pane.

Why can't I create operations?
It still exists but now it creates an operation. What we removed is the option to create built-in operations such
as HTTP, SSH, Command line etc. Those have to be copied from an existing template operation.

You cannot create built-in operations, such as HTTP, SSH, or Command line. You will need to copy them
from an existing template operation, and create a new operation from an action within the plugin. For more
information, see "Creating Operations" on page 299.

Why can't I create sleep scriptlets?
Sleep scriptlets have been deprecated. In OO 10.x, scriptlets must be written in Rhino or Nashorn.

Where is the Categories domain term?
There is now aConfiguration\Categories folder, where you can store categories for classifying flows. This
replaces theCategories domain term.
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Comparison of versions OO 9.x and 10.x
Task How it was done in OO 9.x How it is done in OO 10.x

Creating
operations

Use theNew > Operationmenu
option, and select the type of
operation.

Import actions plugins, or create operations
from imported action plugins.

See "Creating Operations" on page 299.

Checking flows
into a shared
repository

Use theCheck In button within
Studio.

Save projects locally and commit them to a
shared repository, using a source control
management tool.

See "Working with Source Control in
OO Studio" on page 36.

Deploy and run a
flow

Open the flow in the Central
application, and run the flow.

Release the flow as a content pack and deploy
it to the OO server, via API.

See theOO Installation Guide and theOO
Application Program Interface (API) Guide.

Createmulti-
instance steps

Right-click a step and select the
Toggle Multi-instance option to
turn it into amulti-instance step.
Then, createmultiple loops for the
different targets of the step.

Drag theMulti-instance icon on theStep
palette to the authoring canvas. Add one or
more subflows or operations to themulti-
instance lane, and set multiple targets for the
step via an input list of values.

See "Creating a Flow with Multi-Instance
Steps" on page 244.

Create actions for
operations

Create IAction implementation
classes, compile them into a .dll or
.jar file, copy the .dll or .jar file into
yourWeb service, and import the
Web service into Studio.

Create and pack an action plugin, import it into
Studio, and create a new operation from it.

See "Creating Operations" on page 299.

Create categories
to use for
classifying flows

In the domain term called
Categories, in the
Configuration\Domain Terms
folder, add a new row for the new
category.

Create a new category in the
Configuration\Categories folder.

HPE Live Network Troubleshooting
What can I do if I get an error when performing a HPE Live Network search?
OOno longer uses repositories. Files are stored locally on your file system and it is recommended to use a
source control application for collaboration.

Youmay receive the following error when performing a HPE Live Network search:
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sun.security.validator.ValidatorException: PKIX path building failed:
sun.security.provider.certpath.SunCertPathBuilderException: unable to
find valid certification path to requested target

To solve this issue:

1. Close Studio.
2. Export the HPE Live Network root certificate, (the certificate with the nameSymantec Class 3 Secure

Server CA - G4—the second one in the chain) into a file named hpln-ca.cer in DER encoded binary
X.509 format.

You can use a browser to navigate to https://api.hpln.hp.com/hpln and then export the root certificate as
shown below:
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3. Copy the certificate file hpln-ca.cer to the <oo_install_folder>\studio\var\security folder.
4. Import the certificate into Studio's TrustStore using the following command:

<oo_install_folder>\java\bin\keytool -import -alias hplnroot -keystore
client.truststore -file hpln-ca.cer

Note:

l The default password for the keystore is changeit. If you changed the default password, when
prompted, use the value of the parameterDjavax.net.ssl.trustStorePassword from the <oo_
install_folder>\studio\Studio.l4j.ini file.

l To change the Studio Truststore password, add the property client.truststore.password with
value the password in obfuscated format to the Studio.properties file from the “.oo” folder.

client.truststore.password=={OBFUSCATED}6L9+NqBjKYp5heuvMEzg0g==

If this property is not defined, Studio will fall back to the system property
javax.net.ssl.trustStorePassword for the truststore password.

5. Restart Studio.
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GIT Troubleshooting
What can I do if I get a "System cannot find specified file" error when performing
Git operations?
Theremay be cases in which youmay see the following error when performing Git SCM operations:

“Cannot run program "C:\<oo_installation_folder>\ studio\Git\bin\git" (in directory
"C:\<user_home_folder> \.oo\Workspace"):
CreateProcess error=2, The system cannot find the file specified “

1. Download the Git client from the following URL:
https://github.com/msysgit/msysgit/releases/download/Git-1.9.5-preview20150319/Git-1.9.5-
preview20150319.exe.

2. Save the Git client to <oo_installation_folder>/studio/Git, so that the bin folder is directly under <oo_
installation_folder>/studio/Git. In the Git installation wizard, use the default options.

Alternatively, if you already have aGit client installation with version git-1.9.5-preview20150319 on your
local disk, point Studio to use that Git installation by performing the following steps:

1. Close Studio.
2. Go to the user home folderC:\Users\<user>\.oo (the Studio workspace location) and locate the

Studio.properties file.
3. Modify theStudio.properties file by adding the following property at the end of the file:

studio.git.installation.location=<git-1.9.5-preview20150319_installation_folder>

For example:

studio.git.installation.location=C:/Program Files (x86)/Git

The bin folder should be directly underC:/Program Files (x86)/Git. Note that / should be used as a path
separator.

4. Save theStudio.properties file and start Studio.

Note: If you opted for this second alternative, you need to consider the following:

If you are usingmultiple workspaces and you want the Git location property to be added in each new
workspace, you should edit the template properties file located in
Studio\conf\studio.properties.template. Otherwise, each time you switch to a new workspace, you
will have to set the Git location in the new workspace in the .oo\Studio.properties file.

If you have another version of the Git client installed, note that youmust use the git-1.9.5-preview20150319
version with Studio. This is the version that was validated with Studio. While other versions might still work
correctly, they are not officially supported.
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SVN Troubleshooting
What can I do if I updated my projects and deleted someone else’s changes?
l In the following scenario a conflict can occur during update:

a. User1 edits Flow1, and commits.
b. User2 edits Flow1, and then updates.
Since User2 will receive updates for a file that has local changes, a conflict will occur.
Studio resolves such conflicts with the updating user’s copy. This means that in our case, any changes
User1made to Flow1will be deleted.
To avoid such cases we recommend always updating and locking any item before editing it.

l I made changes directly in the file system and something went wrong
While it is possible to create directories and rename files directly in the file system it is not recommended.
It is preferable to perform all tasks from within Studio.
If changes weremade in the file system and those changes results in problems, it is recommend to revert
those changes using an outside SVN tool such as SlickSVN or TortoiseSVN to perform a clean-up of the
workspace.

Viewing Studio Errors in the Log Viewer
The Log Viewer is a useful tool that allows you to see all the errors that have occurred in the current user
session in one central location within Studio.The errors are presented in the sameway as they are displayed
in theStudio.log log file.

The Log Viewer shows two types of errors:

l Fatal errors (labeled FATAL in Studio.log)
l Errors (labeled ERROR in Studio.log)

Note:Warnings (WARN) and Information (INFO) messages are not shown in the Log Viewer but can be
seen in theStudio.log file.

If theStudio Log Viewer option in theWindow menu is selected, the Log Viewer tab appears as one of the
tabs at the bottom of the Studio window when Studio opens.

What do you want to do?
Enable the Log Viewer tab
1. From theWindows menu, select Studio Log Viewer.
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