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Legal Notices

Warranty
The only warranties for Hewlett Packard Enterprise Development LP products and services are set forth in the
express warranty statements accompanying such products and services. Nothing herein should be construed as
constituting an additional warranty. HPE shall not be liable for technical or editorial errors or omissions contained
herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend
Confidential computer software. Valid license from HPE required for possession, use or copying. Consistent with
FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and Technical Data
for Commercial Items are licensed to the U.S. Government under vendor's standard commercial license.

Copyright Notice
© Copyright 1992 - 2016 Hewlett Packard Enterprise Development LP

Trademark Notices
Adobe® and Acrobat® are trademarks of Adobe Systems Incorporated.

Google™ and Google Maps™ are trademarks of Google Inc

Intel® and Pentium® are trademarks of Intel Corporation in the U.S. and other countries.

Microsoft®, Windows®, Windows® XP, and Windows Vista ® are U.S. registered trademarks of Microsoft
Corporation.

Oracle and Java are registered trademarks of Oracle and/or its affiliates.

Documentation Updates
The title page of this document contains the following identifying information:

l Software Version number, which indicates the software version.
l Document Release Date, which changes each time the document is updated.
l Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go to:
https://softwaresupport.hpe.com.

This site requires that you register for an HPE Passport and sign in. To register for an HPE Passport ID, go to
https://softwaresupport.hpe.com and click Register.

Support
Visit the HPE Software Support Online web site at: https://softwaresupport.hpe.com

This web site provides contact information and details about the products, services, and support that HPE Software
offers.
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HPE Software online support provides customer self-solve capabilities. It provides a fast and efficient way to
access interactive technical support tools needed to manage your business. As a valued support customer, you
can benefit by using the support web site to:

l Search for knowledge documents of interest
l Submit and track support cases and enhancement requests
l Download software patches
l Manage support contracts
l Look up HPE support contacts
l Review information about available services
l Enter into discussions with other software customers
l Research and register for software training

Most of the support areas require that you register as an HPE Passport user and sign in. Many also require a
support contract. To register for an HPE Passport ID, go to: https://softwaresupport.hpe.com and click Register.

To find more information about access levels, go to: https://softwaresupport.hpe.com/web/softwaresupport/access-
levels.

HPE Software Solutions & Integrations and Best Practices
Visit HPE Software Solutions Now at https://softwaresupport.hpe.com/group/softwaresupport/search-result/-
/facetsearch/document/KM01702710 to explore how the products in the HPE Software catalog work together,
exchange information, and solve business needs.

Visit the Cross Portfolio Best Practices Library at https://hpln.hpe.com/group/best-practices-hpsw to access a wide
variety of best practice documents and materials.
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Welcome to the Run Results Viewer User
Guide
The HP Run Results Viewer User Guide explains how to use the Run Results Viewer to
interpret and use the test results from your GUI or API tests.

It is recommended to have some prior knowledge of UFT and its testing capabilities so
you can fully evaluate the test results.

Additional Online Resources
The following additional online resources are available:

Resource Description

HP Software
Support Online

The HP Software Support Web site
(www.hpe.com/go/hpsoftwaresupport). To access, choose Help > HP
Software Support.

Note:Most of the support areas require that you register as an
HP Passport user and sign in. Many also require a support
contract. To register for an HP Passport user ID, go to:
http://h20229.www2.hpe.com/passport-registration.html

Testing Forums l API Testing: http://h30499.www3.hpe.com/t5/Service-Test-
Support-and-News/bd-p/sws-Serv_TEST_SF

l BPT: http://h30499.www3.hpe.com/t5/Business-Process-
Validation/bd-p/sws-BPT_SF

UFT Product
Page

The HP Unified Functional Testing product page
(http://www8.hpe.com/us/en/software-solutions/unified-functional-
testing-automated-testing/index.html), with information and related
links about UFT. To access, select Help > Useful Links > Product Page.

Troubleshooting
& Knowledge
Base

The Troubleshooting page
(http://h20230.www2.hpe.com/troubleshooting.jsp) on the HP
Software Support Web site where you can search the HP Software
Self-solve knowledge base. To access, select Help > Knowledge Base
or Help > Troubleshooting.
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Resource Description

HP Software
Community

The HP IT Experts Community site
(http://h10124.www1.hpe.com/campaigns/IT_
Experts/pages/home.html), where you can interact with other HP
software users, read articles and blogs on HP software and access
downloads of other software products.

HP Manuals Site The HP Software Product Manuals Web site
(http://support.openview.hpe.com/selfsolve/manuals), to search for
the most up-to-date documentation for a selected HP Software
product. To access, select Help > Useful Links > HP Manuals Site.

What's New The UFT What's New Help, describing the new features and
enhancements in this version of UFT.

Product Movies The UFT HPLN (HP Live Networks) page
(https://hpln.hpe.com/page/uft-120-videos) with a list of all product
movies.

HP Software
Web site

The HP Software Web site (www.hpe.com/go/software). This site
provides you with the most up-to-date information on HP Software
products. This includes new software releases, seminars and trade
shows, customer support, and more.
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Chapter 1: Using the Run Results Viewer
After running a test or component, you can view the run results in the HPRun Results
Viewer. The Run Results Viewer contains multiple panes, each of which displays
specific types of information. The Run Results Tree Pane and Search Box displays a
hierarchical representation of the run results. The remaining panes provide details about
a selected node or step, the data used for a particular step, optional screen captures or
images (UFTGUI testing only), optional system information (UFTGUI testing only), and
so on.

In addition, you can view the run results in HTML format directly in your browser or in
UFT. To select the format in which you want to view the run results, open the Run
Sessions pane in the Options dialog box (Tools > Options > General tab > Run Sessions
node).

By default, the Run Results Viewer opens automatically at the end of a run session. If
you want to change this behavior, in UFT, clear the View results when run session ends
check box in the Run Sessions pane of the Options dialog box.

The Run Results Viewer contains a description of the steps performed during the run
session.

l For a GUI component, or for a GUI test that does not contain Data Pane parameters,
the Run Results Viewer shows a single test iteration.

l For tests, if the test contains Data Pane parameters, and the test settings are
configured to run multiple iterations, the Run Results Viewer displays details for each
iteration of the test run. The results are grouped by the actions in the test.

l For an API test, the individual steps and checkpoints included in the test. If a test is set
to run multiple iterations, each iteration is displayed.

You set the test to run for one or all iterations in the Run pane of the Settings dialog box.
For details, see the section describing the Run pane in the HP Unified Functional Testing
User Guide.

The Run Results Viewer is installed automatically with UFT.

You can also install the Run Results Viewer as a standalone application. This enables
you to share the results of your tests with business analysts and developers who do not
have UFT installed on their computers.

Run results XML file
The results of each run session are saved in a single .xml file (called results.xml). This
.xml file stores information on each of the run result nodes in the display. The
information in these nodes is used to dynamically create .htm files that are shown in the
Result Details pane in the Run Results Viewer.

HP Run Results Viewer (12.53) Page 7 of 42



Each node in the run results tree is an element in the results.xml file. In addition, there
are different elements that represent different types of information displayed in the run
results. You can take run result information from the .xml file and use XSL to display the
information you require in a customized format (either when printing from within the Run
Results Viewer, when displaying run results in your own customized results viewer, or
when exporting the run results to an .html file).

The diagram below for a GUI test, shows the correlation between some of the elements
in the .xml file and the items they represent in the run results. These elements are similar
for both tests and business components.

XSL provides you with the tools to describe exactly which run result information to
display and exactly where and how to display, print or export it. You can also modify the
.css file referenced by the .xsl file, to change the appearance of the report (for example,
fonts, colors, and so forth).

For example, in the results.xml file, one element tag contains the name of an action or a
component, and another element tag contains information on the time at which the run
session is performed. Using XSL, you could tell your customized Run Results Viewer
that the action or component name should be displayed in a specific place on the page
and in a bold green font, and that the time information should not be displayed at all.

User Guide
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You may find it easier to modify the existing .xsl and .css files provided with the Run
Results Viewer application, instead of creating your own customized files from scratch.
The files are located in the HP\Run Results Viewer\dat folder, and are named as follows:

l PShort.xsl. Specifies the content of the run results report printed, or exported to an
HTML file, when you select the Short option in the Print or Export to HTML File dialog
boxes.

l PDetails.xsl. Specifies the content of the run results report printed, or exported to an
HTML file, when you select the Detailed option in the Print or Export to HTML File
dialog boxes.

l PStringTable.xsl. Specifies the string constants to be used in the exported document.
For example, Iteration #may be used for the iteration number prefix. If you select the
User-defined XSL option in the Print or Export to HTML File dialog boxes, the .xsl file
you specify must contain an "include" call to this file. You can localize the strings, if
needed.

l PResults.css. Specifies the appearance of the run results print preview. This file is
referenced by the above .xsl files.

l Results.css. Specifies the styles, fonts, and colors of the various elements displayed in
the run results.

UFT only: For details on the structure of the XML schema, and a description of the
elements and attributes you can use to customize the run results reports, see the HP Run
Results Schema Reference (Help > HP UFT GUI Testing Automation and Schema References Help >
HP Run Results Schema Reference).

Custom Fields (UFT API Testing Only)
You can use the Report function to show custom information in the Run Results Viewer.
You can specify strings or existing arguments and display them in the viewer.

You add the Report function to the step's events. For details, see the section on Custom
Code and Events in the HP Unified Functional Testing User Guide.

The following example prints APR-12-2010_CYCLE_1 in the Value column for TestID.

args.Activity.Report("TestID","APR-12-2010_CYCLE_1");

User Guide
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The report displays the keyword and its value at the Activity level of the results.

Navigate the run results tree
This task describes how to collapse or expand a branch in the run results tree to select
the level of detail that the tree displays.

When you open run results in the Run Results Viewer for the first time, the tree expands
one level at a time. If the child branches under a parent branch were previously
expanded, that state is maintained when you expand or collapse the parent branch.

You can do the following to view the results:

l "Expand a specific branch" below
l "Expand a branch and all branches below it" on the next page
l "Expand all of the branches in the run results tree" on the next page
l "Collapse a specific node" on the next page
l "Collapse all of the nodes in the tree" on the next page
l "Move between previously selected nodes within the run results tree" on the next
page

l "Find specific steps within the Run Results" on the next page
l "Filter the tree to display only nodes that match certain criteria" on the next page
Expand a specific branch

l Double-click the branch.
l Select the branch and click the arrow to the left of the branch icon.

User Guide
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l Press the plus key (+) on your keyboard number pad.
The tree displays the details for the branch, and the expand sign changes to collapse.

Expand a branch and all branches below it

l Select the branch and press the asterisk (*) key on your keyboard number pad.
l Right-click a branch and select Expand All.
Expand all of the branches in the run results tree

l Right-click the top level branch and select Expand All.
l Select View > Expand All.

l Click the Expand All button .
l Select the top level of the tree and press the asterisk (*) key on your keyboard number
pad.

Collapse a specific node

l Double-click the node.
l Right-click a node and select Collapse All.
l Select it and click the arrow to the left of the node icon.
l Press the minus key (–) on your keyboard number pad.
The node's child nodes disappear from the tree.

Collapse all of the nodes in the tree

l Right-click the top level branch and select Collapse All.
l Select View > Collapse All.

l Click the Collapse All button .
Move between previously selected nodes within the run results tree

Click the Go to Previous Node or Go to Next Node buttons .

Find specific steps within the Run Results

Use the Search box (located above the run results tree), for example:

You can search for text, status, and/or types of nodes.

Filter the tree to display only nodes that match certain criteria

Use the Filter dialog box (View > Filters).

User Guide
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Jump to a step in a GUI test from the run results
You can view the step in UFT that corresponds to a node in the Run Results tree for any
node that has a corresponding step in a GUI test.

Note: This feature is disabled for:

l Any testing document other than a GUI test.
l The Action, Iteration, and Test Summary nodes.
l Any step that is part of an action that was run using the LoadAndRunAction
statement.

l Any step performed by a recovery scenario.
l Tests that were run in Fastmode.
l Any step run from the Watch or Console debug panes in UFT.

1. Make sure that UFT is open to the test whose results are displayed in the Run
Results Viewer.

2. Select a node in the run results tree.
3. Perform one of the following:

a. Click the Jump to Step in Test button from the Run Results toolbar.
b. Right-click and select Jump to Step in Test from the context menu.
c. Select View >Jump to Step in Test.

4. The UFT window is activated and the step is highlighted.

Manually submit defects to ALM
This task includes the following steps:

l "Prerequisites" below
l "Connect to an ALM project" below
l "Add a new defect" below
l "Results" on the next page
1. Prerequisites

Ensure that the ALM client is installed on your computer. (Enter the ALM Server
URL in a browser and ensure that the Login screen is displayed.)

2. Connect to an ALM project

Select Tools > ALM Connection or click the ALM Connection button and connect to
an ALM project.

3. Add a new defect
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a. Select Tools > Add Defect or click the Add Defect button to open the New Defect
dialog box in the specified ALM project. The New Defect dialog box opens.

b. Modify the defect details as necessary. Basic information on the test or
component and any checkpoints (if applicable) is included in the description:

Tip: You can attach movies (.fbr files) to defects in ALM. If you have the
Unified Functional Testing Add-in for ALM installed, you can view the movies
from ALM.

4. Results

The defect is added to the ALM project's defect database.

Automatically submit defects to an ALM project
This task describes how to set the Run options in UFT to automatically submit defects to
your ALM project for each failed step in your GUI test, eliminating the need to remember
to submit these defects after a run session.

This task includes the following steps:

l "Prerequisites" below
l "Modify the Run settings in the Options dialog box" below
l "Results" on the next page
1. Prerequisites

l In UFT, make sure you are connected to the relevant ALM project prior to the run
session (ALM > ALM Connection).

l The run results must be stored in this ALM project.
2. Modify the Run settings in the Options dialog box

User Guide
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a. Select Tools > Options. The Options dialog box opens.
b. In the GUI Testing tab, click the Test Runs node.

c. Select the Submit a defect to ALM for each failed step check box.
d. Click OK to close the Options dialog box.

3. Results

During each run session, the necessary defects are added to your ALM project.
A sample of the information that is submitted to ALM for each defect is shown below:

Export run results
This task describes how to export run results to a file.

This task includes the following steps:

User Guide
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l "Open the results in the Run Results Viewer" below
l "Specify the export settings" below
l "Save the file" below
l "Results" below
1. Open the results in the Run Results Viewer

In the Run Results Viewer, select File > Open.
2. Specify the export settings

Select File > Export To File. The Export Run Results dialog box opens.
3. Save the file

Click Export. The Save As dialog box opens. Specify the file name and path, and
select the required file type.

Report type Save as type

Step details l HTML (*.htm, *.html) (default)
l PDF (*.pdf)
l DOC (*.doc) (Available if Microsoft Word is installed)

Data Table Excel (*.xls)

Log Tracking
(UFTGUI Testing
only)

XML (*.xml)

Screen Recorder
(UFTGUI Testing
only)

FlashBack (*.fbr)

System Monitor
(UFTGUI Testing
only)

l Text (*.csv, *.txt) (default)
l Excel (*.xls)
l XML (*.xml)
l HTML (*.htm, *.html)

Note:Only the system monitor data is exported, not
the graph.

4. Results

When you click Save, the file is exported in the specified format to the designated
location.

Note: You can view .fbr files in the HP Micro Recorder. You can also attach
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.fbr files to defects in ALM. If you have the Unified Functional Testing Add-in
for ALM installed, you can view the movies from ALM.

Play a Screen Recorder movie in the HP Micro
Player

Note: UFT must be installed on the computer on which you want to use the HP
Micro Player.

1. Perform one of the following:
l Double-click any .fbr file in Windows Explorer.
l Select Start > All Programs > HP Software > HP Unified Functional Testing > Tools > HP

Micro Player and then select File > Open in the Micro Player to select any .fbr file.
l Open the program at <UFT installation folder\bin\Free_HPSR_Player.exe.
The movie opens in the HP Micro Player and begins playing.

Note: For details on accessing UFT and UFT tools and files in Windows 8.X or
higher and Windows Server 2012, see "Accessing the UFT in Windows 8.X
or Higher Operating Systems" on the next page.

2. Use the controls at the top of the window to access a particular location in the movie
or to modify the volume settings.

Delete run results
This task describes how to use the Run Results Deletion Tool to remove unwanted or
obsolete run results from the file system, according to specific criteria that you define.
For example, you may want to always delete run results older than a certain date or over
a minimum file size. This enables you to free up valuable disk space.

Prerequisites

To delete run results from an ALM project, you must first:

l Make sure that you have Delete Run permissions for this ALM project.
l Connect to the ALM project.
Delete run results using the Run Results Deletion Tool

In the Run Results Deletion Tool, select the file or folder from which to delete run results
and then select the selected run results to delete.

The selected run results are deleted from the file system and/or the ALM project.
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Known Issues- Viewing Run Results
Local
system
monitor

After you run a test or component with the local system monitoring option
activated when the test or component is either very short, or the number of
seconds entered for the Enable local system monitoring every: __ seconds option
is high (a high percentage relative to the length of your entire test run), then
when you select one of the last steps in the Run Results tree, the Current
Step indicator in the System Monitor pane may jump to a position outside
(to the right) of the graph.

Workaround: Add a Wait statement to the end of the test or reduce the
number of seconds entered in the Enable local system monitoring every: __
seconds option.

Run
session
errors

Errors during the run session produce more than one error node in the run
results.

Exporting
run
results

l Exporting run results.When UAC is set to ON and you select to export the
Run Results to a system folder, the exported file is stored under Virtual
Storage rather than under the specified folder. (Relevant for Windows 7,
Windows Server 2008 R2, Windows 8.x, and Windows Server 2012)

Viewing
run
results
from
ALM

If you installed the Run Results Viewer without installing UFT, then after
you run a BPT test from ALM, pressing Show Last Run Results might fail to
display the results in the Run Results Viewer if the Visual C++ 2005
redistributable is installed on your computer.

Workaround: Install the Unified Functional Testing Add-in for ALM from the
ALM Add-ins page.

Accessing the UFT in Windows 8.X or Higher
Operating Systems
By default, the Run Results Viewer is not displayed on the Start or Apps screen in
Windows 8.x or higher.

You can add the Run Results Viewer to the Start screen by navigating to its location on
the file system or the Desktop screen and pinning it to the Start screen.

In addition, you can add other related files, including .exe files and documentation the
Start screen by pinning these items.

Note: By default, the Start and Apps screens on Windows 8.x or higher are set to
open Internet Explorer in Metro Mode. However, if User Account Control is turned
off on your computer, Windows 8 will not open Internet Explorer in Metro mode.
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Therefore, if you try to open an HTML shortcut from the Start or Apps screen, such
as the UFT Help or Readme file, an error will be displayed.

To solve this, you can change the default behavior of Internet Explorer so that it
never opens in Metro mode. In the Internet Properties dialog box > Programs tab,
select Always in Internet Explorer on the desktop for the Choose how you open links
option. For more details, see http://support.microsoft.com/kb/2736601 and
http://blogs.msdn.com/b/ie/archive/2012/03/26/launch-options-for-internet-
explorer-10-on-windows-8.aspx.
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Chapter 2: Run Results - Understanding Step
Results
In the run results, certain steps are displayed differently to help you gain a greater
understanding of the results of your test run.

These include:

l Steps that used Smart Identification
l Checkpoint and output value steps
l Parameterized steps
l Calls to UFT API or Service Test tests/actions

Smart Identification in the Run Results (UFT GUI
Testing Only)
If the learned description does not enable UFT to identify the specified object in a step,
and a Smart Identification definition is defined (and enabled) for the object, then UFT
tries to identify the object using the Smart Identification mechanism. The following
examples illustrate two possible scenarios.

No Object Matches the Learned Description

If UFT successfully uses Smart Identification to find an object after no object matches
the learned description, the run results display a warning status and include the
following information:

In the results
tree In the Result Details pane

A description
mismatch
icon for the
missing
object. For
example:

An indication that the object (for example, the userNameWebEdit object)
was not found.
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In the results
tree In the Result Details pane

A Smart
Identification
icon for the
missing
object. For
example:

An indication that the Smart Identification mechanism successfully
found the object, and information on the properties used to find the
object. You can use this information to modify the learned test object
description, so that UFT can find the object using the description in
future run sessions.

The actual
step
performed.
For example:

Normal result details for the performed step.

The image below shows the results for a test or component in which Smart Identification
was used to identify the userNameWebEdit object after one of the learned description
property values changed.

Multiple Objects Match the Learned Description

If UFT successfully uses Smart Identification to find an object after multiple objects are
found that match the learned description, UFT shows the Smart Identification
information in the Run Results Viewer. The step still receives a passed status, because
in most cases, if Smart Identification was not used, the test object description plus the
ordinal identifier could have potentially identified the object.
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In such a situation, the run results show the following information:

In the results
tree In the Result Details pane

A Smart
Identification
icon for the
missing
object. For
example:

An indication that the Smart Identification mechanism successfully
found the object, and information on the properties used to find the
object. You can use this information to create a unique object
description for the object, so that UFT can find the object using the
description in future run sessions.

The actual
step
performed.
For example:

Normal result details for the performed step.
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The image below shows the results for a test or component in which Smart Identification
was used to uniquely identify the Flight Confirmation: Mercury object after the learned
description resulted in multiple matches.

If the Smart Identification mechanism cannot successfully identify the object, the test or
component fails and a normal failed step is displayed in the run results.

Checkpoint and Output Value results
The information displayed in the Run Results Viewer and the available options are
determined by the type of checkpoint or output value step you select.
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l "Accessibility Checkpoints" below
l "Bitmap Checkpoints Results" on page 27
l "File Content Checkpoints" on page 28
l "Standard Checkpoint Results" on page 30
l "Table and Database Checkpoint Results" on page 31
l "Text and Text Area Checkpoint Results" on page 32
l "XML Checkpoint Results" on page 33
l "Output Value Results" on page 35
l "File Content Output Values" on page 36
l "XML Output Values" on page 36

Accessibility Checkpoints

When you include accessibility checkpoints in your test, the Run Results Viewer
displays the results of each accessibility option that you checked.

The run results tree displays a separate step for each accessibility option that was
checked in each checkpoint. For example, if you selected all accessibility options, the
run results tree for an accessibility checkpoint may look something like this:

The run result details provide information that can help you pinpoint parts of your Web
site that may not conform to the W3C Web Content Accessibility Guidelines. The
information provided for each check is based on the W3C requirements.

Note: Some of the W3C Web Content Accessibility Guidelines that are relevant to
accessibility checkpoints are cited or summarized in the following sections. This
information is not comprehensive. When checking whether your Web site satisfies
the W3C Web Content Accessibility Guidelines, you should see the complete
document at: http://www.w3.org/TR/WAI-WEBCONTENT/.
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ActiveX
Check

Guideline 6 of the W3C Web Content Accessibility Guidelines requires
you to ensure that pages are accessible even when newer technologies
are not supported or are turned off. When you select the ActiveX check,
UFT checks whether the selected page or frame contains any ActiveX
objects. If it does not contain any ActiveX objects, the checkpoint passes.
If the page or frame does contain ActiveX objects then the results display
a warning and a list of the ActiveX objects so that you can check the
accessibility of these pages on browsers without ActiveX support. For
example:

Alt
Property
Check

Guideline 1.1 of the W3C Web Content Accessibility Guidelines requires
you to provide a text equivalent for every non-text element. The Alt
property check checks whether objects that require the Alt property under
this guideline, do in fact have this attribute. If the selected frame or page
does not contain any such objects, or if all such objects have the required
attribute, the checkpoint passes. If one or more objects that require the
property do not have it, the test fails and the run result details display a list
that shows which objects are lacking the attribute. For example:

The Captured Data pane displays the captured page or frame, so that you
can see the objects listed in the Alt property check list.
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Applet
Check

The Applet Check also helps you ensure that pages are accessible, even
when newer technologies are not supported or are turned off (Guideline 6
of the W3C Web Content Accessibility Guidelines), by finding any Java
applets or applications in the checked page or frame. The checkpoint
passes if the page or frame does not contain any Java applets or
applications. Otherwise, the results display a warning and a list of the
Java applets and applications. For example:

Frame
Titles
Check

Guideline 12.1 of the W3C Web Content Accessibility Guidelines requires
you to title each frame to facilitate frame identification and navigation.
When you select the Frame Titles check, UFT checks whether Frame and
Page objects have the TITLE tag. If the selected page or frame and all
frames within it have titles, the checkpoint passes. If the page, or one or
more frames, do not have the tag, the test fails and the run result details
display a list that shows which objects are lacking the tag. For example:

The Captured Data pane displays the captured page or frame, so that you
can see the frames listed in the Frame Titles check list.

Multimedia
Links
Check

Guidelines 1.3 and 1.4 of the W3C Web Content Accessibility Guidelines
require you to provide an auditory, synchronized description of the visual
track of a multimedia presentation. Guideline 6 requires you to ensure that
pages are accessible, even when newer technologies are not supported
or are turned off. The Multimedia Links Check identifies links to
multimedia objects so that you can confirm that alternate links are
available where necessary. The checkpoint passes if the page or frame
does not contain any multimedia links. Otherwise, the results display a
warning and a list of the multimedia links.`
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Server-
Side Image
Check

Guideline 1.2 of the W3C Web Content Accessibility Guidelines requires
you to provide redundant text links for each active region of a server-side
image map. Guideline 9.1 recommends that you provide client-side image
maps instead of server-side image maps except where the regions cannot
be defined with an available geometric shape. When you select the
Server-side Image check, UFT checks whether the selected page or
frame contains any server-side images. If it does not, the checkpoint
passes. If the page or frame does contain server-side images, then the
results display a warning and a list of the server-side images so that you
can confirm that each one answers the guideline requirements. For
example:

Tables
Check

Guideline 5 of the W3C Web Content Accessibility Guidelines requires
you to ensure that tables have the necessary markup to be transformed by
accessible browsers and other user agents. It emphasizes that you
should use tables primarily to display truly tabular data and to avoid using
tables for layout purposes unless the table still makes sense when
linearized. The TH, TD, THEAD, TFOOT, TBODY, COL, and COLGROUP tags are
recommended so that user agents can help users to navigate among
table cells and access header and other table cell information through
auditory means, speech output, or a Braille display.

The Tables Check checks whether the selected page or frame contains
any tables. If it does not, the checkpoint passes. If the page or frame does
contain tables, the results display a warning and a visual representation
of the tag structure of the table. For example:
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Bitmap Checkpoints Results

The Result Details pane displays the checkpoint step results, including its status (Passed
or Failed), the date and time the checkpoint was run and the portion of the checkpoint
timeout interval that was used (if any).

When
Comparing
Expected
Bitmaps
with
Actual
Bitmaps

The Captured Data pane shows the expected and actual bitmaps that
were compared during the run session, and a View Difference button. When
you click the View Difference button, UFT opens the Bitmap Checkpoint
Results window, displaying an image that represents the difference
between the expected and actual bitmaps. This image is a black-and-
white bitmap that contains a black pixel for every pixel that is different in
the two images. Similar results would be displayed for a component.
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When
Locating
Specified
Bitmaps in
Actual
Bitmaps

The Captured Data pane shows the actual bitmap of the runtime object in
the application and the source bitmap that UFT attempted to locate within
the object. It may also show the coordinates of a possible candidate that
was found, and the image similarity percentage used to find the
candidate.

Note: By default, the information in the Captured Data pane is
available only if the bitmap checkpoint fails. You can change the
conditions for when bitmaps are saved in the run results, using the
Save still image captures to results option in the Screen Capture pane
(Tools > Options > GUI Testing tab > Screen Capture node) of the
Options dialog box.

Considerations

l When comparing bitmaps, if the checkpoint is defined to compare only specific areas
of the bitmap, the run results display the actual and expected bitmaps with the
selected area highlighted.

l When comparing bitmaps, if the dimensions of the actual and expected bitmaps are
different, UFT fails the checkpoint without comparing the bitmaps. In this case the
View Difference functionality is not available in the results.

l The View Difference functionality is not available when viewing results generated in a
version of QuickTest earlier than 10.00.

l If the bitmap checkpoint is performed by a custom comparer:
l UFT passes the bitmaps to the custom comparer for comparison even if their
dimensions are different.

l The Result Details pane also displays the name of the custom comparer (as it
appears in the Comparer box in the Bitmap Checkpoint Properties dialog box), and
any additional information provided by the custom comparer.

l The difference bitmap is provided by the custom comparer.

File Content Checkpoints

The Result Details pane displays detailed results of the selected checkpoint, including
its status (Passed or Failed), and the date and time the checkpoint was run. It also displays
the number of lines that were checked, the number of changes found in the checked
lines, and the total number of changed lines found in the file (including both the lines
that were selected in the checkpoint and the lines that were not).

The details area also specifies whether the checkpoint includes the following options:
Match case, Ignore spaces, Verify page count, and Fail checkpoint for added or removed lines
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For failed steps, the Captured Data pane displays any differences found for all lines in
the actual file, regardless of whether they were selected for comparison in the
checkpoint. An asterisk (*) adjacent to the line number indicates that a regular
expression was selected for comparison against the actual file.

In the following example, the details of the failed checkpoint indicate that the expected
results and the current results do not match.

l The expected value in line 1 is not identical to the actual value.
l The asterisk (*) in line 1 indicates that a regular expression was selected for
comparison against the actual file and the lines in the expected and actual files are
different.

l Lines that were selected for comparison are displayed in black.
Lines that were not selected for comparison are displayed in light grey.

l The last line exists in the source (expected) file but is missing from the actual file. This
line was not selected for comparison, so its textual content is displayed in grey
instead of black.
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l No lines were added to the actual file.

Standard Checkpoint Results

The Result Details pane displays detailed results of the selected checkpoint, including
its status (Passed or Failed), the date and time the checkpoint was run, and the portion of
the checkpoint timeout interval that was used (if any). It also displays the values of the
object properties that are checked, and any differences between the expected and
actual property values.

The Captured Data pane displays the image capture for the checkpoint step (if
available).
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In the following example, the details of the failed checkpoint indicate that the expected
results and the current results do not match. The expected value of the flight departure is
Paris, but the actual value is Frankfurt.

Table and Database Checkpoint Results

The results displayed for table and database checkpoints are similar. The Result Details
pane displays the checkpoint step results, including its status (Passed or Failed), the date
and time the checkpoint was run, the verification settings you specified for the
checkpoint, and the number of individual table cells or database records that passed
and failed the checkpoint.

If the checkpoint failed, the Captured Data pane shows the table cells or database
records that were checked by the checkpoint. Cell values or records that were checked
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are displayed in black; cell values or records that were not checked are displayed in
gray. Cells or records that failed the checkpoint are marked with a failed  icon.

The following is an example of the results for a table checkpoint:

Text and Text Area Checkpoint Results

The Result Details pane displays the checkpoint step results, including its status (Passed
or Failed), the date and time the checkpoint was run and the portion of the checkpoint
timeout interval that was used (if any). It also shows the expected text and actual text
that was checked, and the verification settings you specified for the checkpoint.
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The following is an example of the results for a text checkpoint:

XML Checkpoint Results

The Result Details pane displays the checkpoint step results.

The Captured Data pane shows the details of the schema validation (if applicable) and
a summary of the checkpoint results. If the schema validation failed, the reasons for the
failure are also shown.

If the checkpoint failed, you can view details of each check performed in the checkpoint
by clicking View XML Checkpoint Results in the Captured Data pane. The XML Checkpoint
Results window opens, displaying details of the checkpoint's failure.
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The following is an example of the results for an XML checkpoint:

Note: By default, if the checkpoint passes, the View XML Checkpoint Results button is
not available. The availability of these detailed results is dependent on the Save
still image captures to results setting in the Screen Capture pane (Tools > Options > GUI
Testing tab > Screen Capture node) of the Options dialog box.
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Output Value Results

The Result Details pane displays detailed results of the selected output value step,
including its status, and the date and time the output value step was run. It also displays
the details of the output value, including the value that was captured during the run
session, its type, and its name, as shown in the following example. Similar results would
be displayed for a component.
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File Content Output Values

The Result Details pane displays the results of the file content output value step,
including its status, the date and time the step was run, and details for the parameterized
file content output value. This pane also shows the configuration settings (whether match
case and ignore spaces were set), as shown in the following example.

XML Output Values

The Result Details pane displays a summary of the output value results.

From the Captured Data pane, you can view detailed results by clicking View XML Output
Value Results to open the XML Output Value Results window.
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The following is an example of the results for an XML output value:

Note: By default, the View XML Output Value Results button is available only when an
error occurs. The availability of these detailed results is dependent on the Save
still image captures to results setting in the Screen Capture pane (Tools > Options > GUI
Testing tab > Screen Capture node) of the Options dialog box.

Parameterized values in the run results
A parameter is a variable that is assigned a value from an external data source or
generator for a test, or from within a component. You can view the values for the
parameters defined in your test or component in the Run Results Viewer.
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To view parameterized values, expand the nodes in the run results tree and click the
root node to view test or component input and output parameters, or click an action node
that contains parameterized values (tests only).

Test and component parameters are displayed in the Parameters section of the Executive
Summary area of the Results Details pane, which you display by clicking the root node
of the run results tree. The example below shows input test parameters. The Parameters
section would be identical for input component parameters.

If output test or component parameters were defined, they would be displayed in this
pane beneath the input parameters.
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For action parameters, the name and value of the input and output parameters are
displayed in the Result Details pane. Similar results would be displayed for a
component.

The example above shows input parameters that were defined at the action level. If
output parameters were defined at this level, they would also be displayed in this
pane.W
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GUI Tests containing calls to UFT API /Service Test
Tests
If your test contains a call to a UFT API or Service Test test, you can view the results of
that test in the run results. The run results tree displays all of the GUI test-specific nodes
that preceded the call to the UFT API or Service Test test, all of the UFT API or Service
Test test-specific nodes from that test call, and all of the GUI test-specific nodes that
followed that call.
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Send Us Feedback
Let us know how we can improve your experience with the User Guide.

Send your email to: docteam@hpe.com
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