Save web passwords in Chrome might cause issue when changing operator records

  • KM02125262
  • 05-Feb-2016
  • 10-Feb-2016

Summary

When changing operator records in Service Manager (SM) user might see incorrect value in password field. This document provides a workaround to resolve the problem.

Error

When browsing an operator record, or changing operator records via Mass Update > Simple Update, user might see incorrect value in password field of operator table. Please refer to the screenshots as below.

Browse an operator record:

image text

 

The correct display of the password field should be:

image text

Select several operator records, perform Mass Update > Simple Update. Go to Security tab, the value in password field is supposed to be empty, while it is displaying as if there was value in this field.

 image text

The incorrect display of password might cause issues when saving the record(s).

NOTE: This behavior was currently seen in particular SM versions as below, using Chrome browser:

SM RTE: 9.35.2003
SM APP: 7.11.000
Web Client: 9.35.2003
Chrome: 47.0.2526.80

It is not seen in 9.35 APP/RTE and 9.4x APP/RTE with Chrome/Internet Explorer.

Cause

The problem is related to Chrome passwords settings.

Open Chrome browser, select Settings > Show advanced settings > Passwords and forms

image text

The wrong behavior in SM web tier was only observed when option "Offer to save your web passwords" was checked.

Fix

To workaround this issue, user could uncheck "Offer to save your web passwords" option in Chrome settings in above screenshot, then close whole Chrome browser and open a new one.

After logging in SM with the newly opened login page, user will see the password field is showing expected value.