The Northbound integration feature is not working on NNMi Freemium edition.

  • KM02109844
  • 28-Jan-2016
  • 08-Jun-2021

Summary

This document confirms that per product design, the Northbound integration is disabled for NNMi Freemium version.

Error

The NBI (Northbound Integration) feature in NNMi v10.x (Network Node Manager) is not working. Additionally, when 'FINE' level logging is enabled for the 'com.hp.ov.nnm.northbound.im' logger, the following entries are recorded to the nnm-trace.log

   "FINE  [com.hp.ov.nnm.northbound.im.ejb.engine.NorthboundEngineBean] (pool-1-thread-50) NBI available for use?...
    FINE  [com.hp.ov.nnm.northbound.im.ejb.engine.NorthboundEngineBean] (pool-1-thread-50) NBI not available for use"


To enable FINE/FINER/FINEST level of logging for 'com.hp.ov.nnm.northbound.im' -

   a. On the NNMi management station, switch directory to - %nnmInstallDir%\support 'OR' /opt/OV/support

   b. Enable FINE, FINER or FINEST level tracing on the said module via the command -

       #nnmsetlogginglevel.ovpl com.hp.ov.nnm.northbound.im <log_level>

   c. The trace log information will be written to nnm-trace.log under the directory %nnmDataDir%\log\nnm 'OR' /var/opt/OV/log/nnm

Cause

Per product design, the NBI (Northbound Integration) feature is disabled on NNMi Freemium version.

Fix

To enable and use the Northbound integration feature, upgrade the existing NNMi Freemium to either Standard/Advanced/Premium/Ultimate version.

The product design dictates that -

A. When the NNMi Freemium license is active and in use, the NBI feature is 'disabled'. If 'FINE' level tracing is enabled on the 'com.hp.ov.nnm.northbound.im' logger, the following entries will be    recorded to the nnm-trace.log file.

         "FINE  [com.hp.ov.nnm.northbound.im.ejb.engine.NorthboundEngineBean] (pool-1-thread-50) NBI not available for use"

    To check if 'Freemium' license is in use on the NNMi management station -

         Goto, NNMi Console -> Help (menu) -> System Information -> Product (tab) -> View Licensing Information

                                                                        'OR'

         Run the command: %nnmInstallDir%\support 'OR' /opt/OV/support> nnmtwiddle.ovpl -u <username> -p <password> get com.hp.ov.nms.licensingejb:mbean=LicensingInterface FreeLicensed

         The command output as "FreeLicensed=true", suggests that NNMi Freemium version is in use. Alternatively, when a NNMi Evaluation/Advanced/Premium/Ultimate license type is in use,       the command will result in "FreeLicensed=false"

B. When the NNMi Evaluation license is active and in use, the NBI feature is 'enabled'. If 'FINER' level tracing is enabled on 'com.hp.ov.nnm.northbound.im', the following entries will be recorded to the nnm-trace.log file.

         "FINER  [com.hp.ov.nnm.northbound.im.ejb.engine.NorthboundEngineBean] (pool-1-thread-50) NBI is available for evaluation"

    To check if a temporary 'Evaluation' license is in use on the NNMi management station -      

         Goto, NNMi Console -> Help (menu) -> System Information -> Product (tab) -> View Licensing Information

                                                                         'OR'

         Run the command: %nnmInstallDir%\support 'OR' /opt/OV/support> nnmtwiddle.ovpl -u <username> -p <passsword> invoke "com.hp.ov.nms.licensingejb:mbean=LicensingInterface" isEvaluationLicensed "NNM"

         The command output as 'true', confirms that an Evaluation license is in use. Alternatively, this should result in 'false'

C. When a valid NNMi Standard/Advance/Premium/Ultimate license is in use, the NBI feature is 'enabled'. If 'FINEST' level tracing is enabled on 'com.hp.ov.nnm.northbound.im', the following entries will be recorded to the nnm-trace.log file.

         "FINEST  [com.hp.ov.nnm.northbound.im.ejb.engine.NorthboundEngineBean] (pool-1-thread-50) NBI available for use"