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Legal Notices

Warranty
The only warranties for HP products and services are set forth in the express warranty statements accompanying such
products and services. Nothing herein should be construed as constituting an additional warranty. HP shall not be liable
for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend
Confidential computer software. Valid license from HP required for possession, use or copying. Consistent with FAR
12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and Technical Data for
Commercial Items are licensed to the U.S. Government under vendor's standard commercial license.

Copyright Notice
© Copyright 1992 - 2016 Hewlett-Packard Development Company, L.P.

Trademark Notices
Adobe® and Acrobat® are trademarks of Adobe Systems Incorporated.

Google™ and Google Maps™ are trademarks of Google Inc

Intel® and Pentium® are trademarks of Intel Corporation in the U.S. and other countries.

Microsoft®, Windows®, Windows® XP, and Windows Vista ® are U.S. registered trademarks of Microsoft Corporation.

Oracle and Java are registered trademarks of Oracle and/or its affiliates.

Documentation Updates
The title page of this document contains the following identifying information:

l Software Version number, which indicates the software version.
l Document Release Date, which changes each time the document is updated.
l Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go to:
https://softwaresupport.hp.com.

This site requires that you register for an HP Passport and sign in. To register for an HP Passport ID, go to
https://softwaresupport.hp.com and click Register.

Support
Visit the HP Software Support Online web site at: https://softwaresupport.hp.com

This web site provides contact information and details about the products, services, and support that HP Software
offers.
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HP Software online support provides customer self-solve capabilities. It provides a fast and efficient way to access
interactive technical support tools needed to manage your business. As a valued support customer, you can benefit by
using the support web site to:

l Search for knowledge documents of interest
l Submit and track support cases and enhancement requests
l Download software patches
l Manage support contracts
l Look up HP support contacts
l Review information about available services
l Enter into discussions with other software customers
l Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a support
contract. To register for an HP Passport ID, go to: https://softwaresupport.hp.com and click Register.

To find more information about access levels, go to: https://softwaresupport.hp.com/web/softwaresupport/access-
levels.

HP Software Solutions & Integrations and Best Practices
Visit HP Software Solutions Now at https://h20230.www2.hp.com/sc/solutions/index.jsp to explore how the products
in the HP Software catalog work together, exchange information, and solve business needs.

Visit the Cross Portfolio Best Practices Library at https://hpln.hp.com/group/best-practices-hpsw to access a wide
variety of best practice documents and materials.
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About the UFT Runtime Engine
The UFTRuntime Engine enables you to run UFT tests (both GUI and API) and business process tests on
your computer without installing the entire UFT IDE. In addition, you can also install the Runtime Engine
without the Run Results Viewer, UFT Add-in for ALM, sample applications, or Help documentation. This
can potentially save you valuable disk space on your computer.

When you run tests with the Runtime Engine, you can access and run the test from a number of
different places without the need to open the UFT interface and configure UFT options. When the test
runs it runs in the background. At the end of the test run, you can view the test results.

Using the Runtime Engine requires very little experience in using UFT - you do not need to edit tests,
change configurations or settings, or understand how to make UFT work with your application. You
simply select the test, run the test, and view the run results.

The Runtime Engine can be used in a number of different scenarios:

Running
tests and
components
from ALM

You can set up test runs from theTest Lab module in ALM, and run these on a computer using theRuntime
Engine. Using theRuntimeEngine enables you to run the test, without the need to interact with theUFT
interface (such as loading UFT add-ins in theAdd-in Manager dialog box).

Running
tests from
automation:

You also can run tests using automation using theRuntimeEngine. TheRuntimeEngine installation enables
you to save disk space on the computer running these tests, freeing up system resources on that computer for
other tasks

Running
tests using
the Jenkins
plug-in:

TheRuntimeEngine can be installed on abuild server or computer running builds of your applications. Using
the Jenkins plug-in, you run aUFT test as a post-build action of your application's build process. Having the
RuntimeEngine installed on this computer to run theUFT test enables you to free up system resources for the
important application build tasks.

Running
tests using
external
UFT tools

When you install theRuntimeEngine, you also have external tools which enable you to run UFT tests locally,
including the Test Batch Runner and the Silent Test Runner. These tools enable you to run a test locally against
your application as it is developed, and view the results instantly after the test run. Because theRuntimeEngine
does not enable you to edit a test, this version of theUFT installation can beused by your application's
developers and QA on an ongoing basis to provide regular testing of the application throughout the
development process.

The Runtime Engine also supports all the UFT Add-ins as the the full UFT IDE, so you can run tests using
any supported technology using the Runtime Engine. All objects and methods for all UFT Add-ins are
supported for use with the Runtime Engine.

As part of running a test, you can set specific run-time options. These options are set in the Runtime
Engine Settings dialog box, available from the Start Menu (Start > All Programs > HP Software > HP
Unified Functional Testing > Tools > Runtime Engine Settings):

Add-ins You can specify add-ins to be loaded.

Run options You can specify how theRuntimeEngine runs tests, including the format of the run results, whether the
run results are opened automatically after a test run, and if theRuntimeEngine takes screen captures or
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movies of the run session.

Remote
connection
options

You can specify if other HP applications are permitted to run tests on this computer using theRuntime
Engine or specify how another computer can run tests via RemoteDesktop Connection.

Run result
export options

You can specify how and what theRuntimeEngine should export from the run results after a run session.

Text Recogition
options

You can specify how theRuntimeEngineworks with text in your application when running aGUI test.

Web and
Windows
Application
options

You can specify how theRuntimeEngine runs tests for specific scenarios against aWeb application or
Windows application.

For task details on how to use the Runtime Engine, see "How to Use the UFT Runtime Engine" on page 6.
For details on the Runtime Engine Settings, see "Prerequisite - How to set test run options" on page 8.
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How to Use the UFT Runtime Engine
What is the UFT Runtime Engine? The UFT Runtime Engine is a slimmer installation of UFT that enables
you to run UFT tests without the entire UFT IDE.

When you should use the UFT Runtime Engine? You can use the UFT Runtime Engine in a number of
different scenarios:

l Running tests and components from ALM (either from the Test Plan, Test Lab, or Business
Components modules)

l Running tests from an automation script

l Running tests from the Jenkins plugin

l Running tests from external UFT tools such as the Test Batch Runner or the Silent Test Runner

l Running tests locally against your application (after it has been updated) without needing to edit the
test

What do you want to know?

l "Prerequisite - How to ensure the Runtime Engine is installed correctly" below

l "Prerequisite - How to install your license" below

l "Prerequisite - How to set test run options" on page 8

l "How to run tests from ALM" on page 9

l "How to run tests using automation" on page 10

l "How to run tests from the Jenkins plugin" on page 11

l "How to run rests using the Test Batch Runner" on page 11

l "How to run tests using the Silent Test Runner" on page 12

Prerequisite - How to ensure the Runtime Engine is installed correctly

Before running a test using the Runtime Engine, ensure the following:

l You have installed and loaded the correct add-ins for your test. The currently loaded add-ins can be
modified in the Runtime Engine settings dialog box.

l You have selected the Allow other HP products to run tests and components option in the UFT
Configurations screen of the installation wizard

If you did not perform one or both of these options, you can configure this option by running the UFT
Setup again and selecting the Change option in the installation wizard.

Prerequisite - How to install your license

Before you can run tests with the Runtime Engine, you must install a valid UFT license. You do this either
using the license installation wizard or with the command line:
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From the
License
Wizard

1. From theStart Menu, open the License Installation Wizard (Start > All Programs > HP Software
> Unified Functional Testing > Tools > License Installation Wizard).

2. Follow the steps in thewizard to install the correct license type.

Note:

l When requesting a license, you need the license typeUFT Runtime Engine.

l For a seat license, you need a license key string or a license key file.

l For a concurrent license installation, you need the address of the License Server on which your
licenses are installed.

3. Exit thewizard.

When theRuntimeEngine runs your test, it will check for the license before running the test.

From the
Command
Line

1. Open a command window.

2. In the command window, enter oneof the following:

l For a seat license: "<UFT installation
directory>\bin\HP.UFT.LicenseInstall.exe" seat "<license key
string>"/seat "<path to the license key file"

Note: You need to provide either the license key string or the path to the license key file, not both.

l For a concurrent license: "<UFT installation
directory>\bin\HP.UFT.LicenseInstall.exe" concurrent <license ID>
<license version> <server name/address> [<redundant server
name/address>] [/force]

Note:

o The<server name/address> or <redundant server name/address> uses
the format server name/address:port. The port number is optional.

o The<server name/address> or <redundant server name/address>must
be in the same format as the server nameor address listed in theMain tab of the Configuration
paneof the License Server. For more details on setting up the License Server address, see the
Autopass License Server User Guide.

o Both the[redundant server name/address] and /force parameters are
optional.

o The/force parameter saves the license installation information even if the current
installation fails. On subsequent UFT sessions, UFT will check the listed license server for the
listed license.

3. Exit thewizard.

When theRuntimeEngine runs your test, it will check for the license before running the test.
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Prerequisite - How to set test run options

Before you run your tests, you should specify the options for running your tests. You can use the
Runtime Engine Settings dialog box to specify these settings. This dialog box is available from the Start
Menu (Start > All Programs > HP Software > HP Unified Functional Testing > Tools > Runtime Engine
Settings).

You can update the settings in the following ways:

Manually
configure the
settings:

Using the options provided in the dialog box, select the relevant values from thedrop-down lists and click
Apply to save the settings.

After you update these settings, you can click theExport Settings to Script button , which
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exports these settings into an automation script file (saved with a .vbsextension). This script can be
reimported on your computer for later test runs or shared with others running tests via theRuntime
Engine.

Import the
settings from a
configuration
script:

You can also update these settings from an generated automation script exported from theUFT IDE on
another computer or exported from another installation of theRuntimeEngine.

Do the following:

1. Click the Import Settings from Script button .

2. Navigate to the directorywhere your import script (with a .vbsextension) is saved and clickOpen.

The settings in the dialog are updated accordingly to reflect the data in the script.

For descriptions of each of the options, select the item in the dialog box and view the description at the
bottom of the dialog.

Note: If you are setting the options for the Remote Desktop connection in the Runtime Engine
Settings dialog, you must log in to the computer as an administrator and start the HP.UFT.Helper
service before changing these options.

How to run tests from ALM

Using the Runtime Engine, you can run tests and components directly from the Test Lab Modules:

1. Ensure that the DCOM has been configured to run tests from ALM as part of the installation.

If this configuration was not done during the Runtime Engine installation, you can perform the
configuration with the Additional Installation Requirements tool (installed with the Runtime
Engine), found in the Start Menu (Start > All Programs > HP Software > HP Unified Functional
Testing > Tools > Additional Installation Requirements > Configure DCOM Settings for
ALM  Integration option).

2. Set your test run options, as described in "Prerequisite - How to set test run options" on the
previous page.

3. Start the Remote Agent from the Start Menu (Start > All Programs > HP Software > HP Unified
Functional Testing > Tools > Remote Agent).

4. In the Windows tray, right-click the Remote Agent icon and select Settings.

5. In the Remote Agent Settings dialog box, configure the following options as needed:

l Restart testing tool after __ runs

l Close testing tool after __ idle minutes

l Restart testing tool after

Note: The other options in the Remote Agent are not applicable for use with the Runtime
Engine.
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6. In ALM, from the Test Plan module, run individual tests or a test set, depending on your needs. For
details on setting up test sets and running from ALM, see the HP Application Lifecycle Management
User Guide.

7. After the test run is finished, view the results as specified in your test run options.

How to run tests using automation

Automation is a Microsoft technology that makes it possible to access software objects inside one
application from other applications. These objects can be created and manipulated using a scripting or
programming language such as VBScript or VC++. Automation enables you to control the functionality of
an application programmatically.

Using automation, you can write scripts that open UFT, set options and settings, and run the test. This
enables you to automatically run tests at scheduled times without your manual intervention.

For example, you can create and run an automation script from Microsoft Visual Basic that does the
following:

l Loads the required add-ins for a test or component

l Starts UFT

l Opens the test or component

l Configures settings that correspond to those in the Options dialog box, Test or Business Components
Settings dialog box, and the Record and Run Settings dialog box (all in the full UFT IDE)

l Runs the test or component

When you run tests using automation, do the following:

1. If another computer is running automation scripts via the computer with the Runtime
Engine, ensure that the DCOM has been configured to run tests with automation as part of the
installation.

If this configuration was not done during the Runtime Engine installation, you can perform the
configuration with the Additional Installation Requirements tool (installed with the Runtime
Engine), found in the Start Menu (Start > All Programs > HP Software > HP Unified Functional
Testing > Tools > Additional Installation Requirements > Configure DCOM Settings for
Automation Scripts option).

2. Ensure that your script is accessible from the computer with the Runtime Engine.

3. Set your test run options, as described in "Prerequisite - How to set test run options" on page 8.

4. Run your test script, using your preferred automation run model. For details on running tests via
automation, see the HP Unified Functional Testing User Guide, available from the HP Software
Product Manuals Web site (https://softwaresupport.hp.com/group/softwaresupport/search-
result?keyword=).

Note: The options in your automation scripts that set UFT to be visible are ignored when
running a test with the Runtime Engine. The test runs without problems even if your
automation scripts contain these options, including the following automation methods:
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l AutoGenerateWith

l DisableVORRecognition

l DisplayKeywordView

l TimetoActivateWinAfterPoint

l WithGenerationLevel

5. After the test run is finished, view the results as specified in your test run options.

How to run tests from the Jenkins plugin

The Jenkins CI plugin integrates with the Runtime Engine to enable you to automatically run your UFT
tests directly from the file system as part of the build process. To run these tests, do the following:

1. Ensure that your tests or test batches are saved and accessible on the file system.

2. Set your test run options, as described in "Prerequisite - How to set test run options" on page 8.

3. Configure the Jenkins plug-in to run functional tests. For details on this configuration, see the
Jenkins plug-in wiki page at https://wiki.jenkins-
ci.org/display/JENKINS/HP+Application+Automation+Tools#HPApplicationAutomationTools-
RunningFunctionalTestsorLoadRunnerScenariosfromtheFileSystem.

4. In the Jenkins plug-in, specify the location of the tests or test batches in the Tests box of the plug-
in.

Note: To specify multiple entries, click the down arrow on the right of the field and enter each
test path on a separate line. Make sure that the paths are accessible from all machines in the
local network.

When a build of your application runs, the Jenkins plug-in will automatically run this test as
configured in the plug-in settings.

5. After the test run is finished, view the results as specifed in your test run options.

How to run rests using the Test Batch Runner

You can also use the Test Batch Runner (installed with the Runtime Engine) to run a single test or a
group of tests combined into a test batch (saved with an .mtb extension). To run these tests, do the
following:

1. Ensure that your tests and test batches are saved and accessible on the file system.

2. Set your test run options, as described in "Prerequisite - How to set test run options" on page 8.

3. Open the Test Batch Runner from the Start Menu (Start > All Programs > HP Software >
HP Unified Functional Testing > Tools > Test Batch Runner).

4. In the Test Batch Runner main window, add tests to the list of tests to be run in one of the
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following ways:

l Select File > Add and select a precompiled Test Batch (.mtb) file.

l Create or open a test batch file (File > New/Open), and then add tests to the test batch
(Tests > Add Test from Folder).

5. When you have added all the necessary tests to run, in the toolbar, click the Run button .

The Runtime Engine runs the test or tests on your application automatically. You can view the
status of each individual test run in the main Test Batch Runner window.

6. After the test run is finished, view the results as specified in your test run options. The Test Batch
Window provides the location of the run results.

How to run tests using the Silent Test Runner

The Runtime Engine enables you to run tests using the Silent Test Runner (installed with the Runtime
Engine). This enables you to simulate the way a UFT test runs from LoadRunner and Business Service
Management and to verify that your UFT test is compatible with LoadRunner and Business Service
Management.

Note: If you want to run tests with the Silent Test Runner, you must install the Samples component
in the Custom Setup screen of the installation wizard.

To run a test with the Silent Test Runner, do the following:

1. Ensure that your tests and test batches are saved and accessible on the file system.

2. Set your test run options, as described in "Prerequisite - How to set test run options" on page 8.

3. Open the Silent Test Runner from the Start Menu (Start > All Programs > HP Software
> HP Unified Functional Testing > Tools > Silent Test Runner).

4. In the Silent Test Runner window, click the Browse button and select a test.

5. Click Run Test to start the test run.

When the test run is complete, the Silent Test Runner window displays a message confirming the
end of the test run.

6. In the Silent Test Runner window, click the Test Run Log window. A text file is displayed with a
report of all test steps from the current run.
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Send Us Feedback
Can we make this Runtime Engine Guide better?

Tell us how: docteam@hpe.com
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