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To check for recent updates or to verify that you are using the most recent edition of a document, go to:
https://softwaresupport.hp.com.

This site requires that you register for an HP Passport and sign in. To register for an HP Passport ID, go to
https://softwaresupport.hp.com and click Register.

Support
Visit the HP Software Support Online web site at: https://softwaresupport.hp.com
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HP Software online support provides customer self-solve capabilities. It provides a fast and efficient way to access
interactive technical support tools needed to manage your business. As a valued support customer, you can benefit by
using the support web site to:

l Search for knowledge documents of interest
l Submit and track support cases and enhancement requests
l Download software patches
l Manage support contracts
l Look up HP support contacts
l Review information about available services
l Enter into discussions with other software customers
l Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a support
contract. To register for an HP Passport ID, go to: https://softwaresupport.hp.com and click Register.

To find more information about access levels, go to: https://softwaresupport.hp.com/web/softwaresupport/access-
levels.

HP Software Solutions & Integrations and Best Practices
Visit HP Software Solutions Now at https://h20230.www2.hp.com/sc/solutions/index.jsp to explore how the products
in the HP Software catalog work together, exchange information, and solve business needs.

Visit the Cross Portfolio Best Practices Library at https://hpln.hp.com/group/best-practices-hpsw to access a wide
variety of best practice documents and materials.
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Welcome to the Run Results Viewer User
Guide
The HP Run Results Viewer User Guide explains how to use the Run Results Viewer to interpret and use
the test results from your GUI or API tests.

It is recommended to have some prior knowledge of UFT and its testing capabilities so you can fully
evaluate the test results.

Additional Online Resources
The following additional online resources are available:

Resource Description

HP Software
Support Online

TheHP Software Support Web site (www.hp.com/go/hpsoftwaresupport). To access, chooseHelp > HP
Software Support.

Note: Most of the support areas require that you register as an HP Passport user and sign in. Many
also require a support contract. To register for an HP Passport user ID, go to:
http://h20229.www2.hp.com/passport-registration.html

Testing Forums l API Testing: http://h30499.www3.hp.com/t5/Service-Test-Support-and-News/bd-p/sws-Serv_
TEST_SF

l BPT: http://h30499.www3.hp.com/t5/Business-Process-Validation/bd-p/sws-BPT_SF

UFT Product
Page

TheHP Unified Functional Testing product page (http://www8.hp.com/us/en/software-
solutions/unified-functional-testing-automated-testing/index.html), with information and related
links about UFT. To access, select Help > Useful Links > Product Page.

Troubleshooting
& Knowledge
Base

TheTroubleshooting page (http://h20230.www2.hp.com/troubleshooting.jsp) on theHP Software
Support Web sitewhere you can search theHP Software Self-solve knowledgebase. To access, select
Help > Knowledge Base orHelp > Troubleshooting.

HP Software
Community

TheHP IT Experts Community site (http://h10124.www1.hp.com/campaigns/IT_
Experts/pages/home.html), where you can interact with other HP software users, read articles and blogs
on HP software and access downloads of other software products.

HP Manuals Site TheHP SoftwareProduct Manuals Web site (http://support.openview.hp.com/selfsolve/manuals), to
search for themost up-to-date documentation for a selected HP Software product. To access, select
Help > Useful Links > HP Manuals Site.

What's New TheUFT What's New Help, describing the new features and enhancements in this version of UFT.

Product Movies TheUFT HPLN (HP LiveNetworks) page (https://hpln.hp.com/page/uft-120-videos) with a list of all
product movies.
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Resource Description

HP Software
Web site

TheHP SoftwareWeb site (www.hp.com/go/software). This site provides you with themost up-to-date
information on HP Software products. This includes new software releases, seminars and trade shows,
customer support, and more.
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Chapter 1: Using the Run Results Viewer
This chapter includes:

• Run Results Viewer Overview 8

• Run Results XML File 10

• Run Results File Location 11

• Custom Fields (UFT API Testing Only) 12

• How to Install the Run Results Viewer as a Standalone Application 14

• How to Open Run Results 14

• How to Navigate the Run Results Tree 15

• How to Customize the Run Results Viewer 17

• How to Jump to a Step in a GUI Test (UFT GUI Tests Only) 18

• How to Manually Submit Defects to ALM 18

• How to Automatically Submit Defects to an ALM Project (UFT GUI Tests Only) 20

• How to Export Run Results 21

• How to Play a Screen Recorder Movie in the HP Micro Player (UFT GUI Testing Only) 22

• How to Delete Run Results 23

• Run Results Viewer User Interface 23

• Troubleshooting and Limitations - Viewing Run Results 28

Run Results Viewer Overview
After running a test or component, you can view the run results in the HP Run Results Viewer. The Run
Results Viewer contains multiple panes, each of which displays specific types of information. The Run
Results Tree Pane and Search Box displays a hierarchical representation of the run results. The
remaining panes provide details about a selected node or step, the data used for a particular step,
optional screen captures or images (UFT GUI testing only), optional system information (UFT GUI testing
only), and so on.

In addition, you can view the run results in HTML format directly in your browser or in UFT. To select the
format in which you want to view the run results, open the Run Sessions pane in the Options dialog box
(Tools > Options > General tab > Run Sessions node).
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By default, the Run Results Viewer opens automatically at the end of a run session. If you want to
change this behavior, in UFT, clear the View results when run session ends check box in the Run
Sessions pane of the Options dialog box.

The Run Results Viewer contains a description of the steps performed during the run session.

l For a GUI component, or for a GUI test that does not contain Data Pane parameters, the Run Results
Viewer shows a single test iteration.

l For tests, if the test contains Data Pane parameters, and the test settings are configured to run
multiple iterations, the Run Results Viewer displays details for each iteration of the test run. The
results are grouped by the actions in the test.

l For an API test, the individual steps and checkpoints included in the test. If a test is set to run
multiple iterations, each iteration is displayed.

You set the test to run for one or all iterations in the Run pane of the Settings dialog box. For details,
see the section describing the Run pane in the HP Unified Functional Testing User Guide.

UFT GUI/UFT API Integration

If you run a UFT GUI test that contains a call to a UFT API or Service Test test, or vice versa, you can view
the results for all steps performed in the main test and in the called test.

(Not relevant for business components)

Viewing Partial Results (UFT GUI Testing Only)

In addition to viewing the results for a run session after a run is complete (including runs that crash
prior to completion), you can view the results during a run session by opening the results.xml file for
that run. This enables you to view partial results (up to the step for which the results are opened). For
example, you may want to view the results for a specific iteration before the run continues to the next
iteration. One way to do this is to insert a step that opens a message box, as this stops the run until you
close the message box. For example:

MsgBox "Open the following file:" & Reporter.ReportPath

Note: To view the partial results in the Run Results Viewer, you need to open the results file from
another computer.

Installing the Run Results Viewer

The Run Results Viewer is installed automatically with UFT.

You can also install the Run Results Viewer as a standalone application. This enables you to share the
results of your tests with business analysts and developers who do not have UFT installed on their
computers. For details, see "How to Install the Run Results Viewer as a Standalone Application".
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Run Results XML File
The results of each run session are saved in a single .xml file (called results.xml). This .xml file
stores information on each of the run result nodes in the display. The information in these nodes is used
to dynamically create .htm files that are shown in the Result Details pane in the Run Results Viewer.

Each node in the run results tree is an element in the results.xml file. In addition, there are different
elements that represent different types of information displayed in the run results. You can take run
result information from the .xml file and use XSL to display the information you require in a customized
format (either when printing from within the Run Results Viewer, when displaying run results in your
own customized results viewer, or when exporting the run results to an .html file).

The diagram below for a GUI test, shows the correlation between some of the elements in the .xml file
and the items they represent in the run results. These elements are similar for both tests and business
components.

XSL provides you with the tools to describe exactly which run result information to display and exactly
where and how to display, print or export it. You can also modify the .css file referenced by the .xsl
file, to change the appearance of the report (for example, fonts, colors, and so forth).

For example, in the results.xml file, one element tag contains the name of an action or a component,
and another element tag contains information on the time at which the run session is performed. Using
XSL, you could tell your customized Run Results Viewer that the action or component name should be

User Guide
Chapter 1: Using the Run Results Viewer

HP Run Results Viewer (12.51) Page 10



displayed in a specific place on the page and in a bold green font, and that the time information should
not be displayed at all.

You may find it easier to modify the existing .xsl and .css files provided with the Run Results Viewer
application, instead of creating your own customized files from scratch. The files are located in the
HP\Run Results Viewer\dat folder, and are named as follows:

l PShort.xsl. Specifies the content of the run results report printed, or exported to an HTML file,
when you select the Short option in the Print or Export to HTML File dialog boxes.

l PDetails.xsl. Specifies the content of the run results report printed, or exported to an HTML file,
when you select the Detailed option in the Print or Export to HTML File dialog boxes.

l PStringTable.xsl. Specifies the string constants to be used in the exported document. For
example, Iteration #may be used for the iteration number prefix. If you select the User-defined
XSL option in the Print or Export to HTML File dialog boxes, the .xsl file you specify must contain an
"include" call to this file. You can localize the strings, if needed.

l PResults.css. Specifies the appearance of the run results print preview. This file is referenced by
the above .xsl files.

l Results.css. Specifies the styles, fonts, and colors of the various elements displayed in the run
results.

UFT only: For details on the structure of the XML schema, and a description of the elements and
attributes you can use to customize the run results reports, see the HP Run Results Schema Reference
(Help > HP UFT GUI Testing Automation and Schema References Help > HP Run Results Schema
Reference).

Run Results File Location
Depending on the type of test, run results can be stored in different locations.

GUI Tests

Tests saved in the file system. By default, the results of a GUI test saved in the file system are stored
in the test folder. When you run your test, you can specify a different location to store the results, using
the Results Location tab of the Run dialog box. Specifying your own location for the results file can
make it easier for you to locate the results file in the file system.

Tests saved in ALM. Run results are stored in the test folder in ALM. You cannot change the location of
the run session results.

For details, see the section describing the Run dialog box in the HP Unified Functional Testing User Guide.

GUI Components

By default, the results of a component run are stored in an ALM cache folder on your computer.

User Guide
Chapter 1: Using the Run Results Viewer

HP Run Results Viewer (12.51) Page 11



When you run your test, you can specify a different location to store the results, using the Results
Location tab of the Run dialog box. Specifying your own location for the results file can make it easier
for you to locate the results file in the file system.

For details, see section describing the Run dialog box in the HP Unified Functional Testing User Guide.

API Tests

Tests saved in the file system. By default, the results of API tests that are saved in the file system, are
stored in the test folder. When you run your test, you can specify a different location to store the
results, using the Results Location tab of the Run dialog box. Specifying your own location for the
results file can make it easier for you to locate the results file in the file system.

Tests saved in ALM. Run results are stored in your ALM project. You cannot change the location of the
run session results.

For details, see the HP Unified Functional Testing User Guide.

Custom Fields (UFT API Testing Only)
You can use the Report function to show custom information in the Run Results Viewer. You can specify
strings or existing arguments and display them in the viewer.

You add the Report function to the step's events. For details, see the section on Custom Code and
Events in the HP Unified Functional Testing User Guide.

The following example prints APR-12-2010_CYCLE_1 in the Value column for TestID.

args.Activity.Report("TestID","APR-12-2010_CYCLE_1");

User Guide
Chapter 1: Using the Run Results Viewer

HP Run Results Viewer (12.51) Page 12



The report displays the keyword and its value at the Activity level of the results.

Accessing the UFT in Windows 8.X or Higher
Operating Systems
By default, the Run Results Viewer is not displayed on the Start or Apps screen in Windows 8.x or higher.

You can add the Run Results Viewer to the Start screen by navigating to its location on the file system
or the Desktop screen and pinning it to the Start screen.

In addition, you can add other related files, including .exe files and documentation the Start screen by
pinning these items.

Note: By default, the Start and Apps screens on Windows 8.x or higher are set to open Internet
Explorer in Metro Mode. However, if User Account Control is turned off on your computer, Windows
8 will not open Internet Explorer in Metro mode. Therefore, if you try to open an HTML shortcut
from the Start or Apps screen, such as the UFT Help or Readme file, an error will be displayed.

To solve this, you can change the default behavior of Internet Explorer so that it never opens in
Metro mode. In the Internet Properties dialog box > Programs tab, select Always in Internet
Explorer on the desktop for the Choose how you open links option. For more details, see
http://support.microsoft.com/kb/2736601 and
http://blogs.msdn.com/b/ie/archive/2012/03/26/launch-options-for-internet-explorer-10-on-
windows-8.aspx.
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How to Install the Run Results Viewer as a
Standalone Application
The Run Results Viewer is installed by default together with UFT. This task describes how to install the
Run Results Viewer as a standalone application. For example, business analysts and developers that do
not have UFT installed on their computers can install the Run Results Viewer locally as a standalone
application. You can then share the results of your tests with them.

1. Install the prerequisite applications, if any.

Insert the UFT installation DVD into a DVD drive and browse to and double-click
RunResultsViewer\EN\setup.exe. Setup checks your computer for the required prerequisites,
and enables you to install them, if needed. Follow the on-screen instructions. After the
prerequisites are installed, you may need to restart the computer.

2. Install the HP Run Results Viewer.

Insert the UFT installation DVD into a DVD drive and browse to and double-click
RunResultsViewer\EN\setup.exe. Follow the on-screen instructions.

The Run Results Viewer is installed and can be opened from Start > All Programs > HP Software >
HP Run Results Viewer > Run Results Viewer.

Note: For details on accessing UFT and UFT tools and files in Windows 8 and Windows Server
2012, see "Accessing the UFT in Windows 8.X or Higher Operating Systems" on the previous
page.

How to Open Run Results
The following steps describe how to open specific run results in the Run Results Viewer:

l "Open the Run Results Viewer" on the next page

l "Connect to your ALM project - optional" on the next page

l "View saved results " on the next page
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Open the Run Results Viewer

Open the Run Results Viewer in one of the following ways:

l In UFT, select View > Last Run Results or click the Results button .

l From the Startmenu, select Start > All Programs >HP Software > HP Run Results Viewer > Run
Results Viewer.

l Run a test or component. By default, the results are displayed in the Run Results Viewer at the end of
the run session. (In UFT, you can change the default setting in the Run Sessions pane of the Options
dialog box. For details, see the HP Unified Functional Testing User Guide.)

Note: This section describes how to open tests and components run in UFT. For other types of
tests, see your testing product's documentation.

Connect to your ALM project - optional

If your run results are saved in ALM, connect to your ALM project before opening the results file.

View saved results

When you open the Run Results Viewer manually, the Open Run Results dialog box opens automatically,
enabling you to select results to display.

If the Run Results Viewer opened automatically, click the Open button or select File > Open .
Browse to the relevant results.

How to Navigate the Run Results Tree
This task describes how to collapse or expand a branch in the run results tree to select the level of
detail that the tree displays.

When you open run results in the Run Results Viewer for the first time, the tree expands one level at a
time. If the child branches under a parent branch were previously expanded, that state is maintained
when you expand or collapse the parent branch.

You can do the following to view the results:

l "Expand a specific branch" on the next page

l "Expand a branch and all branches below it: " on the next page

l "Expand all of the branches in the run results tree: " on the next page

l "Collapse a specific node: " on the next page

l "Collapse all of the nodes in the tree: " on the next page

l "Move between previously selected nodes within the run results tree: " on the next page
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l "Find specific steps within the Run Results: " on the next page

l "Filter the tree to display only nodes that match certain criteria: " on the next page

Expand a specific branch

l Double-click the branch.

l Select the branch and click the arrow to the left of the branch icon.

l Press the plus key (+) on your keyboard number pad.

The tree displays the details for the branch, and the expand sign changes to collapse.

Expand a branch and all branches below it:

l Select the branch and press the asterisk (*) key on your keyboard number pad.

l Right-click a branch and select Expand All.

Expand all of the branches in the run results tree:

l Right-click the top level branch and select Expand All.

l Select View > Expand All.

l Click the Expand All button .

l Select the top level of the tree and press the asterisk (*) key on your keyboard number pad.

Collapse a specific node:

l Double-click the node.

l Right-click a node and select Collapse All.

l Select it and click the arrow to the left of the node icon.

l Press the minus key (–) on your keyboard number pad.

The node's child nodes disappear from the tree.

Collapse all of the nodes in the tree:

l Right-click the top level branch and select Collapse All.

l Select View > Collapse All.

l Click the Collapse All button .

Move between previously selected nodes within the run results tree:

Click the Go to Previous Node or Go to Next Node buttons .
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Find specific steps within the Run Results:

Use the Search box (located above the run results tree), for example:

You can search for text, status, and/or types of nodes.

Filter the tree to display only nodes that match certain criteria:

Use the Filter dialog box (View > Filters).

How to Customize the Run Results Viewer
The following steps describe how to customize the layout of the Run Results Viewer:

l "Move, float, and dock panes" below

l "Show and hide panes" below

l "Restore the default layout of the panes" below

Move, float, and dock panes

You can move the panes to suit your personal preferences by dragging the title bar or tab of the pane
you want to move and dropping it in the required location.

Docked panes are fixed in a set position relative to the rest of the application. For example, when you
move a pane to a position indicated by a marker, the pane is docked in that position.

Floating panes are displayed on top of all other windows. They can be dragged to any position on your
screen, even outside of the Run Results Viewer.

Show and hide panes

l To close panes that are not needed: Click the X in the top-right corner of a pane.

l To show panes that are closed: Select View > <Name of pane>.

Restore the default layout of the panes

Select View > Restore Layout.
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How to Jump to a Step in a GUI Test (UFT GUI
Tests Only)
You can view the step in UFT that corresponds to a node in the Run Results tree for any node that has a
corresponding step in a GUI test.

Note: This feature is disabled for a variety of settings. For details, see "Guidelines for using the
Jump to Step in Test command" below, below.

To view the step in the test that corresponds to a node:

1. Make sure that UFT is open to the test whose results are displayed in the Run Results Viewer.

2. Select a node in the run results tree.

3. Perform one of the following:

a. Click the Jump to Step in Test button from the Run Results toolbar.

b. Right-click and select Jump to Step in Test from the context menu.

c. Select View >Jump to Step in Test.

4. The UFT window is activated and the step is highlighted.

Guidelines for using the Jump to Step in Test command

l The test must be saved before the run session.

l The run results must be from QuickTest Professional 10.00 or later.

This feature is disabled for:

l Any testing document other than a GUI test.

l The Action, Iteration, and Test Summary nodes.

l Any step that is part of an action that was run using the LoadAndRunAction statement. For more
details, see the Utility Objects section of the HP UFT Object Model Reference for GUI Testing.

l Any step performed by a recovery scenario.

l Tests that were run in Fastmode. For details on this setting, see the section on the Test Runs pane
in the HP Unified Functional Testing User Guide.

l Any step run from the Watch or Console debug panes in UFT.

How to Manually Submit Defects to ALM
This task describes how to manually add defects to an ALM project, which enables you to submit defects
to your ALM project while viewing the run results.
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This task includes the following steps:

l "Prerequisites" below

l "Connect to an ALM project" below

l "Open the New Defect dialog box" below

l "Modify the defect information if needed and submit it" below

l "Results" below

1. Prerequisites

Ensure that the ALM client is installed on your computer. (Enter the ALM Server URL in a browser
and ensure that the Login screen is displayed.)

2. Connect to an ALM project

Select Tools > ALM Connection or click the ALM Connection button and connect to an ALM
project.

Note: If you do not connect to an ALM project before proceeding to the next step, you are
prompted to connect before continuing.

3. Open the New Defect dialog box

Select Tools > Add Defect or click the Add Defect button to open the New Defect dialog box in
the specified ALM project. The New Defect dialog box opens.

4. Modify the defect information if needed and submit it

Basic information on the test or component and any checkpoints (if applicable) is included in the
description, but you can modify the defect if needed:

Tip: You can attach movies (.fbr files) to defects in ALM. If you have the Unified Functional
Testing Add-in for ALM installed, you can view the movies from ALM.

5. Results

The defect is added to the ALM project's defect database.
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How to Automatically Submit Defects to an ALM
Project (UFT GUI Tests Only)
This task describes how to set the Run options in UFT to automatically submit defects to your ALM
project for each failed step in your GUI test, eliminating the need to remember to submit these defects
after a run session.

This task includes the following steps:

l "Prerequisites" below

l "Modify the Run settings in the Options dialog box" below

l "Results" on the next page

1. Prerequisites

l In UFT, make sure you are connected to the relevant ALM project prior to the run session (ALM >
ALM Connection).

l The run results must be stored in this ALM project.

2. Modify the Run settings in the Options dialog box

a. Select Tools > Options. The Options dialog box opens.

b. In the GUI Testing tab, click the Test Runs node.

User Guide
Chapter 1: Using the Run Results Viewer

HP Run Results Viewer (12.51) Page 20



c. Select the Submit a defect to ALM for each failed step check box.

d. Click OK to close the Options dialog box.

3. Results

A sample of the information that is submitted to ALM for each defect is shown below:

How to Export Run Results
This task describes how to export run results to a file.

This task includes the following steps:

l "Open the results in the Run Results Viewer" below

l "Specify the export settings" below

l "Save the file " below

l "Results" on the next page

1. Open the results in the Run Results Viewer

In the Run Results Viewer, select File > Open.

2. Specify the export settings

Select File > Export To File. The Export Run Results dialog box opens.

3. Save the file

User Guide
Chapter 1: Using the Run Results Viewer

HP Run Results Viewer (12.51) Page 21



Click Export. The Save As dialog box opens. Specify the file name and path, and select the required
file type.

Report type Save as type

Step details l HTML (*.htm, *.html) (default)

l PDF (*.pdf)

l DOC (*.doc) (Available if Microsoft Word is installed)

Data Table Excel (*.xls)

Log Tracking
(UFT GUI Testing only)

XML (*.xml)

Screen Recorder
(UFT GUI Testing only)

FlashBack (*.fbr)

System Monitor
(UFT GUI Testing only)

l Text (*.csv, *.txt) (default)

l Excel (*.xls)

l XML (*.xml)

l HTML (*.htm, *.html)

Note: Only the systemmonitor data is exported, not the graph.

4. Results

When you click Save, the file is exported in the specified format to the designated location.

Note: You can view .fbr files in the HP Micro Recorder. You can also attach .fbr files to
defects in ALM. If you have the Unified Functional Testing Add-in for ALM installed, you can
view the movies from ALM.

How to Play a Screen Recorder Movie in the HP
Micro Player (UFT GUI Testing Only)
Note: UFT must be installed on the computer on which you want to use the HP Micro Player.
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1. Perform one of the following:

l Double-click any .fbr file in Windows Explorer.

l Select Start > All Programs > HP Software > HP Unified Functional Testing > Tools > HP
Micro Player and then select File > Open in the Micro Player to select any .fbr file.

l Open the program at <UFT installation folder\bin\Free_HPSR_Player.exe.

The movie opens in the HP Micro Player and begins playing.

Note: For details on accessing UFT and UFT tools and files in Windows 8 and Windows Server
2012, see "Accessing the UFT in Windows 8.X or Higher Operating Systems" on page 13.

2. Use the controls at the top of the window to access a particular location in the movie or to modify
the volume settings.

How to Delete Run Results
This task describes how to use the Run Results Deletion Tool to remove unwanted or obsolete run
results from the file system, according to specific criteria that you define. For example, you may want to
always delete run results older than a certain date or over a minimum file size. This enables you to free
up valuable disk space.

Prerequisites

To delete run results from an ALM project, you must first:

l Make sure that you have Delete Run permissions for this ALM project.

l Connect to the ALM project.

Delete run results using the Run Results Deletion Tool

In the Run Results Deletion Tool, select the file or folder from which to delete run results and then
select the selected run results to delete.

Results

The selected run results are deleted from the file system and/or the ALM project.

Run Results Viewer User Interface
This window enables you to view the results of a run session.

GUI Test. The following example shows the Executive Summary results of a test. Notice that the results
for a test are organized by the test's actions.
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In the Statistics area, you can see howmany iterations passed, contained warnings, or failed, and, when
previous runs exist, you can compare the current results with the previous results. You can also access
the previous run results by clicking the Open button.
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GUI Component. Below is an example of the run results for a component:

Note: In this example, the component failed due to a run error in a test object. If the run error had
not occurred, the Result would indicate Done.
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UFT API Test. The following example shows an Executive Summary for an API test run:

To access Do oneof the following:

l Select View > View Last Run Results from UFT.

l Select HP Software > HP Run Results Viewer > Run Results Viewer from theStart Menu.

For details, see "How to Open Run Results" on page 14.

By default, the left pane (dockable) contains the run results tree. The right side of the window contains
two rows of additional dockable panes. These user interface elements are described below (unlabeled
elements are shown in angle brackets):

UI Elements Description

Executive Summary
Page

l A high-level results overview report (general information, pass/fail status, statistics, link to
previous run results (if any), notes, and so on) displayed in theResult Details panewhen the
topmost node is selected.

l ALM information for your test (if the test or component was run from ALM, or if a test that is
stored in ALM is run from UFT and you choose to store the results in ALM).

Run Results Tree
pane

l A graphical representation of the results in an expandable tree

l A search box

l Displays the test or component steps, specifying exactly where application failures occurred
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UI Elements Description

Result Details pane Detailed explanations of each step and checkpoint pass or failure, at each stageof the test or
component.

Captured Data pane l A still imageof the state of your application at a particular step

l For UFT, additional information, such as abitmap checkpoint image.

Data pane Thedata used in all iterations

Test Flow pane A captured imageof the test for aUFT API test.

Screen Recorder
pane (UFT GUI
testing only)

Amovie clip of the state of your application at a particular step or of the entire test or component

System Monitor
pane (UFT GUI
testing only)

Any system counters that weremonitored for your test or component

Log Tracking pane
(UFT GUI testing
only)

Any log messages that were received for your test or component

<status bar> Displays:

l A description of any highlighted menu command (Available only if themenu command is enabled)

l The status of the currently selected command

l Connection information (when connected to an ALM project)

l A filter indication icon (when the results are filtered)
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Troubleshooting and Limitations - Viewing Run
Results
This section describes troubleshooting and limitations for viewing run results.

l Local system monitor. After you run a test or component with the local system monitoring option
activated when the test or component is either very short, or the number of seconds entered for the
Enable local system monitoring every: __ seconds option is high (a high percentage relative to the
length of your entire test run), then when you select one of the last steps in the Run Results tree, the
Current Step indicator in the System Monitor pane may jump to a position outside (to the right) of
the graph.

Workaround: Add a Wait statement to the end of the test or reduce the number of seconds entered
in the Enable local system monitoring every: __ seconds option.

l Run session errors. Errors during the run session produce more than one error node in the run
results.

l Exporting run results.When UAC is set to ON and you select to export the Run Results to a system
folder, the exported file is stored under Virtual Storage rather than under the specified folder.
(Relevant for Windows 7, Windows Server 2008 R2, Windows 8, and Windows Server 2012)

l Viewing run results from ALM. If you installed the Run Results Viewer without installing UFT, then
after you run a BPT test from ALM, pressing Show Last Run Resultsmight fail to display the results
in the Run Results Viewer if the Visual C++ 2005 redistributable is installed on your computer.

Workaround: Install the Unified Functional Testing Add-in for ALM from the ALM Add-ins page.
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Chapter 2: Run Results - Understanding
Step Results
This chapter includes:

• Smart Identification in the Run Results (UFT GUI Testing Only) 29

• Smart Identification - No Object Matches the Learned Description (UFT GUI Testing Only) 30

• Smart Identification - Multiple Objects Match the Learned Description (UFT GUI Testing Only) 31

• Checkpoint and Output Value Results (UFT GUI Testing Only) 33

• Accessibility Checkpoint Results (UFT GUI Tests Only) 33

• Bitmap Checkpoint Results (UFT GUI Tests Only) 37

• File Content Checkpoint Results (UFT GUI Tests Only) 38

• Standard Checkpoint Results (UFT GUI Tests Only) 41

• Table and Database Checkpoint Results (UFT GUI Tests Only) 42

• Text and Text Area Checkpoint Results (UFT GUI Tests Only) 44

• XML Checkpoint Results (UFT GUI Tests Only) 44

• Output Value Results (UFT GUI Tests Only) 46

• File Content Output Value Results (UFT GUI Tests Only) 47

• XML Output Value Results (UFT GUI Tests Only) 47

• Parameterized Values in the Run Results 49

• GUI Tests Containing Calls to UFT API /Service Test Tests (UFT GUI Tests Only) 52

Smart Identification in the Run Results (UFT GUI
Testing Only)
If the learned description does not enable UFT to identify the specified object in a step, and a Smart
Identification definition is defined (and enabled) for the object, then UFT tries to identify the object
using the Smart Identification mechanism. The following examples illustrate two possible scenarios.

l "Smart Identification - No Object Matches the Learned Description (UFT GUI Testing Only)" on the next
page

l "Smart Identification - Multiple Objects Match the Learned Description (UFT GUI Testing Only)" on
page 31
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Smart Identification - No Object Matches the Learned
Description (UFT GUI Testing Only)
If UFT successfully uses Smart Identification to find an object after no object matches the learned
description, the run results display a warning status and include the following information:

In the results tree In the Result Details pane

A description
mismatch icon for
themissing object.
For example:

An indication that the object (for example, theuserNameWebEdit object) was not found.

A Smart
Identification icon for
themissing object.
For example:

An indication that the Smart Identification mechanism successfully found the object, and information
on the properties used to find the object. You can use this information to modify the learned test object
description, so that UFT can find the object using the description in future run sessions.

The actual step
performed. For
example:

Normal result details for the performed step.

For details on the Smart Identification mechanism, see the section describing Smart Identification in the
HP Unified Functional Testing User Guide.

The image below shows the results for a test or component in which Smart Identification was used to
identify the userNameWebEdit object after one of the learned description property values changed.
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Smart Identification - Multiple Objects Match the
Learned Description (UFT GUI Testing Only)
If UFT successfully uses Smart Identification to find an object after multiple objects are found that
match the learned description, UFT shows the Smart Identification information in the Run Results
Viewer. The step still receives a passed status, because in most cases, if Smart Identification was not
used, the test object description plus the ordinal identifier could have potentially identified the object.

In such a situation, the run results show the following information:

In the results
tree

In the Result Details pane

A Smart
Identification icon
for themissing
object. For example:

An indication that the Smart Identification mechanism successfully found the object, and information on
the properties used to find the object. You can use this information to create a uniqueobject description
for the object, so that UFT can find the object using the description in future run sessions.

The actual step
performed. For
example:

Normal result details for the performed step.
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The image below shows the results for a test or component in which Smart Identification was used to
uniquely identify the Flight Confirmation: Mercury object after the learned description resulted in
multiple matches.

If the Smart Identification mechanism cannot successfully identify the object, the test or component
fails and a normal failed step is displayed in the run results.
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Checkpoint and Output Value Results (UFT GUI
Testing Only)
The information displayed in the Run Results Viewer and the available options are determined by the
type of checkpoint or output value step you select.

To learn more, see:

l "Accessibility Checkpoint Results (UFT GUI Tests Only) " below

l "Bitmap Checkpoint Results (UFT GUI Tests Only) " on page 37

l "File Content Checkpoint Results (UFT GUI Tests Only) " on page 38

l "Standard Checkpoint Results (UFT GUI Tests Only) " on page 41

l "Table and Database Checkpoint Results (UFT GUI Tests Only) " on page 42

l "Text and Text Area Checkpoint Results (UFT GUI Tests Only) " on page 44

l "XML Checkpoint Results (UFT GUI Tests Only) " on page 44

l "Output Value Results (UFT GUI Tests Only) " on page 46

l "XML Output Value Results (UFT GUI Tests Only) " on page 47

Accessibility Checkpoint Results (UFT GUI Tests Only)
When you include accessibility checkpoints in your test, the Run Results Viewer displays the results of
each accessibility option that you checked.

The run results tree displays a separate step for each accessibility option that was checked in each
checkpoint. For example, if you selected all accessibility options, the run results tree for an accessibility
checkpoint may look something like this:

The run result details provide information that can help you pinpoint parts of your Web site that may
not conform to the W3C Web Content Accessibility Guidelines. The information provided for each check
is based on the W3C requirements.

Note: Some of the W3C Web Content Accessibility Guidelines that are relevant to accessibility
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checkpoints are cited or summarized in the following sections. This information is not
comprehensive. When checking whether your Web site satisfies the W3C Web Content Accessibility
Guidelines, you should see the complete document at: http://www.w3.org/TR/WAI-WEBCONTENT/.

For details on accessibility checkpoints, see the HP Unified Functional Testing User Guide.

ActiveX Check

Guideline 6 of the W3C Web Content Accessibility Guidelines requires you to ensure that pages are
accessible even when newer technologies are not supported or are turned off. When you select the
ActiveX check, UFT checks whether the selected page or frame contains any ActiveX objects. If it does
not contain any ActiveX objects, the checkpoint passes. If the page or frame does contain ActiveX
objects then the results display a warning and a list of the ActiveX objects so that you can check the
accessibility of these pages on browsers without ActiveX support. For example:

Alt Property Check

Guideline 1.1 of the W3C Web Content Accessibility Guidelines requires you to provide a text equivalent
for every non-text element. The Alt property check checks whether objects that require the Alt property
under this guideline, do in fact have this attribute. If the selected frame or page does not contain any
such objects, or if all such objects have the required attribute, the checkpoint passes. If one or more
objects that require the property do not have it, the test fails and the run result details display a list
that shows which objects are lacking the attribute. For example:

The Captured Data pane displays the captured page or frame, so that you can see the objects listed in
the Alt property check list.
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Applet Check

The Applet Check also helps you ensure that pages are accessible, even when newer technologies are
not supported or are turned off (Guideline 6 of the W3C Web Content Accessibility Guidelines), by finding
any Java applets or applications in the checked page or frame. The checkpoint passes if the page or
frame does not contain any Java applets or applications. Otherwise, the results display a warning and a
list of the Java applets and applications. For example:

Frame Titles Check

Guideline 12.1 of the W3C Web Content Accessibility Guidelines requires you to title each frame to
facilitate frame identification and navigation. When you select the Frame Titles check, UFT checks
whether Frame and Page objects have the TITLE tag. If the selected page or frame and all frames
within it have titles, the checkpoint passes. If the page, or one or more frames, do not have the tag, the
test fails and the run result details display a list that shows which objects are lacking the tag. For
example:

The Captured Data pane displays the captured page or frame, so that you can see the frames listed in
the Frame Titles check list.

Multimedia Links Check

Guidelines 1.3 and 1.4 of the W3C Web Content Accessibility Guidelines require you to provide an
auditory, synchronized description of the visual track of a multimedia presentation. Guideline 6 requires
you to ensure that pages are accessible, even when newer technologies are not supported or are turned
off. The Multimedia Links Check identifies links to multimedia objects so that you can confirm that
alternate links are available where necessary. The checkpoint passes if the page or frame does not
contain any multimedia links. Otherwise, the results display a warning and a list of the multimedia links.
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Server-Side Image Check

Guideline 1.2 of the W3C Web Content Accessibility Guidelines requires you to provide redundant text
links for each active region of a server-side image map. Guideline 9.1 recommends that you provide
client-side image maps instead of server-side image maps except where the regions cannot be defined
with an available geometric shape. When you select the Server-side Image check, UFT checks whether
the selected page or frame contains any server-side images. If it does not, the checkpoint passes. If the
page or frame does contain server-side images, then the results display a warning and a list of the
server-side images so that you can confirm that each one answers the guideline requirements. For
example:

Tables Check

Guideline 5 of the W3C Web Content Accessibility Guidelines requires you to ensure that tables have the
necessary markup to be transformed by accessible browsers and other user agents. It emphasizes that
you should use tables primarily to display truly tabular data and to avoid using tables for layout
purposes unless the table still makes sense when linearized. The TH, TD, THEAD, TFOOT, TBODY, COL, and
COLGROUP tags are recommended so that user agents can help users to navigate among table cells and
access header and other table cell information through auditory means, speech output, or a Braille
display.

The Tables Check checks whether the selected page or frame contains any tables. If it does not, the
checkpoint passes. If the page or frame does contain tables, the results display a warning and a visual
representation of the tag structure of the table. For example:
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Bitmap Checkpoint Results (UFT GUI Tests Only)
The Result Details pane displays the checkpoint step results, including its status (Passed or Failed), the
date and time the checkpoint was run and the portion of the checkpoint timeout interval that was used
(if any).

When Comparing Expected Bitmaps with Actual Bitmaps

The Captured Data pane shows the expected and actual bitmaps that were compared during the run
session, and a View Difference button. When you click the View Difference button, UFT opens the
Bitmap Checkpoint Results window, displaying an image that represents the difference between the
expected and actual bitmaps. This image is a black-and-white bitmap that contains a black pixel for
every pixel that is different in the two images. Similar results would be displayed for a component.
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When Locating Specified Bitmaps in Actual Bitmaps

The Captured Data pane shows the actual bitmap of the runtime object in the application and the
source bitmap that UFT attempted to locate within the object. It may also show the coordinates of a
possible candidate that was found, and the image similarity percentage used to find the candidate.

Note: By default, the information in the Captured Data pane is available only if the bitmap
checkpoint fails. You can change the conditions for when bitmaps are saved in the run results,
using the Save still image captures to results option in the Screen Capture pane (Tools > Options
> GUI Testing tab > Screen Capture node) of the Options dialog box. For details, see the section
describing the Screen Capture pane in the HP Unified Functional Testing User Guide.

Considerations for Reviewing Bitmap Checkpoint Results

l When comparing bitmaps, if the checkpoint is defined to compare only specific areas of the bitmap,
the run results display the actual and expected bitmaps with the selected area highlighted.

l When comparing bitmaps, if the dimensions of the actual and expected bitmaps are different, UFT
fails the checkpoint without comparing the bitmaps. In this case the View Difference functionality is
not available in the results.

l The View Difference functionality is not available when viewing results generated in a version of
QuickTest earlier than 10.00.

l If the bitmap checkpoint is performed by a custom comparer:

l UFT passes the bitmaps to the custom comparer for comparison even if their dimensions are
different.

l The Result Details pane also displays the name of the custom comparer (as it appears in the
Comparer box in the Bitmap Checkpoint Properties dialog box), and any additional information
provided by the custom comparer.

l The difference bitmap is provided by the custom comparer.

For details on bitmap checkpoints and custom comparers, see the section describing bitmap
checkpoints in the HP Unified Functional Testing User Guide.

File Content Checkpoint Results (UFT GUI Tests Only)
The Result Details pane displays detailed results of the selected checkpoint, including its status (Passed
or Failed), and the date and time the checkpoint was run. It also displays the number of lines that were
checked, the number of changes found in the checked lines, and the total number of changed lines
found in the file (including both the lines that were selected in the checkpoint and the lines that were
not).

The details area also specifies whether the checkpoint includes the following options:Match case,
Ignore spaces, Verify page count, and Fail checkpoint for added or removed lines
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For failed steps, the Captured Data pane displays any differences found for all lines in the actual file,
regardless of whether they were selected for comparison in the checkpoint. An asterisk (*) adjacent to
the line number indicates that a regular expression was selected for comparison against the actual file.

In the following example, the details of the failed checkpoint indicate that the expected results and the
current results do not match.

l The expected value in line 1 is not identical to the actual value.

l The asterisk (*) in line 1 indicates that a regular expression was selected for comparison against the
actual file and the lines in the expected and actual files are different.

l Lines that were selected for comparison are displayed in black.
Lines that were not selected for comparison are displayed in light grey.

l The last line exists in the source (expected) file but is missing from the actual file. This line was not
selected for comparison, so its textual content is displayed in grey instead of black.

User Guide
Chapter 2: Run Results - Understanding Step Results

HP Run Results Viewer (12.51) Page 39



l No lines were added to the actual file.

Captured Data Pane — Buttons

UI Elements Description

Color
Settings

Opens the Color Settings dialog box, enabling you to define the text and background color for each filter
type. For details, see theHPUnified Functional Testing User Guide.

Next
Difference

Finds the next difference between the lines in the compared versions.

Previous
Difference

Finds the previous difference between the lines in the compared versions.
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UI Elements Description

Filter Opens the Filter dialog box, enabling you to show or hide the following types of filter elements in the
comparison window:

l Modified

l Deleted

l Added

l Identical

Tip: The legend in the top-right corner of the comparison window indicates how many lines match
each filter type. The legend adjacent to a collapsed node indicates how many sub-nodes match each
filter type. For details, see theHPUnified Functional Testing User Guide.

View
Horizontal
or
View
Vertical

View Horizontal.Displays the open documents one above the other.

View Vertical.Displays the open documents side-by-side.

For details, see the section describing file content checkpoints in the HP Unified Functional Testing User
Guide.

Standard Checkpoint Results (UFT GUI Tests Only)
The Result Details pane displays detailed results of the selected checkpoint, including its status (Passed
or Failed), the date and time the checkpoint was run, and the portion of the checkpoint timeout interval
that was used (if any). It also displays the values of the object properties that are checked, and any
differences between the expected and actual property values.

The Captured Data pane displays the image capture for the checkpoint step (if available).
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In the following example, the details of the failed checkpoint indicate that the expected results and the
current results do not match. The expected value of the flight departure is Paris, but the actual value is
Frankfurt.

For details, see the section describing standard checkpoints in the HP Unified Functional Testing User
Guide.

Table and Database Checkpoint Results (UFT GUI Tests
Only)
The results displayed for table and database checkpoints are similar. The Result Details pane displays
the checkpoint step results, including its status (Passed or Failed), the date and time the checkpoint
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was run, the verification settings you specified for the checkpoint, and the number of individual table
cells or database records that passed and failed the checkpoint.

If the checkpoint failed, the Captured Data pane shows the table cells or database records that were
checked by the checkpoint. Cell values or records that were checked are displayed in black; cell values
or records that were not checked are displayed in gray. Cells or records that failed the checkpoint are
marked with a failed  icon.

The following is an example of the results for a table checkpoint:

You can click the Next Mismatch button in the Captured Data pane to highlight the next table cell
or database record that failed the checkpoint.

You can click the Compare Values button in the Captured Data pane to display the expected and
actual values of the selected table cell or database record.

For details, see the sections describing table checkpoints and database checkpoints in the HP Unified
Functional Testing User Guide.
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Text and Text Area Checkpoint Results (UFT GUI Tests
Only)
The Result Details pane displays the checkpoint step results, including its status (Passed or Failed), the
date and time the checkpoint was run and the portion of the checkpoint timeout interval that was used
(if any). It also shows the expected text and actual text that was checked, and the verification settings
you specified for the checkpoint.

The following is an example of the results for a text checkpoint:

For details, see the section describing text and text area checkpoints in the HP Unified Functional
Testing User Guide.

XML Checkpoint Results (UFT GUI Tests Only)
The Result Details pane displays the checkpoint step results.

The Captured Data pane shows the details of the schema validation (if applicable) and a summary of the
checkpoint results. If the schema validation failed, the reasons for the failure are also shown.
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If the checkpoint failed, you can view details of each check performed in the checkpoint by clicking View
XML Checkpoint Results in the Captured Data pane. The XML Checkpoint Results window opens,
displaying details of the checkpoint's failure.

The following is an example of the results for an XML checkpoint:

Note: By default, if the checkpoint passes, the View XML Checkpoint Results button is not
available. The availability of these detailed results is dependent on the Save still image captures
to results setting in the Screen Capture pane (Tools > Options > GUI Testing tab > Screen Capture
node) of the Options dialog box. For details, see the section describing the Screen Capture pane in
the HP Unified Functional Testing User Guide.
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Output Value Results (UFT GUI Tests Only)
The Result Details pane displays detailed results of the selected output value step, including its status,
and the date and time the output value step was run. It also displays the details of the output value,
including the value that was captured during the run session, its type, and its name, as shown in the
following example. Similar results would be displayed for a component.

For details, see the section describing output values in the HP Unified Functional Testing User Guide.

For details on XML output value steps, see "XML Output Value Results (UFT GUI Tests Only) " on the next
page.
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File Content Output Value Results (UFT GUI Tests Only)
The Result Details pane displays the results of the file content output value step, including its status,
the date and time the step was run, and details for the parameterized file content output value. This
pane also shows the configuration settings (whether match case and ignore spaces were set), as shown
in the following example.

For details, see the section describing file content output values in the HP Unified Functional Testing
User Guide.

XMLOutput Value Results (UFT GUI Tests Only)
The Result Details pane displays a summary of the output value results.
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From the Captured Data pane, you can view detailed results by clicking View XML Output Value Results
to open the XML Output Value Results window.

The following is an example of the results for an XML output value:

Note: By default, the View XML Output Value Results button is available only when an error
occurs. The availability of these detailed results is dependent on the Save still image captures to
results setting in the Screen Capture pane (Tools > Options > GUI Testing tab > Screen Capture
node) of the Options dialog box. For details, see the section describing the Screen Capture pane in
the HP Unified Functional Testing User Guide.

For details, see the section describing XML output values in the HP Unified Functional Testing User Guide.
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Parameterized Values in the Run Results
A parameter is a variable that is assigned a value from an external data source or generator for a test,
or from within a component. You can view the values for the parameters defined in your test or
component in the Run Results Viewer.

To view parameterized values, expand the nodes in the run results tree and click the root node to view
test or component input and output parameters, or click an action node that contains parameterized
values (tests only).

Test and component parameters are displayed in the Parameters section of the Executive Summary
area of the Results Details pane, which you display by clicking the root node of the run results tree. The
example below shows input test parameters. The Parameters section would be identical for input
component parameters.
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If output test or component parameters were defined, they would be displayed in this pane beneath the
input parameters.
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For action parameters, the name and value of the input and output parameters are displayed in the
Result Details pane. Similar results would be displayed for a component.

The example above shows input parameters that were defined at the action level. If output parameters
were defined at this level, they would also be displayed in this pane.

For details on defining and using parameters in your tests and components, see the HP Unified
Functional Testing User Guide.
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GUI Tests Containing Calls to UFT API /Service
Test Tests (UFT GUI Tests Only)
If your test contains a call to a UFT API or Service Test test, you can view the results of that test in the
run results. The run results tree displays all of the GUI test-specific nodes that preceded the call to the
UFT API or Service Test test, all of the UFT API or Service Test test-specific nodes from that test call, and
all of the GUI test-specific nodes that followed that call.
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Send Us Feedback
Can we make this User Guide better?

Tell us how: sw-doc@hp.com
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