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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an 
additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license.

Copyright Notices

© Copyright 2015 Hewlett Packard Enterprise Development LP.

Trademark Notices

Adobe® is a trademark of Adobe Systems Incorporated.

Intel® and Itanium® are trademarks of Intel Corporation in the U.S. and other countries.

Microsoft®, Windows®‚ Windows® XP are U.S. registered trademarks of Microsoft Corporation.

Oracle and Java are registered trademarks of Oracle and/or its affiliates.

UNIX® is a registered trademark of The Open Group.

This product includes software developed by the Apache Software Foundation (http://www.apache.org/).

Support

Visit the HP Software Support Online website at:

https://softwaresupport.hp.com/ 

This website provides contact information and details about the products, services, and support that HP 
Software offers. 

HP Software online support provides customer self-solve capabilities. It provides a fast and efficient way 
to access interactive technical support tools needed to manage your business. As a valued support 
customer, you can benefit by using the support website to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training
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Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract. To register for an HP Passport ID, go to:

https://hpp12.passport.hp.com/hppcf/createuser.do

To find more information about access levels, go to:

https://softwaresupport.hp.com/web/softwaresupport/access-levels

Support Matrices

For complete support and compatibility information, see the support matrix for the relevant product 
release. All support matrices and product manuals are available here on the HP Software Support Online 
website:

https://softwaresupport.hp.com/group/softwaresupport/support-matrices

You can also download the HP Server Automation Support and Compatibility Matrix for this release from 
the HP Software Support Online Product Manuals website:

https://softwaresupport.hp.com/ 

This site requires that you register for an HP Passport and sign in. After signing in, click the Search 
button and begin filtering documentation and knowledge documents using the filter panel. 

Documentation Updates

All the latest Server Automation product documentation for this release is available from the SA 
Documentation Library:

https://softwaresupport.hp.com/group/softwaresupport/search-result/-/
facetsearch/document/KM00417675

Use the SA Documentation Library to access any of the guides, release notes, support matrices, and white 
papers relevant to this release or to download the full documentation set as a bundle. The SA 
Documentation Library is updated in each release and whenever the release notes are updated or a new 
white paper is introduced.

How to Find Information Resources

You can access the information resources for Server Automation using any of the following methods:

Method 1: Access the latest individual documents by title and version with the new SA Documentation 
Library

Method 2: Use the complete documentation set in a local directory with All Manuals Downloads

Method 3: Search for any HP product document in any supported release on the HP Software 
Documentation Portal

To access individual documents:

1 Go to the SA 10.x Documentation Library: 

https://softwaresupport.hp.com/group/softwaresupport/search-result/-/
facetsearch/document/KM00417675

2 Log in using your HP Passport credentials.

3 Locate the document title and version that you want, and then click go.
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To use the complete documentation set in a local directory:

1 To download the complete documentation set to a local directory:

a Go to the SA Documentation Library: 

https://softwaresupport.hp.com/group/softwaresupport/search-result/-/
facetsearch/document/KM00417675

b Log in using your HP Passport credentials.

c Locate the All Manuals Download title for the SA 10.1 version.

d Click the go link to download the ZIP file to a local directory.

e Unzip the file.

2 To locate a document in the local directory, use the Documentation Catalog (docCatalog.html), which 
provides an indexed portal to the downloaded documents in your local directory.

3 To search for a keyword across all documents in the documentation set:

a Open any PDF document in the local directory.

b Select Edit > Advanced Search (or Shift+Ctrl_F).

c Select the All PDF Documents option and browse for the local directory.

d Enter your keyword and click Search.

To find additional documents on the HP Software Documentation Search Portal:

Go to the HP Software Documentation Search Portal:

https://softwaresupport.hp.com/ 

This site requires that you register for an HP Passport and sign in. After signing in, click the Search 
button and begin filtering documentation and knowledge documents using the filter panel. 

To register for an HP Passport ID, click the Register link on the HP Software Support Online login page.

You can also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details. See Documentation Change Notes for a list of any 
revisions.

Product Editions

There are two editions of Server Automation:

• Server Automation (SA) is the Ultimate Edition of Server Automation. For information about Server 
Automation, see the SA Release Notes and the SA User Guide: Server Automation.

• Server Automation Virtual Appliance (SAVA) is the Premium Edition of Server Automation. For more 
information about what SAVA includes, see the SAVA Release Notes and the SAVA at a Glance Guide. 

https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM00417675
https://softwaresupport.hp.com/ 
https://hpp12.passport.hp.com/hppcf/createuser.do


5



6



Contents
1 Overview and Prerequisites  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .13
Terminology . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .14

Server Configurations. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .16
Enforce Security Standards  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .16
Capture & Replicate Golden Servers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .16

ESXi Servers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .17
Running Commands Against ESXi Servers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .17
ESXi Prerequisites . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .18

Refer to the VMware ESXi Hardening Guides. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .18
Ensure vCenter Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .18
Download PowerCLI Installer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .18
Install or Upgrade Your PowerShell Version . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .18
Download and Install Windows Manager Framework . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .19
Set the PowerShell Execution Policy  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .19
Set the Configuration Value for the InvalidCertificateAction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .19
Set the Configuration Value for WebOperationTimeout  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .19
Run the XML Serializers Script . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .20
Disable Check for Certificate Revocation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .20

vCenter Performance Tuning  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .21
Install and Compile VMware PowerCLI XML Serializers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .21
Configure Agent  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .21
Manage ESXi Server  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .21
Download the ESXi Compliance Library . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .21

Minimum Windows and VMware Permissions for ESXi Audit Functions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .22
Windows Permissions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .22
VMware Permissions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .22

2 Audits, Audit Policies, and Audit Results  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .25
Audits  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .25

Audit Policies . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .25
Snapshots  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .26
Compliance and Remediation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .26

Audit Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .26
Audit Comparison Types  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .27
Audit Process . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .28
Audit Elements. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .28
Configuring an Audit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .29
Creating an Audit  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .30

Creating an Audit from a Server. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .30
Creating an Audit from a Group of Servers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .30
 7



Creating an Audit from the SA Library  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .31
Creating an Audit from a Snapshot . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .31
Creating an Audit from an Audit Policy . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .31

Running an Audit  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .32
From the SA Library  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .32
From All Managed Servers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .33
From Audit Results . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .33

Clearing Audit or Snapshot Results . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .34
Scheduling an Audit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .34

Scheduling a Recurring Audit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .35
Editing an Audit Schedule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .36
Viewing a Completed Audit Job  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .37

Exporting/Importing an Audit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .37
Cancelling an Active Audit Job  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .37
Viewing Audit and Snapshot Usage . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .38

From All Managed Servers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .38
From the Device Explorer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .38

Audit Configuration  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .39
Audit & Snapshot Sources . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .41

Source: Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .41
Source: Snapshot  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .42
Source: Snapshot Specification . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .43
Source: Rules . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .43

Server Objects  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .44
Audit & Remediation Rules . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .46

Configuration Rules  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .47
Audit and Snapshot Rules . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .48
Configuring the Application Configuration Rule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .49

Application Configuration Audit Rule Color Scheme  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .52
Configuring the COM+ Rule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .53
Configuring the Custom Scripts Rule. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .54

Custom Scripts Example . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .56
Powershell / PowerCLI Scripts Example. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .56

Configuring the Discovered Software Rule  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .57
Configuring the File Rule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .58

Common Scope Cases with Diagrams . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .60
Ways to Add a Rule to an Audit. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .63
Comparing Files in Audits with Configuration Templates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .65

Configuring the Hardware Rule  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .66
Configuring the IIS Metabase Rule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .67
Configuring the IIS Rule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .68
Configuring the IIS 7.0 Rule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .69
Configuring the Local Security Settings Rule. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .70
Configuring the Registered Software Rule. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .71
Configuring the Storage Rule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .72
Configuring the Windows .NET Framework Configurations Rule. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .73
Configuring the Windows Registry Rule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .74
8



Windows Registry Object. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .74
Access Control Levels (ACLs)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .75

Configuring the Windows Services Rule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .76
Configuring the Users and Groups Rule  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .76
Configuring Compliance Checks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .77
Renaming Compliance Checks  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .79
Searching for Compliance Checks from the Audit/Snapshot Specification Window  . . . . . . . . . . . . . . . . . . .79

Compliance Checks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .80
Editing Compliance Check Properties . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .80
Creating Custom Compliance Check Categories  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .81
Restoring Compliance Checks to Defaults . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .82
Showing Deprecated Checks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .83
Setting Inclusions & Exclusions for Checks  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .83

File Inclusion and Exclusion Rules  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .84
Inclusion and Exclusion Rule Types . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .84
Example: Including all .txt Files in a Snapshot or Audit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .86
Example: Including Only File a in a Snapshot or Audit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .86
Example: Including last temp.txt file and exclude all else  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .87
File Rule Overlap . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .87

Example A. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .87
Example B. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .88
Example C. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .88

Parameterizing Filenames for SA/Custom Attributes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .88
Examples of Parameterizing Filenames. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .89

Environment Variables in Pathnames . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .90
Audit Rule Exceptions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .90

Rules That Cannot Have Exceptions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .91
Considerations When Applying Exceptions to Device Groups  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .91
Adding a Rule Exception to an Audit  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .91
Editing or Deleting a Rule Exception . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .92

Audit Policy Management  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .92
Linking & Importing an Audit Policy. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .93

Linking an Audit Policy. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .93
Importing an Audit Policy  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .93

Rule Overlap with Multiple Linked Audit Policies  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .94
Creating an Audit Policy  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .94
Saving an Audit as an Audit Policy . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .95
Ways to Link & Import Audit Policies. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .96

Linking an Audit Policy to an Audit or a Snapshot Specification  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .96
Linking Audit Policies to a Master Audit Policy . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .97
Importing Audit Policy Rules. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .98
Saving an Audit or a Snapshot Specification as an Audit Policy. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .98

Locating an Audit Policy in the Folder Library . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .99
Exporting an Audit Policy. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .99
Viewing Compliance of an Audit Policy . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .99

Audit Results  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 100
Viewing Audit Results. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 101
Audit Result Window. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 101
9



Views . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 102
Summary  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 102
Details . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 103

Remediation Methods: All, By Server, or By Rules  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 103
Remediate All. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 103
Remediate By Rule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 104
Remediate by Server  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 106
Remediating Comparison-Based Audit Results  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107
Remediating Rules with Inherited Values  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108
Viewing Value-Based Audit Results–Audit Rule Remediation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108

Remediating Rules with Inherited Values. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 109
Viewing and Remediating Audit Results Differences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110

Viewing and Remediating File Differences. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110
Cancelling an Active Remediate Audit Results Job . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111

Viewing and Remediating Object Differences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 112
Viewing Audit Results with Exceptions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 113
Searching for an Audit  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 114
Deleting an Audit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 114
Deleting Audit Results  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 114
Archiving Audit Results  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115
Exporting an Audit Result  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115

3 Snapshots, Snapshot Specifications, & Snapshot Jobs  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 117
Snapshots . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 117
Snapshot Process  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 117
Snapshots & Snapshot Specifications . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 118

Snapshot Used in an Audit. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119
Snapshot Specification Used in an Audit. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119

Snapshot Specification Elements. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119
Viewing Snapshots . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 120

In the SA Library  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 120
In the Device Explorer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 120

Searching for Snapshots  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 121
Viewing Snapshot Results . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 121
Archiving a Snapshot  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 123
Deleting a Snapshot  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 123
Exporting/Importing a Snapshot  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 124
Copying Objects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 124

From a Snapshot to a Server. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 124
Snapshot Specifications  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 125

Snapshot Specifications & Audit Policies . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 125
Creating a Snapshot Specification  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126

From a Server  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126
From the SA Library  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126

Deleting a Snapshot Specification . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 126
Configuring a Snapshot Specification . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 127
Configuring Snapshot Specification Rules . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129
10



Saving a Snapshot Specification as an Audit Policy . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129
Running a Snapshot Specification . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129

Snapshot Jobs  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 130
Scheduling a Recurring Snapshot Job . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 130
Viewing and Editing a Snapshot Job Schedule. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 132
Deleting a Snapshot Job Schedule. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133
Cancelling an Active Snapshot Job. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133

4 Compliance in the SA Client  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 135
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 135
Terminology . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 136
Compliance Categories . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 137
Compliance Statuses. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 138

Compliance Status Definitions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 140
Compliance Status Thresholds—Policy, Server, & Multiple Servers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 141
Compliance Status Thresholds—Device Group. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 142
Changing Device Group Compliance Settings  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 142

The Compliance Dashboard . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 143
Viewing Compliance for a Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 144

Compliance Summary Pie Chart and Details . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 144
Viewing Compliance for Multiple Servers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 146

Device Group Compliance: Status Rollup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 146
Device Group Compliance: Aggregate Rollup  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 147

Viewing Group Compliance  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 147
Adding and Removing Compliance View Columns  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 148
Sorting the Compliance Category Display  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 149
Filtering By Compliance Status. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 150
Refreshing Compliance Information . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 150
Setting Automatic Compliance Check Frequency . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 151
Exporting Compliance View Information  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 151
Compliance Dashboard Remediation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 152

Compliance View Remediate—Group of Servers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 152
Compliance View Remediate—Server  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 153

Compliance Scans  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 153
Patch Compliance  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 154

Patch Compliance Status Criteria. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 155
Remediating Patch Compliance for Servers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 155
Remediating Patch Compliance for Groups . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 156

Audit Compliance. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 157
Audit Compliance Status Criteria . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 158
Audit Compliance Remediation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 158

Remediating Audits Attached to Servers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 159
Audit Policy Compliance. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 160

Software Compliance  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 161
Software Compliance Status Criteria. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 162
Software Compliance Remediation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 162
11



Remediating Software Compliance for Servers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 163
Remediating Software Compliance for Groups. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 164

Configuration Compliance . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 165
Configuration Compliance Status Criteria  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 166

Remediating Configuration Compliance—Servers and Groups. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 166
12



1 Overview and Prerequisites
In HP Server Automation (SA), Audit and Remediation allows you to identify which objects you want 
checked, where you want to check for them, and when you want to check them in your IT environment.

• Audit policies define what to check—such as files, directories, configuration values, and so on.

• Audits define where to check—such as servers or multiple servers.

• Audit schedules define when to check—such as one time or as a recurring job.

These capabilities help you understand how to make your managed server environment compliant. In SA, 
you can define server configuration policies to ensure that servers in your facilities meet policy standards. 
When servers are found to be out of compliance—not configured the way you want them to be—you can 
remediate them to comply with your organization’s standards.

Using the SA Client, you can audit server configuration values based on a live server or a server snapshot, 
based on your own custom values, or based on pre-configured audit policies. You can also take server 
configuration snapshots to capture the current state of a system, so that you can compare other servers 
against a known baseline.

Audit policies allow you to define company or industry-wide compliance standards, which can then be 
used inside of audits, snapshot specifications, and other audit policies. Referencing audit policies in your 
audits or snapshot specifications helps verify that you are up to date with the latest compliance 
definitions in your organization.

Best Practice: If you have a content subscription to BSA Essentials Subscription Services, you can be kept 
up to date on the latest industry compliance standard, based on the needs of your data center. For 
example, Subscription Services give you access to regularly updated security best practices, such as the 
Center for Internet Security (CIS), Payment Card Industry (PCI), and so on. It also enables access to 
additional free non-subscription content such as Microsoft Patch Supplement for Server Automation. BSA 
Essentials Subscription Services enables you to access the most current regulatory compliance policies, 
such as Federal Information Security Management Act (FISMA, Sarbanes-Oxley, and daily vulnerability 
alerts. You can also join the content developer communities on the HP Live Network (HPLN) portal to 
share and access custom-created audit policies and rules. For information about subscribing to BSA 
Essentials Subscription Services, contact your sales representative. 

See the SA Support and Compatibility Matrix for detailed information about supported operating 
systems for audit and remediation. 
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Terminology

The following list defines key terms and concepts used in HP Server Automation Audit and Remediation:

• Archived Audit Result/Snapshot: Archiving audit results and snapshots allows you to move them 
from the audit result or snapshot list and keep them available for historical purposes. 

• Audit: A set of rules (which may contain individual checks) that expresses the desired state of a 
managed server’s configuration objects, such as a server’s file system directory structure or files, a 
server’s Windows Registry, application configuration, and so on. An audit also contains sources 
(servers, snapshots, or snapshot specifications), targets (servers or snapshots), rule exceptions, and 
a schedule.

An audit’s rules can be linked to an audit policy—which means the rules of the audit policy are 
substituted for those in the audit. An audit can be run to baseline compare server configuration 
object values against a golden server, a server snapshot, or user-defined values, to determine how 
values differ. When an audit reports a difference between servers or user-entered values, you can 
install software and server objects to remediate the differences so that servers conform to your audit 
rules.

• Audit Job: The process that occurs when you run an audit. An audit job can be run immediately one 
time or on a recurring basis by scheduling the job. When an audit job is finished, it produces an audit 
result that reports the differences.

• Audit Rule Type: An audit can contain the following types of rules: 

— Comparison: A rule that compares a server’s or snapshot’s configurations of a server with other 
managed servers or snapshots. 

— Value-based (user-defined): A rule that compares one or more set of user-defined values. This 
type of audit includes an audit that links to an audit policy. 

— Non-existence: Checks for the non-existence of an object, to determine if it does not exist on the 
target server.  If the object exists on the target server, then the rule is out of compliance.  Note 
that, at runtime, the source server, if any, is not queried.  Also, if a Wildcard rule object is 
selected, it will only apply to the target server.

• Audit Policy: A collection of rules that defines a desired configuration for a server. A policy can be 
used by an audit in the following ways: 

— Link: A linked policy maintains a persistent connection between the audit and the policy. This 
means that the rules in the audit are exactly those of the audit policy and if any updates are 
made to the policy, the latest changes are also reflected in the audit to which the policy is linked. 
When an audit policy is linked to an audit or snapshot specification, the rules are shown inside 
the audit or snapshot specification as read-only. The rules inside the audit policy remain 
editable.

— Import (replace, non-linked): When you import a policy into an audit, the connection between 
the audit and the audit policy is no longer maintained. You can make changes to the audit 
without affecting the policy. Conversely, any changes or updates made to the policy will not be 
reflected in the audit.

— Import (merge): When an audit policy is imported and merged into an audit, the audit policy's 
rules are added to the rules already present in the audit. No persistent link between the audit and 
the audit policy is maintained. During the merge, if rules are found to conflict, the newly 
imported rules from the audit policy will replace the rules in the audit policy.

• Audit Result: The results of running an audit. This information shows how configuration-object 
values of a target server, or multiple servers, match/do not match the values defined in the audit.
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• Exception: A server and specific rules that has been excepted or disabled, so that when the audit is 
run, the rule exception is not checked on the selected server. This server is excluded when 
determining audit compliance. 

• Compliance: The degree to which a server’s configuration conforms to a check or test established in a 
collection of rules defined in an audit, a snapshot specification, or an audit policy. Compliance in Audit 
and Remediation is defined by the audit’s or snapshot’s rules that specify the values expected of the 
target servers. If the values on the target server are different than specified in the audit’s rules, the 
server is considered Non-Compliant. 

• Policy Setter: A user who is responsible for defining server configuration compliance standards (the 
way a server should be configured) and audit policies in your organization.

• Rule: A check on a particular server configuration object that includes a desired value and an optional 
remediation value.

There are two types of rules: 

— server-based rule: derived directly from a source server

— user-defined rule: created by a user

If you are subscribed to BSA Essentials Subscription Services, you can access predefined rules that 
define a wide range of industry compliance standards, such as the latest patch supplement for 
Microsoft Windows, current regulatory compliance policies (FISMA, Sarbanes-Oxley), user-created 
rules from the EP developer community, daily vulnerability content updates, and so on. 

• Server Object: An object from a server to which an audit or snapshot specification rule can be applied. 
This can be a value, such as minimum password length, or an object, such as a file or directory, 
registry entry, Windows Services hardware configuration, and so on.

• Snapshot: A representation of the configuration state of a managed server, where the information 
was captured on a certain date, at a certain time of day. A snapshot is the result of a snapshot 
specification job that has been run.

• Snapshot Specification: A source for an audit. This is commonly known as reflexive auditing. When 
you run an audit from a snapshot specification, the audit uses all the information defined in the 
specification, then applies any filters that you have defined. 

• Snapshot Specification Job: The process that occurs when you run a snapshot specification. A 
snapshot job can be run once or on a recurring basis, by scheduling the job. When a snapshot 
specification job is completed, it produces a snapshot.

• Target: The server or servers that you run an audit against or take a snapshot of. The target for an 
audit can be a server, multiple servers, a group of servers, or a snapshot. The target for a snapshot 
can also be other servers.

Note: ESXi servers can only use another ESXi server as a target.
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Server Configurations

The following best practices and examples illustrate ways that SA helps you manage server 
configurations in your facility: 

• Enforce Security Standards

• Capture & Replicate Golden Servers

Enforce Security Standards

Your IT organization typically has security policies that you must enforce. These policies verify whether 
your servers are correctly configured and are protected from security attacks. Your policy setter can 
create an audit policy to enforce these security standards. A pre-defined audit policy can be linked to 
multiple audits or snapshot specifications. Administrators who manage live servers can reference the 
correct audit policy to ensure their servers are being audited correctly. 

Example: Your company has Solaris 10 servers that must be kept up to date with the most recent 
commonly known security vulnerabilities that are specified by Common Vulnerabilities and Exposures 
(CVE). Your company wants to make sure your servers are not vulnerable to a known threat to Solaris 10, 
such as CVE-2009-0168 (CVSS 4.9), which checks for an unspecified vulnerability in PPD File Manager 
(ppdmgr) in Solaris 10 and OpenSolaris snv_61 through snv_106. By subscribing to the BSA Essentials 
Subscription Services, you have access to an online collection of compliances checks. You can use these 
checks to audit your Solaris 10 servers and verify whether they are not at risk to this security 
vulnerability. Your system administrator, who is responsible for defining compliance standards in your 
organization, can create an audit policy that contains the CVE-2009-0168 compliance check.

Best Practice: System administrators who are responsible for managing Solaris servers can create audits 
for their servers and then link their audit’s rules to this audit policy. When an audit links to an audit policy, 
any changes made to the policy are immediately reflected in the audit. Therefore, the person who runs 
the audits on the servers knows that the audit rules are always up to date. For example, if a new CVE 
update came out for Solaris 10 servers, the policy setter would update the policy and all audits that link to 
that policy will have the latest compliance checks. Knowing that her audit will always contain the latest 
vulnerabilities checks, the policy setter can schedule the audit to run regularly to check all of the Solaris 
10 servers that she manages. If the audit results show that any of the target servers do not contain the 
new CVE security check, those servers can be remediated to fix the problem. 

Capture & Replicate Golden Servers

Sometimes a server becomes configured in such a way that is represents the ideal state of server 
configuration for a certain purpose in your facility. For example, if you want to set up a collection of 
servers that handle Web traffic, you might configure a single server that represents an ideal 
configuration—a golden server configuration—for a group of Web servers. After you configure this 
golden server, you can duplicate its configuration across a group of SA managed servers.

Example: You have a Red Hat Linux server that has a unique configuration of Apache Web Servers, and 
you want to duplicate this exact configuration across several other managed servers. Using Audit and 
Remediation, you can create an audit that uses the golden server as the source configuration. In the audit, 
you select those configurations to use to audit other servers, such as an application policy and specific 
application configuration rules. Select those servers as the target of the audit to be configured like the 
golden server. After you run the audit, you can remediate any target server's configurations that do not 
match the golden server. You can schedule the audit to run on a regular basis. If any server becomes 
non-compliant, you remediate it when it deviates from the golden server. 
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ESXi Servers

This section introduces audit-related VMware ESXi server functions and describes prerequisite actions.

You can now perform the following audit-related actions for ESXi servers:

• Create audits.

• Create snapshots and snapshots specification.

• Create and manage audit policies.

Your ESXi servers must be managed by a vCenter that has PowerShell and PowerCLI installed. 

Running Commands Against ESXi Servers 

When you run a command on ESXi servers, the SA Client interacts with the vCenter to execute the 
command. The following diagram displays this process.

When users run scripts with PowerCLI commands against ESXi servers in the SA Client, the server injects 
the ESXi server name from the device records, and routes the script to the vCenter that manages that ESXi 
server. The PowerCLI plugin translates PowerCLI commands in the scripts into calls to the vCenter internal 
APIs, which then communicate with the ESXi servers.

Supported Versions

SA 10.2 supports the following ESXi server versions: 5.0, 5.1 and 5.5.

Note: If you use vCenter 5.1, you must install VMware ESXi 5.1, Patch ESXi510-201307401-BG: Updates 
esxi-base and misc-drivers (2052144) from the VMware site.
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ESXi Prerequisites

This section lists prerequisites for using the audit features on ESXi servers.

• Refer to the VMware ESXi Hardening Guides

• Ensure vCenter Management

• Download PowerCLI Installer

• Install or Upgrade Your PowerShell Version

• Download and Install Windows Manager Framework

• Set the PowerShell Execution Policy 

• Set the Configuration Value for the InvalidCertificateAction

• Set the Configuration Value for WebOperationTimeout 

• Run the XML Serializers Script

• Disable Check for Certificate Revocation

Refer to the VMware ESXi Hardening Guides

The basis for the SA ESXi compliance check library is the set of VMware ESXi Hardening Guides, located at: 
http://www.vmware.com/security/hardening-guides.

These guides explain how to deploy and operate VMware products securely. They also include script 
examples for enabling security automation.

Ensure vCenter Management

All vSphere ESXi servers are managed through a Windows-based vCenter Server. ESXi servers do not have 
their own SA agents. The vCenter Server must have an SA agent installed. The vCenter Server must also 
be integrated with SA Virtualization. To check if your vCenter Server is integrated, make sure it is visible in 
the server window when you select the Virtualization tab in the SA Client. For more information on 
virtualization integration, see the SA Virtualization Guide. 

Download PowerCLI Installer

The PowerCLI Installer is available at the VMware Download site. Download the version that matches your 
vCenter Server.

Install or Upgrade Your PowerShell Version

PowerCLI requires PowerShell 2.0 and above to run. If you do not have PowerShell installed, first install 
PowerShell 1.0, then upgrade to PowerShell 2.0 or higher.

To install PowerShell 1.0 on a vCenter Server Computer

1 In a vCenter Server Computer, launch the Server Manager component:

a Select Add Feature.

b In the Select Features panel, select Windows PowerShell 1.0.

c Click Install.

To upgrade PowerShell 1.0 to PowerShell 2.0 or higher:

1 Use the following command to verify the installed PowerShell version:



PS > $PSVersionTable.PSVersion

The version number will be in the Major column of the screen display.

2 Use Windows Update Manager to download and install PowerShell 2.0. Once you download it, the 
PowerShell2.0 Installer can be seen in the Windows Update application. To check if it is installed, click 
Install Updates. 

Download and Install Windows Manager Framework

To use PowerShell 3.0, you can use Windows Manager Framework (WMF) 2.0, 3.0. or higher to download 
the PowerShell 3.0 Installer package.

To download and install Windows Manager Framework:

1 Uninstall pre-release versions of WMF 3.0, if any.

2  Close all PowerShell windows.

3 Download the correct WMF 3.0 package for your operating system and architecture from the 
Microsoft Download site.

Set the PowerShell Execution Policy 

PowerShell scripts can only run if the PowerShell Execution Policy is set in accordance with your company 
security policy (either RemoteSigned or Unrestricted).

To set the PowerShell Execution Policy:

1 As Windows administrator, log in to the vCenter Server.

2 Open the PowerShell console.

3 Run the command. For example, to set the policy to Unrestricted, use the following command:

PS > Set-ExecutionPolicy Unrestricted. 

Set the Configuration Value for the InvalidCertificateAction

By default, the InvalidCertificateAction configuration item value is set to Warn. If the certificates are 
invalid, a message will be written to the script output, which will cause some compliance code to fail. To 
address this, fix the certificate issue in accordance with your company's security policy or set the 
configuration to ignore the invalid certificate. 

If you choose to ignore the certificate, execute the following command from each vCenter: 

Set-PowerCLIConfiguration -InvalidCertificateAction Ignore -Scope AllUsers 

For more information, see VMware documentation. 

Set the Configuration Value for WebOperationTimeout 

By default, the WebOperationTimeout configuration item value is set to 300 (seconds). Some PowerCLI 
commands may take longer than this to run, depending on the network and server load. The 
recommendation is to set this value to -1 (infinite). If that value is not feasible, test and adjust as needed. 
For more information on this configuration item, see VMware documentation. 

Set-PowerCLIConfiguration -WebOperationTimeout -1 -Scope AllUsers 
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Run the XML Serializers Script

Another preparatory step to run audits on ESXi servers is to execute the XML Serializers script. 

To execute the script: 

1 Log in to the SA Client.

2 In the Library tab, choose to select By Type.

3 Expand the Scripts node.

4 Select Windows.

5 From the list of Windows scripts:

a Select the install-powercli-xmlserializers.ps1 script. 

b Right-click the script and choose Run with PowerShell.

c In the Run Server Script window, select all vCenter servers (or add the servers, then select them).

d Click Start Job to execute the script on all vCenter servers.

Note: To back out the change (that is, to reverse the changes that occurred when you ran the script), run 
the following script: uninstall-powercli-xmlserializers.ps1.

Disable Check for Certificate Revocation 

Each ESXi check (script) runs in its own PowerShell process. We enable PowerCLI by using the 
Add-PSSnapin command in the scripts. There is a delay, however, of 7 to 9 seconds every time the process 
is launched, because PowerShell tries to download the Certificate Revocation List from the Internet and 
verify the digital signatures. To avoid this delay, change the following two registry entries to the indicated 
values. 

Note: The keys or the path to this registry might change in future versions of Windows.

Tip: After setting this up on one vCenter, use SA to take a snapshot (Snapshot Specification), then audit 
and remediate the change to other vCenters.

When users run scripts with PowerCLI commands against ESXi servers in the SA Client, the server injects 
the ESXi server name from the device records, and routes the script to the vCenter that manages that ESXi 
server. The PowerCLI plugin translates PowerCLI commands in the scripts into calls to the vCenter internal 
APIs, which then communicate with the ESXi servers.

table 1 Registry Keys and Values

Registry Keys Values

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\

Internet Settings\CertificateRevocation 

dword:00000
001 

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\

WinTrust\Trust Providers\Software Publishing\State

dword:00023
c00 
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vCenter Performance Tuning

This section describes performance tuning steps for the vCenter that hosts your ESXi server.

Install and Compile VMware PowerCLI XML Serializers

Another prerequisite for running ESXi Servers is to set up the XML serializers.

To set up the XML serializers:

1 Make sure an SA Agent is installed on the vCenter.

2 Set the PowerShell execution policy.

3 Access the .PS1 files in SA at Library > Scripts > Windows.

4 Run the files from SA. 

See also Run the XML Serializers Script on page 20.

Configure Agent

If you see the following error: Error from remote (3056): connect to Agent failed 
(Connection refused), in the agent service configuration file located at:

C:\Program Files\Common Files\Opsware\etc\agent\ agentservice.args

increase the value of the following parameter (the default value is 20): 
cogbot.max_concurrent_shell_connections: 50 

Manage ESXi Server

See the SA Virtualization Guide for information on how to manage your ESXi servers through a 
vCenter.

Download the ESXi Compliance Library

Access the HP Live Network site (https://hpln.hp.com) to download the ESXi Compliance Library. 
The Compliance Library Policies include an array of user-customizable checks to audit and remediate 
commonly-used objects on platforms, such as Local Security Settings on Windows or configurations on 
Linux. Regulatory Policies provide pre-defined values for audit and remediation according to guidelines 
such as SOX or CIS.

The Compliance Library Policies contain user-customizable checks to audit and remediate 
commonly-audited objects on all supported SA platforms, and comprise of a set of items that Audit and 
Remediation dynamic policies are based on. Where possible, checks have remediation enabled to allow 
users to bring managed servers into custom-defined compliance.

The ESXi compliance content is part of the cc_security stream.
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Minimum Windows and VMware Permissions for ESXi Audit Functions

ESXi audits use an integration user for listing ESXi targets and servers, and running the PowerCLI scripts. 
You might have already created this user if you use SA VMware virtualization. This section describes how 
to control access for the integration user.

Windows Permissions

This section describes the user Windows account required to use ESXi servers.

1 Create a non-administrator user account, for example, SAUser. 

2 Minimize this user’s access in accordance with your company’s security policies.

For more information about virtualization users, see the SA Virtualization Guide.

VMware Permissions

This section describes VMware roles required to use ESXi servers.

These steps include: setup a VMware role with host-only access, create a permission with our 
integrated user, in that role, and apply it to all the hosts that you want to manage.

1 Create a VMware role with all privileges and host-only access.

2 Select hosts.
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3 Assign permissions:

a Right-click on the selected hosts to bring up the context menu.

b Click Add Permission…

c Select the role created in step 1.

d Add the integrated user.

e Uncheck the Propagate to Child Objects box (if permissions are propagated to the VMs, even 
host-only permissions, then those VMs will appear in SA as agentless devices).

f Add the vCenter to SA Virtualization. If the vCenter has already been added, run the Reload Data 
job.
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2 Audits, Audit Policies, and Audit Results
Audits 

An audit defines a set of rules or configuration values that determine whether the configuration of a 
managed server or group of managed servers matches your organization’s compliance standards. Audit 
rules can be configured in an ad-hoc manner or, more effectively, reference a predefined audit policy that 
specifically defines the required configuration for a managed server in HP Server Automation.

An audit can:

• Compare a server’s configuration against the rules defined in the audit policy. 

• Check that a configuration value meets the criteria specified in the audit rule.

• Check to ensure that a specific value does or does not exist. 

Some audit rules also allow you to run scripts that capture more detailed configuration information. 

Best Practice: You can define the audit policy to: 

• Identify whether an IIS Metabase value exists, especially when you do not want it to.

• Make sure a specific Linux service is set to always be running, especially if it’s a critical service that 
must always be running for security reasons. 

• Determine if a certain file system directory does not exceed a certain size limit.

• Make sure that the maximum length setting for user passwords has not been exceeded.

You can define what the audit should look for, what values you expect to find on the server, and what 
replacement values to use that will fix them when differences are found. 

After it is configured, an audit can be run once, scheduled for a future run, or be scheduled to run a regular 
basis. After an audit is run, its results indicate the extent to which those servers meet the definitions set in 
the audit rules. In cases where discrepancies are found, you can remediate those servers to bring them 
into compliance.

Audit Policies 

An audit policy is a collection of reusable rules that define the desired state of server configuration, based 
on industry standards and the compliance goals set by your organization. An audit policy can be linked to 
audits, snapshot specifications, and other audit policies. When changes are made to an audit policy, all 
references to that audit policy are also updated. 

An audit policy is typically created by a policy setter who understands the compliance standards that a 
company requires its servers to meet for a specific configuration domain and operating system. 
Administrators who manage servers can use predefined audit policies by linking them to their audits or 
snapshot specifications. If any changes are made to an audit policy, the audit that links to it also contains 
the updated rules. Administrators who audit SA managed servers can be sure their audits always reflect 
the latest policy standards in their organization.
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Snapshots 

A snapshot is a representation of the configuration state of a managed server, where the information was 
captured on a certain date, at a certain time of day. A snapshot is useful for capturing the configuration of 
a golden server that you would like to baseline compare against other servers in your facility. You can use 
the snapshot as the source of an audit. If a server does not match the configuration captured in the 
snapshot, you can remediate those servers after the audit has run. 

•  Capture & Replicate Golden Servers

•  Snapshots, Snapshot Specifications, & Snapshot Jobs

•  Audit Results

Compliance and Remediation 

The Compliance view in the SA Client allows you to view the overall compliance levels for SA managed 
servers in your facility. The Compliance view is also known as the compliance dashboard. From the 
compliance dashboard, you can identify and then, subsequently, remediate compliance problems.

•  Compliance in the SA Client

•  Server Objects

Audit Management 

An audit is a collection of rules that enable you to define what should be or what should not be in a 
server’s configuration. An audit contains rules, a source, target servers, and a schedule that defines when 
and how often the audit will run.

Audit rules allow you to define and check the state of various configurations or objects and files on a 
managed server, such as the state of server’s file system, registry settings, installed and registered 
software (patches and packages), events, software, application configurations, operating system 
settings, and so on.

Note: If a configuration or object on the target server is different than the state you defined in the audit 
rules, or if an object or rule exists in the source server but not in the target server, the rule is considered 
Non-Compliant. 

For example, you will not be able to run a successful audit or remediation if you add a group or user to the 
source server, but not to the target server. You will also get an error if you change a registry setting in the 
source server, but not in the target server.

When you view an audit’s results, you can remediate the object configuration to make sure the target 
server’s configuration is in compliance with the desired configuration.

You can audit server configuration values for a single server, multiple servers, or another server 
snapshot. You can schedule audits to run immediately or on a recurring schedule, and send email 
notifications when the audit has completed. You can also cancel an audit job while it is running.
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•  Audit and Snapshot Rules

•  Audit Results

•  Audit & Remediation Rules

•  The Compliance Dashboard

•  Scheduling an Audit

•  Cancelling an Active Audit Job

Audit Comparison Types

In general, an audit can contain the following types of comparisons, based on the source of the audit: 

• Comparison: An audit based on configuration values from a source server or source snapshot 
specified at the time the audit is created. The source server or server snapshot is also known as a 
golden server. For example, you might want to compare file directories or file contents, registry 
structures, IIS Metabase entries, or user group settings among managed servers. Using a snapshot as 
the source of an audit, you can compare the snapshot with other servers in your facility. 

Comparison audits can perform the following types of comparisons:

— Property: Checks the property of a selected object or object configuration. For example, you 
could check the release version of a patch on a target server or multiple servers, to make sure it 
matches what you expect to be installed on the targets. You can select this version number 
based on a source server or snapshot or add your own value. 

— Equivalence: Checks to determine that a target server configuration is the same between the 
source server or snapshot of the audit. For example, you could check to see if the target of the 
audit has the same user group as a group you selected from a source server. 

— Non-existence: Checks for the non-existence of an object, to determine if it does not exist on the 
target server. If the object exists on the target server, then the rule is out of compliance. For 
example, you could check a server to make sure it does not contain a specific COM+ object. Note 
that, at runtime, the source server, if any, is not queried.  Also, if a Wildcard rule object is 
selected, it will only apply to the target server.

• Value-based (user-defined): An audit based on custom, user-defined values for each server object 
(file system, windows services, IIS Metabase, users and groups, and so on). These values can be 
derived from a source server, SA attributes, or custom attributes. This type of audit includes those 
based on an audit policy. In an audit policy, a policy setter pre-defines values for each configuration 
object, based on company or industry compliance standards. 
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Audit Process

Figure 1 shows the audit process, including step-by-step descriptions.

figure 1 Audit Process 

Audit Elements

An audit consists of the following elements: 

• Properties: The name and description of the audit. 

• Source: The source of an audit can be a server, a snapshot, or no source at all. However, some rules 
require a source. 

— Choosing a server as the source for an audit allows you to select server objects from that server 
as the basis of your audit. 

Note: If you target an ESXi server, you can only choose an ESXi server as the source.

— Choosing a snapshot as the source of an audit allows you to use the configuration values of the 
snapshot. 

— Choosing a snapshot specification as the source allows you to audit a server against itself over 
time. 

For example, if you took a snapshot of a server, then used that snapshot specification as the source 
of the audit, every time you run the audit, you can compare the original state of the server against the 
server’s actual configuration over time, using a recurring audit schedule. If you choose no source, you 
can only define your own custom values for the audit or snapshot. 

Source:
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 Audit Policy
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Audit Results Correct settings
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be on target servers.
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• Rules: A check on a particular server object with a desired value and an optional remediation value. 
For example, you might check to see if this server contains a specific Windows Service, and if found, 
determine if the service is turned off. See Server Objects on page 44. 

Note: For Audits created below the VMware ESXi node, only two rules (Compliance Check and Custom 
Script) can be used.

• Targets: The servers that the audit will check for compliance. You can choose as many servers and 
groups of servers as needed for an audit or snapshot. 

Note: Audits created below the VMware ESXi node can only target ESXi servers.

• Exceptions: Servers and specific rules that will not be checked for compliance when the audit is run. 

• Schedule: You can run an audit on a one-time basis or on a recurring schedule. Audits that run on a 
recurring schedule appear as a single compliance column in the compliance dashboard.

• Notifications: You can send emails when the audit has finished running, and base the notification on 
the success, failure, or the completion of an audit job.

Configuring an Audit

To configure an audit, select server configuration objects and then apply rules to those objects in order to 
define their desired configuration state. 

For example, Figure 2 shows an audit that includes 33 defined rules for Windows or Unix servers. These 
rules are used to determine whether target server configurations match the rules in the audit.

figure 2 Audit Browser Showing Objects in an Audit    

Note: Audits in the SA UI can only be created below the VMware ESXi node. Audits for ESXi can only target 
ESXi servers, and can only use Compliance Checks and Custom Script rules.
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Creating an Audit 

In the SA Client, there are several ways to create an audit.

You can:

• Select a managed server as the source of the audit, to run the audit on a single server.

See Creating an Audit from a Server on page 30.

Note: If you are using an ESXi server, you can only choose an ESXi unmanaged server as the source.

• Select a group of managed servers as the source of the audit, to run the audit on all servers in that 
group.

See Creating an Audit from a Group of Servers on page 30.

• Create a new audit from the SA Library.

See Creating an Audit from the SA Library on page 31.

• Create an audit that is based on the server configuration captured in a snapshot.

See Creating an Audit from a Snapshot on page 31.

• Create an audit that is based on the audit policy.

See Creating an Audit from an Audit Policy on page 31

Creating an Audit from a Server

When you create a new audit from a managed server, the audit uses the selected server as the source of 
the audit. You can choose another server or snapshot for the audit source, or even not choose a source 
and define your own custom rules. 

Note: If you are using an ESXi server, you can only choose an ESXi server as the source.

To audit a managed server, you must have access to the server.

To create an audit from a server: 

1 In the navigation pane, select Devices > Servers > All Managed Servers.

2 Select a server.

3 From the Actions menu, select Create > Audit to open the Audit window.

Creating an Audit from a Group of Servers

When you create an audit from a group of servers, the audit will evaluate all accessible servers in that 
group. However, the audit will evaluate only those servers in a group for which your user has access.

To audit a group of servers: 

1 In the navigation pane, select Devices > Device Groups.

2 In the content pane, select Public or private.

3 Select the group of servers that you want to audit. 
30 Chapter 2



4 In the content pane, select a group of servers.

5 From the Actions menu, select Create > Audit to open the Audit window.

When you perform an audit by selecting a group of servers, the group of servers becomes the target. 
If the audit rule requires a source, you must specify one.

Creating an Audit from the SA Library

To create an audit from the SA Library: 

1 In the navigation pane, select Library > By Type > Audit and Remediation.

2 In the navigation pane, expand Audits.

3 Select an operating system.

4 From the Actions menu, select New to open the Audit window.

Creating an Audit from a Snapshot

You can select any snapshot in the SA Library and create an audit that is based on the server configuration 
captured in the snapshot. The snapshot will serve as the source of the audit; however, after you create 
the new audit from the snapshot, you can also select a different snapshot or server as the source. 

To create an audit from a snapshot:

1 In the navigation pane, select Library > By Type > Audit and Remediation.

2 In the navigation pane, expand Snapshot Specifications.

3 Select an operating system.

4 From the Actions menu, select New to open the Snapshot Specification window. 

Creating an Audit from an Audit Policy

Audit policies are designed to be used by audits. When you create an audit from an audit policy, the audit 
policy is linked to the audit. When updates are made to that audit policy, all changes are reflected in the 
audit. 

To create an audit from an audit policy:

1 In the navigation pane, select Library > By Type > Audit and Remediation.

2 In the navigation pane, expand Audit Policies.

3 Select an operating system.

4 From the Actions menu, select New to open the Audit Policy window. 

•  Saving an Audit as an Audit Policy
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Running an Audit 

Running an audit will execute the selected audit on the target server, servers, or snapshot of the audit. 
The audit evaluates the targets according to the rules defined in the audit. You can run an audit from the 
following locations in the SA Client: 

• From the SA Library on page 32

• From All Managed Servers on page 33

• From Audit Results on page 33

From the SA Library

The SA Library contains all available audits that you can run, organized by operating system. The list of 
audits in the Library can be sorted by any of the columns, such as Name, Last Modified Date, and so on. 
The search tool can also be used to search the audit list by entering a name, ID, person who created the 
audit, and so on.

To run an audit from the SA Library: 

1 In the navigation pane, select Library > By Type > Audit and Remediation. 

1 Select Audits, and then select an operating system.

2 Select the audit you want to run, right-click, and select Run Audit.

3 In the Run Audit window, step one shows you the name of the audit, the source server, or snapshot 
being used in the audit, the total number of rules defined in the audit, and all targets of the audit 
(servers and snapshot). Click View Rule Details to view the rule definitions.

(Optional) If you want to immediately run the audit, click Start Job at any point in the process.

4 Click Next. 

5 In the Scheduling page, choose whether you want the audit to run immediately or at a later date and 
time. To run the audit at a later time, select Run Task At and then choose a day and time. 

6 Click Next.

7 In the Notifications window, by default your user will have a notification email sent when the audit 
finishes, whether or not the audit job is successful. To add an email notifier, click Add Notifier and 
enter an email address. 

8 (Optional) You can specify if you want the email to be sent on success or failure of the audit job. 

9 (Optional) You can specify a Ticket Tracking ID in the Ticket ID field. The ticket ID field is only used 
when SA Professional Services has integrated SA with your change control systems. Otherwise, it 
should be left blank.

10 Click Next.

11 In the Job Status page, click Start Job to run the audit. When the audit has run, click View Results to 
view the results of the audit.
32 Chapter 2



From All Managed Servers

You can run an audit from this location, if the server is being used as a target for an audit. 

Note: ESXi servers can only use another ESXi server as a target.

To run an audit from the All Managed Servers list: 

1 In the navigation pane, select Devices > Servers > All Managed Servers.

2 Select a server. 

3 From the View drop-down list, select Audit and Remediation. The details pane displays below the 
content pane. 

4 In the details pane Show drop-down list, select Audit - Server is Target. 

5 Select an audit from the list, right-click, and select Run Audit. 

6 In the Run Audit window, step one shows you the name of the audit, the source server, or snapshot 
being used in the audit, the total number of rules defined in the audit, and all targets of the audit 
(servers and snapshot). Click View Rule Details to view the rule definitions.

(Optional) If you want to immediately run the audit, click Start Job at any point in the process.

7 Click Next. 

8 In the Scheduling page, choose whether you want the audit to run immediately or at a later date and 
time. To run the audit at a later time, select Run Task At and then choose a day and time. 

9 Click Next.

10 In the Notifications window, by default your user will have a notification email sent when the audit 
finishes, whether or not the audit job is successful. To add an email notifier, click Add Notifier and 
enter an email address. 

11 (Optional) You can specify if you want the email to be sent on success or failure of the audit job. 

12 (Optional) You can specify a Ticket Tracking ID in the Ticket ID field. The ticket ID field is only used 
when SA Professional Services has integrated SA with your change control systems. Otherwise, it 
should be left blank.

13 Click Next.

14 In the Job Status page, click Start Job to run the audit. When the audit has run, click View Results to 
view the results of the audit.

From Audit Results

You can rerun an audit from an audit results if you would like to run the same audit another time. 

When you review the results of an audit or a snapshot and re-run the audit from those results, the rules in 
the original audit might have changed after the results were captured. It is possible that you will be 
running the updated audit and not necessarily the original audit that produced these results.

To rerun an audit: 

1 In the navigation pane, select Library > By Type > Audit and Remediation. 

1 Select Audits, and then select an operating system.

2 Select an audit, and in the details pane, select an audit result for the audit. Each time the audit is run, 
its results are accumulated in the details pane.

3 Double-click the audit result to open it. 
Audits, Audit Policies, and Audit Results 33



4 From the Actions menu, select Re-Run audit.

5 In the Run Audit window, step one shows you the name of the audit, the source server, or snapshot 
being used in the audit, the total number of rules defined in the audit, and all targets of the audit 
(servers and snapshot). Click View Rule Details to view the rule definitions.

(Optional) If you want to immediately run the audit, click Start Job at any point in the process.

6 Click Next. 

7 In the Scheduling page, choose whether you want the audit to run immediately or at a later date and 
time. To run the audit at a later time, select Run Task At and then choose a day and time. 

8 Click Next.

9 In the Notifications window, by default your user will have a notification email sent when the audit 
finishes, whether or not the audit job is successful. To add an email notifier, click Add Notifier and 
enter an email address. 

10 (Optional) You can specify if you want the email to be sent on success or failure of the audit job. 

11 (Optional) You can specify a Ticket Tracking ID in the Ticket ID field. The ticket ID field is only used 
when SA Professional Services has integrated SA with your change control systems. Otherwise, it 
should be left blank.

12 Click Next.

13 In the Job Status page, click Start Job to run the audit. When the audit has run, click View Results to 
view the results of the audit.

When you review the results of an audit or a snapshot and re-run the audit from those results, consider 
that the rules in the original audit might have been changed after the results were captured and reviewed. 
When you re-run the audit, it is possible that you will be running the updated audit and not necessarily the 
original audit that produced these results.

Clearing Audit or Snapshot Results

Once you run an audit or snapshot on a server, and view its results, you must close the audit or snapshot 
window to clear the results before you run an audit or snapshot on a different server. If you do not close 
the window, any results and rules you view will belong to the initial server.

Scheduling an Audit 

Scheduling an audit requires specifying when you want an audit to be run (either once or as a recurring 
job) and who you want to receive email notification about the status of the job. You can also view, edit, 
and delete or cancel existing scheduled audits. When you delete a scheduled audit, all schedules that you 
have created associated with that audit will also be deleted. You can also cancel an audit job that is in 
progress. See Cancelling an Active Audit Job on page 37.

You must have permissions to create, view, edit, and delete audit schedules. To obtain these permissions, 
contact your SA administrator. See the SA Administration Guide for more information on permissions.
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Scheduling a Recurring Audit

After you have created, configured, and saved an audit, you can set up a schedule that specifies when you 
want the audit to run on a recurring basis. When you specify a recurring schedule, the end date must allow 
for the audit job to run at least once. After the schedule is set, you can edit the schedule according to your 
needs. 

To schedule a recurring audit:

1 In the navigation pane, select Library > By Type > Audit and Remediation, and then select Audits.

2 Select an OS, and then double-click an audit to open it.

3 In the Views pane of the Audit window, select Schedule.

4 In the Schedule section, choose to run the audit once, daily, weekly, monthly, or on a custom 
schedule. Parameters include: 

— None: No schedule will be set. To run the audit, select the audit, right-click, and select Run Audit. 

— Daily: Choose this option to run the audit on a daily basis. 

— Weekly: Choose the day or days of the week to run the audit.

— Monthly: Choose the months to run the audit run, and the days of the month. 

— Custom: In the Custom Crontab string field, enter a string the indicates a time schedule. 

A crontab file has five fields for specifying the day of the week, the month, the day of the month, 
the hour, and the minute. The following diagram shows each position in the crontab file, what 
the position corresponds to, and the allowed values:

The crontab string can include serial (1,2,3,4) and range (1-5) values. Only some operating 
systems support the minutes format /2 or /10 for running the audit every 2 minutes or 10 
minutes. An asterisk (*) denotes all values for that field, such as all months of the year. Days can 
be specified in two fields: month day and week day. If both days are specified, both of the values 
will be executed. All operating systems support comma-separated values within each field. 

For example:

5,10 0 10 * 1 means run an audit 12.05 and 12.10 AM every month or on the 10th and on every 
Monday.

For more information about crontab entry formats, consult the Unix man pages.

5 In the Time and Duration section, for each type of schedule, specify the hour and minute you want the 
daily schedule to start. Unless you specify an end time, the audit will keep running indefinitely. 

To choose a date to end the audit schedule, select End and then choose a date. The Time Zone is set 
(Optional) Deselect the End option, if you want the audit schedule to run indefinitely.

6 To save the audit schedule, from the File menu, select Save. The audit will now run according to the 
defined schedule.
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Editing an Audit Schedule 

You can edit an audit schedule after you have created (or edited) and saved it. 

To edit a scheduled audit:

1 In the navigation pane, select Jobs and Sessions. 

2 Select Recurring Schedules. 

3 In the drop-down list at the top of the content pane, select Audit Servers. 

4 Select a scheduled audit job, right-click, and select Open. 

5 In the Audit window, select Schedule in the Views pane to view the audit schedule. 

6 To edit the audit Schedule, modify the following parameters: 

— None: No schedule will be set. To run the audit, select the audit, right-click, and select Run Audit. 

— Daily: Choose this option to run the audit on a daily basis. 

— Weekly: Choose the day or days of the week to run the audit.

— Monthly: Choose the months to run the audit run, and the days of the month. 

— Custom: In the Custom Crontab string field, enter a string the indicates a time schedule. 

A crontab file has five fields for specifying the day of the week, the month, the day of the month, 
the hour, and the minute. The following diagram shows each position in the crontab file, what 
the position corresponds to, and the allowed values:

The crontab string can include serial (1,2,3,4) and range (1-5) values. Only some operating 
systems support the minutes format /2 or /10 for running the audit every 2 minutes or 10 
minutes. An asterisk (*) denotes all values for that field, such as all months of the year. Days can 
be specified in two fields: month day and week day. If both days are specified, both of the values 
will be executed. All operating systems support comma-separated values within each field. 

For example:

5,10 0 10 * 1 means run an audit 12.05 and 12.10 AM every month on the 10th and on every 
Monday.

For more information about crontab entry formats, consult the Unix man pages.

7 In the Time and Duration section, for each type of schedule, specify the hour and minute you want the 
daily schedule to start. Unless you specify an end time, the audit will keep running indefinitely. To 
choose a date to end the audit schedule, select End and then choose a date. The Time Zone is set 
according to the time zone set in your user profile. 

8 (Optional) Deselect the End option, if you want the audit schedule to run indefinitely.

9 To save the audit schedule, from the File menu, select Save. The audit will now run according to the 
defined schedule.
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Note: If you set an audit schedule in previous releases (pre-SA 10.0), and you used System time zones 
(such as SystemV/PST8 or System V/PST8PDT), you must reset the audit schedule to use supported time 
zones or you will get an error when you try to run it.

Viewing a Completed Audit Job

To view information about a completed audit job: 

1 In the navigation pane, select the Jobs and Sessions tab. 

2 Select Job Logs. 

3 The content pane displays all jobs run in this SA core. To display only audit jobs, from the drop-down 
list at the top of the content pane, select Run Audit Task. If you want to see only your scheduled 
audits, enter your user ID in the User ID field at the top of the content pane. 

4 Open an audit job to view the audit results and then click View Results.

Exporting/Importing an Audit

Use the audit filter to tell DET which audit to export from an SA core/mesh so that you can then import it 
into another SA core/mesh. See the SA Content Utilities Guide.

Cancelling an Active Audit Job

In the SA Client, you can terminate an active audit job. An active audit job is one that has already started 
and is running.

The terminate action on an active audit job is known as a soft-cancel. A soft-cancel is the activity where a 
job was partially run and then stopped when you clicked End Job in the Job Status step in the Audit 
Servers wizard. Soft-cancel applies only to an active audit job that you want to stop.

You must have permissions to cancel an audit that is in progress. In general, if you have permission to 
start an audit job, you will also be able to stop an audit job that is running. In addition, if you have the Edit 
or Cancel Any Job permission, you will be able to soft-cancel a running audit job. See the sections on 
terminating active jobs and the permissions reference chapter in the SA Administration Guide. To obtain 
these permissions, contact your SA administrator.

To stop an active audit job:

1 In the Job Status pane, click End Job. 

This button is enabled only when the job is in progress.

2 The End Job dialog will display. This dialog briefly describes how job termination works:

• The job will not initiate work on any additional servers. 

• If work has started on a server, the job will cancel any steps that can be skipped.

• The Job Status will indicate the steps that were completed or skipped.

3 If the job ends successfully, the final job status will display as Terminated.
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4 Click OK to confirm that you want to terminate the job. The Job Status window displays the progress 
of the termination action.

The job status will be Terminated. The server status will be Cancelled. The task statuses will be 
Succeeded or Skipped.

5 When the termination is complete, you can also view the job in the SA Client Job Log. 

In the SA Client navigation pane, select Jobs and Sessions. The Job Logs view displays your job with a 
Terminated status.

Viewing Audit and Snapshot Usage

After you create and run an audit, you can view it from the All Managed Servers list or from the Device 
Explorer, and see all audits that are associated with a certain server. 

From All Managed Servers

To view a server’s audit usage from the All Managed Servers list: 

1 In the navigation pane, select Devices > Servers > All Managed Servers.

2 In the content pane, select a server. 

3 From the View drop-down list, select By Type > Audits and Remediation. 

4 In the Audits and Remediation window, select Audits or Snapshot Specifications. The details pane 
shows information about audit and snapshot usage. 

5 The details pane shows information about the audit or snapshot.

6 (Optional) In any either of these views, you can select an audit or audit results, and perform actions 
from the Actions menu. For example, you can open an audit, create an audit, re-run an audit, or 
delete an audit. 

From the Device Explorer

To view a server’s audit usage from the Device Explorer: 

1 In the navigation pane, select Devices > All Managed Servers.

2 In the content pane, select a server, right-click, and then select Open.

3 In the Device Explorer, from the Views pane, select Management Policies > Audits.
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4 In the content pane, from the Show drop-down list, select one of the following options: 

• Audit - Server is Target: Shows all audits where the selected server is the target of the audit. 

• Audit - Server is Source: Shows all audits where the selected server is used as the source of the 
audit. 

Note: ESXi servers can only use another ESXi server as a target.

5 (Optional) In this view, you can select an audit and perform actions from the Actions menu. For 
example, you can open an audit, create an audit, re-run an audit, or delete an audit. 

6 Next, from the Views pane you can select Archived Audit Results to see all audit results associated 
with this server that have been archived.

•  Archiving Audit Results

Audit Configuration 

The following tasks are required to configure an audit or an audit policy:

• Name and describe the audit or audit policy

• Select a source for the audit or audit policy: a server, a snapshot, snapshot specification, or none. 

• Configure the audit rules—you have the option of linking to an audit policy. This specifies that you 
want to use the rules from an audit policy in your audit. This also disables the ability to configure 
individual rules. You can also import all rules of an audit policy into the audit.

• Choose a target server, group of servers, or snapshot to audit

• Add audit rule exceptions (optional)

• Schedule the audit

• Set the Email Notification (optional)

• Save the audit

To configure an audit: 

1 Create the new audit from one of the methods described in Creating an Audit on page 30. The Audit 
window opens.

2 Enter the following information for the audit: 

• Properties: Enter a name and description for the audit. 

• Source: Every audit can use a server, snapshot, or snapshot specification as its source. (Or, you 
can choose no source and define your own rules.) If you use a server as the source, you can 
browse the server for values to define the audit’s rules. If you choose a snapshot, you will be 
limited to the rules in the snapshot and the snapshot results when you define the audit rules. If 
you choose a snapshot specification, then the audit will compare the snapshot taken of the 
targets of the snapshot specification, and compare those against the targets of the audit. When 
you choose snapshot specification as the source, the rules in the snapshot are not editable. If 
you choose no source, you must define your own rules, or choose to link to an audit policy in the 
rules section. Some rules, however, require a source in order to be defined. 

• Rules: Choose a rule category from the list to begin configuring your audit’s rules. Each audit rule 
is unique and requires its own instructions. For information on how to configure individual audit 
rules, see Audit & Remediation Rules on page 46. 
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If you want to use an audit policy to define the rules of your audit, click either Link Policy or 
Import Policy. When you link an audit policy, the audit maintains a direct connection with the 
audit policy, and disables the ability to create rules. After you link a policy, the audit will use only 
the rules configured in the audit policy. So if any changes are made to the policy, the audit will 
update with the new changes. If you import an audit policy, the audit will use all the rules defined 
in the policy but will not maintain a link to the audit policy. For information about audit policies, 
see Audit Policy Management on page 92.

• Targets: Choose the Targets of the audit. These are servers, groups of servers, or snapshots that 
you want the configured audit rules to evaluate and compare. To add a server or group of 
servers, click Add. To add a snapshot target, in the Snapshot Targets section, click Add.

Note: ESXi servers can only use another ESXi server as a target.

• Exceptions: Click Add to add exceptions to the rules in your audit. In the Add Exception window, 
select a server or multiple servers (or device groups), and then select one or more rules you want 
to except from the chosen servers. You can except any of the rules in the audit from any of the 
target servers or snapshots. You can optionally add an explanation, a ticket ID, and an expiration 
date for the exception. 

• Schedule (Optional): Choose whether you want to run the audit once, daily, weekly, monthly, or 
on a custom schedule. Parameters include: 

— None: No schedule will be set. If you want to run the audit immediately, or on a onetime 
basis, you have to select the audit, right-click, and select Run Audit. 

— Daily: Choose this option to run the audit on a daily basis. 

— Weekly: Choose the day of the week that you want the audit to run. 

— Monthly: Choose the months that you want the audit run. 

— Custom: In the Custom Crontab string field, enter a string the indicates a time schedule. 

A crontab file has five fields for specifying the day of the week, the month, the day of the 
month, the hour, and the minute. The following diagram shows each position in the crontab 
file, what the position corresponds to, and the allowed values:

The crontab string can include serial (1,2,3,4) and range (1-5) values. Only some operating 
systems support the minutes format /2 or /10 for running the audit every 2 minutes or 10 
minutes. An asterisk (*) denotes all values for that field, such as all months of the year. Days 
can be specified in two fields: month day and week day. If both days are specified, both of 
the values will be executed. All operating systems support comma-separated values within 
each field. For example:

5,10 0 10 * 1 means run an audit 12.05 and 12.10 AM every month or on the 10th and on 
every Monday.

For more information about crontab entry formats, consult the Unix man pages.
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— Time and Duration: For each type of schedule, specify the hour, minute, day of the week, 
and month for the schedule to start. Unless you specify an end time, the audit will keep 
running indefinitely. To choose an end date, select End. In the calendar selector, choose an 
end date. The Time Zone is set according to the time zone set in your user profile. 

— Notifications: Enter email addresses to notify people when the audit job finishes running. 
You can choose to send the email on both the success and the failure of the audit job (not the 
success of the audit rules). To add an email address, click Add Notification rule. (This is only 
relevant if the audit is set to run on a recurring schedule.)

3 When you have finished configuring the audit, from the File menu, select Save.

•  Ways to Link & Import Audit Policies

•  Audit and Snapshot Rules

Audit & Snapshot Sources

There are several options for choosing a source for an audit or a snapshot specification: 

• Source: Server on page 41

• Source: Snapshot on page 42

• Source: Snapshot Specification on page 43

• Source: Rules on page 43

The source of an audit determines the rules you are able to select from and configure in your audit or 
snapshot specification. Choosing a source depends on the purpose of your audit or snapshot 
specification.

Source: Server

A managed server can be a source for an audit or a snapshot specification.

If you know that a certain server contains the desired server objects that you want to add to the audit or 
snapshot specification, choose that server as the source of an audit. For example, if you are interested in 
auditing or taking a snapshot of application configuration files for an Apache Web Server (such as 
httpd.conf) on certain target servers, choose a server that you know has Apache installed on it and that is 
configured correctly—as the source of your audit. 

You can choose several different source servers when you create your audit or snapshot specification 
rules. You can also choose a different source for each server object rule.

Note: ESXi servers can only use another ESXi server as a target.
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Figure 3 shows the content pane that displays in an Audit window or in a Snapshot Specification window, 
when you choose a server as the source for an audit.

figure 3 Server as Source of Audit: Creating Audit Rules 

See Common Scope Cases with Diagrams on page 60 for more information about Directory Options.

Source: Snapshot

A snapshot can be a source for an audit or a snapshot specification.

If you have a snapshot of a managed server that is in a known good state (a golden server configuration) 
and you would like to compare that snapshot with other servers in an audit, choose that snapshot as the 
source for an audit or a snapshot specification. Or, choose this option to use the captured server values to 
take a snapshot of another server. Using a snapshot as the source for an audit or snapshot specification 
allows you to choose both the results and the rules of the original snapshot specification that the 
snapshot was based on. 
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Figure 4 shows the options for creating audit or snapshot specification rules when you use a snapshot as 
the source. You can choose from the snapshot’s results and the snapshot’s rules. 

figure 4 Snapshot as Source of Audit: Available Server Objects to Create Audit Rules 

Source: Snapshot Specification

A snapshot specification can be a source for an audit. This is commonly known as reflexive auditing. When 
you run an audit from a snapshot specification, the audit uses all the information defined in the 
specification, then applies any filters that you have defined. 

Choose this option if you want to keep track of a server’s configuration over time and monitor any 
changes that occur. For example, you might want to keep track of an application to make sure that its 
configuration remains correct over a period of time. If this application runs on several servers, you can 
create a snapshot specification that defines a desired state of server configuration and then run the 
snapshot. 

Next, you can create an audit and use the snapshot specification as the source for your audit. Each server 
that was targeted by the snapshot is now also included as a target of the audit. When you run the audit, 
either on-demand or on a scheduled basis, each server’s current configuration will be compared with the 
state originally captured from the snapshot. If the snapshot specification that serves as the source of the 
audit is set to run on a recurring basis, the audit will compare against the most recently run snapshot. Any 
changes are displayed in the audit results window.

Source: Rules

Rules that use a source value from a source server can be used as a source for an audit.

Most rules require a source in order to define them, except the following rules: 

• Any of the pre-configured rules that you do not set the value to derive from a source (server or 
snapshot or snapshot specification)
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• Custom Scripts rules that you do not set the compare value to derive from a source (server or 
snapshot or snapshot specification)

You cannot save an audit that contains rules that require a source and no source has been specified You 
must select a source for all comparison checks and for rules that compare against a source value.

Server Objects

Table 2 lists all server objects that you can create rules for in an audit or in a snapshot specification. 
Some server object values are captured and audited live and some objects are captured from the Model 
Repository.  

table 2 Server Objects Used in Audits and Snapshots

Server Object Description
Captured Live and/or 
from Model Repository

Application 
Configurations 

Contents of application configuration files and 
their values. 

Live 

Windows COM+
(See note below table.)

COM+ objects and component categories. Live

Compliance Checks You must use existing compliance reports from 
the VMware EXSi compliance library. 

Live

Custom Scripts Write your own custom scripts to retrieve 
information from a server and compare 
contents. For example, you can run a script to 
gather output from a custom application and 
evaluate returned output against values set in 
the audit. (Python only for python scripts.)

If you target an ESXi server, you can only run 
PowerShell scripts.

Live

Discovered Software Discovered Software provides a 
signature-based software discovery mechanism 
for Windows and UNIX managed servers to help 
you manage applications and software that are 
not managed by SA.

Live

Files Contents of files and directories (and 
subdirectories), user and group access, 
checksum for files, file modification date, and 
Windows ACLs (Windows only). 

Live

Hardware CPU, storage devices, and memory. Model Repository

IIS Metabase Microsoft IIS Metabase objects and 
configuration values to snapshot or audit. 

Live

IIS 7.0 Microsoft IIS 7.0 Live

Internet Information 
Server 

Real time information about IIS for a Windows 
server, such as server name, server type, server 
state, log file path, document file path, and so 
on.

Live
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Local Security Settings Real time information about security settings, 
including security settings such as password 
policy, audit policy, user rights, and security 
options. 

Live

Registered Software All installed packages or patches actually 
installed on a source server, whether or not they 
have been registered by the model repository. 

Live

Storage Information related to storage devices and SAN 
devices and connections in your data center (if 
your core is storage-enabled). 

In order to audit and snapshot SAN objects, 
Storage Essentials (SE) version 6.1.1 or later is 
required and the Server Automation SE 
Connector component must be installed and 
configured on your SA core.

Live

BSA Essentials 
Subscription Services 
“compliance checks”

If you are subscribed to BSA Essentials 
Subscription Services, you have access to many 
different types of audit rules and their 
constituent components (also known as 
“compliance checks”. The exact kind of checks 
you have access to depend on your subscription, 
but can include such rules as the latest patch 
supplements for Microsoft Windows, current 
regulatory compliance policies (for example, 
FISMA, Sarbanes-Oxley), user-created rules 
from the BSA Essentials Subscription Services 
developer community, daily updated 
vulnerability content, and so on.

Live

Users and Groups Compare information about users and groups on 
servers, such as user name for last login, 
whether or not CTRL + ALT + DELETE is enabled, 
and so on. 

Live

Windows .NET Framework 
Configuration 

Real time information about Assembly Cache 
and Configured Assembly List, such as assembly 
name, version, locale, public key token, cache 
file (GAC or ZAP), processor architecture, 
custom, and file name. 

For every Configured Assembly List, you can use 
information such as assembly name, public key 
token, codebases, binding policy, file name, file 
data. 

Live

table 2 Server Objects Used in Audits and Snapshots (cont’d)

Server Object Description
Captured Live and/or 
from Model Repository
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A Windows COM+ category (folder) that does not have any objects will not be included in a snapshot or 
audit, even though SA will display an empty COM+ folder in the Device Explorer. 

The SA Client cannot create a snapshot of the entire Windows Registry or a snapshot of all system keys. 
The volume of data is larger than the current design allows.

SA Audit and Remediation does not support device files or sockets.

Audit & Remediation Rules 

When you create an audit or a snapshot specification, you must configure Audit and Remediation rules. 
These rules define: 

• The type of server object to snapshot or audit and compare. These are objects such as the server’s 
file system, hardware information, application configurations, installed patches or software, users 
and user groups, and so on. 

• Information about the object to audit or snapshot. For example, for a server’s file system, you can 
capture Windows NT file’s Access Control Levels. For an application, you can capture the application 
configuration values you want to snapshot or audit, plus any remediation values that specify whether 
differences are discovered between the rule and the actual value that is on the target server.

Note: For ESXi servers, you can only configure rules for two objects: compliance checks and custom 
scripts.

A rule can contain a custom script that determines whether all passwords stored in a file match a certain 
character length. A rule can also include a check to determine whether a particular Windows Service is 
running or disabled on a server. For some rules, you can also specify the remediation value for the server 
object if the value defined in the audit or snapshot differs from the server’s value after the audit has run. 
For example, if a Windows Service is disabled, you can specify that the remediation value should restart 
the service. Remediation values are implemented manually, after the audit has run, from the Audit Result 
window

•  Audit Results

Windows Registry 
(See warning below table.)

Select Windows Registry directories or registry 
key values to capture and compare. 

Live

Windows Services Select Windows services. Live

Windows Users and 
Groups 

Users and groups information on a Windows 
Unix servers. 

Live

table 2 Server Objects Used in Audits and Snapshots (cont’d)

Server Object Description
Captured Live and/or 
from Model Repository
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Configuration Rules

Some rules are very simple to configure and define and do not require anything more than selecting the 
server objects that you want to snapshot or audit. Some rules might check to determine whether a value 
or property exists on a configuration file on a server, without the need for setting any advanced 
parameters. 

Example: The Discovered Software rule checks for all registered and unregistered software that is 
installed or deployed on a target servers. 

Example: The Hardware rule allows you to check the CPU, memory, or storage values that exist on target 
servers. In this case, no extra rule parameters are necessary. 

Other rules are more complex and require more advanced configuration, such as specifying an expression 
that looks for a range of values and specifies remediation that replaces undesired values. 

In an audit and audit policy, you can also define what, if any, remediation value you would like the object 
to have. Remediation values are used only if a server object is found to be different than the desired 
state—where the configuration on the target server is out of compliance with the rules of the audit. 
Remediation values are implemented manually, after the audit has been run, from the Audit Result 
window.

An audit rule consists of the following components:

• Server Object: This is a specific server configuration that an audit can evaluate, such as a server’s file 
system, application configuration values, hardware information, installed software (patches and 
packages), Windows Registry entries, and so on. A server object typically consists of several other 
objects that you can check as well. 

Example: On a Windows server you want to know if a specific Windows service exists on target 
servers and whether or not it is enabled. 

• Target Value: This is a value or setting you want to check for on the target server. 

Example: For example, you might want to determine if a specific directory exists on a server, an 
application is configured properly, a particular service is enabled, and so on. 

• Remediation Value: This is the value that you want to change for the server object during 
remediation, if the target value is not found on the target server. The remediation value is not 
automatically implemented. You must make the remediation change after the audit has run. 
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Figure 5 illustrates an audit rule defined for an ESXi Server.

figure 5 Custom Audit Rule Configured with Remediation Values 

In Figure 5, the audit rule has been configured in the following manner: 

• Linked Audit Policy: Lists the audit policy.

• Rules Details

— Check - Target Value: This is the desired value compared against the value on the target of the 
audit. 

• Remediation: The remediation value determines the action to take if the value on the target server 
does not match the value you defined in the audit (target value).

— Remediation Value: Additional arguments.

— Remediation Description: Description.

• Technical Description: Describes the value that is being checked on the target server.

This information instructs the audit to evaluate the target server’s Application Event Log file size and 
determine whether it exceeds 16MB.

• Properties: Details of the Test ID, External ID, Severity Level, and list of Platforms.

Audit and Snapshot Rules

You must have permissions to create and configure Audit and Remediation rules. To obtain these 
permissions, contact your SA administrator. See the SA Administration Guide for more information on 
permissions.

For information about rules you can set for each type of server object, see one of the following sections 
for the specific server object that you want to configure a rule for:
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• Configuring the Application Configuration Rule

• Configuring the COM+ Rule

• Configuring the Custom Scripts Rule

• Configuring the Discovered Software Rule

• Configuring the File Rule

• Configuring the Hardware Rule

• Configuring the IIS Metabase Rule

• Configuring the IIS Rule

• Configuring the IIS 7.0 Rule

• Configuring the Local Security Settings Rule

• Configuring the Registered Software Rule

• Configuring the Storage Rule

• Configuring the Windows .NET Framework Configurations Rule

• Configuring the Windows Registry Rule

• Configuring the Windows Services Rule

• Configuring the Users and Groups Rule

• Configuring Compliance Checks

Some SA cores may contain legacy content, such as Event Logging, Operating System, and Users and User 
Groups rules with compliance checks. These checks have been integrated into the CIS policies available 
from the EP.

Configuring the Application Configuration Rule

The application configuration audit rule allows you to audit configuration file values on managed servers, 
to check that those files are configured the way you want them to be. 

You can choose from a list of predefined application configuration templates that serve as the basis of 
comparison for the target configuration file you want to audit. You can also choose from custom 
application configurations that a user in your organization has created and made available for usage in an 
audit, a snapshot specification, or an audit policy. 

An application configuration in an audit models the values and structure of an application’s configuration 
file. This allows you to set rules that check the values in existing configuration files on managed servers. 

When you choose an application configuration in an audit, a snapshot specification, or an audit policy and 
click View, you will see the contents of the configuration file from the source of the audit. All key-value 
pairs that you are able to add to the audit rule will display. 

The information displayed in an Audit window depends on the source of the audit or audit policy (or the 
target for a snapshot specification): 

• If you choose a server as the source of the audit or audit policy, the application configuration values 
displayed in the audit rule will be those of the configuration file on the source server, as filtered 
through the application configuration template. 

• If you choose a snapshot as the source of the audit or audit policy, you will only be able to modify the 
values that were captured at the time the snapshot was taken. 
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• If you do not choose any source, you will not be able to configure a rule for the application 
configuration file.

• If you choose to configure an application configuration in a snapshot specification, the values of the 
configuration will be derived from the target server. 

In an audit’s application configuration rule, you will only see values of the source configuration file that 
have been modelled in the application configuration. If the application configuration is customized and 
has no custom attributes defined (but the value exists in the source configuration file), you will not see it 
in the audit or audit policy. 

After you view the contents of the source application configuration file, you can define your rules by 
selecting values from the source file and building rules that will be used to check against the target 
configurations. You can also define remediation values in the event that the audit finds differences 
between the rules and the target configuration file values.

Creating an Application Configuration Rule

To understand how to configure an application configuration rule, it is helpful to look at an example. 

Example: Your goal is to create an audit rule for a UNIX hosts file (/etc/hosts) and then audit a group of 
servers’ /etc/hosts files to make sure they contain the correct values. You know that the UNIX hosts 
file on a particular golden server represents the ideal state of hosts file configuration that you would like 
other servers to conform to. You can choose that golden server as the source for your audit and borrow 
the values from that file to construct the rule for the audit. After you create the rule and save the audit, 
you can run the audit against a group of servers to see if their /etc/hosts files are configured correctly 
(according to the audit rule). 

In this example, the equals (=) operator is used. Valid operators for an application configuration rule are: 
= (equals), <> (does not equal), < (less than), <= (less than or equal to), > (greater than), >= (greater than 
or equal to), Contain, Does not contain, Match RE, and Does not match RE.

To create an application configuration rule: 

1 Create an audit from any one of the methods for creating an audit described in Creating an Audit on 
page 30. If you want to create this rule for a snapshot specification, see Creating a Snapshot 
Specification on page 126.

2 Select an Audit Source: Server, Snapshot, Snapshot Specification, or No Source. The source selected 
for the audit will determine what types of rules, if any, you can create for an application 
configuration. You must choose a source or you will not be able to configure the application 
configuration rule. 

3 In the Audit window, in the Views pane, select Rules > Application Configurations. 

4 In the content pane, click  to access all available configuration templates.

5 In the Select Configuration Templates window, select one or more templates you would like to add to 
the audit rule and then click OK.

6 Select the template you want to configure. Its contents appear in the template editor.

7 Click View to see the contents of the configuration file in the File View tab.

If you cannot see the contents of the configuration file, enter the correct path in the Filename section.
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Example: If you view a UNIX hosts file, you would see information similar to the example in Figure 6. 
You can see the contents and the IP address/host name pairs from the source hosts file (highlighted 
in blue text).

figure 6 Application Configuration Audit Rule for Hosts File 

8 To create an audit rule for this configuration file, choose a key-value pair from the hosts file on the 
source server (the server you choose as the source for the audit). 

9 To create this rule, select an IP addresses in the File View tab area. This shows the contents of the file 
obtained from the source server. In the example in Figure 6, you can select an IP address such as 
127.0.0.1. After you select the IP address, the element becomes highlighted in blue. Blue text means 
that the element is ready to have a rule created from it.

For more information on the color scheme used when configuring an application configuration audit 
rule, see Table 2.

After you have selected the IP address in the contents area, the value in the Operator field is empty. 
This means that an operator has not yet been added to the rule. To add the value to the rule, you can 
either double-click it or enter the following parameters in the rule expression area below the 
contents: 

– Operator: Choose = (equals). When you change the operator to =, the equals operator 
immediately becomes added to the rule. If you change the operator back to no selection, the 
operator is immediately removed from the rule. 

– Reference: Choose Value. 
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– Value: Enter 127.0.0.1.

– Remediate With: Enter 127.0.0.1.

This expresses that you want to look for an IP address with the value of 127.0.0.1. If this is not found, 
the remediation should be 127.0.0.1, so you can add this to any host files on the target servers that 
do not contain this IP address. 

10 Select a host name in the File View tab area. The initial IP address you selected in the previous step 
has turned green. Green text means that the next rule parameter you set will be paired with the IP 
address you previously selected.

11 In the Rule section, set the following parameters: 

– Operator: Choose = (equals).

– Reference: Choose Value. If you choose a custom attribute for the rule definition, this 
custom attribute must also exist on the target servers or the audit for this rule will fail.

– Value: Choose host.

– Remediate With: Choose host. This adds the final part of the rule that will check the target 
server for the key-value pair of the IP address 127.0.0.1 matched with host.

12 Select the Rules View tab. The rule will be expressed as: 

“Check that there is an entry where IP address is equal to value 127.0.0.1 and Hostnames contains an 
entry equal to value host.” 

This rule is what will be used to audit the hosts file on the target server or snapshot specification. 

Note: The I IP address and hostname are key-value pairs, so you must always provide an IP address and a 
Hostname together.

13 To configure more application configuration rules, select more application configurations from the 
Available for Audit section. 

14 To finish configuring the audit, define other rules and set the target servers, schedule, and 
notification for the audit. 

15 Save the audit. 

16 To run the audit, from the Actions menu, select Run audit. See Running an Audit on page 32 for 
more information.

Application Configuration Audit Rule Color Scheme

When you first view an application configuration, all elements that can be used to build an audit rule will 
appear in blue underlined text. After you start selecting and building rules, then the colors will change. 
Table 2 describes the color scheme used for configuring application configuration audit rules.    

table 3 Application Configuration Audit Rule Color Scheme 

Text Color Description

Blue underlined All elements in the source configuration file that can be used in a rule. 

Highlighted Dark Blue A selected element that does not have a rule associated with it.

Highlighted Light blue An element that has been added to a rule.

Highlighted Medium blue A selected element that has a rule associated with it.
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Configuring the COM+ Rule

To configure a Windows COM+ rule, select the source COM+ objects that you want to audit or snapshot on 
a target server. The COM+ rule also checks Access Control Levels (ACLs) for the selected object, including 
ACLs that are inherited. 

COM+ objects are categorized based on attributes of the object, where the COM+ object specifies zero or 
more categories. The audit or snapshot window displays all COM+ objects in one node in the Rules section 
of the COM+ object tree. To add a COM+ rule to the audit or snapshot, select it and then click the right 
arrow button.

If you want to be able to remediate COM+ rules in your audit or snapshot results, select the “Archive all 
associated files” option when you select the COM+ object or category. This option also includes all 
AccessPermissions and LaunchPermissions associated with the COM+ object in the audit or snapshot rule, 
including those that are inherited parent COM+ objects. 

You cannot audit the COM+ root folder. However, you can audit the COM+ individual objects or 
sub-categories.

To configure a COM+ rule: 

1 Create a new audit, using one of the methods for creating an audit described in Creating an Audit on 
page 30. If you want to create this rule for a snapshot specification, see Creating a Snapshot 
Specification on page 126.

2 Select an Audit Source: Server, Snapshot, Snapshot Specification, or No Source. Some audit rules, 
such as Application Configuration and Windows User’s and Groups, must have a source.

3 In the Audit window, from the Views pane, select Rules > COM+. 

4 In the content pane of the Audit window, expand the top level node in the Available for Audit section 
and select a COM+ object or object category. 

5 Click the right arrow button to move the COM+ object or object category into the Selected for Audit 
section. All COM+ object or object categories you select will be audited on the target servers or 
snapshot specification. You can select individual and COM+ categories for the rule. You cannot select 
the root folder to add to the audit rules.

Green An element that is a primary key, is related to the currently selected 
element, and is used in the same rule as the currently selected element.

If the currently selected element is given a comparison value (=, 
contains, matches...), the other elements with green text will 
automatically be given a comparison value of =, such as:

127.0.0.1 localhost

If localhost is selected, 127.0.0.1 would be green. If localhost is given 
a comparison value, 127.0.0.1 will also be given an automatic 
comparison value, giving you a rule such as:

There is an entry where ip is equal to 127.0.0.1 AND hostname is 
equal to localhost.

Bold A primary key.

Italicized Custom attribute or SA attribute.

table 3 Application Configuration Audit Rule Color Scheme  (cont’d)

Text Color Description
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6 Choose an option from the bottom of the rule window: 

• Select the “Archive all associated files” option if you want to be able to remediate COM+ rules in 
your audit or snapshot results. 

• Select Compare only the file name and not the full pathname if you want the COM+ rule to check 
only the selected filename and not the full path.

7 To finish configuring the audit, define any other COM+ object or object category rules you want and 
set the target servers, schedule, and notification for the audit. 

8 To save the audit, from the File menu, select Save. You can also save the Audit as a policy. For more 
information, see Saving an Audit or a Snapshot Specification as an Audit Policy on page 98.

9 To run the audit, from the Actions menu, select Run Audit. For more information about running an 
audit, see Creating an Audit Policy on page 94.

Configuring the Custom Scripts Rule

The custom scripts rule allows you to define your own script (batch, Python, or Visual Basic, and, for ESXi 
servers, only PowerShell) to retrieve and compare values used in an audit, an audit policy, or a snapshot 
specification. You can also write your own remediation scripts. 

When you configure a custom scripts rule, you specify the target value, which is the expected values you 
want the script to return. The audit can gather this information based on the following methods: 

• Comparison-Based Audit: Execute the script on the source server. The return values from the script 
(exit code or standard output) are compared with the output of the script after it has run on the target 
server or servers. This option is named Source. 

• Value-Based Audit: Specify your own value. This value is compared with the output of the script after 
it has run on the target server. You can enter this value manually, if you know what the expected 
results of the script should be, or you can execute the script on the source server and use those 
return values. When the audit is run, this value is compared with the returned results from the script 
after it has executed on the target server or servers. The option is named Value. 

For an audit, you can also configure a remediation script, which can be used if differences are found 
between the rule and the value returned after the script has run on the target server. 

For a snapshot, the script results will be generated by running the script (as defined in the rule detail) on 
target servers and then captured in the snapshot. When you set up a snapshot specification, you can also 
add a remediation script. This type of script can be used to force remediation on target servers. You can 
execute the snapshot’s remediation script on target servers on an individual server basis from the 
Snapshot window. 

To configure a custom script rule: 

1 Create the new audit using one of the methods for creating an audit in Creating an Audit on page 30. 
(If you want to create this rule for a snapshot specification, see Creating a Snapshot Specification 
on page 126.)

2 Select an Audit Source: Server, Snapshot, Snapshot Specification, or No Source. (Some audit rules, 
such as Application Configuration and Windows User’s and Groups, must have a source.)

3 To build a script and define the audit rule, you can choose the following options: 

Source

— Rules: Click Add Rule to add a new custom script rule.

— Move Up: Click Move Up to move selected audit rules up to specify the execution order for 
custom script audit rules. The audit rules are saved in the order you specify. This order displays 
when you open the audit or audit policy.
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— Move Down: Click Move Down to move selected audit rules down to specify the execution order 
for custom script audit rules. The audit rules are saved in the order you specify. This order 
displays when you open the audit or audit policy.

Rule Details

— Name: Enter a name for the script.

— Type of Script: Choose from Batch, Python, PowerShell, Visual Basic (VBS), or PowerShell for 
ESXi.

— Script: Type or copy and paste the script contents here. Or, click Import Script to import a script 
from your local drive.

Success Criteria

— Output: Either Exit Code or Standard Output.

— Operator: Choose an Operator, such as equals (=), not equals (<>), less than (<(), greater than (>), 
and so on. 

— Reference: Choose the source of the script output. 

— Source: Select this option if you want the rule to execute the script on the source when an audit is 
run, and gets the value that the script requests. It will then compare that value with the value 
retrieved from the script that was run on the target server.

If you choose this option for a snapshot specification, then the script will run on the target, 
and the results of the script execution will be captured in the snapshot (results). 

If the source of the audit is a snapshot, then the custom script rule will use the custom script 
definition configured in the snapshot specification.

— Value: Enter your own value. This option uses the value you enter and compares it with the value 
returned from the script after it is run on the target server. This option means that the script 

does not run on the source server at audit runtime. Click the  icon if you want to immediately 
get the output from the script from the source server. The returned value is displayed in the text 
box, which you can accept as is or edit as needed. 

If the source of the audit is a snapshot, the custom script rule will use the Custom Script 
definition that is configured in the snapshot specification. 

— Server Attribute: Select this option to compare a server attribute found on the source server 
with the output from the script that is run on the target server.

— Custom Attribute: Select this option to compare a custom attribute found on the target server 
with the output from the script that is run on the target server. Custom attributes for this option 
derive from the selected source server for the audit. 

If you choose a custom attribute here for the rule definition, this custom attribute must also 
exist on the target servers or the audit for this rule will fail. 

If you do not choose a source for the audit, this list will be empty. 

Remediation

— Type of Script: Choose from Batch, Python, PowerShell, Visual Basic (VB), or PowerShell for ESXi.

— Script: Type or copy and paste the script contents here. Or, click Import Script to import a script 
from your local drive.

4 (Optional) You can add a remediation script to run if the audit comparison fails. The remediation will 
not be applied automatically; you can only run the remediation script from the audit results after the 
audit has run. 
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For a snapshot, the remediation script you define here can be executed on target servers on an 
individual server basis. The execution order for remediation is not separately specified. Instead, 
remediation for selected, non-compliant rules are executed in the same order that is defined in the 
audit or audit policy. For example, if the audit policy has 10 rules and rules 2, 4, 6, and 8 are 
non-compliant, and rules 4 and 8 are selected for remediation, rule 4's remediation script will run 
first, followed by rule 8's remediation script.

5 To finish configuring the audit, set the target servers, schedule, and notification for the audit. 

6 To save the audit, from the File menu, select Save. You can also save the Audit as a policy. For more 
information, see Saving an Audit or a Snapshot Specification as an Audit Policy on page 98.

7 To run the audit, from the Actions menu, select Run audit. For more information about running an 
audit, see Creating an Audit Policy on page 94.

Custom Scripts Example

The following example is a custom VB script rule that is designed to enable a Windows user account and 
set the user’s password. This script will only work on Windows OS versions that are later than Windows NT 
4.0. If you want to enable a user account and set the password on Windows NT 4.0, you must manually 
perform the required actions.

strComputer = "."
strAccountName = "red2"
Set objUser = GetObject("WinNT://" & strComputer & "/" & strAccountName )
objUser.AccountDisabled = False
objUser.SetPassword "AiH345^hjq"
objUser.SetInfo 

Powershell / PowerCLI Scripts Example

This section shows an example of a Custom PowerShell script you can use to target ESXi hosts.

When this script executes on the managing Windows vCenter, SA will prepend and append code to:

• Enable the PowerCLI component.

• Connect or disconnect to the vCenter that manages the ESXi host targeted by the script. 

• Handle authentication. 

• Set two variables that contain the IP address (HPSA_VMHOST) and hostname (HPSA_VCENTER) of the 
ESXi target and its managing vCenter.

• Trigger compliance (exit 0) or non-compliance (exit 1).

Sample script:
Write-Host "Hello, world ! I’m targeting ESXi host “ + $HPSA_VMHOST + “ 

managed by “ + $HPSA_VCENTER + “ vCenter.”

exit 0

Additionally you can use Write-Host statements to convey additional information that can also be used to 
check compliance status.
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Configuring the Discovered Software Rule

The Discovered Software rule provides a signature-based software discovery mechanism for Windows 
and UNIX managed servers to help you audit and snapshot applications and software that are not 
managed by SA. The Discovered Software rule can:

• Discover unregistered software that is not currently managed by SA.

• Create an inventory of software that is not installed as part of an OS-registered application or that 
was custom built.

• Give you the ability to create snapshots of the discovered software on a server and then periodically 
audit against the snapshots.

• Enable you to track in-house or custom-built software.

To configure the discovered software rule:

1 Create a new audit using one of the methods in Creating an Audit on page 30. (If you want to create 
this rule for a snapshot specification, see Creating a Snapshot Specification on page 126.)

2 Select an Audit Source: Server, Snapshot, Snapshot Specification, or No Source. 

3 In the Audit window, from the Views pane, select Rules > Discovered Software. 

4 In the content pane of the Audit window, in the Available for Audit section expand the Software icon. 
This may take a few moments to load if this is the first time you are loading the rule and you have 
selected a source for the audit or snapshot. 

5 Select an element from the list and then click the right arrow button to move the rule object into the 
Selected for Audit section, which enables you to create a rule for the element. 

6 For each check you want to configure in the rule, in the lower section of the Audit window you can 
select one of the following rule criteria types: 

• Property Values: A values-based check that checks individual properties of the target object. For 
this type of check, each object requires that you build an expression that defines properties 
related to the object using the drop down lists at the bottom of the rule window. You can specify 
a unique operator which, depending on the type of object, can be a String, a Number (integer or 
float), Boolean (comparing values of ‘true’ and ‘false’), Date (a date compare, not a time of day 
compare), or an Array. 

• Equivalent to source: A comparison check that performs a one to one comparison between the 
object on the source vs. the target servers. In this type of check, the values of each property 
selected from both the source and target servers must match exactly for the object to be 
compliant.

• Non-existence: A rule that checks for the non-existence of an object to determine if it exists on 
the target server. If the object exists on the target server, the user or group rule is out of 
compliance. Note that, at runtime, the source server, if any, is not queried.  Also, if a Wildcard 
rule object is selected, it will only apply to the target server.

7 You can also configure the rule based on a wildcard search by selecting the Wildcard rule object . 
When you select this object, in the rule configuration section at the bottom of the window displays a 
Name field, into which you can type a name (primary key) that will be searched on the target server.

For example, you could enter simply * which would match everything on the target, P* would match 
all objects that begin with a capital P, while *P would match all elements ending with uppercase 
character 'P'. 
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After you enter a name or wildcard string, you can configure the rule parameters as you did in step 6. 

It is important to notice that when using wildcard, all matching objects are restricted by the rule 
configuration. This type of audit rule is considered compliant if all found objects match the rule 
parameters. 

8 To finish configuring the audit, set the target servers, any rule exceptions, the schedule, and the 
notification for the audit. 

9 To save the audit, from the File menu, select Save. You can also save the Audit as a policy, which 
enables other users to access the rule set you create in the audit. For more information, see Saving 
an Audit or a Snapshot Specification as an Audit Policy on page 98.

10 To run the audit, from the Actions menu, select Run Audit. For more information about running an 
audit, see Running an Audit on page 32.

Configuring the File Rule

The file rule allows you to audit and compare files and directories on a target server by specifying the 
following options:

• Directory Name: The absolute path of the selected file or directory.

 (Optional) You can add a reference to an environment variable (${varName}) or a custom 
attribute (@varName@). See Parameterizing Filenames for SA/Custom Attributes on page 88 
and Environment Variables in Pathnames on page 90.

• Scope: The default scope is directories + files. The Scope Example diagram in the Directory Options 
pane shows the scope use case hierarchy that is based on the options you selected. This diagram 
does not show exclusions. Click View Exclusions to view exclusions in the Set Includes/Excludes 
window.

Recurse Directory Structure—Includes contents of all subdirectories for a selected file system 
folder to the audit, such as directories + files (recursive), files only (recursive), and directories 
only (recursive).

Include Directory(s)—Specify directories in the file system you want included in and excluded 
from the audit. See File Inclusion and Exclusion Rules on page 84. 

[Include Files—Specify files in the file system you want included in and excluded from the audit. 
See File Inclusion and Exclusion Rules on page 84.

The following list identifies 8 common use cases, in priority order. See the following Common Scope 
Cases with Diagrams:

Scope Case 1: Directories + Files (recursive) on page 60

Scope Case 2: Directories + Files (default) on page 60

Scope Case 3: Files Only on page 61

Scope Case 4: Files (recursive) on page 61

Scope Case 5: Directories (recursive) on page 61

Scope Case 6: Directory Only on page 62

Scope Case 7: Directories Only on page 62

Scope Case 8: Recursive Only on page 62



• Check Differences: 

By Properties

Checksum: Performs a checksum on the contents of the selected file or files in a directory. 
You can choose to audit the entire contents of the file (Full) or only the first 1MB of the file 
(Partial).

Modification Date: Audits the file modification date to use for file or folder comparison.

User and Group Access Rights (Unix only): Audits the user and group access related to the 
file and directories.

Windows ACLs (Windows only): Audits the Windows Access Control List (ACL) for files and 
directories.

Note: If you are checking ACLs for the file rules and the user and group ACL does not exist on 
the target, after the audit and remediation processes complete, a temporary user and group 
will be created and assigned an unknown name. The next time you run an audit, the user and 
group displays as unknown. For more information on remediation, see Audit Results on 
page 100.

Version Numbers: For certain Windows file types (.exe, .dll, .ocx, .olb, .scr, .rll, .sys, .drv, 
.acm), the author of the file can set a file version and a product version. This option 
compares these version numbers. If they are different, the rule is considered non-compliant 
and the actual values on the target file can be viewed in the audit results. 

Note: Not all files with these extensions always have a product version or a file version 
attribute.

Archive Files for Remediation: Archives the entire file. This option enables the audit to 
check for differences of a specified file, based on the differences you specify in the rule. Use 
this option when you want to remediate and view file differences found between the rule 
and the target file. If differences are found, remediating the differences will copy the source 
file to the target server and replace the target file with the source. 

Note: This option can potentially create disk space demands on the SA core’s database, 
depending on the size and number of files being compared. There is a hard limit (2 GB by 
default) on the amount of data that can be captured. This feature is intended to be used on a 
small set of configuration files, not large binaries.

By Application Configuration Value Sets: Uses an application configuration to evaluate 
configuration files on a target server. This option (including the Advanced Association Settings) 
lets you use a configuration template to compare any differences in values between a source 
configuration file and one on a target server. See Comparing Files in Audits with Configuration 
Templates on page 65.

• Remediation Summary: Remediate by copying the file and its properties from the source when 
selected properties do not match.
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Common Scope Cases with Diagrams

The following examples show Windows directory options for each type of scope use case and related file 
system diagrams. For Windows, the Windows ACLs option is available. For Unix, the User and Group 
Access Rights option is available.

• Scope Case 1: Directories + Files (recursive) on page 60

• Scope Case 2: Directories + Files (default) on page 60

• Scope Case 3: Files Only on page 61

• Scope Case 4: Files (recursive) on page 61

• Scope Case 5: Directories (recursive) on page 61

• Scope Case 6: Directory Only on page 62

• Scope Case 7: Directories Only on page 62

• Scope Case 8: Recursive Only on page 62

Figure 7 is an example of options required for Directories + Files (recursive).

figure 7 Scope Case 1: Directories + Files (recursive)

Figure 8 is an example of options required for Directories + Files. These are the default options.

figure 8 Scope Case 2: Directories + Files (default)
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Figure 9 is an example of options required for Files Only.

figure 9 Scope Case 3: Files Only

Figure 10 is an example of options required for Files (recursive). 

figure 10 Scope Case 4: Files (recursive)

Figure 11 is an example of options required for Directories (recursive). 

figure 11 Scope Case 5: Directories (recursive)
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Figure 12 is an example of options required for Directory Only.

figure 12 Scope Case 6: Directory Only

Figure 13 is an example of options required for Directories Only.

figure 13 Scope Case 7: Directories Only

Figure 14 is an example of options required for Recursive Only.

figure 14 Scope Case 8: Recursive Only
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Ways to Add a Rule to an Audit

There are several ways you can add a rule to an audit.

You can:

• (Recommended) Link to an existing audit policy. See Linking an Audit Policy to an Audit or a 
Snapshot Specification on page 96 and Linking Audit Policies to a Master Audit Policy on page 97.

• Import an audit policy. See Importing Audit Policy Rules on page 98. 

• Select a rule inside an audit.

To configure a file rule:

1 Create the new audit using one of the methods in Creating an Audit on page 30. If you want to create 
this rule for a snapshot specification, see Creating a Snapshot Specification on page 126.

2 Specify the source of the reference data against which target values will be compared.

Best Practice: The source should represent the ideal configuration of the server or its applications.

g In the Audit window, in the Views pane, select Source.

h In the Source pane, specify the source of the reference data against which target values will be 
compared, such as No Source, Server, Snapshot-One for All Targets, or Snapshot 
Specification-Most Recent per target. If you select a snapshot, you will only be able to compare 
those files captured in the snapshot. Some audit rules, such as Application Configurations and 
Windows Users and Groups, must have a source.

Depending on which Source you select, one of the following windows appears:

If you select Server, the Select Server window appears.

If you select Snapshot-One for All Targets, the Select Snapshot window appears.

If you select Snapshot Specification-Most Recent per target, the Select Snapshot 
Specification window appears.

i Make your selection and click OK to save your settings and close the selection window.

3 Select the file rule:

a In the Audit window, in the Views pane, select Rules > Files.

(Recommended) In the Rules content pane, click  to open the Select an Audit Policy window. 
Select a policy and then click OK.

Best Practice: This selection allows you to create a linked rule, which is a link to a existing audit policy. 
This means that any changes made to the policy will also be reflected in this audit rule.

Or

b (Optional) If you want to create an unlinked rule, check Enable unlinked rules (prevents linking 
to predefined audit policies).

In the Rules content pane, click Import Rules to open the Select an Audit Policy window. Select a 
policy and then click OK. 
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Or

c (Optional) In an audit or audit policy, check Enable unlinked rules (prevents linking to 
predefined audit policies). 

Click  to open the Select Files window. Expand the file system and select files or directories. 
Click OK to add selected rules to the audit.

4 Select the files and directories you want to audit:

a In the Audit window, in the Views pane, select Rules > Files.

In the Source Server content pane, click  to open the Select Files window. 

b In the Available for Audit section, expand the top level node and select a folder or file to apply the 
rule to.

c Make your selections and then click Select to save your settings and close the Select Files 
window.

Or

a In the Audit window, in the Views pane, select Rules > Files.

In the Source Server content pane, select a file or directory to modify the File Options or the 
Directory Options in the details pane.

b (Optional) For folders, you can select a file/directory wildcard option to specify files and 
directories that you want to include or exclude from the audit. 

c Click  to add a new rule or click  to remove a rule. For more information on how to enter 
files and directories and how this affects the audit, see File Inclusion and Exclusion Rules on 
page 84. 

5 (Optional) If you want to use an application configuration to compare configuration files, select By 
Application Configuration Value Sets and then click Advanced Association Settings. 

In the AppConfig File Comparison Associations window, in the AppConfig Templates list, select the 
template you want to use to compare a source and a target configuration file. In the Associated Files 

section, use the default path to the source configuration file or edit the path. Click  to add 
another path to a source configuration file that you want to compare with a configuration file on the 
target. 

When you are finished, click OK.

6 To finish configuring the audit, set the target servers, schedule, and notification for the audit. 

7 To save the audit, from the File menu, select Save. You can also save the Audit as a policy. For more 
information, see Saving an Audit or a Snapshot Specification as an Audit Policy on page 98.

8 To run the audit, from the Actions menu, select Run Audit. For more information about running an 
audit, see Creating an Audit Policy on page 94.

Note: Use the Refresh button to refresh the Select Files screen. 
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Comparing Files in Audits with Configuration Templates

Another way you can audit files on a target server is to compare them with a source server file, using 
application configuration (AppConfig) templates as the basis of the comparison. 

Configuration templates model the structure of a configuration file and determine its contents and 
organization. When you use configuration templates in an audit’s file rule to compare files, the audit uses 
the configuration template to filter both the source and the target files’ contents for the comparison. This 
ensures that you are comparing only the value sets defined in the template when you run the audit and 
compare the files. 

For example, you might want to compare the /etc/passwd file on several target servers to make sure 
they contain only the values defined in the /etc/passwd file on a golden server that you know has 
acceptable values. Using the configuration file comparison feature, you select a configuration template 
that models the /etc/passwd file (passwd.tpl) and associate that configuration template with the 
actual passwd file on both the golden source server and the servers that are targeted by the audit. 

You create the association by selecting the template and then by entering the file pathname to where the 
file exists on the target servers. You can also compare multiple files using this feature. For example, you 
can select a directory that you know contains several configuration files to compare and you can 
associate configuration templates with directories you know contain the files you want to compare. 

To use the configuration file comparison feature in an audit:

1 Create the new audit using one of the methods in Creating an Audit on page 30.

2 Specify the source of the reference data against which target values will be compared.

Best Practice: The source should represent the ideal configuration of the server or its applications.

a In the Audit window, in the Views pane, select Source.

b In the Source pane, specify the source of the reference data against which target values will be 
compared, such as No Source, Server, Snapshot-One for All Targets, or Snapshot 
Specification-Most Recent per target. If you select a snapshot, you will only be able to compare 
those files captured in the snapshot. Some audit rules, such as Application Configurations and 
Windows Users and Groups, must have a source.

Depending on which Source you select, one of the following windows appears:

If you select Server, the Select Server window appears.

If you select Snapshot-One for All Targets, the Select Snapshot window appears.

If you select Snapshot Specification-Most Recent per target, the Select Snapshot 
Specification window appears.

c Make your selection and click OK to save your settings and close the selection window.

3 In the Audit window, in the Views pane, select Rules > Files. 

4 In the Audit window, in the details pane, select By Application Configuration Value Sets and then 
click Advanced Association Settings.

5 In the AppConfig File Comparison Associations window, in the AppConfig Templates list, select the 
template you want to use to compare a source and a target configuration file. In the Associated Files 

section, use the default path to the source configuration file or edit the path. Click  to add 
another path to a source configuration file that you want to compare with a configuration file on the 
target. 

6 In the Associated Files section, enter the pathname to where the actual source and target 
configuration file exists on both the source and the target servers. 
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Note: The files you want to compare with the configuration template must exist in the same 
directory.

7 (Optional) If you want to make more than one association for a template, click  to add another 
directory. Each directory you add applies to whatever template you have selected in the AppConfig 
Templates section. You can make as many associations as you want in this window. 

8 When you are finished, click OK.

9 To finish configuring the audit, set the target servers, the schedule, and the notification for the audit. 

10 To save the audit, from the File menu, select Save. You can also save the Audit as a policy. For more 
information, see Saving an Audit as an Audit Policy on page 95.

11 To run the audit, from the Actions menu, select Run Audit. For more information about running an 
audit, see Creating an Audit Policy on page 94. 

Configuring the Hardware Rule

Configuring a hardware rule allows you to audit the following information about a server’s hardware: 

• Interfaces: Compares duplex mismatch and all network interfaces on a server.

• CPU: Compare CPU type and specification of target server.

• Memory: Compare memory of the target server.

• Storage: Compare storage capacity on the target server. 

• Interfaces: Compare all network interfaces attached to the device. 

If you are auditing or taking a snapshot of the Hardware rule on a server that just recently had the SA 
Agent installed on it, it is possible that the hardware has not been fully registered with the Model 
Repository, and you will not be able to audit or snapshot accurate hardware information. (The SA Agent 
registers hardware usually within 24 hours after agent installation.) If you are not sure, contact your SA 
Administrator or the person who installed the SA Agent on the server. See the SA User Guide: Server 
Automation for instructions on how to register a server's hardware manually.

To configure hardware rules: 

1 Create the new audit using one of the methods for creating an audit listed in Creating an Audit on 
page 30. (If you want to create this rule for a snapshot specification, see Creating a Snapshot 
Specification on page 126.)

2 Select an Audit Source: Server, Snapshot, Snapshot Specification, or No Source. (Some audit rules, 
such as Application Configuration and Windows User’s and Groups, must have a source.)

3 In the Audit window, from the Views pane, select Rules > Hardware. 

4 In the content pane of the Audit window, expand the top level node in the Available for Audit section 
and select a hardware category to create a rule for. 

5 Click the right arrow button to move the hardware item into the Selected for Audit section. All items 
that you select will be used to audit or snapshot the target server.

6 To finish configuring the audit, set the target servers, the schedule, and the notification for the audit. 

7 To save the audit, from the File menu, select Save. You can also save the Audit as a policy. For more 
information, see Saving an Audit or a Snapshot Specification as an Audit Policy on page 98.

8 To run the audit, from the Actions menu, select Run Audit. For more information about running an 
audit, see Creating an Audit Policy on page 94.
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Configuring the IIS Metabase Rule

The IIS Metabase audit rule allows you to select IIS Metabase objects and objects folders to compare in 
your audit. The audit will capture IIS Metabase object property information such as ID, name, path, 
attributes, and so on. 

If you are checking ACLs for Metabase rule, and the user and group ACL does not exist, then after the audit 
is run and after remediation, if user and group does not exist on target a temporary user and group will be 
created as unknown name. The next time you run the audit, it shows up as unknown, which shows name 
other than the source user. 

Additionally, if you create an IIS Metabase rule from a source server and the metabase object selected for 
the rule inherits its values from a parent Metabase object, differences will show after an audit is run. For 
example, if you remediate once and then rerun the audit, if the source key was not inherited and the 
attribute has an IED when it gets created on target server, the object will be created based on parent key 
inheritance. When you rerun the audit, the results will show the IED as a difference for the object's 
attribute.

For more information on remediation, see Audit Results on page 100.

If you want to audit Microsoft IIS 7.0 on a Windows Server 2008 server, create and configure the IIS 7.0 
rule in your audit. See Configuring the IIS 7.0 Rule on page 69.

To configure IIS Metabase rules:

1 Create the new audit using one of the methods for creating an audit listed at Creating an Audit on 
page 30. (If you want to create this rule for a snapshot specification, see Creating a Snapshot 
Specification on page 126.)

2 Select an Audit Source: Server, Snapshot, Snapshot Specification, or No Source. (Some audit rules, 
such as Application Configuration and Windows User’s and Groups, must have a source.)

3 In the Audit window, from the Views pane, select Rules > IIS Metabase. 

4 In the content pane of the Audit window, expand the top level node in the Available for Audit section 
and select an IIS Metabase folder or object to create a rule for. (You can select any metabase folder or 
object for the rules, but you cannot select the root folder to use as a rule.)

5 Click the right arrow button to move the IIS Metabase folder or object into the Selected for Audit 
section. All items you select will be used to audit or snapshot the target server.

6 To finish configuring the audit, set the target servers, the schedule, and the notification for the audit. 

7 To save the audit, from the File menu, select Save. You can also save the Audit as a policy. For more 
information, see Saving an Audit or a Snapshot Specification as an Audit Policy on page 98.

8 To run the audit, from the Actions menu, select Run Audit. For more information about running an 
audit, see Creating an Audit Policy on page 94.
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Configuring the IIS Rule

The Microsoft Internet Information Server rule allow you to use real time information about IIS for your 
audit, such as a Windows server, such as server name, server type, server state, log file path, document 
file path, and so on.

To configure the Internet Information Server rule:

1 Create the new audit using one of the methods in Creating an Audit on page 30. (If you want to 
create this rule for a snapshot specification, see Creating a Snapshot Specification on page 126.)

2 Select an Audit Source: Server, Snapshot, Snapshot Specification, or No Source. (Some audit rules, 
such as Application Configuration and Windows User’s and Groups, must have a source.)

3 In the Audit window, from the Views pane, select Rules  >  Internet Information Server. 

4 In the content pane of the Audit window, expand the top level node in the Available for Audit section 
and select an Internet Information Server rule that you want to create a rule from. 

5 Click the right arrow button to move the rule object into the Selected for Audit section. All Internet 
Information Server rules that you configure will be audited on the target servers or snapshot 
specification. 

6 For each rule, select one of the following check types: 

• Property Values: A values-based check that checks individual properties of the target object. For 
this type of check, each object requires that you build an expression that defines properties 
related to the object using the drop down lists at the bottom of the rule window. You can specify 
a unique operator which, depending on the type of object, can be a String, a Number (integer or 
float), Boolean (comparing values of ‘true’ and ‘false’), Date (a date compare, not a time of day 
compare), or an Array. 

• Equivalent to source: A comparison check that performs a one to one comparison between the 
object on the source vs. the target servers. In this type of check, the values of each property 
selected from both the source and target servers must match exactly for the object to be 
compliant.

• Non-existence: A rule that checks for the non-existence of an object to determine if it exists on 
the target server. If the object exists on the target server, the user or group rule is out of 
compliance. Note that, at runtime, the source server, if any, is not queried.  Also, if a Wildcard 
rule object is selected, it will only apply to the target server.

7 You can also configure a rule based on a wildcard search by selecting the Wildcard rule object . 
When you select this object, in the rule configuration section at the bottom of the window displays a 
Name field, into which you can type a name (primary key) that will be searched on the target server.

For example, you could enter simply * which would match everything on the target, P* would match 
all objects that begin with a capital P, while *P would match all elements ending with uppercase 
character 'P'. 

After you enter a name or wildcard string, you can configure the rule parameters as you did in step 6. 

It is important to notice that when using wildcard, all matching objects are restricted by the rule 
configuration. This type of audit rule is considered compliant if all found objects match the rule 
parameters. 

8 To finish configuring the audit, set the target servers, any rule exceptions, the schedule, and the 
notification for the audit. 

9 To save the audit, from the File menu, select Save. You can also save the Audit as a policy. See Saving 
an Audit or a Snapshot Specification as an Audit Policy on page 98.

10 To run the audit, from the Actions menu, select Run Audit. See Creating an Audit Policy on page 94.
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Configuring the IIS 7.0 Rule

In SA 9.10, you can create audit and snapshot specification rules for Microsoft IIS 7.0 running on Windows 
Server 2008. You can expand and browse IIS 7.0 Application Pools, Web Sites, and features and add them 
to your audits or snapshot specifications to determine whether they meet your organization’s compliance 
standards. After your audit or snapshot has run, you can view the results and remediate any discrepancies 
found (with some exceptions).

For example, you might want to audit several Windows Server 2008 servers running IIS 7.0 to make sure 
that Anonymous Authentication is enabled on each server.

To perform this compliance check, select a Windows Server 2008 server that has Anonymous 
Authentication enabled to be the source server of the audit. Then, configure the audit rule to check that 
Anonymous Authentication is enabled on all servers targeted by the audit.

When you run the audit (which you can schedule on a recurring basis), the rule will check the target 
servers and discover if any do not have Anonymous Authentication enabled. If the audit finds any 
discrepancies, you can remediate those servers to enable their IIS 7.0 Anonymous Authentication.

Note: You cannot remediate ISAPI filters for the IIS 7.0 audit rule in this release. 

To configure the IIS 7.0 rule:

1 Create a new audit using one of the methods in Creating an Audit on page 30. (If you want to create 
this rule for a snapshot specification, see Creating a Snapshot Specification on page 126.)

2 Select an Audit Source: Server, Snapshot, Snapshot Specification, or No Source. 

Some audit rule types, such as Application Configuration and Windows User’s and Groups, must have 
a source server on which to base the rule. Some specific rules and criteria, such as checking IIS 7.0 
Anonymous Authentication, also require that you select a source server. If you do not select a source 
server, you will be limited on the specificity of the rule. 

3 In the Audit window, from the Views pane, select Rules > IIS 7.0. 

4 In the content pane of the Audit window, in the Available for Audit section expand one of the IIS 7.0 
elements you want to create a rule for, such as Application Pools, Sites, or Features. This may take a 
few moments to load if this is the first time you are loading one of the elements. 

5 Select an element from the list and then click the right arrow button to move the rule object into the 
Selected for Audit section, which enables you to create a rule for the element. For example, you could 
expand the Authentication folder and select Anonymous Authentication, then click the right arrow 
button to add the selection to your audit. 

6 For each rule, in the lower section of the Audit window, select one of the following rule criteria types: 

• Property Values: Values-based check that checks individual properties of the target object. For 
this type of check, each object requires that you build an expression that defines properties 
related to the object using the drop down lists at the bottom of the rule window. You can specify 
a unique operator which, depending on the type of object, can be a String, a Number (integer or 
float), Boolean (comparing values of ‘true’ and ‘false’), Date (a date compare, not a time of day 
compare), or an Array. 

• Equivalent to source: Comparison check that performs a one to one comparison between the 
object on the source vs. the target servers. In this type of check, the values of each property 
selected from both the source and target servers must match exactly for the object to be 
compliant.

Remediation of the IIS 7.0 rule is possible only when an audit is setup with the Equivalent to 
source check.
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• Non-existence: A rule that checks for the non-existence of an object to determine if it exists on 
the target server. If the object exists on the target server, the user or group rule is out of 
compliance. Note that, at runtime, the source server, if any, is not queried.  Also, if a Wildcard 
rule object is selected, it will only apply to the target server.

For example, if you wanted to check that a target server (or multiple servers) running IIS 7.0 has 
Anonymous Authentication enabled, in the bottom of the Audit window, you would select:

• Property Values

• Status

• =

• Enabled

This tells the audit to find out if each target server’s IIS 7.0 Anonymous Authentication is enabled.

7 You can also configure a rule based on a wildcard search by selecting the Wildcard rule object . 
When you select this object, in the rule configuration section at the bottom of the window displays a 
Name field, into which you can type a name (primary key) that will be searched on the target server.

For example, you could enter an asterisk (*), which would match everything on the target. P* would 
match all objects that begin with a capital P, while *P would match all elements ending with 
uppercase character 'P'. 

After you enter a name or wildcard string, you can configure the rule parameters as you did in step 6. 

It is important to notice that when using wildcard, all matching objects are restricted by the rule 
configuration. This type of audit rule is considered compliant if all found objects match the rule 
parameters. 

8 To finish configuring the audit, set the target servers, any rule exceptions, the schedule, and the 
notification for the audit. 

9 To save the audit, from the File menu, select Save. You can also save the Audit as a policy, which 
enables other users to access the rule set you create in the audit. See Saving an Audit or a Snapshot 
Specification as an Audit Policy on page 98.

10 To run the audit, from the Actions menu, select Run Audit. See Running an Audit on page 32.

Configuring the Local Security Settings Rule

The Local Security Settings rule allows you to use real time information about security settings, such as 
password policy, audit policy, user rights, and security options in your rule. 

To configure the Local Security Settings rule:

1 Create the new audit using one of the methods in Creating an Audit on page 30. (If you want to 
create this rule for a snapshot specification, see Creating a Snapshot Specification on page 126.)

2 Select an Audit Source: Server, Snapshot, Snapshot Specification, or No Source. (Some audit rules, 
such as Application Configuration and Windows User’s and Groups, must have a source.)

3 In the Audit window, from the Views pane, select Rules >Local Security Settings. 

4 In the content pane of the Audit window, expand the top level node in the Available for Audit section 
and select an Internet Information Server rule that you want to create a rule from. 

5 Click the right arrow button to move the rule object into the Selected for Audit section. All Internet 
Information Server rules that you configure will be audited on the target servers or snapshot 
specification. 
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6 For each rule, select one of the following check types: 

• Property Values: A values-based check that checks individual properties of the target object. For 
this type of check, each object requires that you build an expression that defines properties 
related to the object using the drop down lists at the bottom of the rule window. You can specify 
a unique operator which, depending on the type of object, can be a String, a Number (integer or 
float), Boolean (comparing values of ‘true’ and ‘false’), Date (a date compare, not a time of day 
compare), or an Array. 

• Equivalent to source: A comparison check that performs a one to one comparison between the 
object on the source vs. the target servers. In this type of check, the values of each property 
selected from both the source and target servers must match exactly for the object to be 
compliant.

• Non-existence: Checks for the non-existence of an object, to determine if it does not exist on the 
target server. If the object exists on the target server, then the rule is out of compliance. For 
example, you could check a server to make sure it does not contain a specific COM+ object. Note 
that, at runtime, the source server, if any, is not queried.  Also, if a Wildcard rule object is 
selected, it will only apply to the target server.

7 You can also configure a rule based on a wildcard search by selecting the Wildcard rule object . 
When you select this object a Name field displays in the rule configuration section at the bottom of 
the window. Enter a name (primary key) that will be searched on the target server.

For example, you could enter simply * which would match everything on the target, P* would match 
all objects that begin with a capital P, while *P would match all elements ending with uppercase 
character 'P'. 

After you enter a name or wildcard string, you can configure the rule parameters as you did in step 6. 

It is important to notice that when using wildcard, all matching objects are restricted by the rule 
configuration. This type of audit rule is considered compliant if all found objects match the rule 
parameters. 

8 To finish configuring the audit, set the target servers, any rule exceptions, the schedule, and the 
notification for the audit. 

9 To save the audit, from the File menu, select Save. You can also save the Audit as a policy. See Saving 
an Audit or a Snapshot Specification as an Audit Policy on page 98.

10 To run the audit, from the Actions menu, select Run Audit. See Running an Audit on page 32.

Configuring the Registered Software Rule

The Registered Software rule allows you to audit use all installed packages or patches actually installed 
on a source server to build your rule, whether or not the patches or packaged have been registered by the 
SA model repository. 

To configure the Registered Software rule:

1 Create the new audit using one of the methods in Creating an Audit on page 30. (If you want to 
create this rule for a snapshot specification, see Creating a Snapshot Specification on page 126.)

2 Select an Audit Source: Server, Snapshot, Snapshot Specification, or No Source. (Some audit rules, 
such as Application Configuration and Windows User’s and Groups, must have a source.)

3 In the Audit window, from the Views pane, select Rules  >  Registered Software. 

4 In the content pane of the Audit window, expand the top level node in the Available for Audit section 
and select a patch or a package that you want to create a rule from. 
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5 Click the right arrow button to move the rule object into the Selected for Audit section. All rules that 
you configure will be audited on the target servers or snapshot specification. 

6 For each rule, select one of the following check types: 

• Property Values: A values-based check that checks individual properties of the target object. For 
this type of check, each object requires that you build an expression that defines properties 
related to the object using the drop down lists at the bottom of the rule window. You can specify 
a unique operator which, depending on the type of object, can be a String, a Number (integer or 
float), Boolean (comparing values of ‘true’ and ‘false’), Date (a date compare, not a time of day 
compare), or an Array. 

• Equivalent to source: A comparison check that performs a one to one comparison between the 
object on the source vs. the target servers. In this type of check, the values of each property 
selected from both the source and target servers must match exactly for the object to be 
compliant.

• Non-existence: A rule that checks for the non-existence of an object to determine if it exists on 
the target server. If the object exists on the target server, the user or group rule is out of 
compliance. Note that, at runtime, the source server, if any, is not queried.  Also, if a Wildcard 
rule object is selected, it will only apply to the target server.

7 You can also configure a rule based on a wildcard search by selecting the Wildcard rule object . 
When you select this object, a Name field displays in the rule configuration section at the bottom of 
the window. Enter a name (primary key) that will be searched on the target server.

For example, you could enter an asterisk (*) that would match everything on the target. P* would 
match all objects that begin with a capital P, while *P would match all elements ending with 
uppercase character 'P'. 

After you enter a name or wildcard string, you can configure the rule parameters as you did in step 6. 

It is important to notice that when using wildcard, all matching objects are restricted by the rule 
configuration. This type of audit rule is considered compliant if all found objects match the rule 
parameters. 

8 To finish configuring the audit, set the target servers, any rule exceptions, the schedule, and the 
notification for the audit. 

9 To save the audit, from the File menu, select Save. You can also save the Audit as a policy. See Saving 
an Audit or a Snapshot Specification as an Audit Policy on page 98.

10 To run the audit, from the Actions menu, select Run Audit. See Running an Audit on page 32.

Configuring the Storage Rule

The storage rule allows you audit servers for storage devices and SAN devices and connections in your 
data center, if your core is configured to connect to SE. 

In order to audit and snapshot SAN objects, Storage Essentials (SE) version 6.1.1 or later is required and 
the Server Automation SE Connector component must be installed and configured on your SA core. For 
more information, see your SA administrator or the Storage Visibility and Automation documentation.

To configure the storage rule:

1 Create the new audit using one of the methods in Creating an Audit on page 30. (If you want to 
create this rule for a snapshot specification, see Creating a Snapshot Specification on page 126.)

2 Select an Audit Source: Server, Snapshot, Snapshot Specification, or No Source. (Some audit rules, 
such as Application Configuration and Windows User’s and Groups, must have a source.)
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3 In the Audit window, from the Views pane, select Rules > Storage. 

4 In the content pane of the Audit window, expand the top level node in the Available for Audit section 
and select a Storage rule that you want to create a rule from. Each storage audit rules check for the 
acceptable values for each category. You can configure the rule to check for minimum, maximum, or 
exact numbers.

• Unmounted Volume Capacity: Acceptable total capacity of unmounted volumes in bytes.

• Unmounted Volume Count: Acceptable number of unmounted volumes.

• Fabrics: Acceptable number of fabrics.

• FCA: Acceptable number of Fibre Channel Adapters (FCAs).

• Initiator Ports: Acceptable number of initiator ports

• Switches: Acceptable number of SAN switches.

• Target Ports: Acceptable number of target ports.

• RAID Types: Acceptable RAID types on the target storage array. (Note: The audit will fail if this 
rule is selected and no RAID type is specified.)

The compliance rules that involve ports, switches, or fabrics, check active ports only. These types of 
compliance rules do not check for physical port connectivity. 

5 Click the right arrow button to move the rule object into the Selected for Audit section. All storage 
rules that you configure will be audited on the target servers or snapshot specification. 

6 For each rule, select one of the following check property: 

• An operator, such as equal to (=), less than (<), less than or equals to (<=), and so on. 

• A value, depending on the rule type, such as a number. 

7 To finish configuring the audit, set the target servers, any rule exceptions, the schedule, and the 
notification for the audit. 

8 To save the audit, from the File menu, select Save. You can also save the Audit as a policy. See Saving 
an Audit or a Snapshot Specification as an Audit Policy on page 98.

9 To run the audit, from the Actions menu, select Run Audit. See Running an Audit on page 32.

Configuring the Windows .NET Framework Configurations Rule

The Windows .NET Framework Configuration rule allows you to use time information about Assembly 
Cache and Configured Assembly List, such as assembly name, version, locale, public key token, cache file 
(GAC or ZAP), processor architecture, custom, and file name in your audits. 

To configure the Windows .NET Framework Configuration rule:

1 Create the new audit using one of the methods in Creating an Audit on page 30. (If you want to 
create this rule for a snapshot specification, see Creating a Snapshot Specification on page 126.)

2 Select an Audit Source: Server, Snapshot, Snapshot Specification, or No Source. (Some audit rules, 
such as Application Configuration and Windows User’s and Groups, must have a source.) 

3 In the Audit window, from the Views pane, select Rules > Windows .NET Framework Configuration. 

4 In the content pane of the Audit window, expand the top level node in the Available for Audit section 
and select a Windows .NET Framework Configuration rule that you want to create a rule from. 
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5 Click the right arrow button to move the rule object into the Selected for Audit section. All Windows 
.NET Framework Configuration rules that you configure will be audited on the target servers or 
snapshot specification. 

6 For each rule, select one of the following check types: 

• Property Values: A values-based check that checks individual properties of the target object. For 
this type of check, each object requires that you build an expression that defines properties 
related to the object using the drop down lists at the bottom of the rule window. You can specify 
a unique operator which, depending on the type of object, can be a String, a Number (integer or 
float), Boolean (comparing values of ‘true’ and ‘false’), Date (a date compare, not a time of day 
compare), or an Array. 

• Equivalent to source: A comparison check that performs a one to one comparison between the 
object on the source vs. the target servers. In this type of check, the values of each property 
selected from both the source and target servers must match exactly for the object to be 
compliant.

• Non-existence: A rule that checks for the non-existence of an object to determine if it exists on 
the target server. If the object exists on the target server, the user or group rule is out of 
compliance. Note that, at runtime, the source server, if any, is not queried.  Also, if a Wildcard 
rule object is selected, it will only apply to the target server.

7 You can also configure a rule based on a wildcard search by selecting the Wildcard rule object . 
When you select this object, in the rule configuration section at the bottom of the window displays a 
Name field, into which you can type a name (primary key) that will be searched on the target server.

For example, you could enter an asterisk (*) that would match everything on the target. P* would 
match all objects that begin with a capital P, while *P would match all elements ending with 
uppercase character 'P'. 

After you enter a name or wildcard string, you can configure the rule parameters as you did in step 6. 

It is important to notice that when using wildcard, all matching objects are restricted by the rule 
configuration. This type of audit rule is considered compliant if all found objects match the rule 
parameters. 

8 To finish configuring the audit, set the target servers, any rule exceptions, the schedule, and the 
notification for the audit. 

9 To save the audit, from the File menu, select Save. You can also save the Audit as a policy. See Saving 
an Audit or a Snapshot Specification as an Audit Policy on page 98.

10 To run the audit, from the Actions menu, select Run Audit. See Running an Audit on page 32.

Configuring the Windows Registry Rule

Windows Registry rules are comparison-based rules that enable you to select a Windows Registry key or 
folder from the source of the audit or snapshot specification, and then compare them with the target 
servers. The audit compares the selected registry folders and keys, and then determines whether these 
keys and folders exist on the target servers. You cannot set a target or remediation value in the rule. 

Windows Registry Object

The Windows Registry object allows you to capture registry keys, registry values, and subkeys. A registry 
key is a directory that contains registry values, where registry values are similar to files within a directory. 
A subkey is similar to a subdirectory. The SA Client supports the following Windows Registry keys: 
HKEY_CLASSES_ROOT, HKEY_CURRENT_CONFIG, HKEY_LOCAL_MACHINE, and HKEY_USERS.
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Valid control characters audited and captured for the contents of the key entry (Data) include: #x9, #xA, 
[#xD, #x20-#xD7FF], [#xE000-#xFFFD], and [#x10000-#x10FFFF]. Invalid control characters cannot be 
stored by the SA Client and will be converted to XML entities that will display as &#;. For example, if the 
data value is 00 00 (in bytes), &#x00; will display in the audit or snapshot specification results.

Access Control Levels (ACLs)

You can also choose to compare Access Control Levels (ACLs) for a Windows Registry rule. If you are 
checking ACLs for a Windows Registry rule where the user and group ACL does not exist, after the audit is 
run and after remediation, if a user and group does not exist on the target, a temporary user and group 
will be created using an unknown name. The next time you run the audit it shows up as unknown, which is 
not the name of the source user. See Audit Results on page 100 for more information.

To configure Windows Registry audit rules: 

1 Create a new audit. See Creating an Audit on page 30 for ways to create an audit. 

(Optional) If you want to create this rule for a snapshot specification, see Creating a Snapshot 
Specification on page 126.

2 Select an Audit Source: Server, Snapshot, Snapshot Specification, or No Source. 

Some audit rules, such as Application Configuration and Windows User’s and Groups, must have a 
source.

3 In the Audit window, from the Views pane, select Rules > Windows Registry.

4 In the content pane of the Audit window, expand the top level node in the Available for Audit section 
and select a Windows Registry folder or key to create a rule for. 

5 Click the right arrow button to move the Windows Registry folder or key into the Selected for Audit 
section. All items that you select will be used to audit or snapshot the target server.

6 For each registry entry key rule you create, you can set the following options to include when the 
audit checks the target: 

• Also Compare Contents of Sub-Keys—Evaluate all subkeys that belong to the selected registry 
key.

• Also Compare ACLs—Compare ACLs of the selected registry key.

• Use case-insensitive compare for Key Values—Do not show Key Value differences in the audit 
result if the names use a different case.

7 To finish configuring the audit, set the target servers, the schedule, and the notification for the audit. 

8 From the File menu, select Save to save your audit. 

(Optional) You can also save the Audit as a policy. See Saving an Audit or a Snapshot Specification 
as an Audit Policy on page 98.

9 To run the audit, from the Actions menu, select Run Audit. See Running an Audit on page 32.

Note: In the Audit Policy window, if you select a server to view its registry information, and then want to 
check the registry information for another server, you must close the Audit Policy window, then reopen it 
to refresh the registry-contents field.
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Configuring the Windows Services Rule

Windows Services rules are comparison-based rules that enable you to select a Windows Service from the 
source of the audit or snapshot specification, and then compare them with the target servers. The audit or 
snapshot specification compares the selected services with services on the target servers to determine 
whether the services exist and whether the services are started, stopped, or disabled. You cannot set a 
target or remediation value with this type of rule

To configure Windows Services audit rules: 

1 Create a new audit. See using Creating an Audit on page 30 for ways to create an audit. 

(Optional) If you want to create this rule for a snapshot specification, see Creating a Snapshot 
Specification on page 126.

2 Select an Audit Source: Server, Snapshot, Snapshot Specification, or No Source. 

Some audit rules, such as Application Configuration and Windows User’s and Groups, must have a 
source.

3 In the Audit window, from the Views pane, select Rules > Windows Services. 

4 In the content pane of the Audit window, expand the top level node in the Available for Audit section 
and select a Windows Service to create a rule for. You can select any available service for the rule; 
however, you cannot select the root folder for all Windows services.

5 Click the right arrow button to move the selected Windows Services into the Selected for Audit 
section. All items that you select will be used to audit or snapshot on the target server.

6 To finish configuring the audit, set the target servers, the schedule, and the notification for the audit. 

7 Save the audit.

8 To run the audit, from the Actions menu select Run Audit. See Running an Audit on page 32.

Configuring the Users and Groups Rule

The Windows or Unix Users and Groups rule allows you to access local users and groups information from 
Windows and Unix servers.

To configure the Users and Groups rule:

1 Create the new audit using one of the methods in Creating an Audit on page 30. (If you want to 
create this rule for a snapshot specification, see Creating a Snapshot Specification on page 126.)

2 Select an Audit Source: Server, Snapshot, Snapshot Specification, or No Source. (Some audit rules, 
such as Application Configuration and Windows User’s and Groups, must have a source.)

3 In the Audit window, from the Views pane, select Rules > Windows/Unix Users and Groups. 

4 In the content pane of the Audit window, expand the top level node in the Available for Audit section 
and select a Users and Groups rule that you want to create a rule from. 

5 Click the right arrow button to move the rule object into the Selected for Audit section. All Users and 
Groups rules that you configure will be audited on the target servers or snapshot specification. 

6 For each rule, select one of the following check types: 

• Property Values: A values-based check that checks individual properties of the target object. For 
this type of check, each object requires that you build an expression that defines properties 
related to the object using the drop down lists at the bottom of the rule window. You can specify 
a unique operator which, depending on the type of object, can be a String, a Number (integer or 
76 Chapter 2



float), Boolean (comparing values of ‘true’ and ‘false’), Date (a date compare, not a time of day 
compare), or an Array. For some property types you can select the values from the ‘value 
selector box’. 

• Equivalent to source: A comparison check that performs a one to one comparison between the 
object on the source vs. the target servers. In this type of check, the values of each property 
selected from both the source and target servers must match exactly for the object to be 
compliant.

— Non-existence: Checks for the non-existence of an object, to determine if it does not exist on the 
target server. If the object exists on the target server, then the rule is out of compliance. Note 
that, at runtime, the source server, if any, is not queried.  Also, if a Wildcard rule object is 
selected, it will only apply to the target server.

7 You can also configure a rule based on a wildcard search by selecting the Wildcard rule object . 
When you select this object, a Name field displays in the rule configuration section at the bottom of 
the window. Enter a name (primary key) that will be searched on the target server.

For example, you could enter an asterisk (*) that would match everything on the target. P* would 
match all objects that begin with a capital P, while *P would match all users with name ending with 
uppercase character 'P'. 

After you enter a name or wildcard string, you can configure the rule parameters as you did in step 6. 

It is important to notice that when using wildcard, all matching objects are restricted by the rule 
configuration. This type of audit rule is considered compliant if all found objects match the rule 
parameters. 

8 To finish configuring the audit, set the target servers, any rule exceptions, the schedule, and the 
notification for the audit. 

9 To save the audit, from the File menu, select Save. You can also save the Audit as a policy. See Saving 
an Audit or a Snapshot Specification as an Audit Policy on page 98.

10 To run the audit, from the Actions menu, select Run Audit. See Running an Audit on page 32.

Configuring Compliance Checks

If you subscribe to the BSA Essentials Subscription Services, you have access to dozens of compliance 
rules and their components, known by content developers as compliance checks. 

The kinds of checks you have access to depends on your content subscription, but can include such checks 
as the latest patch supplements for Microsoft Windows, current regulatory compliance policies (for 
example, FISMA, Sarbanes-Oxley), user-created checks distributed by the content developer community, 
daily updated vulnerability content, and so on.

I If you do not subscribe to BSA Essentials Subscription Services, you will not see any compliance checks in 
your audits, audit policies, snapshots, or the Compliance Check Editor. If you would like more information 
on content subscriptions and obtaining compliance checks, contact your BSA Essentials Subscription 
Services sales representative. 

While each compliance check is slightly different and requires its own configuration values, the basic 
parameters for each check require that you define the Target Value — the expected value you want to 
find on the server — and an optional Remediation Value. 

For more information on managing your core’s compliance checks, such as editing check property data or 
creating compliance check groupings, see Compliance Checks on page 80. 
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To configure compliance checks in audits or snapshot specifications:

1 Create an audit or snapshot using one of the methods described in Creating an Audit on page 30. (If 
you want to create this rule for a snapshot specification, see Creating a Snapshot Specification on 
page 126.)

2 Select an Audit Source: Server, Snapshot, Snapshot Specification, or No Source. 

3 In the Audit window, from the Views pane expand the Rules object.

4 Select the Compliance Checks rule.

5 In the content pane of the Audit window, click the Add  button.

6 In the Select Check window, from the Browse tab, you can browse for the compliance checks 
categories and select a check for the audit or snapshot. 

Alternately, you can select the Search tab and search for check by name. The check search tool 
searches on the name of a check and any words in a check’s description. For example, if you wanted 
to find all rules that check for maximum password length, you could enter max password in the 
Keywords field. 

The Advanced search option allows you to set more specific parameters to find checks. 

7 When you select a check (or multiple checks using CTRL or SHIFT + click), click OK to add the checks to 
your audit. 

8 Select the check and then define or set the following parameters: 

Input Value

Some custom checks require an input value as part of the configuration of the target value. For those 
checks, you will need to specify a success or failure which you can set to true or false. The Description 
section of the audit rule explains the recommended values. 

Target Value

Specify the value that you expect to be on the target server or servers of the audit, or the value you 
want to capture in a snapshot. You can change the following parameters: 

— Operator: To build an expression from the output of the script, choose an Operator, such as 
equals (=), not equals (<>), less than (<), greater than (>), and so on. 

— Reference: Choose the source of the script output. 

— Source: This will use the value from the source server and compare that value to with the value 
found on the target server or servers. 

— Value: Enter your own value. This option uses the value you enter and compares it with the value 

returned on the target server. Click the  icon get the value from the source server. The 
returned value is displayed in the text box, which you can accept as is or edit as needed. 

— Server Attribute: Select to compare a server attribute located on the source server.

— Custom Attribute: Select to compare a custom attribute found on the target server.

Remediation Value

Each remediation value setting will be different depending on the type of rule, so choose accordingly.

9 To finish configuring the audit, set the target servers, the schedule, and the notification for the audit. 

10 To save the audit, from the File menu, select Save. You can also save the Audit as a policy.See Saving 
an Audit or a Snapshot Specification as an Audit Policy on page 98.

11 To run the audit, from the Actions menu, select Run Audit. See Running an Audit on page 32.
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Renaming Compliance Checks

You can easily rename instances of compliance checks in an audit, audit policy, or snapshot specification 
using the right-click menu.

For information on renaming compliance checks and editing their properties, see Compliance Checks on 
page 80. 

To rename a compliance check name:

1 In the navigation pane, select Library > By Type > Audit and Remediation and open an audit, audit 
policy, or snapshot specification.

2 In the Audit (or Audit Policy or Snapshot Specification) window, from the Views pane, select a specific 
rule that contains custom checks, such as Users and Groups.

3 In the contents pane, in the Available for Audit section, select a custom rule check, right-click, and 
then select Rename Rule to rename the rule.

You cannot rename a rule check if the audit or snapshot specification is linked to an audit policy.

Searching for Compliance Checks from the Audit/Snapshot Specification 
Window

Since your SA core can potentially contain dozens, if not hundreds, of compliance checks, you can use the 
search tool inside the Audit or Snapshot Specification window to find the checks you want.

To search for compliance checks from inside an audit or snapshot specification:

1 In the Audit or Snapshot Specification window, from the Views pane expand the Rules object.

2 Select the Compliance Checks  rule.

3 In the content pane, click Add .

4 In the Select Check window, from the Browse tab, you can browse for the compliance checks 
categories and select a check for the audit or snapshot. 

5 Select the Search tab to search for checks by name. The check search tool searches on the name of a 
check and any words in a check’s description. For example, if you wanted to find all rules that check 
for maximum password length, you could enter max password in the Keywords field. 

6 Click the Advanced Search link to build more specific search criteria. Advanced search allows to look 
for a text string plus restrict the query to values in the check’s properties, such as Security Level, 

External ID, Platforms, and Test ID. Click  to add additional advanced search parameters. 

For information on how to add a Test ID, Security Level, or External ID to your compliance check 
properties, see Editing Compliance Check Properties on page 80.

7 To execute the search, click Search.

8 In the search results, you can select the checks you want to add to the audit or snapshot specification 
and then click OK.
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Compliance Checks 

You must have permissions to access the Compliance Check Editor. To obtain these permissions, contact 
your SA administrator or see the SA Administration Guide for more information.

The Compliance Check Editor allows you to browse, regroup, and edit property information (metadata) 
about your core’s BSA Essentials Subscription Services compliance checks. 

For example, your organization might require that an external numbering system be associated with all 
compliance checks that you run against servers in your data center. Using the Compliance Check Editor, 
you can add an external ID to those checks. You can also create custom groupings for checks you modify 
with this external ID, so that when you need to access those checks, you can easily find them in the 
custom folder. This external ID can also be used as search criteria for finding all checks with the ID number 
or string.

You can also edit information about custom check, such as changing a check's name, adding a custom 
security level, or modifying descriptive information about a check. For example, you can add to a check’s 
remediation description to clarify what happens during remediation. This provides valuable information 
about its behavior for someone else who wants to use the check.

•  Editing Compliance Check Properties

•  Creating Custom Compliance Check Categories

•  Restoring Compliance Checks to Defaults

•  Showing Deprecated Checks

•  Setting Inclusions & Exclusions for Checks

Editing Compliance Check Properties

The Compliance Check Editor allows you to modify a compliance check’s properties, such as renaming it, 
adding a description, modifying its property information, adding an external ID to it, and so on.

To edit compliance check property information:

1 In the SA Client, from the Tools menu, select Compliance Check Editor. If you do not see the menu 
item, contact your SA administrator to obtain access permissions.

2 In the Compliance Check Editor window, in the Browse tab, expand the different Custom Checks 
categories to find the check you want to edit. Narrow the list by selecting an operating system in the 
Platform filter drop-down list. 

3 Select the Search tab if you want to search for a check by a name or a keyword in its name and 
Description fields.

For example, if you want to find all rules that check for security logs, enter security log in the 
Keywords field. If you want to narrow the search further, add the keyword size to find all checks 
that audit for security log file size.

The Advanced Search option allows you to set more specific parameters to find checks. Using 
advanced search, you can filter by other properties such as security level, external ID, platform, or 
test ID. 

To add additional search parameters, click .
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4 To edit a check’s property information, select the check from the Browse tab or Search tab results.

5 On the right side of the Compliance Check Editor, in the Properties tab, edit the following check 
information:

• Name: Double-click inside the Name’s value field to modify the check’s name.

• Categories: Click the “Click to edit” link to add the check to a custom folder. For example, click 
the link and in the Categories window, press ENTER on your keyboard and then type a name to 
create a new compliance check category. Click Apply. To create the custom grouping folder, click 
Apply Changes at the bottom of the Compliance Check Editor window. For information on 
creating custom grouping for your checks, see Creating Custom Compliance Check Categories 
on page 81.

• External ID: Double-click inside the value field to add or modify an External ID.

• Security Level: Double-click inside the value field to enter or modify security level for the check.

6 Click Apply Changes at the bottom of the Compliance Check Editor window to apply the modifications 
to the checks.

7 To edit a check’s descriptions, select the Description, Remediation Description, or Technical 
Description tabs to edit the descriptive text for each.

8 To access the HTML editor for the description, click the edit icon .

9 In the HTML editor, click the HTML Edit icon at the bottom left of the description window. 

10 Edit the HTML description. 

11 Click Apply. If you want to undo any changes, from the File menu, select Revert.

12 Click Apply Changes at the bottom of the Compliance Check Editor window to apply the description 
modifications to the checks.

•  Compliance Checks

•  Creating Custom Compliance Check Categories

•  Restoring Compliance Checks to Defaults

•  Showing Deprecated Checks

•  Setting Inclusions & Exclusions for Checks

Creating Custom Compliance Check Categories

The Compliance Check Editor allows you to create your own custom categories that contain compliance 
checks installed on your core. For example, you can create a custom category that contains all checks that 
audit user and group settings on your Windows servers. Or, you might only be interesting in accessing 
specific Linux services-related checks and can create a category that contains them.

To create custom compliance check categories:

1 In the SA Client, from the Tools menu, select Compliance Check Editor. If you do not see the menu 
item, contact your SA administrator to obtain access permissions.

2 In the Compliance Check Editor window, in the Browse tab, expand the different Custom Checks 
categories to find the check you want to edit. Narrow the list by selecting an operating system in the 
Platform filter drop-down list. 

3 Select a compliance check.
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4 In the upper right side of the Compliance Check Editor window, Properties tab, Categories row, click 
the “Click to edit” link.

5 In the Categories window, place your mouse point at the end of the main check category name and 
then press ENTER on your keyboard.

6 Type a name to create a new compliance check category. This creates a new compliance check 
category in the Compliance Check Editor. To add more categories, press ENTER again to start a new 
line and then type the name of the category. The selected check will be added to each new category.

7 Click Apply.

8 To create the custom grouping folder, click Apply Changes at the bottom of the Compliance Check 
Editor window. 

9 To delete the custom category, repeat the process and delete the name of the category in the 
Categories window.

•  Compliance Checks

•  Editing Compliance Check Properties

•  Restoring Compliance Checks to Defaults

•  Showing Deprecated Checks

•  Setting Inclusions & Exclusions for Checks

Restoring Compliance Checks to Defaults

If you want to restore all of your compliance checks to their default state—their original state when they 
were first downloaded from the BSA Essentials Subscription Services portal—use the restore defaults 
operation. Restore defaults deletes any customizations made to your compliance checks and then reverts 
them to their original released state. 

To restore compliance checks to their default state:

1 In the SA Client, from the Tools menu, select Compliance Check Editor. If you do not see the menu 
item, contact your SA administrator to obtain access permissions.

2 In the Compliance Check Editor window, from the Edit menu, select Restore defaults. 

The restore defaults action applies only to selected compliance checks.

•  Compliance Checks

•  Editing Compliance Check Properties

•  Creating Custom Compliance Check Categories

•  Showing Deprecated Checks

•  Setting Inclusions & Exclusions for Checks
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Showing Deprecated Checks

For compliance checks that have been deprecated, you can choose to show them in the Compliance Check 
Editor. 

To show deprecated checks in the Compliance Check Editor: 

1 In the SA Client, from the Tools menu, select Compliance Check Editor. If you do not see the menu 
item, contact your SA administrator to obtain access permissions.

2 From the View menu, select Show Deprecated Checks. 

3 Expand any of the checked categories to view any deprecated checks. 

Deprecated checks display in grayed out, italic font. 

•  Compliance Checks

•  Editing Compliance Check Properties

•  Creating Custom Compliance Check Categories

•  Setting Inclusions & Exclusions for Checks

Setting Inclusions & Exclusions for Checks

You can specify the files or directories that you want included in, or excluded from, your compliance 
checks.

Note: This section does not apply to ESXi servers, as the file option is not enabled for ESXi servers.

To specify the files or directories that you want to include or exclude:

1 In the Audit browser, in the Views pane, expand Rules and then select Files.

2 In the Rules > Files content pane, in Directory Options, click Set Exclusions.

3 In the Set Includes/Excludes window, specify Include or Exclude from each drop-down list.

4 Click Browse to select files or directories from the source server or enter a file path. 

Valid wildcard characters include the asterisk (*) and percent sign (%). For example, if you want to 
exclude all .exe files from your compliance checks, enter “*.exe”, without the quotation marks, in the 
Exclude field.

When you select a directory, you can recursively browse to files and sub-directories that are under 
that directory. You do not have to start browsing from your c: directory or from the root directory.

5 Click  to add another row or click  to remove a row.

6 In the Browse window, click Select to save your choices.

7 In the Set Includes/Excludes window, click Set to save your settings.

•  File Inclusion and Exclusion Rules

•  Compliance Checks

•  Editing Compliance Check Properties

•  Creating Custom Compliance Check Categories
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File Inclusion and Exclusion Rules

When configuring a file rule inside an audit, audit policy, or snapshot specification, you can specify the 
directories and files that you want included in and excluded from an audit or a snapshot. This section 
explains what the inclusion and exclusion rules are and how these rules are applied to the relative subset 
of the absolute path of the file.

Inclusions and exclusion rules inside of an audit’s file rule are found at the bottom of the audit or 
snapshot specification window, as shown in Figure 15.

figure 15 File System File/Directory Wildcard Inclusion and Exclusion Rules 

When you configure the file rule in an audit or snapshot specification, you can enter inclusion/exclusion 
rules in the File/Directory Wildcard field. After you enter a rule, you can choose either Include or Exclude 

from the drop-down list. To add a new inclusion or exclusion rule, click . 

For information on how to create and configure file system rules for an audit or snapshot specification, 
see Configuring the File Rule on page 58. 

Inclusion and Exclusion Rule Types

Audit and Remediation provides the following types of inclusion and exclusion rules configuring a file 
rule:

• A file-type rule applies to the file name path and contains neither a “/” or a “\”.

• A relative-type rule applies to the relative path and can contain a “/” for Unix and a “\” for Windows, 
and is not fully qualified.
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• An absolute-type rule applies to the absolute path. In Unix, an absolute path begins with a “/”. In 
Windows, an absolute path begins with a volume letter that is followed by “:\” and is fully qualified, 
such as “C:\”, “d:\”, “f:\”, and so on. If you use a “/” (forward slash) for Windows paths, Audit and 
Remediation will convert it to a “\” (backslash) to use it as a valid path.

• Environment variable and custom attribute parameterization for filenames and path. For more 
information, see Parameterizing Filenames for SA/Custom Attributes on page 88.

Audit and Remediation processes all exclusion rules first. After all exclusion rules are applied, then the 
inclusion rules are applied. The default for include is to include all objects in the file system. In many 
cases, inclusion rules might not even be processed because, combined with the exclusion rules (which 
occur first), they might become a moot point.

You can also use the asterisk (*) and the question mark (?) as valid wildcards in inclusion and exclusion 
rules. The wildcard character is a placeholder for matching a path, or one or more characters.

Depending on the type of inclusion and exclusion rule, the rule is applied only to the relevant subset of 
the absolute path of the file. In Audit and Remediation, there is one top level for each snapshot or audit. 
Each file that you compare against the inclusion and exclusion rules has an absolute path. In Figure 16, 
the absolute path is /usr/home/abc/defg. A snapshot or an audit looks down the /usr/home/abc/
defg absolute path and sees abc/defg as the relative path and defg as the file name. In this example, 
the inclusion and exclusion rules apply in the following manner:

• A file-type rule applies to the file name path defg.

• A relative-type rule applies to the relative path abc/defg.

• An absolute-type rule applies to the absolute path /usr/home/abc/defg.See Figure 16 for an 
illustration of how Audit and Remediation applies the inclusion and exclusion rules to a relative 
subset of the path of the file.

figure 16 How Inclusion and Exclusion Rules Apply 

To best explain how these rules are applied, the following examples are provided.

A sample file system structure used in Example: Including all .txt Files in a Snapshot or Audit on 
page 86 and Example: Including last temp.txt file and exclude all else on page 87 is as follows:

/dir1/dir2/a
/dir1/dir2/b
/dir1/dir2/names.txt
/dir1/dir2/temp.txt
/dir1/dir2/version1.exe
/dir1/dir2/subdir/version2.exe

/usr/home/abc/defg

Absolute Path
/usr/home/abc/defg

Relative Path
abc/defg

File Name
defg

Apply Absolute-type rules Apply Relative-type rules Apply File-type rules
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Example: Including all .txt Files in a Snapshot or Audit

If you want to include all files with the .txt extension in your snapshot or audit, your inclusion and 
exclusion rules would be:

• /dir1/dir2

• include *.txt (This is a file-type rule.)

• exclude * (This is a file-type rule.)

The following steps explain how Audit and Remediation iterates through the file structure and applies any 
corresponding inclusion and inclusion rules:

a The * causes /dir1/dir2/a to be excluded. Then *.txt is applied against the file portion of /dir1/
dir2/a (a) and there is no match. The file is not included.

b The * causes /dir1/dir2/b to be excluded. Then *.txt is applied against the file portion of /dir1/
dir2/b (b) and there is no match. The file is not included.

c The * matches names.txt, but *.txt matches names.txt as well, which causes the file to be 
excluded.

d Same as step 3.

e Compare a to *, which is a match; compare a to a, which is a match. The file is included.

f Compare b to *, which is a match; compare b to a which is not a match. The file is excluded.

These step numbers correspond to the paths in the sample file structure, with the numbering starting 
with the top-level path.

Example: Including Only File a in a Snapshot or Audit

If you want to include only the file in your snapshot or audit, your inclusion and exclusion rules would be:

• /dir1/dir2

• exclude * (This is a file-type rule.)

• include a (This is a file-type rule.)

The following steps explain how Audit and Remediation iterates through the file structure and applies any 
corresponding inclusion and inclusion rules:

a The * causes /dir1/dir2/a to be excluded. Then *.txt is applied against the file portion of /dir1/
dir2/a (a) and there is no match. The file is not included.

b The * causes /dir1/dir2/b to be excluded. Then *.txt is applied against the file portion of /dir1/
dir2/b (b) and there is no match. The file is not included.

c The * matches names.txt, but *.txt matches names.txt as well, which causes the file to be 
included.

d Same as step 3.

e Compare a to *, which is a match; compare a to a, which is a match. The file is included.

f Compare b to *, which is a match; compare b to a which is not a match. The file is excluded.

These step numbers correspond to the paths in the sample file structure, with the numbering starting 
with the top-level path.
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Example: Including last temp.txt file and exclude all else

If you want to include the last temp.txt file and exclude everything else in your snapshot or audit, your 
inclusion and exclusion rules would be:

• /dir1/dir2

• exclude * (This is a file-type rule.)

• include dir3/temp.txt (This is a relative-type rule.)

The following steps explain how Audit and Remediation iterates through the file structure and applies any 
corresponding inclusion and inclusion rules:

a The * causes /dir1/dir2/a to be excluded. Then *.txt is applied against the file portion of /dir1/
dir2/a (a) and there is no match. The file is not included.

b The * causes /dir1/dir2/b to be excluded. Then *.txt is applied against the file portion of /dir1/
dir2/b (b) and there is no match. The file is not included.

c The * matches names.txt, but *.txt matches names.txt as well, which causes the file to be 
included.

d Same as step 3.

e dir3/temp.txt is dir3/temp.txt is compared against the relative portion of /dir1/dir2/dir3/
temp.txt and there is a match.

f Compare a to *, which is a match; compare a to subdir/version2.exe, which is not a match. The file 
is excluded.

These step numbers correspond to the paths in the sample file structure, with the numbering starting 
with the top-level path.

File Rule Overlap

When you include a parent directory (with options) in a rule and a child directory (with different options) 
as additional parameters, the parent directory snapshot and the child directory snapshot will overlap 
each other as one snapshot. This logic also applies to Windows NT ACL collection and content collection 
options, and Windows Registry content collection options. The following examples explain how audit 
rules for a parent and child directory overlap.

Consider the following file system, where an ending forward slash (/) represents a directory: 

/cust/app/bin/
/cust/app/bin/file1
/cust/app/bin/conf/
/cust/app/bin/conf/conf1
/cust/app/bin/conf/conf2
/cust/app/bin/conf/dev/
/cust/app/bin/conf/dev/conf3

Example A

If you create a snapshot using the following two rules:

Directory /cust/app/bin (recursive, no checksum)

Directory /cust/app/bin/conf (not recursive, checksum)

The snapshot will record the following file system information:
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/cust/app/bin/ (directory)
/cust/app/bin/file1 (no checksum)
/cust/app/bin/conf/ (directory)
/cust/app/bin/conf/conf1 (*checksum*)
/cust/app/bin/conf/conf2 (*checksum*)
/cust/app/bin/conf/dev/ (directory)
/cust/app/bin/conf/dev/conf3 (no checksum)

As you can see, even though /cust/app/bin was recursive and had no checksum, the /cust/app/
bin/conf directory overrode it and all files in that directory have checksums recorded for them.

Example B

If you create a snapshot using the following two audit rules (by switching the options used in Example A):

Directory /cust/app/bin (recursive, checksum)
Directory /cust/app/bin/conf (not recursive, no checksum)

The snapshot will record the following file system information:

/cust/app/bin/ (directory)
/cust/app/bin/file1 (checksum)
/cust/app/bin/conf/ (directory)
/cust/app/bin/conf/conf1 (*no checksum*)
/cust/app/bin/conf/conf2 (*no checksum*)
/cust/app/bin/conf/dev/ (directory)
/cust/app/bin/conf/dev/conf3 (checksum)

Example C

If you create a snapshot using the following three audit rules (by adding a file option):

Directory /cust/app/bin (recursive, checksum)

Directory /cust/app/bin/conf (not recursive, no checksum)

File      /cust/app/bin/conf/conf1 (checksum)

The snapshot will record the following file system information:

/cust/app/bin/ (directory)
/cust/app/bin/file1 (checksum)
/cust/app/bin/conf/ (directory)
/cust/app/bin/conf/conf1 (*checksum*)
/cust/app/bin/conf/conf2 (no checksum)
/cust/app/bin/conf/dev/ (directory)
/cust/app/bin/conf/dev/conf3 (checksum)

In this example, the very detailed audit rules for conf1 override the
/cust/app/bin/conf audit rule.

Parameterizing Filenames for SA/Custom Attributes

When you create a file rule in an audit or snapshot specification, you can also reference environment 
variables and custom attributes in the file name. In the File/Directory Wildcard area of the rule window, 
you can edit the file name to add these references. 

To add a reference to a Windows environment variable, the syntax is %envVarName% and for Unix, the 
syntax is ${varName}. 
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The syntax for specifying custom attributes is @varName@. For example: 

@/customattribute/custAttrbuteNAME@\rest\of\the\path
@/customattribute/FacilityCustomAttrbuteNAME@\rest\of\the\path 
@/customattribute/CustomerCustomAttributeNAME@\rest\of\the\path
@/customattribute/ServerAttrbuteNAME@\rest\of\the\path
@/customattribute/GrpAttrbuteNAME@\rest\of\the\path

This allows for auditing relative paths on both source and target servers using a parameterized 
environment variable or custom attribute in the filename. 

Examples of Parameterizing Filenames

For example, on the servers you want to audit you know the relative path to an application, but not 
necessarily the absolute path for all servers. You can parameterize the path in your audit’s File rule so the 
relative pathname is eliminated and the audit checks the relative path anywhere it exists on the target 
server. 

For example, you want to audit a target servers against a golden source server where 
'%ProgramFiles%' is :\Program Files” against target servers where %ProgramFiles% is 
D:\Program Files.

In the File/Directory Wildcard section of the File rule, you can specify the root of the directory rule in the 
audit to be %ProgramFiles%\Company\MyApp. The audit will remove %ProgramFiles% from the 
paths of the servers it targets when you run the audit. In other words, C:\Program 
Files\Company\MyApp\file1.txt on the source server will be compared with D:\Program 
Files\Company\MyApp\file1.txt on the target servers.

In another example, you may want to audit an application that is installed into two completely different 
subdirectories on two different servers. 

For example, in your audit you choose from a golden source server configuration the installation path of 
the following:

/usr/local/app-version-1232/prog

And, your target servers have the application installed anywhere under this path:

/usr/local/app

In order to audit the target server, you can defines a custom attribute APP_INSTALL_LOC with a value of /
usr/local/app-version-1232/prog for the golden server and 
/usr/local/app for the production servers. The File rule in the audit would look something like this:

@/customattribute/APP_INSTALL_LOC@/prog

This would cause the audit to treat @/opsware/customattribute/APP_INSTALL_LOC@ as if it were 
an environment variable on the target server and do a path replacement.

If you wanted to reference a server attribute, the path would be entered like this:

@/server/APP_INSTALL_LOC@/prog
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Environment Variables in Pathnames

Best Practice: If you want to use environment variables in file name PATH on Unix (commonly known as 
parameterized checks), it is best to define those environment variables under the following file and 
directory: etc/opt/opsware/snapshot/env. Be sure that you do not use /etc/profile to source 
environment variables on Unix.

To define environment variables that can be sourced for the File rule configuration, you can create a file 
with the variables on the managed server you want to audit or snapshot. 

Example:

1 ssh to the managed server that you want to audit or snapshot.

2 Create a new directory in the following location:

mkdir /etc/opt/opsware/snapshot

3 Create a new empty file, such as:

touch /etc/opt/opsware/snapshot/env

4 Define the environment variables you want to source from the file rule by entering them in the new 
file. Example:

TEST1='/tmp/test1'
TEST2='/home/test2'
export TEST1 TEST2

5 When you have finished editing, save the file. 

Audit Rule Exceptions 

For most audit rules, you can create temporary or permanent rule exceptions on selected target servers 
(or groups of servers) in the audit. This means you can exclude specific rules on selected targets of the 
audit when the audit runs.

For example, in an audit that is auditing several servers, you might want to suspend one one more of the 
rules for a subset of the servers targeted by the audit. You might have a collection of Windows servers 
that are regularly audited to make sure that the IIS service is disabled, for example, to meet company 
security standards. Your audit is configured to check each of those servers to make sure IIS is disabled. If 
IIS is enabled on any of the servers, the audit will fail. 

However, for a short period of time you might want to run a business application that requires the IIS 
service to be enabled in order to run on a few of the servers targeted in the audit. You can create a rule 
exception for the rule governing the IIS service and associate the exception with the servers that need to 
run the application. This ensures that the audit can still run and not fail when it encounters the servers 
that do have the IIS service enabled. 

You can set an expiration date for the rule exceptions to make sure that when the rule exception is no 
longer needed or permitted, the rule will be applied to all servers in the audit. You can also write a reason 
for the exception and associate a ticket ID with it. Exceptions you create in one audit do not affect rules in 
any other audits. 
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Rules That Cannot Have Exceptions

Most audit rules can have exceptions created for them. However, rule categories that include ALL of a set 
of rules cannot have exceptions.

Considerations When Applying Exceptions to Device Groups

When you set an audit rule exception for a device group, the exception will be applied to all servers in the 
group. It is possible that one of the servers in the group with the exception also belongs to another device 
group, which also happens to be the target of an audit that has no exceptions applied to it. 

In this situation, the rule exception always applies to the server, even though the server also belongs to a 
device group with no exceptions. As a rule of thumb, keep in mind any servers in a device group that has a 
rule exception applied to it will have the audit rule excepted, whether or not the server belongs to another 
device group that is targeted by an audit and has the same rule applied without an exception.

Adding a Rule Exception to an Audit

To create an audit rule exception, select any of the rules configured in your audit and using the Add Rule 
Exception window, associate them with a target server in the audit. When you run the audit, the selected 
rule and the target servers or snapshots associated with the rule will not be applied. 

You can also apply rule exceptions to device groups. You can set the rule exception to run indefinitely, or 
to expire at some future point in time. You can add a comment to explain why you are creating the 
exception, and also associate a ticket ID with the exception.

Some audit rules and audit rule collections cannot be excepted. For more information, see Rules That 
Cannot Have Exceptions on page 91.

To add a rule exception to an audit: 

1 First, create an audit. For information see Creating an Audit on page 30.

2 Configure audit rules for the audit. For information on configuring audit rules, see Audit & 
Remediation Rules on page 46. 

3 In the audit view pane on the left, select the Exception  icon. 

4 Next, from the content pane, click Add. 

You can also select any rule in the Audit window. Right-click and then select Add Exception. However, if 
the audit is referencing a linked audit policy, you cannot right-click a rule to add an exception. 

5 In the Add Exception window, from the Select Target Server section, select a server, multiple servers, 
or device groups to which you want to apply the rule exception. 

6 Next, from the Select Rule section, select one or more rules you want to associated with the servers 
you selected in the previous step.

7 (Optional) In the Reason for Exception section, add an explanation.

8 (Optional) In the Ticket ID section, add the ticket ID associated with this exception.

9 In the Expires section, either enter a date to indicate when the exception expires or select a date from 
the drop down list. 
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10 When you are finished configuring the exception, click Add. 

11 You now see a list of rule exceptions that will be applied when you run the audit.

Editing or Deleting a Rule Exception

You can edit an exception in one of two ways: 

• Double-click the exception to modify the reason for the exception, the ticket ID, and the exception 
expiration date

• Click the Add to edit a rule (overwrite the existing rule).

To edit an exception: 

1 Open an Audit window. 

2 In the Views pane, select the Exception  icon.

3 In the content pane, double-click an exception.

4 In the Edit Exception window, you can edit any of the exceptions and servers or device groups they 
are assigned to. When you have edited the exception, click Add.

5 If you want to completely change and the rule, click Add and then in the Add Exception window, 
change the rule by selecting target server and one or more rules. When you are finished, click Add to 
change the exception. 

To delete an exception: 

1 Open an Audit window. 

2 In the audit view pane on the left, select the Exception  icon.

3 In the contents pane, select the exception you want to select, and then click Delete.

Audit Policy Management 

An audit policy allows you to define and store a centralized and reusable collection of server 
configuration compliance rules. You can link an audit policy to audits, snapshot specifications, and other 
audit policies.

An audit policy is typically created by a policy setter who understands the compliance standards that a 
company wants its servers to meet. Another set of users, whose job it is to manage and audit actual 
servers, can use predefined audit policies by linking them to their audits or snapshot specifications. If 
changes are made to the audit policy, the audit or snapshot specification that links to it will reference the 
audit policy’s updated rules. Users who audit servers can be sure their audits always reflect the latest 
compliance standards in their organization. 

Audit policies can link to other audit policies. For example, you could combine several different discrete 
audit policies together as one master policy that defines how Windows services should be configured. 
After you run the audit, if any discrepancies are discovered you can remediate them from the audit 
results.
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You can create an audit policy from scratch or you can save the rules of an audit, snapshot specification 
(or another audit policy) as an audit policy. All audit policies are stored in the SA Client Library.

You can also view the status of managed servers (targets) that are attached to a certain audit policy.

•  Audit & Remediation Rules

•  Linking & Importing an Audit Policy

•  Creating an Audit Policy

•  Saving an Audit as an Audit Policy

•  Ways to Link & Import Audit Policies

•  Locating an Audit Policy in the Folder Library

•  Exporting an Audit Policy

•  Viewing Compliance of an Audit Policy

•  The Compliance Dashboard

Linking & Importing an Audit Policy

An audit policy can be used inside audits and snapshot specifications, or other audit policies, through 
linking. Audits and snapshot specifications also use audit policies through importing.

Linking an Audit Policy

Best Practice: Linking an audit policy to an audit or snapshot specification enables the audit or snapshot 
specification to use the exact same rule set of the audit policy. If any of the rules in the audit policy 
change, the same changes are reflected in the audit and snapshot specification’s rules the next time they 
are run, since they link to the rule set defined in the audit policy. 

You can break this link by selecting the Enable unlinked rules (prevents linking to predefined audit 
policies) option. See Configuring the File Rule on page 58.

Audit policies can be also be linked to other audit policies, and you can link as many audit policies as you 
want into an audit policy. When you link one or more audit policies to an audit policy, the linked audit 
policies become children of the parent audit policy. If you create an audit that links to the parent audit 
policy, when you run the audit on a target server, the rules from all linked policies are run against on the 
target server.

Importing an Audit Policy

Importing an audit policy into an audit or snapshot specification imports all rules from the audit policy. 
After they are imported, the rules are editable. When you import an audit policy into an audit, you can 
choose to replace any current values in the audit or merge rules from the audit policy with those in the 
audit or snapshot specification. Audit policies cannot import rules from another audit policy; however, 
they can link to other audit policies. 

•  Ways to Link & Import Audit Policies
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Rule Overlap with Multiple Linked Audit Policies

Because you can link your audit or snapshot specifications to an audit policy that may references other 
audit policies, it is possible that some of the linked policies might contain the same rules but with 
different configuration options.

Rules become merged in audit results when you identify the same object for a rule and the only way to 
customize the rule is by setting options. The options may or may not be different, but they still get 
merged into one rule before running and there is only one result. If the options are different, the options 
are OR'ed together into the single rule. Examples include file rules, registry rules, metabase rules (legacy 
comparison type), Windows Service rules, etc. 

Rules that take parameters or you specify the compliance criteria are  merged if and only if the 
parameters and the criteria are exactly the same. Otherwise they are executed as separated rules. 
Examples include compliance (pluggable) rules, custom script rules, and server module based rules.

Creating an Audit Policy 

When you create an audit policy, you have the option of creating its rules using a live server as a source to 
pick and choose for rules, by creating your own custom rules, or linking to the rules of another audit 
policy.

Using a source server for building audit policy rules allows you to base the audit policy’s rules on the 
actual configurations of a managed server. The source server used to build rules is not used after the 
audit policy is linked to an audit or snapshot specification.

All audit policies must be saved to a folder in the SA Client Library. Each audit policy name within a folder 
must be unique. To save an audit policy to a folder, you must have permissions to write to that folder. For 
more information about folder permissions, see the SA Administration Guide. 

To create an audit policy:

1 In the navigation pane, select Library > By Type > Audit and Remediation > Audit Policies.

2 Select an operating system.

3 From the Actions menu, select New. 

4 (Optional) In the Properties content pane, enter a name and description. The name can contain 
underscores.

5 Click Select to specify a location in the SA Library where you want to save the audit policy. 

6 In the Select Folder window, select a folder for the location. You must have permissions to write to 
the folder where you save the policy. 

7 After you have chosen the location, click Select.

8 In the Audit Policy window, in the Views pane, select Source if you would like to use a managed server 
to base the audit policy’s rules on. 

Note: This step does not apply to ESXi servers.

9 In the Source content pane, click Select to choose a source server for the audit policy.

10 In the Select Server window, select a server and then click OK. 

11 In the Audit Policy window, in the Views pane, select Rules. 
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If you want to link other audit policies to this audit, click  to select an audit policy. 

If you want to edit any of the linked audit policies, from the Rules list, select an audit policy and then 

click  to open the Audit Policy window. 

12 In the Select an Audit Policy window, select one or more audit policies to link to the audit policy, and 
then click OK to save your selections.

If you link one or more audit policies to an audit policy, you can still configure individual rules in the 
audit policy. All rules from an externally referenced audit policy will be combined with any rules you 
create to build one single rule set. 

13 In the Views pane, in the Rules list, create any other rules you want to include in the audit policy. See 
Audit and Snapshot Rules on page 48 in Chapter 2 for information about how to configure specific 
audit and remediation rules.

14 When you are finished configuring the audit, from the File menu select Save. After it is saved, the 
audit policy is ready to be linked to an audit, snapshot specification, or another audit policy. 

Note: In the Audit Policy window, if you select a server to view its registry information, and then want to 
check the registry information for another server, you must close the Audit Policy window, then reopen it 
to refresh the registry-contents field.

•  Ways to Link & Import Audit Policies

Saving an Audit as an Audit Policy

You can save an audit as an audit policy. This action saves only the rules from the audit and then creates a 
new audit policy. If your audit rules require the latest Agent on the target servers, the SA Client displays a 
message reminding you to update the Agents or create exceptions in the audit to avoid runtime errors.

All audit policies you create must be saved in the SA Library in a folder. Each audit policy name within a 
folder must be unique. You must have permissions to write to the folder you want to save the audit policy 
to. For more information on folder permissions, see the SA User Guide: Server Automation or contact 
your SA Administrator. 

To save an audit so that it creates an audit policy: 

1 In the Audit or Snapshot Specification window, from the File menu, select Save As. 

2 In the Save As window, enter a name. If you are renaming an audit or snapshot specification, you 
must use a unique name. 

3 (Optional) Enter a description. 

4 From the Type drop-down list, select Audit, Snapshot Specification, or Audit Policy.

5 If you selected Audit Policy, from the Location section, click Select. 

6 Select a folder in the SA Library to save the audit policy to. You must have write permission on the 
folder to save the audit policy.

7 Click OK.

•  Audit Policies
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Ways to Link & Import Audit Policies

You can import or save an audit policy to an audit, snapshot specification, or another audit policy: 

• Saving an Audit or a Snapshot Specification as an Audit Policy on page 98

• Linking Audit Policies to a Master Audit Policy

• Importing Audit Policy Rules (replace or merge) 

• Saving an Audit or a Snapshot Specification as an Audit Policy on page 98

Linking an Audit Policy to an Audit or a Snapshot Specification

Linking an audit policy to an audit or snapshot specification creates a link that uses the rules from the 
audit policy for the audit or snapshot specification.

Best Practice: Linking to an audit policy is useful when a policy setter wants to define a server 
configuration policy for servers and then have other users link their audits and snapshot specifications to 
the same audit policy. If the policy setter makes any changes to the audit policy, the changes will be 
reflected in the audits or snapshot specifications that are linked to the policy. 

When an audit policy is linked to an audit or snapshot specification, the rules cannot be modified in the 
context of the audit or snapshot specification. However, you can access the audit policy and edit its rules 
if you have the required user permissions. 

If the audit or snapshot specification you are linking the audit policy to already has rules defined, all 
pre-existing rules in the audit or snapshot specification will be overwritten when you link to an external 
audit policy.

To link an audit policy to an audit or snapshot specification: 

1 Open an existing audit or snapshot specification from the SA Library: 

a In the navigation pane, select Library > Audit and Remediation > Audits. Select an operating 
system. From the content pane, open an audit.

b In the navigation pane, open an existing snapshot specification by select Library > Audit and 
Remediation > Snapshot Specifications. From the content pane, open a snapshot specification.

2 From the Actions menu, select Link to Policy. 

3 In the Select an Audit Policy window, select an audit policy to link to the audit or snapshot 
specification. You can only link to one audit policy per audit or snapshot specification. However, you 
can link multiple audit policies to one audit policy. See Creating an Audit Policy on page 94 or 
Linking Audit Policies to a Master Audit Policy on page 97. 

4 After you have selected an audit policy, click OK. 

If you are linking an audit policy to an audit or snapshot specification that already has rules defined, a 
message prompts you to confirm whether you want to overwrite any existing rule definitions. Click 
Yes to import the audit policy and overwrite pre-existing rules.

5 From the File menu, select Save to save the audit or snapshot specification.
96 Chapter 2



Linking Audit Policies to a Master Audit Policy

Linking an audit policy to another audit policy enables you to combine multiple audit policies into a single, 
master audit policy. Because you can link as many audit policies as you want to an audit policy, you can 
build and reuse existing audit policies as a single audit policy that meets a specific auditing need. 

When you link one or more audit policies to an audit policy, the linked audit policies become children of 
the parent (or master) audit policy. If you create an audit that links to the parent audit policy, when you 
run the audit on a target server, the rules from all linked policies are run against the target server.

Example: Your SA Library contains several individual audit polices that define compliance standards for a 
group of HP-UX servers. One policy contains rules that check to make sure the FTP services are enabled. 
Another policy contains rules that check to make sure that cron logging is always enabled. In this 
example, you can create a single master audit policy that links to these two policies. This master audit 
policy can, subsequently, be referenced to by other audits. 

To link audit policies to a master audit policy: 

1 In the navigation pane, select Library > By Type > Audit and Remediation > Audit Policies.

2 Select an operating system.

3 Select an existing audit policy or create a new audit policy. See Creating an Audit Policy on page 94.

4 In the Audit Policy window, in the Views pane, select Source if you want to use a managed server to 
base the audit policy’s rules on. 

Note: This step does not apply to ESXi servers because they are not managed servers.

a Click Select to choose a source server for the audit policy.

b In the Select Server window, select a server and then click OK. 

5 In the Audit Policy window, in the Views pane, select Rules 

a If you want to link other audit policies to this audit, click  to select an audit policy. 

b If you want to edit any of the linked audit policies, from the Rules list, select an audit policy and 

then click  to open the Audit Policy window. 

6 In the Select an Audit Policy window, select one or more audit policies to link to the audit policy and 
then click OK to save your selections. 

If you link one or more audit policies to an audit policy, you can still configure individual rules in the 
audit policy. All rules from an externally referenced audit policy will be combined with any rules you 
create in the audit policy. 

7 In the Views pane, in the Rules list, create any other rules you want to include in the audit policy. See 
Audit and Snapshot Rules on page 48.

If you want to edit any of the linked audit policies, from the Rules list, select an audit policy and then 

click then click .

8 When you are finished configuring the audit policy, from the File menu select Save. After it is saved, 
the audit policy is ready to be linked to another audit policy.
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Importing Audit Policy Rules

Importing an audit policy into an audit or snapshot specification allows you to import (and optionally 
merge) an audit policy’s rules into an audit or a snapshot specification, without keeping a link to the audit 
policy. 

After you import an audit policy, there is no longer a connection to that audit policy. Any changes made to 
the source audit policy are not reflected where the audit policy was imported into. 

To import an audit policy into an audit: 

1 Open an existing audit or snapshot specification from the SA Library: 

a In the navigation pane, select Library > Audit and Remediation > Audits. Select an operating 
system. From the content pane, open an audit.

b In the navigation pane, open an existing snapshot specification from select Library > Audit and 
Remediation > Snapshot Specifications. From the content pane, open a snapshot specification.

2 From the Actions menu, select Link to Policy. 

3 If the audit or snapshot specification already has rules defined, choose to either to overwrite the 
existing rules or merge the audit policy rules with the existing rules. 

Best Practice: Depending on the rule type, merging rules can produce different results. As a best practice, 
review all resulting rules to make sure that the merged audit policy rules meet your requirements or need 
to be modified.

If you click Yes, the audit policy will overwrite any existing rules in the audit or snapshot specification.

If you click No, the audit policy will merge the audit policy rules with any existing rules. If any conflicts 
are found, the audit policy rules will overwrite any existing rules. 

4 From the File menu, select Save to save the audit or snapshot specification.

Saving an Audit or a Snapshot Specification as an Audit Policy

You can save an audit or a snapshot specification’s rules as an audit policy. The audit policy can then be 
used in another audit or snapshot specification. If your audit rules require the latest Agent on the target 
servers, the SA Client displays a message reminding you to update the Agents or create exceptions in the 
audit to avoid runtime errors.

All audit policies you create must be saved in the SA Library in a folder. Each audit policy name within a 
folder must be unique. To save an audit policy to a folder, you must have permissions to write to that 
folder. For more information on folder permissions, see the SA User Guide: Server Automation or 
contact your SA administrator. 

To save an audit or snapshot specification as an audit policy:

1 Open an existing audit or snapshot specification from the SA Library: 

a In the navigation pane, select Library > Audit and Remediation > Audits. Select an operating 
system. From the content pane, open an audit.

b In the navigation pane, open an existing snapshot specification from select Library > Audit and 
Remediation > Snapshot Specifications. From the content pane, open a snapshot specification.

2 After you have configured the audit’s or the snapshot specification’s rules, from the File menu, select 
Save As.

3 In the Save As window, enter a name and description.
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4 In the Type list, select Audit Policy.

5 Click Select.

6 In the Select Folder window, choose a folder where you want to save the audit policy and then click 
OK. The audit policy is saved and can be accessed at Library > Audit and Remediation > Audit 
Policies.

Locating an Audit Policy in the Folder Library

After you create and save an audit policy to the folder library, you can easily find the audit policy in the SA 
Library by using the Locate in Folders feature.

To locate an audit policy in folder: 

1 In the navigation pane, select Library > By Type > Audit and Remediation > Audit Policies, and then 
select an operating system.

2 Select an audit, right-click, and then select Locate in Folders. The location where the audit policy is 
saved is displayed. 

Exporting an Audit Policy

If you want to get a list of all the rules contained and configured in an audit policy, you can export the 
policy to CSV and HTML. 

To export an audit policy: 

1 In the navigation pane, select Library > By Type > Audit and Remediation > Audit Policies.

2 Select an operating system.

3 Open an audit policy:

a Select an audit and then double-click.

Or

b Select an audit, right-click, and then select Open.

4 From the Actions menu, select Export, then select one of the formats (CSV, HTML). 

5 Select a path and filename for the file, and then click Export.

6 Open the file to view the exported information.

Note: To view the exported information correctly, open the .csv file with a text editor, turn off word wrap, 
and extend the text window horizontally.

Viewing Compliance of an Audit Policy

In the Audit Policy browser, you can view the status of managed servers (targets) that are attached to a 
certain audit policy. 

When you create an audit policy and a target references it, you must run the audit to display its 
compliance information in this browser. At least one audit run or an existing audit result that links the 
audit policy to the target is required to display the compliance status of the target server.
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Best Practice: Select audit policies that are critical for maintaining compliance in your data center. You 
can also see which managed servers are non-compliant. Compliance status is based on the latest audit 
results and/or any audit policy changes.

To view compliance of an audit policy:

1 In the navigation pane, select Library > By Type > Audit and Remediation > Audit Policies.

2 Select an operating system.

3 Select an existing audit policy.

4 In the Audit Policy window, in the Views pane, select Compliance. 

The content pane lists all managed servers that are referenced in the audit policy and their 
compliance status.

5 (Optional) To view detailed information about a server in the list, select it and then click View to 
display the Server browser.

•  Audit Policy Management

•  Audit Compliance

Audit Results 

An audit defines the server configurations that you want to check on a server, according to the audit’s 
rules. Audit results are produced by running an audit. These results show the differences between the 
audit rules and the actual server configuration values for each target server or target snapshot. 

Whether or not you can remediate a rule depends on the rule type. The rule must support remediation and 
the source of the audit rule for that server must contain data to support the remediation. 

Example: Some rules do not support remediation, such as a Hardware rule. You cannot remediate a 
server’s physical memory or hardware. Also, if your audit is using a snapshot as a source and the 
snapshot was unable to gather sufficient information from a rule, that rule will not be remediated.

For audits that link to audit policies, the results will show all rules in the audit. However, the results do not 
show the audit policy or policies where the rules were originally defined.

•  Audit & Remediation Rules

•  Remediating Rules with Inherited Values

•  Audit Result Window

•  Remediation Methods: All, By Server, or By Rules

•  Remediating Audits Attached to Servers

•  Remediating Rules with Inherited Values

•  Viewing and Remediating Audit Results Differences

•  Viewing Audit Results with Exceptions
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Viewing Audit Results

In the SA Client, you can view a list of audit results for any audit, as shown in Figure 17. When you select 
an audit in the Library, all results associated with that audit are listed in the bottom details pane.

figure 17 Audit Results 

Audit Result Window

The Audit Result window provides detailed information about your audit job, such as the differences 
between servers targeted by the audit and the rules defined in the audit, as shown in Figure 18. This 
information helps you see whether the servers that have been audited are in compliance with the 
standards set for your data center.

figure 18 Audit Result Window

It is a known limitation that SA does not assume that only the name uniquely identifies a package 
(Registered Software Rule).
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Example: If you have a rule checking installation of a certain package (Registered Software Rule) with a 
certain version number on a server and the audit finds a package with the same package name but with a 
different version number, SA does not indicate that it is the package you are looking for. Instead, SA 
indicates that the rule did not find the package.

Views

The Views pane shows an overview of the audit results, including remediation options and servers 
(targets) grouped by their compliance status.

• Summary: Remediation options that allow you to remediate by server, by rule, or remediate all rules 
on all servers. Remediation is only available in instances where the target server configurations do 
not match the rule definitions in the audit. This Summary view also shows the source server used in 
the audit that the results are based on. The source of an audit can be a server, a snapshot, or no 
source at all. However, some rules require a source. See Audit Elements on page 28.

• Compliant:  Servers that match all rules in the audit.

• Non-Compliant:  Servers that did not match all rules in the audit.

• Scan Failed:  Servers that the audit was unable to determine the target server configuration for, 
such as servers that cannot communicate with the SA core.

• Skipped:  Servers that were skipped.

Summary

The Summary pane shows the following information about your audit job:

• Created, Created By: When the audit was created and the name of the user who created it.

• Source: The source server used in the audit that the results are based on. The source of an audit can 
be a server, a snapshot, or no source at all. However, some rules require a source. See Audit Elements 
on page 28.

• Rules: View Rules Details... This link opens the Rules window so that you can view the audit’s rule.

• Warnings: The number of warnings discovered during the audit.

• Object ID: An internal identification number that is used by the SA Client.

• Compliant:  The number of servers that matched all rules in the audit.

• Non-Compliant:  The number of servers that did not match all rules in the audit.

• Scan Failed:  The number of servers that the audit was unable to determine the target server 
configuration for, such as servers that cannot communicate with the SA core.

• Skipped:  Servers that were skipped.

• Run Partial Audit: This link allows you to select servers and re-run the audit on only those rules that 
have a Non-Compliant or Scan Failed compliance status.
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Details

The details pane lists all servers that the audit was run against, the compliance status of each server and 
counts of how many rules in the audit are compliant, non-compliant, and scan failed. Counts for excepted 
rules and failed rules are also shown. 

Use the column selector tool  to change your display preferences. To rearrange the order of columns, 
click the column heading and then drag it left or right to change your display preferences.

• Compliant:  The number of rules for which target server configurations matched the rules in the 
audit.

• Non-Compliant:  The number of target server configurations that did not match the rules in the 
audit.

• Scan Failed:  The number of rules for which the audit was unable to determine the target server 
configuration for, such as servers that cannot communicate with the SA core.

• Skipped:  Servers that were skipped.

•  Remediation Methods: All, By Server, or By Rules

•  Remediating Comparison-Based Audit Results

•  Remediating Rules with Inherited Values

Remediation Methods: All, By Server, or By Rules

In the Audit Result window, there are several ways to remediate non-compliant rules in audit results: 

• Remediate All: In the Audit Result window, from the Actions menu, select Remediate all to remediate 
differences found in the audit results. 

• Remediate by Server: Remediate by servers targeted by the audit results. 

• Remediate By Rule: Remediate specific, individual audit rules.

SA does not support the remediation of the following two values on Windows Server 2000 servers for the 
Windows Local Security Settings rule, under Security Options: Rename AdministratorAccount and Rename 
Guest Account.

In this release, you cannot remediate ISAPI filters for the IIS 7.0 audit rule. 

Remediate All

You can select to remediate all differences found in an audit result for all rules that are remediable. This 
option remediates all remediable rules on all servers targeted by the audit. Rules that have a status of 

Compliant  are not remediated when the audit is run. 

To remediate all differences found in an audit results:

1 In the navigation pane select Library > By Type > Audit and Remediation > Audits.

2 Select an audit. In the details pane below the audit list, all audit results associated with the audit are 
displayed. 

3 Select an audit result, right-click, and then select Open. 
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4 In the Audit Result window, from the Actions menu select Remediate All. 

5 In the Remediate Audit window, step one shows the name of the audit, the target of the audit, and the 
total number of rules defined in the audit. If you want to bypass all audit task steps, click Start Job to 
immediately run the audit job. 

6 Click Next. 

7 In the Scheduling page, specify whether you want the audit to run immediately or at a later time and 
date. To run the audit at a later time, select Run Task At and then specify a day and time. 

8 Click Next.

9 In the Notifications page, by default your user will have a notification email sent when the audit 
completes, whether or not the audit job is successful. To add an email notifier, click Add Notifier and 
enter an email address. 

10 (Optional) You can specific whether you want the email to be sent on success or failure of the audit 
job. 

11 (Optional) You can specify a Ticket Tracking ID in the Ticket ID field. The ticket ID field is only used 
when HP Professional Services has integrated SA with your change control systems. Otherwise, leave 
this field empty.

12 Click Next.

13 In the Job Status page, click Start Job to run the audit. When the audit has run, click View Results to 
view the results of the audit.

Remediate By Rule

You can remediate specific differences found in rules in audit results by selecting individual rules that are 
out of compliance, and then re-running the audit to remediate only the rules you select. You can select to 
remediate by individual rule for all servers targeted by the audit, or choose only selected servers to have 
rules remediated. 

To remediate specific differences found in audit results:

1 In the navigation pane select Library > By Type > Audit and Remediation > Audits.

2 Select an audit. 

3 In the details pane below the audit list, you see all audit results associated with the audit. 

4 Select an audit result, right-click, and select Open. 

5 In the Audit Result window, expand the Summary list, and then select Remediate By Rule. All 
differences discovered by rule in the audit results are displayed.
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6 For each rule you want to remediate, select the check mark in the list in the Enable Remediation 
column. This means that when you remediate the audit results, the rule will be remediated on all 
servers targeted by the audit that the rule is applied to. 

If you want to globally select all rules, right-click and then select Select All. To deselect all rules, 
right-click and then select Deselect All. 

7 When you have selected the rules you want to remediate, from the Actions menu, select Remediate. 

8 In the Remediate Audit window, step one shows the name of the audit, the target of the audit, and the 
total number of rules defined in the audit. If you want to bypass all audit task steps, click Start Job to 
immediately run the audit job. 

9 Click Next. 

10 In the Scheduling page, specify whether you want the audit to run immediately or at a later time and 
date. To run the audit at a later time, select Run Task At and then specify a day and time. 

11 Click Next.

12 In the Notifications page, by default your user will have a notification email sent when the audit 
completes, whether or not the audit job is successful. To add an email notifier, click Add Notifier and 
enter an email address. 

13 (Optional) You can specific whether you want the email to be sent on success or failure of the audit 
job. 

14 (Optional) You can specify a Ticket Tracking ID in the Ticket ID field. The ticket ID field is only used 
when HP Professional Services has integrated SA with your change control systems. Otherwise, leave 
this field empty.

15 Click Next.

16 In the Job Status page, click Start Job to run the audit. When the audit has run, click View Results to 
view the results of the audit.
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Remediate by Server

You can remediate specific differences found in rules in audit results by the server that the audit targets. 
You can select to remediate all rules on all servers, or, for all rules on selected servers. 

To remediate specific differences found in an audit results by server:

1 In the navigation pane select Library > By Type > Audit and Remediation > Audits.

2 Select an audit. 

3 In the details pane below the audit list, all audit results associated with the audit are displayed. 

4 Select an audit result, right-click, and then select Open. 

5 In the Audit Result window, expand the Summary list. 

6 The contents pane lists servers targeted by the audit. For each server you want to audit, select the 
check box next to the server in the list in the Enable Remediation column, and then click Run Partial 
Audit.

Or

You can and expand the list of servers in the Views pane, and for each server you see all differences 
discovered on all servers targeted by the audit.

For each server you want to remediate, select the check mark in the list in the Enable Remediation 
column. This means that when you remediate the audit results, all rules will be remediated on the 
selected servers. 

Or

If you want to globally select all servers in the audit results, right-click and then select Select All. To 
deselect all servers, right-click and then select Deselect All. 

7 When you have selected the servers you want to remediate, from the Actions menu, select 
Remediate. 

8 In the Remediate Audit window, step one shows the name of the audit, the target of the audit, and the 
total number of rules defined in the audit. If you want to bypass all audit task steps, click Start Job to 
immediately run the audit job. 

9 Click Next. 

10 In the Scheduling page, specify whether you want the audit to run immediately or at a later time and 
date. To run the audit at a later time, select Run Task At and then specify a day and time. 

11 Click Next.
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12 In the Notifications page, by default your user will have a notification email sent when the audit 
completes, whether or not the audit job is successful. To add an email notifier, click Add Notifier and 
enter an email address. 

13 (Optional) You can specific whether you want the email to be sent on success or failure of the audit 
job. 

14 (Optional) You can specify a Ticket Tracking ID in the Ticket ID field. The ticket ID field is only used 
when HP Professional Services has integrated SA with your change control systems. Otherwise, leave 
this field empty.

15 Click Next.

16 In the Job Status page, click Start Job to run the audit. When the audit has run, click View Results to 
view the results of the audit.

Remediating Comparison-Based Audit Results

Audit results based on a comparison-based audit allow you to view differences between the source server 
or snapshot and target servers or snapshot. If the audit results fails—that is, it finds differences between 
the source and the target—you can remediate the differences (for most rule types). You can remediate 
the rule values of the source objects in the audit and overwrite the values on the target (or add values 
that exist on the source, but do not exist on the target.)

The Audit Result window shows all the objects defined in the audit in the Views pane. It also shows the 
audit results that failed, the differences found between the audit and the target servers are highlighted in 
light blue font. 

For example, Figure 19 shows audit results for a windows file system rule, where the selected file and 
path exist on both the source (audit rule source server) and the target, but are different, located under the 
Only Both But Different tab of the Audit Result window. 

In the Audit Result window, you can select the Files rule, and from the Actions menu select Remediate.

figure 19 Audit Result for a Comparison-Based Audit Rule 
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In this example where file difference were found between the source and the target, you can double-click 
the rule to view those differences in a separate window. Review the differences information to make sure 
you want to perform the remediation. Then, you can select Remediate from the Actions menu and 
remediate the out-of-compliance rule or schedule the audit to run at a later time. When you remediate, 
the values from the audit (derived from the source) will replaces those on the target server. 

When remediating COM+ objects from snapshot or audit results, the SA Client does not check the version 
of the COM+ object. SA will always remediate the object, whether or not there is any difference between 
them.

Remediating Rules with Inherited Values

If you create an audit rule based on an object that inherits properties from a parent object, be aware that 
if you remediate the rule, the target server object will not inherit the parent object's properties. 

Example: If you created a rule for a Registry entry and that registry entry inherited some values from a 
parent, when you remediate the rule on to a target server, none of the values inherited from its parent 
will be remediated and the rule will show in the audit results as a difference.

Additionally, if your audit checks ACLs for the File, Registry, or IIS Metabase rules, and the user and group 
ACL does not exist, then after the audit is run and after remediation, if user and group do not exist on a 
target, a temporary user and group will be created as an unknown name. The next time you run the audit, 
it will display as unknown—which does not identify the source user. 

Additionally, if you create an IIS Metabase rule from a source server and the metabase object selected for 
the rule inherits its values from a parent Metabase object, differences will show after an audit is run. 

Example: If you remediate once and then rerun the audit and if the source key was not inherited and the 
attribute has an IED when it was created on a target server, the object will be created, based on parent key 
inheritance. When you rerun the audit, the results will show the IED as a difference for the object's 
attribute.

If you have audit results with differences from audits that were created in SA 5.1 and you have upgraded 
to SA 6.x and higher, when you view those audit results in the upgraded version of the SA Client, the 
Differences column in the audit results list will incorrectly display the value of -1 differences. To view the 
actual number of results, open the Audit Result window to see all differences in the results.

Viewing Value-Based Audit Results–Audit Rule Remediation

Value-based audit results indicates if the server configuration matches the values defined in the audit 
rule. You can view the differences between what was defined as the expected value in the rule and the 
actual value found on the target server. Depending on the rule, you can remediate the difference found on 
the target server by replacing it with the value specified in the rule. 

Some value-based rules are not remediable. For example, Windows/Unix users and groups, the Property 
value check is not remediable.
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Figure 20 shows a value-based audit rule in the form of a custom script where the output of the script 
was different than the results of the same script run on the source server. The Status column for the rule 
indicates Non-Compliant, which means the output of the script rule is different between the source and 
the target. To fix the discrepancy, select the Remediate option and select Remediate from the Actions 
menu. Or, double-click the rule and click Remediate.

figure 20 Audit Result for a Value-Based Audit Rule 

Remediating Rules with Inherited Values

If you create an audit rule based on an object that inherits properties from a parent object, be aware that 
if you remediate the rule, the target server object will not inherit the parent object's properties. 

Example: If you created a rule for a Registry entry and that registry entry inherited some values from a 
parent, when you remediate the rule on to a target server, none of the values inherited from its parent 
will be remediated and the rule will show in the audit results as a difference.

Additionally, if your audit checks ACLs for the File, Registry, or IIS Metabase rules, and the user and group 
ACL does not exist, then after the audit is run and after remediation, if user and group do not exist on a 
target, a temporary user and group will be created as an unknown name. The next time you run the audit, 
it will display as unknown—which does not identify the source user. 

Additionally, if you create an IIS Metabase rule from a source server and the metabase object selected for 
the rule inherits its values from a parent Metabase object, differences will show after an audit is run. 

Example: If you remediate once and then rerun the audit and if the source key was not inherited and the 
attribute has an IED when it was created on a target server, the object will be created, based on parent key 
inheritance. When you rerun the audit, the results will show the IED as a difference for the object's 
attribute.

If you have audit results with differences from audits that were created in SA 5.1 and you have upgraded 
to SA 6.x and higher, when you view those audit results in the upgraded version of the SA Client, the 
Differences column in the audit results list will incorrectly display the value of -1 differences. To view the 
actual number of results, open the Audit Result window to see all differences in the results.
Audits, Audit Policies, and Audit Results 109



Viewing and Remediating Audit Results Differences

For some objects in an audit result, you can view those differences between object that exist on both the 
target and the source and that have differences between them. You can also see what is different about 
them and remediate them, if necessary. 

For some audit rules, you can view general differences, such as a service’s status, the release number for 
a patch, a registry key’s value, and so on. For other server objects, such as files, you can view the 
differences of the file’s contents. 

Viewing and Remediating File Differences

For some rules, such as file system, you can view differences between files side by side and line by line. 
You can see lines that were added, deleted, or modified.

To view and remediate contents of two files that differ in an audit:

1 In the navigation pane select Library > By Type > Audit and Remediation > Audits.

2 Select an audit. 

3 In the details pane below the audit list, you see all audit results associated with the selected audit. 

4 Select an audit result, right-click, and select Open. 

5 In the Views pane of the Audit Result window, expand one of the target servers and select a result.

6 In the content pane, expand a target server and select one of the results. 

7 Next, in the content pane, select the On Both but Different tab.

8 Select a file, right-click, and select View Differences. 

9 In the Comparison window, select an item from the Encoding drop-down list to specify the character 
encoding of the data displayed.

If the file in question exceeds 2MB in file size, Audit and Remediation cannot display the file differences.

10 Click the arrows to find the first, next, previous, or last lines that were added, deleted, or modified. 
Differences are highlighted according to the following color scheme:

— Green: This content was added.

— Blue: This content was modified.

— Red: This content was deleted.

— Black: No changes were made to this content.

11 Click Close to close this window.

12 To remediate file differences, from inside the Audit Result window, select either the Only On Source 
tab or On Both But Different tab, select a file, right-click and select Remediate. 

13 In the Select Server window, select a server you want to copy the file from the source to, and then 
click OK.
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Cancelling an Active Remediate Audit Results Job

In the SA Client, you can terminate an active remediate audit results job. An active remediate audit results 
job is one that has already started and is running. 

The terminate action on an active remediate audit results job is known as a soft-cancel. A soft-cancel is 
the activity where a job was partially run and then stopped when you clicked End Job in the Job Status 
step in the Remediate Audit results wizard. Soft-cancel applies only to an active remediate audit results 
job that you want to stop.

You must have permissions to cancel a remediate audit results job that is in progress. In general, if you 
have permission to start a remediate audit results job, you will also be able to stop a remediate audit 
results job that is running. In addition, if you have the Edit or Cancel Any Job permission, you will be able 
to soft-cancel a running remediate audit results job. For more information on audit-related permissions, 
see the SA Administration Guide. To obtain these permissions, contact your SA administrator.

To stop an active remediate audit results job:

1 In the Job Status pane, click End Job. 

This button is enabled only when the job is in progress.

2 The End Job dialog will display. This dialog briefly describes how job termination works:

• The job will not initiate work on any additional servers. 

• If work has started on a server, the job will cancel any steps that can be skipped.

• The Job Status will indicate the steps that were completed or skipped.

3 If the job ends successfully, the final job status will display as Terminated.

4 Click OK to confirm that you want to terminate the job. The Job Status window displays the progress 
of the termination action.

The job status will be Terminated. The server status will be Cancelled. The task statuses will be 
Succeeded or Skipped.

5 When the termination is complete, you can also view the job in the SA Client Job Log. 

In the SA Client navigation pane, select Jobs and Sessions. The Job Logs view displays your job with a 
Terminated status.

•  Terminating Active Jobs

•  Cancelling an Active Audit Job
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Viewing and Remediating Object Differences

For many server objects, such as Users and Groups, IIS Metabase, Windows Registry, and so on, when 
there are differences between the source object and the target object, you can view differences in object 
properties side by side. Each server object will show different windows, depending on the object and if the 
audit rule set was comparison-based (comparison between source and target) or value-based 
(comparison between user-defined audit rule and target). 

For some value-based audit rules, you can remediate the values on the target server. 

To view the contents of two objects that differ:

1 In the navigation pane select Library > By Type > Audit and Remediation > Audits.

2 Select an audit. 

3 In the details pane below the audit list, you see all audit results associated with the selected audit. 

4 Select an audit result, right-click, and select Open. 

5 In the Views pane, expand one of the target servers and select a result.

6 In the Views pane, select an object.

7 In the content pane, select the On Both but Different tab.

8 In the content pane, select an object, right-click, and select Open. You will see a window that shows 
the differences between the object as defined the audit and the object on the target server.

The example in Figure 21 displays the audit Result differences for two IIS Metabase objects, showing 
an attribute of the object that exists on the server but does not exist on the source server, displayed 
in blue font.

figure 21 Comparison-Based Audit Results Difference: IIS Metabase Objects  

For a value-based rule, the difference window will be slightly different and will also include a 
Remediate option, if remediation is possible. This difference window displays the audit rule, including 
the policy value and the actual value found on the target server. 
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The example in Figure 22 shows the permissions differences for a value-based Windows Registry 
rule.

figure 22 Rule-Based Audit Results Difference: Windows Registry Permissions Differences  

9 To remediate the differences, select the Remediate check mark next to each rule. 

10 From the Actions menu, select Remediate. 

11 In the Remediate window, follow the steps to run or schedule the remediation. For more information 
on remediating audit results, see Viewing and Remediating Audit Results Differences on page 110.

Viewing Audit Results with Exceptions

If an audit contains rule exceptions, then the excepted rules are not checked on the target servers when 
the audit is run. However, your audit results will show which of the rules in the audits are exceptions, 
including details about the rule exceptions. 

The manner in which rule exceptions are displayed in audit results depends on the type of rule that has 
been excepted: 

• Custom script and custom or pluggable check rule exceptions (such as those created by developers or 
provided by a EP Content Subscription) appear in the content pane of the Audit Result window. You 
can double-click the rule exception for details on the exception.

• All other rule exceptions, such as file system, registry settings, services, IIS Metabase, and COM+ 

rules, the Audit Result window will display an Exceptions icon  in the Views pane, which you can 
select and see the details of the exception in the contents pane. 
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Searching for an Audit

You can use the SA Client Search tool to find audits in your facility. You can search for audits by name, by 
the operating system, and many other criteria. 

To search for audits: 

1 In the SA Client, make sure the search pane is activated by selecting View > Search pane. 

2 From the top drop-down list, select Audit. 

3 Click the green arrow button or ENTER to execute the search. 

4 The results appear in the content pane. 

If you want to extend your search criteria, add new criteria in the search parameters section at the top of 
the content pane. You can also save the search by clicking Save, or export the Search results. See 
Exporting an Audit Result on page 115.

Note: To view the search results correctly, open the .csv file with a text editor, turn off word wrap, and 
extend the text window horizontally.

Deleting an Audit

To conserve disk space, you can delete audits that you no longer need. You can choose to archive all audit 
results generated from the audit, if you would like to keep a record of the results. 

When you delete an audit, all schedules associated with it are also deleted.

To delete an audit:

1 In the navigation pane, select Library > By Type > Audit and Remediation > Audits.

2 Choose an operating system.

3 Select one or more audits and then select Actions > Delete.

4 In the Confirmation Dialog, click Yes to delete this audit, or click No to cancel. You can also select the 
Archive Audits option, which will archive all audit results generated from the audit. If you do not 
select the Archive option, all audit results from the selected audit will be deleted. 

Deleting Audit Results

Best Practice: Delete audit results that you know you will no longer need.

You must have read permissions for the snapshot to be able to delete it. To obtain these permissions, 
contact your SA administrator. See the SA Administration Guide for more information.

To delete audit results:

1 Select a snapshot or select multiple snapshots and then select Actions > Delete.

2 In the Confirmation Dialog, click Yes to delete this snapshot or click No to cancel.

3 If you want to archive the snapshot instead of delete it, select the snapshot, right-click, and select 
Archive. 

When you delete a snapshot, you do not delete the snapshot specification that was used to create it. See 
Deleting a Snapshot Specification on page 127.
114 Chapter 2



Archiving Audit Results

Best Practice: Some audits yield numerous results, especially audits that are scheduled to run on a 
recurring basis. Archive all audit results to keep a record of all audit results run from an audit. When you 
archive an audit result, SA removes its connection to the original audit; however, the results and targets 
of the audit are kept intact.

To archive audit results: 

1 In the navigation pane select Library > By Type > Audit and Remediation > Audits.

2 Select an operating system.

3 Select an audit. Audit results appear in the panel below the list of audits. 

4 To archive an audit result, select it, right-click, and then select Archive. 

5 In the Continue Archive Audit Result window, click Yes to archive the audit result and remove the link 
between the result and the audit.

6 To view all archived audit results, in the navigation pane, select Library > By Type > Audit and 
Remediation > Archived Audit Results. 

Exporting an Audit Result

You can export an audit result to CSV, HTML, XML, and JSON formats. 

To export an audit result: 

1 In the navigation pane, select Library > By Type > Audit and Remediation > Audits.

2 Select an operating system.

3 Select an audit. Audit results appear in the panel below the list of audits. 

4 Right-click an audit result.

5 Choose Open.

6 In the Audit Result window, choose Actions > Export.

7 Select one of the formats (CSV, HTML, XML, JSON).

8 In the Export window, choose a folder for the exported contents, a file name, an Encoding type, and a 
file type. 

9 Click Export. 

The export-progress bar appears. Before SA connects with the server, the status bar is in 
indeterminate mode and displays the message: “Fetching data...”. Once a connection is established, 
the bar displays export progress status in terms of number of export tasks completed. 

10 Click Stop to stop the export process.

11 Click Run In Background to close the progress window and continue to run the export process in the 
background. 

When you click Run in Background, a temporary window appears for a few seconds in the lower right 
corner. Click the link in this temporary window to reactivate the progress bar display. 
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12 For non-HTML export types, click Close to close the progress bar display when the export process is 
complete.

If the audit export type is HTML, the progress window closes automatically when the export process 
is complete, and the audit results are displayed in a browser.

13 Open the file to view the exported information.

Note: To view the exported CVS information correctly, open the .csv file with a text editor, turn off word 
wrap, and extend the text window horizontally.
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3 Snapshots, Snapshot Specifications, & 
Snapshot Jobs
Snapshots  

A snapshot captures the configuration of a managed server at a particular point in time and provides a 
means of capturing the current state of a known working (or a known not working) server. A snapshot is 
useful for capturing a server configuration that you know represents a desired state of configuration. 

Best Practice: You can also compare the snapshot with other servers in your facility by using the 
snapshot in an audit.

A snapshot is also a useful way to back up a managed server, especially if you plan to make changes to 
the server and want to keep a record of it before you change anything. 

In addition to recording information about objects on managed servers, a snapshot can contain the 
content of some objects. A server snapshot also identifies attributes of other objects on specific types of 
operating systems, such as the Windows Registry and Windows Services, application configurations, 
COM+ objects, hardware information, installed patches, and more. You can even create custom scripts 
that gather data from the target managed servers. 

The SA Client cannot create a snapshot of the entire Windows Registry or a snapshot of all system keys. 
The volume of data is larger than the current design allows.

Snapshot Process

The following tasks are required to create a snapshot of a server configuration: 

• Create a snapshot specification, which is a template that defines the configuration parameters 
captured on a target server. 

• Run the snapshot specification job that results in a snapshot.
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Figure 23 shows the snapshot process, including step-by-step descriptions.

figure 23 Snapshot Process 

Snapshots & Snapshot Specifications

Snapshots are configured in similar way as you configure an audit. First, you create a snapshot 
specification, which is like a template that defines exactly what you want to capture for a server’s 
configuration. Next, you configure the snapshot specification’s rules and then run it. The results are a 
snapshot—a picture of a server’s configuration. The main difference between a snapshot and an audit is 
that a snapshot takes a picture of a server’s configuration, whereas an audit compares a server 
configuration with the rule values that you define. 

You can schedule when you want a snapshot to be created (either once or as a recurring job) and who you 
want to receive email notification about the status of the job.
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Snapshot Used in an Audit

You can use a snapshot in an audit to compare managed servers, groups of servers, and snapshots. By 
using a snapshot in an audit, you can compare a problematic server (target of the audit) with a known 
working server (snapshot as source for the audit). To further extend the audit definition, you can also 
define rules for server objects.

When a snapshot is used as the source for an audit, all server configuration values captured in the 
snapshot results are available to use as rules for the audit.

Snapshot Specification Used in an Audit

You can use a snapshot specification as the source of an audit if you want to keep track of a server’s 
configuration over time and monitor any changes that occur. For example, you might want to keep track 
of a specific application to make sure that its configuration remains correct over a period of time. If this 
application runs on several servers, you can create a snapshot specification that defines a desired state of 
server configuration, and then run the snapshot. 

Next, you can create an audit and use the original snapshot specification as the source for your audit. 
Each server that was targeted by the snapshot are now also included as targets of the audit. Next, when 
you run the audit (either on-demand or on a scheduled basis), each server’s current configuration will be 
compared with the state originally captured when you took the initial snapshot. Any changes are 
displayed in the audit results window. 

Snapshot Specification Elements

A snapshot specification consists of the following elements: 

• Properties: The name and description of the snapshot specification. If you want to create an 
inventory of some snapshot specification rules, you can select the Perform Inventory and the 
snapshot result will collect all information about the specific rules from the target servers. This 
option applies to the following rules: Discovered Software, Internet Information Server, Local 
Security Settings, Registered Software, Windows and Unix Users and Groups. 

• Targets: The servers that you want to take a snapshot of — that is, capture the specific server 
configuration as defined in the snapshot specification’s rules. You can choose as many servers and 
groups of servers as you want. 

• Source: The source of a snapshot specification. If you choose a server then you can select server 
objects from that server as the basis of your snapshot. The source of a snapshot specification can be 
a server, or no source at all. (Some rules require a source server. Other rules can be defined by your 
own custom values without a source.) 

Note: You cannot use a server as the source for ESXi.

• Note that the value of a source parameter is not used when taking a snapshot. It only has meaning 
when defining a snapshot specification.

• Rules: A check on a particular server object with a desired value and an optional remediation value. 
For example, you might check if a server contains a specific Windows Service, and if found, determine 
if the service is turned off. For a description of server objects that you can define rules for in a 
snapshot specification, see Audit & Remediation Rules on page 46. 

• Schedule: The time the snapshot will run. You can run the snapshot specification as a job on a 
onetime basis, or on a recurring schedule. 
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• Notifications: The email notification send after the snapshot has run. You can base the notification 
on success, failure, or simply the completion of the snapshot specification job. 

When you set up a snapshot specification, you select the objects to check for on the target server. You can 
also apply rules to these objects that define their desired configuration state. For some rules, you can 
define remediation values, in the event that the resulting snapshot is used as the source for an audit. 

Figure 24 shows a snapshot specification that has three rules that will capture configuration information 
about the target server for event logging, operating system, and windows services.

figure 24 Snapshot Specification Server Objects 

Viewing Snapshots 

After you have created a snapshot, you can view it in several locations in the SA Client.

In the SA Library

To view snapshots associated with a specific server:

1 In the navigation pane, select Library > By Type > Audit and Remediation > Snapshot 
Specifications. 

2 Select an operating system: Windows or Unix. 

3 In the list, select a snapshot specification. The details pane displays all snapshots that were run from 
the selected snapshot specification. 

In the Device Explorer

To view snapshots associated with a specific server:

1 In the navigation pane, select Devices > Servers > All Managed Servers.
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2 Select a server from the list, right-click, and then select Open. 

3 In the Device Explorer window, select Inventory > Snapshot Specification. 

4 In the content pane, select a snapshot specification. The details pane displays all associated 
snapshots.

5 To view a snapshot, select it and then double-click to open it. 

Searching for Snapshots
You can use the SA Client Search tool to find snapshots in your facility. You can search for snapshots by 
name, by the operating system, and many other criteria.

To search for snapshots: 

1 In the SA Client, select View > Search Pane.

2 From the drop down list, select Snapshot. 

3 Click the green arrow or ENTER to start the search. The results appear in the content pane. 

To expand your search criteria, add additional criteria in the search parameters section at the top of 
the content pane. You can also save the search or export the search results to .html or .csv files.

Note: To view the results correctly, open the .csv file with a text editor, turn off word wrap, and extend 
the text window horizontally.

Viewing Snapshot Results

You can view the contents of a snapshot and view detailed information about the server configurations 
that were recorded.

For information about remediating snapshot results, see Copying Objects on page 124. 

To view the contents of a snapshot:

1 From one of the starting points described in Viewing Snapshots on page 120, open a snapshot.

figure 25 Snapshot of a Windows Server 

2 In the Snapshot window, you can select or expand the following server objects in the Views pane:



• Summary: Displays general information about a snapshot, such as the date and time the 
snapshot was created and by whom, the snapshot source (name of the managed server), the size 
of the snapshot file, a snapshot ID number, the server that the snapshot results reference, and 
the IP address of that server.

You can also click View Rules Details to see the snapshot specification which this snapshot is 
based on. 

• Compliance Library: Information relevant to the specific compliance checks configured in the 
snapshot specification. For more information about the types of BSA Essentials Subscription 
Services compliance checks available and how to configure them, see Configuring Compliance 
Checks on page 77.

• Installed Hardware: Information about the type of CPU processor and speed, cache size, memory 
size for SWAP and RAM, and storage devices that were recorded in the snapshot.

• Installed Patches: Displays information about the installed patches that were recorded in the 
snapshot, such as the patch type.

• Installed Packages: Displays information about the installed packages that were recorded in the 
snapshot, such as package type, package version, and release number. 

• For .zip packages, the Snapshots do not show a version number, but instead displays the install 
path of the package on the server. 

• Event Logging: Displays security, application, and system log files recorded in the snapshot.

• File System: Displays the directories, file properties, attributes, and contents of the files 
recorded in the snapshot.

If a file in the snapshot exceeds 2MB in file size, Audit and Remediation cannot display the file contents.

• Windows Services: Displays information about the running services recorded in a snapshot, such 
as the name, description, startup state, startup type, and log on account.

• Windows Registry: Displays information about Windows Registry entries in the snapshot, such 
as the registry key, registry value, and subkey. A registry key is a directory that contains registry 
values, where registry values are similar to files within a directory. A subkey is similar to a 
subdirectory. The content area in this window excludes subkeys. Audit and Remediation 
supports the following Windows Registry keys: HKEY_CLASSES_ROOT, HKEY_CURRENT_CONFIG, 
HKEY_LOCAL_MACHINE, and HKEY_USERS.
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• COM+: Displays information about Windows COM (Component Object Model) objects in the 
snapshot, such as the name and GUID (Globally Unique Identifier) of the object, and the path to 
the in-process server DLL.

• SA provides warning messages that explain how Windows COM folders were processed. The 
following scenarios apply:

• When you create a snapshot and select a Windows COM folder that does not contain any objects, 
the snapshot window displays a summary. SA displays a warning that the GUID (Globally Unique 
Identifier) for that folder is invalid, which means that the Windows COM folder does not contain 
any objects.

• When you create a snapshot specification and select a Windows COM+ object that does not exist 
on a target, SA displays a warning that the folder is invalid.

• When you create a snapshot and select a Windows COM+ folder that does not contain any 
objects, SA displays a warning that the folder is empty.

• Metabase: Displays information about IIS Metabase objects in the snapshot, such as the ID, 
name, path, attributes, and data of the object.

• Custom Scripts: Displays information about the custom script rule recorded in the snapshot.

• Users and Groups: Displays information about users and groups on servers, such as user name 
for last login, whether or not CTRL + ALT + DELETE is enabled, and so on. 

3 Click Close to close the object browser.

Archiving a Snapshot 

Some snapshot specification yield numerous snapshots, especially those scheduled to run on a recurring 
basis. You can archive all snapshots to keep a record of all snapshots run for a server or group of servers.

When you archive a snapshot, it detaches the snapshot from the server and removes its connection to the 
original snapshot specification.

To archive a snapshot: 

1 In the navigation pane select Library > By Type > Audit and Remediation > Snapshot Specifications.

2 Select an operating system: Windows or Unix.

3 Select a Snapshot Specification. 
The Details pane displays all snapshots associated with the selected snapshot specification.

4 To archive a snapshot, select it, right-click it, then select Archive.

5 Click Yes to confirm that you want to archive the snapshot, since doing so will remove the link 
between the snapshot and the snapshot specification.

6 To view all archived snapshot results, in the navigation pane, select Library > By Type > Audit and 
Remediation > Archived Snapshots.

Deleting a Snapshot

Best Practice: You should delete snapshots from the Software Repository only if you no longer need 
them. This helps conserve disk space.
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You must have read permissions for the snapshot to be able to delete it. To obtain these permissions, 
contact your SA administrator. See the SA Administration Guide for more information.

To delete a snapshot:

1 Select a snapshot or select multiple snapshots and then select Actions > Delete.

2 In the Confirmation Dialog, click Yes to delete this snapshot or click No if you do not want to delete it.

3 If you want to archive the snapshot instead of delete it, select the snapshot, right-click, and select 
Archive. 

When you delete a snapshot, you do not delete the snapshot specification that was used to create it. See 
Deleting a Snapshot Specification on page 127.

Exporting/Importing a Snapshot

Use the snapshot filter to tell DET what snapshot to export from an SA core/mesh so that you can then 
import it into another SA core/mesh. For more information about snapshot filters, see the SA Content 
Utilities Guide.

Copying Objects

From a Snapshot to a Server

After viewing snapshot contents, you can copy certain objects to a target server. SA allows you to copy 
directories, files, windows services (state only), IIS Metabase objects, COM+ objects and categories, and 
Windows Registry keys to a managed server. 

You must have write permission on the destination server to be able to copy an object to it. To obtain 
these permissions, contact your SA Administrator. See the SA Administration Guide for more 
information on permissions.

In order to copy COM+ rule snapshot results from a snapshot to a server, you must have selected the 
“Archive all associated files” option when you configured the COM+ rule. Also the COM+ object being 
copied must not be in use by any application in order for the copy to remediation to work. See Configuring 
the COM+ Rule on page 53. 

Before you copy these objects over to a managed server, it is important to understand what actually gets 
copied to or created on the destination server:

• When you select a directory, only the directory will be copied to the destination server, excluding any 
files in that directory. For example, if dir1 contains file1 and file2, and you select dir1, Audit and 
Remediation copies only dir1 (not file1 and file2) to the destination server.

• When you select a file and its parent directory does not exist on the destination server, Audit and 
Remediation will create the directory on and copy the files to the destination server. For example, if 
you select file1 and dir1 does not exist on the destination server, Audit and Remediation will create 
dir1 on and copy file1 to the destination server.
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• When you copy a Windows Services object, you copy the state of the service, such as started, 
stopped, paused, and so on. You can select one or more Windows Services objects for a single copy 
process.

• When you copy a Windows Registry object, you can select one or more registry keys and subkeys for a 
single copy process. 

• ACLs are not copied along with COM+ objects or Microsoft IIS objects to the target server. 

• When remediating COM+ objects from snapshot results using copy to, the SA Client does not check 
the version of the COM+ object, and thus will always copy the object, whether or not there is any 
difference between them.

To copy an object from a snapshot to a managed server:

1 Open a snapshot. See Viewing Snapshots on page 120.

2 In the Views pane, select a file system, Windows Services, or a Windows Registry object.

3 In the content pane, select one or more objects that you want to copy.

4 Select Actions > Copy To.

5 In the Select Server window, select a destination server.

 Use the search tool to dynamically filter this list by entering a server name, IP address, or 
operating system.

6 Click Select to copy the object to that managed server or click Cancel to close this window without 
saving your changes.

Note: Soft cancel is supported for Audit, Remediation of Audit Result, and Create Snapshot jobs. However, 
Soft Cancel is not supported for snapshot remediation jobs, including ‘Copy To’ from a snapshot to a 
server. 

Snapshot Specifications 

The SA Client lets you perform the following tasks to manage your snapshot specifications:

• Snapshot Specifications & Audit Policies on page 126

• Creating a Snapshot Specification on page 126

• Deleting a Snapshot Specification on page 127

• Configuring a Snapshot Specification on page 127

• Configuring Snapshot Specification Rules on page 129

• Saving a Snapshot Specification as an Audit Policy on page 129

• Running a Snapshot Specification on page 130

• Scheduling a Recurring Snapshot Job on page 131
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Snapshot Specifications & Audit Policies

An audit policy is collection of rules that defines a desired state of a server’s configuration. An audit policy 
can be used inside a snapshot specification, either through linking or importing. An audit policy is useful 
because it allows a policy setter to define server configuration compliance values, which then can be used 
by others in their snapshot specifications. 

Because an audit policy can be linked to an audit or snapshot specification, whenever a change is made to 
the policy, the audit or snapshot specification using the policy will also reflect the latest changes. Or, an 
audit policy can be imported into a snapshot specification, without keeping the link to the source audit 
policy. When you import an audit policy into a snapshot specification, you can choose to replace any 
current values in the audit or merge values from the audit policy with those in the snapshot specification. 

•  Ways to Link & Import Audit Policies

Creating a Snapshot Specification 

You can create a snapshot specification from the following locations in the SA Client:

• From a Server on page 126

• From the SA Library on page 126

You must have a set of permissions to create and modify snapshot specifications. To obtain these 
permissions, contact your SA administrator. See the SA Administration Guide for more information on 
permissions.

From a Server

When you create a new snapshot specification from a managed server, the snapshot specification will use 
the selected server as its source. You can choose several different server sources for the snapshot 
specification as you define the rules or choose no source at all and define your own custom rules. 
However, some rules require a source. 

To take a snapshot of a managed server, the server must be reachable and you must have access to the 
server. 

To create a snapshot specification from a server: 

1 In the navigation pane, select Devices > Servers > All Managed Servers.

2 Select a server and then select Actions > Create Snapshot Specification. 

From the SA Library

If you want to create a new snapshot specification and set all your own rules, create the audit from the SA 
Client Library by performing the following steps: 

1 In the navigation pane, select Library > By Type > Audit and Remediation.

2 In the navigation pane, select snapshot specifications, and then select Windows or Unix.
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Deleting a Snapshot Specification

To conserve disk space, you can delete snapshot specifications that you no longer need. You can choose 
to archive all snapshots generated from the snapshot specification, if you would like to keep a record of 
the results. Or, you can choose to delete the snapshot specification and all snapshots associated with it. 

To delete a snapshot specification:

1 In the navigation pane, select Library > By Type > Audit and Remediation > Snapshot 
Specifications.

2 Select Windows or Unix. 

3 Select one or more snapshot specifications and then select Actions > Delete.

4 In the Confirmation Dialog, click Yes to delete this snapshot specification or click No if you do not 
want to delete it. You can also select the Archive Snapshots option, which will archive all snapshots 
generated from the snapshot. If you do not select the Archive option, all snapshots generated from 
the selected snapshot specification will be deleted. 

When you delete a snapshot specification, all schedules associated with it are also deleted. See Snapshot 
Jobs on page 130.

Configuring a Snapshot Specification 

The following tasks are required to configure a snapshot specification:

• Name and describe the snapshot specification, and decide if you want to perform an inventory. 

• Choose target servers you want to take a snapshot of. You can choose to snapshot multiple servers 
or groups of servers. 

• Configure your own custom rules, or choose settings from a source server to serve as the basis for 
the snapshot specification rules.

• Schedule the snapshot specification job to run once or on a recurring schedule. 

• Set up email notifications to notify users when the snapshot specification job finishes successfully, if 
the job fails, or on both conditions. 

• Save the snapshot specification.

If you take a snapshot of COM+ objects from a 32 bit Windows server and you attempt to remediate the 
results using copy to on to a Windows 64 bit server, this action might fail.

To configure a snapshot specification:

1 In the navigation pane, select Library > By Type > Audit and Remediation.

2 In the navigation pane, select Snapshot Specifications, then either Windows or Unix.

3 From the Actions menu, select New.

4 In the Snapshot Specification window, enter the following information: 

• Properties: Enter a name and description for the snapshot specification. Also, for certain 
snapshot specification rules (Discovered Software, Internet Information Server, Local Security 
Settings, Packages and Patches, Windows and Unix Users and Groups), you can select the 
Perform Inventory option, which will capture all resources associated with the rule.
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• Source: Select a source for the snapshot specification. By default, the source server for the 
snapshot specification will be the managed server that you chose as the source for the snapshot 
specification. Browse the source server for values to populate the snapshot specification’s rules. 
You can also choose a different source server as the basis of the snapshot specification for each 
rule category, or no source at all. If you choose no source, you must define your own rules, or 
choose to link to an audit policy in the rules section. 

• Rules: Choose a rule category from the list to begin configuring your snapshot specification’s 
rules. Since each rule is unique and requires its own instructions, to configure specific rules see 
Audit & Remediation Rules on page 46. 

If you want to use an audit policy to define the rules of your snapshot specification, click either 
Link Policy or Import Policy. When you link an audit policy, the snapshot specification maintains 
a direct connection with the audit policy, so if any changes are made to the policy, the snapshot 
specification will update it with the new changes. If you import an audit policy, the snapshot 
specification will use all the rules defined in the policy but will not maintain a link to the audit 
policy. For information on how to import or link to a snapshot specification, see Ways to Link & 
Import Audit Policies on page 96. 

• Targets: Choose the Targets of the snapshot specification. These are servers or groups of 
servers that you want the configured snapshot specification rules to capture. To add a server or 
group of servers, click Add. To choose a source server to use to create the snapshot specification 
rules, click Select. 

• Schedule: Choose to run the snapshot specification immediately, or on a recurring schedule. 
Choose whether you want to run it once, daily, weekly, monthly, or on a custom schedule. 
Parameters include: 

• None: No schedule will be set. To run the snapshot specification, select the snapshot 
specification, right-click, and select Run snapshot specification. 

• Daily: Choose this option to run the snapshot specification on a daily basis. 

• Weekly: Choose a day of the week to run the snapshot specification. 

• Monthly: Choose the months to run the snapshot specification. 

• Custom: In the Custom Crontab string field, enter a string the indicates a time schedule. 

A crontab file has five fields for specifying the day of the week, the month, the day of the month, 
the hour, and the minute. The following diagram shows each position in the crontab file, what 
the position corresponds to, and the allowed values:

The crontab string can include serial (1,2,3,4) and range (1-5) values. Only some operating 
systems support the minutes format /2 or /10 for running the audit every 2 minutes or 10 
minutes. An asterisk (*) denotes all values for that field, such as all months of the year. Days can 
be specified in two fields: month day and week day. If both days are specified, both of the values 
will be executed. All operating systems support comma-separated values within each field. For 
example:

5,10 0 10 * 1 means run an audit 12.05 and 12.10 AM every month or on the 10th and on every 
Monday.
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For more information about crontab entry formats, consult the Unix man pages.

• Time and Duration: For each type of schedule, specify the hour and minute you want the daily 
schedule to start. Unless you specify an end time, the snapshot specification will keep running 
indefinitely. To choose an end date to end the snapshot specification schedule, select End, and 
from the calendar selector, choose a date. The Time Zone is set according to the time zone set in 
your user profile. 

• Notifications: Enter the email addresses (separated by a comma or a space) of those you want 
to receive an email when the snapshot specification Job finishes running. You can choose to send 
the email notification on both success and the failure of the snapshot specification job (not the 
success of the audit rules). To add an email address, click Add Notification Rule.

5 When you have finished configuring the snapshot specification, from the File menu, select Save.

To prevent runaway processes, the snapshot process will time out if it exceeds 60 minutes or if the data 
that is collected from a managed server exceeds 1 gigabyte (GB). If you specify that you want to collect 
the full contents of files in the selection criteria, the data collected might exceed the maximum size that 
can be successfully recorded in a snapshot.

Configuring Snapshot Specification Rules

For information on how to configure specific snapshot specification rules, see Audit & Remediation Rules 
on page 46.

Saving a Snapshot Specification as an Audit Policy

You can save selection criteria used in a snapshot and save it as an audit policy. This can be useful if you 
would like to use the rules configured in a snapshot specification for other snapshot specifications or 
audits. If your audit rules require the latest Agent on the target servers, the SA Client displays a message 
reminding you to update the Agents to avoid runtime errors.

All audit policies you create must be saved in the SA Library in a folder. You must have permissions to 
write to the folder you want to save the audit policy to. For more information on folder permissions, see 
the SA User Guide: Server Automation or contact your SA Administrator.

To save your snapshot specification as an audit policy:

1 Launch the SA Client. 

2 In the navigation pane, select Library > By Type > Audit and Remediation. 

3 Select Snapshots Specification and then double-click a snapshot specification that you want to save 
as an audit policy.

4 In the Snapshot Specification window, select File > Save As.

5 In the Save As window, enter a name and a brief description. 

6 From the Type drop-down list, select Audit Policy. 

7 Click Save. The selected snapshot specification has been saved as an audit policy. 

8 To view the audit policy, from the navigation pane, select Library > By Type > Audit and 
Remediation > Audit Policies. For more information about using audit polices, see Audit Policy 
Management on page 92.
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Running a Snapshot Specification 

When you run a snapshot specification, SA captures (from the target servers) all configuration 
parameters configured in the rules. After you run a snapshot specification, the results of the snapshot job 
become a snapshot and can be viewed inside the snapshot. 

To run a snapshot specification: 

1 In the navigation pane, select Library > By Type > Audit and Remediation.

2 In the navigation pane, select Snapshot Specifications.

3 Select Windows or Unix.

4 Select a snapshot specification, right-click, and then select Run. In the Run Snapshot Specification 
window, step one shows you the name of the snapshot, the total number of rules defined, and all 
targets. 

5 Click View Rules Details to view the rule definitions.

6 Click Next. 

7 In the Scheduling window, choose whether you want the audit to run immediately or at a later date 
and time. To run the audit at a later time, select the second option and choose a date and time. 

8 Click Next.

9 In the Notifications view, by default your user will have a notification email sent when the audit 
completes, whether or not the audit job is successful. To add an email notifier, click Add Notifier and 
enter an email address. 

10 (Optional) You can specify if you want the email to be sent on success of the audit job ( ) or 

failure of the audit job ( ). 

11 (Optional) You can specify a Ticket Tracking ID in the Ticket ID field. The ticket ID field is only used 
when HP Professional Services has integrated SA with your change control systems. Otherwise, leave 
this field empty.

12 Click Next.

13 In the Job Status view, click Start Job to run the audit. When the audit has run, click View Results to 
view the results of the audit.

Snapshot Jobs

A snapshot specification job enables you to specify when you want the SA Client to create a snapshot 
(either once or on a recurring basis) and who you want to receive email notification about the status of the 
job. You can also view, edit, and delete existing snapshot specification schedules. When you delete a 
snapshot specification, all schedules associated with that snapshot specification will be deleted.

The SA Client lets you perform the following tasks to manage your snapshot jobs:

• Scheduling a Recurring Snapshot Job on page 131

• Viewing and Editing a Snapshot Job Schedule on page 132

• Deleting a Snapshot Job Schedule on page 133
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Scheduling a Recurring Snapshot Job

After you have created, configured, and saved an snapshot specification, you can schedule snapshot 
specification a recurring snapshot job. After the schedule is set, you can edit the schedule according to 
your needs. 

To schedule a recurring snapshot specification:

1 In the navigation pane, select Library > By Type > Audit and Remediation > Snapshot 
Specifications. 

2 Select either Windows or Unix.

3 Select a snapshot and then double-click to open it. 

4 In the Snapshot Specification window Views pane, select Schedule.

5 In the Schedule section, choose to run the snapshot job immediately or on a recurring schedule. 
Choose to run it once, daily, weekly, monthly, or on a custom schedule: 

• None: No schedule will be set. To run the snapshot job, select the snapshot specification, 
right-click, and select Run Audit. 

• Daily: Choose to run the snapshot job on a daily basis. 

• Weekly: Choose a day of the week to run the snapshot specification job. 

• Monthly: Choose the months to run the snapshot specification job. 

• Custom: In the Custom Crontab string field, enter a string the indicates a time schedule. 

A crontab file has five fields for specifying the day of the week, the month, the day of the month, 
the hour, and the minute. The following diagram shows each position in the crontab file, what 
the position corresponds to, and the allowed values:

The crontab string can include serial (1,2,3,4) and range (1-5) values. Only some operating 
systems support the minutes format /2 or /10 for running the audit every 2 minutes or 10 
minutes. An asterisk (*) denotes all values for that field, such as all months of the year. Days can 
be specified in two fields: month day and week day. If both days are specified, both of the values 
will be executed. All operating systems support comma-separated values within each field. For 
example:

5,10 0 10 * 1 means run an audit 12.05 and 12.10 AM every month or on the 10th and on every 
Monday.

For more information about crontab entry formats, consult the Unix man pages.

• In the Time and Duration section, for each type of schedule, specify the hour and minute you 
want the daily schedule to start. Unless you specify an end time, the snapshot specification job 
will keep running indefinitely. To choose an end date to end the audit schedule, select End, and 
then choose an end date. The Time Zone is set according to the time zone set in your user profile. 

• (Optional) Deselect the End option if you want the snapshot specification job to run indefinitely.
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6 To save the snapshot specification job schedule, from the File menu select Save. The snapshot 
specification will now run according to the defined schedule. 

Viewing and Editing a Snapshot Job Schedule

You can edit a snapshot specification schedule after you have created (or edited) and saved it.

To edit a scheduled snapshot specification:

1 In the navigation pane, select Jobs and Sessions.

2 Select Recurring Schedules.

3 From the drop-down list, select Create Snapshot. The list shows all scheduled snapshot specification 
jobs.

4 To view a scheduled snapshot specification, double-click one.

5 Select the Schedule object in the Views pane.

6 To edit the snapshot specification job schedule, modify the following parameters: 

• Schedule: Choose to run the snapshot specification immediately, or on a recurring schedule. 
Choose to run it once, daily, weekly, monthly, or on a custom schedule. Parameters include: 

• None: No schedule will be set. To run the snapshot specification, select the snapshot 
specification, right-click, and select Run snapshot specification. 

• Daily: Choose to run the snapshot job on a daily basis. 

• Weekly: Choose the day of the week you want the snapshot job to run. 

• Monthly: Choose the months to run snapshot specification job. 

• Custom: In the Custom Crontab string field, enter a string the indicates a time schedule. 

A crontab file has five fields for specifying the day of the week, the month, the day of the month, 
the hour, and the minute. The following diagram shows each position in the crontab file, what 
the position corresponds to, and the allowed values:

The crontab string can include serial (1,2,3,4) and range (1-5) values. Only some operating 
systems support the minutes format /2 or /10 for running the audit every 2 minutes or 10 
minutes. An asterisk (*) denotes all values for that field, such as all months of the year. Days can 
be specified in two fields: month day and week day. If both days are specified, both of the values 
will be executed. All operating systems support comma-separated values within each field. For 
example:

5,10 0 10 * 1 means run an audit 12.05 and 12.10 AM every month or on the 10th and on every 
Monday.

For more information about crontab entry formats, consult the Unix man pages.
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• Time and Duration: For each type of schedule, specify the hour and minute, the day of the week 
(and month) you want the daily schedule to start. Unless you specify an end time, the snapshot 
specification job will keep running indefinitely. To choose a date to end the snapshot 
specification job schedule, select End and then choose a date. The Time Zone is set according to 
the time zone set in your user profile. 

• (Optional) Deselect the End option if you want the snapshot specification schedule to run 
indefinitely.

7 To save the snapshot specification schedule, from the File menu select Save. The snapshot job will 
now run according to the defined schedule.

Deleting a Snapshot Job Schedule

To delete a snapshot job schedule:

1 In the navigation pane, select Jobs and Sessions. 

2 Select Recurring Schedules. 

3 From the drop-down list, select Create Snapshot. 

4 The content pane displays all snapshot specification jobs that have been run on this SA core. To 
display only snapshot specification jobs, from the drop-down list at the top of the content pane, 
select Run Snapshot Task. If you want to see only those snapshot specifications that you have 
scheduled or run, enter your user ID in the User ID field at the top of the content pane. 

5 To delete the schedule, select it, right-click, and then select Delete Schedule.

Cancelling an Active Snapshot Job

In the SA Client, you can terminate an active snapshot job. An active snapshot job is one that has already 
started and is running. 

The terminate action on an active snapshot job is known as a soft-cancel. A soft-cancel is the activity 
where a job was partially run and then stopped when you clicked End Job in the Job Status step in the 
Snapshot Servers wizard. Soft-cancel applies only to an active snapshot job that you want to stop.

Note: Soft cancel is supported for Audit, Remediation of Audit Result, and Create Snapshot jobs. However, 
Soft Cancel is not supported for snapshot remediation jobs, including ‘Copy To’ from a snapshot to a 
server. 

You must have permissions to cancel a snapshot that is in progress. In general, if you have permission to 
start a snapshot job, you will also be able to stop a snapshot job that is running. In addition, if you have 
the Edit or Cancel Any Job permission, you will be able to soft-cancel a running snapshot job. For more 
information on audit-related permissions, see the SA Administration Guide. You can also obtain these 
permissions from your SA administrator.

To stop an active snapshot job:

1 In the Job Status pane, click End Job.

This button is enabled only when the job is in progress.

2 The End Job dialog will display. This dialog briefly describes how job termination works:

• The job will not initiate work on any additional servers. 

• If work has started on a server, the job will cancel any steps that can be skipped.

• The Job Status will indicate the steps that were completed or skipped.
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3 If the job ends successfully, the final job status will display as Terminated.

4 Click OK to confirm that you want to terminate the job. The Job Status pane displays the progress of 
the termination action.

The job status will be Terminated. The server status will be Cancelled. The task statuses will be 
Succeeded or Skipped.

5 When the termination is complete, you can also view the job in the SA Client Job Log. 

In the SA Client navigation pane, select Jobs and Sessions. The Job Logs view displays your job with a 
Terminated status.

•  Terminating Active Jobs
134 Chapter 3



4 Compliance in the SA Client
Overview

In the SA Client, the Compliance view (also known as the compliance dashboard) allows you to:

• See compliance levels and statuses for audits, audit policies, software policies, patch policies, and 
application configurations for all servers and groups of servers in your facility, collectively or 
individually. 

• Remediate servers that are out of compliance. 

• Determine whether the server’s actual installed software, packages, patches, and configuration files 
settings match the configuration defined in the software policy. 

A server’s compliance status is based on a compliance policy, which defines unique server configuration 
settings or values to ensure that your IT environment is configured as it should be. A compliance policy is 
typically created and defined by a policy setter. In some environments, a system administrator might be 
required to create an ad-hoc policy. The policy setter creates compliance policies and then attaches them 
to servers to ensure that servers are compliant with your organization’s standards and policies. For 
example, a policy setter can create a software policy that defines a standard set of patches and packages 
that must be installed on a server. The policy setter can also define the manner in which certain 
application files must be configured on a server. A server or group of servers is considered compliant if its 
configuration matches the rules, defined by the policy setter, in the compliance policy.

From the Compliance view, you can discover servers and groups of servers that are out of compliance and 
then remediate any problems. See Figure 26 and Figure 5.

figure 26 Compliance View—Managed Servers 
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The information displayed in the compliance dashboard is as up-to-date as the last time the SA Client 
requested compliance information from the core. By default, the SA Client checks for new compliance 
information every 5 minutes. 

For information on how to change this time interval, see Setting Automatic Compliance Check 
Frequency on page 151.See Setting Automatic Compliance Check Frequency for more information on 
changing this time interval.

Press F5 to immediately retrieve the latest compliance information, instead of waiting for the default 
setting (5 minutes) to lapse.

Best Practice: Routinely review the compliance dashboard to assess server compliance levels and 
perform any necessary actions to fix problems. For example, use the Compliance view to determine the 
status of an individually scheduled audit that makes sure a Web application’s configuration, such as 
Apache’s http.conf file, meets the standards set by your group. You want to ensure that no one has 
changed the application’s configuration. To verify that no unwanted changes have been made, you should 
regularly check the Compliance view on this server’s Device Explorer to see if this scheduled audit’s 
compliance status has changed to Non-Compliant. If the status has changed to Non-Compliant, view the 
audit results and remediate the problem. 

Best Practice: Use the compliance dashboard to help you answer a specific question or diagnose a 
specific problem. For example, create a scheduled audit that defines security standards for a group of 
servers in your facility. This audit example requires that all servers that are Windows Server 2003 contain 
a certain security patch. When Microsoft releases a new security patch, you need to identify your Windows 
Server 2003 servers that contain the new patch and those that do not. Update the audit to contain the 
new security patch and then browse Windows Server 2003 servers in the device group’s Compliance view. 
Rerun the audit to find servers that require the patch and then remediate them by installing the new, 
required security patch.

Terminology

The following list defines key terms and concepts used in HP Server Automation server compliance:

• Compliance: The degree to which a server’s configuration conforms to a check or test established in a 
collection of rules defined in an audit, a snapshot specification, or an audit policy. Compliance in Audit 
and Remediation is defined by the audit’s or snapshot’s rules that specify the values expected of the 
target servers. If the values on the target server are different than specified in the audit’s rules, the 
server is considered Non-Compliant.

• Compliance Category: The Compliance view displays compliance statuses for the following 
compliance categories: Audit, Audit Policy, Software, Patch, Patch Policy, and Configuration 
(Application Configuration). 

• Compliance Policy: The user-defined configuration that expresses the desired state for a server or 
device configuration or setting. 

Examples:

A patch policy defines the specific patches that must be installed on a computer. 

An audit policy might define that a certain Windows service must be disabled at all times.

An application configuration policy defines the way in which a configuration file must be 
configured. 
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• Compliance Rule: The content or setting inside of a policy that defines an ideal configuration for a 
server, such as a patch or package, a file configuration, software installation order, user and group 
membership and privileges, and so on.

• Compliance Statuses: Indicates the compliance status for a compliance category, reporting the 
differences between what should be (compliance policy) and what actually is (server configuration). 
For example, software compliance category in the Compliance view displays a status of Compliant if 
all configurations defined in the policy match the server configuration. Compliance calculation for 
groups is sightly different than individual servers.

• Compliance Scan Results: The results of a compliance scan. These results report the compliance 
status, details, and can also include remediate options. 

• Compliance Scan: The mechanism that checks servers targeted by a compliance policy (audit, 
software, patch, and application configuration) and returns the results to the SA Client. A compliance 
scan could check to see what patches are installed on a computer targeted by a patch policy or 
software policy and return the results, or it can check a configuration file’s contents and determine if 
it matches the rules defined in an application configuration. In the Compliance view, you can perform 
a compliance scan for the Software, Patch, and Configuration compliance categories. Audits do not 
have a scan feature; however, running an audit achieves the same results. Running an audit checks 
the servers targeted by the audit to determine if they are in compliance with an audit’s rule 
definitions.

• Compliance View: Displays overall and individual compliance levels for all managed servers or 
groups of servers in your facility. This view is also known as the compliance dashboard.

•  Compliance Categories

•  Compliance Statuses

•  Compliance Scans

Compliance Categories
The Compliance view for servers and groups of servers displays compliance for the following categories: 

• Audit: Audit compliance represents an aggregate of all audits that run on a recurring schedule and 
indicates whether or not the rules defined in a scheduled audit match what is installed and configured 
on a target server or servers. 

• Audit Policy: An audit policy is associated with a managed server via an audit. An audit links to an 
audit policy for the compliance rules and defines a list of multiple servers for which to verify the 
rules. Optionally, the audit can define a recurring schedule. An audit policy can contain other audit 
policies. 

• Software: Software compliance is determined by whether or not a software policy definition matches 
what is installed on a server. A software policy defines patches, packages, and application 
configurations, and scripts, including a host of other server objects, such as services, Windows 
registry, COM+, IIS Metabase, and so on. A software policy can also contain other software policies. 
See the SA User Guide: Software Management for more information.

• Patch: Patch compliance is determined by whether or not the patch policy definition matches the 
patches that are installed on a server or group of servers. The Compliance view displays compliance 
information for Windows patches only. See the SA User Guide: Server Patching for more 
information.

Note: Patch compliance is not supported on ESXi servers.

• Patch Policy: A patch policy defines the specific patches that must be installed on a computer. 

Note: Patch policies are not supported on ESXi servers.
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• Configuration: Configuration compliance is determined by whether or not the application 
configuration definition matches the configurations on a server or on a group of servers. An 
application configuration defines the configuration settings and values for application configuration 
files. Configuration compliance status is always an aggregation of all application configurations that 
are attached to the server. Individual status is not supported. See the SA User Guide: Application 
Configuration for more information. See also these sections:

•  Audits

•  Audit Compliance

•  Patch Compliance

•  Software Compliance

•  Configuration Compliance

•  The Compliance View

•  Compliance View Remediation

•  Creating and Managing Software Policies

•  Patch Management for Windows

•  Patch Management for HP-UX

•  Patch Management for Unix

•  Patch Management for Solaris

Compliance Statuses

In general, a server or group of servers can be Compliant or Non-Compliant. This information is displayed 
in the Compliance View.

Compliant : The Compliance view displays this icon when a server is in compliance with the policy 
attached to it. A server is considered Compliant if the rules defined in the policy match the actual 
configuration on the server that the policy is attached to. 

Non-Compliant : The Compliance view displays this icon when the server’s actual configuration does 
not match the rules configured in a policy. For example, you can configure an audit to make sure that a 
Windows Server 2003 server has the Windows CIS recommended minimum password length of at least 8 
characters. When the audit runs and checks the server’s user password and discovers a user password 
that is only 4 characters, the Compliance view shows the server’s audit policy as Non-Compliant.

Best Practice: Do not confuse non-compliant rules with object differences. A non-compliant rule can show 
more than one object difference. SA counts non-compliant rules—it does not count object differences. 
For example, when a directory rule includes many files (objects) in that directory and the audit finds that 
some objects are different, SA counts this as one difference. SA does not count this as multiple 
differences. In the SA Client, the Compliance view and the summary view in the Audit Results browser 
display a count for non-compliant rules. These views do not show a count for object differences.

When more than one policy is attached to a server, the aggregation column combines (rolls up) the status 
of all policies. If this server belongs to a device group of multiple servers, you can access the Compliance 
view for the group to see compliance status levels for all audits that run on all servers in the group, 
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including servers in any sub-groups. The method used for determining compliance statuses for groups is 
based on a default calculation. The group of servers is considered Compliant if at least 95% of the servers 
that belong to the group have a status of Compliant. If less than 95% of the servers have a status of 
Compliant, the status of the group is shown as Partial Compliant.

You can customize the default compliance status threshold for groups of servers. See Changing Device 
Group Compliance Settings on page 128. 

It is possible that actual server configurations, including policy information, might have changed from the 
last time you viewed compliance for a server or group in the Compliance view. To get the latest 
compliance data from the SA core, select Refresh from the View menu or press F5. You can also run a 
compliance scan on the server or group to determine the latest compliance status.

•  Compliance Status Definitions

•  The Compliance View

•  Compliance Scans

•  Refreshing Compliance Information
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Compliance Status Definitions

Table 3 lists default compliance statuses for a policies, servers, and device groups.  

table 4 Compliance Status Icons

Icon Compliance Status Description

          

Compliant

• Policy: All rules or items defined in the policy match the actual server 
configuration. 

• Servers: Compliance scan ran successfully and the server configuration matches 
all rules defined in all policies attached to the server. 

• Device Groups: Compliance scan ran successfully and the percentage of 
compliant servers is greater than the minimum threshold set in the Compliance 
Settings option in the Administration pane. By default, the threshold for a 
Compliant status is 95% of servers in the group. The compliance threshold 
definitions for Compliant can be modified.

Partial Compliance

• Policy: One or more rules or items defined in the policy does not match the actual 
server configuration, due to an exception applied to one of the rules. This applies 
only to Windows Patch policies.

• Servers: Compliance scan ran successfully and the server configuration did not 
match at least one of the rules defined in any of the policies attached to the 
server, due to an exception applied to one of the rules. This applies only to 
Windows Patch policies.

• Device Groups: Compliance scan ran successfully and enough servers in the 
group meet the threshold criteria for Non-Compliance set in the Compliance 
Settings in the Administration pane, while the rest of the servers in the group are 
Compliant. The compliance threshold definitions for Partial Compliance can be 
modified. 

Non-Compliant

• Policy: One or more rules or items defined in the policy does not match the actual 
server configuration.

• Servers: Compliance scan ran and the actual server configuration does not match 
at least one or more of the rules defined in the policy.

• Device Groups: Compliance scan ran and enough servers in the group meet the 
threshold criteria for Non-Compliance set in the Compliance Settings option in the 
Administration pane to indicate the group is Non-Compliant. The compliance 
threshold definitions for Non-Compliance can be modified.

Scan Failure

Compliance scan was unable to run.

Skipped

Server was skipped.
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•  The Compliance View

•  Compliance Scans

•  Viewing Compliance for Multiple Servers

•  Changing Device Group Compliance Settings

•  Compliance Status Thresholds—Policy, Server, & Server Group

•  Compliance Status Thresholds—Device Group

Compliance Status Thresholds—Policy, Server, & Multiple Servers

Policy: Compliance status for a policy is based on all of the rules in the policy. If one of the rules in a policy 
is Non-Compliant (does not match the actual configuration on the managed server), the entire policy is 
considered Non-Compliant for a server.

Server & Multiple Servers: Compliance status for a server is based on all of the policies attached to the 
server or that define the server as a target. If any one of the compliance categories has a compliance 
status of Non-Compliant, the server’s overall compliance status is also considered Non-Compliant. All of 
the policies in all of the compliance categories must be Compliant for the server’s overall compliance 
status to be Compliant.

•  The Compliance View

•  Compliance Scans

•  Viewing Compliance for Multiple Servers

•  Changing Device Group Compliance Settings

Scan Needed

Results undefined. This status can result if a compliance scan was never run (such as 
on a new installation) or the configuration on the server (or servers in the device 
group) changed since the last time information was reported to the SA Client.

Scanning: The compliance scan is currently running.

— 
No Tests Defined

No compliance policies of this type are attached to the server or all servers in the 
device groups, including all servers in any sub-groups.

table 4 Compliance Status Icons (cont’d)

Icon Compliance Status Description
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Compliance Status Thresholds—Device Group

Whether or not a server is considered Compliant or Non-Compliant is important when viewing device 
group compliance in the Compliance view. This status is based on a default threshold calculation that you 
can configure and customize. 

Non-Compliant: In the device group Compliance view, in order for a compliance category (Audit, Audit 
Policy, Software, Patch, or Configuration) to display a status of Non-Compliant, more than 5% of all 
servers in a group must have the status of Non-Compliant for that category. Another way to understand 
Non-Compliant for a device group is to remember that when less than 95% of the servers are Compliant, a 
status of Non-Compliant will display.

Partial-Compliant: In the device group Compliance view, in order for a compliance category (Audit, Audit 
Policy, Software, Patch, or Configuration) to display a status of Partial-Compliant, more than 2% but less 
than or equal to 5% of all servers in a group must have the status of Non-Compliant for that category. 
Another way to understand Partial-Compliant for a device group is to remember that when less than 98% 
but at least 95% of the servers are Compliant, a status of Partial-Compliant will display.

Compliant: In the device group Compliance view, in order for a compliance category (Audit, Software, 
Patch, or Configuration) to display a status of Compliant, less than 2% of all servers in a group must have 
the status of Non-Compliant for that category. Another way to understand Compliant for a device group is 
to remember that at least 98% of the servers are Compliant.

Device group status is calculated based on all policies (in all compliance categories) attached to all 
servers that belong to the group. This includes servers in all sub-groups that are children to the selected 
group. 

You can change the default thresholds used to calculate compliance status. For example, you could 
configure that group compliance status be calculated non-recursively, which would exclude all sub-group 
server members from the compliance calculation. 

•  The Compliance View

•  Compliance Scans

•  Viewing Compliance for Multiple Servers

•  Changing Device Group Compliance Settings

Changing Device Group Compliance Settings

By default, the SA Client allows you to configure the manner in which compliance for a device group is 
determined.

In order to change device group compliance settings, you must be a member of a group that is assigned 
permission to the SA feature Model: Opsware. For more information on what type of permissions you 
have been granted, contact your SA Administrator.

To change the settings for device group compliance:

1 In the navigation pane, select Administration >Compliance Settings.

2 In the Compliance Settings pane, in the Device Group Compliance section, click Edit Settings. 
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3 In the Device Group Compliance Settings window, configure the following settings:

• Display Device Group Rollup Compliance: This option allows you to show or hide the icon that 
indicates compliance status of the parent group shown at the top of each compliance category 
column. This icon indicates a compliance status rollup for all members of a selected group. 

For example, if this option is selected, when you select a group and then from the View 
drop-down list select Compliance, the top column heading for each compliance category column 
(Audit, Software, Patch, and Configuration) shows an icon that indicates the compliance status 
for all servers in the selected group. You can cursor-over this column heading to view compliance 
status for all devices in this category. 

• Member Calculations: This option allows you to choose whether or not you want to include 
servers that belong to sub-groups when calculating overall group compliance level for a 
compliance category. For example:

— Server and group members are considered: This means that the compliance status for a 
device group will recursively check compliance for all servers in a group and for all servers in 
all sub-groups that belong to the selected device group. 

— Only server members are considered: This means that the compliance status for the 
selected device group will check compliance only for servers at the top level of the group 
and will exclude any servers that belong to any sub-group members.

• Thresholds: Allows you to change the compliance threshold calculation percentage (%) that is 
used to determine device group compliance status for all compliance categories. 

By default, a device group will display the following statuses:

Non-Compliant—If more than 5% of its members are Non-Compliant.

Partial Compliance—If more than 2% but less than 5% of its members are Non-Compliant.

Compliant—If 2% or less of its members are Non-Compliant.

• Column Types: Allows you to change which compliance categories are able to be discovered and 
then displayed, such as Audit, Audit Policy, Software, Patch, and Configuration. 

4 Click OK to save your settings.

•  Compliance Status Definitions

•  Compliance Status Thresholds—Policy, Server, & Multiple Servers

•  Compliance Status Thresholds—Device Group

The Compliance Dashboard
In the SA Client, you can view compliance for individual servers, for multiple servers, and for both:

• Viewing Compliance for a Server

• Viewing Compliance for Multiple Servers

• Viewing Group Compliance

When viewing compliance status for multiple servers, it is possible that there are servers in the group that 
your user does not have permission to see. In addition, your user account might not have permissions to 
view some of the policies (Audit, Software, and Patch) used to calculate the compliance status for a group 
of servers. 

In these cases, even though you cannot see some servers and some policies, you will still be able to see 
overall compliance status for multiple servers that your user has access to view. You will also still be able 
to see compliance category rollups, even though some of the policies may be hidden from your view.
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Viewing Compliance for a Server

To view compliance information for an individual server: 

1 In the navigation pane, select Devices > All Managed Servers or Virtual Servers.

2 In the content pane, select a server.

3 Right-click and select Open to display the server browser.

4 In the Information pane, choose Management Policies > Compliance.

The content pane displays a compliance summary pie chart of compliance statuses for each 
compliance category, including detailed status information for individual policies. See Figure 27.

5 To perform an action on one of the compliance categories or on an individual policy in the categories, 
make a selection in the details list and click Run Audit (for audits only), Remediate, or Scan Device. 

The ability to both view policies and perform remediation operations on them is determined by your user 
permissions. If you are not able to view a policy or perform an action on one, consult your SA 
Administrator.

Compliance Summary Pie Chart and Details

The Compliance view contains the following main sections:

• The compliance summary pie chart provides a graphical display of the overall compliance status for 
all policies attached to the selected server. You can also filter this pie chart to show status only for a 
specific compliance category. See Figure 27. 

• The compliance summary details list allows you to drill down in each compliance category to see the 
overall compliance status, the policies contained in each category, the compliance status for each 
policy and a summary description for each. Depending on your selection, you can launch actions to 
remediate policies that are out of compliance, such as viewing details of a policy, running an audit, or 
scanning the device for compliance. See Figure 27.

figure 27 Compliance Summary for Managed Servers — All Policies 
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Select the drop-down list below the pie chart to view the pie chart filtered by each compliance test 
category, such as Audit Policy. See Figure 28.

figure 28 Compliance Summary for a Managed Server—Audit Policy

You can also choose to filter the compliance policy breakdowns in the details pane to see all compliance 
policies that contain a certain compliance status. For example, in Figure 29, the compliance view has 
been filtered to show only all compliance policies that are non-compliant.

figure 29 Compliance Summary Filtered By Non-Compliant

In the previous example, the Compliance view details pane shows all Non-Compliant policies attached to 
the server. A policy is considered Non-Compliant if at least one of the rules configured in the policy does 
not match the configuration on the server. 

•  Compliance View Remediation
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Viewing Compliance for Multiple Servers

To view compliance information for multiple servers: 

1 In the navigation pane, select Devices > Device Groups.

2 In the Device Groups tree, select Public or select your own user group list. The content pane displays 
the contents of all device groups in the list, either all public groups or all groups your user created. 

3 From the View drop-down list, select Compliance.

4 For one or more of the device groups or any servers in the list, select the check box next to it to 
include it in the Compliance view details pane. The details pane displays compliance information for 
all servers in the selected group. 

5 (Optional) Use the status filter drop-down list to filter the view by compliance status. For example, 

you can choose to view only device groups that have a Non-Compliant  status. 

6 (Optional) In the details pane, select one of the categories. Depending on the category and your user 
permissions, click one of the action buttons at the bottom of the pane for more details, to run an 
audit, to remediate a software policy or a patch policy, or to run a compliance scan on all members of 
the group. 

Device Group Compliance: Status Rollup

The device group content pane displays a summary of compliance status rollups for all group members 
and contents of groups that you selected in the navigation pane (Devices  >  Device Groups). 

Compliance status (Compliant, Non-Compliant, Partial, and so on) icons in the column heading at the top 
of the list indicate the rollup status for all groups in the list. To view the overall status for the compliance 
category for all visible groups, move the cursor over the column heading for a category.

In each row of the list, this view displays compliance status for each group in all compliance categories for 
each group in the list. These categories include Audit, Audit Policy, Software, Patch, and Configuration, 
including any individually scheduled audits that you choose to display in this view. In Figure 31, each 
compliance category displays a compliance status for all policies of each type that are attached to servers 
in the group.

figure 30 Compliance Rollups for Device Groups 
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Device Group Compliance: Aggregate Rollup

When you select one or more groups (or all of them) in the content pane, the details pane displays device 
compliance aggregate rollups in each column in the content pane for all members of the group. See 
Figure 32.

figure 31 Compliance Aggregate Rollups for Device Groups 

Use the status filter drop-down list to filter the view by compliance status. For example, you can choose 

to view only device groups that have a Non-Compliant  status.

Depending on the category and your user permissions, click an action button for more details, to run an 
audit, to remediate a software policy or a patch policy, or to run a compliance scan on all members of the 
group.

•  Compliance View Remediation

•  Changing Device Group Compliance Settings

•  Adding and Removing Compliance View Columns

•  Sorting the Compliance Category Display

•  Filtering By Compliance Status

Viewing Group Compliance

In the Group explorer, the Compliance view shows a rollup of compliance policy aggregates for each policy 
type for all members of the group as a whole, as opposed to compliance status for individual servers. This 
gives you a sense of whether or not the group is compliant for each policy type and for all servers in the 
group (and any sub-groups). 

Use the status filter drop-down list to filter the view by compliance status. For example, you can choose 

to view only device groups that have a Non-Compliant  status.

Depending on the category and your user permissions, click an action button for more details, to run an 
audit, to remediate a software policy or a patch policy, or to run a compliance scan on all members of the 
group

To view a group of servers in the Device Group Explorer: 

1 In the navigation pane, select Devices > Device Groups.

2 In the Device Groups tree, select Public or select your own user group list. The content pane displays 
the contents of all device groups in the list, either all public groups or all groups your user created. 

3 Select a group of servers. 
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4 Right-click and then select Open. 

5 From the Views pane of the Group explorer, select Management Policies > Compliance. The 
Compliance view displays summary and rollup compliance status information about all servers in the 
group. See Figure 33.

figure 32 Group Compliance View 

Note: This view is not available for ESXi servers.

The compliance summary pie chart is a graphical display of the overall compliance status for all 
policies aggregates for all associated servers in the group. Sections in the pie chart show the 
compliance status and percentage of each status level by category, such as Compliant, 
Non-Compliant, Scan Needed, Scan Failed, and so on. You can also filter this pie chart to show status 
only for a certain compliance category.

The details pane displays device compliance aggregate rollups by compliance categories. 

Depending on the category and your user permissions, click an action button for more details, to run 
an audit, to remediate a software policy or a patch policy, or to run a compliance scan on all members 
of the group.

•  Compliance Statuses

•  Compliance Status Thresholds—Device Group

Adding and Removing Compliance View Columns

When you view device groups in the Compliance view, by default, the following compliance categories 
display as columns in the content pane: Audit, Audit Policy, Software, Patch, and Configuration. You can 
show or hide any of these categories, and add or remove an individual policy in each category.

To add or remove device group compliance categories in the Compliance view:

1 In the navigation pane, select Devices > Device Groups.

2 In Device Groups, expand your list of device groups or the Public list of device groups.

3 In the content pane, select a device group.

4 In the View drop-down list, select Compliance. 

The content pane lists the following compliance categories: Audit, Audit Policy, Software, Patch, and 
Configuration. The content pane also indicates the statuses for each member of the device group.

5 Use the column selector  to add or remove a category. 
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6 In the Select Compliance View Columns window, the left side of the window displays tabs for each 
compliance category and all compliance policies in those categories that you have permissions to 
see. The right side of the window displays the currently visible policies in each category in the 
Compliance view. By default, the Compliance view displays the aggregate (rollup) of all policies in the 
category.

7 To add an individual policy as a column in the Compliance view, on the left side, select a compliance 
category tab and then a policy, and then click the plus (+) arrow button. 

8 To remove an individual policy or an aggregate column from the Compliance view, select one on the 
right-side of the window and then click the minus (-) arrow button.

9 Click OK to save your changes.

•  Sorting the Compliance Category Display

•  Filtering By Compliance Status

Sorting the Compliance Category Display

Best Practice: It is useful to arrange the compliance categories in an ascending or descending order to 
customize your Compliance view display requirements.

To sort the columns in the Compliance view:

1 In the Compliance view, click inside a column heading.

The number “1” displays, superscripted adjacent to the compliance category name. This is the 
primary sort key for this table. 

2 Click the UP or DOWN arrows inside the heading to indicate whether the data is sorted in ascending or 
descending order. 

3 Press the Ctrl key and then click inside another column heading.

The number “2” displays, superscripted adjacent to the compliance category name. This is the 
secondary sort key for this table.

4 (Optional) Repeat step 3 as needed.

5 (Optional) Move the cursor over a column heading to display a rollup of the compliance statuses for a 
specific category.

6 To reset the sort keys, click on a column heading that is not annotated.

•  Filtering By Compliance Status
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•  Adding and Removing Compliance View Columns

Filtering By Compliance Status

When you view compliance for individual managed servers and groups of servers in the Compliance view, 
you can filter the view to show only groups and servers that have at least one server that matches a 
specific compliance status for any of the displayed compliance categories. For example, when you select 
a group and then select Compliance view, you can use the status filter to only show members of the 
selected group (individual servers and those in any sub-groups) that have a Non-Compliant status for 
each of the compliance categories, such as Audit, Audit Policy, Patch, Software, and so on. 

To filter the Compliance view by compliance status:

1 In the navigation pane, select Devices > Device Groups.

2 In the Device Groups tree, navigate and select Public or select your own user group list.

3 In the Public pane, select a device group.

The content pane shows the Compliance view statuses for all members of the selected group.

4 To filter this view by compliance status, select one from the status filter drop-down list. See 
Figure 34.

figure 33 Compliance Status Filter 

5 The Compliance view displays only those members of the group (individual servers and those in any 

sub-groups) that have a status of Non-Compliant .

6 Select any of the servers or sub-groups in the group listed. 

The details pane shows the compliance status information for those servers. You can filter 
information in the details pane by using the status filter in this pane. 

Refreshing Compliance Information

Best Practice: It is useful to refresh the Compliance view to make sure you are looking at the latest 
compliance information in your core. To get the latest compliance information from the core, from the 
View menu, select Refresh or press F5. 
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When you first select the Compliance view, the information displayed shows the latest information 
reported from the SA core for each compliance category. It is possible that a server’s configuration has 
changed since you last looked at the Compliance view. It is also possible that a policy has changed since 
you last viewed server and groups in the Compliance view. If this is the case, you might want to scan for 
compliance or rerun an audit to generate new data for the Compliance view display.

•  Setting Automatic Compliance Check Frequency

Setting Automatic Compliance Check Frequency

By default, the SA Client will check the core for new or changed compliance information every 5 minutes. 
You can change this time interval, using the Set Options window. 

Press F5 if you want the SA Client to immediately check for new compliance information in the core.

To change the automatic compliance check frequency setting:

1 In the SA Client, in the Tools menu, select Options.

2 In the Set Options window, in the Views pane, select General.

3 In the Cache section, in the “Check for updates every <xx> minute(s)” field, enter a time interval for 
how often you want the SA Client to check the core for new compliance information.

This check applies to all information accessed from the core by the SA Client, not just to compliance 
information. A longer interval increases the likelihood that the information you are viewing is out of 
date. A shorter interval increases network traffic flowing to and from your core—this means you are 
viewing more recent information.

4 (Optional) Click Update Cache to immediately check for new information from the core.

5 (Optional) Click Reload Cache to immediately reload (refresh) the cache.

6 Click Save.

•  Refreshing Compliance Information

Exporting Compliance View Information

If you want to view all information displayed in the Compliance view to a file, you can export the view to 
either .html or .csv. 

To export Compliance view information to a file: 

1 In the navigation pane, select Devices > Device Groups.

2 Select a group that you want to view compliance for, and from the View menu, select Compliance. 

3 In the contents pane, select a server in the group.

4 Right-click, select Export to, and then select CSV or HTML.

5 In the Export Compliance View window:

a Enter a name for the file name.

b (Optional) Change the encoding if you want the saved file to use a specific encoding scheme. 

c Click Save.
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Note: To view the compliance results correctly, open the .csv file with a text editor, turn off word wrap, 
and extend the text window horizontally.
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Compliance Dashboard Remediation

In addition to providing compliance status information for servers and groups, the Compliance view 
enables you to remediate server configurations that are not in compliance with your organization’s 
standards, as defined by your audit, software, patch, and application configuration compliance policies. 

By definition, the action of remediating a server or group of servers means finding how and where a 
server or group of servers is out of compliance (Non-Compliant), and then making sure that a server’s 
actual configuration conforms to your compliance policies. 

From the Compliance view for a server or a group of servers, you can perform the following actions:

• Remediate a patch policy or a software policy.

• Run, view, and remediate audit results.

• Push an application configuration to a server.

• Run a compliance scan for patches, software, or application configurations to get the latest 
compliance information for your servers.

When you select a server or group of servers in the Compliance view, or view them in the Device or Device 
Group Explorer, the details pane provides action buttons for operations that help you discover and 
remediate out of compliance policies. The type of actions available are based on the type of policy, 
whether you select a single managed server or group of servers, and whether or not you select an 
individual policy, multiple policies, or the rollup of a compliance category in the details pane.

Compliance View Remediate—Group of Servers

Figure 35 shows how the Compliance view enables the remediate action for a group of servers.

figure 34 Remediate for a Group of Servers 

The details pane for the selected group shows a summary of all policies attached to all servers in the 
group (and all servers in any sub-groups) arranged by a compliance category—Audit, Audit Policy, 
Software, Patch, and Configuration. When you select a group, you can only remediate an entire category 
of policies, such as all software policies or all patch policies attached to all servers in the group that are 
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out of compliance. If you select the Software category in the details pane, the Remediate button is 
enabled. When you click Remediate, the SA Client launches the Remediate wizard. Complete the steps in 
this wizard to remediate any out-of-compliance policy configurations for all servers in the group. 

You can view this same information and access these option by selecting the group, and from the Actions 
menu select Open. This action launches the Group explorer and displays the same details pane for the 
group, along with the action buttons in the details pane. 

Compliance View Remediate—Server

Figure 36 shows how the Compliance view enables the remediate action for an individual server.

figure 35 Remediate for a Server

Note: This view is not available for ESXi servers.

For a group of servers, remediate actions always apply to all members of the group. For an individual 
managed server, you can remediate either all or selected policies that are attached to the server. For 
example, you can launch a server and, from the server’s Device Explorer, select Management Policies > 
Compliance to view all compliance policies attached to the server. 

In the details pane, select an audit or a software policy to view the audit. Use an action button to run the 
audit, remediate the software policy, or scan the device for compliance.

Compliance Scans

In the Compliance view, you can perform a compliance scan for the Audit, Audit Policy, Software, Patch, or 
Configuration compliance categories. When you scan for compliance, you scan servers targeted by a 
compliance policy to determine whether target server configurations match the policy’s rule definitions. 
For example, a compliance scan can check to see what patches are installed on a computer, compare that 
with a patch or software policy, and then return the results to the Compliance view. Or, a compliance scan 
can check the contents of a configuration file on a server in order to determine whether it matches the 
rules defined in an application configuration. 
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Audits do not have a scan feature; however, running an audit produces the same results. For an audit, 
when you run an audit, SA checks the target server configuration to determine the extent to which it 
matches the audit’s rule definitions.

The following actions occur when scanning the compliance categories: 

• Software Compliance Scan: Compares files on a server to determine whether they match those 
stored in the software policies attached to the server.

• Patch Compliance Scan: Compares patches that are installed on a server with patch policies and 
patch policy exceptions that are attached to that server. The results of this scan show servers that 
are in compliance (have all required patches installed) and servers that are out of compliance (do not 
have all required patches installed). Scanning for patch compliance applies only to Windows patch 
management.

• Configuration Compliance Scan: Compares configuration files on a server with the template-defined 
application configurations that are attached to that server. The results of this scan show servers that 
are in compliance (configuration file definitions match the configuration templates) and servers that 
are out of compliance (configuration file definitions do not match the configuration templates). See 
for more information about Configuration compliance.

Patch Compliance

In HP Server Automation, patch management enables you to identify, install, and remove patches on 
managed servers and groups of servers. Using Windows patch management, you can identify and install 
patches for Windows Server 2000 SP 4, Windows Server 2003, and Windows Server 2008, and operating 
systems, including Service Packs, Update Rollups, and hotfixes.

In the Compliance view, you can review the compliance status for patch policies to see whether your 
servers have the correct patches installed on them. During a patch compliance scan, HP Server 
Automation checks managed servers and public device groups to determine whether all patches in a 
policy and a policy exception were installed successfully. If the patches installed (or not installed) on the 
server do not match the patch policy definitions, the Compliance view displays the server’s patch policies 
as Non-Compliant . 

Compliance scans can be run on a one-time basis or they can be scheduled on a recurring basis. You can 
remediate a patch policy to a server to ensure a server’s or group of servers’s patch compliance.

See the SA User Guide: Server Patching for more information.

•  Patch Compliance

•  Verifying Patch Policy Compliance

•  Compliance Scans

•  Scheduling a Patch Compliance Scan

•  Patch Management for Windows

•  Patch Management for HP-UX

•  Patch Management for Unix

•  Patch Management for Solaris
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Patch Compliance Status Criteria

Patch compliance status is determined by the following criteria: 

• Patch Compliance—Single Server: If at least one item in a patch policy does not match what is 
discovered (or does not exist) on the server the policy is attached to, the server’s patch compliance 

status is Non-Compliant . The details pane of a server’s Device explorer window shows the Patch 
category as Non-Compliant and the summary column indicates how many rules (patch policy items) 
are Non-Compliant out of the total number of rules. 

For example, if a patch policy contains 10 items and 6 of the items are Non-Compliant, the patch 
policy’s status is Non-Compliant and the summary description reads: “6 of 10 Rules Out of 
Compliance.”

If more than one patch policy targets a single server and if at least one of those policies is 
Non-Compliant, then the aggregate compliance status for Patch is also displayed as Non-Compliant 
as well. You can expand the Patch category of the details pane to see which of the policies are not in 
compliance, including a breakdown of how many rules in each policy are either in or out of 
compliance. 

• Patch Policy—Rule Exception: If a rule exception is applied to one of the patch policy items, the 

server’s Patch compliance displays a compliance status of Partial-Compliant . Patch is the only 
compliance category that allows rule exceptions at the policy level.

Patch Compliance—Device Groups: A patch policy attached to a group of servers is considered 
Compliant if more than 5% of the servers in the group attached to the policy have a status of 

Non-Compliant . If this is the case, the aggregate compliance for patch policy displays as 
Non-Compliant. Another way to understand Non-Compliant for a device group is to remember that 
when less than 95% of the servers are Compliant, a status of Non-Compliant will display.

However, if more than 2%, but less than or equal to 5%, of all servers in a group have the status of 

Non-Compliant for that category, then the status is Partial-Compliant . Another way to understand 
Partial-Compliant for a device group is to remember that when less than 98% but at least 95% of the 
servers are Compliant, a status of Partial-Compliant will display.

If less than 2% of all servers in a group have a Patch Policy status of Non-Compliant for that category, 
then the overall status is Compliant. Another way to understand Compliant for a device group is to 
remember that at least 98% of the servers are Compliant.

The details pane for a group of servers in the Compliance view shows whether the patch policies are 
compliant or not. This information does not expand to show a breakdown of individual servers and 
policies. 

You can modify the thresholds used to determine compliance for groups of servers.

Remediating Patch Compliance for Servers

Note: This section does not apply to ESXi.

When you remediate patch compliance for one or multiple servers, you can choose to remediate either all 
of the policies attached to the servers or choose to remediate individual policies.
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To remediate patch policies on one or multiple servers:

1 In the Device Explorer, in the navigation pane, select Devices > Servers > All Managed Servers.

2 From the View drop-down list, select Compliance.

3 Select one or more servers.

4 In the details pane of the Compliance view, expand the Patch category and select a patch policy that 
is attached to the selected servers. Or, select the top level Patch category if you want to remediate all 
of the patch policies attached to the selected servers.

5 Click Remediate and then complete the steps in the Remediate wizard.

Remediating Patch Compliance for Device Groups

When you remediate patch policies on one device group, you can remediate all the policies attached to all 
device groups. However, when you select a group, you can only remediate all patch policies attached to 
all groups and any sub-groups.

To remediate patch policies on one or multiple device groups:

1 In the Device Explorer, in the navigation pane, select Devices > Device Groups.

2 From the View drop-down list, select Compliance.

3 Select one or more device groups.

4 In the details pane of the Compliance view, expand the Patch category and select a policy that is 
attached to the selected groups. Or, select the top level Patch category if you want to remediate all of 
the policies attached to the selected groups.

5 Click Remediate and then complete the steps in the Remediate wizard.

Audit Compliance

In HP Server Automation, audit and remediation allows you to define server configuration policies in an 
audit. An audit helps you make sure that the servers in your facilities meet your audit policy standards. An 
audit consists of a collection of rules that you can define to model those standards. For example, an audit 
can consist of Windows COM+ configurations, registry settings, services, file system settings, hardware 
configuration, user and group password settings, software installation, packages, storage settings, and 
so on, that define an ideal server configuration. Or, the audit might represent a negative server 
configuration that enables you to determine the way a server should not be configured.

Audit compliance determines whether the rules defined in a recurring audit match the actual server 
configuration for all servers targeted by the audit. The Compliance view allows you to see both the 
aggregate and individual compliance status of all audits that run on a recurring schedule on a server or 

group of servers. If any of the audits are Non-Compliant , you can remediate any differences found 
between the audit and the audit’s target server or servers.

The Compliance view derives audit compliance servers and groups of servers from regularly scheduled 
audits.

•  Audit Policy Compliance

•  Audit Compliance Status Criteria

•  Audit Compliance Remediation
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Audit Compliance Status Criteria

Audit compliance status is determined by the following criteria:

• Audit Compliance—Single Server: If a single rule in an audit does not match the target server’s 

configuration, the server’s audit compliance status is Non-Compliant . The details pane in a 
server’s Device explorer shows the Audit category as Non-Compliant and the summary column 
indicates how many rules are Non-Compliant out of the total number of rules. 

For example, if an audit has 10 rules and 4 of the rules are Non-Compliant, the audit’s status is listed 
as Non-Compliant and the summary description displays: “4 of 10 Rules Out of Compliance.”

If more than one audit targets the server and if at least one of those audits is Non-Compliant, the 
aggregate compliance status for audits is also displayed as Non-Compliant. You can expand the Audit 
category of the details pane to see which of the audits are not in compliance, including a breakdown 
of how many rules in each audit are in compliance or out of compliance.

• Audit Compliance—Device Groups: An audit that targets a group of servers (and all servers in all 
sub-groups) is considered Compliant if at least 95% of the servers in the group that are targeted by 
the audit have a compliance status of Compliant . 

If more than 5% of the servers in the group targeted by an audit have a status of Non-Compliant, the 
aggregate compliance for audits displays as Non-Compliant. Another way to understand 
Non-Compliant for a device group is to remember that when less than 95% of the servers are 
Compliant, a status of Non-Compliant will display.

However, if more than 2%, but less than or equal to 5%, of all servers in a group have the status of 

Non-Compliant for that category, the status is Partial compliant . Another way to understand 
Partial-Compliant for a device group is to remember that when less than 98% but at least 95% of the 
servers are Compliant, a status of Partial-Compliant will display.

If less than 2% of all servers in a group have an Audit status of Non-Compliant for that category, the 
overall status is Compliant. Another way to understand Compliant for a device group is to remember 
that at least 98% of the servers are Compliant.

The details pane for a group of servers in the Compliance view shows whether all of the audits are 
compliant. This information does not expand to show a breakdown of individual servers and audits. 

•  Changing Device Group Compliance Settings

•  Audit Compliance Remediation

Audit Compliance Remediation

The Compliance view allows you to view all audits that target a server or group of servers and to 
remediate those results that are out of compliance. This ensures that a server’s configuration complies 
with the rules defined in an audit. 

For each audit rule that is out of compliance on the target server (the server’s configuration either did not 
match the rule definition or simply did not exist), remediation copies the rule object to the target server 
so it matches the rule. Or, in the case of a value-based audit rule, remediation changes the target server’s 
configuration to match the rule. 

Example: You have an audit that checks a group of Windows servers to make sure that they contain 
certain registry keys and ACLs. After the audit runs against a Windows server, it is possible that several of 
the rules are out of compliance. This means the Registry keys specified in the audit rules were not found 
on the target servers. When you remediate, the audit feature copies the Registry keys specified in the 
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audit rule to the target servers. This ensures that the servers have the specific keys and associated ACLs. 
For a group of servers, remediation has the same results—where only the remediation operation applies 
to all servers in the group, including all servers contained in any sub-groups. 

Remediating Audits Attached to Servers

You can remediate an audit that is attached to a single server or an audit that is attached to multiple 
servers. You can only remediate individual audits. You cannot aggregate audits at the top level. For any 
group that is selected, all direct server children in that group are the subject of the remediation.

When the Remediate button is not enabled in the Compliance view, even though a single policy is selected 
in the detail pane and one or more servers are selected in the summary pane, it typically means that there 
is no audit result for that policy to remediate.

You cannot run an audit on a group of servers from the Compliance view. However, you can create an 
audit that runs against a group of servers and remediate those audit results for a group of servers from 
the Audit Results window.

To remediate an individual audit on a single server:

1 In the navigation pane, select Devices > Servers > All Managed Servers.

2 In the content pane, select a server.

3 Right-click and then select Open to open the Server explorer.

4 In the navigation pane, select Management Policies > Compliance.

5 In the details pane of the Compliance view, expand the Audit category and then select an individual 
policy.

6 Click Remediate and then complete the steps in the Remediate wizard.

To remediate an individual audit on multiple servers:

1 In the navigation pane, select Devices > Device Groups, and then select a group.

2 From the View drop-down list, select Compliance. 

3 Select multiple servers by selecting the check boxes next to each server.

4 In the details pane of the Compliance view, expand the Audit category and select an individual audit 
that is targeting all of the selected servers. 

5 Click one of the following buttons to perform a type of remediation for an audit on a single server or 
on multiple servers:

• Details: Displays the Audit Result window that shows all differences found between the audit 
and the target, and allows you to remediate the differences by rule or by server. Click the View 
Rules Details link to open the Rules window and view the audit rules. Select a server and click 
Run Partial Audit to launch the Audit Servers wizard.

• Run Audit: Launches the Audit Servers wizard and allows you to run the audit immediately or 
schedule to run the audit at a later time. The audit will run against all servers targeted by the 
audit. 

• Remediate: Launches the Remediate wizard, which allows you to remediate target server 
configurations that are out of compliance with the audit rules. You can remediate differences by 
rule or by server. If none of the selected servers have remediate results for the selected policy, a 
No Results Found to Remediate! message will display.
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• Scan Devices: Displays the Scan for Compliance dialog where you first select the types of policies 
you want scanned and then click Scan to launch the job. This processes scans the selected 
servers for all Audit, Audit Policy, Software, Patch, and Configuration policies attached to the 
servers, and does not have any effect on the audits that target this server.

To monitor the scan’s progress, refresh the Compliance window (press F5).

Note: You can also choose Action > Scan to view a scan’s progress. 

•  Audit Configuration

•  Audit Results

•  Compliance Scans

Audit Policy Compliance

You can add an audit that has a recurring schedule to the Compliance view. The Compliance view displays 
the result of the latest run of that audit. The audit can directly contain audit rules or it can inherit audit 
rules from the source snapshot or source snapshot specification. In the Compliance view, you should 
display the Audit column to confirm associated audit rules. See Figure 37.

figure 36 Compliance View with Audit & Audit Policy.

Best Practice: You should link your audits to audit polices for the audit rules. This is a common and 
recommended use case. This structure allows for several audits to be linked to the same audit policy. 
Each audit can include a different set of servers or multiple servers that have different recurring 
schedules. In the Compliance view, in the Audit Policy column, all compliance results for each audit linked 
to the policy are displayed.

If there is more than one audit with an overlapping set of servers, the Audit Policy column shows the 
status of the most recent result for each server, regardless of which audit ran last. To view the most 
recent audit result for a given operation, select an audit and then click Details, Run Audit, or Remediate 
in the Compliance view. See Figure 37.
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An audit policy can be hierarchical. That is, an audit policy can link to other audit policies. 

Example:

Policy A links to Policy B. Policy B links to Policy C.

• When an audit is created and linked to Policy A, the audit will run using a flattened list of compliance 
rules that belong to Policy A, Policy B, and Policy C.

• If you add the Audit Policy column in the Compliance view for Policy A, the compliance status shows 
the result of the audit with all rules from Policy A, Policy B, and Policy C.

• If there are no audits directly linked to Policy B or Policy C, there are no individual results available for 
these policies. If you add the Audit Policy column in the Compliance view for these policies, a dash (-) 
indicates that there are no results to display.

Another difference between the Audit and Audit Policy columns in the Compliance view is that only audits 
with recurring schedules are available for display. However, any audit policy can be a column, just as it 
applies to software and patch policies.

The compliance categories (columns) that are selectable for the Compliance view are configurable. 

• The default setting includes Audit Policy, Software, Patch, and Configuration.

• For new installations, the Audit category is not listed.

•  Adding and Removing Compliance View Columns

•  Sorting the Compliance Category Display

•  Linking & Importing an Audit Policy

Software Compliance

In HP Server Automation, software management allows you to create software policies that enable you to 
install software and configure applications simultaneously. A software policy can contain several 
different items, such as packages, RPM packages, patches, application configurations, and other software 
policies. After creating a software policy, you can attach it to servers or groups of servers.

Software compliance indicates whether items in a software policy are compliant with the actual server 
configuration. If the actual server configuration does not match the software policy definitions, the 

server’s software policies are Non-Compliant . 

The Compliance view derives software compliance information for software policies when you scan a 
server or group for software compliance.

See the SA User Guide: Software Management for more information.

•  Compliance Scans

•  Creating and Managing Software Policies

•  Software Compliance Status Criteria

•  Software Compliance Remediation
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Software Compliance Status Criteria

Software compliance status is determined by the following criteria: 

• Software Compliance—Single Server: If at least one item in a software policy does not match what 
is discovered (or does not exist) on the server the policy is attached to, the server’s software 

compliance status is Non-Compliant . The details pane of a server’s Device explorer shows the 
Software category as Non-Compliant and the summary column indicates how many rules (software 
policy items) are Non-Compliant, out of the total number of rules. 

For example, if a software policy contains 10 items and 6 of the items are Non-Compliant, the 
software policy’s status is listed as Non-Compliant and the summary description reads: “6 of 10 
Rules Out of Compliance.”

If more than one software policy targets a single server and if at least one of those policies is 
Non-Compliant, the aggregate compliance status for Software is also displayed as Non-Compliant. 
You can expand the Software category of the details pane to see which of the policies are not in 
compliance, including a breakdown of how many rules in each policy are either in or out of 
compliance.

• Software Compliance—Device Groups: A software policy attached to a group of servers is 
considered Compliant if more than 5% of the servers in the group attached to the policy have a status 

of Non-Compliant . If this is the case, the aggregate compliance for software policy displays as 
Non-Compliant. Another way to understand Non-Compliant for a device group is to remember that 
when less than 95% of the servers are Compliant, a status of Non-Compliant will display.

However, if more than 2%, but less than or equal to 5%, of all servers in a group have the status of 

Non-Compliant for that category, the status is Partial-Compliant . Another way to understand 
Partial-Compliant for a device group is to remember that when less than 98% but at least 95% of the 
servers are Compliant, a status of Partial-Compliant will display.

If less than 2% of all servers in a group have a Software Policy status of Non-Compliant for that 
category, the overall status is Compliant. Another way to understand Compliant is to remember that 
at least 98% of the servers are Compliant.

The details pane for a group of servers in the Compliance view shows whether the software policies 
are compliant or not. This information does not expand to show a breakdown of individual servers 
and policies. 

You can modify the thresholds used to determine compliance for groups of servers. 

•  Changing Device Group Compliance Settings

•  Software Compliance Remediation

Software Compliance Remediation

The Compliance view allows you to view all software policies attached to a server or to groups of servers, 
and to remediate those servers that are out of compliance. This enables you to ensure that a server’s 
software configuration complies with the software policy definition. 

For each software policy item—such as software, packages, patches, scripts, and application 
configurations—software remediation installs (or for a script, executes) those items on the target server. 
If the items do not exist on the server, they get installed. If the items existed but did not match the policy, 
they get updated with the correct version. 
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For example, you have a software policy that consists of several packages, patches, scripts, and an 
application configuration, all organized in the order in which they are to be installed and executed. First, 
you remediate the software the policy on a server to make sure the server is in compliance with your 
company’s software installation standards. Over time, some of the items in the software policy get 
updated—such as a new set of packages gets added—and, for whatever reason, a software item on the 
server was uninstalled. 

When you perform a software compliance scan, the scan determines the server’s compliance status by 
comparing the software policy contents with the actual software installed on the server. Even if only one 
software item attached to one of the servers is not in compliance with the policy, the server will have a 

software compliance status of Non-Compliant .

When you remediate a server or group of servers, the patches, packages, and application configurations 
specified in the policy are installed and applied in the order specified in the policy. For a group of servers, 
remediation has the same results, only the remediation operation applies to all servers in the group, 
including all servers contained in any sub-groups.

•  Changing Device Group Compliance Settings

•  Remediating Software Compliance for Servers

•  Remediating Software Compliance for Groups

Remediating Software Compliance for Servers

When you remediate software compliance for a single server or for multiple servers, you can choose to 
remediate all of the policies attached to the servers or choose to remediate individual policies. 

You can select the Software Aggregate policy, which remediates all software policies for all servers 
selected. If a group is selected, it remediates against all direct server children in that group. If a single 
software policy is selected in the details pane, the entities selected in the summary pane have that policy 
remediated.

To remediate software policies on a single server:

1 In the navigation pane, select Devices > Servers > All Managed Servers.

2 Select a server in the content pane. 

3 Right-click and then select Open to open the Server browser.

4 In the navigation pane, select Management Policies > Compliance.

5 In the details pane of the Compliance view, expand the Software category and select an individual 
software policy or the top level Software category. This selection enables you to remediate policies 
that are attached to the server.

6 Click Remediate and then complete the steps in the Remediate wizard. If SA does not find devices to 
remediate, a warning dialog displays.

To remediate software policies on multiple servers:

1 In the navigation pane, select Devices > Device Groups, and then select a group.

2 From the View drop-down list, select Compliance. 

3 In the content pane, select servers.

4 In the details pane of the Compliance View, expand the Software category and select a software 
policy that is attached to the selected servers. Or, select the top level Software category if you want 
to remediate all of the software policies attached to the selected servers.
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5 Click one of the following buttons to remediate software policies:

• Remediate: Launches the Remediate wizard that allows you to remediate the selected software 
policy or policies against the selected server or servers. 

• Scan Device: Displays the Scan for Compliance window where you first select the types of 
policies you want scanned and then click Scan to launch the job. This processes scans the 
selected servers for all Audit, Audit Policy, Software, Patch, and Configuration policies attached 
to the servers, and does not have any effect on the audits that target this server.

To monitor the scan’s progress, refresh the Compliance window (press F5).

Note: You can also choose Action > Scan to view a scan’s progress. 

•  Compliance Scans

•  Remediating Software Compliance for Groups

Remediating Software Compliance for Groups

When you remediate software policies for a single group of servers or for multiple groups of servers, you 
can remediate all policies attached to all servers in the single group or in multiple groups. However, when 
you select a group or multiple groups, you can only remediate all software policies attached to all servers 
in the group and any sub-groups.

To remediate software policies for a single group of servers or for multiple groups of servers:

1 To remediate software policies for a single server in the Device Explorer, in the navigation pane, 
select Devices > Servers > All Managed Servers.

2 In the content pane, select a server. 

3 Right-click and then select Open to open the Device browser.

4 In the navigation pane, select Management Policies > Compliance.

5 In the details pane of the Compliance view, expand the Software category and select an individual 
software policy or the top level Software category. This selection enables you to remediate all 
policies attached to the server.

6 Click Remediate and then complete the steps in the Remediate wizard.

Or

7 In the content pane that shows a list of servers that belong to the group, select multiple servers by 
selecting the check box next to each server. (Optional) Select Check All Rows to select all servers.

8 To remediate software policies for multiple servers, in the navigation pane, select Devices > Device 
Groups, and then select a group.

9 From the View drop-down list, select Compliance. 

10 In the details pane of the Compliance view, expand the Software category and select a software 
policy that is attached to the selected servers. Or, select the top level Software category if you want 
to remediate all of the software policies attached to the selected servers.

11 Click one of the following buttons to remediate software policies:
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• Remediate: Launches the Remediate wizard that allows you to remediate the selected software 
policy or policies against the selected server or servers. 

• Scan Device: Displays the Scan for Compliance window where you first select the types of 
policies you want scanned and then click Scan to launch the job. This processes scans the 
selected servers for all Audit, Audit Policy, Software, Patch, and Configuration policies attached 
to the servers, and does not have any effect on the audits that target this server.

To monitor the scan’s progress, refresh the Compliance window (press F5).

Note: You can also choose Action > Scan to view a scan’s progress. 

•  Compliance Scans

•  Remediating Software Compliance for Servers

•  Creating and Managing Software Policies

•  Software Compliance Status Criteria

•  Software Compliance Remediation

Configuration Compliance

In HP Server Automation, an application configuration manages configuration files on a managed server. 
An application configuration can manage one or several configuration files for an individual server or for 
group of servers. Each application configuration includes one or more templates that model an ideal 
configuration state for the fields. These templates help you manage configuration values (key-value 
pairs) for specific files on a server. 

For example, you can create an application configuration that manages the hosts file for servers in your 
data center. You can define the IP address-hostname key-value pairs for a standard Unix hosts file and 
then attach the application configuration to several servers or to a group of servers that contain the file. 
The application configuration serves as the policy that helps ensure that the hosts files on the target 
servers have the correct IP address-hostname definitions. 

Application configuration compliance indicates whether all of the application configurations (policies) 
attached to a server are compliant with the actual application configuration files on the managed server. 
In the hosts file example, if the information inside the hosts file in a server configuration does not match 
the values defined in the application configuration, the server’s Configuration is Non-Compliant . If 
more than one application configuration is attached to a server and any one of the actual configuration 
files targeted by the application configuration is different, the entire server is shown as Non-Compliant in 
the Compliance view.

Conversely, if there are no differences found between the application configuration and the files on a 
server, the Configuration compliance status is Compliant . All application configurations must be 100% 
compliant for the server’s Configuration compliance status to display as Compliant in the Compliance 
view.

To check the latest state of a configuration file targeted by an application configuration, you can perform 
an application configuration compliance scan to determine whether there are any differences between 
the application configuration and the actual configuration files on the server.

See the SA User Guide: Application Configuration for more information.

•  Compliance Scans

•  Configuration Compliance Status Criteria
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Configuration Compliance Status Criteria

Configuration compliance status is determined by the following criteria: 

• Configuration Compliance—Single Server: If any differences are discovered between the 
application configuration and the actual configuration file on the target server, the server’s 

Configuration compliance status is Non-Compliant . The details pane of a server’s Device explorer 
shows the Configuration category as Non-Compliant. If the server has several application 
configurations attached to it and any one of the actual configuration files targeted by the application 
configuration is different than the application configuration, the entire server is considered 
Non-Compliant in the Compliance view.

• Configuration Compliance—Device Groups: An application configuration attached to a group of 
servers is considered Compliant if more than 5% of the servers in the group attached to the 

application configuration have a status of Non-Compliant . If this is the case, the aggregate 
compliance for Configuration displays as Non-Compliant. Another way to understand Non-Compliant 
for a device group is to remember that when less than 95% of the servers are Compliant, a status of 
Non-Compliant will display. However, if more than 2%, but less than or equal to 5%, of all servers in a 

group have the status of Non-Compliant for that category, the status is Partial-Compliant . 
Another way to understand Partial-Compliant for a device group is to remember that when less than 
98% but at least 95% of the servers are Compliant, a status of Partial-Compliant will display.

If less than 2% of all servers in a group have a Configuration status of Non-Compliant for that 
category, the overall status is Compliant. Another way to understand Compliant is to remember that 
at least 98% of the servers are Compliant.

The details pane for a group of servers in the Compliance view shows whether the application 
configurations are compliant or not. This information does not expand to show a breakdown of 
individual servers and policies. 

You can modify the thresholds used to determine compliance for groups of servers. 

Remediating Configuration Compliance—Servers and Groups

Remediation for an application configuration is slightly different than the other compliance category 
types. Rather than remediating a policy on a server (as you can with Audit Policy, Software, or Patch), to 
remediate an application configuration, you select an application configuration in the Device explorer or 
Group explorer. You then use the push function to push the values defined in the application to the actual 
configuration files on the server or group of servers. When you push an application configuration, all 
values defined in the application configuration templates are added to or replace those on the target 
configuration files.

The manner in which a value in an application configuration get pushed, such as sequences of lists and 
scalars, depends on how those values have been set in the application configuration inheritance hierarchy 
and what sequence merge modes have been configured in the configuration template.

To remediate application configurations on a server or on a group of servers:

1 To remediate an application configuration for a single server in the Device Explorer, in the navigation 
pane, select Devices > Servers > All Managed Servers, and then select a server.

Or

2 To remediate an application configuration for a group of servers, in the navigation pane, select 
Devices > Device Groups, and then select a group.

3 Right-click and then select Open to open the Device browser. 

•  In the Information pane, select Management Policies > Configured Applications. See the SA User 
Guide: Application Configuration to continue. 
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