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Legal Notices

Warranty
The only warranties for Hewlett Packard Enterprise products and services are set forth in the express
warranty statements accompanying such products and services. Nothing herein should be construed as
constituting an additional warranty. HPE shall not be liable for technical or editorial errors or omissions
contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend
Confidential computer software. Valid license from HPE required for possession, use or copying. Consistent
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard
commercial license.

Copyright Notice
© Copyright 2015 Hewlett Packard Enterprise Development LP

Trademark Notices
Adobe™ is a trademark of Adobe Systems Incorporated.

Microsoft®, Windows NT®, Windows® and Microsoft®, Windows are U.S. registered trademarks of the
Microsoft group of companies.

UNIX® is a registered trademark of The Open Group.

Documentation Updates
The title page of this document contains the following identifying information:

l Software Version number, which indicates the software version.
l Document Release Date, which changes each time the document is updated.
l Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go to:
https://softwaresupport.hp.com/group/softwaresupport/search-result?keyword=.

This site requires an HPE Passport account. If you do not have one, click the Create an account button on
the HP Passport Sign in page.

Support
Visit the HPE Software Support web site at: https://softwaresupport.hp.com

This web site provides contact information and details about the products, services, and support that HPE
Software offers.

HPE Software Support provides customer self-solve capabilities. It provides a fast and efficient way to
access interactive technical support tools needed to manage your business. As a valued support customer,
you can benefit by using the support web site to:

l Search for knowledge documents of interest
l Submit and track support cases and enhancement requests
l Download software patches
l Manage support contracts
l Look up HPE support contacts
l Review information about available services
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l Enter into discussions with other software customers
l Research and register for software training

Most of the support areas require that you register as an HPE Passport user and sign in. Many also require a
support contract. To register for an HP Passport ID, go to https://softwaresupport.hp.com and click Register.

To find more information about access levels, go to:
https://softwaresupport.hp.com/web/softwaresupport/access-levels

HPE Software Solutions & Integrations and Best Practices
Visit HPE Software Solutions Now at https://h20230.www2.hp.com/sc/solutions/index.jsp to explore how the
products in the HPE Software catalog work together, exchange information, and solve business needs.

Visit the Cross Portfolio Best Practices Library at https://hpln.hpe.com/group/best-practices-hpsw to access a
wide variety of best practice documents and materials.
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Chapter 1: OMi Management Pack for Oracle
Database
The HPE OMi Management Pack for Oracle Database (OMi MP for Oracle Database) works with Operations
Manager i (OMi) and enables you tomonitor Oracle database environments. It includes Indicators - Health
Indicators (HIs), Event Type Indicators (ETIs) and Correlation Rules that analyze the events that occur in the
Oracle databases and report the health status of the Oracle databases. It also includes out-of-the-box
(OOTB) Aspects for monitoring different types of Oracle database environments (single instance databases,
Real Application Cluster (RAC), Automatic StorageManagement (ASM), and Data Guard. TheManagement
Templates consist of a wide range of Aspects which enable themonitoring of Oracle components and the
system components.

TheseManagement Templates can be seamlessly deployed by administrators for monitoring Oracle
databases in an environment. The Subject Matter Experts (SMEs) and developers can easily customize the
Oracle Management Templates.

TheOMi MP for Oracle Database works with OMi and provides the following additional functionalities to
support a unifiedmonitoring solution:

l Oracle instance based deployment and configuration
l Agent and agentless monitoring of Oracle instances

User Guide

HPE OMi Management Pack for Oracle Database (1.11) Page 7 of 102



Chapter 2: Getting Started
The following section provides step-by-step instructions about monitoring Oracle databases using OMi MP for
Oracle Database.

Task 1: Adding Nodes to the BSMConsole
Note: If the node already exists in RTSM, you can skip this step and proceed to Task 2.

Before you beginmonitoring, you need to add the nodes to the BSM console.

1. Open theMonitored Nodes manager from theOperations Management Administration:
On BSM 9.2x, click Admin > Operations Management > Setup > Monitored Nodes.
OnOMi 10.x, click Administration > Setup and Maintenance > Monitored Nodes.

2. In the Node Views pane, click Predefined Node Filters > Monitored Nodes and click and then
click Computer > Windows or Unix. The Create New Monitored Nodes dialog box appears.

3. Specify the Primary DNS Name, IP address, Operating System, and Processor Architecture of the node
and click OK.
The newly created node is saved as a CI instance in RTSM.

Note: The node with the HP Operations Agent must be connected to OMi server and certificate
must be granted.

Task 2: User Privileges for non-privileged HP
Operations Agent User
Before deploying the Oracle Discovery Aspect, youmust follow these steps:

On Windows: No additional permission is required.

On Linux:

1. Youmust provide read, write, and execute permissions to non-privileged user for /var/opt/OV directory.
2. Youmust create /etc/opt/OV directory and provide read, write, and execute permissions to non-

privileged user.

Note: Make sure that the HP Operations Agent non-root user is given read permission to the ORACLE_
HOME directory.

Task 3: Deploying the Oracle Discovery Aspect
To discover the Oracle CI on the addedmanaged nodes, youmust deploy the Oracle Discovery Aspect by
following these steps:

HPE OMi Management Pack for Oracle Database (1.11) Page 8 of 102



1. Open theManagement Templates & Aspects pane:
On BSM 9.2x, click Admin > Operations Management > Monitoring > Management Templates &
Aspects
OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects

2. In the Configuration Folders pane:
Configuration Folders > Database Management > Oracle > Oracle Aspects

3. In theOracle Aspects folder, right-click the Oracle Discovery Aspect, and then click Assign and
Deploy Item to open the Assign and Deploy Wizard.

4. In theConfiguration Item tab, click the CI to which you want to deploy the Oracle Discovery Aspect
and then click Next.

5. In theRequired Parameters tab, click Next.

Note: Oracle Discovery Aspect do not havemandatory parameters. You will get a notification
stating the followingmessage:

There are no parameters that require editing for this Assignment.

6. (Optional). In theAll Parameters tab, you can change the default values of the parameters. To change
the default values of the parameters, follow these steps:

a. Select the Frequency of OracleDB_DeepDiscovery parameter and then click . The Edit
Instance Parameter window appears.

b. Click Value, specify the value, and then click OK.
c. Click Next.

7. (Optional).In theConfigure Options tab, if you do not want to enable the assignment immediately, clear
theEnable Assigned Objects check box. You can enable the assignment later using the Assignments
& Tuning pane.

8. Click Finish.

Note: After the Oracle Discovery Aspect is deployed, amessage stating the Assignment and
deployment jobs created appears. To check the status of the deployment jobs, go toAdmin >
Operations Management > Monitoring > Deployment Jobs.

Task 4: Configuring OMi MP for Oracle Database for
HP Operations Agent running with non-privilege user
After deploying the Oracle Discovery Aspect, youmust follow these steps:

On Windows: No additional permission is required.

On Linux:

1. Run the script as a root user under /var/opt/OV/bin/instrumentation:
dbspi_root.pl

The /etc/dbspi.su is created.
2. Edit the dbspi.su file as a root user by uncommenting the lines or adding new lines:

<user>:<commands>
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As in the following examples:

oracle:/opt/oracle/product/sqlplus /nolog - allows sqlplus commands
or

oracle:/opt/oracle/product/* - allows execution of all commands by anOracle user

Task 5: Verifying Discovery
After you deploy the Oracle Discovery Aspect, youmust verify if the CIs are populated in the Top view.

To view the CIs populated in the Browse Views, follow these steps:

1. Open the Event Perspective pane:
On BSM 9.2x, click Applications > Operations Manager > Event Perspective.
OnOMi 10.x, clickWorkspaces > Operations Console > Event Perspective.

2. In theBrowse Views tab, select theOracle_Database_Deployment.

Task 6: Deploying the Oracle Management
Templates or Oracle Aspects
If you have already deployedOMi MP for Oracle Database 1.10 - Management Templates and Aspects, then
skip to "Task 8: Updating Assignments to Newer version".

You can deploy Oracle Management Templates or Aspects to the Oracle CIs. For more information about
deploying Oracle Management Templates, go to "Task 6a: Identifying and Deploying anOracle Management
Template" For information about deploying Oracle Aspects, go to "Task 6b: Deploying Oracle Aspects".

Data Collection Process
The frequency (polling interval) at which each policy must bemonitored is predefined with a default value in a
specific frequency parameter. Frequency parameter is an expert parameter that is defined for each of the
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metrics regardless of whether they are for generating events or not.

Following are the four predefined frequency parameters:

Scheduler Frequency Default value

Very High 5mins

High 15mins

Medium 1 hour

Low 24 hours

After Management Templates and Aspects are deployed, collector is triggered based on the parameter value
in a specific policy. You canmodify the default value of the parameter at the following levels:

l During deployment of theManagement Template or Aspects using theManagement Templates & Aspects
pane

l After deployment using the Assignments & Tuning pane.
For more information about how tomodify the parameter values, see "Tuning Oracle Management Templates
".

Task 6a: Identifying and Deploying an Oracle
Management Template
Youmust deploy the Oracle Discovery Aspect even if the CIs are already populated by other source such as
SiteScope, DDM and so on. For more information, see "Task 3: Deploying the Oracle Discovery Aspect".

Before deploying the Oracle Management Templates, follow these recommendations to identify the Oracle
Management Template suitable for your environment:

l If you want to monitor the basic functionalities such as Locks & Latches, memory, tablespaces, and
transactions for single instanceOracle database environment, you can deploy theEssential Oracle
Management Template.

l If you want to monitor performance of IO, query, objects, and database space utilization along with the
basic functionality, you can deploy theExtensive Oracle Management Template.

l For agentless monitoring, you can deploy theHybrid Oracle Management Template.
OMi MP for Oracle Database contains Aspects that are not part of any existingManagement Templates. You
can add the required Aspects to any of the existingManagement Template. For more information about how
to add required Aspects, see the section "Tuning Oracle Management Templates " and for list of Aspects,
see the section "Overview of Oracle Aspects" on page 27. You can also create new Management Template
with the combination of required Aspects, see the section "Creating New Oracle Management Templates".

To deploy the Oracle Management Template, follow these steps:

1. Open theManagement Templates & Aspects pane:
On BSM 9.2x, click Admin > Operations Management > Monitoring > Management Templates &
Aspects.
OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects

2. In the Configuration Folders pane:
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Configuration Folders > Database Management > Oracle > Oracle Management Templates
3. In theOracle Management Templates folder, click theManagement Template that you want to deploy,

and then click . The Assign and Deploy wizard opens.
4. In theConfiguration Item tab, click the CI to which you want to assign theManagement Template, and

then click Next. You can select multiple items by holding down theCtrl orShift key while selecting
them. Click Next to accept the CIs and go toRequired Parameters.

5. In theRequired Parameters tab, youmust specify themandatory parameters - Oracle Instance User
Name andOracle Instance password. To specify theRequired Parameters, follow these steps:

Note: Required Parameters lists all mandatory parameters in themanagement template that do not
have a value.

a. Select theOracle Instance User Name parameter in the list, and then click . TheOracle
Instance User Name dialog box opens.

b. Click Value, specify the value, and then click OK

c. Select theOracle Instance Password parameter in the list, and then click . TheOracle
Instance Password dialog box opens.

d. Click Value, specify the value, and then click OK.
e. Click Next.

6. In theAll ParametersParameter Summary tab, you can change the default values of the parameters.
To change the default values of the parameters, follow these steps:

a. Select theOracle Instance Name parameter and then click . The Edit Instance Parameter
window appears.

b. Select the parameter from the list and then click . The Edit Parameter dialog box opens. Click
Value, specify the value, and then click OK.

c. If the Oracle database is enabled with the Oracle listener service, then youmust provide password

for the listener service. Select the Listener Name parameter and click .
d. Double-click theOracle Listener Password dependent parameter.
e. Enter the listener password in thePassword field.
f. Enter the same password in theVerify Password field and click OK.

Note: In theAll ParametersParameter Summary tab, you can override the default values of any
parameter. You can specify a value for each parameter at theManagement Template level. By
default, parameters defines as expert parameters are not shown. To show expert parameters, click

Hide Expert Parameters.

g. Click Next.
7. (Optional). In theConfigure Options tab, if you do not want to enable the assignment immediately,

perform the following
On BSM 9.2x, clear theEnable Assigned Objects check box.
OnOMi 10.x, clear theEnable Assignment(s) check box.
You can enable the assignment later using the Assignments & Tuning pane.

8. Click Finish.
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Note: The username given during the deployment of aManagement Template should have required
privileges for OMi MP for Oracle Database to collect data. You can use the oracle user system or you
can create a user. To create a user on the node, you can use the script dbspiocr.sh or dbspiocr.bat as
mentioned in the following steps or you can create a user manually by referring the dbspiocr.sql. This
script also contains information about the required list of privileges. The script is available at the following
location only after deploying the Oracle Discovery Aspect:

Linux:

/var/opt/OV/bin/instrumentation

Usage:dbspiocr.sh -oracle_home <OracleHomeDir> -oracle_sid <InstanceName> -sys_pass
<SysPassword> -user <NewUserName> -user_pass <NewUserPassword> -def_ts
<DefaultTableSpaceName> -tmp_ts <TempTableSpaceName>

For example:dbspiocr.sh -oracle_home /app/oracle/product/db_1 -oracle_sid orcl -sys_
pass manager -user hporamp -user_pass hporamp -def_ts users -tmp_ts temp

Windows:

<ovagentdir>\bin\instrumentation

Usage:dbspiocr.bat -oracle_home <OracleHomeDir> -oracle_sid <InstanceName> -sys_pass
<SysPassword> -user <NewUserName> -user_pass <NewUserPassword> -def_ts
<DefaultTableSpaceName> -tmp_ts <TempTableSpaceName>

Example:dbspiocr.bat -oracle_home C:\app\oracle\product\db_1 -oracle_sid orcl -sys_
pass manager -user hporamp -user_pass hporamp -def_ts users -tmp_ts temp

In case of Oracle database 12.1 or later, the user name should begin with c## as prefix. For example,
c##hporamp.

For more information about the permission that the username requires, see the section "Permission and
Grants".

Task 6b: Deploying Oracle Aspects
Youmust deploy the Oracle Discovery Aspect even if the CIs are already populated by other source such as
SiteScope, DDM and so on. For more information, see "Task 3: Deploying the Oracle Discovery Aspect".

To deploy the Oracle Aspects, follow these steps:

1. Open theManagement Templates & Aspects pane:
On BSM 9.2x, click Admin > Operations Management > Monitoring > Management Templates &
Aspects.
OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:
Configuration Folders > Database Management > Oracle > Oracle Aspects

3. In theManagement Templates & Aspects pane, click the Oracle Aspect that you want to deploy, and
then click . The Assign and Deploy wizard opens.

4. In theConfiguration Item tab, click the CI to which you want to assign the Aspect, and then click Next.

Note: The required parameters are already specified while deploying the Oracle Discovery Aspect.
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Note: In theAll ParametersParameter Summary tab, you can override the default values of any
parameter. You can specify a value for each parameter at theManagement Template level. By
default, parameters defined as expert parameters are not shown. To show expert parameters, click

Hide Expert Parameters.

5. In theRequired Parameters tab, youmust specify themandatory parameters - Oracle Instance User
Name andOracle Instance password. To specify theRequired Parameters, follow these steps:

Note: Required Parameters lists all mandatory parameters in themanagement template that do not
have a value.

a. Select theOracle Instance User Name parameter in the list, and then click . TheOracle
Instance User Name dialog box opens.

b. Click Value, specify the value, and then click OK

c. Select theOracle Instance Password parameter in the list, and then click . TheOracle
Instance Password dialog box opens.

d. Click Value, specify the value, and then click OK.
e. Click Next.

6. In theAll ParametersParameter Summary tab, you can change the default values of the parameters.
To change the default values of the parameters, follow these steps:

a. Select theOracle Instance Name parameter and then click . The Edit Instance Parameter
window appears.

b. Select the parameter from the list and then click . The Edit Parameter dialog box opens. Click
Value, specify the value, and then click OK.

c. If Oracle database with Oracle listener service enabled, then youmust provide password for the

listener service. Select the Listener Nameparameter and click .
d. Double-click theOracle Listener Password dependent parameter.
e. Enter the listener password in thePassword field.
f. Enter the same password in theVerify Password field and click OK.

Note: In theAll ParametersParameter Summary tab, you can override the default values of any
parameter. You can specify a value for each parameter at theManagement Template level. By
default, parameters defined as expert parameters are not shown. To show expert parameters, click

Hide Expert Parameters.

g. Click Next.
7. (Optional). In theConfigure Options tab, if you do not want to enable the assignment immediately,

perform the following:
On BSM 9.2x, clear theEnable Assigned Objects check box.
OnOMi 10.x, click theEnable Assignment(s) check box.
You can then enable the assignment later using the Assignments & Tuning pane.

8. Click Finish.
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Task 7: Configuring Oracle Database Error Log
Monitoring for non-privileged HP Operations Agent
User
On Windows:

As an Administrator, youmust provide read permission for the following directories to non-privileged user:

<ORACLE_BASE>\oradata\<ORACLE_SID>\

<ORACLE_BASE>\diag\

On Linux:

1. To identify the Oracle database alert log that needs to bemonitored, run the following command as a root
user:

/var/opt/OV/bin/instrumentation/dbspicao -l

2. Youmust provide read permission to the non-root user for alert logmonitoring.

Task 8: Updating Assignments to Newer version
To updateManagement Templates or Aspects to the latest version, perform the following steps for each
Management Template or Aspect assignment on each node:

Note: Youmust deploy Oracle Management Templates and Aspects to theOracleCI.

On BSM 9.2x, to update perform the following steps:

1. Open theManagement Template & Aspects pane:
Admin > Operations Management > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:
Configuration Folders > Database Management > Oracle

3. To deploy the latest version of Essential Oracle Management Template:
In theManagement Templates & Aspects pane, expand theEssential Oracle Management Template
and select 1.100 version and click Assign and Deploy Item.
Similarly, you can select the 1.100 version of the requiredManagement Template or Aspects and click

.
OnOMi 10.x, to update perform the following steps:

1. Open the Assignments & Tuning pane:
Administration > Monitoring > Assignments & Tuning

2. In the Browse Views pane, select theOracle_Database_Deployment view and select each CI where
version update is required.

3. Click Show Assignments That Require an Update.
All theManagement Templates and Aspects that requires an update are listed.
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4. Select each of theManagement Templates and Aspects and click Update Assigned Item.
The Update Assigned Item dialog box appears.

5. In theUpdate Options tab, follow these steps:
a. Select the latest version from theUpdate to Version drop down list.
b. Select the parameter value that you require for the assignment:

If you select Use parameter values from existing assignments, only the new mandatory
parameters that do not have a default value are listed.
If you select Use default parameter values from version selected above, all mandatory
parameters from the selectedManagement Template or Aspect version that do not have a default
value are displayed. These parameters must be edited before proceeding to the next step of the
wizard.

c. Click Next.
6. In theRequired Parameter tab, edit and provide values for each of themandatory parameters. Oracle

Instance User Name andOracle Instance Password are themandatory parameters.
7. In theParameter Summary tab, if you have assigned theOracle ASM Health aspect to the ASM

environment, then youmust provide value for the dependent Oracle ASM Instance parameter. You can
view this parameter when you edit Oracle Instance Name parameter.

8. Click Finish to save the changes and close the wizard.

The assigned item is updated to the specifiedManagement Template or Aspect version.

Monitoring Oracle Environment
After you deploy Management Template and Aspects, you can analyze the status and health of Oracle CIs
from the following perspectives:

l Event Perspective
l Health Perspective
l Performance Perspective

Event Perspective
The Event Perspective provides complete information of events. In the Event Perspective, you can view the
event information of the Oracle CI that aremonitored by OMi MP for Oracle Database.

To view the Event Perspective of Oracle CIs, follow these steps:

1. Open the Event Perspective pane:
On BSM 9.2x, click Applications > Operations Management > Event Perspective.
OnOMi 10.x, clickWorkspaces > Operations Console > Event Perspective.

2. In theBrowse Views tab, select theOracle_Database_Deployment that contains the Oracle CIs for
which you want to view the events. Alternatively, you can useSearch tab to find aOracle CI.

3. Click the Oracle CI for which you want to view the Event Perspective. The list of events for the selected
Oracle CI appears on the Event Browser pane.
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When you click an event from the Event Browser, the Event Details pane opens where you can view the
following details:
o General - Displays the detailed information about the selected event such as Severity, Lifecycle

State, Priority, Related CI and so on.

o Additional Info - Displays more detailed information about the attributes of the selected event.

o Source Info - Displays an overview of the information available about the source of the selected
event.

o Actions - Displays the list of actions available for a selected event. There are two types of possible
actions: User Actions and Automatic Action.

o Annotations - Displays a list of the annotations attached to the selected event.

o Custom Attributes - Displays a list of the attributes that either an administrator or the responsible
user manually configured and added to the selected event.

o Related Events - Displays an overview of all the events that are related to the event selected in the
Event Browser.

o History - Displays the history of the selected event.

o Resolver Hints - Displays the information used to identify the node and CI associated with an event.

o Instructions - Displays instructions designed to help operators handle the associated event.

o Forwarding - Displays the transfer of ownership details if any, for the events.

Health Perspective
The Health Perspective provides a high-level view of the overall health information of the related CIs in the
context of events. In the Health Perspective, you can view the health information of the Oracle CIs that are
monitored by OMi MP for Oracle Database.

To view the Health Perspective of Oracle CIs, follow these steps:

1. Open the Health Perspective pane:
On BSM 9.2x, click Applications > Operations Management > Health Perspective.
OnOMi 10.x, clickWorkspaces > Operations Console > Health Perspective.

2. In theBrowse Views tab, select theOracle_Database_Deployment that contains the Oracle CIs for
which you want to view the health related events. Alternatively, you can useSearch tab to find an
Oracle CI.

3. Click theOracle CI for which you want to view the Health Perspective. The list of health related events
for the selected Oracle CI appears on the Event Browser pane.
When you click an event from the Event Browser pane, the following panes appear:
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o Health Top View - Displays the health top view of the selected event.

o Health Indicators - Displays the Key Performance Indicators (KPIs) and HIs related to the CI that
you select from the Health Top View pane.

o Actions - Displays the list of actions available for a selected event.

Performance Perspective
Performance Perspective enables you to populate graphs from existing graph templates. You can also plot
customized graphs by selecting the requiredmetrics for a specific CI.

To view the Performance Perspective of Oracle CIs using graphs, follow these steps:

1. Open the Performance Perspective pane:
On BSM 9.2x, click Applications > Operations Management > Performance Perspective.
OnOMi 10.x, clickWorkspaces > Operations Console > Performance Perspective.

2. In theBrowse Views tab, select theOracle_Database_Deployment. The list of CIs appear. Select a
specific CI. The Performance pane appears, which lists the default graphs available for theOracle_
Database_Deployment view.

3. Click the graph you want to plot from theGraphs tab, and then click Draw Graphs. The selected
graph is plotted on the right pane.

Note: Formore information about Event Perspective, Health Perspective, and Performance
Perspective, see theOperations Manager i Concepts Guide.
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Chapter 3: Components
TheOMi MP for Oracle Database includes the following components for monitoring Oracle databases in an
environment:

Oracle Management Templates
TheManagement Templates consists of several Aspects which enables you tomonitor Oracle databases
based on the criticality and type of the environment. By default, the OMi MP for Oracle Database consists of
a set of Management Templates. You can deploy the out of the box Management Templates with the default
parameters or you can customize theManagement Templates based on your requirements. In addition, you
can also createManagement Templates based on themonitoring requirements using the Oracle Aspects.

Overview
TheOMi MP for Oracle Database comprises the followingManagement Templates:

l Essential Oracle Management Template
l Extensive Oracle Management Template
l Hybrid Oracle Management Template
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How to Access the Oracle Management Templates

1. OpenManagement Templates & Aspects pane:
On BSM 9.2x, click Admin > Operations Management > Monitoring > Management Templates &
Aspects.
OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. Click Configuration Folders > Database Management > Oracle > Oracle Management Templates.

Note: For OMi MP for Oracle Database version 1.11 theManagement Templates and Aspects version is
1.100.

Tasks
How to Automatically Assign Oracle Management Templates and Oracle Aspects

To automatically assign Oracle Management Templates or Oracle Aspects, youmust specify the required
privileges.

1. Open Automatic Assignment Rules pane:
On BSM 9.2x, click Admin > Operations Management > Monitoring > Automatic Assignment
Rules.
OnOMi 10.x, click Administration > Monitoring > Automatic Assignment Rules.
The pane consists of the Auto-Assignment Rules pane at the top, and a Parameter list at the bottom.

2. Click New Assignment in the toolbar of the Auto-Assignment Rules pane and select the
appropriate option.

3. In theSelect Target View tab, select the Oracle view containing the CIs for which you want to create an
automatic assignment, and click Next.

4. In theSelect Item to Assign tab, select the Oracle management template or aspect that you want to
automatically assign to all CIs with a CI type appearing in the selected view.

The list shows only themanagement templates that have a root CI type that appears in the view
that you selected or, in case an aspect is auto-assigned, compatible aspects.

The latest version of themanagement template or aspect that you want to assign is selected by default.
If required, select a different version inVersion column.
Click Next.

5. In theRequired Parameter tab, all themandatory parameters in themanagement template are listed.

a. To change a parameter, double-click it, or select it in the list and click Edit.
b. For standard parameters, the Edit Parameter dialog opens.

Click Value, specify the value, and then click OK.
c. For instance parameters, the Edit Instance Parameter dialog opens.

Add instance values, and then for each instance value, specify dependent parameter values. After
you specify the instances and dependent parameter values, click OK.

d. Click Next.
6. (Optional). In theAll Parameters/Parameter Summary tab, specify a value for each parameter that
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must bemonitored against a different value than the default value.

a. To change a parameter, double-click it, or select it in the list and click Edit.
b. For standard parameters, the Edit Parameter dialog opens.

Click Value, specify the value, and then click OK.
c. For instance parameters, the Edit Instance Parameter dialog opens.

Add instance values, and then for each instance value, specify dependent parameter values. After
you specify the instances and dependent parameter values, click OK.

d. Click Next.
Click Next to go to theConfigure Options tab, or Finish to save the assignment and close the wizard.

7. (Optional). In theConfigure Options tab, clear theEnable Assigned Objects check box on BSM 9.2x
or clear theEnable Assignment(s) check box onOMi 10.x, if you do not want to activate the
assignment rule immediately.

8. Click Finish to save the changes and close the wizard.
The assignment rule is added to the list of auto-assignment rules.

An assignment may trigger an event to be sent to OMi if one of the following situations applies:

l A deployment job fails.
l An auto-assignment fails.
l An auto-assignment succeeds. This behavior can be configured in the Infrastructure Settings.
Follow the steps to check if the automatic assignment rule successfully created the expected assignments:

l Open Assignments & Tuning pane:
On BSM 9.2x, click Admin > Operations Management > Monitoring > Assignments & Tuning.
OnOMi 10.x, click Administration > Monitoring > Assignments & Tuning.

l In theBrowse Views tab, select the view you identified when creating your automatic assignment rule.
l Expand the view, and select a node that corresponds to the root CI type of the assigned item.
Assignments created as a result of Automatic Assignment Rules are shown in the list of assignments at
the top of the right pane, and have the value AutoAssignment in the columnAssigned By.

You can consider the following options for tuning the assignment:

l Use the Auto-Assignment Rules pane to tune the parameter values for all assignments triggered by the
automatic assignment rule.

l Use the Assignments pane to tune, redeploy, delete, and enable or disable individual assignments.

How to Display an Assignment Report for an Oracle Management Template

1. Select theManagement Template you want to create the report for.

2. Click Generate Assignment Report in theManagement Templates & Aspects pane.
The preconfigured Assignment Report is displayed.

You can display additional types of reports from the Assignments & Tuning pane.

Essential Oracle Management Template
The Essential Oracle Management Template can be used tomonitor Oracle databases in an environment. It
comprises of essential Oracle Aspects and Infrastructure Aspects for monitoring the availability, health, and
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performance of Oracle database environments.

If you want to check the availability, health, and performance of the Oracle databases in your environment,
and also want to monitor the basic functionalities of the Oracle features - tablespaces, memory, objects,
segments, transactions, locks and latches. In such a scenario, you can deploy the Essential Oracle
Management Template on all the Oracle CIs in the environment. The Essential Oracle Management Template
comprises of specific Aspects to monitor these features.

Note: To use and deploy Infrastructure Aspects, youmust install OMi Management Pack for
Infrastructure software.

How to Access the Essential Oracle Management Template

1. OpenManagement Templates & Aspects pane:
On BSM, click Admin > Operations Management > Monitoring > Management Templates &
Aspects
OnOMi, click Administration > Monitoring > Management Templates & Aspects

2. In the Configuration Folder pane, click Configuration Folders > Database Management > Oracle >
Oracle Management Templates > Essential Oracle Management Template.

User Interface Reference

Management Template - General
Provides an overview of the attributes of theManagement Template.

UI Element Description

Name Essential Oracle Management Template

Description Manages Oracle database single instance environment in monitoring the primary areas of
database like availability, Oracle IO performance, tablespace andOracle alert log and
others, along with essential infrastructure areas of CPU, Memory and Disk.

ID A unique identifier for this version.

Version ID A unique identifier for this version of the Essential Oracle Management Template.

Version The current version of the Essential Oracle Management Template.

In this instance, the version of theManagement Template is 1.100.

Change
Log

Text that describes what is new ormodified in this version of the Essential Oracle
Management Template.
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Management Template - Topology View

UI Element Description

Topology View ORA_Deployment is the Topology View for Essential Oracle Management
Template. It contains the Oracle related CITs that you want to manage using the
Management Template.

CI Type The type of CIs that the Essential Oracle Management Template enables you to
manage. This is the type of CI to which theManagement Template can be
assigned.

Management Template - Aspects
The Essential Oracle Management Template contains the following Oracle Aspects:

l Basic Oracle Lock & Latches
l Basic Oracle Memory Performance
l Basic Oracle Segment Space
l Oracle Database Availability
l Oracle Discovery
l Oracle IO Performance
l Oracle Tablespace Health
l Oracle Transactions
The Essential Oracle Management Template contains the following Infrastructure Aspects:

Resource Bottleneck Diagnosis

The Resource Bottleneck Diagnosis Aspect identifies congestions and bottleneck conditions for system
resources like the CPU, memory, network and disk. CPU bottleneck monitoring is based on global CPU
utilization and load average (RunQueue Length).

System Infrastructure Discovery

Discovers and gathers information regarding the system resources, operating system, and applications on a
managed node.

System Fault Analysis

The System Fault Analysis Aspect monitors the kernel log file, boot log file, and event log file for critical error
conditions and instructions on what might have caused it.

Extensive Oracle Management Template
The Extensive Oracle Management Template can be used for monitoring single instance databases and high
availability environments - RAC, Data Guard, and ASM environments. This Management Template
comprises complete set of Oracle Aspects and Infrastructure Aspects to monitor the availability, status, and
health of the Oracle database environments.

Manages Oracle database single instance environment as well as High-availability environments in
monitoring the primary and advanced areas of database such as availability, query performance, tablespace,
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Real Application Cluster, DataGuard, ASM andOracle alert log and so on along with deep infrastructure
areas of CPU, Memory and Disk. The Extensive Oracle Management Template comprises of specific
Aspects for monitoring these features.

Note: To use and deploy Infrastructure Aspects, youmust install OMi Management Pack for
Infrastructure software.

How to Access the Extensive Oracle Management Template

1. OpenManagement Templates & Aspects pane:
On BSM, click Admin > Operations Management > Monitoring > Management Templates &
Aspects.
OnOMi, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folder pane, click Configuration Folders > Database Management > Oracle >
Oracle Management Templates > Extensive Oracle Management Template.

User Interface Reference

Management Template - General
Provides an overview of the attributes of theManagement Template.

UI Element Description

Name Extensive Oracle Management Template

Description Manages Oracle database single instance environment in monitoring the advanced areas of
database like query performance, archive health, database space utilization, objects and
Oracle alert log etc along with advanced infrastructure areas of CPU, Memory and Disk.

ID A unique identifier for this version.

Version ID A unique identifier for this version of the Extensive Oracle Management Template.

Version The current version of the Extensive Oracle Management Template.

In this instance, the version of theManagement Template is 1.100.

Change
Log

Text that describes what is new ormodified in this version of theManagement Template.

Management Template - Topology View

UI Element Description

Topology View ORA_Deployment is the Topology View for Extensive Oracle Management
Templates. It contains the Oracle related CITs that you want to manage using the
Management Template.

CI Type The type of CIs that the Extensive Oracle Management Template enables you to
manage. This is the type of CI to which theManagement Template can be
assigned.
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Management Template - Aspects
The Extensive Oracle Management Template contains the following Oracle Aspects:

l Basic Oracle Locks & Latches
l Basic Oracle Memory Performance
l Basic Oracle Query Performance
l Basic Oracle Segment Space
l Oracle Archive Health
l Oracle Database Availability
l Oracle Database Space Utilization
l Oracle Discovery
l Oracle IO Performance
l Oracle Object Faults
l Oracle Tablespace Health
l Oracle Transactions
The Extensive Oracle Management Template contains the following Infrastructure Aspects:

Bandwidth Utilization and Network IOPS

Monitors I/O operations, and performance of the systems in the network. It monitors the network I/O
operations and performance based on the bandwidth used, outbound queue length and average bytes
transferred per second.

CPU Performance

Monitors I/O operations, and performance of the systems in the network. It monitors the network I/O
operations and performance based on the bandwidth used, outbound queue length and average bytes
transferred per second.

Memory and Swap Utilization

Monitors memory performance of the system. Memory performancemonitoring is based onMemory
utilization (in percentage), Swap space utilization (in percentage), Freememory available (in MBs) and Free
swap space available (in MBs).

Remote Disk Space Utilization

Monitors the space utilization of the remote disk.

Space Availability and Disk IOPS

Monitors the disk I/O operations and space utilization of the system.

System Infrastructure Discovery

Discovers and gathers information regarding the system resources, operating system, and applications on a
managed node.
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Hybrid Oracle Management Template
The Hybrid Oracle Management Template can be used for monitoring Oracle databases in an environment
using agent and agentless monitoring. It comprises agent basedOracle Aspects, agent based Infrastructure
Aspects, and agentless Oracle Aspects.

Note: To use and deploy Infrastructure Aspects, youmust install OMi Management Pack for
Infrastructure software.

How to Access the Hybrid Oracle Management Template

1. OpenManagement Templates & Aspects pane:
On BSM, click Admin > Operations Management > Monitoring > Management Templates &
Aspects.
OnOMi, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folder pane, click Configuration Folders > Database Management > Oracle >
Oracle Management Templates > Hybrid Oracle Management Template.

User Interface Reference

Management Template - General
Provides an overview of the attributes of theManagement Template.

UI Element Description

Name Hybrid Oracle Management Template

Description Manages Oracle database single instance environment in monitoring the primary areas of
database like availability and performance through agent and agentless aspects along with
essential infrastructure areas of CPU, Memory and Disk.

ID A unique identifier for this version.

Version ID A unique identifier for this version of theManagement Template.

Version The current version of theManagement Template.

In this instance, the version of theManagement Template is 1.100.

Change
Log

Text that describes what is new ormodified in this version of theManagement Template.
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Management Template - Topology View

UI Element Description

Topology View ORA_Deployment is the Topology View for Hybrid Oracle Management Template.
It contains the Oracle related CITs that you want to manage using theManagement
Template.

CI Type The type of CIs that the Oracle Management Template enables you tomanage.
This is the type of CI to which theManagement Template can be assigned. The
Oracle Management Templates contains Computer CITs.

Management Template - Aspects
The Hybrid Oracle Management Template comprises the following Oracle Aspects:

l Basic Oracle Lock & Latches
l Basic Oracle Memory Performance
l Basic Oracle Segment Space
l Oracle Database Availability
l Oracle Discovery
l Oracle IO Performance
l Oracle Tablespace Health
l Oracle Transactions
The Hybrid Oracle Management Template contains the following Agentless Aspects:

l Oracle Database Availability (Agentless)
l Oracle Database Response Time (Agentless)
The Hybrid Oracle Management Template contains the following Infrastructure Aspects:

System Infrastructure Discovery

Discovers and gathers information regarding the system resources, operating system, and applications on a
managed node.

Resource Bottleneck Diagnosis

The Resource Bottleneck Diagnosis Aspect identifies congestions and bottleneck conditions for system
resources like the CPU, memory, network and disk. CPU bottleneck monitoring is based on global CPU
utilization and load average (RunQueue Length).

System Fault Analysis

The System Fault Analysis Aspect monitors the kernel log file, boot log file, and event log file for critical error
conditions and instructions on what might have caused it.

Overview of Oracle Aspects
Oracle Aspects are used tomonitor the building blocks or units of an Oracle database - tablespace, memory,
objects, segments, Real Application Cluster (RAC), and Automatic StorageManagement (ASM)
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environments.

How to Access the Oracle Aspects

1. OpenManagement Templates & Aspects pane:
On BSM, click Admin > Operations Management > Monitoring > Management Templates &
Aspects.
OnOMi, click Administration > Monitoring > Management Templates & Aspects.

2. Click Configuration Folders > Database Management > Oracle > Oracle Aspects.

Tasks

Oracle Aspects
AnOracle Aspect comprises policy templates, instrumentation, and parameters for monitoring the health and
performance of Oracle databases. EachOracle Aspect can be used tomonitor individual units of Oracle
databases.

User Interface Reference

General Provides an overview of the general attributes of the Oracle Aspects.

CI Type The type of CIs that the Aspect can be assigned to. This is the type of CI to which
theManagement Template can be assigned. TheOracle Aspects contain the
Computer andOracle CITs.

Instrumentation Provides a single package which contains the binaries for discovery, collection, and
data logging.

Aspects Provides an overview of Aspects that the Oracle Aspect contains. You can expand
each item in the list to seemore details about the nested aspect. TheOracle Base
aspect is part of all the other Aspects.

Policy Templates Provides an overview of the policy templates that the Oracle Aspect contains. You
can expand each item in the list to seemore details about the policy template.

Basic Oracle Locks and Latches

This Aspect monitors the consumption of Oracle locks (in percentage) and also checks the usage of the
counters - session wait lock count and latch count. This is a basic type of Aspect.
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CI Type
Policy
Template

Roll Up or
Drill Down Policy Description Policy Type

Oracle OracleDB_
0028

N/A Monitors the percentage of DML
locks that are configured.

Measurement Threshold
Template

OracleDB_
0029

N/A Monitors the number of sessions
waiting for a release of a lock.

OracleDB_
0043

N/A Monitors the percentage of
enqueue timeouts to enqueue
requests.

Basic Oracle Memory Performance

This Aspect monitors the Oracle memory units - BufferCache, Shared Pool, and Library Cache. This is a
Basic type of Aspect.

CI Type
Policy
Template

Roll Up or
Drill Down Policy Description Policy Type

Oracle OracleDB_
0021

N/A Monitors the percentage of buffer busy
waits to logical reads.

Measurement
Threshold Template

OracleDB_
0022

N/A Monitors the total percentage of buffer
cache.

OracleDB_
0023

N/A Monitors the percentage of current buffer
cache.

OracleDB_
0024

N/A Monitors the percentage of enqueue waits
to enqueue requests.

OracleDB_
0026

N/A Monitors the percentage of cache in
dictionary cache.

OracleDB_
0027

N/A Monitors the percentage of library cache.

OracleDB_
0032

N/A Monitors the number of waits for redo log
space.

OracleDB_
0033

N/A Monitors the percentage of redo allocation
latch failures.

OracleDB_
0034

N/A Monitors the percentage of redo copy
latch failures.

OracleDB_
0035

N/A Monitors the rate of background
checkpoints completed.
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CI Type
Policy
Template

Roll Up or
Drill Down Policy Description Policy Type

OracleDB_
0045

N/A Monitors the percentage of free pool
memory.

OracleDB_
0083

N/A Monitors the rate of DatabaseWriter
(DBWR) checkpoints.

Basic Oracle Query Performance

This Aspect monitors the performance of Oracle queries by checking the Oracle metrics - Elapsed time and
CPU time. This is a basic type of aspect.

CI Type
Policy
Template

Roll Up or
Drill Down Policy Description Policy Type

Oracle OracleDB_
0106

Roll Up Monitors the SQL statements with high
elapsed time per execution.

Measurement
Threshold
Template

OracleDB_
0107

Roll Up Monitors the SQL statements with high
CPU time per execution.

OracleDB_
0108

Roll Up Monitors the SQL statements
performing full table scan.

OracleDB_
0119

N/A Monitors the number of heavy SQL
statements.

Basic Oracle Segment Space

This Aspect monitors the units of database storage - segments and extents. This is a basic type of aspect.

CI Type
Policy
Template

Roll Up or
Drill Down Policy Description Policy Type

Oracle OracleDB_
0016

Roll Up Monitors the segments that cannot
extend.

Measurement
Threshold
Template

OracleDB_
0215

N/A Monitors the segment size that is
allocated (in MB).

Oracle Archive Health

This Aspect monitors the Oracle device space, archive frequency rate, and redo logs that are not archived.
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CI
Type

Policy
Template

Roll Up or
Drill Down Description Policy Type

Oracle OracleDB_
0056

N/A Monitors the number of archive logs that
fit in archive device.

Measurement
Threshold Template

OracleDB_
0057

N/A Monitors the average time inminutes
between archive log writes.

OracleDB_
0058

N/A Monitors the percentage of free space on
archive device.

OracleDB_
0060

N/A Monitors the number of redo logs not
archived.

Oracle Database Availability

This Aspect monitors the Oracle database connection status, processes, and logons.

CI Type Policy Template Roll Up or Drill Down Description Policy Type

Oracle OracleDB_0001 N/A Monitors the
database status.

Measurement
Threshold
Template

OracleDB_0002 N/A Monitors the
database process
check.

OracleDB_0037 N/A Monitors the
number of logons.

ConfigFile
Template

OracleDB_0082 N/A Monitors the
maximum number
of sessions since
startup.

Measurement
Threshold
Template

OracleDB_0087 N/A Monitors the
percentage of
current processes
to be configured.

OracleDB_0201 N/A Reports uptime
information.

ConfigFile
Template

OracleDB_
ListenerStatus

N/A Checks and
monitors the
Oracle listener.

ConfigFile
Template

Oracle Database Availability (Agentless)

This Aspect monitors Oracle database connection status remotely.
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CI
Type Policy Template

Roll Up or Drill
Down Metric Policy Description Policy Type

Oracle Oracle Database
Availability

N/A Monitors Oracle database
availability.

Measurement
Threshold template

Oracle Discovery

This Aspect discovers the Oracle, RAC, and ASM instances.

CI Type Policy Template

Roll Up
or Drill
Down Description Policy Type

Computer
and
Oracle

OracleDB_
Discovery

N/A This policy discovers the instances
running on the nodes.

Service Auto-
Discovery
Template

OracleDB_
DeepDiscovery

N/A This policy discovers the databases,
tablespaces, datafiles, and services on
themanaged nodes. It is scheduled to
run once daily.

Scheduled Task

Oracle Database Response Time (Agentless)

This Aspect monitors Oracle database response time across network.

CI
Type Policy Template

Roll Up or Drill
Down Metric Policy Description Policy Type

Oracle Oracle Database
Response Time

N/A Monitors Oracle database
response time.

Measurement
Threshold template

Oracle Database Space Utilization

This Aspect monitors the Oracle dump device space, flash recovery area and the overall size of the
database.

CI Type
Policy
Template

Roll Up or
Drill Down Description Policy Type

Oracle OracleDB_
0062

N/A Monitors the percentage of
space used on background
dump device.

Measurement Threshold
Template

OracleDB_
0064

N/A Monitors the percentage of
space used on user dump
device.
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CI Type
Policy
Template

Roll Up or
Drill Down Description Policy Type

OracleDB_
0065

N/A Monitors the percentage of
space used on core dump
device.

OracleDB_
0066

N/A Monitors the size in MB of
alert log.

OracleDB_
0136

N/A Monitors the percentage of
disk space used by FRA.

OracleDB_
0212

N/A Monitors the instance size that
is allocated and the instance
size that is free.

Oracle IO Performance

This Aspect monitors the physical and logical read rate of Oracle instances.

CI
Type

Policy
Template

Roll Up or
Drill Down Description Policy Type

Oracle OracleDB_0086 N/A Monitors the number of physical reads
per minute.

Measurement
Threshold Template

OracleDB_0088 N/A Monitors the number of logical reads
per minute.

OracleDB_0213 N/A Monitors the number of physical reads
and writes to the disk since the last
collection for each tablespace.

ConfigFile Template

Oracle Object Faults

This Aspect monitors Oracle database objects like full table scan rate, index, triggers and so on.

CI
Type

Policy
Template Indicator Description Policy Type

Oracle OracleDB_
0004

NA Number of users default
tablespace set to SYSTEM
(E004_UsersTmpDfltCnt)

Measurement
Threshold

OracleDB_
0005

NA Number of foreign objects in
SYSTEM tblspc (E005_
ObjctsForignCnt)
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CI
Type

Policy
Template Indicator Description Policy Type

OracleDB_
0030

SQLQueryTuning:Low,
SQLQueryTuning:Normal

Rate at which full table scans
(long tables) occur (E030_
FulLgTblScnRate)

OracleDB_
0042

SQLQueryTuning:Low,
SQLQueryTuning:Normal

Percentage of never analyzed
tables and indexes (E042_
UnlyzTblIndxPct)

OracleDB_
0077

DatabaseObjectStatus:Invalid,
DatabaseObjectStatus:Valid

SYS.DUAL status (E077_
DualExssRowStat)

OracleDB_
0078

DatabaseObjectStatus:Invalid,
DatabaseObjectStatus:Valid

Number of invalid objects (E078_
ObjctsInvaldCnt)

OracleDB_
0079

NA Number of disabled triggers
(E079_DisbldTrigrsCnt)

OracleDB_
0080

NA Number of disabled constraints
(E080_DisbldCnstrtCnt)

Oracle Tablespace Health

This Aspect monitors the Oracle Table space status, free space, datafile status, and segments.

CI
Type

Policy
Template

Roll Up
or Drill
Down Description Policy Type

Oracle OracleDB_
0007

N/A Monitors the number of tablespaces that are
not online.

Measurement
Threshold
Template

OracleDB_
0008

N/A Monitors the number of tablespaces with high
ratio of block to physical reads.

OracleDB_
0009

N/A Monitors the number of tablespaces with high
use of temporary segments to total.

OracleDB_
0014

N/A Monitors the number of datafiles that are not
online.

OracleDB_
0210

N/A Monitors the tablespace. ConfigFile
Template

Oracle Transactions

This Aspect monitors the Oracle transactions percentage, commit rate, and open cursor.
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CI
Type

Policy
Template

Roll Up or
Drill Down Policy Description Policy Type

Oracle OracleDB_
0031

N/A Monitors the number of users with percentage of
open cursors tomaximum configured.

Measurement
Threshold
Template

OracleDB_
0084

N/A Monitors the long running transactions.

Oracle UDA

This Aspect monitors the user definedmetrics.

CI Type
Policy
Template

Roll Up or
Drill Down Description Policy Type

Oracle OracleDB_
07XX

N/A Monitors the user defined
metrics.

Measurement Threshold
Template

OracleDB_
UDM

N/A Sample template to create
UDM.

ConfigFile Template

Oraspi Base

TheOraspi Base Nested Aspect is used for monitoring Oracle databases. This Nested Aspect is used by all
the Basic and Advanced Aspects.

CI
Type

Policy
Template Policy Description

Policy
Type

Oracle OracleDB_
Messages

Interception of messages submitted by DB SPI programs. Open
Message
Interface

OracleDB_
Logger

Monitors the datalogger feed. Schedule
Task

OracleDB_
VeryHigh

By default, runs the collector every 5minutes. The schedule can be
modified as required in the environment.

OracleDB_
High

By default, runs the collector every 15minutes. The schedule can
bemodified as required in the environment.

OracleDB_
Medium

By default, runs the collector every 1 hour. The schedule can be
modified as required in the environment.

OracleDB_
Low

By default, runs the collector once in a day. The schedule can be
modified as required in the environment.

Oracle OracleDB_
AlertLog

Monitors the alert log file. LogFile
Entry
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CI
Type

Policy
Template Policy Description

Policy
Type

Oracle DB_
Configuration

This policy template contains the parameters (user id, password,
listener name) for establishing connection to the Oracle databases.

Config File
Template

List of Additional OOTB Aspects
OMi MP for Oracle Database provides additional out-of-the-box (OOTB) Aspects that are not part of any
Management Template. You can deploy the required Aspects directly. Additionally, you can add these
Aspects to the existingManagement Template and then deploy the latest version.

Oracle Advanced Replication

This Aspect monitors the errors and failures that occur in Oracle Advanced Replication Servers.

CI
Type

Policy
Template

Roll Up or Drill
Down Policy Description Policy Type

Oracle OracleDB_
0113

N/A Monitors the number of DBMS
jobs.

Measurement Threshold
Template

OracleDB_
0114

N/A Monitors the number of failed
DBMS jobs.

OracleDB_
0115

N/A Monitors the number of deferred
transactions.

OracleDB_
0116

N/A Monitors the number of error
transactions.

OracleDB_
0117

N/A Monitors the number of failed
admin requests.

OracleDB_
0118

N/A Monitors the number of failed
material views.

Oracle ASMHealth

This Aspect monitors the Oracle ASM disk group status and disk group free space. This Aspect or the
customizedManagement Templatemust be deployed on ASMCIs. While deploying, youmust make sure to
edit theOracle Instance Name in theParameter Summary tab. TheOracle ASM Instance parameter is
dependent on various parameters such as Oracle ASMMonitor Frequency, Oracle ASM Instance, and
others. Youmust make sure theOracle ASM Instance parameter is set toYes.
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CI
Type

Policy
Template

Roll Up or Drill
Down Policy Description Policy Type

Oracle OracleDB_
0133

N/A Monitors the number of non-
mounted diskgroups.

Measurement Threshold
Template

OracleDB_
0334

N/A Monitors the disk groups with low
free space.

Tomonitor tablespace in ASM environment, you can addOracle Tablespace Health (Add-on) andOracle
Segment Space (Add-on) Aspects. For more information about the drill-down policies for these Aspects, see
the section "Oracle Roll-Up and Drill-Down Policies".

Oracle DataGuard Faults

This Aspect monitors the gaps and failures that occur in Oracle DataGuard servers. This Aspect or
customizedManagement Templatemust be deployed on primary and standby nodes.

CI
Type Policy Template

Roll Up or Drill
Down Description Policy Type

Oracle OracleDB_0126 N/A Monitors the
duration (in hrs) for
which the archived
files are not sent to
the standby
databases.

Measurement Threshold
Template

OracleDB_0127 N/A Monitors the number
of dataguard
destinations that are
getting errors or are
in an invalid state.

Oracle OracleDB_0128 N/A Monitors the number
of hours the log files
are not applied to the
standby databases.

OracleDB_0129 N/A Monitors the number
of hours the last sql
query was
processed on the
logical standby
databases.

OracleDB_0130 N/A Monitors the latest
time stamp in the
redo was received
on the logical
standby databases.
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CI
Type Policy Template

Roll Up or Drill
Down Description Policy Type

OracleDB_0137 N/A Monitors the fast-
start failovers that
occurred.

Oracle RAC Health

TheOracle Real Application Cluster (RAC) Aspect monitors the status and performance of Oracle Real
Application Clusters. This Aspect or customizedManagement Template should not be deployed to virtual
Oracle RAC Database name. Aspects or customizedManagement Templatemust be deployed only to the
actual Oracle instances on the node.

CI
Type

Policy
Template

Roll Up or
Drill Down Description Policy Type

Oracle OracleDB_
0121

N/A Monitors the number of blocks that
encounter a failure during interconnect.

Measurement
Threshold
Template

OracleDB_
0122

N/A Monitors the number of blocks that get lost
during interconnect.

OracleDB_
0123

N/A Monitors the average waiting time for
consistent read per block.

OracleDB_
0131

N/A Monitors the number of blocks that are
received during interconnect.

Oracle OracleDB_
0132

N/A Monitors the datafiles of cluster databases
with highest sum of rate of transfer for
consistent read blocks as well as current
blocks.

OracleDB_
0146

N/A Monitors the CRS NodeApps Virtual IP
status.

OracleDB_
0147

N/A Monitors the CRS NodeApps Listener
status.

OracleDB_
0148

N/A Monitors the CRS NodeApps Global
Service Daemon status.

OracleDB_
0149

N/A Monitors CRS NodeApps Oracle
Notification Service status.

OracleDB_
0150

N/A Monitors Oracle RAC VIP Relocation of a
node.

Oracle CRS
Alert Log
Template

N/A Monitors the Oracle CRS Alert Log file. LogFile Entry
Template
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Oracle Locks & Latches (Add-on)

Monitors Oracle locks latch, disabled table locks and so on.

CI
Type

Policy
Template Indicator Description Policy Type

Oracle OracleDB_
0038

LatchContentionRatio:High,
LatchContentionRatio:Normal

Number of latches with high
contention ratio > threshold (E038_
LtchOvrLimitCnt)

Measurement
Threshold

OracleDB_
0097

NA Number of tables with table locks
disabled (E097_DisbldTblLckNum)

Oracle Memory Performance (Add-on)

Monitors Oracle Memory units BufferCache, Shared Pool, Library Cache and so on.

CI
Type

Policy
Template Indicator Description Policy Type

Oracle OracleDB_
0040

LibraryCacheFunctioning:LowPinHits,
LibraryCacheFunctioning:Normal

Monitors the percentage of
pinhits to pins in dictionary
cache (E040_
LibCacPinHitPct).

Measurement
Threshold

OracleDB_
0020

MemorySortRate:Low,
MemorySortRate:Normal

Monitors the percentage of
memory sorts (E020_
SortMemoryPct).

OracleDB_
0051

NA Average number of rows
per sort.

ConfigFile
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CI
Type

Policy
Template Indicator Description Policy Type

OracleDB_
0039

LibraryCacheFunctioning:LowGetHits,
LibraryCacheFunctioning:Normal

Monitors the percentage of
gethits to gets in dictionary
cache (E039_
LibCacGetHitPct).

Measurement
Threshold

OracleDB_
0059

NA Monitors the percentage of
cursors in cache
parameter (E059_
CursorCachePct).

Oracle OracleDB_
0075

DBCallRate:High,
DBCallRate:Normal

Ratio of recursive calls to
cumulative opened
cursors (E075_
RcrsvCursrRatio).

OracleDB_
0019

MemorySortRate:Low,
MemorySortRate:Normal

Monitors the rate at which
the disk is sorted. (E019_
SortDiskRate).

OracleDB_
0052

TotalSortRate:High,
TotalSortRate:Normal

Monitors the rate of total
sorts on disk and in
memory. (E052_
SortTotalRate).

Oracle Object Faults (Add-on)

Monitors Oracle database objects like table, index, triggers and so on.

CI
Type

Policy
Template Indicator Description Policy Type

Oracle OracleDB_
0047

NA Monitors the number of tables that are
cached.

ConfigFile

OracleDB_
0046

SQLQueryTuning:Low,
SQLQueryTuning:Normal

Monitors the percentage of rows
fetched by index (E046_
RowFetcbyIdxPct).

Measurement
Threshold

OracleDB_
0048

SQLQueryTuning:Low,
SQLQueryTuning:Normal

Monitors the percentage of chained
rows fetched (E048_
ChandRowFtchPct).

OracleDB_
0041

NA Monitors the rate at which full table
scans (short tables) occur.

ConfigFile

OracleDB_
0081

NA Monitors the number of snapshot errors
(E081_SnapshotErrCnt).

Measurement
Threshold
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Oracle Query Performance (Add-on)

Monitors Oracle Query Performance like Disk reads, SQL fetches and so on.

CI
Type

Policy
Template Indicator Description Policy Type

Oracle OracleDB_
0103

LongTableScansPct:High,
LongTableScansPct:Normal

Monitors the SQL statements
with long table scans (E103_
SQLScanRowsMax).

Measurement
Threshold

OracleDB_
0105

NA Monitors the number of SQL
statement with high buffer gets
per execution (E105_
BufferGetsPerExecRatio).

Measurement
Threshold

OracleDB_
0102

NA Monitors the SQL statements
with high fetches (E102_
SQLFetchesMax).

Measurement
Threshold

OracleDB_
0104

NA Monitors the SQL statements
with high execution rate (E104_
SQLExecRateMax).

Measurement
Threshold

OracleDB_
0101

SQLDiskReadWriteRate:High,
SQLDiskReadWriteRate:Normal

Monitors the number of SQL
statement with high disk reads
per execution (E101_
DiskReadsPerExecRatio).

Measurement
Threshold

Oracle Segment Space (Add-on)

Monitors Oracle Segment maximum extents and so on.

CI
Type

Policy
Template Indicator Description Policy Type

Oracle OracleDB_
0017

DatabaseSegmentUsageLevel:High,
DatabaseSegmentUsageLevel:Normal

Monitors the number of
segments approaching
maximum extent (E017_
SegMaxExtentCnt).

Measurement
Threshold

OracleDB_
0018

NA Monitors the number of
segments adding extents
rapidly (E018_
SegExtRapidCnt).

Measurement
Threshold

Oracle Tablespace Health (Add-on)

Monitors Oracle Tablespace freespace count, fragment count and size.
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CI
Type

Policy
Template Indicator Description Policy Type

Oracle OracleDB_
0006

TablespaceUsageLevel:High,
TablespaceUsageLevel:Normal

Monitors the number of table
spaces with low free space
percentage (E006_
TblSpFreePctCnt).

Measurement
Threshold

OracleDB_
0011

TablespaceFSFI:High,
TablespaceFSFI:Normal

Monitors the number of
fragmented tablespaces (E011_
TblSpcFrgmntCnt).

OracleDB_
0003

NA Monitors the number of table
spaces with low free extents
(E003_TblSpaceFreeCnt).

Oracle Transactions (Add-on)

Monitors Oracle transactions percentage, commit rate, roll back rate, and so on.

CI
Type

Policy
Template Indicator Description Policy Type

Oracle OracleDB_
0054

NA Monitors the rate at which
rollbacks are being generated
(E054_RollbackRate).

Measurement
Threshold

OracleDB_
0044

NA Monitors the number of
transactions.

ConfigFile

OracleDB_
0049

NA Monitors the rate of user calls.

OracleDB_
0085

ServerTransactionRate:High,
ServerTransactionRate:Normal

Monitors the percentage of
current transactions to configured
(E085_TransactionPct).

Measurement
Threshold

OracleDB_
0050

DBCallRate:High,
DBCallRate:Normal

Monitors the ratio of recursive
calls to user calls (E050_
RcsvUsrCalRatio).

Oracle Parallel Query Performance

TheOracle Parallel Query Aspect monitors the Oracle parallel query rate and busy percentage.

CI
Type

Policy
Template

Roll Up or
Drill Down Description Policy Type

Oracle OracleDB_
0070

N/A Monitors the percentage of parallel query servers
that are busy.

Measurement
Threshold
Template
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CI
Type

Policy
Template

Roll Up or
Drill Down Description Policy Type

OracleDB_
0071

N/A Monitors the percentage of parallel query servers
busy with high watermark.

Oracle OracleDB_
0074

N/A Monitors the rate of parallel queries initiated.

OracleDB_
0076

N/A Monitors the percentage of full table scans
through row id range compared to total table
scan.

Oracle Sessions Performance

TheOracle Sessions Aspect monitors the Oracle Sessions performance.

CI Type
Policy
Template

Roll Up or Drill
Down Description Policy Type

Oracle OracleDB_0109 Roll Up Monitors the sessions
with high number of hard
parses.

Measurement
Threshold Template

OracleDB_0110 Roll Up Monitors the sessions
with high free buffer wait.

OracleDB_0111 Roll Up Monitors the sessions
with high latch free wait.

OracleDB_0112 Roll Up Monitors the sessions
with high suspended
time.

OracleDB_0309 Drill Down Monitors the sessions
with hard number of
parses.

OracleDB_0310 Drill Down Monitors sessions with
high free buffer wait.

OracleDB_0311 Drill Down Monitors sessions with
high free latch wait.

OracleDB_0312 Drill Down Monitors sessions with
high suspended time.

Oracle Shared Server Performance

This Aspect monitors the Oracle shared server percentage and dispatcher busy percentage.
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CI
Type

Policy
Template

Roll Up or
Drill Down Description Policy Type

Oracle OracleDB_
0090

N/A Monitors the percentage busy for all
dispatchers.

Measurement
Threshold Template

OracleDB_
0091

N/A Monitors the percentage of clients currently
connected to all dispatchers.

OracleDB_
0092

N/A Monitors the percentage of shared servers
waiting for requests.

OracleDB_
0095

N/A Monitors themaximum percentage of shared
pool allocated to UGA.

OracleDB_
0096

N/A Monitors the percentage of high water to
maximum shared server processes.

Oracle Streams

This Aspect monitors Oracle Stream pool size and errors.

CI Type
Policy
Template

Roll Up or
Drill Down Description Policy Type

Oracle OracleDB_
0140

N/A Reports the estimated
optimum size proposed for
Oracle streams pool.

Measurement
Threshold Template

OracleDB_
0141

N/A Monitors the capture
processes having errors in an
Oracle streams environment.

OracleDB_
0142

N/A Monitors propagation errors in
anOracle streams
environment.

OracleDB_
0143

N/A Monitors the apply processes
having errors in anOracle
streams environment.

Oracle OracleDB_
0144

N/A Monitors the general apply
errors in anOracle streams
environment.

OracleDB_
0145

N/A Monitors the number of
messages that are captured to
apply latency higher than the
specified threshold in Oracle
streams environment.
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Policy Template Group
All the Oracle policy templates are available under theOracle Database MP template group.

How to View Policy Template Group

1. Open the Policy Template Groups pane:
On BSM 9.2x, click Admin > Operations Management > Monitoring > Policy Templates.
OnOMi 10.x, click Administration > Monitoring > Policy Templates.

2. In the Policy Template Groups pane, expand Template Groups and click theOracle Database MP.

Grouping of Policy Templates
Grouping of Policy Templates

Following is the list of policy templates of OMi MP for Oracle Database.

Template Category Policy Template

ConfigFile OracleDB_0037

OracleDB_0041

OracleDB_0044

ConfigFile OracleDB_0047

OracleDB_0049

OracleDB_0051

OracleDB_0201

ConfigFile OracleDB_0210

OracleDB_0212

OracleDB_0213

OracleDB_0215

OracleDB_Configuration

OracleDB_ListnerStatus

OracleDB_UDM

LogFile Entry OracleDB_AlertLog

OracleDB_CRSAlertLog
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Template Category Policy Template

Measurement Threshold OracleDB_0001 to OracleDB_0009

OracleDB_0011

OracleDB_0014

OracleDB_0016 to OracleDB_0024

OracleDB_0026 to OracleDB_0035

OracleDB_0038 to OracleDB_0043

OracleDB_0045

OracleDB_0046

OracleDB_0048

Measurement Threshold OracleDB_0050

OracleDB_0052

OracleDB_0054 to OracleDB_0060

OracleDB_0062

OracleDB_0064 to OracleDB_0066

OracleDB_0070

OracleDB_0071

OracleDB_0074 - OracleDB_0088

OracleDB_0090 to OracleDB_0097

OracleDB_0101 to OracleDB_0119

OracleDB_0121 to OracleDB_0123

OracleDB_0126 to OracleDB_0133

OracleDB_0136

OracleDB_0137

OracleDB_0140 to OracleDB_0150
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Template Category Policy Template

Measurement Threshold OracleDB_0203

OracleDB_0206

OracleDB_0216 to OracleDB_0218

OracleDB_0301 to OracleDB_0312

OracleDB_0334

OracleDB_07XX

OpenMessage Interface OracleDB_Messages

Scheduled Task OracleDB_DeepDiscovery

OracleDB_High

OracleDB_Logger

OracleDB_Low

OracleDB_Medium

OracleDB_VeryHigh

SiteScope Oracle Database Availability

Oracle Database Response Time

Parameters
Parameters are variables that are an integral component of Oracle Management Templates, Oracle Aspects,
and Policy Templates. Each parameter corresponds to a variable. Parameters contain default values that are
used for monitoring the different components of Oracle databases. You can alsomodify the values of the
variables to suit your monitoring requirements.

Types of Parameters
The parameters are grouped as follows:

l Instance Parameters - These parameters are essential for monitoring Oracle CIs. For example, Oracle
instance name is an Instance Parameter.

l Mandatory Parameters - These parameters contain the essential information required by policy
templates. For example, Oracle instance name is amandatory parameter.

l Dependent Parameters - There are some parameters which are a subset of themandatory parameters.
Such parameters are referred to as dependent parameters. For example, Oracle username is a dependent
parameter of Oracle instance name.

l Expert Parameters - These parameters can be used by SMEs and Administrators.
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OMi MP for Oracle Database Parameters
OMi MP for Oracle Database contains the following parameters:

Parameter Parameter Type Description
Default
Values

Oracle Instance Name Mandatory Oracle Instance Name that
should bemonitored.

CI Name

Oracle Instance User
Name

Dependent Oracle User Namewith the
required privileges to collect
data.

Oracle Instance Password Dependent Password for Oracle User
Name.

Filter Expert Filter themonitored components.
For example, Oracle Segment
Filter parameter filters the
segments for monitoring.

Oracle Instance Collection Expert Turn on or off collection for
Oracle Instance.

ON

Oracle Instance Tracing Expert Enable Tracing on or off for trace
to be captured on node at
%ovdatadir%/dbspi/log/trace
.

OFF

Frequency of High
Scheduler

Expert Frequency for the scheduler
which is expected to run for high
intervals (in minutes).

15

Frequency of Low
Scheduler

Expert Frequency for the scheduler
which is expected to run for short
intervals (in hours).

24

Frequency of Medium
Scheduler

Expert Frequency for the scheduler
which is expected to run for
medium intervals (in hours).

1

Frequency of Very High
Scheduler

Expert Frequency for the scheduler
which is expected to run for very
high intervals (in minutes).

5

Frequency Mandatory Frequency of monitoring by a
policy template. For example,
the frequency of monitoring
Oracle Database availability.
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Parameter Parameter Type Description
Default
Values

Threshold Mandatory Threshold of a policy template.
For example, the threshold of
monitoring available database
nodes.

Severity Mandatory Severity level of a policy
template. For example, the
severity of monitoring critical
database nodes count.

Tuning Parameters
You can edit the parameters of the Oracle Management Templates andOracle Aspects that are already
deployed to the CIs.

1. Open Assignments & Tuning pane:
On BSM 9.2x, click Admin > Operations Management > Monitoring > Assignments & Tuning.
OnOMi 10.x, click Administration > Monitoring > Assignments & Tuning.

2. In theBrowse Views tab, select theOracle_Database_Deployment view that contains the CI for
which you want to tune parameters. Alternatively, you can use the Search tab to find a CI.

3. In the list of Oracle CIs, click a CI. The Assignments pane shows details of any existing assignments
for the Oracle CI.

4. Click the assignment for which you want to tune parameters. The Assignment Details pane shows the
current parameter values.

5. In the Assignment Details pane, change the parameters:
a. (Optional). By default, the list shows only mandatory parameters.

b. Select a parameter in the list, and then click .
n For standard parameters, the Edit Parameter dialog box opens.

Click Value, specify the value, and then click OK.
n For instance parameters, the Edit Instance Parameter dialog box opens.

Change the instance values if necessary, and then for each instance value, change dependent
parameter values. After you change the instances and dependent parameter values, click OK.

6. In the Assignment Details pane, click Save Changes. Operations Console deploys the new parameter
values to the relevant HP Operation Agents.

Configuration Items (CIs) and Configuration Item
Types (CITs)
CIs are components that have to bemanaged in order to deliver an IT Service. CIs typically include IT
Services, hardware, and software.
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CIT describes the type of a CI and its attributes. TheOracle CIs that are discovered in an environment are
grouped under the CITs. OMi MP for Oracle Database comprises the following CITs:

l Oracle
l Oracle RAC
l Oracle Tablespace
l Oracle Data File

Run-time Service Model (RTSM) Views
A View enables you to build and visualize a subset of the overall CI model that comprises Oracle CITs related
to specific area of interest.

How to Access RTSM Views

1. OpenModeling Studio pane:
On BSM 9.2x, click Admin > RTSM Administration > Modeling > Modeling Studio.
OnOMi 10.x, click Administration > RTSM Administration > Modeling > Modeling Studio.

2. Click Resource Type as Views.
3. Click Database > Oracle from the list.

By default, OMi MP for Oracle Database includes the following Views:

l ORA_Deployment: This view refers to the Oracle, Oracle RAC, Computer, and File System CITs. The
following image shows the relationship among the CITs.

l ORA_Network_Deployment: This view refers to the Oracle, Oracle RAC, Node, Interface, and File
System CITs. The following image shows the relationship among the CITs.
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l Oracle_Database_Deployment: This view refers to the Oracle, Oracle RAC, Node, Interface, File
System, Service, Tablespace, and Data File CITs. The following image shows the relationship among the
CITs.
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Event Type Indicators (ETIs)
ETIs are categorization of events based on the type of occurrence. TheOMi MP for Oracle Database
includes the following ETIs tomonitor Oracle-related events:

How to Access the Event Type Indicators

1. Open Indicators pane:
On BSM 9.2x, click Admin > Operations Management > Monitoring > Indicators.
OnOMi 10.x, click Administration > Service Health > Health- and Event Type Indicators.

2. In the CI Type pane, click InfrastructureElement > RunningSoftware > Database > Oracle.
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CI Type ETI Description Value

Oracle Archive Status Indicates the status of an Oracle Archive Log. Normal

Checkpoint Rate Indicates high checkpoint rate. Normal

Control File
ReadWrite Status

Indicates Oracle control file read or write errors. Normal

Flash Recovery
Errors

Indicates the errors related to flash recovery in anOracle
Instance.

Normal

Heavy SQL
Statements

Indicates the number of heavy SQL statements in an
Oracle Instance.

Normal

Latch Contention
Ratio

Indicates possible latching problems. Normal

Latch Hit Ratio Indicates possible latching problems. Normal,
High

Locks Usage Level Indicates the ratio of locks used in anOracle database
Instance.

Normal,
High

Materialized View
Errors

Indicates the errors related tomaterialized views in an
Oracle database instance.

Normal

Memory Sort Rate Indicates the ratio of whichmemory sorts have been
performed. A low memory sort ratio implies a high disk
sort ratio.

Normal

Oracle Database
Process Status

Indicates Oracle database service/process status. Running

Oracle Disk
ReadWrite Errors

Indicates Oracle disk read write errors. Normal

Oracle Session Count Indicates Oracle session count to be configured. Normal

Streams Errors Indicates the errors in anOracle streams environment. Normal

Database SQLQuery Tuning Indicates SQL statements with low query tuning. Normal

Oracle Tablespaces Free
Space Fragmentation
Index

Indicates the fragmented tablespaces in anOracle
database Instance.

Normal,
Moderate,
High

Total Sort Rate Indicates the total sorts on disk and inmemory in an
Oracle database Instance.

Normal

The CITs from HPOM that aremapped to RTSM (Run-time ServiceModel) using the OMi MP for Oracle
Database areOracle andOracle RAC.
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Health Indicators (HIs)
HIs analyze the events that occur in Oracle CIs and report the health of the Oracle CIs. TheOMi MP for
Oracle Database includes the following HIs tomonitor the Oracle-related events:

How to Access the Health Indicators

1. Open Indicators pane:
On BSM 9.2x, click Admin > Operations Management > Monitoring > Indicators.
OnOMi 10.x, click Administration > Service Health > Health- and Event Type Indicators.

2. In the CI Type pane, click InfrastructureElement > RunningSoftware > Database > Oracle.

CI Type HI Description Value

Database CPU Usage by
SQL

Indicates SQL statements with high CPU time per
execution.

High
Normal

Server Transaction
Rate

Indicates the rate of transactions for the entire database
server.

High
Normal

SQLQuery Tuning Indicates SQL statements with low query tuning. Low
Normal

Oracle DatabaseObject
Status

Indicates database object status. Invalid
Valid
Enabled
Disabled

Database Segment
Status

Indicates the status of segments in anOracle database
instance.

Normal
Inextensible

Database Segment
Usage Level

Indicates the usage of segments in anOracle database
Instance.

High
Normal

Database Database Server
Status

Indicates database server availability. Up
Down

Oracle Datafiles Status Indicates Oracle datafiles status. Online
Offline

Default Bufferpool
Busy Ratio

Indicates the ratio of buffered data requests of the Oracle
default buffer pool.

High
Low

Default Bufferpool
Hit Ratio

Indicates the ratio of buffered data requests of the Oracle
default buffer pool.

High
Normal
Low

Oracle Dictionary Cache
Miss Ratio

Indicates the effectiveness of the Oracle dictionary
cache.

High
Normal
Low
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CI Type HI Description Value

Dispatcher Busy
Ratio by Network

Indicates the workload of the Oracle dispatcher. High
Normal
Low

Dispatcher
Process Queue
Response Time

Indicates the average time an item in the Oracle
dispatcher queue waits before being processed.

High
Low

Oracle Flash Recovery
Area Usage Level

Indicates the availability of an Oracle instance as affected
by the percentage of space used by Flash Recovery
Area.

High
Medium
Normal

Library Cache
Functioning

Indicates the performance of anOracle database instance
as affected by:

1 - library cachemisses to executions

2 - library cache get hits to gets

3 - library cache pin hits to pins

HighReload
LowGetHits
LowPinHits
Normal

Logical Read Rate Indicates the performance of anOracle instance as
affected by the number of logical reads per min.

High
Normal

Long Table Scans
Percentage

Indicates the percentage of long table scans that are
performed.

High
Normal
Low

Oracle Background
DumpDevice
Usage Level

Indicates Oracle background dump device space usage. High
Normal
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CI Type HI Description Value

Oracle Oracle Core Dump
Device Usage
Level

Indicates Oracle core dump device space usage. High
Normal

Oracle Opened
Cursor Current

Indicates the Oracle current opened cursor. High
Normal

Oracle Parse Count
(Hard)

Indicates the hard parses during the sample period. High
Normal

Oracle Parse Count
(Failures)

Indicates the Oracle parse failures. High
Normal

Oracle Session
Connect Time

Indicates the connect time for the Oracle session. High
Normal

Oracle User Dump
Device Usage
Level

Indicates Oracle user dump device space usage. High
Normal

Oracle Users Call
Rate

Indicates rate of recursive calls to user calls and rate of
recursive calls to cumulative opened cursors.

High
Normal

Physical Read
Rate

Indicates the performance of anOracle instance as
affected by the number of physical reads per min.

High
Normal

Row Cache Hit
Ratio

Indicates the ratio of which row data requests could be
served from the cache.

High
Low

Database Replication Status Indicates database server replication status. Broken
Failed
Up

Server Transaction
Rate

Indicates the rate of transactions for the entire database
server.

High
Normal

Oracle Shared Pool
Memory

Indicates the performance of anOracle database instance
as affected by the free space in shared pool memory.

Low
Normal

SQLDisk
ReadWrite Rate

Indicates SQL statement with high disk read-write per
execution.

High
Normal

Database SQLQuery
Performance

Indicates SQL statements with high elapsed time per
execution.

Low
Normal
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CI Type HI Description Value

Oracle Streams Apply
Status

Indicates the performance of anOracle instance affected
by apply processes having errors in anOracle streams
environment.

Disabled
Aborted
Normal

Streams Capture
Status

Indicates the performance of anOracle instance affected
by capture processes having errors in an oracle streams
environment.

Disabled
Aborted
Normal

Streams
Propagation Status

Indicates the performance of anOracle instance affected
by propagation processes having errors in anOracle
streams environment.

Disabled
Aborted
Normal

Tablespace Temp
Segment Usage

Indicates the high use of temporary segments that are
allocated to tablespaces in anOracle database instance.

High
Normal

Tablespaces
Availability

Indicates the availability of DB Tablespaces in a Oracle
database instance.

Online
Offline

Tablespace
Physical Read
Ratio

Indicates the ratio of block to physical reads of
tablespaces in anOracle database instance.

High
Normal

Tablespace Usage
Level

Indicates the usage of tablespaces in anOracle database
instance.

High
Moderate
Normal

Wait Locked
Sessions

Indicates the performance of anOracle database instance
as affected by the number of sessions held by locks.

High
Normal

Waits OnRedo Log
Space

Indicates the performance of anOracle database
Instance as affected by the number of waits for redo log
space.

High
Normal

Topology Based Event Correlation (TBEC) Rules
TheOMi MP for Oracle Database includes the following rules to correlate Oracle-related events:

For more information on how the correlation rules work, see theHPE Operations Manager i Concepts Guide.

How to Access the Correlation Rules

l OpenCorrelation Rules pane:
On BSM 9.2x, click Admin > Operations Management > Event Correlation > Topology-Based Event
Correlation.
OnOMi 10.x, click Administration > Event Processing > Correlation > Topology-Based Event
Correlation.
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Database::FileSystem:Disk Usage Level >> Oracle Device Usage Level HIs
Description: Filesystem usage level impacts Oracle Space Usage (Background, User and Core
dump device free space)

Cause

CIT: File system ETI: Disk Usage Level Value: Near Capacity

Symptom 1

CIT: Oracle ETI: Oracle Background DumpDevice
Usage Level

Value: High

Symptom 2

CIT: Oracle ETI: Oracle Core DumpDevice Usage
Level

Value: High

Symptom 3

CIT: Oracle ETI: Oracle User DumpDevice Usage
Level

Value: High

Database::Computer:Memory Usage Level >> Oracle Performance HIs
Description: Memory Usage Impacts Oracle Performance

Cause

CIT: Computer ETI: Memory Usage Level Value: Near Capacity/Much Higher Than Normal

Symptom 1

CIT: Oracle ETI: Dictionary CacheMiss Ratio Value: High

Symptom 2

CIT: Oracle ETI: Library Cache Functioning Value: HighReload, LowGetHits,
LowPinHits

Symptom 3

CIT: Oracle ETI: Memory Sort Rate Value: Low

Symptom 4

CIT: Oracle ETI: SQLQuery Performance Value: Low

Database::FileSystem: Oracle Tablespace Usage Level >> Disk Usage Level
Description: Correlates High Disk Space Usage by Db Tablespace to Near Capacity Disk Usage
Level of FileSystem

Cause

CIT: Oracle ETI: Tablespace Usage Level Value: High
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Description: Correlates High Disk Space Usage by Db Tablespace to Near Capacity Disk Usage
Level of FileSystem

Symptom

CIT: File System ETI: Disk Usage Level Value: Near Capacity

Database::FileSystem:Oracle Tablespace Temp Segment Usage Level >> Disk Usage Level
Description: Correlates High Disk Space Usage by Db Tablespace Temp Usage to Near Capacity
Disk Usage Level of FileSystem

Cause

CIT: Oracle ETI: Tablespace Temp Segment
Usage

Value: High

Symptom

CIT: File System ETI: Disk Usage Level Value: Near Capacity

Database::Computer:Oracle CPU Usage by SQL >> CPU Load
Description: CPU usage by Oracle SQL query and Heavy SQL statements increase CPU Load on
Computer

Cause

CIT: Oracle ETI: CPU Usage by SQL Value: High

Symptom

CIT: Computer ETI: CPU Load Value: Bottlenecked,
Constrained,
Busy,
Overloaded

Database::Computer:Oracle Heavy SQL Statement >> CPU Load
Description: Oracle Heavy SQL statements increase CPU Load on Computer

Cause

CIT: Oracle ETI: Heavy SQL Statements Value: High

Symptom

CIT: Computer ETI: CPU Load Value: Bottlenecked,
Constrained,
Busy,
Overloaded

Database::Computer:Node Status >> Oracle Database Server Status
Description: Correlates Unavailability of node to that of Database

Cause
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Description: Correlates Unavailability of node to that of Database

CIT: Computer ETI: Node Status Value: Down,
Unknown,
Suspended,
Hang

Symptom

CIT: Oracle ETI: Database Server Status Value: Down

Database::Computer:Ping Availability >> Oracle Database Server Status
Description: Correlates Unavailability of node to that of Database

Cause

CIT: Computer ETI: Ping Availability Value: Unavailable

Symptom

CIT: Oracle ETI: Database Server Status Value: Down

Database::Interface:InterfaceCommunicationStatus >> Oracle Database Broken Jobs
Description: Correlates Interface Communication Status of node to Oracle Database Broken Jobs

Cause

CIT: Interface ETI: Interface Communication
Status

Value: Unavailable

Symptom

CIT: Oracle ETI: Replication Status Value: Broken

Database::Interface:InterfaceCommunicationStatus >> Oracle Database Failed Jobs
Description: Correlates Interface Communication Status of node to Oracle Database Failed Jobs

Cause

CIT: Interface ETI: Interface Communication
Status

Value: Unavailable

Symptom

CIT: Oracle ETI: Replication Status Value: Failed

Database::Interface:InterfaceCommunicationStatus >> Oracle Database Stream Propagation Error
Description: Correlates Interface Communication Status of node to Oracle Database Stream
Propagation Error

Cause
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Description: Correlates Interface Communication Status of node to Oracle Database Stream
Propagation Error

CIT: Interface ETI: Interface Communication
Status

Value: Unavailable

Symptom 1

CIT: Oracle ETI: Streams Propagation Status Value: Aborted

Symptom 2

CIT: Oracle ETI: Streams Propagation Status Value: Disabled

Database::Interface:InterfaceUtilization >> Oracle Database Replication Status
Description: Correlates Interface Utilization of node to Oracle Database Replication and SQL
Query Performance Health

Cause

CIT: Interface ETI: Interface Utilization Value: High,
Higher Than Normal,
Much Higher Than Normal

Symptom 1

CIT: Oracle ETI: Replication Status Value: Broken,
Failed

Symptom 2

CIT: Oracle ETI: Dispatcher Busy Ratio by
Network

Value: High

Symptom 3

CIT: Oracle ETI: SQLQuery Performance Value: Low

Database::Interface:InterfaceUtilization >> Oracle Database SQL Query Performance
Description: Correlates Interface Utilization of node to Oracle Database SQL Query Performance

Cause

CIT: Interface ETI: Interface Utilization Value: High
Much Higher Than Normal

Symptom

CIT: Oracle ETI: SQLQuery Performance Value: Low

Generic::Computer:Memory Usage Level>> Database Performance HIs
Description: Memory Usage impacts Database Performance

Cause
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Description: Memory Usage impacts Database Performance

CIT: Computer ETI: Memory Usage Level Value: Critical,
Higher Than Normal,
Much Higher Than Normal,
Near Capacity

Symptom

CIT: Database ETI: SQLQuery Performance Value: Low

Generic::Interface:InterfaceCommunicationStatus >> Database Job Status
Description: Correlates Interface Communication Status of node to Database Job Status

Cause

CIT: Interface ETI: Interface Communication Status Value: Unavailable

Symptom

CIT: Database ETI: Replication Status Value: Failed,
Broken

Generic::Interface:InterfaceUtilization >> Database Replication and Query Performance Status
Description: Correlates Interface Utilization of node to Database Replication and Query
Performance Health

Cause

CIT: Interface ETI: Interface Utilization Value: High,
Much Higher Than Normal,
Higher Than Normal

Symptom 1

CIT: Database ETI: SQLQuery Performance Value: Low

Symptom 2

CIT: Database ETI: Replication Status Value: Broken,
Failed

Generic::Node:Node Status >> Database Server Status
Description: Correlates unavailability of node to that of Database

Cause

CIT: Node ETI: Node Status Value: Unknown,
Suspended,
Hang,
Down,
Maintenance
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Description: Correlates unavailability of node to that of Database

Symptom

CIT: Database ETI: Database Server Status Value: Down

Generic::Node:Ping Availability >> Database Server Status
Description: Correlates ping unavailability of node to that of Database

Cause

CIT: Node ETI: Ping Availability Value: Unavailable

Symptom

CIT: Database ETI: Database Server Status Value: Down

Operations Orchestration (OO) Flows
HP Operations Orchestration provides OO flows that enable IT process automation and run book automation.
For more information, see theOperations Orchestration documentation. The following section provides
information about using OO flows for OMi MP for Oracle Database.

When creating themapping for the Operations Orchestration (OO) flows, you can set default values for the
attributes listed in the following table. You need not specify these values each time you run the flows.

Attribute Description

omServerPort Port number of the HPOM Tool WS.

omServerUser User name for the HPOM Server that will be used in the HPOM Tool WS.

omServerPassword Password for the HPOM Server that will be used in the HPOM Tool WS.

How to upload OO flows

To uploadOOFlows from OMi MP for Oracle Database, follow these steps:

1. In BSM or OMi, go to the directory:

<HPBSM_Root_Directory>/conf/opr/oo

2. Copy the required OO JAR file to a temporary location on a system where HP OOStudio (version
07.51.02 or greater) is installed.
The file names can be one of the following:
HPOprOO<content_name>.jar
For HP OOStudio version 09.00:
o HPOprOOOra90.jar for Oracle

For HP OOStudio version 07.51.02 to 07.60:
o HPOprOOOra.jar for Oracle

To install and upload the OO flows run the command:
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java -jar -Xmx1024m "<temp>/HPOprOO<content_name>" -centralPassword
<centralpassword>

For example:

java -jar -Xmx1024m "<temp>/HPOprOOOra90" -centralPassword <centralpassword>

Note: If the admin user in HP OO is not the default user, another parameter is required. For further
details about installing content and the options available, see theHP Operations Orchestration
Software Development Kit Guide.

Using HP OOStudio, the uploadedOO flows can be accessed under:
../Library/Operations Management/..

3. From OMi, complete themapping of OO flows to CIs andmap theOO flow input variables to CI
attributes using:
On BSM 9.2x, click Admin > Integration > Operations Orchestration.
OnOMi 10.x, click Administration > Operations Console > Run Books Mapping.

The following section lists the Oracle OO flows:

Oracle Health Check

You can use this flow to check the health of an Oracle Server.

Note: You can run this flow only on anOracle Server, which is monitored by HPOM Smart Plug-in for
Oracle.

This flow checks the following:

l If the Oracle Server is available.
l If the Oracle Tablespaces are online.
l If the Oracle Datafiles are online.
Youmust map this flow to theOracle CIT.

The following table lists the user input items required to run this OO flow:

Flow
input Description

omNode FQDN of the Oracle node. This must be amanaged node for the HPOM Server andmust be
specified each time you run the OO flow.

omServer FQDN of the HPOM Server. You canmap this input to the Event attributeOriginating Server.

instance Name of the Oracle Instance.

timeout Timeout value to be used when running the remote command on the node. This is an optional
attribute and the default value is 100000.

Oracle Performance Check

You can use this flow to check the performance of anOracle Server.

This flow checks the following:
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l If theNumber of Physical Reads per Minute for Oracle database instance is above the specified
threshold.

l If theRedo Log Buffer Space Request Count for Oracle database instance is above the specified
threshold.

l If theDictionary Cache Hit Percentage for Oracle database instance is above the specified threshold.
l If theCurrent Transactions Percentage for Oracle database instance is above the specified threshold.
l If theNumber of Sessions Waiting for release of a Lock for Oracle database instance is above the
specified threshold.

Note: You can run this flow only on anOracle Server, which is monitored by HP Operations Manager
Smart Plug-in for Oracle.

Youmust map this flow to theOracle CIT.

The following table lists the user input items required to run this OO flow:

Flow input Description

omNode FQDN of the Oracle node. This must be amanaged node for the HPOM
Server andmust be specified each time you run the OO flow.

PhysReadsRate_Threshold Threshold value forNumber of Physical Reads per Minute for Oracle
database instance. This is an optional attribute.

RedoLogSpaceWait_
Threshold

Threshold value forRedo Log Buffer Space Request Count for Oracle
database instance. This is an optional attribute.

DictionaryCacheMissRatio_
Threshold

Threshold value forDictionary Cache Hit Percentage for Oracle database
instance. This is an optional attribute.

TransactionPct_Threshold Threshold value forCurrent Transactions Percentage for Oracle database
instance. This is an optional attribute.

SessWaitLokCnt_Threshold Threshold value forNumber of Sessions Waiting for release of a Lock
for Oracle database instance. This is an optional attribute.

timeout Timeout value to be used when running the remote command on the node.
This is an optional attribute and the default value is 100000.

instance Name of the Oracle Instance.

omServer FQDN of the HPOM Server. You canmap this input to the Event attribute
Originating Server.

Tools
TheOMi MP for Oracle Database is packaged with tools which enable administering, monitoring, and
troubleshooting the Oracle CIs. It comprises the following tools:

How to Access Tools

1. Open Tools pane:
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OnBSM 9.2x, click Admin > Operations Management > Operations Console > Tools.
OnOMi 10.x, click Administration > Operations Console > Tools.

2. In the CI Type pane:
For Oracle CIs, click Configuration Item > Infrastructure Element > Running Software >
Database > Oracle.
For Computer CIs, click Administration > Operations Console > Tools > Configuration Item >
Infrastructure Element > Node > Computer.

CI Type Tool Description

Computer Display MP Error File (Oracle
Database)

To view the contents of the OMi MP for
Oracle Database error file.

MP Data Capture Tool (Oracle
Database)

Collects error and log information that can
be sent to HP Support for OMi MP for
Oracle Database troubleshooting issues.

EnableMP Monitoring (Oracle
Database)

Enables OMi MP for Oracle Database
collection and alert notification.

Disable MP Monitoring (Oracle
Database)

Disables OMi MP for Oracle Database
collection and alert notification.

Verify MP Deployment (Oracle
Database)

Shows OMi MP for Oracle Database
deployed files, versions, number of policies,
defaults file, and performs a connection
check.

EnableMP Trace (Oracle Database) Turns OnOMi MP for Oracle Database
tracing.

Disable MP Trace (Oracle Database) Turns Off OMi MP for Oracle Database
tracing.

Oracle Archive Device Free Space Reports free space in archive location for
Oracle database instance configured to OMi
MP for Oracle Database.

Archive LogWrite Rate Average time inminutes between archive
log writes of Oracle database instances
configured to OMi MP for Oracle Database.

Background DumpDevice Usage
Level

Reports information about the background
dump directory for Oracle database
instance configured to OMi MP for Oracle
Database.

Cached Tables Tables cached for Oracle database instance
configured to OMi MP for Oracle Database.
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CI Type Tool Description

Core DumpDevice Usage Level Reports information about the core dump
device usage level for Oracle database
instance configured to OMi MP for Oracle
Database.

Oracle Oracle Database Connection Check Checks the connection of all the Oracle
database instances configured to OMi MP
for Oracle Database.

DatabaseObject Status Reports invalid objects and invalid PL/SQL
ormissing dependencies for Oracle
database instance configured to OMi MP for
Oracle Database.

Datafiles Status Data files that are not online for Oracle
database instance configured to OMi MP for
Oracle Database.

Disabled Constraints Reports disabled constraints for Oracle
database instance configured to OMi MP for
Oracle Database.

Disabled Triggers Reports disabled triggers for Oracle
database instance configured to OMi MP for
Oracle Database.

Flash Recovery Area Usage Level Reports Flash Recovery Area (FRA) disc
space utilization status for Oracle database
instance configured to OMi MP for Oracle
Database.

Global Cache Block Status Reports information about blocks lost for
instances configured to OMi MP for Oracle
Database.

Global Cache Blocks TimedOut
Count

Reports global cache blocks timed out
counts of instances.

Oracle Product Manuals Starts a web browser and connects to the
Oracle product manuals web site.

Segments Near Max Extents Reports segments approachingmax
extents for Oracle database instance
configured to OMi MP for Oracle Database.

Oracle Segments Not Extendable Reports segments that cannot extent for
Oracle database instance configured to OMi
MP for Oracle Database.
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CI Type Tool Description

Sessions Waiting For Lock Reports sessions waiting for a lock for
Oracle database instance configured to OMi
MP for Oracle Database.

Shared Pool Memory Reports shared pool freememory for Oracle
database instance configured to OMi MP for
Oracle Database.

Shared Servers Waiting For
Requests

Shared servers waiting for requests for
Oracle database instance configured to OMi
MP for Oracle Database.

SQL Statements CPU Time SQL statements with high CPU time for
execution for Oracle database instance
configured to OMi MP for Oracle Database.

SQL Statements Performing Full
Table Scans

SQL statements performing full table scan
for Oracle database instance configured to
OMi MP for Oracle Database.

SQL Statements With High Buffer
Gets Per Execution

SQL Statements With High Buffer Gets Per
Execution or Oracle database instance
configured to OMi MP for Oracle Database.

SQL Statements With High Disk
Reads

SQL Statements With High Disk Reads Per
Execution for Oracle database instance
configured to OMi MP for Oracle Database.

SQL Statements With High Elapsed
Time Per Execution

SQL Statements With High Elapsed Time
Per Execution for Oracle database instance
configured to OMi MP for Oracle Database.

SQL Statements With High
Execution Rate

SQL Statements With High Execution Rate
for Oracle database instance configured to
OMi MP for Oracle Database.

SQL Statements With High Fetches SQL Statements With High Fetches for
Oracle database instance configured to OMi
MP for Oracle Database.

SQL Statements With Long Table
Scans

SQL Statements With Long Table Scans for
Oracle database instance configured to OMi
MP for Oracle Database.

Oracle Tables And Indexes Unanalyzed Reports % of tables and indexes that are
unanalyzed for Oracle database instance
configured to OMi MP for Oracle Database.

Tablespace Free Space Reports free space for all tablespaces for
Oracle database instance configured to OMi
MP for Oracle Database.
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CI Type Tool Description

Tablespaces Fragmented Reports tablespaces that have fragmented
free space for Oracle database instance
configured to OMi MP for Oracle Database.

Tablespaces With High Read Tablespaces with high ratio of block to
physical reads for Oracle database instance
configured to OMi MP for Oracle Database.

User DumpDevice Usage Level Reports information about the user dump
directory for Oracle database instance
configured to OMi MP for Oracle Database.

Users Logons Reports currently logged in users for Oracle
database instance configured to OMi MP for
Oracle Database.

Graph Templates
Graphs represent pictorial representation of metrics. TheOMi MP for Oracle Database includes the Oracle
graph family, which is mapped to the Oracle CIT. The graphs are generated from theDBSPI_ORA_GRAPH
data source. For information about creating and viewing graphs, see the documents forPerformance
Dashboard available in documentation for theOperations Manager i.

The following table provides information about the format of generic data source:

Graph
Templates Policy Name Policy Description Metric

Archive
Device

OracleDB_0058 Percentage of free space on archive
device.

E058_
ARCHVFREESPCPCT

Archive Logs OracleDB_0056 Number of archive logs in archive
device.

E056_
ARCHVFREESPCCNT

OracleDB_0057 Average time of archive log writes. E057_
ARCHIVEFREQRATE

Calls OracleDB_0044 Number of transactions. E044_COMMITRATE

OracleDB_0049 Rate of user calls. E049_USERCALLRATE

OracleDB_0050 Ratio of recursive calls to user calls. E050_
RCSVUSRCALRATIO

OracleDB_0075 Ratio of recursive calls to cumulative
opened cursors.

E075_
RCRSVCURSRRATIO
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Graph
Templates Policy Name Policy Description Metric

Checkpoints OracleDB_0035 Rate of background checkpoints
completed.

E035_
BCKGNDCKPTRATE

OracleDB_0083 Rate of DBWR checkpoints. E083_
DBWRCKPTRATE

Dump
Devices

OracleDB_0062 Percentage of space used on
background dump device.

E062_
BKGRDUMPSPCEPCT

OracleDB_0064 Percentage of space used on user
dump device.

E064_
USERDUMPSPACPCT

OracleDB_0065 Percentage of space used on core
dump device.

E065_
COREDUMPSPACPCT

OracleDB_0066 Size in MB of alert log. E066_ALERTLOGSIZE

Initialization
Limits

OracleDB_0028 Percentage of DML locks used to
total configured.

E028_
LOCKSUSEDPCT

OracleDB_0031 Number of users with percentage of
open cursors tomaximum
configured.

E031_
OPENCRSRPCTCNT

OracleDB_0085 Percentage of current transactions to
configured.

E085_
TRANSACTIONPCT

OracleDB_0087 Percentage of current processes to
configured.

E087_PROCESSPCT

OracleDB_0089 Percentage of enqueues to
configured.

E089_EnqueuePct

Multi-threaded
Server

OracleDB_0090 Percentage of busy (average) for all
dispatchers.

E090_DsptchrBusyPct

OracleDB_0091 Number of clients currently
connected to all dispatchers.

E091_NumDsptchrClnts

OracleDB_0092 Percentage of shared servers waiting
for requests.

E092_ShrSrvrReqWtPct

OracleDB_0093 Percentage of busy tomax shared
server processes.

E093_SharedServerPct

OracleDB_0094 Current percentage of shared pool
allocated to UGA.

E094_
SesUGAMemCurPct

OracleDB_0095 Maximum percentage of shared pool
allocated to UGA.

E095_
SesUGAMemMaxPct

OracleDB_0096 Percentage of high water to max
shared server processes.

E096_ShrdSrvHWMPct
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Graph
Templates Policy Name Policy Description Metric

Parallel Query
Option

OracleDB_0070 Percentage of parallel query servers
busy.

E070_
PQSERVRSBUSYPCT

OracleDB_0071 Percentage of parallel query servers
busy highwatermark.

E071_
PQSRVHIGHWTRPCT

OracleDB_0074 Rate of parallel queries initiated. E074_PQQUERYRATE

OracleDB_0076 Percentage of full table scans using
rowid range scans compared to total
full table scans.

E076_
PQRANGESCANPCT

Rollbacks DBSPI-0068 Number of rollback segment shrinks. E068_
RBSgmntShrnkCnt

OracleDB_0069 Percentage of rollback segment wait. E069_
RBSegWaitPctCnt

RollBacks
Generated

OracleDB_0054 Rate of generated rollbacks. E054_RollbackRate

Redo OracleDB_0032 Number of waits for redo log space. E032_
REDOLGSPCREQCNT

OracleDB_0033 Percentage of redo allocation latch
misses.

E033_
REDOALOCLTCHPCT

OracleDB_0034 Percentage of redo copy latch
misses.

E034_
REDOCOPYLTCHPCT

Sessions OracleDB_0037 Number of logons. E037_
USERLOGONCNT

OracleDB_0082 Maximum number of sessions from
startup.

E082_
SESSHIGHWATRCNT

Sharedpool OracleDB_0022 Total buffer cache hit percentage. E022_
TOTBUFCACHITPCT

OracleDB_0023 Current buffer cache hit percentage. E023_
CURBUFCACHITPCT

OracleDB_0026 Percentage of cache get misses to
gets in dictionary cache.

E026_
DICTCACHEHITPCT

OracleDB_0027 Percentage of library cachemisses
to executions.

E027_
LIBCACHRELODPCT

OracleDB_0039 Percentage of gethits to gets in
dictionary cache.

E039_
LIBCACGETHITPCT

Sharedpool OracleDB_0040 Percentage of pinhits to pins in
dictionary cache.

E040_
LIBCACPINHITPCT
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Graph
Templates Policy Name Policy Description Metric

OracleDB_0045 Percentage of free pool memory. E045_
SHRDPOOLFREEPCT

OracleDB_0059 Percentage of cursors in cache
parameter.

E059_
CURSORCACHEPCT

Sorts OracleDB_0019 Disk sort rate. E019_SORTDISKRATE

OracleDB_0052 Rate of total sorts on disk and in
memory.

E052_
SORTTOTALRATE

Sorts
Memory/Rows

OracleDB_0020 Percentage of memory sorts. E020_
SORTMEMORYPCT

OracleDB_0051 Average number of rows per sort. E051_
SORTROWSAVGCNT

Tablespace OracleDB_0006 Number of tablespaces with low free
space percentage.

E006_
TBLSPFREEPCTCNT

OracleDB_0007 Number of tablespaces that are not
online.

E007_
TBLSPCSTATUSCNT

OracleDB_0008 Number of tablespaces with high
ratio of block to physical reads.

E008_
TSBREADRATIOCNT

OracleDB_0009 Number of tablespaces with high use
of temp segments to total.

E009_
TSTMPEXNTPCTCNT

Tablespace OracleDB_0011 Number of fragmented tablespaces. E011_
TBLSPCFRGMNTCNT

OracleDB_0016 Number of segments that cannot
extend.

E016_
SEGMNTEXTENDCNT

OracleDB_0017 Number of segments approaching
max extent.

E017_
SEGMAXEXTENTCNT

OracleDB_0018 Number of segments adding extents
rapidly.

E018_
SEGEXTRAPIDCNT

Table Scan OracleDB_0030 Rate at which full table scans (long
tables) occur.

E030_
FULLGTBLSCNRATE

OracleDB_0041 Rate at which full table scans (short
tables) occur.

E041_
FULSHTBLSCNRATE
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Graph
Templates Policy Name Policy Description Metric

Tables and
Indexes

OracleDB_0042 Percentage of the tables and indexes
which were never analyzed.

E042_
UNLYZTBLINDXPCT

OracleDB_0046 Percentage of the rows fetched by
indFor example

E046_
ROWFETCBYIDXPCT

OracleDB_0047 Number of tables cached. E047_
TABLESCACHEDCNT

OracleDB_0048 Percentage of chained rows fetched. E048_
CHANDROWFTCHPCT

Waits OracleDB_0021 Percentage of buffer busy waits to
logical reads.

E021_
BUFFERBUSYPCT

OracleDB_0024 Percentage of enqueue waits to
enqueue requests.

E024_
EQWAITSREQPCT

OracleDB_0038 Number of latches with high
contention ratio greater than
threshold.

E038_
LTCHOVRLIMITCNT

OracleDB_0043 Percentage of enqueue timeouts to
enqueue requests.

E043_
EQTIMEOUTREQPCT

OracleDB_0029 Number of sessions waiting for
release of a lock.

E029_
SESSWAITLCKCNT
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Chapter 4: Customizing OMi MP for Oracle
Database
OMi MP for Oracle Database can be customized to suit your monitoring requirements. You can edit the
existing Oracle Management Templates or create new Oracle Management Templates tomonitor any
database environment.

This section provides information about the following:

l "Tuning the Components of OMi MP for Oracle Database"
l "Creating New Oracle Management Templates"
l "Creating New Oracle Aspect"
l "User DefinedMetrics (UDM)"

Tuning the Components of OMi MP for Oracle
Database
You can tune the following components:

l Parameters
l Aspects
l Management Template
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Tuning Parameters
You canmodify the default value of parameters either before or after deploying the Oracle Management
Templates or Aspects. You can edit parameter value during deployment usingManagement Templates &
Aspects pane. You can provide customized parameter values after (Management Template or Aspects)
deployment for each of the assignment using Assignments & Tuning pane.

Following is the list of parameters with the default values that you can edit.

Parameters Default Values

Frequency of Very High Scheduler 5mins

Frequency of High Scheduler 15mins

Frequency of Medium Scheduler 30mins

Frequency of Low Scheduler 1 hour

Frequency of daily Scheduler 24 hours

Frequency NA

Note:When the value of Frequency
parameter is set toNORUN, that
particular Policy Template,
Management Template, or Aspect will
not bemonitored for the duration the
Frequency value is modified.

Threshold NA

Severity NA

Tomodify the frequency of collection, corresponding Schedule Task policy must bemodified. Tomodify the
individual policy schedule, corresponding frequency parameters must bemodified.

Advanced Data Collection Filters
Filters are typically used to prevent unnecessary alerts or messages. For example, if you have a database
which you would not want to monitor and generate alerts/messages. In such cases, you can use filters to
exclude some data from being collected and, as a result, prevent the unwantedmessages. You set up filters
for Microsoft SQL Server by defining SQLWHERE clause fragments, part in the parameter during
Management Template or Aspect deployment.

Following is the list of filter parameters that you can edit:

Policy Filter Parameter Label Parameter Description and Example

OracleDB_0003 Tablespace Free Extents Filter Filter tablespaces with low free extents.
Mention SQLQuery to skip. For example:
Tablespace_nameNOT IN ('system').
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Policy Filter Parameter Label Parameter Description and Example

OracleDB_0004 Users Default on System Filter Filter Users having their default
Tablepsace as SYSTEM. Mention SQL
Query to skip. For example.: Username
NOT IN ('Guy','Debbie', 'Barry').

OracleDB_0005 Foreign Objects on System Filter Filter Users having their objects on
SYSTEM Tablepsace. Mention SQL
Query to skip. For example.: Owner NOT
IN ('Guy','Debbie', 'Barry').

OracleDB_0006 Tablespaces with Low Free Space
Filter

Filter tablespaces with low percentage of
free space. Mention the SQLQuery to
skip. For example: Tablespace_name
NOT LIKE 'SAP1001%' and tablespace_
nameNOT BETWEEN 'TS001' and
'TS0101'.

OracleDB_0007 Tablespace Status Filter Filter tablespaces with status offline.
Mention the SQLQuery to skip. For
example: Tablespace_nameNOT LIKE
'SAP1001%' and tablespace_nameNOT
BETWEEN 'TS001' and 'TS0101'.

OracleDB_0008 Tablespace Read Ratio Count Filter Filter tablespaces for read ratio. Mention
the SQLQuery to skip. For example:
Tablespace_nameNOT LIKE
'SAP1001%' and tablespace_nameNOT
BETWEEN 'TS001' and 'TS0101'.

OracleDB_0009 Tablespace with Temp Segments
Count Filter

Filter tablespaces for temp segments
percentage. Mention the SQLQuery to
skip. For example: Tablespace_name
NOT LIKE 'SAP1001%' and tablespace_
nameNOT BETWEEN 'TS001' and
'TS0101'.

OracleDB_0011 Fragmented Tablespaces Count Filter Filter tablespaces for fragmentation.
Mention the SQLQuery to skip. For
example: Tablespace_nameNOT LIKE
'SAP1001%' and tablespace_nameNOT
BETWEEN 'TS001' and 'TS0101'.

OracleDB_0016 Segments Extension Status Filter Filter Segments which can not extend.
Mention the SQLQuery to skip. For
example: Segment_name like 'SAP%'.
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Policy Filter Parameter Label Parameter Description and Example

OracleDB_0017 Segments ApproachingMax Extents
Filter

Filter Segments which are approaching
max extents. Mention the SQLQuery to
skip. For example: Owner NOT IN
('WAREHOUSE') and Segment_name
like 'SAP%'.

OracleDB_0018 Segment Growth Filter Filter Segments which grows rapidly.
Mention the SQLQuery to skip. For
example: Segment_name like 'SAP%'.

OracleDB_0029 SessionWait For Lock Filter Filter to specify session lock duration.
Mention the duration constraint. For
example: (SECONDS_IN_WAIT -
WAIT_TIME / 100 )> 120.

OracleDB_0042 Unanalyzed Tables Indexes Filter Filter tables and indexes which are never
analyzed. For example: "'TABLE_
NAME_A','TABLE_NAME_B'" or
"'INDEX_NAME_A','INDEX_NAME_
B'".

OracleDB_0203 Tablespace Free Extents Filter Filter tablespaces with low free extents.
Mention SQLQuery to skip. Ex:
Tablespace_nameNOT IN ('system').

OracleDB_0206 Tablespaces with Low Free Space
Filter

Filter tablespaces with low percentage of
free space. Mention the SQLQuery to
skip. For example: Tablespace_name
NOT LIKE 'SAP1001%' and tablespace_
nameNOT BETWEEN 'TS001' and
'TS0101'.

OracleDB_0215 Segment Size(Only Logging) Filter Filter segments for logging their sizes.
Mention the SQLQuery to skip. For
example: Segment_name like 'SAP%'.

OracleDB_0216 Segments Extension Status Filter
(Based on Tablespaces)

Filter Segments which can not extend
based on Tablespace. Mention the SQL
Query to skip. For example: Tablespace_
nameNOT LIKE 'SAP1001%' and
tablespace_nameNOT BETWEEN
'TS001' and 'TS0101'.

OracleDB_0217 Segments ApproachingMax Extents
Filter

Filter Segments which are approaching
max extents. Mention the SQLQuery to
skip. For example: Owner NOT IN
('WAREHOUSE') and Segment_name
like 'SAP%'.

OracleDB_0218 Segment GrowthFilter(Drill Down) Filter Segments which grows rapidly(Drill
Down). Mention the SQLQuery to skip.
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Policy Filter Parameter Label Parameter Description and Example

For example: Segment_name like
'SAP%'.

OracleDB_0334 ASMDiskgroup Free Space
Percentage Filter

Filter to skip ASM Diskgroup. Mention
the ASMDiskgoup to skip. For example:
NAME LIKE '%ASMDG1%'.

OracleDB_0101 SQLQuery Filter Filter to skip SQL statements from Query
performancemonitoring. Mention the
SQLQuery to skip. For example:
usernameNOT IN ('SYSTEM', 'SYS')

OracleDB_0102

OracleDB_0103

OracleDB_0104

OracleDB_0105

OracleDB_0106

OracleDB_0107

OracleDB_0108

OracleDB_0119

OracleDB_0301 SQLQuery Filter Filter to skip SQL statements from Query
performancemonitoring. Mention the
SQLQuery to skip. For example:
usernameNOT IN ('SYSTEM', 'SYS')

OracleDB_0302

OracleDB_0303

OracleDB_0304

OracleDB_0305

OracleDB_0306

OracleDB_0307

OracleDB_0308

Tuning Oracle Aspect
Based on themonitoring requirements, you can include or exclude policy template to the existing Oracle
Aspect. For more information about each policy, see the sectionOMi MP for Oracle Database -Reference
Guide.

Oracle Roll-Up and Drill-Down Policies
TheOracle roll-up policies that monitors multiple instances of database objects. TheOracle drill-down policy
monitors each instance of the database object. Roll-up policies send onemessage that could be relevant to
multiple objects.
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For example, when theOracleDB_0016 policy, generates amessage (alert), it indicates that a database
instance on the system has one or more segments that are unable to extend. The database instance name
and segments details are provided in themessage text as follows:

3 segments will not be able to extend in database Eurosales1.

Corresponding drill-down policy is OracleDB_0216, which generates alert for each tablespace.

OMi MP for Oracle Database provides the following drill down policies:

Aspect Roll-up policy Drill-down policy

Basic Oracle Query Performance OracleDB_0106 OracleDB_0306

OracleDB_0107 OracleDB_0307

OracleDB_0108 OracleDB_0308

Basic Oracle Segment Space OracleDB_ 0016 OracleDB_0216

Basic Oracle Query Performance OracleDB_0101 OracleDB_0301

OracleDB_0102 OracleDB_0302

OracleDB_0103 OracleDB_0303

OracleDB_0104 OracleDB_0304

OracleDB_0105 OracleDB_0305

Oracle Query Performance (Add-on) OracleDB_0106 OracleDB_0306

OracleDB_0107 OracleDB_0307

OracleDB_0108 OracleDB_0308

Basic Oracle Segment Space OracleDB_0016 OracleDB_0216

Oracle Segment Space (Add-on) OracleDB_0017 OracleDB_0217

OracleDB_0018 OracleDB_0218

Oracle Tablespace Health (Add-on) OracleDB_0003 OracleDB_0203

OracleDB_0006 OracleDB_0206

Note: It is recommended in a particular instance tomonitor using either roll-up or drill-down policy. Do not
include both roll-up and drill-up policies tomonitor single instance of the database.

If you want to generate alert for each tablespace as described in the example, then perform the following:

1. Open theManagement Templates & Aspects pane:
On BSM 9.2x, click Admin > Operations Management > Monitoring > Management Templates &
Aspects.
OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:
Configuration Folders > Database Management > Oracle > Oracle Aspects
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3. Select theBasic Oracle Segment Space from the list, and then click . The Edit Aspect dialog box
opens.

4. Click thePolicy Templates tab.

5. Select theOracleDB_0016 from the policies list and click .

6. Click and select Add Policy Templates From List.
7. In the list of policies, select OracleDB_0216 policy and click OK.
8. In the Edit Aspect dialog box, click OK.
The version of the Oracle Management Template is incremented. Deploy the new version of the Aspect.

Tuning Oracle Management Templates
You can edit the Oracle Management Templates andmodify the following components:

l Parameters
l Oracle Aspects

Editing Parameters
Use Case:You are using Essential Oracle Management Template tomonitor single instance databases in
your environment. You aremonitoring the table spaces with low free space in the environment and want to
modify the parameters corresponding to tablespaces to closely monitor the free space available.

To closely monitor tablespaces in your environment, youmust modify the tablespace parameters -
tablespaces with low free space frequency, tablespaces with low free space threshold, tablespaces with low
free space severity.

1. Open theManagement Templates & Aspects pane:
On BSM 9.2x, click Admin > Operations Management > Monitoring > Management Templates &
Aspects.
OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:
Configuration Folders > Database Management > Oracle > Oracle Management Templates >
Essential Oracle Management Template

3. Select the Essential Oracle Management Template from the list, and then click . The Edit
Management Template dialog box opens.

4. Click theParameters tab. The list of parameters appear.
5. Double-click the tablespace parameter. The Edit Parameter window appears.
In this instance, tablespace parameter is tablespaces with low free space frequency, tablespaces with
low free space threshold or tablespaces with low free space severity.

6. You can change the default value by using the drop down text. For example, you can change the value of
the parameter tablespace with low free space frequency to High fromMedium.

7. Click OK. The Edit Management Template dialog box opens.
8. Click OK. The version of the Oracle Management Template is incremented.

Note: The version number of the Oracle Management Template is incremented when any
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customizations aremade to the Oracle Management Template.

Including Additional Aspects
Essential and Extensive Oracle Management Template enable you tomonitor basic areas of Lock Latches,
Memory Performance, query performance, object faults, tablespace, and transactions. For in-depth
monitoring of these features, you can add one or more Aspect as required to the existingManagement
Template. For more information about Aspects that are not available in the OOTB Management Templates,
see the section Oracle Aspects.

Use Case:You aremonitor using Essential Oracle Management Template and require in-depthmonitoring of
transactions.

1. Open theManagement Templates & Aspects pane:
On BSM, click Admin > Operations Management > Monitoring > Management Templates &
Aspects.
OnOMi, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:
Configuration Folders > Database Management > Oracle > Oracle Management Templates >
Essential Oracle Management Template

3. Select theEssential Oracle Management Template from the list, and then click . The Edit
Management Template dialog box opens.

4. Click theAspects tab. The list of Aspects matching the Oracle CI type appear. You can deploy the
Management Template only to this CI type.

5. In the Available Aspects list, select the Oracle Transactions (Add-on) Aspect and click .
6. Click OK. The version of the Oracle Management Template is incremented.

Creating New Oracle Management Templates
1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management Templates &
Aspects.
OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:
Click Configuration Folders > Database Management > Oracle

3. In theManagement Templates & Aspects pane, select the new configuration folder and click and
then click Management Template. The CreateManagement Template wizard opens.

4. In theGeneral tab, type aName for the new Oracle Management Template and click Next.
5. AnOracle Management Template enables you tomanageOracle CIs and all the related dependent CIs.

Select theORA_Deployment from the list as the Topology View.
6. Click an item in the topology map to select theOracleCI Type and click Next.
7. In theAspects tab, add theOraspi_BaseAspects and click Next.
8. For each aspect that you add, youmust select Oracle as Target CI.
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9. In theParameters tab, combine all the instances of Oracle Instance Name, Oracle Instance User
Name, andOracle Instance Password parameters.

10. In the CreateManagement Template wizard, click Finish to save theManagement Template and close
the wizard.

The new Management Template appears in theManagement Templates & Aspects pane.

Creating New Oracle Aspect
1. OpenManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management Templates &
Aspects.
OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane, click the configuration folder in which you want to create the new
aspect. If you need to create a new configuration folder, click .

3. In theManagement Templates & Aspects pane, click , and then click Aspect. The Create Aspect
wizard opens.

4. In theGeneral tab, type a uniqueName for the new aspect and click Next.
5. In theCI Types tab, select theOracleCI Type to which this aspect will be assigned.

Click Next.
6. In the Instrumentation tab, addOracle_Monitoring_MP andDatabase_Monitoring_MP and click

Next.
7. In theAspects tab, add theOraspi_BaseAspect and click Next.

8. In thePolicy Templates tab, click Add Policy Templateon BSM 9.2x orAdd Policy Template
From List onOMi 10.x.Select the policy templates that you want to add, and then click OK.
You can add policies from theOracle Database MP policy template group. For more information about
each policy, see theOMi MP for Oracle Database - ReferenceGuide.

9. In theParameters tab, you see a list of all the parameters from the policy templates that you added to
this aspect.
You can set either a specific default value, or you can click From CI Attribute and then browse for a CI
attribute. For theOracle Instance NameParameter, select default value as name.

10. In the Create Aspect wizard, click Finish to save the aspect and close the wizard.
The new aspect appears in theManagement Templates & Aspects pane.

User Defined Metrics (UDM)
You can collect additional data from Oracle databases by creating User DefinedMetrics (UDMs). By default,
the UDMs are part of User Defined Aspects (UDA). TheOMi MP for Oracle Database enables you to define
additional metrics andmechanisms to collect thesemetric values with the help of SQL codes. The User
Defined Aspect includes the following policies:

l OracleDB_07XX -Measurement Threshold policy for monitoring UDM
l OracleDB_UDM - Sample Config file policy template to create a UDM
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Understanding UDM
TheOMi MP for Oracle Database provides you with a UDM configuration file. You can add SQL codes to the
template to define new metrics and themechanism to collect themetric data.

The template uses the following syntax to definemetric name andmetric data collectionmechanism:

ORACLE
METRIC 07XX
COLLECT <OPTIONS> "<sqlcode>"
REPORT 1 "<sqlcode>"
METRIC 07YY

The following snippet of code defines themechanism to collect themetric OracleDB_07XX:

ORACLE
METRIC 07XX
COLLECT <OPTIONS> "<sqlcode>"
REPORT 1 "<sqlcode>"

Where:

l METRIC 07XX is the newly definedmetric (you can type ametric name of your choice).
l COLLECT <OPTIONS> “<sqlcode>” is the syntax to definemetric data collectionmechanism from
managed server nodes.
o <OPTIONS> specifies themechanism to log and represent the collected data.

o “<sqlcode>” is the programming code written in SQL to collect metric data from database nodes. It can
be a direct stand-alone SQL statement.

l REPORT 1 “<sqlcode>” is the syntax to define themechanism to generate reports from the collected
metric data.

TheOMi MP for Oracle Database uses SQL utility to collect and report UDM data.

Database Metric COLLECT utility Metric REPORT utility

Oracle Transact-SQL isql

The SQL codes that youmention in this file are used by the collector/analyzer/script on Oracle database
managed nodes to collect metric data. In the SQL code, you can use the following host variables to facilitate
data collection process:

l :dbspi_error
l :dbspi_threshold
l :dbspi_value

Tasks
How to Create User Defined Aspects

To create user definedmetrics, follow these steps:
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1. To define a new metric, youmust create a copy of themeasurement threshold template OracleDB_
07XX.
a. Open the Policy Template pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Policy Templates.
OnOMi 10.x, click Administration > Monitoring > Policy Templates.

b. In the Policy Templates Groups pane:
Click Templates grouped by type > Measurement Threshold.

c. In Policy Templates pane, click OracleDB_07XX.
d. To create a copy of theOracleDB_07XX policy
e. Rename the policy as OracleDB_0700 and click OK.

Note: You can rename theOracleDB_07XX policy in the range from 0700 to 0797.

f. Tomodify parameter names, description, and values, follow these steps:

i. In the Policy Template pane, select theOracleDB_0700 policy template and then click .

Note: Youmust edit the policy in raw mode.

ii. Click Policy Data > Policy Parameters.

iii. In thePolicy Parameter tab, select the parameter from the list and then click . The Edit
Parameter dialog box opens.

iv. Edit the parameter name (For example, modify UDM Monitor Metric 27XX Severity toUDM
Monitor Metric 2700 Severity), description, and the values.

v. Click OK. The version of the policy template OracleDB_2700 increments by 0.1.
2. Define the UDM metric in the OracleDB_UDM policy.

a. Open the Policy Template pane:
On BSM 9.2x, click Admin > Operations Management > Monitoring > Policy Templates.
OnOMi 10.x, click Administration > Monitoring > Policy Templates.

b. In the Policy Templates Groups pane:
Click Templates grouped by type > ConfigFile Templates

c. In the Policy Template pane, select OracleDB_UDM policy.

d. In theOracleDB_UDM, select 1.0 and then click . Then click Edit Policy Template (Raw
Mode).

e. Click thePolicy Data tab. It contains details about defining a user definedmetric and a sample
example of a user definedmetric. You can edit the data and save the policy. The version number of
the UDM policy is incremented by 0.1.

3. Include bothOracleDB_0700 and latest version of OracleDB_UDM policies and create a new Oracle
User Defined Aspect.
For more information about creating new Oracle Aspect for aspect, see the section "Creating New
Oracle Aspect".
You ca also includeOracle UDA Aspect to existingManagement Template. For more information about
editingManagement Template, see the section "Tuning Oracle Management Templates ".
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Chapter 5: Troubleshooting
The following section provides information about troubleshooting scenarios:

Licensing count is not updated
Problem: Licensing count is not updated on LicenseManagement

Solution: To resolve this problem, follow these steps:

1. After installing OMi MP for Oracle Database, ensure that the license is activated by following these
steps:
a. Open LicenseManagement pane:

On BSM, click Admin > Platform > Setup and Maintenance > License Management.
OnOMi, click Administration > Setup and Maintenance > License Management.

b. Click and select the license.dat file. The license details appears in the LicenseManagement
window.
The LicenseManagement provides details about the name, license type, days left, expiration date,
capacity, and capacity details.

2. To check for the license usage on themanaged node, run the following command on themanaged node:

For Windows: ovodetect –t

For UNIX (except AIX): /opt/OV/bin/ovodetect –t

For AIX: /usr/lpp/OV/bin/ovodetect –t

If the output of the preceding command is mpinstance="1" thenOracle databases are beingmonitored.
If the output of the preceding command is mpinstance="0" thenOracle databases are not being
monitored.

3. If the license is still not updated in License Management, restart agent on themanaged node by running
the following command:

For Windows: ovc –restart opcmsga

For UNIX (except AIX): /opt/OV/bin/ovc –restart opcmsga

For AIX: /usr/lpp/OV/bin/ovc –restart opcmsga

Oracle Instance does not appear in RTSM
Problem: Oracle instance does not sync in RTSM from node.

Solution: To resolve this problem, follow these steps:

1. Open the Infrastructure Settings pane:
On BSM, click Admin > Platform > Setup and Maintenance > Infrastructure Settings
OnOMi, click Administration > Setup and Maintenance > Infrastructure Settings

2. In the Infrastructure Settings Manager, select Applications as Operations Management.
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3. In the Operations Management - HPOM Topology Synchronization Settings, the packages for Topology
Sync should contain the packages that are used for topology synchronization -
default;nodegroups;operations-agent;HPOprSys;HPOprOra.

4. Make sure that the policies -OracleDB_Discovery andOracleDB_DeepDiscovery are deployed on
themanaged node for discovering Oracle instances by running the following command:

Windows: ovpolicy -l

UNIX (except AIX): /opt/OV/bin/ovpolicy -l

AIX: /usr/lpp/OV/bin/ovpolicy -l

5. Check the Oracle discovery log file on themanaged node:

UNIX:/tmp/oracle_disc.log
Windows: %temp%\dbspi_disc_Oracle.log

6. Run the following command to obtain the policy id of OracleDB_Discovery:

ovpolicy -polname "OracleDB_Discovery" -list -level1

7. Verify whether theOracleDB_Discovery policy files exist by checking entries in the policyid.out file:
UNIX: /var/opt/OV/tmp/agtrep/
Windows: %OvDataDir%\tmp\agtrep\

8. Run the following command to synchronize the Oracle instance information to the OMi server from the
discovery output file agtrep.xml:

ovagtrep -publish -all

9. Make sure that the Oracle instance information is synchronized to the OMi MA server. Check the log
files available at the following location:

Linux:/var/opt/OV/dbspi/log/trace
Windows:C:\usr\OV\dbspi\log\trace

Management Templates and Aspects are not
deployed to the managed nodes
Problem:Management Templates and Aspects are not deployed to themanaged nodes.

Solution: To resolve this problem, follow these steps:

1. To check the deployment status:
On BSM, click Admin > Operations Management > Monitoring > Deployment Jobs
OnOMi, click Administration > Monitoring > Deployment Jobs

2. To check the assignment status:
On BSM, click Admin > Operations Management > Monitoring > Assignments & Tuning
OnOMi, click Administration > Monitoring > Assignments & Tuning

3. Check theseOMi log files opr-webapp.log and opr-configserver.log at the following location:
On BSM < or = 9.25:

Linux: /opt/HP/BSM/log/EJBContainer
Windows: %TOPAZ_HOME%\log\EJBContainer
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OnBSM > or = 9.26 andOMi 10.x:

Linux: /opt/HP/BSM/log/jboss
Windows: %TOPAZ_HOME%\log\jboss

No data for Performance Manager i (PMi) Graphs
Problem 1: The information to create graphs is not available from OMi MP for Oracle Database

Solution 1: To resolve this problem, follow these steps:

1. Run the following command to check if the graph data sources are created:

ovcodautil –obj

Verify the list of datasources and ensureDBSPI_ORA_GRAPH is created.
2. If the data sources are not created, run the following command to create the data source:

dbspigre

3. The errors related to data source creation are logged in the Console of command prompt.
4. Make sure that the graph policies are deployed on the nodes and policies log data into the following files:

UNIX:
/var/opt/OV/dbspi/dsi/oracle/<SID>/<SID>.dat

Windows:
C:\usr\OV\dbspi\dsi\oracle\<SID>.dat

5. Ensure that the *.fm files are deployed on themanaged node. Missing *.fm files or improper *.fm files
lead to NULL or zero data logged or populated into the data sources.

6. If the data is being logged into the .dat files in the required format, make sure that theOracleDB_
Logger policy (dbspimwc command) is deployed on themanaged node. TheOracleDB_Logger policy
reads the data from the .dat files and writes the data into the respective data source.

7. You can run the following command to verify if the data is being logged in the datasources.

ovcodautil -dumpds <datasource_name>

In this instance, data source is, DBSPI_ORA_GRAPH, ORADB_<hostname>_<instance>, etc.

Problem 2: In case you are reusing any of the old nodes with Operations Agent 11.x and PA DSI (Data
Source Integration) and if data sources are already created, this impacts data logging.

Solution 2: To resolve this problem, follow these steps:

1. Go to the following location:

UNIX: /var/opt/OV/dbspi
Windows: C:\Usr\dbspi

2. Edit defaults file and add the following command:

DATALOGGING_NEWLOGIC ON

3. To clean up and delete the old data, run the follow commands:
a. Clean the old data:

UNIX: /var/opt/OV/bin/instrumentation/dbspi_mwclup

User Guide

HPE OMi Management Pack for Oracle Database (1.11) Page 87 of 102



Windows: %OvDataDir%\bin\instrumentation\dbspimwi-cleanup
b. To restart data sources, run the command ovc –restart coda.

4. Create an empty file:

UNIX: /var/opt/OV/conf/dsi2ddf/nocoda.opt
Windows: %OvDataDir%\conf\dsi2ddf\nocoda.opt

5. For creating new CODA data sources and logging data for PMi, run the following commands:

dbspigre

Problem 3: If themanaged node is monitored by Smart Plug-in for Oracle Database.

Solution 3: To resolve this problem, follow these steps:

1. You can backup the data of DBSPI_ORA_<data sources> to the HP Reporter or any other Reporting
solution that you are using.

For example: Run the following command to backup the data of DBSPI_ORA_<data sources> on HP
Reporter, gathercoda –h <Oracle_hostname>.

2. Uninstall the HP Operations Smart Plug-in for Oracle from themanaged node.
For more information about uninstalling frommanaged node, seeHP Operations Smart Plug-in for
Databases Installation and Configuration Guide.

3. To remove the data sources, run the following command:

Windows: dbspimwi -cleanup

UNIX: dbspi_mwclup

Unable to log data into Reporter data sources
Problem:OMi MP for Oracle Database is not logging data into Reporter data sources.

Solution: To resolve this problem, follow these steps:

1. Run the following command to check if the report data sources are created:

ovcodautil –obj

In this instance, data sources likeDBSPI_ORA_REPORT, ORAOSM_<hostname>_<instance>, etc.
2. If the data sources are not created, run the following command to create the data source:

Windows: dbspimwi –osm

UNIX: dbspi_mw_int –osm

3. The errors related to data source creation are logged in the console of command prompt.
4. Ensure that the report policies are deployed on the nodes. Data for reports is logged by the report policies

directly into the data sources.

Oracle metric collection fails
Problem:Oracle metric collection fails

Solution: You can identify this problem by following these steps:
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1. You can enable tracing for an Oracle Instance by changing the Oracle Instance Tracing parameter to
ON. Oracle Instance Tracing parameter is an Expert parameter. To show expert parameters, click Show
Expert Parameters.
Select the View and then the corresponding instance and parameters and change theOracle Instance
Tracing parameter to ON.
or

2. Run theEnable MP Trace (Oracle Database) tool to enable tracing for all instances on the node.
The instrumentation log files are available at the following locations:
UNIX:
/var/opt/OV/dbspi/log/trace

/var/opt/OV/App_Monitoring/Oracle/log/*

Windows:
C:\usr\OV\dbspi\log\trace

%OvDataDir%\App_Monitoring\Oracle\log\*

Server scheduling metrics fails to execute after
deploying
Problem: Oracle schedulingmetrics are not executing after deployment.

Solution: To resolve this problem, follow these steps:

1. Ensure the below four policies are deployed on themanaged node by following these steps:
a. On BSM , click Admin > Operations Management > Policy Templates and onOMi, click

Administration > Monitoring > Policy Templates.
b. In Policy Template Groups pane, click Scheduler Task Templates.
c. Check if the policies -OracleDB_High, OracleDB_Low, OracleDB_Medium andOracleDB_

Veryhigh are deployed.
2. Navigate to the following location, to check if the respective policy files are valid:

o Windows: %OvDataDir%\App_Monitoring\Oracle\xml\

o UNIX: /var/opt/OV/App_Monitoring/Oracle/xml/

3. The scheduler xml files are created using the instrumentation file: SpiConfHandler.pl
Instrumentation file is available at the following location:
o Windows: %OvDataDir%\bin\instrumentation\

o UNIX: /var/opt/OV/bin/instrumentation/

4. To enable tracing, run theEnable MP Trace (Oracle Database) tool.
5. The scheduler log file is created at the following path, after enabling the tracing.

o Windows: %OvDataDir%\App_Monitoring\Oracle\log\SpiConfHandler.pl.log

o UNIX: /var/opt/OV/App_Monitoring/Oracle/log/SpiConfHandler.pl.log
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6. If you do not want to run any metric, the “NORUN” value can be selected in the Frequency parameter.
For more information about editing the parameter value, see the section "Tuning Parameters".

Collection failure does not generate alerts on the
Server
Problem: Whenever collector encounters an error, no alerts are generated on the Server.

Solution: To resolve this problem, follow these steps:

1. Enable tracing by following one of below methods:
a. Tracing can be enabled through Assignment & Tuning pane by following steps:

i. On BSM, click Admin > Operations Management > Monitoring > Assignments &
Tuning and onOMi, click Administration > Monitoring > Assignments & Tuning.

ii. In the Browse Views pane, select Oracle_Database_Deployment. Select the CI with the
problem.

iii. In the Assignment Item pane, select theOraspi BaseAspect.

iv. In the Assignment Details pane, click to view the expert parameters.
v. Double-click the Oracle Instance Tracing parameter.

The Edit Instance Parameter wizard opens.

vi. Click and then select Oracle Instance Tracing parameter and select . Change the
value toON and click OK.

vii. Click OK.
b. To enable tracing on all instances on the node, follow these steps:

i. ClickWorkspaces > Operations Console > Event Perspective.
ii. From theView Explorer, select a view and then select an event from the Event Browser.

You can view the tools in the Action pane. 
iii. Double-click Enable MP Trace (Oracle Database) tool. The Preview Tool Execution wizard

opens.

Note: Retain the optional parameter blank.

iv. Click Run Tool.
2. Navigate to the below location and ensure appropriate instrumentation files are deployed on the node.

Windows: %OvDataDir%\bin\instrumentation
UNIX: /var/opt/OV/bin/instrumentation

3. The dbspicao is the collector which is used to get the Oracle metrics.
a. To check the connection of the collector, run the command dpspicao -dpv.
b. To verify if the threshold value has exceeded the limit, run the command dpspicao -pv -m

<metric>.
Themetric values is printed on the CommandConsole.

4. If the threshold value has exceeded the limit, run the following command to generate Alarms:
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dbspicao –m <metric> -i <Instance name>

-m = (metric) Specifies themetric numbers or number ranges on which to collect data.
-i = (instance) Specifies the database instance (optional)

5. Instrumentation log files for tracing are available at the following location:
UNIX:
/var/opt/OV/dbspi/log/trace

/var/opt/OV/App_Monitoring/Oracle/log/*

Windows:
C:\usr\OV\dbspi\log\trace

%OvDataDir%\App_Monitoring\Oracle\log\*

No Instruction Text in Schedule Task Policy
Problem: The schedulemetric collection fails and the Instructions tab is empty:

1. The instrumentation file (CollMgr.bat or CollMgr.sh) is not present in the following location:

Windows: %ovdatadir%/bin/instrumentation/
UNIX: /var/opt/OV/bin/instrumentation/

2. Agent user might not have permission to run the binary.
3. The system where Agent is installedmight have low memory.
Solution:

1. If the instrumentation file (CollMgr.bat or CollMgr.sh) is not available in the folder, redeploy the
Management Template or Aspect to populate the instrumentation folder.

2. Ensure that the Agent user has the permission to run the instrumentation file (CollMgr.bat or
CollMgr.sh).

3. Increase physical memory on the Agent installed system.

Error while creating user for Oracle Database
Problem: Youmight encounter the following error while creating user using dbspiocr in Oracle 10g

grant select on V_$FS_FAILOVER_STATS to orampuser

*

ERROR at line 1:

ORA-00942: table or view does not exist

Disconnected from Oracle Database 10g Enterprise Edition Release 10.2.0.1.0 - 64bit
Production

With the Partitioning, OLAP and Data Mining options

Solution: OMi MP for Oracle Database supports user creation for Oracle version higher to 10g.
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Appendix: Data Sources for Logging
Themetric data is logged into specific data sources for generating graphs and reports.

Generic Data Source
The generic data source reserves a column for the database instance name, labeled instance name. This
column also contains the information that differentiates the data collected for each instance. Other column
represents the graphingmetrics. The following table is a sample of the Data source Table. The complete list
of all the graphingmetrics is stored in the dbspiorag.fm file located at:

Windows: <ovagentdir>\bin\instrumentation

Linux: /var/opt/OV/bin/instrumentation

Format of Generic Data Source
The following table provides information about the format of generic data source.

INSTANCE NAME E001_DbInstanceStat ...

<value> <value> <value>

<value> <value> <value>

Reports
The web based reports enable you to check the health and efficiency of specific Oracle databases. The
reports are generated from theDBSPI_ORA_REPORT data source. The following table provides information
about the Oracle Reports that are available. For information about viewing and accessing reports, see the
documentation forHP Service Health Reporter (SHR) .

TheDBSPI_ORA_REPORT contains information about the following columns:

l Instance Name
l Metric ID
l Value ID
l System ID
l Object ID
The following table provides information about theDBSPI_ORA_REPORT data source:

01/09/14 05:25:03 PM INSTANCENAME onehp

01/09/14 05:25:03 PM METRICID 201.00

01/09/14 05:25:03 PM VALUEID 1.00
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01/09/14 05:25:03 PM VALUE 5.00

01/09/14 05:25:03 PM SYSTEMID Machine
Name

01/09/14 05:25:03 PM OBJECTID onehp
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Appendix B: Permission and Grants
Following is the list of grants and privileges of Oracle user account for OMi MP for Oracle Database.

l grant select on DBA_2PC_NEIGHBORS
l grant select on DBA_2PC_PENDING
l grant select on DBA_ANALYZE_OBJECTS
l grant select on DBA_AUDIT_EXISTS
l grant select on DBA_AUDIT_OBJECT
l grant select on DBA_AUDIT_SESSION
l grant select on DBA_AUDIT_STATEMENT
l grant select on DBA_AUDIT_TRAIL
l grant select on DBA_CATALOG
l grant select on DBA_CLU_COLUMNS
l grant select on DBA_CLUSTER_HASH_EXPRESSIONS
l grant select on DBA_CLUSTERS
l grant select on DBA_COL_COMMENTS
l grant select on DBA_COL_PRIVS
l grant select on DBA_COLL_TYPES
l grant select on DBA_CONS_COLUMNS
l grant select on DBA_CONSTRAINTS
l grant select on DBA_DATA_FILES
l grant select on DBA_DB_LINKS
l grant select on DBA_DEPENDENCIES
l grant select on DBA_DIRECTORIES
l grant select on DBA_ERRORS
l grant select on DBA_EXP_FILES
l grant select on DBA_EXP_OBJECTS
l grant select on DBA_EXP_VERSION
l grant select on DBA_EXTENTS
l grant select on DBA_FREE_SPACE
l grant select on DBA_FREE_SPACE_COALESCED
l grant select on DBA_FREE_SPACE_COALESCED_TMP1
l grant select on DBA_FREE_SPACE_COALESCED_TMP2
l grant select on DBA_HISTOGRAMS
l grant select on DBA_IND_COLUMNS
l grant select on DBA_IND_PARTITIONS
l grant select on DBA_INDEXES
l grant select on DBA_JOBS
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l grant select on DBA_JOBS_RUNNING
l grant select on DBA_LIBRARIES
l grant select on DBA_LOBS
l grant select on DBA_METHOD_PARAMS
l grant select on DBA_METHOD_RESULTS
l grant select on DBA_NESTED_TABLES
l grant select on DBA_OBJ_AUDIT_OPTS
l grant select on DBA_OBJECT_SIZE
l grant select on DBA_OBJECT_TABLES
l grant select on DBA_OBJECTS
l grant select on DBA_PART_COL_STATISTICS
l grant select on DBA_PART_HISTOGRAMS
l grant select on DBA_PART_INDEXES
l grant select on DBA_PART_KEY_COLUMNS
l grant select on DBA_PART_TABLES
l grant select on DBA_PENDING_TRANSACTIONS
l grant select on DBA_PRIV_AUDIT_OPTS
l grant select on DBA_PROFILES
l grant select on DBA_QUEUE_SCHEDULES
l grant select on DBA_QUEUE_TABLES
l grant select on DBA_QUEUES
l grant select on DBA_RCHILD
l grant select on DBA_REFRESH
l grant select on DBA_REFRESH_CHILDREN
l grant select on DBA_REFS
l grant select on DBA_REGISTERED_SNAPSHOTS
l grant select on DBA_REPCATLOG
l grant select on DBA_RESUMABLE
l grant select on DBA_RGROUP
l grant select on DBA_ROLE_PRIVS
l grant select on DBA_ROLES
l grant select on DBA_ROLLBACK_SEGS
l grant select on DBA_SEGMENTS
l grant select on DBA_SEQUENCES
l grant select on DBA_SNAPSHOT_LOG_FILTER_COLS
l grant select on DBA_SNAPSHOT_LOGS
l grant select on DBA_SNAPSHOT_REFRESH_TIMES
l grant select on DBA_SNAPSHOTS
l grant select on DBA_SOURCE

User Guide

HPE OMi Management Pack for Oracle Database (1.11) Page 95 of 102



l grant select on DBA_STMT_AUDIT_OPTS
l grant select on DBA_SYNONYMS
l grant select on DBA_SYS_PRIVS
l grant select on DBA_TAB_COL_STATISTICS
l grant select on DBA_TAB_COLUMNS
l grant select on DBA_TAB_COMMENTS
l grant select on DBA_TAB_HISTOGRAMS
l grant select on DBA_TAB_PARTITIONS
l grant select on DBA_TAB_PRIVS
l grant select on DBA_TABLES
l grant select on DBA_TABLESPACES
l grant select on DBA_TRIGGER_COLS
l grant select on DBA_TRIGGERS
l grant select on DBA_TS_QUOTAS
l grant select on DBA_TYPE_ATTRS
l grant select on DBA_TYPE_METHODS
l grant select on DBA_TYPES
l grant select on DBA_UPDATABLE_COLUMNS
l grant select on DBA_USERS
l grant select on DBA_VIEWS
l grant select on FILEXT$
l grant select on SYS.DEFTRAN
l grant select on SYS.DEFERROR
l grant select on SYS.FET$
l grant select on SYS.FILE$
l grant select on SYS.FILEXT$
l grant select on SYS.OBJ$
l grant select on SYS.SEG$
l grant select on SYS.SYS_DBA_SEGS
l grant select on SYS.SYS_OBJECTS
l grant select on SYS.TS$
l grant select on SYS.UNDO$
l grant execute on SYS.DBMS_SPACE_ADMIN
l grant select on V_$_LOCK
l grant select on V_$ACCESS
l grant select on V_$ACTIVE_INSTANCES
l grant select on V_$AQ1
l grant select on V_$ARCHIVE
l grant select on V_$ARCHIVE_DEST
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l grant select on V_$ARCHIVED_LOG
l grant select on V_$BACKUP
l grant select on V_$BACKUP_CORRUPTION
l grant select on V_$BACKUP_DATAFILE
l grant select on V_$BACKUP_DEVICE
l grant select on V_$BACKUP_PIECE
l grant select on V_$BACKUP_REDOLOG
l grant select on V_$BACKUP_SET
l grant select on V_$BGPROCESS
l grant select on V_$BH
l grant select on V_$BUFFER_POOL
l grant select on V_$CIRCUIT
l grant select on V_$CLASS_PING
l grant select on V_$CONTROLFILE
l grant select on V_$CONTROLFILE_RECORD_SECTION
l grant select on V_$COPY_CORRUPTION
l grant select on V_$DATABASE
l grant select on V_$DATAFILE
l grant select on V_$DATAFILE_COPY
l grant select on V_$DATAFILE_HEADER
l grant select on V_$DB_OBJECT_CACHE
l grant select on V_$DB_PIPES
l grant select on V_$DBFILE
l grant select on V_$DBLINK
l grant select on V_$DELETED_OBJECT
l grant select on V_$DISPATCHER
l grant select on V_$DISPATCHER_RATE
l grant select on V_$DLM_CONVERT_LOCAL
l grant select on V_$DLM_CONVERT_REMOTE
l grant select on V_$DLM_LATCH
l grant select on V_$DLM_LOCKS
l grant select on V_$DLM_MISC
l grant select on V_$ENABLEDPRIVS
l grant select on V_$ENQUEUE_LOCK
l grant select on V_$EVENT_NAME
l grant select on V_$EXECUTION
l grant select on V_$FILE_PING
l grant select on V_$FILESTAT
l grant select on V_$FIXED_TABLE
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l grant select on V_$FIXED_VIEW_DEFINITION
l grant select on V_$GLOBAL_TRANSACTION
l grant select on V_$INDEXED_FIXED_COLUMN
l grant select on V_$INSTANCE
l grant select on V_$LATCH
l grant select on V_$LATCH_CHILDREN
l grant select on V_$LATCH_MISSES
l grant select on V_$LATCH_PARENT
l grant select on V_$LATCHHOLDER
l grant select on V_$LATCHNAME
l grant select on V_$LIBRARYCACHE
l grant select on V_$LICENSE
l grant select on V_$LOADPSTAT
l grant select on V_$LOCK
l grant select on GV_$LOCK
l grant select on V_$LOCK_ACTIVITY
l grant select on V_$LOCK_ELEMENT
l grant select on V_$LOCKED_OBJECT
l grant select on V_$LOCKS_WITH_COLLISIONS
l grant select on V_$LOG
l grant select on V_$LOG_HISTORY
l grant select on V_$LOGFILE
l grant select on V_$LOGHIST
l grant select on V_$SHARED_SERVER_MONITOR
l grant select on V_$MYSTAT
l grant select on V_$NLS_PARAMETERS
l grant select on V_$NLS_VALID_VALUES
l grant select on V_$OBJECT_DEPENDENCY
l grant select on V_$OFFLINE_RANGE
l grant select on V_$OPEN_CURSOR
l grant select on V_$OPTION
l grant select on V_$PARAMETER
l grant select on V_$PQ_SESSTAT
l grant select on V_$PQ_SLAVE
l grant select on V_$PQ_SYSSTAT
l grant select on V_$PQ_TQSTAT
l grant select on V_$PROCESS
l grant select on V_$PWFILE_USERS
l grant select on V_$QUEUE
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l grant select on V_$RECOVER_FILE
l grant select on V_$RECOVERY_FILE_STATUS
l grant select on V_$RECOVERY_LOG
l grant select on V_$RECOVERY_PROGRESS
l grant select on V_$RECOVERY_STATUS
l grant select on V_$REQDIST
l grant select on V_$RESOURCE
l grant select on V_$RESOURCE_LIMIT
l grant select on V_$ROLLSTAT
l grant select on V_$ROWCACHE
l grant select on V_$ROWCACHE_PARENT
l grant select on V_$ROWCACHE_SUBORDINATE
l grant select on V_$SESS_IO
l grant select on V_$SESSION
l grant select on V_$SESSION_CONNECT_INFO
l grant select on V_$SESSION_CURSOR_CACHE
l grant select on V_$SESSION_EVENT
l grant select on V_$SESSION_LONGOPS
l grant select on V_$SESSION_OBJECT_CACHE
l grant select on V_$SESSION_WAIT
l grant select on V_$SESSTAT
l grant select on V_$SGA
l grant select on V_$SGASTAT
l grant select on V_$SGA_DYNAMIC_COMPONENTS
l grant select on V_$SHARED_POOL_RESERVED
l grant select on V_$SHARED_SERVER
l grant select on V_$SORT_SEGMENT
l grant select on V_$SORT_USAGE
l grant select on V_$SQL
l grant select on V_$SQL_BIND_DATA
l grant select on V_$SQL_BIND_METADATA
l grant select on V_$SQL_CURSOR
l grant select on V_$SQL_SHARED_MEMORY
l grant select on V_$SQLAREA
l grant select on V_$SQL_PLAN
l grant select on V_$SQLTEXT
l grant select on V_$SQLTEXT_WITH_NEWLINES
l grant select on V_$STATNAME
l grant select on V_$SUBCACHE
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l grant select on V_$SYSSTAT
l grant select on V_$SYSTEM_CURSOR_CACHE
l grant select on V_$SYSTEM_EVENT
l grant select on V_$SYSTEM_PARAMETER
l grant select on V_$TABLESPACE
l grant select on V_$THREAD
l grant select on V_$TIMER
l grant select on V_$TRANSACTION
l grant select on V_$TRANSACTION_ENQUEUE
l grant select on V_$TYPE_SIZE
l grant select on V_$VERSION
l grant select on V_$WAITSTAT
l grant select on V$ROLLNAME
l grant select on GV_$INSTANCE
l grant select on V_$ROLLNAME
l grant select on V_$TEMPFILE
l grant select on GV_$SYSSTAT
l grant select on V_$FILE_CACHE_TRANSFER
l grant select on GV_$ARCHIVED_LOG
l grant select on V_$ARCHIVED_LOG
l grant select on GV_$ARCHIVE_DEST
l grant select on V_$ARCHIVE_DEST
l grant select on DBA_LOGSTDBY_PROGRESS
l grant select on DBA_LOGSTDBY_LOG
l grant select on V_$DATABASE
l grant select on V_$ARCHIVE_DEST_STATUS
l grant select on V_$RECOVERY_FILE_DEST
l grant select on SYS.DEFTRAN
l grant select on SYS.DEFERROR
l grant select on SYS.DBA_REPCATLOG
l grant select on V_$STREAMS_POOL_ADVICE
l grant select on DBA_CAPTURE
l grant select on DBA_PROPAGATION
l grant select on DBA_APPLY
l grant select on DBA_APPLY_ERROR
l grant select on DBA_APPLY_PROGRESS
l grant select on DBA_UNDO_EXTENTS
l grant select on DBA_MVIEWS
l grant select on DBA_TABLESPACE_USAGE_METRICS
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l grant select on V_$FLASH_RECOVERY_AREA_USAGE
l grant select on V_$FS_FAILOVER_STATS
l grant select on GV_$SESSION
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Send Documentation Feedback
If you have comments about this document, you can contact the documentation team by email. If an email
client is configured on this system, click the link above and an email window opens with the following
information in the subject line:

Feedback on User Guide (OMi Management Pack for Oracle Database 1.11)

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a webmail client, and send
your feedback to docfeedback@hpe.com.

We appreciate your feedback!
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