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l Software Version number, which indicates the software version.
l Document Release Date, which changes each time the document is updated.
l Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go to:
https://softwaresupport.hp.com

This site requires that you register for an HP Passport and sign in. To register for an HP Passport ID, go to:
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Or click the Register link at the top of the HP Software Support page.
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Support
Visit the HP Software Support Online web site at: https://softwaresupport.hp.com

This web site provides contact information and details about the products, services, and support that HP Software
offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and efficient way to access
interactive technical support tools needed to manage your business. As a valued support customer, you can benefit by
using the support web site to:

l Search for knowledge documents of interest
l Submit and track support cases and enhancement requests
l Download software patches
l Manage support contracts
l Look up HP support contacts
l Review information about available services
l Enter into discussions with other software customers
l Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a support
contract. To register for an HP Passport ID, go to:

https://hpp12.passport.hp.com/hppcf/createuser.do

To find more information about access levels, go to:

https://softwaresupport.hp.com/web/softwaresupport/access-levels

HP Software Solutions Now accesses the HPSW Solution and Integration Portal Web site. This site enables you to
explore HP Product Solutions to meet your business needs, includes a full list of Integrations between HP Products, as
well as a listing of ITIL Processes. The URL for this Web site is http://h20230.www2.hp.com/sc/solutions/index.jsp

About this PDF Version of Online Help
This document is a PDF version of the online help. This PDF file is provided so you can easily print multiple topics from
the help information or read the online help in PDF format. Because this content was originally created to be viewed as
online help in a web browser, some topics may not be formatted properly. Some interactive topics may not be present
in this PDF version. Those topics can be successfully printed from within the online help.
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Chapter 1: About the NNMi Console
The HP Network Node Manager (NNMi) console is the graphical user interface for your NNMi application.
The main features of the console are shown in the following diagram and explained in the table below.

When using the NNMi console, note the following:

l If you are using Microsoft Internet Explorer as your browser, you can sign into multiple NNMi sessions
on the NNMi server if you use a different user name for each browser session.

l If you are using Mozilla Firefox as your browser, you can only sign into a single NNMi session on each
NNMi server (for example, the Global NNMi server and each Regional NNMi server).

l You can bookmark the URL for the NNMi console.

l By default, NNMi displays menus, views, and workspaces that require an additional license. If your
NNMi server does not have the required license, NNMi adds the word Unlicensed or Evaluation
(caused by the License Type Instant-On or Temporary) to the end of the menu item name or view
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title.

Note: The NNMi Administrator can configure the User Interface to hide Unlicensed or
Evaluation features.

Feature Description

1 Title bar Used to identify the application you are running. The top-right corner contains the
standard browser buttons for closing and resizing the console window.

2
Workspace
navigation
panel

Helps you navigate between workspaces and views. See "Display Views" on page 10 and
"About Workspaces" on page 19.

3 Views A context that represents your current scope of interest and work. Workspaces provide
a means of grouping views for a related purpose or task flow. Multiple views are
available in each workspace. See "Views Available in NNMi" on page 24.

Note: You will see some or all of the workspaces and views described, depending on
several factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore,
you might see things that are not described in the NNMi online help. Contact
your NNMi administrator if you have questions about any additional items that
are not described.

4 User,
Role, and
Sign Out
button

Your current user name, and role assignment. Your role assignment determines what
you can see and do within the NNMi console.

5 Main
menu bar

Commands available in the console from within the menu structure:

l File

l View (see "Refresh a View" on page 58 and "Restore Table Defaults" on page 82)

l Tools (see "Use the Tools Menu" on page 13)

l Actions (see "Invoke Actions" on page 12 and "Using Actions to Perform Tasks" on
page 175)

l Help (see also "Access Help" on page 15 and "Search the Help Topics" on page 17)

Tip: To expand NNMi menus, you can click with the mouse or use Ctrl-Shift and the
underlined character (if any). NNMi uses Ctrl-Shift (instead of Alt) to avoid the
browser's main menu behavior. For example, NNMi provides Ctrl-Shift+H, then n for
Help→ NNMi Documentation Library. If the NNMi menu does not expand as
expected, your browser configuration already over-rides the NNMi configuration for

Network Node Manager Console Features
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Feature Description

that keyboard combination of Ctrl-Shift+<ASCII character>.

6 Tabs Title of each view and form currently displayed. Each view provides access to a group of
objects. More details about each object are available when you double-click the object
to display that object's form. See "Using Views to Display Data" on page 56 , "Access
Object Information (Forms and Analysis Pane)" on page 12, and "Working with Objects"
on page 170. The tabs allow you to easily navigate between multiple views and forms.

7 View
Toolbar

Tools available within the current view or form. These tools enable you to remove any
data filters that you previously applied, restore any columns that you previously hid, and
manipulate objects within the view. See "Using the View Toolbars" on page 160 for more
information.

The drop-down selectors enable you to modify the factory-set filter values applied to
the visible data. See "Filter a Table View" on page 67.

8 Content
Pane

Displays the currently selected view or form.

9 Status
Bar

In table views, the Status Bar shows the following information:

l Total. The current number of objects in the database that match the criteria for this
table (each row displays data about one object).

Note: You might also see a LIMIT number. This indicates that HP Network Node
Manager i Software Smart Plug-ins (iSPIs) software, has set a limit for the
current view. This number appears when the number of objects that match the
criteria for the current table exceeds the number of rows allowed. See "Help for
Administrators" for more information about NNM iSPIs software.

Tip: To reduce the number of objects displayed so that you see only the objects
of interest, use filters.

l Selected: Indicates the number of rows selected in the table.

l Filter. Indicates if the currently displayed data is a filtered subset of available
objects. See "Filter a Table View" on page 67.

l Auto Refresh. Indicates the current refresh time interval. See "Refresh a View" on
page 58.

In map views, the Status Bar shows the following information:

l The number of nodes displayed on the map.

l Auto status refresh. Automatic refresh rate for the Refresh Status option. See
"Refresh Node Status on a Map" on page 114. To update other aspects of the map
data (changes in node placement, nodes added, and nodes deleted), see "Refresh a
View" on page 58.

Note: The Initial Discovery Progress map indicates the refresh rate for Auto full

Network Node Manager Console Features , continued
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Feature Description

refresh, which refreshes both status and topology.

In both table and map views, the Status Bar displays the Last Updated time to indicate
the time at which the view was last refreshed.

10 Analysis
Pane

Displays additional information about the object selected in the Content Pane. Examples
of additional information include details about an incident's Source Node and Source
Object or information about a node's Interfaces and IP Addresses.

Note: This pane remains blank until an object is selected.

11 Console
message
bar

Alerts about any problems with NNMi, itself.

Network Node Manager Console Features , continued

Configure HowMozilla Firefox Responds to
NNMi Requests
By default, NNMi opens Online help in a new browser window.

In the main console window, opens a duplicate of the current view or form in a new browser window.

To control the number of windows generated, you can configure Mozilla Firefox so NNMi responds to
requests in a new tab within the current Firefox window.

To configure how Mozilla Firefox responds to NNMi links:

1. Open a Mozilla Firefox browser window.

2. In the URL field, type about:config and press Enter.

3. At the top of the displayed form, in the field labeled Filter, type newwindow. A list of relevant
attributes displays.

4. Double-click browser.link.open_newwindow.

5. In the Enter integer value dialog box, type one of the following choices:

1 = Replace the current Firefox window/tab.

2 = Open a new Firefox window.

3 = Open a new tab within the current Firefox window.

6. Click OK to save your changes and close the dialog box.

7. Double-click browser.link.open_newwindow.restriction.

8. In the Enter integer value dialog box, type one of the following choices:

0 = Use settings in browser.link.open_newwindow.

1 = Ignore settings in browser.link.open_newwindow.
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2 = Use settings in browser.link.open_newwindow unless the URL contains other window
instructions.

9. Click OK to save your changes and close the dialog box.

Related Topics

"Configure How Microsoft Internet Explorer Responds to NNMi Requests" below

Configure Mozilla Firefox Timeout Interval
If you use the Mozilla Firefox browser and have timeout issues (for example, being prompted to
Continue before a map appears), try resetting the Mozilla Firefox timeout value:

1. In the Mozilla Firefox address bar, type: about:config

2. Select the dom.max_script_run_time entry from the scroll-down list.

3. Increase the value displayed. For example, enter 0 (zero) to set the timeout value to infinity.

Configure HowMicrosoft Internet Explorer
Responds to NNMi Requests
By default, NNMi opens Online help in a new browser window.

In the main console window, opens a duplicate of the current form or view in a new browser window.

To control the number of windows generated, you can configure Microsoft Internet Explorer so NNMi
responds to requests in a new tab within the current Explorer window.

To configure how Microsoft Internet Explorer responds to NNMi requests:

1. From the Microsoft Internet Explorer browser, select Tools→ Internet Options

2. Select the General tab.

3. Under the Tabs section, click Settings.

4. In the Tabbed Browsing Settings dialog, locate the radio box group labeled When a pop-up is
encountered.

5. Make your selection:

l Let Internet Explorer decide...

l Always open pop-ups in a new window

l Always open pop-ups in a new tab

6. Click OK to save your configuration and close the dialog box.

7. Click OK to close the Internet Options dialog and return to the browser window.

Related Topics

"Configure How Mozilla Firefox Responds to NNMi Requests" on the previous page
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Configure the Microsoft Internet Explorer Title
Bar
When using Internet Explorer, browser settings determine whether the name of an NNMi view or form
displays in the title bar.

To configure Microsoft Internet Explorer to display view and form titles:

1. Open the Internet Explorer browser and click the Tools menu.

2. Select Internet Options.

3. Navigate to the Security tab, Trusted Sites, Custom Level, Miscellaneous section.

4. Disable the Allow websites to open windows without address or status bars attribute
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Chapter 2: About the Smart Plug Ins
(iSPIs)
HP Network Node Manager i Software Smart Plug-ins (iSPIs) for Performance and Advanced Network
Services extend the device and protocol support of NNMi to enable monitoring and management of a
wide range of network devices, services, and facilities. These Smart Plug-ins provide technology-specific
awareness that can provide a broader and more detailed perspective to quickly isolate faults and
improve the efficiency of your network operations team:

l Adaptive baselines and dynamic thresholds identify normal usage patterns, accelerate
implementation efforts, identify cost cutting opportunities, and quickly highlight performance
anomalies.

l Fully integrated discovery, monitoring, and reporting of your MPLS, IP Multicast, and IP Telephony
environments provide a detailed context within which to manage these services.

l Quality assurance probes provide synthetic transactions to measure and report on latency and
variability throughout your network fabric.

l Traffic flow collection and consolidation identifies application traffic patterns throughout the
network fabric.

These Smart Plug-ins provide technology-specific awareness that quickly identifies a problem and
reduces Mean Time to Repair (MTTR). Simply install and configure each iSPI:

l HP Network Node Manager iSPI for IP Multicast Software:

With the NNM iSPI for IP Multicast, you can:

l Discover and analyze any Multicast environment in real-time.

l Perform baseline snapshots and compare them with active flows.

l Utilize "Views for IP Multicast" on page 52 and "Views for Troubleshooting" on page 40 to see
elements such as neighbor views, forwarding paths, and reverse paths.

For more information, search NNMi Help for: "IP Multicast"

l HP Network Node Manager iSPI for IP Telephony Software:

With the NNM iSPI for IP Telephony, you can:

l Manage the fault and availability of Voice Over IP (VoIP) in a multi-vendor environment (Acme,
Avaya, Cisco, Microsoft Lync, and Nortel):

l Analyze the impact of network performance on your VoIP environment.

l Troubleshoot with many tools provided by this iSPI.

For more information, search NNMi Help for: "IP Telephony"

l HP Network Node Manager iSPI for MPLS Software:
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If you are on a service provider's team, the NNM iSPI for MPLS helps your team ensure that customer
obligations are met:

l Actively monitor the provider equipment (PE) and customer edge (CE) Multiprotocol Label
Switching (MPLS) devices that provide network access: "Views for MPLS" on page 51

l Monitor the effects of interface availability and site impact. See "Views for MPLS" on page 51.

l Analyze core MPLS virtual private network (VPN) availability.

l Automate discovery of Virtual Routing and Forwarding (VRF) neighbors including remote provider
equipment (PE routers).

l Generate performance reports about Label-Switched Paths (LSPs) and root-cause analysis for
Traffic Engineering tunnel issues (RCA for TE Tunnel).

For more information, search NNMi Help for: "iSPI for MPLS"

l HP Network Node Manager iSPI Network Engineering Toolset Software:

The NNM iSPI NET provides automated diagnostic flows and tools for troubleshooting the toughest of
network issues. NNM iSPI NET saves operators significant time and effort when diagnosing network
problems or analyzing Trap storms. Results are conveniently provided on the Node Form: Diagnostics
Tab and the Incident Form: Diagnostics Tab.

For more information, search NNMi Help for: "iSPI NET"

l HP Network Node Manager iSPI Performance for Metrics Software:

The NNM iSPI Performance for Metrics provides a complete environment for collecting, alarming, and
reporting on a wide variety of network performance metrics collected using Node Sensor and
Physical Sensor thresholds. Reports include trend and operational analysis statistics for multiple
vendor's equipment:

For more information, search NNMi Help for: "Performance for Metrics"

l HP Network Node Manager iSPI Performance for Quality Assurance Software:

With the NNM iSPI Performance for Quality Assurance, you can:

l Monitor the quality of service levels within your network. See "Views for Quality Assurance" on
page 53.

l Discover preconfigured Service Level Agreement (SLA) probes and gather the probes'
performance metrics.

l Identify SLA exceptions and violations through auto-generated NNMi Incidents.

For more information, search NNMi Help for: "Quality Assurance"

l HP Network Node Manager iSPI Performance for Traffic Software:

The NNM iSPI Performance for Traffic is a comprehensive reporting solution that validates whether
or not sufficient bandwidth is available for mission critical applications. See "Views for Traffic
Analysis" on page 54. The NNM iSPI Performance for Traffic does the following:
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l Supports all common diagnostic flow types

l Performs centralized analysis

l Provides a wide range of reports

For more information, search NNMi Help for: "Performance for Traffic"

For more information:
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Chapter 3: Navigating the Console
The main window of the console is your starting point for navigation.

A view is a collection of related objects that are depicted as a table or map. A form provides all known
details about a selected object.

From the main window, you can perform the following tasks:

l "Display Views" below

l "Access Object Information (Forms and Analysis Pane)" on page 12

l "Invoke Actions" on page 12

l "Use the Tools Menu" on page 13

l "Access Help" on page 15

l "Search the Help Topics" on page 17

l "Mark Your Favorite Help Topics" on page 18

Display Views
Views contain information about the objects in your network. A view can be a table (a list of objects) or a
view can be a map with icons. For example, to assist you in managing incidents, NNMi provides the Open
Key Incidents and My Open Incidents table views.

To display a view:

1. Click a workspace name in the workspaces navigation panel to display a group of views. The
workspaces provided by NNMi are shown below:
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2. Select the view you want. See "Using Views to Display Data" on page 56.

When you select another view from the workspaces navigation panel, the selected view replaces
the current view.

In the view toolbar, you can click the Show View in New Window icon to open the view in a new
window. See "Using the View Toolbars" on page 160.

If the view has more than one page of information, use the scroll bar or the page controls to navigate
through each page of the view. See "Using the View Toolbars" on page 160 for more information about
using page control.

See "Using Actions to Perform Tasks" on page 175 for more information about views that are accessible
from the console's Actions menu.

Tip: You can also right-click any object in a table or map view to access the items available within
the Actions menu.

Online Help: Using the Console
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Access Object Information (Forms and Analysis
Pane)
You can access more information about any object. For example, in your current view, you can obtain
more information about a node or interface that was reported as having problems. From within the
node or interface form, you can access the associated incidents.

Access all object attributes and related objects by displaying the form:

Tip: A red asterisk (*) that precedes an attribute on a form indicates the attribute requires a value.

l To open a form using Tools→ Find Node:

See the "Use the Tools Menu" on the next page for more information.

l To open a form from a table view:

Double-click the row representing an object.

The form appears, containing the details about the object. For more information, see "Working with
Objects" on page 170.

l To open a form from a map view:

Do one of the following:

l Select the map object. Then, click the  Open icon in the toolbar.

l Double-click the map object.

Note: If the map object is a Child Node Group, double-clicking the Child Node Group object
replaces the current map with a map containing each of the nodes in the Child Node Group.

To access a Child Node Group form, use the  Open icon in the toolbar.

l The form appears, containing the details about the object. For more information, see "Working
with Objects" on page 170.

Access more details about an object by using the Analysis Pane: "About the Analysis Pane" on page 157

Invoke Actions
The actions available to you depend on your NNMi user role and on the object selected. If no actions are
available for a particular object, the Actions menu is empty.

To perform an action, you select an object, then select an action from the Actions menu. The Actions
menu is accessible from the NNMi console main menu toolbar and from the menu toolbar in any view or
form that is opened in a new window.

Tip: To expand NNMi menus, you can click with the mouse or use Ctrl-Shift and the underlined
character (if any). NNMi uses Ctrl-Shift (instead of Alt) to avoid the browser's main menu behavior.
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For example, NNMi provides Ctrl-Shift+H, then n for Help→ NNMi Documentation Library. If the
NNMi menu does not expand as expected, your browser configuration already over-rides the NNMi
configuration for that keyboard combination of Ctrl-Shift+<ASCII character>.

l To invoke an action from a table or map view:

a. If you do not have a view displayed, from the workspace navigation panel, select a view.

b. Do one of the following:

o In a table view, single-click a row.

o In a map view, single-click the object of interest.

Tip: For multiple selections, use Ctrl-click.

c. Select the Actions menu in the menu toolbar.

Tip: You can also right-click any object in a table or map view to access the items available
within the Actions menu.

d. Select the action you want to perform from the list of available actions.

l To invoke an action from a form:

a. If you do not have a form open, from the workspace navigation panel, select the table view you
want to access.

b. From the table view, double-click the row representing the object instance (for example, node)
 you want to update.

c. From the menu toolbar, select Actions and then the action you want. For example, select Actions
→ Change Lifecycle→ In Progress to change the Lifecycle State of the selected incident to In
Progress.

When invoking actions, note the following:

l If you are running an action that modifies attributes on a form, the action takes effect immediately.

You do not have to select Save. 

l An action might cause a new window to open.

l In the Actions menu, your administrator can add menu choices. Those action items are not described
in NNMi Help.

Related Topics

"Using Actions to Perform Tasks" on page 175

Use the Tools Menu
Several tools are provided beneath the Tools menu. The list of tools changes depending on the role to
which you are assigned. The tools listed in the following table are available to Operator Level 2.

Tip: To expand NNMi menus, you can click with the mouse or use Ctrl-Shift and the underlined
character (if any). NNMi uses Ctrl-Shift (instead of Alt) to avoid the browser's main menu behavior.
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For example, NNMi provides Ctrl-Shift+H, then n for Help→ NNMi Documentation Library. If the
NNMi menu does not expand as expected, your browser configuration already over-rides the NNMi
configuration for that keyboard combination of Ctrl-Shift+<ASCII character>.

Tool Description

Find a Node Searches the NNMi database for the case-sensitive string of characters you provide.
NNMi finds the associated Node. If multiple Nodes match, NNMi displays the Node form
of the first match. NNMi checks the following Node attributes for a match:

l Name

l Hostname (fully-qualified)

l IP address

l MIB-II sysName

Find
Attached
Switch Port

Identifies the switch port to which the selected node is attached.

MIB
Browser

Displays the responses to NNMi's SNMP requests made to a particular node in your
network environment, starting from a Management Information Base (MIB) object
identifier (OID) within the Internet MIB structure.

NNMi
Status

Displays a list showing the status of each process and service of NNMi. When NNMi is
functioning properly, each process and service should be running. If one is not running,
contact your NNMi administrator.

Status
Distribution
Graphs

Displays the overall health of your network by providing Stacked Area Graphs that
display the distribution of Node, Interface, and IP Address Status information over time.

NNMi Self-
Monitoring
Graphs

Displays information about NNMi components and their usage:

l SNMP Trap Pipeline Rate

l SNMP Trap Forwarding Rate

l Discovery Progress

l SNMP Requests

Trap
Analysis Requires HP Network Node Manager iSPI Network Engineering Toolset Software

(NNM iSPI NET) -- click here for more information.

NNMi measures the rate of incoming SNMP traps. The NNMi administrator configures
thresholds for trap volume within your network. Use this menu item to access the Trap
Analytics reports.

Visio Export
Requires HP Network Node Manager iSPI Network Engineering Toolset Software
(NNM iSPI NET) -- click here for more information.

NNMi Tools Menu Options
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Tool Description

Exports topology maps displayed in NNMi to Visio documents for later use.

Signed In
Users

View a list of the NNMi users who are currently signed in to NNMi.

Incident
Actions Log

Displays a log of recent Incident Actions (configured by your NNMi administrator to
happen when particular incidents are received/generated by NNMi).

Security
Reports

(NNMi administrators only) Generate a report of possible NNMi Security configuration
problems.

NNMi Tools Menu Options , continued

Access Help
If you have a Guest user role, start with the topics in Help→ Using the Console. More information
about each view is in Help→ Help for Operators. If you need more information about a form, use the
Help→ Using the <name> form within the form.

If you are an Operator, task information is provided in Help→ Help for Operators. If you are an
Administrator, all the resources described in the table below are valuable.

Tip: To expand NNMi menus, you can click with the mouse or use Ctrl-Shift and the underlined
character (if any). NNMi uses Ctrl-Shift (instead of Alt) to avoid the browser's main menu behavior.
For example, NNMi provides Ctrl-Shift+H, then n for Help→ NNMi Documentation Library. If the
NNMi menu does not expand as expected, your browser configuration already over-rides the NNMi
configuration for that keyboard combination of Ctrl-Shift+<ASCII character>.

To access the help:

1. Select Help from the NNMi console main menu.

Note: Within the NNMi user interface, pressing [F1] does not access context-sensitive help.

2. From the help you can access all the information described in the table below.

Help Link Description

Using the <name>
form

Context-sensitive help for the current form.

Getting Started
with NNMi

Link to Best Practices Tours that explain some of NNMi’s capabilities.

Using the NNMi
Console

Explains how to use the NNMi console, including how to navigate within the
console, as well as how to access and use the forms and views NNMi provides.

Help for Operators Describes how to use the views, forms, and additional NNMi features that are

Help→ Links

Online Help: Using the Console
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Help Link Description

useful for monitoring and troubleshooting the network.

Help for Administra
tors

Explains how NNMi works and how you can configure NNMi to meet your needs.
Describes how to use the Configuration workspace that lets you configure a
variety of objects and settings for NNMi.

Help for NNM iSPIs Access more information about the HP NNM iSPI software currently installed on
your NNMi server. Your NNMi administrator must install these programs before
their Help entries appear.

NNMi
Documentation
Library

Provides access to Reference Pages (command line tool information), Release
Notes, and more.

HP Software
Support Website

Accesses the HP Software support web site.

System Information Health information about NNMi. See "Displaying Information About NNMi" on
page 180.

What's New Describes the NNMi features provided in the current release.

About HP
Network Node
Manager i Software

Current NNMi licensing information (total licensed capacity limit compared to
the number of nodes currently managed). See "Displaying NNMi Version and
License Information" on page 190.

Help→ Links , continued
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Related Topics

"Search the Help Topics" below

"Mark Your Favorite Help Topics" on the next page

Search the Help Topics
To search for specific information across all help topics:

1. In the top-right corner of the Help window, click the Search box.

2. Type in a search string (see table).

3. Click the button. The order of the resulting list of topics is based on a ranking order, with
highest ranking topics at the top of the list.

4. Click the topic of interest. To return to the search results and make another choice, click the
Backspace key on your keyboard.

Description Variable Example

Search for one or more words. When you enter a group of
words into the search field, "or" is inferred.

node interface

Search for a phrase. " "
(wrap a text

string in quotes)

"navigation pane"

Search for "either of" or "any of" specific strings. OR (case
insensitive)

| (pipe symbol)

node or interface
or address

"node
name"|"interface
status"

Search for two or more specific strings. AND (case
insensitive)

+ (plus symbol)

& (ampersand)

node And interface
And address

"node
name"+address

"node
name"&"interface"

Search for all topics that do not contain something. NOT (case
insensitive)

! (exclamation
mark)

not node

! node

Search for all topics that contain one string and do not
contain another.

^ (carat symbol) node ^ interface

Search Variables

Online Help: Using the Console
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Description Variable Example

Combinations of the above. ( ) parenthesis node and (name or
status)

node or vlan
(!address)

Search Variables , continued

Note: Results returned are case insensitive. However, results ranking takes case into account and
assigns higher scores to case matches. Therefore, a search for "templates" followed by a search
for "Templates" would return the same number of help topics, but the order in which the topics are
listed would be different.

Mark Your Favorite Help Topics
Use the Favorites tab in the Help system to set favorites for your commonly used help topics.

When using this feature, note the following:

l This feature is not related to the Favorites option in your Web browser.

l Any time you delete your Web browser cookies, your help topic favorites list is deleted.

Online Help: Using the Console
Chapter 3: Navigating the Console

HP Network Node Manager i Software (10.10) Page 18 of 196



Chapter 4: About Workspaces
A workspace is a collection of views that represent a scope of interest and work. Workspaces group
views with a related purpose or task flow.

When you click the name of a workspace, the views associated with that workspace display below the
workspace in the workspace navigation panel. After you select a view, the view display panel shows the
requested data. See "About the NNMi Console" on page 1 and "Display Views" on page 10 for more
information about the workspace navigation and view display panels.

The views within workspaces provide convenient access to information associated with each object type
represented. A view displays all the objects of a given type that meet the filter criteria specified for that
view.

Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.

NNMi includes the following workspaces:

Workspace Name Description:

Use the Dashboards workspace to view at-a-glance
information about your network. Dashboard views allow you to
easily compare and quickly isolate the information you need to
manage your network. See "Use Dashboard Views" on page 58 for
more information.

Requires HP Network Node Manager iSPI Performance for
Metrics Software (NNM iSPI Performance for Metrics). To
populate performance data in the dashboard views or
enhance NNM iSPI Performance for Metrics reports by sharing
NNMi configuration settings, install the optional Network
Performance Server (NPS) -- click here for more information.

Use the Incident Management workspace to access the
incidents that are most important to the network Operator and
that often require more immediate action, incidents with the

Lifecycle State equal to Registered, In Progress, or
Completed.

Workspaces in NNMi
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Workspace Name Description:

See "Views for Incident Management" on page 30 for more
information.

The Topology Maps workspace includes multiple map views.

See "Views of Topology Maps" on page 31 for more information.

Tip: The following changes are not automatically visible in the
Topology Maps workspace folders:

l Add one or more Node Groups

l Delete one or more Node Groups

l Modify a Node Group hierarchy

To view any of these changes, click Refresh in the upper
right-hand corner of the workspace. Refresh collapses the
Node Group maps folders. Expand each folder of interest to
view the updated Node Group map list.

The Monitoring workspace includes views to check for those
node sensors, physical sensors, chassis, cards, interfaces, nodes,
SNMP agents, IP addresses, Card Redundancy Groups, Router
Redundancy Groups, and Node Groups that have a Status of
Critical or other than Normal. This workspace also provides views
for checking the health of Custom Polled Collections and Custom
Polled Instances.

See "Views for Monitoring Network Devices" on page 38 for more
information.

Within the Troubleshooting workspace, you can access a
variety of map views.

The Layer 2 Neighbor View map displays Layer 2 network
connectivity. The Layer 3 Neighbor View map displays Layer 3
network connectivity. The Path View map displays the active IPv4
addresses in the path between a source and destination node. The
Path View map is useful when troubleshooting data flow problems.
The Node Group Map view displays all nodes within a specified
group.

See "Views for Troubleshooting" on page 40 for more information.

Each view in the Inventory workspace contains information
related to the object listed. For example, the Nodes view contains
information related to the Nodes object. The Interfaces view
contains information related to the Interface object. The IP
Subnets view contains information related to the IP Subnet object.

Workspaces in NNMi, continued
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Workspace Name Description:

See "Views with Inventory Lists" on page 41 for more information.

The Management Mode workspace includes views of
discovered network elements that are not currently being
managed by NNMi ():

See "Views into Management Mode" on page 43 for more
information.

The Incident Browsing workspace includes views for Key
Incident1 filtered on the incident's Lifecycle State. For example,
the Open Key Incidents view displays all Key Incidents with Lifecycle

State values other than Closed. The Closed Key Incidents view
displays all incidents that have a Lifecycle State of Closed.

This workspace also includes views for incidents based on their
Correlation Nature. Examples include Open Root Cause Incidents
and Service Impact Incidents.

You can also use this workspace to view all incidents.

NNMi provides the Custom Incident and Custom Open Incident
views that include all of the attributes available for an incident.
These views are provided so that you can customize the incident
views to include only the incident attributes of interest.

This workspace also includes views of incidents generated from
NNMi Syslog Messages and SNMP Traps.

See "Views for Incident Browsing" on page 44 for more
information.

Requires HP Network Node Manager iSPI Performance for
Metrics Software (NNM iSPI Performance for Metrics). To
populate performance data in the dashboard views or
enhance NNM iSPI Performance for Metrics reports by sharing
NNMi configuration settings, install the optional Network
Performance Server (NPS) -- click here for more information.

See also "Views for Performance Analysis" on page 46.

Workspaces in NNMi, continued

1Incidents with both: (1) Severity = other than Normal. (2) Correlation Nature = equal to Root Cause,
Service Impact, Stream Correlation, Rate Stream Correlation, Info, or None.
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Workspace Name Description:

Requires HP Network Node Manager iSPI for IP Telephony
Software (NNM iSPI for IP Telephony) -- click here for more
information.

See also "Views for Acme IP Telephony" on page 47.

See also "Views for Cisco IP Telephony" on page 48.

See also "Views for Nortel IP Telephony" on page 48.

See also "Views for Avaya IP Telephony" on page 49.

See also "Views for Microsoft IP Telephony" on page 50.

Requires HP Network Node Manager iSPI for MPLS Software
(NNM iSPI for MPLS) -- click here for more information.

See also "Views for MPLS" on page 51.

Requires HP Network Node Manager iSPI for IP Multicast
Software (NNM iSPI for IP Multicast) -- click here for more
information.

See also "Views for IP Multicast" on page 52.

Requires HP Network Node Manager iSPI Performance for
Quality Assurance Software (NNM iSPI Performance for Quality
Assurance) -- click here for more information.

See also "Views for Quality Assurance" on page 53.

Requires HP Network Node Manager iSPI Performance for
Traffic Software (NNM iSPI Performance for Traffic) -- click
here for more information.

See also "Views for Traffic Analysis" on page 54.

(NNMi Administrators only) Views for Integration Module
Configuration are used to configure NNMi for communication with
other software products. See Help→ Help for Administrators for
more information.

(NNMi Administrators only) Views for Configuration are used to
specify setting choices for NNMi and the iSPIs. See Help→ Help
for Administrators for more information.

Workspaces in NNMi, continued

Related Topics
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"Views Available in NNMi" on page 24
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Chapter 5: Views Available in NNMi
NNMi offers out-of-the-box views that provide a wealth of information about devices in your network.

Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.

Each view is described in the following topics about each Workspace:

"Views available in the Dashboards Workspace" on the next page

"Views for Incident Management" on page 30

"Views of Topology Maps" on page 31

"Views for Monitoring Network Devices" on page 38

"Views for Troubleshooting" on page 40

"Views with Inventory Lists" on page 41

"Views into Management Mode" on page 43

"Views for Incident Browsing" on page 44

"Views for Performance Analysis" on page 46

"Views for Acme IP Telephony" on page 47

"Views for Cisco IP Telephony" on page 48

"Views for Nortel IP Telephony" on page 48

"Views for Avaya IP Telephony" on page 49

"Views for Microsoft IP Telephony" on page 50

Workspaces in NNMi

HP Network Node Manager i Software (10.10) Page 24 of 196



Views for MPLS

Views for IP Multicast

Views for Quality Assurance

"Views for Traffic Analysis" on page 54

(NNMi Administrators only) Views for Integration Module
Configuration are used to configure NNMi for communication with
other software products.

(NNMi Administrators only) Views for the Configuration settings

of NNMi and the iSPIs.

Workspaces in NNMi, continued

Note: Some views appear under folders. To access the list of views available for a folder, click the +
(plus sign) that precedes the folder name.

Related Topics

"About Workspaces" on page 19

"Export Table Information" on page 83

Views available in the DashboardsWorkspace
The following views are available in the Dashboards workspace ("About Workspaces" on page 19).

Views available in the Dashboards workspace show information pertaining to the entire set of objects
managed by NNMi, constrained by the Security Groups to which the logged-in user belongs.

Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.

The following dashboard views are provided by NNMi. Your NNMi administrator can add more:

Online Help: Using the Console
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Panel Title Description

Open Key
Incidents

Lists the incidents that are most important to network Operators (any Key
Incident1) and that often require more immediate action. The Open Key Incidents
view includes those incidents that have a Correlation Nature that is any of the
following:

Incident
Correlation
Nature

Description

 Info This Correlation Nature is meant to be informational.

 None Indicates there is no incident correlation for this incident.

 Rate

Stream
Correlation

Indicates the incident tracks incident patterns based on the
number of incident reoccurrences within a specified time period.
After the count within the specified time period is reached,
NNMi emits a Rate Correlation incident and continues to update
the Correlation Notes with the number of occurrences within that
rate.

 Root

Cause

Indicates an incident that NNMi's Causal Engine determined to be
the root cause of a problem.

 User

Root Cause

Indicates that your NNMi administrator configured NNMi to always
treat this Incident as Correlation Nature: Root Cause.

Note: Key Incidents do not include Incidents with following Correlation
Natures because they are not considered to be Key Incidents:

 Dedup Stream Correlation

 Secondary Root Cause

 Symptom

Schedule
Outages

The Scheduled Node Outages view in the Management Mode workspace provides a
record of all past, present, and future Scheduled Node Outages.

Nodes in
Infrastructure
Node Group

The Networking Infrastructure Device map in the Topology Maps workspace
provides representative Node Groups for the Switches and for the Routers in your
network.

Nodes in
Routers Node

The Routers map in the Topology Maps workspace shows a graphical representation
of the Layer 3 connectivity in your network. Connector devices on Layer 3 maps are

Network Overview

1Incidents with both: (1) Severity = other than Normal. (2) Correlation Nature = equal to Root Cause,
Service Impact, Stream Correlation, Rate Stream Correlation, Info, or None.
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Panel Title Description

Group routers, switch-routers, and gateways. (See About Map Symbols for more
information.)

Top
CPU Utilization
(avg)

(NNM iSPI Performance for Metrics ) If your NNMi administrator installs and
configures thresholds, NNMi provides useful reports here.

CPU 5Sec Utilization

Threshold based on the percentage of a node's CPU usage compared to the total
amount of available CPU capacity. This percentage is the average CPU utilization
over the prior 5-seconds.

CPU 1Min Utilization

Threshold based on the percentage of a node's CPU usage compared to the total
amount of available CPU capacity. This percentage is the average CPU utilization
over the prior 1-minute.

CPU 5Min Utilization

Threshold based on the percentage of a node's CPU usage compared to the total
amount of available CPU capacity. This percentage is the average CPU utilization
over the prior 5-minutes.

Top
CPU Utilization
(avg)%

(NNM iSPI Performance for Metrics ) If your NNMi administrator installs and
configures thresholds, NNMi provides useful reports here.

CPU 5Sec Utilization

Threshold based on the percentage of a node's CPU usage compared to the total
amount of available CPU capacity. This percentage is the average CPU utilization
over the prior 5-seconds.

CPU 1Min Utilization

Threshold based on the percentage of a node's CPU usage compared to the total
amount of available CPU capacity. This percentage is the average CPU utilization
over the prior 1-minute.

CPU 5Min Utilization

Threshold based on the percentage of a node's CPU usage compared to the total
amount of available CPU capacity. This percentage is the average CPU utilization
over the prior 5-minutes.

Top Memory
Utilization
(avg)

(NNM iSPI Performance for Metrics ) If your NNMi administrator installs and
configures thresholds, NNMi provides useful reports here.

Memory Utilization

Threshold based on the percentage of a node's memory usage compared to the
total amount of available memory.

Top Memory (NNM iSPI Performance for Metrics ) If your NNMi administrator installs and

Network Overview, continued
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Panel Title Description

Utilization
(avg)%

configures thresholds, NNMi provides useful reports here.

Memory Utilization

Threshold based on the percentage of a node's memory usage compared to the
total amount of available memory.

Top
ICMP Response
Time (msec)

(NNM iSPI Performance for Metrics ) If your NNMi administrator installs and
configures thresholds, NNMi provides useful reports here.

Management Address ICMP Response Time

Threshold based on elapsed time (in milliseconds) for receiving a node's reply to an
Internet Control Message Protocol (ICMP) echo request. The address queried is the
node's Management Address attribute value. See the node's Node form, Basic
Attributes section for the currently configured address.

Top Interfaces
by Volume

(NNM iSPI Performance for Metrics ) If your NNMi administrator installs and
configures thresholds, NNMi provides useful reports here.

Top Interfaces
by Utilization

(NNM iSPI Performance for Metrics ) If your NNMi administrator installs and
configures thresholds, NNMi provides useful reports here.

Input Utilization

Threshold based on the percentage of the interface's total incoming octets
compared to the maximum number of octets possible (determined by the MIB being
used to query ifSpeed of the device and whether the host system supports high-
speed counters for interfaces).

Tip: Sometimes the ifSpeed value returned by the device's SNMP agent is not
accurate and causes problems with thresholds. If your NNMi role allows, you can
override the ifSpeed reported by the SNMP agent:

1. Open the problem interface's Interface form.

2. Select the General Tab.

3. Locate the Input/Output Speed section.

4. Change the Input Speed or Output Speed setting.

Output Utilization

Threshold based on the percentage of the interface's total outgoing octets
compared to the maximum number of octets possible (determined by the MIB being
used to query ifSpeed of the device and whether the host system supports high-
speed counters for interfaces).

Tip: Sometimes the ifSpeed value returned by the device's SNMP agent is not
accurate and causes problems with thresholds. If your NNMi role allows, you can
override the ifSpeed reported by the SNMP agent:

Network Overview, continued
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Panel Title Description

1. Open the problem interface's Interface form.

2. Select the General Tab.

3. Locate the Input/Output Speed section.

4. Change the Input Speed or Output Speed setting.

Top Interfaces
by Discard
Rate (avg)

(NNM iSPI Performance for Metrics ) If your NNMi administrator installs and
configures thresholds, NNMi provides useful reports here.

Output Discard Rate

Threshold based on the percentage of the interface's discarded output packet
count compared to the total number of outgoing packets. Packets might be
discarded because of a variety of issues, including transmission buffer overflows,
congestion, or system specific issues.

Top Interfaces
by Error Rate
(avg)

(NNM iSPI Performance for Metrics ) If your NNMi administrator installs and
configures thresholds, NNMi provides useful reports here.

Input Error Rate

Threshold based on the percentage of the interface's input packet error count
compared to the total number of packets received. What constitutes an error is
system specific, but likely includes such issues as bad packet checksums, incorrect
header information, and packets that are too small.

FCS LAN Error Rate

Local Area Network interfaces only.Threshold based on the percentage of incoming
frames with a bad checksum (CRC1 value) compared to the total number of
incoming frames. Possible causes include collisions at half-duplex, a duplex
mismatch, bad hardware (NIC2, cable, or port), or a connected device generating
frames with bad Frame Check Sequence.

FCS WLAN Error Rate

Wireless Local Area Network Interfaces only. Threshold based on the percentage of
incoming frames with a bad checksum (CRC3 value) compared to the total number
of incoming frames. Possible causes include wireless communication interference,
bad hardware (NIC4, cable or port), or a connected device generating frames with
bad Frame Check Sequence.

Network Overview, continued

More Dashboards views are available when iSPIs are installed. For example:

1Cyclic Redundancy Check
2Network Interface Controller
3Cyclic Redundancy Check
4Network Interface Controller
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l Interface Performance and Component Performance dashboards with the NNM iSPI Performance for
Metrics

Requires HP Network Node Manager iSPI Performance for Metrics Software (NNM iSPI
Performance for Metrics). To populate performance data in the dashboard views or
enhance NNM iSPI Performance for Metrics reports by sharing NNMi configuration settings,
install the optional Network Performance Server (NPS) -- click here for more information.

l QA Performance dashboard with the NNM iSPI Performance for QA

Requires HP Network Node Manager iSPI Performance for Quality Assurance Software (NNM iSPI
Performance for Quality Assurance) -- click here for more information.

For more information about dashboards:

Views for Incident Management
The following views are available in the Incident Management workspace ("About Workspaces" on page
19).

Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.

View Title Description

Open Key
Incidents

Lists the incidents that are most important to network Operators (any Key Incident1)
and that often require more immediate action. The Open Key Incidents view includes
those incidents that have a Correlation Nature that is any of the following:

Incident
Correlation
Nature

Description

 Info This Correlation Nature is meant to be informational.

 None Indicates there is no incident correlation for this incident.

Views for Incident Management

1Incidents with both: (1) Severity = other than Normal. (2) Correlation Nature = equal to Root Cause,
Service Impact, Stream Correlation, Rate Stream Correlation, Info, or None.
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View Title Description

Incident
Correlation
Nature

Description

 Rate

Stream
Correlation

Indicates the incident tracks incident patterns based on the number of
incident reoccurrences within a specified time period. After the count
within the specified time period is reached, NNMi emits a Rate
Correlation incident and continues to update the Correlation Notes
with the number of occurrences within that rate.

 Root

Cause

Indicates an incident that NNMi's Causal Engine determined to be the
root cause of a problem.

 User

Root Cause

Indicates that your NNMi administrator configured NNMi to always
treat this Incident as Correlation Nature: Root Cause.

Note: Key Incidents do not include Incidents with following Correlation Natures
because they are not considered to be Key Incidents:

 Dedup Stream Correlation

 Secondary Root Cause

 Symptom

Unassigned
Open Key
Incidents

Lists any open Key Incident1 that has not yet been assigned. This view is useful for
identifying the most recent Key Incidents that must be assigned.

My Open
Incidents

Lists the incidents that have been assigned to the name associated with the current
user.

Views for Incident Management , continued

For more information about workspaces:

Views of Topology Maps
The following views are available in the Topology Maps workspace ("About Workspaces" on page 19).

Note: You will see some or all of the workspaces and views described, depending on several
factors:

1Incidents with both: (1) Severity = other than Normal. (2) Correlation Nature = equal to Root Cause,
Service Impact, Stream Correlation, Rate Stream Correlation, Info, or None.
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l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.

(See Help → Help for Operators for more information about Node Group Maps.)

View Title Description

Node Group Overview Displays a map containing all top-level Node Groups.
Child groups are not visible until you double-click the
parent map link:

(See Help → Help for Operators for more information
about Node Group Maps.)

Network Overview
(Layer 3)

By default, this map displays a maximum of the 250
most highly connected nodes in the Layer 3 network.

The NNMi administrator configures aspects of this map:

l The maximum number of nodes displayed. If you are
an NNMi administrator, for more information, see
the "NNMi Console" chapter in the HP Network Node
Manager i Software Deployment Reference, which is
available at:
http://h20230.www2.hp.com/selfsolve/manual
s.

l The refresh rate, 5 minutes by default.

l The NNMi Console's Initial View is by default this
Network Overview. If the the NNMi Administrator
wants a different Node Group map to be displayed
every time an NNMi user opens NNMi, use the
Configuration > User Interface > User Interface
Configuration: Initial View settings.

Node Group Maps (Maps that have been saved at some point in time.)

Lists the Node Group Maps that your NNMi Administrator saved at some point in time.

Views of Topology Maps

Online Help: Using the Console
Chapter 5: Views Available in NNMi

HP Network Node Manager i Software (10.10) Page 32 of 196



View Title Description

When using the Node Group Maps folder, note the following:

l The maps are listed in alphabetical order.

l Each (tree) represents a Node Group hierarchy, a Node Group that contains other Node Groups.

To view the contained Node Groups, click to expand the folder.

l You can perform the actions described in Node Group Map Actions from a Node Group tree.

Task Action

Display a Node
Group map

Click the Node Name

Display the
Node Group
Map Settings
form for the
selected Node
Group

Right-click the Node Name and select Open Node Group Map Settings

This action appears only if you have permission to edit Node Group maps for the
nodes you have permission to access. If you are an Network Node Manager i
Software administrator, see the "Maintaining NNMi" chapter chapter of the HP
Network Node Manager i Software Deployment Reference for information about
how to enable access to this action.

Display the
Node Group
form for the
selected Node
Group

Right-click the Node Name and select Open Node Group

Node Group Map Actions

Note: These Node Group maps include the Node Group maps provided by NNMi as well as the
custom Node Group maps that were created using the Node Group Map Settings option. If you
are an Network Node Manager i Software administrator, see Define Node Group Map Settings for
more information about configuring Node Group Map Settings.

View Titles Description

Networking
Infrastructure

Displays representative Node Groups for the Switches and for the Routers in
your network. Each of the following device types, if applicable, are also included

Node Group Maps (default list)

Views of Topology Maps , continued
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View Title Description

View Titles Description

Devices on the map:

l Chassis

l Firewalls

l Voice Gateways

Note: Your NNMi Administrator can remove this map from the Topology
Maps workspace.

See Help → Help for Operators for more information about Node Group Maps.

And additional
views . . .

Any additional Node Group maps that your NNMi Administrator configured and
saved at some point in time.

Node Group Maps (default list), continued

Quick Access Maps (Maps that have an assigned Ordering Number.)

When the NNMi Administrator assigns a Topology Maps Ordering number to the Node Group’s map
(Configuration > User Interface > Node Group Map Settings):

• The link to that Node Group’s map automatically shows up under the Topology Maps > Quick Access
Maps folder in the assigned order.

The Quick Access Maps folder is visible to all NNMi users.

View Titles Description

Networking
Infrastructure
Devices

This map appears under the Node Group Maps and Quick Access Maps folders.

Displays representative Node Groups for the Switches and for the Routers in your
network. Each of the following device types, if applicable, are also included on the
map:

l Chassis

l Firewalls

l Voice Gateways

Quick Access Maps (default list)

Views of Topology Maps , continued
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View Title Description

View Titles Description

Note: Your NNMi Administrator can remove this map from the Topology Maps
workspace.

See Help → Help for Operators for more information about Node Group Maps.

Routers This map appears under the Node Group Maps and Quick Access Maps folders.

Displays a Node Group Map of the Router and Layer 3 connectivity in your network.

Tip: See "About Node and Interface Groups" on page 70 for more information
about Node Groups.

Note: If the number of Node Groups in your network is greater than the
maximum number of map objects configured to be displayed on the map,
NNMi filters the map to display routers that have interfaces with addresses in
the largest number of overall subnets in the network.

Your NNMi administrator can configure the maximum number of nodes to be
displayed on a map. See "Help for Administrators" for more information.

Note: Your NNMi Administrator can remove this map from the Topology Maps
workspace.

Switches This map appears under the Node Group Maps and Quick Access Maps folders.

Displays a Node Group map of the Switches and Layer 2 connectivity in your
network.

Tip: See "About Node and Interface Groups" on page 70 for more information
about Node Groups.

Note: If the number of nodes in your network is greater than the maximum
number of nodes configured to be displayed on the map, NNMi filters the map
to display switches that are the most highly connected.

Quick Access Maps (default list), continued

Views of Topology Maps , continued
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View Title Description

View Titles Description

Your NNMi administrator can configure the maximum number of nodes to be
displayed on a map. See "Help for Administrators" for more information.

Note: Your NNMi Administrator can remove this map from the Topology Maps
workspace.

And additional
views . . .

Any additional Node Group maps that your NNMi Administrator configured, saved,
and assigned an ordering number at some point in time.

Quick Access Maps (default list), continued

All Node Groups (Links to all defined Node Groups. Visible only to NNMi Administrators.)

When NNMi Administrators create a Node Group:

l The link to that Node Group’s map automatically shows up under the Topology Maps workspace in
the All Node Groups folder in alphabetical order.

l The Node Group Map icon is initially grey ( ).

l When the map is saved at some point in time, the icon changes to multi-colored ( ) and the link
to that map is added to the Node Group Maps folder where other NNMi users can see it.

l When an ordering number is assigned to a Node Group Map, that map is added to the Quick Access
Maps folder where other NNMi users can see it.

When using the All Node Groups folder, note the following:

l If you are an Network Node Manager i Software Administrator, see Define Node Group Map
Settings for more information about configuring Node Group Map Settings.

l This folder appears only if you have permission to create and delete Node Groups for the nodes
you have permission to access. If you are an Network Node Manager i Software Administrator, see
the "Maintaining NNMi" chapter chapter of the HP Network Node Manager i Software Deployment
Reference for information about how to enable access to this folder.

l Each (tree) represents a Node Group hierarchy, a Node Group that contains other Node Groups.

To view the contained Node Groups, click to expand the folder.

l You can perform the actions described in Node Group Map Actions from a Node Group tree:

Task Action

Display a Node
Group map

Click the Node Name

Display the
Node Group
Map Settings

Right-click the Node Name and select Open Node Group Map Settings

This action appears only if you have permission to edit Node Group Maps for

Node Group Map Actions

Views of Topology Maps , continued
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View Title Description

Task Action

form for the
selected Node
Group

the nodes you have permission to access. If you are an Network Node Manager
i Software administrator, see the "Maintaining NNMi" chapter chapter of the HP
Network Node Manager i Software Deployment Reference for information
about how to enable access to this action.

Display the
Node Group
form for the
selected Node
Group

Right-click the Node Name and select Open Node Group

Node Group Map Actions, continued

View Titles Description

Important
Nodes

Any devices in this group receive special treatment. When a current member of
this group stops responding, the Causal Engine generates a "Node Down" incident
and sets the device status to Critical.

Microsoft
Windows
Systems

This Node Group automatically includes any device manufactured by Microsoft.

Neighbor
Connections
Filter

Your NNMi administrator can configure a Node Group map to show devices that
are connected to Node Group members (one-hop neighbors), but not themselves a
member.

A gray halo around the map icon indicates a one-hop neighbor:

Not all one-hop neighbors are shown. Your NNMi administrator chooses a
particular Node Group as the Neighbor Connections Filter. Only one-hop devices
within the specified Node Group are displayed.

Networking
Infrastructure
Devices

This Node Group includes any Routers or Switches within your management
domain. They are monitored with special attention against fault metrics.

Non- This Node Group includes any device that does not respond to SNMP.

All Node Group Maps (default list)

Views of Topology Maps , continued
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View Title Description

View Titles Description

SNMP Devices

Virtual
Machines

(NNMi Advanced) This Node Group includes any virtual machine1 being hosted on a
hypervisor2.

VMware ESX
Hosts

(NNMi Advanced) This Node Group includes any VMware ESXi server that is hosting
virtual machines.

And additional
views . . .

Any additional Node Groups that the NNMi Administrator defined.

All Node Group Maps (default list), continued

Views of Topology Maps , continued

For more information about workspaces:

Views for Monitoring Network Devices
The following views are available in the Monitoring workspace ("About Workspaces" on page 19).

Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.

(See Help → Help for Operators for more information about Node Group Maps.)

View Title Description

Non-Normal
Node
Sensors

(NNM iSPI Performance for Metrics) Lists nodes that might need operator attention
due to a problem with the Node's buffers, CPU, disk, Memory, etc.

Views to Assist You with Monitoring Network Devices

1A device that utilizes components from multiple physical devices. Depending on the manufacture's
implementation, the virtual machine may be static or dynamic.
2The virtual machine manager in charge of delegating various aspects from a pool of resources to
become virtual devices. The delegations might be static or dynamic, depending on the manufacture's
implementation. The type of virtual machines being generated depends on the manufacturer's
implementation.
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View Title Description

Non-Normal
Physical
Sensors

Lists chassis or cards that might need operator attention due to a problem with the
chassis's such as backplane, fan, power supply, temperature, and voltage.

Non-Normal
Chassis

Lists Chassis that might need operator attention due to a problem with the health
objects within the chassis.

Non-Normal
Cards

Lists cards that might need operator attention.

Non-Normal
Interfaces

Lists interfaces that might need operator attention.

Non-Normal
Nodes

Lists nodes that might need operator attention.

Non-Normal
SNMP Agents

Lists SNMP Agents that have a state other than Normal.

Not
Responding
Addresses

Lists addresses that have a state of Not Responding. A Not Responding state
indicates that the address is not responding to ICMP ping.

Interface
Performance

(NNM iSPI Performance for Metrics) Helps you identify the over-used and under-used
interfaces for the nodes in your managed network.

Chassis
Redundancy
Groups

Lists the Chassis Redundancy Groups that NNMi discovered.

See Help → Help for Operators for more information about Chassis Redundancy
Groups.

Card
Redundancy
Groups

Lists the Card Redundancy Groups that NNMi discovered.

See Help → Help for Operators for more information about Card Redundancy Groups.

Router
Redundancy
Groups

Lists the available Router Redundancy Groups created by the NNMi administrator.
Each Router Redundancy Group is a set of two or more routers that use one or more
virtual IP addresses to help ensure that information packets reach their intended
destination.

See Help → Help for Operators for more information about Router Redundancy
Groups.

Node Groups Lists the Node Groups created by the NNMi administrator. Node Groups enable the
NNMi administrator to define groups of nodes based on several criteria, including by
host name or location.

See "About Node and Interface Groups" on page 70 for more information about Node
Groups.

Custom Node Lists the Custom Node Collections that have been created using NNMi's Custom Poller.

Views to Assist You with Monitoring Network Devices , continued
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Collections A Custom Node Collection identifies a topology node that has at least one associated
Custom Poller Policy.

See Help → Help for Operators for more information about Custom Node Collections.

Custom
Polled
Instances

Lists the Custom Polled Instances that have been created using NNMi's Custom Poller.
NNMi creates Custom Polled Instances the first time a MIB Expression is validated with
discovery information.

See Help → Help for Operators for more information about Custom Polled Instances.

Views to Assist You with Monitoring Network Devices , continued

For more information about workspaces:

Views for Troubleshooting
The following views are available in the Troubleshooting workspace ("About Workspaces" on page 19).

Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.

(See Help → Help for Operators for more information about Node Group Maps.)

View
Title

Description

Layer 2
Neighbor
View

Displays a map view of a selected device and its connector devices within a specified
number of hops from the selected device. This view is useful for understanding the switch
connectivity between devices.

The background color of a node in a network map indicates the node's or interface's
status. For example, green indicates the node is up. Red indicates the node or interface is
down.

Layer 3
Neighbor
View

Displays a map view of a selected device and its connector devices within a specified
number of hops from the selected device. This view is useful for understanding the router
connectivity between devices.

The background color of a node in a network map indicates the node's or interface's
status. For example, green indicates the node is up. Red indicates the node or interface is
down.

Views to Assist You with Troubleshooting
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View
Title

Description

Path
View

Displays an active network path between a source and destination end point.

Caution: Do not specify a switch as a Source or Destination node in Path View maps.
To view connectivity between switches, use the Layer 2 Neighbor View.

This view is useful for diagnosing connectivity problems; for example, when one node
cannot communicate with another or when you are not able to access a particular node,
such as a client PC not being able to contact the Microsoft Exchange server.

Note: (NNMi Advanced) Path View works only with IPv4 addresses. The NNMi Advanced
IPv6 address values are not valid choices for Path View. Any devices in your network
that are configured with IPv6 addresses cannot be displayed on Path View maps.

Node
Group
Map

Displays the pre-defined members of a Node Group in the context of not only status and
connectivity, but of a pre-defined background image (for example, a map of North
America).

See Help Help for Operators for more information about Node Group Maps.

Views to Assist You with Troubleshooting , continued

For more information about workspaces:

Views with Inventory Lists
The following views are available in the Inventory workspace ("About Workspaces" on page 19).

Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.

View Title Description

Nodes Lists the status for all nodes discovered by NNMi.

Sorting this view by status lets you see all of the nodes that are down or somehow
disabled.

Interfaces Lists the information about all network interfaces discovered by NNMi.

Sorting this view by associated node Name value (Hosted on Node) lets you see all of

Views with Inventory Lists
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View Title Description

the network interfaces per node.

Sorting the view by Administrative or Operations Status helps you determine the
interfaces or nodes that are down or somehow disabled.

IP Addresses Lists the status for all IP addresses hosted on Nodes that are discovered by NNMi.
(The Node form: IP Addresses tab also displays relevant addresses from this view.)

SNMP Agents List the status for each SNMP Agent that is enabled

IP Subnets Lists the status for all IP subnets.

Sorting this view by status lets you quickly see all of the IP addresses that have a
status that indicates there is a current or potential problem.

VLANs Lists the switch port VLANs discovered in your network environment. A device can
participate in multiple VLANs. And a port can be assigned to multiple VLANs.

Chassis Lists the chassis NNMi discovered in your network environment.

Cards Lists the cards NNMi discovered in your network environment.

Ports Lists the ports NNMi discovered in your network environment.

Node
Sensors

(NNM iSPI Performance for Metrics) Lists information about aspects of nodes such as
buffers, CPU, disks, and memory.

Physical
Sensors

Lists aspects of chassis such as backplanes, fans, power supplies, temperature, and
voltage.

Layer 2
Connections

Lists the Layer 2 connections discovered or added in your network environment.

Nodes (All
Attributes)

Provides a Node view of most Node attributes. Sort and filter this view to meet your
needs.

Interfaces
(All
Attributes)

Provides an Interface view of most Interface attributes. Sort and filter this view to
meet your needs.

IP Addresses
(All
Attributes)

Provides an IP Address view of most IP Address attributes. Sort and filter this view to
meet your needs.

One column shows any currently configured Mapped Addresses. If static Network
Address Translation (NAT) is part of your network, your NNMi administrator can
configure NNMi to display the NAT internal IP address assigned (mapped) to the
selected external IP address.

MIB
Variables

Lists the MIB variables available from the MIBs that are loaded in the NNMi database.

Views with Inventory Lists , continued
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Chassis
Redundancy
Groups

Lists the Chassis Redundancy Groups that NNMi discovered.

See Help → Help for Operators for more information about Chassis Redundancy
Groups.

Card
Redundancy
Groups

Lists the Card Redundancy Groups that NNMi discovered.

See Help → Help for Operators for more information about Card Redundancy Groups.

Router
Redundancy
Groups

(NNMi Advanced) Lists the available Router Redundancy Groups created by the NNMi
administrator. Each Router Redundancy Group is a set of two or more routers that
use one or more protected (virtual) IP addresses to help ensure that information
packets reach their intended destination. See Help → Help for Operators for more
information about Router Redundancy Groups.

Router
Redundancy
Members

(NNMi Advanced) Lists the members of the Router Redundancy Groups created by the
NNMi administrator.

Node Groups Lists the Node Groups provided by NNMi and created by the NNMi administrator.

See "About Node and Interface Groups" on page 70 for more information about Node
Groups.

Interface
Groups

Lists the Interface Groups provided by NNMi and created by the NNMi administrator.

See Help → Help for Operators for more information about Interface Groups.

MPLS WAN
Clouds
(RAMS)

(NNMi Advanced, plus HP Route Analytics Management System (RAMS) for MPLS WAN)
Shows the information about all MPLS WANs discovered by NNMi.

Views with Inventory Lists , continued

For more information about workspaces:

Views into Management Mode
The following views are available in the Management Mode workspace ("About Workspaces" on page
19).

Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.
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Unmanaged
Nodes

Lists all of the nodes that have a management mode set to Not Managed or

Out of Service. These nodes are no longer being monitored nor updated.

Unmanaged
Interfaces

Lists all of the interfaces that have a management mode set to Not Managed or

Out of Service. These interfaces are no longer being monitored nor updated.

Unmanaged
IP
Addresses

Lists all of the addresses that have a management mode set to Not Managed or

Out of Service. These addresses are no longer being monitored nor updated.

Unmanaged
Chassis

Lists all of the chassis that have a management mode set to Not Managed or

Out of Service. These chassis are no longer being monitored nor updated.

Unmanaged
Cards

Lists all of the cards that have a management mode set to Not Managed or

Out of Service. These cards are no longer being monitored nor updated.

Unmanaged
Node
Sensors

(NNM iSPI Performance for Metrics) Lists all of the node sensors that have a
management mode set to Not Managed or Out of Service. These node sensors

are no longer being monitored nor updated.

Unmanaged
Physical
Sensors

Lists all of the physical sensors that have a management mode set to Not Managed
or Out of Service. These physical sensors are no longer being monitored nor

updated.

Scheduled
Node
Outages

Lists all past, present, and future Scheduled Node Outages.

During the Scheduled Outage time period, NNMi suspends any Discovery and Monitoring
of that Node and changes the following:

l Node Status =  No Status

l Node Management Mode =  Out of Service

When the specified time period ends, NNMi gathers current information and updates
the Node data.

Management Mode Views

For more information about workspaces:

Views for Incident Browsing
The following views are available in the Incident Browsing workspace ("About Workspaces" on page 19).

Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.
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l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.

View Title Description

Open Key
Incidents

Shows the incidents that are most important to network Operators (any Key Incident1)
and that often require more immediate action. The Open Key Incidents view includes
those incidents that have a Correlation Nature that is any of the following:

Incident
Correlation
Nature

Description

 Info This Correlation Nature is meant to be informational.

 None Indicates there is no incident correlation for this incident.

 Rate

Stream
Correlation

Indicates the incident tracks incident patterns based on the number
of incident reoccurrences within a specified time period. After the count
within the specified time period is reached, NNMi emits a Rate
Correlation incident and continues to update the Correlation Notes
with the number of occurrences within that rate.

 Root

Cause

Indicates an incident that NNMi's Causal Engine determined to be the
root cause of a problem.

 User

Root Cause

Indicates that your NNMi administrator configured NNMi to always
treat this Incident as Correlation Nature: Root Cause.

Note: Key Incidents do not include Incidents with following Correlation Natures
because they are not considered to be Key Incidents:

 Dedup Stream Correlation

 Secondary Root Cause

 Symptom

Closed Key
Incidents

Shows the key incidents that have been closed. This view is useful for identifying the
root cause incidents that have been resolved. This view might be particularly useful for
reporting on how many incidents were closed within a given time period.

Open Root
Cause

Shows the root cause incidents that have not yet been closed. This view is useful for
identifying the root cause incidents that need to be resolved.

Views for Incident Browsing

1Incidents with both: (1) Severity = other than Normal. (2) Correlation Nature = equal to Root Cause,
Service Impact, Stream Correlation, Rate Stream Correlation, Info, or None.
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View Title Description

Incidents

Service
Impact
Incidents

Indicates incidents that have a relationship to other incidents in which a network
service is affected. For example, an Interface Down incident can effect a Router
Redundancy Group that is part of an HSRP service. The Service Impact incident helps to
identify the service that is affected.

This Correlation Nature is available for use by HP Network Node Manager i Software
Smart Plug-ins (iSPIs).

See Help → Help for Administrators for more information about NNM iSPIs.

All Incidents Shows all incidents. This view is useful for determining all of the incidents that have
been generated within a certain time period.

Custom
Open
Incidents

Enables you to choose the columns of incident information for all Open incidents, to
better meet your needs. For example, you might want to filter the view to display only
the incidents related to a particular set of devices. You might also want to filter the
view to display only the incidents assigned to you.

Custom
Incidents

Lets you create a customized view for your incident information. For example, you
might want to filter this view to include only the incidents assigned to you.

Syslog
Messages

(HP ArcSight ) The HP NNMi–ArcSight integration adds syslog message information to
NNMi so that you can view these syslog messages and investigate potential problems.

SNMP Traps Lists all of the traps that were received from devices in your network environment.
Your NNMi administrator must configure specific traps before they are displayed within
NNMi incident views.

Views for Incident Browsing , continued

For more information about workspaces:

Views for Performance Analysis

Requires HP Network Node Manager iSPI Performance for Metrics Software (NNM iSPI Performance
for Metrics). To populate performance data in the dashboard views or enhance NNM iSPI
Performance for Metrics reports by sharing NNMi configuration settings, install the optional
Network Performance Server (NPS) -- click here for more information.

The following views are available in the Performance Analysis workspace.

Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

Online Help: Using the Console
Chapter 5: Views Available in NNMi

HP Network Node Manager i Software (10.10) Page 46 of 196



l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.

View Title Description

Node Performance Metrics Lists the statuses of nodes on which performance monitoring is
configured.

Interface Performance
Metrics

Lists the statuses of interfaces on which performance monitoring is
configured.

Views for Performance Analysis

For more information about workspaces:

Views for Acme IP Telephony

Requires HP Network Node Manager iSPI for IP Telephony Software (NNM iSPI for IP Telephony) --
click here for more information.

The following views are available in the Acme IP Telephony workspace. You can view this workspace only
after installing the NNM iSPI for IP Telephony.

To check that the NNM iSPI for IP Telephony is installed:

1. Select the Help→ System Information in the menu toolbar.

2. In the System Information popup, go to the Extensions tab. If you can see iSPI for IP
Telephony under the HP NNM iSPI Software Deployed section, the NNM iSPI for IP Telephony is
installed.

Click Help→ Help for NNM iSPIs→ IP Telephony Online Help for an explanation about these views
added by the NNM iSPI for IP Telephony.

Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.

View Title Description

Session
Director

Lists the Acme Session Directors that are discovered and monitored in your
environment.

Views for Acme IP Telephony

For more information about workspaces:
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Views for Cisco IP Telephony

Requires HP Network Node Manager iSPI for IP Telephony Software (NNM iSPI for IP Telephony) --
click here for more information.

The following views are available in the Cisco IP Telephony workspace. You can view this workspace only
after installing the NNM iSPI for IP Telephony.

To check that the NNM iSPI for IP Telephony is installed:

1. Select the Help→ System Information in the menu toolbar.

2. In the System Information popup, go to the Extensions tab. If you can see iSPI for IP
Telephony under the HP NNM iSPI Software Deployed section, the NNM iSPI for IP Telephony is
installed.

Click Help→ Help for NNM iSPIs→ IP Telephony Online Help for an explanation about these views
added by the NNM iSPI for IP Telephony.

Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.

View Title Description

UCM Clusters Lists the Cisco Unified Communications Manager clusters discovered on the network.

UCMEs Lists the available Unified Call Manager Expresses (UCMEs) on the network.

IP Phones Lists the discovered Cisco IP phones on the network.

Gatekeepers Lists the discovered Cisco gatekeeper devices on the network.

Unity Devices Lists the discovered Cisco unity devices on the network.

Views for Cisco IP Telephony

For more information about workspaces:

Views for Nortel IP Telephony

Requires HP Network Node Manager iSPI for IP Telephony Software (NNM iSPI for IP Telephony) --
click here for more information.
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The following views are available in the Nortel IP Telephony workspace. You can view this workspace
only after installing the NNM iSPI for IP Telephony.

To check that the NNM iSPI for IP Telephony is installed:

1. Select the Help→ System Information in the menu toolbar.

2. In the System Information popup, go to the Extensions tab. If you can see iSPI for IP
Telephony under the HP NNM iSPI Software Deployed section, the NNM iSPI for IP Telephony is
installed.

Click Help→ Help for NNM iSPIs→ IP Telephony Online Help for an explanation about these views
added by the NNM iSPI for IP Telephony.

Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.

View Title Description

Call Servers Lists the Nortel Call Servers discovered on the network.

Signaling Servers Lists the Nortel Signaling Servers discovered on the network.

IP Phones Lists the Nortel IP phones discovered on the network.

Media Gateways Lists the Nortel Media Gateways discovered on the network.

Views for Nortel IP Telephony

For more information about workspaces:

Views for Avaya IP Telephony

Requires HP Network Node Manager iSPI for IP Telephony Software (NNM iSPI for IP Telephony) --
click here for more information.

The following views are available in the Avaya IP Telephony workspace. You can view this workspace only
after installing the NNM iSPI for IP Telephony.

To check that the NNM iSPI for IP Telephony is installed:

1. Select the Help→ System Information in the menu toolbar.

2. In the System Information popup, go to the Extensions tab. If you can see iSPI for IP
Telephony under the HP NNM iSPI Software Deployed section, the NNM iSPI for IP Telephony is
installed.
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Click Help→ Help for NNM iSPIs→ IP Telephony Online Help for an explanation about these views
added by the NNM iSPI for IP Telephony.

Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.

View Title Description

Call Controllers Lists the Avaya Call Controllers discovered on the network.

IP Phones Lists the Avaya IP phones discovered on the network.

Media Gateways Lists the Avaya Media Gateways discovered on the network.

Views for Avaya IP Telephony

For more information about workspaces:

Views for Microsoft IP Telephony

Requires HP Network Node Manager iSPI for IP Telephony Software (NNM iSPI for IP Telephony) --
click here for more information.

The following views are available in the Microsoft IP Telephony workspace. You can view this workspace
only after installing the NNM iSPI for IP Telephony.

To check that the NNM iSPI for IP Telephony is installed:

1. Select the Help→ System Information in the menu toolbar.

2. In the System Information popup, go to the Extensions tab. If you can see iSPI for IP
Telephony under the HP NNM iSPI Software Deployed section, the NNM iSPI for IP Telephony is
installed.

Click Help→ Help for NNM iSPIs→ IP Telephony Online Help for an explanation about these views
added by the NNM iSPI for IP Telephony.

Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.
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View Title Description

Lync Sites Lists the Lync sites discovered on the network.

Servers Lists the servers discovered from all the server pools associated with the Lync
server on the network.

Gateways Lists the gateways discovered on the network.

Lync End Users Lists the end users discovered on the network for the Lync Server.

End User Groups Lists the end user groups discovered on the network for the Lync Server.

Sites Lists the sites defined by the iSPI administrator.

SIP Trunck
Configurations

Lists the SIP trunks discovered on the network.

Dial Plans Lists the dial plans discovered on the network.

Voice Routes Lists the voice routes discovered on the network.

Voice Policies Lists the voice policies discovered on the network.

Views for Microsoft IP Telephony

For more information about workspaces:

Views for MPLS

Requires HP Network Node Manager iSPI for MPLS Software (NNM iSPI for MPLS) -- click here for
more information.

If you are on a service provider's team, the NNM iSPI for MPLS.helps your team ensure that customer
obligations are met. The following views are available in the MPLS workspace. You can view this
workspace only after installing the NNM iSPI for MPLS.

To check that the NNM iSPI for MPLS is installed:

1. Select the Help→ System Information in the menu toolbar.

2. In the System Information popup, go to the Extensions tab. If you can see iSPI for MPLS under
the HP NNM iSPI Software Deployed section, the NNM iSPI for MPLS is installed.

Click Help→ Help for NNM iSPIs→ iSPI for MPLS Help for an explanation about these views added by
the NNM iSPI for MPLS.

Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.
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l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.

View Title Description

LSR Inventory Lists all the MPLS-enabled routers managed by the NNM iSPI for MPLS.

L3 VPN Inventory Lists all available Level 3 (L3) virtual private network (VPNs) on the network.

MVPN Inventory Lists all available multicast virtual private networks (MVPNs) on the network.

VPLS VPN Inventory Lists all available Virtual Private LAN Service (VPLS) virtual private networks
(VPNs) on the network.

VPWS VPN Inventory Lists all available Virtual Private Wire Service (VPWS) virtual private networks
(VPNs) on the network.

Pseudowire
VC Inventory

Lists all available Pseudowire Virtual Circuits (VCs) on the network.

TE Tunnel Inventory Lists all available Traffic Engineering (TE) tunnels on the network.

Monitored LSP
Inventory

Lists all monitored MPLS Label Switched Paths (LSPs) on the network.

SDP Inventory Lists all available telecommunications service delivery platforms (SDPs) on the
network

Views for MPLS

For more information about workspaces:

Views for IP Multicast

Requires HP Network Node Manager iSPI for IP Multicast Software (NNM iSPI for IP Multicast) -- click
here for more information.

The following views are available in the IP Multicast workspace. You can view this workspace only after
installing the NNM iSPI for IP Multicast.

To check that the NNM iSPI for IP Multicast is installed:

1. Select the Help→ System Information in the menu toolbar.

2. In the System Information popup, go to the Extensions tab. If you can see IP Multicast SPI
under the HP NNM iSPI Software Deployed section, the NNM iSPI for IP Multicast is installed.

Click Help→ Help for NNM iSPIs→ iSPI for IP Multicast Help for an explanation about these views
added by the NNM iSPI for IP Multicast.

Note: You will see some or all of the workspaces and views described, depending on several
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factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.

View Title Description

IP Multicast Nodes Lists multicast-enabled nodes on the network.

IP Multicast Interfaces Lists PIM interfaces on the network.

IP Multicast Flows Lists multicast traffic flows on the network.

Views for IP Multicast

For more information about workspaces:

Views for Quality Assurance

Requires HP Network Node Manager iSPI Performance for Quality Assurance Software (NNM iSPI
Performance for Quality Assurance) -- click here for more information.

The following views are available in the Quality Assurance workspace. You can view this workspace only
after installing the NNM iSPI Performance for QA.

To check that the NNM iSPI Performance for QA is installed:

1. Select the Help→ System Information in the menu toolbar.

2. In the System Information popup, go to the Extensions tab. If you can see NNM iSPI Performance
for Quality Assurance under the HP NNM iSPI Software Deployed section, the NNM iSPI
Performance for QA is installed.

Click Help→ Help for NNM iSPIs→ iSPI Performance for QA Help for Operators for an explanation
about these views added by the NNM iSPI Performance for Quality Assurance

Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.
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View Title Description

Probes Lists all quality assurance probes discovered on the network.

Probes Critical Lists all quality assurance probes that are in critical condition.

Probes Threshold
Exceptions

Lists all quality assurance probes that experienced threshold violation.

Probes Baseline
Exceptions

Lists all quality assurance probes that experienced baseline exceptions.

QoS Interfaces Lists all discovered interfaces for which the QoS Policies are configured.

QoS Policies Lists all QoS policies that are configured on interfaces.

QoS Actions Lists details of QoS Actions that are applied to interfaces based on
particular traffic flows and policies.

QoS Interfaces Threshold
Exception

Lists QoS interfaces for which any of the actions crossed the threshold.

QoS Actions Threshold
Exceptions

Lists QoS actions that crossed the threshold.

Ping Latency Pairs Lists ping latency pairs configured by the iSPI administrator.

QA Groups Lists QA groups configured by the iSPI administrator.

Views for Quality Assurance

For more information about workspaces:

Views for Traffic Analysis

Requires HP Network Node Manager iSPI Performance for Traffic Software (NNM iSPI Performance
for Traffic) -- click here for more information.

The following views are available in the Traffic Analysis workspace. You can view this workspace only
after installing the NNM iSPI Performance for Traffic.

To check that the NNM iSPI Performance for Traffic is installed:

1. Select the Help→ System Information in the menu toolbar.

2. In the System Information popup, go to the Extensions tab. If you can see NNM iSPI Performance
for Traffic under the HP NNM iSPI Software Deployed section, the NNM iSPI Performance for
Traffic is installed.

Click Help→ Help for NNM iSPIs→ NNM iSPI Performance for Traffic for an explanation about these
views added by NNM iSPI Performance for Traffic.
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Note: You will see some or all of the workspaces and views described, depending on several
factors:

l Your assigned NNMi Security Group Mapping.

l The HP Network Node Manager i Smart Plug-in software currently installed.

l Your NNMi administrator can integrate other applications into NNMi. Therefore, you might see
things that are not described in the NNMi online help. Contact your NNMi administrator if you
have questions about any additional items that are not described.

View Title Description

Traffic Reporting Nodes Lists the nodes that host flow collector interfaces that are capable of
exporting traffic data.

Threshold Exceptions
Reporting Nodes

Lists traffic data-reporting nodes that experienced threshold
exceptions.

Traffic Reporting
Interfaces

Lists the flow collector interfaces that are capable of exporting traffic
data.

Threshold Exceptions
Reporting Interfaces

Lists traffic data-reporting interfaces that experienced threshold
exceptions.

Traffic Sites Lists the sites defined by the iSPI administrator using the NNM iSPI
Performance for Traffic Configuration Console.

Views for Traffic Analysis

For more information about workspaces:
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Chapter 6: Using Views to Display Data
A view is the primary mechanism for displaying data. In the console, many views are available to help
you visualize your network.

View Type Strength

Table Views Present summary information for a list of objects in a sorted order. Examples include:
viewing a list of incidents sorted by Status and filtered by Lifecycle State.

Map Views Display graphical relationships among objects.

Dashboard
Views

Display at-a-glance data in the form of panels.

Type of Views in the NNMi Console

To access a view, select a workspace and then click the view that you want to display. Some views are
also accessible from the console's Actions menu. See "Using Actions to Perform Tasks" on page 175 for
more information.

You can also right-click any object in a table or map view to access the items available within the
Actions menu.

Note: Some NNMi users can delete nodes and other objects from the NNMi database (depending on
the assigned NNMi Role). Any node that has been deleted appears as a transparent icon to all NNMi
users until their map is refreshed using the Refresh icon. After Refresh, the deleted node is
removed from the map. NNMi does not automatically refresh the connectivity or set of nodes in a
map view, except on the Initial Discovery Progress and Network Overview maps.

From a view, you can:

l "Select Multiple Objects" on the next page

l "Refresh a View" on page 58 ( )

l "Refresh Node Status on a Map" on page 114 ( )

l "Stop Periodic Refresh of a View" on page 66 ( )

l "Using the View Toolbars" on page 160 to Display a View in a New Window ( )

l "Invoke Actions" on page 12

Depending on the NNMi Role to which you are assigned, you may or may not be allowed to create or
delete instances of some objects from the view. See Help→ Help for Administrators for more
information.

Related Topics

"Use Dashboard Views" on page 58

"Use Table Views" on page 63

"Use Map Views" on page 85
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Select Multiple Objects
You can select or deselect multiple objects when using a table or map view. This feature is useful when
you want to access details or invoke an action on multiple objects, such as nodes, IP addresses, or
interfaces.

Multiple Objects in Table Views

Tip: Look in the status bar of each table view to see the number of objects currently selected as
well as the total number of objects in the view.

To select multiple objects in a table view:

Press Ctrl-Click to select the row for each object you want to select.

To de-select an object in a table view:

Re-select the row for each object you want to de-select.

Multiple Objects in Map Views

To select multiple objects in a map view:

Do one of the following:

l Use Ctrl-Click to select each object of interest on the map.

l Left-click the mouse and drag the cursor over the area of the map you want to select. When you use
this method, NNMi indicates the selection area using a dotted line (or rubber band) as shown in the
following example:

Each object you select changes to indicate it has been selected.

To de-select an object in a map view:

Re-select an object of interest on the map.

Each object you de-select returns to normal on the map.
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Related Topics

"Select all Rows in a Table" on page 65

Refresh a View
You can manually refresh a view at any time so that you are viewing the latest set of information. You
cannot change the automatic refresh rate that was set by NNMi for each view.

To perform view Refresh, do one of the following:

l Display any view, then select the View → .Refresh menu item.

l To refresh a table view, click the  Refresh icon in the table view.

The table view status bar displays the refresh rate and whether the refresh rate is enabled or
disabled. (If disabled, clicking the Refresh icon enables periodic refresh.)

l To refresh a map view, click the  Refresh icon in the map view toolbar to update changes in node
placement, nodes added, and nodes deleted.

To refresh the status of nodes on a map, see "Refresh Node Status on a Map" on page 114.

Related Topics

"Stop Periodic Refresh of a View" on page 66

Use Dashboard Views
NNMi includes dashboard views, which, depending on the dashboard type, can contain multiple panels of
data pertaining to the entire network, a specific object (for example, a node or interface), or a group of
objects (such as a Node Group or Interface Group).

Dashboard views provide at-a-glance information, allowing you to easily compare and quickly isolate the
information you need. Dashboard panels can contain tables and charts, some of which might be
customizable. See "Customize a Dashboard View" on the next page.

There are two types of dashboard views:

l "Views available in the Dashboards Workspace" on page 25:
These views contain information scoped to the entire set of objects managed by this NNMi
management server, constrained by the Security Groups to which the logged-in user belongs.

l "Dashboard Views based on an Object" on the next page:
These views are scoped to a selected object. These are also further scoped by the Security Groups to
which the logged-in user belongs.

For more information about dashboards:

Launch a Dashboard View from the Dashboard
Workspace
To launch a dashboard view from the Dashboards workspace:
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1. From the workspace navigation panel, click the Dashboards workspace.

2. Select the desired dashboard view. See "Views available in the Dashboards Workspace" on page 25.

For more information about dashboards:

Dashboard Views based on an Object
Object-based dashboard views include a wealth of information about the selected object. The
dashboard view presents at-a-glance information, allowing you to easily compare and quickly isolate
the information you need to investigate and identify network problems:

l Dashboard panels can contain graphs, gauges, maps, and tables.

l Smart Plug Ins (iSPIs) add more information to the Dashboards, for example performance data might
also be displayed. See "About the Smart Plug Ins (iSPIs)" on page 7.

There are multiple ways to "Launch an Object-based Dashboard View" below.

l For more information about dashboards:

Launch an Object-based Dashboard View
There are multiple ways to access an object-specific Dashboard view:

l Table views: Right-click any row in a table and select Open Dashboard.

l Map views: Right-click any map object and select Open Dashboard.

l Form's Analysis panel: Click any underlined item in a chart's legend to launch a customized Dashboard
view specific to that selected object.

l Dashboard panels: Click any underlined item in a chart's legend to launch a customized Dashboard
view specific to that selected object.

Smart Plug Ins (iSPIs) add more information to the Dashboards, for example performance data for
Nodes and Interfaces. See "About the Smart Plug Ins (iSPIs)" on page 7.

Tip: After you display a dashboard, you can return to the previous screen using the breadcrumbs in
the title bar.

For more information about dashboards:

Customize a Dashboard View
Some panels in Dashboard views can be filtered for a certain time period by using the Time Filter.

Drop-down in the top right corner of the
Dashboard view:

Fine-tune bar:
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Note: This Time Filter drop-down does
not appear in Dashboard views when
none of the panels support time
filtering.

All panels that acknowledge the Time Filter setting display data according to the currently selected
period in the Time Filter drop-down at the top of the Dashboard view and have the  icon on the top
right corner of their panel toolbar:

By default, these panels display data for the last four hours.

You can customize a dashboard view in the following ways:

l "Customize Charts" below

l "Minimize or Restore Dashboard Panels" on page 63

For more information about dashboards:

Customize Charts

Certain dashboard panels display customizable area, bar, line, or scatter charts. Change the chart type
by clicking one of the controls provided in the upper-right portion of the panel (choices might include
area, bar, line, and scatter):
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To customize a chart, do the following:

Tip: Click an underlined item in the chart Legend to launch a new Dashboard specific to that object.

l Click the checkmarks in the chart Legend to show or hide a subset of objects:

l Click a color tile in the chart Legend to instantly display only one specific object:

l Hover the cursor:

l Over the component list to instantly view data for one particular component.

l Over the chart to display a particular value at a particular time.
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l Smooth the appearance of a chart by clicking and dragging the button in the Smoother control.

l Isolate the view to a particular timeframe by clicking and dragging the buttons on the slider beneath
the chart under the time captions:

For more information about dashboards:
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Minimize or Restore Dashboard Panels

Minimize a dashboard panel by clicking the  button available in the upper-left corner of a given
panel's title bar.

Restore a dashboard panel by clicking the  button available in the upper-left corner of a given panel's
title bar.

For more information about dashboards:

Use Table Views
Table views display data in tabular format. Each row displays data about one object.  If there are more
rows than fits on a single screen, you can scroll through the table view using the scroll bar.

If a table contains more rows than the maximum limit set for a table, filter your table view to reduce the
number of rows. See "Using the View Toolbars" on page 160 for more information about how NNMi
indicates the table has exceeded the maximum limit specified. See "Filter a Table View" on page 67 for
information about how to filter a table view.

From a table view, in addition to the tasks accessed with the view display panel toolbar, you can perform
the following tasks:

l "Resize a Column" on the next page

l "Hide a Column" on the next page

l "Sort Column Data " on page 65

l "Filter a Table View" on page 67

l "Restore Table Defaults" on page 82

l "Export Table Information" on page 83

l "Invoke Actions" on page 12

l "Access Object Information (Forms and Analysis Pane)" on page 12

The following customizations are saved across browser sessions:

l Column width

l Hidden columns

l Sort column and order

l Column filters

l Quick filter value

l Node or interface group filter

l Time period filter (for incidents)
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See "Limits to View Settings" on page 84 for more information about the number of tables that have
customizations that can be stored.

Resize a Column
You can resize columns using your mouse.

To resize a column in the table:

1. Mouse over the edge of the column until you see a ↔ resize icon.

2. Drag the column edge to the width you want.

Related Topics

"Hide a Column" below

"Sort Column Data " on the next page

Hide a Column
If you find you no longer want to include a column of information in your view, you can hide a specified
column.

To hide a table column:

1. Right-click the column of interest.

2. Select Visibility.

The list of column names appears.

3. Click to clear the check box that precedes the name of the column you want to hide.

Related Topics

"Display a Hidden Column" below

"Resize a Column" above

"Sort Column Data " on the next page

Display a Hidden Column
If you want to display a hidden column.

To display a hidden table column:

1. Right-click the column of interest.

2. Select Visibility.

The list of column names appears.

3. Click to check the check box that precedes the name of the column you want to display.

Related Topics

"Hide a Column" above
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"Resize a Column" on the previous page

"Sort Column Data " below

Select all Rows in a Table
If you want to select all rows in a table.

To select all rows in a table:

1. Select any row in the table.

2. Do one of the following:

l Press Ctrl-a.

l Right-click any row in the table view, and select Select All.

3. The table view data appears highlighted.

Related Topics

"Filter a Table View" on page 67

"Hide a Column" on the previous page

"Resize a Column" on the previous page

"Restore Table Defaults" on page 82

Sort Column Data 
By sorting columns, you can get the most important information at the top of your table. For example,
at times you might want to view all critical nodes. At other times, you might need to find node contact
information.

To sort by columns:

1. Right-click the column heading or data cell on which you want to sort.

2. To sort the column in ascending order, select Sort:→ Ascending

3. To sort the column in descending order, select Sort:→ Descending

When sorting column data, note the following:

l You can click the column header to initiate a sort on the column values. Clicking the column heading
again, reverses the sort direction.

l HP Network Node Manager i Software Smart Plug-ins (iSPIs) might provide table views in which
sorting is disabled for one or more columns.

l Sorting tables that contain large amounts of data (for example, viewing all interfaces or incidents),
can sometimes result in slow response times. In this case, it is better to first filter the table
information so that it contains only the values of interest before performing your sort.

More About Sorting

When sorting table columns, note the following:
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l You can sort on only one column heading at one time.

l Capital letters are sorted separately from lowercase.

Note: The Assigned To column in incident views is sorted in alphabetical order according to the
language locale that is set for the NNMi management server. When determining alphabetical
order, NNMi uses the user display name rather than the actual login name and does not sort
capital letters separately from lowercase. If you are an NNMi administrator, you can set the
language locale for the sort order using the server.properties file. See the "Maintaining
NNMi" chapter of the HP Network Node Manager i Software Deployment Reference at
http://h20230.www2.hp.com/selfsolve/manuals for more information. The default sort locale
value is English (en_US).

l NNMi sorts some table columns using lexicographical ordering. This might produce unfamiliar orders
for strings such as Object IDs that contain numbers. For example you might expect the following
order when sorting the sysObjectID data type:

l 1.3.6.1.4.1.1

l 1.3.6.1.4.1.3

l 1.3.6.1.4.1.20

Using lexicographical ordering, these system object ID values are ordered as follows:

l 1.3.6.1.4.1.1

l 1.3.6.1.4.1.20

l 1.3.6.1.4.1.3

l Some table columns, such as Status and ifType, display data types which have a natural sort order
that is distinct from an alphabetical order. When sorting these columns, the values are sorted
according to a natural or pre-determined order rather than alphabetically. For example when sorting
the Status column, you always see the following order (ascending) or the reverse (descending):
Critical, Major, Minor, Warning, Unknown, Disabled, Normal, and No Status.

l Your sort choices are saved across user sessions.

Related Topics

"Filter a Table View" on the next page

"Hide a Column" on page 64

"Resize a Column" on page 64

"Restore Table Defaults" on page 82

"Select all Rows in a Table" on the previous page

Stop Periodic Refresh of a View
You can manually stop the periodic refresh of the group of items displayed in a table view at any time.
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Note: The status of this group of objects is always updated on a regular basis, you are only
stopping updates based on network objects being added or deleted from the NNMi database.

NNMi's status bar displays the refresh rate and whether the refresh rate has been disabled.

To stop the periodic refresh of a table view:

1. In the view toolbar, click the  Stop Periodic Refresh icon. The following message displays in the
Status Bar at the bottom-right corner of the table:

2. If you want to restart the refresh rate, click the  Refresh icon in the view toolbar. The following
message displays in the Status Bar at the bottom-right corner of the table:

Note: You cannot change the refresh rate. NNMi sets that default rate for each view.

Related Topics

"Refresh a View" on page 58

Filter a Table View
When using table views, you can reduce the amount of information displayed by filtering a view using
one of the object's attribute values. For example, you can access only those incidents that have a Status
of Critical, or only those incidents that have a Description that is Interface Down.

Filtering a table view is also useful to reduce the number of rows when a table contains more rows than
the maximum limit set for a table. See "Using the View Toolbars" on page 160 for more information
about how NNMi indicates the table has exceeded the maximum limit specified.

When a view is first displayed, it displays a set of filtered columns based on the view definition provided
by NNMi.

Note: The view status bar indicates if one or more filters have been set for the view. FILTER:ON
indicates that one or more filters have been set. These are filters that you can modify. In some
views, NNMi provides factory set filters that cannot be changed. For example, the My Open
Incidents view is filtered on the Assigned To attribute, which cannot be changed. FILTER:OFF
indicates no modifiable filters have been set for the view. These views might have factory set
filters.

When specifying filters, you can perform the following tasks:

Drop-Down List Selection Filters

l "Filter Tables by Node or Interface Group" on page 69

l "Filter by Time Period (Incident Views Only)" on page 71

Column Selection Filters

l "Filter by Attribute Value" on page 71

l "Modify a Table View Filter" on page 77

l "Remove a Filter" on page 80
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l "Restore Default Filters" on page 81

l "Display Current Filter Settings" on page 81

When using filters, note the following:

l You can filter on multiple table columns. The resulting filter is a logical AND of the filters for all of the
columns.

l HP Network Node Manager i Software Smart Plug-ins (iSPIs) might provide table views in which
filtering is disabled for one or more columns.

l NNMi matches to the milliseconds when filtering on columns that represent time values (for example,
Last Occurrence). Therefore, only those times that match to the milliseconds are included in your
view. Try using the less than or equal or greater than or equal filter options to include a wider range
of time values.

l NNMi restricts certain filter operations or options per data type. Only the filter options that apply to
the attribute data type appear. The data types and valid filter options are described in the table
below.

l A different subset of these filter options appears depending on whether you are clicking a data cell, a
column header, or a blank row. A data cell filter menu includes filters that use the value of the
selected data cell.

Data Type Valid Filter Options

All data types Equals this value

Not equal to this value

See "Filter by Attribute Value" on page 71 for more
information.

Text (String)

Numeric

Enumerated List

IP Address

Date and Time

Create Filter...

Boolean data types Is true

Is false

Numeric (Integer, IP address, and
date)

Greater than or equal to this value

Less than or equal to this value

See "Filter by Attribute Value" on page 71 for more
information.

Filter Options Available
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Data
Type

Valid Filter Options

Group
Filter

Provides a drop-down menu in the view display panel toolbar of the node and interface
groups available to you.

See "Filter Tables by Node or Interface Group" below  for more information about group
filters.

Quick
Filter

Provides a drop-down menu in the view display panel toolbar of all of the possible values for
an attribute. These drop-down menus are provided for table views that include "by" in the
view name.

Time
Period
Filter

Provides a drop-down menu in the view display panel toolbar in incident views. This filter lists
a variety of time periods for which you can filter your incident views. Possible values
include: Last 5 minutes, Last Hour, Last 8 Hours, Last Day, Last 3 Days, Last Week, Last
Month, and All.

See "Filter by Time Period (Incident Views Only)" on page 71 for more information.

Addtional Filter Options Available

Filter Tables by Node or Interface Group

NNMi lets you filter your table views by node or interface group. For example, you might want to view all
of the important Cisco routers, or all of the Voice-Over-IP interfaces within your network.

Your NNMi administrator creates these groups. They are listed in a "group selector" drop-down menu
list on the view toolbar as shown below:

Node Group filters are available for: 

l Node views

l Interface views

l IP address views

l Incident views

l Node Sensor views

l Physical Sensor views

Interface Group filters are available for:

l Interface views

l IP Address views

l Card views

To filter a view by Node or Interface Group:

1. Navigate to the view of interest.

a. From the workspace navigation panel, select the workspace that contains the view you want to
use; for example, Inventory.
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b. Select the view of interest; for example, Interfaces.

2. In the group selector drop-down list, select the Node Group or Interface
Group you want to use as a filter.

When using Node Group or Interface Group filters, note the following:

l By default, table views are not filtered by Node or Interface Group.

l If a view can be filtered by both Node Group and Interface Group, the selection box lists the Node
Groups first, followed by the Interface Groups. Each list appears in alphabetical order.

l When the filter is applied, the view automatically refreshes to show the appropriate set of objects.

l If you set a Node Group or Interface Group filter, NNMi combines the group filter with any other
filters using the AND Boolean operator.

l To clear the group filter, return the selection value to "<Set node group filter>" or "<Set node or
interface group filter>".

Related Topics

"Filter by Attribute Value" on the next page

"Modify a Table View Filter" on page 77

"Remove a Filter" on page 80

"Restore Default Filters" on page 81

"Display Current Filter Settings" on page 81

About Node and Interface Groups

When monitoring your network, you might be interested in only viewing information for a particular set
of nodes or interfaces. Your network administrator can group sets of nodes or interfaces into node or
interface groups. An example Node Group could be all important Cisco routers, or all routers in a
particular building. As another example, all interfaces used for Voice-Over-IP might be grouped together
in your network.

Your administrator configures Node Groups based on any of the following:

l Vendor or model SNMP object identifiers.

l Specific devices identified by name or IP address.

l Devices identified with wildcard characters to define a Node Group. These groups might be based on
a naming strategy that is set in place for your organization.

Note: Node Groups can also control how NNMi monitors network devices. For example, your
administrator might configure each group to have a different health monitoring interval.

You can display the definition of a group:

l Node Group definitions

a. From the workspace navigation panel, select the Inventory workspace.

b. Select the Node Groups view.

c. Double-click the row representing the Node Group.
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d. The Node Group form displays.

e. When finished, click the  Close icon.

l Interface Group definitions

a. From the workspace navigation panel, select the Inventory workspace.

b. Select the Interface Groups view.

c. Double-click the row representing the Interface Group.

d. The Interface Group form displays.

Interface group definitions match the way your team identifies important network devices. Each
interface group can include one or more interface-type specifications (based on industry-
standard IANA ifType-MIB variables).

e. When finished, click the  Close icon.

Special Actions are provided for Node Groups and Interface Groups. See Using Actions to Perform Tasks.

Filter by Time Period (Incident Views Only)

Incident views enable you to filter your view by time period. Filtering using the time period filter lets you
focus on the most recent incidents of interest. The available time periods include:

l Last 5 Minutes

l Last Hour

l Last 8 Hours

l Last Day

l Last 3 Days

l Last Week

l Last Month

l All

Note: A month is defined as 31 days.

Filter by Attribute Value

When specifying filters based on attribute (column) values, some filter options require that you specify
the value by selecting the value in an object instance and some require that you open a Create Filter...
dialog to specify the value. You can also specify a filter based on whether an attribute contains a value.

l "Select Filter Values" below

l "Create a Filter to Specify Values" on page 73

l "Use Null Value Filters" on page 76

Select Filter Values

The following filter options require an attribute value as the basis for the filter.
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Note: When using the filter options listed below, first right-click the value in the table on which you
want to filter.

Filter Option Description

Equals this value NNMi displays only instances that contain the attribute value you specify.

Not equal to this
value

NNMi displays only instances that have an attribute value that does NOT
contain the value specified.

You can specify multiple values for this filter; but can only supply one value
each time you select this option.

Note: For certain attributes, this option can also filter values that are
"empty" or null.

Greater than or equal
to this value

NNMi displays only instances that contain the attribute values that are
greater than or equal to the value you specify.

Less than or equal to
this value

NNMi displays only instances that contain the attribute values that are less
than or equal to the value you specify.

Is true NNMi displays only instances that have an attribute value that contains the
value true.

Is false NNMi displays only instances that have an attribute value that contains the
value false.

Filter Settings

You can change a filter at any time. NNMi saves filters per user so that the filters you specify are
maintained during subsequent user sessions. See "Limits to View Settings" on page 84 for information
about the number of tables that have customizations that can be saved based on your web browser.
See "Restore Table Defaults" on page 82 for information about how to remove table view
customizations.

To filter your view by selecting an attribute value in the table:

1. Right-click the attribute value on which you want to base your filter.

2. Select one of the following filter options:

l Equals this value

l Not equal to this value

l Greater than or equal to this value

l Less than or equal to this value

l Is true

l Is false
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NNMi displays a table view of all instances that have been selected based on the filter option and
attribute values you specified or selected.

Each filtered column is indicated using the filter icon.

Related Topics

"Use Null Value Filters" on page 76

Create a Filter to Specify Values

NNMI enable you to provide attribute values on which you want to filter. You can provide attributes
values by creating a filter for any of the following types of values:

l Text (String)

l Numeric

l Enumerated List

l IP Address

l Date and Time

To filter information by specifying one or more values:

1. Right-click the column or attribute on which you want to filter.

2. Select Create filter...

NNMi displays the Filter Dialog that is appropriate for the selected column's data type.

3. In the Create Filter ... Dialog displayed:

a. Select a Filter Option (see Filter Option tables) .

b. Specify one or more valid values (see Valid Filter Values)

If your NNMi administrator is using Lightweight Directory Access Protocol (LDAP) to store user
name information, NNMi shows the configured display name in the Incident Assigned To
column, but internally stores the user name that identifies the user account. To specify a filter
for the Incident Assigned To column, do one of the following:

o Specify the user name as the filter value.

o Right-click the Assigned To on which you want to filter. Then, select Filter > Equals this
value or Filter > Not equal to this value. NNMi creates the filter using the stored user
name value.

If you are an NNMi administrator, see the "Maintaining NNMi" chapter in the HP Network Node
Manager i Software Deployment Reference for more information about configuring the
Incident Assigned To display name.

4. Click Apply.

NNMi displays a table view of all instances that have been selected based on the filter option and
attribute values you specified or selected.

Each filtered column is indicated using the filter icon.
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Filter
Option

Description

starts
with

NNMi displays only instances that have an attribute value that starts with the text string
value specified.

Use this option when you are looking for an entry that begins with a specific string value.
For example if all of your Cisco devices started with the text string "Cisco", and you wanted
to find all Cisco devices, you could use the value string "Cisco".

contains NNMi displays only those instances that have an attribute value that contains the text
string value you enter.

You can use the wildcard character ('*') to match one or more characters within the
contains value. For example, c*m matches the following values:

3com9000

callmgr1

matches NNMi displays only those instances that have an attribute value that matches the text
string value you enter.

Use the question mark (?) to match one character.

Use the asterisk (*) as a wildcard character to match zero or more characters.

less
than or
equal to

NNMi performs an alphabetical (lexicographical) comparison and displays all text string
values that are before the text string value you enter.

greater
than or
equal to

NNMi performs an alphabetical (lexicographical) comparison and displays all text string
values that are after the text string value you enter.

Text (String) Filter Options

Filter Option Description

equals NNMi displays only instances that contain the numeric value or values you specify.

not equals NNMi displays only instances that have an attribute value that does NOT contain the
numeric value or values specified.

Note: For certain attributes, this option can also filter values that are "empty" or
null.

greater than
or equal to

NNMi performs an alphabetical (lexicographical) comparison and displays all text
string values that are after the text string value you enter.

less than or
equal to

NNMi displays all values that are less than or equal to the numeric value you enter

Numeric Filter Options
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Filter
Option

Description

equals NNMi displays only instances that contain the value or values you select.

not
equals

NNMi displays only instances that have an attribute value that does NOT contain the
value or values you selected.

Note: For certain attributes, this option can also filter values that are "empty" or
null.

Enumerated List Filter Options

Filter Option Description

equals NNMi displays only instances that contain the IP Address value you specify.

range NNMi displays only instances that are within the IP Address range you specify.

is empty NNMi displays only the instances that do not have a value for this attribute.

is not empty NNMi displays only the instances that contain a value for this attribute.

IP Address Filter Options

Filter
Option

Description

on or
after

NNMi displays only instances that have date and time values that occur on or after the
date and time you specify.

on or
before

NNMi displays only instances that have date and time values that occur on or before the
date and time you specify.

between NNMi displays only instances that have date and time values that occur after the first date
and time you specify and before the second date and time you specify.

Use the between operator when you want to filter on instances that occur within a
specified hour or day.

Date and Time Filter Options

Data Type Description

Wildcards % or * means multiple characters allowed at that location.

? or _ means any single character allowed at that location.

Valid Filter Values
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Data Type Description

Text Enter the value for which you want NNMi to search. Text (string) filters are case
sensitive.

Numeric Enter the numeric value or values for which you want NNMi to search. To enter more
than one numeric value, enter a comma-separated list.

Enumerated
List

Select one or more values from the enumerated list.

IP Address Enter an IP Address or range of addresses using two IP addresses separated by a '-' or
using Classless Inter-Domain Routing (CIDR) notation:

IPv4 examples:

10.168.0.1 - 10.168.13.1

10.2.120.0/21

IPv6 examples (NNMi Advanced):

2001:d88:a00:: - 2001:d88:aff:ffff:ffff:ffff:ffff:ffff

2001:d88:0:a00::/56

Date and
Time

You must enter either a date or time or both. When entering a date only the day is
required. When entering the time only the minutes are required.

Note: NNMi uses a 24-hour clock, beginning at midnight (which is 0000 hours). For
example, 1:00 AM is 0100 hours, 2:00 AM is 0200 hours, and 11:00 PM is 2300
hours.

Valid Filter Values, continued

Related Topics

"Select Filter Values" on page 71

"Use Null Value Filters" below

Use Null Value Filters

NNMi provides the following filter options to filter your view based on whether the attribute contains a
value. These filter options appear for data types that do not require a value:

l Is not empty

l Is empty

To filter your view based on null values:

1. Right-click the column or attribute value on which you want to filter.

2. Select from the filter options described in the table below.

3. NNMi displays a table view of all instances that have been selected based on the filter option and
any attribute values you specified or selected.

Online Help: Using the Console
Chapter 6: Using Views to Display Data

HP Network Node Manager i Software (10.10) Page 76 of 196



Each filtered column is indicated using the filter icon.

You can change a filter at any time. NNMi saves filters per user so that the filters you specify are
maintained during subsequent user sessions.

Filter Option Description

Is not empty NNMi displays only the instances that contain a value for this attribute.

Is empty NNMi displays only the instances that do not have a value for this attribute.

Filter Choices

Related Topics

"Select Filter Values" on page 71

Modify a Table View Filter

You can change a filter for a table view at any time. NNMi saves filters per user so that the filters you
specify are maintained during subsequent user sessions.

To modify a filter :

1. Right-click the column or attribute on which you want to filter.

2. Select Modify filter...

Note the following:

l If a filter is not created for the selected table column, the Modify filter.... option does not
appear.

l If you have used an existing attribute value with the Not equal to this value filter, you can
select an additional attribute value and select Not equal to this value also.

l NNMi displays the filter dialog that is appropriate for the selected column's data type. If the
filter was created using the “Not equal to this value” option with the Text (String) or IP address
data type, NNMi does not include the values for the current filter.

3. In the Modify Filter ... dialog displayed:

a. Select a Filter Option (see Filter Option tables) .

b. Specify one or more valid values (see Valid Filter Values)

4. Click Apply.

NNMi replaces the previous filter with the new filter values. NNMi displays a table view of all
instances that have been selected based on the filter option and attribute values you specified or
selected.

Each filtered column is indicated using the filter icon.
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Filter
Option

Description

start
with

NNMi displays only instances that have an attribute value that starts with the text string
value specified.

Use this option when you are looking for an entry that begins with a specific string value.
For example if all of your Cisco devices started with the text string "Cisco", and you wanted
to find all Cisco devices, you could use the value string "Cisco".

contains NNMi displays only those instances that have an attribute value that matches the text
string value you enter.

You can also use a wildcard character (*) within your string value.

If a wildcard is not specified, this filter option finds those values that exactly match the
value string you enter. For example, if you wanted to find only the Cisco1 device from the
following list of values, you would use "Cisco1" as your value string:

l Cisco1

l Cisco12

l Cisco123

In this example, NNMi would not include Cisco12 and Cisco123.

matches NNMi displays only those instances that have an attribute value that matches the text
string value you enter.

Note: Do not use the asterisk (*) within your string value unless you want NNMi to
match * (asterisk).

less
than or
equal

NNMi performs an alphabetical (lexicographical) comparison and displays all text string
values that are before the text string value you enter.

Note: Not all text (string) column values include this option.

greater
than or
equal

NNMi performs an alphabetical (lexicographical) comparison and displays all text string
values that are after the text string value you enter.

Note: Not all text (string) column values include this option.

Text (String) Filter Options

Filter
Option

Description

equal NNMi displays only instances that contain the numeric value or values you specify.

not equal NNMi displays only instances that have an attribute value that does NOT contain the
numeric value or values specified.

Numeric Filter Options
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Filter
Option

Description

greater
than or
equal

NNMi performs an alphabetical (lexicographical) comparison and displays all text string
values that are after the text string value you enter.

less than or
equal

NNMi displays all values that are less than or equal to the numeric value you enter.

Numeric Filter Options, continued

Filter
Option

Description

equal NNMi displays only instances that contain the value or values you select.

not equal NNMi displays only instances that have an attribute value that does NOT contain the
value or values you selected.

Enumerated List Filter Options

Filter Option Description

equal NNMi displays only instances that contain the IP Address value you specify.

range NNMi displays only instances that are within the IP Address range you specify.

IP Address Filter Options

Filter
Option

Description

on or
after

NNMi displays only instances that have date and time values that occur on or after the
date and time you specify.

on or
before

NNMi displays only instances that have date and time values that occur on or before the
date and time you specify.

between NNMi displays only instances that have date and time values that occur after the first date
and time you specify and before the second date and time you specify.

Use the between operator when you want to filter on instances that occur within a
specified hour or day.

Date and Time Filter Options
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Data Type Description

Text Enter the value for which you want NNMi to search. Text (string) filters are case
sensitive.

Numeric Enter the numeric value or values for which you want NNMi to search. To enter more
than one numeric value, enter a comma-separated list.

Enumerated
List

Select one or more values from the enumerated list.

IP Address Enter an IP Address or range of addresses using two IP addresses separated by a '-' or
using Classless Inter-Domain Routing (CIDR) notation:

IPv4 examples:

10.168.0.1 - 10.168.13.1

10.2.120.0/21

IPv6 examples (NNMi Advanced):

2001:d88:a00:: - 2001:d88:aff:ffff:ffff:ffff:ffff:ffff

2001:d88:0:a00::/56

Date and
Time

You must enter either a date or time or both. When entering a date only the day is
required. When entering the time only the minutes are required.

Note: NNMi uses a 24-hour clock, beginning at midnight (which is 0000 hours). For
example, 1:00 AM is 0100 hours, 2:00 AM is 0200 hours, and 11:00 PM is 2300
hours.

Valid Filter Values

Related Topics

"Filter Tables by Node or Interface Group" on page 69

"Filter by Attribute Value" on page 71

"Remove a Filter" below

"Restore Default Filters" on the next page

"Display Current Filter Settings" on the next page

Remove a Filter

NNMi lets you remove a filter for a selected column at any time.

To remove a filter:

1. Right-click the column that has a filter that you want to remove.

2. Select Remove filter from the drop-down menu.

NNMi removes all existing filters that have been set for that column.
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Related Topics

"Modify a Table View Filter" on page 77

"Modify a Table View Filter" on page 77

"Restore Default Filters" below

Restore Default Filters

You can restore the default filters for a view. This option removes any filters that you have defined for
the current view.

To restore the default filter settings:

In the table toolbar, click the Restore Default Filters icon.

Note: If you are viewing a table that appears in the form, open the table in a new window using the

Show View In New Window icon, and then click the Restore Default Filters icon.

All filters are reset to the default values and any filters that you have created are removed for the
current view.

Note: You will lose any selections you have in the view.

Related Topics

"Display Current Filter Settings" below

"Remove a Filter" on the previous page

Display Current Filter Settings

To keep track of the filters you have created, you can view the filter that has been set on a column by
column basis.

To view a column's filter: 

Mouse over the column of interest.

The example below shows the filter option and the string provided for that filter:

The following table explains the symbols used for each filter option

Symbol Filter Option

<= Less than or equal to this value

>= Greater than or equal to this value

= Equals this value

NOT IN Not equal to this value

Filter Definitions
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Symbol Filter Option

IS NULL Is empty

IS NOT NULL Is not empty

LIKE Contains string...

Starts with string...

Matches string...

Filter Definitions , continued

Note: The percent sign (%) represents the wildcard character.

Related Topics

"Restore Default Filters" on the previous page

"Modify a Table View Filter" on page 77

"Modify a Table View Filter" on page 77

"Remove a Filter" on page 80

Restore Table Defaults
You can remove the types of table view customizations described in the following table. Remove
customizations when you no longer find them useful or when you reach the limit for the maximum
number of customizations that can be stored. See "Limits to View Settings" on page 84 for more
information about the number of tables that have customizations that can be stored. 

If you are concerned about reaching your table view settings limit, remove view settings for tables that
are not important.

Note: The Restore Default Filters icon does not appear on table views in forms. If you want to
clear settings from a table view that appears in a form, use the Show View in New Window icon
to open the table view in a new window and perform these operations.

What You can
Remove

How Description

Only table view
filters

From the view display
panel toolbar, select

Restore Default
Filters.

Clears all customizations to filters for the table view and
refreshes the view with the view's default filter settings.

All
customizations
for all table
views

Select View →

Restore All Default
View Settings

Clears all customizations (and cookies) for all table view
customizations. See "Limits to View Settings" on page 84 for
more information about how NNMi uses cookies to store
table view customizations.

Restore Default Table View Settings
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Related Topics

"Filter a Table View" on page 67

"Hide a Column" on page 64

"Resize a Column" on page 64

"Restore Table Defaults" on the previous page

"Select all Rows in a Table" on page 65

Export Table Information
You can export the contents of a table view for use in other applications. You can choose to export only
the rows that are selected or all of the rows in your table.

Note: You must have a minimum of Operator Level1 Role to export table information.

When printing table information, note the following:

l The first column of table information does not appear in the exported version. The contents of this
column is for selection purposes only.

l You can copy and paste the table data to other applications, such as Microsoft Excel, for additional
editing and manipulating, such as getting a list of hostnames.

To export selected table rows:

1. Select the row or rows that you want to export.

2. Right-click a selected row.

3. Select Export to CSV.

NNMi displays the Export to CSV dialog.

4. To included the table column headings in the exported data, click to check Include Column
Headings.

5. NNMi stores date and enumerated values in both localized (Jul 12, 2010 10:07 AM) and raw
(1278950859739) format. By default, NNMi exports only the localized (human readable) format for
date and enumerated values.

Select the Use Localized (Human Readable) Data option to include only the localized (human
readable) format for both dates and enumerated values.

Select the Use Raw (Computer Readable) Data option to include only the raw (computer readable)
format for both date and enumerated values.

6. In the Opening <file_name> dialog, select one of the following options.

a. Open with to view the file contents.

b. Save File to save the file to a specified file name.

To export all table rows:

1. Right-click any cell or column header with the table.

2. Click Select All.

3. Right-click a row.
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4. Select Export to CSV.

NNMi displays the Export to CSV dialog.

5. To included the table column headings in the exported data, click to check Include Column
Headings.

6. NNMi stores date and enumerated values in both localized (Jul 12, 2010 10:07 AM) and raw
(1278950859739) format. By default, NNMi exports only the localized (human readable) format for
date and enumerated values.

Select the Use Localized (Human Readable) Data option to include only the localized (human
readable) format for both dates and enumerated values.

Select the Use (Computer Readable) Raw Data option to include only the raw (computer readable)
format for both date and enumerated values.

7. In the Opening <file_name> dialog, select one of the following options.

a. Open with to view the file contents.

b. Save File to save the file to a specified file name.

Related Topics

"Filter a Table View" on page 67

"Hide a Column" on page 64

"Resize a Column" on page 64

"Restore Table Defaults" on page 82

"Select all Rows in a Table" on page 65

Limits to View Settings
NNMi automatically saves the following kinds of table view settings:

l Column width

l Hidden columns

l Sort column and order

l Filters

When customizing table views, note the following:

l All settings for each table are stored in a corresponding cookie for that table.

l The number of tables that have settings that can be saved, and the behavior when the limit is
reached depends the browser you use:

Microsoft Internet Explorer discards your oldest cookie and lets you continue creating
customizations. If you are using Microsoft Internet Explorer, the cookie limit is 48.

If you are using Mozilla Firefox, the cookie limit is 48. If you reach the 48 limit, Mozilla Firefox removes
the next to last cookie before saving the latest cookie created.

l Table view settings are specific to each operating system user. Therefore, if you log on as a different
operating system user, you will have different view settings. If you sign into NNMi as a different NNMi
user, but as the same operating system user, you will have the same view settings.
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Note: NNMi displays a warning message when your last cookie and subsequent table settings are
being saved.

You can remove the customizations for all of your tables using the View → Restore All Default View
Settings. See "Restore Table Defaults" on page 82 for more information.

Related Topics

"Restore Default Filters" on page 81

"Hide a Column" on page 64

"Resize a Column" on page 64

"Select all Rows in a Table" on page 65

Use Map Views
A map view is a powerful way to display information about your network. In a map view, nodes,
interfaces, IP address, and subnets are represented as symbols on the map. The lines between the
nodes and interfaces represent the connection or relationship between these objects.

For each symbol, a background shape indicates the type of device, such as router or switch. See "About
Map Symbols" on page 93. The color of this background shape indicates the current health of the
device. See "About Status Colors" on the next page for more information about map color values

On the maps, a foreground image is placed over the background shape. The foreground image identifies
the make and model of the network device.

You access map views from the Topology Maps and Troubleshooting workspaces. You can also open
maps from table views using the Actions menu. See "Access Maps Provided by NNMi" on page 115 and
"Using Actions to Perform Tasks" on page 175 for more information.

Tip: You can also right-click any object in a table or map view to access the items available within
the Actions menu.

Depending on the type of map you are viewing, NNMi uses additional conventions to depict other kinds
of objects on the map:

"Node Group Map Objects" on page 99

"Layer 2 Map Objects" on page 101

"Layer 3 Map Objects" on page 104

"Path View Map Objects" on page 105

Note: Some NNMi users can delete nodes and other objects from the NNMi database (depending on
the assigned NNMi Role). Any node that has been deleted appears as a transparent icon to all NNMi
users until their map is refreshed using the Refresh icon. After Refresh, the deleted node is
removed from the map. NNMi does not automatically refresh the connectivity or set of nodes in a
map view, except on the Initial Discovery Progress and Network Overview maps.

You can perform the following operations in a map view:
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l "Access Object Information (Forms and Analysis Pane)" on page 12

l "Refresh a View" on page 58

l "Change the Map Layout" on page 107

l "Adjust the Zoom Factor" on page 110

l "Pan Around the Map" on page 111

l "Set the Location of the Overview Pane" on page 112

l "Refresh Node Status on a Map" on page 114

l "Control Tool Tips Information on a Map" on page 114

If you use the Mozilla Firefox browser and have any timeout issues; for example, being prompted to click
Continue before a map appears, see "Configure Mozilla Firefox Timeout Interval" on page 5.

Related Topics

"Use Table Views" on page 63

"About Workspaces" on page 19

Understand Maps
To understand how to interpret the contents of maps provided by NNMi, you want to know the following:

• About Status Colors 86

• About Map Symbols 93

• Node Group Map Objects 99

• Layer 2 Map Objects 101

• Layer 3 Map Objects 104

• Path View Map Objects 105

About Status Colors

The color of the background shape of each map symbol conveys the most recent health status of that
Node. The color of each connection icon (the line) conveys the most recent health of communication
between the two Nodes (determined by evaluating the status of each Interface or IP address involved).
At the end of each connection line, the color of each interface icon (small square) or IP address icon
(small hexagon) also conveys its most recent health status. For example:

NNMi calculates the appropriate Status for objects:

l "Status Color for Objects" on the next page

l "Status Color for Aggregator Objects (NNMi Advanced)" on page 88

l "Status Color for Network Connections" on page 90
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Tip: NNMi's Causal Engine collects the data for calculating each object's Status value. Using the
State information collected by the State Poller as well as this additional information, the Causal
Engine calculates the Status of each Node, Interface, and SNMP agent.

l State = This value is provided by the NNMi State Poller and is always up to date for each object.

l Status = This value can run behind by the amount of time listed for Delay Processing Input in the
System Information dialog's Causal Engine tab. See System Information: Causal Engine tab and
Verify Current Status of a Device.

Status Color for Objects

NNMi displays the status color within background shapes on map objects that represent Nodes (devices)
within your network.

The following table describes the meaning of each potential status color.

Color Meaning Description

Unknown Indicates the object is unreachable and cannot be polled.

Normal Indicates there are no known problems related to the associated object.

Warning Indicates there might be a problem related to the associated object.

Minor Indicates NNMi detected problems related to the associated object that require
further investigation.

Major Indicates NNMi detected problems related to the associated object to be resolved
before they become critical.

Critical Indicates NNMi detected problems related to the associated object that require
immediate attention.

Disabled Indicates the object is administratively disabled.

No
Status

Indicates one of the following:

l NNMi's current configuration excludes this object from monitoring. The Status
is not calculated because the object is set to Not Managed/Out Of
Service/Scheduled Node Outage.

l The object has just been added to the NNMi database and the Causal Engine
has not yet calculated its health status.

Background Shape's Status Color

Related Topics

"Status Color for Aggregator Objects (NNMi Advanced)" on the next page

"Status Color for Network Connections" on page 90
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Status Color for Aggregator Objects (NNMi Advanced)

Link Aggregation protocols enable network administrators to configure a set of interfaces on a switch to
function as one. This technique of combining multiple interfaces increases bandwidth, the speed at
which data travels, and provides redundancy.

On a Layer 2 map, a thick line with a superimposed ellipse represents a Link Aggregation1 or Split Link
Aggregation2 (group of multiple Layer 2 Connections that are functioning as one). The icon representing
an Interface at either end of the thick line is an Aggregator Interface (a logical interface comprised of
many physical interfaces that are functioning as one).

Two endpoints: Three endpoints: More than three endpoints:

1Protocols used on Switches to configure multiple Interfaces (Aggregation Member Interfaces) to
function as if they were one (an Aggregator Interface). When two Aggregator Interfaces establish a
connection, that connection is an Aggregator Layer 2 Connection. The Aggregator Layer 2 Connection
appears on Layer 2 Neighbor View maps as a thick line with an Interface icon at each end (representing
the Aggregator Interface). When you double-click the thick line, it converts into multiple thin lines
representing the participating Aggregation Member Layer 2 Connections with their Aggregation
Member Interfaces at each end of the lines.
2Link Aggregation with more than two endpoints. Some vendors refer to this as Multi-Chassis Link
Aggregation, SLAG, MLAG, or MC-LAG.
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See "Layer 2 Map Objects" on page 101 for more information.

The following table describes the meaning of each potential status color for an Aggregator Interface.

Color Status Meaning

Unknown Indicates all of the participating Aggregation Member Interfaces are unreachable
and cannot be polled.

Normal Indicates all of the participating Aggregation Member Interfaces have a Status of
Normal.

Minor Indicates at least one (but not all) of the participating Aggregation Member
Interfaces has a Status of Critical.

Critical Indicates all of the participating Aggregation Member Interfaces have a Status of
Critical.

Disabled Indicates all of the participating Aggregation Member Interfaces are
administratively disabled.

No
Status

Indicates one of the following:

l NNMi's current configuration excludes all of the participating Aggregation
Member Interfaces from monitoring, so the Status is not calculated. For
example, the entire device or the Aggregator Interface is set to Not
Managed/Out Of Service/Scheduled Node Outage.

l All of the participating Aggregation Member Interfaces have just been added to
the NNMi database and the Causal Engine has not yet calculated their health
status.

Aggregator Interface Status Color

Related Topics

"Status Color for Objects" on page 87

"Status Color for Network Connections" on the next page
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Status Color for Network Connections

Map lines indicate network connections. The color of these lines indicates current status. There are
three types of lines on NNMi maps that indicate network communication paths:

l Single connection lines from one interface to another (network Layer 2 communications) or from one
address to another (network Layer 3 communications).

l Multiconnection lines save space on complex NNMi maps. The NNMi administrator configures how
many single connections dynamically condense into one thick line.

l Aggregate connection lines are thick lines with a superimposed ellipse representing a group of
multiple connections that are functioning as one.

Single Connections

The following table describes the meaning of each potential status color for a single network
connection.

Tip: Special icons within the line indicate additional information.

Color Meaning Description

Unknown Indicates that due to other network problems, the status of one interface
cannot be determined at this time.

Normal Indicates both interfaces in the connection are responding.

Warning Indicates there might be a problem with either interface.

Minor Indicates the interface on one end is not responding. The interface on the
other end is responding.

Critical Indicates neither interface or IP address is responding.

Disabled Indicates one or both interfaces are administratively disabled.

No
Status

Indicates one of the following:

l NNMi's current configuration excludes one or both interfaces from
monitoring. The Status is not calculated because the interface is set to Not
Managed/Out Of Service.

l The interface has just been added to the NNMi database and the Causal

Network Connections Status Color
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Color Meaning Description

Engine has not yet calculated its health status.

Network Connections Status Color, continued

Multiconnections

Multiconnection line: Expanded to show the group of single connections:

Note the following about multiconnection1 lines:

l No Interface or IP address icon appears at either end of the thick line.

l To view the individual connections and the associated interfaces or IP addresses within a
multiconnection, double-click the multiconnection line of interest.

l To collapse the expanded group of member connections, use the Refresh icon to refresh the map.

l To popup summary information about the multiconnection, move the mouse cursor over the
multiconnection of interest.

The following table describes the meaning of each potential status color for a multiconnection line.

Color Meaning Description

Unknown Indicates that all connections in the multiconnection have a Status of
Unknown.

Normal Indicates that all connections in the multiconnection have a Status of Normal.

Warning Indicates one of the following: 

l All connections in the multiconnection have a Status of Warning.

l All connections in the multiconntection do not have the same Status and
none of the connections have a Status of Major or Minor.

Major All connections but one in the multiconnection have a Status of Critical. One
connection has a Status of either Normal, Warning, Minor, or Major.

Multiconnections Status Color and Meaning

1A multiconnection is a thick line on a map view between two Node icons, two Node Group icons, or
between a Node icon and a Node Group icon (with no Interface icon or IP Address icon at either end of
the line). This thick line represents a set of multiple connections that have been combined to preserve
space and simplify the map. Your NNMi administrator specifies the number of connections that must
exist before NNMi condenses them into a multiconnection line (User Interface Configuration's
Multiconnection Threshold attribute). Double-click the thick line to convert it into the original set of
connections with Interface icons or IP Address icons at either end of the lines.
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Color Meaning Description

Minor Indicates all connections but one in the multiconnection are Normal. The
Status of one connection is Minor, Warning, or Critical.

Critical Indicates that all connections in the multiconnection have a Status of Critical.

Disabled Indicates that all connections in the multiconnection have a Status of Disabled.

No
Status

Indicates that all connections in the multiconnection have a Status of No
Status.

Multiconnections Status Color and Meaning, continued

Aggregate Connections (NNMi Advanced)

Thick lines with a superimposed ellipse represent Link Aggregation1 or Split Link Aggregation2 protocol
usage (a group of multiple connections that are functioning as one). The icon representing an Interface
at either end of the thick line is an Aggregator Interface (a logical interface comprised of many physical
interfaces that are functioning as one).

Two endpoints: Three endpoints: More than three endpoints:

1Protocols used on Switches to configure multiple Interfaces (Aggregation Member Interfaces) to
function as if they were one (an Aggregator Interface). When two Aggregator Interfaces establish a
connection, that connection is an Aggregator Layer 2 Connection. The Aggregator Layer 2 Connection
appears on Layer 2 Neighbor View maps as a thick line with an Interface icon at each end (representing
the Aggregator Interface). When you double-click the thick line, it converts into multiple thin lines
representing the participating Aggregation Member Layer 2 Connections with their Aggregation
Member Interfaces at each end of the lines.
2Link Aggregation with more than two endpoints. Some vendors refer to this as Multi-Chassis Link
Aggregation, SLAG, MLAG, or MC-LAG.
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The following table describes the meaning of each potential status color for an Aggregator Layer 2
Connection. See "Layer 2 Map Objects" on page 101 for more information.

Color Meaning Description

Unknown Indicates all of the participating Aggregation Member Layer 2 Connections are
unreachable and cannot be polled.

Normal Indicates all of the participating Aggregation Member Layer 2 Connections
have a Status of Normal.

Minor Indicates at least one (but not all) of the participating Aggregation Member
Layer 2 Connections has a Status of Critical.

Major All connections but one of the participating Aggregation Member Layer 2
Connections has a Status of Critical. One connection has a Status of either
Normal, Warning, Minor, or Major.

Critical Indicates all of the participating Aggregation Member Layer 2 Connections
have a Status of Critical.

Disabled Indicates all of the participating Aggregation Member Layer 2 Connections are
administratively down.

No
Status

Indicates one of the following:

l NNMi's current configuration excludes all of the participating Aggregation
Member Layer 2 Connections from monitoring, so the Status is not
calculated. For example, the entire device or the Aggregator Interfaces on
both ends of the connection are set to Not Managed/Out Of Service.

l All of the Layer 2 Connections within the Aggregator Layer 2 Connection
have just been added to the NNMi database and the Causal Engine has not
yet calculated their health status.

Aggregator Layer 2 Connection (thick line) Status Color

Related Topics

"Status Color for Objects" on page 87

"Status Color for Aggregator Objects (NNMi Advanced)" on page 88

AboutMap Symbols

Map symbols convey the following information:

l The background shape and foreground image of map icons indicate the type of device being
depicted.

l The lines between devices indicated network connections. Special icons within those lines indicate
additional information.

For more information: 

Background and Foreground
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Map symbols represent nodes or node groups. Each map symbol that represents a single node has a
background shape and a superimposed foreground image (default images are shown in the table
below). Custom foreground images might represent specific vendors and models.

Note: The NNMi administrator can customize the NNMi foreground image for each Device Profile.
Therefore, you might see foreground images that are not described in the following table. Contact
your NNMi administrator if you have questions about any additional foreground shapes.

The color of the background shape indicates the most recent health status of the device (see "Status
Color for Objects" on page 87 and "Status Color for Aggregator Objects (NNMi Advanced)" on page 88).

Background
Shape

Foreground Image \ Meaning Background
Shape

Foreground  Image \ Meaning

Hypervisor (NNMi Advanced)

The virtual machine manager in charge
of delegating various aspects from a
pool of resources to become virtual
devices.

When you double-click the hypervisor
map icon, the displayed form includes a
Hosted Nodes tab listing the virtual
devices being provided.

The virtual devices provided by the
hypervisor have a Hosted On attribute
that identifies which hypervisor provided
the resources.

 = Computer

 = Server

 = Workstation

 = Other

Note: Other includes
non-SNMP nodes.

 = ATM Switch

 = Switch

Note: (NNMi Advanced) If the map
object represents a virtual switch,
double-click opens an Interface
form (see Virtual Switch's Interface
Form).

= Gateway

 = Hub

 = Router

 = Switch-Router

 = Voice Gateway

 = Chassis
(visible when Multiple-Chassis device's

icon is expanded)

Multiple Chassis inside:

 = Computer

 = Server

 = Workstation

Multiple Chassis inside:

 = Switch

Multiple Chassis inside:

 = Switch-Router

Background and Foreground Shapes for Specific Devices

Online Help: Using the Console
Chapter 6: Using Views to Display Data

HP Network Node Manager i Software (10.10) Page 94 of 196



Background
Shape

Foreground Image \ Meaning Background
Shape

Foreground  Image \ Meaning

 = Analyzer

 = Firewall

 = Load Balancer

 = Network Appliance

 = Power Supply

 = Printer

 = Wireless Access Point

 = IP Phone

Child Node Group
(no foreground image)

Background and Foreground Shapes for Specific Devices, continued

Special Connections

The icons in the following table provide valuable information about certain connection lines between
devices within your network. There are various types of communication channels within networks. The
lines between map objects provide valuable information about both the type of connection and current
health of that connection. See "Status Color for Network Connections" on page 90 for more information.

Tip: When you click a connection line, NNMi displays the port number at each end of the selected
connection:

l Press p to toggle the port number off or on.

l Press n to toggle the device names off or on.

Icon Meaning

Used in maps to represent Point-to-Multipoint (a connection with multiple interfaces)
when NNMi detects a shared media, such as a hub or a mesh, connecting multiple
devices.Click here for an example.

If you double-click the line or the (in prior NNMi releases the icon or the
 icon), the Layer 2 Connection Form displays and the Topology Source value is FDB.

Icons for Special Connections
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Icon Meaning

Used in maps to represent Point-to-Multipoint (a connection with multiple interfaces)
Layer 3 edge connectivity across wide-area-networks (WANs).

The  icon (in prior NNMi releases the  icon) represents an unidentified set of

devices between two nodes on the map (most likely a Service Provider's network or
WAN). Click here for an example.

NNMi accomplishes this by following special rules for subnets with prefix lengths between
28 and 31. These special rules are called Subnet Connection Rules. NNMi administrators
can configure these rules.

If you double-click the line or the  icon, the Layer 2 Connection Form displays and the
Topology Source value is SUBNETCONNECTION.

Used in maps to represent IPv4 subnets. Click here for an example.

(NNMi Advanced) Used in maps to represent IPv6 subnets.Click here for an example.

Icons for Special Connections, continued
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Icon Meaning

(NNMi Advanced) In Layer 2 maps, a thick line with a superimposed ellipse represents Link
Aggregation1. See "Layer 2 Map Objects" on page 101.

(NNMi Advanced) In Layer 2 maps, the icon, in combination with the superimposed
ellipse indicates three or more endpoints participating in a Split Link Aggregation2 (also
known as SLAG mesh connection). See "Layer 2 Map Objects" on page 101.

In Layer 2 maps, these icons
indicate that the object contains
more than one Chassis.

l Click to display the entire

group of Chassis.

l  Click to close the expanded
stack.

l  Click and drag to resize the
expanded stack.

l  Save Map toolbar button. If
your NNMi role allows, click to
keep the Chassis visible when
you return to that map in the
future.

Node contains more than one chassis:

Icons for Special Connections, continued

1Protocols used on Switches to configure multiple Interfaces (Aggregation Member Interfaces) to
function as if they were one (an Aggregator Interface). When two Aggregator Interfaces establish a
connection, that connection is an Aggregator Layer 2 Connection. The Aggregator Layer 2 Connection
appears on Layer 2 Neighbor View maps as a thick line with an Interface icon at each end (representing
the Aggregator Interface). When you double-click the thick line, it converts into multiple thin lines
representing the participating Aggregation Member Layer 2 Connections with their Aggregation
Member Interfaces at each end of the lines.
2Link Aggregation with more than two endpoints. Some vendors refer to this as Multi-Chassis Link
Aggregation, SLAG, MLAG, or MC-LAG.
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Icon Meaning

Lines within the expanded object
convey special meaning:

l Known Interface installed
directly at device level.

l Known Interface installed
directly at Chassis level inside
device.

Switch contains more than one Chassis.

Switch-Router contains more than one Chassis.

(NNMi Advanced) In Layer 2 maps,
this icon represents the
hypervisor1 (virtual machine
manager) in charge of delegating
various aspects from a pool of
resources to become virtual
devices.

Here is one example:

Icons for Special Connections, continued

1The virtual machine manager in charge of delegating various aspects from a pool of resources to
become virtual devices. The delegations might be static or dynamic, depending on the manufacture's
implementation. The type of virtual machines being generated depends on the manufacturer's
implementation.
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Icon Meaning

Used in Path Views if NNMi detects a connection, but cannot verify the device's
identification (no response to SNMP), that device is indicated on the map by a the (in

prior NNMi releases the icon) cloud symbol. 

Click here for an example.

Note: In Path View maps, a black arrow or empty black circle indicates that NNMi was
not able to determine a status value because the connection or interface is not in the
NNMi database.

For more information, see "Path View Map Objects" on page 105.

(NNMi Advanced, plus HP Route Analytics Management System (RAMS) for MPLS WAN) Used
in RAMS MPLS WAN Map views. If NNMi detects an MPLS connection across the network, it
is indicated on the map by a cloud symbol. Click here for an example.

If you are an NNMi administrator, also see HP RAMS MPLS WAN Configuration (NNMi
Advanced) for more information.

Icons for Special Connections, continued

Related Topics

"Working with Objects" on page 170

Node Group Map Objects

Tip: See "Help for Operators" for more information about Node Group maps.

Node Group maps show members of a Node Group (as defined by the NNMi administrator). Each Node
Group Map shows either Layer 2 or Layer 3 information.

The map displays the status of each member, connection, and Child Node Group. To provide context for
your environment, the NNMi administrator might also add a background image (for example, a map of
North America).
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NNMi can enlarge the map symbol of any node associated with a Key Incident1. Use the Indicate Key
Incidents button in the map view toolbar (see Using the View Toolbars: Node Group Map Toolbar Icons):

(on) = When the this Node Group map opens, NNMi enlarges any objects on a Node Group map that
are Source Objects for a Key Incident2. (For example, when viewing the Node Group map, NNMi
enlarges any node on a Node Group map that has an open root cause incident associated with it.)

(off) = When the this Node Group map opens, NNMi does not indicate the objects on a Node Group
map that are Source Objects for a Key Incident3.

To view the associated incident for the node, double-click the node symbol. In the Node form, select the
Incidents tab.

Because these maps are based on Node Groups rather than connectivity, some nodes might not have
any connections on the map.

A hexagon (as shown below) indicates a Child Node Group:

A gray halo around a map icon indicates a device that is one-hop outside of the displayed Node Group
(connected to a Node Group member, but not itself a member). Not all one-hop neighbors are displayed.
Your NNMi administrator must configure the Node Group map to show one-hop neighbors if those
neighbors are members of the particular Node Group used as the filter.

See "Views Available in NNMi" on page 24 for information about the Node Group maps that NNMi
provides.

Related Topics

"About Map Symbols" on page 93

"About Status Colors" on page 86

"About Workspaces" on page 19

1Incidents with both: (1) Severity = other than Normal. (2) Correlation Nature = equal to Root Cause,
Service Impact, Stream Correlation, Rate Stream Correlation, Info, or None.
2Incidents with both: (1) Severity = other than Normal. (2) Correlation Nature = equal to Root Cause,
Service Impact, Stream Correlation, Rate Stream Correlation, Info, or None.
3Incidents with both: (1) Severity = other than Normal. (2) Correlation Nature = equal to Root Cause,
Service Impact, Stream Correlation, Rate Stream Correlation, Info, or None.
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Layer 2Map Objects

Layer 2 maps show a map view of a selected device and any connected devices within a specified
number of hops from the selected device. This is useful for understanding the switch connectivity
between devices. See "Help for Operators" for more information.

During discovery, NNMi reads the Forwarding Database (FDB) tables from Ethernet switches within a
network to help NNMi determine communication paths between network devices. NNMi searches these
FDB tables for information about discovered nodes. When an NNMi management server finds FDB
references to duplicate MAC addresses1:

l If two or more discovered nodes contain an interface associated with the same Media Access Control
(MAC) address within the same Tenant or with one of those nodes in Default Tenant and one in any
other Tenant, NNMi disregards the communication paths reported for those duplicate MAC addresses
in the FDB. This might result in missing connections on NNMi maps in network areas that include
those duplicate MAC addresses.

(NNMi Advanced - Global Network Management feature) If two NNMi management servers discover
nodes that contain an interface associated with the same Media Access Control (MAC) address, the
Global NNMi management server's maps could be missing connections that are visible on the
Regional NNMi management server's maps.

l If a single node contains multiple interfaces that have the same MAC address, NNMi gathers all
communication path information for those interfaces and displays that information on NNMi maps.

Forwarding Database (FDB) information can cause NNMi to establish wrong Layer 2 Connections in the
following cases:

l When the FDB is configured as cache and contains obsolete data.

l In network environments with hardware from a variety of vendors, when each vendor generates
different and sometimes conflicting FDB data.

Optional: NNMi administrators can configure Spiral Discovery to ignore the FDB data from one Node
Group when calculating Layer 2 Connections (the FDB data is still included in other calculations).

For example, in Layer 2 Neighbor View maps, interfaces are indicated by little squares around the
background shape of the parent node. Each interface also has a status color.  Green indicates the
interface is working properly. Red indicates the interface is down.

Connection Lines Meaning of Connection Line

Thin lines between devices indicate communication
channels between the two devices (connections). The
lines also show status color indicating the current health
of that connection. See "Status Color for Objects" on
page 87.

1The Media Access Control address (hardware address or physical address) that the factory burns into a
network adapter or device with built-in networking capability. A MAC address has six pairs of
hexadecimal digits, separated by colons or dashes. For example 02:1F:33:16:BC:55

Online Help: Using the Console
Chapter 6: Using Views to Display Data

HP Network Node Manager i Software (10.10) Page 101 of 196



Connection Lines Meaning of Connection Line

Expanded Connection:

A thick line that does not have any interface icon at both
ends is a multiconnection1.

Double-click the thick line to expand the group of
individual links.

Two endpoints:

Three endpoints:

(NNMi Advanced) Thick lines (connections) with an ellipse
around them indicate Link Aggregation2 protocols are in
use. These protocols enable network administrators to
configure a set of interfaces on a switch as one
Aggregator Interface, creating an Aggregator Layer 2
Connection to another device using multiple interfaces in
parallel to increase bandwidth, increase the speed at
which data travels, and increase redundancy.

Double-click the thick line (the Aggregator Layer 2
Connection) to open the Layer 2 Connection form for
more information.

NNMi calculates the status of the thick line (Aggregator
Layer 2 Connection) based on the status of the entire
group of Aggregation Member Layer 2 Connections. See
"Status Color for Aggregator Objects (NNMi Advanced)"
on page 88 for more information.

1A multiconnection is a thick line on a map view between two Node icons, two Node Group icons, or
between a Node icon and a Node Group icon (with no Interface icon or IP Address icon at either end of
the line). This thick line represents a set of multiple connections that have been combined to preserve
space and simplify the map. Your NNMi administrator specifies the number of connections that must
exist before NNMi condenses them into a multiconnection line (User Interface Configuration's
Multiconnection Threshold attribute). Double-click the thick line to convert it into the original set of
connections with Interface icons or IP Address icons at either end of the lines.
2Protocols used on Switches to configure multiple Interfaces (Aggregation Member Interfaces) to
function as if they were one (an Aggregator Interface). When two Aggregator Interfaces establish a
connection, that connection is an Aggregator Layer 2 Connection. The Aggregator Layer 2 Connection
appears on Layer 2 Neighbor View maps as a thick line with an Interface icon at each end (representing
the Aggregator Interface). When you double-click the thick line, it converts into multiple thin lines
representing the participating Aggregation Member Layer 2 Connections with their Aggregation
Member Interfaces at each end of the lines.
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Connection Lines Meaning of Connection Line

More than three endpoints: When the link aggregation has more than two endpoints,
NNMi depicts the link as a Split Link Aggregation1 (SLAG)
group of links.

Node:

Switch:

Switch-Router:

These icons indicate that the device contains more than

one Chassis.

l Click to display the entire group of Chassis. For
example:

l Click  to close the expanded stack.

l Click  and drag to resize the expanded stack.

l If your NNMi role allows, click the  Save Map toolbar
button to keep the Chassis visible when you return to
that map in the future.

Hypervisor (NNMi Advanced): In Layer 2 maps, this icon represents the virtual machine
manager in charge of delegating various aspects from a

1Link Aggregation with more than two endpoints. Some vendors refer to this as Multi-Chassis Link
Aggregation, SLAG, MLAG, or MC-LAG.
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Connection Lines Meaning of Connection Line

pool of resources to become virtual devices.

Here is one example of a hypervisor1:

See "Help for Operators" for more information about Layer 2 maps.

Related Topics

"About Map Symbols" on page 93

"About Status Colors" on page 86

"About Workspaces" on page 19

Layer 3Map Objects

Layer 3 maps show a selected device and its connected devices within a specified number of hops from
the selected device. This view is useful for understanding the router connectivity between devices.

For example, in Layer 3 Neighbor View maps, addresses connected to neighbors within the same subnet
are indicated by hexagons around the background shape of the parent node. Each address has a status
color. Green indicates the address is working properly. Red indicates the address is not responding. The
line between devices indicates the subnet. The subnet does not have any status:

(NNMi Advanced) IPv6 subnets are indicated by this symbol:

1The virtual machine manager in charge of delegating various aspects from a pool of resources to
become virtual devices. The delegations might be static or dynamic, depending on the manufacture's
implementation. The type of virtual machines being generated depends on the manufacturer's
implementation.

Online Help: Using the Console
Chapter 6: Using Views to Display Data

HP Network Node Manager i Software (10.10) Page 104 of 196



See "Help for Operators" for more information about Layer 3 Neighbor View maps.

Related Topics

"About Map Symbols" on page 93

"About Status Colors" on page 86

"About Workspaces" on page 19

Path View Map Objects

Path View maps show an active network path between a source and destination end point.

The main objects in the displayed path in a Path View map are routers and switches.

Caution: Do not specify a switch as a Source or Destination node in Path View maps. To view
connectivity between switches, use the Layer 2 Neighbor View.

When NNMi cannot determine the nodes within a portion of the path, it uses a Cloud object as shown in
the example below:

If a black arrow or empty black circle appears at the end of the connection in Path View
maps, NNMi was not able to determine a status value because the connection or interface is not in the
NNMi database. Click here for more information.

Reasons a connection or interface are not stored in the NNMi database, include the following:

l NNMi is unable to collect information about a node in the path because it is a non-SNMP node.

l A node in the path is not managed by NNMi.

l The discovery information for a node is not up-to-date (for example, interface information is
missing).

Path View maps also show objects included in Layer 2 Neighbor View maps and Layer 3 Neighbor View
maps. See "Help for Operators" for more information.

(NNMi Advanced) Path View works only with IPv4 addresses. The NNMi Advanced IPv6 address values are
not valid choices for Path View. Any devices in your network that are configured with IPv6 addresses
cannot be displayed on Path View maps.
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(NNMi Advanced) If your network administrator configures NNMi to gather data from Router Redundancy
Groups that have more than one Active router, NNMi selects one Active router for the path. To indicate
there is more than one possible path, NNMi connects any additional routers to the Active router as
shown in the example below:

(NNMi Advanced), plus HP Route Analytics Management System (RAMS) for MPLS WAN) If your network
administrator configures NNMi to gather data from Route Analytics Management System (RAMS), the
Path View can show multiple OSPF1 Equal Cost paths through a Layer 3 cloud as shown in the example
below:

If you are an NNMi administrator, see HP RAMS MPLS WAN Configuration (NNMi Advanced) for
information about configuring RAMS.

Related Topics:

"About Map Symbols" on page 93

"About Status Colors" on page 86

"About Workspaces" on page 19

Navigate Maps
NNMi enables you to navigate within map views in the following ways:

"Change the Map Layout" on the next page

Toggle Map Object's Label Text

1Open Shortest Path First Protocol
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"Adjust the Zoom Factor" on page 110

"Pan Around the Map" on page 111

"Set the Location of the Overview Pane" on page 112

"Find a Node in a Map" on page 113

Change theMap Layout

If you prefer a different layout for the symbols on your map, you can change the placement (see "About
Map Symbols" on page 93):

l To make quick changes:

n   to toggle node labels on/off

p   to toggle port labels on/off

l To display the  Chassis icons associated with a device:

Devices with more than one Chassis are indicated by the following icons:

 Node  Switch  Switch-Router

l Click to display the entire group of Chassis within a device. NNMi adjusts the layout of the
entire map to make room for the expanded map icon. For example:

Collapsed Expanded

l Click the  icon and drag to resize the expanded device icon.

l Click the  icon to collapse the expanded device icon.

Tip: To return the map to its prior layout, click the Workspace: View link for that map. NNMi

draws a fresh rendering in the layout last  Saved by an NNMi user (all NNMi users share the
same version of the map).

l To move a single object:

Left-click and drag any map symbol to the location you want on the map.
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To deselect the object, either click on the map background or use Ctrl + Left-Click.

l To move multiple objects:

Do any of the following:

l Shift+Left-Click the mouse in an empty space between nodes and drag the cursor over the area
of the map you want to select. When you use this method, NNMi indicates the selection area using
a dotted line (or rubber band) as shown in the following example:

l Use Ctrl+Left-Click to select or deselect each object of interest on the map.

Each object you select changes to indicate it has been selected. Drag any one of the selected
nodes to move the group of objects to the location you want on the map.

Tip: If you drag using space between the nodes, all objects are deselected.

This placement persists until you refresh or otherwise reload the map.

Node Group Maps only: If your role permits, click the Save Map toolbar button to keep the new
layout visible on that map in the future. Once a map is saved, newly discovered devices appear in the
bottom left corner of the map.

Note: Each time you select Save Map, NNMi deletes any previous node location information
for the map. All team members see the changes.

l Virtual devices (NNMi Advanced):
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L2 Map Wheel Dialog

To display in formation about one Hypervisor's
resources, right-click any object representing a
hypervisor, virtual machine, or component of a
hypervisor (such as Interface), and then select:

Hypervisor > Hypervisor Wheel ("Using the Wheel
Dialog" on page 118)

Hypervisor > Hypervisor Loom ("Using the Loom
Dialog" on page 137)

Related Topics

"Toggle Map Object's Label Text" on the next page

"Adjust the Zoom Factor" on the next page

"Pan Around the Map" on page 111

"Set the Location of the Overview Pane" on page 112

"Find a Node in a Map" on page 113
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Toggle Map Object's Label Text

Press n to show/hide object names on the map.

Press p to show/hide Port names at the end of connection lines.

Related Topics

"Change the Map Layout" on page 107

"Adjust the Zoom Factor" below

"Pan Around the Map" on the next page

"Set the Location of the Overview Pane" on page 112

"Find a Node in a Map" on page 113

Adjust the ZoomFactor

You can adjust the zoom factor in a map in several ways.

l To zoom-in a map:

Do one of the following:

l Rotate the mouse wheel button forward.

l Click .

l Press + (PLUS SIGN).

l In the Overview Pane, double-click the Focus Area that is indicated with the blue rectangle as
shown in the following example:

Note: If NNMi does not indicate a Focus Area, double-click anywhere in the Overview Pane.

The Overview Pane provides a view of the entire map you selected. The Focus Area indicates the
portion of the map that NNMi displays in the larger map view.

Tip: See "Set the Location of the Overview Pane" on page 112.

l To zoom-out a map:

Do one of the following:
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l Rotate the mouse wheel button backward.

l Click .

l Press - (minus sign).

l In the Overview Pane, double-click outside the Focus Area that is indicated with the blue rectangle.

l To fit the entire map to the screen size:

Do one of the following:

l Click .

l Press = (equal sign).

l To display the map at 100 percent (actual size device images):

Do one of the following:

l Click

l Press 1 (ONE).

Related Topics

"Change the Map Layout" on page 107

"Toggle Map Object's Label Text" on the previous page

"Pan Around the Map" below

"Set the Location of the Overview Pane" on the next page

"Find a Node in a Map" on page 113

Pan Around theMap

If the node of interest is not easily visible on the map, you can move to other sections of the map.

To pan to other sections of the map:

Do one of the following:

l Press the arrow keys to move the map around (↑ up arrow, ↓ down arrow, → right arrow, ← left
arrow).

l Left-click the background and use the mouse to drag to a new location.

l Press Ctrl + Left-Click to pan around the map.

l The Overview Pane provides a view of the entire map.

NNMi indicates the Focus Area using a light-blue rectangle as shown in the following example:
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Tip: See "Set the Location of the Overview Pane" below.

l Drag the Focus Area to pan around the map.

l Double click inside the Focus Area to zoom in.

l Double click outside the Focus Area to zoom out.

Related Topics

"Change the Map Layout" on page 107

"Toggle Map Object's Label Text" on page 110

"Adjust the Zoom Factor" on page 110

"Set the Location of the Overview Pane" below

"Find a Node in a Map" on the next page

Set the Location of the Overview Pane

You can choose which corner of the map contains the Overview Pane:

Alternatively, you can hide the Overview Pane .

To set the location of the Overview Pane:

1. In the Map toolbar, toggle the Overview Location button on:
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2. In the menu, select one of locations

3. To close the menu, toggle the Overview Location button off:

Related Topics

"Change the Map Layout" on page 107

"Toggle Map Object's Label Text" on page 110

"Adjust the Zoom Factor" on page 110

"Pan Around the Map" on page 111

"Find a Node in a Map" below

Find a Node in a Map

You can easily find a particular Node in a map.

To find a Node in the current map:

1. In the Map toolbar, toggle the Find button on:

2. In the text box , do one of the following:

l Click the drop-down icon to display the complete list of choices within this map. Select any
item from the list.

l Type the Name attribute value (not case-sensitive) of the Node you want to find in the map. This
is the Name attribute value from the Node form, that becomes the map icon label.

As you type, the auto-complete feature displays a list of possible matches. Select any item from
the list.

3. NNMi selects the Node that has a Name attribute value that matches your choice. If necessary,
NNMi pans to the appropriate area in the Map.

4. To navigate elsewhere in the map, toggle the Find button off:

Related Topics

"Change the Map Layout" on page 107

"Toggle Map Object's Label Text" on page 110
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"Adjust the Zoom Factor" on page 110

"Pan Around the Map" on page 111

"Set the Location of the Overview Pane" on page 112

Refresh Node Status on a Map
In map views, you can refresh the node status on a map while maintaining the layout of the nodes. This
feature enables you to quickly refresh a view when you are only concerned with status updates for one
or more nodes on your map.

NNMi automatically refreshes node status on a map every 60 seconds. The refresh counter begins after
the completion of the last status refresh.

Note: If a map is taking longer than expected to refresh, the maximum number of nodes that are
displayed on a map might be set too high. The NNMi administrator can set this value. See "Help for
Administrators" for more information.

You can refresh the node status manually.

To refresh only the node status:

Click the  Refresh Status icon in the toolbar to manually refresh node status on your map view.

The last update time is changed and the status of each node is refreshed on the map. Nodes are not
added, deleted, or rearranged. Connectivity is not recalculated.

Note: Some NNMi users can delete nodes and other objects from the NNMi database (depending on
the assigned NNMi Role). Any node that has been deleted appears as a transparent icon to all NNMi
users until their map is refreshed using the Refresh icon. After Refresh, the deleted node is
removed from the map. NNMi does not automatically refresh the connectivity or set of nodes in a
map view, except on the Initial Discovery Progress and Network Overview maps.

Related Topics

"Using the View Toolbars" on page 160

"Refresh a View" on page 58

Control Tool Tips Information on a Map
When you place the mouse cursor over an object on a map, NNMi displays Tool Tips information for the
current object. Tool Tips information is a subset of the information contained in the object's form.

Each time you open a map, the Tool Tips button is enabled.

To disable Tool Tips popups, click the Tool Tips button. NNMi closes any open Tool Tip dialog boxes.

Related Topics

"Using the View Toolbars" on page 160
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Access Maps Provided by NNMi
You can access maps in the following ways:

l From table views using the Actions menu

l From the  Topology Maps and  Troubleshooting workspaces

Table Views

To display a map view from a table view:

See "Using Actions to Perform Tasks" on page 175 for more information about using the Actions menu.

1. Select the table view you want from the workspaces navigation panel. (For example, select the
Inventory workspace, Nodes view.)

2. In the table view, click the row that contains the object of interest.

3. Select the Actions menu in the main toolbar and select the map view you want. 

Note: You can also access map views from the Actions menu in a form. See "About the NNMi
Console" on page 1, for more information.

Tip: You can also right-click any object in a table or map view to access the items available
within the Actions menu.

The label for the starting node appears in bold text on the map.

4. If you are displaying either Layer 2 or Layer 3 Neighbor View maps, after the map view appears, you
can change the number of hops1.

In the Number of Hops drop-down list, select the number of hops to display. The default number of
hops is 1. The maximum number of hops is 9.

Topology Maps Workspace

To display a Node Group map:

1. Select the Topology Maps workspace.

2. Click to expand the folder of interest.

3. Select the name of the Node Group map you want to view.

Troubleshooting Workspace

1A hop is a node representing any network device, such as a workstation, gateway, or switch, which is
connected by a link with no intermediate nodes.
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l To display a Layer 2 or Layer 3 Neighbor View map:

a. Select the Troubleshooting workspace.

b. Select the type of map you want to generate.

c. In Layer 2 Neighbor View and Layer 3 Neighbor View maps, you can designate the starting node
using either the node name or IP address. The label for the starting node appears in bold text on
the map.

Note: After you begin to type the node name or IP address, NNMi displays a list that includes
all potential existing names or IP addresses that match the letters or numbers as you enter
them.

d. After the map view appears, you can change the number of hops1.

In the Number of Hops drop-down list, select the number of hops to display. The default number
of hops is 1. The maximum number of hops is 9.

l To display a Path View:

a. Select the Troubleshooting workspace.

b. Select Path View.

c. In the Source and Destination fields, designate the nodes at both ends of the path using either
the node name or IPv4 address.

Note: After you begin to type the node name or IPv4 address, NNMi displays a list that
includes all potential existing names or IPv4 addresses that match the letters or numbers as
you enter them.

(NNMi Advanced) Path View works only with IPv4 addresses. The NNMi Advanced IPv6 address
values are not valid choices for Path View. Any devices in your network that are configured with
IPv6 addresses cannot be displayed on Path View maps.

l To display a Node Group map:

a. Select the Troubleshooting workspace.

b. Select Node Group Map.

c. In the Node Group field, specify the name of the Node Group that contains the nodes you want to
display.

Note: After you begin to type the Node Group name, NNMi displays a list that includes all
potential existing names (case-sensitive) that match the letters or numbers as you enter
them.

1A hop is a node representing any network device, such as a workstation, gateway, or switch, which is
connected by a link with no intermediate nodes.
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Chapter 6: Using Hypervisor Diagrams
and Dialogs
(NNMi Advanced) NNMi provides two types of interactive diagrams that show detailed information about
virtual objects offered by a particular hypervisor1. These diagrams are available on tabs in the Analysis
Pane and available within interactive popup dialogs when the hypervisor or one of its virtual devices is
selected:

Wheel Dialog (displaying the wheel
diagram)

See "Using the Wheel Dialog" on the next page.

Loom Dialog (displaying the loom
diagram)

See "Using the Loom Dialog" on page 137.

Accessing Hypervisor Dialogs

The dialogs can be accessed in a variety of ways.

Access Point Procedure

Map Views

Table Views

For any object representing a hypervisor, virtual machine, or other
component of a hypervisor (such as Node, Interface, or related
Incident), do one of the following to launch the dialog:

Right-click the object:

l Hypervisor > Hypervisor Wheel dialog

l Hypervisor > Hypervisor Loom dialog

1The virtual machine manager in charge of delegating various aspects from a pool of resources to
become virtual devices. The delegations might be static or dynamic, depending on the manufacture's
implementation. The type of virtual machines being generated depends on the manufacturer's
implementation.
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Access Point Procedure

Select the object and then use the Actions menu:

l Actions > Hypervisor > Hypervisor Wheel dialog

l Actions > Hypervisor > Hypervisor Loom dialog

Analysis pane and
Dashboard view for:

Node

Interface

Incident

Select a hypervisor, virtual machine (VM), Virtual Switch (vSwitch), or
other component being provided by a hypervisor, and then navigate to
the Analysis pane or Dashboard view.

Select one of the following Analysis Pane tab or Dashboard panel:

l Wheel Diagram

l Loom Diagram

Only a limited number of Wheel Dialog and Loom Dialog features are
available within the Analysis pane and Dashboard panel.

For access to all available features:
Click Show Diagram in New Window in the Analysis pane.

Docked dialog: When you click the Dock icon (in the dialog title bar), the dialog
popup collapses into a small rectangular link at the bottom of the
Analysis Pane's tab space. Click the link to display the dialog.

= Wheel

Dialog

= Loom

Dialog

Tip: Your NNMi administrator can display the Wheel and Loom outside of NNMi using showWheel
and showLoom commands with special URLs to provide detailed information about a particular
hypervisor or one of the resources being provided by that hypervisor.

Using the Wheel Dialog
(NNMi Advanced) The Wheel Dialog shows the current deployment of virtual resources:

Slide 1: The initial display shows the entire set of virtual nodes currently being deployed by the
hypervisor1 (any resources that are currently Powered Off are not displayed):

1The virtual machine manager in charge of delegating various aspects from a pool of resources to
become virtual devices. The delegations might be static or dynamic, depending on the manufacture's
implementation. The type of virtual machines being generated depends on the manufacturer's
implementation.
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Slide 2: Inner ring segments represent categories of device types being provided by the hypervisor:
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Slide 3: Outer ring segments represent virtual devices being deployed by the hypervisor:
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Slide 4: Hover a name to display that object's current communication channels:
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Slide 5-6: Click an outer arc to hide/show one device's interfaces or ports:
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      The interfaces or ports are represented by rectangles within the arc.
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Slide 7: Highlight the device name to display connection details:
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Slide 8: Click an inner arc to hide or show all device interfaces or ports within a category of devices:
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Slide 9: Color represents current status for each node, interface, or port:
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Slide 10-11:  Powered Off resources can be shown or hidden:
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      Their status color is gray:
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Slide 12-13: Search for and find any node, interface, or port:
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      The found object is displayed and highlighted:
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Slide 14-15:  Filter the Wheel to one device's environment:
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      Return to the previous display:

Change Size and Location of the Wheel

Left-click the background to establish which point should be considered the new center, and use the
mouse to:

l Rotate the mouse wheel to zoom in or zoom out.

l Drag to pan to a new location a short distance within the diagram.

l Pan while maintaining the current highlighted selection (for example follow a highlighted connection
line across the diagram):

l Ctrl + rotate the mouse wheel

l Ctrl-drag

You can also change the size and location of the popup. NNMi remembers your preferences from
session to session (per browser):

Note: When minimized the Wheel appears at the bottom of the console window with the
hypervisor's name:
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Display Additional Information

l Click any text around the outside perimeter of the Wheel to populate the Analysis Pane in the main
console.

l Double-click any text around the outside perimeter of the Wheel to display the node or interface
form in the main console.

Note: When the Wheel Dialog is launched from a map view, clicking an object on the wheel
automatically highlights that object on the map. See also "Using Hypervisor Diagrams and Dialogs"
on page 117.
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Display devices connected beyond the Wheel

1. In the Wheel Dialog toolbar, click Open the Hypervisor Form to display the Node form in the
main console.

2. Use Actions→ Maps→ Layer 2 Neighbor View.

Tip: In addition to the following, you will see everything else connected to the access Switch.

3. In the map toolbar, increase the Number of Hops setting to see a wider range of connections.
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Toolbar Actions

Toolbar icons are at the top of the Wheel Dialog:

Icon Description

Dock. Minimizes the Wheel Dialog into a small rectangular link at the bottom right side of
the console's workspace:

Close. Close the Wheel Dialog.

Find Auto complete pull-down that allows you to pick an item by VM name, VSwitch name,
interface name, management address, or IP address:

To highlight the selected object in the diagram, do one of the following:

l Click a list item

l Press enter

Note: If the selected item is not currently visible, NNMi automatically takes the
appropriate action:

l The parent object is expanded to display the selected item.

l All powered off items are shown to display the selected item.

 or 
Show Tool Tips. Toggle button to  Enable or  Disable popups showing additional
information when you mouse-over an object:

l Virtual Machines popup shows Name, Management Address, Power State, and System
Description

l Virtual Switches and Virtual Interfaces popup shows ifName, ifAlias, ifTtype, and all
current IP addresses

 or 
Powered-Off VMs. Toggle button to  Show or  Hide all VMs currently with a Power
State of Powered Off. See Nodes (All Attributes) view.

Refresh. Refreshes the current diagram, showing the most recent virtual configuration and
status of each object.

 or  The icon is grey when the current Wheel depicts a hypervisor and all virtual objects being
provided by that hypervisor.
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Icon Description

The icon is black when the current loom depicts a subset of a hypervisor's resources
(Virtual Switch, Virtual Interface, or physical interface).

Simplifies the Wheel diagram by hiding anything not directly in
communication with the selected object.

Open the Hypervisor Form. Displays the hypervisor's form no matter which subset of the
hypervisor's resources are currently displayed in the Wheel.

Tip: Double-click any node or interface label to display that object's form.

 or  Maximize.

 The icon is black when clicking will make the Wheel Dialog is as large as possible, filling
all space currently available within the NNMi console window.

 The icon is gray when the loom is already maximized. See  Restore (below).

Restore. Reverts the dialog to the size and settings prior to clicking Maximize.

Help. Click the icon for access to the Wheel Dialog Help.

Resize:

1. Click the Wheel Dialog's title bar and move it to the desired location within the console.

2. Drag the bottom right corner  to resize the dialog to the preferred size.

Note: NNMi remembers your preference for size and location (stored in your browser
settings).

Using the Loom Dialog

Change What Is Displayed within the Loom

(NNMi Advanced) The Loom Dialog shows the current deployment of virtual resources:

Slide 1: The initial display shows the entire set of virtual nodes currently being deployed by the
hypervisor1 (any resources that are currently Powered Off are not displayed):

1The virtual machine manager in charge of delegating various aspects from a pool of resources to
become virtual devices. The delegations might be static or dynamic, depending on the manufacture's
implementation. The type of virtual machines being generated depends on the manufacturer's
implementation.
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Slide 2: Columns represent categories of device types being provided by the hypervisor:
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Slide 3: Hover a name to display the connections assigned to that object:
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Slide 4-5: Right-click to show or hide one device's interfaces or ports:
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       The interfaces or ports are represented within the object.

Online Help: Using the Console
Chapter 6: Using Hypervisor Diagrams and Dialogs

HP Network Node Manager i Software (10.10) Page 142 of 196



Slide 6: Right-click to show all device interfaces or ports within a category of devices:
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Slide 7: Color represents current status for each node, interface, or port:
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Slide 8: Right-click to hide all device interfaces or ports within a category of devices:
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Slide 9-10:  Powered Off resources can be shown or hidden:
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       Their status color is gray:
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Slide 11-12: Search for and find any node, interface, or port:
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       The found object is displayed and highlighted:
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Slide 13-14:  Filter the Loom to one device's environment:

Online Help: Using the Console
Chapter 6: Using Hypervisor Diagrams and Dialogs

HP Network Node Manager i Software (10.10) Page 150 of 196



       Return to the previous display:

Change Size and Location of the Loom

Left-click the background to establish which point should be considered the new center, and use the
mouse to:

l Rotate the mouse wheel to zoom in or zoom out.

l Drag to pan to a new location a short distance within the diagram.

l Pan while maintaining the current highlighted selection (for example follow a highlighted connection
line across the diagram):

l Ctrl + rotate the mouse wheel

l Ctrl-drag

You can also change the size and location of the popup. NNMi remembers your preferences from
session to session (per browser):
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Note: When minimized the Loom appears at the bottom of the console window with the
hypervisor's name:

Display Additional Information

l Click any text in the Loom to populate the Analysis Pane in the main console.

l Double-click any text in the Loom to display the node or interface's form in the main console.

Note: When the Loom Dialog is launched from a map view, clicking an object automatically
highlights that object on the map. See also "Using Hypervisor Diagrams and Dialogs" on page 117.
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Display devices connected beyond the Loom

1. In the Loom Dialog toolbar, click Open the Hypervisor Form to display the Node form in the
main console.

2. Use Actions→ Maps→ Layer 2 Neighbor View.

Tip: In addition to the following, you will see everything else connected to the access Switch.
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3. In the map toolbar, increase the Number of Hops setting to see a wider range of connections.

Toolbar Actions

Toolbar icons are at the top of the Loom Dialog:

Icon Description

Dock. Minimizes the Loom Dialog into a small rectangular link at the bottom right side of the
console's workspace:

Close. Close the Loom Dialog.

Find Auto complete pull-down that allows you to pick an item by VM name, VSwitch name,
interface name, management address, or IP address:

To highlight the selected object in the diagram, do one of the following:

l Click a list item

l Press enter

Note: If the selected item is not currently visible, NNMi automatically takes the
appropriate action:

l The parent object is expanded to display the selected item.

l All powered off items are shown to display the selected item.

 or 
Show Tool Tips. Toggle button to  Enable or  Disable popups showing additional
information when you mouse-over an object:

l Virtual Machines popup shows Name, Management Address, Power State, and System
Description
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Icon Description

l Virtual Switches and Virtual Interfaces popup shows ifName, ifAlias, ifTtype, and all
current IP addresses

 or 
Powered-Off VMs. Toggle button to  Show or  Hide all VMs currently with a Power
State of Powered Off. See Nodes (All Attributes) view.

Refresh. Refreshes the current diagram, showing the most recent virtual configuration and
status of each object.

 or  The icon is gray when the current loom depicts a hypervisor and all virtual objects being
provided by that hypervisor.

The icon is black when the current loom depicts a subset of a hypervisor's resources
(Virtual Switch, Virtual Interface, or physical interface).

Show this only Simplifies the Loom diagram by hiding anything not directly in
communication with the selected object.

Expand or Collapse
this Object

Does one of the following within the selected parent object:

l Simplifies the Loom dialog by hiding all child objects (Virtual
Ports or Interfaces).

l Enhances the Loom dialog by displaying all child objects (Virtual
Ports or Interfaces).

Expand or Collapse
All in Column

Does one of the following within all objects in the column:

l Simplifies the Loom dialog by hiding all child objects (Virtual
Ports or Interfaces).

l Enhances the Loom dialog by displaying all child objects (Virtual
Ports or Interfaces).

Open the Hypervisor Form. Displays the hypervisor's form no matter which subset of the
hypervisor's resources are currently displayed in the Loom.

Tip: Double-click any node or interface label to display that object's form.

 or  Maximize.

 The icon is black when clicking will make the Loom Dialog is as large as possible, filling all
space currently available within the NNMi console window.
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Icon Description

 The icon is gray when the loom is already maximized. See  Restore (below).

Restore. Reverts the dialog to the size and settings prior to clicking Maximize.

Help. Click the icon for access to the Loom Loom Dialog Help.

Resize:

1. Click the Loom Dialog's title bar and move it to the desired location within the console.

2. Drag the bottom right corner  to resize the dialog to the preferred size.

Note: NNMi remembers your preference for size and location (stored in your browser
settings).
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Chapter 7: About the Analysis Pane
The Analysis Pane displays related details about the selected object. NNMi performs the appropriate
analysis on the selected object to determine the most important information to display. Any hyperlink
within the Analysis Pane displays more information about the selected detail.

For example: When you select an Incident, the Analysis Pane might include important details about the
incident's Source Node and Source Object. When you select a Node, the Analysis Pane might include
important information about the node's Interfaces and IP Addresses.

1. l Access the Analysis Pane from a table view:

i. Select the workspace of interest (for example, Inventory).

ii. Select the view that contains the object of interest (for example, the Nodes view).

iii. Select the row that contains the object of interest.

iv. NNMi displays detailed information at the bottom of the view in the Analysis Pane.

l Access the Analysis Pane in a map view:

i. Select the workspace of interest (for example, Topology Maps).

ii. Select a map view (for example, select Routers).

Note: If the map requires a starting node before it opens, enter the name or
IP Address for the starting node you want to use.

iii. Click the map object of interest.

iv. NNMi displays detailed information at the bottom of the view in the Analysis Pane.

l Access the Analysis Pane in a form:

o Click the form's toolbar Show Analysis icon to display information about the current
form's top-level object in the Analysis Pane.

Note: Show Analysis always displays the top-level object's information.

o Click a row in a table on one of the form's tabs to display detailed information about the
selected object in the Analysis Pane.

NNMi displays detailed information at the bottom of the form in the Analysis Pane. See Working
with Objects for more information about forms.

2. Open the Analysis Pane if necessary by clicking the expand button in the Analysis Pane banner
bar:
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If you change views, NNMi clears the Analysis Pane. The Analysis Pane remains blank unless an
object is selected.

If you select multiple objects, the Analysis Pane displays data about the first selected object.

3. Using the Analysis Pane: 

l To resize, place your mouse cursor over the title bar to display the ↕ symbol and drag to adjust
the size.

l To refresh a subset of information in the Analysis Pane, click any displayed Refresh icon .

To refresh all data in the Analysis Pane, open the object's form and click Refresh or Save.

l To launch an SNMP Line Graph for the selected metric, click the icon that appears at the bottom
of each gauge.

l To select and copy the tooltip information, double-click the gauge. NNMi opens a text window
that enables you to select and copy the tooltip information.

l The Gauges tab shows real-time SNMP gauges to display State Poller and Custom Poller SNMP
data.

o These gauges are displayed for Nodes, Interfaces, Custom Node Collections, and for Node
Sensors of type CPU, Memory, or Buffers, and Physical Sensors of type Backplane.

o NNMi displays a gauge for each significant MIB Object Identifier (OID) that the node or
interface supports, up to the default maximum of 24.

Tip: If you are an NNMi administrator, for information about using the nms-
ui.properties file to change this default, see the "NNMi Console" chapter in the HP
Network Node Manager i Software Deployment Reference, which is available at:
http://h20230.www2.hp.com/selfsolve/manuals.

o Each gauge displays the current OID value, using the default refresh rate of 15 seconds.

Tip: If you are an NNMi administrator, for information about using the nms-
ui.properties file to change this default, see the "NNMi Console" chapter of the HP
Network Node Manager i Software Deployment Reference, which is available at:
http://h20230.www2.hp.com/selfsolve/manuals.

o The value range displayed indicates the OID minimum and maximum values that NNMi has
encountered.

o For any gauge that tracks percentage values, NNMi uses a red line to indicate where the OID
value is near 100 percent.

o There is not a one-to-one match between the OIDs used to analyze monitoring thresholds
and those displayed in the Analysis Pane. For example, the Analysis Pane might display a
Cisco Memory Pool OID value that does not match the value used to calculate whether the
Memory Utilization Monitored Attribute threshold is reached or exceeded. This is because
some threshold metrics require more complex calculations than a single OID allows. 

If a gauge label appears to be a duplicate value, mouse over the label to view the more
complete tooltip name that appears.
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Tip: If you are an NNMi administrator, to change the gauge title - for example, to the
SNMP MIB variable name - see the "Maintaining NNMi" chapter of the HP Network Node
Manager i Software Deployment Reference, which is available at:
http://h20230.www2.hp.com/selfsolve/manuals.)

Tip: Some views are also accessible from the console's Actions menu. See "Using Actions to
Perform Tasks" on page 175 for more information. You can also right-click any object in a table or
map view to access the items available within the Actions menu.

For more information about the types of information displayed, see Use the Analysis Pane.

Related Topics

"Use Table Views" on page 63

"Use Map Views" on page 85
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Chapter 8: Using the View Toolbars
NNMi provides toolbars for the following types of views:

l Table views toolbar

l Node Group Map views toolbar

l Neighbor views toolbar

l Path View toolbar

l Network Overview toolbar

Table View Toolbar

This is the table view display panel toolbar:

Use the table view toolbar to perform the following tasks within the displayed view.

Icon Description

Show View in New Window. Displays the current view in a new
window.

New. NNMi Administrators only. Opens the form to create a new
object instance.

Open. Displays the form for the selected object. See "Access
Object Information (Forms and Analysis Pane)" on page 12.

Refresh. Refreshes the current view. See "Refresh a View" on
page 58 for more information. Restarts periodic refresh if it has
been disabled.

Stop Periodic Refresh. Temporarily disables the periodic refresh
of a view. See "Stop Periodic Refresh of a View" on page 66 for
more information.

Restore Default Settings. Resets default settings, including the
resizing of table columns, sort selections, and filters. Any hidden
columns are restored to the view. See "Hide a Column" on page
64.

Restore Default Filters. Clears any currently applied filters. See
"Filter a Table View" on page 67.

View Toolbar Icons
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Icon Description

Delete. If your role permits, deletes the selected object instance
and any objects contained in that object. For example, deleting a
node also deletes the interface and address instances
associated with that node, and the history of those objects.

Selects a time period filter. This filter only appears in incident
views.

Selects an available node group or interface group filter.

The page controls only appears when viewing tables. They let you page through table information by
rows.

Use Previous or [Page Up] to move up one page.

Use Next or [Page Down] to move down one page.

Use First or [Home] to move to the top of the table.

Use Last or [End] to move to the end of the table.

Tip: Use the keyboard's keys:

l [ ↑ ] up arrow key to scroll up one row.

l [  ↓ ] down arrow key to scroll down one row.

l [ page up ] and [ page down ] keys to scroll through the total number of rows in the current
table.

Note: In the Table status bar: Total value displays the number of rows in the current table. If the
table row count exceeds the maximum table size specified by NNMi, the Total value is followed by
the limit set for the table. If the limit is exceeded:

l Each time you refresh the table view or update the table filter, NNMi computes the actual
number of rows in the table.

l When you scroll to the last row of the table, NNMi displays a dialog explaining that the table is
larger than the specified limit and recommending that you filter the table view. See "Filter a
Table View" on page 67 for more information about how to filter a table view.

or  Text Wrap:

l Off = Each row is one text line high. Any text too wide for
the column width disappears from view.

l On = Each row becomes deep enough to show the entire
text string (as many lines of text as necessary).

(view name tab) Close. Close the current view.

View Toolbar Icons, continued
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Node Group Map Toolbar

This is the Node Group Map display panel toolbar:

The Node Group Map view toolbar lets you perform the following tasks within the displayed map.

Icon Description

Show View in New Window. (Only available from the main console.) Displays the current view
in a new window.

Open. Displays the form for the selected object. See "Access Object Information (Forms and
Analysis Pane)" on page 12.

Open Node Group Map. Opens the Node Group Map for the selected Child Node Group. The
Child Node Group map replaces the current map and displays each node within the Child Node
Group.

Note: You can also double-click the  Node Group symbol to open the Child Node
Group Map.

See "About Node and Interface Groups" on page 70 for more information about Node Groups.

Save Map. Saves the current position of each of the nodes on the current Node Group Map.

Note: Each time you use this option, any previous location information is deleted.

Refresh. Refreshes the current view. See "Refresh a View" on page 58 for more information.

Refresh Status. Refreshes only the status of each node in the map. See "Refresh Node
Status on a Map" on page 114 for more information.

Fit Content. Adjusts the size of the node symbols so that all members of the Node Group fit
within the current window. See "Adjust the Zoom Factor" on page 110 for more information.

Actual Size. Cancels any current zoom setting. See "Adjust the Zoom Factor" on page 110 for
more information.

Zoom Out. Zooms out 25% of current size. See "Adjust the Zoom Factor" on page 110 for
more information.

Zoom In. Zooms in 25% of current size. See "Adjust the Zoom Factor" on page 110 for more
information.

 or 

Find. Toggles on or off highlighting the identified Node in the current map and ensures that
node is in the map's display area. See "Find a Node in a Map" on page 113.

Node Group Map Toolbar Icons
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Icon Description

 or 

Indicate Key Incidents. Toggles on or off NNMi's enlarging any map symbol that has
an associated Key Incident1. See "Node Group Map Objects" on page 99 for more information.

 or 

Tool Tips. Toggles on or off Tool Tips information that pops up when the mouse cursor is
placed over an object on a map. See "Control Tool Tips Information on a Map" on page 114 for
more information.

 or 

Overview Location. Pops up a dialog of choices for
placement of the Overview Pane (used to pan around on
the map). See "Pan Around the Map" on page 111:

For more information, see "Set the
Location of the Overview Pane" on
page 112.

(view
name
tab)

Close. Close the current view.

Node Group Map Toolbar Icons , continued

Neighbor View Toolbar

This is the neighbor view display panel toolbar:

The neighbor view toolbar lets you perform the following tasks within the displayed view.

1Incidents with both: (1) Severity = other than Normal. (2) Correlation Nature = equal to Root Cause,
Service Impact, Stream Correlation, Rate Stream Correlation, Info, or None.
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Icon Description

Show View in New Window. (Only available from the main console.) Show View in
New Window. Displays the current view in a new window.

Open. Displays the form for the selected object. See "Access Object Information
(Forms and Analysis Pane)" on page 12.

Refresh. Refreshes the current view. See "Refresh a View" on page 58 for more
information.

Refresh Status. Refreshes only the status of each node in the map. See "Refresh
Node Status on a Map" on page 114 for more information.

Fit Content. Adjusts the size of the node symbols so that all members of the Node
Group fit within the current window. See "Adjust the Zoom Factor" on page 110 for
more information.

Actual Size. Cancels any current zoom setting. See "Adjust the Zoom Factor" on
page 110 for more information.

Zoom Out. Zooms out 25% of current size. See "Adjust the Zoom Factor" on page
110 for more information.

Zoom In. Zooms in 25% of current size. See "Adjust the Zoom Factor" on page 110
for more information.

Specify the starting node for the neighbors you want to map. Populate this field
with the current value of the node's Name attribute or one of the Node's IP
addresses.

Note: As you type, NNMi provides a selection list of all current valid entries
matching your criteria. You must use one of the suggested values.

Select the number of hops to be displayed within the map view. A hop is a node
representing any network device, such as a workstation, gateway, or switch, which
is connected by a link with no intermediate nodes.

or Find. Toggles on or off highlighting the identified Node in the current map and
ensures that node is in the map's display area. See "Find a Node in a Map" on page
113.

or Tool Tips. Toggles on or off Tool Tips information that pops up when the mouse
cursor is placed over an object on a map. See "Control Tool Tips Information on a
Map" on page 114 for more information.

Neighbor View Toolbar Icons
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Icon Description

 or  Overview Location. Pops up a dialog of choices for
placement of the Overview Pane (used to pan around
on the map). See "Pan Around the Map" on page 111:

For more information, see
"Set the Location of the
Overview Pane" on page
112.

(view name

tab)

Close. Close the current view.

Neighbor View Toolbar Icons, continued

Path View Toolbar

This is the Path View display panel toolbar:

The Path View toolbar lets you perform the following tasks within the displayed view.

Icon Description

Show View in New Window. (Only available from the main console.) Displays the
current view in a new window.

Open. Displays the form for the selected object. See "Access Object Information
(Forms and Analysis Pane)" on page 12.

Refresh. Refreshes the current view. See "Refresh a View" on page 58 for more
information.

Refresh Status. Refreshes only the status of each node in the map. See "Refresh
Node Status on a Map" on page 114 for more information.

Fit Content. Adjusts the size of the node symbols so that all members of the Node
Group fit within the current window. See "Adjust the Zoom Factor" on page 110 for
more information.

Actual Size. Cancels any current zoom setting. See "Adjust the Zoom Factor" on page
110 for more information.

Zoom Out. Zooms out 25% of current size. See "Adjust the Zoom Factor" on page 110

Path View Toolbar Icons
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Icon Description

for more information.

Zoom In. Zooms in 25% of current size. See "Adjust the Zoom Factor" on page 110 for
more information.

Specify the source node to be used in the Path View.

Caution: Do not specify a node that is a switch.

Populate this field with the current value of the node's Hostname attribute (case-
sensitive) or one of the node's IPv4 addresses. These are the values from the Node
form.

Note: As you type, the auto-complete feature displays a list of possible
matches. Select any item from the list.

(NNMi Advanced) Path View works only with IPv4 addresses. The NNMi Advanced IPv6
address values are not valid choices for Path View. Any devices in your network that
are configured with IPv6 addresses cannot be displayed on Path View maps.

Swap Nodes. Swaps the source and destination nodes in the Path View.

Specify the destination node in the Path View.

Caution: Do not specify a node that is a switch.

Populate this field with the current value of the node's Hostname attribute (case-
sensitive) or one of the node's IPv4 addresses. These are the values from the Node
form.

Note: As you type, the auto-complete feature displays a list of possible
matches. Select any item from the list.

(NNMi Advanced) Path View works only with IPv4 addresses. The NNMi Advanced IPv6
address values are not valid choices for Path View. Any devices in your network that
are configured with IPv6 addresses cannot be displayed on Path View maps.

Compute Path. Computes the Path View.

Note: Also use this icon to re-compute the Path View.

or Find. Toggles on or off highlighting the identified Node in the current map and
ensures that node is in the map's display area. See "Find a Node in a Map" on page
113.

or Tool Tips. Toggles on or off Tool Tips information that pops up when the mouse
cursor is placed over an object on a map. See "Control Tool Tips Information on a
Map" on page 114 for more information.

Path View Toolbar Icons, continued
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Icon Description

 or  Overview Location. Pops up a dialog of choices
for placement of the Overview Pane (used to
pan around on the map). See "Pan Around the
Map" on page 111:

For more information, see "Set the
Location of the Overview Pane" on
page 112.

(view

name tab)

Close. Close the current view.

Path View Toolbar Icons, continued

Network Overview Toolbar

This is the Network Overview display panel toolbar:

The Network Overview toolbar lets you perform the following tasks within the displayed view.

Icon Description

Show View in New Window. (Only available from the main console.) Displays the current view
in a new window.

Open. Displays the form for the selected object. See "Access Object Information (Forms and
Analysis Pane)" on page 12.

Refresh. Refreshes the current view. See "Refresh a View" on page 58 for more information.

Refresh Status. Refreshes only the status of each node in the map. See "Refresh Node
Status on a Map" on page 114 for more information.

Fit Content. Adjusts the size of the node symbols so that all members of the Node Group fit
within the current window. See "Adjust the Zoom Factor" on page 110 for more information.

Actual Size. Cancels any current zoom setting. See "Adjust the Zoom Factor" on page 110 for
more information.

Zoom Out. Zooms out 25% of current size. See "Adjust the Zoom Factor" on page 110 for
more information.

Zoom In. Zooms in 25% of current size. See "Adjust the Zoom Factor" on page 110 for more

Network Overview Toolbar Icons
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Icon Description

information.

or

Find. Toggles on or off highlighting the identified Node in the current map and ensures that
node is in the map's display area. See "Find a Node in a Map" on page 113.

or

Tool Tips. Toggles on or off Tool Tips information that pops up when the mouse cursor is
placed over an object on a map. See "Control Tool Tips Information on a Map" on page 114 for
more information.

 or 

Overview Location. Pops up a dialog of choices for
placement of the Overview Pane (used to pan around on
the map). See "Pan Around the Map" on page 111:

For more information, see "Set the
Location of the Overview Pane" on
page 112.

(view
name
tab)

Close. Close the current view.

Network Overview Toolbar Icons, continued
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Chapter 9: Using the Form Toolbar
This is the form toolbar:

If your role permits, the toolbar lets you perform the following tasks within the form. The group of
available actions can change from form to form:

Tip: You can also right-click any object in a table or map view to access the items available within
the Actions menu.

Icon Action

Show Form in New Window. Displays the current form in a new window.

Note: NNMi closes the current form before displaying the form in a new window.

Show Analysis. Displays the Analysis Pane information for the current form. See "About the
Analysis Pane" on page 157 for more information.

Save. Saves the current form.

Save and New. Saves the current form, and opens a new empty form where you can create a
new object instance.

Save and Close. Saves and closes the current form.

Refresh. Refreshes the data in the current form.

Delete. Deletes the selected object instance and any objects contained in that object. For
example, deleting a node also deletes the interface and address instances associated with
that node, and the history of those objects.

Note: When you delete an object instance that is created using a filter, such as a Node
Group or Interface Group, NNMi deletes only the Node or Interface Group filter. NNMi does
not remove the nodes or interfaces that belong to the selected group.

Close. Closes the current form.

Form Toolbar Icon Actions

Related Topics

"Access Object Information (Forms and Analysis Pane)" on page 12
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Chapter 10: Working with Objects
Objects are database records of information about your environment and events that occur within it.
Each type of object represents a particular kind of information. For example, incident objects represent
situations or events that arise in your environment.

An object is defined by its attributes. For example, an incident object includes a status attribute and a
source node (among many others). Different object types have different amounts and types of
attributes. Some attribute values are simple things, such as numbers and text strings. Other attribute
values are more complex, such as a reference to a related object. For example, when an SNMP Agent
attribute appears in a Node form, it represents the SNMP Agent that is related to the selected node.

If more than one of a certain type of object can be related to the selected object (for example, incidents
related to a node), the form contains a tab that displays a table with the entire list of related objects.

A view is a collection of related objects that are depicted graphically as a table or map. A form provides
all stored attributes about a selected object. The attributes on the form can be attributes of the
selected object or related objects.

Operations that can be performed on objects are called actions. Actions are simply shortcuts to simple
or complex tasks. A particular action can be associated with a specific object type. For example, when
displaying a node table view, you might want to open a map showing all of that node's Layer 2
neighbors.

Tip: You can also right-click any object in a table or map view to access the items available within
the Actions menu.

To access an object's form from a table view:

Double-click the row representing an object.

NNMi displays the form for the selected object.

To access an object's form from a map view:

Do one of the following:

l Select the node of interest and click the Open icon.

l In most cases, double-click the object of interest.

Note: If the map object is a Child Node Group, double-clicking the Child Node Group object
replaces the current map with a map of the nodes in the Child Node Group. To access a Child

Node Group form, select the Child Node Group object and click the  Open icon. See "Help for
Operators" for more information.

NNMi displays the form for the selected object.
A red asterisk (*) that precedes an attribute on a form indicates the attribute requires a value.
From an object form, you can:

"Modify Object Attribute Values" on page 172

"Access All Information About a Related Object" on the next page
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"Access a Subset of the Available Information About a Related Object" below

Access a Subset of the Available Information
About a Related Object
While investigating the available information for an object (within that object's form), some information
represents attributes of the object itself and some information is about related objects. The related

objects are indicated by a Lookup icon. For example, when viewing information for an Interface
object, you can access information about the Node in which that interface resides.

A red asterisk (*) that precedes an attribute on a form indicates the attribute requires a value.

This is an example Lookup Field:

To display a subset of information about a related object from within a form:

1. Locate the field for the related object that you want to learn more about.

2. Click the Lookup icon, and select Show Analysis from the drop-down menu.

3. The Analysis Pane appears showing information about the related object. See "About the Analysis
Pane" on page 157 for more information.

Note: NNMi displays only the information that the NNMi Security configuration permits you to
access. See Determine which NNMi Role to Assign in "Help for Administrators" for more
information.

4. Mouse-over any Refresh icon to see the last time the details were updated.

Click any Refresh icon to gather the most recent data.

Access All Information About a Related Object
While investigating the details for one object using a form, you can access information about another
related object. For example, when viewing all information stored for a node, you can access all available
information for an interface for that node to determine the interface status.

A red asterisk (*) that precedes an attribute on a form indicates the attribute requires a value.

Online Help: Using the Console
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You can open another form from within a form for any object that is contained in the form you are

viewing. Such objects are indicated using a Lookup icon.

This is an example Lookup Field:

To open another form from within a form:

1. Locate the field of an object about which you want to see more information.

2. Click the Lookup icon, and select Open from the drop-down menu.

A new form appears showing all of the attributes for that object. Any default values specified for the
object are pre-populated in the form

Modify Object Attribute Values
When viewing details for an object, such as a node, subnet, or interface, you can change one or more of
its attribute values. For example, you can add notes to an incident to explain steps that were taken to
date to resolve the problem. Until the problem is resolved you can enter information related to a
workaround. Finally, after a solution is determined, you can add information describing how the problem
was resolved.

Note: If you have Guest user role, you cannot modify any attributes.

Two kinds of fields indicate that you can modify an attribute.

A red asterisk (*) that precedes an attribute on a form indicates the attribute requires a value.

To modify information in a text box:

1. Move your cursor to the modifiable field of interest.

2. Type the new value. For example, the Notes attribute is a modifiable field:

Tip: If the attribute appears to be a modifiable field, but it does not permit text entry, it is a
memo field.
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Tip: Click the attribute label to access a dialog box that enables you to view or edit text. Using
this feature, you can insert more text or view a text field that is longer than the original
display area.

3. When you are finished with your edits:

l Click Save to save your changes.

l Click Save and Close to save your changes and close the form.

To modify information in a Lookup field:

1. Look for this icon to the right of a text box . For example:

2. Do one of the following:

l Start to type into the text box. NNMi displays a list of all valid choices. You can select from the
list to complete your choice.
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l Click the Lookup icon, and choose  Quick Find to display a list of valid choices:

3. When you are finished with your edits:

l Click Save to save your changes.

l Click Save and Close to save your changes and close the form.
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Chapter 11: Using Actions to Perform
Tasks
Actions let you perform operations on selected items. The actions available to you depend on your NNMi
user role. Administrators have more action choices than operators. If SPIs are installed in your
environment, the list of actions could expand. Some Actions change an object's attribute value or
require log on access to a node (for example, telnet).

See the NNMi Actions table for a description of possible actions.

To perform any of the actions described, you select an action from the Actions menu. The Actions menu
is accessible from the NNMi console main menu bar and from the menu bar in any form or view that is
opened in a new window. See "Invoke Actions" on page 12 for more information about how to access
actions.

Action Description

Layer 2 Neighbor
View

Maps→ Layer 2 Neighbor View

Displays a map of the Layer 2 network. Layer 2 maps help you better understand
your switch connectivity. See "Help for Operators" for more information.

Layer 3 Neighbor
View

Maps→ Layer 3 Neighbor View

Displays a map of the Layer 3 network. Layer 3 network maps help you better
understand your router connectivity. See "Help for Operators" for more
information.

Path View Maps→ Path View

Displays a map showing the route between two specified nodes. The Source and
Destination nodes should not be switches.

Note: (NNMi Advanced) Path View works only with IPv4 addresses. The NNMi
Advanced IPv6 address values are not valid choices for Path View. Any devices
in your network that are configured with IPv6 addresses cannot be displayed
on Path View maps.

MPLS WAN
Clouds Map

(NNMi Advanced, plus HP Route Analytics Management System (RAMS) for MPLS
WAN) Displays a map of the Layer 3 connectivity across MPLS WAN Clouds.
See "Help for Operators" for more information.

If you are an NNMi administrator, see HP RAMS MPLS WAN Configuration (NNMi
Advanced) for information about configuring RAMS.

NNMi Actions
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Action Description

Interface
Actions

Only available for incidents that have a Source Object that is an interface.

Provides access to all of the actions available for an interface. See Actions Specific
to Nodes, Interfaces, and IP Addresses for more information about the actions
available for interfaces.

IP Address
Actions

Only available for incidents that have a Source Object that is an IP address.

Provides access to all of the actions available for an IP address. See Actions
Specific to Nodes, Interfaces, and IP Addresses for more information about the
actions available for IP addresses.

Node Actions Provides access to all of the actions available for a node. See Actions Specific to
Nodes, Interfaces, and IP Addresses for more information about the actions
available for nodes.

The action is applied to the incident's Source Node.

Node Group
Members

Island Node Group incidents only. Displays a table of the nodes that are members
of the Island Node Group that is the Source Object for the selected incident.

An Island Group is a group of fully-connected nodes discovered by NNMi, and NNMi
determines this group is not connected to the rest of the topology.

Note: Incidents that have a Source Object that is an Island Node Group include
Remote site in the incident message.

Node Group Map Maps→ Node Group Map

Displays the lowest level Node Group map to which the Source Node belongs. For
example, if the node belongs to a Child Node Group, the Child Node Group displays.

If the Source Node is a member of more than one Node Group at the lowest level,
NNMi prompts you to select the Node Group map you want to display.

If the incident's Source Object is an Island Node Group, NNMi displays the Island
Node Group map.

An Island Group is a group of fully-connected nodes discovered by NNMi, and NNMi
determines this group is not connected to the rest of the topology.

Note: Incidents that have a Source Object that is an Island Node Group include
Remote site in the incident message. See "Help for Operators" for more
information.

When the selected Source Node is not a member of any Node Group, and you
select the Node Group Map action, NNMi displays an information message.

Source Node Opens the Node form for the Source Node of the current incident.

Source Object Opens the Source Object's form for the current incident. For example, if the Source
Object is a Layer 2 Connection, NNMi opens the Layer 2 Connection form.

NNMi Actions Specific to Incidents
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Action Description

Graph Custom
Poller Results

Graphs all MIB expressions from each of the Custom Poller Collections associated
with the selected incident's Source Node.

NNMi Actions Specific to Incidents, continued

Action Description

Node Group Map Maps→ Node Group Map

This action displays the lowest level Node Group map to which the Source Node, or
selected interface or IP address on a node belongs. For example, if the node
belongs to a Child Node Group, the Child Node Group displays.

If the Source Node, or selected interface or IP address on a node is a member of
more than one Node Group at the same level, NNMi prompts you to select the
Node Group map you want to display.

When the selected Source Node, interface, or IP address is not a member of any
Node Group, and you select the Node Group Map action, NNMi displays an
information message.

Graphs Graphs in real time the SNMP data configured to be displayed for the selected
nodes or interfaces. The graph name should help to identify the type of data in the
graph.

NNMi provides a set of Line Graphs. See "Help for Operators" for more information.
An NNMi administrator or HP Network Node Manager i Software Smart Plug-ins
(iSPIs) might configure additional Line Graphs that appear in the Actions menu list.

Actions Specific to Nodes, Interfaces, and IP Addresses

Action Description

Node Group Map Maps→ Node Group Map

Displays a current map of all nodes that belong to the selected Node Group.

Preview Members Node Group Details→ Preview Members (Current Group Only).

Displays a list of all nodes that belong to the selected Node Group.

Show Members Node Group Details→ Show Members (Include Child Groups).

Displays a list of all nodes that belong to the selected Node Group as well as all of
its Child Node Groups. .

Show All Incidents Node Group Details→ Show All Incidents

Checks for any Incidents associated with the selected Node Group.

Show All Open
Incidents

Node Group Details→ Show All Open Incidents

Checks for any open Incidents associated with the selected Node Group.

Actions Provided for Node Groups
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Action Description

Status Details Node Group Details→ Status Details

Displays a report about the status of all members of the selected Node Group.

Actions Provided for Node Groups , continued

Action Description

Open Node Group
Map

Displays the selected Node Group map.

Open Node Group
Map Settings

Opens the Node Group Map Settings form for the selected Node Group map. See
Define Node Group Map Settings for more information.

Actions Provided for Node Group Maps

Action Description

Show Members Node Group Details→ Show Members

Displays a list of all nodes that belong to the selected interface Group.

Actions Provided for Interface Groups

Action Description

Graph Polled
Instance

Graphs the line representing the Custom Poll results for the selected Custom
Polled Instance.

Actions Specific to Custom Polled Instances

NNM iSPI Performance for Metrics Actions

Requires HP Network Node Manager iSPI Performance for Metrics Software (NNM iSPI Performance
for Metrics). To populate performance data in the dashboard views or enhance NNM iSPI
Performance for Metrics reports by sharing NNMi configuration settings, install the optional
Network Performance Server (NPS) -- click here for more information.

An additional choice is available in the Actions menu that displays the NNM iSPI Performance for Metrics
Report Menu. The context of the Report Menu changes depending on the currently selected object
(Node, Node Group, Interface, or Interface Group). When selecting more than one object, multiple NNM
iSPI Performance for Metrics reports open (one for each object, maximum 5).

No matter where you are in the NNMi console, the following option appears under the Actions menu:

Actions→ HP NNM iSPI Performance→ Reporting - Report Menu

In a Path View, this additional option appears under the Actions menu:

Actions→ HP NNM iSPI Performance→ Reporting - Path Health
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NNMi administrators can force NNMi to synchronize the Interface and Node Group information between
NNMi and NNM iSPI Performance for Metrics more quickly than the default time frame. This additional
option also appears under the Actions menu:

Actions→ HP NNM iSPI Performance→ Sync Interface and Node Groups

If you an NNMi administrator, see Creating Groups of Nodes or Interfaces for more information.

You can launch Performance Troubleshooting to view graphs of metrics collected by the NNM iSPI
Performance for Metrics. This option appears under the Actions menu after selecting a node or
interface:

Actions→ HP NNM iSPI Performance→ Performance Troubleshooting

See Invoke Actions for more information about how to access actions.
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Chapter 12: Displaying Information About
NNMi
Two menu items provide current information about your installed NNMi:

l Help→ System Information

The System Information popup provides a wealth of current information about NNMi. The
information available depends on your assigned NNMi role:

l NNMi Guest User:

l NNMi Level 1 Operator:

l NNMi Level 2 Operator:

l NNMi Administrator:

Within the System Information popup, click the icon for access to the Help.

l Help→ About HP Network Node Manager i Software

System Information: Product Tab
To display the NNMi System Information, select Help→ System Information. The System Information
popup provides a wealth of current information about NNMi.

Note: The information available depends on your assigned NNMi role.

For information about each tab:

l NNMi Guest User:

l NNMi Level 1 Operator:

l NNMi Level 2 Operator:

l NNMi Administrator:

The Product tab: Displays information about NNMi.

l HP Network Node Manager product name, version number, and date/time installed.

l Locale Information (language) for the current NNMi session:

l Client Locale

l Server Locale
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l SNMP String Encodings

l Web Browser

l NNMi System Health shows the current status of NNMi health:

l Status

l Last Updated

l User Information about the current NNMi user:

l User Name that you used when logging into NNMi.

l NNMi Role1 to which you are currently assigned.

l User Groups to which you currently belong.

l The name of the NNMi product currently installed:

l Network Node Manager i Community

l Network Node Manager i

l Network Node Manager i Advanced

l Network Node Manager i Premium

l Network Node Manager i Ultimate

l Type will be one of the following:

Instant-On NNMi provides a 60-day 250 Node license automatically during installation.

Community This means the free trial version of NNMi is installed.

Capacity This means NNMi is installed.

Capacity(Adv) This means NNMi Advanced is installed.

Premium This means NNMi Premium is installed.

Ultimate This means NNMi Ultimate is installed.

System Information: Health Tab
To display the NNMi System Information, select Help→ System Information. The System Information
popup provides a wealth of current information about NNMi.

1Determined by your membership in one of four special NNMi User Groups (NNMi Administrators, NNMi
Level 2 Operators, NNMi Level 1 Operators, or NNMi Guest Users). This membership determines what you
can see and do within the NNMi console.

Online Help: Using the Console
Chapter 12: Displaying Information About NNMi

HP Network Node Manager i Software (10.10) Page 181 of 196



Note: The information available depends on your assigned NNMi role.

For information about each tab:

l NNMi Guest User:

l NNMi Level 1 Operator:

l NNMi Level 2 Operator:

l NNMi Administrator:

Health tab: Displays information about the current health of the NNMi server.

Displays summary level information regarding NNMi health, including NNMi's overall status as well as
information and any issues related to the following:

l Memory

l The NNMi database

l System resources

l Disk usage

l SNMP requests and queues

l Global Network Management (NNMi Advanced)

Note: NNMi administrators can view more details by clicking the View Detailed Health Report
button on the Health tab.

NNMi uses Status values to communicate about NNMi's overall health Status.

Status Description

Normal Indicates that NNMi is not experiencing any problems.

Warning Indicates performance issues that are not significantly affecting NNMi.

Minor Indicates problems that might result in out of date data. For example, an NNMi component,
such as State Poller might be out of synch because it is operating outside of expected
ranges.

Major Indicates problems that are significantly affecting the NNMi management server's
operations, but are not yet critical. Major Status usually indicates that some action is
required. For example, a trap threshold is reached.

Critical Indicates NNMi is not functioning. For example, NNMi is out of memory, all database
connections are lost, or a major NNMi component has failed.

NNMi Overall Health Status

System Information: Server Tab
To display the NNMi System Information, select Help→ System Information. The System Information
popup provides a wealth of current information about NNMi.

Online Help: Using the Console
Chapter 12: Displaying Information About NNMi

HP Network Node Manager i Software (10.10) Page 182 of 196



Note: The information available depends on your assigned NNMi role.

For information about each tab:

l NNMi Guest User:

l NNMi Level 1 Operator:

l NNMi Level 2 Operator:

l NNMi Administrator:

Server tab: Displays information about the NNMi management server:

l Hostname

l IP Address

l IPv6 Address (NNMi Advanced)

Tip: (NNMi Advanced) If this is set to Disabled, consider the following:

l Are you using NNMi Advanced (required for IPv6 support)?

l Did your NNMi Administrator disable NNMi Advanced's IPv6 feature? See the "Configuring
NNMi Advanced for IPv6" chapter in the HP Network Node Manager i Software Deployment
Reference, which is available at: http://h20230.www2.hp.com/selfsolve/manuals.

l IPv6 Management (NNMi Advanced)

l IPv6 Communication (NNMi Advanced)

l Official Fully Qualified Domain Name (FQDN)

l User Account and User Group information obtained from (either the NNMi database or Directory
Service using LDAP)

l Single Sign-On (configuration file name and whether the feature is enabled)

l Operating System

l Install Directory

l Data Directory

l Available Processors

l NNMi's Free / Allocated Memory (% Free)

l NNMi's Maximum Attemptable Memory

Note: (NNMi Advanced) When using the Global Network Management feature, this tab displays
information about two NNMi servers:

l If your NNMi management server is a Global Manager, the displayed information's heading is
Global Management Server.

l If your NNMi management server is a Regional Manager, the displayed information's heading on
this tab is Management Server.
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System Information: Global Network
Management Tab
Global Network Management tab: (NNMi Advanced) Lists relevant information when the Global Network
Management feature is enabled.

l If your NNMi management server is a Global Manager, the displayed information's heading is
Regional Managers Reporting to this Global Manager.

l If your NNMi management server is a Regional Manager, the displayed information's heading on this
tab is Reporting to Global Managers.

For each management server listed, the following information is provided:

l Name

l Connection State

l Node Count

System Information: Database Tab
To display the NNMi System Information, select Help→ System Information. The System Information
popup provides a wealth of current information about NNMi.

Note: The information available depends on your assigned NNMi role.

For information about each tab:

l NNMi Guest User:

l NNMi Level 1 Operator:

l NNMi Level 2 Operator:

l NNMi Administrator:

Database tab: Lists the number of each type of object stored in the NNMi database.

Possible objects include:

l Nodes

l SNMP Agents

l Interfaces

l IP Addresses

l Layer 2 Connections

l Incidents

l IP Subnets

l VLANs

l Node Sensors

l Chassis
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l Cards

l Physical Sensors

l Ports

l Card Redundancy Groups

l Router Redundancy Groups (NNMi Advanced)

System Information: State Poller Tab
To display the NNMi System Information, select Help→ System Information. The System Information
popup provides a wealth of current information about NNMi.

Note: The information available depends on your assigned NNMi role.

For information about each tab:

l NNMi Guest User:

l NNMi Level 1 Operator:

l NNMi Level 2 Operator:

l NNMi Administrator:

State Poller tab: Lists statistics about the NNMi State Poller's current health:

l Status

l Collections requested

l Collections completed

l Collections in progress

l error instances for skips, stale collections, or exceptions

l Queue lengths

Extensions

This section displays information about the health of State Poller interactions with other NNM iSPI
programs installed in your environment.

Monitored Objects

This section displays the details about which network objects are currently being monitored by NNMi;
such as the number of object type and the current monitoring rates.

Nodes

This sections displays the number of nodes currently reporting faults, the total number of nodes being
polled by each NNM iSPI and by NNMi.

System Information: Custom Poller Tab
To display the NNMi System Information, select Help→ System Information. The System Information
popup provides a wealth of current information about NNMi.
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Note: The information available depends on your assigned NNMi role.

For information about each tab:

l NNMi Guest User:

l NNMi Level 1 Operator:

l NNMi Level 2 Operator:

l NNMi Administrator:

Custom Poller tab: Lists statistics about the NNMi Custom Poller's current health.

l Status

l Discoveries requested

l Nodes waiting for discovery

l Node discoveries in process

l SNMP response queue size

l Discoveries completed

l Stale nodes in last 5 minutes

l Stale node total

Extensions

This section displays information about the health of Custom Poller interactions with other NNM iSPI
programs installed in your environment.

Monitored Objects

This section displays the details about which network objects are currently being monitored by NNMi;
such as the number of object type and the current monitoring rates.

System Information: Causal Engine Tab
To display the NNMi System Information, select Help→ System Information. The System Information
popup provides a wealth of current information about NNMi.

Note: The information available depends on your assigned NNMi role.

For information about each tab:

l NNMi Guest User:

l NNMi Level 1 Operator:

l NNMi Level 2 Operator:

l NNMi Administrator:

Causal Engine tab: Lists statistics about the NNMi Causal Engine's current health.

Tip: NNMi's Causal Engine collects the data for calculating each object's Status value. Using the
State information collected by the State Poller as well as this additional information, the Causal
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Engine calculates the Status of each Node, Interface, and SNMP agent.

State = This value is provided by the NNMi State Poller and is always up to date for each object.

Status = This value can run behind by the amount of time listed below for Delay Processing Input.

The following information is available on the Causal Engine tab:

l Delay Processing Input

l Failures pre-loading data for conditions

l Average time to pre-load data for condition batch

l Average time to process condition

l Resynchronizing all NNMi components in progress (true or false)

System Information: Extensions Tab
To display the NNMi System Information, select Help→ System Information. The System Information
popup provides a wealth of current information about NNMi.

Note: The information available depends on your assigned NNMi role.

For information about each tab:

l NNMi Guest User:

l NNMi Level 1 Operator:

l NNMi Level 2 Operator:

l NNMi Administrator:

Extensions tab: Lists the NNMi Extensions deployed on your NNMi management server (click here for
more information):

l Product Extension Information

NNMi is configured to allow communication with the items in this list:

Network Performance Server (NPS): provided by the HP Network Node Manager iSPI Performance for
Metrics Software (Enabled or Disabled)

Diagnostic Server: provided by the HP Network Node Manager iSPI Network Engineering Toolset
Software

l HP NNM iSPI Software Deployed

This section displays a list of currently installed HP Network Node Manager i Software Smart Plug-ins
(iSPIs). In the far right column, NNMi displays the hostname of the server on which the NNM iSPI
software and device extensions are installed.

l Other.

Other extensions that enhance NNMi functionality (independent of any NNM iSPI).
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System Information: Integrations Tab
To display the NNMi System Information, select Help→ System Information. The System Information
popup provides a wealth of current information about NNMi.

Note: The information available depends on your assigned NNMi role.

For information about each tab:

l NNMi Guest User:

l NNMi Level 1 Operator:

l NNMi Level 2 Operator:

l NNMi Administrator:

Integrations tab: A table listing the other software products deployed on your NNMi management server
that integrate with NNMi. This table includes the following columns of information:

l Name of the integration

l Identifier text string

l Version number

l A link that displays the actual configuration file currently in use for the selected integration.

System Information: Devices Tab
To display the NNMi System Information, select Help→ System Information. The System Information
popup provides a wealth of current information about NNMi.

Note: The information available depends on your assigned NNMi role.

For information about each tab:

l NNMi Guest User:

l NNMi Level 1 Operator:

l NNMi Level 2 Operator:

l NNMi Administrator:

Devices tab: A table listing the currently available Device Extension Information. This table includes the
following columns of information:

l Name of the device extension

l Identifier text string

l Version number

l A link that displays the actual configuration file currently in use for the selected device extension.
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System Information: Component Versions Tab
To display the NNMi System Information, select Help→ System Information. The System Information
popup provides a wealth of current information about NNMi.

Note: The information available depends on your assigned NNMi role.

For information about each tab:

l NNMi Guest User:

l NNMi Level 1 Operator:

l NNMi Level 2 Operator:

l NNMi Administrator:

Component Versions tab: Lists each NNMi component in your NNMi software by name and version
number. Each component is a subset of the code that comprises the NNMi software.
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Chapter 13: Displaying NNMi Version and
License Information
Select Help→ About HP Network Node Manager i Software to display the following information:

l The name of the NNMi product currently installed:

l Network Node Manager i

l The current version number of NNMi.

l Type will be one of the following:

Instant-On NNMi provides a 60-day 250 Node license automatically during installation.

Community This means the free trial version of NNMi is installed.

Capacity This means NNMi is installed.

Capacity(Adv) This means NNMi Advanced is installed.

Premium This means NNMi Premium is installed.

Ultimate This means NNMi Ultimate is installed.

Tip: See also Help→ System Information, and navigate to the "System Information: Product Tab"
on page 180 and "System Information: Extensions Tab" on page 187.
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Glossary

A

AES
Advanced Encryption Standard

Anycast Rendezvous Point IP Address
Rendezvous Point addresses are loopback
addresses used for routers in multi-cast
network configurations.

Autonomous System
An Autonomous System (AS) is a collection of
connected Internet Protocol (IP) routing
prefixes that present a common, clearly
defined Border Gateway Protocol (BPG)
routing policy to the Internet by having an
officially registered Autonomous System
Number (ASN).

B

BGP
Border Gateway Protocol

C

Causal Engine
The NNMi Causal Engine analyzes the health
of your network and provides the ongoing
health status reading for each device. The
Causal Engine also extensively evaluates
problems and determines the root cause for
you, whenever possible, sending incidents to
notify you of problems. Any incident
generated from a Causal Engine
management event has an Origin of NNMi in
your incident views.

CBC
Cipher Block Chaining

CE
Customer Edge router. The router in your
network that sends data to an Internet
Service Provider's router (the Provider Edge)
on the path to the data's final desination.

CRC
Cyclic Redundancy Check

Custom Node Collection
A Custom Node Collection identifies a
topology node that has at least one
associated Custom Poller Policy. Because a
topology node can be associated with more
than one Policy, the same topology node
might appear in multiple Custom Node
Collections.

Custom Polled Instance
A Custom Polled Instance represents the
results of a MIB variable when it is evaluated
against a node. The first time a MIB variable
is validated with discovery information, the
results appear in the Monitoring workspace's
Custom Polled Instances view. The Custom
Polled Instance is updated whenever a
change in State occurs and includes the most
recent polled value that caused the State to
change. These results are then used to
determine the Status of the associated
Custom Node Collection.

Custom User Groups
Custom User Groups are the User Groups that
you create. These User Groups are additional
to the NNMi User Groups, which are those
User Groups that NNMi provides.

D

DES
Data Encryption Standard
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E

EIGRP
Enhanced Interior Gateway Routing Protocol

EVPN
Ethernet Virtual Private Network.

G

global unicast address
(2000:: to 3fff:ffff:ffff:ffff:ffff:ffff:ffff:ffff) A
publically routable IPv6 unicast address, used
for communication between nodes anywhere
on the internet. The first part of the address
is a global routing prefix in the 2000::/3
address space for your organization
(assigned by the Internet Service Providers).
The complete host address can either be
manually configured or automatically
assigned using IPv6 auto-configuration and
neighbor discovery.

H

HMAC
Hash-based Message Authentication Code

hops
A hop is a node representing any network
device, such as a workstation, gateway, or
switch, which is connected by a link with no
intermediate nodes.

HSRP
Hot Standby Router Protocol

hypervisor
The virtual machine manager in charge of
delegating various aspects from a pool of
resources to become virtual devices. The
delegations might be static or dynamic,
depending on the manufacture's
implementation. The type of virtual machines

being generated depends on the
manufacturer's implementation.

I

IPv6 link-local address
A non-routable IPv6 unicast address only used
for communication with other nodes on the
same link (LAN or VLAN). Link local addresses
cannot be used for communication that must
be forwarded through a router. IPv6 auto-
configuration automatically assigns a unique
link local address in the fe80::/10 address
space to each IPv6-enabled interface on a
system.

ISIS
Intermediate System to Intermediate System
Protocol

J

Jython
Jython is a programming language (successor
of JPython) uses Java class, instead of Python
modules.

K

Key Incident
Incidents with both: (1) Severity = other than
Normal. (2) Correlation Nature = equal to
Root Cause, Service Impact, Stream
Correlation, Rate Stream Correlation, Info, or
None.

L

Layer 2
Refers to the Data Link layer of the
multilayered communication model, Open
Systems Interconnection (OSI). The Data Link
layer moves data across the physical links in
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the network. The switches and switch-routers
are devices that redirect data messages at
the layer 2 level, using the destination Media
Access Control (MAC) address to determine
where to direct the message.

Layer 3
Refers to the Network layer of the
multilayered communication model, Open
Systems Interconnection (OSI). The Network
layer is concerned with knowing the address
of the neighboring nodes in the network,
selecting routes and quality of service, and
recognizing and forwarding incoming
messages to local host domains. The router
and switch-router are the devices that
redirect data messages at the Layer 3 level.
Everything in a subnet is connected at the
Layer 3 (IP) level.

Link Aggregation
Protocols used on Switches to configure
multiple Interfaces (Aggregation Member
Interfaces) to function as if they were one (an
Aggregator Interface). When two Aggregator
Interfaces establish a connection, that
connection is an Aggregator Layer 2
Connection. The Aggregator Layer 2
Connection appears on Layer 2 Neighbor View
maps as a thick line with an Interface icon at
each end (representing the Aggregator
Interface). When you double-click the thick
line, it converts into multiple thin lines
representing the participating Aggregation
Member Layer 2 Connections with their
Aggregation Member Interfaces at each end
of the lines.

loopback address
The address associated with the loopback
interface. The loopback interface is a virtual
interface on a device that provides a route
for internal communication. Many vendors
provide a specially configured loopback for
management purposes. Exact details of how
loopbacks are configured varies by vendor
and model. See each device's documentation

for details. NNMi identifies these loopback
addresses by using ifType Number 24,
softwareloopback from the IANA ifType-MIB.

M

MAC address
The Media Access Control address (hardware
address or physical address) that the factory
burns into a network adapter or device with
built-in networking capability. A MAC address
has six pairs of hexadecimal digits, separated
by colons or dashes. For example
02:1F:33:16:BC:55

MAC addresses
The Media Access Control address (hardware
address or physical address) that the factory
burns into a network adapter or device with
built-in networking capability. A MAC address
has six pairs of hexadecimal digits, separated
by colons or dashes. For example
02:1F:33:16:BC:55

MD5
Message-Digest algorithm 5

MIB file
Management Information Base files are the
basic building block of SNMP communication
protocol. SNMP Agents are configured to
respond to requests defined by a group of
supported MIB files.

MPLS
Multiprotocol Label Switching

multicast address
Used to identify a group of hosts joined into a
group. IPv4 multicast addresses are in the
range 224.0.0.0 to 239.255.255.255 and IPv6
multicast addresses have the prefix ff00::/8.
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multiconnection
A multiconnection is a thick line on a map
view between two Node icons, two Node
Group icons, or between a Node icon and a
Node Group icon (with no Interface icon or IP
Address icon at either end of the line). This
thick line represents a set of multiple
connections that have been combined to
preserve space and simplify the map. Your
NNMi administrator specifies the number of
connections that must exist before NNMi
condenses them into a multiconnection line
(User Interface Configuration's
Multiconnection Threshold attribute). Double-
click the thick line to convert it into the
original set of connections with Interface
icons or IP Address icons at either end of the
lines.

N

NAT
Network Address Translation. NNMi supports
the following protocols: Static Network
Address Translation, Dynamic Network
Address Translation, Dynamic Port Address
Translation.

NIC
Network Interface Controller

NNMi Role
Determined by your membership in one of
four special NNMi User Groups (NNMi
Administrators, NNMi Level 2 Operators, NNMi
Level 1 Operators, or NNMi Guest Users). This
membership determines what you can see
and do within the NNMi console.

NNMi User Group
NNMi User Groups are those User Groups
provided by NNMi. Users cannot access the
NNMi console until their User Account is
mapped to at least one of the following NNMi
User Groups: NNMi Administrators, NNMi Level
2 Operators, NNMi Level 1 Operators (with

more limited access privileges than Level 2
Operators), and NNMi Guest Users

Node
A physical or virtual collection of network
interfaces that NNMi can pragmatically
associate together.

O

OSPF
Open Shortest Path First Protocol

P

PE
Provider Edge router. The Internet Service
Provider's router that receives your data on
the path to your data's final desination. The
Customer Edge (CE) router in your network
connects to this PE.

private IP addresses
These are IPv4 addresses that can be reused
in home and office local area networks
(LANs). Following the standards set by RFC
1918 and RFC 4193 (10.*.*.*, 169.254.*.*,
172.16-31.*.*, and 192.168.*.*)

R

RAMS
HP Router Analytics Management System

routing prefixes
A network protocol technique used to shorten
or filter the amount of required routing
information in each packet by declaring a
prefix for an entire group of packets. This
prefix also indicated the number of bits in the
address.
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S

SHA
Secure Hash Algorithm

SNMP
Simple Network Management Protocol

SNMP Agent
Simple Network Management Protocol
(SNMP) is an Internet-standard protocol used
to manage devices on IP networks. The SNMP
Agent uses this protocol to report
information to authorized management
programs.

SOAP
Simple Object Access Protocol

Split Link Aggregation
Link Aggregation with more than two
endpoints. Some vendors refer to this as
Multi-Chassis Link Aggregation, SLAG, MLAG,
or MC-LAG.

U

unique local address
(fd00:: to fdff:ffff:ffff:ffff:ffff:ffff:ffff:ffff) A
privately routable IPv6 unicast address used
only for communication between nodes
within your organization. The unique local
addresses cannot be routed to the public
internet. The address consists of a routing
prefix in the fd00:/8 address spaces, assigned
locally by your organization. And the full host
address might be manually configured or
automatically assigned using IPv6 auto-
configuration and neighbor discovery.

Unmanaged
Indicates the Management Mode is "Not
Managed" or "Out of Service".

USM
User-based Security Model

UUID
Universally Unique Object Identifier, which is
unique across all databases.

V

virtual machine
A device that utilizes components from
multiple physical devices. Depending on the
manufacture's implementation, the virtual
machine may be static or dynamic.

VMware
VMware ESX and VMware ESXi software uses
SOAP protocol to implement bare-metal
hypervisors.

VRRP
Virtual Router Redundancy Protocol

W

WAN Cloud
Layer 3 connectivity between your network
and any MPLS networks.

Web Agent
The Web Agent represents a management
service running on a device and contains the
settings NNMi uses to communicate with the
device.



Send Documentation Feedback
If you have comments about this document, you can contact the documentation team by email. If an
email client is configured on this system, click the link above and an email window opens with the
following information in the subject line:

Feedback on Online Help: Using the Console (Network Node Manager i Software 10.10)

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a web mail client, and
send your feedback to network-management-doc-feedback@hpe.com.

We appreciate your feedback!
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