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XS 9.50 Patch 04 for Windows

This patch includes defects corrections as well as support for Cloud Service Automation (CSA) 4.5,
SAP BusinessObjects Enterprise (BOE) 4.1 SP3, SAP BusinessObjects Data Services (BODS) 4.2
SP04, and Service Manager (SM) 9.41.

Installation Instructions for Patch 04

Before you begin

Note: Before installing XS 9.50 Patch 0004, you must upgrade SAP BusinessObjects Enterprise
(BOE) and SAP BusinessObjects Data Services (BODS).

Review all instructions and the Hewlett-Packard SupportLine User Guide or your Hewlett-Packard
support terms and conditions for precautions, scope of license, restrictions, and, limitation of liability
and warranties, before installing this patch.

Prerequisites

Before you install the patch, perform the following steps:

Back up your customized files.

Back up your databases.

Ensure Java 7 is installed.

Make sure XS is working before starting the patch installation.

a oD~

Go to the HP Software Support Online web site at: https://softwaresupport.hp.com/ go to
Product Information > Downloads, and search and download HP IT Executive Scorecard 9.50
Patch 004.
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Patch Installation for single server configuration

1. Upgrade BOE and BODS:

a. Toupgrade SAP BusinessObjects Enterprise (BOE), double click BIPLATSVR4103_0-
20010870.EXEand follow the wizard.

This procedure might take more than 2 hours.

b. Toupgrade SAP BusinessObjects Data Services (BODS), double click DS4204_0-
20011165.EXE and follow the wizard.

c. Toupgrade the BODS repository after the upgrade of the BODS service has completed, click
Start > SAP data services 4.2 > Data Services Repository Manager. Log on and click the
Upgrade button

d. Restart the BOE server.
2. Install the Patch

Note: For an installation on 3 or 4 servers (distributed), install the patch (HPXS_
9.50.0004.exe) on each server including the BOE server.

a. Run HPXS_9.50.0004.exe.
b. Once the patch is installed, restart the relevant server.
The patch installation is complete.

Note: If you had deployed a data source before you installed the patch, you must redeploy it using
the following command:

$HPXS_HOME\agora\DataWarehouse\bin\dw_ds_automation.bat -task Redeploy -cp <CP_
name> where CP_name is the name of the content pack you activated in ADMIN > Data Source
Management.

Patch Installation for distributed configuration

Note: Make sure that the patch is first installed on the BOE server, then on the DWH server, and
last on the XS server, in that order.

1. Upgrade BOE and BODS:

Note: You must install the BOE upgrade and BODS upgrade on both the BOE and DWH
server.

2. Upgrade BOE and BODS on the BOE Server:

a. Toupgrade SAP BusinessObjects Enterprise (BOE), double click BIPLATSVR4103_0-
20010870.EXEand follow the wizard.

This procedure might take more than 2 hours.

b. Toupgrade SAP BusinessObjects Data Services (BODS), double click DS4204_0-
20011165.EXE and follow the wizard.

c. Restart the BOE server.
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3. Upgrade BOE and BODS on the DWH server:

a. Toupgrade SAP BusinessObjects Enterprise (BOE), double click BIPLATSVR4103_0-
20010870.EXEand follow the wizard.

This procedure might take more than 2 hours.

b. Toupgrade SAP BusinessObjects Data Services (BODS), double click DS4204_0-
20011165.EXE and follow the wizard.

c. Toupgrade the BODS repository after the upgrade of the BODS service has completed, click
Start > SAP data services 4.2 > Data Services Repository Manager. Log on and click the
Upgrade button

d. Restart the DWH server.
4. Install the Patch
« On the BOE server:
i. Run HPXS_9.50.0004.exe.
ii. Oncethe patchis installed, restart the BOE server.

e On the DWH server:
i. Run HPXS_9.50.0004.exe.
ii. Once the patchis installed, restart the DWH server.

« On the XS server:
i. Run HPXS_9.50.0004.exe.
ii. Oncethe patchis installed, restart the XS server.

The patch installation is complete.

Configure BOE and XS using the HTTPS proxy to access the
report

For a single server configuration:
Proceed as follows:

1. Open <BOE_install_driver>\Program Files (x86)\SAP
BusinessObjects\Tomcat\confiserver.xml.

2. Remove the comment for the connector with port 8443 and modify it as below:

<Connector port="8443" protocol="HTTP/1.1" SSLEnabled="true"
maxThreads="150" scheme="https" secure="true"
keystoreFile="C:\HPXS\agora\jdk\jre\lib\security\cacerts"
keystorePass="changeit"

clientAuth="false" sslProtocol="TLS" />

3. Restart Tomcat in the Central Configuration Manager (CCM) of BOE.
4. Update the BO open docking port in database.
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Change the BO open docking port in the management database using the command:

UPDATE [dbo].[SETTINGS_MANAGEMENT] set VALUE = 8443
Where CONTEXT = 'bo' and NAME = 'bo.cms.opendoc.port’

5. Change the BO open doc protocol TP HTTPS in the BO settings XML located at:
<HPXS>\agora\glassfish\glassfish\domains\BTOA\config\settings\bo-settings.xml

<setting name="bo.cms.protocol”
sectionKey="sections.bo"
nameKey="settings.bo.cms.protocol.name"
descKey="settings.bo.cms.protocol.desc"
refreshRate="Immediate"
displayInUI="false"
settingType="tenant">
<string>https</string>

</setting>

6. Restart the XS service.

For a distributed configuration:

o On the BOE server:
Proceed as follows:
a. Onthe BOE server, run the following commands:

i. c:\\HPXS\agora\jdk\jre\bin\keytool —genkey —alias tomcat —keyalg RSA —keystore
c:\ssl\.keystore

ii. c:\\HPXS\agora\webserver\bin\openssl genrsa —des3 —out c:\ssl\server.key 4096

iii. c:\\HPXS\agora\webserver\bin\openssl req —new —key c:\ssl\server.key —out
c:\ssl\server.csr

iv. c:\HPXS\agora\webserver\bin\openssl x509 —req —days 999 —in c:\ssl\server.csr —
signkey c:\ssl\server.key —out c:\ssl\server.crt

v. c:\HPXS\agora\jdk\jre\bin\keytool —import —alias root —keystore
<HPXS>\ssl\.keystore —trustcacerts —file <HPXS>\ssl\server.crt

b. Open <BOE install driver>:\Program Files (x86)\SAP
BusinessObjects\Tomcat\confiserver.xml.

c. Remove the comment for the connector with port 8443 and modify it as below:

<Connector port="8443" protocol="HTTP/1.1" SSLEnabled="true"
maxThreads="150" scheme="https" secure="true"
keystoreFile="C:\ssl\.keystore"

keystorePass="changeit"

clientAuth="false" sslProtocol="TLS" />

d. Restart Tomcat in the Central Configuration Manager (CCM) of BOE.
« Update the BO open docking port in database:
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Change the BO open docking port in the management database using the command:

UPDATE [dbo].[SETTINGS _MANAGEMENT] set VALUE = 8443
Where CONTEXT = 'bo' and NAME = 'bo.cms.opendoc.port’

« On the XS server:

a. Change the BO open doc protocol TP HTTPS in the BO settings XML located at:
<HPXS>\agora\glassfish\glassfish\domains\BTOA\config\settings\bo-settings.xml

<setting name="bo.cms.protocol”
sectionKey="sections.bo"
nameKey="settings.bo.cms.protocol.name"
descKey="settings.bo.cms.protocol.desc"
refreshRate="Immediate"
displayInUI="false"
settingType="tenant">
<string>https</string>

</setting>

b. Restart the XS service.

c. Access the BOE CMC (for example: https://<boe_name>.fpazsh.com/BOE/CMC), and install
its certificate under Intermediate Certification Authorities and Trusted Root Certification
Authorities by clicking the certification error, and then exporting the certification.

Additional Steps Related to the CSA Content Update

If you want to work with the Patch 004 CSA Content Pack for CSA, perform the following steps:

1. Ifthe CSA data source was activated in the system prior to installing the patch, perform the steps
below to redeploy CSA content pack and reactivate CSA data source.

a. Open the cmd window in the DWH server, go to the DWH bin folder, using the following
command:
cd %BTOA_HOME%\DataWarehouse\bin

b. Deactivate the CSA datasource, if it was previously activated, by executing the command:
dw_ds_automation.bat -task DeActivate -cp CSA

c. Re-deploy the CSA Content Pack by executing the command:
dw_ds_automation.bat -task Redeploy -cp CSA

d. Reactivate the CSA datasource by executing the command:
dw_ds_automation.bat -task Activate -cp CSA

2. If you upgraded from XS 9.50 to XS 9.50 Patch 004, it is recommended to clean the previous
data of the CSA-related entities “BILLING” and "SUBSCRIPTION". To do so, perform the steps
below:

a. Open the cmd window in the DWH server, go to the DWH bin folder, using the command:
cd %BTOA_HOME%\DataWarehouse\bin

b. Execute the command:
dw_abc_cleandata.bat —batch 1 —entity SUBSCRIPTION,BILLING

Log onto XS, click Admin > ETL Management.

Inthe DW ABC Streams Management page that opens, select Show hidden streams.
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e. Thenrun the Cleandata stream.

After this stream completes, the historical data for the entities "BILLING" and
"SUBSCRIPTION" is cleaned up. You can now run a new ETL load to reload the data.
3. If you upgraded from XS 9.50 patch 3, execute the following SQL in the STAGING database:
INSERT INTO DWS.CSA_SUBSCRIPTIONUSER_TSNP (
MD_BATCH_ID , MD_PROCESS_ID , MD_CP_ID ,
MD_BUSINESS_KEY , SUBSCRIPTION_ID |,
UPDATETIME, USER_IDENTIFIER )
SELECT T.MD_BATCH_ID , T.MD_PROCESS_ID , T.MD_CP_ID ,
T.SUBSCRIPTION_ID + ':' + T.PERSON_ID AS MD_BUSINESS_ KEY,
T.SUBSCRIPTION_ID ,
T.UPDATETIME , T.PERSON_ID
FROM DWS.CSA_SUBSCRIPTION_TSNP T ;
COMMIT;
4. If you upgraded from XS 9.50, perform the steps below to import one work flow into BODS:

a. Open the cmd window on the DWH server, go to the DWH bin folder, and execute the
command:
cd %BTOA_HOME%\DataWarehouse\bin

b. Execute the command:
dw_bods_xml_import.bat -fromfile %BTOA _
HOME%\ContentPacks\Core\ETL\entities\BILLING\BILLING_MSI_WF.xml -verbose

5. If you want to upload the upgraded CSA_CAP or CSA_CAP_Demo CAPs, you must
upgrade the CAPs by performing the following steps:

a. Logonto XS, and click Admin > Content Acceleration Packs.

b. Deactivatethe CSA_CAP or CSA Demo CAP CAP ifitis active. For details, see
"Deactivate a CAP" in the Guide to XS Content Acceleration Packs.

Delete the CAP.
Upload the new CAP to XS from the following location:

o CSA_CAP: %BTOA_
HOME%\glassfish\glassfish\domains\BTOA\config\cap\import\languages\en_
US\CSA_CAP.zip

o CSA Demo CAP: %BTOA_
HOME%\glassfish\glassfish\domains\BTOA\config\cap\import\languages\en_
US\CSA_Demo_CAP.zip

For details, see "Upload a CAP" in the Guide to XS Content Acceleration Packs.

e. Activate the CAP. For details, see "Activate a CAP" in the Guide to XS Content Acceleration
Packs.

6. If your XS was upgraded from 9.50 and CSA_CAP was not activated in the system prior to
installing the patch, perform the steps below to update the CSA_CAP.

a. Logonto XS and click Admin> Content Acceleration Pack.
b. Deletethe CSA _CAP.
¢. Upload the new CAP to XS from the following location:
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o CSA_CAP: %BTOA_
HOME%\glassfish\glassfish\domains\BTOA\config\cap\import\languages\en_
US\CSA_CAP.zip

o CSA Demo CAP: %BTOA_
HOME%\glassfish\glassfish\domains\BTOA\config\cap\import\languages\en_
US\CSA_Demo_CAP.zip

For details, see "Upload a CAP" in the Guide to XS Content Acceleration Packs. Activate the
CAP. For details, see "Activate a CAP" in the Guide to XS Content Acceleration Packs.
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Uninstallation Instructions for Patch 0004

Note: You cannot uninstall Patch 0004 once you have installed it.
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Defects Corrected in the XS 9.50 Patch 04 for
Windows

XS 9.50 Patch 04 for Windows supersedes the XS 9.50 Patch 03, Patch 02, and Patch 01 for
Windows.

XS 9.50 Patch 04 for Windows corrects the following:

Change
Request Description

QCCR8B20814 XS 9.50 help seems refers to old HP Anywhere (HPA) software, not to the soon to be
released new client.

For the latest information about Executive Scorecard (XS) on mobile devices, see
Getting Started with the XS on Mobiles App Powered by Executive Scorecard available
at KM01081359

QCCR8B21266 XS - CAP - activate CSA_CAP first and then activate the CSA_CAP_DEMO, the KPI
calculation for CSA_CloudOptimization does not complete.

QCCR8B21334 Breakdown names are not displayed in components.
QCCR8B21374 SM KPI: Mean Time To Resolve Customer Incident formula is incorrect.
QCCR8B21375 SM KPI: % Of Problems Reported By Customers formula is incorrect.

QCCR8B21376 SM KPI: The name and formula of % of Problems Resolved by Due Date are not
consistent.

QCCR8B21453 Application - Explorer - user should not be able to edit the annotations which are
added by other users.

QCCR8B21569 = CSAETL; ABC aborts the source extraction job when it meets timeout issue instead of
retrying it.

QCCR8B21573 = Application - Number of digits after Decimal Point configuration and presentation.

By default, the total number of the digits displayed for KPI/Metric is up to 6 digits and
the number of digits after the decimal point for KPI/Metric results is up to 5 digits.

To work with a different default, click Admin > Scorecard > XS Settings>Total
number of digits displayed for KPI/Metric results setting and change the default to
any number between 3 and 6. The new thresholds are then updated automatically for
all KPls.

The Admin > Scorecard > XS Settings > Number of digits after decimal point for
KP1/Metric results was added to complement the capabilities. Change the default
number of digits after the decimal point to any number between 0 and 5. For details,
see "Decimal Precision" on page 57 or KM01855072.

QCCR8B21948 SM PinkVerify - Add Breakdown Location for Number of Opened requests KPI.
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Change
Request

QCCR8B22405

QCCR8B22592

QCCR8B22644

QCCR8B22669

QCCR8B22703

QCCR8B22757

QCCR8B22851

QCCR8B22866

QCCR8B23059

QCCR8B23116

QCCR8B23129

QCCR8B23222

QCCR8B23254
QCCR8B23267

QCCR8B23739

QCCR8B23840
QCCR8B23966
QCCR8B24022
QCCR8B24061

QCCR8B24087

HP IT Executive Scorecard (9.50)

Description
Source Extractor - AWS/AWSCW: AWS/AWSCW extractor failed after SDK update.

Error occurs while running the billing report after configuring the LDAP
authentication when the user name includes spaces.

The Additional Information button is not enabled on Explorer pop-up dialog for KPlIs.

CSA - Limitation: The modification initial values are not calculated when the
subscription is modified with different initial charges - only recurring charges are
updated in the Showback report.

CSA Webi report: The default period of the CSA BO report should not be from 1970 to
2010.

Document: A note regarding the configuration of LDAP in a distributed environment
was added to the documentation.

More than one BO Webi report with input controls do not work wellin the Google
Chrome browser.

FBI - AWSCW: The data cannot be extracted because of the endpoint.

Scorecard - Configure Component Dialog Box - manual order arrows - there are 2
"down" arrows by default.

BO report: 'Refresh on open' window pops up when opening the Webi Report View
component in XS 9.50.

Metrics: When using the page filter, the 'last closed period' is used for calculations
and displays instead of the period set in the Metric configuration window in the
Studio.

Dashboard, Scorecard component: Missing scroll bar to display all items in the
Scorecard component if there are many items.

Unable to launch BO reports from Additional Info section on IE9 browsers.
CSAKPI: Incorrect formula for Service Subscription Lifespan KPI.

Dashboard: The name format of the breakdown displayed on the dashboard is
Entity+Dimension and not the Breakdown name defined by the user in the Studio.

Pop up Java Applet unreachable error when log on XS.

XS cannot connect to UCMDB when it requires client authentication (CAC).

XS cannot connect to CSA when CSAis configured to use client authentication.
XS cannot be started by supervisor.

DWH - PPM - ETL: XFR_FACT_JB failed for request is updated to support both
dimensions and facts in SM, but in PPM it only support dimensions.
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Enhancements Added in the XS 9.50 Patch 04 for
Windows

The enhancements added to the Patch are as follows:

Enhancement
Request Description

QCCR8B20473  Updating from trial to permanent license in distributed environment.
Workaround:
1. HP Support need to provide the BO/BODS licenses.

2. The XS installation then needs to be run once only, on the DWH server.

QCCR8B20473 Documentation Enhancement Request: Updating from trial to permanent license in
Distributed environments.
For details, see "Update from a Trial License to a Permanent License in Distributed
Environments" on page 14 or KM01837431.

QCCR8B23022 Enhancement: Enable CAC on XS. For details, see "Configure CAC" on page 39 or
KM01855433.

QCCR8B23966 XS cannot connect to UCMDB when it requires client authentication (CAC).

QCCR8B24022 XS cannot connect to CSA when CSAis configured to use client authentication

New Certifications
Cloud Server Automation (CSA) 4.5 is supported.

Note: Make sure to install CSA 4.5 with CSA 4.50.0001 if you are planning to use the CSA-Billing
Statement for Cloud Services report.

SAP BusinessObjects Enterprise (BOE) 4.1 SP3 & SAP BusinessObjects Data Services (BODS) 4.2
SP04 are certified.

Service Manager (SM) 9.41 is supported.
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Documentation Changes Related to Patch 0004

The documentation changes related to Patch 0004 are as follows:

The "Update from a Trial License to a Permanent License in Distributed Environments" on the next
page (QCCR8B20473) section is new. It is also provided in the KM01837431. It does not appear in
the latest Administrator Guide.

The "Connect to CAC-enabled UCMDB Server" on page 28 section was added to the "Activate the
UCMDB Data Source" on page 19. The section is also provided in KM01855061. It does not appear
in the latest relevant Content Reference Guide.

The "Configure CAC" on page 39 section describes how to enable CAC for XS. This section is new
and is only provided in this document or in KIM01855433.

The "Decimal Precision” on page 57 section (QCCR8B21573) provides details about the new
setting: Max number of digits after decimal point. The setting is new and is only provided in this
document or in KM01855072.

In XS installation, you do not have to configure the SQL server with Windows authentication. The
Installation Guide for XS 9.50 was fixed and republished. The information is also avaiable in
KM01275262.

Database Migration step - dw_ds_import.bat failed. For the corrected document, see KM01837431.

HP IT Executive Scorecard (9.50) Page 13 of 68


https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM01837431
https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM01855061
https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM01855433
https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM01855072
https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM01275262
https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM01837431

Update from a Trial License to a Permanent
License in Distributed Environments

This section describes how to update from a trial to a permanent license in distributed environments.
Note: The license renewal must be performed on the server where DWH is installed.

Log on to the XS (DWH) server.

2. Inthe start menu, click Start > HP Executive Scorecard > Administration > License
Renewal.
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3. Inthe Introduction page of the Configuration Wizard for the renewal of licenses, click Next.
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£8) Configuration Wizard

a3 Introduction

o

® Introduction This corfiguration wizard guides you through the configuration required to complete the license renewal process,

® | icense Management

® Summary

4. Inthe License Management - Load a Power Named User License page, click Next.

HP IT Executive Scorecard (9.50)
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@Eonﬁguration Wizard [_ ]
a License Management - Load a Power Named User License @
® Introduction A validd Power Mamed User License was found.

#® License Management

® Summary

o A valid Power Mamed User License was found.

In the License Management - Load a Casual Named User/Viewer License page, click Next.

5.
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@Eonﬁguration Wizard M= B3
3 License Management - Load a Casual Named User/'\Viewer License ®
® |ntrocuction

#® License Management

= ,
& Summary Load & Casual Named User/Viewer License. If it is not available, please click Next to continue.

Click the Load button to load a license file

A

6. Inthe Summary page, click Finish.
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@Eonﬁguration Wizard

=)
Summary ®
A v
® Introduction Configuration Wizard completed successfully.
R CEiEEEnEng e o Operation completed successfully.
® Summary
A

Note that the license configuration wizard updates the log file located at:
%BTOA_HOME%\confwizard\log\ConfigWizard.log.
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Activate the UCMDB Data Source

The purpose of the integration of UCMDB as a data source is to bring quality management information
into the Data Warehouse.

To access:

Select ADMIN > Data Management > Connect Data Source then click Add data source and select
UCMDB to activate the integration processes for the UCMDB data source.

| earn More

« Content Packs and their functionality

To learn about Content Packs and their functionality, see Connect the Data Source in the
Administrator Guide.

« FBI Integration:

An extractor using the File Based Integration mechanism that extracts entities from the UCMDB
source and generates corresponding flat files. For details, see Connect the Data Source in the
Administrator Guide. The UCMDB FBI extractor is used by both BSM and UCMDB.

« UCMDB Push Adapter:

A package installed on the UCMDB server that can push data into XS Data Warehouse database.
The relevant XSinformation is set when you deploy the push adapter. You can then use the push
adapter to access certain data based on the query you configure. For details, see "Access and
Deploy the UCMDB Push Adapter" on page 21

Important Information

« UCMDB supports multiple instances of the Content Pack.

« If youwork with IT Financial Management (ITFM), this data source is not supported. When you
activate this data source, the ITFM application displays No data.

« Allfields are case-sensitive.

: Tasks

This section includes:

® Activate the Integration ... ... . 20
® Connect to UCMDB on a Secured Connection ... ... .. ... 20
* Consolidate Between BSMand UCMDB ... .. 20
® Access and Deploy the UCMDB Push Adapter .. ... . 21
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® Connect to CAC-enabled UCMDB SerVer ... ... 28

Activate the Integration

1. Important Note: First day of the week

In Data Warehouse, the first day of the week is set in the Post-Install wizard, and the Period tool is
using is as an input to build PERIOD_DIM days, weeks, months, and more, as well as relevant
hierarchies.

After the administrator has installed Data Warehouse, the administrator selects the cooperation
first-day-of-week. If the data source has a different first-day-of-week definition, the administrator
should be aware that for weekly periodicity, the linkage to the period key uses the Data
Warehouse week definition and not the data source week definition.

Select ADMIN > Data Management > Connect Data Source then click Add data source.
The Add Data Source page opens. Select the UCMDB data source type.
Select or enter the configuration parameters.

o M oD

Click Next to proceed to the validation page.

Note: Before reactivating the UCMDB data source, click Edit Settings and enter the Username
and Password.

Connect to UCMDB on a Secured Connection

1. Export the UCMDB SSL certificate to a file. For details, see the UCMDB Hardening Guide
available in the HP Software Product Manual Site
(http://support.openview.hp.com/selfsolve/manuals).

2. Reveal the UCMDB certificate to Data Warehouse as follows:

Import the SSL certificate trusted by the UCMDB server into the JDK key store using a tool
provided by the JDK called keytool.exe by running the command :

<HP-XS>\jdk\jre\bin\keytool -importcert -alias <alias> -file <file> -keystore
<HP-XS>\agoral\jdk\jre\lib\security\cacerts -trustcacerts

Note: The default password for JVM keystore is a 'changeit'. If this password wasn't
changed before, use the default keystore password for certificate import.

3. Restart the XS server.
4. Select Is secured in the activation parameters page.
5. Change the port to a secured port (default is 8080).

Consolidate Between BSM and UCMDB

Business Services and Infrastructure Services are automatically consolidated between BSM and
UCMDB during ETL.

Note: You must perform synchronization of BSM and UCMDB before each time you run the ETL,
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to enable consolidation between these sources.

Access and Deploy the UCMDB Push Adapter

The UCMDB push adapter enables you to access data links and nodes from UCMDB, which are then
pushed into the Data Warehouse. You can deploy the push adapter on the UCMDB server and
schedule the execution time of the adapter. You can also configure the adapter integration and add an
integration point in the Integration Studio.

You must deploy the push adapter package when the UCMDB Content Pack is activated in the
Connect Data Source Ul, and before the first run of the ETL in order to get the Node, Application and
Services topology from UCMDB.

This section includes:

Deploy the push adapter package in Package Manager

1.
2.
3.

In UCMDB, navigate to Administration > Package Manager.
Select Deploy package to server (from local disk) then click Add.
Select the XSpush adapter package from and then click Open.

The new adapter is deployed and displayed in the Adapters list.
Badipens ____________________________________________________________________ m=g|

v [ [ search sdapers

g( ;.v| ~ Computer v Mew Yolume (D:) ~ HPSS ~ agora = DataWarehouse - integration ~ adapters =

Organize »  Includeinlbrary »  Sharewith v  New folder = - 0O @

[ Picturss Al e - Date modfied - Size |

B videos

B xs-ucmdb-push-adapter.zip 6/18/2014 10:34 AN WinRAR ZIP archive 533K

18 computer
&2, Local Disk (C2)
busingssobiects
sdb
app
Builds
& Config.msi
datafiles
Fixes
HPXs
inetpub
PerfLogs
Program Files
Program Files (€
Programbata
SEOPWebapp_Bl
SEOPWebapp_M
SEOPWebapp_0
sqldeveloper-2.1
Lsers
Windows
B chrome-30.0,15¢
» New Volume (D:)
% TTA (\GdcentsT\se

€ Metwork

1 itern

Deployment Limitation

If you deploy an incorrect version of the push adapter you need to redeploy as follows:

1.
2.

Delete the relevant Integration Point in Data Flow Management > Integration Studio.
Un-deploy the package in Administration > Package Manager. If necessary, delete the package
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directory manually, as follows.
a. Stopthe UCMDB server: Start > All Programs > HP UCMDB > Stop HP Universal

CMDB Server.

b. Delete the XS adapter directory, for example,

C:\hp\UCMDB\UCMDBServer\runtime\fcmdb\CodeBase\XSAdapter.
c. Startthe UCMDB server: Start > All Programs > HP UCMDB > Start HP Universal

CMDB Server.

d. Deploy the adapter package using the Package Manager.

Locate the adapter in Adapter Management
1. InUCMDB, navigate to Data Flow Management > Adapter Management.

2. Select XSUcmdbAdapter in the Resources area.

3. Expand Adapters and select XSAdapter to check the adapter definition.

Magagers ~ \View~ Tools» Help ~

Data Flow Probe Sstup

7
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& &) Oraciespps
Dizcovery Control Panel B push-sdapter
) Somples
| - SAP_tkecovery
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aF ServiceCenter Adapters-2
@ ServicaManagerSdapter 7L
ﬂ ServiceManager Adapter 7-1
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Cisplay MName _Exccun.'l.- Soorecand
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Type: javia_ncdagber
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Input

Input €I Type: | destination_canfig
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_ =) WenServer destinationkd
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Add the XS integration point in the Integration Studio

Note: For UCMDB version 10.0, see the procedure below.

In UCMDB, navigate to Data Flow Management > Integration Studio.
In the Integration Point area, select New Integration Point.

Enter the integration name, for example, XS.

Select Executive Scorecard from the Adapter list.

o M Dd =

In Adapter Properties, enter the following.
« Hostname/IP: The XS database.

o Port: 1433.
« Database: The XS DWH staging database name.
« Database Schema: dws

« Credentials: Browse to select SQL protocol, and add new credentials.

i. Enterauser, the Microsoft SQL Server for Database Type, leave default values for Port
Number and Connection Timeout, and enter User and Password to connect to the XS
DWH database.

ii. Click OK.

iii. Select the new created credential and click OK.

6. Click Test Connection.
7. Click OK in the New Integration Point dialog box.
The new integration point is created and added into Integration Point area.
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Note: If the integration point already exists, a message appears accordingly.

)

| | Hew Integration Point

Integration Properties

* iniegration Hame €5

i egrstion IDescriplion

dnphar Eascuve Scorscard
Iz ntegrotion Activated )

Adapter Properties

®  HoginameiP 16.186.72 147

& Port 1432

* [Catabaze FRASELVMZ STG

*  Credentisls

Add an integration point using UCMDB version 10.0

1. InUCMDB, navigate to Data Flow Management > Integration Studio.

Enter the integration name, for example, XS.

Select the Is Integration Activated checkbox.

A

In Adapter Properties, enter the following.
« Hostname/IP: The XS database.

« Port: 1433.

« Database: The XS DWH staging database name.

¢ Schema: dws

« Credentials ID: Browse to select SQL protocol, and add new credentials.

In the Integration Point area, select New Integration Point.

Select Executive Scorecard and then select XS push job and federation from the Adapter list.

i. Enterauser, the Microsoft SQL Server for Database Type, leave default values for Port
Number and Connection Timeout, and enter User and Password to connect to the XS

DWH database.
ii. Click OK.

HP IT Executive Scorecard (9.50)

Page 24 of 68



XS 9.50 Patch 04

iii. Select the new created credential and click OK.
- Data Flow Probe: Select a Probe that has IP of the XS database in range.

7. Click Test Connection.
8. Click OK inthe New Integration Point dialog box.
The new integration point is created and added into Integration Point area.

9 Edit Integration Point

f Edit Integration Point

Integration Properties

*  Integration Mame

Integration Description | |

Adapter ?

Iz Integration Activated

Adapter Properties

*  Hostname/IP |16.186.79.17 |«
* Port 11433 |
* Database | ITAVM2KBRZENBS_STG |3
* Schema | dws |
*  Credentialz 1D Generic DB Protocol (SGL): Generic DB Protocol (SQL) Credential 1
* Data Flow Probe | PFDEVXS930VMPDY =] 4

*  Mandstory Properties

Edit a push job
1. InUCMDB, navigate to Data Flow Management > Integration Studio.
2. Select the job you want to edit from the Integration Point area.
3. Edit the properties and add queries, as required.
4

In the Scheduler Definition area, select the repeat frequency, start time, end time and time zone
for the job and click OK. Make sure that the Allow Deletion checkbox is selected.
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EAEdit Integration Job
y} Edit Integration Job
Define the Integration Job details and scheduling information

wa

Jab Definition
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® v il
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Yoo smrn | s aw mho o sono [=] & Sarvar e “IEF D5 BB A

Change or add TQL queries

After the Push Adapter is deployed, Application_To_Node, Application_To_Service, Service_To_
Application, Service_To_Node are added automatically. You can change these queries or add a new

TQL query.
Note: You must use the required naming convention, for example, Application_To_Node.

1. InUCMDB, view the XS push adapter list of OOTB queries in the Resources area of the Modeling
Studio.

2. You can modify a query by opening the query definitions. Click Save and the changes are added to
the adapter.
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Integration Studio.
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Enter a new name and then proceed to editing the query in the XS push job you created in the

Select the job you want to edit from the Integration Point area.

Click h‘E’J to add the new query and click Save. The query is added to the XS list.
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Edit Integration Job
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Connect to CAC-enabled UCMDB Server

To connect XS with a Common Access Card-enabled UCMDB server, proceed as follows:

1. Import the UCMDB server certificate into XS jdk. (Like we import CSA certificate).

Steps for creating keystore files contains certain certificates with the p12 format:

a. Download KeyStore Explorer 5.1 from http://sourceforge.net/projects/keystore-
explorer/?source=typ_redirect and run it as the Administrator on any server with Windows but
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not on the XS server.
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b. Click File > New > JKS Radio button > OK.

/1 KeyStore Explorer 511 = | =

|_|
}I‘Dallh »XxhABRLAR=ORdE@QIAE|O

Mo KeyStore Loaded
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c. Click Tools > Import Key Pair >, select the PKCS #12 radio button, and click OK.

-

J~ Untitled-1 * - KeyStore Explorer 5.1.1 |ﬂ|

File Edit View Tools Examine Help
lNE e~ XABRIRE—OACdEQE| O
Untitled-1*

T |d |E EntryMName Algorithm Key Size Certificate Expiry Last Modified
' R
Import Key Pair Type | = |
Select the type of key pair import required:
|§| PKCS #12
() PKCS 8
g @ PVK i
(7) OpenssL
[ ok ][ cancel
]
\ A
]

KeyStore Type: JKS, Size: 0 Entries, Path: 'Untitled-1'

HP IT Executive Scorecard (9.50) Page 31 of 68



XS 9.50 Patch 04

d. Inthe dialog box that opens, click Browse to go to the relevant file Decryption Password
(certificate’s password), import de p12 key pair.

-

Untitled-1 * - KeyStore Explorer 5,11 | = | = x |

File Edit View Tools Examine Help

[ XhBRLAAT—ORcdd@A|®
Untitled-1* %

T |d |[E EntryName Algorithim Key Size Certificate Expiry Last Modified
rImport PKCS #12 Key Pair [ = J]
Decryption Password: |:|
PKCS #12Key Pair File: | | [ Browse ] [ Details ]
N |
[ import || Cancel |

KeyStore Type: JKS, Size: 0 Entries, Path: 'Untited-1'
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e.

Inthe New Key Pair Entry Alias dialog box, click OK for the default alias.

-

w

J - Untitled-1* - KeyStore Explarer 5.1.1 | = | = S _|1
File Edit View Tools Examine Help

NE e xhBRLRE—OACCQE|O

T | |[E EntryName Algorithim Key Size Certificate Expiry Last Modified

”
MNew Key Pair Entry Alias M
Enter Alias: administrator (jianchal.fp

ok cancel |

KeyStore Type: JKS, Size: 0 Entries, Path: 'Untitled-1'

f. Enter the password for the new key pair and click OK.
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s A
“ Untitled-1 * - KeyStere Explarer 5.1.1 (= 8] % |

FA!

File Edit View Tools Examine Help
NEerXhABRERARA—ORCCQL|O®
Untitled-1* ®

T/ |8 |E| Entry Name Algorithm Key Size Certificate Expiry Last Modified

.
" MNew Key Pair Entry Password u

S
enpemass

Lo J[ cond ]

KeyStore Type: JKS, Size: 0 Entries, Path: ‘Untited-1'
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g. The following message is displayed when the Key Pair is imported successfully.

Untitled-1 * - Key5tore Explorer 5.1.1

File Edit View Tools Examine Help
NEG e~ xhBRLEATE—O R LHQL|@

Untitled-1 ¥ %

T |d |E| EntryName Algorithm Key Size Certificate Expiry Last Modified
lﬂs' g @ administrator iancha... RSA 2048 07/ulf2025 11:14:35... 19/Aug/2015 10:29:5...
| Import Key Pair ﬁ

:' Key Pair Impeort Successful,

KeyStore Type: JKS, Size: 1 Entry, Path: 'Untiled-1'

h. Save the keystore (enter the same password from step f). When you Import the converted

keystore you must enter the same password.

Note:

« The keystore used for client SDK must be in Java Keystore format (JKS).

« The Java Cryptography Extension KeyStore (JCEKS) or other formats are not supported.

« The keystore used for SDK must contain only one key-pair and nothing else. The
password for this key-pair must be the same as the one for the keystore.

2. Select ADMIN > Data Management > Connect Data Source then click Add data source and

select UCMDB to activate the integration processes for the UCMDB data source.
Enter the relevant information, and select CAC ENABLED to enable the CAC feature.

4. Provide the path to the Client Certificate. The client certificate can be located in the XS server.
Once you have provided the path, XS uses it to setup a 2-way SSL authentication with the

UCMDB server.
5. Click Next to test the connection.
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o | Ul Description
UCMDB Activation Page

The data warehouse is connected to UCMDB through high-level integration processes. A set of
database views enables the extraction of the main UCMDB objects.

« With CAC:
Data Source Wizard Help %
UCMDE (Universal Configuration Managment Database)

*nstance name : \ucmdh |
UCMOB Version 110.11/10.2(CAC) v |
Time Zone . \AsiafCalcutta v |
Data Source Type : \UCMDE ~ |

*Certificate: | |

*Password: | |
*Port \BOSO0 |
*HostnamefIP Address: | 16.186.74. 166 |
*Customer Mame |Default Client |
Initial Load Period (months) : |6 v

| Next || cancel |
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o Without CAC:

Data Source Wizard Help %
UCMOB (Universal Canfiguration Managment Database)
*nstance name : ucmdhb
UCMDE Wersion . T0.0x 10, Tf 10, 2IMOM_C,,
Time Zone : AsiafCalcutta ~
Data Source Type: UCMDE ~
*sername ; admin
*Passwoard
[ Secured
*Port . 080
*Hostname/IP Address 16.186.74,186
*ustormer Mame Default Client
Initial Load Period (manths): B ~
| Mext | | Cancel |
Mandatory fields are marked with a red asterisk.
User interface elements are described below:
Ul Element Description
Instance name Enter a name for the data source instance you are activating.

UCMDB Version Select the relevant UCMDB version. For details, see the Support Matrix.

You can select to work with CAC or not.
Time Zone Select the time zone for the data source.

Data Source Type UCMDB. This parameter is read only.
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Ul Element
Certificate
Password

Username

Password

Is Secured
Port

Hostname/IP
Address

Customer Name

Initial Load
Period (months)

Description
The location of the UCMDB server's certificate file.
The password of the certificate file.

Enter the user name used to log on to CMDB. You must create a new integration
user in UCMDB for integration with XS.

Enter the password used to log on to CMDB. You must create a new integration
password in UCMDB for integration with XS.

Select if the server host is secured.
The port number. The default value is 8080.

Enter the server hostname or IP address of the server where the UCMDB is
installed.

Used for tenant client purposes. If no username is given, then Default Client is
displayed.

Select the number of months from which you want the initial data loaded.

(@ | Reference

List of Entities

List of Entities in Excel format

This document is available in the PDFs directory in the Installation DVD, is accessible from the Help
Center page in the online Help Center (documentation library), or from the HP Software Product Manual
Site (http://h20230.www2.hp.com/selfsolve/manuals).
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Configure CAC

This section explains how to configure Common Access Card (CAC) (Smart Card/PKI Authentication)
on XS.

Note: In a distributed environment, the Administrator must configure both the DWH server and the
XS server using the procedure provided below.

1. Prepare certificates.

To prepare the root Certificate Authority (CA) certificate and client certificates for the XS server,
copy the root CA certificate to the following path in the XS server:
$HPXS_HOME\agora\confikeys

Note: Apache uses PEM format certificates, so that the root certificate provided by the
customer must obey this rule.

If your certificate is DER binary format, please convert the binary certificate file into PEM format
using one of the following methods:

« Convert DER to PEM using: $ openssl x509 -inform der -in certificate.cer -out
certificate.pem

« Convert it with the online tool: https://www.sslshopper.com/ssl-converter.html

2. Configure the root CA in the XS Server.

Edit the %HPXS_HOME%\agora\webserver\confiextra\httpd-ssl.conf configuration file. In the
file, add following lines to enable the SSL authentication:

SSLCACertificateFile "../conf/keys/ca.cer "
JkOptions +ForwardSSLCertChain
<Location /bsf >
SSLVerifyClient optional
SSLVerifyDepth 10
SSLOptions +StdEnvVars +ExportCertData
</Location>

The highlighted values can vary depending on your CA certificate file name and verification depth.

Make sure the CA certificate (ca.cerfile) is located in the %HPXS_HOME%\agora\confikeys
folder.

3. Enable CAC mode in the XS Server.

In the XS server, edit the % HPXS _
HOME%\agora\glassfish\glassfish\domains\BTOA\config\confi\cac.properties property file.

a. Enable CAC mode.

Mark the following flag as true to enable CAC. The default value is false.
isCACEnabled=true

b. Set the Distinguished Name (DN) field for certificate extraction.

The following flag is used to indicate which field is "login name".
certificateFieldExtractDN=<certificate_standard>
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where <certificate_standard> can be either SUBJECT.E or SUBJECT.CN.

See the following example:

Certificate Details | i

|"|

Details | Certification Path

Shiow: [ <All= v]
Field Value it
= |valid from 201543530 8:00:00
(= | valid to 201653830 7:59:59 £
DSubject y@hp.com, Smart Ca... |E
= |Public key RSA (2048 Bits)
a CRL Distribution Paints [1]CRL Distribution Point: Distr...
i3 | Autharity Key Identifier KeylD=37ed f7 1579 2d 30 a...
3| Subject Key Identifier 9d 17 16 10 e5 4b Ob 59 76 c5...
mfh thiert Alternative Mame Fither Mame Princinal Name =l ~
E =l " ai@hp.com
OU = =mart Card
0l = Employment Status - Emplovees
0L = Computer Mame - .
oU = VPN-WEB-H
CN = .
0 = Hewlett-Packard Company

Edit Properties. .. [ Copy to File. .. ]

Learn mare about certificate details

L.

c. Enforce the client certificate validation using the following flag:

validationEnforced=<true|false>
o true. all validation strategies are enforced.
o false. the following validation strategies are ignored: LOCAL_CRL, ONLINE_CRL and so
on.
d. Choose validation strategy.
For example: validationStrategy=<validation_strategy>
where <validation_strategy> can be:
o LOCAL_CRL. Local Certificate Revocation Location (CRL) validation. Then make sure
that CRLStoreLocation is set as shown below.
o ONLINE_CRL. Online CRL validation. Then make sure that CRLDownloadURL is set as
shown below.
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o OCSP OCSP. Validation. Then make sure that OCSPResponderURL is set as shown
below. OCSP stands for Online Certificate Status Protocol.

o CER_TYPE. Smart card certificate validation.
o EXPIRATION. Certificate expiration validation.

Note: The validation strategy can be a combination of these values and the delimiters are
commas. For example:
validationStrategy=CER_TYPE, EXPIRATION

e. Set the root certificate path.
RootCertPath=<root_certificate_path>

where <root_certificate_path> is used for validation strategy. It can be: LOCAL_CRL,
ONLINE_CRL, or OCSP.

f. Set the store path.
CRLStoreLocation=LOCAL_CRL

This is used for validation strategy.

g. Settheonline CRL URL Path.
CRLDownloadURL=ONLINE_CRL

This is used for validation strategy.

h. Set the OCSP Responder URL.
OCSPResponderURL=0CSP

This is used for validation strategy.

i. Setthe OCSP Server cert.
OCSPServerCertPath=0CSP

This is used for validation strategy. If the value is not set, the OCSP Server cert used
RootCert instead.
4. Customize the content of the splash screen.

Once CAC is enabled, you MUST configure the splash screen to show a popup dialog that
displays agreement terms to the end user. The end user MUST agree to the terms to continue after
choosing the certificate for login.

The customized splash screen can be configured with pure html code in the following file:
%HPXS_
HOME%\agora\glassfish\glassfish\domains\BTOA\applications\bsfisplashScreen.html
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The splash screen with the default content is as follows:

HP IT Executive Scorecard

HF IT Executive Scorecard is a strategy enabler that enables executives to continuously improve their business by measuring what happened
and what iz happening, analyzng that information, and planming new strategies using the gathered information Thiz enables a better strategy
execution resulting i a reduction of cost and risk, and an mereasze m quality and value.

The following topics provide the main steps to follow to get started with the Studio and the Dashhoard:

* Learn about how the Executive Dashboard can help the challenges facing Executives.

o Ifake sure the HP IT Executive Scorecard settings are configured.

* MMake sure the HP IT Executive Scorecard users and permissions are configured.

* Create and activate Scorecards, Perspectives, Objectives, Metrics, and EPLs.

* Enrich the Dashboard contents with Metric Breakdowns and EPIz, overrides, Cascading Scorecards, and more.

* Beview the out-of-the-box Executive pages, add components to pages, create your own compotents, of create your own pages.
* The Executive user can now wiew and analyze the relevant business objectives.

® Perform the maintenance of HP IT Executive Scorecard.

5. Install the client certificate in the client browser.
In the client browser, select Internet Options.

J:*j' A7) wiaiting For smpink. Fpazsh.com X u Tk #
3
3
3
3

Prink

File

Zoom {100%:)
Safety

Security Configuration is enabled

sonfiguration is currently enabled on yvour server. This configures a nu
and intranet Web sites. The configuration also reduces the exposure
omplete list of the security settings in this configuration, see Effects o Add site o Stark meny

View downloads Ckrl+3

event Web sites from displayving correctly in Internet Explorer and res Manage add-ons

laming Convention (UNC) shares. If you want to browse a Web site th
zabled, you can add the Web site to the inclusion lists in the Local intre  F12 developer boals
aternet Explorer Enhanced Security Configuration. 50 ko pinned sites

Inkternet options
About Internet Explorer
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Click Content > Certificates:

1ni=ddil= mninda i -l - i III -II IR ]
o
.1'\. .
izeneral I Security I Privacy Content |Cu:nnnecti-:nns | Frograms I &dvanced |

Certificates

Ise cerkificates for encrypted connections and identification,

Clear 550 skate | Certificates | Publishers |

R

Internet Options ﬂ E ,0

Internet Explorer

Al C waiking

rity Configuratio

ration is currently enal
tranet Web sites. The «
re list of the security s

ke~ amnlaka

Certificates

Web sites from displayi
_ 0 she
Web

ced Se

Intended purpose:

|<AII:=-

=~

HP IT Executive Scorecard (9.50)

Personal IOther People | Inkermediake Certification suthorities I Trusted Rook Certificatior 4 I *I

Issued To | Issued By | Expirakia, .. | Friendly Marme |

Import. .. Expork, .. Remove

Advanced |

Cettificate intended purposes
Wi |

Close

Learn more about certificates
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Click Import:

R Internet Options

"Gereral I Security I Privacy Content |Cnnnectinns I Programs I Advanced I

Certificates
Use certificates for encrypted connections and identification.

Clear S5L state | Certificates | Publishers |

AnikeCarnnlaka

Intended purpose: |<AII>

Personal | Other People I Intermediate Certification Autharities I

Issued To | Issued B | Expiratio
Irnpart... Export... Remoyve
E—

Certificate intended purposes

memmmvrm Internet Explorer

,O:Iv A | O Waiting for smpink.Fpazsh.com X | |

rity Configuration is enabled

ration is currently enabled on your server. This configures a number of security
tranet Web sites. The configuration also reduces the exposure of your server tc
e list of the security settings in this configuration, see Effects of Internet Explor

eb 5|tes from dlsplaymg correctly in Internet Explorer and restrlct access to ne

Intsr
Cettificates Certificate Import Wizard [ Xlsted «

Welcome to the Certificate Import
Wizard

This wizard helps you copy certificates, certificate trust
lists, and certificate revocation lists from your disk to a
certificate store,

A certificate, which is issued by a certification autharity, is
a confirmation of your identity and contains information
used ko protect data or to establish secure netwark
connections, & certificate store is the system area where
certificates are kept,

To continue, click kext.,

Learn more about certificates

= Back I ek = I Cancel
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Enter the path to the file you want to import:

E— nn_ - P emmn 1 - - ) i 1 ) T | - 'l ' - Internet
I Certificate Import Wizard lsted sites
o File to Import

Specify the file wou want ko impaort,

= File name:

I Z:\Builds\shibai, zhang. pFx Browse, ., I
-

Mote: More than one certificate can be stared in a single file in the following Farmats:

Personal Information Exchange- PKCS #12 (.PFX, .P12)

Cryprographic Message Syntax Standard- PECS #7 Certificates ( P7E)
Microsoft Serialized Certificate Store (.55T)

Learn more about certificate file Formats

< Back Mext = Cancel
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Enter the password:

Certificate Import Wizard | x| |

Password

Ta mainkain security, the private key was protected with a passwaord,

Type the password For the private key.

Password:

¥ Enable strong private key protection. You will be prompted every time the
private key is used by an application if wou enable this option.

[ Mark this key as exportable, This will allov you ko back up or branspork your
kews at a later time,

¥ Include all extended properties,

Learn more about protecting private kewvs

< Back I Mext = I Cancel
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Click Next.
| Certificate Import Wizard l

Certificate Store

Certificate stores are system areas where certificabes are kept,

Windows can automatically select a cerkificate store, or you can specify a location For
the certificate.

" Automatically seleck the certificate store based on the bype of certificate
{*' Place all certificates in the following store

Certificate store:

Personal Browse, ., |

Learn mare about cerkificate stores

< Back. I Mexk = I Cancel
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Click Next.

I Certificate Import Wizard Ed I

b
®

Completing the Certificate Import
Wizard

The certificate will be imparted after you click Finish,

You have specified the Following setktings:

Certificate Store Selected by User [E=E =
Content PF=
File Mame ;Y Buildsshihai, zhang

< Back I Finish I Cancel
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Click Next.

Certificates Xl web site to the inclusion lists in the Local intra

- ) Shares. 1 yuu Walll W Uruwse o ywweld Sive Ui
Eed Security Configuration.

L«

Intended purpose: |<nll>

Personal | Other People I Intermediate Certification Authorities I Trusted Root Certificatiorﬂ_’l

Issued To I Issued B I Expiratio. .. I Friendly Mame I

Importing a new private signature key m

An application is creating a Protected item.

CryptodPl Private ey

Irnport, ., Expork, ., Remove

Security level st to Medium Set Security Level.. |
0k I Cancel | Dretailz... |

—_—

Learn more abouk certificates Close |

Click Next.
- T TP
Certificates [ XL Web site to the inclusion lis

ed Security Configuration.

Cettificate intended purposes

Intended purpose: Ic:F\II:b j
Personal |Other People I Intermediate Certification Autharities I Trusted Root Certificatior_4 I ’I
Issued To I Issued B I E:xpiratio. .. I Friendlv Mame I
Certificate Import Wizard
:l The import was successful,

Imnpart. .. Ezport, .. Remaoye

Certificate intended purposes

Learn mare about certificates Clase |
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Click Next.
Certificates
Intended purpose: I::AII::— j

Personal |Dther People | Irkermediake Certification Autharities I Trusted Rook Certificatior 4 I r I

Issued To | Issued By | Expiraki. .. | Friendly Mame |
s Shi-Hai Zhang Hewlett-Packard Priva,.. 6/26/2016  Class B For shihai...

\ -

Impott... I Export, .. Remove Advanced

Certificate intended purposes

Yiew

Learn more abouk cerkificates

i

Close

6. Restart the XS server.

When performing a logon, the end user is now required to provide CAC credentials before
accessing the XS application from a browser.

BN Request For Permission to Use a Key |

Grant or deny this application permission to use this key

Key name:  Application supplied name for the key

¥ Grant permission

" Deny perrmission

j Wiew key details Ik Cancel

Note that if you work with Chrome or Firefox you must make sure to follow a similar procedure for
these browsers.
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Note: The <HPXS>\agora\glassfish\glassfish\domains\BTOA\logs\cac.log is issued when the
user certification is revoked.

Example of a CAC Configuration

Precondition:

1. Certification files:
We have the following certification files.

ﬂ Trust Anchor CRL CP.OL.01.crl

= Trust Anchor CP.01.01.crt

ﬂ Intermediate CRL CP.01.02.crl

5l Intermediate Certificate CP.O1.02.crt
_‘ﬁ End User Certificate CP.01.02.p12

where:
e Trust Anchor CP.01.01.crt: The CA certification.

o Trust Anchor CRL CP.01.01.crl: The certification revocation list by CA certification.

« Intermediate Certificate CP.01.02.crt: The sub CA certification, which is issued by above
CA.

« Intermediate CRL CP.01.02.crl: The certification revocation list by the sub CA certification.

« End Certificate CP.01.02.p12: The end user certification, which is issued by the sub CA
certification. If the end user certification is issued by CA certification, the sub certification is
not needed.

2. Relations: The end useris issued by sub CA, sub CA is issued by CA.
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General | Details | Certification Path

Certificate

@g Certificate Information

General | Details | Certification Path

This iz Ch certification

Certificate
This CA Root certificate is not trusted. To enable @a Certificate Information
install this certificate in the Trusted Root Certifid — General ‘ | — |
Authorities store. Details | Certification Path

The integrity of this certificate cannot be guarant]
The certificate may be corrupted or may have be(
altered.

e Certificate Information
This is sub CA certificatien

Windows does not have enough information to verify

Issued to: Trust Anchor

Issued by: Trust Anchar

Learn more about certificates

validfrom 1/ 1/ 1999 to 1} 1/ 2048

Install Certificate... | | Issu Issued by: CA1-CP.0L02Z

this certificate.

Issued to: CA1-CP.01.02 This is the end user certification

Issued by: Trust Anchor

Issued to: User1-CP.01.02
Valid from 1/ 1f 1998 to 1/ 1/ 2048

Install Certificate... | | Issug valid from 1f 1 1998 to 1] 1/ 2048

3. End User Certification:

Learn more about certificates

Install Certificate... | | Issuer Statement

Learn more about certificates

Note: The SUBJECT.CN for the end user certification is : User1-CP.01.02. It is the logon
name in this example, so make sure you have such alogon user in already in the XS

application.
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« End User certification details:

Certificate Ed |

General Details |Certificatinn Fath I

Show: I::.ﬁ.ll:b j
Field | Walue | :I
Signature hash algorithm shal
Issuer CA1-CP.01.02, Testing, Dod, ...
Walid From Thursdaw, January 01, 1998 &...
Yalid ko Wednesday, January 01, 204, .,

Subiject Userl-CP.01.02, Testing, DaoD...
Public key RSA (1024 Bits)

Certificate Policies [1]Certificate Policy:Policy Ide. ..
Subject Keyw Identifier 7f9992 5ee3 61 b3S LI

EEGE TS

_N = Userl-CP.01.02
O = Tesking

0l = Do)

0 = L,5, Government
Z =15

Edit Properties. .. | Copy bo File... |

Learn more about certificate details

UK, | ancel | ARl
Ok

« XS application logon user:

SMPINK.smpin...FU_PRINCIPAL

17 = D | Loam_namE | PASSWRD | UNIGUE_ID

= dbo.BSFU_GROUP_ROLES a]|»  |or7mns IENEREIME  (SSHAZSEHKEA.. 24305

1 dbo.BSFU_GROUPS 1146380 George {SSHAZSEIROEX.., 34908

=1 dbo.BSFU_FRINCIPAL —

= dbo.BSFU_PRINCPL_ATTR * | ALLL ALLL MLEL

=1 dbe.BSFU_PRINCPL_ATTR_VAL

=1 dbo BSFU_PRINCFL_GROUP

m~ M AL~ DCCI AATREEAL RS

Configure CA certification

On the XS application server (Do the following on the XS application server if you have a distributed
configuration)

1. Copy the above certification files to %eHPXS_HOME%\agora\confikeys.

2. Edit the %HPXS_HOME%\agora\webserver\confiextra\httpd-ssl.conf configuration file, as
shown below.
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§| C:\HPXS'agora’webserver,conf,extraihttpd-ssl.conf - Notepad++

File Edt 3Search ‘iew Encoding Language Settings Macro Fun Plugins  Window 7
o HE 2 @@l%'mm|éﬁe|ﬁﬁbﬂl % 3|~—"|."1-'|.|‘="

|=| httpd-zzl.conf |. cac.properties |

22

e JkHountCopy On

24

Z5 B3LEngine on

26

27 &S3LCertificateFile "../conf/keva/btoa.host.hp.com.cert. pem'™
28

Z9 S3LCertificateKewFile "../conf/keys/btoa.host.hp.com.key.pem™
30

31 JSS3LCACertificateFile '../conf/kevys/Trust Anchor CP.O1.01.crt™

32 JkOptions +Forward3SLCertChain
%% | <Location fbsf >

34 S5LlVerifyClient optional
35 F33LVerifyDepth 10
36 353Loptions +3cdEnvWars +ExportCertData
37 | </Location>
35
32 fBrowserMatch ".FMIIE.*+" 3
40 # nokeepalive ssl-unclean-shutdown b
41 f downgrade-1.0 force-response-1.0
42
43
44 Custowlog "../webserver/logs/ssl regquest.log” b
45 ":t %h %{53L PROTOCOL}x %{33L CIPHER}=x WrEEL T ght
46
47 </VirtualHost>
45
3. Enable the CAC mode:
Edit the %HPXS _

HOME%\agora\glassfish\glassfish\domains\BTOA\config\confi\cac.properties property file,
as shown below:
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-ac.properties - Notepad++

dle Edt Search Wiew Encoding Language Settings Macro Run  Plugins  Window #

o

HE 5 @lddbhl et +s|EE] 06 = E e

B hitpd-sslcont [ cac.properties I

1
2
3
4
5
(3
<
=1
gl

i
11
1z
13
14
15
16
17
15

# The flag used to open CAC mode
#i==== Default value - false
igCACEnshled=True

# The flag used to indicate which field is "login name"
certificateFieldExtractDN=3UBJECT.CN

foidMap an OID map, where each key iz =n object identifier in String form
#eg:"E:1.2.540.113545.1.9.1" mutiple wappings seperated by conms
cercificate0IDMapping=

# The flag used to indicate the requirement of validation
#==== Default value - true
validationEnforced-trus

# wvalidation strategy

# optional wvalues :LOCAL_CRL,ONLINE CEL,QCSP,CER_TYPE,EXPIRATION
# Delimiters is comtas . e CER_TYPE, EXPIRATION
validationftrategy=EXPIRATICON, LOCAL_CRL

#Root Cert Path
#i==== This walue is used for validation strategy: LOCAL CRL,ONLINE CRL,QCSP.
RootCertPath=C:/HPXS/agora/ cont/keys/Trust inchor CP.0O1.01.crro,C:/HPES/agora/cont/keys/ Intermediate Certificate CP.O1.0Z.crt

H#CRL store path
#==== This wvalue is used for validation strategy:LOCLL_CRL
CRLStoreLocation=C:/HPES/agora/ cont/keys/ Trust Anchor CRL CP.01.0l.crl,C:/HPXS/agora/conf/keys/ Intermediate CRL CP.01.0Z.crl

#online CRL URL Path
#i==== This walue is used for validation strategy: CHLINE CRL
CRLDownloadURL=

H#OCSP Responder URL
#i==== This walue is used for validation strategy:OCSP

OC3FPResponder URL=

HOCSP Zerver cert

# = This wvalue is used for validation strategy:QCSP
#==== if this value is not indicared ,it would use Rootlert instead
0CgPServerCertPathd

4. Restart the XS service.

5. Install the End Certificate CP.01.02.p12 certification to your browser according to the steps that
mentioned above:

HP IT Executive Scorecard (9.50) Page 55 of 68



XS 9.50 Patch 04

5] noin Fo 25 - Windowe Internel Fxnlore
Internet Options

Certificates

Inktended purpose; I«::.ﬁ.ll:s j
Personal |Other People | Inkermediate Certification Autharities | Trusked Root Certificatior 4 I *I

Issued To ... | Friendly Mame

serl-CP.01.02 CAal-CP.01.02 1/1/2045 MMy Certificate

—.-____-___.—-_—-

Impart, .. Export, .. Remove Advanced |
Certificate intended purposes i
<all=

Wiew |
Learn more about cerkificates

—_— e
(0] 4 Cancel apply |

You can now log on to the XS application using the end user certification via CAC.
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Decimal Precision

The decimal precision used in displays in Business Analytics is as follows:

» Studio/Dashboard/Explorer.By default, the values of KPls and Metrics are displayed with a
maximum of 6 digits (default) (for example: 123456) and if needed a decimal point (123.456).

Digits after the decimal point are rounded to 5 digits maximum. For example: 456.7893 is rounded to
456.789.

Digits before the decimal point are rounded to 3 digits maximum. If there are more than 3 digits
before the decimal point, K, M, or T are used to indicate the correct value. For example: 3300122.111
is displayed as 3.300 M, and 999999 is displayed as 999.999 K.

KPI View

Gauge(1)(0) =

=-888 555k

= FY2013/11(Nov)

« Thresholds in Studio.

Because the threshold fields in the Studio are where you enter the threshold values, the thresholds
display all the digits before the decimal point. Nevertheless, if you configure a KPI threshold with
more than 3 digits after the decimal point, they are rounded to 3 digits. For example:

L [ -] T T T T
100 |[1371506( [3612392]  [s513652 [7287.957] 23456781
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The Administrator can change the default using one of the following options:

« in Admin > Settings > Dashboard Settings, you can specify a total number of digits (between 3
and 6) in the Total number of digits displayed for KPI/Metric results setting. Note that the
number of digits before the decimal point is up to 3 with a K, M, or T indication when needed.

« in Admin > Settings > Dashboard Settings, you can specify the number of digits (between 0 and
5) after the decimal point in the Max number of digits after decimal point setting.

Note that the two settings must work together. The Total number of digits displayed for
KPI/Metric results setting decides the total number of digits that is displayed while the Max
number of digits after decimal point setting provides the number of digits that is displayed after
the decimal point depending on the number of digits of the number.

Number
Settings 123.123456 1.123456 12345.123456

Total number of digits displayed for KPI/Metric results = = 123.123 1.12345  12.3451K
6

Max number of digits after decimal point =5

Total number of digits displayed for KPl/Metric results = 123 1.12 123K
3

Max number of digits after decimal point =5

Total number of digits displayed for KPI/Metric results = = 123.12 1.12 12.34K
6

Max number of digits after decimal point =2
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Defects Corrected in the XS 9.50 Patch 03 for
Windows

XS 9.50 Patch 03 for Windows supersedes the XS 9.50 Patch 02 for Windows and the XS 9.50 Patch
01 for Windows.

XS 9.50 Patch 03 for Windows corrects the following:

Change
Request Description

QCCR8B21176 DWH - SM - PERSON/ORG/NODE/APPLICATION/CI/ASSET/MODEL/LOCATION.MD_
BUSINESS_KEY should support non-sensitive case.

QCCR8B21252 DWH - SM-backfill control has performance issues.

QCCR8B21333 LDAP - The User/RootGroups/SearchGroups/ list is blank when the results set is
larger than the MaxPageSize configure of LDAP server.

QCCR8B21452 SM - Update MSI template to update the Datetime lookup method should be '=' to
resolve performance issue.

QCCR8B21536 LDAP- We cannot add view role to the ldap groups in the UserManagement page.

QCCR8B21537  Login Error- An error message (Google java null point error) pops up when first time
logon XS after configure LDAP.

QCCR8B21587 ' Date format is always in US format.

QCCR8B21682 DWH - SM - If the foreign key points to
PERSON/ORG/NODE/APPLICATION/CI/ASSET/MODEL/LOCATION.MD_BUSINESS_KEY, it is
always equal to -2.

QCCR8B21704 The KPI View component incorrectly displayed after it is changed to a historical chart
when wiring from the Objective in Perspective (containing more than two Objectives)
of Cascading Scorecard.

QCCR8B22091 'Generate URL' for dashboard page disappears in IE9 and IE10.
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Enhancements Added in the XS 9.50 Patch 03
Revision 1 for Windows

The enhancements added to the Patch are as follows:

Change
Request Description

QCCR8B20938 = SM PinkVerify

New KPIs, compliant with PinkVERIFY™, were added to Patch 03 Revision 1 for
Windows. Refer to "List of KPIs and Metrics" in the SM Content Acceleration Pack Guide
that is part of the patch package for a detailed description of these new KPIs. Note
that some of these KPIs have a version limitation that is provided in the detailed
description.

The documents that accompany the patch are (click go to download the document
from the Support Site
(https://softwaresupport.hp.com/group/softwaresupport/home)):

e HPIT Executive Scorecard XS 9.50 Patch 03 Revision 1 for Windows -- go

o CAP_SM Content Acceleration Pack Guide -- go

o Content Reference Guide for the Integration with HP Service Manager -- go
o Support Matrix -- go

The patchis available at: go
QCCR8B20943 SA 10.2 support

QCCR8B21572  Page filter to affect ‘Scorecard component

New Certifications

Supported Integrations: HP Service Manager9.40 and HP Server Automation 10.2.
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XS 9.50 Patch 02 for Windows
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Defects Corrected in the XS 9.50 Patch 02 for

Windows

XS 9.50 Patch 02 for Windows supersedes the XS 9.50 Patch 01 for Windows.
XS 9.50 Patch 02 for Windows corrects the following:

Change
Request

QCCR8B20895
QCCR8B20934
QCCR8B20936
QCCR8B20941

QCCR8B21023

QCCR8B21104

QCCR8B21122
QCCR8B21145
QCCR8B21250
QCCR8B21251
QCCR8B21302
QCCR8B21325

QCCR8B21326

Symptoms

Context Designer: Excel file loading issue.

Log Portal does not work on distribution model.
Initial load has performance issue.

CSAbilling is incorrect if the XS ETL is not set to run daily.

XS950 doesn't perform the calculation for the option initial_price and recurring_price

in CSA.

XS950 will use the resource provider of the parent node if the current node doesn't

have resource provider in CSA design.

XS950 only support English in the Scorecard component.

XS950 will get a hang issue during a KPI calculation.

Missing org page in CSA and CSA_CSP_DEMO.

XS950 filter the consumer from userlist.

XS950 will produce a Java Applet unreachable error when log on XS.
XS950 application is getting stuck on Loading Data API after login.

Cannot run insecure content of XS in Chrome.
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Enhancements Added in the XS 9.50 Patch 02 for
Windows

The enhancements added to the XS 9.50 Patch 02 for Windows are as follows:

Change
Request Description

QCCR8B20907 = Android platforms are now supported.
QCCR8B20935 ' The JDBC Driver was updated to 4.0.
QCCR8B20937 = Delta load was optimized.

QCCR8B20942 Data filter in CSA bundle pages and reports by organization name and consumer
name is now supported.

QCCR8B20972 The one server design in CSA is now supported.
QCCR8B21119 = KPIs can be sorted in the Studio and in Explorer.

QCCR8B21127 = The sorting for Perspectives, Objectives and Child KPIS is now supported in the
Cascade Scorecard.

New Certifications

Client Environments and Optional Software: Microsoft Exchange 2013
Supported Integrations: HP Server Automation10.1, HP Cloud Service Automation4.2 and 4.1.

Report tool: Xcelsius Reports Viewer component supports the new SAP® Business Objects
Dashboards 4.1 (Xcelsius dashboards) format.xIf.
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XS 9.50 Patch 01 for Windows corrects security issues.
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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements
accompanying such products and services. Nothing herein should be construed as constituting an
additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying.
Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software
Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under
vendor's standard commercial license.

Copyright Notice
© Copyright 2011-2015 Hewlett-Packard Development Company, L.P.

Trademark Notices

Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.
AMD is a trademark of Advanced Micro Devices, Inc.

Intel and Xeon are trademarks of Intel Corporation in the U.S. and other countries.

Oracle and Java are registered trademarks of Oracle and/or its affiliates.

Documentation Updates

The title page of this document contains the following identifying information:

« Software Version number, which indicates the software version.
« Document Release Date, which changes each time the document is updated.
« Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go to:
https://softwaresupport.hp.com

This site requires that you register for an HP Passport and sign in. To register for an HP Passport ID,
go to: https://hpp12.passport.hp.com/hppcf/createuser.do

Or click the Register link at the top of the HP Software Support page.

You will also receive updated or new editions if you subscribe to the appropriate product support
service. Contact your HP sales representative for details.
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Support

Visit the HP Software Support Online web site at: https://softwaresupport.hp.com

This web site provides contact information and details about the products, services, and support that
HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and efficient
way to access interactive technical support tools needed to manage your business. As a valued
support customer, you can benefit by using the support web site to:

« Search for knowledge documents of interest

« Submit and track support cases and enhancement requests

« Download software patches

« Manage support contracts

« Look up HP support contacts

« Review information about available services

« Enterinto discussions with other software customers

« Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also
require a support contract. To register for an HP Passport ID, go to:
https://hpp12.passport.hp.com/hppcf/createuser.do

To find more information about access levels, go to:

https://softwaresupport.hp.com/web/softwaresupport/access-levels

HP Software Solutions Now accesses the HPSW Solution and Integration Portal Web site. This site
enables you to explore HP Product Solutions to meet your business needs, includes a full list of
Integrations between HP Products, as well as a listing of ITIL Processes. The URL for this Web site is
http://h20230.www2.hp.com/sc/solutions/index.jsp

About this PDF Version of Online Help

This document is a PDF version of the online help. This PDF file is provided so you can easily print
multiple topics from the help information or read the online help in PDF format. Because this content
was originally created to be viewed as online help in a web browser, some topics may not be formatted
properly. Some interactive topics may not be present in this PDF version. Those topics can be
successfully printed from within the online help.
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Document Change Notes

The following table provides details of any changes introduced in this version of this document.

Date Change

August 2015 Original release of this document
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