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Welcome
This guide provides information for setting up and configuring the Service Asset and Configuration
Management (SACM) solution. This guide outlines the integration between HP Asset Manager,
HP Universal CMDB, and HP Service Manager. It explains how to install and configure the
components of the integration, as well as outlining how functionality of the integrated applications is
enhanced.
This chapter includes:
l

"How This Guide is Organized" below

l

"Who Should Read This Guide" on the next page

l

"Additional Online Resources" on page 7

How This Guide is Organized
This guide contains the following chapters:
Introduction to SACM
In addition to providing an overview of the Service Asset and Configuration Management Solution,
provides an introduction to SACM integrations and briefly describes how the following products work
with each other:
l

HPE Service Manager (SM)

l

HPE Universal CMDB (UCMDB)

l

HPE Asset Manager (AM)

l

HPE Connect-It (CIT)

"HPE Service Manager and HPE Universal CMDB Integration" on page 21
Provides the installation and configuration steps required to configure and verify the integration
between Service Manager and Universal CMDB .
"HPE Asset Manager and HPE Universal CMDB Integration" on page 21
Provides the installation and configuration steps required to configure and verify the integration
between Asset Manager and Universal CMDB .
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"HPE Asset Manager - HPE Service Manager Integration" on page 21
Provides the installation and configuration steps required to configure and verify the integration
between Service Manager and Asset Manager pursuant to a request from the catalog.
"CI Reconciliation Priority Best Practices" on page 37
Provides the Best Practices guidelines and configuration instructions for how to prioritize the
information received from Asset Manager and Service Manager into UCMDB in order for UCMDB to
contain the most accurate CI information.
"Technical Reference" on page 41
Describes how data objects are sourced and mapped by which scenario or adapter, as well as the
reconciliation keys used, and any special requirements needed for data transfers to work properly

Who Should Read This Guide
This solution is intended for IT organizations that want to better manage all their assets from
procurement to decommissioning, all the while supplying both operational as well as IT Financial
Management data.
This guide is intended for:
l

Customers

l

Presales and sales personnel

l

PSO

l

Anyone who wants to learn about the solution, its flow, and its value or the value it delivers

The information in this guide may duplicate information available in other SACM documentation, but is
provided here for convenience.
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Additional Online Resources
Troubleshooting & Knowledge Base accesses the Troubleshooting page on the HP Software
Support Web site where you can search the Self-solve knowledge base. Choose Help >
Troubleshooting & Knowledge Base. The URL for this Web site is
http://h20230.www2.hp.com/troubleshooting.jsp.
HP Software Support accesses the HP Software Support Web site. This site enables you to browse
the Self-solve knowledge base. You can also post to and search user discussion forums, submit
support requests, download patches and updated documentation, and more. Choose Help >
HP Software Support. The URL for this Web site is www.hpe.com/go/hpsoftwaresupport.
Most of the support areas require that you register as an HPE Passport user and sign in. Many also
require a support contract.
To find more information about access levels, go to:
http://h20230.www2.hp.com/new_access_levels.jsp
To register for an HPE Passport user ID, go to:
http://h20229.www2.hp.com/passport-registration.html.
HPE Software Web site accesses the HPE Software Web site. This site provides you with the most
up-to-date information on HPE Software products. This includes new software releases, seminars and
trade shows, customer support, and more. Choose Help > HP Software Web site. The URL for this
Web site is www.hp.com/go/software.
HPE Software Solutions Now accesses the HPSW Solution and Integration Portal Web site. This
site enables you to explore HPE Product Solutions to meet your business needs, includes a full list of
Integrations between HP Products, as well as a listing of ITIL Processes. The URL for this Web site is
http://support.openview.hp.com/sc/solutions/index.jsp.
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Introduction to SACM
This chapter includes:

Note: If you have any feedback or comments, please contact
solutionpackagingandscp@hp.com.

Service Asset and Configuration
Management – Overview
SACM provides a necessary data foundation that is core to operating IT. This enables the business to
function within its own constraints while taking into account the unique needs of the business. Many
key IT (ITIL) processes rely on SACM being in place in the organization; including all of the following:
l

Service Portfolio Management (Service Strategy)

l

IT Financial Management (Service Strategy)

l

Service Level Management (Service Design)

l

Incident Management (Service Operations)

l

Problem Management (Service Operations)

l

Request Management (Service Operations)

l

Configuration Management (Service Transition)

l

Change Management (Service Transition)

By enabling and supporting these processes, SACM contributes to:
l

Planning and proactive management of IT to support the needs of the business.

l

Financial traceability—the ability to understand where the IT budget is being spent and in support of
which business drivers
This also supports better financial decision making in general and specifically determining if the IT
budget is truly supporting the important business services that drive the company’s revenue
stream.
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l

Maintaining appropriate service levels to support the business adequately IT should not overdeliver, which is expensive and wasteful, or under-deliver, which inhibits the business from
producing better results. SACM provides the data points and transparency to more accurately meet
business needs.

l

Enabling services to be operated effectively and efficiently

l

Populating and managing the Configuration Management Database (CMDB)—discovering and
recording all the relevant components that comprise the IT environment

l

Providing a process for on-boarding Assets and CIs—managing them throughout their respective
life cycles and retiring them in an organized manner to minimize the negative impact on the
business

l

Improving the understanding of the complex interdependencies between the various components of
IT and reducing the negative impact they may have on each other

l

Standardizing IT environments, resulting in reducing maintenance costs and improving consistency
and predictability of IT outcomes

SACM provides these values to the business throughout the entire service life cycle, from request
through procurement to deployment into the IT environment, management of the service in production,
and ending at the retirement and disposal phases. SACM is responsible for creating and managing the
Configuration Management System (CMS) and as such provides IT organizations with more control
over their IT environments, better adherence to the policies it defines, and greater accessibility to the
necessary information. SACM does so by delivering the following:
l

Management and planning: Designing what level of configuration management is needed and how
this level will be achieved

l

Configuration identification: Establishing a system of classification of Configuration Items (CIs) into
types, defining the relevant attributes for each CI type, determining the key attributes and the
relationships between the various CI types

l

Configuration Control: Governing the addition, removal and updating of each CI and ensuring that
the appropriate process and procedures are followed for each such activity

l

Status accounting and reporting: Providing an accurate account of the status of each CI/Asset

l

Verification and audit: Conducting periodical audits to ensure that there are no discrepancies
between the documented and/or desired state of the environment and the actual state
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Installing SACM Products
Before you can install and configure the integration, the SACM products must be installed and
accessible by the integration components via the network.
In-depth knowledge and administration privileges to each of the following integration products are
required to install, configure and manage the integration successfully.
l

HPE Asset Manager

l

HPE Universal CMDB and its probe

l

HPE Service Manager

l

HPE Connect-It

l

HPE Service Manager <-> HP Universal CMDB integration (reuse the CI Types that are mapped
from UCMDB to SM)
Note: For more information about the SM <-> UCMDB integration, see the HPE Universal CMDB
to HPE Service Manager Integration Guide, which is available from the Service Manager help
center:
System Administration > Integrations > HP Universal CMDB (UCMDB) > HPE Universal
CMDB to HPE Service Manager Integration Guide

Refer to the installation guides provided with each of the products that represent the SACM solution.
Note: Although not in the scope of the SACM solution, integrating AM with IT infrastructure
discovery tools such as HPE Discovery and Dependency Mapping Inventory can complement the
SACM solution by providing accurate, up-to-date inventory data which serves as the foundation of
the SACM solution. It is suggested to implement this integration before installing and configuring
the SACM solution.
Refer to the AM support matrix for the supported versions of various discovery tools. Refer to the
documentation provided with the discovery tools for integration information.
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SACM Prerequisites
This guide expects that the following products are installed and fully functional:
l

HPE Universal CMDB (UCMDB) 10.21 or later: Server should be installed. Data flow probe
should be connected and running.

l

HPE Service Manager (SM) 9.41 or later: Server, Client, Help Server, and Web Tier should be
installed and running.

l

HPE Asset Manager (AM) 9.50 or later: Application designer, client, and AM web application.

l

HPE Connect-It 9.60 or later: Scenarios from SACM 9.41 kit.
Important: For find out the most recent version of each product to be certified for use in SACM
9.41, visit Service Asset and Configuration Management.
Note: This guide assumes that the SACM products are installed in the following default locations:
l

Universal CMDB – C:\hpe\UCMDB\

l

Service Manager – C:\Program Files\HPE\Service Manager <X.xx>

l

Asset Manager – C:\Program Files\HPE\Asset Manager <X.xx> en

l

HP Connect-It – C:\Program Files\HPE\Connect-It <X.xx> en
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SACM 9.41 Solution Diagram
The following diagram displays a typical deployment of the SACM Solution.

ID#

Integration Name

#351

Employee Self-Service Catalog for Asset Manager (AM - SM)

#415

Reference Data Synchronization via Connect-It (AM <-> SM)

#816

Inventory, Software Utilization and Business Data Synch (UCMDB to AM)
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ID#

Integration Name

#817

Asset to CI Replication (AM -> UCMDB)

#820

CI sync and actual state federation (UCMDB to SM)
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Hardware and Software Requirements
The instructions in this document assume that products are installed in the default location. If this is not
the case, you will need to make the appropriate modifications to file paths mentioned in this document.

Supported Versions
The following product versions were validated for the SACM 9.41 solution:
Product

Version

Instructions

UCMDB

10.21 or later

For installation instructions, see the HPE Universal
CMDB Deployment Guide.

Service
Manager

9.41 or later

For installation instructions, see the HPE Service
Manager Interactive Upgrade Guide

ConnectIt

9.60 or later

For installation instructions, see the HPE Connect-IT
Connector Guide.

Asset
Manager

9.50 (with the SACM 9.41
content pack) or later

For installation instructions, see HPE Asset Manager
Installation and Upgrade.

Note: Make sure that each application you install is up and running before you perform any
configuration steps.

Hardware and Software Requirements
For detailed information about hardware and software requirements, including supported operating
systems, databases, and browsers, refer to the Support Matrix for each product.

UCMDB
l

10.21
https://softwaresupport.hpe.com/km/KM01737045

l

10.30
https://softwaresupport.hpe.com/km/KM02557405
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Service Manager
l

9.41
https://softwaresupport.hpe.com/kb/KM01793337

l

9.50
https://softwaresupport.hpe.com/kb/KM02588593

Asset Manager
l

9.5x
https://softwaresupport.hpe.com/kb/KM01450310

Connect-It
l

9.60
https://softwaresupport.hpe.com/kb/KM01292731
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SACM Project Planning
HPE Service Asset and Configuration
Management
The various tasks that must be done in order to use the SACM solution appear in the following diagram:
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HPE Asset Manager – Overview
HPE Asset Manager (AM) helps IT organizations minimize their compliance risk, effectively manage
their IT services, and maximize the utilization of IT.
AM supports the life cycle management of physical and logical assets. AM’s modules—Asset
Tracking, IT Procurement, Contract Management, Software Asset Management and Financial
Management—will ensure that IT organizations get full visibility on their portfolio and can smoothly run
operations and optimize their use of IT.
AM's main benefits are described as follows:
l

l

l

l

Asset Tracking:
o

Track and manage fiscally relevant physical and virtual assets throughout their life cycle

o

Optimize IT spending

o

Reduce the number of lost and unused assets

o

Improve IT governance

IT Procurement:
o

Streamline IT procurement life cycle process

o

Optimize purchase costs by tracking vendor prices

o

Manage approvals and fulfillment of requests

o

Measure contract objectives against vendor delivery metrics

Contract Management:
o

Automatically manage the operational state of contracts in use

o

Track compliance with vendor terms and conditions

o

Link assets to contracts (purchase, leasing, maintenance, support contracts)

o

Monitor and re-evaluate contracts and suppliers

o

Optimize cost of IT contracts

Software Asset Management (SAM):
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l

o

Ensure vendor software license compliance using out-of-the-box SAM best practices

o

Allow organizations to optimize what is already owned

o

Enable active management for the authoritative state of software CIs

IT Financial Management:
o

Track cost of assets and business services

o

Define service offerings, manage user subscriptions

o

Support showback/chargeback for use of business services

o

Execute Budget Management Best Practices

HPE Service Manager – Overview
HPE Service Manager stores the managed or expected state of CIs and CI relationships as attribute
values in a CI record. To be part of the integration, a CI attribute in your UCMDB system must map to a
managed field in the SM CI record. You can add, remove, or update the managed fields that are part of
the integration by tailoring the SM Web services that manage the integration.
SM runs according to a set of rules that define what actions you want the system to take whenever a
CI’s actual state does not match the expected state as defined in the CI record. You define these rules
from the Discovery Event Manager (DEM) in SM where you can do the following:
l

Automatically update a CI record to match the attribute values listed in the actual state. (This is the
default behavior.)

l

Automatically create a change record to review the differences between the actual state and the
managed state.

l

Automatically create an incident record to review the differences between the actual state and the
managed state.

HPE Universal CMDB – Overview
HPE Universal CMDB (UCMDB) consists of a rich business-service-oriented data model with built-in
discovery of configuration items (CIs) and configuration item dependencies, visualization and mapping
of business services, and tracking of configuration changes.
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UCMDB implements data model, data flow management, and data modeling capabilities, and also
provides impact analysis, change tracking, and reporting capabilities to transform CMDB data into
comprehensible, actionable information that helps answer critical questions and solve business
problems.
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HPE Connect-It – Overview
Connect-It is an Enterprise Application Integration (EAI) type integration platform. An EAI solution
enables a company to integrate the different applications from which it can obtain or to which it can
provide internal data (Internal support, equipment management software, and so on) or external data
(ERP, B2B, B2C). Connect-It integrates not only data, but also a company's application processes.
You can use Connect-It to:
l

Transfer information from one database to another.

l

Duplicate the information from one database to another in real-time.

l

Import information from e-mails, delimited text files, XML files or other formats into a database.

l

Export information from a database to e-mails, delimited text files, XML files or other formats.

l

Import NT Security-based information into a database.
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HPE Service Manager and
HPE Universal CMDB Integration
For information about the necessary steps to configure and verify the integration between SM and
UCMDB, refer to chapters 13 and 14 of Universal Discovery Content Guide - HPE Integrations.

HPE Asset Manager and
HPE Universal CMDB Integration
For information about the necessary steps to configure and verify the integration between out-of-box
versions of UCMDB and AM, refer to chapters 2, 3 and 4 of Universal Discovery Content Guide - HPE
Integrations.

HPE Asset Manager - HPE Service
Manager Integration
This chapter includes:

Overview
This chapter describes the necessary steps to configure and verify the integration between SM and AM
following a request from the catalog. This integration enables the Employee Self Service (ESS) user of
Service Manager to create a request which will be transferred to Asset Manager and will be processed
there until completion (Service Catalog integration).
A typical request handled by this integration includes the procurement of new IT assets—such as the
purchase of a new laptop computer for an employee or a new server for a data center.
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Prerequisites
Before integrating AM and SM, there is some data that needs to be synchronized via HPE Connect-It
(CIT). This data includes information about People, Places, Things (PPT, not CIs), commonly referred
to as PPT in the description described in this chapter. Depending on the current customer
implementation phase, the master data source can be either Service Manager or Asset Manager—or
each product will contain master data for specific record types.
By default, the provided HPE Connect-It scenarios transfer the same PPT types from AM to SM and
from SM to AM. You cannot implement the scenarios as they are, because data replication would circle
back and forth. Therefore, you must decide whether the AM or SM database will store the reference
data for each of the PPT types:
l

Companies

l

Vendors

l

Locations

l

Departments

l

Contacts

l

Models

l

Stock rooms

Run scenarios to synchronize PPT data between AM and SM:
1. Install HPE Connect-It 9.60.
2. Download the SACM 9.41 content pack from HPLN (https://hpln.hpe.com) and unzip it to
C:\SACM941.
3. The HPE Connect-It scenarios depend on the SACM Integration Web Service. You need to add
this web service to SM:
a. Log on to HPE Service Manager client with administrative rights.
b. Select Menu Navigation > Tailoring > Database Manager in the navigation pane.
c. Right-click the screen in the right pane and select Import/Load.
d. In the File Name field, enter C:\SACM941\datakit\sc\sm94\SACMintegration.unl.
e. Click Load FG.
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f. Select Menu Navigation > Tailoring > Web Services > Web Service Configuration in
the navigation pane
g. In the Service Name field, enter SACMIntegration.
h. Click Search.
Verify that you see a list of entries prefixed with SACM.
4. Open HPE Connect-It , browse to C:\SACM941.
5. Select one of the following scenarios:
o

If the reference database for all PPT types is AM:
l

Use amsm-ppt.scn to transfer the PPTs from AM to SM.

l

Do not use amsm-ci-ppt-link.scn because links between CIs and Contact, Model,Vendor,
Location and Department are managed by the amsm-ppt.scn scenario.

o

o

If the reference database for all PPT types is SM:
l

Use smam-ppt.scn to transfer the PPTs from AM to SM.

l

Use smam-wo.scn to transfer changes and tasks.

If the reference database for PPT types is a mixed solution between AM or SM according to
PPT type:
l

Customize smam-ppt.scn so that PPTs referenced in SM are transferred to AM.

l

Customize amsm-ppt.scn so that PPTs referenced in AM are transferred to SM.

l

Do not use amsm-ci-ppt-link.scn because links between CIs and Contact, Model,Vendor,
Location and Department are managed by the amsm-ppt.scn scenario.

l

Use smam-wo.scn to transfer changes and tasks.

6. For each scenario, define the AM details and SM details.
7. After all the details are defined in the components, click Produce now to run the scenario.
Note: In an environment where an Employee Self Service (ESS) Catalog integration is planned
(as described in "Use the Request Self-Service to Verify Asset Manager- Service Manager
Integration" on page 34), it is necessary to disable Contact synchronization in order to prevent
possible data duplication.
To disable the synchronization of Contact records:
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1. Open the amsm-ppt.scn scenario in Connect-It.
2. In the Scenario diagram pane, select the Mapping box, and then select the Mappings tab.
3. In the Detail of the connector 'Mapping' pane, uncheck Creation of a contact and Update a
contact.
4. Save the changes and exit the scenario.

Install and Configure Asset Manager Web
Service
This section shows you how to install and configure AM web service. For more information about Asset
Manager web configuration, refer to the Installation and upgrade guide.
1. Install JDK 7 and configure the environment variable of the JAVA_HOME to JDK folder; for
example, C:\Java\jdk1.7.0_65.
2. Install Apache Tomcat7.0.42 to C:\Tomcat7042.
3. In order for some required libraries to be found by AM Web, make sure <Asset Manager
Installation folder>\bin or <Asset Manager Installation folder>\bin\x64 is in an environment
variable of path.
4. Implement AM Automated Process Manager in Windows:
a. Browse to Start > Run.
b. Type services.msc.
c. Select Asset Manager Automated Process Manager 9.xx and change the startup type to
automatic.
d. Click Start and OK.
e. Browse to Start > All Programs > HP > Asset Manager 9.xx en > Automated Process
Manager.
f. Click File to connect to the new database.
g. Select the relevant database and enter the credentials.
5. Start the Tomcat configuration console (In Windows, click Start >All Programs > Apache
Tomcat 7.0 Tomcat7 > Configure Tomcat), click the JAVA tab, populate the following fields:
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Field

Value

Java
Virtual
Machine

C:\Java\jdk1.7.0_65\jre\bin\client\jvm.dll

Java
C:\Java\jdk1.7.0_65\lib\tools.jar;C:\Tomcat7042\bin\bootstrap.jar
Classpath

Java
Options

Add the following lines:
-Djava.library.path=<Asset Manager Installation folder>\bin
-Dsun.lang.ClassLoader.allowArraySyntax=true
Note: If you are running the x64 version of Windows Server 2008, the path
needs to be replaced by -Djava.library.path=<Asset Manager
Installation folder>\x64 -XX:MaxPermSize=128m.

Initial
memory
pool

512 (or another value adapted to your computer)

Maximum
memory
pool

1024 (or another value adapted to your computer)

Thread
1000 (or another value adapted to your computer ; it should be less than the total
stack size RAM of the computer ; at least 250 Mb less than the total RAM of the computer)

6. Make a backup copy of <Asset Manager Installation folder>\websvc, and then edit the parameters
in the <Asset Manager Installation folder>\websvc\package.properties file. For parameter
descriptions, see the Installation Guide of Asset Manager.
7. Open a command-line prompt, go to the <Asset Manager installation folder>\deploy folder, run the
command:
deploy.bat ..\websvc\package.properties
If you are running the x64 version of Windows Server 2008, run the following command instead:
deploy.bat /x64 ..\websvc\package.properties
8. Copy <Asset Manager installation folder>\websvc\AssetManagerWebService.war to
C:\Tomcat7042\webapps.
9. Start Tomcat.
10. Open a browser and go to following URL:
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http://<Name or IP address of the Asset Manager Web Service server>:<Asset
Manager Web Service port>/AssetManagerWebService
For example, http://localhost:8080/AssetManagerWebService
11. Make sure that the a page that resembles the following appears (this image is taken from an earlier
Asset Manager release).

Install and Configure AM Web Service Proxy
The web service proxy is an interface that is used to convert a query to create a purchase request from
the HPE Service Manager catalog into a series of calls to Asset Manager web service which enable the
purchase request to be created in Asset Manager.
You can install the web service proxy on any computer (for example, on the computer that runs Asset
Manager web service).
1. Install Apache Ant ( http://ant.apache.org) on the computer where you want to set up the web
service proxy.
2. Install Java SE.
3. Back up <Asset Manager installation folder>\esscat\build\ant.properties.default
and rename the duplicated file to ant.properties.

HP Service Asset and Configuration Management (SACM) Solution (9.41)

Page 26 of 53

Configuration Guide

4. Edit ant.properties and change the ws.host, ws.port and ws.service parameters to have the
http://<ws.host>/<ws.port>/<ws.service> link point to the computer where Asset Manager
web service is installed.
5. Open a command-line prompt and go to the <Asset Manager installation
folder>\esscat\build\ folder.
Execute the following command:
ant webapp
6. Deploy the generated ServiceCatalog.war file on your application server by following the
standard procedure.
7. Because the Java virtual machine launched by the application server uses a lot of memory, you
need to increase the available memory to at least 256 MB. To do so, modify the JVM (Java Virtual
Machine) MaxPermSize parameter with the following switch:
-XX:MaxPermSize=256m
If you are using the Tomcat application server, follow these steps.
a. Start the Tomcat configuration console (Start >All Programs > Apache Tomcat 7.0
Tomcat7 > Configure Tomcat Windows menu).
b. Select the Java tab.
c. Add the following line to the Java Options section:
-XX:MaxPermSize=256m
d. Close the Tomcat configuration console.
8. Create ESS reference records in Asset Manager.
The different items that need to be created beforehand in Asset Manager are:
o

Employees that can connect to the database and use the request self-service system
(amEmplDept table). These employees must have a user account and password.

o

Employees for whom a request is made (amEmplDept table).

o

Standard request and product models (amModel table).

o

Standard requests (amRequest table), products (amCatProduct table) and off-catalog products
(amModel table).
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Install and Configure HPE Service Manager
Website
This section shows how to install and configure Service Manager website.

Installation
1. Stop and copy the SM web tier war file to TOMCAT_HOME\webapps\, and then rename it to
sm941.war.
2. Start Tomcat to deploy this war file.
3. Search and modify these value of parameters in web.xml under
C:\Tomcat7042\webapps\sm941\WEB-INF\.
<context-param>
<param-name>secureLogin</param-name>
<param-value>false</param-value>
</context-param>
Set this value to false if Service Manager is not configured as secure login.
<param-name>serverHost</param-name>
<param-value>192.168.0.1</param-value>
</init-param>
This IP address goes to the SM server. Generally, the param-value should be "localhost".
<init-param>
<param-name>serverPort</param-name>
<param-value>13080</param-value>
</init-param>
The SM service port is specified in the installation wizard. The initial value is 13080. If that is
incorrect, contact the technician who installed the SM server (sm.ini).
4. Remove sm941.war, and then restart Tomcat.
5. Test SM web with the following URL.
http://<Name or IP address of the SM Web client server>:<SM Web client server
port number>/<SM instance name>/index.do
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For example:
http://localhost:8080/sm941/index.do
6. For ESS user, test http://<Name or IP address of the SM Web client server>:<SM Web
client server port number>/<SM instance name>/ess.do
For example:
http://localhost:8080/sm941/ess.do

Configuration
If you already have a full version of HPE Service Manager, make sure that you have installed HPE
Service Manager web for an ESS (Employee Self-Service) user or consult the HP Service Manager
installation guide to install it.
1. Disable the request validation.
a. Log on to the SM website.
b. In the browser, select Menus Service Catalog > Administration > Approval Activities.
c. Select the first line of the General Approval table.
d. Click the Remove Approval Activity link.
e. Click Finish.
2. Enable the transfer of catalog items.
a. Log on to the SM website with administrative rights.
b. Select Menu Tailoring > Database Dictionary in the navigation pane.
c. Enter svcDisplay in the File name field, click Search.
d. Select the descriptor entry in the table (first line of the table, do not click the name column).
e. Click the New Field/Key button.
f. Populate the Name field with the optionList value, the Type field with the character value,
and click Add Field.
g. Edit the optionList entry in the table to populate the SQL Name field with OPTIONLIST, SQL
Type with IMAGE, and SQL Table with m1, then click OK.
h. Click OK, click SM Alters.
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i. Enter svcDisplay in the File name field, click Search.
j. Select the descriptor entry in the table (first line of the table) again.
k. Click the New Field/Key button.
l. Populate the Name field with the optionOptions value, the Type field with the character
value,and click Add Field.
m. Edit the optionOptions entry in the table to populate the SQL Name field with
OPTIONOPTIONS, SQL Type with IMAGE, and SQL Table with m1, and then click OK.
n. Click OK, click SM Alters.
o. Select Tailoring > Database Manager.
p. Click More > Import/Load.
q. In the File Name field, select the <Asset Manager Installation
folder>\esscat\sc\sm71\SCR42940.unl file path, and then click the Load FG button.
r. Wait until you get a message like "SCR42940.unl file loaded".
3. Enable the transfer of images.
a. Log on to SM website with administrative rights.
b. Select Tailoring > Database Manager.
c. Click More > Import/Load.
d. Right-click the Database Manager screen and select Import/Load in the contextual menu.
e. In the File Name field, select the <Asset Manager Installation
folder>\esscat\sc\sm71\QC8955.unl file, and then click the Load FG button.
f. Wait until you get a message like "QC8955.unl file loaded".
4. Expose the detailed Description field in the ServiceCatalog web service so that the cart status
can be updated by the HPE Connect-It scenario.
a. Log on to the SM website with administrative rights.
b. Select Tailoring- Web Services > Web Service Configuration from the navigation bar.
c. In the Service Name field, enter ServiceCatalog, click Search.
d. Select the ServiceCatalog entry in the list of results, uncheck the Deprecated option.
e. In the details of the ServiceCatalog web service, select the Fields tab.
At the end of the list of fields, add a new entry with the following information:

HP Service Asset and Configuration Management (SACM) Solution (9.41)

Page 30 of 53

Configuration Guide

l

Field: detailedDescription

l

Caption: DetailedDesc

l

Type: StringType

f. Click Save and OK.
5. Expose the resolution field in the ServiceDesk web service so that images can be transferred from
Asset Manager to HPE Service Manager by the HPE Connect-It scenario.
a. Log on to the SM website client with administrative rights.
b. Select Tailoring > Web Services > WSDL Configuration from the navigation bar.
c. In the Service Name field, enter ServiceDesk, click Search.
d. Select the ServiceDesk entry in the list of results.
In the details of the ServiceDesk web service, select the Fields tab.
e. At the end of the list of fields, modify the resolution field with the following information:
l

Caption: Resolution

l

Type: StringType

f. In the same list, modify the resolution.code field with the following information:
l

Caption: ResolutionCode

g. Click Save and OK.
6. As the web service proxy acts as a link between HPE Service Manager and Asset Manager Web
Service, you will need to configure the links between these elements.
To configure the link between HPE Service Manager and the web service proxy, configure the
Catalog connector in HPE Service Manager as follows:
a. Log on to SM website with administrative rights.
b. Select Service Catalog > Tailoring > Catalog Connectors.
c. Click Search.
d. Select the connector named Open a Standard Request in Asset Manager.
e. On the Expressions tab, enter the path to the web service proxy just after $L.url:
$L.url="http://<Name or IP address of the AM Web Service Proxy>:<AM Web
Service Proxy port number>/ServiceCatalog/services/ServiceCatalog"
For example:
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$L.url="http://ProxyServer:8080/ServiceCatalog/services/ServiceCatalog"
f. Enter user account and password value for $L.login and $L.pwd, for example:
$L.login="Admin"
$L.pwd=""
7. Update the AM web service proxy JAVA script.
a. Log on to the SM website with administrative rights.
b. Select Tailoring > Web Services > Run WSDL to JS.
c. Enter the URL for the WSDL of Asset Manager web service proxy.
The format is:
http://<Name or IP address of the AM Web Service Proxy>:<AM Web Service
Proxy port number>/ServiceCatalog/wsdl/ServiceCatalog.wsdl
For example:
http://ProxyServer:8080/ServiceCatalog/wsdl/ServiceCatalog.wsdl
d. Click Proceed.
This displays a window with the new Java script corresponding to the web service proxy.
e. Click Replace.
You should get the following message:
Successful compilation of JavaScript function or expression.
f. Click Save.
g. Click Compile.
You should get the following message:
Successful compilation of JavaScript function or expression.
8. Activate the linker scheduler.
a. Log on to SM website with administrative rights.
b. Select Miscellaneous > System Status.
c. Check linker that appears in the list.
d. If the linker scheduler already appears in the list, restart it.
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i. In the Command column of the linker line, enter K.
ii. Click the Execute Commands button.
iii. Repeat this action until the linker line disappears.
e. Click the Start Scheduler button.
f. Double-click linker-startup in the list.
9. Configure User profiles for ESS (Employ Self Service).
a. Log on to SM website with administrative rights.
b. Select System Administration > Ongoing Maintenance > Operators.
c. Enter Template_SelfService in the Login Name field, and then click Search.
d. On the Self Service tab, check the Self Service Access Only checkbox.
e. On the Startup tab, section Execute Capabilities, if svcCatEmployeeRequester is not in
the list, add svcCatEmployeeRequester to the first empty line of the table
f. Save your changes

Verify Asset Manager - Service Manager
Normal Integration
To verify the normal integration of Asset Manager and Service Manager, follow these steps.
1. Log on to the SM website and open a new change request.
2. Browse to Change Management > Changes > Create New Change.
3. Enter all relevant data and mandatory fields.
4. Click Save.
5. Open HPE Connect-It.
6. Open the scenario smam-wo.scn.
7. Fill the relevant parameters for each product.
8. Click Produce Now .
9. Log on to HPE Asset Manager.
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10. Browse to Asset Lifecycle > Work Orders > Work Orders.
11. Confirm that AM receives the change request .
Note: This out-of-the-box integration synchronizes all Change and Change Tasks records from
Service Manager to Asset Manager. In the production environment, the user may want to limit the
scope for specific Change categories. To achieve this, there is a need to modify the smam-wo.scn
scenario.

Use the Request Self-Service to Verify Asset
Manager- Service Manager Integration
1. Run the OOB scenarios in Connect-It to synchronize the basic data from Asset Manager to
Service Manager.
a. Open Connect-It 9.60, click File > Open.
b. Open and run scenarios located in <HPE Connect-It installation
folder>\scenario\ac\am94\esscat\am94sm933\ in the following order:
l

users.scn: Synchronization of employees

l

sso.scn: Synchronization of logins

l

categories.scn: Synchronization of standard request and product models

l

catalogitems.scn: Synchronization of standard requests, products and off-catalog
products

l

status.scn:Synchronization of request/cart statuses
Note: Synchronized logins in Service Manager use the default password
"P@assword1." If you would like to change the default password, open the Service
Manager WSDL definition for "Operator700," and then change the default password in the
following expression:
if ($L.bg.action="add" and null(password in $L.file)) then (password in
$L.file="P@assword1")

c. In the Scenario diagram window, modify the configuration of the SM web service connectors
and AM connectors.
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d. Save your changes.
e. Run the scenarios.
2. Check the operator in Service Manager.
a. Log on to SM website with administrative rights.
b. Select System Administration > Ongoing Maintenance > Operators.
c. Enter the logon name(amEmplDept.name in AM) in the Login Name field, for example,
Shivute, who is administrator in AM.
d. On the Self Service tab, make sure that the Self Service Access Only option is selected.
e. On the Startup tab, the user has the following execute capabilities:
l

partial.key

l

partial.key.msg.skip

l

service desk

l

service catalog

l

change request

l

svcCatEmployeeRequester

l

svcCatDeptRequester

3. Create the request self-service.
a. Log on to the SM ESS website (http://<Name or IP address of the SM Web client
server>:<SM Web client server port number>/<SM instance name>/ess.do) with a user
account that has self-service right.
b. Select Miscellaneous > Order from Catalog.
c. Select a service catalog in the right list which is from Asset Manager, for example: Deskpro
HPE EliteDesk 800 G1 (000025).
d. Select the user in the list for Request for field, select the Quantity, add attachments if
needed.
e. Click Add to Cart, you will get a message like :
Deskpro HPE EliteDesk 800 G1 (000025) has been added to your cart.
f. Click View Cart/Checkout.
g. Click Submit Request.
h. Enter values in the Purpose and Urgency fields.
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i. Click Submit.
j. Log on to AM, from menu Asset lifecycle > Procurement lifecycle > Purchase requests,
the request created in SM should be in the list.
k. The request is then processed in Asset Manager and the standard procurement cycle is
triggered.
l. The status of the cart is updated in HPE Service Manager through the status.scn scenario in
HPE Connect-It.
For more information about the HPE Service Manager Service Catalog and the request creation
procedure in HPE Service Manager, refer to the Service Catalogs section of the HPE Service Manager
online help.
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CI Reconciliation Priority Best Practices
This chapter includes:

Overview
In the SACM Solution, as well as from the ITPS Suite perspective, UCMDB is the central CI
repository. As such, it is populated with CI information from various HP and third-party products.
Therefore, UCMDB must decide which source is more reliable and which source has the most accurate
information.
UCMDB uses internal out-of-the-box reconciliation rules that make sure no duplications are created
and the CI information is accurate. In addition, it also uses the Reconciliation Priority module that gives
the Configuration Manager the power to determine for UCMDB which integration points are more
reliable for which CI Types or Attributes (for more information, see Chapter 10 Reconciliation Priority in
the HP UCMDB Data Flow Management Guide).
In the SACM Solution, UCMDB is populated with CI information from two products – AM and SM.
This chapter details the Best Practice guidelines and configuration instructions for how to prioritize the
information received from AM and SM into UCMDB in order for your UCMDB to contain the most
accurate CI information.

Priorities Logic
Consider the following when building the priorities detailed in the following CI Reconciliation Priority
Mapping table:
l

UCMDB DDMA discovery reflects reality by its capability and is the most reliable source of
information for discoverable CITs.

l

Business services and applications information is most likely to be more accurate in SM as the
owner of the Service Catalog.
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l

There are CITs that are coming from AM or SM—but not both. Thus, if it is a discoverable CIT,
DDMA will get the highest priority, and AM or SM will get the lower priority. Otherwise, the relevant
product will get the priority. For example, for the Asset CIT, AM gets the highest priority.
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Note: The following table of priorities is based only on CITs and Attributes that are supported by
the Out-of-the-Box (OOTB) population integration.
The CI Reconciliation Priority Mapping table maps the various CITs and attributes between the three
products—UCMDB, AM, and SM. The table also contains the necessary values to be defined for each
integration point using the following instructions.

Note: For more information about the impact of the Global ID solution on CI reconciliation
priorities, see the "CI Reconciliation Rules" section of the HP Universal CMDB to HP Service
Manager Integration Guide, which is available from the following HP website:
https://softwaresupport.hp.com/group/softwaresupport/search-result//facetsearch/document/KM01294561

CI Reconciliation Priority
One of the challenges of managing an asset in its lifecycle phase as an active CI is to have as much
information on it as possible collected from various systems—in addition to Discovery (such as
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business-related information)—but at the same time prevent duplication in the CMS system and, most
importantly, keep the data's integrity. For these reasons, UCMDB holds the reconciliation capability
and, in addition, allows the Configuration Manager to set priorities for the various sources of CIs.
In the SACM Solution, we have three sources – AM, SM and DDM. As part of the Solution’s assets,
there are Best Practices guidelines on how to set the Reconciliation Priority between AM, SM and
DDM.
To configure CI Reconciliation Priority
1. Log on to UCMDB as an administrator.
2. From the left-hand navigation pane, select Data Flow Management > Reconciliation Priority.
3. In the CI Types pane, in the Managed Object tree, select the relevant CI type.
4. In the CI Type Overrides pane, select the integration name you wish to change the priority value
for and click the Priority field to modify the value.
Repeat this step for every Integration Name you wish to change the Priority value for.
5. When the changes for the CI types are complete, click the Save

button in the CI Types

pane.
To set the priority for a specific attribute for a particular CI type:
1. Select the relevant integration name in the CI Type Overrides pane.
2. In the Attribute Overrides pane, click the Add

button. The Add Attribute dialog box is

displayed.
3. Select the relevant Attribute from list and click OK. The selected CI Attribute appears in Attribute
Overrides pane.
4. Modify the Priority value.
Note: If you add the wrong attribute to the list, use the Reset Attribute

button to reset

the Attribute Overrides list. Be aware this action clears all values in the Attribute Overrides
list.

5. When finished with the changes to that CI type, click the Save
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Technical Reference
This Appendix includes:

Overview
This appendix explains, for each database involved in the SACM integration, which data objects are
sourced and mapped by which scenario or adapter, as well as the reconciliation keys used and any
special requirements needed for data transfers to work properly.

HP Service Manager <-> HP Asset Manager
This section includes:

Overview
Overview of the HP Asset Manager – HP Service Manager integration
Integration
direction
Integration
technology
Populated data

From AM to SM

From SM to AM

HP Connect-It

HP Connect-It

l

amsm-ppt.scn:

l

smam-ppt.scn:

o

Companies

o

Companies

o

Vendors

o

Vendors

o

Locations

o

Locations

o

Departments

o

Departments

o

Contacts

o

Contacts

o

Models

o

Models
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Integration
direction

From AM to SM
o

Stock rooms

o

Links between CIs and Contact, Model,
Vendor, Location, Department

From SM to AM
o
l

smam-wo.scn:
o

l

amsm-ci-ppt-link.scn
o

HP Connect-It
scenarios

Stock rooms

Changes and
tasks

Links between CIs and Contact, Model,
Vendor, Location, Department

l

amsm-ppt.scn

l

smam-ppt.scn

l

amsm-ci-pptlink. scn

l

smam-wo.scn

Note: These scenarios do not create CIs. CIs are created in AM directly or created in HP
Discovery and Dependency Mapping Inventory and populated in AM.
AM CIs are populated/federated to UCMDB.
UCMDB CIs are populated to SM.

What happens when a CI does not exist in SM
If a CI does not exist in SM yet when a PPT/CI link is presented, an AM output event is created by the
HP Connect-It scenarios.
HP Connect-It will try and process the output events whenever the scenario is rerun.
Note that output events automatically expire according to the AM database options:
1. Start the AM Windows client and connect to the database.
2. Use the Administration/ Database options... menu.
3. Configure the Event management/ Expiration time for output events (hours) option.

Reconciliation keys for amsm-ppt.scn
This section includes:
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Companies
Key in SM

AM value searched for in the SM key

company:customer.id

amCompany.Code

Only AM companies for which amCompany.Qualif1 = Parent company are replicated.
For languages other than English, the <HP Connect-It installation folder>\config\ac\strings\qualif.str
file must be customized. The ID of the string to modify in this file is AMQUALIF_PARENT. Replace
Parent company with the right string for your language.
The AM amCompany:Code field must be populated.

Vendors
Key in SM

AM value searched for in the SM key

vendor:vendor

amCompany.Name

AND vendor:location

amCompany.MainSite:Barcode

Locations
Key in SM

AM value searched for in the SM key

location:location

amLocation.BarCode

The AM amLocation.BarCode field must be populated.

Departments
Key in SM

AM value searched for in the SM key

dept:company +
dept:dept

amEmplDept.Location.Company.Code Reconciliation uses the following rule:
RetVal = RemoveSlashAtExtremity([FullName])
If [Location.Company.Code] <> "" Then
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Key in SM

AM value searched for in the SM key
RetVal = [Location.Company.Code] & "/"
_
& RetVal
End If
Example:
In AM, we have four departments:
l

Department NameA
FullName = /NameA/

l

Department NameB under NameA
FullName = /NameA/NameB/

l

Department NameC under NameB
FullName = /NameA/NameB/NameC/

l

Department NameD under NameC
FullName = /NameA/NameB/NameC/NameD/
NameD is linked to a location linked to a company with
amCompany.Code = COMPANY_CODE SM.

The key for NameD is COMPANY_CODE/NameA/NameB/NameC/NameD.
The key for NameC is NameA/NameB/NameC.
Only AM departments for which amEmplDept.bDepartment = 1 are replicated.

Contacts
Key in SM

AM value searched for in the SM key

contacts:contact.name

amEmplDept.Name, Name.FirstName (amEmplDept.BarCode)

Note:
l

amEmplDept:Name can be up to 50 characters long, Name:FirstName up to 30 characters,
and amEmplDept.BarCode up to 255 characters long.

l

contacts.contact.name can only store 140 characters.
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l

If the amEmplDept.BarCode field does not exceed 55 characters, the reconciliation keys
work fine.

Models
Key in SM

AM value searched for in the SM key

model:part.no

amModels.BarCode

Note: The AM amModels.BarCode field must be populated.

Stock rooms
Key in SM

AM value searched for in the SM key

stockroom:stockroom

amStock.Name

Reconciliation keys for amsm-ci-ppt-link.scn
This section includes:

Links between device CIs and PPT objects
Key in SM

AM value searched for in the SM key

device:asset.tag

amComputer.AssetTag

Devices are linked to the
following objects:

The same keys are used as for the transfer of PPTs themselves.
See tables above.

l

Contact

l

Model

l

Vendor

l

Location

l

Department

The AM amComputer:AssetTag field must be populated.
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Reconciliation keys for smam-ppt.scn
This section includes:
The smam-ppt.scn scenario uses the SACMIntegration web service.

Locations and their link to a company and a country
Key in AM

SM value searched for in the AM key

amLocation.BarCode

location:location

amCompany.Code

location:company

amLocation.Country.Name

location:country

If no country can be found for which amCompany:Code = location:country, the location will be
linked to a location with amCompany:Code = Unknown country.
Make sure the AM amCompany:Code field is populated.
Make sure the AM amCountry:Name field is populated with unique values.
smam-ppt.scn uses the ScCountryToAc map table in the catmod.mpt file to map SM countries to AM
countries.

Companies
Key in AM

SM value searched for in the AM key

amCompany.Code

company:CompanyCode

amCompany.MainSite.Name

company:CompanyCode

amCompany.Sites.Name

company:CompanyCode

Make sure the AM amCompany.CompanyCode field is populated with unique values.
Make sure the AM amCompany.Code field is populated.
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SM Companies replicated as AM departments
Key in AM

SM value searched for in the AM key

amEmplDept.BarCode

company:CompanyCode

amEmplDept.Location.FullName

company:CompanyCode

Make sure the SM amCompany.CompanyCode field is populated with unique values.
amEmplDept.bDepartment is set to 1.

Departments
Key in AM

SM value searched for in the AM key

amEmplDept.FullName

dept:dept.structure

amEmplDept.bDepartment is set to 1.
A function converts dept:dept.structure to amEmplDept.FullName.

Contacts
Key in AM

SM value searched for in the AM key

amEmplDept.BarCode

contacts:contactname

amEmplDept.Location.BarCode

contacts:location

amEmplDept.Parent.FullName

contacts:dept

Make sure the SM contacts:locationcode field is populated with unique values.

Operators
Key in AM

SM value searched for in the AM key

amEmplDept.BarCode

operator:name

amEmplDept.WorkUnit.Description

operator:name
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Key in AM

SM value searched for in the AM key

amEmplDept.WorkUnit.Model.Name The scenario links the employee to the model for which
amModel.Name = Hourly rate
Operators is an extension of the contacts table.
After contacts have been imported, operators are imported to populate amEmplDept.WorkUnit.
A model is created in AM with amModel.Name = Hourly rate.
This model is linked to a nature (which must pre-exist) with amNature.Code = TCO_WORK_UNIT
and also linked to a parent model which amModel.Name = Work unit and which will be created if it
does not exist.
The parent model must also be linked to a similar nature.
This must be created by hand or can be retrieved through the import of Financials – Line-of-business
data (TCO-budgets-chargeback).

Vendors
Key in AM

SM value searched for in the AM key

amCompany.Name

vendor:vendor

amCompany.MainSite.FullName

vendor:vendor.id +
vendor:vendor.location

amCompany.MainSite.Country.Name

vendor:country

amCompany.Contact.FirstName + amCompany.
Contact.Name

l

vendor:contract.person

l

vendor:order.person

l

vendor:sales.mgr

l

vendor:service

Make sure vendor:contract.person, vendor:order.person, vendor:sales.mgr and vendor:service
use the <Last name>, <First name> format.
This is split into amCompany.Contact.FirstName and amCompany.Contact.Name in AM.
Make sure the SM vendor:vendor field is populated with unique values. If two different SM vendors
have the same value for the vendor:vendor field in SM in different locations, only the first vendor is
imported to AM.
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Make sure the SM vendor:vendor.location + vendor:vendor.id fields are populated with unique
values. If two SM vendors have the same value for the vendor:vendor.location field and for the
vendor:vendor.id field although they are linked to different locations (address differs), the two vendors
will be linked to the same location (the first that was transferred to AM)
Make sure the AM amCountry.Name field is populated with unique values.
The HP Connect-It scenario uses the ScCountryToAc map table in the catmod.mpt file to map
amCountry.Name.

SM vendor sites replicated as companies in AM
Key in AM

SM value searched for in the AM key

amLocation.FullName

vendor:vendor.id + vendor:location are used to create a full name

amLocation.Company.Name

vendor:vendor

Make sure the SM vendor:vendor.id + vendor:location fields are populated with unique values. If
two SM vendors have the same value for the vendor:vendor.id + vendor:location fields although
they are linked to different locations (address differs), the two vendors locations will result in a single
location in AM (the first that was transferred to AM)
When vendors were created (see "Vendors" on the previous page), if two different SM vendors have the
same value for the vendor:vendor field in SM in different locations, only the first vendor is imported to
AM. So when the location created by this mapping is linked to a company, it may be associated to the
wrong company.

Stocks
Key in AM

SM value searched for in the AM key

amStocks.Name

stockRoom:stockroom

amStock.Supervisor.BarCode

stockRoom:manager

amStock.DelivLocation.Field1

location:location
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Models
Key in AM

SM value searched for in the AM key

amModel.BarCode

model:part.no

amModel.Brand.Name
+ amModel.Brand.Commodel:manufacturer
pany.Name

model:manufacturer

amModel.Nature.Code

model:Category

amModel.Parent.BarCo
de

model:Category

amModel.Photo

if
[RetrieveSACMModelResponse.model.instance.attachments.attac
hment(0).name] = "" then RetVal =
[RetrieveSACMModelResponse.mod el.instance.Model] + "_" +
[RetrieveSAC MModelResponse.model.instance.PartNumber] else
RetVal = "SM_" & [RetrieveSACMModelResp
onse.model.instance.attachments.attachment(0).name] end if

amModel.Nature.Code is mapped using the ScToAcNature map table located in <HP Connect-It
installation folder>\scenario\ac\ac53\sacm\mpt\catmod.mpt.
The natures listed in the ScToAcNature map table must exist in the AM database.
A model is not created in AM unless at least one of following is populated in SM: model:Model,
model:PartNumber, model:Category.

Reconciliation keys for smam-wo.scn
This section includes:
This scenario propagates details of unplanned changes and tasks from SM to AM as Work Orders.
The relevant links between CIs and PPT data are propagated from AM to SM by another HP Connect-It
scenario.
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Changes > Workorders
Key in AM

SM value searched for in the AM key

amWorkOrder.WoNo

cm3r:header.number

Tasks > Workorders
Key in AM

SM value searched for in the AM key

amWorkOrder.WoNo

cm3t:header.number

For the corresponding CI
Key in AM

SM value searched for in the AM key

amComputer.AssetTag

device:logical.name
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Send documentation feedback
If you have comments about this document, you can contact the documentation team by email. If an
email client is configured on this system, click the link above and an email window opens with the
following information in the subject line:
Feedback on Configuration Guide (Service Asset and Configuration Management (SACM)
Solution 9.41)
Just add your feedback to the email and click send.
If no email client is available, copy the information above to a new message in a web mail client, and
send your feedback to ovdoc-ITSM@hpe.com.
We appreciate your feedback!
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