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Legal Notices

Warranty
The only warranties for HP products and services are set forth in the express warranty statements
accompanying such products and services. Nothing herein should be construed as constituting an
additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.
The information contained herein is subject to change without notice.

Restricted Rights Legend
Confidential computer software. Valid license from HP required for possession, use or copying. Consistent
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard
commercial license.

Copyright Notice
© Copyright 2015 Hewlett-Packard Development Company, L.P.

Trademark Notices
Adobe® is a trademark of Adobe Systems Incorporated.
Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.
Linux® is the registered trademark of Linus Torvalds in the U.S. and other countries.
Java® is a registered trademark of Oracle and/or its affiliates.
Red Hat® is a registered trademark of Red Hat, Inc. in the United States and other countries.
VMware® is a registered trademark of VMware, Inc. in the United States and other countries.

Documentation Updates
The title page of this document contains the following identifying information:
l Software Version number, which indicates the software version.
l Document Release Date, which changes each time the document is updated.
l Software Release Date, which indicates the release date of this version of the software.
To check for recent updates or to verify that you are using the most recent edition of a document, go to:
https://softwaresupport.hp.com.
This site requires that you register for an HP Passport and sign in. To register for an HP Passport ID, go to
https://softwaresupport.hp.com and click Register.

Support
Visit the HP Software Support Online web site at: https://softwaresupport.hp.com
This web site provides contact information and details about the products, services, and support that HP
Software offers.
HP Software online support provides customer self-solve capabilities. It provides a fast and efficient way to
access interactive technical support tools needed to manage your business. As a valued support customer,
you can benefit by using the support web site to:
l Search for knowledge documents of interest
l Submit and track support cases and enhancement requests
l Download software patches
l Manage support contracts
l Look up HP support contacts
l Review information about available services
l Enter into discussions with other software customers
l Research and register for software training
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Most of the support areas require that you register as an HP Passport user and sign in. Many also require a
support contract. To register for an HP Passport ID, go to: https://softwaresupport.hp.com and click Register.
To find more information about access levels, go to:
https://softwaresupport.hp.com/web/softwaresupport/access-levels.

HP Software Solutions & Integrations and Best Practices
Visit HP Software Solutions Now at https://h20230.www2.hp.com/sc/solutions/index.jsp to explore how the
products in the HP Software catalog work together, exchange information, and solve business needs.
Visit the Cross Portfolio Best Practices Library at https://hpln.hp.com/group/best-practices-hpsw to access
a wide variety of best practice documents and materials.

About this PDF Version of Online Help
This document is a PDF version of the online help. This PDF file is provided so you can easily print multiple
topics from the help information or read the online help in PDF format. Because this content was originally
created to be viewed as online help in a web browser, some topics may not be formatted properly. Some
interactive topics may not be present in this PDF version. Those topics can be successfully printed from
within the online help.
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Chapter 1: NV Predictor overview
HP NV Predictor is a flexible analytical tool that predicts the performance degradation effects when an
application under test is operated under various network conditions. NV Predictor analyzes test results
from HP LoadRunner and HP Performance Center tests that include network virtualization, and
generates reports for SLO compliance and baselinemeasurements. These customizable reports
display a comprehensive analysis of application performance, by virtual location.

How it works:
1. Use HP LoadRunner or HP Performance Center to conduct a performance test that includes one

non-virtual location and one or more virtual locations.
2. Run the test. Result data is generated automatically during the test run, and saved as a standard

results file or an HP LoadRunner Analysis file.
3. Import the results file into NV Predictor and generate the reports.
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Chapter 2: Install NV Predictor
NV Predictor can be installed on the HP LoadRunner Controller computer, HP Performance Center
computer, or on any other computer on which HP LoadRunner Analysis is installed.

Note: NV Predictor does not support LoadRunner Controller or LoadRunner Analysis installed with
a language pack other than English.

System Requirements
Before installing NV Predictor, make sure that the target computer meets the followingminimum
requirements:

Memory: 1GBRAM (recommended)

Operating System: Supported operating system for the HP LoadRunner or HP PerformanceCenter machine.

Virtual Machine: VMwareWorkstation 6.0 or later (recommended)
VMware ESX3.0 or later (supported)

Prerequisites
On the HP LoadRunner Controller:
l HP LoadRunner Controller 12.50
l HP NV for Controller 12.50
l Microsoft Office 2007, 2010, or 2013 (Word and Excel)
On the HP Performance Center Host:
l HP Performance Center 12.50
l HP NV for Controller 12.50
l Microsoft Office 2007, 2010, or 2013 (Word and Excel)
On an HP LoadRunner Analysis host:
l HP LoadRunner Analysis 12.50
l Microsoft Office 2007, 2010, or 2013 (Word and Excel)

Installing NV Predictor
Run theNVPredictorSetup.exe file as an administrator, and follow the instructions in the online setup
wizard.

Uninstalling NV Predictor
In theMicrosoft Windows Control Panel, click Uninstall a program, select NV Predictor, and then
click Uninstall.
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Chapter 3: Create reports
After running a test in LoadRunner or Performance Center, you use NV Predictor to process the test
results and generate a report.

Note: The input files for NV Predictor can be either the raw results files [with an .lrr extension], or
results files that have been processed by HP LoadRunner Analysis [with an .lra extension].

To generate a report with NV Predictor
1. Create an HP LoadRunner or HP Performance Center test that includes NV virtual locations. It is

recommended to include at least two virtual locations, including one "local location" with no
network virtualization (to differentiate between networking and other performance issues).

2. Run the HP LoadRunner or HP Performance Center test and wait until all the results are collated.
3. For HP Performance Center users only:

a. Download and unzip the RawResults.zip file for the test.
4. In NV Predictor, click File > Load LoadRunner Analysis or click the Load LoadRunner

Analysis button on the NV Predictor toolbar.
5. Locate and select the results file for your test (e.g. Results_178.lra or Test_178.lrr)

Launching NV Predictor automatically
If you are running a test on the HP LoadRunner Controller, NV Predictor can be configured to launch
automatically after the results are collated. See "Configure NV Predictor to run automatically after
analysis" on page 11. NV Predictor will then open the test results and automatically create an
NV Predictor Analysis Report after each test run. Tomodify the location of the test results, see "Define
global settings" on page 10.
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Chapter 4: Analyze results
After generating a NV Predictor report, you canmodify various input parameters and then view how
your SLOs are affected by the changing input parameters.

To modify report input parameters:
1. When NV Predictor is finished processing (a progress bar indicates the advancement), open the

generated report in MSWord by double-clicking the topmessage in theEvent Log (or selecting
File > Open Last Report).

Note: If NV Predictor does not open automatically, it can be opened from theStartmenu: HP
Software > HP Network Virtualization > HP NV Predictor > NV Predictor.

The Event Log refreshes with each action, including errors. To view the details of an event,
double-click the row in the event log.

2. Once your first analysis is completed, modify classifications and settings as required to assess
various scenarios. The classifications are always displayed as percentage increase from the
performance of a local user (a user without network virtualization) or from Service Level Objective
(SLO).
a. Tomodify the classifications select Options > Classifications, see "Update results with

classifications" on the next page.
b. Tomodify themetrics used in the SLO calculation (Transaction Response Time, Bandwidth

Utilization, etc.) select Options > Key Performance Indicators, see "Update results with
KPIs" on the next page.

3. Once your settings are customized, you can generate a new report from the same test results
without reloading the HP LoadRunner or HP Performance Center results:
a. Tomanually override any outlier transaction response times, select File > Modify Location

Data. For details, see "Modify locations" below.
b. Depending on the settings, NV Predictor may save the generated report in a designated

location along with theMS Excel file that was used to generate the report. In addition,
NV Predictor exports the report data in CVS format to allow for integration with third party
applications. For further details, see "Define global settings" on page 10.

Note: NV Predictor uses Microsoft Word templates to generate the reports. You can create
new templates andmodify the templates, but make sure to keep the requiredmerge fields in
the templates.

Note that all charts in the NV Predictor report are embeddedMicrosoft Excel objects; you can change
their layout, colors and charts type in the report itself without regenerating a new report.

Modify locations
After running a test, you can choose to specify custom values to override the Transaction Response
Time (TRT) for some transactions for specific locations.

To specify an override value for a transaction:
1. Select File > Modify Location Data.
2. In theModify Locations dialog box, select Override Location Data, and then select a transaction.
3. In theOverride column, type the required value.
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Update results with classifications
SLO classifications match service levels experienced by users tomeasurable categories. This
categorization assists in rating various aspects of application performance and user experience. All the
fields in this dialog box are editable, enabling you tomodify the name of each category and the
associated values.
The upper table compares each transaction to the defined SLO for that transaction, either the default
SLO of 3 seconds, or a custom value or an override as defined in Key Performance Indicators dialog
box. The lower table compares each remote Location to the non-virtual location baseline.

To modify the classifications:
1. Click Options > Classifications to open the Classifications dialog box.
2. Select the classification or the percentage value and replace the label. The value in each row must

be lower than the next row, for example, the 'Excellent' value cannot have a higher ’Max Increase
%’ than the ’Good’ value.

3. Regenerate the reports to view the effect of the updated values.

Update results with KPIs
Some or all of the Key Performance Indicators can be enabled tomodify the SLO in the "Increase from
Service Level Objective Classifications" in the Classification dialog box:
l Include Throughput Performance
l Include Hits per Second Performance
l Include Errors per Second Performance
l Include Bandwidth Utilization Performance (includes the Bandwidth Utilization options available in
the network virtualization settings. To learnmore about bandwidth options, see theNetwork
Virtualization for LoadRunner and Performance Center User Guide.)

To enable and modify the KPI values:
1. Click Options > Key Performance Indicators to open the Key Performance Indicators dialog

box.
2. UnderKey Performance Indicators Service Level Objectives, select the required option, such

as "Include Hits per Second Performance".
3. Enter the required values, and if required, modify any fields in the tables, then click OK.
4. Regenerate the reports to view the effect of the updated values.

Select transactions
You can specify that the NV Predictor report include only some of the transactions that are included in
the imported results file. You can search for specific instances of the transactions in the Filter area,
scroll through the list of transactions and include the required transactions, or choose automatic
transaction selection.

To choose specific transactions to include in a report:
1. Click Options > Select Transactions.
2. Select Automatic selection orManual selection. For manual selection, select the transactions

to include in the reports.
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Chapter 5: Define global settings
You can specify the following settings for NV Predictor:
l Include Think Time: Includes Vuser think-time in the NV Predictor reports. See the LoadRunner
User Guide to learnmore about Vuser think time.

l Export results as .csv files: Creates .csv files that contain the information that is included in the
NV Predictor reports. These files can be used for further analysis using third party applications

l Overwrite existing reports: Overwrites existing reports to reduce disk space usage.
l Automatically add "Local" Location: If a test was run without a "local" location, i.e. a location in
which the test is conducted without any network virtualization, a local user can be added during
analysis to provide a "baseline" location in each graph and table.

l Results and template directories: Lets you specify where the NV Predictor templates are located,
where the results files are saved, and the location that can be used by NV Predictor for temporary
file storage.

To change the reports directory:
a. Select Options > Global Settings.
b. In the Global Settings dialog box, in theReports Directory field, type the path of the location

where NV Predictor will save the reports.

To change the templates directory:
a. Select Options > Global Settings.
b. In the Global Settings dialog box, in the Templates Directory field, type the path where the

NV Predictor templates are located.

To change the temporary analysis directory:
a. Select Options > Global Settings.
b. In the Global Settings dialog box, in the Temporary Analysis Directory field, type the path of

the location for the NV Predictor temporary analysis files.
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Chapter 6: Configure NV Predictor to run
automatically after analysis
You can configure NV Predictor to run automatically after analyzing the test results.

Note: This functionality is available only for HP LoadRunner installations, not for HP PC
installations.

1. In HP LoadRunner Controller, click Tools > Options.
2. Click theExecution tab.
3. In thePost Collate Command box, add the following:

PredictorLauncher.exe "%ResultDir%"
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Send Us Feedback
Canwemake this User Guide better?
Tell us how: SW-Doc@hp.com
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