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Chapter 1: OMi Management Pack for IBM
WebSphere Application Server
TheOMi Management Pack for IBMWebSphere Application Server (OMi MP for IBMWebSphere
Application Server) works with Operations Manager i (OMi) and enables you tomonitor IBM
WebSphere Application Servers and the underlying infrastructure running in your environment using the
OMi console. TheOMi Management Pack for IBMWebSphere Application Server (OMi MP for IBM
WebSphere Application Server) works with Operations Manager i (OMi) and enables you tomonitor
IBMWebSphere Application Servers and the underlying infrastructure running in your environment
using the Business ServiceManagement (BSM). It includes Health Indicators (HIs), Event Type
Indicators (ETIs), and Correlation Rules that analyze the events that occur in the IBMWebSphere
Application Servers and report the health status. It also provides out-of- the-box Management
Templates and Aspects for monitoring the availability, health, and performance of IBMWebSphere
Application Servers. TheManagement Templates consists of a wide range of Aspects which enable
monitoring the cluster status, server status, EJB (Enterprise JavaBeans) performance, and so on.

TheManagement Templates or Aspects can be seamlessly deployed by administrators for monitoring
the IBMWebSphere Application Servers in an enterprise environment. The Subject Matter Experts
(SMEs) and developers can easily customize theWebSphereManagement Templates.

The out-of-the-box Management Templates or Aspects can be used tomonitor the following types of
environments:

l Network Deployment

l Standalone

l Cluster

l Secure configurations - LDAP and SSL

OMi MP for IBMWebSphere Application Server supports the following:

l Automated instance based simplified configuration and deployment.

l Provides a 360 degreemonitoring of the health and performance of IBMWebSphere Application
Servers and its underlying infrastructure in all deployment scenarios.

l Ready to deploy out-of- the-box management solutions to suit different monitoring requirements.

l Monitoring of composite applications - IBMWebSphere Application Servers, Oracle databases, and
the underlying system infrastructure.
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Chapter 2: Getting Started
The following section provides step-by-step information about monitoring IBMWebSphere Application
Servers from the BSM console.

Task 1: Adding Nodes to BSM 9.2x or OMi 10.x
Console
Note: If theWebSphere Application Servers that you want to monitor is already beingmonitored
by Smart Plug-in forWebSphere Application Server (SPI forWebSphere Application Server), then
remove the SPI artifacts and datasources from themanaged node hosting theWebSphere
Application Server before proceeding.

Note: If the node already exists in RTSM, you can skip this step and proceed to Task 2.

Before you beginmonitoring, you need to add the nodes, by following these steps:

1. Open theMonitored Nodes manager from Administration:

On BSM 9.2x, click Admin > Operations Management > Setup > Monitored Nodes.

OnOMi 10.x, click Administration > Setup and Maintenance > Monitored Nodes.

2. In the Node Views pane, click Predefined Node Filter > Monitored Nodes and then click
and then select Computer > <select required OS type>. The Create New Monitored Nodes
dialog box appears.

3. Specify the Primary DNS Name, IP Address, Operating System, and Processor Architecture of
the node and click OK.

Task 2: Enabling the Enrichment Rules
Youmust enable the following enrichment rules to populate theWebSphere CI’s display label with
additional information about container or the hostname. The Enrichment Rules must be enabled to
reconcile more than one j2eedomain CIs with the same name as a single CI entity:
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l SoftwareElementDisplayLabelForNewHost

l SoftwareElementDisplayLabelForExistingHost

l SoftwareElementDisplayLabelPopulator

To enable the Enrichment Rules, follow these steps:

1. Open the Enrichment manager:

On BSM 9.2x, click Admin > RTSM Administration > Modeling > Enrichment manager.

OnOMi 10.x, click Administration > RTSM Administration > Modeling > Enrichment
manager.

2. In the Enrichment Rules pane, select SoftwareElementDisplayLabelForNewHost from the list.

3. Right-click and select Properties. The Enrichment Rule Properties window appears.

4. Click Next.

5. Select Rule is Active.

6. Click Finish.

7. In the Enrichment Rules pane, click to save the changes.

8. Select SoftwareElementDisplayLabelForExistingHost and repeat steps 3 to 7.

9. Select SoftwareElementDisplayLabelPopulator and repeat steps 3 to 7.

10. In the Enrichment Rules pane, click Root > Operations Management > J2EE Application
Servers.

11. SelectWebSphereJ2EEDomainReconciliation and repeat steps 3 to 7.

Task 3: Deploying the WebSphere Discovery
Aspect
TheWebSphere Discovery Aspect enables you to discover IBMWebSphere Application Server
instances in the environment. To discover the IBMWebSphere Application Server CIs on the added
managed nodes, youmust deploy theWebSphere Discovery Aspect to a Computer CI.

TheWebSphere Discovery Aspect deployment discovers the Configuration Item (CIs) of the following
CI types (CITs):

User Guide
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l j2eedomain

l websphereas

To deploy theWebSphere Discovery Aspect, follow these steps:

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:

Configuration Folders > Application Server Management > IBM WebSphere Management
> Aspects

3. In the Aspects folder, clickWebSphere DiscoveryAspect, and then click to open the Assign

and Deploy Wizard.

4. In theConfiguration Item tab, select the configuration item to which you want to deploy the
Discovery Aspect and then click Next.

5. In theRequired Parameters tab, click Next.

Note: A message appears stating that There are no parameters that require editing
for this Assignment.

6. (Optional). In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x, to
change the default value of the Frequency of WebSphere_MPlog parameter, you can select the

parameter and then click . The Edit Parameter dialog box opens. Click Value, specify the
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value, and then click OK.

7. Click Next.

8. (Optional). In theConfigure Options tab, if you do not want to enable the assignment
immediately, perform the following:

On BSM 9.2x, clear theEnable Assigned Objects check box.

OnOMi 10.x, clear theEnable Assignment(s) check box.

You can then enable the assignment later using the Assignments & Tuning pane.

9. Click Finish.

Note: After theWebSphere Discovery Aspect is deployed, amessage stating the Assignment
and deployment jobs created appears. To check the status of the deployment job, go to the
following location:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Deployment Jobs.

OnOMi 10.x, click Administration > Monitoring > Deployment Jobs.

Task 4: Verifying Discovery
After you deploy theWebSphere Discovery Aspect, you can verify if the CIs are populated in the View
Explorer.

1. Open the Event Perspective pane:

On BSM 9.2x, click Applications > Operations Management > Event Perspective.

OnOMi 10.x, clickWorkspaces > Operations Console > Event Perspective.

2. In the View Explorer, select theWebSphere_Deployment_View from the drop-down list. You can
see the CIs associated with theWebSphere_Deployment_View.

Task 5: Deploying the WebSphere Management
Templates or WebSphere Aspects
This section provides information abut data collection, deployingmanagement template and aspects.
For more information about deployingWebSphereManagement Templates, go to "Task 5a: Identifying
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and DeployingWebSphereManagement Templates". For more information about deploying
WebSphere Aspects, go to "Task 5b: DeployingWebSphere Aspects".

Management Pack Data Collection Process

The frequency (polling interval) at which each Aspect must bemonitored is predefined with a default
value in a specific frequency parameter. Frequency parameter is an expert parameter that is defined for
each of themetrics regardless of whether they are for generating events or not.

Following are the four predefined frequency parameters:

Scheduler Frequency Default value

Very High 5mins

High 15mins

Medium 1 hour

Low 24 hours

After Management Templates and Aspects are deployed, collector is triggered based on the parameter
value in a specific Aspect. You canmodify the default value of the parameter at following two levels:

l During deployment of theManagement Template or Aspects using theManagement Templates &
Aspects pane

l After deployment using the Assignments & Tuning pane.

For more information about how tomodify the parameter values, see Editing Parameters.

Task 5a: Identifying and Deploying WebSphere

Management Templates

Before deploying theWebSphereManagement Templates, youmust deploy theWebSphere Discovery
Aspect. For more information, see "Task 3: Deploying theWebSphere Discovery Aspect".

TheWebSphereManagement Template discovers the CIs of the following CITs and completes the
topology as shown in the following figure:
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l JVM

l J2EE Application

l JDBC Data Source

You can identify theWebSphereManagement Template suitable for your environment by following
these recommendations:

l If you want to monitor the primary areas of IBMWebSphere Application Server such as server
status, JVM, JDBC, EJB and Servlets, and server logs, you can deploy the Essential WebSphere
Management Template.
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l If you want to monitor the primary and advanced areas of IBMWebSphere Application Server such
as transactions, cluster status cache usage, and threads, you can deploy the Extensive
WebSphereManagement Template.

l If you want to monitor composite applications comprising IBMWebSphere Application Servers,
Oracle databases, and the underlying infrastructure, you can deploy the ExtensiveWebSphere and
Oracle DatabaseManagement Template.

To deploy theWebSphereManagement Templates to theWebSphere cell CIs (j2eedomain), follow
these steps:

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:

Configuration Folders > Application Server Management > IBM WebSphere Management
> Management Templates

3. In theManagement Templates folder, click theManagement Template that you want to deploy,

and then click . The Assign and Deploy wizard opens.

4. In theConfiguration Item tab, click the j2ee Domain CI to which you want to assign the
Management Template, and then click Next. You can select multiple items by holding down the
CTRL orSHIFT key while selecting them. Click Next to accept the CIs and go toRequired
Parameters.

5. In theRequired Parameters tab, youmust specify the values of all the parameters that are listed
(Username and Password). To specify the values of the parameters, you can select the parameter

and then click . The Edit Parameter dialog box opens. Click Value, specify the value, and then
click OK.

Note:Youmust specify values for all the parameters to be able to continue the configuration
process.

Note: The credentials given during the deployment of aManagement Template should have
required privileges. For more information see the section User Privileges in theOMi MP for
IBMWebSphere Application Server Installation Guide.

6. Click Next.
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7. In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x, you can
override the default value of any parameters. You can specify a value for each parameter at the
Management Template level. By default, parameters defined as expert parameters are not shown.

To view expert parameters, click Show Expert Parameters.

Note: If the protocol configured for data collection is JSR160RMI, the values for the
parameters (             WebSphere Application Server JMX Connector Type andWebSphere
Application Server Port Number) must be specified.

8. Click Next.

9. (Optional). If you do not want to enable the assignment immediately, perform the following:

On BSM 9.2x, clear theEnable Assigned Objects check box.

OnOMi 10.x, clear theEnable Assignment(s) check box.

You can then enable the assignment later using the Assignments & Tuning pane.

10. Click Finish.

Task 5b: Deploying WebSphere Aspects

Before deploying theWebSphere Aspects, youmust deploy theWebSphere Base Aspect to discover
the CIs of the following CITs:

l JVM

l J2EE Application

l JDBC Data Source

To deploy theWebSphere Base Aspect, follow these steps:

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:

Click Configuration Folders > Application Server Management > IBM WebSphere
Management > Aspects > WebSphere Base
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3. In the Aspects folder, click theWebSphere Base, and then click . The Assign and Deploy

wizard opens.

4. In theConfiguration Item tab, Select theWebSphere CI and then click Next. You can select
multiple items by holding down theCTRL orSHIFT key while selecting them. Click Next to
accept the CIs and go toRequired Parameters.

Note: If you want to deploy Aspects to Node CIs, select Also show CIs of type Node.

5. In theRequired Parameters tab, youmust specify the values of all the parameters that are listed
(Username and Password). To specify the values of the parameters, you can select the parameter

and then click . The Edit Parameter dialog box opens. Click Value, specify the value, and then
click OK.

Note:Youmust specify values for all the parameters to be able to continue the configuration
process.

Note: The credentials given during the deployment of aManagement Template should have
required privileges for OMi MP for IBMWebSphere Application Server to collect performance
management data.

6. Click Next.

7. In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x, you can
override the default value of any parameter. You can specify a value for each parameter at the
Management Template level. By default, parameters defined as expert parameters are not shown.

To show expert parameters, click Show Expert Parameters.

Note: If the protocol configured for data collection is JSR160RMI, the values for the
parameters (             WebSphere Application Server JMX Connector Type andWebSphere
Application Server Port Number) must be specified.

8. Click Next

9. (Optional). If you do not want to enable the assignment immediately,perform the following:

On BSM 9.2x, clear theEnable Assigned Objects check box.

OnOMi 10.x, clear theEnable Assignment(s) check box.

You can then enable the assignment later using the Assignments & Tuning pane.

10. Click Finish.

To deploy the remainingWebSphere Aspects, follow these steps:
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1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:

Configuration Folders > Application Server Management > IBM WebSphere Management
> Aspects

3. In the Aspects folder, click theWebSphere Aspect that you want to deploy, and then click . The

Assign and Deploy wizard opens.

4. In theConfiguration Item tab, click the CI to which you want to assign theWebSphere Aspect,
and then click Next. You can select multiple items by holding down theCTRL orSHIFT key while
selecting them. Click Next to accept the CIs and go toRequired Parameters.

Note: If you want to deploy Aspects to Node CIs, select Also Show CIs of type Node.

5. In theRequired Parameters tab, youmust specify the values of all the parameters that are listed
(Username and Password). To specify the values of the parameters, you can select the parameter

and then click . The Edit Parameter dialog box opens. Click Value, specify the value, and then
click OK.

Note:Youmust specify values for all the parameters to be able to continue the configuration
process.

Note: The credentials given during the deployment of WebSphere Aspects should have
required privileges. For more information see the section User Privileges in theOMi MP for
IBMWebSphere Application Server Installation Guide.

6. Click Next.

Note: If the protocol configured for data collection is JSR160RMI, the values for the
parameters (             WebSphere Application Server JMX Connector Type andWebSphere
Application Server Port Number) must be specified.

7. In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x, you can
override the default value of any parameter. You can specify a value for each parameter at the
Management Template level. By default, parameters defined as expert parameters are not shown.

To view the expert parameters, click Show Expert Parameters.
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Note: If the protocol configured for data collection is JSR160RMI, the values for the
parameters (             WebSphere Application Server JMX Connector Type andWebSphere
Application Server Port Number) must be specified.

8. Click Next.

9. (Optional). If you do not want to enable the assignment immediately, clear theEnable Assigned
Objects check box. You can then enable the assignment later using the Assignments &Tuning
pane.

10. Click Finish.

Task 6: Verifying Discovery for Extended
Topology
After you deploy theWebSphereManagement Templates orWebSphere Base Aspect, you can verify if
the CIs are populated in the View Explorer.

To view the CIs in the View Explorer, follow these steps:

1. In the BSMConsole, click Applications > Operations Management > Event Perspective.

2. In the View Explorer, selectWebSphere_Deployment_View from the drop-down list. You can
see the extended topology comprising CIs associated with theWebSphere_Deployment_View
as shown in the following figure.

Additional tasks for OMi MP for IBM WebSphere
Application Server 1.01
Youmust perform the following tasks, if OMi MP for IBMWebSphere Application Server 1.00 is used
for monitoring theWebSphere Application Server instances in your environment. Youmust stop the
monitoring, update theManagement Templates and Aspects to latest version and then restart
monitoring.
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Perform following steps:

1. Stopmonitoring all theWebSphere instances by following the steps:

a. Open the Event Perspective pane:

On BSM 9.2x, click Application > Operations Management > Event Perspective > View
Explorer > Browse Views.

OnOMi 10.x, clickWorkspaces > Event Perspective > View Explorer > Browse Views.

b. In theBrowse Views tab, Select theWebSphere_Deployment_View from the drop-down
list.

c. Right-click aWebSphere node and click Launch Tool. The Preview Tool Execution page
opens.

d. Select theStop WebSphere Monitoring tool and click Run Tool.

Note: Youmust run theStop WebSphere Monitoring tool on each node CI.

2. On themanaged node, perform the following steps:

a. Navigate to the location <OvDataDir>/conf/WebSphere/wbsjmx and delete the file
WebSphere_Config.collConfig.

b. Delete the directory <OvDataDir>/tmp/WebSphere.

3. To updateManagement Templates or Aspects to the latest version, perform the following steps for
eachManagement Template or Aspect assignment on each node:

Note: Youmust deploy WebSphereManagement Templates to the J2EE DomainCI or
WebSphere Aspects toWebSphere AS CI.

a. On BSM 9.2x, to update perform the following steps:

i. Open theManagement Template & Aspects pane:

Admin > Operations Management > Monitoring > Management Templates &
Aspects.

ii. In the Configuration Folders pane:

Configuration Folders > Application Server Management > IBM WebSphere
Management

iii. To deploy the latest version of Essential WebSphereManagement Template:
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In theManagement Templates & Aspects pane, expand theEssential WebSphere
Management Template and select 1.100 version and click Assign and Deploy
Item.

Similarly, you can select the 1.100 version of the requiredManagement Template or

Aspects and click .

b. OnOMi 10.x, to update perform the following steps:

i. Open the Assignments & Tuning pane:

Administration > Monitoring > Assignments & Tuning

ii. In the Browse Views pane, select theWebSphere_Deployment_View view and select
each CI where version update is required.

iii. Click Show Assignments That Require an Update.

All theManagement Templates and Aspects that requires an update are listed.

iv. Select each of theManagement Templates and Aspects and click Update
Assigned Item.

The Update Assigned Item dialog box appears.

v. In theUpdate Options tab, follow these steps:

l Select the latest version from theUpdate to Version drop down list.

l If you select Use parameter values from existing assignments, only the new
mandatory parameters that do not have a default value are listed.

l If you select Use default parameter values from version selected above, all
mandatory parameters from the selectedManagement Template or Aspect version
that do not have a default value are displayed. These parameters must be edited
before proceeding to the next step of the wizard.

vi. Click Next.

To change a parameter, double-click or select the parameter from the list and click

Edit.

The Edit Parameter dialog opens.

vii. Click Next to go toParameter Summary tab.

viii. Click Finish to save the changes and close the wizard. The assigned item is updated to
the specifiedManagement Template or Aspect version.

4. To check the status of the deployment job, go to the following location:
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OnBSM 9.2x, click Admin > Operations Management > Monitoring > Deployment Jobs.

OnOMi 10.x, click Administration > Monitoring > Deployment Jobs.

If the deployment fails, remove the failed Deployment Jobs and re-deploy.

Checking the Topology Synchronization
Settings
Note: It is recommended to check the Topology Synchronization settings if a node or a
Configuration Item (CI) is monitored by Operations Manager.

1. Open the Infrastructure Settings from Administration:

On BSM 9.2x, click Admin > Platform > Setup and Maintenance > Infrastructure Settings.

OnOMi 10.x, click Administration > Setup and Maintenance > Infrastructure Settings.

2. In the Infrastructure Settings pane, select Applications > Operations Management.

3. In the Operations Management - HPOM Topology Synchronization Settings, Packages for
Topology Sync contains the packages that are used for topology synchronization. In addition to
other packages, ensure that you have the default;nodegroups;operations-
agent;HPOprSys;HPOprJEE packages.

4. If the package is not available, add the toposync package by following these steps:

a. In the Packages for Topology Sync, click .

b. In Value, add default;nodegroups;operations-agent;HPOprSys;HPOprJEE and click
Save.
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Chapter 3: Components
TheOMi MP for IBMWebSphere Application Server includes the following components for monitoring
IBMWebSphere Application Servers in your environment:

l WebSphereManagement Templates

l WebSphere Aspects

l Parameters

l Configuration Items (CIs) and Configuration Item Types (CITs)

l Run-time ServiceModel (RTSM) Views

l Event Type Indicators (ETIs)

l Health Indicators (HIs)

l Topology Based Event Correlation (TBEC) Rules

l HI Assignments

l Key Performance Indicators (KPIs) Assignments

l Tools

l Operations Orchestration (OO) Flows

l Graph Templates

WebSphere Management Templates
TheWebSphereManagement Templates provide a completemanagement solution for monitoring the
health and performance of IBM Application servers in your environment.

By default, OMi MP for IBMWebSphere Application Server comprises of four Management Templates
with predefined set of Aspects. You can deploy the out-of-the-box Management Templates or can
customize theManagement Templates based on your monitoring requirements. You can also create
Management Templates using theWebSphere Aspects to monitor the IBMWebSphere Application
servers in your environment.
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How to Access Management Templates

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. Click Configuration Folders > Application Server Management > IBM WebSphere
Management > Management Templates.

Overview

OMi MP forWebSphere comprises the followingWebSphereManagement Templates:

l Essential WebSphereManagement Template

l ExtensiveWebSphereManagement Template

l ExtensiveWebSphere andOracle DatabaseManagement Template

Tasks

How to Deploy WebSphere Management Templates

For information about deployingManagement Templates, see Task 5: Deploying theWebSphere
Management Templates orWebSphere Aspects .
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How to Automatically Assign WebSphere Management

Templates and WebSphere Aspects

To automatically assignWebSphereManagement Templates orWebSphere Aspects, follow these
steps:

1. Open Automatic Assignment Rules:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Automatic
Assignment Rules.

OnOMi 10.x, click Administration > Monitoring > Automatic Assignment Rules.

Automatic Assignment Rules consists of Automatic Assignment Rules pane at the top and
Parameters pane at the bottom.

2. In the Automatic Assignment Rules pane, click and select the appropriate option. The Create

Auto-Assignment Rule wizard opens.

3. In theSelect Target View tab, select the view for which you want to create the automatic
assignment rule, and then click Next.

4. In theSelect Item to Assign tab, click theManagement Template or Aspect that you want to
automatically assign to all the CIs, and then click Next.

The latest version of theManagement Template or Aspect that you want to assign is selected by
default.

5. In theRequired Parameters tab, type the user name and password details and click OK.

6. (Optional). In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x, you
can change the default value of parameters by following these steps:

a. Double-click the parameter you want to edit or select the parameter from the list and click

Edit. The Edit Parameter window opens.

b. Modify the value and click OK.

7. Click Next.

8. (Optional). In theConfigure Option tab, clear theActivate Automatic Assignment Rule check
box if you do not want to activate the assignment rule immediately. You can activate automatic
assignment rules later using the Automatic Assignment Rules window at Administration >
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Monitoring > Automatic Assignment Rules onOMi 10.x andAdmin > Operations
Management > Monitoring > Automatic Assignment Rules on BSM 9.2x.

9. Click Finish to save the changes. The assignment rule is added to the list of automatic
assignment rules.

An assignment may trigger an event to be sent to OMi if one of the following situations applies:

o A deployment job fails.

o An auto-assignment fails.

o An auto-assignment succeeds. This behavior can be configured in the Infrastructure settings.

You can check if the automatic assignment rule successfully created the expected assignments
as by following these steps:

a. Open the Assignments & Tuning pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Assignments &
Tuning.

OnOMi 10.x, click Administration > Monitoring > Assignments & Tuning.

b. In theBrowse Views tab, select the view you identified while creating your automatic
assignment rule.

c. Expand the view, and select a node that corresponds to the root CI type of the assigned item.
Assignments created as a result of Automatic Assignment Rules are shown in the list of
assignments at the top of the right pane, and have the value Auto-Assignment in the column
Assigned By.

You can consider the following options for tuning the assignment:

o Use the Automatic Assignment Rules pane to tune the parameter values for all assignments
triggered by the automatic assignment rule.

o Use the Assignments & Tuning pane to tune, redeploy, delete, and enable or disable individual
assignments.

How to Deploy an Assignment Report for a WebSphere

Management Template

1. Select theManagement Template you want to create the report.
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2. Click Generate Assignment Report in theManagement Templates & Aspects pane. The

pre-configuredAssignment Report is displayed.

You can display additional types of reports from the Assignments & Tuning pane.

Essential WebSphere Management Template

The Essential WebSphereManagement Templatemanages IBMWebSphere Application Server
environments and enables you tomonitor the primary areas of IBMWebSphere Application Server
such as JVM, JDBC, EJB, and servlets. In addition, you can alsomonitor the critical infrastructure
areas in the IBMWebSphere Application Server such as CPU, memory, and disk.

How to Access Essential WebSphere Management Template

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. Click Configuration Folders > Application Server Management > IBM WebSphere
Management > Management Templates > Essential WebSphere Management Template.

User Interface Reference

Management Template - General

Provides an overview of the attributes of theManagement Template.

UI Element Description

Name Essential WebSphereManagement Template.

Description The description of theManagement Template.

ID A unique identifier for GUI version of theManagement Template.

Version ID A unique identifier for this version of theManagement Template.

Version The current version of theManagement Template. In this instance, the version of the
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UI Element Description

Management Template is 1.100.

Change
Log

The text that describes what is new ormodified in this version of theManagement
Template.

Management Template - Topology View

Provides an overview of the CI type you want to assign to theManagement Template.

UI
Element Description

Topology
View

WebSphere_Deployment_View is the topology view for Essential WebSphere
Management Template. It contains the CI types that you want to manage using the
Management Template.

CI Type The type of CIs managed by Essential WebSphereManagement Template. This is the
type of CI to which theManagement Template can be assigned. The Essential
WebSphereManagement Template contains WebSphere Application Server CI types.

Management Template - Aspects

The Essential WebSphereManagement Template consists of the followingWebSphere Aspects to
monitor IBMWebSphere Application Servers:

l WebSphere Base

l WebSphere EJB Performance

l WebSphere JDBC Connection Pool Status

l WebSphere JVM HeapMemory

l WebSphere Server Status

l WebSphere Servlet Performance

List of Infrastructure MP Aspects

The Essential WebSphereManagement Template consists of the following Infrastructure Aspects to
monitor Infrastructure elements:

Resource Bottleneck Diagnosis

The Resource Bottleneck Diagnosis Aspect identifies congestion and bottleneck conditions for system
resources like the CPU, memory, network, and disk. CPU bottleneck monitoring is based on global
CPU utilization and load average (RunQueue Length). Memory bottleneck monitoring is based on
memory utilization, freememory available, andmemory swap out rate. File systemmonitoring is based
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on space utilization level for busiest file system on the node. Network monitoring is based on Packet
collision rate, packet error rate, and outbound queue length.

System Fault Analysis

The System Fault Analysis Aspect monitors the kernel log file, boot log file, and event log file for critical
error conditions and instructions.

System Infrastructure Discovery

The System Infrastructure Discovery Aspect discovers and gathers information regarding the system
resources, operating system, and applications on amanaged node.

Extensive WebSphere Management Template

The ExtensiveWebSphereManagement Templatemanages IBMWebSphere Application Server
environments and enables you tomonitor the primary and advanced areas of IBMWebSphere
Application Servers such as transactions, cluster status, cache usage, threads, and server logs. In
addition, you can alsomonitor the infrastructure areas of IBMWebSphere Application Servers such as
CPU, memory, and disk.

How to Access Extensive WebSphere Management Template

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. Click Configuration Folders > Application Server Management > IBM WebSphere
Management > Management Templates > Extensive WebSphere Management Template.

User Interface Reference

Management Template - General

Provides an overview of the attributes of theManagement Template.
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UI Element Description

Name ExtensiveWebSphereManagement Template.

Description The description of theManagement Template.

ID A unique identifier for GUI version of theManagement Template.

Version ID A unique identifier for this version of theManagement Template.

Version The current version of theManagement Template. In this instance, the version of the
Management Template is 1.100.

Change
Log

The text that describes what is new ormodified in this version of theManagement
Template.

Management Template - Topology View

Provides an overview of the CI type you want to assign to theManagement Template.

UI
Element Description

Topology
View

WebSphere_Deployment_View is the topology view for ExtensiveWebSphere
Management Template. It contains the CI types that you want to manage using the
Management Template.

CI Type The type of CIs managed by ExtensiveWebSphereManagement Template. This is the
type of CI to which theManagement Template can be assigned. The Extensive
WebSphereManagement Template contains WebSphere Application Server CI types.

Management Template - Aspects

The ExtensiveWebSphereManagement Template consists of the followingWebSphere Aspects to
monitor IBMWebSphere Application Servers:

WebSphere Base

WebSphere Cluster Status

WebSphere EJB Performance

WebSphere JDBC Connection Pool Status

WebSphere JVM HeapMemory

WebSphere Server Status

WebSphere Servlet Performance

WebSphere Thread Status

WebSphere Transaction Status

User Guide
WebSphereManagement Templates

HPE OMi Management Pack for IBM WebSphere Application Server (1.01) Page 29 of 138



List of Infrastructure MP Aspects

The ExtensiveWebSphereManagement Template consists of the following Infrastructure Aspects to
monitor Infrastructure elements:

Bandwidth Utilization and Network IOPS

The Bandwidth Utilization and Network IOPS Aspect monitors I/O operations and performance of the
systems in the network. It monitors the network I/O operations and performance based on the
bandwidth used, outbound queue length, and average bytes transferred per second.

CPU Performance

The CPU Performance Aspect monitors the overall CPU performance like the CPU utilization
percentage and spike in CPU usage. Individual CPU performancemonitoring is based on total CPU
utilization, CPU utilization in user mode, CPU utilization in systemmode and interrupt rate.

Memory and Swap Utilization

TheMemory and SwapUtilization Aspect monitors memory performance of the system. memory
performancemonitoring is based onmemory utilization (in percentage), swap space utilization (in
percentage), freememory available (in MBs) and free swap space available (in MBs).

Remote Disk Space Utilization

The Remote Disk Space Utilization Aspect monitors space utilization of remote disk.

Resource Bottleneck Diagnosis

The Resource Bottleneck Diagnosis Aspect identifies congestion and bottleneck conditions for system
resources like the CPU, memory, network, and disk. CPU bottleneck monitoring is based on global
CPU utilization and load average (RunQueue Length). Memory bottleneck monitoring is based on
memory utilization, freememory available, andmemory swap out rate. File systemmonitoring is based
on space utilization level for busiest file system on the node. Network monitoring is based on packet
collision rate, packet error rate, and outbound queue length.

Space Availability and Disk IOPS

The Space Availability and Disk IOPS Aspect monitors the disk I/O operations and space utilization of
the system.

System Fault Analysis

The System Fault Analysis Aspect monitors the kernel log file, boot log file, and event log file for critical
error conditions and instructions.

System Infrastructure Discovery

The System Infrastructure Discovery Aspect discovers and gathers information regarding the system
resources, operating system, and applications on amanaged node.
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Extensive WebSphere and Oracle Database

Management Template

The ExtensiveWebSphere andOracle DatabaseManagement Templatemonitors components of your
WebSphere server along with basic components of Infrastructure andOracle database. The Extensive
WebSphere andOracle DatabaseManagement Templatemanages the IBMWebSphere Application
Server environments in monitoring the primary and advanced areas of server such as transactions,
cluster status, cache usage, threads, and server logs along with Oracle database single instance
environment in monitoring the primary areas of database such as availability, query performance,
tablespace, andOracle alert log with critical infrastructure areas of CPU, memory, and disk.

Note: The ExtensiveWebSphere andOracle DatabaseManagement Template can be deployed
only when the deployment of Discovery Aspect and deployment of Management Template or
Aspect discovers the JDBC and its dependent Oracle CIs.

How to Access Extensive WebSphere and Oracle

Database Management Template

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. Click Configuration Folders > Application Server Management > IBM WebSphere
Management > Management Templates > Extensive WebSphere and Oracle Database
Management Template.

User Interface Reference

Management Template - General

Provides an overview of the attributes of theManagement Template.
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UI Element Description

Name ExtensiveWebSphere andOracle DatabaseManagement Template

Description The description of theManagement Template.

ID A unique identifier for GUI version of theManagement Template.

Version ID A unique identifier for this version of theManagement Template.

Version The current version of theManagement Template. In this instance, the version of the
Management Template is 1.100.

Change
Log

The text that describes what is new ormodified in this version of theManagement
Template.

Management Template - Topology View

Provides an overview of the CI type you want to assign to theManagement Template.

UI
Element Description

Topology
View

WebSphere_Deployment_View is the topology view for ExtensiveWebSphere and
Oracle DatabaseManagement Template. It contains the CI types that you want to
manage using theManagement Template.

CI Type The type of CIs managed by ExtensiveWebSphere andOracle DatabaseManagement
Template. This is the type of CI to which theManagement Template can be assigned.
The ExtensiveWebSphere and DatabaseManagement Template contains WebSphere
Application Server CI types.

Management Template - Aspects

The ExtensiveWebSphere andOracle DatabaseManagement Template consists of the following
WebSphere Aspects to monitor IBMWebSphere Application Servers:

WebSphere Base

WebSphere Cluster Status

WebSphere EJB Performance

WebSphere JDBC Connection Pool Status

WebSphere JVM HeapMemory

WebSphere Server Status

WebSphere Servlet Performance

WebSphere Thread Status
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WebSphere Transaction Status

List of Infrastructure MP Aspects

The ExtensiveWebSphere andOracle DatabaseManagement Template consists of the following
Infrastructure Aspects to monitor Infrastructure elements:

Bandwidth Utilization and Network IOPS

The Bandwidth Utilization and Network IOPS Aspect monitors IO operations, and performance of the
systems in the network. It monitors the network I/O operations and performance based on the
bandwidth used, outbound queue length, and average bytes transferred per second.

CPU Performance

The CPU Performance Aspect monitors the overall CPU performance like the CPU utilization
percentage and spike in CPU usage. Individual CPU performancemonitoring is based on total CPU
utilization, CPU utilization in user mode, CPU utilization in systemmode and interrupt rate.

Memory and Swap Utilization

TheMemory and SwapUtilization Aspect monitors memory performance of the system. Memory
performancemonitoring is based onmemory utilization (in percentage), swap space utilization (in
percentage), freememory available (in MBs) and free swap space available (in MBs).

Remote Disk Space Utilization

The Remote Disk Space Utilization Aspect monitors space utilization of remote disk.

Resource Bottleneck Diagnosis

The Resource Bottleneck Diagnosis Aspect identifies congestion and bottleneck conditions for system
resources like the CPU, memory, network, and disk. CPU bottleneck monitoring is based on global
CPU utilization and load average (RunQueue Length). Memory bottleneck monitoring is based on
memory utilization, freememory available, andmemory swap out rate. File systemmonitoring is based
on space utilization level for busiest file system on the node. Network monitoring is based on Packet
collision rate, packet error rate, and outbound queue length.

Space Availability and Disk IOPS

The Space Availability and Disk IOPS Aspect monitors the disk IO operations and space utilization of
the system.

System Fault Analysis

The System Fault Analysis Aspect monitors the kernel log file, boot log file, and event log file for critical
error conditions and instructions.
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System Infrastructure Discovery

The System Infrastructure Discovery Aspect discovers and gathers information regarding the system
resources, operating system, and applications on amanaged node.

CI Type Policy Template Description Policy Type

Computer OPC_PERL_
INCLUDE_
INSTR_DIR

This policy is used for setting OPC_PERL_
INCLUDE_INSTR_DIR in operations agent xpl
config namespace. Set the value to TRUE for
Infrastructure SPI policies to work.

Node Info
Template

Sys_
SystemDiscovery

This policy template gathers service information
from themanaged nodes such as hardware
resources, operating system attributes, and
applications.

Service Auto-
Discovery
Template

List of Oracle MP Aspects

The ExtensiveWebSphere and DatabaseManagement Template consists of the following Oracle
Aspects to monitor Oracle components:

Basic Oracle Locks and Latches

The Basic Oracle Locks and Latches Aspect monitors the consumption of Oracle locks (in percentage)
and also checks the usage of the counters - session wait lock count and latch count. This is a basic
type of Aspect.

Basic Oracle Memory Performance

The Basic Oracle Memory Performance Aspect monitors the Oracle memory units - BufferCache,
Shared Pool, and Library Cache. This is a Basic type of Aspect.

Basic Oracle Query Performance

The Basic Oracle Query Performance Aspect monitors the performance of Oracle queries by checking
the Oracle metrics - Elapsed time and CPU time. This is a basic type of Aspect.

Basic Oracle Segment Space

The Basic Oracle Segment Space Aspect monitors the units of database storage - segments and
extents. This is a basic type of Aspect.

Oracle Archive Health

TheOracle Archive Health Aspect monitors the Oracle device space, archive frequency rate, and redo
logs that are not archived.

Oracle Database Availability

TheOracle Database Availability Aspect monitors the Oracle database connection status, processes,
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and logons.

Oracle Discovery

This Oracle Discovery Aspect discovers the Oracle, RAC, and ASM instances.

Oracle IO Performance

TheOracle IO Performance Aspect monitors the physical and logical read rate of Oracle instances.

Oracle Tablespace Health

TheOracle Tablespace Health Aspect monitors the Oracle table space status, free space, datafile
status, and segments.

Oracle Transactions

TheOracle Transactions Aspect monitors the Oracle transactions percentage, commit rate, and open
cursor. This is an advanced version of Basic Oracle Transactions Aspect.

WebSphere Aspects
WebSphere Aspects are used tomonitor the basic and advanced components of theWebSphere
Application Servers in your environment.

Tasks

How to Access WebSphere Aspects

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. Click Configuration Folders > Application Server Management > IBM WebSphere
Management > Aspects.
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How to Deploy WebSphere Aspects

Formore information about deployingWebSphere Aspects, see Task 5: Deploying theWebSphere
Management Templates orWebSphere Aspects.

How to Create WebSphere Aspects

To createWebSphere Aspects, follow these steps:

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In theManagement Template & Aspects pane, click , and then select Create Aspect. The Add
New Aspect window opens.

3. In theGeneral tab, specify aName, ID, Version ID, andDescription for the Aspect. Click Next.

4. In theCI Type tab, select one or more CI Types (CITs) from the Available CI Types pane to

associate with the Aspect and click to add them to the Assigned CI Types pane, and then click

Next.

Note: You can use either use theCTRL orSHIFT key to select multiple items.

5. In the Instrumentation tab, click Add Instrumentation to select the instrumentation
category that needs to be added to an Aspect. Click Next.

6. In theAspects tab, click Add Existing Aspect to add Aspects as nested aspects. The Add
Existing Aspect dialog box opens and lists the Aspects. Select one or more Aspects by using
either theCTRL orSHIFT key. Click OK and then click Next.

7. In thePolicy Templates tab, click Add Policy Templates on BSM 9.2x orAdd Policy
Templates from List onOMi 10.x to select the policy templates that has to be added to an
Aspect. The Add New Policy Template to Aspect dialog box opens and lists the Policy Templates.
Select one or more Policy Templates by selecting either theCTRL orSHIFT key. Click OK and
then click Next.

8. If no suitable Policy Templates exist:
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a. Click and then select Add New Policy Template. The Select New Policy Template

dialog box opens.

b. Select theMeasurement Threshold Policy Template from the Type drop-down list. Click
OK.

c. In the Policy Related Information window, specify theName and click OK. The Policy
Template is added to the list of existing Policy Templates.

9. Click Next.

10. In theParameters tab, you see a list of parameters from the Policy Templates that you assigned
to a template.

a. Click Edit. The Edit Parameter dialog box opens.

b. Modify the required details and click OK.

11. In the Add New Aspect window, click Finish to save the Aspect. The new Aspect appears in the
Management Templates & Aspects pane.

User Interface Reference

General Provides an overview of the general attributes of theWebSphere Aspects.

CI Type The type of configuration items that the Aspect can be assigned to. This is the
type of CI to which the Aspect can be assigned. TheWebSphere Aspects
contain the Computer, Node, Cluster, and CI types.

Instrumentation Provides a single package which contains the binaries for discovery, collection,
and data logging.

Aspects Provides an overview of any Aspects that theWebSphere Aspect contains. The
WebSphere Base Aspect is part of all the other Aspects.

Policy
Templates

Provides an overview of the policy templates that theWebSphere Aspect
contain. You can expand each item in the list to seemore details about the policy
template.

List of WebSphere Aspects

TheOMi MP for IBMWebSphere Application Server comprises of the followingWebSphere Aspects:
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WebSphere Base

TheWebSphere Base Aspect is the basic Aspect for monitoring the IBMWebSphere Application
Servers and it contains the config file, openmessage interface, and scheduled task policy templates.

CI Type
Policy
Template Indicator Description

Policy
Type

j2eeserver WebSphere_
Medium

N/A Runs theWebSphere collector or analyzer as
per themedium schedule.

Scheduled
Task

j2eeserver WebSphere_
High

N/A Runs theWebSphere collector or analyzes per
the high schedule.

Scheduled
Task

j2eeserver WebSphere_
TextLogs

N/A This policy templatemonitors the specifics of
IBMWebSphere Application Servers such as
SystemOut, SystemErr, andmessages using
JMX notifications.

LogFile
Entry

j2eeserver WebSphere_
Messages

N/A WebSphereMessage Interceptor Open
Message
Interface

j2eeserver WebSphere_
Configuration

N/A WebSphere_Configuration ConfigFile

j2eeserver WebSphere_
VeryHigh

N/A Runs theWebSphere collector or analyzer as
per the very high schedule.

Scheduled
Task

j2eeserver WebSphere_
MPLog

N/A This policy templatemonitors theWebSphere
Perl, Discovery, and Collector Log files.

LogFile
Entry

WebSphere Cluster Status

TheWebSphere Cluster Status Aspect monitors the IBMWebSphere Application Server running in a
cluster environment.

CI Type
Policy
Template Indicator Description Policy Type

j2eeserver WebSphere_
ClusterStatus

ClusterStatus:Stopped /
ClusterStatus:Started,
ClusterStatus:PartialStop

This policy template
monitors the status of the
cluster.

Measurement
Threshold
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CI Type
Policy
Template Indicator Description Policy Type

/ ClusterStatus:Started

WebSphere Discovery

TheWebSphere Discovery Aspect discovers the IBMWebSphere Application Server instances.

CI
Type

Policy
Template Indicator Description

Policy
Type

host_
node

WebSphere_
Messages

N/A WebSphereMessage Interceptor Open
Message
Interface

host_
node

WebSphere_
Discovery

N/A This policy template discovers theWebSphere
Server domains, clusters, and, application servers.
In addition, it also discovers the deployed
applications and JDBC datasources.

Service
Auto-
Discovery

host_
node

WebSphere_
MPLog

N/A This policy templatemonitors theWebSphere Perl,
discovery, and collector log files.

LogFile
Entry

WebSphere EJB Performance

TheWebSphere EJB Performance Aspect monitors the IBMWebSphere Application Servers and
checks the status of EJB transactions and pools.

CI Type Policy Template Indicator Description Policy Type

j2eeserv
er

WebSphere_
EJBMethCallsRt

N/A This policy template
monitors the number
of EJB method calls
per minute.

ConfigFile

j2eeserv
er

WebSphere_
EJBPoolMissPctAp
p

N/A This policy template
monitors the
average percentage
of time a call to
retrieve an EJB from

ConfigFile
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CI Type Policy Template Indicator Description Policy Type

the pool failed for
each application.

j2eeserv
er

WebSphere_
EJBEntDatLdStRt

N/A This policy template
monitors the number
of times an EJB is
written to or loaded
from the database
per minute.

ConfigFile

j2eeserv
er

WebSphere_
EJBMsgBackoutRat
e

N/A This policy template
monitors the rate at
which the
messages failed to
be delivered to the
MessageDrivenBea
ns onMessage
method.

Measureme
nt Threshold

j2eeserv
er

WebSphere_
EJBConcLivesApp

EJBConcurrentLives:High
/
EJBConcurrentLives:Nor
mal

This policy template
monitors the
average number of
EJB Concurrent
Lives for an
application.

Measureme
nt Threshold

j2eeserv
er

WebSphere_
EJBMethRespTime

EJBPerformance:Low /
EJBPerformance:Normal,
EJBPerformance:Low /
EJBPerformance:Normal

This policy template
monitors the
average EJB
response time in
milliseconds.

Measureme
nt Threshold

j2eeserv
er

WebSphere_
EJBPoolMissPct

N/A This policy template
monitors the
average percentage
of time a call to
retrieve an EJB from
the pool failed.

ConfigFile

j2eeserv
er

WebSphere_
EJBEntDatLdStRtA
pp

N/A This policy template
monitors the number
of times an EJB
was written to or
loaded from the
database per minute
for an application.

Measureme
nt Threshold

j2eeserv WebSphere_ N/A This policy template ConfigFile
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CI Type Policy Template Indicator Description Policy Type

er EJBPoolUtil monitors the
percentage of active
beans in the pool.

j2eeserv
er

WebSphere_
EJBPoolSize

N/A This policy template
monitors the
average size of the
EJB pool.

ConfigFile

j2eeserv
er

WebSphere_
EJBMethCallsRtApp

N/A This policy template
monitors the number
of EJB method calls
per minute for an
application.

Measureme
nt Threshold

j2eeserv
er

WebSphere_
EJBConcLives

N/A This policy template
monitors the
average number of
EJB objects in the
pool.

ConfigFile

j2eeserv
er

WebSphere_
EJBPoolUtilApp

EJBUtilization:High /
EJBUtilization:Normal

This policy template
monitors the
percentage of active
beans in the pool for
an application.

Measureme
nt Threshold

j2eeserv
er

WebSphere_
EJBReturnDiscrdRt

N/A This policy template
monitors the rate at
which the returning
object was
discarded because
the (entity and
stateless EJB) pool
was full.

Measureme
nt Threshold

WebSphere JDBC Connection Pool Status

TheWebSphere JDBC Connection Pool Status Aspect monitors the JDBC connection availability and
connection pools.
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CI
Type Policy Template Indicator

Descripti
on

Policy
Type

j2eeser
ver

WebSphere_
JDBCConnPoolWaite
rs

DataSourceConnectionWaiters:High /
DataSourceConnectionWaiters:Norma
l,
DataSourceConnectionWaiters:High /
DataSourceConnectionWaiters:Norma
l

This
policy
template
monitors
the
average
number of
threads
waiting for
a JDBC
connectio
n from
connectio
n pools for
an
applicatio
n.

Measurem
ent
Threshold

j2eeser
ver

WebSphere_
JDBCConnPoolWaitT
ime

DataSourceConnectionPoolAvailability
:Low /
DataSourceConnectionPoolAvailability
:Normal,
DataSourceConnectionPoolAvailability
:Low /
DataSourceConnectionPoolAvailability
:Normal

This
policy
template
monitors
the
average
time that
a client
waited for
a JDBC
connectio
n in
millisecon
ds for an
applicatio
n.

Measurem
ent
Threshold

j2eeser
ver

WebSphere_
JDBCConPoolThroug
hput

DataSourceConnectionPoolPerforman
ce:Low /
DataSourceConnectionPoolPerforman
ce:Normal

This
policy
template
monitors
the
number of
JDBC
connectio
ns
allocated

Measurem
ent
Threshold
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CI
Type Policy Template Indicator

Descripti
on

Policy
Type

and
returned
by
applicatio
ns per
second
for an
applicatio
n.

j2eeser
ver

WebSphere_
JDBCConPoolThru

N/A This
policy
template
monitors
the
number of
JDBC
connectio
ns
allocated
and
returned
by
applicatio
ns per
second.

ConfigFile

j2eeser
ver

WebSphere_
JDBCConnPoolSize

N/A This
policy
template
monitors
the
average
number of
JDBC
connectio
ns in the
connectio
n pool.

Measurem
ent
Threshold

j2eeser
ver

WebSphere_
JDBCConnPoolTime
OutRts

DataSourceConnectionPoolAvailability
:Low /
DataSourceConnectionPoolAvailability
:Normal,
DataSourceConnectionPoolAvailability
:Low /

This
policy
template
monitors
the

Measurem
ent
Threshold
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CI
Type Policy Template Indicator

Descripti
on

Policy
Type

DataSourceConnectionPoolAvailability
:Normal

number of
times a
client
timed out
waiting for
a JDBC
connectio
n from the
pool for an
applicatio
n per
minute.

j2eeser
ver

WebSphere_
JDBCConPoolTimeRt

N/A This
policy
template
monitors
the
number of
times a
client
timed out
waiting for
a JDBC
connectio
n from the
pool per
minute.

ConfigFile

j2eeser
ver

WebSphere_
JDBCConPoolWtTim
e

N/A This
policy
template
monitors
the
average
time that
a client
waited for
a JDBC
connectio
n in
millisecon
ds.

ConfigFile

j2eeser
ver

WebSphere_
JDBCConnPoolMaxP

N/A This Measurem
ent
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CI
Type Policy Template Indicator

Descripti
on

Policy
Type

ct policy
template
monitors
the
percentag
e of time
that all
JDBC
connectio
ns in a
pool are in
use.

Threshold

j2eeser
ver

WebSphere_
JDBCConnPoolUtil

DataSourceConnectionPoolUtilization:
High /
DataSourceConnectionPoolUtilization:
Normal,
DataSourceConnectionPoolUtilization:
High /
DataSourceConnectionPoolUtilization:
Normal

This
policy
template
monitors
the
percentag
e of
JDBC
connectio
n pool in
use.

Measurem
ent
Threshold

j2eeser
ver

WebSphere_
JDBCConPoolWait

N/A This
policy
template
monitors
the
average
number of
threads
waiting for
a JDBC
connectio
n from
connectio
n pools.

ConfigFile

j2eeser
ver

WebSphere_
JDBCPreparedStDisc
Rt

DataSourceConnectionPoolPerforman
ce:Low /
DataSourceConnectionPoolPerforman
ce:Normal

This
policy
template
monitors
the rate at

Measurem
ent
Threshold

User Guide
WebSphere Aspects

HPE OMi Management Pack for IBM WebSphere Application Server (1.01) Page 45 of 138



CI
Type Policy Template Indicator

Descripti
on

Policy
Type

which the
prepared
statement
s are
discarded
by the
least
recently
used
(LRU)
algorithm
of the
statement
cache.

WebSphere JVM Heap Memory

TheWebSphere JVM HeapMemory Aspect monitors the IBMWebSphere Application Server
parameters.

CI Type Policy Template Indicator
Descriptio
n

Policy
Type

j2eeserv
er

WebSphere_
JVMMemFreePct

N/A This policy
template
monitors
the
percentage
of JVM free
memory
available.

ConfigFile

j2eeserv
er

WebSphere_
GarbageCollectionCt

TotalGarbageCollectionCount:High
/
TotalGarbageCollectionCount:Nor
mal,
TotalGarbageCollectionCount:High
/
TotalGarbageCollectionCount:Nor
mal

This policy
template
monitors
the
garbage
collection
count.

Measureme
nt Threshold

j2eeserv WebSphere_ TotalGarbageCollectionTime:High / This policy Measureme
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CI Type Policy Template Indicator
Descriptio
n

Policy
Type

er GarbageCollectionTi
me

TotalGarbageCollectionTime:Norm
al,
TotalGarbageCollectionTime:High /
TotalGarbageCollectionTime:Norm
al

template
monitors
the
garbage
collection
time.

nt Threshold

j2eeserv
er

WebSphere_
JVMCpuUsagePct

N/A This policy
template
monitors
the CPU
percentage
usage of
the JVM.

ConfigFile

j2eeserv
er

WebSphere_
JVMMemUtilPct

JVMMemoryUtilization:High /
JVMMemoryUtilization:Normal,
JVMMemoryUtilization:High /
JVMMemoryUtilization:Normal

This policy
template
monitors
the
percentage
of heap
space used
in the JVM.

Measureme
nt Threshold

j2eeserv
er

WebSphere_
GCIntervalTime

N/A This policy
template
monitors
the
average
garbage
collection
value in
seconds
between
two
garbage
collections.

ConfigFile

j2eeserv
er

WebSphere_
ProcessCpuUsage

AllProcessorsAverageLoad:High /
AllProcessorsAverageLoad:Norma
l,
AllProcessorsAverageLoad:High /
AllProcessorsAverageLoad:Normal

This policy
template
monitors
the
percentage
of process
CPU
usage.

Measureme
nt Threshold
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WebSphere Server Status

TheWebSphere Server Status Aspect monitors the availability and performance of IBMWebSphere
Application Servers.

CI Type
Policy
Template Indicator Description Policy Type

j2eeserver WebSphere_
ServerStatus

ServerStatus:Unavailable
/ ServerStatus:Available

This policy template
monitors the status of the
IBMWebSphere
Application Servers.

Measurement
Threshold

WebSphere Servlet Performance

TheWebSphere Servlet Performance Aspect monitors the IBMWebSphere Application Server servlet
sessions for web applications.

CI Type Policy Template Indicator Description Policy Type

j2eeserve
r

WebSphere_
WebAppServReqRt

N/A This policy
template
monitors the
number of
servlet
sessions
being
invalidated
per second.

ConfigFile

j2eeserve
r

WebSphere_
WebAppServletRespTim
e

ServletPerformance:Low /
ServletPerformance:Norma
l,
ServletPerformance:Low /
ServletPerformance:Normal

This policy
template
monitors the
average
response
time for a
web
application
servlet in
millisecond
s.

Measuremen
t Threshold
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CI Type Policy Template Indicator Description Policy Type

j2eeserve
r

WebSphere_
ServInvSessRt

N/A This policy
template
monitors the
number of
servlet
sessions
being
invalidated
per second.

Measuremen
t Threshold

j2eeserve
r

WebSphere_
ServSessActSess

ServerSessions:High /
ServerSessions:Normal

This policy
template
monitors the
number of
servlet
sessions
currently
being
accessed.

Measuremen
t Threshold

j2eeserve
r

WebSphere_
WebAppServErrRt

N/A This policy
template
monitors the
number of
errors in a
servlet per
second.

ConfigFile

j2eeserve
r

WebSphere_
WebAppServErrRtApp

N/A This policy
template
monitors the
number of
errors in a
servlet per
second for
an
application.

Measuremen
t Threshold

j2eeserve
r

WebSphere_
WebAppServRelRt

NA This policy
template
monitors the
number of
servlets
reloaded for
a web
application
per minute.

ConfigFile
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CI Type Policy Template Indicator Description Policy Type

j2eeserve
r

WebSphere_
WebAppServReqRtApp

ServletRequests:High /
ServletRequests:Normal

This policy
template
monitors the
number of
requests for
a servlet per
second for
an
application.

Measuremen
t Threshold

j2eeserve
r

WebSphere_
ServSessAveLife

NA This policy
template
monitors the
average
servlet
session
lifetime in
millisecond
s.

Measuremen
t Threshold

j2eeserve
r

WebSphere_
WebAppServLoad

ServletsLoaded:High /
ServletsLoaded:Normal

This policy
template
monitors the
number of
servlets
currently
loaded for a
web
application.

Measuremen
t Threshold

WebSphere Thread Status

TheWebSphere Thread Status Aspect monitors the thread status of IBMWebSphere Application
Servers.

CI Type Policy Template Indicator
Descriptio
n Policy Type

j2eeserve
r

WebSphere_
CcrtThreadPlHngCt

N/A This policy
template
monitors
the number

ConfigFile
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CI Type Policy Template Indicator
Descriptio
n Policy Type

of
concurrentl
y hung
threads.

j2eeserve
r

WebSphere_
ThreadPoolHungRt

ThreadHungRate:High /
ThreadHungRate:Normal

This policy
template
monitors
the rate at
which the
threads are
declared
hung.

Measuremen
t Threshold

j2eeserve
r

WebSphere_
ThreadPoolAveSize

N/A This policy
template
monitors
the average
number of
threads
(active and
idle) in a
pool during
collection
interval.

ConfigFile

j2eeserve
r

WebSphere_
ThreadPoolUtilPct

ThreadPoolUtilization:High /
ThreadPoolUtilization:Normal,
ThreadPoolUtilization:High /
ThreadPoolUtilization:Normal,
ThreadPoolUtilization:High /
ThreadPoolUtilization:Normal

This policy
template
monitors
the
percentage
of threads
used in a
pool during
collection
interval

Measuremen
t Threshold

j2eeserve
r

WebSphere_
ThreadPoolCrtRt

N/A This policy
template
monitors
the number
of threads
created per
minute.

ConfigFile

j2eeserve WebSphere_ N/A This policy ConfigFile
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CI Type Policy Template Indicator
Descriptio
n Policy Type

r ThreadPoolPctMax template
monitors
the
percentage
of time
number of
threads in
pool
reached
configured
maximum
size.

j2eeserve
r

WebSphere_
ThreadPoolPctMaxAp
p

N/A This policy
template
monitors
the
percentage
of time
number of
threads in
pool
reached
configured
maximum
size for an
application.

Measuremen
t Threshold

j2eeserve
r

WebSphere_
ThreadStartedCt

TotalNumberOfThreads:High /
TotalNumberOfThreads:Norma
l,
TotalNumberOfThreads:High /
TotalNumberOfThreads:Normal

This policy
template
monitors
the number
of threads
spawned for
garbage
collection.

Measuremen
t Threshold

j2eeserve
r

WebSphere_
ThreadPoolActThread
s

N/A This policy
template
monitors
the average
number of
active
threads in a
pool during
collection

ConfigFile
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CI Type Policy Template Indicator
Descriptio
n Policy Type

interval.

WebSphere Transaction Status

TheWebSphere Transaction Status Aspect monitors the IBMWebSphere Application Server
Transactions activities.

CI Type Policy Template Indicator Description Policy Type

j2eeserver WebSphere_
TranLocDur

N/A This policy
template
monitors the
average
duration of
local
transactions
in
milliseconds.

Measurement
Threshold

j2eeserver WebSphere_
TranGlobCommDur

N/A This policy
template
monitors the
average
duration of
commits for
global
transactions
in
milliseconds.

Measurement
Threshold

j2eeserver WebSphere_
TranLocCommDur

N/A This policy
template
monitors the
average
duration of
commits for
local
transactions
in
milliseconds.

Measurement
Threshold
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CI Type Policy Template Indicator Description Policy Type

j2eeserver WebSphere_
TranRollbackRt

TransactionRollbackRate:High /
TransactionRollbackRate:Normal

This policy
template
monitors the
number of
global and
local
transactions
rolled back
per second.

Measurement
Threshold

j2eeserver WebSphere_
TranCommitRt

TransactionCommitRate:High /
TransactionCommitRate:Normal

This policy
template
monitors the
number of
global and
local
transactions
that were
committed
per second

Measurement
Threshold

j2eeserver WebSphere_
TranStartRt

TransactionStartRate:High /
TransactionStartRate:Normal

This policy
template
monitors the
number of
global and
local
transactions
that were
begun per
second.

Measurement
Threshold

j2eeserver WebSphere_
TranTimeoutRte

TransactionTimeoutRate:High /
TransactionTimeoutRate:Normal

This policy
template
monitors the
number of
global and
local
transactions
that timed
out per
second.

Measurement
Threshold

j2eeserver WebSphere_
TranGlobDur

N/A This policy
template
monitors the
average

Measurement
Threshold
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CI Type Policy Template Indicator Description Policy Type

duration of
global
transactions
in
milliseconds.

Parameters
Parameters are variables that are an integral component of WebSphereManagement Templates,
Aspects, and Policy Templates. Each parameter corresponds to a variable. Parameters contain default
values that are used for monitoring different components of IBMWebSphere Application Servers. You
can alsomodify the values of the variables to suit your monitoring requirements.

The parameters are grouped as follows:

l Instance Parameters - These parameters are essential for monitoring IBMWebSphere Application
Servers. For example, WebSphere Server Home.

l Mandatory Parameters - These parameters contain the essential information required by policy
templates. For example, WebSphere Username andWebSphere Password aremandatory
parameters.

l Dependent Parameters - There are some parameters which are a subset of themandatory
parameters. Such parameters are referred to as dependent parameters.

l Expert Parameters - These parameters can be used by SMEs and Administrators. For example,
Frequency of Medium Scheduler is an expert parameter.

Grouping of Parameters

Parameter Parameter Type Description
Default
Values

WebSphere
Application Server
Profile Home

Instance IBMWebSphere Application Server
Profile Home

WebSphere
Username

Mandatory Username corresponding to the profile
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WebSphere
Password

Mandatory Password corresponding to the profile

WebSphere Server
Home

Optional IBMWebSphere Application Server home

WebSphere JAVA
Home

Optional IBMWebSphere JAVA Home.

WebSphere
Application Server
Port Number

IBMWebSphere Application Server Port
Number

Default port
value is
SOAP. If the
server is
configured for
RMI, port
needs to be
provided as a
user input.

WebSphere
Application Server
SSL TrustStore File
Path

IBMWebSphere Application Server SSL
TrustStore File Path

WebSphere
Application Server
SSL TrustStore File
Password

IBMWebSphere Application Server SSL
TrustStore File Password

****

WebSphere
Application Server
SSL KeyStore File
Path

IBMWebSphere Application Server SSL
KeyStore File Path

WebSphere
Application Server
SSL KeyStore File
Password

IBMWebSphere Application Server SSL
KeyStore File Password

****

WebSphere
Application Server
JMX Connector
Type

WebSphere Application Server JMX
connector type can be
SOAP/JSR160RMI.

Default value
is SOAP. If
server is
configured for
RMI, the
value needs
to be
specified.

WebSphere
Application Server
Jar File Path

IBMWeb Sphere Application Server jar
file path.

User Guide
Parameters

HPE OMi Management Pack for IBM WebSphere Application Server (1.01) Page 56 of 138



Frequency of
WebSphere Text
Logs

Expert Frequency of monitoringWebSphere text
logs with defined patterns.

30

Frequency of IBM
WebSphereMP
Log

Expert Frequency for usingWebSphereMP logs
with defined patterns.

1

Frequency of
VeryHigh
Scheduler

Expert Frequency for the scheduler which is
expected to run on very short interval (in
minutes).

5 Minutes

Frequency of High
Scheduler

Expert Frequency for the scheduler which is
expected to run on short interval (in
minutes).

15Minutes

Frequency of
Medium Scheduler

Expert Frequency for the scheduler which is
expected to run onmedium interval (in
hours).

1 Hour

Tuning Parameters

You can edit the parameters of the IBMWebSphereManagement Templates and Aspects that are
already deployed to the IBMWebSphere Application Server CIs.

To edit the parameters, follow these steps:

1. Open the Assignments & Tuning pane:

On BSM 9.2x, click Admin > Monitoring > Assignments & Tuning.

OnOMi 10.x, click Administration > Monitoring > Assignments & Tuning.

2. In theBrowse Views tab, select theWebSphere_Deployment_View view that contains the IBM
WebSphere Application Server CI for which you want to tune parameters. Alternatively, you can
use theSearch tab to find a CI.

3. In the list of IBMWebSphere Application Server CIs, click a CI. The Assignments pane shows
details of existing assignments for the CI.

4. Click the assignment for which you want to tune parameters. The Assignment Details pane shows
the current parameter values.
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5. In the Assignment Details pane, change the parameters:

a. Select a parameter in the list, and then click .
i. For standard parameters, the Edit Parameter dialog box opens.

Click Value, specify the value, and then click OK.

ii. For instance parameters, the Edit Instance Parameter dialog box opens.

Change the instance values if necessary, and then for each instance value, change
dependent parameter values. After you change the instances and dependent parameter
values, click OK.

6. In the Assignment Details pane, click Save Changes. Operations Management deploys the new
parameter values to the relevant Operations Agent.

Configuration Items (CIs) and Configuration
Item Types (CITs)
CIs are components that have to bemanaged in order to deliver an IT Service. CIs typically include IT
Services, hardware, and software.

CIT describes the type of a CI and its attributes. TheWebSphere CIs that are discovered in an
environment are grouped under the CITs. OMi MP for IBMWebSphere Application Server comprises
the following CITs:

l j2ee Domain

l websphereas

l JVM

l J2EE Application

l JDBC Data Source

l Oracle

Run-time Service Model (RTSM) Views
AnRTSM View enables you to build and visualize a subset of the overall RTSMmodel. The RTSM
Views for OMi MP for IBMWebSphere Application Server enables you to visualize the topology of IBM
WebSphere Application Server environment that you want to monitor. The RTSM Views for OMi MP for
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IBMWebSphere Application Server can be used to view andmanage the Event Perspective and
Health Perspective of the IBMWebSphere Application Server CIs discovered usingWebSphere
Discovery Aspect. You can also use RTSM Views for assigning and tuning the OMi MP for IBM
WebSphere Application Server in theWebSphere Application Server environment.

How to Access RTSM Views

1. Open the RTSM Views:

On BSM 9.23, click Admin > RTSM Administration > Modeling > Modeling Studio.

OnOMi 10.x, click Administration > RTSM Administration > Modeling > Modeling Studio.

2. Select Views from theResource Type drop-down list.

3. Select Operations Management > J2EE Application Servers.

By default, OMi MP for IBMWebSphere Application Server contains the following RTSM Views:

l WebSphere_Deployment_View: This RTSM view refers to the J2EE cluster, J2EE domain,
JDBC data source, J2EE application, database, and computer, andOracle CITs. TheWebSphere_
Deployment_View enables you to visualize the Event and Health perspectives of the IBM
WebSphere Application Server CIs that youmonitor. You can use theWebSphere_Deployment
view for visualizing events that are specific to themonitored IBMWebSphere Application Servers.
You can also use theWebSphere_Deployment_View view for assigning and tuning the OMi MP
for IBMWebSphere Application Server deployment in the IBMWebSphere Application Server
environment. In addition, you can use this view for monitoring composite applications. The following
image shows the relationship among the CI types.
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l J2EE_Deployment: This RTSM view refers to the J2EE cluster, J2EE domain, JDBC data source,
J2EE application, database, and computer CI types. The J2EE_Deployment view enables you to
visualize the Event and Health perspectives of the IBMWebSphere Application Server CIs that you
monitor. You can use the J2EE_Deployment view for visualizing events that are specific to the
monitored IBMWebSphere Application Servers. You can also use the J2EE_Deployment view for
assigning and tuning the OMi MP for IBMWebSphere Application Server deployment in the IBM
WebSphere Application Server environment. The following image shows the relationship among the
CI types.
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l J2EE_Network_Deployment_View: This RTSM view refers to the J2EE Cluster, J2EE Domain,
J2EE Server, JDBC Data Source, J2EE Application, Database, and File System CI types. The
J2EE_Network_Deployment_View enables you to visualize the components of an associated
network along with themonitored IBMWebSphere Application Server CIs in your environment. The
following image shows the relationship among the CI Types.
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l J2EE_Database_Deployment: This view refers to the J2EE cluster, J2EE domain, JDBC data
source, J2EE server, J2EE application, database, Oracle CIs, file system, and Computer CI types.
The following image shows the relationship among the CI Types. The J2EE_Database_
Deployment view enables you to visualize the Event and Health perspectives of the IBM
WebSphere Application Server CIs andOracle database that youmonitor.
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Topology based Event Correlation (TBEC)
Rules
TheOMi MP for IBMWebSphere Application Server includes the following rules to correlate IBM
WebSphere Application Server related events:

Note: Formore information about using correlation rules, see theOperations Manager i Concepts
Guide.

How to Access TBEC Rules

Open the Correlation rules:

On BSM 9.2x, click Admin > Operations Management > Event Correlation.

OnOMi 10.x, click Administration > Event Processing > Correlation > Topology -Based Event
Correlation.

J2EE::Computer:CPU Load >> JVM Memory Utilization & JMS Server Utilization &
Transaction System Errors & EJB Performance

Description: Computer CPU Load Impacts JVM Memory Utilization and JMS Server
Utilization and Transaction System Errors and EJB Performance

Cause

CIT: Computer ETI: CPU Load Value: Overloaded

Symptom 1

CIT: J2EE Application ETI: EJB Performance Value: Low

Symptom 2

CIT: J2EE Server ETI: EJB Performance Value: Low

Symptom 3

CIT: J2EE Server ETI: JMS Server Utilization Value: High

Symptom 3
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Description: Computer CPU Load Impacts JVM Memory Utilization and JMS Server
Utilization and Transaction System Errors and EJB Performance

CIT: J2EE Server ETI: Transaction System Errors Value: High

Symptom 4

CIT: JVM ETI: JVMMemory Utilization Value: High

J2EE::Computer:CPU Load >> Real User Transaction Performance & Real User Sessions
Performance

Description: Computer CPU Load Impacts Real User Transaction Performance and Real
User Sessions Performance

Cause

CIT: Computer ETI: CPU Load Value: Overloaded

Symptom 1

CIT: Business Application ETI: Real User Sessions
Performance

Value: Critical

Symptom 2

CIT: Business Transaction ETI: Real User Transaction
Performance event

Value: Critical

J2EE::Computer:CPU Load >> Synthetic User Transaction Performance

Description: Computer CPU Load Impacts Synthetic User Transaction Performance

Cause

CIT: Computer ETI: CPU Load Value: Overloaded

Symptom 1

CIT: Business
Transaction

ETI: Synthetic User Transaction
Performance event

Value: Critical

J2EE::Computer:Memory Usage Level >> Server Status & Transaction System Errors &
Thread Hung Rage

Description: Computer Memory Usage Level Impacts Server Status and Transaction System
Errors and Thread Hung Rate

Cause

CIT: Computer ETI: Memory Usage Level Value: Much Higher Than
Normal
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Description: Computer Memory Usage Level Impacts Server Status and Transaction System
Errors and Thread Hung Rate

Symptom 1

CIT: J2EE Server ETI: Server Status Value: Unavailable

Symptom 2

CIT: J2EE Server ETI: Thread Hung Rate Value: High

Symptom 3

CIT: J2EE Server ETI: Transaction System Errors Value: High

J2EE::Database:CPU Usage By SQL >> Transaction Timeout Errors & Transactions Rolled
Back & EJB Performance & DataSource ConnectionPool Performance

Description: Database CPU Usage By SQL Impacts Transaction Timeout Errors and
Transactions Rolled Back and EJB Performance and DataSource ConnectionPool
Performance

Cause

CIT: Database ETI: CPU Usage by SQL Value: High

Symptom 1

CIT: J2EE Application ETI: EJB Performance Value: Low

Symptom 2

CIT: J2EE Server ETI: DataSource Connection
Pool Performance

Value: Low

Symptom 3

CIT: J2EE Server ETI: EJB Performance Value: Low

Symptom 4

CIT: J2EE Server ETI: Transaction Timeout
Errors

Value: High

Symptom 5

CIT: J2EE Server ETI: Transactions Rolled Back Value: High

Symptom 6

CIT: JDBC Data ETI: Datasource Connection
Pool Performance

Value: Low
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J2EE::Database:Database Server Status >> DataSource ConnectionPool Availability

Description: Database Server Status Impacts DataSource ConnectionPool Availability

Cause

CIT: Database ETI: Database Server Status Value: Down

Symptom 1

CIT: J2EE Server ETI: Data Source Connection Pool
Availability

Value: Low

Symptom 2

CIT: JDBC Data Source ETI: Data Source Connection Pool
Availability

Value: Low

J2EE::Database:Database Server Status >> Real User Transaction Availability & Real User
Sessions Availability

Description: Database Server Status Impacts Real User Transaction Availability and Real
User Sessions Availability

Cause

CIT: Database ETI: Database Server Status Value: Down

Symptom 1

CIT: Business Application ETI: Real User Sessions
Availability

Value: Critical

Symptom 2

CIT: Business Transaction ETI: Real User Transaction
Availability event

Value: Critical

J2EE::Database:Database Server Status >> Synthetic User Transaction Availability

Description: Database Server Status Impacts Synthetic User Transaction Availability

Cause

CIT: Database ETI: Database Server Status Value: Down

Symptom 1

CIT: Business
Transaction

ETI: Synthetic User Transaction Availability
event

Value: Critical

J2EE::Database:SQL Query Performance >> Transaction Timeout Errors & Transactions
Rolled Back & EJB Performance & DataSource ConnectionPool Performance
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Description: Database SQL Query Performance Impacts Transaction Timeout Errors and
Transactions Rolled Back and EJB Performance and DataSource ConnectionPool
Performance

Cause

CIT: Database ETI: SQLQuery Performance Value: Low

Symptom 1

CIT: J2EE Application ETI: EJB Performance Value: Low

Symptom 2

CIT: J2EE Server ETI: Datasource Connection
Pool Performance

Value: Low

Symptom 3

CIT: J2EE Server ETI: EJB Performance Value: Low

Symptom 4

CIT: J2EE Server ETI: Transaction Timeout
Errors

Value: High

Symptom 5

CIT: J2EE Server ETI: Transactions Rolled Back Value: High

Symptom 4

CIT: JDBC Data Source ETI: Data Source Connection
Pool Performance

Value: Low

J2EE::File System:Disk Usage Level >> Server Status & Transaction Resource Errors &
Transaction System Errors

Description: File System Disk Usage Level Impacts Server Status and Transaction Resource
Errors and Transaction System Errors

Cause

CIT: FileSystem ETI: Disk Usage Level Value: Near Capacity

Symptom 1

CIT: J2EE Server ETI: Server Status Value: Unavailable

Symptom 2

CIT: J2EE Server ETI: Transaction Resource
Errors

Value: High
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Description: File System Disk Usage Level Impacts Server Status and Transaction Resource
Errors and Transaction System Errors

Symptom 3

CIT: J2EE Server ETI: Transactions System
Errors

Value: High

J2EE::J2EE Application:EJB Concurrent Lives >> EJB Utilization

Description: EJB Concurrent Lives Impacts EJB Utilization

Cause

CIT: J2EE Application ETI: EJB Concurrent Lives Value: High

Symptom 1

CIT: J2EE Application ETI: EJB Utilization Value: High

Symptom 2

CIT: J2EE Server ETI: EJB Utilization Value: High

J2EE::J2EE Application:EJB Free Pool Wait Rate >> Servlet Performance

Description: EJB Free Pool Wait Rate Impacts Servlet Performance

Cause

CIT: J2EE Application ETI: EJB Free Pool Wait Rate Value: High

Symptom 1

CIT: J2EE Application ETI: Servlet Performance Value: Low

Symptom 2

CIT: J2EE Server ETI: Servlet Performance Value: Low

J2EE::J2EE Application:EJB Performance >> EJB Free Pool Wait Rate & EJB Missed Count
Rate & Servlet Performance

Description: EJB Performance Impacts EJB Free Pool Wait Rate and EJB Missed Count
Rate and Servlet Performance

Cause

CIT: J2EE Application ETI: EJB Performance Value: Low

Symptom 1

CIT: J2EE Application ETI: EJB Free Pool Wait Rate Value: High
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Description: EJB Performance Impacts EJB Free Pool Wait Rate and EJB Missed Count
Rate and Servlet Performance

Symptom 2

CIT: J2EE Application ETI: EJB Missed Count Rate Value: High

Symptom 3

CIT: J2EE Application ETI: Servlet Performance Value: Low

Symptom 4

CIT: J2EE Server ETI: EJB Free Pool Wait Rate Value: High

Symptom 5

CIT: J2EE Server ETI: EJB Missed Count Rate Value: High

Symptom 6

CIT: J2EE Server ETI: Servlet Performance Value: Low

J2EE::J2EE Application:EJB Timeout Rate >> Servlet Performance & EJB Transaction
Throughput Rate & EJB Transaction Rollback Rate

Description: EJB Timeout Rate Impacts Servlet Performance and EJB Transaction
Throughput Rate and EJB Transaction Rollback Rate

Cause

CIT: J2EE Application ETI: EJB Timeout Rate Value: High

Symptom 1

CIT: J2EE Application ETI: EJB Transaction Rollback
Rate

Value: High

Symptom 2

CIT: J2EE Application ETI: EJB Transaction
Throughput Rate

Value: High

Symptom 3

CIT: J2EE Application ETI: Servlet Performance Value: Low

Symptom 4

CIT: J2EE Server ETI: EJB Transaction Rollback
Rate

Value: High

Symptom 5

CIT: J2EE Server ETI: Servlet Performance Value: Low
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J2EE::J2EE Application:EJB Utilization >> DataSource Connection Waiters & DataSource
Connection Pool Utilization

Description: EJB Utilization Impacts DataSource Connection Waiters and DataSource
Connection Pool Utilization

Cause

CIT: J2EE Application ETI: EJB Utilization Value: High

Symptom 1

CIT: J2EE Server Data Source Connection Pool
Utilization

Value: High

Symptom 2

CIT: J2EE Server ETI: Data Source Connection
Waiters

Value: High

Symptom 3

CIT: JDBC Data Source ETI: Data Source Connection
Waiters

Value: High

Symptom 4

CIT: JDBC Data Source ETI: Data Source Connection Pool
Utilization

Value: High

J2EE::J2EE Application:HTTP Sessions >> JVM Memory Utilization

Description: J2EE Application HTTP Sessions Impacts JVM Memory Utilization

Cause

CIT: J2EE Application ETI: HTTP Sessions Value: High

Symptom 1

CIT: J2EE Server ETI: JVMMemory Utilization Value: High

Symptom 2

CIT: JVM ETI: JVMMemory Utilization Value: High

J2EE::J2EE Application:Servlet Requests >> InterfaceUtilization

Description: J2EE Application Servlet Requests Impacts Interface Utilization

Cause

CIT: J2EE Application ETI: Servlet Requests Value: High
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Description: J2EE Application Servlet Requests Impacts Interface Utilization

Symptom

CIT: Interface ETI: InterfaceUtilization Value: Much Higher Than Normal

J2EE::J2EE Application:Servlet Requests >> Real User Transaction Performance & Real User
Sessions Performance

Description: J2EE Application Servlet Requests Impacts Real User Transaction
Performance and Real User Sessions Performance

Cause

CIT: J2EE Application ETI: Servlet Requests Value: High

Symptom 1

CIT: Business Application ETI: Real User Sessions
Performance

Value: Critical

Symptom 2

CIT: Business Transaction ETI: Real User Transaction
Performance event

Value: Critical

J2EE::J2EE Application:Servlet Requests >> Synthetic User Transaction Performance

Description: J2EE Application Servlet Requests Impacts Synthetic User Transaction
Performance

Cause

CIT: J2EE Application ETI: Servlet Requests Value: High

Symptom 1

CIT: Business Application ETI: Synthetic User Transaction
Performance event

Value: Critical

J2EE::J2EE Application:Servlet Requests >> Thread Pool Utilization & Active Sockets Count
& JVM Memory Utilization & HTTP Sessions & Thread Requests Pending & Servlets Loaded
& Interface Discard Rate & Interface Utilization

Description: J2EE Application Servlet Requests Impacts Thread Pool Utilization and Active
Sockets Count and JVM Memory Utilization and HTTP Sessions and Thread Requests
Pending and Servlets Loaded and Interface Discard Rate and Interface Utilization

Cause

CIT: J2EE Application ETI: Servlet Requests Value: High
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Description: J2EE Application Servlet Requests Impacts Thread Pool Utilization and Active
Sockets Count and JVM Memory Utilization and HTTP Sessions and Thread Requests
Pending and Servlets Loaded and Interface Discard Rate and Interface Utilization

Symptom 1

CIT: Interface ETI: Interface Discard Rate Value: High

Symptom 2

CIT: Interface ETI: Interface Utilization Value: High

Symptom 3

CIT: Interface ETI: Interface Utilization Value: Higher Than Normal

Symptom 4

CIT: J2EE Application ETI: HTTP Sessions Value: High

Symptom 5

CIT: J2EE Server ETI: Active Sockets Count Value: High

Symptom 6

CIT: J2EE Server ETI: HTTP Sessions Value: High

Symptom 7

CIT: J2EE Server ETI: JVMMemory Utilization Value: High

Symptom 8

CIT: J2EE Server ETI: Servlets Loaded Value: High

Symptom 9

CIT: J2EE Server ETI: Thread Pool Utilization Value: High

Symptom 10

CIT: J2EE Server ETI: Thread Requests Pending Value: High

Symptom 11

CIT: JVM ETI: JVMMemory Utilization Value: High

J2EE::J2EE Cluster:Cluster Health >> Domain Status

Description: J2EE Cluster Health Impacts Domain Status

Cause

CIT: J2EE Cluster ETI: Cluster Health Value: Poor
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Description: J2EE Cluster Health Impacts Domain Status

Symptom 1

CIT: J2EE Domain ETI: Domain Status Value: Poor

J2EE::J2EE Cluster:Cluster Health >> Real User Transaction Performance & Real User
Sessions Performance

Description: J2EE Cluster Health Impacts Real User Transaction Performance and Real
User Sessions Performance

Cause

CIT: J2EE Cluster ETI: Cluster Health Value: Poor

Symptom 1

CIT: Business Application ETI: Real User Sessions
Performance

Value: Critical

Symptom 2

CIT: Business Application ETI: Real User Transaction
Performance event

Value: Critical

J2EE::J2EE Cluster:Cluster Health >> Synthetic User Transaction Performance

Description: J2EE Cluster Health Impacts Synthetic User Transaction Performance

Cause

CIT: J2EE Cluster ETI: Cluster Health Value: Poor

Symptom 1

CIT: Business
Application

ETI: Synthetic User Transaction
Performance event

Value: Critical

J2EE::J2EE Cluster:Cluster Status >> Domain Status

Description: J2EE Cluster Status Impacts Domain Status

Cause

CIT: J2EE Cluster ETI: Cluster Status Value: Stopped

Symptom 1

CIT: J2EE Domain ETI: Domain Status Value: Poor

J2EE::J2EE Cluster:Cluster Status >> Real User Transaction Availability & Real User
Sessions Availability
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Description: J2EE Cluster Status Impacts Real User Transaction Availability and Real User
Sessions Availability

Cause

CIT: J2EE Cluster ETI: Cluster Status Value: Stopped

Symptom 1

CIT: Business Application ETI: Real User Sessions
Availability

Value: Critical

Symptom 2

CIT: Business Application ETI: Real User Transaction
Availability event

Value: Critical

J2EE::J2EE Cluster:Cluster Status >> Synthetic User Transaction Availability

Description: J2EE Cluster Status Impacts Synthetic User Transaction Availability

Cause

CIT: J2EE Cluster ETI: Cluster Status Value: Stopped

Symptom 1

CIT: Business
Transaction

ETI: Synthetic User Transaction Availability
event

Value: Critical

J2EE::J2EE Server:DataSource Connection Pool Availability >> EJBPerformance &
Transaction Timeout Rate & Transaction Commit Rate

Description: J2EE Server DataSource Connection Pool Availability Impacts
EJBPerformance and Transaction Timeout Rate and Transaction Commit Rate

Cause

CIT: J2EE Server ETI: Data Source Connection
Pool Availability

Value: Low

Symptom 1

CIT: J2EE Application ETI: EJB Performance Value: Low

Symptom 2

CIT: J2EE Server ETI: EJB Performance Value: Low

Symptom 3

CIT: J2EE Server ETI: Transaction Commit Rate Value: High
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Description: J2EE Server DataSource Connection Pool Availability Impacts
EJBPerformance and Transaction Timeout Rate and Transaction Commit Rate

Symptom 4

CIT: J2EE Server ETI: Transaction Timeout Rate Value: High

J2EE::J2EE Server:DataSource Connection Pool Performance >> EJB Performance

Description: J2EE Server DataSource Connection Pool Performance Impacts EJB
Performance

Cause

CIT: J2EE Server ETI: Data Source Connection Pool
Performance

Value: Low

Symptom 1

CIT: J2EE Application ETI: EJB Performance Value: Low

Symptom 2

CIT: J2EE Server ETI: EJB Performance Value: Low

J2EE::J2EE Server:DataSource Connection Waiters >> DataSource Connection Pool
Availability

Description: J2EE Server DataSource Connection Waiters Impacts DataSource Connection
Pool Availability

Cause

CIT: J2EE Server ETI: Data Source Connection
Waiters

Value: High

Symptom 1

CIT: J2EE Server ETI: Data Source Connection Pool
Availability

Value: Low

Symptom 2

CIT: JDBC Data Source ETI: Data Source Connection Pool
Availability

Value: Low

J2EE::J2EE Server:DataSource ConnectionPool Utilization >> Transaction Capacity
Utilization & JDBC Connection Pool Wait Count & Transaction Time & Transaction Commit
Rate & Transaction Start Rate & DataSource Connection Pool Availability
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Description: J2EE Server DataSource ConnectionPool Utilization Impacts Transaction
Capacity Utilization and JDBC Connection Pool Wait Count and Transaction Time and
Transaction Commit Rate and Transaction Start Rate and DataSource Connection Pool
Availability

Cause

CIT: J2EE Server ETI: Data Source Connection
Pool Utilization

Value: High

Symptom 1

CIT: J2EE Server ETI: Data Source Connection
Pool Availability

Value: Low

Symptom 2

CIT: J2EE Server ETI: JDBC Connection Pool
Wait Count

Value: High

Symptom 3

CIT: J2EE Server ETI: Transaction Capacity
Utilization

Value: High

Symptom 4

CIT: J2EE Server ETI: Transaction Commit Rate Value: High

Symptom 5

CIT: J2EE Server ETI: Transaction Start Date Value: High

Symptom 6

CIT: J2EE Server ETI: Transaction Time Value: High

Symptom 7

CIT: JDBC Data Source ETI: Data Source Connection
Pool Availability

Value: Low

Symptom 8

CIT: JDBC Data Source ETI: JDBC Connection Pool
Wait Count

Value: High

J2EE::J2EE Server:EJB Concurrent Lives >> EJB Utilization

Description: EJB Concurrent Lives Impacts EJB Utilization

Cause

CIT: J2EE Server ETI: EJB Concurrent Lives Value: High
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Description: EJB Concurrent Lives Impacts EJB Utilization

Symptom 1

CIT: J2EE Application ETI: EJB Utilization Value: High

Symptom 2

CIT: J2EE Server ETI: EJB Utilization Value: High

J2EE::J2EE Server:EJB Free Pool Wait Rate >> Servlet Performance

Description: EJB Free Pool Wait Rate Impacts Servlet Performance

Cause

CIT: J2EE Server ETI: EJB Free Pool Wait Rate Value: High

Symptom 1

CIT: J2EE Application ETI: Servlet Performance Value: Low

Symptom 2

CIT: J2EE Server ETI: Servlet Performance Value: Low

J2EE::J2EE Server:EJB Performance >> EJB Free Pool Wait Rate & EJB Missed Count Rate
& Servlet Performance

Description: EJB Performance Impacts EJB Free Pool Wait Rate and EJB Missed Count
Rate and Servlet Performance

Cause

CIT: J2EE Server ETI: EJB Performance Value: Low

Symptom 1

CIT: J2EE Application ETI: EJB Free Pool Wait Rate Value: High

Symptom 2

CIT: J2EE Application ETI: EJB Missed Count Rate Value: High

Symptom 3

CIT: J2EE Application ETI: Servlet Performance Value: Low

Symptom 4

CIT: J2EE Server ETI: EJB Free Pool Wait Rate Value: High

Symptom 5
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Description: EJB Performance Impacts EJB Free Pool Wait Rate and EJB Missed Count
Rate and Servlet Performance

CIT: J2EE Server ETI: EJB Missed Count Rate Value: High

Symptom 6

CIT: J2EE Server ETI: Servlet Performance Value: Low

J2EE::J2EE Server:EJB Timeout Rate >> Servlet Performance & EJB Transaction Throughput
Rate & EJB Transaction Rollback Rate

Description: EJB Timeout Rate Impacts Servlet Performance and EJB Transaction
Throughput Rate and EJB Transaction Rollback Rate

Cause

CIT: J2EE Server ETI: EJB Timeout Rate Value: High

Symptom 1

CIT: J2EE Application ETI: EJB Transaction Rollback
Rate

Value: High

Symptom 2

CIT: J2EE Application ETI: EJB Transaction
Throughput Rate

Value: High

Symptom 3

CIT: J2EE Application ETI: EJB Transaction Rollback
Rate

Value: High

Symptom 4

CIT: J2EE Server ETI: Servlet Performance Value: Low

J2EE::J2EE Server:EJB Utilization >> DataSource Connection Waiters & DataSource
Connection Pool Utilization

Description: EJB Utilization Impacts DataSource Connection Waiters and DataSource
Connection Pool Utilization

Cause

CIT: J2EE Server ETI: EJB Utilization Value: High

Symptom 1

CIT: J2EE Server ETI: DataSource Connection Pool
Utilization

Value: High
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Description: EJB Utilization Impacts DataSource Connection Waiters and DataSource
Connection Pool Utilization

Symptom 2

CIT: J2EE Server ETI: DataSource Connection
Waiters

Value: High

Symptom 3

CIT: JDBC Data Source ETI: DataSource Connection
Waiters

Value: High

Symptom 4

CIT: JDBC Data Source ETI: DataSource Connection Pool
Utilization

Value: High

J2EE::J2EE Server:HTTP Sessions >> JVM Memory Utilization

Description: J2EE Server HTTP Sessions Impacts JVM Memory Utilization

Cause

CIT: J2EE Server ETI: HTTP Sessions Value: High

Symptom 1

CIT: J2EE Server ETI: JVMMemory Utilization Value: High

Symptom 2

CIT: JVM ETI: JVMMemory Utilization Value: High

J2EE::J2EE Server:JVM Memory Utilization >> Real User Transaction Performance & Real
User Sessions Performance

Description: J2EE Server Memory Utilization Impacts Real User Transaction Performance
and Real User Sessions Performance

Cause

CIT: J2EE Server ETI: JVMMemory Utilization Value: High

Symptom 1

CIT: Business Application ETI: Real User Sessions
Performance

Value: Critical

Symptom 2

CIT: Business Application ETI: Real User Transaction
Performance event

Value: Critical
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Description: J2EE Server Memory Utilization Impacts Real User Transaction Performance
and Real User Sessions Performance

Symptom 3

CIT: J2EE Application ETI: EJB Transaction Rollback
Rate

Value: High

Symptom 4

CIT: J2EE Server ETI: Servlet Performance Value: Low

J2EE::J2EE Server:JVM Memory Utilization >> Synthetic User Transaction Performance

Description: J2EE Server Memory Utilization Impacts Synthetic User Transaction
Performance

Cause

CIT: J2EE Server ETI: JVMMemory Utilization Value: High

Symptom 1

CIT: Business Application ETI: Synthetic User Transaction
Performance event

Value: Critical

J2EE::J2EE Server:JVM Memory Utilization >> Transaction Time & Transaction System Errors
& Servlet Performance

Description: J2EE Server JVMMemoryUtilization Impacts Transaction Time and Transaction
System Errors and Servlet Performance

Cause

CIT: J2EE Server ETI: JVMMemory Utilization Value: High

Symptom 1

CIT: J2EE Application ETI: Servlet Performance Value: Low

Symptom 2

CIT: J2EE Server ETI: Servlet Performance Value: Low

Symptom 3

CIT: J2EE Server ETI: Transaction System Errors Value: High

Symptom 4

CIT: J2EE Server ETI: Transaction Time Value: High
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J2EE::J2EE Server:Server Sessions >> JVM Memory Utilization

Description: J2EE Server Sessions Impact JVM Memory Utilization

Cause

CIT: J2EE Server ETI: Server Sessions Value: High

Symptom 1

CIT: J2EE Server ETI: JVMMemory Utilization Value: High

Symptom 2

CIT: JVM ETI: JVMMemory Utilization Value: High

J2EE::J2EE Server:Server Status >> Domain Status & Cluster Health & Cluster Status

Description: J2EE Server Status Impacts Domain Status and Cluster Health and Cluster
Status

Cause

CIT: J2EE Server ETI: Server Status Value: Unavailable

Symptom 1

CIT: J2EE Cluster ETI: Cluster Health Value: Poor

Symptom 2

CIT: J2EE Cluster ETI: Cluster Status Value: Partial Stop

Symptom 3

CIT: J2EE Cluster ETI: Cluster Status Value: Stopped

J2EE::J2EE Server:Server Status >> Real User Transaction Availability & Real User Sessions
Availability

Description: J2EE Server Status Impacts Real User Transaction Availability and Real User
Sessions Availability

Cause

CIT: J2EE Server ETI: Server Status Value: Unavailable

Symptom 1

CIT: Business Application ETI: Real User Sessions
Availability

Value: Critical

Symptom 2

CIT: Business Application ETI: Real User Transaction
Availability event

Value: Critical
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J2EE::J2EE Server:Server Status >> Synthetic User Transaction Availability

Description: J2EE Server Status Impacts Synthetic User Transaction Availability

Cause

CIT: J2EE Server ETI: Server Status Value: Unavailable

Symptom 1

CIT: Business
Application

ETI: Synthetic User Transaction Availability
event

Value: Critical

J2EE::J2EE Server:Servlet Requests >> Real User Transaction Performance & Real User
Sessions Performance

Description: J2EE Server Servlet Requests Impacts Real User Transaction Performance and
Real User Sessions Performance

Cause

CIT: J2EE Server ETI: Servlet Requests Value: High

Symptom 1

CIT: Business Application ETI: Real User Sessions
Performance

Value: Critical

Symptom 2

CIT: Business Application ETI: Real User Transaction
Performance event

Value: Critical

J2EE::J2EE Server:Servlet Requests >> Synthetic User Transaction Performance

Description: J2EE Server Servlet Requests Impacts Synthetic User Transaction
Performance

Cause

CIT: J2EE Server ETI: Servlet Requests Value: High

Symptom 1

CIT: Business Application ETI: Synthetic User Transaction
Performance event

Value: Critical

J2EE::J2EE Server:Servlet Requests >> Thread Pool Utilization & Active Sockets Count &
JVM Memory Utilization & HTTP Sessions & Thread Requests Pending & Servlets Loaded &
Interface Discard Rate & Interface Utilization
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Description: J2EE Server Servlet Requests Impacts Thread Pool Utilization and Active
Sockets Count and JVM Memory Utilization and HTTP Sessions and Thread Requests
Pending and Servlets Loaded and Interface Discard Rate and Interface Utilization

Cause

CIT: J2EE Server ETI: Servlet Requests Value: High

Symptom 1

CIT: Interface ETI: Interface Discard Rate Value: High

Symptom 2

CIT: Interface ETI: Interface Utilization Value: Higher Than Normal

Symptom 3

CIT: J2EE Server ETI: Active Sockets Count Value: High

Symptom 4

CIT: J2EE Server ETI: JVMMemory Utilization Value: High

Symptom 5

CIT: J2EE Server ETI: Servlets Loaded Value: High

Symptom 6

CIT: J2EE Server ETI: Thread Pool Utilization Value: High

Symptom 7

CIT: J2EE Server ETI: Thread Requests Pending Value: High

Symptom 8

CIT: JVM ETI: JVMMemory Utilization Value: High

J2EE::J2EE Server:Servlets Loaded >> JVM Memory Utilization

Description: J2EE Server Status Impacts Real User Transaction Availability and Synthetic
User Transaction Availability and Real User Sessions Availability

Cause

CIT: J2EE Server ETI: Servlets Loaded Value: High

Symptom 1

CIT: J2EE Server ETI: JVMMemory Utilization Value: High

Symptom 1

CIT: JVM ETI: JVMMemory Utilization Value: High
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J2EE::J2EE Server:ThreadPoolUtilization >> ExecuteQueueWaitCount & ActiveSocketsCount
& ServletPerformance & DeferredThreadRequests & ThreadRequestWaitTime &
ThreadRequestsPending & ThreadRequestServiceTime & ThreadPoolAvailability &
JVMMemoryUtilization

Description: J2EE Server Thread Pool Utilization Impacts Execute Queue Wait Count and
Active Sockets Count and Servlet Performance and Deferred Thread Requests and Thread
Request Wait Time and Thread Requests Pending and Thread Request Service Time and
Thread Pool Availability and JVM Memory Utilization

Cause

CIT: J2EE Server ETI: Thread Pool Utilization Value: High

Symptom 1

CIT: J2EE Application ETI: Servlet Performance Value: Low

Symptom 2

CIT: J2EE Server ETI: Active Sockets Count Value: High

Symptom 3

CIT: J2EE Server ETI: Deferred Thread Requests Value: High

Symptom 4

CIT: J2EE Server ETI: Execute QueueWait
Count

Value: High

Symptom 5

CIT: J2EE Server ETI: JVMMemory Utilization Value: High

Symptom 6

CIT: J2EE Server ETI: Servlet Performance Value: Low

Symptom 7

CIT: J2EE Server ETI: Thread Pool Availability Value: Low

Symptom 8

CIT: J2EE Server ETI: Thread Request Service
Time

Value: High

Symptom 9

CIT: J2EE Server ETI: Thread Request Wait Time Value: High

Symptom 10
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Description: J2EE Server Thread Pool Utilization Impacts Execute Queue Wait Count and
Active Sockets Count and Servlet Performance and Deferred Thread Requests and Thread
Request Wait Time and Thread Requests Pending and Thread Request Service Time and
Thread Pool Availability and JVM Memory Utilization

CIT: J2EE Server ETI: Thread Requests Pending Value: High

Symptom 11

CIT: JVM ETI: JVMMemory Utilization Value: High

J2EE::J2EE Server:Total Garbage Collection Count >> CPU Load

Description: J2EE Server Total Garbage Collection Count Impacts CPU Load

Cause

CIT: J2EE Server ETI: Total Garbage Collection Count Value: High

Symptom 1

CIT: Computer ETI: CPU Load Value: Overloaded

J2EE::J2EE Server:Total Garbage Collection Time >> CPU Load

Description: J2EE Server Total Garbage Collection Time Impacts CPU Load

Cause

CIT: J2EE Server ETI: Total Garbage Collection Time Value: High

Symptom 1

CIT: Computer ETI: CPU Load Value: Overloaded

J2EE::J2EE Server:Total Number of Threads >> CPU Load & Memory Usage Level

Description: J2EE Server Total Number Of Threads Impacts CPU Load and Memory Usage
Level

Cause

CIT: J2EE Server ETI: Total Number Of Threads Value: High

Symptom 1

CIT: Computer ETI: CPU Load Value: Overloaded

Symptom 2

CIT: Computer ETI: Memory Usage Level Value: Higher Than Normal

Symptom 3

CIT: Computer ETI: Memory Usage Level Value: Much Higher Than
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Description: J2EE Server Total Number Of Threads Impacts CPU Load and Memory Usage
Level

Normal

J2EE::J2EE Server:Transaction Application Errors >> Transactions Rolled Back

Description: J2EE Server Transaction Application Errors Impacts Transactions Rolled Back

Cause

CIT: J2EE Server ETI: Transaction Application
Errors

Value: High

Symptom 1

CIT: J2EE Server ETI: Transactions Rolled Back Value: High

J2EE::J2EE Server:Transaction Resource Errors >> Transactions Rolled Back

Description: J2EE Server Transaction Resource Errors Impacts Transactions Rolled Back

Cause

CIT: J2EE Server ETI: Transaction Resource Errors Value: High

Symptom 1

CIT: J2EE Server ETI: Transactions Rolled Back Value: High

J2EE::J2EE Server:Transaction System Errors >> Transactions Rolled Back

Description: J2EE Server Transaction System Errors Impacts Transactions Rolled Back

Cause

CIT: J2EE Server ETI: Transaction System Errors Value: High

Symptom 1

CIT: J2EE Server ETI: Transactions Rolled Back Value: High

J2EE::J2EE Server:Transaction Time >> JDBC Connection Pool Wait Count

Description: J2EE Server Transaction Time Impacts JDBC Connection Pool Wait Count

Cause

CIT: J2EE Server ETI: Transaction Time Value: High

Symptom 1

CIT: J2EE Server ETI: JDBC Connection Pool Wait
Count

Value: High
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Description: J2EE Server Transaction Time Impacts JDBC Connection Pool Wait Count

Symptom 2

CIT: JDBC Data Source ETI: JDBC Connection Pool Wait
Count

Value: High

J2EE::J2EE Server:Transaction Timeout Errors >> Transactions Rolled Back

Description: J2EE Server Transaction Timeout Errors Impacts Transactions Rolled Back

Cause

CIT: J2EE Server ETI: Transaction Timeout Errors Value: High

Symptom 1

CIT: J2EE Server ETI: Transactions Rolled Back Value: High

J2EE::JDBC Data Source:DataSource Connection Pool Availability >> EJBPerformance &
Transaction Timeout Rate & Transaction Commit Rate

Description: JDBC DataSource Connection Pool Availability Impacts EJBPerformance and
Transaction Timeout Rate and Transaction Commit Rate

Cause

CIT: JDBC Data Source ETI: Data Source Connection
Pool Availability

Value: Low

Symptom 1

CIT: J2EE Application ETI: EJB Performance Value: Low

Symptom 2

CIT: J2EE Server ETI: EJB Performance Value: Low

Symptom 3

CIT: J2EE Server ETI: Transaction Commit Rate Value: High

Symptom 4

CIT: J2EE Server ETI: Transaction Timeout Rate Value: High

J2EE::JDBC Data Source:DataSource Connection Pool Performance >> EJB Performance

Description: JDBC DataSource Connection Pool Performance Impacts EJB Performance

Cause

CIT: JDBC Data Source ETI: Data Source Connection Pool
Performance

Value: Low
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Description: JDBC DataSource Connection Pool Performance Impacts EJB Performance

Symptom 1

CIT: J2EE Application ETI: EJB Performance Value: Low

Symptom 2

CIT: J2EE Server ETI: EJB Performance Value: Low

J2EE::JDBC Data Source:DataSource Connection Waiters >> DataSource Connection Pool
Availability

Description: JDBC DataSource Connection Waiters Impacts DataSource Connection Pool
Availability

Cause

CIT: JDBC Data Source ETI: Data Source Connection
Waiters

Value: High

Symptom 1

CIT: J2EE Server ETI: Data Source Connection Pool
Availability

Value: Low

Symptom 2

CIT: JDBC Data Source ETI: Data Source Connection Pool
Availability

Value: Low

J2EE::JDBC Data Source:DataSource ConnectionPool Utilization >> Transaction Capacity
Utilization & JDBC Connection Pool Wait Count & Transaction Time & Transaction Commit
Rate & Transaction Start Rate & DataSource Connection Pool Availability

Description: JDBC DataSource ConnectionPool Utilization Impacts Transaction Capacity
Utilization and JDBC Connection Pool Wait Count and Transaction Time and Transaction
Commit Rate and Transaction Start Rate and DataSource Connection Pool Availability

Cause

CIT: JDBC Data Source ETI: Data Source Connection
Pool Utilization

Value: High

Symptom 1

CIT: J2EE Server ETI: Data Source Connection
Pool Availability

Value: Low

Symptom 2

CIT: J2EE Server ETI: JDBC Connection Pool
Wait Count

Value: High
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Description: JDBC DataSource ConnectionPool Utilization Impacts Transaction Capacity
Utilization and JDBC Connection Pool Wait Count and Transaction Time and Transaction
Commit Rate and Transaction Start Rate and DataSource Connection Pool Availability

Symptom 3

CIT: J2EE Server ETI: Transaction Capacity
Utilization

Value: High

Symptom 4

CIT: J2EE Server ETI: Transaction Commit Rate Value: High

Symptom 5

CIT: J2EE Server ETI: Transaction Start Rate Value: High

Symptom 6

CIT: J2EE Server ETI: Transaction Time Value: High

Symptom 7

CIT: JDBC Data Source ETI: DataSource Connection
Pool Availability

Value: Low

Symptom 8

CIT: JDBC Data Source ETI: JDBC Connection Pool
Wait Count

Value: High

J2EE::JDBC Data Source:DataSource Leaked Connections Rate >> DataSource
ConnectionPool Utilization

Description: JDBC DataSource Leaked Connections Rate Impacts DataSource
ConnectionPool Utilization

Cause

CIT: JDBC Data Source ETI: DataSource Leaked
Connections Rate

Value: High

Symptom 1

CIT: J2EE Server ETI: DataSource ConnectionPool
Utilization

Value: High

Symptom 2

CIT: JDBC Data Source ETI: DataSource ConnectionPool
Utilization

Value: High
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J2EE::JVM:All Processors Average Load >> CPU Load

Description: JVM All Processors Average Load Impacts CPU Load

Cause

CIT: JVM ETI: All Processors Average Load Value: High

Symptom 1

CIT: Computer ETI: CPU Load Value: Overloaded

J2EE::JVM:JVM Memory Utilization >> Real User Transaction Performance & Real User
Sessions Performance

Description: JVM Memory Utilization Impacts Real User Transaction Performance and
Synthetic User Transaction Performance and Real User Sessions Performance

Cause

CIT: JVM ETI: JVMMemory Utilization Value: High

Symptom 1

CIT: Business Application ETI: Real User Sessions
Performance

Value: Critical

Symptom 2

CIT: Business Application ETI: Real User Transaction
Performance event

Value: Critical

J2EE::JVM:JVM Memory Utilization >> Synthetic User Transaction Performance

Description: JVM Memory Utilization Impacts Synthetic User Transaction Performance

Cause

CIT: JVM ETI: JVMMemory Utilization Value: High

Symptom 1

CIT: Business
Application

ETI: Synthetic User Transaction
Performance event

Value: Critical

J2EE::JVM:JVM Memory Utilization >> Transaction Time & Transaction System Errors &
Servlet Performance

Description: JVMMemoryUtilization Impacts Transaction Time and Transaction System
Errors and Servlet Performance

Cause

CIT: JVM ETI: JVMMemory Utilization Value: High
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Description: JVMMemoryUtilization Impacts Transaction Time and Transaction System
Errors and Servlet Performance

Symptom 1

CIT: J2EE Application ETI: Servlet Performance Value: Low

Symptom 2

CIT: J2EE Server ETI: Servlet Performance Value: Low

Symptom 3

CIT: J2EE Server ETI: Transaction System Errors Value: High

Symptom 4

CIT: J2EE Server ETI: Transaction Time Value: High

J2EE::JVM:Total Garbage Collection Count >> CPU Load

Description: JVM Total Garbage Collection Count Impacts CPU Load

Cause

CIT: JVM ETI: Total Garbage Collection Count Value: High

Symptom 1

CIT: Computer ETI: CPU Load Value: Overloaded

J2EE::JVM:Total Garbage Collection Time >> CPU Load

Description: JVM Total Garbage Collection Time Impacts CPU Load

Cause

CIT: JVM ETI: Total Garbage Collection Time Value: High

Symptom 1

CIT: Computer ETI: CPU Load Value: Overloaded

J2EE::JVM:Total Number Of Threads >> CPU Load & Memory Usage Level

Description: JVM Total Number Of Threads Impacts CPU Load and Memory Usage Level

Cause

CIT: JVM ETI: Total Number Of Threads Value: High

Symptom 1

CIT: Computer ETI: CPU Load Value: Constrained
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Description: JVM Total Number Of Threads Impacts CPU Load and Memory Usage Level

Symptom 2

CIT: Computer ETI: Memory Usage Level Value: Higher Than Normal

J2EE::Network Interface:Interface Communication Status >> Server Status

Description: Network Interface Communication Status Impacts Server Status

Cause

CIT: Interface ETI: Interface Communication Status Value: Unavailable

Symptom

CIT: J2EE Server ETI: Server Status Value: Unavailable

J2EE::Network Interface:Interface Utilization >> Real User Transaction Performance & Real
User Sessions Performance

Description: Network Interface Utilization Impacts Real User Transaction Performance and
Real User Sessions Performance

Cause

CIT: Interface ETI: Interface Utilization Value: Higher Than Normal

Symptom 1

CIT: Business Application ETI: Real User Sessions
Performance

Value: Critical

Symptom 2

CIT: Business Transaction ETI: Real User Transaction
Performance event

Value: Critical

J2EE::Network Interface:Interface Utilization >> Servlet Performance

Description: Network Interface Utilization Impacts Servlet Performance

Cause

CIT: Interface ETI: Interface Utilization Value: Higher Than Normal

Symptom 1

CIT: J2EE Application ETI: Servlet Performance Value: Low

Symptom 2

CIT: J2EE Server ETI: Servlet Performance Value: Low
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J2EE::Network Interface:Interface Utilization >> Synthetic User Transaction Performance

Description: Network Interface Utilization Impacts Synthetic User Transaction Performance

Cause

CIT: Interface ETI: Interface Utilization Value: Higher Than Normal

Symptom 1

CIT: Business Application ETI: Synthetic User Transaction
Performance

Value: Critical

Event Type Indicators (ETIs)
ETIs categorizes events based on the type of occurrence. TheOMi MP for IBMWebSphere
Application Server includes the following ETIs tomonitorWebSphere Application Server related
events:

How to Access ETIs

1. Open the Indicators pane:

On BSM, click Admin > Operations Management > Monitoring > Indicators.

OnOMi, click Administration > Service Health > CI Status Calculation > Event and Health
Type Indicators.

2. Click Configuration Item > Infrastructure Element > Application System > J2EE Domain.

The following table lists the ETIs and policies that set the ETIs.

ETI/HI Policy Name Policy Description

Server
Status

WebSphere_ServerStatus The server status in terms of availability.

Thread Pool
Utilization

WebSphere_CcrtThreadPlHngCt The number of threads used in the server to
execute tasks.

WebSphere_ThreadPoolHungRt

WebSphere_ThreadPoolAveSize

Server
Sessions

WebSphere_ServSessAct Sess The number of sessions opened to the server.
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ETI/HI Policy Name Policy Description

Servlets
Loaded

WebSphere_WebAppServLoad The number of servlets currently loaded for a
web application.

Thread Pool
Utilization

WebSphere_ThreadPoolUtilPct The number of threads used in the server to
execute the tasks.

Thread Hung
Rate

WebSphere_ThreadPoolHungRt The rate at which the threads are declared
hung.

Transactions
Rolled Back
Rate

WebSphere_TranRollbackRt Percentage of transactions rolled back due to
system, resource or other errors.

Transaction
Timeout
Rate

WebSphere_TranTimeoutRte The number of transactions that timed out per
second.

Transaction
Commit
Rate

WebSphere_TranCommitRt The number of transactions that were
committed per second.

Transaction
Start Rate

WebSphere_TranStartRt The number of transactions that were begun
per second.

JVM
Memory
Utilization

WebSphere_JVMMemUtilPct The percentage of heap size used.

Total
Garbage
Collection
Count

WebSphere_GarbageCollectionCt The number of times garbage collector has
run.

Total
Garbage
Collection
Time

WebSphere_
GarbageCollectionTime

Total time taken for garbage collection.

Total
Number of
Threads

WebSphere_ThreadStartedCt Total number of threads spawned for garbage
collection.

All
Processors
Average
Load

WebSphere_ProcessCpuUsage Average load on all the processors on the
system.

Cluster
Status

WebSphere_ClusterStatus Cluster Status in terms of availability.
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ETI/HI Policy Name Policy Description

EJB
Concurrent
Lives

WebSphere_EJBConcLivesApp The average number of bean objects in the
pool.

EJB
Performance

WebSphere_EJBMethRespTime The performance statistics namely cache
utilization.

EJB
Utilization

WebSphere_EJBPoolUtilApp The utilization of the EJB pool.

Servlet
Performance

WebSphere_
WebAppServletRespTime

The performance statistics such as execution
time.

Servlet
Requests

WebSphere_
WebAppServReqRtApp

Number of incoming requests to the servlet.

Data Source
Connection
Waiters

WebSphereJDBCConnPoolWaiters The average number of threads waiting for a
connection from the connection pool.

Data Source
Connection
Pool
Utilization

WebSphere_JDBCConnPoolUtil DataSource connection pool utilization.

Data Source
Connection
Pool
Availability

WebSphere_
JDBCConnPoolWaitTime

Availability of JDBC connections in the
connection pool.

Data Source
Connection
Pool
Performance

WebSphere_
JDBCPreparedStDiscRt

DataSource connection pool performance.

Health Indicators (HIs)
HIs analyze the events that occur in the IBMWebSphere Application Servers and report the health of
theWebSphere Application Server CIs.
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How to Access HIs

1. Open the Indicators pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Indicators.

OnOMi 10.x, click Administration > Service Health > CI Status Calculation > Event and
Health Type Indicators.

2. Click Configuration Item > Infrastructure Element > Application System > J2EE Domain.

TheOMi MP for IBMWebSphere Application Server includes the following Health Indicators (HIs) to
monitor the IBMWebSphere Application Server related events:

CI Type HI Description Value

J2EE
Server

Active Sockets
Count

Number of HTTP socket connections opened to
the server.

High,
Normal

J2EE
Server

Application Server
Load

Load on the application server. High,
Normal

J2EE
Server

Deferred Thread
Requests

The number of requests that were denied a
thread for execution because of themax-
threads-constraint.

High,
Normal

J2EE
Server

HTTP Request
Average Service
Time

Average time required to service an HTTP
request.

High,
Normal

J2EE
Server

HTTP Request Total
Service Time

Total time required to service HTTP requests. High,
Normal

J2EE
Server

HTTP Server Active
Connections

Number of connections currently open. High,
Normal

J2EE
Server

HTTP Server Active
Request

Child servers currently in the request
processing phase.

High,
Normal

J2EE
Server

HTTP Server
Connection Time

Total time spent servicing HTTP connections. High,
Normal

J2EE
Server

JMS Active
Connection Count

Number of active JMS connections. High,
Normal

J2EE
Server

JMS Server
Utilization

JMS Server queue utilization. High,
Normal
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CI Type HI Description Value

J2EE
Server

OracleWebCache
Average Latency
Current Interval

Average latency for 10 second intervals to
process requests for OracleWebCache.

High,
Normal

J2EE
Server

OracleWebCache
Latency Since Start

Average number of seconds to process
requests for OracleWebCache since the
applicationWeb server started.

High,
Normal

J2EE
Server

Server Sessions Number of sessions opened to this server. High,
Normal

J2EE
Server

Server Status Shows the server status in terms of availability. Unavailable,
Available

J2EE
Server

Servlets Loaded Number of servlets currently loaded for a web
application (cumulative value per server).

High,
Normal

J2EE
Server

Thread Hung Rate Rate at which the threads are declared hung. High,
Normal

J2EE
Server

Thread Pool
Availability

The availability of the threads in the Thread
Pool.

Low,
Normal

J2EE
Server

Thread Pool
Utilization

The number of threads used in the server to
execute tasks.

High,
Normal

J2EE
Server

Thread Request
Service Time

The time a request has to wait for a thread. High,
Normal

J2EE
Server

Thread Request Wait
Time

The time (in milliseconds) a request had to wait
for a thread.

High,
Normal

J2EE
Server

Threads Request
Pending

Requests that are pending because they are
waiting for an available thread.

High,
Normal

J2EE
Server

Transaction
Application Errors

Transaction errors due to application errors. High,
Normal

J2EE
Server

Transaction Capacity
Utilization

The number of simultaneous in-progress
transactions.

High,
Normal

J2EE
Server

Transaction Commit
Rate

The number of transactions that were
committed per second.

High,
Normal

J2EE
Server

Transaction
Resource Errors

Transaction errors caused due to system
resource errors.

High,
Normal

J2EE
Server

Transaction Rollback
Rate

The number of transactions rolled back due to
system, resource, or others.

High,
Normal

J2EE
Server

Transaction Start
Rate

The number of transactions that were begun per
second.

High,
Normal
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CI Type HI Description Value

J2EE
Server

Transaction System
Errors

Transaction errors caused due to system errors. High,
Normal

J2EE
Server

Transaction Time Time taken to complete a transaction. High,
Normal

J2EE
Server

Transaction Timeout
Errors

Transaction errors caused due to transaction
timeout.

High,
Normal

J2EE
Server

Transaction Timeout
Rate

The number of transactions that timed out per
second.

High,
Normal

J2EE
Server

Transactions Rolled
Back

Number/Percentage of transactions rolled back
due to system, resource, or other errors.

High,
Normal

J2EE
Server

EJB Concurrent
Lives

The average number of bean objects in the pool. High,
Normal

J2EE
Server

EJB Utilization The utilization of the EJB pool. High,
Normal

J2EE
Server

Execute QueueWait
Count

The number of client requests waiting to be
serviced by the execute queue.

High,
Normal

J2EE
Server

HTTP Sessions Number of open HTTP sessions. High,
Normal

J2EE
Server

EJB Missed Count
Rate

Total number of times a failed attempt was
made to get an instance from the free pool.

High,
Normal

J2EE
Server

EJB Free Pool Wait
Rate

The number of times per minute no EJBs were
available from the free pool.

High,
Normal

J2EE
Server

EJB Performance The performance statistics such as cache
utilization.

Low,
Normal

J2EE
Server

EJB Timeout Rate The number of times per minute a client timed
out waiting for an EJB.

High,
Normal

J2EE
Server

EJB Transaction
Rollback Rate

Number of EJB Transaction Rolled back in unit
time.

High,
Normal

J2EE
Server

Servlet Performance Performance statistics such as execution time. Low,
Normal

J2EE
Server

Servlet Requests Number of incoming requests to the servlet. High,
Normal

J2EE
Server

Connections in Use Number of currently used JDBC connections. High,
Normal

J2EE JDBC Connection Number of clients waiting for a JDBC High,
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CI Type HI Description Value

Server Pool Wait Count connection. Normal

J2EE
Server

Data Source
Connection Pool
Availability

Availability of JDBC connections in the
connection pool.

Low,
Normal

J2EE
Server

Data Source
Connection Pool
Failures

Number of failed attempts to refresh a
connection in the connection pool.

Critical,
Normal

J2EE
Server

Data Source
Connection Pool
Utilization

Data source connection pool utilization High,
Normal

J2EE
Server

Data Source
Connection Pool
Performance

Data source connection pool performance Low,
Normal

J2EE
Server

Data Source
ConnectionWaiters

The average number of threads waiting for a
connection from the connection pool.

High,
Normal

J2EE
Server

JDBC Active
Connection Count

Active JDBC connections High,
Normal

J2EE
Server

Total Number of
Threads

Total number of threads for garbage collection. High,
Normal

J2EE
Server

Total Garbage
Collection Count

Number of times garbage collector has run. High,
Normal

J2EE
Server

Total Garbage
Collection Time

Total time taken for garbage collection. High,
Normal

J2EE
Server

JVMMemory
Utilization

The percentage of heap size used. High,
Normal

J2EE
Server

Heap Free Current Amount of free heap available. Low,
Normal

J2EE
Server

Heap Size Current Amount of heap in use. High,
Normal

J2EE
Server

All Processors
Average Load

Average load on all the processors on the
system.

High,
Normal

J2EE
Cluster

Cluster Health Cluster health in terms of performance. Poor,
Normal

J2EE
Cluster

Cluster Incoming
Message Failure
Rate

The number of multicast messages that were
lost from the cluster.

High,
Normal
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CI Type HI Description Value

J2EE
Cluster

Cluster Outgoing
Message Failure
Rate

The number of multicast messages that were
sent to the cluster.

High,
Normal

J2EE
Cluster

Cluster Status Cluster Status in terms of availability. Started,
Partial
Stopped,
Stopped

JDBC
Data
Source

Connections in Use Number of currently used JDBC connections. High,
Normal

JDBC
Data
Source

Data Source
ConnectionWaiters

The average number of threads waiting for a
connection from the connection pool.

High,
Normal

JDBC
Data
Source

Data Source
Connection Pool
Availability

Availability of JDBC connections in the
connection pool.

Low,
Normal

JDBC
Data
Source

Data Source
Connection Pool
Failures

The number of failed attempts to refresh a
connection in the connection pool.

Normal,
Critical

JDBC
Data
Source

Data Source
Connection Pool
Performance

Data source connection pool performance. Low,
Normal

JDBC
Data
Source

Data Source
Connection Pool
Utilization

Data source connection pool utilization. High,
Normal

JDBC
Data
Source

Data Source Leaked
Connections Rate

The rate of new leaked JDBC connections. High,
Normal

JDBC
Data
Source

JDBC Active
Connections Count

Active JDBC connections High,
Normal

JDBC
Data
Source

JDBC Connection
Pool Wait Count

The number of clients waiting for a JDBC
connection.

High,
Normal

J2EE
Application

EJB Concurrent
Lives

The average number of bean objects in the pool. High,
Normal

J2EE
Application

EJB Free Pool Wait
Rate

The number of times per minute no EJBs were
available from the free pool.

High,
Normal
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CI Type HI Description Value

J2EE
Application

EJB Missed Count
Rate

The total number of times a failed attempt was
made to get an instance from the free pool.

High,
Normal

J2EE
Application

EJB Performance The performance statistics such as cache
utilization.

Low,
Normal

J2EE
Application

EJB Timeout Rate The number of times per minute a client timed
out waiting for an EJB.

High,
Normal

J2EE
Application

EJB Transaction
Rollback Rate

Number of EJB transaction rolled back in unit
time.

High,
Normal

J2EE
Application

EJB Transaction
Throughput Rate

Number of EJBs Transactions completed in unit
time.

High,
Normal

J2EE
Application

EJB Utilization The utilization of the EJB pool. High,
Normal

J2EE
Application

HTTP Sessions Number of open HTTP sessions. High,
Normal

J2EE
Application

Servlet Performance The performance statistics such as execution
time.

Low,
Normal

J2EE
Application

Servlet Requests Number of incoming requests to the servlet. High,
Normal

JVM All Processors
Average Load

Average load on all the processors on the
system.

High,
Normal

JVM Heap Free Current Amount of free heap available. Low,
Normal

JVM Heap Size Current Amount of heap in use. High,
Normal

JVM JVMMemory
Utilization

The percentage of heap size used. High,
Normal

JVM Total Garbage
Collection Count

Number of times garbage collector has run. High,
Normal

JVM Total Garbage
Collection Time

Total time taken for garbage collection. High,
Normal

JVM Total Number of
Threads

Total number of threads for garbage collection. High,
Normal

J2EE
Domain

Domain Status The status of domain. Normal,
Poor
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HI Assignments
OMi MP for IBMWebSphere Application Server includes the following HI Assignments.

HI Mapping HI Assignment

J2EE Application J2EE ApplicationMapping for HIs assignment

J2EE ApplicationMapping for HIs assignment with empty monitor

J2EE Cluster J2EE Cluster for HIs assignment

J2EE Cluster for HIs assignment with empty monitor

J2EE Domain J2EE DomainMapping for HIs assignment

J2EE DomainMapping for HIs assignment with empty monitor

J2EE Server J2EE Server Mapping for HIs assignment

J2EE Server Mapping for HIs assignment with empty monitor

JDBC Data Source JDBC Data SourceMapping for HIs assignment

JDBC Data SourceMapping for HIs assignment with empty monitor

JVM JVMMapping for HIs assignment

JVMMapping for HIs assignment with empty monitor

Key Performance Indicators (KPIs) Assignments
OMi MP for IBMWebSphere Application Server includes the following KPI assignments.

CI Type KPI Assignment

J2EE Application J2EE ApplicationMapping for Service Health

J2EE ApplicationMapping for SLM

J2EE Cluster J2EE Cluster Mapping for Service Health

J2EE Cluster Mapping for SLM
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CI Type KPI Assignment

J2EE Domain J2EE DomainMapping for Service Health

J2EE DomainMapping for SLM

J2EE Server J2EE Server Mapping for Service Health

J2EE Server Mapping for SLM

JDBC Data Source JDBC Data SourceMapping for Service Health

JDBC Data SourceMapping for SLM

JVM JVMMapping for Service Health

JVMMapping for SLM

Operations Orchestration (OO) Flows
When creating themapping for the OO flows, you can set default values for the attributes listed in the
following table. You need not specify these values each time you run the flows.

Note: TheOO flows shipped by OMi MP for IBMWebSphere Application Server can only be used
in deployment scenarios where the application is monitored by Smart Plug-ins managed by an
Operations Manager (OM) server. In such a case, the OO flows included in OMi MP for IBM
WebSphere Application Server can be installed on anOO server and launched through theOMi-
OO integration. For information about installing OO flows, see theOMi MP for IBMWebSphere
Application Server Installation Guide. For more information about the OMi-OO integration, see the
OMi- Operations Orchestrations Integration Guide.

Attribute Description

omServerPort Port number of the OM Tool Web Service (WS). This is an optional attribute.

omServerUser User name for the OM Server that will use used in the OM Tool WS.

omServerPassword Password for the OM Server that will use used in the OM Tool WS.

OMi MP for IBMWebSphere Application Server is packaged with the following OO flows:

Application Server Health Check

You can use this flow to check the health of an IBMWebSphere Application Server.

You canmap this flow to the CIT J2EEServer.
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The following table lists the user input items when executing this OO flow.

Flow input Description

omNode Full Qualified Domain Name (FQDN) of the node. This must be amanaged node
for the OM Server andmust be specified each time you run the OO flow.

jeeserver Determines the type and the valid values are wls/wbs. Youmust specify this value
each time you run the OO flow.

omServer FQDN of the OM Server. You canmap this input to the Event attributeOriginating
Server.

jeeserverName Name of the J2EE Server.You canmap this input to the CI attribute J2eeserver_
fullname of CI Type J2EEServer.

timeout Used when running the remote command on the node. This is an optional attribute
and the default value is 100000.

Application Server Performance Check

You can use this flow to check the performance of an IBMWebSphere Application Server.

Youmust map this flow to the CIT J2EEServer.

The following table lists the user input items when executing this OO flow.

Flow input Description

omNode FQDN of the node. This must be amanaged node for the OM Server andmust be
specified each time you run the OO flow.

jeeserver Determines the type and the valid values are wls/wbs. Youmust specify this
value each time you run the OO flow.

omServer FQDN of the OM Server. You canmap this input to the Event attribute
Originating Server.

jeeserverName Name of the J2EE Server.You canmap this input to the CI attribute J2eeserver_
fullname of CI Type J2EEServer.

timeout Used when running the remote command on the node. This is an optional attribute
and the default value is 100000.

JDBC Health Check

You can use this flow to check the health of the JDBC Connection.

Youmust map this flow to the CIT J2EEServer.
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The following table lists the user input items when executing this OO flow.

Flow input Description

omNode FQDN of the node. This must be amanaged node for the OM Server andmust be
specified each time you run the OO flow.

jeeserver Determines the type and the valid values are wls/wbs. Youmust specify this value
each time you run the OO flow.

omServer FQDN of the OM Server. You canmap this input to the Event attributeOriginating
Server.

jeeserverName Name of the J2EE Server. You canmap this input to the CI attribute J2eeserver_
fullname of CI Type J2EEServer.

timeout Used when running the remote command on the node. This is an optional attribute
and the default value is 100000.

Tools
TheOMi MP for IBMWebSphere Application Server is packaged with tools which enables
administering, monitoring, and troubleshooting theWebSphere Application Server CIs. OMi MP for IBM
WebSphere Application Server comprises the following tools:

How to Access Tools

OnBSM 9.2x, click Admin > Operations Management > Operations Console.

OnOMi 10.x, click Administration > Operations Console > Tools.

CI Type Tool Description

Computer Restart WebSphere
Monitoring

Restarts WebSpheremonitoring on themanaged
server.

Start WebSphereMonitoring Starts WebSpheremonitoring on themanaged server.

StopWebSphereMonitoring Stops WebSpheremonitoring on themanaged server.

Data Capture Tool Captures and archives MP logs and configuration data.
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Graph Templates
OMi MP for IBMWebSphere Application Server is packaged with pre-defined graph templates to
analyze the performance perspective of the IBMWebSphere Application Servers. The graph templates
aremapped to theWebSphere CI type. The following section provides information about the graph
family, graph templates and themetrics associated with the graph templates. It also provides
information about accessing the graph templates and viewing the graphs.

How to Access Graph Templates

1. Open the graph templates:

On BSM 9.2x, click Admin > Operations Management > Operation Console.

OnOMi 10.x, click Administration > Operations Console > Performance Graph Mappings.

2. In the CI Types pane, select Infrastructure Element > Running Software > Application
Server > J2EE Server > Websphere AS.

Graph Family
Graph
Templates Metric Name

Metric
Description

ThreadPool ThreadPool WEBSPHERE_PERCENTMAXED Provides
information about
the percentage of
time the number of
threads in pool take
to reach the
configured
maximum size.

WEBSPHERE_CREATECOUNT Provides
information about
the number of
threads created per
minute (used only
for graphing).

WEBSPHERE_
DECLAREDTHREADHUNGCOUNT

Provides
information about
the number of
threads hung per
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Graph Family
Graph
Templates Metric Name

Metric
Description

minute.

WEBSPHERE_
CONCURRENTHUNGTHREADCOUNT

Provides
information about
the number of
concurrent hung
threads.

EJB EJB Pool WEBSPHERE_LIVECOUNT Provides
information about
the average
percentage of bean
objects in the pool.

WEBSPHERE_
RETRIEVEFROMPOOLSUCCESSCOUNT

Provides
information about
the average
percentage of time
a call to retrieve an
EJB from the pool
successfully.

WEBSPHERE_
RETRIEVEFROMPOOLCOUNT

Provides
information about
the average
percentage of time
a call to retrieve an
EJB from the pool
failed.

EJB Activity WEBSPHERE_METHODCALLCOUNT Provides
information about
the number of EJB
method calls per
minute.

WEBSPHERE_STORECOUNT Provides
information about
the number of
times an EJB was
written to or loaded
from the database
per minute.

WEBSPHERE_
MESSAGEBACKOUTCOUNT

Provides
information about
themessage
backout rate.
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Graph Family
Graph
Templates Metric Name

Metric
Description

WEBSPHERE_
RETURNSDISCARDCOUNT

Provides
information about
the returns discard
rate.

EJB Pool
Size

WEBSPHERE_LIVECOUNT Provides
information about
the average
percentage of bean
objects in the pool.

Servlet Servlet
Session
Activity

WEBSPHERE_LIFETIME Provides
information about
the average
lifetime for a
servlet session.

WEBSPHERE_LIVECOUNT Provides
information about
the active servlet
sessions.

Servlet
Session
Invalidations

WEBSPHERE_INVALIDATECOUNT Provides
information about
the servlet
invalidated session
rate.

WEBSPHERE_REQUESTCOUNT Provides
information about
the number of
request for a
servlet per second.

WEBSPHERE_ERRORCOUNT Provides
information about
the number of
errors in a servlet
per second.

WebApplication Web
Application

WEBSPHERE_
LOADEDSERVLETCOUNT

Provides
information about
the web application
servlet load.

WEBSPHERE_RELOADCOUNT Provides
information about
the number of
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Graph Family
Graph
Templates Metric Name

Metric
Description

servlets reloaded
for a web
application per
minute.

JDBC JDBC Pool
Waits

WEBSPHERE_WAITINGTHREADCOUNT Provides
information about
the average
percentage of
threads waiting for
a connection from
connection pools.

WEBSPHERE_WAITTIME Provides
information about
the average time
that a client waited
for a connection in
milliseconds.

JDBC Pool
Performance

WEBSPHERE_FAULTCOUNT Provides
information about
the number of
times a client timed
out waiting for a
connection from
the pool per
minute.

WEBSPHERE_RETURNCOUNT Provides
information about
the number of
connections
allocated and
returned by
applications per
second.

JDBC SQL
Statistics

WEBSPHERE_
PREPSTMTCACHEDISCARDCOUNT

Provides
information about
the prepared
statement discard
rate.

Transaction Transaction
Duration
Times

WEBSPHERE_GLOBALTRANTIME Provides
information about
the transaction
global duration.

User Guide
Graph Templates

HPE OMi Management Pack for IBM WebSphere Application Server (1.01) Page 110 of 138



Graph Family
Graph
Templates Metric Name

Metric
Description

WEBSPHERE_LOCALTRANTIME Provides
information about
the transaction
local duration.

WEBSPHERE_GLOBALCOMMITTIME Provides
information about
the transaction
global commit
duration.

WEBSPHERE_LOCALCOMMITTIME Provides
information about
the transaction
local commit
duration.

Transaction
Activity

WEBSPHERE_ROLLEDBACKCOUNT Provides
information about
the transaction
rollback rate.

WEBSPHERE_GLOBALTIMEOUTCOUNT Provides
information about
the number of
global transactions
completed.

WEBSPHERE_LOCALTIMEOUTCOUNT Provides
information about
the number of local
transactions
completed.

WEBSPHERE_GLOBALCOMMITTIME Provides
information about
the transaction
commit rate.

WEBSPHERE_
LOCALROLLEDBACKCOUNT

Provides
information about
the transaction
rollback rate.

WEBSPHERE_GLOBALBEGUNCOUNT Provides
information about
the number of
global transactions
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Graph Family
Graph
Templates Metric Name

Metric
Description

that were
completed per
second.

WEBSPHERE_LOCALBEGUNCOUNT Provides
information about
the transaction
start rate.

JVM Statistics JVM
Utilization

WEBSPHERE_USEDMEMORY Provides
information about
theJVMmemory
utilization percent.

WEBSPHERE_FREEMEMORY Provides
information about
the JVMmemory
free percent.

WEBSPHERE_PROCESSCPUUSAGE Provides
information about
the JVMmemory
CPU usage
percentage.

WEBSPHERE_HEAPSIZE Provides
information about
the Garbage
collection value.

How to View Graphs

Performance Perspective enables you to populate graphs from existing graph templates. You can also
plot customized graphs by selecting the requiredmetrics for a selected CI.

To view the Performance Perspective of IBMWebSphere Application Server CIs using graphs, follow
these steps:

1. Open the Performance Perspective pane:

On BSM 9.2x, click Applications > Operations Management > Performance Perspective.

OnOMi 10.x, clickWorkspaces > Operations Console > Performance Perspective.
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The View Explorer pane appears.

2. In theBrowse Views tab, selectWebSphere_Deployment_View. The performance pane
appears, which lists the default graphs available for theWebSphere_Deployment_View.

3. Click the graph you want to plot from theGraphs tab, and then click Draw Graphs. The selected
graph is plotted on the right pane.

Note: Formore information about Managing Events, see theOperations Manager i Concepts
Guide.
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Chapter 4: Customization Scenarios
OMi MP for IBMWebSphere Application Server can be customized to suit your monitoring
requirements. You can edit the existingWebSphereManagement Templates or create new WebSphere
Management Templates tomonitor the IBMWebSphere Application Servers in your environment.

This section provides information about the following:

l CreatingWebSphereManagement Templates

l EditingWebSphereManagement Templates

Creating WebSphere Management Templates
You can edit the existingWebSphereManagement Templates or create new WebSphereManagement
Templates tomonitor the IBMWebSphere Application Servers in your environment.

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:

Configuration Folders > Application Server Management > IBM WebSphere Management

3. Select theWebSphere configuration folder and if you need to create a new configuration folder,

click . The Create Configuration Folder opens.

4. Type the name of the new configuration folder and the description. For example, you can type the
new configuration folder name as <Test>.

5. Click OK. The new configuration folder is created.

Configuration Folders > Application Server Management > WebSphere Management >
Test

6. In theManagement Templates & Aspects pane, select the new configuration folder and click

and then click Create Management Template. The CreateManagement Template wizard
opens.
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7. In theGeneral tab, type aName for the new WebSphereManagement Template. Click Next.

8. In the Topology View tab, select theWebSphere_Deployment_View from the list as the
Topology View. TheWebSphere_ Deployment _View shows theWebSphere CIs and all the
related CITs. A WebSphereManagement Template enables you tomanageWebSphere CIs and
all the related dependent CIs.

9. Click an item in the topology map to select theCI Type of the CIs that this Management Template
enables you tomanage. This is the type of CI to which theManagement Template can be
assigned. For example, you can select J2EE Application tomonitorWebSphere Application
Server.

10. Click Next.

11. In theAspects tab, add the Aspects to theManagement Template. Youmust add theWebSphere
BaseAspect to the new Management Template. TheWebSphere BaseAspect contains the
config file, openmessage interface, and scheduled task policy templates, which are essential for
data collection.

To add an existing Aspect, follow these steps:

a. Select the Aspect you want to add from the Available Aspects matching the CI Types pane.
You can use CTRL or SHIFT key to select multiple Aspects.

b. Click to move the Aspect to the Selected Aspects pane. The Aspect is added to the

Management Template.

c. Click Next.

12. For each aspect that you add, youmust specify at least one Target CI.

Click an Aspect in the list, and then in the topology map click the CIT you want the Aspect to
monitor when this Management Template is assigned. (Press CTRL to select several CITs.) Each
CIT that you select heremust correspond to one of the CI types assigned within the Aspect itself
(or a child of one of those CITs). For example, you can select WebSphere CI from the topology
map.

13. In theParameters tab, you see a list of all the parameters from the Aspects that you added to this
Management Template.

To combine parameters:

a. Press CTRL and click the parameters that you want to combine.

b. Click the . The Edit/Combine Parameters dialog box opens.

c. Type aName for the combined parameters.
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d. (Optional). Specify aDescription, Default Value, and whether the combined parameter is
Read Only, anExpert Setting, orHidden.

You can specify either a specific default value, or you can click From CI Attribute and then
browse for a CI attribute. When you specify a CI attribute, Operations Management sets the
parameter value automatically during the deployment of the underlying policy templates, using
the actual value of this attribute from the CI. You can also change values of conditional
parameters.

The conditions are read-only and cannot be changed at Management Template level.

Read Only prevents changes to the parameter value when theManagement Template is
assigned to a configuration item. Hidden also prevents changes, but additionally makes the
parameter invisible when theManagement Template is assigned, and during parameter
tuning. Users can choose whether to show expert settings when they make an assignment.

e. Click OK.

You can also edit the parameters without combining them, to override the defaults in the

Aspects or policy templates. Click one parameter, and then click . The Edit/Combine

Parameters dialog box opens.

14. In the CreateManagement Template wizard, click Finish to save theManagement Template and
close the wizard. The new Management Template appears in theManagement Templates &
Aspects pane.

Editing WebSphere Management Templates
The following section provides information about customizingManagement Templates and Aspects.

Use Case 1:You are using ExtensiveWebSphereManagement Template tomonitor your J2EE
environment. You do not want to use some Aspects which are included in the ExtensiveWebSphere
Management Template.

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:
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Configuration Folders > Application Server Management > IBM WebSphere Management
> Management Templates > Extensive WebSphere Management Template

3. Select theExtensive WebSphere Management Template from the list, and then click . The

Edit Management Template dialog box opens.

4. Click theAspects tab. The list of Available Aspects matching the CI types and the list of Selected
Aspects appear.

5. Select the Aspect that you do not want to use and click . A message appears stating that the

Combined parameters based on parameters from the deleted objects will be
changed, or removed if empty . Do you want to continue?

6. Click Yes.

7. Click OK. The version of the ExtensiveWebSphereManagement Template is incremented.

Use Case 2:You are usingWebsphere JVM HeapMemory Aspects to monitor the J2EE environment.
You do not want to use some Policy Templates that are included in theWebSphere JVM HeapMemory
Aspect.

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, clickAdmin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, clickAdministration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:

Configuration Folders > Application Server Management > IBM WebSphere Management
> Aspects > WebSphere JVM Heap Memory

3. Select theWebSphere JVM Heap Memory from the list, and then click . The Edit

Management Template dialog box opens.

4. Click thePolicy Templates tab. The list of Policy Templates appear.

5. Select the Policy Template that you do not want to use and click . For example, you can select

WebSphere_GCIntervalTime.

6. Click OK. The version of theWebSphere JVM HeapMemory Aspect is incremented.
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Chapter 5: Deployment Scenarios
This section provides information about deploying OMi MP for IBMWebSphere Application Server on
predominant configurations of IBMWebSphere Application Servers. OMi MP for IBMWebSphere
Application Server can be used tomonitor the following configurations:

l Network Deployment

l Cluster

l Secure configurations with LDAP and SSL authentication

WebSphere Application Servers in Network
Deployment
TomonitorWebSphere Application Servers in a Network Deployment configuration, follow these
steps:

1. Youmust add the nodes you want to monitor to the BSM or OMi console. For more information
about adding nodes, see Task 1: Adding Nodes to BSM Console.

2. To discoverWebSphere CIs on eachmanaged nodes in the network deployment configuration,
you can deploy theWebSphere Discovery Aspect. For more information about deploying the
discovery Aspects from the BSM console, see Task 4: Deploying theWebSphere Discovery
Aspect on BSM and Task 4: Deploying theWebSphere Discovery Aspect on OMi.

3. Tomonitor themanaged nodes in the network deployment configuration, you can deploy the
"ExtensiveWebSphereManagement Template" on each domain CI in the network deployment
configuration. For more information about deploying theManagement Templates, see Task 5:
Deploying theWebSphereManagement Templates orWebSphere Aspects.

WebSphere Application Servers in Cluster
Environment
To deploy OMi MP for IBMWebSphere Application Server in aWebSphere cluster environment, follow
these steps:

HPE OMi Management Pack for IBM WebSphere Application Server (1.01) Page 118 of 138



1. Youmust add the nodes you want to monitor to the BSM or OMi console. For more information
about adding nodes to the BSM console, see Task 1: Adding Nodes to BSM Console.

2. To discoverWebSphere CIs on eachmanaged nodes in the cluster, you can deploy the
WebSphere Discovery Aspect. For more information about deploying the discovery Aspects, see
Task 4: Deploying theWebSphere Discovery Aspect.

3. Tomonitor themanaged nodes in the cluster, you can deploy the "ExtensiveWebSphere
Management Template" on each domain CI in the cluster. For more information about deploying
theManagement Templates, see Task 6: Deploying theWebSphereManagement Templates or
WebSphere Aspects.

WebSphere Application Servers Using LDAP
and SSL Authentication Providers
WebSphere Application Servers can be configured using authentication providers like Secure Sockets
Layer (SSL) and Lightweight Directory Access Protocol (LDAP) to provide a secure and stable server
environment. To deploy OMi MP for IBMWebSphere Application Server onWebSphere Application
Servers using SSL and LDAP authentication, follow these steps:

1. Youmust add the nodes you want to monitor to the BSM or OMi console. For more information
about adding nodes to the BSM console, see Task 1: Adding Nodes to BSM Console.

2. To discover theWebSphere Application Server CIs, you can deploy theWebSphere Discovery
Aspect to discoverWebSphere Application Server CIs on themanaged nodes:

a. Open theManagement Templates & Aspects pane:

On BSM, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi, click Administration > Monitoring > Management Templates & Aspects.

b. In the Configuration Folders pane:

Configuration Folders > Application Server Management > IBM WebSphere
Management > Aspects

c. In theWebSphere Aspects folder, click theWebSphere DiscoveryAspect, and then click
to open the Assign and Deploy Wizard.

d. In theConfiguration Item tab, click the configuration item to which you want to deploy the
Discovery Aspect and then click Next.
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TheRequired Parameters tab opens.

e. In theRequired Parameters tab, youmust specify themandatory parameterWebSphere
Profile Home and dependent parameters.

Note: For every WebSphere Server Home parameter, youmust configure the dependent
parameters WebSphere JAVA Home, WebSphere Username, andWebSphere
Password.

i. Select theWebSphere Server Home parameter in the list, and then click . The Edit

Instance Parameter: WebSphere Server Home dialog box opens.

ii. Specify values for the dependent parameters:

A. Select theWebSphere Username parameter in the list, and then click . The

Edit Parameter: WebSphere Username dialog box opens.

B. Click Value, specify your LDAP username depending on the type of
authentication, and then click OK.

C. Select theWebSphere Password parameter in the list, and then click . The

Edit Parameter: WebSphere Password dialog box opens.

D. Click Value, specify your LDAP password depending on the type of authentication,
and then click OK.

iii. ForWebSphere Application Servers using SSL authentication:

A. Select theWebSphere KeyStore Path parameter in the list, and then click .

The Edit Parameter: WebSphere KeyStore Path dialog box opens.

B. Click Value, specify the path toWebSphere KeyStore, and then click OK.

C. Select theWebSphere Passphrase Password parameter in the list, and then

click . The Edit Parameter: WebSphere Passphrase Password dialog box

opens.

D. Click Value, specify theWebSphere Passphrase password, and then click OK.

E. Click OK.

f. Click Next to go toAll Parameters andParameter Summary. To change the default values

of the parameters, you can select the parameter and then click . The Edit Parameter dialog

box opens. Click Value, specify the value, and then click OK.
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Note: In theParameter Summary tab, you can override the default values of any
parameter. You can specify a value for each parameter at the Aspect level. By default,
parameters defined as expert parameters are not shown. To show expert parameters,

click Show Expert Parameters.

g. Click Next.

h. (Optional). If you do not want to enable the assignment immediately, clear theEnable
Assigned Objects or Enable Assignment(s) check box. You can then enable the
assignment later using the Assignments & Tuning pane.

i. Click Finish.

3. Tomonitor themanaged nodes in the cluster, youmust deploy the "ExtensiveWebSphere
Management Template" on each domain CI. For more information about deploying the
Management Templates, see Task 6: Deploying theWebSphereManagement Templates or
WebSphere Aspects.
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Chapter 6: Composite Applications
This section provides information about monitoring an environment comprising composite applications -
IBMWebSphere Application Servers, Oracle databases, and the underlying infrastructure.

Consider an enterprise environment topology for an instance of composite application that consists of
systems that are hostingWebSphere Application Server andOracle database.

Monitoring Composite Applications
Tomonitor an instance of a composite application, follow these tasks:

Task 1: Adding Nodes to OMi Console

Before youmonitor an instance of composite application, youmust ensure that the Operations Agent is
installed on all the nodes and add the nodes to the OMi console.

Note: If the Node already exists in RTSM, you can skip this step and proceed to Task 2.

Before you beginmonitoring, you need to add the nodes to the OMi console.
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1. Open theMonitored Nodes pane from Administration:

On BSM 9.2x, click Admin > Operations Management > Setup > Monitored Nodes.

OnOMi 10.x, click Administration > Setup and Maintenance > Monitored Nodes.

2. In the Node Views pane, click Predefined Node Filter > Monitored Nodes and then click
and then select Computer > Windows or Unix. The Create New Monitored Nodes dialog box
appears.

3. Specify the Primary DNS Name, IP Address, Operating System, and Processor Architecture of
the node and click OK.

Task 2: Deploying WebSphere Discovery Aspect

TheWebSphere Discovery Aspect enables you to discover IBMWebSphere Application Server
instances in the environment. To discover the IBMWebSphere Application Server CIs on the added
managed nodes, youmust deploy theWebSphere Discovery Aspect to a Computer CI.

TheWebSphere Discovery Aspect deployment discovers the Configuration Item (CIs) of the following
CI types (CITs):

l j2eedomain

l websphereas
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1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:

Configuration Folders > Application Server Management > IBM WebSphere Management
> Aspects

3. In the Aspects folder, clickWebSphere DiscoveryAspect, and then click to open the Assign

and Deploy Wizard.

4. In theConfiguration Item tab, select the configuration item to which you want to deploy the
Discovery Aspect and then click Next.

TheRequired Parameters tab opens and amessage appears stating that there are no
parameters that require editing for this Assignment.

5. In theRequired Parameters tab, click Next to go to theAll Parameters tab on BSM 9.2x or
Parameter Summary tab onOMi 10.x.

6. (Optional). In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x, to
change the default value of the Frequency of WebSphere_MPlog parameter, you can select the

parameter and then click . The Edit Parameter dialog box opens. Click Value, specify the
value, and then click OK.

7. In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x, click Next to
go to theConfigure Option tab.

8. (Optional). In theConfigure Option tab, if you do not want to enable the assignment immediately,
clear theEnable Assigned Objects check box on BSM 9.2x orEnable Assignment(s) check
box onOMi 10.x. You can then enable the assignment later using the Assignments & Tuning pane.

9. Click Finish.

Task 3: Verifying Discovery

After you deploy theWebSphere Discovery Aspect, you can verify if the CIs are populated in the View
Explorer.

To view the CIs populated in the View Explorer, follow these steps:
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1. Open the Event Perspective pane:

On BSM 9.2x, click Applications > Operations Management > Event Perspective.

OnOMi 10.x, clickWorkspaces > Operations Console > Event Perspective .

In the View Explorer, selectWebSphere_Deployment_View from the drop-down list. You can
see the CIs associated with theWebSphere_Deployment_View as shown in the following
figure.

Task 4: Deploying Extensive WebSphere and Oracle

Database Management Template

Before deploying theWebSphereManagement Templates, youmust deploy theWebSphere Discovery
Aspect. For more information, see Task 3: DeployingWebSphere Discovery Aspect.

TheWebSphereManagement Template discovers the CIs of the following CITs and completes the
topology as shown in the following figure:

l JVM

l Application Servers

l JDBC and underlying databases

l Oracle
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To deploy the ExtensiveWebSphere andOracle DatabaseManagement Template, follow these steps:

1. Open theManagement Templates & Aspects pane:

On BSM, click Admin > Operations Management > Monitoring > Management Templates &
Aspects.

OnOMi, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:

Configuration Folders > Application Server Management > IBM WebSphere Management
> Management Templates > Extensive WebSphere and Oracle Database Management
Template
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3. In theWebSphereManagement Templates folder, click the ExtensiveWebSphere andOracle

DatabaseManagement Template, and then click . The Assign and Deploy wizard opens.

4. In theConfiguration Item tab, click theWebSphere Domain CI to which you want to assign the
Management Template, and then click Next. You can select multiple items by holding down the
CTRL orSHIFT key while selecting them. Click Next to accept the CIs and go toRequired
Parameters.

5. In theRequired Parameters tab, you can specify the values of all the parameters that are listed
(Server profile home, Username, and Password). To specify the values of the parameters, you

can select the parameter and then click . The Edit Parameter dialog box opens. Click Value,
specify the value, and then click OK.

Note:Youmust specify all the values of the parameters to be able to continue the
configuration process.

6. Click Next to go toAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x.

7. In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x, you can
override the default values of any parameter. You can specify a value for each parameter at the
Management Template level. By default, parameters defined as expert parameters are not shown.

To show expert parameters, click Show Expert Parameters.

8. (Optional). If you do not want to enable the assignment immediately, clear theEnable Assigned
Objects on BSM 9.2x orEnable Assignment(s) check box onOMi 10.x. You can then enable the
assignment later using the Assignments & Tuning pane.

9. Click Finish.

Note: The credentials given during the deployment of aManagement Template should have
required privileges for OMi MP for IBMWebSphere Application Server to collect data.

Task 5: Verifying Discovery for Extended Topology

After you deploy theWebSphereManagement Templates orWebSphere Base Aspect, you can verify if
the CIs are populated in the View Explorer.

To view the CIs in the View Explorer, follow these steps:

1. Open the View Explorer pane:

On BSM 9.2x, click Applications > Operations Management > Event Perspective.
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OnOMi 10.x, clickWorkspaces > Operations Console > Event Perspective.

2. In the View Explorer, selectWebSphere_Deployment_View from the drop-down list. You can
see the extended topology comprising CIs associated with theWebSphere_Deployment_View
as shown in the following figure.
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Chapter 7: Troubleshooting
The following section provides information about troubleshooting scenarios. Some of the
troubleshooting procedures must be run on themanaged node.

Licensing count is not updated

Problem: Licensing count is not updated on LicenseManagement

Solution: To resolve this problem, follow these steps on theOMi Linux orWindows servers:

1. After installing OMi MP for IBMWebSphere Application Server, ensure that the license is
activated by following these steps:

a. Open the LicenseManagement pane:

On BSM 9.2x, click Admin > Platform > Setup and Maintenance > License
Management.

OnOMi 10.x, click Administration > Setup and Maintenance > License Management.

b. Click and select the license.dat file. The license details appears in the License

Management window.

The LicenseManagement provides details about the name, license type, days left, expiration
date, capacity, and capacity details.

2. To check for the license usage on themanaged node, run the following command on themanaged
node:

<OvAgentDir>/bin/ovodetect -t

If the output of the preceding command is mpinstance="1", then IBMWebSphere Application
Servers are beingmonitored. If the output of the preceding command is mpinstance="0", then IBM
WebSphere Application Servers are not beingmonitored.

3. If the license is still not updated in LicenseManagement, restart agent on themanaged node by
running the following command:

<OvAgentDir>/bin/ovc- restart opcmsga

Management Templates and Aspects are not deployed to themanaged nodes

Problem:Management Templates and Aspects are not deployed to themanaged nodes

Solution: To resolve this problem, follow these steps on theOMi Linux orWindows servers:
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1. To check the deployment status, open the Deployment Jobs pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Deployment Jobs.

OnOMi 10.x, click Administration > Monitoring > Deployment Jobs.

2. To check the assignment status, open the Assignment & Tuning pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Assignments &
Tuning.

OnOMi 10.x, click Administration > Monitoring > Assignments & Tuning.

3. Check the OMi log files at the following locations:

Linux:

/opt/HP/BSM/log/EJBContainer/opr-webapp.log

/opt/HP/BSM/log/EJBContainer/opr-configserver.log

Windows:

%topaz_home%\log\EJBContainer\opr-webapp.log

%topaz_home%\log\EJBContainer\opr-configserver.log

OMi MP for IBMWebSphere Application Server displays errors during installation

Problem: Installation of OMi MP for IBMWebSphere Application Server returns errors.

Solution:You can identify specific errors by checking the mpinstall.log log file.

The mpinstall.log log file is available at the following locations:

Windows:

%TOPAZ_HOME%\log\mpinstall.log

UNIX:

$TOPAZ_HOME/log/mpinstall.log

Error during upload of OMi MP for IBMWebSphere Application Server

Problem:OMi MP for IBMWebSphere Application Server returns error during upload.

Solution:You can identify specific errors by checking the opr-configserver.log log file.

The opr-configserver.log log file is available at the following locations:

Windows:
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%TOPAZ_HOME%\log\EJBContainer\opr-configserver.log

UNIX:

$TOPAZ_HOME/log/EJBContainer/opr-configserver.log

Views not getting populated after deployment of theWebSphere Discovery Aspect

Problem:Views for OMi MP for IBMWebSphere Application Server are not getting populated after
deployment of theWebSphere Discovery Aspect.

Solution:You can identify specific errors by following these steps:

1. Open theWebSphere Instrumentation folder:

Windows:

%OVADATADIR%\bin\instrumentation

UNIX:

/var/opt/OV/bin/instrumentation

2. In the Instrumentation folder, look for the following file:

bin/instrumentation/WebSphere_Discovery_Log4j.properties

3. OpenWebSphere_Discovery_Log4j.properties file.

4. Select log4j.appender.FILE.Threshold andmodify to
log4j.appender.FILE.Threshold=trace.

Tracing is enabled forWebSphere Discovery. WebSphereDiscovery.log log file is created.

5. Check the WebSphereDiscovery.log log file for specific errors.

The WebSphereDiscovery.log log file is available at the following locations.

Windows:

%OVDATADIR%\log\WebSphere\

UNIX:

/var/opt/OV/log/WebSphere/

Error during deployment of theWebSphere Discovery Aspect

Problem:During deployment of WebSphere Discovery Aspect, an error message appears stating that
the connection could not be established.

Solution: To resolve this problem, follow these steps:
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1. Check if the credentials entered during deployment have required access permissions to
WebSphere Application Server.

2. ConfigureWebSphere Keystore and Passphrase if theWebSphere Application Server uses SSL
Authentication Providers.

CollectionManager not getting invoked

Problem:Collectionmanager for OMi MP for IBMWebSphere Application Server is not getting
invoked for data collection.

Solution: To resolve this problem, follow these steps:

1. Open the IBMWebSphere Application Server Instrumentation folder:

Windows:

%ovdatadir%\bin\instrumentation

UNIX:

/var/opt/OV/bin/instrumentation

2. In the Instrumentation folder, look for the following file:

bin/instrumentation/WebSphere_cmlog4j.properties

3. Open WebSphere_cmlog4j.properties file.

4. Select log4j.appender.FILE.Threshold andmodify to
log4j.appender.FILE.Threshold=trace.

Tracing is enabled forWebSphere CollectionManager.

5. Check the Collector.log and CollectionManager.log log file for specific errors.

The Collector.log log file is available at the following locations.

Windows:

%OVDATADIR%\log\WebSphere

UNIX:

/var/opt/OV/log/WebSphere

The CollectionManager.log log file is available at the following locations.

Windows:

%OVDATADIR%\log\WebSphere\collectionManager
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UNIX:

/var/opt/OV/log/WebSphere/collectionManager

No data for PerformanceManager i (PMi) Graphs

Problem: The information to create PMi graph is not available from theOMi MP for IBMWebSphere
Application Server.

Solution: To resolve this problem, follow these steps:

1. Run the following command to check if the graph data sources are created:

ovcodautil –obj WebSphere_DATA

2. Run the following command to check data dumps of WebSphere_DATA data source:

ovcodautil –dumpds WebSphere_DATA

If there are empty instances, perform step 3 and 4.

3. From the WebSphere_cmlog4j.properties file, select log4j.appender.FILE.Threshold and
modify to log4j.appender.FILE.Threshold=trace.

Tracing is enabled forWebSphere CollectionManager.

4. Check the Collector.log and CollectionManager.log log file for specific errors.

The Collector.log log file is available at the following locations.

Windows:

%OVDATADIR%\log\WebSphere

UNIX:

/var/opt/OV/log/WebSphere

The CollectionManager.log log file is available at the following locations.

Windows:

%OVDATADIR%\log\WebSphere\collectionManager

UNIX:

/var/opt/OV/log/WebSphere/collectionManager

Unable to access lib folder

Problem: Non-root users are unable to access lib folder.
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Solution: For non-root users, provide the read access to IBMWebSphere Application Server lib folder
in the installation path.

Data logging for metric may show values as -1

Problem:Data logging for few metric may shows values of -1 for one of the following reasons:

l If theWebSphereMP installation prerequisites are not met for themanaged node. The Performance
Monitoring Infrastructure (PMI) instrumentation category should be set to all and the ConfigProxy
MBean needs to be enabled.

l If theWebSphere runtimeMbean returns null values for raw metrics.

l If the calculatedmetric has operands as raw metrics which have null values.

l Delta and rate of changemetrics will result in -1 values for the very first scheduled collection. This
is expected behaviour.

Solution: To know more details about the cause of -1 errors, Check the Installation Prerequisites. For
more information, see the section Setting the PMI Counters in theOMi MP for IBMWebSphere
Application Server Installation Guide. If the prerequisites are already met, follow these steps:

1. To view the data logged for metrics, run the following command:

ovcodautil -dumpds WEBSPHERE_DATA

2. Identify themetric name and check for themetric which contains value logged as -1 in the CODA
dump.

3. Determine themetric ID using the WebSphere_MetricDefinition.xml available at the following
location:

%ovdatadir%/bin/instrumentation

4. Verify collector logs on themanaged node and check for the collection ID that is showing
exceptions with null value returnmessage in the collector.log file available at the following
location:

%ovdatadir%/log/WebSphere.

Themessage provides exact details about whichMBean query failed and which returned a null
value for themetric.
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Appendix: Metrics and Data Sources
The following table lists the table names and relatedmetrics for OMi MP for IBMWebSphere
Application Server:

Note:WEBSPHERE_DATA is the data source used by OMi MP for IBMWebSphere Application
Server for logging collected data.

Aspect
Name

Table
Name or
Class
Name Policy Name

Collection
Name Metric Name

Data
Type

WebSpher
e_
ServerStat
us

WebSpher
e_Server

WebSphere_
ServerStatus

WebSpher
e_C0001

Server Status UTF8

WebSphere_
ProcessCpuUsage

WebSpher
e_C0801

CPUUsagePerct

WebSpher
e Thread
Status

WebSpher
e_Thread

WebSphere_
ThreadStartedCt

WebSpher
e_C0803

ThreadsCount_D UTF8

WebSphere_
ThreadPoolHungRt

WebSpher
e_C0812

ThreadPoolHungRt

WebSphere_
GarbageCollectionCt

WebSpher
e_C0804

GCCalls_D

WebSphere_
ThreadPoolUtilPct

WebSpher
e_C0212

ThreadPoolUtilPct

WebSphere_
ThreadPoolPctMaxApp

WebSpher
e_C0213

ThreadPoolPctMaxAp
p

WebSpher
e JVM
Heap
Memory

WebSpher
e_JVM_
Perf

WebSphere_
GarbageCollectionTime

WebSpher
e_C0805

GCAvgCallDur_D REAL
64

WebSphere_
JVMMemUtilPct

WebSpher
e_C0005

UsdHeapSz_P

WebSpher
e Cluster
Status

WebSpher
e_Cluster

WebSphere_
ClusterStatus

WebSpher
e_C0006

ClusterStatus REAL
64

WebSpher
e EJB
Performan

WebSpher
e_EJB

WebSphere_
EJBPoolUtil

WebSpher
e_C0020

EJBPoolUtil REAL
64
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Aspect
Name

Table
Name or
Class
Name Policy Name

Collection
Name Metric Name

Data
Type

ce
WebSphere_
EJBPoolUtilApp

WebSpher
e_C0220

EJBPoolUtil

WebSphere_
EJBConcLivesApp

WebSpher
e_C0226

EJBMsgBackoutRate

WebSphere_
EJBMethRespTime

WebSpher
e_C0221

EJBMethRespTime

WebSphere_
EJBMethCallsRtApp

WebSpher
e_C0222

EJBMethCallsRtApp

WebSphere_
EJBEntDatLdStRtApp

WebSpher
e_C0224

EJBEntDatLdStRtAp
p

WebSphere_
EJBMsgBackoutRate

WebSpher
e_C0810

EJBMsgBackoutRate

WebSphere_
EJBReturnDiscrdRt

WebSpher
e_C0811

EJBReturnDiscrdRt

WebSpher
e Servlet
Performan
ce

WebSpher
e_Servlet

WebSphere_
ServSessAveLife

WebSpher
e_C0040

ServSessAveLife REAL
64

WebSphere_
ServSessActSess

WebSpher
e_C0041

ServSessAct

WebSphere_
ServInvSessRt

WebSpher
e_C0042

ServInvSessRt

WebSphere_
WebAppServReqRtApp

WebSpher
e_C0245

WebAppServReqRtA
pp

WebSphere_
WebAppServletRespTi
me

WebSpher
e_C0246

WebAppSrvltRespTi
me

WebSphere_
WebAppServErrRtApp

WebSpher
e_C0247

WebAppSrvltErrorRt

WebSphere_
WebAppServLoad

WebSpher
e_C0048

WebAppServLoad

WebSpher
e JDBC
Connectio
n Pool

WebSpher
e_JDBC

WebSphere_
JDBCConnPoolSize

WebSpher
e_C0260

JDBCConnPoolSize REAL
64
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Aspect
Name

Table
Name or
Class
Name Policy Name

Collection
Name Metric Name

Data
Type

Status
WebSphere_
JDBCConnPoolWaiters

WebSpher
e_C0261

JDBCConnPoolWaite
rs

WebSphere_
JDBCConnPoolWaitTim
e

WebSpher
e_C0262

JDBCConPoolWaitTi
me

WebSphere_
JDBCConnPoolUtil

WebSpher
e_C0263

JDBCConnPoolUtil

WebSphere_
JDBCConnPoolMaxPct

WebSpher
e_C0264

JDBCConnPoolMaxP
ct

WebSphere_
JDBCConnPoolTimeOu
tRts

WebSpher
e_C0265

JDBCConPoolTmeO
utRt

WebSphere_
JDBCConPoolThroughp
ut

WebSpher
e_C0266

JDBCConPoolThrupu
t

WebSphere_
JDBCPreparedStDiscRt

WebSpher
e_C0814

JDBCPrepredStDisc
Rt

WebSpher
e
Transactio
n Status

WebSpher
e_Transact

WebSphere_
TranGlobDur

WebSpher
e_C0070

TranGlobDur REAL
64

WebSphere_TranLocDur WebSpher
e_C0071

TranLocDur

WebSphere_
TranGlobCommDur

WebSpher
e_C0072

TranGlobCommDur

WebSphere_
TranLocCommDur

WebSpher
e_C0073

TranLocCommitDur

WebSphere_
TranRollbackRt

WebSpher
e_C0074

TranRollbackRt

WebSphere_
TranTimeoutRte

WebSpher
e_C0075

TranTimeoutRt

WebSphere_
TranCommitRt

WebSpher
e_C0076

TranCommitRt

WebSphere_TranStartRt WebSpher
e_C0078

TranStartRt

User Guide

HPE OMi Management Pack for IBM WebSphere Application Server (1.01) Page 137 of 138



Send documentation feedback
If you have comments about this document, you can contact the documentation team by email. If an
email client is configured on this system, click the link above and an email window opens with the
following information in the subject line:

Feedback on User Guide (OMi Management Pack for IBM WebSphere Application Server 1.01)

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a webmail client, and
send your feedback to docfeedback@hpe.com.

We appreciate your feedback!
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