Summary
Searching in the KM Knowledgebase returns different results in Windows/web client and SRC
Error
In SM9.40 with SRC9.40.
When searching for Knowledge articles inside SRC the results differs depending on the SRC-login-language (which defined in the browser language settings).
Example:
Searching for 'how code'
- SRC in English lists 2 results
- SRC in German lists articles with the 2 words included (ie. 3 results total)
- SRC in English lists the articles when I search for "how" and code
Cause
The word 'how' is in kmstopwords in English, but not in German. That's why the number of results is lower in English
Fix
Remove the word 'how' from the list of kmstopwords.
Then go to Knowledge Management > Administration > Environment and then “Full Reindex”