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Getting Started with the Content Reference Guide
The Content ReferenceGuide includes information about IT Business Analytics integrations with the
supported data sources as well as information about the context, KPIs, andMetrics relevant for each
data source.

Note: You can add tables to contexts andmodify the contexts using the Context Designer. For
details, see "Semantic Layer - Contexts and Universes" on the next page in theAdministrator
Guide.

Contexts
This section provides information about contexts.

Semantic Layer - Contexts and Universes 8

Semantic Layer - Context Management 9

Semantic Layer - Context Designer 13

Semantic Layer - Excel (or .CSV) File Loader 43

Semantic Layer - Data Loader Scheduler 59

SAP BusinessObjects Enterprise Contexts (Universes) 65

Import or Export Contexts, Data, KPIs, Metrics, Trees, Pages, or Components 70

Reference: Contexts (Universes) 71
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Semantic Layer - Contexts and Universes

ITBA semantic layer includes Contexts and universes.

The Context Designer feature enables you to create andmanage Contexts (universes). The Contexts
can be based on your target schema tables or on Excel (or .CSV) files that can be uploaded to the
target schema using the Data Loader.

Context Designer can be used to upload data and create contexts based on the data, when you want to
work with the IT Business Analytics application without using DataWarehouse and
SAP BusinessObjects Enterprise. It is a direct way to upload data into the IT Business Analytics
Studio using files without performing integrations to external sources or to other HP products. It can be
used, to integrate third party data, testing, or for Proof of Concept (POC) sessions. It can also be used
as a component of IT Business Analytics to integrate third party data.

Context Designer provides KPI results based on your real data.
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Semantic Layer - Context Management

The Context Management feature enables you to view the Contexts that have being created in your
application or the Contexts that have been loaded in your application, to delete Contexts, and to launch
Context Designer where you can create a new Context, view the design of an existing Context, or
upload a .CSV file.

To access:

In ITBA, click ADMIN > Semantic Layer > Semantic Layer. The Context Management page opens.

Tasks

This section includes:

View existing out-of-the-box Contexts (universes) 9

Export contexts using Content Acceleration Packs (CAPs) 10

Import contexts using Content Acceleration Packs (CAPs) 10

View existing out-of-the-box Contexts (universes)

1. In ITBA, click ADMIN > Semantic Layer > Semantic Layer. The Context Management page
opens.

2. The list of out-of-the-box Contexts is displayed.

3. You can now:

o Click Launch Context Designer to open the Context Designer. For details, see "Semantic
Layer - Context Designer" on page 13.

o Double-click the relevant Context in the list to open the Context Designer in context. For
details, see "Semantic Layer - Context Designer" on page 13.

o Click to refresh the display.

o Select the relevant context and click to delete the context.
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Export contexts using Content Acceleration Packs (CAPs)

To export contexts, proceed as follows:

1. Create a CAP that only includes the contexts you want to export. For details, see Create a CAP
with the Business Analytics application data in theContent Acceleration Packs Guide.

2. Export the CAP you created. For details, see Download a CAP to the user's local system in the
Content Acceleration Packs Guide.

Import contexts using Content Acceleration Packs (CAPs)

To import contexts, proceed as follows:

1. Copy the CAP that includes the relevant contexts to the relevant local system.

2. Upload the CAP. For details, see Upload a CAP to the Business Analytics application in the
Content Acceleration Packs Guide.

3. Activate the CAP inADMIN > Data management > Activate CAP. For details, see Activate a
CAP in theContent Acceleration Packs Guide.

4. Verify the upload by accessing the contexts inADMIN > Semantic Layer > Semantic Layer.
For details, see "Semantic Layer - Context Designer" on page 13.

Note:

l If the context you import already exists, it is deleted and replaced by the context imported using
the CAP.
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UI Description

Context Management Page

The Context Management page enables you tomanage the Contexts.
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User interface elements are described below (when relevant, unlabeled elements are shown in angle
brackets):

UI Element Description

Select the relevant context and click to delete the context.

You can select more than one context and click the icon to delete all the
selected contexts from the list.

Refreshes the display.

Launch Context
Designer

Click to open the Context Designer. For details, see "Semantic Layer - Context
Designer" on the next page.

<Context name> Double-click the Context name to open its detail in the Context Designer. For
details, see "Semantic Layer - Context Designer" on the next page.
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Semantic Layer - Context Designer

The Context Designer feature enables you to create andmanage Contexts (universes). The Contexts
can be based on your target schema tables or on Excel (or .CSV) files that can be uploaded to the
target schema using the Data Loader.

Context Designer can be used to upload data and create contexts based on the data, when you want to
work with the IT Business Analytics application without using DataWarehouse and
SAP BusinessObjects Enterprise. It is a direct way to upload data into the IT Business Analytics
Studio using files without performing integrations to external sources or to other HP products. It can be
used, to integrate third party data, testing, or for Proof of Concept (POC) sessions. It can also be used
as a component of IT Business Analytics to integrate third party data.

Context Designer provides KPI results based on your real data.

l The total number of KPI Breakdowns (STUDIO and on-Demand) is limited to 5000 per
dimension.

l If the calculation of a KPI or Metric ends in error, check the engine.log for a number of
Breakdowns being larger than the default value. You can update the default value in $HPBA_
Home\glassfish\glassfish\domains\BTOA\config\settings\engine-settings.xml. For details,
see Logs and the LogTool in theAdministrator Guide.

To access:

1. In ITBA, click ADMIN > Semantic Layer > Semantic Layer. The Context Management page
opens. If not , click Data Loader. For details, see "Context Designer Page" on page 34.

2. In the Context Designer page that opens:

o To create a new context, click Create a new context.

o To edit a context, click Open an existing context.

Learn More

This section includes:

View existing Contexts (universes) 26
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Create a Context and use its contents in the Studio 28

Update a Context 30

Export contexts using Content Acceleration Packs (CAPs) 31

Import contexts using Content Acceleration Packs (CAPs) 31

Add a column to a Target database table and the impact on the context 31

Remove a column from a Target database table and impact on context 32

Clone a context 33

Semantic Layer (Context and Universe)

A semantic layer is a business representation of corporate data that helps end-users access data
autonomously using common business terms. It maps complex data into familiar business terms such
as product, customer, or revenue to offer a unified, consolidated view of data across the organization.
By using common business terms, rather than data language, to access, manipulate, and organize
information, it simplifies the complexity of business data. These business terms are stored as objects
in a Business Context (or universe), accessed through business views. Business Contexts enable
business users to access and analyze data stored in a relational database andOLAP cubes. This is
claimed to be core business intelligence (BI) technology that frees users from IT while ensuring correct
results.

Business Views is amulti-tier system that is designed to enable companies to build comprehensive
and specific business objects that help report designers and end users access the information they
require. Business Views is intended to enable people to add the necessary business context to their
data islands and link them into a single organized Business View for their organization.

A Context or universe is a business representation of an organization's data that helps end-users
access data using common business terms. A Context is the result of a semantic layer of metadata
that creates a business oriented view of the data. A Context contains a schema of the tables that make
up the dimension andmeasurement objects. A Context is an interface between the data warehouse
and the analytics that display the data.

Context aremade up of objects and classes that aremapped to the source data and are accessed
through queries and reports. They correspond to the business contexts used in IT Business Analytics.

Each Context includes classes (entities), objects with a dimension attribute, and relationships between
the entities. The entity's values are used in the calculation of values and statuses of the Key
Performance Indicators (KPIs) or Metrics that represent them. The KPIs or Metrics are the building
blocks used by the IT Business Analytics engine and the Studio.

IT Business Analytics Semantic Layer may include:
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l Universes created in SAP BusinessObjects. For more details on universes, see the relevant
SAP BusinessObjects documentation.

l Out-of-the-box Contexts created using the Context Designer.

l User-defined Contexts created using Context Designer and populated with data uploaded from
.CSV files using Context Designer. For details on the Context Designer, see Semantic Layer -
Context Designer in theContent ReferenceGuide.

If you want to change the formula of a KPI or Metric , youmust be aware of the relationships in the
context (universe) of the KPI or Metric. For details, see the KPI andMetric Library in Excel format, in
the relevant integration sections in this document, or in the relevant Content Acceleration Pack (CAP)
in theContent Acceleration Packs Guide.

The contexts, entities, and dimensions that are displayed and used in the Studio are part of the
universes that are located in the ITBA library.

Context or Universe Contents

A Context (or Universe) is a set of entities. Each entity is a set of fields. Each field can be a dimension,
measurement, or fact that can provide information about the business.

A formula calculates, for a specified time period, using the values of specific entities, a value that
represents a specific aspect of the business. The value is assigned to a Key Performance Indicator
(KPI) so that the KPI represents a specific aspect of the business.

Each Context includes some KPIs. The KPIs are the building blocks of the Studio and the KPI engine.

These entities that are used in the calculation of the KPIs are provided by the relevant integrated data
source. Each data source corresponds to a specific Content Pack that provides the connection
between the data source and ITBA.

Out-of-the-Box Contexts

You can only addmore tables and entities to an out-of-the-box Context, you cannot remove or modify
the original elements.

Terms

Dimension. An entity that describes, qualifies, or otherwise adds meaning to themeasurements
(facts) that business users want to analyze.
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Measure. A value collected by the executable during execution, such as the number of rows processed
during an ETL job, or an amount extracted from a table that describes expenses in a source application.

Metric. A framework to establish and collect measurements of success or failure on a regulated, timed
basis that can be audited and verified.

Contexts, entities, and fields UUIDs

To uniquely identify contexts, entities, and fields, a universally unique identifier (UUID) is assigned to
them. When you save a new context, the UUID is auto-generated.

The flowchart explains the different configurations and their impact on the import of a Context in the
Context Designer:

Loops in Contexts

Contexts can include tables that are linked together forming a loop.
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To perform the calculation of a KPI or Metric, the system selects the path with the lowest number of
joins as the default path. If the formula includes both fields in A and in E, then the system will choose A-
B-E (2 joins) instead of A-C-D-E (3 joins).

If the structure has the same number of joins and the formula includes fields from the three tables, then
the system cannot select the path with the lowest number of joins (same number for each path).

In that case, the selection of the path used for calculation is random.

The paths could then be:

Or

Or
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Tip: The problem of loops in context structure is that calculations may have different results
depending on the path selected by the system (random or lowest number of joins), therefore loops
are not recommended.

Workarounds:

l Modify the formulas: If you want the path to follow a specific path, youmust modify the formula so
it includes the path. For example, if the formula is SUM (A.duration, *) filter E.status=’OK’ it will
follow the A-B-E path because it has the smallest number of joins, but if you want it to pass via C
you canmodify the formula as follows: SUM (A.duration,*) with filter E.status=’OK’ but then the
path could go A-C-D-E or C-A-B-E. If you want it to follow A-C-D-E you should use SUM
(A.duration, C.id=C.id and D.id=D=id) with filter E.status=’OK’.

l Duplicate the table:Duplicate the table that is linked to a large number of other tables. If you have
the following context structure:
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You can create the same structure without loops by using copies (aliases) of theMember table, give
each table another name, and create the relevant joins, as follows:

Once you have created the aliases you can drag them to the Entities area.

l Modify the view: If you have the structure below then when the tables are dragged to the
Context Designer Entities area, then each entity and its attributes appear separately .
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You canmodify the views in the Target schema to correspond to the structure below, where the
attributes of the entity include both the entity original attributes and the attributes corresponding to
the person who submitted the idea. You create these views in the SQL server. This way when the
tables are dragged to the Context Designer Entities area they display the entity and its attributes as
well as the correspondingMember entity and its attributes.

Link between Contexts and KPI or Metric Formulas

When you create a Context, you select tables, create links between the tables, and select the relevant
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columns in the tables to be part of the Context. For details, see Semantic Layer - Context Designer in
theAdministrator Guide.

When you create a KPI or aMetric you assign them aContext in the Studio. The Context tables
become variables that you can use when creating KPI or Metric formulas, and the table columns
become the variable entities.

For example the% of Reopened DefectsKPI has the following formula:

RATIO_MATH(COUNT_DISTINCT( DefectHist.Defect , DefectHist.ReopenFlag =1 And
Defect.Status <> 'Closed') , COUNT(  Defect ,Defect.DefectSummary<> 'INVALID' And
Defect.DefectSummary<> 'UNKNOWN' ),0)*100

Its definition is:
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The Business Context is ALM_Defect. Click Admin > Semantic Layer and open the ALM_Defect
Context:
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The contents of the Context including the ALM tables is displayed:

In the Entities area on the right, you can see the tables and the table columns that were selected to be
part of the ALM_Defect Context itself.

It is recommended that the person who creates the KPI or Metric formula should be familiar with the
ALM entities that are used in the ALM_Defect context:

TheDefect_Hist table corresponds to one of the entities (DefectHist) that appears in the list of
Variables that can be used when creating or modifying the formula of a KPI based on theALM_Defect
context. To access the KPI or Metric formula, click Studio, highlight the relevant KPI (% of Reopened
Defects for example), click theCalculation Details tab, and then click Open Formula builder.
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The variables you see in the formula builder correspond to the Entities in the Context Designer (above)
and correspond to the <EntityName> in the syntax of the formulas (as explained in KPI or Metric
Formula in theBusiness Analyst Guide).
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When you expand a variable, the items you see below correspond to the fields (in the Context
Designer) and correspond to the <FieldName> items in the formulas syntax (as explained in KPI or
Metric Formula in theBusiness Analyst Guide).

Tasks

This section includes:

View existing Contexts (universes) 26

Create a Context and use its contents in the Studio 28

Update a Context 30
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Export contexts using Content Acceleration Packs (CAPs) 31

Import contexts using Content Acceleration Packs (CAPs) 31

Add a column to a Target database table and the impact on the context 31

Remove a column from a Target database table and impact on context 32

Clone a context 33

View existing Contexts (universes)

1. In Business Analytics, click ADMIN > Semantic Layer > Semantic Layer. The Context
Management page opens.

2. The list of out-of-the-box Contexts is displayed.
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3. Click Launch Context Designer.

4. In the Context Designer page that opens, click Open an existing context and select the relevant
context.
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5. The structure of the Context is displayed.

Create a Context and use its contents in the Studio

1. Create a new Context
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a. In ITBA, click ADMIN > Semantic Layer > Semantic Layer.

b. In the Context Management page, click Launch Context Designer.

c. Click Create a New Context. The Context Designer page opens.

d. Enter the name of the Context .

e. Click Open Repository. TheRepository area opens. You can use:
l Tables from theExternalTables list. These tables are created from external tables in
CSV format that are uploaded to ITBA. For details on how to upload a CSV table, see
"Semantic Layer - Excel (or .CSV) File Loader" on page 43. After the table is uploaded, a
corresponding table named ext.<csv_table_name> is listed in theExternalTables list.

l Internal tables from the InternalTables list.

If you are working with Enterprise ITBA, the tables listed in the InternalTables list are the
DataWarehouse tables, the Period tables created during the post-install procedure, and
the View table.

f. Drag the relevant tables from theRepository to theScheme area.

g. Define the relationships between the tables by dragging a specific column from one table and
dropping it over the relevant column in another table. A visual link is added to the graph to
indicate the relationship.

h. Drag the relevant tables from theScheme area to theEntities pane. The tables become
variables and the columns become the variable entities that can be used to create KPI or
Metric formulas when a KPI or Metric is assigned the Context in the Studio.

i. Click to save the Context.

2. Load the Context and verify the variables and entities

a. In ITBA, click Studio.

b. Activate a KPI or aMetric or clone any active KPI or Metric that does not have a KPI
Breakdown or BreakdownMetric. For details, see Activate Scorecards, Perspectives,
Objectives, Metrics, or KPIs Using Templates or Create Active Scorecards, Perspectives,
Objectives, Metrics, or KPIs in theBusiness Analyst Guide.

c. Click theCalculation details tab, and click Select business context. For details, see KPI or
Metric Configuration and Calculation Details in theBusiness Analyst Guide.

d. In the Business Context dialog box, change its Context to the new Context.

e. You can thenmodify the formula that is used to calculate the KPI or Metric status by selecting
the variables that correspond to the entities and fields that were defined in the Context
Designer. To do that click Open Formula Builder.
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f. In the Formula Builder dialog box, verify that the variables correspond to the tables you
selected in the Entities area in the Context Designer, and that the entities of the variables
correspond to the selected columns of those tables. Click OK to save the KPI.

Note: In the sameway, you canmodify the Filter of the KPI or Metric to use the variables
corresponding to the .CSV file-based Context (universe).

Update a Context

1. In ITBA, click ADMIN > Semantic Layer > Semantic Layer. In theContext Management page,
click Launch Context Designer. The Context Designer page opens. For details, see "Context
Designer Page" on page 34.
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2. Select the relevant Context.

3. Make the relevant changes: delete or add entities, fields, tables, columns, or relationships.

4. Click to save the Context.

5. Load the Context and verify.

Export contexts using Content Acceleration Packs (CAPs)

To export contexts, proceed as follows:

1. Create a CAP that only includes the contexts you want to export. For details, see Create a CAP
with the Business Analytics application data in theContent Acceleration Packs Guide.

2. Export the CAP you created. For details, see Download a CAP to the user's local system in the
Content Acceleration Packs Guide.

Import contexts using Content Acceleration Packs (CAPs)

To import contexts, proceed as follows:

1. Upload the CAP. For details, see Upload a CAP to the Business Analytics application in the
Content Acceleration Packs Guide.

2. Activate the CAP inADMIN > Data Management > Activate CAP. For details, see Activate a
CAP in theContent Acceleration Packs Guide.

3. Verify the upload by accessing the contexts inADMIN > Semantic Layer > Semantic Layer.

Note:

l If the context you import already exists, it is deleted and replaced by the context imported using
the CAP.

Add a column to a Target database table and the impact on the context

When you restructure the Target database by adding a column to a table, the corresponding tables in
the relevant Contexts are automatically refreshed. Youmust then proceed as follows:
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1. Restructure the Target database by adding a column to a specific table.

The column is automatically and immediately inserted into the corresponding table in the Context,
and the links between the Context tables aremaintained. A new index is not created if you add a
new column directly in the target DB so you have to create an entry for the new column accessing
by the SQL StudioManager. The index is located under the table and then under the columns.

2. If needed, create additional links between the new column and the other tables.

3. If needed, drag the new column into theEntities area.

4. Save the context.

Note:

l If you change the type of a column from a table in the Target database, the formula that
calculates KPIs based on the Context that includes that table, may also be invalid.

l If you change the name of a column from a table in the Target database, the effect is the same
as adding a new column. Refer to the procedure above.

Remove a column from a Target database table and impact on context

When you restructure the Target database by removing a column from a table, the corresponding tables
in the Contexts are automatically refreshed. Youmust then proceed as follows:

1. Remove the index corresponding to the relevant column by accessing the SQL StudioManager.
The index is located under the table and then under the columns.

2. Remove the relevant column from the table in the Target database.

The column is automatically and immediately removed from the corresponding table in the
Context, and the links between the Context tables aremaintained. The link from this column to
other tables are removed.

3. Remove the column from theEntities area.

4. Save the context.

Note:

l If you remove a column from a table in the Target database, the corresponding column is
automatically and immediately removed from the relevant Context.
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l If the columnwas also listed in the Entities thenmake sure to remove it from the Entities as
well before saving and validating themodified context.

l If the column is removed from a table in the Target database, and the Context is not verified,
the formula that calculates KPIs based on the Context, might also be invalid. If the removed
column has a link to another column, the link is also removed

Clone a context

To clone a context:

1. Create a CAP that includes only the context. For details, see Create Content Acceleration Packs
in theContent Acceleration Packs Guide.

2. Download the CAP to your local system. For details, see Download a CAP to the user's local
system in theContent Acceleration Packs Guide.

3. Open the <context_name>.XML file and change the context name and at least one character in
the UUID. Change also the UUID of all the entities, and the fields in the context.

For example:

<?xml version="1.0" encoding="UTF-8" standalone="true"?>
-<contexts>
-<context uuid="4c60950d-2fdc-49c5-a34e-5c041963d0bb" active="false"
name="SALARY">
-<entity uuid="c3a48abd-7156-47a7-a489-527bfa2385c9" name="ext_IT_Salary_

new" isVisible="false">
<field uuid="7adedab5-9336-490b-8594-db81fe559c37" name="NAME"
isVisible="false"
tableName="@extension.schemaName@.IT_Salary_new"
columnName="NAME" qualification="DIMENSION" type="STRING"
isLOV="false"/>

</entity>
-<table name="@extension.schemaName@.IT_Salary_new" height="126"

yPos="236.95" xPos="493.0">
<column name="NAME" type="varchar"/>
<column name="ORGANIZATION_NAME" type="varchar"/>
<column name="ORG_ID" type="numeric"/>
<column name="SALARY" type="numeric"/>
</table>

</context>
</contexts>

4. Save the XML file.
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5. Rename the CAP in your local system.

6. Upload it. For details, see Upload a CAP to the Business Analytics application in theContent
Acceleration Packs Guide.

7. Activate it. For details, see Activate a CAP in theContent Acceleration Packs Guide.

UI Description

Context Designer Page

The Context Designer page enables you tomanage the Contexts that you create using the Context
Designer feature.

User interface elements are described below (when relevant, unlabeled elements are shown in angle
brackets):

UI
Element Description

Click to display a list of existing Contexts created in the Context Designer. Select the
relevant Context and click OK.
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Click to create a new Context. The Context Designer Wizard opens. For details, see
below.

Click to open the Import Content wizard. For details, see "Semantic Layer - Excel (or
.CSV) File Loader" on page 43.

Context Designer Wizard

The Context Designer wizard enables you to create a Context with tables, entities, and relationships.
Once you have completed the Context, save it. The Context is then added to the list of Contexts
available in the Studio. The tables that compose the universe are added as variables and the table
columns as variable entities. The variables and entities can be used to calculate the formulas for the
KPIs that are assigned the Context. For details, see KPI or Metric Configuration and Calculation
Details in theBusiness Analyst Guide.
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This page enables you to configure a Context.

Context Designer Toolbar

User interface elements are described below (when relevant, unlabeled elements are shown in angle
brackets):

UI
Element Description

New. Click to create a new Context.

Save. Click to save the currently opened Context.

Open. Click to display a list of existing Contexts created in the Context Designer. Select
the relevant Context and click OK.
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Add table. Click to add tables in CSV format to the Repository. The data loader wizard
opens. For details, see "Semantic Layer - Excel (or .CSV) File Loader" on page 43.

Click to validate the Context. The validation checks if the name of the Context is unique,
if all the tables in the Context exist in the Repository, andmore.

When you click the Save button, the Context is validated. An invalid Context is not
saved.

Context Area

User interface elements are described below (when relevant, unlabeled elements are shown in angle
brackets):

UI
Element Description

Context
name

The name of the Context.

Limitation: SAP BusinessObjects Enterprise Universe names should not duplicate
Context names, and all names of Universes and Contexts should be unique.

Note: If you have assigned to a KPI a Context created with the Context Designer,
and then youmodify the Context name in the Context Designer, make sure that you
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UI
Element Description

assign themodified Context to the KPI in the Studio otherwise the KPI becomes
invalid as it uses a Context that does not exist.

Scheme Area

User interface elements are described below (when relevant, unlabeled elements are shown in angle
brackets):

UI Element Description

Repository Click the button to open the table repository. For details, see
"Repository" on the next page.

<Drag and drop> Select the relevant table in the Repository and drag and drop it
in the Scheme area tomake the table part of the universe.

<Create relationships> Select the relevant entity in a table and drag and drop it on the
relevant entity in another table to create the relationship
between these two entities.
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UI Element Description

Note:

l Double-click a table to shrink it down to its title.
Double-click a shrunk table to expand it.

l To delete a relationship, click it and press theDelete
key.

Use the slider to zoom in or out.

Repository

The Repository area enables you to select external or internal tables to add to the Context you are
building.
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User interface elements are described below (when relevant, unlabeled elements are shown in angle
brackets):

UI Element Description

Click to close the Repository.

External
Tables
(CSV)

Lists the CSV tables that were uploaded using the data loader wizard.

Click the relevant table to display its column details.

Click to add tables in CSV format to the Repository. The data loader wizard opens.
For details, see "Semantic Layer - Excel (or .CSV) File Loader" on page 43.

Internal
Tables

Lists the tables. Click on the relevant table to display its entities in the Column details
section.

Column
Details

Lists the entities (columns) of the table selected in the Internal Tables section. Each
entity is preceded by an icon indicating the type of entity:

l - date.

l - string.

l - numeric

Entities Area

You drag tables from the Scheme area to the Entities area to add a variable corresponding to the table
to the list of variables available to create the formula for the KPI that is assigned the Context. The table
columns become the variable entities.
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User interface elements are described below (when relevant, unlabeled elements are shown in angle
brackets):

UI
Element Description

<Drag
and
drop>

Drag and drop a table from themiddle pane to the Entities pane to add the table's
entities and fields to the list of available entities and fields available to be added to a
KPI formula in the Formula Builder. For details, see KPI or Metric Formula in the
Business Analyst Guide.

<Table> The table that you dragged from the Scheme area to the Entities area is displayed
followed by its columns.

<Left
column>

Icons indicate the format of the column.

l - date.

l - string.

l - numeric

<Right
columns>

The icons to the right of the column enable you to decide to:

- Enable the auto completion feature. For details, see Variables in theBusiness
Analyst Guide.

- Enable the creation of a Breakdown for the relevant KPI. This can cause
performance issues if the KPI Breakdown has more than 100 values.

- Enables you to set the dimension permission for this entity dimension in the
Dimension Permission page.
For details, see Dimension Permissions in theAdministrator Guide.

Note: Youmust also have selected to enable the creation of a Breakdown.

The list of fields that are available for breakdowns is configured in the Context
Designer. By default,numeric fields are not dimensions, therefore they are not available
for breakdowns. If you want them to be available for breakdown, open the Context
Designer and in the Entities area, click to enable the creation of Breakdowns. For
details, see Semantic Layer - Context Designer in theContent ReferenceGuide.

Date fields are not available for breakdowns.

Remove Click to remove the selected table or entity.
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Semantic Layer - Excel (or .CSV) File Loader

The Context Designer feature enables you to create andmanage Contexts (universes). The Contexts
can be based on your target schema tables or on Excel (or .CSV) files that can be uploaded to the
target schema using the Data Loader.

Context Designer can be used to upload data and create contexts based on the data, when you want to
work with the IT Business Analytics application without using DataWarehouse and
SAP BusinessObjects Enterprise. It is a direct way to upload data into the IT Business Analytics
Studio using files without performing integrations to external sources or to other HP products. It can be
used, to integrate third party data, testing, or for Proof of Concept (POC) sessions. It can also be used
as a component of IT Business Analytics to integrate third party data.

Context Designer provides KPI results based on your real data.

Note: It is recommended to use Excel files instead of .CSV files.

To access:

l In ITBA, click ADMIN > Semantic Layer > Semantic Layer. The Context Management page
opens. Click Launch Context Designer and select Import Content.

l In the Context Designer page, click the Import Content icon in the toolbar to open the Import

wizard.

l In the Context Designer page, in the Repository area, click the Import Content icon to open

the Import wizard.

Learn More

To understandmore about Contexts, see the LearnMore section in "Semantic Layer - Context
Designer" on page 13.
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Import an Excel or a .CSV file in Context Designer or use them as data

sources in IDE

The differences between the two techniques is as follows:

l Context Designer:When you import an Excel or a .CSV file using the Context Designer located in
the Admin tab, a Context based on the structure of the file is created in Context Designer. You can
then extend the context by adding other tables and creating connections. The newly created context
can then be used as a base for KPIs.

This process is fast and efficient and displays value very quickly. It is recommended for one-time
operations, when the data does not change very often, when you don't need historical information,
or for POCs.

Note that you can also schedule the automatic import of an Excel or a .CSV file. You can even
schedule the automatic import of an Excel or a .CSV files with a changed structure.

l IDE:When you use an Excel or a .CSV file as the data source in the IDE, you create a content pack
and a basic ETL.

This process is more complex, but providemore flexibility. It is recommended for Production
environments. Because this procedure creates a content pack and uses an ETL, it enables the use
of all the other capabilities of the system. It provides the handling of historical information, the
scheduling of data import from the same Excel or .CSV file when the file changes periodically, the
creation of Target database tables different from the original Excel or .CSV table, the connection to
other entities, the splitting of the original Excel or .CSV table into different tables in the Target
database, or the addition of the original data to other tables in the Target database. In addition, the
process identifies changes and deletions of data, and can handle large amounts of data.

Tasks

This section includes:

Upload tables in Excel format to the Tables Repository 44

Upload tables in .CSV format to the Tables Repository 45

Use Case - Create a New Business Context Using .CSV Files 46

Upload tables in Excel format to the Tables Repository

You can upload data into the Table Repository of the Context Designer, using Excel files and without
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integration with external sources or with other HP products. It can be used to integrate third party data
sources, testing, or for Proof of Concept (POC) sessions. You can, in the sameway, replace the data
in an existing table, or add data to an existing table when the table has been loaded using an Excel file.

Note: You can upload Excel tables with .XLSX or.XLS formats.

To upload data from the Excel file into the Table Repository:

1. Create the Excel file containing the data you want to use in the Table Repository (for
example: latest.XLSX).

Recommended:Excel tables should have unique names across all active Content
Acceleration Packs (CAPs). For details on CAPs, see Create Content Acceleration Packs in
theContent Acceleration Packs Guide. See also additional limitations in Limitations in the
Content ReferenceGuide.

2. In IT Business Analytics, click theADMIN > Semantic Layer > Semantic Layer.

3. In the Context Management page, click Launch Context Designer .

4. Click Import Content to open the Import Wizard (data loader). Follow the steps to upload the

Excel file. For details, see Content Import Wizard in theContent ReferenceGuide.

The file is uploaded. The upload operation saves the changes youmade to the Excel file. The new
table appears in the External Tables area.

Upload tables in .CSV format to the Tables Repository

You can upload data into the Studio using .CSV files and without integration to external sources or to
other HP products. It can be used to integrate third party data sources, testing, or for Proof of Concept
(POC) sessions. You can, in the sameway, replace the data in an existing table, or add data to an
existing table when the table has been loaded using a .CSV file.

To upload data from the .CSV file into the Studio:

1. Create the .CSV file containing the data you want to use in the Studio (for example: latest.CSV).

Recommended:CSVtables should have unique names across all active Content
Acceleration Packs (CAPs). For details on CAPs, see Create Content Acceleration Packs in
theContent Acceleration Packs Guide. See also additional limitations in Limitations in the
Content ReferenceGuide.

2. InITBA, click theADMIN > Semantic Layer > Semantic Layer.
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3. In theContext Management page, click Launch Context Designer .

4. Click Import Content to open the Import Wizard (data loader). Follow the steps to upload the

.CSV file. For details, see "Content Import Wizard" on the next page.

The file is uploaded. The upload operation saves the changes youmade to the .CSV file. The new
table appears in the External Tables area.

Use Case - Create a New Business Context Using .CSV Files

For details, see Create a New Business Context in theGetting Started.
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UI Description

Content Import Wizard

The wizard enables you to upload content.
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1 - Content Import

User interface elements are described below (when relevant, unlabeled elements are shown in angle
brackets):

UI
Element Description

Select
the data
on
which
you
want to
base
the KPI.

You can use Excel (or .CSV) files as a data source. A .CSV file contains data separated
by commas. Each Excel file sheet or each .CSV file that is uploaded corresponds to a
Context with only one entity. The name of the Context that is created is the name of the
Excel sheet (or .CSV) file. The names of the columns in the Excel sheet (or for .CSV
files, the first row of the file) represent the names of the entity fields. These fields become
the variables that can be used to create the formula that is used to calculate the value of
the KPIs or Metrics associated with the Context.

File Structure
The .CSV file should have a table structure.

Example The following is an example of a .CSV file in CSV format:

MD_BUSINESS_KEY,SLA_NAME,SLA_STATE,SLA_TYPE,DATE_START,DATE_END
SLA01,SLA01,Passed,Corporate,1/1/2011 13:00:00,2/1/2011 19:00:00
SLA02,SLA02,Passed,Corporate,1/2/2011 13:00:00,2/2/2011 19:00:00
SLA03,SLA03,Passed,Corporate,1/3/2011 13:00:00,2/3/2011 19:00:00
SLA03,SLA03,Passed,Corporate,1/3/2011 13:00:00,2/3/2011 19:00:00
SLA04,SLA04,Passed,Corporate,1/4/2011 13:00:00,2/4/2011 19:00:00
SLA13,SLA13,Passed,Corporate,1/3/2011 13:00:00,2/3/2011 19:00:00
SLA14,SLA14,Passed,Corporate,1/6/2011 13:00:00,2/6/2011 19:00:00

Example The following is an example of an Excel file:
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UI
Element Description

Limitations for .CSV and Excel files

l Data file size. Themaximum size of the data file is 20MB. This is configurable using
theMaximum Size of .CSV file (MB) setting inADMIN > Settings > BA Settings.

l Names:

o General:

l The entity field names should follow the rules of column titles in the database
(only alphanumeric characters and underscores (_)).

l The name of the data file should follow the rules of Context names (only
alphanumeric characters and underscores (_)).

o .CSV file.

l Themaximum number of characters in an entity field name is 30 characters (an
entity field name is the string between commas in the first row of the .CSV file).

l Data included between commas (corresponding to columns) should not include
commas.

o Excel file:x

l Themaximum number of characters in a sheet name in an Excel file is 254
characters.

l Excel file sheets should have a name even if they are empty.

l Excel file sheets should not have empty columns at the beginning or in the
middle of the columns.

l The names of the Excel sheets should follow the rules of Context names
(database tables) and include only alphanumeric characters, and underscores
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UI
Element Description

(_).

l Themaximum number of digits in a data field is 18 digits and 2 decimal digits.

l Themaximum number of characters in a data field is 254 characters.

l A data field should not include a formula.

l A column should not include different types of data (for example, numeric, and
date data).

l A date column should only include dates.

Make sure you also check out the limitations in Limitations in theContent Reference
Guide.

Tip:

l The date data obtained from the data sources is automatically reformatted
internally using theYYYY.MM.dd HH:mm:ss (based on 24 hours) format. All
internal calculations are performed using this format.

l If you are using CSV files, you can select the date format in the <Data upload>
wizard. The selected format is automatically reformatted internally using the
YYYY.MM.dd HH:mm:ss (based on 24 hours) format.

l The dates displayed in the application user interface are reformatted according to
the browser locale.

Create a
.CSV or
Excel
File

Hover above file template to display an example of the file structure in table format that
can be uploaded.
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2 - Select Action

User interface elements are described below (when relevant, unlabeled elements are shown in angle
brackets):

UI
Element Description

Upload
a new
table

Select this option if you want to create a new table in the Context Designer using the
information from the Excel or .CSV file.

Update
an
existing
table

Select this option if you want to update an external table that was previously uploaded to
the Context Designer.

When you click this option, the following options are displayed:
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UI
Element Description

l Add data to an existing table. Select this option when you want to add data to an
existing table. The data from the new imported file is added at the end of the existing
table. The formats of the two imported files must be the same.

l Override the data in an existing table with the new data. Select this option when
you want to override the data of an existing table with the data of the file you are
uploading. The formats of the two imported files must be the same.

l Override the data with new data in a table with changed structure. Select this
option when you want to override the data of an existing table with the data of the file
you are uploading. The formats of the two imported files is different. Youmight have
added or removed columns.

If you want to override the data of a table with changed structure and the file you
import is an Excel file with more than one sheet, note that you can only import one
sheet at a time. Youmust import separately each one of the sheets.

3 - Select File

This page is displayed when you selected theUpload a new table option:
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This page is displayed when you selected theUpdate an existing table option:

User interface elements are described below (when relevant, unlabeled elements are shown in angle
brackets):

UI Element Description

File Name Select the file you want to upload.

Table Name Select the relevant table name.
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4 - Select Sheets

This page displays the table created from an Excel file.

Select the sheets you want to upload.

In you are performing the override of an Excel file with more than one sheet, note that you can only
import one sheet at a time when you override the data of a table with changed structure. If you change
the structure of more than one sheet, perform the import for each one of the sheets.
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5 - Table Preview

This page displays the table created from the Excel file:

This page displays the table created from the .CSV:

The page displays the table with a new columnwhen you override an existing file.
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User interface elements are described below (when relevant, unlabeled elements are shown in angle
brackets):

UI Element Description

<table_name> The name of the table. It corresponds to the selected sheet in the Excel file
or to the CSV file itself.

<sheet_nbr/total_
nbr_sheets>

The sheet number and the total number of uploaded sheets in the Excel
file.

Click the arrows to display the other table previews.

<table> The contents of the .CSV or Excel file are displayed in the box in table
format.

If you selectedmore than one sheet of the Excel file, arrows appear and
you can view a sample of each sheet you selected.

You can set the date format only for the CSV file.

If you override an Excel file you can only import one sheet at a time if the
sheet structure has changed. In the table in the Table Preview page:

l The title of a column that was added to the imported file but did not exist
in the database is green.
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UI Element Description

l The title of a column that was removed from the imported file but exists
in the database is red and crossed-out.

Select the date
format you used in
the file

Select the date format you used in the .CSV file.

6 - Automatic Import Scheduler

You can schedule the upload of a .CSV or Excel file automatically.

Content ReferenceGuide

HPE IT Business Analytics (10.00)
Monday, March 28, 2016- 6:55:37 AM Page 57 of 237



User interface elements are described below (when relevant, unlabeled elements are shown in angle
brackets):

UI Element Description

Schedule import later Select to schedule the automatic import at a later time. For details, see
"Semantic Layer - Data Loader Scheduler" on the next page.

This is the default.

The automatic import
should occur
<periodicity> at <time>

Select to import the file:

Daily.and select the time (from 00:00 to 23:30) when you want to
perform the import operation.

Weekly. and select the day (Monday toSunday) and time (from 00:00
to 23:30) when you want to perform the import operation.

Monthly., and select the date (1 to 31, or last day of the month) and
time (from 00:00 to 23:30) when you want to perform the import
operation.

File location The location of the .CSV or Excel file that you want to upload
automatically. Use the format described in the field. The locationmust
be accessible by BA.

Select upload type l Add data. Select this option when you want to add the data from the
new imported file at the end of the existing table. The formats of the
two imported files must be the same.

l Override data. Select this option when you want to replace the data
of the existing table with the data of the file you are uploading The
formats of the two files must be the same.
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Semantic Layer - Data Loader Scheduler

You can schedule the import of Excel (or .CSV) files into Context Designer.

You can also schedule the automatic import of Excel (or .CSV) files directly into Context Designer
when you import for the first time. For details, see "Content Import Wizard" on page 47.

Note: It is recommended to use Excel files instead of .CSV files.

You can also select to schedule the import at a later time.

To access:

Click ADMIN > Semantic Layer > Data Loader Scheduler.

Tasks

Schedule (or edit) the automatic import of an Excel (or .CSV) file

1. Click Admin > Semantic Layer > Data Loader Scheduler.

2. In the Data Loader Scheduler page, click Add Schedule (or ) .

3. In the dialog box that opens, select or enter the frequency and the time when the upload should
take place, the type of upload (Add data orOverride data), and the location of the file.

4. Click OK.
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UI Description

Data Loader Scheduler Page

User interface elements are described below (when relevant, unlabeled elements are shown in angle
brackets):

UI
Element Description

Add
Schedule

Click to schedule the automatic upload of a .CSV or Excel file.
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UI
Element Description

File
location

The location of the .CSV or Excel file that you want to upload
automatically.

Limitations

l Path. The path to the file to be imported should have shared
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UI
Element Description

access (read/write), and should not include authentication.

l .CSV Files:
o Date format. The date format in .CSV files that you want to

import using the Data Loader Scheduler must be:
DD/MM/YYYY as it is not possible to specify the data format
in the Data Loader Scheduler.

o File name. The .CSV file name should be as the same as
the DB table name.

Column names. The column names in the .CSV file should
match the names of the columns in the DB table.

l Excel file.

o Make sure that the sheet names in the Excel file that you
import using the Data Loader Scheduler match the names of
the sheets (tables) in the original Excel file you imported
using the Data Loader wizard.

o Make sure that the column names in the Excel file that you
import using the Data Loader Scheduler match the names of
the columns in the original Excel file you imported using the
Data Loader wizard. If the column names do not match, an
error is issued: Failed populating content for table:
<table_name> <database_exception_number>.

Make sure you also check out the limitations in "Limitations for
.CSV and Excel files" on page 49.

Import all
sheets

The option is selected by default. When the option is selected, all the
sheets of the Excel file are imported.

If you deselect the option, the list of sheets is displayed. You can then
select the relevant sheets.

Select
upload
type

l Add data.Select this option when you want to add the data from the
new imported file at the end of the existing table. The formats of the
two imported files must be the same.

l Override data. Select this option when you want to replace the data
of the existing table with the data of the file you are uploading The
formats of the two files must be the same.

Test
location

Click to test the location of the file you want to import.

Edit If inEdit frequency, you selected:
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UI
Element Description

frequency l Daily, you can then select the time when you want to perform the
import operation in the Import time field.

l Weekly, you can then select the day of the week when you want to
perform the import operation in the Import day list.

l Monthly, you can then select the day of themonth when you want to
perform the import operation in the Import day of month list.

If you chose day 31, the import occurs only onmonths with 31 days.
If you want to schedule the import on the last day of every month,
select Last day of month.

Import
time

Select the time (from 00:00 to 23:30) when you want to perform the
import operation.

Tip:Do not schedulemore than 15 imports during the same 5
minutes.

Import
day

This field appears when you have selectedEdit frequency = Weekly.

Select the day when you want to perform the import operation.

Import
day of
month

This field appears when you have selectedEdit frequency = Monthly.

Select the day of themonth when you want to import the data.

If you chose day 31, the import occurs only onmonths with 31 days. If
you want to schedule the import on the last day of every month, select
Last day of month.

Click to edit the scheduler for the relevant file. For details, see "Add Schedule" on page
60.

Datafile
name

The name of the .CSV or Excel file that you want to upload automatically.

File
location

The location of the .CSV or Excel file that you want to upload automatically.

Start date The date from when you want to start the scheduling.

Import
frequenc
y

When the upload of the file takes place. The frequency can be: Daily,Weekly, or
Monthly. The scheduled time of the upload is a time frame between 00:00 and 23:00.

Status l Active. Select this option to activate the scheduler.

l Suspended. Select this option to suspend the scheduler. The upload will not take
place.
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Upload
type

l Add data.Select this option when you want to add the data from the new
imported file at the end of the existing table. The formats of the two imported files
must be the same.

l Override data. Select this option when you want to replace the data of the existing
table with the data of the file you are uploading The formats of the two files must be
the same.

Deletes the scheduling.
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SAP BusinessObjects Enterprise Contexts (Universes)

A KPI or Metric Context (universe) represents a global business facet related to the aspect of business
the KPI or Metric represents. For example, the% of Assets in Maintenance KPI represents one aspect
of the AssetManagement universe.

You can add a Context to the Studio and the BA engine and attach KPIs or Metrics to the new Context
in the Studio.

Tasks

This section includes:

Add a Context to Studio using Context Designer 65

Add a Context to Studio using BO 65

Universe Creation Guidelines 66

Add a Context to Studio using Context Designer

You can create new Contexts, using Context Designer. For details, see Semantic Layer - Context
Designer in theAdministrator Guide.

If you have SAP BusinessObjects Enterprise installed, you can also create Contexts (Universes) using
BOE. Once you are done youmust add these Contexts to the Studio.

Add a Context to Studio using BO

1. Make sure you havemodeled the data structure in your database.

2. Add the universe using the BO Designer according to the Universe Creation Guidelines. For
details, see "Universe Creation Guidelines" on the next page.

3. Export the universe to the BA directory in your BOCMS (Central Management Server) using the
BODesigner .
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4. To load the universe to the Studio library you can do one of the following:
o Run the JMX reloadmetadata.

i. Make sure you have JDK installed.

ii. Run jconsole in theStartmenu.

iii. In the window that opens, select theRemote Process option, enter <host_name>:<port_
number> and click Connect.

iv. After the application completes its loading, click theMBeans tab.

v. Click com.hp.btoa.studio.jmx.

vi. Click loadMetaData.

o Note that if you do not click loadMetaData, the change will be performed by an automatic
update after 24 hours or 7 days depending on your configuration. You canmodify the
configuration using theMeta Data reload rate (Days) parameter in theBA Settings section of
the ADMIN Tab. For details, see BA Settings in theAdministrator Guide.

5. You can now design active or template entities, create the formulas and filters for the KPIs or
Metrics, andmore.

Reference

Universe Creation Guidelines

This section explains how you can create Universes that can be used by the IT Business Analytics
Studio and the BA Engine.

Guidelines

1. Folders represent the name of the entity that is presented.

2. Classes in the directory represent the attributes of that entity.

3. Classes should be of type Date, String, or Numeric.

4. Entities (represented by directories) in the same universemust have a relationship between them.

5. Hierarchical relationships should be flattened to attributes (Level1, Level2, …). These
relationships can be defined in a joined table.

Limitations

1. No current support for directories within directories or other hierarchies.
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2. Ensure that there aren’t multiple joins between entities represented in the Universe (This is a
Universe limitation). Use aliases to copy.

3. Folder names should be unique.

4. Count, in a formula, can only be performed on Numeric and String fields.

5. Conditions on objects not supported.

6. Details on objects not supported.

7. Do not put mappings in the universe – where fields are translated from the value in the database to
the value that the universe returns.

Field Types

l Dimensions
o Fields that can be broken down per KPIs or Metrics should bemarked as Dimensions – see the

topmark in the figure below.

o If the field can only have a limited set of values, then turn on the List of Values field below – see
the secondmark in the figure below. The studio will only show the first 100 values.

o Warning - this should only be turned on for fields that have a small set of values – all the values
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will be loaded intomemory in the studio.

l Measures
o Fields that are only used as measures in KPI or Metric formulas should bemarked as Measures.

Make sure to configure as in figure below.
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Import or Export Contexts, Data, KPIs, Metrics, Trees, Pages, or

Components

You can import or export complete trees (with their Scorecards, Perspectives, Objectives, and
KPIs), Unassigned KPIs, Metrics from the Active KPIs pane, as well as user-defined pages or
components.

The import or export flows aremeant to be used whenmoving from staging to production and not as a
way to update system configuration. If you want to use the import or export flows to update the system
configuration, youmust delete all the nodes in the active KPIs pane, before performing the import
operation. . For details, seeMigrate from Development or Test Environment to Production in the
Administrator Guide.

The export and import flows are alsomeant to be used for localization purposes, when you want to
work with other languages than English. For details, see Localization andGlobalization in the
Administrator Guide.

To export or import the items listed above, you can use the Content Acceleration Pack (CAP) feature.
You can export or import:

l Contexts. For details, seeMigrate contexts in theAdministrator Guide.

l Data imported using .CSV files. For details, seeMigrate Data Imported using .CSV files in the
Administrator Guide.

l Trees of their Scorecards, Perspectives, Objectives, and KPIs, Unassigned KPIs, andMetrics. For
details, seeMigrate Trees, Metrics, and Unassigned KPIs in theAdministrator Guide.

l User-defined pages or components. For details, seeMigrate User-defined Pages or Components in
theAdministrator Guide.

Note: You canmigrate Contexts, trees, KPIs, Metrics, user-defined pages, or components using
one CAP per type of item or one CAP for all the items you want to export/import/migrate.
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Reference: Contexts (Universes)

IT Business Analyticss includes out-of-the-box Context (universes) that correspond to specific aspects
of the business.The entities in these Contexts are IT DataModel-compliant. For details about IT Data
Model, see IT DataModel in theBusiness Analyst Guide.

To access:

In IT Business Analytics, click Admin > Semantic Layer > Semantic Layer. In the Context
Management page, click Launch Context Designer. In the Context Designer page, click Open an
existing context, and select the Context.

Learn More

Contexts Created using SAP BusinessObjects Enterprise

A Context (universe) represents a business universe.

A Context is a set of entities. Each entity is a set of fields. Each field can be a dimension, measure, or
fact. It can bemeasured.

A formula calculates, for a specified time period, using the values of specific entities, a value that
represents a specific aspect of the business. The value is given to a Key Performance Indicator (KPI).
The KPI represents the specific aspect of the business.

Each universe includes some KPIs. The KPIs are the building blocks of the Studio and the KPI engine.

The universe entity relationship diagrams (ERDs) are logical views of the universe datamodels. The
ERDs are interactive and contain details about the tables and classes used in the universe.

Tasks

This section includes:

Plan the integration of the relevant data sources and the activation of the corresponding Content
Packs 72

Display the Context 72
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Plan the integration of the relevant data sources and the activation of the

corresponding Content Packs

Proceed as follows:

1. Learn about KPIs andMetrics (Key Performance Indicators (KPIs) andMetrics in theBusiness
Analyst Guide).

2. Consult the list of KPIs andMetrics for each data source in theContent ReferenceGuide(or in the
KPI Library in Excel format - you can sort the list according to the business context).

This document is accessible from the Help Center page in the online Help Center (documentation
library), or from the HPE Software Product Manual Site
(https://softwaresupport.hpe.com/group/softwaresupport/search-
result?doctype=manuals?keyword=).

3. Understand the structure of the Contexts and about the KPIs or Metrics and their relation to
Contexts. For details, see Semantic Layer - Context Designer or SAP BusinessObjects
Enterprise Contexts (Universes) in theAdministrator Guide.

Display the Context

1. In IT Business Analytics, click Admin > Semantic Layer > Semantic Layer. The Context
Management page opens.

2. The list of out-of-the-box Contexts is displayed.

3. Click Launch Context Designer.

4. In the Context Designer page that opens, click Open an existing context.

5. Select the relevant Context.

The structure of the Context is displayed.

KPIs, Metrics, Contexts, and Data Source Integrations
The following sections provide information about the Data Sources, the Contexts linked to the data
sources, and the corresponding KPIs andMetrics, and indicates if there is a need for consolidation
when working with other data sources.
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Learn More

Note: The Period_Universe context is not based on external data sources. It is used tomanage
periods internally.

Application Lifecycle Management Data Source
Data source: "Integration with ALM" on page 76

KPIs andMetrics: "ALM-Related KPIs andMetrics" on page 84

Related CAPs: ALM_Demo and ALM Content Acceleration Packs in theContent Acceleration Packs
Guide.

Consolidation with PPM ("Integration with ALM" on page 76)

Asset Manager Data Source
Data source: "Integration with AM" on page 86

KPIs andMetrics: KPIs andMetrics in theContent Acceleration Packs Guide.

Related CAPs: AM_Demo and AM Content Acceleration Packs in theContent Acceleration Packs
Guide.

Amazon Web Services Data Source
Data source: "Integration with AWS" on page 91

KPIs andMetrics: KPIs andMetrics in theContent Acceleration Packs Guide.

Related CAPs: CSA_Demo and CSA Content Acceleration Packs in theContent Acceleration Packs
Guide.

Amazon Web Service CloudWatch Data Source
Data source: "Integration with AWSCW" on page 96

KPIs andMetrics: KPIs andMetrics in theContent Acceleration Packs Guide.

Related CAPs: CSA_Demo and CSA Content Acceleration Packs in theContent Acceleration Packs
Guide.
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Azure Data Source
Data source: "Integration with Azure" on page 101

KPIs andMetrics: KPIs andMetrics in theContent Acceleration Packs Guide.

Related CAPs: CSA_Demo and CSA Content Acceleration Packs in theContent Acceleration Packs
Guide.

Configuration Management System Data Source
Data source: "Integration with CMS" on page 112

KPIs andMetrics: KPIs andMetrics in theContent Acceleration Packs Guide.

Related CAPs: CMS_Demo and CMS Content Acceleration Packs in theContent Acceleration
Packs Guide.

Cloud Service Automation Data Source
Data source: "Integration with CSA" on page 118

KPIs andMetrics: KPIs andMetrics in theContent Acceleration Packs Guide.

Related CAPs: CSA_Demo and CSA Content Acceleration Packs in theContent Acceleration Packs
Guide.

Project and Portfolio Management Data Source
Data source: "Integration with PPM" on page 215

KPIs andMetrics: KPIs andMetrics in theContent Acceleration Packs Guide

Related CAPs: PPM_Demo and PPM Content Acceleration Packs in theContent Acceleration Packs
Guide

Server Automation Data Source
Data sources: "Integration with SA" on page 219

KPIs andMetrics: KPIs andMetrics in theContent Acceleration Packs Guide.

Related CAPs: SA_Demo and SA Content Acceleration Packs in theContent Acceleration Packs
Guide.

The Context includes the Node entity, so you can create a KPI based on that entity and then break it
down by service and/or application.
Do not create a Service to Application drill down or an Application to Service drill down.
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Service Manager Data Source
Data source: "Integration with SM" on page 223

KPIs andMetrics: KPIs andMetrics in theContent Acceleration Packs Guide.

Related CAPs: SM Content Acceleration Pack in theContent Acceleration Packs Guide.

Virtual Performance View
Data source: "Integration with vPV" on page 230

KPIs andMetrics: KPIs andMetrics in theContent Acceleration Packs Guide.

Related CAPs: CSA_Demo and CSA Content Acceleration Packs in theContent Acceleration Packs
Guide.

Content ReferenceGuide

HPE IT Business Analytics (10.00)
Monday, March 28, 2016- 6:55:41 AM Page 75 of 237



Integration with ALM
HP Application Lifecycle Management (ALM) empowers IT tomanage the core application life cycle,
from requirements through deployment, granting application teams the crucial visibility and
collaboration needed for predictable, repeatable, and adaptable delivery of modern applications. ALM
supports you through all phases of the application life cycle management. By integrating the tasks
involved in applicationmanagement,it enables you to better align IT with your business needs.

This section describes the integration, contexts, KPIs, Metrics, and reports, if any, associated with the
integration with the Application Lifecycle Management data source. The purpose of the integration of
ALM as a data source is to bring quality management information into the DataWarehouse.

The data warehouse is connected to ALM through high-level integration processes. A set of database
views enables the extraction of themain ALM objects.

Note: To locate ALM documentation in the HPE Manual Site, youmay have to input QC in the
search field.

To access:

Select ADMIN > Data Management > Connect Data Source then click Activate to activate the
integration processes for theALM data source.

Learn More

Content Packs and their functionality

To learn about Content Packs and their functionality, see Connect the Data Source in theAdministrator
Guide.

Important Information

l ALM supports multiple instances of the Content Pack.
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l DCS Integration: An extractor using the Data Collection Servicemechanism that extracts entities
from the source and generates corresponding flat files. For details, see Data Collection Service
(DCS) in theAdministrator Guide.

l All fields are case-sensitive.

ALM Adapter Limitations

l To control the data extraction page size from the DataWarehouse server side, set the
alm.page.size parameter to 1000 in%HPBA_
Home%/ContentPacks/ALM/EXTRACTOR/extractor-alm/settings.properties.

l The ALM Adapter transfers the relevant information from the ALM data source. In the ALM Site
Administration, select theSite Configuration tab andmake sure that the REST_API_MAX_
PAGE_SIZE configuration is at least 2000 pages. In the ALM activation page in ALM, the
alm.page.size setting should be equal to or less than the REST_API_MAX_PAGE_SIZE setting.

Tasks

This section includes:

Activate the Integration 77

Connect to ALM on a Secured Connection 78

ALM Customization 79

Consolidate Between ALM and PPM 80

Configure ALM Reopen Events 80

Configure ALM_PAGE_SIZE 81

ALM-Related KPIs andMetrics 84

Place Holder Mapping 84

Activate the Integration

1. Prerequisites:
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o Port 8080 / 8443must be available.

2. Select ADMIN > Data Management > Install Content Pack then click the install button
relevant for the data source.

3. Select ADMIN > Data Management > Connect Data Source then click Add data source.

4. The Add Data Source page opens. Select theALM data source type.

5. Select or enter the configuration parameters.

6. Click Next to proceed to the validation page.

Connect to ALM on a Secured Connection

1. Export the ALM SSL certificate to a file. For details, see the ALM Hardening Guide.

2. After the installation procedure is finished, reveal the ALM certificate to DataWarehouse, you
import the SSL certificate trusted by the ALM server into the JDK key store using the keytool.exe
tool provided by the JDK by running the command :

On the server side (glassfish): Run the <HP-BA>\jdk\jre\bin\keytool" -importcert -alias
<alias> -file <path_to_certificate>" –keystore "<JRE>\lib\security\cacerts" -trustcacerts -
storepass changeit command.

Example

"%HP_BA_Home%/jdk/jre/bin/keytool" -importcert -alias hpba -file

"c:\<HP-BA>\agora\jdk\jre\bin\keytool" -importcert -alias hpxs -file

"%HP_BA_Home%/vmbtoarnd09.cer" –keystore "%HP_BA_
Home%/jdk/jre/lib/security/cacerts" –trustcacerts –storepass changeit

3. Select the Is secured toggle-button in the activation parameters screen.

4. Change the port to a secured port (default is 8443).

Note:

l The default password for JVM keystore is changeit. If this password was not changed before,
use the default keystore password for certificate import.
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l In Connect Data Source, the specifiedmachine namemust be identical to the name of the
machine for which the certificate is issued.

ALM Customization

ALM DemandManagement provides system parameter fields. You can change name and data length
of these parameter fields in ALM DemandManagement, depending on your purpose and requirements.

To support all customers’ KPIs, all ALM customized fields of DemandManagement are populated to
the DataWarehouse and added as place holders in the universe. You can use these fields in BA KPI
formulas.

Related Dimension Tables and Views

Related Dimension Tables

l REQUIREMENT_PLHD_DIM

l PROJECT_PLHD_DIM

l DEFECT_PLHD_DIM

l TEST_PLHD_DIM

l TESTINSTANCE_PLHD_DIM

l TESTRUN_PLHD_DIM

l TESTSET_PLHD_DIM

Related Views

l REQUIREMENT_PLHD_DIM_V

l PROJECT_PLHD_DIM_V

l DEFECT_PLHD_DIM_V

l TEST_PLHD_DIM_V

l TESTINSTANCE_PLHD_DIM_V

l TESTRUN_PLHD_DIM_V

l TESTSET_PLHD_DIM_V
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Consolidate Between ALM and PPM

If you are integrating ALM and PPM data sources, the consolidation process between ALM and PPM
identifies ALM releases as child- projects of PPM projects.You canmapwhich release of the ALM
domain is connected to the specific PPM project. Themanual mappingmust be performed before
running ETL.

To configure ALM and PPM consolidation:

1. Navigate to%HP_BA_Home%/DataWarehouse/ExternalSources/ALM_RELEASE_
MAPPING.

2. Open the <External_Source_Folder>/ALM_RELEASE_MAPPING.csv file.

3.
Note: Do not remove the header row. In addition, if the spreadsheet has a dummy row under
the header row, do not edit or delete the dummy record. This record tells the ETL process
what data type to use when processing the column.

4. Save your additions and changes.

Configure ALM Reopen Events

You can configure a defect's reopen event by mapping which defect status changes can trigger a
reopen event. When you configure the file, all of these status changes aremarked as reopen events.
This allows for a dynamic configuration of reopen events mapping.

To configure reopen event mapping:

1. Navigate to%HPBA_HOME%/ContentPacks/ALM/EXTERNAL/DEFECT_REOPEN_
MAPPING.CSV.

2. Open the <External_Source_Folder>/ALM_DEFECT_REOPEN_MAPPING.csv file.

3. Enter the required defect status, for example, old_value = Fixed, new_value= Open. All records
that match this pattern will bemarked as reopen event.

4. Save your additions and changes.
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Note: Configurationmust be done prior to running ETL. If data is processed without this
configuration, no reopen events will be calculated (besides the out-of-the-box ones).

Configure ALM_PAGE_SIZE

In the ALM Site Administration, select the Site Configuration tab andmake sure the REST_API_MAX_
PAGE_SIZE configuration is at least 2000. I

Content ReferenceGuide

HPE IT Business Analytics (10.00)
Monday, March 28, 2016- 6:55:41 AM Page 81 of 237



UI Description

ALM Activation Page

The data warehouse is connected to ALM through high-level integration processes. A set of database
views enables the extraction of themain ALM objects.

Mandatory fields aremarked with a red asterisk.
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User interface elements are described below:

UI Element Description

Instance name Enter a name for the data source instance you are activating.

ALM Version Select the relevant version. For details, see theSupport Matrix.

Time Zone Select the time zone for the data source.

Data Source
Type

Select the data source type.

Username Enter the username used to log on to ALM.

Password Enter the password used to log on to ALM.

Hostname/IP
Address

Enter the hostname of the server on which ALM is installed.

Note: In the case of SSL secured connection, the server hostnamemust be
identical to the name to which the certificate was issued.

Port Enter the server port number.

Default port for http protocol: 80

Default port for https protocol: 443

Is Secured Select the option to use the https protocol.

Default protocol is http.

Domain,Project Enter the domain and project pair, separated by a semicolon ";".

Example domain1,project1;domain2,project2;domain3,project3.

A * represents all projects. For example: domain1,*;domain2,project2. This
means the ALM extractor extracts all projects under domain1, and only project2
under domain2.

Note: If you do not specify the domain and project pair, the ETL extracts
data from all domains and projects.

Initial Load
Period
(months)

Select the number of months from which you want the initial data loaded.
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Reference

ALM-Related KPIs and Metrics

For a list of the ALM-related KPIs andMetrics, see KPIs andMetrics in theContent Acceleration
Packs Guide.

Place Holder Mapping

The place holder entities: DEFECT_PLHD, REQUIREMENT_PLHD, PROJECT_PLHD columns are
listed below with their corresponding context columns:

DEFECT_PLHD

DEFECT_PLHD.BG_USER_05 OpenClose

DEFECT_PLHD.BG_USER_06 SecurityImpact

DEFECT_PLHD.BG_USER_14 LastDate

DEFECT_PLHD.BG_USER_15 CloseInDate

DEFECT_PLHD.BG_USER_16 OpenInDate

DEFECT_PLHD.BG_USER_22 NewInDate

DEFECT_PLHD.BG_USER_24 FixedInDate

DEFECT_PLHD.BG_USER_27 GlobalID

DEFECT_PLHD.BG_USER_34 DevelopmentEngineer

DEFECT_PLHD.BG_USER_36 InvestigationEngineer

DEFECT_PLHD.BG_USER_41 SourceIncidentID

DEFECT_PLHD.BG_USER_43 IssueType

DEFECT_PLHD.BG_USER_44 CustomerCompany

DEFECT_PLHD.BG_USER_45 CustomerEmail

DEFECT_PLHD.BG_USER_63 ResolutionNote

DEFECT_PLHD.BG_USER_64 CustomerNote
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DEFECT_PLHD.BG_USER_71 ReopenCount

DEFECT_PLHD.BG_USER_83 Regression

DEFECT_PLHD.BG_USER_84 EscalationStatus

DEFECT_PLHD.BG_USER_89 Workaround

DEFECT_PLHD.BG_USER_95 Team

PROJECT_PLHD

PROJECT_PLHD.REL_USER_04 ReleaseState

PROJECT_PLHD.REL_USER_05 PRS_ID

PROJECT_PLHD.REL_USER_06 PRS_MR_Date

PROJECT_PLHD.REL_USER_10 ReleaseType

REQUIREMENT_PLHD

REQUIREMENT_PLHD.RQ_USER_52 EstimatedCompletedDate

REQUIREMENT_PLHD.RQ_USER_50 ActualCompletedDate

REQUIREMENT_PLHD.RQ_USER_01 Status

REQUIREMENT_PLHD.RQ_USER_20 Team

REQUIREMENT_PLHD.RQ_USER_44 QAStatus

REQUIREMENT_PLHD.RQ_USER_47 ActualStartDate

REQUIREMENT_PLHD.RQ_USER_49 ActualEndDate

REQUIREMENT_PLHD.RQ_USER_48 ActualImpDate
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Integration with AM
Asset Management helps you tomanage your assets across procurement, active lifecycle, and
disposals so you can optimize end-to-end asset usage for optimal value and lower costs.

The AM integration uses the SAP BusinessObjects Data Services drivers for data store connections.

This section describes the integration, contexts, KPIs, Metrics, and reports, if any, associated with the
integration with the Asset Manager data source.

The Asset Manager (AM) content pack enables you to receive data information from the
AM application. AM is a fully integrated suite of modules delivered as part of the ServiceManagement
Center software package. AM softwaremanages the physical, virtual, financial, and contractual
aspects of assets.

Note: Information about the ALT data source andmore general content issues are detailed in the
Content ReferenceGuide.

To access:

Select ADMIN > Data Management > Connect Data Source then click Add data source and select
AM to activate the integration processes for theAM data source.

Learn More

Content Packs and their functionality

To learn about Content Packs and their functionality see, Connect the Data Source in theAdministrator
Guide.

Important Information

l The AM Content Pack supports multiple instances.

l DCS Integration: An extractor using the Data Collection Servicemechanism that extracts entities
from the source and generates corresponding flat files. For details, see Data Collection Service
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(DCS) in theAdministrator Guide.

l All fields are case-sensitive.

Tasks

Activate the integration

1. Prerequisite:

The AM data source can have either the Oracle or the SQL Server type.

2. Activate the AM Data Source:

a. Select ADMIN > Data Management > Connect Data Source then click Add data source.

b. The Add Data Source page opens. Select theAM data source type.

c. Select or enter the configuration parameters.

d. Click Next to proceed to the validation page.

Note: The system does not support changing theData Source Type, therefore youmust
select the relevant type, SQL or Oracle, before activation.

UI Description

AM Activation Page

The data warehouse is connected to Asset Manager through high-level integration processes.

User interface elements are described below:
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For the SQL server:

The following is an example of the AM Activation page when the database backup of Asset Manager is
restored on an SQL Server.

Mandatory fields aremarked with a red asterisk.

UI Element Description

Instance name Enter a name for the data source instance you are activating.

AM Version Select the relevant AM version. For details, see theSupport Matrix.

Time Zone Select the time zone for the data source.
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UI Element Description

Data Source Type AM should be configured to run on an SQL Server.

Username Enter the username used to log on to the AM database.

Password Enter the password used to log on to the AM database.

Hostname/IP Address Enter the SQL server database hostname or IP address.

Port Enter the server port number.

Database Name Enter the database name used by AM.

Initial Load Period
(months)

Select the number of months from which you want the initial data
loaded.
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For the Oracle Server:

The following is an example of the AM Activation page when the database backup of Asset Manager is
restored on anOracle Server.

Mandatory fields aremarked with a red asterisk.

Note: TheOracle database can have both Server ID (SID) and Service Name properties, but the
user should specify only one. If you define the SID, then the SID is used, and if you define Service
Name, then Service Name is used. If you define both in the UI, only SID is used.
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UI Element Description

Instance name Enter a name for the data source instance you are activating.

AM Version Select the relevant AM version. For details, see theSupport Matrix.

Time Zone Select the time zone for the data source.

Data Source Type AM should be configured to run on anOracle server.

Username Enter your username used to log on to the AM database.

Password Enter your password used to log on to the AM database.

Hostname/IP
Address

Enter the Oracle server hostname or IP address.

Port Enter the server port number.

SID Enter the unique name of the database.

Service Name Enter the alias used when connecting.

Initial Load Period
(months)

Select the number of months from which you want the initial data loaded.

Reference

AM-Related KPIs andMetrics

For a list of the AM-related KPIs andMetrics, see KPIs andMetrics in theContent Acceleration Packs
Guide.

Integration with AWS
This section describes the integration, contexts, KPIs, Metrics, and reports, if any, associated with the
integration with the AmazonWeb Services data source.

AmazonWeb Services (AWS) offers a complete set of infrastructure and application services that
enable you to run virtually everything in the cloud: from enterprise applications and big data projects to
social games andmobile apps. One of the key benefits of cloud computing is the opportunity to replace
up-front capital infrastructure expenses with low variable costs that scale with your business.

The purpose of the integration of AWS as a data source is to bring AWS information into the Data
Warehouse.

To access:
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Select ADMIN > Data Management > Connect Data Source then click Add data source and select
AWS to activate the integration processes for theAWS data source.

Learn More

Cloud Optimization Offering

The CloudOptimization offering includes integrations with:

l Amazon Web Services (AWS). For details see Integration with AWS in theContent Reference
Guide.

l Amazon Web Service CloudWatch(AWSCW). For details see Integration with AWSCW in the
Content ReferenceGuide.

l Cloud Service Automation (CSA). For details see Integration with CSA in theContent Reference
Guide.

Content Packs and their functionality

To learn about Content Packs and their functionality, see Connect the Data Source in theAdministrator
Guide.

Important Information

l The AWS Content Pack supports multiple instances.

l DCS Integration: An extractor using the Data Collection Servicemechanism that extracts entities
from the source and generates corresponding flat files. For details, see Data Collection Service
(DCS) in theAdministrator Guide.

l All fields are case-sensitive.

l The AWS DCS extraction of the csv file from the S3 bucket uses a properties file along with the
datasource.xml file. It is available once the AWS content pack is deployed under: $HPBA_
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Home/ContentPacks/AWS/conf.

The properties file defines fixed csv properties, such as the csv file name, suffix, time format, filters
in csv file, delayDay, and can bemodified.

l AWS proxy parameters are optional in a public network.

l

Tip: If you integrate with both CSA and AWS/AWSCW, youmust run the AWS/AWSCW ETL
before the CSA ETL. If you do not run the ETL as recommended, youmust wait for the end of
the CSA ETL run to view the correct data.

l The cloud-related reports (Dashboard pages) provided in the CSA_CAP and CSA_Demo_
CAP CAPs combine integrated data from the following data sources Cloud Service Automation
(CSA), AmazonWeb Services (AWS), AmazonWeb Service CloudWatch (AWSCW)

For details, see CSA_Demo and CSA Content Acceleration Packs in theContent Acceleration
Packs Guide.

Tasks

Activate the Integration

1. Select ADMIN > Data Management > Install Content Pack then click the install button
relevant for the data source.

2. Select ADMIN > Data Management > Connect Data Source then click Add data source.

3. The Add Data Source page opens. Select theAWS data source type.

4. Select or enter the configuration parameters.

5. Click Next to proceed to the validation page.
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UI Description

AWS Activation Page

The following is an example of the AWS Activation page.
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User interface elements are described below:

Note: If the AWS configuration is for a named instance connection, make sure to enter the named
instance port.

UI Element Description

Instance name Enter a name for the data source instance you are activating.

AWS Version This parameter is Not Applicable.

Time Zone PST only

Data Source Type AWS. This parameter is read only.

Access Key Id Enter the AWS access key ID.

Secret Access Key Enter the AWS secret access key.

Bucket Enter the AWS S3 bucket namewhich was specified when you set up the
Programmatic Billing Access.

Account Id Enter the AWS account ID.

Proxy Host Enter the proxy host name.

Proxy Port Enter the proxy port number.

Proxy Username Enter the proxy username used to log on to the network.

Proxy Password Enter the proxy password used to log on to the network.

Proxy Domain Enter the proxy domain.

Proxy Workstation Enter the proxy workstation.

Initial Load Period
(months)

Select the number of months from which you want the initial data loaded.

Reference

AWS-Related KPIs and Metrics

The KPIs andMetrics related to the AmazonWeb Services data source are provided in the CSA and
CSA_DemoCAPs. For details, see CSA_Demo and CSA Content Acceleration Packs in theContent
Acceleration Packs Guide.
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Integration with AWSCW
This section describes the integration, contexts, KPIs, Metrics, and reports associated with the
integration with the AmazonWeb Service CloudWatch data source.

Amazon CloudWatch (AWSCW)monitors your AmazonWeb Services resources and the applications
you run on AWS in real-time. You can use CloudWatch to collect and track metrics, which are the
variables you want to measure for your resources and applications. CloudWatch alarms send
notifications or automatically make changes to the resources you aremonitoring based on rules that
you define. For example, you canmonitor the CPU usage and disk reads and writes of your Amazon
Elastic Compute Cloud (Amazon EC2) instances and then use this data to determine whether you
should launch additional instances to handle increased load. You can also use this data to stop under-
used instances to savemoney. In addition tomonitoring the built-in metrics that comewith AWS, you
canmonitor your own custommetrics. With CloudWatch, you gain system-wide visibility into resource
utilization, application performance, and operational health.

The purpose of the integration of AWSCW as a data source is to bring this information into the Data
Warehouse.

To access:

Select ADMIN > Data Management > Connect Data Source then click Add data source and select
AWSCW to activate the integration processes for theAWSCW data source.

Learn More

Cloud Optimization Offering

The CloudOptimization offering includes integrations with:

l Amazon Web Services (AWS). For details see Integration with AWS in theContent Reference
Guide.

l Amazon Web Service CloudWatch(AWSCW). For details see Integration with AWSCW in the
Content ReferenceGuide.
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l Cloud Service Automation (CSA). For details see Integration with CSA in theContent Reference
Guide.

Content Packs and their functionality

To learn about Content Packs and their functionality, see Connect the Data Source in theAdministrator
Guide.

Important Information

l The AWSCW Content Pack supports multiple instances.

l DCS Integration: An extractor using the Data Collection Servicemechanism that extracts entities
from the source and generates corresponding flat files. For details, see Data Collection Service
(DCS) in theAdministrator Guide.

l All fields are case-sensitive.

l The AWSCW DCS extracts themetric data from AmazonWeb Service CloudWatch and uses it as
a properties file along with the datasource.xml file. It is available once the AWSCW content pack is
deployed under:%HPBA_Home%/ContentPacks/AWSCW/conf.

The properties file defines the rule to extract themetrics data, such as criteriaTimeFormat,
dimensionDelimiter, valueDelimiter, period, andminimumScope. Generally, the value of the
period is changed to define the frequency of metrics data.

l AWSCW proxy parameters are optional in a public network.

l

Tip: If you integrate with both CSA and AWS/AWSCW, youmust run the AWS/AWSCW ETL
before the CSA ETL. If you do not run the ETL as recommended, youmust wait for the end of
the CSA ETL run to view the correct data.

l The cloud-related reports (Dashboard pages) provided in the CSA_CAP and CSA_Demo_
CAP CAPs combine integrated data from the following data sources Cloud Service Automation
(CSA), AmazonWeb Services (AWS), AmazonWeb Service CloudWatch (AWSCW)

For details, see CSA_Demo and CSA Content Acceleration Packs in theContent Acceleration
Packs Guide.
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Tasks

Activate the Integration

1. Select ADMIN > Data Management > Install Content Pack then click the install button
relevant for the data source.

2. Select ADMIN > Data Management > Connect Data Source then click Add data source.

3. The Add Data Source page opens. Select theAWSCW data source type.

4. Select or enter the configuration parameters.

5. Click Next to proceed to the validation page.
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UI Description

AWSCW Activation Page

The following is an example of the AWSCW Activation page.

User interface elements are described below:
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UI Element Description

Instance name Enter a name for the data source instance you are activating.

Note: If the AWSCW configuration is for a named instance connection,
make sure to enter the named instance port.

AWSCW Version This parameter is Not Applicable.

Time Zone UTC only.

Data Source Type AWSCW. This parameter is read only.

Access Key Id Enter the AWS access key ID.

Secret Access
Key

Enter the AWS secret access key.

Proxy Host Enter the proxy host name.

Proxy Port Enter the proxy port number.

Proxy Username Enter the proxy username used to log on to the network.

Proxy Password Enter the proxy password used to log on to the network.

Proxy Domain Enter the proxy domain.

Proxy
Workstation

Enter the proxy workstation.

Initial Load
Period (months)

14 days.

AWS CloudWatch stores only 14 days data.

Reference

AWSCW-Related KPIs and Metrics

The KPIs andMetrics related to the AmazonWeb Service CloudWatch data source are provided in the
CSA and CSA_DemoCAPs. For details, see CSA_Demo and CSA Content Acceleration Packs in the
Content Acceleration Packs Guide.
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Integration with Azure
Azure is Microsoft cloud computing platform, a growing collection of integrated services like analytics,
computing, database, mobile, networking, storage, and web, for moving faster, achievingmore, and
savingmoney.

The purpose of the integration of Azure as a data source is to bring Azure information into the Data
Warehouse.

The integration with Azure provides a general idea on how muchmoney is spent on each Virtual
Machine daily by different usage types. In addition, if the diagnostics function is enabled, you can also
view the CPU utilization andMemory.

The data extracted from Azure is correlated to the data available in the KPIs and reports available in the
CSA CAP. For details, see CSA_Demo and CSA Content Acceleration Packs in theContent
Acceleration Packs Guide.

To access:

Select ADMIN > Data Management > Connect Data Source then click Add data source and select
Azure to activate the integration processes for the Azure data source.

Learn More

Content Packs and their functionality

To learn about Content Packs and their functionality, see Connect the Data Source in theAdministrator
Guide.

Important Information

l The Azure Content Pack supports multiple instances.

l DCS Integration: An extractor using the Data Collection Servicemechanism that extracts entities
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from the source and generates corresponding flat files. For details, see Data Collection Service
(DCS) in theAdministrator Guide.

l All fields are case-sensitive.

l Azuremust be activated with the CSA data source. If you activate Azure alone, only the cost fact
information is displayed, without the ability to drill down further.

Azure Usage Data.

For performance reasons, the ETL job extracts only, at most, 1 month of data for the initial and delta
loads.

Utilization Data.

For performance reasons, the ETL job extracts only, at most, 1 week of data for the initial and delta
loads.

Azure utilization data is based on the latest Microsoft Azure preview portal function. Make sure you
switch on Diagnostic for theMicrosoft Azure Cloud VM instances, to have utilization data returned by
theMicrosoft Azure Cloud Service API.

Limitation:

l You can create Virtual Machines, storage, web apps, and a lot of other components with one
subscription ID under a global account of Azure. If the Virtual Machine type is Windows, BA
can obtain the name of the Cloud Services and provide its utilization data. If the Virtual Machine
type is Linux, BA cannot obtain the name of the Cloud Services and provide its utilization data.
The impact is on the SERVICE_PROVIDER_UTILIZATION_FACT entity.

l In Azure, you can enter your VM namewhen creating the VMs, and it is possible to use the
same VM name for different Cloud Services. Due to the above limitation, the deployment ID is
not displayed in the storage table, making it impossible to know the VM from which themetric
data originates. So it is recommended not to create VMs with the same name.

l When using CSA with Azure Content Pack version: 14.12, and the OOTB design : CSL_BP_
MICROSOFT_AZURE_COMPUTE_3.20_CP3.0, Azure usage related data is displayed in the
CSA-Resource Usage and Utilization for Consumer andCSA_Resource Usage and
Utilization for Resource Supplier Manager reports, but Azure CPU utilization data is not
available and is not displayed in these reports.

Content ReferenceGuide

HPE IT Business Analytics (10.00)
Monday, March 28, 2016- 6:55:44 AM Page 102 of 237



Tasks

This section includes:

Create an application in Azure portal 103

Assign permission to subscriptions in the Azure portal 106

Create the certificate and bind all subscriptions 107

Activate the Integration 109

Create an application in Azure portal

1. To create an application in the Azure portal, open: https://manage.windowsazure.com/ and click
ACTIVE DIRECTORY > Default Directory > APPLICATIONS > ADD > Add an application
my organization is developing.
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2. Click <Application_just_created> > CONFIGURE > keys > Select Duration > Save to get the
key as App password; and the CLIENT ID as App id. They are used when configuring the data
source in ITBA.
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Assign permission to subscriptions in the Azure portal

1. To assign permissions to subscriptions in the Azure portal, open: https://portal.azure.com/ and
click Subscriptions , select the relevant subscription for which the customer wants to view data
in ITBA, click Access (Roles) > Reader .
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2. Click Add and select the application that the customer created for ITBA and click Select.

Note: If, in ITBA, you want to view data frommultiple subscriptions youmust assign the
permissions to each subscription separately using the above procedure.

Create the certificate and bind all subscriptions

1. Generate a self-signed certificate using the JDK keytool:

a. After ITBA is installed, log on to the ITBA Linux server and use the following command in the
command line to generate the certificate:

cd $HPBA_HOME/jdk/bin

keytool -genkey -keyalg RSA -keystore <certificatename>.jks -keysize 2048

where <certificatename> is the name of the certificate you want to create.
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b. Enter the keystore password and the requested information.

c. Convert <certificatename>.jks to <certificatename>.cer and <certificatename>.pfx. using
the following command:

keytool -importkeystore -srckeystore <certificatename>.jks -srcstoretype JKS -

destkeystore <certificatename>.pfx -deststoretype PKCS12

d. Enter destination keystore password. Remember this password which will be used in the
Connect to Data Source page.

Use the same password for destination keystore and source keystore.

e. Enter the following command:

keytool -export -file <certificatename>.cer -keystore <certificatename>.jks

Enter the keystore password.
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2. In the AzureManagement Portal accessed via https://manage.windowsazure.com/, select
SETTINGS > MANAGEMENT CERTIFICATES > UPLOAD.

3. Upload <certificatename>.cer for each subscriptions.

Activate the Integration

1. Select ADMIN > Data Management > Connect Data Source then click Add data source.

2. The Add Data Source page opens. Select the Azure data source type.

3. Select or enter the configuration parameters.

4. Click Next to proceed to the validation page.

Note: If you want to display Azure utilization data returned by theMicrosoft Azure Cloud Service
API, make sure you switch on Diagnostic for theMicrosoft Azure Cloud VM instances.
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UI Description

Azure Activation Page

The following is an example of the Azure Activation page.
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User interface elements are described below:

UI Element Description

Instance
name

Enter a name for the data source instance you are activating.

Azure
Version

Select the relevant Azure version. For details, see theSupport Matrix.

Time Zone Time zonemust be UTC.

Data
Source
Type

GENERIC. This parameter is read only.

Tenant ID The unique ID of the organization in Azure AD that has granted access for your app.

APP ID The unique identifier for your application. Youmust use this if your application
accesses data in another application, such as theMicrosoft Azure AD Graph API.

Input the CLIENT ID that you obtain after creating the relevant application in the
Azure portal.

Note: In Azure, oneGlobal ID can havemultiple subscriptions. To get
consumption data for an Azure subscription, APP ID is required. If you want to
get consumption data for all subscriptions under the Global ID, all subscriptions
are required to be authorized for the same APP ID, which will be added to the
DCS page.

APP
Password

If your app reads or writes data from/to Microsoft Azure AD, such as data that is
made available through theGraph API, your app need a key. The APP Password is
the key that you obtain after creating the relevant application in the Azure portal.

Certificate Once you have created amanagement certificate, (a .cer file with only the public key)
you can upload it into the portal. When the certificate is available in the portal, anyone
with amatching certificate (private key) can connect through theManagement API
and access the resources for the associated subscription.

The absolute path to the .pfx certification file on the ITBA Linux server. For example,

/home/ITBA/Azure_certification.pfx.

Certificate
Password

The keystore password of the .pfx certification.

Proxy Host The proxy host.

Proxy Port The proxy port.

Proxy
Username

The Proxy user name.
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UI Element Description

Proxy
Password

The Proxy password.

Proxy
Domain

The Proxy domain.

Proxy
Workstation

The Proxy workstation.

Initial Load
Period
(month)

Select the number of months from which you want the initial data loaded.

The Initial load period is 1month for usage and 1 week for utilization.

Reference

Azure-Related KPIs and Metrics

The KPIs andMetrics related to the Azure data source are provided in the CSA and CSA_DemoCAPs.
For details, see CSA_Demo and CSA Content Acceleration Packs in theContent Acceleration Packs
Guide.

Integration with CMS
HPE ConfigurationManagement System (CMS) comprises three components: UCMDB, Discovery,
and ConfigurationManager. The UCMDB reconciles data frommultiple discovered and federated
sources into one data set, model your business services, calculate the potential impact of changes
within these services, track changes for any configuration item, and contains reporting capabilities to
transform CMDB data into comprehensible, actionable information that helps answer critical questions
and solve business problems. HPE Universal Discovery (UD) software is used by UCMDB to acquire
andmaintain application and IT infrastructure data. ConfigurationManager makes it possible to analyze
IT environments in order to move toward fewer standards and improve IT management processes. This
helps you improve data quality in your configurationmanagement system (CMS), avoid single points of
failure, achieve geographic redundancy of applications and drive changes based on configuration
standards.

This section describes the integration, contexts, KPIs, Metrics, and reports, if any, associated with the
integration with the ConfigurationManagement System data source.

The purpose of the integration of ConfigurationManagement System (CMS) as a data source is to bring
quality management information into the DataWarehouse.
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To access:

Select ADMIN > Data Management > Connect Data Source then click Add data source and select
CMS to activate the integration processes for theCMS data source.

Learn More

Content Packs and their functionality

To learn about Content Packs and their functionality see, Connect the Data Source in theAdministrator
Guide.

DCS Integration:

An extractor using the Data Collection Servicemechanism that extracts entities from the CMS source
and generates corresponding flat files using the TQL query language. For details, see Connect the Data
Source in theAdministrator Guide.

Important Information

l CMS supports multiple instances of the Content Pack.

l All fields are case-sensitive.

Tasks

Activate the integration

1. Activate the CMS Data Source:

a. Select ADMIN > Data Management > Connect Data Source then click Add data source.

b. The Add Data Source page opens. Select theCMS data source type.
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c. Select or enter the configuration parameters.

d. Click Next to proceed to the validation page.

Note: The system does not support changing theData Source Type, therefore youmust
select the relevant type: CAC or non-CAC, before activation.

Note: Before reactivating the CMS data source, click Edit Settings and enter theUsername
andPassword.

Connect to CMS on a Secured Connection

1. Export the CMS SSL certificate to a file. For details, see the CMS Hardening Guide available in
the HPE Software Support Online web site
(https://softwaresupport.hp.com/group/softwaresupport/home).

2. If you have selected CAC, perform this step, otherwise go to the next step.

To reveal the CMS certificate to DataWarehouse, import the SSL certificate trusted by the CMS
server into the JDK key store using a tool provided by the JDK called keytool.exe by running the
command :

$HPBA_Home/dk/jre/bin/keytool -importcert -alias <alias> -file <file> -keystore
%HPBA_Home%/jdk/jre/lib/security\cacerts -trustcacerts

Note: The default password for JVM keystore is a 'changeit'. If this password wasn't
changed before, use the default keystore password for certificate import.

3. Restart the ITBA server.

4. Select Is secured in the activation parameters page.

Is secured unchecked with NON CAC still works.

5. Change the port to a secured port. Default port is 8080. Secured default port is 8443, CAC default
port is 8444.

UI Description

CMS Activation Page
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The data warehouse is connected to ConfigurationManagement System through high-level integration
processes.

l Non CAC Access:

Mandatory fields aremarked with a red asterisk.
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l CAC Access:

UI Element Description

Instance name Enter a name for the data source instance you are activating.

CMS Version Select the relevant CMS version. For details, see theSupport Matrix.

Time Zone Select the time zone for the data source.

Data Source Type CMS.

Access Type Select CAC orNon CAC
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UI Element Description

Certificate/User
Name

If you select CAC, the field is displayed as Certificate. Enter the name of
the certificate.

If you select Non CAC, the field displayed as User Name. Enter the name
of the user used to access the UCMDB server.

Password If you select CAC, enter the password of the UCMDB server's certificate
file.
If you select Non CAC, enter the password of the user used to access the
UCMDB server.

Is Secured Select to use https to get data.

Unselect to use http to get data.

Hostname/IP
Address

Enter the CMS hostname or IP address.

Port Enter the server port number.

Customer Name Used for multi-customer purposes. If no user name is given, thenDefault
Client is displayed.

Initial Load Period
(months)

Select the number of months from which you want the initial data loaded.

Reference

CMS-Related KPIs andMetrics

For a list of the CMS-related KPIs andMetrics, see KPIs andMetrics in theContent Acceleration
Packs Guide.
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Integration with CSA
Cloud Service Automation (CSA) is a platform that orchestrates the deployment of computation and
infrastructure resources and of complex multi-tier application architectures. HP CSA integrates and
leverages the strengths of a hybrid cloud environment, providing the ability to design and deploy
enterprise-ready cloud services tailored to the business needs of your organization. It works through a
catalog-based subscription process. Subscribers request andmodify cloud service offerings with pre-
defined pricing and other customer-specific features. Once the request is approved, through a policy-
driven process, HP CSA deploys the cloud service offering using a structured lifecycle with pre-defined
integrationmechanisms for invoking external processes.

The integration with CSA as new content pack provides reporting analysis based on CSA datamodel.

The purpose of the integration of CSA as a data source is to bring this information into the Data
Warehouse.

This section describes the integration, contexts, KPIs, Metrics, and reports, if any, associated with the
integration with specific data sources.

To access:

Select ADMIN> Data Management > Connect Data Source then click Add data source and select
CSA to activate the integration processes for theCSA data source.

Learn More

Cloud Optimization Offering

The CloudOptimization offering includes integrations with:

l Amazon Web Services (AWS). For details see Integration with AWS in theContent Reference
Guide.

l Amazon Web Service CloudWatch(AWSCW). For details see Integration with AWSCW in the
Content ReferenceGuide.

HPE IT Business Analytics (10.00)
Monday, March 28, 2016- 6:55:51 AM Page 118 of 237



l Cloud Service Automation (CSA). For details see Integration with CSA in theContent Reference
Guide.

Other Data Sources

The data from the below data sources is integrated with the data from CSA and displayed in the CSA
CAP pages, KPIs, andMetrcs. For details, see CSA_Demo and CSA Content Acceleration Packs in
theContent Acceleration Packs Guide.

l AmazonWeb Services (AWS) offers a complete set of infrastructure and application services that
enable you to run virtually everything in the cloud: from enterprise applications and big data projects
to social games andmobile apps. One of the key benefits of cloud computing is the opportunity to
replace up-front capital infrastructure expenses with low variable costs that scale with your
business.

The integration with AWS provides cost and usage reports based on the cost allocation report
provided by AWS account.

l Amazon CloudWatch (AWSCW)monitors your AmazonWeb Services resources and the
applications you run on AWS in real-time. You can use CloudWatch to collect and track metrics,
which are the variables you want to measure for your resources and applications. CloudWatch
alarms send notifications or automatically make changes to the resources you aremonitoring based
on rules that you define. For example, you canmonitor the CPU usage and disk reads and writes of
your Amazon Elastic Compute Cloud (Amazon EC2) instances and then use this data to determine
whether you should launch additional instances to handle increased load. You can also use this
data to stop under-used instances to savemoney. In addition tomonitoring the built-in metrics that
comewith AWS, you canmonitor your own custommetrics. With CloudWatch, you gain system-
wide visibility into resource utilization, application performance, and operational health.

l Azure is Microsoft cloud computing platform, a growing collection of integrated services like
analytics, computing, database, mobile, networking, storage, and web, for moving faster, achieving
more, and savingmoney.

l Virtual Performance Viewer (vPV) is a web-based analysis and visualization tool that analyzes
performance trends of elements in virtualized environments. vPV gives you at-a-glance visibility
across your virtual environment for real-time insights into performance, capacity, and health. This
helps you to optimize your infrastructure and quickly solve virtualization and cloud performance
issues. It enables virtualizationmonitoring by providing an overview of the environment, near-real-
time and historical data analysis and triaging using an interactive dashboard. It also enables
monitoring for cloud and hypervisor environments. HPE vPV provides performancemonitoring,
graphing, and reporting in a single interface.
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Important Information

l To learn about Content Packs and their functionality, see Connect the Data Source in the
Administrator Guide.

l The CSA Content Pack supports multiple instances.

l All fields are case-sensitive.

l The CSA ETL job aggregates the CSA Subscription Price with a daily granularity in the target
database. This means that the ETL job gets the price from CSA, converts it into the actual cost
according to the ETL running date, generates a cost record for that day, and stores it in the target
database. For example, if the current date is April 22nd, for themonth of April, after the ETL run has
completed, you see a total of the 22 aggregated records of the CSA subscription Price in the target
database.

l

Example of a CSA subscription price calculation: If, for example, the price of one daily
subscription is $10, you have just used the subscription for 12 hours, and the ETL starts to run
at this moment, the total you have to pay is 10*12/24=$5. The CSA subscription price is
calculated for the real usage accurate to the second. Though some customers would prefer to
see $10 on the report even if the usage is not yet 24 hours, BA displays $5 after the ETL load
because it represents the real usage.

l DCS Integration: An extractor using the Data Collection Servicemechanism that extracts entities
from the source and generates corresponding flat files. For details, see Data Collection Service
(DCS) in theAdministrator Guide.

l

Tip: If you integrate with both CSA and AWS/AWSCW, youmust run the AWS/AWSCW ETL
before the CSA ETL. If you do not run the ETL as recommended, youmust wait for the end of
the CSA ETL run to view the correct data.

l The CSA and CSA_DemoCAPs are associated with the CSA data source, its context, KPIs, and
Metrics. For details, see the CSA_Demo and CSA Content Acceleration Packs in theContent
Acceleration Packs Guide.

l When using CSA with Azure Content Pack version: 14.12, and the OOTB design : CSL_BP_
MICROSOFT_AZURE_COMPUTE_3.20_CP3.0, Azure usage related data is displayed in the
CSA-Resource Usage and Utilization for Consumer andCSA_Resource Usage and
Utilization for Resource Supplier Manager reports, but Azure CPU utilization data is not
available and is not displayed in these reports.
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Tasks

This section includes:

Change the default exchange rate of each currency 121

Configure the BA Website Browser SSL 122

Import the CSA SSL certificate to BA keystore 133

Install the Content Pack 141

Activate the CSA data source 141

Execute the ETL process 146

Activate the relevant CSA CAP 147

Calculate the KPI 148

Configure the Cloud Analytic Tiles in the Provider Portal 150

Support CSA Multiple Currency for Service Offering 155

Configure the Showback report for the Consumer Organization Administrator 155

CSA-Related KPIs andMetrics 181

Customize CSA Service Designer for AmazonWeb Service Resource Provider 182

Change the default exchange rate of each currency

To help you convert the billing amount to different currencies, ITBA has pre-configured their default
exchange rates.

If you want to change the default exchange rate of each currency, open the $HPBA_
HOME/ContentPacks/CSA/EXTERNAL/EXCHANGE.csv file and change the rates.
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Configure the BA Website Browser SSL

1. Log on to BA, and click Continue to this website (not recommended).

2. Click Certificate error and then click View certificates.

3. Click theDetails tab and click Copy to File …
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Click Next.
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Click Next.
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Click theBrowse... button and give a file name, such as CSA45.cer, and click Next.
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Click the Finish button.
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4. Open the Internet Options > Content and click Certificates.
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5. Open the Trusted Root Certification Authorities and click Import… link.
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6. Select the relevant certificate file and click Import.

7. Click Next.
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8. Click Yes.
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9. Open your browser and reopen the BA logon page.
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Import the CSA SSL certificate to BA keystore

1. Export the CSA SSL certificate:

a. Access the CSA portal from the browser of the BA server.
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b. Click the red cross in the URL bar and then click Certificate information.

Content ReferenceGuide

HPE IT Business Analytics (10.00)
Monday, March 28, 2016- 6:55:55 AM Page 134 of 237



c. In the window that pops up, click theDetails tab, and click theCopy to File…button.
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d. In the window that pops up, click Next.
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e. Click Next.
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f. Specify the name of the file you want to export and click Next.
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g. In the next page, click Finish.

The CSA SSL cert file is now exported.

In the above example, the file is located at C:\software\csa-certificate_
fromExplorer.cer%HPBA_Home%/software/csa-certificate_fromExplorer.cer.

2. Open a command prompt and run the following commands:

o In Linux:

keytool -importcert -alias csa -file %HPBA_Home%/software/csa-certificate_
fromExplorer.cer -keystore %HPBA_Home%/jdk/jre/lib/security/cacerts -trustcacerts

o InWindows:

cd <HPBA_Home>\jdk\jre\bin
keytool –importcert –alias csa –file “c:/Software\csa-certificate_fromExplorer.cer” –
keystore C:/%HPBA_Home%/jdk/jre/lib/security/cacerts –trustcacerts
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a. When prompted for the keystore password, type changeit.

b. When prompted to trust this certificate, type yes.

c. Restart theHP IT Business AnalyticsService from Services Windows admin tools.

d. Run%HPBA_Home%/supervisor/bin/hpba-restart.sh to restart BA.

e. Wait a few minutes for the services to fully start.
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Install the Content Pack

1. Make sure you have imported the CSA SSL Certificate (see above).

2. Log on to the BA application.

3. Click ADMIN > Data Management, click Install Content Pack to install the CSA Content Pack.
For details, see Install Content Pack.

Activate the CSA data source

1. Make sure you have imported the CSA SSL Certificate (see above).

2. Log on to the BA application.

3. Make sure you have installed the Content Pack (see above).

4. Click ADMIN > Data Management and the click Connect Data Source .
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5. Click Add data source.
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6. Select the CSA data source type and press Next.
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If theNext button does not appear in theWizard dialog box, click the edge of the Data Source
Wizard and when the black cross appear, move the window upwards until you see theNext
button.

User interface elements are described below:

Note: If the CSA configuration is for a named instance connection, make sure to enter the
named instance port.
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UI Element Description

Instance name Enter a name for the data source instance you are activating.

CSA Version Select the relevant version. . For details, see theSupport Matrix.

Time Zone Select the time zone for the data source.

Data Source Type CSA

This parameter is read only.

Organization Name Enter the Organization Name that is necessary to retrieve admin
details.

The default value is CSA-Provider.

Username Enter your admin username used to log on to CSA. The default
username is ooInboundUser.

Password Enter your admin password used to log on to CSA. The default admin
password is cloud.

Hostname/IP
Address

Enter the CSA server hostname or IP address.

Port Port for REST API (default value is 8444).

Initial Load Period
(months)

Select the number of months from which you want the initial data
loaded.
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7. Enter the CSA configuration parameters and click Next to validate the parameters.

Execute the ETL process

After adding the CSA data source, you need to run the ETL to pull data from CSA source.

You can schedule the running of the ETL process. For details, see Run ETL - Content Flow
Managementin theAdministrator Guide.

1. Log on to the BA application.

2. Make sure you have imported the CSA SSL Certificate (see above).

3. Make sure you have installed the Content Pack (see above).

4. Make sure you have activated the data source (see above).

5. Click ADMIN > Data Management > Run ETL.
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6. Click Add Scheduler to schedule the ETL run or click >. This loads the data from the CSA data
source.

Note: The ETL runmight last some time depending on the volume of data it has to load.

Activate the relevant CSA CAP

Activate the CSA_DemoCAP for demo purposes or activate the CSA CAP for live data into BA.

For live data cases, if you had activated the CSA_Demo previously, youmust deactivate it before you
activate the CSA CAP.

1. Log on to the BA application.

2. Ignore theUnreachable Java Applet. Click OK.

3. Make sure you have imported the CSA SSL Certificate (see above).

4. Log on to the BA application.

5. Make sure you have installed the Content Pack (see above).

6. If you plan to activate the CSA_Demo proceed to the next step. If you plan to activate the CSA,
make sure you have executed the ETL (see "Execute the ETL process" on the previous page).

7. Click ADMIN > Data Management and click Activate CAP.

8. Select theCSA or theCSA_Demo in the list of CPs, and click Activate to activate the CAP.
Click Yes to begin the activation process.
Then wait until the CAP activation is successful.

9. Close theADMIN tab.
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Calculate the KPI

1. Log on to the BA application.

2. Click theSTUDIO tab and click the calculation tool and select Recalculate.

a. Select theCSA_CloudOptimization in theUniverse/Context for recalculation list.

b. Select the recalculation start date.

c. Check the check box.

d. Click Calculate.

The calculationmay take a few minutes.
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3. To check the KPI calculation status, click the calculation tool and select Calculation
monitoring.

4. Select Calculations running now in theMonitoring options.

If No items to show is displayed, the KPI calculation is finished.

Now you can view the CSA dashboard pages with live data.

You can schedule the Scheduled calculation of the KPI. For details, see Calculation Scheduling in
theBusiness Analyst Guide.
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Configure the Cloud Analytic Tiles in the Provider Portal

1. Create a user in ITBA with the same login name as in CSA.

a. From the ITBA ADMIN tab, create an ITBA user account with same login name as CSA
(admin). The password does not need to be the same. The password needs to be complex.

b. Log out from ITBA, and log on again in as the administrator.

c. Select the pages relevant to CSA andmake sure you can see the pages with live data.

2. Configure single sign-on:

a. Enable SSO between the CSA Cloud ServiceManagement Console (SMC) and BA. For
details, see "Enabling the Cloud Analytics Secondary Tiles" in theHP Cloud Service
Automation Configuration Guide.

Enable SSO between theMarketplace Portal (MPP) and BA. For details, see "Configure the
Showback Report Tile" in theHP Cloud Service Automation Configuration Guide.

b. In CSA, initString is configured in the crypto element in the
%CSA_HOME%\jboss-as-7.1.1.Final\standalone\deployments\csa.war\WEB-
INF\hpssoConfiguration.xml file.
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The initString value represents a secret key and should be treated as such in your
environment.

Navigate to the <crypto> tag and enter the relevant value in the initString parameter. 

c. In BA, click ADMIN > Settings > Single Sign-on and set the LW-SSO Token Creation key
(initString) with the key above (without the double-quote and without the string “initString”).
Change the domain name to the BA server domain (CSA server should have the same domain
name). Click Save.

3. Configure the embedded page URL:

a. In CSA server, backup the%CSA_HOME%/jboss-as-
7.1.1.Final/standalone/deployments/csa.war/dashboard/config.json file (where%CSA_
HOME% is the directory in which Cloud Service Automation is installed).

b. Edit the config.json file.
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c. Search for the id: executive_scorecard tile (beware there are two such tiles), start from the
second (type = secondary) as shown below:

d. Under the tiles node, change “enabled”: false to “enabled”: true, for the following ids:

i. Executive_scorecard_resource_manager

ii. Executive_scorecard_service_business_manager

iii. Executive_scorecard_showback_report

e. Do not change it in the id: executive_scorecard_standalone.

f. Change “enabled”: true to “enabled”: falsein the id: assistance_executive_scorecard.
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g. For all tiles that are under the id: executive_scorecard, in the data section, change
<CONFIGURE_HOST_NAME> to match the hostname of your Business Analytics
installation. For example xs.example.com.

4. Access BA pages in the CSA system:
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a. Log on to CSA using the full qualifier domain name (FQDN) URL.

b. Open the embedded BA pages in the CSA system.
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Support CSA Multiple Currency for Service Offering

1. Edit EXCHANGE.csv.

2. UploadEXCHANGE.csv to%HPBA%/ContentPacks/CSA/EXTERNAL in the BA server.

3. Run the ETL to import exchange data. For details, see Run ETL - Content Flow Managementin the
Administrator Guide.

Configure the Showback report for the Consumer Organization

Administrator

In this section, we simulate the CSA Consumer Organization administrator use case that leverages
two existing groups in the LDAP server. Each group can only see its own group's data. CSAEngineers
group can only see the engineering group data and the CSAHR group can only see the HR group data.
For details, see also Setting access restrictions on a universe in theUniverse Designer for
BusinessObjects XI 3.1.

"Step 1 - Configure resource, user and permission" on the next page

"Step 2 - Configure the restriction of Cloud Billing universe" on page 166

"Step 3 - Configure the Business Analytics tile in the CSA Market Place Portal" on page 178
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Step 1 - Configure resource, user and permission

1. In the CSA integrated LDAP server, select 2 groups: CSAHR and CSAEngineers.
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2. In the ITBA application, configure LDAP. For details, see LDAP Management in theAdministrator
Guide.

Create the CSAengineers and CSAHR groups and assign them users.

3. Create the resource for the CSA-Showback for Consumer Organization Admin page.
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4. Create the CSAreportviewer role.

5. Assign the role CSAreportviewer to two groups.

6. Configure LDAP with BOE. For details, see LDAP in BusinessObjects in theAdministrator Guide.
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7. Configure the group permission in the BOE server:

a. Log on to BusinessObjects Central Management Console (http:// <local BOE server
name>:8080/BOE/CMC) using the administrator name and password and configure
LDAP with BOE. For details, see LDAP in BusinessObjects in theAdministrator Guide.

b. Open the Connections:
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c. Select the XS_DWH_JDBC connection that your report uses and click User Security.

d. Grant theView On Demand permission to the two groups.

8. Open the Universes.
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9. Select theCloudBilling universe that your report uses and click Universe Security.
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10. Add thePrivate security to the two groups.

11. Grant theView on Demand permission to the 2 groups inUser Security.
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12. Select Folders.
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13. Select theShowback for Consumer Organization Admin report and click User Security.
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14. Grant theView On Demand to the 2 groups.
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Step 2 - Configure the restriction of Cloud Billing universe

1. Configure the restrictions of the Cloud Billing universe:

a. On the BOE server, install SAP BusinessObjects BI platform 4Client Tools. Unzip the bip-
client.ZIP file from installation file and click setup.exe to install it.

Content ReferenceGuide

HPE IT Business Analytics (10.00)
Monday, March 28, 2016- 6:56:15 AM Page 166 of 237



b. Open the Universe Design Tool.

c. Log on to the Universe Design using the BOE administrator.

Content ReferenceGuide

HPE IT Business Analytics (10.00)
Monday, March 28, 2016- 6:56:16 AM Page 167 of 237



d. Click the Import button.

e. Open the Cloud Billing universe.
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f. Add the relevant restrictions in theManage Access Restrictions wizard:

l Engineer_restriction is set for CSAengineers which is configured to see only the
engineering group’s data.

l HR_restriction is set for CSAHR which is configured to see only the HR group’s data.
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g. Create the restriction.
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i. Click New in the wizard.

ii. Click theRows tab and click Add....
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iii. Select theXS_BUSINESS_UNIT_DIM_V table in the Table list, and set the SQL query
in as follows:

iv. Click OK.

v. Add restrictions1 as XS.BUSINESS_UNIT_DIM_V.Name = ‘Engineering’.
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vi. Click OK.

h. Repeat the steps from "Create the restriction. " on page 171 to create the second restriction.
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2. Click theAdd user orAdd group button, select the user and click the > button.
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3. Click OK.

4. Select Engineers_Restriction inAvailable Restrictions area, select theCSAengineers group
in theAvailable groups and users area, and then click the >>Apply button.
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5. Repeat the previous step for theHR_Restriction and the HR group.

6. Click Export...

7. Click OK.

8. Log on to BA as the HR group one user and open the CSA billing report in the Dashboard.
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9. Click theRefresh button to display the following value for Org Name.

10. Log on BA as the Engineers group one user and open the CSA billing report in the Dashboard.

11. Click theRefresh button to display the following value for Org Name.

Step 3 - Configure the Business Analytics tile in the CSA Market Place Portal

To enable and configure the Showback report on the CSA Market Place Portal for the Consumer
Organization Administrator persona:

1. Locate the%CSA_HOME%\portal\conf\dashboard.json file.

2. In the file, locate the section below and in the highlighted url replace the <CONFIGURE_HOST_
NAME> placeholder with the host name of the BA instance.
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{
"label": "common.section.ADMINISTRATION.label",
"role": ["CONSUMER_ORGANIZATION_ADMINISTRATOR"],
"tiles": {
"default": {
"className": "light-gray"

},
"items": [{
"label": "common.items.MANAGE_USER_SUBSCRIPTIONS",
"icon": {
"className": "icon-manage-subscriptions"

},
"link": "#/user/manage"

}, {
"label": "common.items.SCORECARD",
"icon": {
"className": "icon-status"

},
"link": {
"url":"https://<CONFIGURE_HOST_

NAME>/fndwar/loadEmbeddedPage.jsp?com.hp.bsm.uim.pageUID=ef63ab7f-b86b-43c8-
b8d8-bb81869b73dc",

"target": "_blank"
}

}]
}

}

3. Save.
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UI Description

CSA Activation Page

The following is an example of the CSA Activation page.

User interface elements are described below:
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Note: If the CSA configuration is for a named instance connection, make sure to enter the named
instance port.

UI Element Description

Instance name Enter a name for the data source instance you are activating.

CSA Version Select the relevant version. . For details, see theSupport Matrix.

Time Zone Select the time zone for the data source.

Data Source Type CSA

This parameter is read only.

Organization Name Enter the Organization Name that is necessary to retrieve admin details.

The default value is CSA-Provider.

Username Enter your admin username used to log on to CSA. The default username
is ooInboundUser.

Password Enter your admin password used to log on to CSA. The default admin
password is cloud.

Hostname/IP Address Enter the CSA server hostname or IP address.

Port Port for REST API (default value is 8444).

Initial Load Period
(months)

Select the number of months from which you want the initial data loaded.

Reference

CSA-Related KPIs and Metrics

For a list of the KPIs andMetrics related to the Cloud Service Automation data source, see KPIs and
Metrics in theContent Acceleration Packs Guide.
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Customize CSA Service Designer for Amazon Web Service

Resource Provider

In CSA, you can define different service designs for Amazon Provider and those service designs can
be different from user to user, and can be different from the CSA OOTB service design.

By default, the ETL logic hardcodes, the component type value, the component property value, and the
values match only the CSA OOTB service design. If you do not use the CSA OOTB service designer,
then youmust change the ETL scripts manually.

In addition, when you add fields to component property list, and then display these field in the report,
the datamodel does not include the new customized data.

l The CSA Content Pack provides a separate ETL logic to support customized CSA service
designs

Below is the ETL logic that you can use to get the component value from the AWS service design.
To easily customize the logic in the ETL scripts:

a. The logic used to handle the AWS service design is extracted into a separate script instead of
having all logic in one Server Side Includes (SSI) step. The file name of the script is AWS-
service-design.

b. Afterwards, you canmodify the OOTB logic to support your ownCSA service design, without
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impacting the others. Modify the $HPBA_
HOME/ContentPacks/CSA/INBUILT/ETL/COMPONENT/CSA_COMPONENT_CONF_
DF.sql file by providing the SSI scripts folder and the file name for the SSI component in the
CSTM_PROPERTY_<NN> fields.

l Additional Customized Fields in the Component Entity to Support Customized CSA
Service Designs

Currently, you cannot add extra fields to theShowback for Cloud Services report as the current
datamodel cannot accommodate customized fields.

To support the capability of adding customized fields to theShowback for Cloud Services report,
the component was modified to include 10 additional customized fields. For details, see
"Customize CSA Service Designer for AmazonWeb Service Resource Provider" on the previous
page.

l BILLING_FACT table details

To support option level pricing calculation, the existing BILLING_FACT table was modified. It
stores the real cost based on the subscription details including the subscription request, request
option, and option property. The granularity of BILLING_FACT table is at the levels of subscription,
request, option, property, daily.

Field Name Field Type Null Field Description

SUBSCRIPTION_ID FK N Foreign Key to subscription

SERVICE_
REQUEST_ID

FK N Foreign Key to subscription request

REQUEST_
OPTION_ID

FK N Foreign Key to request option

OPTION_
PROPERTY_ID

FK N Foreign Key to property

SERVICE_ FK N Foreign Key to service instance
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Field Name Field Type Null Field Description

INSTANCE_ID

BILLING_START DATE N Foreign Key to billing start period

BILLING_END DATE N Foreign Key to billing end period

CURRENCY_LOC VARCHAR
(10)

Y Source currency

CURRENCY_BASE VARCHAR
(10)

Y DWH currency

AMOUNT_LOC NUMERIC Y The cost stays with the source currency

AMOUNT_BASE NUMERIC Y The cost is converted into DWH currency

RECURRING_FLAG INTEGER Y The flag to identify if the cost is coming from
recurring price or not
1=Recurring price, 0=Initial price

BASE_FLAG INTEGER Y The flag to identify if the cost is coming from base
price or not

OPTION_FLAG INTEGER Y The flag to identify if the cost is coming from option
or not

PROPERTY_FLAG INTEGER Y The flag to identify if the cost is coming from
property price or not

l SERVICE_REQUEST_DIM table details

The user can subscribe to any on-shelf service offering in the CSA Consumer portal. When the user
subscribes to a service, CSA creates the relevant request for the subscription, and if the user
changes the subscription option from CPU 1 to CPU 2, another request is generated for the
modified subscription.

The SERVICE_REQUEST_DIM table holds the subscription request information for the business
analysis.

Field Name Field Type Null Field Description

SERVICE_
REQUEST_ID

PK N PK of service request

NAME VARCHAR
(1000)

Y Name of service request

DISPLAY_LABEL VARCHAR Y Display name of service request
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Field Name Field Type Null Field Description

(1000)

INITIAL_PRICE NUMERIC Y Initial price of service request

RECURRING_
PRICE

NUMERIC Y Recurring price of service request

RECURRING_
PERIOD

VARCHAR
(100)

Y Recurring period of service request

CURRENCY VARCHAR
(10)

Y Source currency

REQUEST_
START

DATE Y The create time of service request

REQUEST_END DATE Y The time that the service request is end of lifecycle

REQUEST_
STATE

VARCHAR
(100)

Y The state of service request

REQUEST_
STATUS

VARCHAR
(100)

Y The status of service request

REQUEST_
ACTION

VARCHAR
(100)

Y The action of service request(mainly used to capture
the user subscription cancellation action)

SUBSCRIPTION_
ID

FK N Foreign Key to subscription

l REQUEST_OPTION_DIM table details

The user can subscribe to any on-shelf service offering in the CSA Consumer portal. When
subscribing to a service, the user can select the relevant option.

Below is the screenshot for CSA catalog ordering, Application ABC (1.0.0) is the subscription. It
contains three options Primary Storage, Backup Storage, andApplication Scaling. Each option
can define its own initial price and recurring price.
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The REQUEST_OPTION_DIM table is designed to store the option level price information for each
user submitted service request.

Field Name Field Type Null Field Description

REQUEST_OPTION_ID PK N PK of Request Option

OPTIONSET_NAME VARCHAR
(1000)

Y Name of Option Set

OPTIONSET_DISPLAY_
LABEL

VARCHAR
(1000)

Y Display name of Option Set

OPTION_NAME VARCHAR
(1000)

Y Name of Option

OPTION_DISPLAY_LABEL VARCHAR
(1000)

Y Display name of Option

OPTION_FULL_NAME VARCHAR
(2000)

Y Name of Option Set + Name of Option

OPTION_FULL_DISPLAY_
LABEL

VARCHAR
(2000)

Y Display name of Option Set + Display
name of Option
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Field Name Field Type Null Field Description

INITIAL_PRICE NUMERIC Y Initial price of option

RECURRING_PRICE NUMERIC Y Recurring price of option

RECURRING_PERIOD VARCHAR
(100)

Y Recurring period of option

SERVICE_REQUEST_ID FK N Foreign Key to Service request

PARENT_ID FK N Parent Foreign Key to Request Option

l REQUEST_OPTION_DIM_HIER table details

The user can subscribe any on-shelf service offering in the CSA Consumer portal. When
subscribing to a service, the user can select the relevant option. Each option can contain sub
options, which can themselves include sub options.

The REQUEST_OPTION_DIM_HIER table stores the option name hierarchy information for each
user submitted service request. Themaximum supported number of levels in the hierarchy is 20.

Field Name Field Type Null Field Description

MD_SLEVEL INTEGER N The level of the option

MD_LEVEL_0_NAME VARCHAR(2000) N The full name of top level option

MD_LEVEL_1_NAME VARCHAR(2000) Y The full name of second level option

MD_LEVEL_2_NAME VARCHAR(2000) Y The full name of third level option

…… VARCHAR(2000) Y The full name of n level option

MD_LEVEL_19_NAME VARCHAR(2000) Y The full name of twentieth level option

REQUEST_OPTION_ID FK N Foreign Key to Request option

For example, if you have the following hierarchy: option1 > option1.1> option1.1.1, then the row is
displayed as follows:

MD_
SLEVEL

MD_LEVEL_
0_NAME

MD_LEVEL_
1_NAME

MD_LEVEL_
2_NAME

MD_LEVEL_
3...19_NAME

REQUEST_
OPTION_ID

3 option1 option1.1 option1.1.1 Null option1.1.1's
PK

2 option1 option1.1 Null Null option1.1's PK

1 option1 Null Null Null option1's PK
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l OPTION_PROPERTY_DIM table details

The user can subscribe any on-shelf service offering in the CSA Consumer portal. When
subscribing to a service, the user can select the relevant option. The option contains three
properties (250 GB, 500 GB, 800 GB), and each property can define its own initial price and
recurring price. The price supports fixed values, listed values, or multiple values.

TheOPTION_PROPERTY_DIM table stores the property information for each user selected
property value in its related service request.

Field Name Field Type Null Field Description

OPTION_PROPERTY_ID PK N PK of Option property

PROPERTY_NAME VARCHAR
(1000)

Y The name of the property

PROPERTY_DISPLAY_
NAME

VARCHAR
(1000)

Y The display name of the property

PROPERTY_VALUE_ID VARCHAR
(1000)

Y The value ID of the option property

PROPERTY_VALUE_TYPE VARCHAR Y The value type of the property

Content ReferenceGuide

HPE IT Business Analytics (10.00)
Monday, March 28, 2016- 6:56:23 AM Page 188 of 237



Field Name Field Type Null Field Description

(1000)

PROPERTY_VALUE VARCHAR
(1000)

Y The value of the property

PROPERTY_DISPLAY_
VALUE

VARCHAR
(1000)

Y The display value of the property

INITIAL_PRICE NUMERIC Y The initial price of the property

INITIAL_PRICE_TYPE VARCHAR(100) Y The initial price type of the property

RECURRING_PRICE NUMERIC Y The recurring price of the property

RECURRING_PRICE_TYPE VARCHAR(100) Y The recurring price type of the
property

RECURRING_PERIOD VARCHAR(100) Y The recurring period of the property

REQUEST_OPTION_ID FK N Foreign Key to request option

l COMPONENT_DIM table enhancements

The existing COMPONENT_DIM table was extended by addingmore component properties to
support customized service designs.

Field Name Field Type Null Field Description

CSTM_PROPERTY_01 VARCHAR
(1000)

Y Customized component property
field

CSTM_PROPERTY_02 VARCHAR
(1000)

Y Customized component property
field

CSTM_PROPERTY_03 VARCHAR
(1000)

Y Customized component property
field

CSTM_PROPERTY_04 VARCHAR
(1000)

Y Customized component property
field

CSTM_PROPERTY_05 VARCHAR
(1000)

Y Customized component property
field

CSTM_PROPERTY_06 VARCHAR
(1000)

Y Customized component property
field

CSTM_PROPERTY_07 VARCHAR
(1000)

Y Customized component property
field
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Field Name Field Type Null Field Description

CSTM_PROPERTY_08 VARCHAR
(1000)

Y Customized component property
field

CSTM_PROPERTY_09 VARCHAR
(1000)

Y Customized component property
field

CSTM_PROPERTY_10 VARCHAR
(1000)

Y Customized component property
field

Other existing fields did not
change

l CSA Component_Property entity

Field Name Field Type Null Field Description

PROPERTY_NAME VARCHAR(1000) Y The name of the component property.

PROPERTY_VALUE VARCHAR(2000) N The value of the component property.

COMPONENT_ID FK Y Foreign Key to COMPONENT.

l CSA Target entity

Entity Name Change Description

BILLING_FACT Refactor the existing logic of the cost aggregation to store option
and property cost

REQUEST_OPTION_
DIM_HIER

New entity add to support option and sub option info

REQUEST_OPTION_DIM New entity add to support option info

OPTION_PROPERTY_
DIM

New entity add to support option property info

SERVICE_REQUEST_
DIM

New entity add to support service request info

COMPONENT_DIM Refactor the existing logic of the cost aggregation to store option
and property cost
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How to Upload .BIAR Files

SomeWebi reports are supported in ITBA. You can view these reports in the relevant ITBA Dashboard
pages.  They are provided in the CSA CAP and the CSA_DemoCAP.

You can view these reports through the Dashboard pages that are linked to the BOE server.

Only the CSA CAP reports are imported into the BOE server automatically if you have configured the
BOE connection while installing ITBA.

Note:

l Cloud_Billing.biar is needed for theBilling Statement for Cloud Services orBilling
Statement for Consumer Organization Admin reports provided in the CSA CAP.

l Cloud_Billing_Demo.biar is needed for theBilling Statement for Cloud Services Demo
report provided by the CSA_DemoCAP.

If you did not configure the BOE connection while installing ITBA, or if you want to watch demo reports,
run the below steps.

To import theCloud_Billing.biar or theCloud_Billing_Demo.biar:

1. Copy the .biar files from the ITBA server:

$HPBA_HOME /ContentPacks/CSA/INBUILT/BI/BOE/Cloud_Billing.biar

$HPBA_HOME /ContentPacks/DEMO_CONTENT/INBUILT/BI/BOE/Cloud_Billing_
Demo.biar

2. Log on to the SAP BusinessObjects Central Management Console (CMC) at: http://<BOE_
Server_IP>:8080/BOE/CMC.
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3. Click Promotion Management.

4. Click Promotion Jobs > Import > Import file.

5. Click Choose File and select the relevant .biar file.
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6. In theDestination field, select Login to a New CMS.

7. Enter the BOE server IP number or server name, user name, and password, and then click Login.

8. Click Create to create promotion job.
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9. Click Promote.

10. Click Promote.

The .biar file is uploaded successfully.
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11. Log on to theUniverse Design Tool from the BOE Client.

12. Click Tools > Connections…. Edit the relevant connection.

If you are uploading the CSA CAP, edit XS_DWH_JDBC.

If you are uploading the CSA_DemoCAP, edit XS_EXT_JDBC.
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13. Enter the relevant connectionmessage of the Vertica server and click Next.

14. Click Next > Finish > Close.

The import of the .biar files is complete.

15. By default, the application schema name is BA, the extension schema name is ext, and the
database name is xsvertica. If the customer server settings are different, change the as shown
below.
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a. Click File > Import…, and select theCloud Billing universe directory.

b. Select Cloud Billing and click OK.
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c. Right-click the relevant table, and select Rename Table.

d. In theOwner field enter the correct application schema name and in theQualifier field enter
the correct database name.

e. After modifying all the relevant tables as shown above, click File > Export….
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f. Click OK to upload the changes to BOE the server.

16. Proceed in the sameway for the Cloud Billing Demo universe directory.

CSA-Related Reports

The Showback for Cloud Services, Showback for Cloud Services Demo, and the Showback for
Consumer Organization Admin reports are available as Dashboard pages when you activate the
relevant CSA or CSA_DemoCAPs. For details, see CSA_Demo and CSA Content Acceleration
Packs in theContent Acceleration Packs Guide.

The reports can also be viewed in aWeb Intelligence Viewer component that you can add to a
Dashboard page. For details, see TheWeb Intelligence Report Viewer Component in theBusiness
Analyst Guide.

The CSA-Showback for Cloud Services report displays the subscription cost incurred, during the time
period specified when the user opened the report, by the organizations for which the user has
permission. It also displays the Option Full Name, Property Name, Property Value, and Cost for each
selected user subscription. The period granularity of this report is daily. You can search by specific date
range, by user name, or by organization name.

The CSA-Showback for Cloud Services report displays the subscription cost incurred by each
organization based on demo data.

The CSA-Showback for Consumer Organization Admin report displays the subscription cost incurred
by each organization during the time period you specified when you opened the report for the Admin
user.

To access:

In the Dashboard, click theCSA-Showback for Cloud Services or theCSA-Showback for Cloud

Services Demo tab, if it is displayed, or click thePage Gallery button in the Dashboard toolbar,

and drag theCSA-Showback for Cloud Services or theCSA-Showback for Cloud Services Demo
page outside thePage Gallery box, and close the box.

The cloud-related reports (Dashboard pages) provided in the CSA_CAP and CSA_Demo_CAP CAPs
combine integrated data from the following data sources Cloud Service Automation (CSA), Amazon
Web Services (AWS), AmazonWeb Service CloudWatch (AWSCW)

For details, see CSA_Demo and CSA Content Acceleration Packs in theContent Acceleration Packs
Guide.
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Troubleshooting

This section includes:

The billing statement (Showback) report does not display in Chrome and IE 201

The CSA-related Dashboard pages do not open 202

The KPI and the Dashboard CSA-related pages do not display data 202

The Revenue KPI does not display correctly due to a currency problem 202

Demo data is displayed instead of real data 202

The CSA data source does not activate 203

Consumer user data is not displayed 211

The CSA cost lags by one day 211

Configure the Flash player plugin 212

Hide the INVALID and UNKNOWN columns 212

How to Schedule the ETL 213

How to Schedule the KPI engine 213

The BA Dashboard pages are not displayed in the CSA portal 214

Make sure to use the correct out-of-the-box CSA 214

The billing statement (Showback) report does not display in Chrome and IE

To run the BOE reports in an BA Dashboard page, youmust set Chrome to allow the running of
unsecure content, by default. If you do not do that, the shield icon is displayed in the browser address
bar, each time you start the application. .

l In Chrome, click the gray shield on the right top corner of the application, click Load unsafe script,
and click Done.
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l In IE, click theShow all content link.

The CSA-related Dashboard pages do not open

Make sure you have activated the CSA-related CAPs: CSA orCSA_Demo.

Note: Only one of these two CAPs can be activated at a time in the BA application.

The KPI and the Dashboard CSA-related pages do not display data

Make sure that the CSA data source is activated, then run the ETL, and calculate the KPI. Run the KPI
calculation from the Studio.

The Revenue KPI does not display correctly due to a currency problem

Do the following:

1. Edit EXCHANGE.csv.

2. UploadEXCHANGE.csv to%HP_BA%/ContentPacks/CSA/EXTERNAL.

3. Run ETL to import exchange data.

Demo data is displayed instead of real data

Make sure you de-activated theCSA_Demo and activate theCSA CAP.

Content ReferenceGuide

HPE IT Business Analytics (10.00)
Monday, March 28, 2016- 6:56:29 AM Page 202 of 237



The CSA data source does not activate

Make sure you have imported the CSA SSLCertificate before activating the CSA data source.

To configure the CSA SSLCertificate:

1. Export the CSA SSL certificate:

a. Access the CSA portal from browser of BA server:
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b. Click the red cross on the left side of the URL bar and click Certificate information.
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c. Click theDetails tab and click Copy to File …
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Click Next.
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Click Next.
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Click theBrowse... button and give it a file name, such as CSA45.cer, and click Next.
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Click the Finish button.

The CSA SSLcert file is now exported. In this example, the file is located at C:\software\csa-
certificate_fromExplorer.cerC:/software/csa-certificate_fromExplorer.cer.

2. Import the certificate to BA keystore:

a. Open a command prompt:

cd “C:\<HP-BA>\agora\jdk\jre\bin”
keytool –importcert –alias csa –file
“c:\Software\csa-certificate_fromExplorer.cer”
–keystore C:\<HP-BA>\agora\jdk\jre\lib\security\cacerts
–trustcacerts

cd “%HPBA_Home%/jdk/jre/bin”
keytool –importcert –alias csa –file
“c:/Software/csa-certificate_fromExplorer.cer”
–keystore %HPBA_Home%/jdk/jre/lib/security/cacerts
–trustcacerts
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b. When prompted for the keystore password, type changeit.

c. When prompted to trust this certificate, type yes.

d. Restart theHP Executive Scorecard Service from the Services Windows admin tools.

e. Run%HP_BA_Home%/supervisor/bin/hpba-restart.sh to restart BA.

f. Wait a few minutes for the services to fully start.
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Consumer user data is not displayed

Configure the <HP-XS>\agora\ContentPacks\CSA\conf\csa.properties%HP_BA_
Home/ContentPacks/CSA/conf/csa.properties file and remove the invalid users.

The CSA cost lags by one day

ETL only get data for the last closed date, so for the current date, youmust wait for 1more day. This
issue will be fixed in a patch after version 9.50.
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Configure the Flash player plugin

Disable the Chrome embedded Flash, and install the Adobe Flash plugin.

Hide the INVALID and UNKNOWN columns

The INVALID / UNKNOWN columns are the default columns for KPIs in BA. Based on the data that
BA has to generate KPIs, these columns may or may not have proper data to display in a Dashboard
page.

To hide these default columns, complete the following steps:

1. Open the component that shows the INVALID / UNKNOWN columns.

2. Click “Configure Component” option from the tray.

3. Select a number from theMaximum number of slices list that is higher than the number of slices
that are displayed in the component. For example: The number of slices displayed in a component
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are 3 then by selecting 4 from the pick list, the UNKNOWN and INVALID columns are replaced
with the OTHER column.

How to Schedule the ETL

To schedule a batch job:

1. Select ADMIN > Content Flow Management > Add Scheduler to configure the ETL run
schedule.

The Stream Scheduler dialog box opens.

2. Select the Load -Batch Scheduler tab.

3. Select the relevant Schedule Type and times and click Save.

To schedule the run_steps command:

1. Select ADMIN > Content Flow Management and click in the Stream Information area.
The Stream Scheduler dialog box opens.

2. Select theRun-Steps Scheduler tab.

3. Click Add New to create a new schedule for a specific stream.

4. Click Save.

5. Click Delete to delete a displayed schedule. You can then add a new one to replace it.

How to Schedule the KPI engine

In this section, you will learn how to schedule an automatic context calculation, so the calculation runs
automatically according to your configuration and the data that is presented in the Dashboard is the
latest data. The calculation engine will then run automatically according to your settings.

To schedule a business context calculation

1. Click theStudio tab.

2. In the Active KPIs pane, select the relevant KPI, click theCalculation options button, and select
the option.
Note that you schedule the calculation per Business Context.

3. In the Business Context Calculation Scheduling dialog box, select the relevant business context
in the drop downBusiness Context list, and in theSchedule details area, enter the day and time

Content ReferenceGuide

HPE IT Business Analytics (10.00)
Monday, March 28, 2016- 6:56:31 AM Page 213 of 237



when you want to run the scheduled calculation.

4. Click Save.

The BA Dashboard pages are not displayed in the CSA portal

Make sure you configured the BA website SSL. For details, see "Configure the BA Website Browser
SSL" on page 122.

Make sure to use the correct out-of-the-box CSA

Make sure that you are using the out-of-the-box CSA provided by Amazon Service Design, vCenter
Service Design, and Hyper-V service design in their service offering and related subscriptions, so the
following KPIs display their values in Business Analytics:

l Network Traffic

l Public vs Private Cloud Spending

l Number of Used Instances

l Amount of Used Storage

l % of Server Utilization

l Resource Provider Cost

The Service Designs are as follows:

l For Amazon service design, the service design name is CSL_BP_AMAZON_EC2_COMPUTE_
3.10.
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Integration with PPM
Project and Portfolio Management (PPM) Software provides an integrated platform for planning,
staffing andmonitoring Agile development projects, as well as managing application quality. PPM
Center offers a consolidated view of all IT activities so that management has better visibility into the
portfolio, more effective controls, greater flexibility in applying automated processes, and better-defined
quality standards.

This section describes the integration, contexts, KPIs, Metrics, and reports, if any, associated with the
integration with the Project and Portfolio Management data source.

The purpose of the integration of PPM as a data source is to bring quality management information into
the DataWarehouse.

To access:

Select ADMIN > Data Management > Connect Data Source then click Add data source and select
PPM to activate the integration processes for thePPM data source.

Learn More

Content Packs and their functionality

To learn about Content Packs and their functionality see, Connect the Data Source in theAdministrator
Guide.

Important Information

l The PPMContent Pack supports multiple instances.

l DCS Integration: An extractor using the Data Collection Servicemechanism that extracts entities
from the source and generates corresponding flat files. For details, see Data Collection Service
(DCS) in theAdministrator Guide.

l All fields are case-sensitive.

HPE IT Business Analytics (10.00)
Monday, March 28, 2016- 6:56:31 AM Page 215 of 237



Tasks

This section includes:

Activate the Integration 216

Consolidate PPM and ALM 216

Dimensions that are filled by XLSs 218

PPM-Related KPIs andMetrics 218

Activate the Integration

1. Select ADMIN > Data Management > Install Content Pack then click the install button
relevant for the data source.

2. Select ADMIN > Data Management > Connect Data Source then click Add data source.

3. The Add Data Source page opens. Select thePPM data source type.

4. Select or enter the configuration parameters.

5. Click Next to proceed to the validation page.

Consolidate PPM and ALM

If you are integrating ALM and PPM data sources, the consolidation process between ALM and PPM
identifies ALM releases as child- projects of PPM projects.You canmapwhich release of the ALM
domain is connected to the specific PPM project. Themanual mappingmust be performed before
running ETL. For details, see Consolidate Between ALM and PPM in theContent ReferenceGuide.
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UI Description

PPM Activation Page

The data warehouse is connected to Project and Portfolio Management through high-level integration
processes. A set of database views enables the extraction of themain PPM objects.

Mandatory fields aremarked with a red asterisk.

User interface elements are described below:

Note: TheOracle database can have both Server ID (SID) and Service Name properties, but the
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user should specify only one. If you define the SID, then the SID is used, and if you define Service
Name, then Service Name is used. If you define both in the UI, only SID is used.

UI Element Description

Instance name Enter a name for the data source instance you are activating.

PPM Version Select the relevant PPM version. For details, see theSupport Matrix.

Time Zone Select the time zone for the data source.

Data Source Type PPM can be run only onOracle.

Username Enter your username used to log on to the PPM database.

Password Enter your password used to log on to the PPM database.

Hostname/IP Address Enter the Oracle server database hostname or IP address.

Port Port for database connections.

SID Enter the unique name of the database.

Service Name Enter the alias used when connecting.

Schema Name Enter the name of the Schema.

Initial Load Period
(months)

Select the number of months from which you want the initial data
loaded.

Reference

Dimensions that are filled by XLSs

l Budget

l Cost Category

PPM-Related KPIs and Metrics

For details about the KPIs andMetrics related to the integration with PPM, see KPIs andMetrics in the
Content Acceleration Packs Guide.
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Integration with SA
This section describes the integration, contexts, KPIs, Metrics, and reports, if any, associated with the
integration with the Server Automation data source.

Server Automation (SA) enables you to govern the full spectrum of your softwaremanagement
requirements. With SA policy-based softwaremanagement you can automate software installation and
application configuration, and ensure that managed servers are compliant with software policies.

Note: Information about the ALT data source andmore general content issues are detailed in the
Content ReferenceGuide.

The purpose of the integration of SA  as a data source is to bring quality management information into
the DataWarehouse.

To access:

Select ADMIN > > Data Management > Connect Data Source then click Add data source and
select SA to activate the integration processes for theSA data source.

Learn More

Content Packs and their functionality

To learn about Content Packs and their functionality, see Connect the Data Source in theAdministrator
Guide.

Important Information

l The SA Content Pack supports multiple instances.

l All fields are case-sensitive.

Tasks

This section includes:

Activate the Integration 220
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Activate the Integration

1. Prerequisite:

o Make sure that the Server Automation Platform is ready for use, meaning a set of APIs and a
runtime environment that facilitate the integration and extension of SA.

o Check theSupport Matrix for supported versions.

2. Select ADMIN > Data Management > Connect Data Source then click Add data source.

3. The Add Data Source page opens. Select theSA data source type.

4. Select or enter the configuration parameters.

5. Click Next to proceed to the validation page.
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UI Description

SA Activation Page

Mandatory fields aremarked with a red asterisk.

User interface elements are described below:
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UI Element Description

Instance name Enter a name for the data source instance you are activating.

SA Version Select the relevant SA version. For details, see theSupport Matrix.

Time Zone Select the time zone for the data source.

Data Source Type Oracle

This parameter is read only.

User Enter your username used to log on to the SA database.

Password Enter your password used to log on to the SA database.

Hostname/IP
Address

The remote server on which the SA database resides.

Port Enter the port in the SA server which waits for connections from the SDK
Client side. By default, the port number is 443.

Enter the port of the SA DB. By default, the port number is 1521.

SID Enter the unique name of the database.

Service Name Enter the alias used when connecting.

Initial Load
Period (months)

Select the number of months from which you want the initial data loaded.

Reference

SA-Related KPIs and Metrics

For details about the KPIs andMetrics related to the integration with SA, see KPIs andMetrics in the
Content Acceleration Packs Guide.
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Integration with SM
This section describes the integration, contexts, KPIs, Metrics, and reports associated with the
integration with the ServiceManager data source.

ServiceManager (SM) is a comprehensive and fully integrated IT ServiceManagement software suite
that enables IT to improve service levels, balance resources, control costs, andmitigate risk exposure
to the organization.

The purpose of the integration of SM as a data source is to bring quality management information into
the DataWarehouse.

To access:

Select ADMIN > Data Management > Connect Data Source then click Add data source and select
SM to activate the integration processes for theSM data source.

Learn More

Content Packs and their functionality

To learn about Content Packs and their functionality see, Connect the Data Source in theAdministrator
Guide.

Important Information

l The SM Content Pack supports multiple instances.

l DCS Integration: An extractor using the Data Collection Servicemechanism that extracts entities
from the source and generates corresponding flat files. For details, see Data Collection Service
(DCS) in theAdministrator Guide.

l All fields are case-sensitive.

l SM DBdict (Database Dictionary) Interface: The structure of the SM databasemay differ
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according to SM version. The SM FBIDCS extractor uses the DBdict interface containing themap
between entities and physical tables. Dbdict interface for SM, maintains a logical view of RDBMS
tables and columns in the database dictionary. DBdict describes how each table and column in your
system is mapped to logical entities within SM. The SM applications use the logical definitions in
the database dictionary to query andmanage the actual records in your RDBMS. DBDict is used to
avoid SM version compatibility issues.

Tasks

Activate the Integration

1. Prerequisite:

The SM data source can work with either the Oracle, SQL Server, or DB2 Server type.

2. Select ADMIN > Data Management > Install Content Pack then click the install button
relevant for the data source.

3. Select ADMIN > Data Management > Connect Data Source then click Add data source.

4. The Add Data Source page opens. Select theSM data source type.

5. Select or enter the configuration parameters.

6. Click Next to proceed to the validation page.

UI Description

SM Activation Page

The data warehouse is connected to SM through high-level integration processes.

User interface elements are described below:

For the SQL server
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The following is an example of the SM Activation page when SM is installed on an SQL server.

Mandatory fields aremarked with a red asterisk.

UI Element Description

Instance name Enter a name for the data source instance you are activating.

SM Version Select the relevant SM version.

For details, see theSupport Matrix.

Time Zone UTC is recommended.

Data Source
Type

l SelectMSSQL(dbdict). It is recommended to configure SM to run on an
SQL Server through DBdict (SM application interface).
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UI Element Description

l SelectMSSQL(Non dbdict)Configure SM to run on a regular MSSQL
server.

Username Enter your username used to log on to the SM database.

Password Enter your password used to log on to the SM database.

Hostname/IP
Address

Enter the SQL data source hostname or IP address.

If you connect to Named Instance, enter: <host_name or IP
Address>\<instance_name>.

Port Port for database connections.

Database Name Enter the name of the database for theMS SQL server.

Initial Load
Period (months)

Select the number of months from which you want the initial data loaded.

For the Oracle server

Note: TheOracle database can have both Server ID (SID) and Service Name properties, but the
user should specify only one. If you define the SID, then the SID is used, and if you define Service
Name, then Service Name is used. If you define both in the UI, only SID is used.

Content ReferenceGuide

HPE IT Business Analytics (10.00)
Monday, March 28, 2016- 6:56:33 AM Page 226 of 237



The following is an example of the SM Activation page when SM is installed on anOracle server.

Mandatory fields aremarked with a red asterisk.

UI Element Description

Instance name Enter a name for the data source instance you are activating.

SM Version Select the relevant SM version.

For details, see theSupport Matrix.

Time Zone Select the time zone for the data source.

Data Source
Type

l Select Oracle(dbdict). It is recommended to configure SM to run on an
Oracle Server through DBdict (SM application interface).
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UI Element Description

l Select Oracle(Non dbdict)Configure SM to run on a regular Oracle server.

Username Enter your username used to log on to the SM database.

Password Enter your password used to log on to the SM database.

Hostname/IP
Address

Enter the Oracle data source hostname or IP address.

If you connect to Named Instance, enter: <host_name or IP
Address>\<instance_name>.

SID Enter the unique name of the database.

Service Name Enter the alias used when connecting.

Schema Name Enter the name of the Schema.

Initial Load
Period (months)

Select the number of months from which you want the initial data loaded.

For the DB2 server
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The following is an example of the SM Activation page when SM is installed on a DB2 server.

Mandatory fields aremarked with a red asterisk.

UI Element Description

Instance
name

Enter a name for the data source instance you are activating.

SM Version Select the relevant SM version.

For details, see theSupport Matrix.

Time Zone UTC is recommended.
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UI Element Description

Data Source
Type

Select DB2(dbdict). Configure SM to run on an IBM DB2 database.

Username Enter your username used to log on to the SM database.

Password Enter your password used to log on to the SM database.

Hostname/IP
Address

Enter the data source hostname or IP address. Currently only the default port for
connecting toMS SQL data sources is supported.

There is no option to connect to a SQL server named instance. Only the default
instance is supported.

Port Port for database connections.

Database
Name

Enter the name of the database for theMS SQL server.

Schema
Name

Enter the db_owner of the source entities for the Oracle server, if your user who
deploys the data source is not the db_owner of the source entities.

When integrating with SM 7.11, make sure the name does not include the double-
quote character as the character is not supported by the Data Collection Service
(DCS).

Initial Load
Period
(months)

Select the number of months from which you want the initial data loaded.

Reference

SM-Related KPIs and Metrics

For details about the KPIs andMetrics related to the integration with SM, see KPIs andMetrics in the
Content Acceleration Packs Guide.

Integration with vPV
The integration with VPV (Virtual Performance View) as a data source enables accessing vCenter and
HP Helion data.

The purpose of the integration of VPV as a data source is to bring this information into the Data
Warehouse.
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Virtual Performance Viewer (vPV) is a web-based analysis and visualization tool that analyzes
performance trends of elements in virtualized environments. vPV gives you at-a-glance visibility across
your virtual environment for real-time insights into performance, capacity, and health. This helps you to
optimize your infrastructure and quickly solve virtualization and cloud performance issues. It enables
virtualizationmonitoring by providing an overview of the environment, near-real-time and historical data
analysis and triaging using an interactive dashboard. It also enables monitoring for cloud and hypervisor
environments. HPE vPV provides performancemonitoring, graphing, and reporting in a single interface.

The data extracted from vPV is correlated to the data available in the KPIs and reports available in the
CSA CAP. For details, see CSA_Demo and CSA Content Acceleration Packs in theContent
Acceleration Packs Guide.

To access:

Select ADMIN > Data Management > Connect Data Source then click Add data source and select
VPV to activate the integration processes for theVPV data source.

Learn More

Content Packs and their functionality

To learn about Content Packs and their functionality, see Connect the Data Source in theAdministrator
Guide.

Important Information

l The VPV Content Pack supports multiple instances.

l DCS Integration: An extractor using the Data Collection Servicemechanism that extracts entities
from the source and generates corresponding flat files. For details, see Data Collection Service
(DCS) in theAdministrator Guide.

l All fields are case-sensitive.

l VPV must be activated with the CSA data source. If you activate VPV alone, only the cost fact
information is displayed, without the ability to drill down further.

Note: When configuring VPV reports:
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l VPV Custom reports are not supported, therefore it is recommended to select theDaily report
option.

l Only cost reports are supported.

l When you generate a report in vCenter Chargeback Manager, you cannot select the following
values:

o Disk Read

o Disk Write

o Network Transmitted

o Network Received

Although the combined disk read and write utilization data and the combined network
transmitted and received utilization data can be fetched and included in the report, the split
utilization data for disk read, disk write, network transmitted, and network received is
unavailable.

When using both the AWS and VCM data sources. Both the AWS and the VCM data sources offer
the same type of information. If you integrate with both data sources, the values provided by the
relevant Metrics might combine. For example, the Number of Used Instances Metric calculates how
many VMs users are using the hybrid cloud environment. Both of the AWS data source (100
VM subscriptions) and the VCM data source (300 VM subscriptions) include this information. If, for
example, you work with AWS only, the Number of Used Instances Metric is 100. If you work with
VCM only, the Number of Used Instances Metric is 300. If you work with both data source, the Number
of Used Instances Metric is 400.

The cloud-related reports (Dashboard pages) provided in the CSA_CAP and CSA_Demo_CAP CAPs
combine integrated data from the following data sources Cloud Service Automation (CSA), Amazon
Web Services (AWS), AmazonWeb Service CloudWatch (AWSCW)

For details, see CSA_Demo and CSA Content Acceleration Packs in theContent Acceleration Packs
Guide.

Tasks

This section includes:

Activate the Integration 233
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Change the default price of the vPV private cloud resources 233

vPV-Related KPIs andMetrics 235

Activate the Integration

1. Select ADMIN > Data Management > Connect Data Source then click Add data source.

2. The Add Data Source page opens. Select the VPV data source type.

3. Select or enter the configuration parameters.

4. Click Next to proceed to the validation page.

Change the default price of the vPV private cloud resources

To help you calculate the cost for vPV supported private cloud resources (CPU, Memory, Disk), ITBA
has pre-configured their default prices.

To change the default price:

1. Log on to the ITBA server.

2. Edit the last column in thePRICING_MODEL.csv located in $HPBA_
Home/ContentPacks/vPV/EXTERNAL. The column provides the unit price.

3. Save.

The new pricingmodel will be valid in the next ETL run.
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UI Description

VPV Activation Page

The following is an example of the VPV Activation page for MS SQL server.

User interface elements are described below:

For the SQL server:
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If the VPV configuration is for a named instance connection, make sure to enter the named instance
port.

UI Element Description

Instance name Enter a name for the data source instance you are activating.

VPV Version Select the relevant VPV version. For details, see theSupport Matrix.

Time Zone Time zonemust be UTC.

Data Source Type VPV. This parameter is read only.

vpvUsername Enter your username used to log on to the VPV web application.

vpvPassword Enter your password used to log on to the VPV web application.

Hostname/IP Address Enter the hostname or IP address on which VPV is installed.

Port Port for VPV web application.

Initial Load Period
(months)

Select the number of months from which you want the initial data
loaded.

Reference

vPV-Related KPIs and Metrics

The KPIs andMetrics related to the integration with vPV are part of the integration with CSA. For
details, see "CSA-Related KPIs andMetrics" on page 181.

Content ReferenceGuide

HPE IT Business Analytics (10.00)
Monday, March 28, 2016- 6:56:34 AM Page 235 of 237



Send Documentation Feedback
If you have comments about this document, you can contact the documentation team by email. If an
email client is configured on this system, click the link above and an email window opens with the
following information in the subject line:

Feedback on Content Reference Guide (IT Business Analytics 10.00)

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a webmail client, and
send your feedback to SW-Doc@hpe.com.

We appreciate your feedback!
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