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Legal Notices

Warranty
The only warranties for HP products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be 
construed as constituting an additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend
Confidential computer software. Valid license from HP required for possession, use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, 
Computer Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard commercial license.

Copyright Notice
© 1994-2015 Hewlett-Packard Development Company, L.P.

Trademark Notices
Adobe™ is a trademark of Adobe Systems Incorporated.

Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.

UNIX® is a registered trademark of The Open Group.

This product includes an interface of the 'zlib' general purpose compression library, which is Copyright © 1995-2002 Jean-loup Gailly and Mark Adler.

Documentation Updates
The title page of this document contains the following identifying information:

 l Software Version number, which indicates the software version.
 l Document Release Date, which changes each time the document is updated.
 l Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go to:           https://softwaresupport.hp.com

This site requires that you register for an HP Passport and sign in. To register for an HP Passport ID, go to:           http://h20229.www2.hp.com/passport-registration.html

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support service. Contact your HP sales representative for details.

Support
Visit the HP Software Support Online website at: https://softwaresupport.hp.com

This website provides contact information and details about the products, services, and support that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and efficient way to access interactive technical support tools needed to manage your 
business. As a valued support customer, you can benefit by using the support website to:

 l Search for knowledge documents of interest
 l Submit and track support cases and enhancement requests
 l Download software patches
 l Manage support contracts
 l Look up HP support contacts
 l Review information about available services
 l Enter into discussions with other software customers
 l Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a support contract. To register for an HP Passport ID, go to:

      http://h20229.www2.hp.com/passport-registration.html

To find more information about access levels, go to: 

      http://h20230.www2.hp.com/new_access_levels.jsp

HP Software Solutions Now accesses the HPSW Solution and Integration Portal website. This site enables you to explore HP Product Solutions to meet your business needs, 
includes a full list of Integrations between HP Products, as well as a listing of ITIL Processes. The URL for this website is http://h20230.www2.hp.com/sc/solutions/index.jsp
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Service Manager 7.1x end of support statement
The end of support date for Service Manager 7.1x is May 31, 2015. On that date, support for Service 
Manager 7.1x will end, with the exception of Service Manager 7.1x applications with server, web, and 
client binaries upgraded to Service Manager 9.3x. For more information, see the following HP Software 
Support website:

https://softwaresupport.hp.com/web/softwaresupport/document/-
/facetsearch/document/KM01006232

To read the latest HP Software Support guidelines, see the following HP Software Support website:

https://softwaresupport.hp.com/web/softwaresupport/document/-
/facetsearch/document/KM00868611
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What's new in this release
This section describes important changes in this release.

Embedded JRE Upgraded (Server, Windows client, and 
Windows client configuration tool)
This patch release upgrade the embedded JRE in the Service Manager server, Windows client, and 
Windows client configuration tool.

Server

The server embedded JRE for x86 systems has been upgraded  to version 1.7.0_80.

Since the Service Manager server does not come with an embedded JRE for non-x86 systems (Solaris, 
HP-UX, and AIX), users using these platforms need to install one of the following JRE1.7 versions and 
make sure server/RUN/jre is a symbolic link pointing to the JRE1.7.

Platform JRE Version

All supported Windows and Linux platforms JRE1.7 (update 80  or greater)

Solaris JRE1.7 (update 80  or greater)

HP-UX JRE1.7 (JRE_7.0.12 or greater)

AIX JRE1.7 (SR8 or greater)

Note: After you upgrade the JRE version on AIX, please check that the LIBPATH variable contains the 
following line: 

$JRE_HOME/lib/ppc:$JRE_HOME/lib/ppc/j9vm

$JRE_HOME is a placeholder for the directory in which the JRE is installed.

Caution: As JRE1.7 is not supported by Solaris 9, we recommend that you upgrade your server 
operating system to Solaris 10. 

Windows client

The Windows client embedded JRE has been upgraded to version 1.7.0_80.
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Windows client configuration tool

The Windows client configuration tool embedded JRE has been upgraded to version 1.7.0_80.

Certifications
This release includes the following support matrix changes.

Added Support

 l JRE 7 Update 80 (Service Manager server, web tier, Windows client, and Windows client configuration 
tool)

Discontinued Support

 l None
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Enhancements
N/A.
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Fixed defects
N/A.
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Backup and backout instructions
In case you need to restore your Service Manager system to its original state after installing the 
component patches in this release, make necessary backups before each patch installation. If a rollback 
is needed, follow the backout instructions.

Server
Backup

Before applying the server patch, make a backup of the server installation folder. For example, 
C:\Program Files\HP\Service Manager 7.11\Server.

Note: If you have a horizontally scaled system, be sure to back up the server installation folder for 
each server instance.

Backout

 1. Stop the Service Manager server.

 2. Remove the existing server installation folder.

 3. Copy the backup folder back.

Note: Make sure that the embedded Tomcat is also replaced with the backup, because the 
version of the embedded Tomcat may have dependency on a specific server version.

Note: If you have a horizontally scaled system, make sure that every server instance is 
replaced with its  backup.

 4. If you have also loaded platform unload files required for your server changes, you must also roll 
back the application changes made by the unload files. See "Applications" on page 11.

 5. Restart the Service Manager server.
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Web tier
Backup

Before deploying the new web tier, make a backup of the following items:

 l web.xml file

 l application-context.xml

 l log4j.properties

 l splash screen

 l style sheets

 l any other customizations you made, including your webtier-<version>.war (webtier-ear-
<version>.ear) file.

Backout

To roll back to the old web tier:

 1. Delete or uninstall the existing web tier.

 2. Clear the cache of your web application server (for example, Tomcat).

 3. Redeploy the old web tier.

 4. Restore your old customizations.

Windows client
Backup

 1. Make a backup of your Windows client home folder, for example, 
C:\Users\<username>\ServiceManager. Your connections and personalized settings are stored 
in this folder.

Note: This is the out-of-the-box home directory, and could differ from yours if you made 
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changes  to <Client>\configuration\config.ini file. If so, back up the files from the 
location specified in that file.

 2. Make a backup of your certificate configuration files if any (Window > Preferences > HP Service 
Manager > Security). For example, your CA certificates file and client keystore file. 

Backout

 1. Uninstall the new Windows client.

 2. Reinstall the previous Windows client.

 3. Restore your old Windows connections and configurations.

Applications
If you plan to upgrade your applications to this release level, make a backup of your database before 
the upgrade, in case you need to restore your database after the upgrade. Creating a backup of the 
entire database and restoring the database if needed is a better approach for a full applications 
upgrade.

If you plan to load individual unload files in this release, follow the backup and backout instructions 
below.

Backup

Tip: If your application version is 7.11 ap3 or later, you are recommended to use Unload Manager to 
make a backup of the files to be modified by an unload file, because Unload Manager can create a 
backup of your old data during the installation of the unload; if your application version is other 
than any of these, Unload Manager is not available and you can use Database Manager instead. 

To use Unload Manager to make a backup:

 1. Go to System Administration > Ongoing Maintenance > Unload Manager.

 2. Double-click Apply Unload. A wizard opens.

 3. Select the unload file you want to apply, also specify a backup file, and then click Next. Details of 
the unload file appear.
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 4. Double-click a conflicting object in the table to open the merge tool:

 a. Merge the object, and then select the Reconciled check box.

 b. Click Save to go back to the wizard.

 5. Click Next after all the conflicting objects are reconciled.

 6. Click Yes on the confirmation window to apply the unload.

 7. Click Finish. 

Now, the unload has been applied and at the same time your old data backed up.

To use Database Manager to make a backup:

 1. Go to Database Manager, select Import/Load from More or the More Actions menu, and browse to 
the unload file.

 2. Click List Contents on the menu bar, to view a list of files that have been updated in this unload.

See the following figure for an example.

This figure shows the contents of an unload file that contains changes to the following files:
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File Record

Process     svc.add.cart

application money.format

Note: The scmessage records listed under each RAD application are messages 
used in this RAD application; no backup is needed for them.

ScriptLibrary svcCartHelper

datadict activity

dbdict activity

Note: The “activity” file with no records actually represents the dbdict record 
of the activity file.

scmessage The record whose message class is “fc” and message number is 1000. 

 3. Go to Database Manager, in the Table field enter a file name you got in step 2, and click the Search 
button.

 4. If the format selection page shows, select the proper format by double-clicking it (for example, 
select the device format for the device file), and then search for the file record.

 5. Click More (or the More Actions menu) > Export/Unload after the file record displays.

Note: If Export/Unload is not available, check the Administration Mode check box in Database 
Manager and try again.

 6. In the pop-up window, specify your backup upload file path/name, and click Unload Appl. 

Caution: Make sure that Append to file is selected.

 7. Repeat steps 3 through 6 to back up the rest of the files you got in step 2.

Backout

Tip: You can use Unload Manager (recommended) or Database Manager (if Unload Manager is not 
available in your application version) to roll back to your old data, as described in the following.
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To roll back to your old data using Unload Manager:

 1. Go to  System Administration > Ongoing Maintenance > Unload Manager.

 2. Double-click Apply Unload. A wizard opens.

 3. Select the unload file generated in the backup process, specify a backup file, and then click Next. 
Details of the unload file display.

 4. Double-click a conflicting object in the table to open the merge tool:
 a. Merge the object, and then select the Reconciled check box.

 b. Click Save to return to the wizard.

 5. Click Next after all the conflicting objects are reconciled.

 6. Click Yes on the confirmation window to apply the backup unload.

 7. Click Finish.

To roll back to your old data using Database Manager:

 1. Go to Database Manager, click More > Import/Load.

 2. Browse to the backup unload file you created.

 3. Click Load FG.
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Installation notes
This section provides instructions on how to install each component in this patch release.

Digital signature notice
HP signs Windows executable files with a digital signature. Since January 2012, this process has been 
updated to use a new VeriSign root certificate. On a Windows-based system that does not have the new 
VeriSign root or intermediate certificate installed, a  “The certificate in this signature cannot be 
verified.” verification error is displayed when you right-click the file, and then go to Properties > Digital 
Signatures > Details.

To resolve this issue, enable Windows Update or download and install the G5 Root certificate that is 
described at the following website:

https://knowledge.verisign.com/support/ssl-certificates-
support/index?page=content&actp=CROSSLINK&id=SO19140
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Web tier installation
This release does not include any Web Tier updates. The last any Web Tier updates were released 
together with Service Manager 7.11p23. To download the Service Manager 7.11p23 Web Tier patch, go 
to the following HP Software Support website:

https://softwaresupport.hp.com/group/softwaresupport/search-result/-
/facetsearch/document/KM01404795

Windows client installation
The Windows client update consists of a compressed file (sm7.11.801_Windows_Client.zip), which 
contains the executable installation files. Specifically, the embedded Java Runtime Environment (JRE) 
1.7 in the  Windows client  is updated to a higher 1.7 version.

To install the Windows client update, follow these steps:

 1. Stop the Service Manager Windows client.

 2. Uninstall the Service Manager Windows client. (Your connection and personalized settings are 
retained.)

 3. Run setup.exe and install the client by following the instructions in the Service Manager 
Installation Guide. 

 4. Click Help > About Service Manager Client to check the version number. The version number of 
the client should be as follows: 7.11.801.

Windows client configuration utility installation
Service Manager 7.11p24 includes an updated version of the Windows Client Configuration Utility 
(sm7.11.801-P24_Windows_Client_Configuaration.zip). Specifically, the Java Runtime Environment (JRE) 
1.7 in the  client configuration utility is updated to a higher 1.7 version.

For detailed installation instructions, see the Service Manager 7.11 Installation Guide.
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Server update installation
The server update for your operating system consists of a compressed file (sm7.11.801-P24_<OS>.zip 
(or .tar)), which contains the Service Manager server files. These files add to or replace the files in the 
[SM Server Root]\ ([SM Server Root]/) RUN, irlang, legacyintegration, and platform_
unloads directories.

Note: If you have a load balanced system, you must upgrade all server instances.

To install the Server update, follow these steps:

 1. Stop all Service Manager clients.

 2. Stop the Service Manager server.

 3. Back up the Run directory.

 4. Delete the RUN/tomcat directory. Tomcat in this directory will be upgraded to version 6.0.36 when 
you extract the server files later.

 5. Delete the RUN/lib directory.

 6. For Windows and Linux platforms, delete the RUN/jre directory. 

Note: This step is required only when you are upgrading from a server version earlier than 
7.11p23. This is to avoid conflicts between the old 1.6-based JRE and new the 1.7-based JRE.

 7. Extract the compressed files for your operating system into the main Service Manager directory on 
the server. The default path is: C:\Program Files\HP\Service Manager 7.11\Server.

 8. For UNIX servers, set the file permissions for all Service Manager files to 755.

 9. Manually upgrade to JRE1.7 on the Unix servers as needed, if you have not already done so. To do 
this, follow these steps:
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 a. Install a supported JRE or JDK version for your specific platform.

 o All supported Windows and Linux platforms:  1.7.0.80 or greater

 o Solaris 10: JRE1.7: 1.7.0.80 or greater

 o Solaris 9: JRE1.6: update 20 or greater

 o HP-UX: JRE1.7: JRE 1.7.0.12 or greater

 o AIX: JRE1.7: SR8 or greater

 b. Set your JAVA_HOME environment variable to point to the JDK above (if you have JDK installed) 
or JRE above (if you have only JRE installed).

 c. Execute \RUN\removeLinks.sh to remove the old symbolic links and then execute 
\RUN\setupLinks.sh to create new symbolic links.

 d. Run the following command to check that the JRE version is correct: 

RUN\jre\bin\java –version

Note: Additionally, after you upgrade the JRE version on AIX, please check that the 
LIBPATH variable contains the following line: 

$JRE_HOME/lib/ppc:$JRE_HOME/lib/ppc/j9vm

$JRE_HOME is a placeholder for the directory in which the JRE is installed.

 10. If you have made any customizations/changes to the original RUN/tomcat folder, restore them in 
the new RUN/tomcat folder.

 11. Restart the Service Manager server.

 12. Restart the Service Manager clients.

 13. Check the version in Help > About Service Manager Server. The version number of the client 
should be as follows: 7.11.801

Note: This patch upgrades the embedded Java Runtime Environment (JRE) to JRE 7, which uses 
Server Name Indication (SNI) extensions during the SSL handshakes. If the endpoint does not 
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support SNI, then SSL-encrypted calls to the webservice fail. For more information about this issue, 
go to the following HP Software Support web page:

https://softwaresupport.hp.com/group/softwaresupport/search-result/-
/facetsearch/document/KM00491282

Application unload installation
This patch release does not include any application unload files from previous patch releases.

Unload files that are included in the current patch
The following are unload files included in the current patch release.

Unload file

Introduced 
in  7.11 
patch

Used 
for 
apps 
version
(s) Description

QCCR1E71099_
SM711P19.unl

P19 7.11 Displays Value Lists instead of the data directly retrieved 
from the database in a QBE list when adding a field by using 
Modify Columns. See server fix QCCR1E71099.

QCCR1E67072_
SM711P18.unl

P18 7.11 Improves the performance of the Knowledge Management 
update process (KMUpdate).

QCCR1E67610_
SM711P18.unl

P18 7.11 Enables Service Manager to block potentially dangerous 
attachments.

QCCR1E49721_
SM711P17.unl

P17 7.11 Allows a translation of Display/Value Lists on dynamic 
forms. This is a required fix for the Export to Excel redesign.

QCCR1E56678_
SM711P17.unl

P17 7.11 Lists the records in the right group order when a record list 
is refreshed.

QCCR1E58562_
SM711P17.unl

P17 7.11 Includes applications changes for the Export to Excel 
redesign.
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Unload file

Introduced 
in  7.11 
patch

Used 
for 
apps 
version
(s) Description

QCCR1E59385_
SM711P16.unl

P16 7.11 Improves performance by removing the duplicate select 
from JavaScript sloDisplay.getListSLOs.

— If you haven't tailored the JavaScript sloDisplay, load 
QCCR1E59385_SM711P16.unl file

— If you have tailored the JavaScript, see installation for 
tailored sloDisplay JavaScript in the SM711 patch 17 release 
notes.

QCCR1E59389_
SM711P16.unl

P16 7.11 Improves performance by removing extra selects from the 
various displayscreen and displaycache records.

— If you haven't tailored the display screens, load 
QCCR1E59389_SM711P16.unl.

— If you have tailored the display screens, see installation 
for tailored displayscreen and displaycache records in the 
SM711 patch 17 release notes.

QCCR1E55713_
SM711p15.unl

P15 7.11 Includes application changes to reduce database I/O on 
login.

QCCR1E57766_
SM711p15.unl

P15 7.11 Includes application changes to reduce jgroups traffic on 
login.

QCCR1E55852_
SM711p14.unl

P14 7.11 Includes a new activity timer that makes the 
communication between SM processes more efficient.

To load an unload file:

 1. Make sure the Windows client is configured for server-side load/unload.
 a. From the Windows client, go to Window > Preferences > HP Service Manager.

 b. Unselect Client Side Load/Unload if is flagged.

 c. Restart the Windows client.

 2. Open Tailoring > Database Manager.

 3. Right-click the form or open the options menu and select Import/Load.
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 4. Fill in the following fields.

Field Description

File Name Type the name and path of the file to 
load.

Import Descriptor Since unload files do not require an 
Import Descriptor record, leave this field 
blank.

File Type Select the source operating system of 
the unload file.

Messages Option —  

All Messages Select this option to see all messages 
that Service Manager generates loading 
the file.

Messages Option —  

Totals Only Select this option to see only the total 
number of files Service Manager loads.

Messages Option — None Select this option to hide all messages 
that Service Manager generates when 
loading the file.

Note: You can view the contents of an unload file before importing it by clicking List Contents.

5 Click Load FG.

ODBC driver update installation
This release does not include an ODBC driver update. The last ODBC driver update  was released together 
with Service Manager 7.11p19. To download this update, go to the following SSO website:

https://softwaresupport.hp.com/group/softwaresupport/search-result/-
/facetsearch/document/KM1448270

The ODBC driver update contains the following updated DLL files:
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 l Scodbc32.dll

 l Sci18n.dll

 l Sccl32.dll

To install the ODBC driver update, follow these steps:

 1. Extract the files to your ODBC driver installation folder (for example: C:\Program Files\HP\Service 
Manager 7.11\Server\ODBC driver).

 2. When you are prompted to do so, replace the three old DLL files with the new files.
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Service Manager compatibility matrix
The Compatibility Matrix lists supported versions of operating systems, browsers, HP Software 
products, and other compatibility and support information.

Note: Most of the support areas require that you register as an HP Passport user and sign in. Many also 
require an active support contract. To find more information about support access levels, go to      Access 
levels.

To register for an HP Passport ID, go to      HP Passport Registration.

To access the Compatibility Matrix:

 1. Use a browser to navigate to the HP Software Support webpage:

https://softwaresupport.hp.com/group/softwaresupport/support-matrices

 2. Log on with your Customer ID and password or your HP Passport sign-in.

 3. Navigate to the applicable information.
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