"There is no valid license" error lauching controller

  • KM01411699
  • 18-Feb-2015
  • 20-Feb-2015

Summary

There is no valid license........to renew license contact HP Software customer support

Question

Issue:

Getting the following message when trying to launch the Controller:

"There is no valid license........to renew license contact HP Software customer support"

Checking the licenses via the LR license utility, it shows valid licenses are applied in the system.

 

Cause:

The reason for this error is because the registry of one LoadRunner’s component, LRWrapper.dll, is overwritten by UFT installation.


Answer

Solution:

To overcome this issue it is necessary to manually register LRWrapper.dll from LoadRunner’s installation.

1. Go to Start-> Run

2. If LoadRunner was installed at the default path, the below command has to be executed:

"regsvr32 C:\Program Files (x86)\HP\LoadRunner\bin\LRWrapper.dll"

**Note**
If you install a UFT patch or any changes, you’ll have to register the .dll again
Please also consider visiting the web-based version of this response at:
http://support.microfocus.com/kb/kmdoc.php?id=KM01411699