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Welcome
This guide provides information for setting up and configuring the Service Asset and Configuration
Management (SACM) solution. This guide outlines the integration between HP Asset Manager,
HP Universal CMDB, and HP Service Manager. It explains how to install and configure the components of
the integration, as well as outlining how functionality of the integrated applications is enhanced.

This chapter includes:

l "How This Guide is Organized" below

l "Who Should Read This Guide" on the next page

l "Additional Online Resources" on page 9

How This Guide is Organized
This guide contains the following chapters:

Introduction to SACM

In addition to providing an overview of the Service Asset and Configuration Management Solution,
provides an introduction to SACM integrations and briefly describes how the following products work
with each other:

l HP Service Manager (SM)

l HP Universal CMDB (UCMDB)

l HP Asset Manager (AM)

l HP Connect-It (CIT

"HP Service Manager and HP Universal CMDB Integration" on page 34

Provides the installation and configuration steps required to configure and verify the integration
between Service Manager and Universal CMDB .

"HP Asset Manager and HP Universal CMDB Integration" on page 40

Provides the installation and configuration steps required to configure and verify the integration
between Asset Manager and Universal CMDB .
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"HP Asset Manager - HP Service Manager Integration" on page 46

Provides the installation and configuration steps required to configure and verify the integration
between Service Manager and Asset Manager pursuant to a request from the catalog.

"CI's Reconciliation Priority Best Practices" on page 63

Provides the Best Practices guidelines and configuration instructions for how to prioritize the
information received from Asset Manager and Service Manager into UCMDB in order for UCMDB to
contain the most accurate CI information.

"Technical Reference" on page 67

Describes how data objects are sourced and mapped by which scenario or adapter, as well as the
reconciliation keys used, and any special requirements needed for data transfers to work properly

Who Should Read This Guide
This solution is intended for IT organizations that want to better manage all their assets from
procurement to decommissioning, all the while supplying both operational as well as IT Financial
Management data.

This guide is intended for:

l Customers

l Presales and sales personnel

l PSO

l Anyone who wants to learn about the solution, its flow, and its value or the value it delivers

The information in this guide may duplicate information available in other SACM documentation, but is
provided here for convenience.

Configuration Guide
Welcome
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Additional Online Resources
Troubleshooting & Knowledge Base accesses the Troubleshooting page on the HP Software Support
Web site where you can search the Self-solve knowledge base. Choose Help > Troubleshooting &
Knowledge Base. The URL for this Web site is http://h20230.www2.hp.com/troubleshooting.jsp.

HP Software Support accesses the HP Software Support Web site. This site enables you to browse the
Self-solve knowledge base. You can also post to and search user discussion forums, submit support
requests, download patches and updated documentation, and more. Choose Help > HP Software
Support. The URL for this Web site is www.hp.com/go/hpsoftwaresupport.

Most of the support areas require that you register as an HP Passport user and sign in. Many also
require a support contract.

To find more information about access levels, go to:
http://h20230.www2.hp.com/new_access_levels.jsp

To register for an HP Passport user ID, go to:
http://h20229.www2.hp.com/passport-registration.html.

HP Software Web site accesses the HP Software Web site. This site provides you with the most up-to-
date information on HP Software products. This includes new software releases, seminars and trade
shows, customer support, and more. Choose Help > HP Software Web site. The URL for this Web site is
www.hp.com/go/software.

HP Software Solutions Now accesses the HPSW Solution and Integration Portal Web site. This site
enables you to explore HP Product Solutions to meet your business needs, includes a full list of
Integrations between HP Products, as well as a listing of ITIL Processes. The URL for this Web site is
http://support.openview.hp.com/sc/solutions/index.jsp.
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Introduction to SACM
This chapter includes:

Service Asset and Configuration Management – Overview 10

SACM 9.40 Solution Diagram 15

Hardware and Software Requirements 17

SACM Project Planning 29

HP Asset Manager – Overview 30

HP Service Manager – Overview 31

HP Universal CMDB – Overview 32

HP Connect-It – Overview 33

Note: If you have any feedback or comments, please contact solutionpackagingandscp@hp.com.

Service Asset and Configuration Management –
Overview
SACM provides a necessary data foundation that is core to operating IT. This enables the business to
function within its own constraints while taking into account the unique needs of the business. Many key
IT (ITIL) processes rely on SACM being in place in the organization; including all of the following:

l Service Portfolio Management (Service Strategy)

l IT Financial Management (Service Strategy)

l Service Level Management (Service Design)

l Incident Management (Service Operations)

l Problem Management (Service Operations)

l Request Management (Service Operations)
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l Configuration Management (Service Transition)

l Change Management (Service Transition)

By enabling and supporting these processes, SACM contributes to:

l Planning and proactive management of IT to support the needs of the business.

l Financial traceability—the ability to understand where the IT budget is being spent and in support of
which business drivers
This also supports better financial decision making in general and specifically determining if the IT
budget is truly supporting the important business services that drive the company’s revenue
stream.

l Maintaining appropriate service levels to support the business adequately IT should not over-deliver,
which is expensive and wasteful, or under-deliver, which inhibits the business from producing better
results. SACM provides the data points and transparency to more accurately meet business needs.

l Enabling services to be operated effectively and efficiently

l Populating and managing the Configuration Management Database (CMDB)—discovering and
recording all the relevant components that comprise the IT environment

l Providing a process for on-boarding Assets and CIs—managing them throughout their respective life
cycles and retiring them in an organized manner to minimize the negative impact on the business

l Improving the understanding of the complex interdependencies between the various components of
IT and reducing the negative impact they may have on each other

l Standardizing IT environments, resulting in reducing maintenance costs and improving consistency
and predictability of IT outcomes

SACM provides these values to the business throughout the entire service life cycle, from request
through procurement to deployment into the IT environment, management of the service in production,
and ending at the retirement and disposal phases. SACM is responsible for creating and managing the
Configuration Management System (CMS) and as such provides IT organizations with more control over
their IT environments, better adherence to the policies it defines, and greater accessibility to the
necessary information. SACM does so by delivering the following:

l Management and planning: Designing what level of configuration management is needed and how
this level will be achieved

Configuration Guide
Introduction to SACM
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l Configuration identification: Establishing a system of classification of Configuration Items (CIs) into
types, defining the relevant attributes for each CI type, determining the key attributes and the
relationships between the various CI types

l Configuration Control: Governing the addition, removal and updating of each CI and ensuring that
the appropriate process and procedures are followed for each such activity

l Status accounting and reporting: Providing an accurate account of the status of each CI/Asset

l Verification and audit: Conducting periodical audits to ensure that there are no discrepancies
between the documented and/or desired state of the environment and the actual state

Configuration Guide
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Installing SACM Products
Before you can install and configure the integration, the SACM products must be installed and
accessible by the integration components via the network.

In-depth knowledge and administration privileges to each of the following integration products are
required to install, configure and manage the integration successfully.

l HP Asset Manager

l HP Universal CMDB and its probe

l HP Service Manager

l HP Connect-It

l HP Service Manager <-> HP Universal CMDB integration (reuse the CI Types that are mapped from
UCMDB to SM)

Note: The HP Universal CMDB to HP Service Manager Integration Guide to the SM <-> UCMDB
integration is provided with SM.

You can access the guide through the SM Help Server.

Refer to the installation guides provided with each of the products that represent the SACM solution.

Note: Although not in the scope of the SACM solution, integrating AM with IT infrastructure
discovery tools such as HP Discovery and Dependency Mapping Inventory can complement the SACM
solution by providing accurate, up-to-date inventory data which serves as the foundation of the
SACM solution. It is suggested to implement this integration before installing and configuring the
SACM solution.

Refer to the AM support matrix for the supported versions of various discovery tools. Refer to the
documentation provided with the discovery tools for integration information.

Configuration Guide
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SACM Prerequisites
This guide expects that the following products are installed and fully functional:

l HP Universal CMDB (UCMDB) 10.20 or later: Server should be installed. Data flow probe should be
connected and running.

l HP Service Manager (SM) 9.40 or later: Server, Client, Help Server, and Web Tier should be installed
and running.

l HP Asset Manager (AM) 9.41 or later: Application designer, client, and AM web application.

l HP Connect-It 9.60 or later: Scenarios from SACM 9.40 kit.

Note: This guide assumes that the SACM products are installed in the following default locations:

l Universal CMDB – C:\hp\UCMDB\

l Service Manager – C:\Program Files\HP\Service Manager 9.40

l Asset Manager – C:\Program Files\HP\Asset Manager 9.41 en

l HP Connect-It – C:\Program Files\HP\Connect-It 9.60 en

Configuration Guide
Introduction to SACM

HP Service Asset and Configuration Management (SACM) Solution (9.40) Page 14 of 79



SACM 9.40 Solution Diagram
The following diagram displays a typical deployment of the SACM Solution.

ID# Integration Name

#351 Employee Self-Service Catalog for Asset Manager (AM - SM)

#415 Reference Data Synchronization via Connect-It (AM <-> SM)

Configuration Guide
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ID# Integration Name

#816 Inventory, Software Utilization and Business Data Synch (UCMDB to AM)

#817 Asset to CI Replication (AM -> UCMDB)

#820 CI sync and actual state federation (UCMDB to SM)

Configuration Guide
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Hardware and Software Requirements
The instructions in this document assume that products are installed in the default location. If this is
not the case, you will need to make the appropriate modifications to file paths mentioned in this
document.

This section also includes:

Supported Versions 17

Hardware and Software Requirements 18

Supported Versions
The following product versions were validated for the SACM 9.40 solution:

Product Version Instructions

UCMDB 10.20 or later

Recommended: 10.20

For installation instructions, see the HP Universal
CMDB Deployment Guide.

Service
Manager

9.40 or later

Recommended: 9.40

For installation instructions, see the HP Service
Manager Interactive Upgrade Guide

Connect-
It

9.60 or later

Recommended: 9.60

For installation instructions, see the HP Connect-IT
Connector Guide.

Asset
Manager

9.41 or later

Recommended: 9.41 with the
SACM 9.40 content pack

For installation instructions, see the
HP Asset Manager Installation and Upgrade.

Note: Make sure that each application you install is up and running before you perform any
configuration steps.

Configuration Guide
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Hardware and Software Requirements
This section includes:

HP Asset Manager Requirements 19

HP Service Manager Requirements 22

HP Universal CMDB Requirements 24

HP Connect-It Requirements 27
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HP Asset Manager Requirements

Supported operating systems

Asset Manager client programs

The Asset Manager client programs support:

l Windows

l Linux

To find out what operating system versions are supported, consult the Support Matrix at:
www.hp.com/go/hpsoftwaresupport.

See Installation guide, chapter Supported environments, section Supported operating
systems\Asset Manager client programs.

Asset Manager database server

The server may be used with all the operating systems and hardware platforms supported by your
DBMS.

To acquire the list of these supported items, refer to the documentation of your DBMS.

Minimal Configuration

All programs except Asset Manager Automated Process Manager and Asset Manager Web and
Asset Manager Web Service

Environment Windows Vista, Windows 7 and Windows Server 2008

CPU Intel Xeon or equivalent

RAM 2 GB

Disk space (*) 4 GB (all packages installed)

(*) The files installed with Asset Manager require about 700 MB disk space (excluding production
database and client database layers).

Asset Manager Automated Process Manager

Configuration Guide
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Environment Windows Server 2008

CPU Intel Xeon dual-core or equivalent

RAM 1 GB reserved for Asset Manager Automated Process Manager

Disk space 4 GB

Recommended Configuration

All programs except Asset Manager Automated Process Manager and Asset Manager Web and
Asset Manager Web Service

Environment
Windows Vista, Windows 7, Windows 8, Windows Server 2008, and Windows
Server 2012

CPU Intel Xeon or equivalent

RAM 4 GB

Disk space
(*)

50 GB (all packages installed)

(*) The files installed with Asset Manager (client only) require about 350 MB disk space (excluding
production database and database layers).

Asset Manager Automated Process Manager

Environment Windows Server 2008, and Windows Server 2012

CPU Intel Xeon quad-core or equivalent

RAM 2 GB reserved for Asset Manager Automated Process Manager

Disk space 4 GB

Network High speed link with DBMS server. (For example: Ethernet 100 Mbps or Gigabit) and
low latency (<5 ms).

Asset Manager Web
For details of the configuration needed to support Asset Manager Web, see the AM Sizing Guide Using
Oracle DB2 or MSSQL.

Supported DBMSs

The following DBMSs are supported for the Asset Manager database:

Configuration Guide
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l Microsoft SQL Server

l Oracle Database Server

l IBM DB2 UDB

To find out what DBMS versions are supported (servers, clients, network protocols, drivers, and so on)
consult the Support Matrix at: https://softwaresupport.hp.com/group/softwaresupport/support-
matrices.

Configuration Guide
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HP Service Manager Requirements

Service Manager server

l Windows (64-bit):

n Windows Server 2012 R2, 2012

n Windows Server 2008 R2, 2008

l Linux (64-bit):

n Red Hat Enterprise Linux 7.0, 6.x

n Oracle Enterprise Linux 7.0, 6.x

n Novell SUSE Linux Enterprise Server 11 SPx, 10 SP1

For more supported platforms, refer to the product compatibility guide.

RDBMS

l Oracle 11.2 (11.2.0.3 or later)

l Oracle 12c

l SQL Server 2012

l SQL Server 2014

For more details about supported RDBMS, refer to the product compatibility guide.

Service Manager Client

l Web tier

n Application server: Apache Tomcat 7.0

n Web Server: Apache HTTP Server 2.2, IIS 7.5

Configuration Guide
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n Web client: Internet Explorer (IE) 11, 10, Firefox 31 or a later version (Extended Support Releases
are recommended), Google Chrome 31 or a later version

l Mobility client

n Application server: Apache Tomcat 7.0

n Handset:

o iOS 7.x, 8.x: Safari

o Android 4.x : Chrome, Android browser

o BlackBerry 10.0: BlackBerry browser

l Windows client

Operating Systems:

n Windows 8.1 and Windows 8 (32-bit and 64-bit)

n Windows 7 (32-bit and 64-bit)

Configuration Guide
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HP Universal CMDB Requirements

Hardware

Computer/processor

Windows/Linux.

To fulfill the CPU requirements, you must have one of the following:

l Intel Dual Core Xeon Processor 2.4 GHz or later

l AMD Opteron Dual Core Processor 2.4 GHz or later

In addition to the above requirements, you must have the following number of CPU Cores, depending on
your deployment configuration:

l Small deployment: 1 CPU

l Standard deployment: 4 CPUs

l Enterprise deployment: 8 CPUs

Note: As HP Universal CMDB performance is dependent upon processor speed, to ensure proper HP
Universal CMDB performance, we recommend that you use the fastest possible processor speed.

Memory

Windows/Linux.

l Small deployment: 4 GB RAM

l Standard deployment: 8 GB RAM

l Enterprise deployment:

n 16 GB RAM

n 32 GB RAM (for more than 40 million CIs and relationships)

Memory Swap File

Windows.

Configuration Guide
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l Small deployment: 6 GB (Supported)

l Standard deployment: 12 GB

l Enterprise deployment: 24 GB

Linux.

l Small deployment: 4 GB (Supported)

l Standard deployment: 8 GB

l Enterprise deployment: 16 GB

Note: The virtual memory for Windows should be at least 1.5 times the size of the physical
memory.

The Linux swap file size should be equal to the size of the physical memory.

Free hard disk space

30 GB at minimum (for logs, memory dumps, and so on).

Display

Windows.

Color palette setting of at least 256 colors (recommended: 32,000 colors).

Operating System

l Windows Server(64-bit):

n Windows Server 2012 and Windows Server 2012 R2

n Windows Server 2008 Enterprise SP2, R2,and R2 SP1 64-bit, Standard R2 and R2, SP1 64-bit

l Red Hat Linux(64-bit)

n Enterprise/AdvancedServer 5.x

n Enterprise Server 6.2, 6.3, 6.4, and 6.5

l Oracle Linux

Configuration Guide
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n Oracle Enterprise Linux Server with Red Hat Compatible Kernel v6.3

n Oracle Enterprise Linux Server with Unbreakable Enterprise Kernel v6.3

Database

l Oracle Server 11g or later

l Microsoft SQL Server 2008 or later

l PostgreSQL Server 9.22 or later

Application Servers

l Apache Tomcat, version 7.0.19

Web Servers

l Jetty, version 7.6.0

Web Browsers

l Windows Internet Explorer 7 or later, recommended to use Windows Internet Explorer 9

l Google Chrome on windows

l Firefox 10 and higher on windows

Plug-ins

l JAVA 7 or later

The recommended JRE version is 1.7u25.

Configuration Guide
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HP Connect-It Requirements

Hardware

Windows

l CPU: Dual-core 2 GHz or above

l RAM: 2 GB or above

Linux

l CPU: Dual-core 2 GHz or above

l RAM: 2 GB or above

Operating System

Connect-It is a 32 bit application and only supports 32 bit interfaces.

l x86-32 / Microsoft Windows

n Windows Server 2008 SP1/SP2

n Windows Vista

n Windows 7 SP1 Enterprise

n Windows 8

l x86-64 / Microsoft Windows

n Windows Server 2008 SP1/SP2

n Windows Vista

n Windows 7 SP1 Enterprise

n Windows 8

l x86-32 / Linux
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n Red Hat Enterprise Linux 5 and 6 (32-bit and 64-bit)

n Oracle Linux 6
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SACM Project Planning

HP Service Asset and Configuration Management
The various tasks that must be done in order to use the SACM solution appear in the following diagram:
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HP Asset Manager – Overview
HP Asset Manager (AM) helps IT organizations minimize their compliance risk, effectively manage their
IT services, and maximize the utilization of IT.

AM supports the life cycle management of physical and logical assets. AM’s modules—Asset Tracking, IT
Procurement, Contract Management, Software Asset Management and Financial Management—will
ensure that IT organizations get full visibility on their portfolio and can smoothly run operations and
optimize their use of IT.

AM's main benefits are described as follows:

l Asset Tracking:

n Track and manage fiscally relevant physical and virtual assets throughout their life cycle

n Optimize IT spending

n Reduce the number of lost and unused assets

n Improve IT governance

l IT Procurement:

n Streamline IT procurement life cycle process

n Optimize purchase costs by tracking vendor prices

n Manage approvals and fulfillment of requests

n Measure contract objectives against vendor delivery metrics

l Contract Management:

n Automatically manage the operational state of contracts in use

n Track compliance with vendor terms and conditions

n Link assets to contracts (purchase, leasing, maintenance, support contracts)
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n Monitor and re-evaluate contracts and suppliers

n Optimize cost of IT contracts

l Software Asset Management (SAM):

n Ensure vendor software license compliance using out-of-the-box SAM best practices

n Allow organizations to optimize what is already owned

n Enable active management for the authoritative state of software CIs

l IT Financial Management:

n Track cost of assets and business services

n Define service offerings, manage user subscriptions

n Support showback/chargeback for use of business services

n Execute Budget Management Best Practices

HP Service Manager – Overview
HP Service Manager stores the managed or expected state of CIs and CI relationships as attribute
values in a CI record. To be part of the integration, a CI attribute in your UCMDB system must map to a
managed field in the SM CI record. You can add, remove, or update the managed fields that are part of
the integration by tailoring the SM Web services that manage the integration.

SM runs according to a set of rules that define what actions you want the system to take whenever a
CI’s actual state does not match the expected state as defined in the CI record. You define these rules
from the Discovery Event Manager (DEM) in SM where you can do the following:

l Automatically update a CI record to match the attribute values listed in the actual state. (This is the
default behavior.)

l Automatically create a change record to review the differences between the actual state and the
managed state.

l Automatically create an incident record to review the differences between the actual state and the
managed state.
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HP Universal CMDB – Overview
HP Universal CMDB (UCMDB) consists of a rich business-service-oriented data model with built-in
discovery of configuration items (CIs) and configuration item dependencies, visualization and mapping
of business services, and tracking of configuration changes.

UCMDB implements data model, data flow management, and data modeling capabilities, and also
provides impact analysis, change tracking, and reporting capabilities to transform CMDB data into
comprehensible, actionable information that helps answer critical questions and solve business
problems.
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HP Connect-It – Overview
Connect-It is an Enterprise Application Integration (EAI) type integration platform. An EAI solution
enables a company to integrate the different applications from which it can obtain or to which it can
provide internal data (Internal support, equipment management software, and so on) or external data
(ERP, B2B, B2C). Connect-It integrates not only data, but also a company's application processes.

You can use Connect-It to:

l Transfer information from one database to another.

l Duplicate the information from one database to another in real-time.

l Import information from e-mails, delimited text files, XML files or other formats into a database.

l Export information from a database to e-mails, delimited text files, XML files or other formats.

l Import NT Security-based information into a database.
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HP Service Manager and HP Universal CMDB
Integration
This chapter includes:

Overview 34

Set up Service Manager for Integration with Universal CMDB 35

Set up Universal CMDB for Integration with Service Manager 36

Verify Service Manager and Universal CMDB Integration 37

Overview
This chapter describes the necessary steps to configure and verify the integration between SM and
UCMDB and uses an out-of-the box configuration where a default set of configuration items (CIs) and
their relations are synchronized between UCMDB and Service Manager.
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Set up Service Manager for Integration with Universal
CMDB
This task includes:

Add the UCMDB Connection Information to the System Information Record 35

Add RESTful API to Operator's Capabilities 35

Add the UCMDB Connection Information to the System
Information Record

1. Log on to your SM system as an administrator.

2. From the System Navigator, select System Administration > Base System Configuration >
Miscellaneous > System Information Record.

3. Click the Active Integrations tab.

4. Select the HP Universal CMDB option. The form displays the UCMDB Web service field URL.

5. In the UCMDB Web service URL field, enter the URL to the UCMDB Web service API. The URL has the
following format:

http://<UCMDB server name>:<port>/axis2/services/ucmdbSMService.

6. In the UserId dialog box, enter your UCMDB user name and password and click Save.

Add RESTful API to Operator's Capabilities

1. In the System Navigator, go to System Administration > Ongoing Maintenance > Operators.

2. Enter or select your search criteria, and then click Search.

3. Select an operator from the record list to view the operator record.

4. Click the Startup tab, add RESTful API in the Execute Capabilities section, and then click Save.
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Set up Universal CMDB for Integration with Service
Manager
This task includes:

Create a New Integration Point 36

Create a New Integration Point

1. Log on to UCMDB as an administrator.

2. From the left-hand navigation pane, select Data Flow Management > Integration Studio.

3. In the Integration Point pane, click the New Integration Point button. The New Integration

Point dialog box opens.

Enter the following information:

Name Recommended Value Description

Integration Name SM Integration The name you give to the integration point.

Adapter <user defined> Select the appropriate adapter for the version of
SM you are using.

Is Integration
Activated

selected Select this check box to create an active
integration point.

4. In the Adapter Properties fields, fill in the relevant details.

Name Recommended Value Description

Hostname/IP <user defined> The name of the SM server.

Port <user defined> The port through which you access SM.
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Name Recommended Value Description

Credentials <user defined> If SM credentials appear in the Credentials column,
select them.

If no SM credentials appear, select Generic Protocol and
click the Add new connection details for selected

protocol type button.

Enter the following information:

n Description. Enter Service Manager.

n User Name. Enter the Service Manager user name.
The default value is falcon.

n User Password. Enter and confirm a password.

Probe Name <user defined> Select the name of the Data Flow Probe used to run
population jobs.

5. Click Test Connection.

6. After the connection success message appears, click OK.

7. On the Federation tab, select the Incident, Problem, and RequestForChange CI types and click the

Save Integration Point button.

8. Log on to the JMX console.

9. From the UCMDB section, select UCMDB:service=Multiple CMDB Instances Services.

10. Invoke:

n setAsGlobalIdGenerator and verify it succeeded.

n getGlobalIdGeneratorScopes and verify it succeeded.

Verify Service Manager and Universal CMDB
Integration
This task includes:
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Run the Data Push Jobs 38

Run the Population Jobs 39

Run the Data Push Jobs

Note: To verify that Data Push is working, find a CI in UCMDB that does not appear in SM.

1. Log on to UCMDB.

2. From the left-hand navigation pane, select Data Flow Management > Integration Studio.

3. In the Integration Point pane, click the correct integration.

4. Click the Data Push tab. The Job Definition pane appears.

5. Select your job and click the Run Job – Sync All Data button to run the replication job.

6. When the Confirm synchronizing window appears, click Yes.

7. Click the Refresh button and wait until the Succeeded message appears in the Status tab. The

updated synchronization status appears.

8. Browse to your SM server.

9. From the System Navigator, select Configuration Management > Resources > Search CIs.

10. Click Search and verify that all the CIs from UCMDB are listed in SM.

11. Double-click one CI that is replicated from UCMDB.

12. Drill down to the Actual State section and verify that all parameters are OK.

13. Click View in UCMDB and verify that UCMDB opens and you can view the CI.
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Run the Population Jobs

Note: To verify that population is working, create a new CI in SM.

1. Log on to UCMDB.

2. From the left-hand navigation pane, select Data Flow Management > Integration Studio.

3. In the Integration Point pane, click the correct integration.

4. Click the Population tab.

5. Select the SM Configuration Items Population job and click the Run Job – Sync All Data

button to run the population job.

6. When the Confirm synchronizing window is displayed, click Yes.

7. Click the Refresh button and wait until the Succeeded message appears in the Status tab. The

updated synchronization status appears.

8. Take the same action with the SM Relations Population job.

9. Log on to UCMDB and validate that the CI that was created in SM is validated in UCMDB.
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HP Asset Manager and HP Universal CMDB
Integration
This chapter includes:

Overview 40

Set up Asset Manager for Integration with Universal CMDB 40

Set up Universal CMDB for Integration with Asset Manager 41

Verify HP Asset Manager - HP Universal CMDB Integration 44

Overview
This section describes the necessary steps to configure and verify the integration between UCMDB and
AM as it comes out of the box, without customizing it to specific customer requirements.

Note: For more information about Asset Manager and Universal CMDB integration configuration,
refer to the Discovery and Integration Content Guide - HP Integration in Universal CMDB.

Set up Asset Manager for Integration with Universal
CMDB
In order for the adapter to connect to the appropriate Asset Manager version, you must supply the Data
Flow Probe/Integration Service with the appropriate Asset Manager API DLLs and Jars. To do this, follow
these steps:

1. Copy the following files:
n <Asset Manager Installation folder>\x64\*.dll

n <Asset Manager Installation folder>\websvc\lib\*.jar

2. Create a package called AMPushAdapterAPI_<AM Version Number>.zip. For example, for version
9.41, the package is AMPushAdapterAPI_9.41.zip.
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3. Paste the copied files to:

<AMPushAdapterAPI_{AM Version
Number}.zip>\discoveryResources\AMPushAdapter\amVersion\<AM Version Number>

For example, for version 9.41, the path is:

AMPushAdapterAPI_9.41.zip\discoveryResources\AMPushAdapter\amVersion\9.41

4. Deploy the AMPushAdapterAPI_<AM Version Number>.zip package.

The workflow used by SACM should be active in Asset Manager, to do this, following theses steps:

1. Log on to Asset Manager client.

2. On the Tools menu, point to Workflow, click Workflow schemes.

3. Locate the Update dtRecCreation (SQL name: sysCoreUpCrTime) workflow and the Update last
modify time (SQL name: sysCoreUpMdifyTime) workflow.

4. On the General tab, empty the End field of the Validity pane.

5. Save the changes.

Set up Universal CMDB for Integration with Asset
Manager
Create a new Integration Point for Asset Manager, to do this, follow these steps.

1. Log on to UCMDB.

2. Browse to Data Flow Management > Integration Studio.

3. Click the New Integration Point button.

4. In the New Integration Point dialog box, fill in the following Integration Properties.

Field Required Description

Integration
Name

Yes Type the name (unique key) of the integration point.
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Field Required Description

Integration
Description

No Type a description of the current integration point.

Adapter Yes Select HP Software Products > Asset Manager > AMGenericAdapter.

Is
Integration
Activated

Yes Select this option to indicate the integration point is active.

Hostname/IP Yes Type the hostname or IP Address of the Asset Manager database.

DB Type Yes Select the database type your Asset Manager schema is located on.

DB Port Yes Type the communication port of the Asset Manager database.

DB
Name/SID

Yes n DB2: type in the name of the Database Alias you defined in the
database connection.

n Oracle: type the service name.

n SQL Server: type the name of the schema.

DB Owner
Name

No Enter the owner of the AM database schema.

Credentials
ID

Yes Select Asset Manager Protocol. Create a new protocol, under Asset
Manager Protocol, complete:

n Asset Manager User Name: AM administrator's user name.

n Asset Manager Password: AM administrator's password.

n DB User Name: The AM database user's name.

n DB Password: The AM database user's password.

AM Version Yes Select the version of the Asset Manager this integration point
connects to.

AM
Population
Push Back ID

No Select True to allow the adapter to push the GlobalId of UCMDB CI
back to the corresponding AM entity.
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Field Required Description

AM Other
Connection
Options

No Options can be used in the amdb.ini file. See Asset Manager
Installation guide > Chapter 9: .ini, .cfg, and .res files > Amdb.ini File
Entries.

Enable
Parallel Push

No Select to allow parallel (multi-threaded) data push to Asset Manager.
This improves performance. Note that you must configure SQL Server
& DB2 to support parallel push. See "Prepare Asset Manager for
Parallel Push".

Data Flow
Probe

Yes Select the name of the Data Flow Probe/Integration service used to
execute the synchronization from.

Additional
Probes

No Select additional probes to use when pushing to AM in order to
increase redundancy.

5. Click Test Connection to make sure there is a valid connection.
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Verify HP Asset Manager - HP Universal CMDB
Integration

Run the Data Push Jobs
To verify that Data Push is working, create a Node CI in UCMDB, and then follow these steps.

1. Log on to UCMDB.

2. From the left-hand navigation pane, select Data Flow Management > Integration Studio.

3. Create a new integration point, select the AM Generic Adapter.

4. Select the Integration Pointer, click the Data Push tab page on top right corner from right part.

5. Select out of box push job, then click the Full Synchronization - Runs the selected job,
synchronizing all of the data button.

6. When the Confirm synchronizing window appears, click Yes.

7. Click the Refresh button and wait until the Succeeded message appears on the Status tab. Then,
updated synchronization status appears.

8. To check push result: Go to AM web client, select IT equipment to confirm that all discovered CIs
from UCMDB appear in AM.

Run the Population Jobs
To verify that population is working, create a Business Service CI whose status is not Retired/Consumed
in SM, and then follow these steps.

1. Log on to UCMDB.

2. From the left-hand navigation pane, select Data Flow Management > Integration Studio.

3. In the Integration Point pane, select the AM Generic Adapter.

4. Select the Integration Pointer, click the Population tab page on top right corner from right part .
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5. Select out of box population job, then click the Full Synchronization - Runs the selected job,
synchronizing all of the data button.

6. When the Confirm synchronizing window is displayed, click Yes.

7. Click the Refresh button and wait until the Succeeded message appears on the Status tab. Then,
updated synchronization status appears.

8. To check population result: From the left-hand navigation pane, select Modeling > IT Universe
Manager.

9. Select the Search CIs tab . In the CI type, select Node and click Enter. Confirm that all CIs from AM
appear in UCMDB.
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HP Asset Manager - HP Service Manager
Integration
This chapter includes:

Overview 46

Prerequisites 46

Install and Configure Asset Manager Web Service 49

Install and Configure AM Web Service Proxy 51

Install and Configure HP Service Manager Website 53

Verify Asset Manager - Service Manager Normal Integration 59

Use the Request Self-Service to Verify Asset Manager- Service Manager Integration 60

Overview
This chapter describes the necessary steps to configure and verify the integration between SM and AM
following a request from the catalog. This integration enables the Employee Self Service (ESS) user of
Service Manager to create a request which will be transferred to Asset Manager and will be processed
there until completion (Service Catalog integration).

A typical request handled by this integration includes the procurement of new IT assets—such as the
purchase of a new laptop computer for an employee or a new server for a data center.

Prerequisites
Before integrating AM and SM, there is some data that needs to be synchronized via HP Connect-It (CIT).
This data includes information about People, Places, Things (PPT, not CIs), commonly referred to as PPT
in the description described in this chapter. Depending on the current customer implementation phase,
the master data source can be either Service Manager or Asset Manager—or each product will contain
master data for specific record types.

By default, the provided HP Connect-It scenarios transfer the same PPT types from AM to SM and from
SM to AM. You cannot implement the scenarios as they are, because data replication would circle back
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and forth. Therefore, you must decide whether the AM or SM database will store the reference data for
each of the PPT types:

l Companies

l Vendors

l Locations

l Departments

l Contacts

l Models

l Stock rooms

Run scenarios to synchronize PPT data between AM and SM:

1. Install HP Connect-It 9.60.

2. Download the SACM 9.40 content pack from HPLN(https://hpln.hp.com) and unzip it to C:\SACM940.

3. The HP Connect-It scenarios depend on the SACM Integration Web Service. You need to add this
web service to SM:

a. Log on to HP Service Manager client with administrative rights.

b. Select Menu Navigation > Tailoring > Database Manager in the navigation pane.

c. Right-click the screen in the right pane and select Import/Load.

d. In the File Name field, enter C:\SACM940\datakit\sc\sm94\SACMintegration.unl.

e. Click Load FG.

f. Select Menu Navigation > Tailoring > Web Services > Web Service Configuration in the
navigation pane

g. In the Service Name field, enter SACMIntegration.

h. Click Search.

Verify that you see a list of entries prefixed with SACM.
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4. Open HP Connect-It , browse to C:\SACM940.

5. Select one of the following scenarios:

n If the reference database for all PPT types is AM:

o Use amsm-ppt.scn to transfer the PPTs from AM to SM.

o Do not use amsm-ci-ppt-link.scn because links between CIs and Contact, Model,Vendor,
Location and Department are managed by the amsm-ppt.scn scenario.

n If the reference database for all PPT types is SM:

o Use smam-ppt.scn to transfer the PPTs from AM to SM.

o Use smam-wo.scn to transfer changes and tasks.

n If the reference database for PPT types is a mixed solution between AM or SM according to PPT
type:

o Customize smam-ppt.scn so that PPTs referenced in SM are transferred to AM.

o Customize amsm-ppt.scn so that PPTs referenced in AM are transferred to SM.

o Do not use amsm-ci-ppt-link.scn because links between CIs and Contact, Model,Vendor,
Location and Department are managed by the amsm-ppt.scn scenario.

o Use smam-wo.scn to transfer changes and tasks.

6. For each scenario, define the AM details and SM details.

7. After all the details are defined in the components, click Produce now to run the scenario.

Note: In an environment where an Employee Self Service (ESS) Catalog integration is planned (as
described in "Use the Request Self-Service to Verify Asset Manager- Service Manager Integration"
on page 60), it is necessary to disable Contact synchronization in order to prevent possible data
duplication.

To disable the synchronization of Contact records:

1. Open the amsm-ppt.scn scenario in Connect-It.

2. In the Scenario diagram pane, select the Mapping box, and then select the Mappings tab.
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3. In the Detail of the connector 'Mapping' pane, uncheck Creation of a contact and Update a
contact.

4. Save the changes and exit the scenario.

Install and Configure Asset Manager Web Service
This section shows you how to install and configure AM web service. For more information about Asset
Manager web configuration, refer to the Installation and upgrade guide.

1. Install JDK 7 and configure the environment variable of the JAVA_HOME to JDK folder; for example,
C:\Java\jdk1.7.0_65.

2. Install Apache Tomcat7.0.42 to C:\Tomcat7042.

3. In order for some required libraries to be found by AM Web, make sure <Asset Manager Installation
folder>\bin or <Asset Manager Installation folder>\bin\x64 is in an environment variable of path.

4. Implementing AM Automated Process Manager in Windows:

a. Browse to Start > Run.

b. Type services.msc.

c. Select Asset Manager Automated Process Manager 9.41 and change the startup type to
automatic.

d. Click Start and OK.

e. Browse to Start > All Programs > HP > Asset Manager 9.41 en > Automated Process Manager.

f. Click File to connect to the new database.

g. Select the relevant database and enter the credentials.

5. Start the Tomcat configuration console (In Windows, click Start >All Programs > Apache Tomcat
7.0 Tomcat7 > Configure Tomcat), click the JAVA tab, populate the following fields:
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Field Value

Java
Virtual
Machine

C:\Java\jdk1.7.0_65\jre\bin\client\jvm.dll

Java
Classpath

C:\Java\jdk1.7.0_65\lib\tools.jar;C:\Tomcat7042\bin\bootstrap.jar

Java
Options

Add the following lines:

-Djava.library.path=<Asset Manager Installation folder>\bin
-Dsun.lang.ClassLoader.allowArraySyntax=true

Note: If you are running the x64 version of Windows Server 2008, the path
needs to be replaced by -Djava.library.path=<Asset Manager
Installation folder>\x64 -XX:MaxPermSize=128m.

Initial
memory
pool

512 (or another value adapted to your computer)

Maximum
memory
pool

1024 (or another value adapted to your computer)

Thread
stack
size

1000 (or another value adapted to your computer ; it should be less than the total
RAM of the computer ; at least 250 Mb less than the total RAM of the computer)

6. Make a backup copy of <Asset Manager Installation folder>\websvc, and then edit the parameters
in the <Asset Manager Installation folder>\websvc\package.properties file. For parameter
descriptions, see the Installation Guide of Asset Manager.

7. Open a command-line prompt, go to the <Asset Manager installation folder>\deploy folder, run the
command:

deploy.bat ..\websvc\package.properties

If you are running the x64 version of Windows Server 2008, run the following command instead:

deploy.bat /x64 ..\websvc\package.properties
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8. Copy <Asset Manager installation folder>\websvc\AssetManagerWebService.war to
C:\Tomcat7042\webapps.

9. Start Tomcat.

10. Open a browser and go to following URL:

http://<Name or IP address of the Asset Manager Web Service server>:<Asset
Manager Web Service port>/AssetManagerWebService

For example, http://localhost:8080/AssetManagerWebService

11. Make sure that the following page appears.

Install and Configure AM Web Service Proxy
The web service proxy is an interface that is used to convert a query to create a purchase request from
the HP Service Manager catalog into a series of calls to Asset Manager web service which enable the
purchase request to be created in Asset Manager.

You can install the web service proxy on any computer (for example, on the computer that runs Asset
Manager web service).
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1. Install Apache Ant ( http://ant.apache.org) on the computer where you want to set up the web
service proxy.

2. Install Java SE.

3. Back up <Asset Manager installation folder>\esscat\build\ant.properties.default
and rename the duplicated file to ant.properties.

4. Edit ant.properties and change the ws.host, ws.port and ws.service parameters to have the
http://<ws.host>/<ws.port>/<ws.service> link point to the computer where Asset Manager
web service is installed.

5. Open a command-line prompt and go to the <Asset Manager installation
folder>\esscat\build\ folder.

Execute the following command:

ant webapp

6. Deploy the generated ServiceCatalog.war file on your application server by following the
standard procedure.

7. Because the Java virtual machine launched by the application server uses a lot of memory, you
need to increase the available memory to at least 256 MB. To do so, modify the JVM (Java Virtual
Machine) MaxPermSize parameter with the following switch:

-XX:MaxPermSize=256m

If you are using the Tomcat application server, follow these steps.

a. Start the Tomcat configuration console (Start >All Programs > Apache Tomcat 7.0 Tomcat7 >
Configure Tomcat Windows menu).

b. Select the Java tab.

c. Add the following line to the Java Options section:

-XX:MaxPermSize=256m

d. Close the Tomcat configuration console.

8. Create ESS reference records in Asset Manager.

The different items that need to be created beforehand in Asset Manager are:
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n Employees that can connect to the database and use the request self-service system
(amEmplDept table). These employees must have a user account and password.

n Employees for whom a request is made (amEmplDept table).

n Standard request and product models (amModel table).

n Standard requests (amRequest table), products (amCatProduct table) and off-catalog products
(amModel table).

Install and Configure HP Service Manager Website
This section shows how to install and configure Service Manager website.

Installation

1. Stop and copy SM web tier war file to TOMCAT_HOME\webapps\ and rename it to sm940.war.

2. Start Tomcat to deploy this war file.

3. Search and modify these value of parameters in web.xml under
C:\Tomcat7042\webapps\sm940\WEB-INF\.

<context-param>
<param-name>secureLogin</param-name>
<param-value>false</param-value>

</context-param>

Set this value to false if Service Manager is not configured as secure login.

<param-name>serverHost</param-name>
<param-value>192.168.0.1</param-value>

</init-param>

This IP address goes to the SM server. Generally, the param-value should be "localhost".

<init-param>
<param-name>serverPort</param-name>
<param-value>13080</param-value>

</init-param>
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The SM service port is specified in the installation wizard. The initial value is 13080. If that is
incorrect, contact the technician who installed the SM server (sm.ini).

4. Remove sm940.war, and then restart Tomcat.

5. Test SM web with the following URL.

http://<Name or IP address of the SM Web client server>:<SM Web client server
port number>/<SM instance name>/index.do

For example:

http://localhost:8080/sm940/index.do

6. For ESS user, test http://<Name or IP address of the SM Web client server>:<SM Web
client server port number>/<SM instance name>/ess.do

For example:

http://localhost:8080/sm940/ess.do

Configuration
If you already have a full version of HP Service Manager, make sure that you have installed HP Service
Manager web for an ESS (Employee Self-Service) user or consult the HP Service Manager installation
guide to install it.

1. Disable the request validation.

a. Log on to the SM website.

b. In the browser, select Menus Service Catalog > Administration > Approval Activities.

c. Select the first line of the General Approval table.

d. Click the Remove Approval Activity link.

e. Click Finish.

2. Enable the transfer of catalog items.
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a. Log on to the SM website with administrative rights.

b. Select Menu Tailoring > Database Dictionary in the navigation pane.

c. Enter svcDisplay in the File name field, click Search.

d. Select the descriptor entry in the table (first line of the table, do not click the name column).

e. Click the New Field/Key button.

f. Populate the Name field with the optionList value, the Type field with the character value, and
click Add Field.

g. Edit the optionList entry in the table to populate the SQL Name field with OPTIONLIST, SQL Type
with IMAGE, and SQL Table with m1, then click OK.

h. Click OK, click SM Alters.

i. Enter svcDisplay in the File name field, click Search.

j. Select the descriptor entry in the table (first line of the table) again.

k. Click the New Field/Key button.

l. Populate the Name field with the optionOptions value, the Type field with the character
value,and click Add Field.

m. Edit the optionOptions entry in the table to populate the SQL Name field with OPTIONOPTIONS,
SQL Type with IMAGE, and SQL Table with m1, and then click OK.

n. Click OK, click SM Alters.

o. Select Tailoring > Database Manager.

p. Click More > Import/Load.

q. In the File Name field, select the <Asset Manager Installation
folder>\esscat\sc\sm71\SCR42940.unl file path, and then click the Load FG button.

r. Wait until you get a message like "SCR42940.unl file loaded".

3. Enable the transfer of images.
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a. Log on to SM website with administrative rights.

b. Select Tailoring > Database Manager.

c. Click More > Import/Load.

d. Right-click the Database Manager screen and select Import/Load in the contextual menu.

e. In the File Name field, select the <Asset Manager Installation
folder>\esscat\sc\sm71\QC8955.unl file, and then click the Load FG button.

f. Wait until you get a message like "QC8955.unl file loaded".

4. Expose the detailed Description field in the ServiceCatalog web service so that the cart status can
be updated by the HP Connect-It scenario.

a. Log on to the SM website with administrative rights.

b. Select Tailoring- Web Services > Web Service Configuration from the navigation bar.

c. In the Service Name field, enter ServiceCatalog, click Search.

d. Select the ServiceCatalog entry in the list of results, uncheck the Deprecated option.

e. In the details of the ServiceCatalog web service, select the Fields tab.

At the end of the list of fields, add a new entry with the following information:

o Field: detailedDescription

o Caption: DetailedDesc

o Type: StringType

f. Click Save and OK.

5. Expose the resolution field in the ServiceDesk web service so that images can be transferred from
Asset Manager to HP Service Manager by the HP Connect-It scenario.

a. Log on to the SM website client with administrative rights.

b. Select Tailoring > Web Services > WSDL Configuration from the navigation bar.

c. In the Service Name field, enter ServiceDesk, click Search.
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d. Select the ServiceDesk entry in the list of results.

In the details of the ServiceDesk web service, select the Fields tab.

e. At the end of the list of fields, modify the resolution field with the following information:

o Caption: Resolution

o Type: StringType

f. In the same list, modify the resolution.code field with the following information:

o Caption: ResolutionCode

g. Click Save and OK.

6. As the web service proxy acts as a link between HP Service Manager and Asset Manager Web
Service, you will need to configure the links between these elements.

To configure the link between HP Service Manager and the web service proxy, configure the
Catalog connector in HP Service Manager as follows:

a. Log on to SM website with administrative rights.

b. Select Service Catalog > Tailoring > Catalog Connectors.

c. Click Search.

d. Select the connector named Open a Standard Request in Asset Manager.

e. On the Expressions tab, enter the path to the web service proxy just after $L.url:

$L.url="http://<Name or IP address of the AM Web Service Proxy>:<AM Web
Service Proxy port number>/ServiceCatalog/services/ServiceCatalog"

For example:

$L.url="http://ProxyServer:8080/ServiceCatalog/services/ServiceCatalog"

f. Enter user account and password value for $L.login and $L.pwd, for example:

$L.login="Admin"

$L.pwd=""

7. Update the AM web service proxy JAVA script.
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a. Log on to the SM website with administrative rights.

b. Select Tailoring > Web Services > Run WSDL to JS.

c. Enter the URL for the WSDL of Asset Manager web service proxy.

The format is:

http://<Name or IP address of the AM Web Service Proxy>:<AM Web Service
Proxy port number>/ServiceCatalog/wsdl/ServiceCatalog.wsdl

For example:

http://ProxyServer:8080/ServiceCatalog/wsdl/ServiceCatalog.wsdl

d. Click Proceed.

This displays a window with the new Java script corresponding to the web service proxy.

e. Click Replace.

You should get the following message:

Successful compilation of JavaScript function or expression.

f. Click Save.

g. Click Compile.

You should get the following message:

Successful compilation of JavaScript function or expression.

8. Activate the linker scheduler.

a. Log on to SM website with administrative rights.

b. Select Miscellaneous > System Status.

c. Check linker that appears in the list.

d. If the linker scheduler already appears in the list, restart it.

i. In the Command column of the linker line, enter K.

ii. Click the Execute Commands button.
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iii. Repeat this action until the linker line disappears.

e. Click the Start Scheduler button.

f. Double-click linker-startup in the list.

9. Configure User profiles for ESS(Employ Self Service).

a. Log on to SM website with administrative rights.

b. Select System Administration > Ongoing Maintenance > Operators.

c. Enter Template_SelfService in the Login Name field, and then click Search.

d. On the Self Service tab, check the Self Service Access Only checkbox.

e. On the Startup tab, section Execute Capabilities, if svcCatEmployeeRequester is not in the
list, add svcCatEmployeeRequester to the first empty line of the table

f. Save your changes

Verify Asset Manager - Service Manager Normal
Integration
To verify the normal integration of Asset Manager and Service Manager, follow these steps.

1. Log on to the SM website and open a new change request.

2. Browse to Change Management > Changes > Create New Change.

3. Enter all relevant data and mandatory fields.

4. Click Save.

5. Open HP Connect-It.

6. Open the scenario smam-wo.scn.

7. Fill the relevant parameters for each product.

8. Click Produce Now .
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9. Log on to HP Asset Manager.

10. Browse to Asset Lifecycle > Work Orders > Work Orders.

11. Confirm that AM receives the change request .

Note: This out-of-the-box integration synchronizes all Change and Change Tasks records from
Service Manager to Asset Manager. In the production environment, the user may want to limit the
scope for specific Change categories. To achieve this, there is a need to modify the smam-wo.scn
scenario.

Use the Request Self-Service to Verify Asset Manager-
Service Manager Integration

1. Run the OOB scenarios in Connect-It to synchronize the basic data from Asset Manager to Service
Manager.

a. Open Connect-It 9.60, click File > Open.

b. Open and run scenarios located in <HP Connect-It installation
folder>\scenario\ac\am94\esscat\am94sm933\ in the following order.

o users.scn: Synchronization of employees

o sso.scn: Synchronization of logins

o categories.scn: Synchronization of standard request and product models

o catalogitems.scn: Synchronization of standard requests, products and off-catalog products

o status.scn:Synchronization of request/cart statuses

c. In the Scenario diagram window, modify the configuration of the SM web service connectors
and AM connectors.

d. Save your changes.

e. Run the scenarios.
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2. Check the operator in Service Manager.

a. Log on to SM website with administrative rights.

b. Select System Administration > Ongoing Maintenance > Operators.

c. Enter the logon name(amEmplDept.name in AM) in the Login Name field, for example, Shivute,
who is administrator in AM.

d. On the Self Service tab, make sure that the Self Service Access Only option is selected.

e. On the Startup tab, the user has the following execute capabilities:

o partial.key

o partial.key.msg.skip

o service desk

o service catalog

o change request

o svcCatEmployeeRequester

o svcCatDeptRequester

3. Create the request self-service.

a. Log on to the SM ESS website (http://<Name or IP address of the SM Web client server>:<SM
Web client server port number>/<SM instance name>/ess.do) with a user account that has
self-service right.

b. Select Miscellaneous > Order from Catalog.

c. Select a service catalog in the right list which is from Asset Manager, for example: Deskpro HP
EliteDesk 800 G1 (000025).

d. Select the user in the list for Request for field, select the Quantity, add attachments if
needed.

e. Click Add to Cart, you will get a message like :

Deskpro HP EliteDesk 800 G1 (000025) has been added to your cart.
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f. Click View Cart/Checkout.

g. Click Submit Request.

h. Enter values in the Purpose and Urgency fields.

i. Click Submit.

j. Log on to AM, from menu Asset lifecycle > Procurement lifecycle > Purchase requests, the
request created in SM should be in the list.

k. The request is then processed in Asset Manager and the standard procurement cycle is
triggered.

l. The status of the cart is updated in HP Service Manager through the status.scn scenario in HP
Connect-It.

For more information about the HP Service Manager Service Catalog and the request creation
procedure in HP Service Manager, refer to the Service Catalogs section of the HP Service Manager
online help.
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CI's Reconciliation Priority Best Practices
This chapter includes:

Overview 63

Priorities Logic 63

CI Reconciliation Priority 65

Overview
In the SACM Solution, as well as from the ITPS Suite perspective, UCMDB is the center CI repository. As
such, it is populated with CI information from various HP and third-party products. Therefore, UCMDB
must decide which source is more reliable and which source has the most accurate information.

UCMDB uses internal out-of-the-box reconciliation rules that make sure no duplications are created and
the CI information is accurate. In addition, it also uses the Reconciliation Priority module that gives the
Configuration Manager the power to determine for UCMDB which integration points are more reliable
for which CI Types or Attributes (for more information, see Chapter 10 Reconciliation Priority in the HP
UCMDB Data Flow Management Guide).

In the SACM Solution, UCMDB is populated with CI information from two products – AM and SM.

This chapter details the Best Practice guidelines and configuration instructions for how to prioritize the
information received from AM and SM into UCMDB in order for your UCMDB to contain the most accurate
CI information.

Priorities Logic
Consider the following when building the priorities detailed in the following CI Reconciliation Priority
Mapping table:

l UCMDB DDMA discovery reflects reality by its capability and is the most reliable source of
information for discoverable CITs.

l Business services and applications information is most likely to be more accurate in SM as the owner
of the Service Catalog.

HP Service Asset and Configuration Management (SACM) Solution (9.40) Page 63 of 79



l There are CITs that are coming from AM or SM—but not both. Thus, if it is a discoverable CIT, DDMA
will get the highest priority, and AM or SM will get the lower priority. Otherwise, the relevant product
will get the priority. For example, for the Asset CIT, AM gets the highest priority.
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Note: The following table of priorities is based only on CITs and Attributes that are supported by
the Out-of-the-Box (OOTB) population integration.

The CI Reconciliation Priority Mapping table maps the various CITs and attributes between the three
products—UCMDB, AM, and SM. The table also contains the necessary values to be defined for each
integration point using the following instructions.

CI Reconciliation Priority
One of the challenges of managing an asset in its lifecycle phase as an active CI is to have as much
information on it as possible collected from various systems—in addition to Discovery (such as
business-related information)—but at the same time prevent duplication in the CMS system and, most
importantly, keep the data's integrity. For these reasons, UCMDB holds the reconciliation capability and,
in addition, allows the Configuration Manager to set priorities for the various sources of CIs.

In the SACM Solution, we have three sources – AM, SM and DDM. As part of the Solution’s assets, there
are Best Practices guidelines on how to set the Reconciliation Priority between AM, SM and DDM.
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To configure CI Reconciliation Priority

1. Log on to UCMDB as an administrator.

2. From the left-hand navigation pane, select Data Flow Management > Reconciliation Priority.

3. In the CI Types pane, in the Managed Object tree, select the relevant CI type.

4. In the CI Type Overrides pane, select the integration name you wish to change the priority value for
and click the Priority field to modify the value.

Repeat this step for every Integration Name you wish to change the Priority value for.

5. When the changes for the CI types are complete, click the Save button in the CI Types pane.

To set the priority for a specific attribute for a particular CI type:

1. Select the relevant integration name in the CI Type Overrides pane.

2. In the Attribute Overrides pane, click the Add button. The Add Attribute dialog box is displayed.

3. Select the relevant Attribute from list and click OK. The selected CI Attribute appears in Attribute
Overrides pane.

4. Modify the Priority value.

Note: If you add the wrong attribute to the list, use the Reset Attribute button to reset

the Attribute Overrides list. Be aware this action clears all values in the Attribute Overrides
list.

5. When finished with the changes to that CI type, click the Save button in the CI Types pane.
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Technical Reference
This Appendix includes:

Overview 67

HP Service Manager <-> HP Asset Manager 67

Overview
This appendix explains, for each database involved in the SACM integration, which data objects are
sourced and mapped by which scenario or adapter, as well as the reconciliation keys used and any
special requirements needed for data transfers to work properly.

HP Service Manager <-> HP Asset Manager
This section includes:

Overview 67

What happens when a CI does not exist in SM 68

Reconciliation keys for amsm-ppt.scn 69

Reconciliation keys for amsm-ci-ppt-link.scn 72

Reconciliation keys for smam-ppt.scn 73

Reconciliation keys for smam-wo.scn 78

Overview
Overview of the HP Asset Manager – HP Service Manager integration

Integration
direction From AM to SM From SM to AM

Integration
technology

HP Connect-It HP Connect-It
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Integration
direction From AM to SM From SM to AM

Populated data l amsm-ppt.scn:

n Companies

n Vendors

n Locations

n Departments

n Contacts

n Models

n Stock rooms

n Links between CIs and Contact, Model,
Vendor, Location, Department

l amsm-ci-ppt-link.scn

n Links between CIs and Contact, Model,
Vendor, Location, Department

l smam-ppt.scn:

n Companies

n Vendors

n Locations

n Departments

n Contacts

n Models

n Stock rooms

l smam-wo.scn:

n Changes and
tasks

HP Connect-It
scenarios

l amsm-ppt.scn

l amsm-ci-pptlink. scn

l smam-ppt.scn

l smam-wo.scn

Note: These scenarios do not create CIs. CIs are created in AM directly or created in HP Discovery
and Dependency Mapping Inventory and populated in AM.

AM CIs are populated/federated to UCMDB.

UCMDB CIs are populated to SM.

What happens when a CI does not exist in SM
If a CI does not exist in SM yet when a PPT/CI link is presented, an AM output event is created by the
HP Connect-It scenarios.

HP Connect-It will try and process the output events whenever the scenario is rerun.

Note that output events automatically expire according to the AM database options:
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1. Start the AM Windows client and connect to the database.

2. Use the Administration/ Database options... menu.

3. Configure the Event management/ Expiration time for output events (hours) option.

Reconciliation keys for amsm-ppt.scn
This section includes:

Companies 69

Vendors 69

Locations 70

Departments 71

Contacts 72

Models 72

Stock rooms 72

Companies

Key in SM AM value searched for in the SM key

company:customer.id amCompany.Code

Only AM companies for which amCompany.Qualif1 = Parent company are replicated.

For languages other than English, the <HP Connect-It installation folder>\config\ac\strings\qualif.str file
must be customized. The ID of the string to modify in this file is AMQUALIF_PARENT. Replace Parent
company with the right string for your language.

The AM amCompany:Code field must be populated.

Vendors

Key in SM AM value searched for in the SM key

vendor:vendor amCompany.Name

AND vendor:location amCompany.MainSite:Barcode
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Locations

Key in SM AM value searched for in the SM key

location:location amLocation.BarCode

The AM amLocation.BarCode field must be populated.
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Departments

Key in SM AM value searched for in the SM key

dept:company +
dept:dept

amEmplDept.Location.Company.Code Reconciliation uses the following rule:

RetVal = RemoveSlashAtExtremity([FullName])

If [Location.Company.Code] <> "" Then

RetVal = [Location.Company.Code] & "/"

_

& RetVal

End If

Example:

In AM, we have four departments:

l Department NameA

FullName = /NameA/

l Department NameB under NameA

FullName = /NameA/NameB/

l Department NameC under NameB

FullName = /NameA/NameB/NameC/

l Department NameD under NameC

FullName = /NameA/NameB/NameC/NameD/

NameD is linked to a location linked to a company with amCompany.Code
= COMPANY_CODE SM.

The key for NameD is COMPANY_CODE/NameA/NameB/NameC/NameD.

The key for NameC is NameA/NameB/NameC.

Only AM departments for which amEmplDept.bDepartment = 1 are replicated.
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Contacts

Key in SM AM value searched for in the SM key

contacts:contact.name amEmplDept.Name, Name.FirstName (amEmplDept.BarCode)

Note:

l amEmplDept:Name can be up to 50 characters long, Name:FirstName up to 30 characters, and
amEmplDept.BarCode up to 255 characters long.

l contacts.contact.name can only store 140 characters.

l If the amEmplDept.BarCode field does not exceed 55 characters, the reconciliation keys work
fine.

Models

Key in SM AM value searched for in the SM key

model:part.no amModels.BarCode

Note: The AM amModels.BarCode field must be populated.

Stock rooms

Key in SM AM value searched for in the SM key

stockroom:stockroom amStock.Name

Reconciliation keys for amsm-ci-ppt-link.scn
This section includes:

Links between device CIs and PPT objects 73
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Links between device CIs and PPT objects

Key in SM AM value searched for in the SM key

device:asset.tag amComputer.AssetTag

Devices are linked to the
following objects:

l Contact

l Model

l Vendor

l Location

l Department

The same keys are used as for the transfer of PPTs themselves.
See tables above.

The AM amComputer:AssetTag field must be populated.

Reconciliation keys for smam-ppt.scn
This section includes:

Locations and their link to a company and a country 74

Companies 74

SM Companies replicated as AM departments 74

Departments 75

Contacts 75

Operators 75

Vendors 76

SM vendor sites replicated as companies in AM 77

Stocks 77

Models 77

The smam-ppt.scn scenario uses the SACMIntegration web service.
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Locations and their link to a company and a country

Key in AM SM value searched for in the AM key

amLocation.BarCode location:location

amCompany.Code location:company

amLocation.Country.Name location:country

If no country can be found for which amCompany:Code = location:country, the location will be linked to
a location with amCompany:Code = Unknown country.

Make sure the AM amCompany:Code field is populated.

Make sure the AM amCountry:Name field is populated with unique values.

smam-ppt.scn uses the ScCountryToAc map table in the catmod.mpt file to map SM countries to AM
countries.

Companies

Key in AM SM value searched for in the AM key

amCompany.Code company:CompanyCode

amCompany.MainSite.Name company:CompanyCode

amCompany.Sites.Name company:CompanyCode

Make sure the AM amCompany.CompanyCode field is populated with unique values.

Make sure the AM amCompany.Code field is populated.

SM Companies replicated as AM departments

Key in AM SM value searched for in the AM key

amEmplDept.BarCode company:CompanyCode

amEmplDept.Location.FullName company:CompanyCode

Make sure the SM amCompany.CompanyCode field is populated with unique values.

amEmplDept.bDepartment is set to 1.
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Departments

Key in AM SM value searched for in the AM key

amEmplDept.FullName dept:dept.structure

amEmplDept.bDepartment is set to 1.

A function converts dept:dept.structure to amEmplDept.FullName.

Contacts

Key in AM SM value searched for in the AM key

amEmplDept.BarCode contacts:contactname

amEmplDept.Location.BarCode contacts:location

amEmplDept.Parent.FullName contacts:dept

Make sure the SM contacts:locationcode field is populated with unique values.

Operators

Key in AM SM value searched for in the AM key

amEmplDept.BarCode operator:name

amEmplDept.WorkUnit.Description operator:name

amEmplDept.WorkUnit.Model.Name The scenario links the employee to the model for which
amModel.Name = Hourly rate

Operators is an extension of the contacts table.

After contacts have been imported, operators are imported to populate amEmplDept.WorkUnit.

A model is created in AM with amModel.Name = Hourly rate.

This model is linked to a nature (which must pre-exist) with amNature.Code = TCO_WORK_UNIT and
also linked to a parent model which amModel.Name = Work unit and which will be created if it does not
exist.

The parent model must also be linked to a similar nature.

Configuration Guide
Technical Reference

HP Service Asset and Configuration Management (SACM) Solution (9.40) Page 75 of 79



This must be created by hand or can be retrieved through the import of Financials – Line-of-business
data (TCO-budgets-chargeback).

Vendors

Key in AM SM value searched for in the AM key

amCompany.Name vendor:vendor

amCompany.MainSite.FullName vendor:vendor.id +
vendor:vendor.location

amCompany.MainSite.Country.Name vendor:country

amCompany.Contact.FirstName + amCompany.
Contact.Name

l vendor:contract.person

l vendor:order.person

l vendor:sales.mgr

l vendor:service

Make sure vendor:contract.person, vendor:order.person, vendor:sales.mgr and vendor:service use
the <Last name>, <First name> format.

This is split into amCompany.Contact.FirstName and amCompany.Contact.Name in AM.

Make sure the SM vendor:vendor field is populated with unique values. If two different SM vendors have
the same value for the vendor:vendor field in SM in different locations, only the first vendor is imported
to AM.

Make sure the SM vendor:vendor.location + vendor:vendor.id fields are populated with unique values.
If two SM vendors have the same value for the vendor:vendor.location field and for the
vendor:vendor.id field although they are linked to different locations (address differs), the two vendors
will be linked to the same location (the first that was transferred to AM)

Make sure the AM amCountry.Name field is populated with unique values.

The HP Connect-It scenario uses the ScCountryToAc map table in the catmod.mpt file to map
amCountry.Name.
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SM vendor sites replicated as companies in AM

Key in AM SM value searched for in the AM key

amLocation.FullName vendor:vendor.id + vendor:location are used to create a full name

amLocation.Company.Name vendor:vendor

Make sure the SM vendor:vendor.id + vendor:location fields are populated with unique values. If two
SM vendors have the same value for the vendor:vendor.id + vendor:location fields although they are
linked to different locations (address differs), the two vendors locations will result in a single location in
AM (the first that was transferred to AM)

When vendors were created (see "Vendors" on the previous page), if two different SM vendors have the
same value for the vendor:vendor field in SM in different locations, only the first vendor is imported to
AM. So when the location created by this mapping is linked to a company, it may be associated to the
wrong company.

Stocks

Key in AM SM value searched for in the AM key

amStocks.Name stockRoom:stockroom

amStock.Supervisor.BarCode stockRoom:manager

amStock.DelivLocation.Field1 location:location

Models

Key in AM SM value searched for in the AM key

amModel.BarCode model:part.no

amModel.Brand.Name +
amModel.Brand.Com-
model:manufacturer
pany.Name

model:manufacturer

amModel.Nature.Code model:Category
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Key in AM SM value searched for in the AM key

amModel.Parent.BarCo
de

model:Category

amModel.Photo if
[RetrieveSACMModelResponse.model.instance.attachments.attach
ment(0).name] = "" then RetVal =
[RetrieveSACMModelResponse.mod el.instance.Model] + "_" +
[RetrieveSAC MModelResponse.model.instance.PartNumber] else
RetVal = "SM_" & [RetrieveSACMModelResp
onse.model.instance.attachments.attachment(0).name] end if

amModel.Nature.Code is mapped using the ScToAcNature map table located in <HP Connect-It
installation folder>\scenario\ac\ac53\sacm\mpt\catmod.mpt.

The natures listed in the ScToAcNature map table must exist in the AM database.

A model is not created in AM unless at least one of following is populated in SM: model:Model,
model:PartNumber, model:Category.

Reconciliation keys for smam-wo.scn
This section includes:

Changes > Workorders 78

Tasks > Workorders 79

For the corresponding CI 79

This scenario propagates details of unplanned changes and tasks from SM to AM as Work Orders.

The relevant links between CIs and PPT data are propagated from AM to SM by another HP Connect-It
scenario.

Changes > Workorders

Key in AM SM value searched for in the AM key

amWorkOrder.WoNo cm3r:header.number
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Tasks > Workorders

Key in AM SM value searched for in the AM key

amWorkOrder.WoNo cm3t:header.number

For the corresponding CI

Key in AM SM value searched for in the AM key

amComputer.AssetTag device:logical.name
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