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Chapter 1: Introduction
TheOMi Management Pack for SAP Sybase ASE (OMi MP for SAP Sybase ASE) works with
Operations Manager i (OMi) and enables you tomonitor SAP Sybase ASE (Adaptive Server Enterprise)
servers in your environment and its underlying infrastructure using the Business ServiceManagement
(BSM). TheOMi MP for SAP Sybase ASE includes the following components for monitoring the health
and status of the SAP Sybase ASE Servers:

l SAP Sybase ASE Management Templates

l SAP Sybase ASE Aspects

l Parameters

l Run-time ServiceModel (RTSM) Views

l Event Type Indicators (ETIs)

l Health Indicators (HIs)

l Graph Templates

l Tools

Note: Formore information about the components, see theOMi Management Pack for SAP
Sybase ASE Online Help orUser Guide.

Abbreviations Used in this Manual
Abbreviations Expansion

OMi Operations Manager i

RTSM Run-time ServiceModel

OMi MP OMi Management Pack

OMi MP for SAP Sybase ASE OMi Management Pack for SAP Sybase ASE
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Related Documentation
Formore information about OMi MP for SAP Sybase ASE, see the following documents:

l OMi MP for SAP Sybase ASE -Release Notes

l OMi MP for SAP Sybase ASE -User Guide

Licensing
TheOMi MP licenses are available in a pack of 25 license units. Each license can be used per OS
instance, irrespective of the application type. For example, the license pack can contain 5 licenses of
OMi MP for Microsoft Skype for Business Server, 10 licenses of OMi MP for Oracle Database with any
other combination of supported applications.

There are three types of licenses:

l Evaluation: A license with a fixed trial period of up to 60 days. This type of license is available only
until a Time Based or Permanent license is purchased. Once purchased, the trial period
immediately terminates.

l Term: A license that has a time-based expiration date.

l Perpetual: A license that does not expire.

To procure the license for the Entitlement Order Number (EON), go to http://enterpriselicense.hpe.com
and log on using your HPE Passport credentials to redeem the license.

For information about applying the license, see "Applying the License".
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Chapter 2: Installing OMi MP for SAP
Sybase ASE
This section provides information about installing OMi MP for SAP Sybase ASE on BSM 9.2x or OMi
10.x (Linux orWindows) servers.

Installation Media
The following section provides information about the installationmedia for OMi MP for SAP Sybase
ASE. TheOMi MP for SAP Sybase ASE is available in the OMi MP for SAP Sybase ASE DVD
(MPDVD) and also through electronic media (e-media). TheMPDVD and e-media are available for
English and Non-English locale environments. You can use the appropriate installationmedia based on
your locale requirements.

Product Marketplace links

OMi MP for SAP Sybase ASE UnifiedMarketplace

TheOMi MP for SAP Sybase ASE DVD and e-media contains the software and the product
documentation. In a distributed environment, it must be installed on all BSM or OMi Data Processing
Servers (DPS) and BSM or OMi Gateway Servers (GWS).

The following table provides information about the documentation available in theMPDVD and the e-
media:

Document Location Purpose

Online Help Available in the BSM consoleHelpmenu.

From the BSM console, go toHelp > BSM Help >
Application Administration > Operations
Management > OMi Management Pack for SAP
Sybase ASE

Available in the OMi console menu.

From theOMi console, go to > General Help >
Administration Guide > Management Packs >
OMi Management Pack for SAP Sybase ASE.

To provide information
about the following:

l Using SAP Sybase
ASE Management
Templates

l Using SAP Sybase
ASE Aspects and
Policy Templates

l Using Indicators -
HIs and ETIs
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Document Location Purpose

Installation Guide <MPDVD>\DOCUMENTATION\en

User Guide <MPDVD>\DOCUMENTATION\en

Release Notes <MPDVD>\DOCUMENTATION\en To provide information
about the following:

l Salient Features

l Installation Notes

Installation Prerequisites
The following section lists the hardware and software prerequisites for installing OMi MP for SAP
Sybase ASE on BSM 9.2x or OMi 10.x (Linux andWindows) Servers.

Software Requirements
Before installing OMi MP for SAP Sybase ASE version 1.00, the following components must be
installed and configured on the BSM 9.2x or OMi 10.x Servers.

Server Requirements

Component Version

BSM 9.23 or higher*

Operations Manager i 9.23 or higher*

Monitoring Automation 9.23 or higher*

OMi MP for Infrastructure 1.10

Note: For large scale environments, it is recommended to use BSM 9.24 or higher.

Managed Node Requirement

Component Version

Operations Agent 11.12 or higher*

Installation Guide
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Note: * For more information about Support Matrix, see
https://softwaresupport.hpe.com/km/KM323488.

Installation Checklist
Ensure that the installation tasks described in the following table are completed in the specified order:

If you have already installed OMi 10.x, skip to Task 6.

Server Checklist

Serial Task Reference

1 Check the installation prerequisites
for BSM

See the chapterGeneral Prerequisites in the
Business ServiceManagement Installation
Guide.

2 Install BSM version 9.23 or higher See the chapter Install BSM 9.20 and the
chapter Install the latest BSM 9.2x Minor
Minor Release and Patch in theBusiness
ServiceManagement Installation Guide.

3 Install Monitoring Automation version
9.23 or higher

See the chapter InstallingMonitoring
Automation in theOperations Manager i
Monitoring Automation Installation Guide.

4 Verify theMonitoring Automation
installation

5 Install Additional Software Update for
Monitoring Automation 9.23

Note: If you are installing OMi
MP for SAP Sybase ASE on
BSM 9.23, youmust install
additional software update for
Monitoring Automation 9.23.

See the section "Installing Additional
Software Update for Monitoring Automation
9.23".

6 Clean upOMi MP for Infrastructure
version 1.00

If OMi MP for Infrastructure version 1.00 is
already installed, seeMigrating from OMi MP
for Infrastructure version 1.00 to version 1.10
in theOMi Management Pack for
Infrastructure 1.10 Installation Guide.

7 Install OMi MP for Infrastructure 1.10 See the chapter Installing OMi MP for
Infrastructure 1.10 in theOMi Management
Pack for Infrastructure 1.10 Installation Guide.
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Serial Task Reference

8 Install OMi MP for SAP Sybase ASE
1.00

See the section "Installing OMi Management
Pack for SAP Sybase ASE version 1.00 on
BSM or OMi".

9 Apply the License See the section "Applying the License".

Managed Node Checklist

Task Reference

Install Operations Agent 11.12 or higher See the chapter Installing
the Operations agent 11.12
in theOperations Agent and
Operations Smart Plug-ins
for Infrastructure Installation
Guide.

Special Configurations See the section "Special
Configurations".

Configure library path on themanaged node* See the section "Configuring
Library Path on a Solaris
Managed Node".

* This configuration check is applicable only for Solaris managed nodes.

Special Configurations
This section provides information about the special configurations that are different from standard
configurations. It also includes information about using OMi MP for SAP Sybase ASEin environments
with cluster configurations. You need to perform these configurations on themanaged nodes.

Configuring Cluster and Fail-over Environments

OMi MP for SAP Sybase ASE can be configured to support cluster environments where fail-overs allow
uninterrupted database availability. With the synchronized cluster environment, OMi MP for SAP
Sybase ASE monitoring allows to enable or disable the active or passive nodes respectively.

To setup OMi MP for SAP Sybase ASE for a cluster environment, follow these steps:
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1. (Optional). Modify the XML file (dbspi_sapsybasease.apm.xml) included with the OMi MP for SAP
Sybase ASE.

2. Configure each SAP Sybase ASE server instance on every node where the instance runs and
then deploy the required OMi MP for SAP Sybase ASE Management Templates or Aspects on the
CI.

3. Create an XML file that associates OMi MP for SAP Sybase ASE-monitored instances with the
cluster packages.

Prerequisite

Tomonitor a cluster-aware application, OMi MP for SAP Sybase ASE requires that amonitored
resource in the cluster group contains both a network name and an IP address.

Caution: If the cluster group does not meet these requirements, the following errors are logged in
the opcerror file on the cluster node:

l Could not perform cluster API function, error code 1008 returned System Error
Number: -1 (ffffffff) - (OpC30-3223)

l Could not read cluster information System Error Number: -1 (ffffffff) -
(OpC30-3221)

l Application Package Monitor of subagent 0 aborted; process got signal 1
(OpC30-1041)

Software Requirements

OMi MP for SAP Sybase ASE is compatible with cluster software as follows:

l Microsoft Clustering Solutions (MSCS) onWindows

l MC/ServiceGuard on HP-UX nodes

l Veritas on Solaris nodes

l SunCluster on Solaris nodes

Installation Guide
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Task 1: XML file included with the OMi MP for SAP

Sybase ASE

OMi MP for SAP Sybase ASE includes an XML file (dbspi_sapsybasease.apm.xml) for Sybase ASE
Server type. This file works in conjunction with another file that you create in Create the apminfo.xml
file. The purpose of the file is to list all the OMi MP for SAP Sybase ASE Policy Templates on the
managed node so that these files can be disabled or enabled as appropriate for inactive or active
managed nodes.

The configuration describes a scenario where OMi MP for SAP Sybase ASE is enabled for monitoring a
database instance for one node in the cluster, while it remains disabled for all other nodes in the cluster.

(Optional). Modify the OMi MP for SAP Sybase ASE file (which lists OMi MP for SAP Sybase
ASE Policy Templates)

TheOMi MP for SAP Sybase ASE (dbspi_sapsybasease.apm.xml) file for Sybase ASE Server type
is generally ready to use without the necessary for any configurations. However, if you have renamed
any Policy Templates, you need tomodify the file.

The XML file lists all the Scheduled Task and Logfile Entry Policy Templates for purposes of disabling
or enabling. These Policy Templates are disabled only when the last instance is moved to another
node. The start or stop commands are performed for each instance that is started or stopped on the
node.

1. On themanaged node, the file is located in the following directory:

For Windows:

%OvDataDir%\bin\instrumentation\conf

For UNIX:

/var/opt/OV/bin/instrumentation/conf

TheOMi MP for SAP Sybase ASE is named according to the database type as dbspi_
sapsybasease.apm.xml.

2. Modify the OMi MP for SAP Sybase ASE file as required.

The unmodified file is automatically deployed with any OMi MP for SAP Sybase ASE Policy
Templates that you deploy. If youmodify the file, youmust redeploy to each node in the cluster.
The following example shows the contents of dbspi_sapsybasease.apm.xml.

Example (uses SAP Sybase ASE configuration):
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<?xml version="1.0"?>

<APMApplicationConfiguration xmlns="http://www.hp.com/OV/opcapm/app">

<Application>

<Name>dbspi_sapsybasease</Name>

<Template>SAPSybaseASE_High</Template>

<Template>SAPSybaseASE_Logger</Template>

<Template>SAPSybaseASE_Low</Template>

<Template>SAPSybaseASE_Medium</Template>

<Template>SAPSybaseASE_VeryHigh</Template>

<Template>SAPSybaseASE_ErrorLog</Template>

<Template>SAPSybaseASE_Messages</Template>

<StartCommand>dbspisybcol ON $instanceName</StartCommand>

<StopCommand>dbspisybcol OFF $instanceName</StopCommand>

</Application>

</APMApplicationConfiguration>

Task 2: Configuration or Discovery in a Cluster

Environment

In cluster environments, OMi MP for SAP Sybase ASE Sybase ASE Discovery Aspect may not be
able to discover all possible locations of your database instances. In addition, the discovery might
configure andmap instances based only on physical names, not the virtual names that you are using in
a cluster environment. In the following task you need to configure and deploy OMi MP for SAP Sybase
ASE for any node to which a packagemay bemoved.

Task 3: The XML file you create

The second XML file is one that you create and name: apminfo.xml.

This file, working in conjunction with the OMi MP for SAP Sybase ASE-included XML file, allows you to
associate OMi MP for SAP Sybase ASE monitored instances with cluster packages. As a result, when
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a package is moved from one node in a cluster to another node in the same cluster, monitoring stops on
the failed node and starts on the new node.

Create the apminfo.xml file (which describes cluster instances)

The following example shows theOMi MP for SAP Sybase ASE Server instances. The file must be
named apminfo.xml.

1. Using a text editor, create a file as specified:

a. In the apminfo.xml file, type the Application Name to match the prefix of the apm.xml file.

For Example, dbspi_sapsybasease

b. Type the Instance Name to match the instance name configured in OMi MP for SAP Sybase
ASE.

Application Name: dbspi_sapsybasease

Instance Name: Name of Sybase server (from interfaces file)

User-created xml file with entry descriptions

Note: For Sybase, the package name has to be set to the name of the ServiceGroup.

<?xml version="1.0" ?>

<APMClusterConfiguration>

<Application>

<Name><xml_file name without .xml extension></Name>

<Instance>

<Name><SAP Sybase ASE server instance name to be monitored by OMi MP for SAP
Sybase ASE>

</Name>

<Package>< Resource group in which the first instance of SAP Sybase ASE server
runs>

</Package>

</Instance>

<Instance>

<Name><SAP Sybase ASE server instance #2 name to be monitored by OMi MP for SAP
Sybase ASE>.</Name>

<Package><Resource group in which the second instance of SAP Sybase ASE server
runs>
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</Package>

</Instance>

</Application>

</APMClusterConfiguration>

User-created xml file with entries to replace above descriptions

<?xml version="1.0"?>

<APMClusterConfiguration>

<Application>

<Name>dbspi_sapsybasease</Name>

<Instance>

<Name>virtserv\sales</Name>

<Package>virtserv</Package>

</Instance>

<Instance>

<Name>customer</Name>

<Package>customer</Package>

</Instance>

</Application>

</APMClusterConfiguration>

To monitor multiple instances per resource group, modify the file as follows:

<?xml version="1.0" ?>

<APMClusterConfiguration>

<Application>

<Name>dbspi_sapsybasease</Name>

<Instance>

<Name>sales1,sales2</Name>

<Package>virtserv</Package>

</Instance>

</Application>

</APMClusterConfiguration>
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In addition, change the Start or Stop command to dbspisybcol:

<?xml version="1.0" ?>

<APMClusterConfiguration>

<Application>

<Name>dbspi_sapsybasease</Name>

...

<StartCommand>dbspisybcol ON $instanceName</StartCommand>

<StopCommand>dbspisybcol OFF $instanceName</StopCommand>

</Application>

</APMApplicationConfiguration>

2. Save the files in the following directories on all physical nodes in the resource group:

apminfo.xml

Nodes with a Windows operating system:

%OvDataDir%conf\conf\

Nodes with a UNIX or Linux operating system:

$OvDataDir/conf/conf/

Note: These directories does not exist by default. When you create a file for the first time,
youmust manually create these directories. There is no special distributionmechanism to
transport the files from the BSM Server to the nodes. Typically, the files are installed
manually on all nodes. There is nomergemechanism to add further entries. Youmust update
themmanually.

3. On each physical node, check the syntax and configuration of the files using the command
ovappinstance:

Nodes with a 32-bit Windows operating system:

%OvInstallDir%\bin\ovappinstance -vc

Nodes with a UNIX or Linux operating system:

$OvInstallDir/bin/ovappinstance -vc

4. Stop and restart the Operations Agent after copying the files to the physical nodes.

To stop the agent, run the following command:

ovc -stop
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To restart the agent, run the following command:

ovc -start

Installing MDA Table to Monitor Heavy SQL

Statements (Metric 2043 Setup)

This section provides information about setting upmetric 2043 tomonitor Heavy SQL Statements.

2043metric uses table monSysStatement. TheMDA (Monitoring and Diagnostic) table must be
installed on the Sybase ASE Server manually. The SAP Sybase ASE user including sa user must have
mon_role privileges. A few monitoring parameters, described in the following section, must be
configured using sp_configure.

As an example, let us consider setting up the special environment for Sybase version 15.7 on HP-UX
platform.

Note: The steps to set up the special environment for Sybase varies across version and platform.
If you are using a different Sybase version or platform, seeSybase documentation for installing or
configuringMDA table.

Note: By default, 2043metric is not monitored as the Heavy SQL Statements Count Frequency
parameter is set to NORUN. If you want to monitor heavy SQL Statements using 2043metric,
perform the following tasks and set the Heavy SQL Statements Count Frequency parameter
value.

Task 1: Connecting to Sybase Server and checking the configuration parameter

1. Connect to the Sybase ASE Server as a Sybase user and run the following command in the
command prompt:

$SYBASE/$SYBASE_OCS/bin/isql -Usa -P<Password> -S<Server>

2. To check if the parameter enable cis is set to 1, run the following command:

sp_configure 'enable cis'

go

3. If the parameter value is not set to 1, run the following command:
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sp_configure 'enable cis', 1

go

Task 2: Adding loopback server name alias

To add the loopback server name, run the following command:

use master

go

sp_addserver loopback, null, @@servername

go

Task 3: Installing the MDA tables

To install theMDA tables, run the following command:

isql -U sa -P <yourpassword> -S <YourServerName> –i $SYBASE/$SYBASE_
ASE/scripts/installmaster

In this instance, SYBASE is Sybase install directory

SYBASE_ASE is ASE server directory inside SYBASE install directory

Task 4: Assigning mon_role to logins allowed MDA access

To grant permission to sa user, run the following command:

use master

go

grant role mon_role to sa

go

Task 5: Enabling the configuration parameters

To enable the configuration parameters, run the following command:

sp_configure "enable monitoring", 1

go

sp_configure "sql text pipe active", 1

go

sp_configure "sql text pipe max messages", 100

go

sp_configure "plan text pipe active", 1

go
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sp_configure "plan text pipe max messages", 100

go

sp_configure "statement pipe active", 1

go

sp_configure "statement pipe max messages", 100

go

sp_configure "errorlog pipe active", 1

go

sp_configure "errorlog pipe max messages", 100

go

sp_configure "deadlock pipe active", 1

go

sp_configure "deadlock pipe max messages", 100

go

sp_configure "wait event timing", 1

go

sp_configure "process wait events", 1

go

sp_configure "object lockwait timing", 1

go

sp_configure "SQL batch capture", 1

go

sp_configure "statement statistics active", 1

go

sp_configure "per object statistics active", 1

go

sp_configure "max SQL text monitored", 2048

go

Restart the Sybase server

Task 6: Testing the basic MDA configuration

To test the basic MDA configuration, run the following command:
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select count(*) from master..monSysStatement

go

Configuring Library Path on a Solaris Managed
Node
This section provides information about configuring the library path on Solaris managed node.

Note: The following configuration is a prerequisite for only OMi MP for SAP Sybase ASE used for
monitoringmanaged nodes on a Solaris platform.

For OMi MP for SAP Sybase ASE tomonitor managed nodes on Solaris platform, ensure the Expat.so
library used for XML parser perl module is able to resolve dynamic dependency for all the required
libraries using following steps as agent user:

1. To find Expat.so library, run the following commands:

cd /opt/OV/nonOV/perl/a/lib

find . -name Expat.so

2. To find the list of dynamic dependencies, run the following commands:

Go to <Expat.so> path

ldd Expat.so

If you see an error message “file not found” for libgcc_s.so, configure the libgcc_s.so
library path at SYBMP_LIBPATH environment variable on a Solaris managed node by following step
3.

3. Set libgcc_s.so library path in SYBMP_LIBPATH environment variable as root user by following
these steps:

a. Find libgcc_s.so on Solaris managed node using the following command:

find / -name libgcc_s.so

b. Search 32-bit libgcc_s.so using the following command:

file <libgcc_s.so along with path>

c. If 32-bit libgcc_s.so is not installed on the node, install GCC Runtime libraries package.

d. Open /etc/profile in vi editor using the following command:

vi /etc/profile
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e. Add the following lines at the beginning of the /etc/profile file:

SYBMP_LIBPATH=<32-bit libgcc_s.so path>

export SYBMP_LIBPATH

Note: 32-bit libgcc_s.so path is the result of step 2.

f. Save the file.

Installing Additional Software Update for
Monitoring Automation 9.23
Note: Youmust install additional software update for Monitoring Automation 9.23 only for BSM
9.23.

Before installing OMi MP for SAP Sybase ASE, youmust install an additional software update for
Monitoring Automation 9.23. If you are usingMonitoring Automation 9.24 or a later version, you do not
need to install this additional software update. The additional software update for Monitoring
Automation 9.23 (HPOprMA_update.zip) is available in the e-media or MPDVD, under the folder
HPOprMA_update.

For more information about installing the update software, see "InstallingMonitoring Automation 9.23
Software Update".

Installing OMi MP for Infrastructure version
1.10
For information about installing OMi MP for Infrastructure version 1.10, see the chapter Installing OMi
MP for Infrastructure version 1.10 on BSM or OMi in theOMi Management Pack for Infrastructure
Installation Guide.
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Installing OMi Management Pack for SAP
Sybase ASE version 1.00 on BSM or OMi
You can use the e-media or MPDVD to install the OMi MP for SAP Sybase ASE on BSM or OMi Server
(Linux orWindows). The following section provides information about installing the OMi MP for SAP
Sybase ASE on the BSM 9.2x or OMi 10.x Server.

Note: In a BSM 9.2x or OMi 10.x distributed environment, OMi MP for SAP Sybase ASE must be
installed on all BSM or OMi Servers - (BSM or OMi) DPS and (BSM or OMi) GWS.
For BSM 9.2x, youmust make sure that Monitoring Automation is running before proceeding with
the installation. To check the status, log on to BSM console and navigate toAdmin > Setup and
Maintenance > Server Deployment and then check if Monitoring Automation is enabled.

On a Linux BSM 9.2x or OMi 10.x Server

To install the OMi MP for SAP Sybase ASE on a Linux BSM 9.2x or OMi 10.x Server, follow these
steps:

1. Log on as a root user.

2. Set the umask by typing the command umask 022.

3. Create a directory to mount the DVD or e-media by typing the command mkdir /<mount_point>.

For example: mkdir /dvdrom

4. Insert the DVD into the disk drive or you can copy the e-media installation package andmount
using the following commands:

For DVD: mount /dev/<dvdrom_drive_name> /<mount_point>

For e-media: mount -o loop <e-media> /<mount_point>

5. Change the directory to /<mount_point>.

6. Run the following command:

<PATH>/mpinstall.sh -i

Based on the locale, you can see the following table and run the command accordingly:
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E-media
MP locale same as BSM
locale MP locale different from BSM locale

English e-media ./mpinstall.sh -i ./mpinstall.sh -i

Non-English e-
media

./mpinstall.sh -i ./mpinstall.sh -i -locale
<mplocale>

For example, to install OMi MP for SAP Sybase ASE in the Simplified Chinese locale with BSM in
a non Simplified Chinese locale, specify the following command:

./mpinstall.sh -i -locale zh_CN

Note: You can use the following command options:

./mpinstall.sh -i [-locale <MP Locale>] [-h|help]

-i : Install Management Pack.

-locale: Locale specific Management Pack to install.

-h|-help: Shows the helpmessage.

You can specify the <mplocale> as follows:

o zh_CN: Simplified Chinese locale

o ja: Japanese locale

7. To accept the End User License Agreement (EULA), typeYes orY and to decline the license
agreement, typeNo orN.

Note: If you decline the EULA, the OMi MP for SAP Sybase ASE will not be installed.

After the installation is completed, amessage appears stating that the installation of OMi
Management Pack for SAP Sybase ASE is completed.

On a Windows BSM 9.2x or OMi 10.x Server

To install the OMi MP for SAP Sybase ASE on aWindows BSM 9.2x or OMi 10.x Server, follow these
steps:

1. Insert the DVD into the disk drive or you can copy the ZIP file to the BSM or OMi Server and
extract it.
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2. Open the command prompt, change the directory to <DVD- ROM> or to folder that has the
installer script and run the following command:

cscript mpinstall.vbs -i

Based on the locale, you can see the following table and run the command accordingly:

E-media MP locale same as BSM locale
MP locale different from BSM
locale

English e-
media

cscript mpinstall.vbs -i cscript mpinstall.vbs -i

Non-English
e-media

cscript /nologo mpinstall.vbs -i cscript /nologo
mpinstall.vbs -i -locale
<mplocale>

For example, to install OMi MP for SAP Sybase ASE in Simplified Chinese locale with BSM in a
non Simplified Chinese locale, specify the following command:

cscript /nologo mpinstall.vbs -i -locale zh_CN

Note: You can use the following command options:

cscript /nologo mpinstall.vbs -i [-locale <MP Locale>] [-h|help]

-i: Install Management Pack.

-locale : Locale specific Management Pack to install.

-h|-help: Shows the helpmessage.

You can specify the <mplocale> as follows:

o zh_CN: Simplified Chinese locale

o ja: Japanese locale

3. To accept the End User License Agreement (EULA), typeYes orY and to decline the license
agreement, typeNo orN.

After the installation is completed, amessage appears stating that the installation of OMi
Management Pack for SAP Sybase ASE is completed.
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Applying the License
This section provides information about updating and activating the license.

Note: Formore information about procuring the license, see the "Licensing" section.

To update your deployment with a new license and to activate the license, follow these steps:

1. Navigate to the LicenseManagement pane:

On BSM 9.2x, click Admin > Platform > Setup and Maintenance > License Management.

OnOMi 10.x, click Administration > Setup and Maintenance > License Management.

The LicenseManagement provides details about the name, license type, days left to expiry of
license, expiration date, capacity, and capacity details.

2. Click to open the Add License dialog box where you can search for the relevant .dat file.

Note: You can download .dat file from http://enterpriselicense.hpe.com.

Verifying the OMi MP for SAP Sybase ASE
Installation
This section provides information about verifying the installation of OMi MP for SAP Sybase ASE on
BSM 9.2x or OMi 10.x (Linux andWindows) servers.

You can perform any one of the following checks to verify the OMi MP for SAP Sybase ASE
installation:

l Check the log files for any errors onGWS (BSM 9.2x or OMi 10.x), DPS (BSM 9.2x or OMi 10.x),
and typical servers (BSM 9.2x or OMi 10.x) at the following locations:

For Linux:

/opt/HP/BSM/log/mpinstall.log

For Windows:

%TOPAZ_HOME%\log\mpinstall.log

Note: TheOMi logs are available on both (BSM 9.2x or OMi 10.x) GWS and (BSM 9.2x or OMi
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10.x) DPS at the following location:

On BSM < or = 9.25

Linux: /opt/HP/BSM/log/EJBContainer/opr-configserver.log

Windows: %TOPAZ_HOME%\log\EJBContainer\opr-configserver.log

OnBSM > or =9 .26 andOMi 10.x

Linux: /opt/HP/BSM/log/jboss/opr-webapp.log

Windows: %TOPAZ_HOME%\log\jboss\opr-webapp.log

l Check the following location BSM 9.2x or on the OMi 10.x console:

o OnBSM 9.2x, click Admin > Operations Management > Setup > Content Packs.

TheOMi Management Pack forSAP Sybase ASEmust appear in the Content Pack
Definitions pane.

o OnOMi 10.x, click Administration > Setup and Maintenance > Content Packs.

TheOMi Management Pack for SAP Sybase ASEmust appear in the Content Pack
Definitions pane.

l To list the OMi MPs installed on the BSM 9.2x or OMi 10.x server, run the following command on
BSM 9.2x or OMi 10.x GWS:

For Linux:

/opt/HP/BSM/bin/ContentManager.sh -l –username <username> -password <pwd>

For Windows:

%TOPAZ_HOME%\bin\ContentManager.bat -l –username <username> -password <pwd>

Note: The ContentManager.bat or ContentManager.sh command lists the Content Pack
name and version.
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Chapter 3: Getting Started
The following section provides information about the tasks required tomonitor SAP Sybase ASE
Servers using OMi MP for SAP Sybase ASE. You can also analyze the status and health of SAP
Sybase ASE Configuration Items (CIs) through event, health, and performance perspectives.

Task 1: Adding Nodes to BSM 9.2x or OMi 10.x
Console
Note: If the SAP Sybase ASE Server that you want to monitor is already beingmonitored by
Smart Plug-in (SPI) for Sybase Databases, then remove the SPI artifacts and data sources from
themanaged node hosting the SAP Sybase ASE Server before proceeding.

Note: If the node already exists in Run-time ServiceModel (RTSM), you can skip this step and
proceed to Task 2.

Before you beginmonitoring, you need to add the nodes by following these steps:

1. Open theMonitored Nodes pane from Administration:

On BSM 9.2x, click Admin > Operations Management > Setup > Monitored Nodes.

OnOMi 10.x, click Administration > Setup and Maintenance > Monitored Nodes.

2. In theNode Views pane, click Predefined Node Filters > Monitored Nodes, and then click
, and then click Computer > <select required OS type>. The Create New Monitored Nodes
dialog box opens.

3. Specify the Primary DNS Name and verify the IP Address.

4. Specify the Operating System and Processor Architecture of the node from the drop-down list, and
then click OK.

The newly created node is saved as a CI instance in RTSM.

Note: Youmust activate the node with Operations Agent onOMi Server and grant certificate.
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Task 2: Enabling the Enrichment Rule
Youmust enable the following enrichment rules to populate the SAP Sybase ASE CI’s display label
with additional information about container or the hostname:

l SoftwareElementDisplayLabelForNewHost

l SoftwareElementDisplayLabelForExistingHost

l SoftwareElementDisplayLabelPopulator

To enable the Enrichment Rule, follow these steps:

1. Open the Enrichment manager:

On BSM 9.2x, click Admin > RTSM Administration > Modeling > Enrichment manager.

OnOMi 10.x, click Administration > RTSM Administration > Modeling > Enrichment
manager.

2. In the Enrichment Rules pane, select SoftwareElementDisplayLabelForNewHost from the list.

3. Right-click and select Properties. The Enrichment Rule Properties window appears.

4. Click Next.

5. Select Rule is Active.

6. Click Finish.

7. In the Enrichment Rules pane, click to save the changes.

8. Select SoftwareElementDisplayLabelForExistingHost and repeat steps 3 to 7.

9. Select SoftwareElementDisplayLabelPopulator and repeat steps 3 to 7.

Task 3: Deploying the SAP Sybase ASE
Discovery Aspect
Note: If SAP Sybase ASE CIs are already discovered, you can skip this step and proceed to Task
4.

The SAP Sybase ASE Discovery Aspect enables you to discover SAP Sybase ASE Server instances
in the environment. To discover both SAP Sybase ASE CIs and SAP Sybase Replication Server CIs
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on the addedmanaged nodes, youmust deploy the SAP Sybase ASE Discovery Aspect to a Computer
CI.

The SAP Sybase ASE Discovery Aspect deployment discovers the Configuration Item (CIs) of the
following CI types (CITs):

l Sybase (Both SAP Sybase ASE Server and SAP Sybase Replication Server are identified with
sameCI)

l Computer

To deploy the SAP Sybase ASE Discovery Aspect, follow these steps:

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:

Configuration Folders > Database Management > SAP Sybase ASE > Aspects.

3. Follow one of the below methods to assign and deploy the Aspect. In theManagement Templates
& Aspects pane:
o Select theSAP Sybase ASE DiscoveryAspect, and then click .

o Right-click theSAP Sybase ASE DiscoveryAspect, and then click Assign and Deploy
Item.

The Assign and Deploy Wizard appears.

4. In theConfiguration Item tab, select the requiredmanaged node CI and then click Next.

5. (Optional). In theRequired Parameters tab, click Next.
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Note: SAP Sybase ASE Discovery Aspects do not havemandatory parameters. You will get
a notification stating the followingmessage: There are no parameters that require
editing for this Assignment.

6. (Optional). In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x,
click Next.

Note: SAP Sybase ASE Discovery Aspect do not have any parameters. You will get a
notification stating the followingmessage: There is no parameter available for this
assignment.

7. (Optional). If you do not want to enable the assignment immediately, perform the following:

On BSM 9.2x, clear theEnable Assigned Objects check box.

OnOMi 10.x, clear theEnable Assignment(s) check box.

You can then enable the assignment later using the Assignments & Tuning pane.

8. Click Finish.

Note: After the SAP Sybase ASE Aspect is deployed, the followingmessage appears:
Assignment and deployment jobs created. To check the status of the deployment job, go to
the following location:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Deployment Jobs.

OnOMi 10.x, click Administration > Monitoring > Deployment Jobs.

Task 4: Verifying Discovery
After you deploy the SAP Sybase ASE Discovery Aspect, you can verify if the CIs are populated in the
View Explorer.

To view the CIs discovered, follow these steps:

1. Open the Event Perspective pane:

On BSM 9.2x, click Applications > Operations Manager > Event Perspective.

OnOMi 10.x, clickWorkspace > Operations Console > Event Perspective.

2. In theBrowse View tab, select theSAPSybaseASE_DeploymentView.
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Task 5: Configuring OMi MP for SAP Sybase
ASE for Operations Agent running with non-
root user
In addition to the tasks mentioned above, the following tasks have to be performed for UNIX nodes that
haveOperations Agent running with non-root users.

After deploying the SAP Sybase ASE Discovery Aspect, youmust follow these steps:

1. Run the following script as a root user under /var/opt/OV/bin/instrumentation:

# dbspisyb_perl dbspisyb_root.pl

The /var/opt/OV/conf/dbspisyb.su is created.

2. Edit the dbspisyb.su file as a root user by uncommenting the lines or adding new lines in the
following format: <user>:<commands>

root:<SYBINSTPATH>/startserver -f <SYBINSTPATH>/RUN_<SVRNAME>

where <SYBINSTPATH> is the SAP Sybase ASE install path.

Task 6: Deploying the SAP Sybase ASE
Management Templates or Aspects
This section provides information about collection process, permission required for monitoring
SAP Sybase ASE instances and deployingManagement Template adn Aspects. For more information
about deployingManagement Template, go to Task 6a: Identifying and Deploying the SAP Sybase
ASE Management Template and for more information about deploying Aspects, go to Task 6b:
Deploying the SAP Sybase ASE Aspects.

Management Pack Data Collection Process

The frequency (polling interval) at which each policy must bemonitored is predefined with a default
value in a specific frequency parameter. Frequency parameter is an expert parameter that is defined for
each of themetrics regardless of whether they are for generating events or logging data.

Following are the four predefined frequency parameters:
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Scheduler Frequency Default value

Very High 5mins

High 15mins

Medium 1 hour

Low 24 hours

After Management Templates and Aspects are deployed, collector is triggered based on the parameter
value in a specific policy. You canmodify the default value of the parameter at following two levels:

l During deployment of theManagement Template or Aspects using theManagement Templates &
Aspects pane.

l After deployment using the Assignments & Tuning pane.

For more information about how tomodify the parameter values, see the sectionEditing Parameters in
theOMi Management Pack for SAP Sybase ASE 1.00 User Guide.

Required User Privilege

Tomonitor SAP Sybase ASE Servers, provide a user with credentials and the following privileges:
system administrator (sa).

Task 6a: Identifying and Deploying the SAP Sybase

ASE Management Template

Before deploying the SAP Sybase ASE Management Templates, youmust identify the SAP Sybase
ASE Management Template suitable for your environment by following these recommendations:

l If you want to monitor the key performance and availability metrics on an SAP Sybase ASE server,
you can deploy theEssential SAP Sybase ASE Management Template.

l If you want to monitor the advance features such as network packets, parallel processing, and so
on along with key performance and availability, you can deploy theExtensive SAP Sybase ASE
Management Template.
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To deploy the SAP Sybase ASE Management Templates to the SAP Sybase ASE CIs, follow these
steps:

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:

Configuration Folders > Database Management > SAP Sybase ASE > Management
Templates

3. In the SAP Sybase ASE Management Templates folder, select theManagement Template that

you want to deploy, and then click Assign and Deploy Item. The Assign and Deploy wizard

opens.

4. In theConfiguration Item tab, select the CI to which you want to assign theManagement
Template, and then click Next.

5. In theRequired Parameters tab, to enter the required parameters detail follow these steps:

a. Select theSAP Sybase ASE Instance Username parameter in the list, and then click .

The SAP Sybase ASE Instance Username dialog box opens.

b. Click Value and type the Username. Click OK.

c. Select theSAP Sybase ASE Instance Password parameter, and then click . The SAP

Sybase ASE Instance Password dialog box opens.

d. Click Value and type a value in thePassword field.

e. In theVerify Password field and type the same password and then click OK.

f. Click Next.

6. (Optional). In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x, you
can change the default values of the parameters. To change the default values of the parameters,
follow these steps:

a. Select SAP Sybase ASE Instance Name parameter and then click . The Edit Instance

Parameter window appears.

b. Select the parameter from the list and then click . The Edit Parameter dialog box opens.

Click Value, specify the value, and then click OK.
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Note: In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x,
you can override the default values of any parameter. You can specify a value for each
parameter at theManagement Template level. By default, parameters defined as expert

parameters are not displayed. To display expert parameters, click Show Expert
Parameters.

Note: Similarly, you can edit theSAP Sybase ASE Error Log Frequency parameter.

c. Click Next.

7. (Optional). In theConfigure Options tab, if you do not want to enable the assignment
immediately, perform the following:

On BSM 9.2x, clear theEnable Assigned Objects check box.

OnOMi 10.x, clear theEnable Assignment(s) check box.

You can then enable the assignment later using the Assignments & Tuning pane.

8. Click Finish.

Task 6b: Deploying the SAP Sybase ASE Aspects

To deploy SAP Sybase ASE Aspects to the SAP Sybase ASE CIs, follow these steps:

1. Open theManagement Templates & Aspects pane:

On BSM 9.2x, click Admin > Operations Management > Monitoring > Management
Templates & Aspects.

OnOMi 10.x, click Administration > Monitoring > Management Templates & Aspects.

2. In the Configuration Folders pane:

Configuration Folders > Database Management > SAP Sybase ASE > Aspects

3. In theManagement Templates & Aspects folder, select the Aspect that you want to deploy, and

then click Assign and Deploy Item.

Alternately, you can right-click the SAP Sybase ASE Aspect that you want to deploy, and then
click Assign and Deploy Item to open the Assign and Deploy Wizard.

4. In theConfiguration Item tab, select theSybaseCI to deploy the Aspect and then click Next.
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Note: If you want to deploy Aspects to Node CIs, select Also show CIs of type Node
check box.

5. In theRequired Parameters tab, youmust specify themandatory parameters by following these
steps:

a. Select theSAP Sybase ASE Instance Name parameter in the list, and then click . The

SAP Sybase ASE Instance Name dialog box opens.

b. Specify the value, and then click OK.

c. Select theSAP Sybase ASE Instance Username parameter in the list, and then click .

The SAP Sybase ASE Instance Username dialog box opens.

d. Specify the value, and then click OK.

e. Select theSAP Sybase ASE Instance Password parameter in the list, and then click .

The SAP Sybase ASE Password dialog box opens.

f. Click Value and type a value in thePassword field.

g. In theVerify Password field and type the same password and then click OK.

h. Click Next.

6. (Optional). In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x, you
can change the default values of the parameters. Else click Next.

To change the default values of the parameters, follow these steps:

a. Select theSAP Sybase ASE Instance Name parameter and then click . The Edit

Instance Parameter window appears.

b. Select the parameter from the list and then click . The Edit Parameter dialog box opens.

Click Value, specify the value, and then click OK.

Note: In theAll Parameters tab on BSM 9.2x orParameter Summary tab onOMi 10.x,
you can override the default values of any parameter. You can specify a value for each
parameter at theManagement Template level. By default, parameters defined as expert

parameters are not displayed. To display expert parameters, click Show Expert
Parameters.

Note: Similarly, you can edit theSAP Sybase ASE Error Log Frequency parameter.

c. Click Next.
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7. (Optional). In theConfigure Options tab, if you do not want to enable the assignment
immediately, perform the following:

On BSM 9.2x, clear theEnable Assigned Objects check box.

OnOMi 10.x, clear theEnable Assignment(s) check box.

You can then enable the assignment later using the Assignments & Tuning pane.

8. Click Finish.

Task 7: Verifying SAP Sybase ASE
Deployment
To verify the deployment of SAP Sybase ASE on themanaged node, follow these steps:

1. Open the Browse View pane:

On BSM 9.2x, click Application > Operations Management > View Explorer > Browse View.

OnOMi 10.x, clickWorkspaces > Operations Console > Event Perspective > View Explorer
> Browse View.

2. In theBrowse View pane, right-click a node and then click Launch Tool. The Select Tool page
opens.

3. Select theVerify SAP Sybase ASE Management Pack Deployment tool and then click Run
Tool.

Task 8: Configuring SAP Sybase ASE Error Log
Monitoring for non-root Agent User
By default, the non-root agent user does not have permission to read error log file of SAP Sybase ASE
Server. Set read permission to enable the error log file monitoring by following these steps:

1. To identify the SAP Sybase ASE server alert log to bemonitored, run the following command:

/var/opt/OV/bin/instrumentation/dbspicas -l

The error log file name appears.

2. To provide read permission to the non-root user for error logmonitoring, run the following command
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as a Sybase user:

chmod +r <Sybase-error-logfile>
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Appendix A: Installing Monitoring
Automation 9.23 Software Update
This section provides detailed information about installing the software update in a distributed BSM
environment.

If you do not have a distributed BSM environment, you can skip to the section "Installing Additional
Software Update in a Typical BSM Environment".

Installing Additional Software Update in a
Distributed BSM Environment
In a distributed BSM environment, the BSM DPS and BSMGWS are available on different systems.
The additional software update needs to be installed on both the BSMDPS and BSMGWS.

Installing Additional Software Update on BSM DPS

To install the additional software update on BSMDPS running in a distributed BSM environment, follow
these steps:

1. Run the following commands to check the version of the current opr-config-content-
server.war file:

On Linux:

cd /opt/HP/BSM/opr/webapps

/opt/HP/BSM/opr/support/what.sh ./opr-config-content-server.war

On Windows:

Go to the drive where BSM is installed:

cd /d %TOPAZ_HOME%\opr\webapps

cscript %TOPAZ_HOME%\opr\support\what.vbs opr-config-content-server.war
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Note: If the version number is lower than 09.23.174, then proceed to the next step. If the version
number is 09.23.174 or higher, then the current BSM installation already contains the required
software update and you do not need to perform the remaining steps in this section.

2. Run the following command to stop the BSM services running on BSMDPS:

On Linux:

/opt/HP/BSM/scripts/run_hpbsm stop

On Windows:

%TOPAZ_HOME%\bin\SupervisorStop.bat

3. Take a backup of the existing opr-config-content-server.war file, which exists in the
following folder:

On Linux:

/opt/HPBSM/opr/webapps

On Windows:

%TOPAZ_HOME%\opr\webapps

The opr-config-content-server.war file must be backed up to a different folder.

4. Extract the HPOprMA_update.zip to a temporary folder and copy opr-config-content-
server.war to the following folder:

On Linux:

/opt/HPBSM/opr/webapps

On Windows:

%TOPAZ_HOME%\opr\webapps

5. Run the following command to deploy the new WAR file from the extracted ZIP file:

On Linux:

/opt/HP/BSM/opr/bin/oprcfg-configuration.sh -setup omi -noGW

On Windows:

cscript %TOPAZ_HOME%\opr\bin\oprcfg-configuration.vbs -setup omi -noGW

6. Run the following command to start the BSM services:
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On Linux:

/opt/HP/BSM/scripts/run_hpbsm start

On Windows:

%TOPAZ_HOME%\bin\SupervisorStart.bat

Installing Additional Software Update on BSM GWS

To install the additional software update on BSMGWS running in a distributed BSM environment,
follow these steps:

1. Run the following commands to check the version of the current opr-config-server.war file:

On Linux:

cd /opt/HP/BSM/opr/webapps

/opt/HP/BSM/opr/support/what.sh ./opr-config-server.war

On Windows:

Go to the drive where BSM is installed:

cd /d %TOPAZ_HOME%\opr\webapps

cscript %TOPAZ_HOME%\opr\support\what.vbs opr-config-server.war

Note: If the version number is lower than 09.23.174, then proceed to the next step. If the version
number is 09.23.174 or higher, then the current BSM installation already contains the required
software update and you do not need to perform the remaining steps in this section.

2. Run the following command to stop the BSM services running on BSMGWS:

On Linux:

/opt/HP/BSM/scripts/run_hpbsm stop

On Windows:

%TOPAZ_HOME%\bin\SupervisorStop.bat

3. Take a backup of the existing opr-config-server.war file which exists in the following folder:
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On Linux:

/opt/HPBSM/opr/webapps

On Windows:

%TOPAZ_HOME%\opr\webapps

The opr-config-server.war file must be backed up to a different folder.

4. Extract the HPOprMA_update.zip to a temporary folder and copy opr-config-server.war to the
following folder:

On Linux:

/opt/HPBSM/opr/webapps

On Windows:

%TOPAZ_HOME%\opr\webapps

5. Run the following command to deploy the new WAR file from the extracted ZIP file:

On Linux:

/opt/HP/BSM/opr/bin/oprcfg-configuration.sh -setup omi

On Windows:

cscript %TOPAZ_HOME%\opr\bin\oprcfg-configuration.vbs -setup omi

6. Run the following command to start the BSM services:

On Linux:

/opt/HP/BSM/scripts/run_hpbsm start

On Windows:

%TOPAZ_HOME%\bin\SupervisorStart.bat

Installing Additional Software Update in a
Typical BSM Environment
In a typical BSM environment, the BSM DPS and BSMGWS are available in the same system. To
install the additional software update in a typical BSM environment, perform the following steps:
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1. Run the following commands to check the version of the current opr-config-server.war:

On Linux:

cd /opt/HP/BSM/opr/webapps

/opt/HP/BSM/opr/support/what.sh ./opr-config-server.war

On Windows:

Go to the drive where BSM is installed:

cd /d %TOPAZ_HOME%\opr\webapps

cscript %TOPAZ_HOME%\opr\support\what.vbs opr-config-server.war

Note: If the version number is lower than 09.23.174, then proceed to the next step. If the version
number is 09.23.174 or higher, then the current BSM installation already contains the required
software update and you do not need to perform the remaining steps in this section.

2. Run the following command to stop the BSM services running on BSM Server:

On Linux:

/opt/HP/BSM/scripts/run_hpbsm stop

On Windows:

%TOPAZ_HOME%\bin\SupervisorStop.bat

3. Take a backup of the existing opr-config-server.war file which exists in the following folder:

On Linux:

/opt/HPBSM/opr/webapps

On Windows:

%TOPAZ_HOME%\opr\webapps

The opr-config-server.war file must be backed up to a different folder.

4. Extract the HPOprMA_update.zip to a temporary folder and copy opr-config-server.war to the
following folder:

On Linux:

/opt/HPBSM/opr/webapps

On Windows:
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%TOPAZ_HOME%\opr\webapps

5. Run the following command to deploy the new WAR file from the extracted ZIP file:

On Linux:

/opt/HP/BSM/opr/bin/oprcfg-configuration.sh -setup omi

On Windows:

cscript %TOPAZ_HOME%\opr\bin\oprcfg-configuration.vbs -setup omi

6. Run the following command to start the BSM services:

On Linux:

/opt/HP/BSM/scripts/run_hpbsm start

On Windows:

%TOPAZ_HOME%\bin\SupervisorStart.bat
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Send documentation feedback
If you have comments about this document, you can contact the documentation team by email. If an
email client is configured on this system, click the link above and an email window opens with the
following information in the subject line:

Feedback on Installation Guide (OMi Management Pack for SAP Sybase ASE 1.00)

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a webmail client, and
send your feedback to docfeedback@hpe.com.

We appreciate your feedback!
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