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HP ART 5.1 Conversion Guide

Introduction

There are currently three HP Adoption Readiness Tool (ART) 5.x versions available:
e Version 5.10 - released on August 13, 2013
e Version 5.11 - patch released via the SSO in February 2013
e Version 5.20 — released on December 19, 2014

HP ART v5.2 focuses on enhancing and extending the user experience with HP ART. HP ART v5.2
includes a new Authoring interface, improved support for Internet Explorer 11 (recording and
viewing), and additional support for Android. HP ART v5.1 remains supported and customers
have the choice of remaining on v5.1 or upgrading to v5.2 at this time. If you are using HP ART
5.10, you should minimally apply the 5.11 patch but if you don’t require additional IE 11 support
(recording and publishing) or Android device accessibility, you may decide that updating your
5.1 content to 5.2 is not necessary at this time. HP ART 5.1 and 5.2 published content looks the
same, there is no difference in appearance or functionality with the exception of minor formatting

issues when viewing course content in Internet Explorer 11.

The HP ART 5.1 existing courses will not be re-released version 5.2. If you wish to update your
5.1 content to version 5.2 you will need to convert your 5.1 template and content.

Please note that there is always some effort involved in upgrading and learning a new user
interface. As with any software upgrade or conversion, you should perform sufficient testing of the
new product and follow the recommended conversion steps.

Before You Begin

1) Ensure that you have the most current version of the 5.1 Conversion Guide.
The HP ART reference documentation is available on the HP Software Support Online (SSO)

site. After signing in with your HP Passport account, if your account is associated with your HP
ART Support Agreement ID (SAID) number, select the art author developer kit in the My
Products section and the related HP ART documents will display in Manual Library section to
the left. If you do not have your SAID number, you can search for the HP ART documents by
using the Search field located in the page banner. If you search on ART, you can then filter
your selection by specifying the Version and Document Type (manuals) you are interested in.

NOTE: If prompted, create an HP Passport user ID and password to access the site.
2) Start with a solid foundation of HP ART knowledge.
HP ART 5.2 has a new user interface but the same underlying functionality and structure as HP

ART 5.1. The information contained in this guide and the associated resources are intended
for users with HP ART 5.1 training.
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3) Learn about the new HP ART 5.2 features.
Take the free of charge online 5.2 Delta Training from the HP Software Education website or

contact the HP ART mailbox (hpsoftware.art@hp.com) for other viewing options. Here, you
learn about the new features, including the updated 5.2 user interface.

It you are not familiar with the look of an ART 5.1 or 5.2 published course (they look the
same), HP recommends that you preview courses to see for yourself. You can view sample
courses on the HP ART HP Software Education Services webpage

4) Determine your HP ART 5.2 testing method.

The HP ART 5.2 Author Toolkit and the 5.1 Author Toolkit cannot be installed on the same
client (machine) at the same time. Here are the common testing method options:

e Option 1: Secure an additional machine to download and test HP ART 5.2.

e Option 2: Once your HP ART 5.1 components are backed up in a separate location,
uninstall HP ART 5.1 and install HP ART 5.2 and perform testing.

You can utilize both HP ART 5.1 and HP ART 5.2 keys for a period of 6 months for testing
purposes. You can download HP ART 5.2 and request a new 5.2 license key from the HP
Software My software updates site (requires current ART SAID number).

5) Determine your HP ART 5.20 conversion scenario.

Due to the flexibility of the HP ART offering, you have several scenarios for using the HP ART
authoring tool and/or prebuilt content. For content conversion from HP ART v5.1 to v5.2, there
are two primary scenarios. Use the following information to determine which scenario applies:

e Scenario A: You use ART 5.1x prebuilt content out of the box and require additional
support for Internet Explorer 11 (recording and publishing) and/or Android mobile
devices (Jelly Bean+ versions).

e Scenario B: You use a customized 5.1 template with your HP ART prebuilt out of the box
published content and/or customized HP ART content.
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Scenario A: 5.10 Out of the Box Published Content with the
default HP template and skin

It you only use the pre-published output or LMS files and are experiencing some issues from users
on IE 11 or you require accessibility to published courses via Android devices, you will need to
republish your 5.1 content with the 5.2 Developer Kit and redeploy. If you require additional
information on this process, please contact the HP ART mailbox (hpsoftware.art@hp.com).

Scenario B: Convert Your Custom 5.10 Template

Follow these steps if you have a customized 5.1 template with use either the HP ART prebuilt out
of the box published content and/or have customized HP ART content.

It is important fo read through this entire section before starting the update process. If you
encounter difficulties during the process, you can contact the Global Support Desk by logging into
SSO (Software Support Offering - http://support.openview.hp.com) to enter a case. You must

have a valid SAID (Service Agreement ID) for ART and you will need to enter it. There are Support
Engineers in Global Support who specialize in ART and will handle your case.

Step 1: Create the ART 5.2 Project Folder and Backup Files
It is very important to back up your original ART 5.2 source files. Once a file is opened in ART
5.2, you cannot open it in ART 5.1.

1. Create a new ART 5.2 project folder.

2. Copy your ART 5.1 source files to the new ART 5.2 project folder.

3. Copy your ART 5.1 template folder to the new ART 5.2 project folder. To locate your
template(s), navigate from the Start menu to All Programs > HP Adoption Readiness Tool >
HP Adoption Readiness Tool Resources > templates.

4. Back up your original ART 5.1 source and template files in secondary location.

Step 2: Install ART 5.2
Refer to the README document located in the HP ART 5.2 Dev Kit for detailed installation

instructions.

Uninstall the ANCILE Capture Engine using the standard Control Panel uninstall process.
Uninstall ART 5.1using the standard Control Panel uninstall process.

Restart your system.

Install ART 5.2.

oo =

Step 3: Replace the HP ART 5.2 Default Template
The HP ART 5.2 template and course skin will automatically install during the ART 5.2 Dev Kit
installation process. Follow these steps to replace the default template with your custom template:
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1. Navigate from the Start menu to All Programs > HP Adoption Readiness Tool > HP
Adoption Readiness Tool Resources > templates.
. HP Adoption Readiness Tool
-1 HP Adoption Readiness Tool Resour
() HP Adoption Readiness Tool
2. The ART 5-20 HP ART Template.udt template and your custom template should be listed in
the folder. The HP ART Dev Kit uses the template that is listed first in this folder.
Pl . » wversion5.20 » templates
urn Mew folder
Mame : Date modified Type Size
[5 ART 5-20 HP ART Template.udt 12/10/20144:24 PM  HP ART Template 5,515 KB
[53 ART5-11 Custom HP ART Template.udt 12/22/201410:37 ... HP ART Template 5,539 KB
Note the Date Modified on the original 5.11 template. During the 5.2 installation process,
it will automatically convert any v5.1 templates located in the All Programs > HP Adoption
Readiness Tool > HP Adoption Readiness Tool Resources > templates folder to v5.2 and
change the Date Modified to the current date.
3. Since your template is updated to v5.2 during the install process, it is optional but
recommend that you rename the template to indicate v5.2 in the name.
. b wversion 5,20 » temnplates
Burn New folder
Name . Date modified Type Size
[ ART 5-20 HP ART Template.udt 12/10/2014 4:24 PM HP ART Template 5,515 KB
(5 ART 5-20 Custom HP ART Template.udt  12/22/201410:37 AM P ART Template 5,539 KB|
4. You can only have on template with the same GUID in the root folder. Therefore, create a
custom folder for all the templates not currently in use.
| . v version 520 » templates »
Burn MNew folder
Name : Date modified Type Size
. Other Templates 12/22/2014 10:52 AM File folder
[E3 ART 5-20 Custom HP ART Templateudt  12/22/2014 1037 AM HP ART Template 5,539 KB
As of December 22, 2014 Page 5 of 15
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Example of the Other Templates folder:

I

Burn New folder
Name = Date modified Type Size
|[5 ABC ART520 template V8.udt 3/19/201411:38 AM  HP ART Template 7,134 KB
[53 ART 5-20 HP ART Template.udt 12/10/2014 4:24 PM  HP ART Template 5,515 KB

5. Confirm the custom template is active by launching HP ART 5.2, select Go to editor > File
> Open > Open Template.

Open Template xX

Template:

# | Local Templates
| ART 5-20 Custormn HP ART Template.udt |

Lock template for editing

Step 4: Remove the Default HP ART Template from Your Installation Folder
When installing ART 5.2, the HP ART 5.2 template is automatically installed as part of the overall
installation process. If you are not using the default HP ART 5.2 template, you need to remove the

file from your installation folder.

1. Navigate to the HP Adoption Readiness Tool installation folder. The default installation
location is shown below:
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Computer » PCCOE(C:) » Program Files (x86) » HP Adoption Readiness Tool »

-—

Include in library = Share with « Burn MNew folder
Mame Date modified Type Size
) Client 7/10/201310:14 PM  File folder
5 % jinitcfg.EXE 3/15/201312:28 PM  Application 1,749 KB
=] sysinfo_bd 7/10/201310:14 PM - Text Docurnent O KE

CES

2. Navigate to the Client>appdata>Templates folder.

Computer » PCCOE(C:) » Program Files (x86) » HP Adoption Readiness Tool » Client » appdata » templates

Burn Mew folder
Mame Date modified Type Size
[ ART 5-20 HP ART Template.udt 12/2/2014 10:02 AM  HP ART Template 5515 KB

3. Delete the ART 5-20 HP ART Template.udt file.

4. NOTE: There is no risk removing this file from the installation folder. A backup of the
default ART 5.2 template is located in the Custom>Templates folder of the ART 5.2 Author
Dev Kit installation package.

Step 5: Set your xml/html Template Editor
There are three minor template variances that occur when you convert your v5.1 template to v5.2.
You will want to make the necessary adjusts to the:

e Font on the Course Launch Window
e Font on Simulation Launch Window
e Format of the Job Aid document Header and Footer

Before you begin, you should set the default xml/html editor. To change the editor, follow the
steps below:

1. Launch the ART Editor.
2. Select File > Open > Open Template > OK.
3. Navigate to General > Data Files >  Interface Settings>General section.
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@ ART 5-20 Custorn HP ART Template.udt - HP Adoption Readiness Too™ — Powered by ANCILE Solutions™

IO Home  Translations

‘ Properties Phroses Publications Styles Blocks Secfions
[ Data Files
General
,j Change Editor... notepad.exe
Information e i
aicc_meta_data.au |j Add
Data Files .
T aicc_meta_data.crs —
Halzsgualgles aicc_meta_data.cst ,—j Update
otspot Images .
aice_meta_data des = -
Textto Speech o - . '—j Modify
ANCILE uPerform. Website xslt
course_index.htm [ Delete
csh_capture_context.html
csh_context_identifiers html L

4. Set your desired xml/html| editor by clicking the Change Editor button within the
General tab of the template. In this example, we have set the Editor set fo
notepad++.exe

@ ART3-11 HP ART Templatev! udt - HP Adoption Readiness Tool™ — Powered by ANCILE Sclutions™

L A
FCRE Home Translations
‘ General ‘ Properties Phroses Publications Styles Blocks Sections
I Data Files
General
@ Change Editor... notepad++.exe
Information .
|mag35 S rmats 4-|=|i=| =

5. Save your changes.

Step 6: Update the Font in the Course Launch window
The configuration file that controls the font style and size of the course launch window is accessed
within the Data Files section of the template.

1. Navigate fo the General > Data Files section of the template.
2. Select the course_index.htm file.
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3. Click the Modify button.

ART5-11 HP ART Templatewv! udt - HP Adoption Readiness Too™ — Powered by ANCILE Solutions™

LAl Home Translations
General Properties Phrozes Publications Styles Blocks Sections
Data Files
General
| @ Change Editor... notepad.exe

:nformatlon accessibility.js |~

— 3§ aice_meta_data.au ’_=|.|. Add

Data Files .

L aicc_meta_data.crs —

Hangu agles aicc_meta_data.cst G Update

otspot Images aice_meta_data.des @ Madifs |

Textto Speech X LT Viadify
ANCILE.uPerform.Website xslt
course_index htm i Delete
csh_capture_context. html
ceh_context_identifiers.html -
csh_cookie_libjs 1
exercise_tasks. html
P T I S

4. The course launch window has four sections in which you will adjust the font: Title, Body
text, Infobox text and Footer text.

n Introduction to HP Service Manager 9.30

2

ACME

N tworklng"’"

e es

Description | 3
This module provides an introduction to HP Service Manager 9.30. Click the

Launch Module button below to view the eLearning course module, or quickly
master a specific task by launching a Simulation or Job Aid.

Date Published | 4 Friday, August 30, 2013

If you are experiencing difficulties viewing this course, please open the
Adobe Flash Player Global Security Settings Panel and select the Always allow
option.
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5. To update the Title font locate the following line and adjust the size and color values as
needed.

Zzdiv id="container">

<table id="root table" border="0" cellpadding="0" cellspacing="0" width="389">
<tr style="height: 20px">
<Btop_left@>

<td style="height: 20px; width: 349px; background-image: url(assets/img/ui_top.gif); background-repeat: repeat-x"></td>
<Btop_right@>

</tr>
<tr>
<@aide_left@>
<td»
<table border="0" cellpadding="0" cellspacing="0" width="349">
<tr>

<table = ="height: 252px" border="0" cellpadding="0" cellspacing="0">
<tr id="rowLessonName" s
<td align="right" wva

<span id="title" s

="font-weight: bold:; font-size: 14pt: color: HFFFFFF: font-family: Tahoma: margin-right:10px:"><@Title@></span>

</td>
</tr>
<tr style="vertical-align: bottom; height: 1px">

<td n="top"»<img src="assets/img/ui_line.png" width="430px" height="1px" /></td>
</tr>
<Cr>

<td align="center" valign="top">

<table style="height: 120px" width="30%" cellpadding="2px" cellspacing="2px">
<Cr>
<td va ="right">

<a
</td>

k="launchContent ('course.htm') ;return false:"><@Course@></a>

6. To update the Body Text font locate the following line and adjust the size and color values
as needed.

a:link, a:active, a:visited
{

font-family: Tahoma:
font-=ize: 12px;
font-weight: bold;

color: #FFFFFF;
text-decoration: none;

}

a:hover

{

color: #003366;
text-decoration: underline;

}

7. To update the Infobox Text font locate the following line and adjust the size and color
values as needed.

.infoboxText

1

font-family: Tahoma:
font-size: 12px;
color: black:

}
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8. To update the Footer Text font locate the following line and adjust the size and color

values as needed.

JTooterText,
JTooterText a:link,
JTooterText a:active,
.footerText a:visited
i

font-family: Tahoma:
font-=ize: 1lpx:
coleor: 000000 ;

}

Step 7: Update the Font in the Simulation Launch window

The configuration file that controls the font style and size of the Simulation launch window is

accessed within the Data Files section of

1. Navigate to the General > Data Files section of the template.

the template.

2. Select the simulation_index.htm file.

3. Click the Modify button.

ART5-11 HP ART Templatewvl .udt - HP Adopfion Readiness Tool™ - Powered by AMCILE Solutions™

[y
m Home Tronslations

Properties Phrases Publications Styles

General

Blocks Secfions

Data Files

2 Change Editor.. notepad++.exe

Information

mage
Data Files
Languages

Hotspot Images
Textto Speech

HPSimplifiedW04-Bold. woff
HPSimplifiedW04-Regular.eot
HPSimplifiedW04-Regular.svg
HPSimplifiedW04-Regular.tf
HPSimplifiedW04-Regular.woff
imsmanifest_12.xml
imsmanifest_2004 xml|
jquen-2.0.2.min.js
multi_sco_imsmanifest_12.xml
multi_sco_imsmanifest_2004 xml
phrases.xml

redirect html

simulation_index him

style css
transparent js
typing. mp3

uparade 440 course indexhtm

&l

Add

&1

Update

Modify

Delete

4. The course launch window has four sections in which you will adjust the font: Title, Body

text, Infobox text and Footer text.
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I8 Log in to the Service Manager Web Client

Launch Show Me

Launch Test Me

r—— /.
Networking 24"

Description 3

Log in to the Service Manager Web Client

Date Published 4 Friday, August 30, 2013

If you are experiencing difficulties viewing this simulaticn, please open the

Adobe Flash Player Global Security Settings Panel and select the Always allow
option.

5. To update the Title font locate the following line and adjust the size and color values as
needed.

1 349px: background-image: DTl (ASSets/ing/ui_top.gif): DBacKOTOUnd-TEPEAT: TEpEAt-X- L/t

height:252px; background-repeat: no-repeat;">
ER="1008">

t: bold: font-size: 14pt: color: SEFEEPE:

e="<ETitlel>"><ETic1el> inbsp; inbsp </ divy

6. To update the Body Text font locate the following line and adjust the size and color values
as needed.

a:link, a:active, a:visited
{

font-family: Tahoma;
font-size: 12px;
font-weight: bold:;

color: #FFFFFF:
text-decoration: none;

}

a:hover

{

color: #003366;
text-decoration: underline;

}
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7. To update the Infobox Text font locate the following line and adjust the size and color

values as needed.

.infoboxText

{

font-family: Tahoma;
font-size: 12px;
color: black:

}

8. To update the Footer Text font locate the following line and adjust the size and color

values as needed.

JTooterText,
JTooterText a:link,
JTooterText a:active,
.footerText a:visited

i

font-family: Tahoma:
font-=ize: 1lpx:
color: #0000D00;

1

Step 8: Job Aid - Document Header and Footer
The Page Title within the Header and the Page Number within the Footer of the Job Aid document

are not right-justified when published.

@ Create a Dashboard

ECopyright 2014 Hewlett-Packard Development Company, LP
Tuesday, December 02, 2014

The Document Header and Footer are controlled within the Blocks section of the template.
To update the Job Aid header follow these steps:

1. Navigate to the Blocks > Header section of the template.
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2. Select the header block and right-click Justify > Right.
3. Save your changes.

w ART5-11 HP ART Templatev] udt - HP Adoption Readiness Tool™ — Powered by ANCILE Solutions™

0@

HCAE Home Transkations

General Properties Phrases

Publicctions Styles | Blocks | Sections

Blocks

Manage All Blocks
Activity
ASAP BPP
Assessment Confirmation
Assessment Note
Configuration Infarmation
Course Footer
Course Header
Exercise/Data Sheet
Field
Footer
Free Text
Heading
Highlighted Note
I

Note

Purpose

Quiz Me Note

Result

Screen Flow

Show Me Note

SME Mote
Start the task using the menu path
Step

Student Guide Footer
Student Guide Header
Substep

Test Information
Test M Note

Test Scenarios

Try Me Nots

[Header
[ER  SelectPhrase
Language Name -
Bahasa Indonssia (Indanesiz) [d_ID]  Kop H
catali (catal3) [ca_ES] Capgalera
Zestina (Geskd republiks) [cs_CZ) Zahlavi
dansk (Danmark) [da_DK] Toptekst
Deutsch (Deutschland) [de_DE] Kopfzsile
English (United Kingdom) [en_GB] Header
English (United States) [en_US] Header
Espaiiol (Espafia. alfabetizacion intemac  Encabezado
frangais (Canads) [fr_CA] En-téte =
0l m »
Content 0O Mirrored view [J
(] {#Names]
Table ¥
Edit »
Format  »
| T
Insert » | = Center
= Right

To update the Job Aid footer, follow these steps:

1. Navigate fo the Blocks > Footer section of the template.
2. Select the footer block, right-click Justify > Right.

3. Save your changes.

@ ART5-11 HP ART Templatev] udt - HP Adoption Readiness Tool™ — Powered by ANCILE Solutions™

0 Em
m Heme  Trenslafions
General || Properties || Phrasss || Publications || Styles I Blocks I Sections
[ Footer
Blocks
Manage Al Blocks

Activity
ASAP BPP Language Name -
Assessment Confirmation Bahasa Indenesia (Indanesia) [id_ID]  Catatan kaki H
Assessment Note catala (catal) [ca_ES] Peu de pagina
Configuration Information Sedtina (Ceskd republika) [cs_CZ] Zdpati
Course Footer dansk (Danmark) [da_DK] Bundiekst
Course Header Deutsch (Deutschland) [de_DE] Fulzeile
Exercise/Data Sheet English (United Kingdem) [en_GE] Feoter
Field English (United States) [en_US] Footer
Footer Espafiol (Espafia, alfsbetizacién internac  Pie de pagina
Free Text frangais (Canada) [fr_CA] Pied de page -
Header a ™ 5
Heading
Highlighted Note
It
Nate Content: [ Wirrored view (1
Purpose
Quiz Me Note
Result © copyright 2014 Hewlett-
Sereen Flow company, LP. #P=g=ti
Show Me Note {LangDated
SME Nots Table v
Start the task using the menu path Edit ’
Step
Student Guide Footer Lormat gy
Student Guide Header Justiy v = Left
Substep =
Test Information =3 D Conter
TestMe Note [ Right
Test Scenarios
T Me Note B oma
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Step 9: Locate the Test Course to Support Upgrade Preparation and Testing

For testing purposes, it is recommended that you locate a single module or small course to use for
template and skin update tests prior to upgrading all your courses. Since many of the changes
require publishing to review, it is easier to work with a small amount of content first.

1. Create a Temp Publish folder outside of your project source file.
2. Open your small test course and publish the course to the Temp Publish folder.

3. Review your published course and determine it additional updates to the template and skin
are needed.
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